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Getting Help on ARCHICAD 24

Online Reference Guide

In ARCHICAD, open from Help > Online Resources > ARCHICAD Reference Guide.

PDF Reference Guide

Click here to access in PDF format.

Context-Sensitive Help

Do one of the following:

• Press F1 (Windows) or Cmd+? (Mac)

Note: Shortcut may vary depending on your language version.

• Right-click on any user interface element and choose the ‘What’s this’ command

The Help will open to a topic relevant to the ARCHICAD interface item you have clicked. (In some cases, the 

Help will open to its starting page.)

GRAPHISOFT Help Center

Knowledgebase articles, tutorials and videos are available at GRAPHISOFT’s online Help Center.

Download Offline Help

If you plan to work offline later, you should install a copy of ARCHICAD Offline Help.

Download Offline Help During ARCHICAD Installation

As you click through the ARCHICAD Installation Wizard, you get the option to install Offline Help.

Click the link provided to download Offline Help installation file (.exe or .dmg)  to your computer.

After you finish installing ARCHICAD: click the downloaded file at any time to install the Offline Help.
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Download Offline Help Later

If you did not download the Help files during ARCHICAD installation, you can still download them later:

1. Disconnect your internet connection.

2. With ARCHICAD running, press F1.

3. The appearing screen provides a URL link.

4. Reconnect the internet.

5. Click on the link to access the installation file (.exe or .dmg) 

6. The Offline Help is downloaded to your computer.

Note for Safari Users

The Safari browser is not supported.

However, if you are still using a Safari browser (v. 11 and later), follow these steps in order to view the offline 

ARCHICAD Help.

1. Go to Safari Browser Settings

2. Choose Preferences

3. Choose Advanced

4. Choose “Show develop menu in menu bar”

5. From the Develop menu: select “Disable local file restrictions.”

Additional Resources

See additional PDF resources in the ARCHICAD Help menu:

• GDL Reference Guide 

This manual is a complete reference to the GRAPHISOFT’s proprietary scripting language, GDL 

(Geometric Description Language). 

• Calculation Guide 

ARCHICAD’s Calculate function interacts with the project database to calculate the number of elements in 

a project, their spatial disposition and the quantity of element components. This is a legacy function. Most 

users will use the Interactive Schedule.
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License & Trademark Information

ARCHICAD Licenses

By installing and using ARCHICAD, you are legally bound by the provisions of the End User License 

Agreement accepted by you during the Installation process.

You can access a copy of the EULA for your version of ARCHICAD 

• from the Help menu of ARCHICAD, or

• from the Documentation folder inside the ARCHICAD folder where you installed the program on your 

computer’s hard drive

Third Party Software Licenses

ARCHICAD leverages technologies and components licensed from third party companies. Major functions 

powered by third party software are:

Dwg I/O and DGN I/O powered by Open Design Alliance (ODA®).

http://www.opendesign.com

PDF technology powered by PDFNet SDK copyright © PDFTron™ Systems Inc., 2001-2013, and distributed 

under license. All rights reserved.

http://www.pdftron.com

IFC interoperability powered by Jotne EPM Technology’s EDM Toolkit.

http://www.epmtech.jotne.com

Cineware Rendering Engine - Copyright MAXON Computer GmbH. All rights reserved.

http://www.maxon.net

Embedded web browsing - created with Chromium Embedded Framework (CEF). Copyright © 2008-2014 

Marshall A. Greenblatt. Portions Copyright © 2006-2009 Google Inc. All rights reserved.

Integrated Energy Evaluation powered by StruSoft’s VIPCore engine

http://www.strusoft.com

Software license Protection by Wibu

http://www.wibu.com

You can find additional third Party license information on the GRAPHISOFT webpage: 

http://www.graphisoft.com/licenses/

http://www.opendesign.com
http://www.pdftron.com
http://www.epmtech.jotne.com
http://www.maxon.net
http://www.strusoft.com
http://www.wibu.com
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Install Guide for ARCHICAD 24

Install ARCHICAD

Mac OS 10.15: Enable Full Disk Access

Your ARCHICAD License Key

Add/Repair ARCHICAD

Updates for ARCHICAD

ARCHICAD Tools and Utilities

Uninstall ARCHICAD

Using a CodeMeter Server

Related:

Network Installation for BIM Managers
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Install ARCHICAD

Download ARCHICAD

ARCHICAD is available for download at:

http://www.graphisoft.com/downloads/

ARCHICAD Hardware/Software Requirements

Hardware/Software requirements are modified from time to time. For up to date information on system 

requirements, please consult the following link:

http://www.graphisoft.com/support/system_requirements

Installation Process

1. Start the installer to open the Welcome Screen.

Click Next to continue.
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2. License Agreement

Read the license agreement carefully and accept it. Click Open in Browser to see the agreement in a 

new window. 

Click Next.

3.  Select Installation Directory

On this page, define the file path of the installation. As a rule, you should choose the path suggested by 

default, to simplify the installation of any future updates.

– On Mac: Installation must be in the Applications folder or any of its sub-folders.

To confirm the file path, click Next.
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4. Choose Setup Type

With the “Typical” installation option (recommended), you will install ARCHICAD 24 together with all of its 

components (e.g. Library). 

Alternatively, choose the “Custom” installation option to install only specific program components. 

After you make your choice, click Next.

5. Installation Summary

This screen summarizes your chosen configuration, so you can make any needed corrections to the 

installation settings. 

Click Install to begin installation.
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6. Installation Underway

Depending on your Hardware configuration, this process may take several minutes. In addition to other 

components, CodeMeter, the BIMx Desktop Viewer, and the License Manager Tool are all installed in the 

background.

7. For Mac users: if you are installing ARCHICAD on a Mac OS 10.15 system, you will see a warning: for 

ARCHICAD to run properly, you must enable Full Disk Access in Mac OS settings. Follow the steps 

described in the warning dialog.

8. Shortcuts/Automatic Updates

Check the box to create an ARCHICAD Desktop shortcut (on Windows) or dock icon (on Mac).

Review the setting to Enable ARCHICAD to Check for Updates automatically (checked by default).

Confirm your choices by clicking Next.
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9. Information on ARCHICAD Help

ARCHICAD installation does not automatically install Help files to your computer. ARCHICAD provides 

up-to-date Help resources online.

If you work online, then you do not need to install Help files to your computer. Click Next to continue.

If you work offline and/or your internet connection is unstable, it is recommended to download and install 

Offline Help. Click the link to access and download Help files to your computer. 

See also Download Offline Help.

Click Next.

10. If the installation process includes installing CodeMeter, you are prompted to restart your computer now.

11. Complete Installation

Click Finish to complete the installation process. You may be prompted to restart your computer.
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Silent Install for ARCHICAD and Add-Ons

It is possible to use a silent install process to install ARCHICAD using a customized, company-preferred 

configuration. 

For details, see Network Installation for BIM Managers.
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Mac OS 10.15: Enable Full Disk Access

When installing or updating ARCHICAD on a mac OS 10.15 system, you will see a warning: for ARCHICAD to 

run properly, you must enable Full Disk Access in Mac OS settings.

Follow these steps:

1. In the ARCHICAD Warning dialog, click the link: Go to Security & Privacy Settings.

The Privacy panel of your computer’s Security & Privacy Settings opens.

2. At bottom left, click the Lock icon so you can make changes. You may need to enter a password.

3. Select Full Disk Access from the list of applications in the left column of the panel.
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4. At the bottom of the list, click the Plus sign.

5. Navigate to Applications > GRAPHISOFT > ARCHICAD Folder > ARCHICAD Application.
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6. Click Open or drag and drop to add it to the list.

7. Return to the ARCHICAD Installer and click Next to continue.
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Your ARCHICAD License Key

When you start ARCHICAD, the program automatically checks to see if you have a license available. If so, 

you are ready to work.

To update, download and otherwise manage your license keys, use the License Manager Tool. 

The License Manager Tool is automatically installed to your computer as part of ARCHICAD 24 installation. It 

is also available for download at

http://www.graphisoft.com/downloads/licensing/.

Hardware Key

The Hardware Key (Dongle) contains your license information on a USB stick. Before you start using the 

latest version of ARCHICAD, this Hardware Key must be updated. 

For the update process, use the License Manager Tool:

http://www.graphisoft.com/downloads/licensing/.

Start the License Manager Tool (LMT) and follow the directions to update your Hardware Key.

Now you are ready to use ARCHICAD 24.

Note: After updating your license key to ARCHICAD 24, you can still use older-version ARCHICADs 

(versions 10-23).

Software Key

The Software Key is a software-based license. Using the License Manager Tool, a software key can be 

downloaded from the License Pool to a local client computer. To update your software key to the latest 

ARCHICAD version, start the License Manager Tool and follow the directions to update your license to the 

latest version.

If you are using a single license and plan to work on a different computer, you should upload the software key 

to the License Pool, so that you can access it from a different location. (Internet connection is required.)

Note: If you are using a network license, there is no need to upload the software key to the license pool.

Serial Number (Education Version or Trial Version)

If you are using the Education or Trial version of ARCHICAD, you must activate it when starting ARCHICAD, 

using a Serial Number. Students and Trial users can register to obtain a Serial Number that is valid for a 

limited time.

• If you are using a Trial Version and later obtain a commercial version, insert your Hardware Key (or 

download a Software Key), then start ARCHICAD. Open your projects and save them again, this time as 

full-version project files.

• The ARCHICAD Education Version cannot be converted to a commercial version, because it is designed 

for use by students or for educational purposes only. The Education Version cannot be used for 

commercial purposes.

Demo Mode

When you start ARCHICAD, the program automatically checks to see if you have a license available. If you 

don’t have a license at all, you can continue in Demo Mode.

Demo Mode gives you full functionality except file saving and Teamwork. Use Demo mode to open, view and 

try out functions using any ARCHICAD file.
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The unavailable commands and menu items are disabled, and the ARCHICAD title bar changes to 

ARCHICAD 24 Demo.

Lost or Defective License Key

In case of a lost or defective License Key, contact your local distributor.

Read More on Help Center
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Add/Repair ARCHICAD

If you already have ARCHICAD installed, and start the Installation Wizard, you are given two options:

1. Add will add new features to your current installation. You will see all available features in a list and you 

can check features to be added to your current installation.

2. Repair will reinstall ARCHICAD with the features of your current installation. 

• The Repair process will revert your ARCHICAD version to its default settings. After Repair, you must 

reinstall the latest ARCHICAD and Library updates.

• Project files you saved into the ARCHICAD 24 folder will not be deleted or overwritten by the repair 

process.
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Updates for ARCHICAD

To check for available updates of your localized version of ARCHICAD or ARCHICAD libraries, start 

ARCHICAD 24 and do any of the following:

• Use Help > Check for Updates

• Open the Action Center (File > Info > Action Center) and select the Updates item to see notifications on 

any updates available for download.

• For automatic checking: Set the Check for Updates options in Options > Work Environment > Network 

and Update. You will be notified if a new library or program version matching your ARCHICAD language 

version is available, which you can then download.

The Check for Updates command takes you to the GRAPHISOFT update website. If there is a new update 

patch available, the web page will automatically offer you the updater package that fits your current 

ARCHICAD installation.

You can find other downloadable materials (example files, goodies etc.) at 

www.graphisoft.com/support/archicad/downloads.

Note: If you have an updater patch installed and use the Add/Repair function of the ARCHICAD 24 

Installer, you will be prompted to re-apply the updates after the modification or repair is carried out. The 

ARCHICAD update option is available to holders of the Commercial or Education ARCHICAD 24 license.
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ARCHICAD Tools and Utilities

The following utilities are automatically installed on your computer together with ARCHICAD.

The following utilities are also installed with ARCHICAD 24. If you prefer not to install them, use Custom 

Installation and uncheck these options.

For more information about additional utilities, open the folders of the applications in the ARCHICAD main 

folder to find detailed descriptions.

CodeMeter system 

components

A Hardware Key driver (CodeMeter) will be installed as part of the installation 

process for ARCHICAD 24.

Plotter Drivers ARCHICAD 24 includes a number of built-in drivers for a wide variety of HPGL 

compatible plotters.

If you are using a large-format printer, make sure you use a printer driver specified 

by the manufacturer, because its plotter function is only an emulation.

GRAPHISOFT Shell 

Extension

Optional, for Windows only. Utility for extended GRAPHISOFT file property 

information on Windows.

BIMx Desktop Viewer Use this to open and explore the interactive, walk-through model´s 3D content (in 

BIMx format) on your computer.

License Manager Tool The License Manager Tool can be used to manage the GRAPHISOFT protection 

keys you have purchased, whether hard or soft.
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Uninstall ARCHICAD

To uninstall ARCHICAD 24 from Windows, it is best to use the “Programs” or “Add or Remove Programs” 

utility, accessible from the Control Panel.

On Mac, navigate to the “Uninstall.AC” folder in your ARCHICAD 24 folder, and select the “Uninstall.app” 

application. 

The Uninstall Wizard will remove files which were installed by the ARCHICAD Installation Wizard. 

CodeMeter and associated components are not removed. 

The uninstaller will not remove any files you have created in the ARCHICAD main folder - e.g. ARCHICAD 

project files that you saved into the ARCHICAD main folder.

Silent Uninstall for ARCHICAD and Add-Ons

See Unattended Uninstall.
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Using a CodeMeter Server

If you would like to use network licenses (e.g. instead of single licenses), you will need a CodeMeter hardware 

key or software key. Contact your local GRAPHISOFT partner to order one or to exchange your existing 

single key(s).

Single or Network Keys

A so-called single key can hold one license for each GRAPHISOFT product (ARCHICAD, EcoDesigner 

STAR) and can be used locally. You connect the hardware key to your computer’s USB port or download the 

software key with License Manager Tool (LMT); if you have the CodeMeter driver installed (it is installed with 

ARCHICAD), your GRAPHISOFT product will find a license and will run in commercial mode. Each 

workstation in an office needs to have an individual key.

A network key can hold multiple licenses related to each product (ARCHICAD, EcoDesigner STAR). To share 

them across multiple computers you need a CodeMeter server. This arrangement provides more flexibility 

than having individual keys, as the licenses are allocated only when they are being used on one of the clients.

System Requirements for a CodeMeter Server

The CodeMeter server is part of the CodeMeter driver, so you only need to select a computer on your network 

that will act as a CodeMeter server. To set up a CodeMeter server as a network license server, you will need 

the following:

• A computer with network connection (should be running during work hours).

• The computer must have at least one free USB port, for hardware key only.

Note: There is no need for a server-level operating system for the CodeMeter server. You can use one of 

the workstations as a CodeMeter server, and you must keep it running during work hours. Any computer 

that has recent Windows or OS X versions can be used.

Set Up the Server

After you have your server running and the CodeMeter driver is installed, start the server as described below. 

All CodeMeter settings can be managed in CodeMeter WebAdmin. To start it:

• Open CodeMeter Center (from Applications or using the Start menu) and click on WebAdmin;

• or simply open localhost:22350 on your browser.

To enable the CodeMeter server:

1. Go to Configuration/Server Access tab.

2. In the Network Server section, check Enable.

3. In the CmWAN Server section, check Enable, if you want to use the computer in a wide area network 

(WAN) and allow license accesses

4. Click Apply.

5. Restart CodeMeter service (on Mac: System Preferences/CodeMeter, on Win: CodeMeter Control Center)
ARCHICAD 24 Reference Guide 65



Using a CodeMeter Server Install Guide for ARCHICAD 24
From that point, the server runs and shares licenses on the local network.

Client Side Settings

All clients on the local network should find the server automatically. In case this does not work (e.g. your 

server is in a different subnet, or you are connecting remotely through the Internet), then you may need to 

specify the server’s hostname IP address. On the client:

1. Open WebAdmin.

2. Go to Configuration/Basic/Server Search List.

3. Add the server to the Server Search List.

This field can have multiple entries; the client searches for available licenses in the specified order and only 

on the specified servers. Only when the list is empty does the client search for other available servers.

Access Control

With the default settings, all computers on the same local network (same subnet) can use a license from the 

server.

To restrict access:

1. Open WebAdmin.

2. Go to Configuration/Server/License Access Permissions.

If the Clients’ list is empty, anyone on the local network can use a license. If at least one entry is listed here, 

only the listed entries can request a license.

Note: If the server is public on the Internet, or no one is allowed to use a license, make sure that this list is 

filled out correctly to avoid unwanted license usage.

You may want to check who is using a license:

1. Open WebAdmin on the server computer.

2. Go to License Monitoring/Sessions.

Here you can see a list of active clients and clients who have borrowed licenses.

Set Up License Borrowing

If your network key has a license borrowing product, the clients can borrow a license.
For more information on License Borrowing, see http://helpcenter.graphisoft.com/?p=25723.
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Network Installation for BIM Managers

The standard installer for ARCHICAD and GRAPHISOFT Add-Ons can be deployed in unattended mode. 

You can use unattended installation with either the default installation options or custom options where 

applicable - such as a different installation path, or a customized AC Work Environment.

This article describes how to deploy unattended installation with either default or custom options.

Note: Administrator permission is required to run the executable file.

Unattended Installation - Default Options

In the command line, add the executable file followed by the parameter --mode unattended

For example:

Win

ARCHICAD-24-INT-3000-1.0.exe --mode unattended

Mac

ARCHICAD\ 24\Installer.app/Contents/MacOS/installbuilder.sh --mode unattended
This will launch the installation without user interface and without any required user input.

If no further parameters are set, the installation will run with default settings.

To run the installation using custom options, please keep reading.

Unattended Installation - Custom Options

There are two ways to set up custom settings for the unattended installation:

• Add command line parameters, in any order

• Add an option file (containing a list of command line parameters). Use an option file if you are using 

multiple parameters whose character count might exceed the command line limit.

Topics in this section:

Command Line Parameters (Custom Install)

Option File (Custom Install)

Installer Log Files and Error Codes

Unattended Uninstall

Third-Party Prerequisites

Customized Company Defaults for Unattended Installation (ARCHICAD Only)
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Command Line Parameters (Custom Install)

The following table lists the parameters that can be used to customize unattended installation of ARCHICAD 

and/or GRAPHISOFT Add-Ons, as applicable.

In the command line, type the executable file name followed by one or more parameters as detailed below.

Note: There are two dashes in front of each parameter. Be careful when adding parameters using copy/

paste, because sometimes the two dashes are converted into a single dash, which will cause errors.

To do this Type this in the command line

Run installation in Unattended Mode --mode unattended

List available standard parameters

See a list of general command-line 

parameters for customizing unattended 

installation.

--help

Specify installation folder

(if you don’t specify, the program will be 

installed to the default location.)

--installdir
followed by the path of the preferred installation folder.

If the path contains spaces, enclose the entire path in quotation 

marks.

Note: The uninstaller will also be located at this path. See 

also Unattended Uninstall

Install additional (non-default) 

components

Use this option to select additional 

(“allowed”) components for installation, 

which would not be installed by default (e.g. 

certain Goodies in the Goodies Suite 

installer).

--enable-components
followed by a comma-separated list of the allowed (non-default) 

components to install.

To see list of allowed components: type  --help.

Disable installation of (default) 

components

Use this option to prevent installation of 

certain components, which otherwise would 

be installed by default.

--disable-components
followed by a comma-separated list of default components to 

omit from the installation. 

To see list of default components: type  --help.

Identify Current User (Mac only)

Installation on Mac is run via a “root” user. In 

case of deployment installation (e.g. Apple 

Remote Desktop), use this parameter to 

specify the current user - for example, to 

create desktop and dock shortcut for a 

specific user (rather than the “root” user).

--currentUserName
followed by the username.
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Additional Command Line Parameters (for ARCHICAD Only)

These parameters are not listed in the --help file, but can be used to customize unattended ARCHICAD 

installation.

Default installation option is shown in red.

Use an Option file containing command 

line parameters

 --optionfile
followed by name of the option file (as well as its directory path, 

if it is not in the same folder as the executable).

For info on how to set up the Option File, see Option File 

(Custom Install).

To do this Type this in the command line

Add AC Shortcut to Desktop

Added by default.

If you don’t want to add it, replace 1 with 0 

--desktopshortcut 1

--desktopshortcut 0

Add AC Dock Icon (Mac only)

Added by default.

If you don’t want to add it, replace 1 with 0 

--dockshortcut 1

--dockshortcut 0

Enable Automatic Update

Enabled by default.

To disable it, replace 1 with 0 

--enableautomaticupdate 1

--enableautomaticupdate 0

Install predefined company-standard 

defaults for

• Work Environment,

• ARCHICAD Template, and/or

• DXF-DWG Translators

--customEnvironment
followed by the path of the Defaults folder containing your 

preferred files. 

For info on how to set up the Defaults folder, see Customized 

Company Defaults for Unattended Installation (ARCHICAD 

Only).

To do this Type this in the command line
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Additional Command Line Parameters: EDU-University and Regional Languages Only

To do this Type this in the command line

ARCHICAD EDU - University 

Licenses only

Provide User ID and Serial 

Number for unattended install.

Not available for individual 

students with EDU licenses.

--eduSerialNumber
followed by 20-character serial number (no spaces, no separators)

--eduUserID
followed by the edu User ID (usually your registration email)

• If the User ID contains spaces, enclose the User ID in quotation marks.

• If these parameters are incorrect, installation will still take place, but 

ARCHICAD will run in Demo mode only. Reinstall as needed using the 

correct data.

• Test the installation with your user data before deploying unattended 

install. 

Examples:

--eduSerialNumber SY6NQKC0K19P06V89S1B

--eduUserID JohnSmith@graphisoft.com

Spanish- or French-language 

ARCHICAD only

Choose preferred regional 

language environment.

--regionOption
followed by FRA or SUI (French-language regions), or

followed by SPA or LATAM (Spanish-language regions)

Example:

--regionOption FRA
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Option File (Custom Install)

As an alternative to using command line parameters to customize the unattended install, you can create an 

option file. 

Thus, instead of typing parameters into the command line, you will list the needed parameters in a text file, 

then add this text file to the command line.

This can be useful if you are using multiple parameters whose character count might exceed the command 

line limit.

1. Create an option file.

– The file must be a utf8 text file

– In the first line, type: # encoding: utf-8

– The file must contain a list of command line parameters, each followed by an equals sign, followed by 

the custom value(s). 

– Start a new line for each parameter

– Do not use -- in front of the parameters

– Do not use quotation marks in parameters - not even if the specified value contains spaces

Example

Contents of an option file to install the ARCHICAD24.exe file, using unattended install, to a customized folder 

location on your D drive, and including all components except ARCHICAD Help:

# encoding: utf-8

mode=unattended

installdir=D:\DATA folder\

disable-components=ARCHICADHelp
2. Save the file as a utf8 text file, e.g. “OptionFile.txt”

3. Add the resulting option file to the command line preceded by --optionfile

ARCHICAD-24-INT-3000-1.0.exe --optionfile OptionFile.txt
If either the executable or the Option file is not located in the current directory, you must specify its full path:

C:\Users\CurrentUser\Downloads\ARCHICAD-24-INT-3000-1.0.exe --optionfile 
D:\DATA\OptionFile.txt

Note: If the file path (specified in the command line) contains spaces, enclose the entire path in quotation 

marks.
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Installer Log Files and Error Codes

After running unattended installation, the associated log files are found here:

Win

C:\ProgramData\Install.GS\bitrock_installer.log
or

bitrock_installer_xxxxx.log

Mac

/Users/Shared/Install.GS/ bitrock_installer.log
or

bitrock_installer_xxxxx.log

Error Codes

1: Not Supported Operating System, OptionFile syntax error, Invalid parameter, misc.

2: Installdir is not empty

3: Add / Repair not allowed in unattended mode, already installed

4: Installdir is in an ARCHICAD or BIMcloud folder

5: VCRedist 2015 cannot be installed

6: There is not enough disk space in the selected installdir

7: In Add-On Installer: ARCHICAD search detection error (ARCHICAD not found…)

8: Installdir’s path contains invalid characters: <>”|?*
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Unattended Uninstall

Use the --mode unattended parameter to uninstall ARCHICAD or Add-Ons in unattended mode.

Notes:

– Be careful when adding parameters using copy/paste, because sometimes the two dashes are 

converted into a single dash, which will cause errors.

– The following examples assume that the program(s) were installed to their default location. If the --

installdir parameter was changed for installation, then the path shown below must be modified 

accordingly. 

Win

C:\Program Files\GRAPHISOFT\ARCHICAD 24\Uninstall.AC\Uninstall.exe --mode 
unattended

Mac

/Applications/GRAPHISOFT/ARCHICAD 24/Uninstall.AC/Uninstall.app/Contents/
MacOS/installbuilder.sh --mode unattended
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Third-Party Prerequisites

The installation process for ARCHICAD includes a number of additional third-party software products which 

are necessary to run ARCHICAD.

When you run the ARCHICAD installer, it will automatically install those third-party products which are not yet 

installed, or which are out of date.

If you don’t want to install these automatically during unattended installation, make sure they are installed 

separately beforehand.

For a list of these products, see:

Third Party Installers for ARCHICAD
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Customized Company Defaults for Unattended Installation 

(ARCHICAD Only)

This description applies only to ARCHICAD installation.

It details how to set up a Defaults folder for use with the --customEnvironment parameter, used to 

customize the unattended installation.

Introduction

When installing ARCHICAD in unattended mode, the default installation includes predefined settings for:

• Work Environment

• Template file

• DXF-DWG Translators

However, you may prefer to use custom options (e.g. your own company preferences) for any or all of these 

factory defaults.

To do this, you must 

• Define your preferred custom settings in ARCHICAD

• Set up a “Defaults” folder location using the hierarchy described below

• Add your customized settings to this folder/sub-folders as described below

• Add the path of this “Defaults” folder to the command line or the Option file.

See more at Command Line Parameters (Custom Install) and Option File (Custom Install).

Step by Step

1. Complete a Standard Single Installation

The first step is to do a Standard installation of ARCHICAD on a single client machine. 

Next, set up your preferred Work Environment, Template, and/or DXF-DWG translators:

2. Customize Work Environment Settings

Use the dialog boxes at Options > Work Environment to set up your company standard Work 

Environment settings. Most such options are found in three dialog boxes of Company Standard Schemes: 

Data Safety & Integrity; Network and Update; and Special Folders. 

Once you have set these options, save these settings as schemes, then save the schemes in a company-

default profile. To save a profile, go to Options > Work Environment > Work Environment Profiles.

3. Customize Templates

Create and save any number of template files. Template files include links to libraries loaded through 

Library Manager (e.g. “Office Standard Library”). Templates can also include Project Preferences (e.g. 

Working Units, Zone calculation preferences), and such items as Master Layouts, Project Info, placed 

elements (e.g. Elevation markers, entire buildings).

Save each template using File > Save as... (ARCHICAD Template file *.tpl).
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4. Create “Defaults” Folder

Create a temporary “Defaults” folder. Make sure it is in a location accessible by all users.

See also Note on Ensuring Network Access to “Defaults” Folder (WIN Only):.

Within this “Defaults” folder, create sub-folders and add your saved, customized defaults as described in 

the next steps.

5. Create “Defaults/ARCHICAD” sub-folder.

– To the ARCHICAD sub-folder, add your saved “WorkEnvironment” folder and its contents.

– Also to the ARCHICAD sub-folder, add your saved Template file(s) (extension .tpl).

6. Create “Defaults/DXF-DWG Translators” folder. 

– To the DXF-DWG Translators sub-folder, add the contents of your saved Translator folders.

7. Add the DXF/DWG Translator List.xml file to the “Defaults” folder. 

8. Provide the path of the “Defaults” folder as a command line parameter: --customEnvironment

– If the file path contains spaces, enclose the entire path in quotation marks.

Example

Note: Make sure you type the name of the “Defaults” folder to correspond to your language version.

Win

ARCHICAD-24-INT-3000-1.0.exe --mode unattended --customEnvironment 
"D:\...\Defaults"

Note on Ensuring Network Access to “Defaults” Folder (WIN Only):

Where to find saved WorkEnvironment folder:

Users\<Username>\AppData\Roaming\Graphisoft\ARCHICAD xx.0.0 yyy (Windows)

~/Library/Preferences/Graphisoft/AC xx.0.0 yyy (Mac)

where xx stands for the version number of ARCHICAD and yyy is the language version of ARCHICAD.

Where to find saved Translator folders:

Users\<Username>\GRAPHISOFT\DXF-DWG Translators xx.0.0. yyy (Windows)

~/Library/<Username>/GRAPHISOFT/DXF-DWG Translators xx.0.0. yyy (Mac)

Where to find the Translator List XML file:

Users\<Username>\AppData\Roaming\Graphisoft\ARCHICAD xx.0.0 yyy R1\Dxf-Dwg Preferences\ 

(Windows)

~/Library/Preferences/Graphisoft/AC xx.0.0 yyy v1. (Mac)
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– If your “Defaults” folder is in a network location, you should include the full network path in this 

parameter. 

– If the folder location is on a mapped network drive, make sure the folder path is accessible regardless 

of user permissions (e.g. Administrator). 

Mac

ARCHICAD\ 24\Installer.app/Contents/MacOS/installbuilder.sh --mode unattended 
--customEnvironment "userhome/.../Defaults"
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New Features in ARCHICAD 24

Integrated Design

Integrated Structural Analytical Model

Integrated MEP Modeler

Model Checking

Collaboration

Tracking Changes in Teamwork Projects

Model Comparison

Issue Management

Coordination

BIMcloud as Multi-Disciplinary Model Hub

Geometry Exchange with Revit

Productivity

Content Library Update - New Residential Furniture Elements

Import and Use Revit Families as GDL Objects

Polyline editing functions refined

ARCHICAD option set values available as a 'pull-down menu' when exported to Excel

DGN v8 Support

Experimental Features

JSON/Python API for ARCHICAD

Dark Mode Support on Mac

IFC Structural Analysis Model Import/Export

BIMx

BIMx (iOS) app update

BIMx Desktop Viewer update
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Integrated Design

Despite continuing developments in digital design tools, the building industry still relies mostly on old 

workflows: different disciplines work separately, exchanging data only at well-defined intervals. 

Yet ideally, architects and engineers should be able to work together on the same team - just as architects 

work with other architects, and engineers work with other engineers. 

Major developments in both ARCHICAD and BIMcloud provide the long-awaited breakthrough toward real, 

interactive collaboration among multidisciplinary teams. These enhancements come in three areas:

Integration between Building Information Model and Structural Analytical Model

While architects design with the help of physical models (BIM), engineers use simplified Structural Analytical 

Models. They use structural analysis tools, such as RISA 3D or SCIA Engineer, to simulate and optimize the 

behavior of the structure. 

ARCHICAD provides bi-directional integration of these two models - BIM and Structural Analytical Model. As a 

result, engineers can check the structure of an architectural model in hours instead of weeks.

Collaboration through Teamwork

The further enhanced Teamwork® brings a whole new set of tools and solutions that provide the ideal 

environment to foster trust between the architect and the engineer. Easy-to-use change tracking and 

visualization tools allow each designer to instantly know about relevant changes and provide immediate 

feedback to the team.

Coordination through BIMcloud

Even in a highly collaborative environment, many outside players will need to join the team at different stages, 

with clearly separated responsibilities. To optimize the sharing of information, BIMcloud is now able to handle 

any kind of file.
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Integrated Structural Analytical Model

ARCHICAD introduces a new bi-directional workflow for structural engineers:

• Automatic derivation of a Structural Analytical Model Members from the load-bearing, core elements of 

ARCHICAD’s Physical Model. Eligible elements include Beam, Column, Wall, single-plane Roof and Slab.

• Sharing of the Structural Analytical Model, including continuously connected structural analytical members 

and Structural Links and Supports, with any structural analysis application that supports open source file 

formats optimized for this purpose.

• The structural engineer, working in the structural analysis program, provides suggestions for changes in 

the analytical model, then sends it back. The Physical Model is updated in ARCHICAD. 

Thanks to these new workflows and features, architects and structural engineers can use ARCHICAD to work 

in parallel to create buildings with correct load-bearing construction.
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Simplified Representation of Load-Bearing Construction

Within ARCHICAD, users can create complex structures, such as composites and complex profiles. Thanks 

to the Structural Function classification, at the element and component level, ARCHICAD detects their load-

bearing core and creates their simplified representation: structural analytical members, which can be used in 

structural analysis. The relationship and unity of these members define the Structural Analytical Model inside 

a project.

The Structural Analytical Model can be exported as a whole, but it is also possible to export only parts of it - 

e.g. visible or selected elements only. This filtering enables engineers to check compliance with national 

standards which differ by structure type (e.g. steel, reinforced concrete, precast, composites, timber).

ARCHICAD includes features and functions that ensure the correctness and professional usability of the 

Structural Analytical Model:

• 1D/2D Members and Supports, with correct and continuous connection to provide load-transfer from one 

to another (this is a must-have criteria for finite element method (FEM)-based analysis and design),

• The parameters of structural analytical Members are derived from the physical properties and 

environment of the load-bearing elements. These parameters include:

– Core geometry (profiles/sizes)

– Core materials and connection types (end/edge releases)

– Structural behavior (in analysis)

ARCHICAD also provides several quality check tools to detect incorrectly modeled construction elements or 

discontinuities in either the Physical or Structural Analytical Models. 

See Model Checking.
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Structural Analytical Model Representation

In ARCHICAD, the Structural Analytical Model can be displayed in all 3D Views, 3D Documents, Floor Plans, 

Sections and Elevations.

Since the Structural Analytical Model is created in parallel with the Physical (BIM) Model, it can be viewed in 

one or the other or both, to fit the current workflow. 

Show Structural Analytical Model
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Show Transparent Physical Model
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Project Preferences now include detailed and flexible settings for the style (colors, transparencies, symbol 

sizes) of the Structural Analytical Model components (nodes, end/edge releases, load-bearing core profile and 

the local coordinate system of Members).

ARCHICAD offers immediate visual feedback about the connections between Structural Analytical Model 

Members. By default, a node with:

• green color represents a correct connection point or intersection between joined analytical Members

• red color represents:

– Free point/end

– Unconnected point/end

– Unsupported point/end
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Automatic Generation of Structural Analytical Model 

A structural analytical member is automatically generated from a Physical Model element if the following 

conditions are met:

• The element’s Structural Function is classified as load-bearing

• For a Composite element or Complex Profile, it must include at least one skin/component as core

• Structural Analytical Model generation must be enabled at the element level (in element settings)

Note: Structural Analytical Members are available only for load-bearing elements created with the 

Column, Beam, Wall, Slab or Roof (Single-plane) tool.

By default, the Member is positioned at the center of gravity of the core of a load-bearing element. 

However, Member position can be modified to guarantee Structural Analytical Model continuity, based on a 

particular design consideration or regulation. 

Member position can be defined as follows:

• Fixed at the element level (if the design concept prohibits its modification)

• Modified (if the design concept allows it)

– Manually, by graphical offset in the model

– Manually, by setting offset/eccentricity value in the Element Settings dialog

– By configuring and applying an Adjustment Rule (Offset, Cutback/Stretch, Snap) or a combination of 

them (see Adjustment Rules, below.)

Set Member Eccentricity Graphically or in Settings 
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For multi-segmented beams and columns, or beams and columns that have a variable cross-section, a 

substitute profile is used to model the 1D member.
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Adjustment Rules

Before exporting a Structural Analytical Model from ARCHICAD, it should be checked and adjusted to ensure 

continuity among the 1D and 2D Members. To optimize connections, Adjustment Rules can be defined and 

applied in each project. 

Continuous Structural Analytical Model generation through Adjustment Rules

Note: A useful workflow is to run the Physical Model Quality Check first, to fix any physical modeling 

errors that could affect the Structural Analytical Model (such as lack of load-bearing core connections). 

Once the Physical Model has been checked, Adjustment Rules can be used to address specific problems 

of the structural model.

For details, see Model Checking.

Filter Openings in 2D Members

The user can control which openings in 2D Members should be considered in structural analysis, and which 

should be ignored:

• Define which openings are too small to be considered

• Ignore narrow “strips” between openings or near the edges
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End/Edge Releases

Control the following behavior of connected Analytical Members:

• End points/edges

• Characteristic types (fixed, hinge, roller)

• Custom stiffness values, by components and directions

Customizable End Release for Analytical Members
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Structural Links

These elements provide a link between Analytical Members, without having to physically adjust the Members 

themselves. Each Structural Link can be assigned custom stiffness values.

Structural Supports

User can place Structural Supports under Columns, Beams, Walls and Slabs, and assign custom stiffness 

values for each component and direction. 
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Exchange of Structural Analytical Model with Analysis Applications

ARCHICAD can share the Structural Analytical Model with structural analysis applications via the Structural 

Analysis Format (SAF). This is a global, open-source file format, developed by Nemetschek Group and 

optimized for this purpose.

Note: Import and export of the Structural Analysis Model in IFC format (IFCStructural Analysis View, 

developed by buildingSMART) is available in ARCHICAD 24 as an Experimental Feature. See IFC 

Structural Analysis Model Import/Export.

 

With the SAF format, the Structural Analytical Model from ARCHICAD can be used for analysis and design in 

external applications which use the finite element method (FEM). 

SAF is a new schema developed on the Excel platform. Its content is easy to understand and well-structured 

by analytical model components, thanks to its table sheets.

After structural analysis, the modified Structural Analytical Model in SAF format can be reimported to 

ARCHICAD, where the original Physical Model can be adjusted accordingly. This bi-directional workflow is 

ensured by ARCHICAD’s import/export functions and the new Model Compare tool. 

With ARCHICAD’s new Model Compare tool:

• Visualize changes between the received new and the previously exported Structural Analytical Model

• Decide which differences can be turned into suggestions for modification, and create issues out of them, 

using ARCHICAD’s new Issue Manager
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• Based on these suggestions, decide whether to update the current project’s Physical Model 

Comparing two Structural Analytical Models: 1: Profile change, 2: Length change, 3: Position change

Data Mapping for Structural Analytical Model Exchange

Since different structural analysis applications may use different naming conventions, ARCHICAD translators 

ensure correct data exchange when importing and exporting SAF files. 

These translators, which include customizable mapping, ensure that ARCHICAD definitions (e.g.: profile and 

material attributes) are correctly recognized and interpreted by the external software, and vice versa. The 

translator also allows segmenting of curved Walls at export (and any associated supports/links) to fit the 

receiving software’s capabilities.
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Integrated MEP Modeler

Built-in MEP design tools further extend the integrated design approach of ARCHICAD 24. As of this version, 

MEP Modeler is a core part of the software, without need for a separate license and installation. Use the MEP 

Engineering Work Environment Profile to easily reach the related interface.

With the integration of the MEP Modeler, ARCHICAD users have access to:

• Native MEP Modeling capabilities inside ARCHICAD

• Improved conversion of imported MEP objects through IFC

• Full MEP Opening workflow
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Joint MEP Openings

The Opening tool developed in ARCHICAD 23 has been updated to better suit collaboration between 

disciplines. With these enhancements, it is now possible to create joint openings out of pipes and ducts 

running parallel to each other. It is possible to set different merge tolerances lengthwise and sideways, giving 

the architect control over how the openings should be created. 

This improvement is particularly useful in the following workflow:

1. IFC file, containing the whole MEP system, is received from the MEP Engineer.

2. The IFC file is hotlinked and the MEP elements are converted to GDL objects or Morphs.

3. This MEP system or individual pipes and ducts can be selected to create the desired openings in walls.
ARCHICAD 24 Reference Guide 93



Integrated Design New Features in ARCHICAD 24
MEP Modeler Enhancements

Changes in Predefined Pipe Sizes

At MEP Preferences, use the Predefined Sizes dialog to define a default bend radius for each size. Newly 

created bends will be created correctly - no remodeling needed. 

Another improvement: the description you add here will be visible in the MEP Routing palette. This is 

particularly useful for copper and plastic pipes, whose diameters can be described in different ways. Add one 

diameter in the size column, and the other in the description column.

All these data can be exported into xml files, so you can use different Predefined Sizes for modeling different 

systems.

Connection improvements

• Connections between ducts/pipes/cable carriers now can be created easily by moving one duct into 

another. Then you can easily define connection type (Tee, Take-off, Wye).
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• Connections between ducts/pipes/cable carriers at different elevations are now created automatically with 

90° bends. This feature is useful when connecting branch pipes to main pipes on the corridors.

Flexible duct overhaul

Flexible ducts make systems less rigid and provide connection possibilities where traditional ducts would not. 

This overhaul focuses on connection freedom. Creating a flexible duct via the MEP Routing window is an easy 

and straightforward task: quickly create a flexible duct of any shape and size at any duct ending. The 

necessary transitions are automatically placed. 

Additional distribution library elements

Four new, highly customizable distribution objects can be downloaded from BIMcomponents. These objects 

make modeling even more intuitive and can be used together with other MEP library elements:

1. Multifunctional Tee Duct

2. Customizable Bend

3. Bypass Pipe

4. Wye Branch Pipe
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Model Checking

Besides the already available Collision Detection, ARCHICAD introduces two new model checking solutions, 

which can be run at any time during the project life-cycle:

• Physical Model Quality Check

• Structural Analytical Model Quality Check

Use the Model Check Report to manage the check results. 

• Easily select an item’s elements in 3D or Floor Plan

• Sort reported items by their details

• Decide which cases are genuine problems that require handling, using the new Issue Management 

workflow.

Model Check Report lists every result from model checking features

The Info button of Model Check Report presents a summary of the reported problems.
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Physical Model Quality Check

This function ensures that the Physical Model is correct. (This also provides a good basis for the Structural 

Analytical Model and its eventual export for structural analysis.) The checked parameters can be customized 

to conform to modeling standards, or to software or project rules.

See Physical Model Quality Check.
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Structural Analytical Model Quality Check

This function ensures that the automatically generated Structural Analytical Model is correct and ready for 

exporting to a structural analysis application.

See Structural Analytical Model Quality Check.
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Model Check Report

The Model Check Report provides straightforward management of reported problems from all three of the 

model checking functions, in a single list. 

You can easily zoom to the problematic item.

Model Check Report lists every result from model checking features

Issue management workflow

Decide which cases are genuine problems that require handling.

These can be easily turned into highlight-type issues directly from the Model Check Report dialog.:

• Create a separate issue for certain reported items, or

• Create a single issue from multiple reported items

For details, see Issue Management.
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Creating issues directly from reported check results

See Model Check Report.
ARCHICAD 24 Reference Guide 100



Collaboration New Features in ARCHICAD 24
Collaboration

Tracking Changes in Teamwork Projects

Note: Change Tracking features are not available for BIMcloud Basic users.

Architects and engineers benefit from close collaboration – especially in early design stages, with rapid 

iterations of different design scenarios.

ARCHICAD introduces Change Tracking, to enable Teamwork users to be notified of relevant changes to the 

model.

See Change Tracking in Teamwork.
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Subscriptions for Change Tracking

The Change Tracking feature is controlled by user-defined Subscriptions. Subscriptions can be flexibly set up 

using various criteria, selection and filtering methods. This way, the user can filter out non-relevant 

modifications.

For example, a user can track changes in individual 3D model elements, or changes in Project Data (Story 

Settings, Attributes).

Every time Teamwork changes are sent to the BIMcloud, the owner of the Subscription is notified of all 

element or project data changes that meet the criteria.

Subscriptions can be easily turned on/off, or imported/exported to other projects.

User can customize which element or Project Data changes to track

Subscription for changes in Project Data
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Filter Element Changes by Parameter Type

When subscribing to 3D element changes: the set of tracked changes can be further refined by parameter 

type.

Filter Changes by Users

When subscribing to 3D elements changes or Project Data changes: the set of tracked changes can be 

further refined by User or Team. This way, notifications arrive only about changes made by a particular design 

team or individual.

Note: “Teams” are sets of users, such as a Team of Structural Engineers, created for the new “BIMcloud 

Project” containers on BIMcloud. 

See Team Management on BIMcloud.
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Manage Tracked Changes

Change Tracking is an optional feature, and notifications appear in the Tracked Changes section of the 

Teamwork Palette only if the user subscribes to them. 

When a notification appears here, the user can click to instantly see which changes have occurred to which 

elements, and can decide whether to receive the changes or not.

Changes are automatically aggregated by element, so continuous editing of a single element will not generate 

a flood of notifications: only one will be delivered. 

Notifications show exactly which element parameter types or Project Data have changed

Change alerts can be snoozed without permanently dismissing them.
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Visualizing Project Changes

When the user is notified of changes in model elements, it is easy to highlight them in the project:

Notifications highlight 3D elements affected by change

Model Compare After Receive

After examining the changefs, the user can decide when to receive them from BIMcloud. Furthermore, the 

new Model Compare feature is integrated into the Teamwork’s Receive process: after receiving changes, this 

compare workflow shows the user what has changed in the model.

Model Compare and change visualization can be run after receiving changes
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Model Comparison

With multiple stakeholders in each project, the job of following, understanding and adapting ongoing design 

changes is a significant task. 

ARCHICAD introduces Model Compare: compare two 3D models or versions, and visualize and filter the 

differences between them. Users can keep track of design changes accurately and even evaluate design 

variants.

Model Compare offers numerous options to visualize changes between two groups of 3D models

For details, see Model Compare.
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Compare 3D Models

Use Model Compare to identify and visualize changes in two versions of a 3D model - not just changes in 

element geometry, but also visual representation and properties.

Multiple Model Compare processes can be run simultaneously in the background, even if they involve large 

and complex projects, while the user works uninterrupted on the current model. The Model Compare tab 

provides feedback on the process and its completion.

Compare Current Model with External Model

Model Compare enables the user to visualize changes between any two timestamps of the following 3D 

models:

• The currently open ARCHICAD model

• Any external PLN, PLA and SAF (Structural Analytical Format) file saved locally or stored on BIMcloud

This flexibility enables the user to compare, visualize and evaluate design variants, whether created in the 

same model or in different files. 

Compare Teamwork Model Versions

In Teamwork, Model Compare shows which changes have occurred in the project’s status before and after 

receiving changes from other users. 

Detect Changes from Hotlink Update

Model Compare can be run directly after updating any hotlinked PLN or MOD model, to show what has 

changed as a result of the update.

Compare Structural Analytical Model Versions

Comparing two Structural Analytical Models in ARCHICAD shows the difference between the original 

analytical model generated in ARCHICAD, and the modified one reimported to ARCHICAD from a 3rd party 

structural analysis application.
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Visualize Model Changes

In the dedicated Model Compare window, the differences between two compared models or versions are 

shown in different colors. Sliders can emphasize or dim the displays of the model changes and the unchanged 

environment, respectively.
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Filter Changes

In the Model Compare window, users can filter the displayed changes in several ways.

Filter Changes by View

As part of the comparison process, the user must define a 3D View from each of the two models or versions 

being compared: View Settings are thus taken into account. By choosing two 3D Views that use different 

Layer Combinations, user can compare two design variants from the same project.

3D View Properties determine participating model elements

Alternatively, user can choose a common 3D View for both participating models, if the goal is to compare 

different timestamps from the same model. 
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When comparing Structural Analytical Models, user can control which properties should be considered. 

Filter Changes by Criteria

Filter the 3D model element changes to show only the relevant ones. For example:

• Walls using concrete material that are thicker than 300 by defining a Custom Criteria set

• Changes already being tracked in Teamwork (by re-using the Criteria Set defined when signing up for 

Change Tracking). For example: modifications to load-bearing columns.

Filtering changes by a Custom Criteria set
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Filter Changes by Parameter Set

The Model Changes list can also be limited to show only the changes involving certain parameters. (For 

example, this way you can filter for changes relevant to a particular discipline.)
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Manage Model Changes

In Model Compare palette, the list of detected changes can be organized by groups, in different tree 

hierarchies, to help easy navigation among numerous list items. For example, changes can be grouped by:

• Status (“Modified”, “Model 1 Only”, “Model 2 Only”)

• Tool (“Wall”, “Slab”, “Column” etc.)

• Source (host file’s or hotlink module’s name)

• Classification

Organize and manage visualized changes efficiently
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Selecting Changed Elements

When the user selects a changed element from the Model Compare window, or any item from the Model 

Changes list, the corresponding element/item is also selected automatically.

Icons at the bottom of the Model Compare palette provide instant feedback on which parameter sets were 

affected in the changed element.

For any selected item in the Model Changes list: context menu commands can Show on Floor Plan or Show 

in 3D.

Turn Changes into Issues

Selected changes can be added (individually or as a group) to issues, as highlights or suggestions. Model 

Compare results are thus integrated with the new Issue Manager and Organizer tools, for context-based 

communication with other project stakeholders.

For details, see Issue Management.
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Add selected changed elements to Issues from the Model Compare window
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Issue Management

ARCHICAD’s new issue management tools allow users to avoid all the coordination overhead, and instead 

concentrate on solving Issues. Architects and engineers can communicate more efficiently, and also propose 

design changes via Issues, without interrupting the project.
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Highlights and Suggestions

As in traditional issue management workflows, ARCHICAD users still have the option to simply highlight 

model elements and assign them to other users, for design communication with no further action needed.

But in the new workflow, issues can contain not only highlighted elements, but also any number of 

suggestions, of three types:

• New – suggest a new element

• Modify – suggest a modified alternative of an existing element

• Delete – suggest that an existing element be deleted

All elements connected to suggestions are displayed in different colors for easy review in any 2D or 3D 

window.

Suggestions for element changes - New, Modify and Delete
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To create a suggestion, users add 3D elements to a currently opened Issue. In Teamwork, every suggestion 

(via its containing issue) can be assigned to any other user for approval, who is instantly notified.

Assign Issues to other team members

Suggested design changes do not become part of the model until the assigned user accepts it.

Furthermore, the user can accept a suggestion only partially; he or she can limit the element changes to 

certain parameter sets (e.g. accept the suggested Building Material, but not the modified geometry).

Accepting suggested element changes partially

Once a suggestion is accepted fully or partially:

• Deleted elements are removed from the project

• Modified elements/element parameters replace the previous instances 

• New elements become part of the project
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Creating Issues

For maximum productivity, issue creation is tightly integrated with all the other collaboration and model 

checking workflows in ARCHICAD.

Issues by Selection

Any selected model element can be added to a new or existing issue, using a context menu command or via 

Issue Manager. 

Issues from Model Checking

The new Model Check Report lists reported problems from all three of the model check functions. 

For each listed item, the user can:

• Fix the problem right away

• Add it to an Issue and assign it to other team members

• Solve it later

For details, see Model Checking.

Issues from Model Compare

In the Model Compare window, the dedicated palette lists the resulting changes. Select any items from this 

change list to add them (individually or as a group) to Issues, as highlights or suggestions. 

For details, see Model Comparison.

Issues from BCF Import

ARCHICAD’s supports the issue management workflow via BCF: import a BCF file using Issue Organizer, 

either from local folder or directly from BIMcloud, then create and add the issues to the ARCHICAD project for 

further management.

ARCHICAD supports the latest BCF format (BCF 2.1), as well as all earlier BCF versions.

See also Support for BCF 2.1.

Issues from PDF markup

Issues coming from PDF markup solutions like Bluebeam are now shown in ARCHICAD’s new Issue 

Manager, for an even more convenient connection between ARCHICAD and Bluebeam Revu.
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Managing Issues

ARCHICAD introduces two new interfaces to manage, edit and organize issues effectively.

Issue Manager

Issue Manager enables the user to detail and manage the content of individual Issues. 

Users can save any number of views into the Issue. These views are based on the visible elements, the 

camera position, the cutting planes and the snapshots. Redlining can be applied to the snapshots using the 

default image editor. Issue Manager is also where the user accepts (or partially accepts) suggested 

modifications.
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Issue Organizer

Issue Organizer manages the full list of all the Issues in the project.

Sort issues using a customizable hierarchical logic to fit user needs. 

Parameters of the selected issues can be instantly changed with inline editing.
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Detail and customize issues with the new Issue Manager and Issue Organizer

Issue Tags

Each issue can be assigned Priority, Status and Type values, and can be sorted accordingly. Available values 

can be customized.
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Selected Elements and Related Issues

Users can easily check whether a selected element is part of an existing issue, then filter for the relevant 

issues in Issue Organizer.

Context-Sensitive Suggestion Feedback

For a selected element that is part of an issue: context-sensitive feedback (in the grip icon) lists which 

parameter groups will be changed if the suggestion is accepted.
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Issue Details & History

Both Issue Manager and Issue Organizer provide access to the details and history of the current issue. In 

Issue Details, the user can modify the issue name and the parameters, add labels, enter the description, and 

determine the responsible person and/or team.

The History panel of Issue Details monitors all activities related to a particular issue.
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BIMcloud Enhancements for Issue Management

In Issue Organizer, the selected issues can be exported to BIMcloud in BCF or XLS file format. With the 

Import from BIMcloud function, new issues can be introduced to the project or existing issues updated.

On BIMcloud, three new permissions are available, to control access to issue management.

• Issue - Create/Modify: Enables user to create and modify issues

• Issue - Delete: Enables user to delete the existing Issues from the project

• Issue Tag - Create/Modify/Delete: Enables user to manage issues’ Status and Priority parameters
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Support for BCF 2.1

ARCHICAD offers support for the latest BCF 2.1 format to exchange traditional, so-called “highlight” type 

issues more precisely. 

A significant advantage of the latest format is that elements’ visibility can be managed in BCF, based on the 

view(s) saved in the issue. Issue details now include several new parameters (Name, Status, Priority, Due 

Date, Responsible, etc.) and can include multiple viewpoints for more straightforward communication.

With BCF 2.1, the new Description field allows for more detailed explanation, and comments can be added 

even without reserving the issue in the ARCHICAD Teamwork project.

Besides support for importing and exporting the latest BCF 2.1 format, ARCHICAD also maintains 

compatibility with former 1.0 and 2.0 versions.
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Coordination

BIMcloud as Multi-Disciplinary Model Hub

Note: These features are not available for BIMcloud Basic users.

BIMcloud has been transformed into a model hub for multi-disciplinary team collaboration and coordination.

Since every professional wants to use the software solution that best meets their needs, BIMcloud now offers 

a totally open BIM based platform, supporting formats like IFC, BCF, PDF and others, as a common ground 

for various collaboration tools. 

Thanks to new user “Teams” and associated project-specific permissions, BIMcloud ensures that every 

member of the project team has the access rights needed to collaborate, or to upload and download the 

relevant files needed for coordination. The new organizational, data exchange, project- and file management 

solutions mirror the complexity of real-life multi-disciplinary projects. 
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Project Management on BIMcloud

The new “BIMcloud Project” on BIMcloud serves as a central directory for all the information and settings 

related to a design project. Settings (e.g. access rights) for each BIMcloud Project can be tailored to meet 

specific situations.

Use BIMcloud Project to store, manage, and access all files, folders and related models in connection with a 

specific project.

BIMcloud Project on browser-based BIMcloud Manager interface
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Team Management on BIMcloud

A Team is a group of Users associated to a particular BIMcloud Project (a container entity hosting project-

related files of various formats). A Team can consist of a particular discipline (e.g. “Structural Engineers”), but 

can just as easily consist of users from different disciplines. 

Teams are different from the existing User Groups. Teams organize Users exclusively in the context of a 

BIMcloud Project. Thus, Teams of the same name can be used with multiple BIMcloud Projects (e.g.: 

Landscape Architects), and the members of these Teams can be different for each. 

In large design projects, with numerous architects and engineers collaborating on several design teams, 

BIMcloud Project’s Teams panel provides an easily accessible interface to see other contributing Teams and 

their members. 

Teams panel inside a BIMcloud Project
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Team Permissions

To mirror real-life project environments, where different design teams have different liabilities, Teams of 

BIMcloud Projects can be assigned permissions, just like assigning permissions to an individual User or 

Group. If no such differentiation of responsibilities is needed among the Teams, the manager can grant 

identical access to all members of all Teams of a BIMcloud Project by selecting the ‘All Team members’ 

option.

Control permissions of each Team inside BIMcloud Project

Teams’ Visibility

In some cases, Teams and their members are considered to be confidential information. Visibility of Team 

data can be controlled with a new permission called ‘View BIMcloud Project’. Users without this permission 

cannot see who is working on the project.

Team Folders

In real-life design projects, different design teams have separate directories to store and share their files 

internally. Similarly, BIMcloud Projects can include dedicated folders for specific Teams, for exclusive data 

exchange. Each file inside these folders can be modified only by the Team which has permission. As needed, 

permissions to view or modify these Team folders can be fine-tuned.
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File Management on BIMcloud

As a fully open BIM platform, BIMcloud can now host file formats from any third party solution, supporting 

coordination among design team members. Any uploaded file can be fit into BIMcloud’s hierarchical system of 

Projects. External disciplines, including non-ARCHICAD users, can easily access relevant data via BIMcloud 

Manager’s browser-based interface.

Browser-based Access

Every file management function is available through BIMcloud Manager, from any browser, on any device. 

Folders as well as files can be uploaded and downloaded from the interface.

Upload any file or folder to BIMcloud

Detailed Permission Control for Uploaded Files 

Uploaded files are integrated into BIMcloud’s customizable permission system. Access to uploaded files can 

be configured for each individual User or Group, or (for BIMcloud Projects) a Team.

Versioning/Rollback for Folders/Uploaded Files

BIMcloud now keeps all previous versions of uploaded files. This ensures transparency in tracking earlier 

modifications. User can easily roll back to an earlier version of a file. The user can also download any 

previous version (thereby maintaining the file’s current state).
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BIMcloud also keeps track of folder history. Folders, with all their files, can be rolled back to an earlier version. 

Folders (like files) can also be downloaded.

File Versions

BIMcloud now keeps a history of every action in connection with files, ensuring transparency and traceability. 

The Versions tab tracks every modification in connection with the specific file’s content and previous rollback 

actions.
ARCHICAD 24 Reference Guide 131



Coordination New Features in ARCHICAD 24
Enhanced Coordination with ARCHICAD

The fully open BIMcloud allows architects and engineers to increase their productivity in workflows involving 

ARCHICAD.

Publishing to BIMcloud from ARCHICAD 

User can publish any set of 2D or 3D deliverables from ARCHICAD directly to BIMcloud. From ARCHICAD’s 

Publisher, select a BIMcloud as a destination and choose the desired folder. Each file of the Publisher Set is 

then uploaded to BIMcloud, where they become instantly accessible to other members of the team who have 

the appropriate permissions.

Accessing BIMcloud Files from ARCHICAD

ARCHICAD can directly access all files uploaded to BIMcloud. 

From ARCHICAD, the user can:

• Place and update hotlinked modules directly from BIMcloud

• Place and update any drawing (e.g.: DWG, DXF) directly from BIMcloud

• Merge any drawing or model into the current project from BIMcloud
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Geometry Exchange with Revit

Note: This feature is planned to be released as part of a stand-alone ARCHICAD 24 add-on. The 

ARCHICAD Action Center will notify you when the add-on becomes available.

Users can import and export elements with their precise geometry and parameters (as non-editable content) 

from Revit (RVT) files for coordination and model referencing purposes. RVT files can be accessed locally or 

via BIMcloud, using Hotlink or Publish functions.

ARCHICAD uses the ODA Teigha BIM Engine, which imports RVT file versions 2015-2020 and exports RVT 

file version 2020.
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Productivity

Content Library Update - New Residential Furniture Elements

As part of our continuous library development, ARCHICAD has applied a little polish to its residential interior 

furnishing elements. Improved user interface makes it easier to select and place the new, modern-style library 

objects into your scene, bringing both 2D and 3D views to life in a more contemporary manner. With an 

extended Leg, Panel and Knob collection, more than 40 new residential objects have been created, including 

sofas and beds, a variety of tables and stands, armchairs and wardrobes, and new accessories and 

decorative elements - all serving to complement 2D drawings and modern-day visualization pipelines.
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Beds and Nightstands

New bed elements in the ARCHICAD Library include metal frame, wooden frame and upholstered structures, 

plus new nightstand elements of different styles. 

Sofas, Armchairs, Ottomans, Coffee tables and Media furniture

New contemporary sofa, armchair, ottoman and coffee table elements are available for many functional 

arrangements.
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Storage Furniture

We have added new Storage Furniture elements that are typical in contemporary residential spaces: Chest of 

drawers, TV Stand, Sideboard, Wardrobe

Decoration elements for residential spaces

New decoration elements include realistic 3D pillows and blankets, adding a casual touch and mood to 

renderings.
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Import and Use Revit Families as GDL Objects

Note: This feature is planned to be released as part of a stand-alone ARCHICAD 24 add-on. The 

ARCHICAD Action Center will notify you when the add-on becomes available.

Users can directly create Objects, Doors and Windows from Revit Families (RFA; mostly manufacturer 

content) and use them in the ARCHICAD project. The generated ARCHICAD library items have the same 

precise geometry and all parameters (in non-editable mode) as those stored in RFA.

ARCHICAD uses the ODA Teigha BIM Engine, which imports RFA file versions 2015-2020.
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Polyline editing functions refined

ARCHICAD 24 improves polyline editing:

• The Intersect command now works between two or more independent Polylines, and between Polyline 

and Wall/Beam/Line/Arc.

• When intersecting Polylines: if only one ends intersects after the first Intersect command, repeat the 

command to intersect the other ends as well (this is the same function as for Lines).

• Fillet/Chamfer command now works on Polylines, (If more than one Polyline is selected for this command, 

first they will be intersected and then filleted or chamfered.)
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ARCHICAD option set values available as a 'pull-down menu' when 

exported to Excel

In ARCHICAD 24, when a user exports an Interactive Schedule to a .xlsx file format: Exported properties 

whose data type is “Option Set” will have the defined options available in the generated spreadsheet in a 

pull-down list, for easy and precise value input. 

After changing a value in Excel and importing the sheet back to ARCHICAD, the change will appear in 

ARCHICAD as well.
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DGN v8 Support

ARCHICAD 24 supports importing the latest version of the .DGN file format (v8). Elements introduced in the 

v8 version are also translated to ARCHICAD elements: the 2D and 3D elements will be transformed into 2D 

elements only. The import can be configured to tailor the translation method based on the user’s needs.

During export, ARCHICAD 24 saves the previous (v7) DGN format.
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Experimental Features

GRAPHISOFT would like to shorten the development cycle of certain features and collect user feedback at an 

earlier stage. Based on this feedback, experimental features may or may not become part of the core 

ARCHICAD functionality in a future version. 

Enable and disable experimental features in Work Environment > More Options > Experimental Functions.

To gauge the usefulness of these and other features, GRAPHISOFT collects anonymous usage statistics as 

part of the Customer Experience Improvement Program (CEIP) from users who allow it. When you turn on an 

Experimental Feature, if you did not enable CEIP when you started ARCHICAD, you are invited to do so 

optionally.

JSON/Python API for ARCHICAD

ARCHICAD 24 introduces a new API layer that aims to lay the foundation for running automation scripts and 

complex command chains from outside ARCHICAD, using higher-level programming languages.

This technology is based on a standardized data exchange format - JSON – into which certain C++ 

commands are being gradually translated to provide a new level of programming interface for ARCHICAD. In 

ARCHICAD 24 we are introducing this technology in two key areas:     

• Access and modify user-defined and built-in properties of AC elements

• Access and modify project navigator elements – documentation automation (in progress)

JSON - as a language-independent format – enables the use of a variety of higher-level programming 

languages such as Python or Perl. To support the wide userbase of Python, we established a Python wrapper 

and documented the available commands in Python. 

To encourage use of this technology, a “Python Palette” has been introduced on the ARCHICAD interface, 

where Python scripts can be imported, run and managed inside ARCHICAD. 
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Dark Mode Support on Mac

Dark Mode was introduced in macOS Mojave (10.14.). ARCHICAD can adapt its appearance to this macOS 

System Preference setting, with dark icons and dark UI color palette. Enable this feature in ARCHICAD first at 

Work Environment > More Options, then you can toggle between Light and Dark mode via System 

Preferences.
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You can even set the background of the workspace to a dark color (View > Grid & Editing Plane Options > 

Grids & Background…):

IFC Structural Analysis Model Import/Export

You can open, compare or save files in IFC Structural Analysis Model format (*.ifc).

Make sure you enable this feature at Work Environment > More Options.

Based on IFC Structural Analysis View (developed by buildingSMART), this format is available from 

• File > Open 

– At Open, elements of the incoming model are converted automatically: what you see corresponds as 

exactly as possible to the original structural model. 

• File > Save 

– At Save, choose to export the entire project, or just visible elements.

• Design > Model Compare

– Browse for models in *.ifc format

See IFC Structural Analysis Model Import/Export - Experimental Feature.
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BIMx 

BIMx (iOS) app update

New features and key changes:

• Hyper-models with unlimited 3D model size, thanks to advanced data streaming technology

• Photo-realistic view with real-time lighting calculation

• Faster startup opens the model in no time

• Redesigned menu structure, so you find all settings in one place

• In-app purchase options were also redesigned, and new subscription plans are available in BIMx app.

• Sharing in-app purchase option will be discontinued

• Smart Measure will be available for free

BIMx Desktop Viewer update

BIMx Desktop Viewer is getting a facelift: based on the technology developed for BIMx Web Viewer, this 

update will deliver a state-of-the-art BIM viewer for clients who like to review the architectural design on their 

desktop.

New features:

• Hyper-model viewer on Windows and Mac with the same feature set that is available currently in the BIMx 

Web Viewer

• Support of 3D Connexion navigation devices

• Substituting the pre-baked Global Illumination with real-time ambient occlusion visual effect 
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Migrating to ARCHICAD 24

Migration Topics: Migrating from Versions 18-23

ARCHICAD 24 opens all older-version projects starting with 8.1.

If you are migrating from version 18-23 to version 24, please be aware of the following migration-related 

issues.

Note: For additional issues affecting projects from pre-18 versions, see also Migrating from Older 

Versions (ARCHICAD 8.1 through 17).

Drawings with Resized Frames are Cropped

Migrate from ARCHICAD 22 and earlier

When opening an older-version project, Drawings whose Frames were “Manually Resized” (as seen in 

Drawing Settings) will be cropped. 

Cropped Drawing content was a new feature in ARCHICAD 23 to enhance performance. Cropped content 

can be restored at any time, as long as its source remains available.

See Drawing Frame for more information.

Migrate Libraries to Preserve Older-Version Surfaces and Textures

Migrate from ARCHICAD 22 and earlier

When opening an older-version project, make sure you “Migrate Libraries” to ensure that older-version 

surfaces and textures are available. (When starting ARCHICAD, Libraries are migrated by default.) All 

surfaces from ARCHICAD 22 and earlier versions are contained in the Migration Library.

See Migrating Libraries to ARCHICAD 24.

Migration Topics

(click topic for info)

Migrating from Version

23 22 21 20 19 18

Drawings with Resized Frames are Cropped + + + + +

Migrate Libraries to Preserve Older-Version Surfaces 

and Textures

+ + + + +

Replace Curtain Wall Frames/Panels + + + +

No “Custom” Model View Options Combinations + + + +

Stair Favorite Settings May Be Reset +

New Stair Tool Replaces StairMaker + + +

Changes in IFC Translators + + +

ID-based Labels with Autotext + + +

New “3D Styles” View Option + + +

Model View Fill Options Replaced By Graphical 

Overrides

+ +

Guide Lines and Snap Points +
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If you wish to replace the older-version surfaces in your project with new ones from the AC24 Library’s 

Surface Catalog, do the following:

1. Open the Surfaces dialog (Options > Element Attributes > Surfaces)

2. Add new Surfaces to the Catalog using the New > New from Catalog radio button, then apply the new 

Surface to existing elements. (Or replace the old surfaces with new ones, using New > Replace Settings 

from Catalog.)

Replace Curtain Wall Frames/Panels

Migrate from ARCHICAD 21 and earlier

Your existing GDL Frames and Panels are migrated as-is to ARCHICAD 24. 

It is recommended that you replace them with corresponding Panels and Frames provided in the ARCHICAD 

24 Library.

Advantages:

• In ARCHICAD 24, these components can be assigned Building Materials separately

• AC 24 Frames will intersect intelligently - including Frames that meet at angles (e.g. hexagonal patterns)

• AC 24 Frames and Panels can use the new Model View Options available for Curtain Walls (Schematic 

and Simplified as well as Full)

Note: Once you replace a GDL Frame-Panel with a one in ARCHICAD 24, you cannot change it back to a 

GDL-based element. 

• In projects migrated to AC 24, the “Main” and “Distinct” Panel classes become user-generated classes of 

the same name.

• The “Mullion,” “Transom” and “Boundary” Frame classes become user-generated classes of the same 

name.

No “Custom” Model View Options Combinations

Migrate from ARCHICAD 21 and earlier

Edited MVO Combinations are no longer “Custom” - they are always named.

“Custom” MVO Combinations migrated from earlier versions automatically become named MVO 

Combinations.

Stair Favorite Settings May Be Reset

Migrate from ARCHICAD 21

When you open an AC 21 project, you may find that the 2D attributes which you customized in your Stair 

Favorites have been reset to their built-in defaults.

This affects all of the attributes (e.g. Break Mark, Walking Line, Numbering) that are set under the Floor Plan 

Display/Reflected Ceiling Plan in Stair Settings, for Stairs saved as Favorites.

As needed, open your Stair Favorite Settings and readjust the 2D attributes.

(This problem stems from a necessary fix to repair an anomaly in the Stair’s data structure.) 

New Stair Tool Replaces StairMaker

Migrate from ARCHICAD 20 and earlier

The StairMaker Add-on is no longer supported. 

StairMaker Stairs from older-version projects are converted into GDL Stair-type objects, with limited GDL 

parameters available from Object Settings.
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Changes in IFC Translators

Migrate from ARCHICAD 20 and earlier

• Translator files are stored in a template (.TPL) file, not in an XML file (as in earlier AC versions).

• Translators from migrated projects are recreated under the same name.

– If the XML files of the older-version Translators are available, these settings will be contained in the 

newly recreated Translators.

– If the XML files are not available, the Translators will be created, but they will not contain any settings: 

you must choose or create presets for each such Translator.

– To import older-version Translators manually: Use the Import button in the IFC Translators dialog box, 

and choose the .XML file format to browse for the Translator.

• IFC Scheme Settings have been replaced by Translator-specific Property Mapping.

– The “Property Mapping for IFC Export” preset contains the older-version project’s Scheme Settings

• Type Mapping is customizable by the user

– The “Type Mapping for IFC Export” preset contains the default Classification Mapping used in older-

version projects.

ID-based Labels with Autotext

Migrate from ARCHICAD 20 and earlier

ID-type Labels (ID Label, Unique ID Label) from earlier versions are transformed into the renewed Text/

Autotext-type label, which uses Autotext to display the element’s ID.

New “3D Styles” View Option

Migrate from ARCHICAD 20 and earlier

The appearance of 3D views depends on 3D Styles, a View Option. (View > 3D View Options > 3D Styles).

These settings replace the 3D Window Settings of earlier versions.

If your project contains a large number of 3D views with varying settings, be aware that a large number of 3D 

Styles may be generated, each with a unique name.

Model View Fill Options Replaced By Graphical Overrides 

Migrate from ARCHICAD 18 and earlier

The Override Fill Display panel of Model View Options has been eliminated. Instead, overrides are handled by 

Graphic Override Rules (GOR). These Rules are applied to individual views/viewpoints as Graphic Override 

Combinations.

The Renovation Override Styles (from previous AC versions) are now predefined as Graphic Override Rules.

Guide Lines and Snap Points

Migrate from ARCHICAD 18 and earlier

• The Snap Point setting formerly called “Along Entire Element” is now called “Between Nodes”.

• Guide Lines on/off status in the migrated file will be interpreted as Snap Guides on/off.

Related Topics

Migrating Libraries to ARCHICAD 24

Migrating a Teamwork Project (v. 13-23) to ARCHICAD 24

Migrating from Older Versions (ARCHICAD 8.1 through 17)
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Migrating Libraries to ARCHICAD 24

The new version of ARCHICAD will work perfectly well with any older-version ARCHICAD libraries. However, 

if you stay with your older libraries, you will not get the full benefit of library improvements and fixes. 

We recommend that when you migrate a project to ARCHICAD 24, you also migrate your older-version 

Library to the ARCHICAD 24 Library, using the easy and automatic Migrate ARCHICAD Libraries function.

IMPORTANT: When migrating an older-version project, if you want to use the newest library, make sure 

you use the Migrate ARCHICAD Libraries function. If you add and delete Libraries using Library 

Manager, you may end up with a large number of missing library parts.

Note: The automatic Migration process described below is available only for projects that use ARCHICAD 

Libraries 10 and later.

At any time, to view information about possible Library-related issues in your current project, check the 

Libraries item in the Action Center (File > Info > Action Center).

Migrate ARCHICAD Libraries when Opening Older-Version Project

When you open an older-version project in ARCHICAD 24, and if your project includes an ARCHICAD Library 

(version 10 and later), you are prompted to use the Migrate ARCHICAD Libraries function:

Click Migrate ARCHICAD Libraries. This process will do the following:

• load the new ARCHICAD library

• load the ARCHICAD Migration Libraries folder (What is a Migration Library? See below.)

• automatically replace placed objects from the older libraries (versions 13-23) with their latest compatible 

version

• remove ARCHICAD libraries with lower version numbers

The Migrate ARCHICAD Libraries process may take several minutes. Once it is complete, if your project 

includes objects from pre-ARCHICAD 13 libraries, you may still have missing library parts. In this case, use 

Library Manager to load Old ARCHICAD Migration Libraries. (What is a Migration Library? See below.)

If instead you choose Skip Migration, you will load the old Library that was saved with the project. All placed 

objects will be available from that library, but you will not be able to use any library improvements and fixes 

from the latest version.

Migrate ARCHICAD Libraries for a Running Project

You can use the Migrate ARCHICAD Libraries process at any time, not only when migrating an older-version 

project. For example: 

• if you did not use the Migrate ARCHICAD Libraries process when opening an older-version project, but 

now would like to
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• if you have new issues with missing library parts as the project develops (e.g. new library parts added as a 

result of Teamwork or Hotlinked Modules)

Use the Migrate ARCHICAD Libraries button in Library Manager.

Note: If the button is not shown in Library Manager, this is because ARCHICAD has determined that there 

is no need for it: all needed libraries (latest ARCHICAD library plus Migration libraries) have already been 

loaded; and the project has no missing library parts.

Migrating Libraries in a Teamwork Project

To migrate a Teamwork project, use the Migrate Project process described here: Migrating a Teamwork 

Project (v. 13-23) to ARCHICAD 24.

During this process, make sure that the Migrate ARCHICAD Libraries checkbox is checked. This will ensure 

smooth migration of your ARCHICAD Libraries together with the Teamwork project.

Note: Some objects in your migrated Teamwork project may be listed as “Temporarily Missing” in the 

Library Manager. As soon as other users do a Send and Receive, this problem will be solved 

automatically.

What is a Migration Library?

Each new version of the ARCHICAD Library contains many objects that have been updated since the 

previous version. For the most part, these updated objects are compatible with placed older versions of the 

same object, and will automatically replace the older versions.
ARCHICAD 24 Reference Guide 149



Migration Topics: Migrating from Versions 18-23 Migrating to ARCHICAD 24
Some objects from older ARCHICAD libraries, however, have no counterpart in the new ARCHICAD 24 library 

(typically, these are “discontinued” objects deemed obsolete). But if you have such objects placed in your 

project, you want them available even if after migrating a project.

ARCHICAD Migration Libraries serve this purpose: they contain only those objects from an earlier-version 

ARCHICAD Library that do not have counterparts in the latest-version ARCHICAD Library. A Migration Library 

is much smaller than full-version ARCHICAD Library.

When Are Migration Libraries Used?

Migration Libraries are loaded automatically with two workflows:

• Migrate ARCHICAD Libraries 

See Migrate ARCHICAD Libraries when Opening Older-Version Project.

• Consolidate: If you have placed objects from multiple ARCHICAD libraries and have loaded all the 

libraries, you will be prompted to Consolidate your libraries. The Migration Libraries are loaded 

automatically.

See Consolidate Multiple ARCHICAD Libraries.

If you do not use these workflows, then some of your placed objects from older-version projects may not have 

a compatible corresponding object in ARCHICAD 24. In this case:

• Those incompatible older objects will be “Missing Objects” if you have removed your old libraries. In this 

case, you must replace these missing objects with new ones from the ARCHICAD 24 library, and reset 

their parameters as needed.

• Keeping your old libraries alongside your new libraries is not recommended, because a great many of the 

loaded objects will be duplicates and/or superfluous, and increase library loading time and potential 

errors.

Notes:

– If you still have missing library parts, it may be because you are using library parts from ARCHICAD 

libraries earlier than version 13. If so, you must manually add the Old ARCHICAD Migration 

Libraries folder to the project, using Library Manager.

– If your ARCHICAD Libraries are BIMcloud/BIM Server Libraries (for example, for a Teamwork project) 

and you want to consolidate them, ARCHICAD will not be able to locate the migration libraries 

automatically. In this case, you must upload the migration libraries from your hard drive to the 

BIMcloud/BIM Server.

Where to Find Migration Libraries

Migration Libraries are installed on your computer as part of ARCHICAD installation. They are divided into two 

folders:

• ARCHICAD Migration Libraries (for ARCHICAD library versions 13 and up)

• Old ARCHICAD Migration Libraries (generally available for ARCHICAD library versions 10-12)

You can also download Migration Libraries from the GRAPHISOFT website.

Note: Available migration libraries may vary, depending on your localized version.

Obsolete Objects

Objects are “obsolete” in two cases:

• the object has been discontinued entirely as of the new ARCHICAD version (e.g. a computer or TV object 

that is no longer current)
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• the object has a counterpart in the new ARCHICAD version, but due to changed parameters or functions 

(e.g. a window whose sash has been altered), the old object will not be replaced automatically

If you use the Migrate Libraries or Consolidate functions as described above, the Migration Libraries will be 

loaded automatically, together with the necessary obsolete objects, and you won’t have any missing objects. 

Note: You will only be able to access only those obsolete objects from the Migration Libraries that have 

already been placed in your project.

Replace Obsolete Object with Latest Library Part

If you are using an obsolete object (e.g. window from an earlier version) and wish to replace it manually with 

the newest corresponding library part, be aware that the new window will not be exactly the same as the older 

one (otherwise, it would have been replaced automatically): something will work differently.

Therefore, when you do replace the old window with the new one, you should reset the new window’s 

parameters as needed. 

To expedite this, use Parameter Transfer: this way, you will pick up the old window’s parameters and inject 

them into the new window before placing it. This still won’t produce an exact replica, but everything that can 

be replicated will be, and this will save you manual work.

1. Use the Pick up Parameters shortcut (Alt+click) to pick up the parameters of the placed object.

2. Select the old window in the project.

3. Open the Window Settings dialog box.

4. In Window Settings, navigate to the new library folder and the corresponding new window that you want to 

use.
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5. Move your cursor to the new replacement window- and press Ctrl+Alt (Mac: Cmd+Opt). The cursor will 

change to a syringe shape.

6. Now click on the new window object to inject the parameters. All transferable parameters of your old 

window will be transferred to the newly activated window.

7. Click OK to close Window Settings and to replace the old window with the new one, using the changed 

parameters.

These modifications to the new window are in effect only until you close the dialog box and place the window; 

the new window’s default settings will not change.
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Migrating a Teamwork Project (v. 13-23) to ARCHICAD 24

To migrate a Teamwork Project from any ARCHICAD version from 13-23 to ARCHICAD 24, you will need:

1. Both ARCHICAD 13-23 and ARCHICAD 24 installed on your client machine.

2. Access to BIMcloud/BIM Server version 13-23 and BIMcloud version 24, either on the same or on different 

machines.

Important: Keep in mind that if you link a hotlinked module or a drawing from a Teamwork project, that 

source Teamwork project must have the same version number as the host project. This means that if you 

migrate a project (either solo or Teamwork) from ARCHICAD 13-23 to ARCHICAD 24, any Teamwork files 

that are linked to it (via hotlinked modules or drawings) must also be migrated.

The migration process entails two phases:

• Prepare Project for Migration (you do this in ARCHICAD 13-23); and 

• Migrate Prepared Project (you do this in ARCHICAD 24).

Prepare Project for Migration

1. Start ARCHICAD 13-23.

2. Open your ARCHICAD 13-23 Teamwork project.

3. Make sure that all other users send in their changes and leave the project. (If they do not, they will lose 

any unsent changes.)

4. Issue the Prepare for Migration command at Teamwork > Project > Migrate Project > Prepare for 

Migration.

5. The Migrate Project dialog appears. Click Prepare.

6. The project is prepared for migration.

7. You now have two choices:

• If you do not want to prepare any more projects now, choose Finish Preparation from the next dialog 

box, then Close.
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• To migrate another project, choose Open and Prepare another Project.

This is the recommended choice if you have several Teamwork projects to migrate. This way, you prepare 

all of them in ARCHICAD 13-23 before changing to ARCHICAD 24 and completing their migration there.

8. Once you have prepared all the projects you need, move on to the next phase:

Migrate Prepared Project

1. Start ARCHICAD 24.

2. Choose Teamwork > Project > Migrate Project > Migrate Prepared Projects.

3. The dialog box lists all the prepared projects: select one to migrate it.

• If the listed project is shown in gray, it means you cannot complete that project’s migration now - for 

example, because the server is offline.

• If you have not prepared any projects, you are prompted to do so.

Optionally, check the Migrate ARCHICAD Libraries box: this will replace the project’s currently used 

ARCHICAD libraries with ARCHICAD Library 24, plus the necessary migration libraries. (These libraries 

will be uploaded to the BIMcloud if they are not there already.) If you do not check this box, you will 

continue using the migrated project with its current ARCHICAD libraries.

4. Click Next.
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5. In the upcoming dialog box, choose a destination server for the project. 

Note: If you are uploading to a BIMcloud: you have an additional option to define the Host Server for the 

migrated project.

You must be logged on to this server, and you must have the correct permissions to add a project to the 

BIMcloud.

If there is a problem with the server connection, you will get feedback on the issue. Click Network 

Diagnostic to open a dialog box with details and help in solving the problem. (See Network Diagnostic 

Information (BIMcloud).)

6. The project content will be uploaded to the chosen BIMcloud. Users and their roles on this project will be 

unchanged.

Note: The Project Log, Comments, messages and any reservations will be deleted during project 

migration.

7. Now that the original project is migrated, you can manually delete it from the old BIM Server.

8. At this point, you can continue in one of three ways:

– Migrate another project

– Join the migrated project

– Leave the migration process

9. If the migrated project contains any hotlinked modules or drawings linked from AC 13-23 Teamwork 

projects, you must also migrate each of those Teamwork projects from ARCHICAD 13-23 to 

ARCHICAD 24, following the steps above.

• If those hotlink/drawing source projects were on the same Server as the migrated host project, then the 

host project will automatically locate and link the source projects, once they are all migrated.

• If those hotlink/drawing source projects were on a different Server than the migrated host project, you 

must re-link the hotlinked modules and drawings manually, once the source projects are all migrated.
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Migrating from Older Versions (ARCHICAD 8.1 through 17)

If you are migrating from ARCHICAD version 17 or earlier, the following additional issues can be relevant. 

Click on the issue to read more.

For additional migration topics, see Migrating to ARCHICAD 24.

Migration Topics

(click topic for info)

Migrating from Version

17 16 15 14 13 12 11 10 8.1/9

Migration of Rendering/Surface Settings to 

Cineware

+ + + + + + + + +

Migration of Lights and Lamp Settings + + + + + + + + +

Images from QuickTime Formats + + + + + + + + +

Element Display in Interior Elevations + + + + + + + + +

Building Materials: Collision Detection 

Setting

+ + + + + + + + +

Building Materials: Attribute Migration 

Issues

+ + + + + + + +

Migrating EcoDesigner or Energy 

Evaluation Data

+ + + + +

Priority-Based Element Intersections + + + + + + + +

Display of Transparent Elements + + + + + + + +

Walls, Zones, Columns: Toplink Option + + + + + + + +

Core-Based Reference Plane for Slab + + + + + + + +

Core-Based Wall Reference Line + + + + + + + +

Changed Renovation Features + + + + + +

Migrating Roofs and Skylights + + + + + +

VR Scenes and VR Objects No Longer 

Supported

+ + + + + +

Migration of Exported Options Files (.xml, 

.aat, .prf)

+ + + + +

Find & Select Criteria Sets + + + +

Open Older (pre-13) Teamwork Files in 

ARCHICAD 24

+ + + +

Migrating Libraries and Objects from 

ARCHICAD 12 and Earlier

+ + + +

“Automatic” Home Story Setting Eliminated + + +

Doors and Windows in Partial Structure 

Display

+ + +

Lost IFC Data + + +

Section/Elevation Marker Display + + +
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DXF/DWG Translator Changes in 

Converting ARCHICAD Fills

+ + +

Migrate Projects Containing Hotlinks + + +

Migrating PlotMaker Layout Books to 

ARCHICAD 24

+

Migration Topics

(click topic for info)

Migrating from Version

17 16 15 14 13 12 11 10 8.1/9
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Migration of Rendering/Surface Settings to Cineware

Migrate from ARCHICAD 17 and earlier.

The Lightworks Rendering engine is no longer available. Instead, the Cineware engine, which is based on 

Maxon Cinema 4D R21 and incorporates most of its parameters, is integrated in ARCHICAD.

If you open an older-version project and wish to use the Cineware engine:

Photorendering Settings

You can save Photorendering Settings as part of 3D views in earlier-version projects. Apart from the size 

parameters, Photorendering Settings for Lightworks are not transferred to the Cineware engine. For such 

views, a default rendering scene is provided.

Photorendering settings for Basic and Sketch engines, however, are retained. If you open such a 3D view in 

ARCHICAD:

• in the 3D only panel of View Settings, the Rendering Scene is set to “Custom” 

• in Photorendering Settings, the scene is also set to “Custom”, whose settings correspond to those saved 

with the current view. Note, however, that one Custom scene at a time is possible in the “Select and 

Manage Scenes” dialog box in ARCHICAD, so you should rename these custom scenes if you want to re-

use them.

Photorendering Size settings from earlier-version 3D views are always retained in these Custom scenes.

Note on Predefined Rendering Scenes in ARCHICAD

To help you get the full benefit of new features, the ARCHICAD template for each language version includes 

several dozen predefined Rendering scenes, with parameters configured for specific rendering scenarios.

If you are using your own company template instead of the ARCHICAD template, you will not access these 

scenes by default. To use these scenes with your own template, do the following: 

1. Open the template file

2. In PhotoRendering Settings, go to the Select and Manage Scenes dialog box
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3. Select any or all of the predefined rendering scenes or folders

4. Click Export to save them to a location on your computer. (File extension: renderingscene)

5. Open your own project/template.

6. In the Select and Manage Scenes dialog box, click Import to bring in the scenes.

Surface Settings

• Surface Settings configured for the Basic (Open GL) rendering engine are compatible: they will be applied 

to their Surface counterpart in Cineware

• When you open an older-version project in ARCHICAD, the program will automatically generate your 

Internal (OpenGL) Surface settings in Cineware: your older renderings will, by default, look similar to the 

model in the 3D window

• Surface Settings configured for Lightworks will not be converted to Surface Settings for Cineware

Recommended Workflow for Migrating Surfaces to Cineware:

Use this workflow if you have an existing template file, and you want to upgrade your surfaces to take 

advantage of Cineware’s more sophisticated surface parameters.

1. In ARCHICAD, go to the Surfaces dialog box.

2. Select an existing Surface that you want to upgrade.

3. In Surfaces, click New.

4. In the New Surface dialog box, choose Replace Settings from Catalog.

5. Search the built-in Surface catalog or the BIM Components portal for a surface that is most similar to your 

existing surface, and click OK.

6. The newly selected surface settings replace the previous surface settings (for the currently selected 

surface only).

Notes:

– The original surface’s Name and Index number (as listed in Attribute Manager) will remain unchanged 

even after the settings have been overridden.

– Although surfaces can include a vectorial hatch (used to display surfaces in certain ARCHICAD 

views), this Replace Settings function will not overwrite the vectorial hatch (if any) of your original 

surface; that vectorial hatch remains unchanged in the project (and continues to be listed as before in 

Attribute Manager).
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Migration of Lights and Lamp Settings

Migrate from ARCHICAD 17 and earlier.

ARCHICAD includes many new and updated Lamp objects (including light sources) for better illumination of 

your project and more realistic renderings.

The Lightworks Rendering engine is no longer available in ARCHICAD. Instead, the Cineware engine, which 

incorporates most of the parameters of the Cinema4D renderer, is integrated in ARCHICAD.

When you open an older-version project in ARCHICAD, you will see that your general lights, interior and 

street lamps are compatible: their geometry and position, and their color and intensity parameters, remain 

unchanged.

• Lights that were configured for the Basic Rendering Engine have retained their parameters.

• Lights that were configured for the Lightworks Engine are, to the extent possible, compatible: their 

parameters are converted into their equivalents for the Cineware Engine.

• The Lightworks Sun Object is replaced by the Sun Object. 

• The Lightworks Window Light and Sky objects are not migrated. If your older-version project contains 

these objects, they will be missing after you migrate the project. The solution is to load the older-version 

Lightworks Library which contained these objects, or to replace them in ARCHICAD using the Physical 

Sky (Environment setting, including a sun) and the new Window Light object.

Recommendations

• Due to the compatible migration noted above, a project migrated from an earlier version of ARCHICAD will 

have lamp effects that closely approximate their appearance in the earlier version. However, since the 

Cineware engine is fundamentally different than Basic and Lightworks engines, you should do a quick test 

render of your scene before generating the full rendering output.

• Due to the Global Illumination capability of the Cineware engine, you may find that the project is better-lit 

than in the old version, and you can remove or change the parameters of some of your light/lamp objects.
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Images from QuickTime Formats

Migrate from ARCHICAD 17 and earlier.

Image files saved in QuickTime formats are no longer supported in ARCHICAD 24, to ensure compatibility for 

image files on both Windows and Mac.

Supported image formats are: JPEG, PNG, GIF, TIFF and BMP. You can save and place image files only to/

from these formats.

If you migrate an older-format ARCHICAD project that contains figures or drawings in a different file format 

than these:

1. Figures and embedded drawings, in projects opened from ARCHICAD 15-17: these images are 

converted automatically into a supported image file format (e.g. png); no action is needed.

2. Figures and embedded drawings, in projects opened from ARCHICAD 14 or earlier: these images 

are not converted. You must open the project in ARCHICAD 15-17, re-save it to convert the images, then 

open the project in ARCHICAD 24.

3. Linked drawings: you must convert the files and re-link them.

Any linked drawings that are in QuickTime based formats must be converted to other file formats. If you 

have such linked drawings in your migrated project, a warning appears when you open the project in 

ARCHICAD 24. 

The drawing content is not visible; their place in the project is an empty white box. The icons of these 

drawings are shown in red in Drawing Manager. 

You must manually convert these files to a supported file format (e.g. PNG or JPG), then re-link them.

4. Image Files in the Embedded Library:

Any image files that are in unsupported formats are shown with the “unsupported file format” icon in the 

Library Manager. You should open and resave these files to a supported file format, and then Add these 

files to the Embedded Library.

If these image files are used in the project (e.g. in a Surface or Image Fill), then they are also listed in the 

Unsupported Objects folder of the Library Manager.

Recommendation

It is recommended to convert your QuickTime-format image files to either PNG or JPG format.

• If you convert a drawing to PNG format, you will not lose any data.

• If you convert a drawing to JPG, you will lose some data during the file compression process, but the file 

size will be smaller.
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Element Display in Interior Elevations

Migrate from ARCHICAD 17 and earlier.

Interior Elevations from older-version projects will be migrated to ensure that they contain the same elements 

as before.

That is: the content of the Interior Elevation depends on whether element bounding boxes fall within the range 

(as determined by IE Markers). This is how Interior Elevations worked in earlier versions.

Any newly placed Interior Elevations will display elements according to the new logic: if you use the Limited 

horizontal range, elements are shown which fall within the limit. If you use Infinite horizontal range, the entire 

model space within the Marker’s range is displayed (as in the case of Section or Elevation views).
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Building Materials: Collision Detection Setting

Migrate from ARCHICAD 17 and earlier.

The Building Materials dialog box has a “Participates in Collision Detection” checkbox in the Properties panel. 

This is useful for defining whether particular building components - parts of composite or complex elements - 

should be exported in IFC, and/or whether they should participate in collision detection.

See Collision Detection.

All Building Materials are migrated with the checkbox ON. (In other words, all migrated Building Materials are 

set to participate in Collision Detection by default.) To exempt any Building Material, uncheck its box in the 

Building Materials dialog box.
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Building Materials: Attribute Migration Issues

Migrate from ARCHICAD 16 and earlier.

Building Material: The New “Super-Attribute”

Starting with ARCHICAD 17, all construction elements use Building Materials instead of Cut Fills.

Editing the Building Material attribute makes changes throughout the model.

Building Materials Are Generated and Assigned Automatically

When opening an earlier-version (pre-ARCHICAD 17) file in ARCHICAD 24, the program automatically 

creates the required Building Materials and assigns them to all elements to maintain the model’s original 

graphical appearance in all model views. 

The migration algorithm searches through all of the project’s model elements, defaults, favorites, unused 

composites/profiles, etc., with their Priorities, Cut Fill, Fill Orientation, Surfaces and Pen settings. 

Where the settings are identical, a new Building Material is generated. (Variations in Cut Fill Pen and Surfaces 

are handled as element-level overrides, to minimize the number of newly created attributes.)

The names of the new Building Materials are generated from the original Cut Fill’s name and will be extended 

with a unique nine-digit identifier (explained below at: Working with Hotlinks: What Happens to the Attributes). 

This automatic generation is the best that can be created via the model analysis process when opening older 

files in ARCHICAD 24. This process results in a true representation of the settings used within the project, 

because it checks all elements in the model and creates all the necessary Building Materials. However, since 

the Building Material introduces a new logic into ARCHICAD, the generated set of attributes should be 

reviewed and finalized by the user.

See What to Do About Attributes in a Migrated Project.

New Composites and Profiles Are Generated

Some element-level settings (including Cut Line, Cut Line Pen, Separator Line, Separator Line Pen and 

Enable Skin Priorities) that were previously available for Composite and Profiled Elements are no longer 

available at the element level in ARCHICAD 24. For Profile and Composite elements, these settings are 

defined in their structures.

Thus, if a composite/profile element used the element-level settings in the older-version file (its “Apply 

Structure’s Settings” option was unchecked), a new Composite or Profile will be generated in ARCHICAD 24.

What to Do About Attributes in a Migrated Project

It is recommended that you spend the time to go through your attribute set manually, to ensure you keep what 

you need and discard what you don’t.

Before Migration

1. Make a Backup

Make a backup copy of your project. If you later inadvertently delete attributes, you can use Attribute 

Manager and append them again from the backup copy.

2. Remove Unnecessary Attributes

• Use the tab pages of the Attribute Manager to view the lists of each attribute type and delete the ones you 

do not use and will not need. Go through each attribute type (each tab page) one by one.
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• For each attribute type, delete each unneeded attribute one by one (select it in Attribute Manager, then 

click Delete). 

• If you are not sure about a particular attribute, you can rename it (e.g. append the tag _delete to its name), 

then review the project to see if it is in fact being used.

• Do not use the Purge Unused command unless you are confident that your project is not using any of the 

attributes to be purged. 

– If any of your element defaults or Favorites uses a particular attribute, but has not been placed in the 

project, the Purge command will delete that attribute as “unused”. 

– The Purge command will delete attributes that are used in GDL scripts of Library Parts.

If you are migrating multiple projects:

If you are migrating multiple similar project files to ARCHICAD 24, the Replace Attributes by File function 

can help you speed up the migration process: it automates the Delete and Replace attributes function, instead 

of you having to issue repetitive “Delete and Replace” commands in each attribute settings dialog. This 

requires generation of a text file in a particular format, and running a command that calls this file.

See a description of this process at Attribute Migration article on Help Center.

3. Review Element Defaults and Favorites

When you migrate a project to ARCHICAD 24, Default and Favorite element settings will potentially 

generate new attributes when migrating. Before migrating, make sure your defaults/favorites are 

necessary and up to date, based on elements that are actually used in the Project. (ARCHICAD 24 will 

generate new attributes to correspond to defaults or favorites, even if they are not actually used in placed 

elements).

After Migration

1. Remove Unnecessary Attributes (Again)

• Review the Building Materials in Building Material Settings to determine which can be deleted and 

replaced with another.

• If you need Building Materials that are not part of the generated set, you can easily add them from another 

ARCHICAD 24 project via Attribute Manager or directly create them (click New) within Building Material 

Settings.

• Eliminate Duplicate Cut Fills: Many older-version projects contain multiple Cut Fills that use identical cut 

fill patterns; these duplicates were necessary to differentiate them by their other properties (e.g. Physical 

Properties). In ARCHICAD 24, a single Cut Fill pattern can be associated to many Building Materials: 

check your list of Cut Fills to eliminate unnecessary duplicates. 

See below for Workflow Tips for Reducing Generated Attributes.

2. Review and Modify Names of Building Materials

Review and modify Building Material names as needed (a Building Material will inherit its name from the Cut 

Fill). 

Note: It is recommended that you do not change Building Material names in files that are to be used as or 

with hotlinks, until all of the participating files have been migrated. Such name changes should be made 

before the hotlinks are updated. 

See Recommendations for Hotlinked Files.

3. Review Intersection Priorities
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Some generated Building Materials may have an Intersection Priority of 0 (most likely from those imported 

elements, like Columns and Slabs, that had no intersection priority in earlier versions, as well as profiles 

imported with a default Intersection Priority of 0). Review these and assign Intersection Priorities as needed.

Workflow Tips for Reducing Generated Attributes 

• Use the new Delete and Replace feature (available after clicking Delete) within Attribute Settings: define 

which attribute should replace it throughout your model (available for Building Materials, Lines, Fills, 

Composites, Profiles, Surfaces, Zone Categories)

• Use Find & Select to search for model elements with certain Attributes within the Project (it is recommend 

to use the 3D window, and to turn on and unlock all layers, and adjust the Filter Elements in 3D settings, to 

make sure all 3D elements are visible and will be found)

• Use the Interactive Schedule to find and list elements within the Project to easily modify them directly, 

using the Interactive Schedule environment. 

Working with Hotlinks: What Happens to the Attributes 

When you add or update a hotlinked file, if the attribute sets do not match, ARCHICAD automatically manages 

them as follows:

Attributes from the hotlinked file (module .MOD or native ARCHICAD .PLN files) are associated to attributes in 

the host file, via their name within the same attribute type. For example:

• If the same name exists - “Attribute A” in the hotlink will link to “Attribute A” in the host.

• If the same name doesn’t exist - “Attribute A” in the hotlink will create a new “Attribute A” in the host.

• If “Attribute A” is renamed to “Attribute B” in the host, and the hotlink file is updated, a new “Attribute A” will 

be created (see point 2)

When migrating hotlinked files, the same ‘use attribute name’ logic described above still applies to maintain 

an accurate model appearance.

As described above, in ARCHICAD 24, Building Material attributes generated from a migrated project will use 

the Cut Fill name and a unique nine-digit number. This identifier represents the contents and settings of the 

generated Building Material; therefore, attributes with the same unique number have identical settings. If you 

change Building Material names (including the ID number), such attributes will not be paired with their 

identical counterparts in hotlinked files, so new attributes will be created after the hotlink is updated.

Recommendations for Hotlinked Files

When working with hotlinked files in a Project, it is best to use the same set of attributes in both the host and 

hotlinked files.

• It is best to migrate all hotlinked files to the same version to maintain consistency between files.

• If you are migrating both the host and hotlinked files to ARCHICAD 24: 

– First consolidate and update attributes in the host

– then do the same with all hotlinked files before updating any hotlinks - otherwise an update may cause 

unnecessary attributes to be generated

• It is recommended that you do not change Building Material names in files that are to be used as or with 

hotlinks, until all of the participating files have been migrated. Such name changes should be made before 

the hotlinks are updated.

• If you do change Building Material names, make sure you do so consistently in all linked files
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In some instances, you may not want to migrate hotlinks to ARCHICAD 24 (perhaps they are still being used 

in older-version ARCHICAD version files). Due to automatic attribute generation and naming, again: it is 

recommended that you do not rename the Building Materials generated from these hotlinked files in the 

ARCHICAD 24 host. If you do rename them, this will cause new attributes to be generated the next time these 

older-version hotlink files are updated in the host.

Alternatively, after updating the Host, Module files (.mod) can be exported from within the Host file, using the 

Hotlink Module Manager: select the module and click “Save to File”. This will generate a new Module file 

based on the cleaned up attributes from the Host. This can save you from cleaning up all the Modules 

individually and separately. However, if this Module is used in other files, then they will then need to be 

relinked to this updated Module.
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Migrating EcoDesigner or Energy Evaluation Data

Migrate from ARCHICAD versions 12-16.

Migrating Data From Energy Evaluation in ARCHICAD 24

All of the data are retained accurately in Energy Evaluation for ARCHICAD 24.

Migrating Data from EcoDesigner Add-On

If you used the EcoDesigner add-on with an older-version ARCHICAD project (ARCHICAD 15), some 

EcoDesigner-specific settings were saved with that project.

If you open that project in ARCHICAD 24 and start the Energy Evaluation function, you will find that some of 

your settings are retained, if the same options are also available in Energy Evaluation:

• Climate and Location settings are replicated in Energy Evaluation

• Thermal properties, defined in EcoDesigner in the old Model Review palette, are retained in Energy 

Evaluation (available in the Physical Properties panel of the Building Materials dialog box)

• EcoDesigner’s factory-default “Activities” profiles are interpreted in Energy Evaluation as Operation Profile 

attributes (user-defined Activities profiles are not converted into Operation Profiles)

Zone-Based Model Analysis in Energy Evaluation

Energy Evaluation’s model analysis, which uses zones to create “space boundaries,” is fundamentally 

different from EcoDesigner, which was element-based. Consequently, your Structures and Openings lists in 

Energy Evaluation will likely be different (and more accurate) than when using EcoDesigner, depending on 

how you modeled the building.

Important: When migrating a project to ARCHICAD 24, the correct Energy Evaluation result greatly 

depends on the accurate use of zones throughout the model. Review and correct your zones as 

necessary before defining the thermal blocks in ARCHICAD 24’s Energy Evaluation.
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Priority-Based Element Intersections

Migrate from ARCHICAD 16 and earlier.

As of ARCHICAD 17, a greatly improved Intersection method allows the intersection priority within the 

Building Material to work among all construction elements - including single-skin, Composite and Profiled 

elements. 

Migration Default: Your Intersections Are Preserved in “Legacy Mode”

When migrating from ARCHICAD 16 or earlier: the Legacy checkbox for element intersections is turned on by 

default to maintain the appearance of your model.

• You will not see any changes in your element intersections

• Some new features from subsequent ARCHICAD releases are not available

Note: When you create a new file from the template, this legacy checkbox is off by default and the new 

intersections method is enabled.

Legacy Mode is controlled in Options > Project Preferences > Legacy.

See Legacy Preferences.

How to Enable New Intersections in ARCHICAD 24 (Turn off Legacy Mode)

The new Intersection method can be enabled by turning off the “legacy intersection method” found under 

Project Preferences > Legacy.

After this legacy checkbox is turned off, your models’ intersections may appear different. It is advised to 

review the model, make necessary amendments to the model geometry and also check for previous 

workarounds that may no longer be necessary (for example 2D patching or SEO). 
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Existing intersections that do not involve geometric element collision will not clean up automatically. If you 

want automatic intersections to take effect for these, a number of features can assist you in achieving 

collisions, thereby allowing the automatic intersection logic to take effect. 

See Tips for Better Intersections in Migrated Projects.

Any newly placed elements whose collisions are modeled using the new modeling methods will clean up 

according to the new logic. 

Tips for Better Intersections in Migrated Projects

If you have migrated your project to ARCHICAD 24 and wish to use the new Intersections logic on your older-

version model, see the following section for techniques and features to optimize your model intersections.

See How to Make Sure Elements Collide for Best Cleanup Results.

For more information, see also Element Intersections.
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Display of Transparent Elements

Migrate from ARCHICAD 16 and earlier.

• Transparent elements in Sections/3DD/3D may appear different after migration to ARCHICAD 24. 

Surfaces set to 100% transparency are now displayed as clear, rather than showing the surface color 

(provided that “Transparency” is ON in Section/3DD/3D Settings).

• 3D views may appear different after migration to ARCHICAD 24: if you have composite elements with 

semi-transparent skins, neighboring skins are now visible.
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Walls, Zones, Columns: Toplink Option

Migrate from ARCHICAD 16 and earlier.

In ARCHICAD 24, Walls, Zones and Columns can be toplinked to a particular story in the project. This means 

their height can vary as story heights change. Alternatively, they can be set as “Not linked”, so their height is 

fixed.

Walls, Zones and Columns migrated to ARCHICAD 24 from earlier-version projects will all be “Not linked”.
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Core-Based Reference Plane for Slab

Migrate from ARCHICAD 16 and earlier.

An option allows you to define a Slab core (top or bottom) as its reference plane, or the Slab top or bottom.

Reference planes of Slabs migrated to ARCHICAD 24 from earlier-version projects will all have a Reference 

plane at the top of the Slab by default.
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Core-Based Wall Reference Line

Migrate from ARCHICAD 16 and earlier.

To support more consistent element positioning and intersection logic, Wall Reference Line options have been 

renamed and expanded. Instead of Left, Right and Center, they are known as Outside Face, Center and 

Inside Face. (New core-based reference line options are also available; these include Core Outside/Center/

Inside). 

The “flip” status means that a selected Wall is flipped (or mirrored) along its reference line. The reference line 

stays in place, but the body of the Wall flips to the other side.

When you migrate to ARCHICAD 24, Wall Reference lines will be redefined as follows:

AC16 Left = Flip on + Outside Face 

AC16 Left + Positive Offset = Flip on + Outside Face + Positive Offset 

AC16 Center = Flip off + Center 

AC16 Center mirrored = Flip on + Center 

AC16 Right = Flip off + Outside Face 

AC16 Right + Positive Offset = Flip off + Outside Face + Positive Offset 
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Changed Renovation Features

Migrate from ARCHICAD 14 and earlier.

The Renovation feature (available since ARCHICAD 15) enables you to set a Renovation Status for each 

element, plus project-level Renovation Filters that show or hide elements by status.

Migrating Older-Version Renovation Projects

Older versions of ARCHICAD (pre-15) did not include a Renovation feature as such. If your older-version 

project used a layer system to differentiate elements in the renovation process, but you want to use the 

Renovation function in ARCHICAD 24 instead, you should:

1. Make needed changes to the model: e.g. eliminate the unnecessary, renovation-specific layers and model 

duplicates

2. Use the new ARCHICAD Renovation feature to define the Renovation Status for each element as needed

Note: When you first open a project ARCHICAD 24, all elements’ Renovation Statuses are set to 

“existing” by default, and the default Renovation Filter is set so that all existing elements are shown. Thus, 

even if you do not use any of the Renovation functions in ARCHICAD 24, all your elements will behave 

and be displayed as usual.

Changed “Demolition” Options for Door/Window Objects (GERMAN or NORWEGIAN library 

only) (ARCHICAD 14 or Earlier)

Your project from ARCHICAD 14 or earlier may use Door/Window objects that you flagged for demolition. (For 

example, doors/windows to be demolished are marked on the Floor Plan with an “X”, or are otherwise 

distinguished.)

However, since ARCHICAD 24 provides dedicated options for displaying all elements by their Renovation 

status, these “demolition” options in Door/Window Settings are no longer necessary in the AC 24 Library and 

have been eliminated.

After migrating your project to ARCHICAD 24, you should use the Renovation feature to select and assign a 

“To Be Demolished” Renovation status to the doors/windows in question.

Note that you can then choose to display your “To Be Demolished” elements the same way as in earlier 

ARCHICAD, by choosing the Override Styles that correspond to your local standards.
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Migrating Roofs and Skylights

Migrate from ARCHICAD 14 and earlier.

Roofs

Single-plane Roofs

All Roofs, including dome and vaulted Roofs, will be turned into a set of Single-plane Roofs in ARCHICAD 24. 

In outward appearance, your Roofs will not change.

Display Preference for Single-plane Roof/Skylight

By default, all newly placed Roofs and Skylights in ARCHICAD 24 will be displayed on the Floor Plan showing 

all visible contours, as if projected from a 3D view (True 3D Projection).

If you prefer to display Single-plane Roofs (and any Skylights they contain) in ARCHICAD 24 as they were in 

ARCHICAD 14 and earlier - that is, their top surface only (Symbolic) - you can switch this as a Project 

Preference: go to Options > Project Preferences > Legacy. Under Legacy Options, choose “Use Symbolic 

Display in Floor Plan for Single-plane Roofs and their Skylights”, as your preferred display mode.

Click the Info button at right for an illustration of the difference in displays.

Skylights

Skylights Placed using the Skylight Tool

If you migrate an older-version project containing Skylights placed with the Skylight tool, they will be 

automatically converted into ARCHICAD 24 Skylights, with all their parameters preserved, and capable of all 

Skylight functionality that is available in ARCHICAD 24. However, their display on the Floor Plan will, by 
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default, remain “symbolic,” as it was in the earlier project version. In outward appearance, your Skylights will 

not change, and their Floor Plan display parameters will be retained, although these are not available for 

Skylights in ARCHICAD 24.

Skylights Placed using the Object Tool

Skylights that were placed using the Object tool will remain objects, and will lack the full functionality of 

ARCHICAD 24 Skylights.
ARCHICAD 24 Reference Guide 177



Migrating from Older Versions (ARCHICAD 8.1 through 17)
VR Scenes and VR Objects No Longer Supported

Migrate from ARCHICAD 14 and earlier.

VR Scenes and VR Objects are not supported as of ARCHICAD 15. Any VR Scenes and VR Objects in 

earlier-version projects will disappear when you migrate these projects to ARCHICAD 24.
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Migration of Exported Options Files (.xml, .aat, .prf)

Migrate from ARCHICAD 13 and earlier.

You can export many types of customized project data from ARCHICAD in XML or other special file formats, 

and then re-use these data in other projects.

These exportable data types include:

• Project Info

• Model View Options Combination

• Interactive Schedule (Scheme Settings)

• Project Index (Index Settings)

• Work Environment (Profile, Schemes)

• Attributes (.aat)

• Favorites (.prf)

• Find and Select Criteria Set (can be imported from ARCHICAD 13 or later only)

• DWG/DXF Translator

In ARCHICAD 24, you can use these customized project data files even if they were created in an older-

version project.

To ensure that the project data is transferred smoothly, it is recommended that you open the older file (e.g. the 

ARCHICAD 13 project) in ARCHICAD 24, and save its project data using ARCHICAD 24. Then import those 

data files to the ARCHICAD 24 project you are working on.

For example, if you have named and stored custom Find & Select Criteria Sets in an ARCHICAD 13 project 

and want to re-use them in an ARCHICAD 24 project, you should:

1. Open the AC 13 project in ARCHICAD 24.

2. Save the customized Criteria Sets to a file (Use the Export command from the pop-up in the Find & 

Select dialog box).

3. Open the ARCHICAD 24 project you want to work on.

4. Import the newly saved Criteria Sets (Use the Import command from the pop-up in the Find & Select 

dialog box).
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Find & Select Criteria Sets

Migrate from ARCHICAD 12 and earlier.

Find & Select criteria sets from earlier (pre-13) versions will be lost when you open the older-version projects 

in ARCHICAD 24.
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Open Older (pre-13) Teamwork Files in ARCHICAD 24

Migrate from ARCHICAD 12 and earlier.

1. Open the Teamwork project in its original, older-version ARCHICAD.

2. After all changes have been sent, all users should sign out (except the Administrator). Then save the .plp 

file.

3. In ARCHICAD 24, go to File > Open > Open.

4. In the appearing file directory dialog box, select the .plp file you saved in Step 2. Click Open.

5. Share the project to a BIMcloud (Teamwork > Share). As part of the Share process:

• Project-specific libraries from earlier ARCHICAD versions will be transformed into Embedded Libraries in 

ARCHICAD 24.

• You should upload the Linked Libraries to the BIMcloud.

See Upload a Library to BIMcloud.

Important:

• All users and workspaces will be lost! Users and roles must be created and assigned for this project on 

the BIMcloud.

• If the older Teamwork project contained Hotlinks and Drawings referring to external content, these will 

function without any problems in ARCHICAD 24.

However, if the older Teamwork project was created in ARCHICAD 11 or earlier, these Hotlinks and linked 

Drawings cannot be updated from their original sources.

In this case, follow the migration procedure described here: Migrate Projects Containing Hotlinks.

• If the older Teamwork project is the source project of Hotlinks and Drawings placed into other projects, 

then those links will be broken when the older Teamwork project is opened in ARCHICAD 24. Thus, these 

hotlinks and drawings must be relinked manually to the host project. (In the host projects, use the relink 

commands in the Hotlink Module Manager and Drawing Manager.)
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Migrating Libraries and Objects from ARCHICAD 12 and Earlier

Migrate from ARCHICAD 12 and earlier.

Note the following, additional Library-related changes when migrating projects from ARCHICAD 12 and 

earlier:

• Active Libraries - Linked Libraries

The active libraries of older-version projects will be loaded in ARCHICAD 24 as linked libraries. (They will be 

listed in the Linked Libraries folder of the Library Manager.)

• Other Objects - Embedded Objects

“Other Objects” items in the older ARCHICAD projects will appear in the “Embedded Objects” folder of 

ARCHICAD 24.

• Other Objects in Hotlinked Modules

If you place a hotlinked module from ARCHICAD 12, any objects placed from the source file’s “Other Objects” 

folder will be missing in ARCHICAD 24. The solution is to embed these objects in your host ARCHICAD 24 

project, using Library Manager, or to place those objects in a library on the BIMcloud, and add that library to 

the project.

• Missing Libraries - Unavailable Libraries

Any library “missing” in the Library Manager of the older version will be listed as “unavailable” in the Library 

Manager of ARCHICAD 24. Locate these libraries and add them as linked libraries, using the Library 

Manager’s “Add” command.

• Missing Objects

Missing objects in the older-version project are also listed as “missing” in the Library Manager. To solve the 

problem, locate the source files of these missing objects and add them to the project, using the Add command 

in Library Manager.

• Unsupported Objects

These files reference unsupported image formats.

See Image Files in the Embedded Library at Images from QuickTime Formats.

For more information on Library Migration, see:

Migrating Libraries to ARCHICAD 24.

At any time, to view information about possible Library-related issues in your current project, check the 

Libraries item in the Action Center (File > Info > Action Center).
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“Automatic” Home Story Setting Eliminated

Migrate from ARCHICAD 10-13.

There is no Automatic Home Story setting in ARCHICAD 24. Elements from older projects (older than AC13) 

whose Home Story was set to Automatic will now be assigned Home Stories that correspond to the story they 

were placed on.

In ARCHICAD 24, during editing operations that affect the elements’ elevation (e.g. elevate, multiply with 

vertical displacement), you have the option to automatically re-assign those elements’ home stories 

accordingly.
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Doors and Windows in Partial Structure Display

Migrate from ARCHICAD 11 and earlier.

Beginning with ARCHICAD 12, Door/Window objects have been reprogrammed to display correctly in light of 

the partial structure display feature.

Doors and Windows migrated from older-version projects (version 11 and earlier) into ARCHICAD 24 will not 

be displayed properly if you use Partial Structure Display. These Door/Window objects are incompatible for 

the purposes of Partial Structure Display.

To address the issue of incompatible library parts, see Migrating Libraries and Objects from ARCHICAD 12 

and Earlier.
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Lost IFC Data

Migrate from ARCHICAD 11 and earlier.

IFC data in ARCHICAD projects in versions 8.1 through 11 will be lost when you migrate the projects to 

ARCHICAD 24.
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Section/Elevation Marker Display

Migrate from ARCHICAD 11 and earlier.

The appearance of each individual Section and Elevation Marker is set in its own Tool Settings Dialog Box. 

(Place Marker at either or both ends of the S/E line, or place one Marker in the middle.)

The Section/Elevation Marker display option is no longer a Model View Option: any S/E Marker’s appearance 

will be uniform throughout the project, regardless of which view it is saved in.

When migrating an older-version file in which you used any Section/Elevation Marker Model View Option 

other than “As in Settings,” you should adjust individual Markers as needed.
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DXF/DWG Translator Changes in Converting ARCHICAD Fills

Migrate from ARCHICAD 11 and earlier.

When saving an ARCHICAD 24 file to AutoCAD-compatible format, the results may vary from earlier version 

conversions (ARCHICAD 11 or earlier). You should check these converted files and make any changes 

necessary.

Possible Differences in Fill Conversion within ARCHICAD 24

• When converting ARCHICAD fills, an option in the DXF/DWG Translator enables you to manually set up a 

custom Fill Conversion table.

• Also, Fill types in ARCHICAD 24 are converted by default as follows:

– Image: converted to a solid fill (technically a background-color hatch)

– Gradient: converted to a solid fill (technically a foreground-color hatch)

– Symbol: if you chose “Export all fills as Solid”, symbol fills are converted into Blocks. If you chose 

“Export Fill Backgrounds as Additional Solid Hatches”, they are converted into Blocks plus a 

Background-color Solid fill.
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Migrate Projects Containing Hotlinks

Migrate from ARCHICAD 11 and earlier.

Legacy Hotlinks from Older-Version Source Files (ARCHICAD 11 and earlier) 

When opening a project which contains hotlink modules from source files that are ARCHICAD 11 or earlier, 

ARCHICAD will display a warning about legacy files, with instructions for how to make the modules 

updateable in the current ARCHICAD:

Note: This process is applicable when migrating older-version projects (11 or earlier) to ARCHICAD 24.

Open Hotlink Module Manager to View Hierarchy of Project’s Hotlink Sources

1. Open the project in ARCHICAD 24. 

2. Go to Hotlink Module Manager (File > External Content > Hotlink Module Manager). 

• The Hotlinked Modules list (in the top half of the dialog box) displays the hierarchy of modules hotlinked 

into the current project. 

• The Hotlink Sources list displays the sources of the hotlinked module files together with their status.
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Note: For a more comprehensive and printable display of the hotlinked source files, click Show hierarchy 

in browser from the pop-up button. 

This opens your browser in a separate window, showing the hotlinked source files in a hierarchical format, 

together with file locations that are hyperlinked.
ARCHICAD 24 Reference Guide 189



Migrating from Older Versions (ARCHICAD 8.1 through 17)
Conversion of a project with Hotlink Source files available in their original location

In this workflow, you will open the hotlinked source files one by one and save them in ARCHICAD 24.

Suppose you are working in Project A, with the modules B and C as hotlinked modules:

1. Open the project (A.pln)

2. In the warning dialog which appears, choose the “Open Hotlink Module Manager” option.

3. The Hotlink Module Manager contains a list of Source files.

4. For each Source file shown as Legacy or Missing, you must open the file in ARCHICAD 24, using the 

Open in Separate ARCHICAD button. Then save the opened file (File > Save.) 

We recommend that you save the files in this order: go through the hierarchy file by file from bottom to 

top in the hierarchy. 

Note: It is possible that the opened source files contain other hotlinks that are not used in A.pln. (for 

example, if the module is placed on a story that is not shown in A.pln, or if B.pln contains nested modules, 

yet the Hotlink Module Manager for A.pln has checked the “Skip Nested Modules” box). If these nested 

modules are in legacy format, ARCHICAD will display a warning when they are opened. In this case, you 
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should continue the conversion process, treating B.pln as a separate project that contains legacy hotlinks: 

you must save those hotlink sources in ARCHICAD 24 as described in this document - by resaving the 

files, locating missing sources, resaving nested legacy source files, etc.

5. In the Hotlink Sources section, click Refresh Status from the pop-up button. 

If you have successfully re-saved all the Legacy files from the Source list (as described in Step 4), then 

the Source list should not show any files in “Legacy” status.

6. Click Update.
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Migrating PlotMaker Layout Books to ARCHICAD 24 

Migrate from ARCHICAD 8.1/9 and PlotMaker 8.1/9.

This chapter contains detailed information about how to migrate your ARCHICAD 8.1 or ARCHICAD 9 project 

files and PlotMaker 8.1 or PlotMaker 9 Layout Books into ARCHICAD 24.

Note: In this description, version “9” should be understood as either version 8.1 or version 9.

In version 9, the Project Model is always located in a PLN file, and the layouts in an LBK (Layout Book) file. 

ARCHICAD 24 (and every ARCHICAD version from 10 up) contains both Model Views and Layouts in an 

integrated environment in a single file.

Since ARCHICAD 24 Projects can be divided among multiple ARCHICAD PLN files, there are two basic ways 

to migrate your ARCHICAD 9 Projects and PlotMaker 9 Layout Books to ARCHICAD 24:

1. Create Two Separate Files in ARCHICAD 24: The ARCHICAD 9 Project file should be placed into its 

own Project File in ARCHICAD 24 (this file would contain only Model Views, plus the default Layout 

Book), and the PlotMaker 9 Layout Book should be placed into a second, separate Project File in 

ARCHICAD 24 (this file would contain all Layouts with no Model information).

2. Create a Single File in ARCHICAD 24: If the Project is small enough, both the ARCHICAD 9 Project File 

(PLN) and the PlotMaker 9 Layout Book (LBK) can be merged into a single file in ARCHICAD 24.

The following sections outline how to carry out both options.

Option 1: Create Two Separate Files in ARCHICAD 24

1. To migrate the ARCHICAD 9 Project File, simply open the PLN file in ARCHICAD 24 and save it. Although 

there are several settings which can affect how elements are displayed on the Floor Plan, these are all 

automatically set during the conversion so that the same look is preserved in ARCHICAD as far as 

possible. Because of new settings in ARCHICAD 24, it is possible that some elements will look slightly 

different than they did in ARCHICAD 9.

For detailed information, see Converting Model Views to AC 24: Floor Plan Display Issues for a detailed list.
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2. To migrate the PlotMaker 9 Layout Book, use the File > Open command. In the Dialog, select PlotMaker 

Layout Book (*.lbk) as File Type and select the desired LBK file. Click the Open button to start opening it.

3. Since Title Types of PlotMaker 9 have become GDL Objects in ARCHICAD 24, the program will convert 

all Title Types defined in the Layout Book File into Library Objects (GSM Files). ARCHICAD will place 

these created Library Parts into its Embedded Library; they will be listed in the Library Manager.

Please note that these generated Title Types have become non-parametric GDL Objects in 

ARCHICAD 24, displaying the same information as the source Title Type in PlotMaker 9. However, if you 

used default Title Types in PlotMaker 9, you will find the counterparts of these in the ARCHICAD 24 

Library and you may change the generated Title Types into parametric ones shipped with ARCHICAD 24.
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4. When ARCHICAD is finished converting the Layout Book data, an Information Dialog will alert you to data 

that could not be converted because of essential differences between the features of ARCHICAD 24 and 

PlotMaker 9. For more detailed information, press Show Detailed Report in Browser to launch your 

default web browser containing a fuller explanation of what could not be converted and why, plus what you 

can do about it.

For example, in PlotMaker 9, you could define custom line weights for each individual drawing element (e.g. 

Lines, Fills, etc.). In ARCHICAD 24, you can define line weights only for Pens, and all elements using a 

certain Pen will be drawn using the line weight defined for that Pen. Because of this difference, specific line 

weights defined in PlotMaker 9 will be converted back to their line weights as specified in the Pens & Colors 

Dialog of ARCHICAD 24.

Please see Conversion Warnings for a detailed list of conversion warnings.

5. Now your new ARCHICAD 24 Documentation Project File (a file containing only Layout Book information) 

is ready for use. One Story will be created as default, but no model data will exist in any Model Views. All 

Layouts will be displayed in the Navigator’s Layout Book.

Option 2: Create Single File in ARCHICAD 24

Use this option for relatively small projects, to merge both the Layout Book from PlotMaker and Project File 

from ARCHICAD 9 into a single project file in ARCHICAD 24.

When creating a single PLN file in ARCHICAD 24, you will merge Layout Data into a Project File. In 

ARCHICAD 24, every Project File must contain both Model Views and a Layout Book as default. This means 

that the PLN file into which Layout Book data is merged will already contain one or more Layouts, with their 

own attributes and settings. For this reason, the procedure follows the usual rules of merging, which means 

that if a particular setting already exists in the receiving file, existing data are used, and are not overwritten by 

merged data. Therefore, when merging Layout Book data into a PLN file, the following settings of the Layout 

Book are not merged:

• Book settings

• Project Info

• Grid settings
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• Default Master Layout setting

Also, Layout-specific settings in the Work Environment of ARCHICAD 24 will not be modified by data of the 

imported Layout Book.

The program will compare the names of the Attributes and Master Layouts of the merged file and the host 

ARCHICAD 24 file.

Please note that the program compares only the names (but not content or definition) when checking for 

matching Attributes/Master Layouts.

If the Attribute or Master Layout names in both files are identical, they will be considered identical by the 

program, and the existing files in ARCHICAD 24, along with their settings, will be kept.

The structure of the merged Layout Book (its Layouts, Subsets, Master Layouts and placed Drawings) is 

inserted into the existing Layout Book structure of the ARCHICAD 24 PLN file.

Follow these steps:

1. Open the PlotMaker 9 LBK file in ARCHICAD 24 and save it as an AC 24 PLN file.

2. Open the ARCHICAD 9 PLN file in ARCHICAD 24 and save it as another AC 24 PLN file.

You now have two new ARCHICAD 24 files; these two must now be merged.

3. In the latter active Project File (the one containing model data), use the File > Interoperability > Merge 

command to merge data from the other saved ARCHICAD 24 file (the one containing Layout Book data). 

In the appearing dialog box, choose Layout Book to merge Layout Book data of the file into your active 

Project File. Click the Merge button.

If you open the Organizer from the Navigator, you will see that all Layout Book data has now been merged 

into the Project File.
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Note: You should follow the route specified in this guide, that is, merge the PLN File containing Layout 

Book data into the PLN File containing Model data, and not the other way around. This is because of the 

rules of merging, and because Views and certain other data would not come through if you merged the 

Model data into the file containing Layout Book data.

In case you do not wish to merge the Layout Book in its entirety, only some of its Layouts, do the following:

1. Open the ARCHICAD 24 PLN File containing the Model data.

2. Open the ARCHICAD 24 PLN File containing the Layout Book data.

3. In the PLN file containing Model data, open the Organizer in such a way that you see the Layout Book of 

both files. In the illustration below, the PLN File containing the Model data is on the right.

4. Using drag-and-drop, move the desired Layouts from the Layout Book PLN file (on the left) into the Model 

PLN file (on the right).

If you have Drawings placed into the Layout Book PLN which point to the Model PLN as their source, then the 

Drawing references will automatically switch from external file references to internal references after the 

Layouts are merged.

Note: Such drawing links will not be redefined as internal references if the name of the source project file 

has changed since the drawings were placed. In this case, you should select all such drawings in the 

Drawing Manager and use the Link To button to re-link these Drawings to their source PLN (the renamed 

project file).
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Conversion Warnings

When you migrate a PlotMaker 9 Layout Book file, ARCHICAD 24 may warn you of some project elements 

that will not be reproduced in ARCHICAD 24, due to changed feature sets.

The following is a list of all warnings that may be displayed by the program during conversion. The warnings 

displayed always apply to the file currently being converted.

1. Printing/Plotting Publisher sets should be reviewed

Some Print/Plot Options in PlotMaker 9 have no equivalent in ARCHICAD, so these settings need 

reviewing before Printing/Plotting them.

2. Original output color of Elements drawn or pasted into Layouts has been restored

In PlotMaker 9, in the Book Settings Dialog box, output color of elements on Layouts may be set to 

grayscale or black. This option has no equivalent in ARCHICAD, so elements will appear in their original 

color.

3. Fill-related display and output options could not be converted

In PlotMaker 9 you may apply global settings to Fills. These options have no equivalent in ARCHICAD, so 

they cannot be converted. Therefore, all fills are displayed as defined in the Fill Settings Dialog Box.

4. OLE Drawings could not be converted 

ARCHICAD does not support OLE technology, so OLE drawings within the LBK file cannot be converted 

properly. (If the OLE drawing was embedded in the LBK file, with no live link to the source application, you 

will see the drawing, but you cannot update it.) You can identify OLE drawings using the Drawing Manager 

palette: look for the OLE icon in the Type column. It is recommended to replace these OLE Drawings with 

PDF files in ARCHICAD 24.

5. Edited drawing Layers are restored

In PlotMaker you could modify the show/hide status of Drawing Layers. This option does not exist in 

ARCHICAD, so these drawing Layers will be displayed according to their original show/hide status.

6. Text and Markers size changes

In PlotMaker, you could set the size of Texts and Markers to retain their original size even after the Output 

Scale was modified. (You checked the Fix Size option for Text and Markers in the Drawing Settings dialog 

box.) This option does not exist in ARCHICAD, so Text and Markers will be resized according to the scale 

change, just like any other element in the drawing.

7. Custom line weight is restored to pen line weight

In PlotMaker you could assign a custom line weight to lines, circles and splines. In this case the color of 

the line came from the assigned pen, but the weight was custom set in the element’s settings dialog box. 

This option does not exist in ARCHICAD, so the line weights of lines, circles or splines will be set to values 

specified in the Pens & Colors Dialog.

Conversion of Other Attributes/Settings

Layers, Pens, Fills: The ARCHICAD 24 PLN file will inherit the Layers of the LBK Layout Book. The 

PlotMaker Layer will be renamed to ARCHICAD Layer. Pens and Fills come through unaltered.

Autotext items: All Autotext entries are converted. The name of some of these items will change. The 

following Autotext items (located in PlotMaker 9’s Book Info Dialog) are now found in the Project Info Dialog of 

ARCHICAD 24:

• Client

• Project Name
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• Street

• City

• State/Country

• Postal Code

• Company

• Project Number

• Architect

• Draftsman (CAD Technician in ARCHICAD 24)

• Project Status

• Date of Issue

• Custom1

• Custom2

• Custom3

The following Autotext items are also converted. They are available in ARCHICAD 24 while editing a Text 

Block in either a Model View or on a Layout. Some names have changed. Some no longer apply, so these are 

converted into their closest match:

• Layout Name

• Layout Number (Layout ID in ARCHICAD 24)

• Subset Name

• Subset Number (Subset ID in ARCHICAD 24)

• Page Number (Layout Number in ARCHICAD 24)

• Number of Pages (Number of Layouts in ARCHICAD 24)

• Book Name (File Name in ARCHICAD 24)

• Book Path (File Path in ARCHICAD 24)

• Drawing Name

• Drawing Name with Extension (Drawing Name in ARCHICAD 24)

• Drawing Number (Drawing ID in ARCHICAD 24)

• Drawing Path (File Path in ARCHICAD 24)

• Drawing Scale (Original Scale in ARCHICAD 24)

• Output Scale (Drawing Scale in ARCHICAD 24)

• AC File Name (File Name in ARCHICAD 24)

• AC File Path (File Path in ARCHICAD 24)

• Last saved at

• Last saved by

• Long Date

• Short Date

• Time

Master Layout: Layout size is defined differently in ARCHICAD 24. In PlotMaker 9 and earlier versions, the 

size of the Layout means the printable area of the page (the full size of the paper minus margins on all four 

sides). In ARCHICAD 24, the size of a Layout means the full size of the paper. This change does not affect 
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either the full size of the Layout (printable area + Margins on all four sides) or the sizes of the printable area or 

any of the Margins. They will be the same as in previous versions; only the names have changed to better 

approximate real-world practice, where a Layout is the whole paper used for printing/plotting. So Master 

Layout sizes are converted accordingly. The Grid for Drawing Numbering and Master Layout default come 

through unaltered.

Layout settings: comes through unaltered.

Subset settings: comes through unaltered.

Book settings: comes through unaltered, except Output Color settings, which does not come through (no 

equivalent in ARCHICAD 24 - see Warning 2 above).

Drawing settings: all settings come through (Title is converted into GDL Object), except for Attributes 

Update Rules, which have no equivalent in ARCHICAD 24. Layer changes are not carried through (see 

Warning 5 above). If the Text and Markers option in PlotMaker has been set to Fix Size, Warning 6 above is 

displayed. If a placed Drawing had its own Pen Set, the same Pen Set will be created in ARCHICAD 24 and 

the Drawing will continue using it. The Output Scale setting will be converted into Drawing Scale.

Note: In ARCHICAD 24, Drawing Scale is the scale of the Drawing on the Layout, which will be output, 

while “Original Scale” is that of the Drawing’s source view.

If several Drawings in PlotMaker 9 used the same Pen Set, ARCHICAD 24 will create only one Pen Set for all 

the Drawings. This Pen Set will have the same name as the first converted Drawing which uses this Pen Set, 

but all the converted Drawings which used it in PlotMaker 9 will use it in ARCHICAD 24.

Grids: come through unaltered.

Project Preferences: Working Units, Mouse Constraints, Publisher preferences, Uniform Pens and Colors 

setting, Miscellaneous settings come through. (Since there is no Uniform Pens and Color settings checkbox 

in ARCHICAD 24, this means in effect that all Drawings will refer to the same Pen Set). If cache data was 

stored in the Layout File in PlotMaker 9 (the option is in Preferences > Cache Folder), the Drawings will be 

stored in the Project File in ARCHICAD 24 (see Drawings placed on Layout below). Custom line weights do 

not come through (no equivalent in ARCHICAD 24 - see Warning 7 above).

Drawings placed on Layouts: In PlotMaker 9, Project links are saved with the Layout Book File 

(Preferences > Cache Folder > Include Cache in Layout Book). By default, external links (e.g. PMK files, 

bitmap files) are not saved with the Layout Book File.

If a Drawing was saved with the Layout in PlotMaker 9 (Include all linked files checkbox of the Save as 

Dialog in PlotMaker 9 is checked), the Drawing generated from it in ARCHICAD 24 will be set to be a manual-

update Drawing, and will be saved with the ARCHICAD 24 Project File (the Store Drawing in the Project file 

checkbox will be checked in the Drawing Settings Dialog).

If a Drawing was not saved with the Layout in PlotMaker 9 (Include all linked files checkbox of the Save as 

Dialog in PlotMaker 9 is not checked), the Drawing generated from it in ARCHICAD 24 will be set to be an 

auto-update Drawing, and will not be saved with the ARCHICAD 24 Project File (the Store Drawing in the 

Project file checkbox will not be checked in the Drawing Settings Dialog).

Drawing Status

It is recommended that you perform an update of all placed Drawings after opening or merging a PlotMaker 9 

LBK file in ARCHICAD 24.

Background: The modification status checking of Drawings is significantly enhanced in ARCHICAD 24, 

compared to PlotMaker 9. In PlotMaker 9, the program monitored the last modification date of the Drawings’ 
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source files. If the last modification date of the file had changed, the program assumed that all Drawings 

coming from that file would need updating.

In contrast, ARCHICAD 24 can monitor the modification status of each Drawing with a PLN source separately.

When opening a PlotMaker 9 LBK file in ARCHICAD 24, a transitional state exists: the LBK file does not 

contain all information necessary for ARCHICAD 24 to decide the modification status of Drawings in the 

Layout Book file. (This transition state can cause Drawings with “OK” status in PlotMaker to have “Modified” 

status in ARCHICAD.) 

In this case, the status checking will be performed according to the old method (which assumes all drawings 

from a modified PLN source require updating). Only after the first update performed in ARCHICAD 24 will the 

status checking mechanism run on the drawing level instead of the file level.

Drawing Name and Drawing ID

Not all Drawing Names and Drawing IDs coming from a PlotMaker 9 LBK file will have their exact equivalent 

when opened in ARCHICAD 24. Therefore it is recommended to review Drawing Names and Drawing IDs to 

make sure everything came through correctly.

For checking Drawing Names/IDs and updating Drawings, it is highly recommended to use the Drawing 

Manager of ARCHICAD 24, which has many customizable columns listing information about Drawings.

Background: In PlotMaker 9, the Drawing Name was always the same as the name of the View from which it 

was created. In ARCHICAD 24, a View Name consists of two parts: View Name and View ID. For this reason, 

Drawing Name can be either “View Name” or “View Name + View ID” (or Custom).

In PlotMaker 9, the value of Drawing ID (which was called Drawing Number in PlotMaker 9), could come from 

the Layout or from the ARCHICAD Viewpoint, or it could be set to a custom value. In ARCHICAD 24, the 

ARCHICAD Viewpoint option is not available. Instead, the View ID value is used.

Library Objects

When merging an LBK file into ARCHICAD 24, all elements placed on Layouts, including library parts, are 

merged. However, the libraries used by the merged project are not automatically loaded into the 

ARCHICAD 24 project. Thus, if after a merge you find that any library parts (such as Drawing Titles) are 

missing, you should load any missing libraries to resolve the problem.

Converting Model Views to AC 24: Floor Plan Display Issues

ARCHICAD 24 offers more sophisticated Display Options for elements than ARCHICAD 9, but predefined 

settings will ensure that files migrated from ARCHICAD 9 will have compatible displays in ARCHICAD 24.

While display options have changed since ARCHICAD 9 (they are now called Model View Options and (for 

Fills) Graphic Override Rules), the following information should help you recreate the same display in 

ARCHICAD 24 for migrated projects.

Door/Window Display Options

In ARCHICAD 24, options for Doors and Windows are set separately in Document > Model View > Model 

View Options, Construction Element Options Panel, giving you more flexibility in displaying model views:

• If you choose the Show Entire option, but leave the with Markers checkbox unchecked, it will achieve 

the same result as the Show on Plans option in ARCHICAD 9.

• If you choose the Show Entire option, and check the with Markers checkbox, it will achieve the same 

result as the Show with Dim. option in ARCHICAD 9.
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• If you choose the Show Opening Only radio button, but leave the with Contour checkbox unchecked, it 

will achieve the same result as the Hide on Plan options in ARCHICAD 9.

• If you choose the Show Opening Only radio button, and check the with Contour checkbox, it will 

achieve the same result as the Reflected Ceiling options in ARCHICAD  9.

• The Hide on Floor Plan radio button is a new choice: it means that Doors/Windows will not be shown on 

the Floor Plan at all, just as if there were no Doors/Windows in Walls. In Section, Elevation, and Interior 

Elevation, the Door/Window hole will be visible.

Fill-Related Overrides

Set Fill-related overrides at Document > Graphic Overrides > Graphic Override Rules.

Regarding the display of Cut Fills, you will notice that there is no option to set Bitmap Patterns. A bitmap 

display is available for on-screen display only: Bitmap or Vectorial is set globally using the Vectorial Hatching 

option at View > On-Screen View Options.

Your project will be automatically migrated to use predefined Graphic Override Rules which largely replicate 

your Fill settings in ARCHICAD 9. 

To adjust these settings, note the following:

• For Fill Type, Fill Pen, Fill Background Pen: Click one or more icons to the right of the control to choose 

which category (Drafting Fill, Cover Fill, Cut Fill) should be affected by the override.

If Cut Fills are chosen for override:

• Check Show Skin Separators to achieve the same result as the Separators Only option in 

ARCHICAD 9.
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• Use Cover Fills - Solid Foreground to achieve the same result as the Solid w/o Separation Lines 

option in ARCHICAD 9.

If the Drafting Fills category is enabled:

• Use All Drafting Fills - Solid to achieve the same result as the Solid option in ARCHICAD 9.

If the Cover Fills category is enabled:

• Use All Cover Fills - Solid Foreground to replicate the Solid option in ARCHICAD 9.

To adjust Zone Fill display, review the predefined Graphic Override Rules for Zone Fills at Document > 

Graphic Overrides > Graphic Override Rules.

• All Zone Fills - Transparent: This replicates the None option in ARCHICAD 9.

• All Zone Fills - Solid Category: This replicates the Category Color option in ARCHICAD 9.

• All Zone Fills - Solid Background: This replicates the Solid Background Colored Fill option in 

ARCHICAD 9.

• All Zone Fills - Category Background: This replicates the Fill Pattern on Category option in 

ARCHICAD 9.

• All Zone Fills - No Background: This replicates the Fill Pattern Only option in ARCHICAD 9.
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Configuration

This section of the ARCHICAD Reference Guide includes information on starting the program, setting up your 

workspace, choosing preferred project settings, and defining the basic project components that you will use 

while working in your projects (templates, attributes, Favorites). It also describes how to manage libraries in 

ARCHICAD.

Start ARCHICAD

Create New Project

Open Recent Project(s)

Browse for a Project

Opening Legacy or Archive Projects: Manage Library Parts

Close Project

Save ARCHICAD Project

File Compression

ARCHICAD License Types

Sign In with GRAPHISOFT ID

Resolving Issues with Serial Numbers

Bug Reporter

Work Environment

Template Files

Backup Files

Archive Projects

ARCHICAD User Feedback - Net Promoter Score Survey

Create Support Package (Troubleshooting)

License Information

Add-Ons and Goodies

Working Units

Project Location and Project North

Project Preferences

Scale

Attributes

Libraries

Favorites
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Start ARCHICAD

1. Do one of the following:

• Double-click the ARCHICAD program icon

• Click the ARCHICAD Starter application

2. If you have a license available, the Start ARCHICAD Dialog Box appears. Use it to create, open and 

manage ARCHICAD files.

Note: If you do not have a license available, a dialog box prompts you with options for continuing. See 

ARCHICAD License Types for more information.

From Start ARCHICAD, do any of the following:

Open Recent Project(s)

Create New Project

Open or Join Teamwork Project

Sign In with GRAPHISOFT ID
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Create New Project

1. Do one of the following:

• Double-click the ARCHICAD program icon

• Click the ARCHICAD Starter application

2. From the Start ARCHICAD dialog, click New.

3. From the appearing dialog, choose a template from the list, or browse for a different template file.

See also Template Files.
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4. Choose a Work Environment Profile for the new project.

• Current Profile: Applies the profile that was in effect when you last closed ARCHICAD, including any 

unnamed Custom schemes and undefined schemes.

• Default Profile: The default one is listed with a checkbox. You can change this default at Options > Work 

Environment > Profile Options.

See Profile Options.

• Or choose any of the predefined Work Environment Profiles shown in the list. 

See Default Work Environment Profiles

5. Click New to create the new project.

Create New Project From a Running ARCHICAD

1. Use File > New > New 

2. If you already have ARCHICAD running: you can choose Latest Project Settings, rather than a template, 

for the new project.

Note: To automatically use the default project settings: press Alt (Opt) key with the New command. The 

command changes to New and Reset All.

Launch a new instance of ARCHICAD

1. From a running ARCHICAD, do one of the following:

– File > New > New

– File > Open > Open

2. From the New Project or Open Project dialog, check Launch a new instance of ARCHICAD
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Open Recent Project(s)

Do one of the following:

• From a running ARCHICAD:

– Use File > Open 

– Select a recent project from the pop-up

• From the Start ARCHICAD dialog: Select one or more recent projects (see below)

Note: To open the Start ARCHICAD dialog, do one of the following:

- Double-click the ARCHICAD program icon

- Click the ARCHICAD Starter application

- If the selected project cannot be opened the first time, check this box and try again.

Start ARCHICAD Dialog: List of Recent Projects

The Start ARCHICAD dialog lists all the ARCHICAD projects, including Teamwork and module (.MOD) files, 

that have been opened by the program.

• Click the list or tile icon to see projects in tile view or list form

• Hover over a project to see its Project Info

Note: These data are user-defined tags entered at File > Project Info.
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Recent Projects in Tile View

Recent Projects in List View

• Recovery files are in red type

Note: If you remove a Recovery file from the Recent Projects list (with the red X), it is deleted entirely, and 

you cannot retrieve it again. 

• Not Available: The project is located on an external drive or network that is not currently available
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• Remove a project from the Recent List: click Delete, Backspace, or the blue X

In List view:

• Sort by name, last used, size or file type, in ascending or descending order

• Filter projects by name, keyword, or any other Project Info data

In Tile view:

• The Preview cycles among the project’s last-opened tabs and its Project Preview picture (if any). 

Related Topics

Project Preview

Project Info

Opening Legacy or Archive Projects: Manage Library Parts
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Browse for a Project

Do one of the following:

• From a running ARCHICAD: Use File > Open > Open 

• From the Start ARCHICAD dialog, click Browse.

Note: To open the Start ARCHICAD dialog, do one of the following:

- Double-click the ARCHICAD program icon

- Click the ARCHICAD Starter application

Browse for a project, then click Open.

Open & Repair Selected File

If the selected project cannot be opened the first time, check this box and try again.
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Related Topics

Launch a new instance of ARCHICAD

Opening Legacy or Archive Projects: Manage Library Parts

File Types Opened by ARCHICAD
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Opening Legacy or Archive Projects: Manage Library Parts

In the Start ARCHICAD dialog, the Settings pop-up contains your preferences for handling Libraries and 

Library parts when opening Legacy (older-version) or Archive projects.

Note: To open the Start ARCHICAD dialog, do one of the following:

- Double-click the ARCHICAD program icon

- Click the ARCHICAD Starter application

Legacy Projects

By default, ARCHICAD will Migrate Library when necessary. 

With this setting, the migration process takes place in the background every time you open a Legacy project, 

with no user input required.

Archive Projects

Another option is available for the startup of Archive (pla) projects: Read Elements Directly from Archive.

If you check this box, library parts are read automatically, with no user input required.

If this box is not checked: each time you open an Archive file, the Open Archive dialog appears, where you 

must define how to handle the library parts.

See Open Archive Project to learn about these options.
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To view information about possible Library-related issues, check the Libraries item in the Action Center (File > 

Info > Action Center).

Related Topics

Action Center
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Close Project

From Floor Plan: File > Close closes the entire Project. 

External files (GDL Object windows, pictures) remain open until you close them separately.

Reopen Project Tabs/Windows of Closed Project

When you close a project with many tabs/windows open simultaneously, ARCHICAD will reopen these the 

next time you open the project. 

Re-opening all these tabs/windows may take time, especially if they must be rebuilt.

If the number of tabs/windows to be re-opened exceeds 20 (not including PhotoRendering windows), a 

warning dialog lets you re-open just the frontmost tab/window (plus the Floor Plan).

Related Topics

Save ARCHICAD Project

Close Teamwork Project
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Save ARCHICAD Project

Use File > Save to save your project.

Choosing File > Save as allows you to save the Project under a new name, archive it or save the current 

window’s contents in a variety of file formats. Some of the available options may depend on the set of 

currently loaded Add-Ons. Some file formats are 2D-only or 3D-only formats.

See File Types Saved by ARCHICAD.

Export to BIMcloud

Use File > Export to BIMcloud to upload the ARCHICAD Project to the BIMcloud.

Choose any of the supported file types.

To use this function, you must be logged on as a BIMcloud user.

Save from List Window

• Basic Element, Component and Zone Lists can be saved as Plain Text, Tabulated Text, HTML tables or 

PDF. Click either radio button to include the file’s Used Column only or All Columns in the file.

• Formatted lists including graphic information can be saved in.rtf (Rich Text Format), ARCHICAD Project 

format, or PDF.
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Save from Schedule Window (Interactive Schedule)

Schedules can be saved in the following formats: Tabbed text, DWF, .xls and PDF. 

From a PC, with MS Office, you can also save in .doc format.

Related Topics:

File Types Saved by ARCHICAD

File Compression

Template Files

Backup Files

Archive Projects
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File Compression

When saving certain file types from ARCHICAD (.pln, .tpl, .pla, .mod), the Options button in the Save dialog 

box presents you with the option to “Compress file.”

This option is enabled by default, and is recommended in most cases, since file compression reduces file size 

considerably (by 60-70%). Using this option also increases download speed if you are working from a slow 

network, because the files are smaller.

However, note that using the Compress file option means increased file saving time, as a consequence of 

increased calculation needs. If the saving procedure takes too long, try turning this option off.
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ARCHICAD License Types

This page explains the different types of ARCHICAD Licenses, including Demo Mode.

Commercial License

To run the commercial license of ARCHICAD in full mode, you need either a hardware key (CodeMeter) or a 

software key.

If you purchased a single copy of ARCHICAD, you received a “single license” key. If you purchased multiple 

licenses of ARCHICAD, you received a “NET” key which holds all your licenses.

Full License

With a full license, you can use the fully functional GRAPHISOFT product with unlimited usage. You will also 

be able to run older versions with some technical limitations.

For more details, see ARCHICAD Protection Key Compatibility.

Rental License (Selected Markets Only)

With the rental option, you can buy a license for a certain time period, such as one month. During the 

purchased time period, you can use ARCHICAD without any limitation - e.g. running multiple sessions all day. 

The time period starts when you first start ARCHICAD using a rental license, not on the day you purchased it.

When starting up ARCHICAD, a dialog box will let you know how many days remain available on your rental 

license. You can also check this number at Help > License information.

Demo Mode

Demo Mode gives you full functionality except file saving and Teamwork. Use Demo mode to open, view and 

try out functions using any ARCHICAD file.

The unavailable commands and menu items are disabled, and the ARCHICAD title bar changes to 

ARCHICAD Demo.

Your ARCHICAD program may also be restricted to Demo mode for the following reasons:

• no key is attached to your computer, or

• all of your ARCHICAD licenses are in use, or

• your hardware protection key is defective, or

• CodeMeter service is not running.

Education License

The Education license is available if you are a student, teacher or contact person at an educational institution. 

A serial number can be obtained by registering at www.myarchicad.com. The first step of registration gives 

you a temporary serial number and a download link immediately. This temporary serial number is valid for 30 

days.

After you register, the credentials you provided go through an approval stage, after which GRAPHISOFT’s 

local representative sends you a final serial number valid for 1 year. When the 1 year license expires, you can 

renew it free of charge.

File Format and Compatibility

• EDU and commercial project files have the same file format (.PLN), but EDU files have an irremovable 

watermark at the top right corner. This watermark will be present on all printouts. 
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• EDU project files (including shared Teamwork projects) can be opened with a commercial version of 

ARCHICAD. In this case, ARCHICAD switches to EDU mode and the watermark will be present.

• Commercial project files can be opened with an EDU version of ARCHICAD. The watermark is added, 

and cannot be removed. 

Note: Teamwork Projects shared in the commercial version cannot be joined by users having the 

Education version.

• Apart from ‘Open’, no other data exchange (e.g. copy, paste, merge, hotlink) is allowed between EDU and 

commercial project files.

• If your serial number is that of an individual student rather than an educational institution, you will not have 

the option to create a custom Installation Package.

Trial License

Use the Trial License to try out the full functionality of ARCHICAD for up to 30 days, on a single computer. 

The trial license requires a serial number, which can be obtained by registering at www.myarchicad.com.

File Format and Compatibility

• Files written in the trial version are encrypted and can only be opened with the same copy of ARCHICAD, 

on the computer on which they were created.

• Trial projects shared in Teamwork: You can try out Teamwork functionality if you share and access the 

Trial-version project on the same computer on which the Trial version is installed. (The BIMcloud can be 

running on another computer.)

• The trial license cannot back-save files to any older version of ARCHICAD.

• At the end of the 30 days, if the files are not converted to full commercial files, the save function is 

disabled, but it is still possible to print.

• The files can be converted to full files by purchasing a commercial license. You must open the files, using 

the commercial license, on the same computer on which they were written.

Read More on Help Center

Time Limit? Save files? Open file? Teamwork?

DEMO None No Open and view any full-

version ARCHICAD file

No

TRIAL 30 days Save as Trial version, 

on same computer only

Open Trial version file, 

on same computer only

Yes, for TW 

projects shared in 

Trial version, on 

same computer 

only

EDU 30 days initially, one 

additional year after 

approval (renewable)

Save as EDU version 

only: Permanent 

watermark appears on 

all output

Open commercial file 

with EDU (watermark 

appears)

Open EDU file with 

commercial (watermark 

appears)

Yes, for TW 

projects shared in 

EDU
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Related Topics

Resolving Issues with Serial Numbers

Sign In with GRAPHISOFT ID
ARCHICAD 24 Reference Guide 220



Sign In with GRAPHISOFT ID Configuration
Sign In with GRAPHISOFT ID

Signing in with your GRAPHISOFT ID (GSID) is required

• to publish a BIMx Hyper-model to the BIMx Model Transfer Site

• to manage your GRAPHISOFT licenses using License Manager

• to activate BIMcloud Basic

Sign In or Out with GSID

In a running ARCHICAD, do one of the following:

• Use the ARCHICAD Help menu

• Right-click GRAPHISOFT ID in the Status Bar

• Use the command in the Select License Types dialog. (This dialog appears during ARCHICAD Startup if 

the required license is missing.)
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Once signed in, use the GRAPHISOFT ID: [your name] command from the Help menu to review your GS 

profile in your browser.

Sign Up for GRAPHISOFT ID

If you don’t have a GSID, first click “Sign In”, then “Sign up”.

You do not need to sign in to use ARCHICAD, but once you sign in, you remain signed in.

p
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Resolving Issues with Serial Numbers

To be able to use ARCHICAD in Trial or Educational mode, you must in put an email address (User ID) & 

Serial number. 

The Serial number can be obtained by registering a Professional or Educational account on 

MyARCHICAD.com. 

ARCHICAD asks for the email address (User ID) & Serial number at the first launch of ARCHICAD:

After you enter your email address (User ID) & Serial number, ARCHICAD checks if it’s a match with the 

MyARCHICAD database. 

If it detects an issue with your credentials, ARCHICAD displays an error message. 

The following points outline the issues that can possibly occur, and explains solutions to each.

What’s Covered

Serial Number is Invalid

Serial Number has Expired

Serial Number Does Not Match the Email Address

Serial Number is Not Valid for the Educational Version

Serial Number is Not Valid for the Trial Version

Serial Number is Valid for Another Language of ARCHICAD

Miscellaneous Issues

Serial Number is Invalid

It often happens that the Serial number contains characters that are visually similar, like 1-I-l, or O-o-0. Make 

sure that you have typed the exact same characters as you can see on your MyARCHICAD profile. A good 

way of eliminating this issue is to copy & paste the Serial number from your MyARCHICAD profile page to the 

ARCHICAD dialog.

Serial Number has Expired

Trial and Educational Serial numbers are issued for a 30 day period from the date of the registration:

• Trial mode: Trial licenses cannot be extended.

• Educational mode: Once registered on MyARCHICAD.com, students can apply for a 1 year license to 

extend their 30-day starting license.

Serial Number Does Not Match the Email Address

The entered Serial number is valid, but it is matched to a different email address/username than what is 

provided in the User ID field. Check your MyARCHICAD profile to see which User ID belongs to this Serial 

number, then try again.

Serial Number is Not Valid for the Educational Version

The entered Serial number was requested for the Educational/Academic version of ARCHICAD, which is 

provided to architecture and design students/teachers/schools, who are using ARCHICAD for their studies.

If you are an Educational user, you must obtain an Educational license. Re-register as a Student, as a 

Teacher, or as a School at MyARCHICAD.com, using a different email address.
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Serial Number is Not Valid for the Trial Version

The entered Serial number was requested for the Trial version of ARCHICAD, which is provided to 

professionals who are trying ARCHICAD out before purchasing a Commercial license.

If you are a professional user who wants to explore ARCHICAD through the Trial version, you must obtain a 

Trial license. Re-register on the Professional page of MyARCHICAD.com, using a different email address.

Serial Number is Valid for Another Language of ARCHICAD

The entered Serial number is valid, but it has been issued for a different language version of ARCHICAD than 

the one you are currently running. Go to your MyARCHICAD.com page and check which language version of 

ARCHICAD you applied for. On this page, you have the flexibility of switching between your language version 

and the International version of ARCHICAD, both having their own Serial numbers.

To solve this issue, choose the Serial number that is provided for the language version of your installed 

ARCHICAD. If you would like to use a different language version of ARCHICAD than you have access to 

through MyARCHICAD, you need to change your Country on the My Account tab of your profile.

Miscellaneous Issues

If none of the above tips could resolve your issue, please contact our MyARCHICAD support at: 

myarchicad@graphisoft.com

In your email please send a screen capture of the issue you are experiencing and describe the steps you have 

taken so far to resolve this problem.
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Bug Reporter

GRAPHISOFT Bug Reporter is a program that creates an electronic report of a bug, error, crash or other 

incorrect functionality of a GRAPHISOFT product. By sending in the Bug Report, you provide valuable 

information which helps GRAPHISOFT fix problems and improve your experience. Thank you for your 

cooperation!

What Does Bug Reporter Do?

Bug Reporter starts automatically whenever your program crashes.

From the appearing dialog, choose to send either a Detailed or an Anonymous bug report.

In both types of reports, Bug Reporter gathers information about your hardware configuration, system 

software and GRAPHISOFT applications you have installed on your computer. Unlike the Anonymous Report, 

the Detailed Report also includes your description of the problem, plus computer name, user name and 

license data. 

See the Privacy Notice for additional information.

Send Detailed Report

1. In the text field, describe what you were doing when the problem occurred. This detail is very useful for 

GRAPHISOFT. 

For example:

“I tried to Click-to-Trim a circular wall with a closed spline intersecting it at 4 points, when bogus lines 

appeared on the screen.”

2. Optionally, add your email address.

3. Check the box: “I agree to send a detailed report...”. 

– This authorizes Bug Reporter to gather additional system data as detailed in the GRAPHISOFT 

Privacy Notice. 

– Sending a detailed report also provides you with a Bug ID number, which you can use to follow up on 

the status of your crash report.

4. Click Send Report. If you are online, the report is sent to GRAPHISOFT.

5. The feedback dialog displays the Bug ID.

If you wish to follow up on this bug with Technical Support, use this Bug ID to reference the issue.

Send Anonymous Report

You can leave the box unchecked, then click Send Report. This creates a Bug Report including limited 

system information, as detailed in the Privacy Notice. It does not include any additional data or description of 

the problem.

If You Are Offline

A Bug report is generated even if you are offline. In this case, you are prompted to save the report file to your 

computer, then send it manually to Technical Support.
ARCHICAD 24 Reference Guide 225

https://www.graphisoft.com/info/legal/bug-reporting-policy/?gstype=legal&gssubtype=gsreport_privacy_note&gslang=INT&gsversion=24&gsdummy=5


Bug Reporter Configuration
Change Your Bug Report Preference (from Anonymous to Detailed)

By default, the Bug Report preference is “Anonymous.” 

You can change this preference to “Detailed”. 

To do this, double-click GSReport in the folder where ARCHICAD is installed.
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Work Environment

The following sections contain information on the main features of the ARCHICAD user interface, and how to 

customize them.

Default Work Environment Profiles

Arranging Palettes, Toolbars and Windows

Set Window Background and Grid Line Color

Tab Bar

Pop-up Navigator

Quick Options Bar

Toolbox

Info Box

Menus

Toolbars

Shortcuts

Palettes

Pet Palettes

Work Environment Dialog Box
ARCHICAD 24 Reference Guide 227



Work Environment Configuration
Default Work Environment Profiles

ARCHICAD is shipped with default Profiles: 

• Architectural

• MEP Engineering

• Structural Engineering

When you first start ARCHICAD, the New Project dialog lets you choose from any of these profiles.

Each Profile, optimized for a particular discipline, is set up to make it easy to find the tools and commands you 

will probably need most often.

Naturally, you or your office CAD manager can reconfigure these profiles as needed.

Apply a Different Work Environment Profile

Use Options > Work Environment > Apply Profile and choose a profile.
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Customize Work Environment Settings

As you get used to working with ARCHICAD, you will develop personal preferences for using the program’s 

features and arranging the various palettes, toolbars and menus on screen. You will set most of these options 

in the many sub-dialog boxes opened from the Work Environment dialog box at Options > Work 

Environment > Work Environment.

You can customize any of these settings while you work: just open the needed dialog box, change the setting, 

and press OK. The setting will take effect.

See Work Environment Dialog Box.
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Arranging Palettes, Toolbars and Windows

Use the following ARCHICAD commands of the Window menu to optimize your workspace.

Enter/Exit Full Screen

Use Full Screen to maximize the workspace.

Show/Hide Tab Bar

The Tab Bar is visible by default. Use this command to turn it on or off.

See also Tab Bar.

Show/Hide Palettes and Toolbars

Use this to hide all the open palettes and toolbars.

Close All Other Tabs and Windows

Closes all Tabs and Windows except for the currently active one. (Inactive Floor Plan, Rendering, GDL 

Editor windows will not be closed.)

Palettes > Show Main Palettes Only

Shows only the main palettes: Toolbox, Info Box, Status Bar, Navigator, Quick Options.

 Toolbars are not affected.

The arrangement and show/hide and docked status of your Toolbars, Palettes and the Tab Bar can be stored 

as part of the “Workspace Scheme” of your Work Environment.

See Work Environment Schemes.

Unified Window Mode on Mac

By default, ARCHICAD works in unified window mode, as the preferred working method for Mac users. 

(ARCHICAD has always worked this way on PC.) All windows, palettes and toolbars are contained within a 

single application window, so you can open, close and move all of them together.

Exception: When migrating projects from pre-19 versions, the Legacy Window mode is on by default.

In unified window mode, the header displays the project’s file name. Cmd+click this file name to display its file 

path.

If you close the project, and no project windows remain open, the application frame will not be visible, but the 

ARCHICAD application will not close (the menu remains on screen).

To use ARCHICAD with floating windows (instead of a unified window) on a Mac, as in ARCHICAD 18 and 

earlier, you can turn on “Legacy Mode” at Options > Work Environment > Legacy Window Mode (Mac 

only).

Dock or Undock Palettes or Toolbars

To dock/undock a palette or toolbar, do one of the following:

• Double-click the header. If the palette/toolbar is undocked, it will jump to a docked position, and vice 

versa.

• Click on its header (on PC, the drag symbol will appear) and drag it to one side or the top or bottom of the 

screen. Release the cursor to dock it. 

• To undock: click the header and drag it out. 

To suspend the docking function while dragging a palette or toolbar, press Ctrl (PC only).
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To cancel the docking/undocking, press ESC.

Note: To dock all undocked windows (Mac only), use Window > Dock All Windows. This command is 

not visible by default; you can add it to your Window menu by customizing your Work Environment 

(Options > Work Environment > Menus).

Toolbars can only be docked at the very edge of the screen (left/right/top/bottom), but they can be next to 

each other in multiple rows; docked toolbars won’t overlap each other. They do not snap together or move 

together the way palettes do, and they cannot be stretched.

Limitations on Docking Palettes

The following palettes cannot be docked: Mark-Up Tools; Find and Select; RoofMaker; Solid Element 

Operations; Profile Manager, PhotoRendering Settings, MEP Routing, IFC Project Manager, Energy Model 

Review. 

Docking Groups of Palettes

You can snap several docked palettes together, forming a group.

• To insert a second palette above the first, click and drag the second palette onto the header of the first. To 

insert a second palette below the first, click and drag the second palette to the line at the bottom of the first 

one.

Quick Options Palette docked with the Favorites Palette

• Within a group, you can arrange palettes next to each other vertically and horizontally in the desired 

arrangement.

• If you resize any palette that is part of a palette group, the rest of the palettes in the group will be resized 

automatically.
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• To set how much of each palette in a group should be visible on screen, drag the splitter bars.

Snap Undocked Palettes Together (Mac Only)

On Mac, you can snap undocked palettes to each other.

Palettes will snap to each other if you pull them within a given range of each other. The palette edge (not the 

cursor) is the docking anchor. Once snapped together, you can drag all of them at once, provided you grab 

the palette at top left.

To suspend the snapping function while dragging a palette, press Cmd.
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Set Window Background and Grid Line Color

1. Open View > Grid & Editing Plane Options > Grids & Background.

2. Double-click the Background field to open the Set Color (on Mac: Color) dialog box to select a different 

color.

3. Double-click the Grid Lines field to open the Set Color (on Mac: Color) dialog box to select a different 

color for the Grid Lines.

Note: The color you select here will also be used for the dimmed Project Origin when it is temporarily 

displaced.

The next two controls are available only if the 3D window is active:

Grid Background/Grid Opacity: Use the sliders to set the intensity of the grid background (editing plane) 

and the grid lines in the 3D window only.

Automatic Pen Color Visibility Adjustment for Model Views

When the luminance value of a particular background color falls below a threshold value - that is, if your 

background is sufficiently dark - black pens will be shown as white on your ARCHICAD screen. (This is useful 

if you use a dark or black background to imitate AutoCAD methods.) 

 

However, when printed, pen colors will print according to their actual settings in the pen set.

Non-black pens that would be difficult to see against a particular background will automatically shift to a 

similar, but more easily visible color. On a white background, elements in white pens are adjusted to a light 

gray to enhance visibility. Again, when printed, pen colors will print according to their actual settings in the pen 

set.

To disable this automatic color adjustment, uncheck the Automatic Pen Color Visibility Adjustment checkbox 

in Options > Work Environment > On-Screen Options.

See On-Screen Options.
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Tab Bar

The Tab Bar at the top of your ARCHICAD workspace shows all of your open views/viewpoints.

• Click any tab to activate that window.

• Hover over any tab to see a preview of its last opened view, with its name.

Turn off Tab Bar

The Tab Bar is visible by default. To turn it on and off, use Window > Show/Hide Tab Bar.

Turn off Tab Preview

By default, Tabs display a preview when you hover over them. Change this preference in Options > Work 

Environment > More Options.

Topics in this Section

Click Tab to Activate

Tab Overview

Tab Navigation Shortcuts and Commands

Tab Bar Context Menus

Open a Tab from a Marker

Overflow Items on the Tab Bar

Close Tabs

Dock/Undock Tabs (Mac only)

Open New View/New Layout Preference
ARCHICAD 24 Reference Guide 234



Work Environment Configuration
Click Tab to Activate

Click any tab, or click on its preview, to activate it.

Note: A tab of a view that has not been opened yet has no generated preview, and displays a view icon 

instead.

Tab Overview

Click the Tab Overview icon to show/hide all tab previews as an overview, then click the one you need:

Show/Hide Tab Overview

Tab Navigation Shortcuts and Commands

• Cycle among the tabs with the shortcuts:

– Ctrl/Cmd+Tab (from left to right) 

– Shift Ctrl/Cmd + Tab (from right to left)

See also Overflow Items on the Tab Bar.
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• Use the Window > Show Next Tab or Window > Show Previous Tab commands

Note: If you do not see these commands in the menu, use the Options > Work Environment > Menus 

dialog box to add them.

Each new Tab is appended to the right end of the Tab Bar.

Tab Bar Context Menus

Available items vary depending on the type of view/viewpoint. 

• From the Story tab, navigate to any story

• From an Interior Elevation view tab, navigate to any other IE in the same group

• From a 3D window tab, switch between Axonometric and Perspective views

• From a GDL editing window, switch back to the Master window

 

• From any viewpoint or view, find recent views created from the same viewpoint.
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• Click All Related Views to access, in a tree structure, all the views created from the same viewpoint as 

the tab:

Open a Tab from a Marker

Use a placed marker to navigate to any view created from a particular viewpoint.

Select Placed Marker, Then Right-Click to Open Any Related View

Overflow Items on the Tab Bar

You can have any number of tabs open at a time. If they no longer fit into the width of the tab bar, a double-

arrow pop-up appears at the right edge of the Tab Bar. 

Click to see a list of the additional tabs.
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The last visible tab is also listed here, shown with a checkmark.

Click on any of these to activate it and add it to the visible tabs on the Tab Bar.

Close Tabs

Do one of the following:

• Click the X on the tab

• Use the Close Tab command from the tab’s context menu

• Use the Close Tab command from the Window menu

• Click the mouse-wheel over the tab

To close all tabs except the currently active one, use Window > Close All Other Tabs and Windows.

Dock/Undock Tabs (Mac only)

Do one of the following:

• Use the Undock command from the tab’s context menu

• Use the Window > Undock command.

To dock a tabbed item, use the Window > Dock command.

Open New View/New Layout Preference

When you open a new view or new layout, it can either replace the opened one (of the same type, in the case 

of views), or be opened in a separate new tab. Change this tab-opening preference in Options > Work 

Environment > More Options.

Exception: You can have only one Floor Plan and one 3D window open at a time.

Related Topics:

Transfer Settings Among Tabs

Watch the Video

Watch the Video
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Transfer Settings Among Tabs

Several explicit commands and shortcuts enable you to transfer or otherwise control tab settings.

Shortcut: Use Current Settings When Switching Tabs

In contrast to the general rule that tabs retain their own settings, you can use this shortcut to apply the 

currently active settings when you click to open a new tab:

• on Mac: Cmd + click

• on Windows: Ctrl + click

Get Last Tab’s Settings

From a tab’s context menu, use the Get Last command to activate the settings of the last-opened tab for the 

currently open tab.

Pick Up/Inject View Settings

Use the Pick Up/Inject commands to transfer the View Settings from one tab to another.

1. Right-click on any tab whose settings you want to transfer. (It does not have to be the currently opened 

tab.)

2. Click Pick Up View Settings (or Alt+Shift on the tab).

3. Right-click the tab of the view/viewpoint where you want to inject the settings.

4. Click Inject View Settings (or Ctrl+Alt+Shift on the tab).

5. The clicked tab is now a viewpoint, which uses the View Settings you injected. If needed, use the Save 

View command from the tab’s context menu to save it as a view.

Match All Settings on Tab Bar

1. Right-click the tab of the currently opened view/viewpoint

2. Click Match All to Current. This applies the View Settings, except the Zoom and Scale settings, of the 

current tab to all the tabs (including grouped ones).

Restore View Settings

If the current view that you are editing no longer matches its saved View Settings, the tab is marked with a 

warning.
ARCHICAD 24 Reference Guide 239



Work Environment Configuration
To restore the view’s saved status, Double-click the tab (or click Restore View from the tab’s context menu).

If the view is linked to other tabs in a group, view settings change identically in all linked tabs.

 

Watch the Video

Watch the Video

Watch the Video
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Quick Options Bar

The Quick Options Bar is shown by default at the bottom of the ARCHICAD window.

Its controls show the current settings of the active tab. Use these as a quick way to apply changes among 

these settings, and to access the dialog box used to set up the relevant options set.

 

Use Window > Show/Hide Quick Options Bar to display or hide it as needed.

Controls available from the Quick Options Bar:

Zoom

See Zoom.

Orientation

See Set Orientation.

Layer Combination

• Applies a new Layer Combination to the view.

See Layer Combinations.

Scale

• Applies a new scale to the currently active window.

See Scale.

Partial Structure Display

• Changing this setting applies a new Partial Structure Setting to the currently active window.

See Partial Structure Display.

Pen Set

• Applies a new pen set to the model. (Not available in the Layout window.)

See Pen Sets.

Model View Options Combination

• Changing this setting applies a new Model View Options Combination to the whole project.

See Model View Options Combinations.
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Graphic Overrides Combination

• Applies a set of Graphic Override Rules to the view.

See Graphic Overrides.

Renovation Filter

• Choose a Renovation Filter to assign to the view.

See Renovation.

Dimensions

• Applies a new Dimensioning standard to the whole project. (Not available in the 3D window)

See Dimensions Preferences.

3D Styles

• Applies a 3D Style to the 3D window.

See 3D Styles.

Quick Options Palette

Use this palette as an alternative to the Quick Options Bar. 

To hide/show the Quick Options Palette, use Windows > Palettes > Quick Options Palette.
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Toolbox

The Toolbox shows a variety of tools for selection, 3D construction, 2D drawing and visualization.

The Toolbox is divided into Tool Groups to make it easier to locate the tool you need.

Toolbox contents vary, depending on the current Work Environment Profile and any Add-Ons.

Display the Toolbox

Use Windows > Palettes > Toolbox

Using the Toolbox

Do any of the following:

• Click any tool to activate it.

• Double-click to open its Tool Settings dialog box.

• Hover over the tool icon to access the Favorites chooser pop-up for that tool.

See also Favorites.
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Customizing the Toolbox

Use Options > Work Environment > Toolbox to customize the contents and arrangement of your toolbox.

See Toolbox Customization Dialog Box.

Store your customized Toolbox settings as part of a Tool Scheme in your Work Environment.

For details, see Work Environment Schemes.
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Info Box

The Info Box is a condensed collection of input and parameter controls for the currently active tool (default 

Settings) or selected element (Selected/Editable Settings).

Unlike Element Settings, the Info Box stays on screen while you work.

If several elements are selected, the Info Box displays the controls for the last selected element.

• Selected/Editable: The current Info Box gives you feedback on the number of Selected Elements, as well 

as how many of those are Editable. Changes made to Info Box settings will affect the Editable elements. 

(An element might not be Editable if it is on a locked layer.)

Header texts indicate what each Info Box control represents. 

Display Info Box

Windows > Palettes > Info Box

Hide Header Texts

Right-click anywhere in the Info Box and choose Hide Header Texts.

Customizing the Info Box

You can customize the order and visibility of panels in each Tool’s Info Box: go to Options > Work 

Environment and open the Info Box Customization Dialog Box.

An easy way to access this dialog box is to open the Info Box context menu by right-clicking anywhere in the 

Info Box, then click Info Box...

See Info Box Customization Dialog Box.

You can store your customized Info Box settings as part of a Tool Scheme in your Work Environment.

For details, see Work Environment Schemes.
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Menus

Menus are displayed across the top of the ARCHICAD window. 

If you don’t see the menu you expect, try changing your Work Environment Profile:

Use Options > Work Environment > Apply Profile and choose a profile.

Customizing Menus

Use the settings in the Options > Work Environment > Menus dialog box to customize the content of your 

menus.

Any command or menu can be placed into or removed from any menu; the order of the commands within any 

menu is entirely customizable.

For details, see Menu Customization Dialog Box.

Exception: Context menus are not customizable.

You can store your customized menu command settings as part of a Command Layout Scheme in your Work 

Environment.

For details, see Work Environment Schemes.
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Toolbars

A toolbar is a collection of commands and/or menus displayed in icon or text form and grouped by topic. It’s a 

good way to easily access frequently used commands, by theme.

The “Edit Elements” Toolbar

Display Toolbar

Open a Toolbar from Window > Toolbars.

Or from the context menu of any displayed toolbar.

See also Arranging Palettes, Toolbars and Windows.

Create or Customize Toolbars

Use Options > Work Environment > Toolbars

See Toolbar Customization Dialog Box.

You can store your customized toolbars as part of a Work Environment scheme:

• The content of named toolbars are saved as part of a Command Layout Scheme.

• The on-screen display of toolbars is saved in a Workspace Scheme.

For details, see Work Environment Schemes.
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Shortcuts

The shortcut keys in effect are defined by your Work Environment settings. 

View/Print List of Keyboard Shortcuts

1. Go to Options > Work Environment > Keyboard Shortcuts

2. Click the Show Shortcut List in Browser button at the bottom of the Keyboard Shortcut Preview Panel.

Customize Keyboard Shortcut

1. Go to Options > Work Environment > Keyboard Shortcuts

2. Choose a command from the list on the left.

3. Enter the desired shortcut combination in the field at the right.

4. Click Assign.

For more details, see Shortcut Customization Dialog Box.

Apart from a few non-customizable shortcuts (listed at the bottom of the Show Shortcut list), all shortcuts in 

any scheme are customizable. Changes to the selected Shortcut scheme are applied when you press OK and 

close the dialog box.

You can store your customized Shortcut settings as part of a Shortcut Scheme in your Work Environment.

For details, see Work Environment Schemes.
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Palettes

ARCHICAD’s palettes help you construct, modify and locate elements. Each palette can be shown or hidden 

separately using the Window > Palettes command.

Show Main Palettes Only

The main palettes (Toolbox, Info Box, Status Bar, Quick Options and Navigator) can be enabled all at once, 

using the Window > Palettes > Show Main Palettes Only command.

See also Arranging Palettes, Toolbars and Windows.

Each of these main palettes is described in detail in the ARCHICAD documentation:

Toolbox

Info Box

Navigator Palette

Quick Options Palette
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Pet Palettes

A pet palette is a collection of icons (representing commands and relevant options).

In some cases, the pet palette appears during input (as when inputting a polyline), but in most cases the pet 

palette appears after you have selected a placed element for further editing.

To access the pet palette, place your cursor on an editable edge, node, or surface, and left-click.

The contents of the pet palette depends on the following:

• The selected element 

• The part of the element you choose to act on (edge, node or surface)

• The active window

Move your cursor over the icons to read the tool tip for each one, and click on the icon for the function you 

need. Use the shortcuts “F” and Shift+F (Opt+F) to move to the next/previous icon in the current pet palette.

You cannot customize the contents of a pet palette.

You can change your mind and choose a different function from the pet palette as long as you have not 

completed the editing operation.

The pet palette automatically disappears when the operation is finished.

Pet Palette Movement

The pet palette will either follow your cursor around on screen as you work (like a pet on a leash), or be placed 

in a preferred spot (and told to “stay”), depending on which Pet Palette movement option you specify.

Set these preferences at Options > Work Environment > Dialog Boxes and Palettes.

See Dialog Boxes and Palettes.
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Template Files

A template is a read-only project file with extension tpl. It contains all project preferences settings, placed 

elements and tool default settings of the project.

When you create a new project in ARCHICAD using a template file, this default template is at the top of the 

pop-up list when you choose a template: 

See also Create New Project.

Template File Location

The default template is located in the ARCHICAD Defaults folder.

On PC: \Program Files\Graphisoft\ARCHICAD 24\Defaults\ARCHICAD

On Mac: \Applications\Graphisoft\ARCHICAD 24\Defaults\ARCHICAD

To create a customized template:

1. Open a new empty project file.

2. Edit your project preferences, IFC Translator settings, and set up the project structure and/or place 

elements.

3. Save this project file as a template: use File > Save as, and choose “ARCHICAD Project Template (*.tpl)” 

as the file type.

To open a template:

Do one of the following:

• Use File > Open, and browse for an existing template file

• Use File > New

– In the appearing New Project dialog, use Create New Project from Template

– Select the desired template file.

Note: Template File selection also occurs when you import or hotlink an IFC-type file to ARCHICAD, 

because IFC Translator files are saved in a template.

For working with IFC Translators, see Important Note on Translators and Template Files

Note: Settings of the Work Environment Profile used to open your project will override Template file 

settings.
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Backup Files

Open a Backup Project file (.bpn) to recover the latest backup copy of a damaged project file.

To open a backup file, do one of the following:

– Browse and double-click its name in the file system

– From the ARCHICAD Open dialog or other system dialogs: use the dialog’s “All file types” filter to 

include BPN files in the available list

Make sure that Make Backup Copy is active in Options > Work Environment > Data Safety & Integrity.

Related Topics:

Data Safety & Integrity
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Archive Projects

Documents saved as Archives are stored together with their Library Parts (in a Library Container File, with 

extension .lcf), and properties contained in and defined with the Project. The Archive format is recommended 

if you want all files referenced by the project’s placed elements to be included.

The Archive file format is recommended when:

• Moving a Project to another computer

• Storing a completed Project

The Archive Options dialog box allows you to add selected additional items to the Archive file (see below).

Save Project in Archive format

1. Use the File > Save as command.

2. From the appearing Save dialog box, choose ARCHICAD Archive Project (*.pla) from the Save as type 

drop-down.

3. Click the Options button to access the Archive Options dialog box:

• Include Background Picture (if loaded in the Background Panel of PhotoRendering Settings)

Use next three checkboxes to include additional loaded library parts as part of the Archive file (in addition to 

library parts placed in the project).

• Include All Parts in

– Favorites: Save all library parts that are included in the project’s Favorites (to avoid missing objects 

when trying to use Favorites)

– Local Libraries: Save all parts from all loaded libraries

• Include Linked Textures

• Include Properties in Loaded Libraries

•  Include All Drawings: This will include all drawings placed on layouts, even those which are NOT 

marked as “Store Drawing in the Project file” in its Drawing Settings dialog box.

•  Break nested Hotlinks and Xrefs

See Nested Modules (Hotlink Module Manager).
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• Compress file

See File Compression.

Watch the Video

Important Notes about Archive Projects:

• If any Library Parts are missing from your Project at the time you save the Project as an Archive, these 

missing parts will not be included in the Archive document either.

• If you add a .pla file to your Linked Libraries folder using Library Manager, make sure you add the 

explicit .pla file itself, not a folder that contains the .pla. Otherwise the parts located within the .pla will not 

be read.

See Library Manager.

• Because of the larger volume of information it stores, an Archive file size is somewhat larger than the 

corresponding Project document.

• Archives store the font information used in the project, but not the fonts themselves. This means that if 

you wish to display textual information the same way as it appears in the original environment, you have 

to install the appropriate fonts.

• Archive files do not store Add-Ons. Therefore, if your project contains elements affected by Add-Ons, 

these elements may lose certain features or behavior if these Add-Ons are not present.

Open Archive Project

Do one of the following:

• Use File > Open > Open to browse for an archive (PLA) project

• Use the Start ARCHICAD dialog to browse for an archive project

By default, when you open an archive project, this dialog appears:

Choose one of the three options:

• Read elements directly from archive (DEFAULT): Library parts will not be extracted from the archive 

file. You can place Objects from the Archive file, but you cannot edit the Library parts themselves (unlike 

the elements in an .lcf file). This also applies to list schemes used in calculations. This method saves a lot 

of disk space, but limits the modification possibilities.

• Extract elements to a new folder: The external library parts required for the project will be extracted 

from the archive and placed in a new folder that you can name. This solution is recommended if you need 

to actually work on the project objects. (You cannot extract objects to the Embedded Library.)
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• Select a library: Instead of extracting the library parts saved with the project, you can indicate a folder to 

store the required elements. This solution is recommended if you wish to update the Project’s objects with 

their latest versions.

– To skip the Open Archive dialog, check Read Elements Directly from Archive from the Settings pop-

up of the Start ARCHICAD dialog. As a result, when you open an archive project from the Start 

ARCHICAD dialog, the library parts will be automatically read during project start-up, with no user 

input required.

To view information about possible Library-related issues, check the Libraries item in the Action Center (File > 

Info > Action Center)

Related Topics

Opening Legacy or Archive Projects: Manage Library Parts

Action Center
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ARCHICAD User Feedback - Net Promoter Score Survey

Note: This feature is available in ARCHICAD 24 Update 2 and above.

We have introduced a new survey feature, so we can make ARCHICAD work even better for you.

We know your time is precious: our surveys are short and take just a minute or two.

The first survey is available now: the “Net Promoter Score” is a key metric that helps us to gauge your overall 

experience with ARCHICAD.

Start Survey from Action Center

To start the survey, go to the Action Center. (File > Info > Action Center)

The new “Feedback panel” indicates that a new survey is available. Just click to open and submit the survey 

directly from the Action Center.
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Check for New Survey

At any time: check to see if a survey is available by clicking Check All Items in the Summary tab of the Action 

Center. (Show the Summary tab, then Check All Items)

Your feedback helps us to improve our products and meet your needs. From time to time, you will receive a 

friendly reminder about available surveys when you close your ARCHICAD project. You can either respond to 

the survey right then, or just close up and revisit the survey in the Action Center at a later time. 

To read more about how we collect and handle data, see our Privacy Notice.

Related Topics:

Action Center
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Create Support Package (Troubleshooting)

If you encounter an error in a project that requires technical support, the problem can be resolved much more 

efficiently if the support personnel can view the problematic project files. The relevant files might be located on 

a BIMcloud as well as on client machines, in various folders.

The Support Package function is a utility that automatically gathers the necessary data and stores it in a 

single file (.support for solo projects or .twsupport for Teamwork projects) that you can easily send to 

GRAPHISOFT for troubleshooting.

In the case of Teamwork projects, certain problems - errors during Send, Receive, or Saving the local copy - 

will automatically bring up the Support Package interface. (At this point, you can proceed or cancel as you 

prefer.)

Create Support Package

1. From the ARCHICAD Help menu, select Create Support Package.

2. You are prompted to close any open projects. (You will also be prompted to Save or Send and Receive 

changes, where applicable.) 

3. The Create Support Package dialog box appears:

Choose either Solo Project or Teamwork Project.

Your most recently closed project is shown in the Project field. To choose a different project, click the Browse 

(...) button.

For a Teamwork project: You must select a BIMcloud, then select the Teamwork Project whose files you 

want to send. 

4. Select the package content to be sent.

Default

Default content is recommended. For a solo project, the Default content includes log files and crash info files.

For a Teamwork project, the Default content includes log files, crash info files, and your local copy of the 

project.

Client Only

The Client Only option is for Teamwork projects: it excludes the logs and Model files from the Server, and 

sends the Model and Log files only from the Client.
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Custom

To include other items as well, choose Custom, then Package Content. In the appearing dialog box, check 

the boxes of the items to include. (The Default content is included automatically; here, choose any additional 

items to include in the package.)

The optional content differs for solo and for Teamwork projects:

5. Enter any comments that could be helpful to support staff. For example, describe what happened; list the 

last few actions you took.

6. Click OK to return to the Create Support Package dialog box.

7. Click Create.

8. Select a destination folder for the Support Package file.

9. Click OK to start the file creation process.

10. Send the file to your local GRAPHISOFT Technical Support.
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License Information

Use the License Information dialog box to borrow, reserve or connect to licenses need to run ARCHICAD 

and certain Add-Ons. 

Do one of the following:

• Click on Help > License Information

• From the Help > About ARCHICAD Dialog, click on License Information

• From the Action Center (File > Info > Action Center), select the Licenses item and click License 

Information

This dialog displays License information and status for ARCHICAD-related products available to you. 

Available options depend on your license configuration. Consult your distributor for more information.

The following License-related features are described on this page:

License Borrowing

Connect ARCHICAD License

Enter Emergency License Activation Code (Not Available in All Markets)

Validate SSA Status

License Borrowing

The License Borrowing feature allows individual users to “borrow” a license key temporarily if they will be 

going offsite, to enable use of the software even without being connected to the network.

License borrowing is available if:

• ARCHICAD is running on your machine with a license from a CodeMeter NET key (either hardware or 

software key)
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• The CodeMeter NET key contains borrowable licenses to use with ARCHICAD and/or other 

GRAPHISOFT products

For more information on CodeMeter NET, see http://helpcenter.graphisoft.com/technotes/licensing/

codemeter-software-protection-for-graphisoft-products/.

In any case, borrowing is available only if the selected product’s License is “Network (CodeMeter)”.

Click Borrow License.

If the process is successful, the program lets you know that you have borrowed a license for the product, with 

a particular expiration date.

In the License Information dialog box:

• The selected product’s License information is listed as either “Borrowed (CodeMeter Stick)” or “Borrowed 

(License file)”, depending on the form of protection used. (This can vary by country.)

• The selected product is now shown with a Return button: click here when you are ready to return the 

license. The expiration date of the borrowed license is shown in the Product Information section.

• If your license expires before you return it, the program will automatically return it for you, even if you are 

not online.

Connect ARCHICAD License

Use this optional function to connect your personal GRAPHISOFT ID to your GRAPHISOFT ID company, 

based on the protection key running ARCHICAD.

Once the personal GRAPHISOFT ID is connected, users can access SSA-exclusive web pages.

For more information, contact your distributor, or see http://helpcenter.graphisoft.com/technotes/licensing/

connect-archicad-license/.

Enter Emergency License Activation Code (Not Available in All Markets)

This feature is relevant only if you have obtained an Emergency License (a temporary solution, for licensed 

users, if ARCHICAD is launched with no Protection Key available). In this case, an Activation Code is issued 

via internet.

Use the Enter Activation Code button to enable the Emergency License on a computer that is currently 

running ARCHICAD in Demo mode.

For more information, contact your distributor, or see http://helpcenter.graphisoft.com/technotes/licensing/

emergency-license/.

Validate SSA Status

This function is relevant only for ARCHICAD users who have a Software Service Agreement (SSA). 

Background: SSA’s are available according to terms and conditions set by your local distributor. Some 

ARCHICAD-related Add-Ons can be used with full functionality only if you have a valid SSA. 
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ARCHICAD automatically validates the status of your SSA at program startup if you are online. If the SSA 

status is up to date, your installed Add-Ons (those which require an SSA) will function, and you don’t have to 

do anything else.

When to Use this Function

If you install an Add-On or obtain a new SSA after starting ARCHICAD, you must run the SSA status 

validation manually:

Click Validate SSA Status.

• If you are online: ARCHICAD will validate your SSA status, and the affected Add-Ons will now function.

• If you are offline: You are directed to access and install the needed SSA validation files manually.
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Opening Projects through a Network

If the file that you wish to open is already in use by someone else on the local network, ARCHICAD will warn 

you about this and let you know the name of the user, that is, the name defined in the Sharing Setup Control 

Panel (Mac) or as the User Name (Windows).

You have the following choices:

• Open the file as read-only

• Open the file with exclusive access

• Cancel opening the file

If you choose to open the file as read-only, you can see and modify the whole file, but you can only save it 

under a different name or into another location. If you try to overwrite the original file, you will again be notified 

that it is in use and that you cannot replace it with your modified Project.

You can also choose to open the file with exclusive access. However, you should be very careful about 

using this option.

There are a number of reasons why ARCHICAD may state that a file is in use although it actually is not:

• The person who last used the file did not properly open and close the file in ARCHICAD, e.g., because of 

a system crash.

• You have made a copy of a file that was in use at the moment, and the copy of the file also includes the 

name of the person who was using it during the copying operation.

Note: If you do open a file with full access while another person is using it, you will both overwrite each 

other’s work without getting any further warning message from ARCHICAD. Therefore, be extremely 

careful when opening a file with exclusive access in any situation other than the emergencies mentioned 

above.
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Add-Ons and Goodies

Add-Ons are small applications that extend ARCHICAD’s core functionality. Many add-ons are integrated as 

ARCHICAD menu commands.

Goodies are other Add-Ons that are not integrated into ARCHICAD’s default interface.

See Goodies, below.

Managing Add-Ons

Open the Add-On Manager using Options > Add-On Manager command.

Use the Add-On Manager to:

• Load Add-Ons from any location. They will be loaded after the next startup of ARCHICAD

• Permanently remove Add-Ons while ARCHICAD is running

• Control which Add-Ons should load automatically when ARCHICAD is started

• Show information about the loaded Add-Ons

See Add-On Manager for more details.
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Menu Location of Add-On Functions

The menu/toolbar location of add-ons is defined in the settings dialogs of Options > Work Environment > 

Menus/Toolbars.

In the Customize Menus (Toolbars) page, add an “Add-On Anchor Point” item to any menu (e.g. File menu) or 

toolbar. The respective Add-Ons will be displayed at this customized menu/toolbar position.

If the Add-On Anchor Point is not part of your menu structure, then the Add-Ons will not be displayed in the 

menu.

Goodies

“Goodies” are another source of ARCHICAD Add-Ons. They are not integrated into ARCHICAD’s default 

interface. To access them, do the following:

1. Go to the ARCHICAD Help menu.

2. Choose Online Resources > ARCHICAD Downloads.

3. From the Downloads page, scroll down to Add-Ons, and click “Add-Ons and Goodies.”

4. Select your Language version to access available Goodies.

5. Click on the Goodies installer to install all Goodies from a single file.
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Working Units

Use the dialog box at Options > Project Preferences > Working Units.

Generally, working units are displayed in dialog boxes and during input (e.g. in the Tracker or Control Box).

Length Unit

Select from standard Length Measurement Units. 

• If the model is saved in BIMx, this model unit will be used by default when the BIMx model is opened in a 

viewer application.

Notes: 

– If you change the Working Units (for example from metric to imperial), some of the other default values 

such as grid spacing or default element sizes may need adjusting for meaningful, round values.

– The Length Unit entered here does not apply to Dimensioning functions. To set Dimension units, use 

Options > Project Preferences > Dimensions.

Area Unit

Select from standard Area Measurement Units. 

Volume Unit

Select from standard Volume Measurement Units. 

Angle Unit

Select from standard Angle Measurement Units. 

Note: Regardless of the angle unit set here, the angle measurements of core data in dialog boxes - such 

as Slant angle - are always displayed in Decimal Degrees. The number of decimal places for these angles 

is defined by the “Numbers without Units” preference below.

Notes on Surveyor’s Unit:
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– The Surveyor’s Unit preference set here is reflected during input in the Control Box, Tracker and 

Measure Tool. 

– The initial Surveyor’s Unit angle is measured from the North direction (set in the Options > Project 

Preferences > Project Location dialog box).

See Project Location and Project North.

Layout Unit

Select from standard Length Measurements units for all editing functions associated with the Layout Book 

(e.g. Layout size, 2D drawing elements added to Layouts, Title size, etc.).

Decimals/Fractions: Set the number of decimals or size of fractions for the chosen Length Measurement 

Unit.

Numbers without Units (Font sizes, Pieces, etc.)

Set the number of decimals displayed for Text Height and Element Property values without units. Also used 

for the display of core angle measurements (e.g. Slant angle)

Note: Text height is measured in mm if the Length Unit is metric and in points if it is feet and inches.

Working Units in Teamwork

If you open a Teamwork project from the server, its Working Units will have default values based on the 

template used to create the Teamwork project. However, you are free to change these Working Units while 

you work on the Teamwork project. Your Working Units preferences specific to each user, and are not saved 

to the server when you Send or Receive changes.

See also Structural Analytical Model Units.
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Project Location and Project North

Use the Project Location dialog box to identify the geographical location of your project.

The Project Location dialog box is available:

• from Options > Project Preferences > Project Location

• from the context menu of the Project Name in the Navigator

Location Settings are significant for:

• Running the Energy Evaluation function

• Calculating Sun position for 3D views, Camera views, photorenderings, and Sun Studies

• ARCHICAD Library parts which refer to the Project North value you set here.

See Project North.

• The Google Earth Connection add-on, which considers the Altitude

Project Name and Address

The data for Project Name and Site Address are taken from the Project Info dialog box.

See Project Info.

Click Edit to modify these data by opening the Project Info dialog box.

Enter Location Data

Enter the Latitude and Longitude of the Project Location.

• For maximum accuracy (e.g. for Energy Evaluation purposes), you should identify and fill in precise 

latitude/longitude data for the location of your project.
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• Click the pop-ups to switch between Latitude North and South, and Longitude East and West.

• Choose your preferred unit of measure from the fly-out menu.

Time Zone

Choose a time zone at the Project Location, expressed as a positive or negative offset from UTC 

(Coordinated Universal Time), together with the name of the corresponding time zone.

Altitude

Enter the altitude of the project location in the desired units. 

• Altitude data is used when you export the project to SketchUp and Google Earth formats. 

• Altitude is used as the Sea Level Reference Level for your project, at Options > Project Preferences > 

Reference Levels.

See SketchUp (.skp) and Google Earth (.kmz).

Use Predefined City as Location Data

As a quick way to enter Location data, you can choose a predefined city: click the globe icon to open Cities.

Note: To edit the list of predefined cities and associated data, go to Options > Element Attributes > 

Attribute Manager.

See Attribute Manager.

Choosing a city has the following effects:

• Latitude, Longitude and Time Zone fields are filled out

• Updates Sun Position in 3D Projection Settings and Cameras

See also Sun Position.
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Note: For maximum accuracy, you should prefer precise latitude/longitude data for the location of your 

project, rather than a predefined city.

Use Google Maps to View and Query Location Data

Provided you have an Internet connection: click on Show in Google Maps to view the project location as 

defined by your latitude/longitude data.

To query precise data using Google Maps, zoom in to the desired location. Right-click to bring up the context 

menu, then choose “What’s Here?” to view (and copy, as needed) latitude/longitude data.

Project North

The Project North value affects the following:

• The calculations of the Energy Evaluation function.

• Some Interior Elevation Markers include text which display the Project North value.

• The North Symbol object (in the ARCHICAD Library), when placed in the project, reflects the Project North 

value. (You must check the “Follow Project North” box in the object’s Settings.)

• When using surveyor’s units (Options > Project Preferences > Working Units), the North of the 

Coordinates Palette and the Tracker will be the same as the one set here.

• The Sun azimuth will be calculated with respect to Project North (where East is at 0.00 degrees).

Sun position is set in 3D Projection Settings. See Sun Position.

Define Project North

Enter an Azimuth (compass) angle value here to orient the Project North direction in the Floor Plan window, or 

drag the compass pointer to orient the Project North Azimuth graphically.

From the pop-up, choose the display unit for Project North.

Note that the accuracy of these units depends on the accuracy set for Angle Unit in Options > Working 

Units.

Define Project North Graphically

• Click Options > Project Preferences > Set Project North, or

• Use the same command from the context menu of the Project Name in the Navigator (provided that the 

Floor Plan or 3D Window is open).
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In either Floor Plan or the 3D window, move the pointer to match the project’s North orientation.

Manage Location Data (XML, SketchUp, Google Earth) 

Use the Import and Export buttons to manage the information displayed in this dialog box.

There are three possible formats: XML, Google Earth (.kmz) and SketchUp (.skp).

All three formats can be used to transfer information between ARCHICAD projects. The Google Earth and 

SketchUp formats also allow users to align their ARCHICAD models with SketchUp and Google Earth models.

• The XML format stores and reads longitude & latitude, angle display format, time zone, altitude & altitude 

unit, north direction and display format.

• The Google Earth (.kmz) format stores longitude, latitude & altitude as a single place mark. The import 

function will also read longitude and latitude data from .kmz files containing a single place mark. The 

altitude will also be imported if it is expressed in absolute mode (not relative or clamped).

• The SketchUp (.skp) format exports and imports longitude, latitude, altitude, North direction and time 

zone. The Site Address:-city and Site Address:-country data are exported but NOT imported).

For further information on SketchUp:

• import: see SketchUp (.skp)

• merge: see Merge SketchUp (.skp) File

• export: see SketchUp (.skp)

For further information on Google Earth:

• import: see Google Earth (.kmz)

• merge: see Merge Google Earth (.kmz) File

• export: see Google Earth (.kmz)
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Project Preferences

The Options > Project Preferences menu contains the Project Preferences tab pages where you set 

standards and working methods specific to the project you are working on, and which are saved along with 

the project.

If another user opens the Project on his or her own computer, the same settings will be applied.

In Teamwork, you must have access rights and must reserve the Project Preference dialog box in order to 

change these preferences.

The Project Preferences dialog box contains a pop-up menu at top left listing each preference category 

(which you can also access directly from Options > Project Preferences). Click Next and Previous to 

navigate among screens.

For details on each of these controls, see:

Dimensions Preferences

Calculation Units and Rules Preferences

Zones Preferences

Reference Levels Preferences

Legacy Preferences

Stair Rules and Standards: Project Preferences

Structural Analytical Model Representation (Preferences)

Structural Analytical Model Units

MEP Preferences

Related Topics:

Working Units
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Scale

To set the scale of the currently active model window, do one of the following:

• Use the Scale pop-up from the Quick Options Bar at the bottom of the window

• Use Document > Floor Plan Scale (the command varies depending on the window)

Select a standard scale from the pop-up list, or choose Custom Scale and type one in.

Scales are saved as part of View Settings.

Scales are displayed using metric or US standards, depending on the Length Unit setting defined at Options 

> Project Preferences > Working Units.

To make a zoomed view match the view at the currently set scale, choose View > Zoom > Actual Size after 

setting the scale.

Actual Size is the equivalent of the 100% scale value.

The 2D Symbol of some GDL Objects can be set to be sensitive to the current scale: the symbol varies 

depending on the current scale.
ARCHICAD 24 Reference Guide 274



Scale Configuration
Model Size vs. Paper Size Elements

Model Size elements are rescaled along with the model whenever you change the project scale. Model size 

elements include all construction elements such as walls, objects, slabs etc.

Paper Size elements are printed or displayed on the screen at the size you specify, regardless of the scale 

selected for the Project. For elements that do not have any real size, such as dimensions and arrowheads, 

you can specify a fixed size defined in either points or millimeters.

Either Model Size or Paper Size: The following elements may be either model size (scaled with the plan) or 

paper size (scale independent):

• Text Blocks created with the Text tool: Choose Model or Paper size.

See Text Tool Settings.

• Dashed and symbol lines: Choose Model or Paper size.

See Lines Dialog Box.

• Vectorial, symbol and image fills: Choose Model or Paper size.

See Create or Edit Image Fill.

Set a Separate Printing Scale for 2D Document

The Scale options in the Print 2D Document and Plot 2D Document dialog boxes (File menu) allow you to 

specify a Custom printing scale each time you print or plot your work from a Floor Plan or other 2D window.

The Text and Markers options enable you to reduce/enlarge text and markers as the printing scale is 

changed, or keep them at a fixed (paper) size.

See Print 2D Document and Plot 2D Document.

Drawing Scale

Drawings based on an ARCHICAD view have a Drawing Scale. By default, this Drawing Scale is the same as 

the Original Scale (the scale of the Drawing’s source view), but you can customize the Drawing Scale in 

Drawing Settings.

See Drawing Settings.

Customizing the Drawing scale has no effect on the scale of objects within the drawing; it is equivalent to a 

graphical resizing of the Drawing, like the effect of magnifying a document with a copy machine.
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Attributes

ARCHICAD Attributes are groups of defined settings available to your project. For example, Lines and 

Surfaces are Attributes which you can apply to many project elements as you create them. What you see in 

these pop-up settings menus are defined in the Attribute sub-dialogs, accessible through Options > Element 

Attributes.

Note: MEP Systems attributes are also available: apply the MEP Modeler Work Environment Profile, or 

add these commands to your Work Environment manually.

ARCHICAD comes with a default set of Attributes.

Attributes are saved with your project, so if you open the project on a different computer, your customized 

Attributes are available.

If you delete an Attribute, this can have consequences for any elements in the project that used it. ARCHICAD 

gives you feedback and a replacement option to ensure a smooth workflow.

Use Attribute Manager to

• List and edit the attributes of your current project

• Import attributes from another project or XML file; edit and add them to current project attributes

• Export any set of attributes as an XML file

See Attribute Manager.

You can customize Attributes or create new ones. For example, you can draw a new fill type, or customize a 

default surface to give it a new look.

To open and (if needed) edit Attribute sets, use the commands from Options > Element Attributes. Each 

attribute type is described in detail here:

Layers

Lines

Fills

Building Materials

Composite Structures

Pen Sets

Surfaces

Zone Categories
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MEP Systems

Operation Profiles (Energy Evaluation)

Profile Manager

Related Topics

Missing Attributes

Attribute Manager

Delete and Replace Attributes in a Model

Custom Attributes of GDL Objects

Attributes of XREF Files

Reservation in Attribute Manager; Reserve All Attributes (Teamwork)
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Layers

The following sections detail how to work with Layers in ARCHICAD.

About Layers

Layer Settings Dialog Box

Quick Layers

Layer Combinations

Use Layers to Prevent Intersections

Use Separate Layer Settings for the Layout Book

Place All Elements on a Single “Active Layer” (Simulate AutoCAD Work Methods)

Show/Hide Layers of Imported DWG/DXF/DWF Files

Attributes of XREF Files
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About Layers

Layers are used to separate elements logically. Related groups of elements, such as dimensions, furniture, 

electrical symbols and so on, are placed on common Layers.

An element can only belong to a single layer.

For each layer, you can define the following settings:

• lock/unlock

• show/hide

• 3D view mode 

• layer intersection group

ARCHICAD comes with a predefined set of layers. Each tool has a default Layer assignment, so if you place 

an element using that tool, the new element is automatically placed on the corresponding layer (e.g. External 

Wall, Column, Beam).

Note: Doors, Windows, Openings, Wall Ends and Corner Windows do not have separate layers; they are 

handled together with the layers of the wall into which they are placed. Cameras do not have layers.

Layers can be deleted; in this case, you will delete all the elements on it. However, the ARCHICAD Layer is a 

special layer that cannot be deleted, hidden or locked, since an ARCHICAD project must always contain at 

least one layer. In case of a file error, any elements that may have lost their layer definitions will be placed on 

the ARCHICAD layer.

Each ARCHICAD project has a single layer set, managed in the Layer Settings Dialog Box.

See Layer Settings Dialog Box.

The Quick Layers toolbar contains shortcuts for changing layer states for multiple layers quickly and easily.

See Quick Layers.

Layers are global, which means that the same layers are available on all stories and in all windows. However, 

layers used in the Layout book can have different settings than those used in Model views. (The title bar of the 

Layer Settings dialog box reflects which type of window is active in ARCHICAD - a Model View or the Layout 

Book.)

See Use Separate Layer Settings for the Layout Book.
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Use Layers to Lock Elements to Prevent Editing

Click the lock icon to toggle between locked/unlocked status for the selected layer.

If a layer status is locked, then elements on that layer cannot be edited - this is useful if you want to prevent 

unintended changes.

Use Layers to Show/Hide Elements

To show/hide a layer, toggle the “eye” icon open or shut for the selected layer.

Elements on a hidden layer are not displayed.
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Use Layers to Show 3D Elements in Wireframe Mode

Click the shaded/wireframe icon for the selected layer to toggle between these display mode options for 3D.

Note: This setting is independent of the current 3D Style in the View > 3D View Options menu.
ARCHICAD 24 Reference Guide 281



Attributes Configuration
Quick Layers

The Quick Layers toolbar lets you quickly change the state of the Layers in your Project without having to 

open the Layer Settings dialog box.

To display Quick Layers, choose the Window > Palettes > Quick Layers command.

Select the element(s) whose layers you wish to manage. (You can select elements using both explicit 

selection and Marquee areas.)

The toggle buttons, from left to right:

• Show/Hide Toggle: inverts the visibility of all layers.

• Lock/Unlock Toggle: inverts the state of all protected and unprotected layers.

• Hide Selection’s Layer: Hides the layer of the selected elements.

• Lock Selection’s Layers: Locks layer of the selected elements.

• Unlock Selection’s Layers: Unlocks layer of the selected elements.

• Hide Others’ Layers: Hides the layer of the elements that are not selected. (If nothing is selected, all 

project layers will be hidden.)

• Lock Others’ Layers: Locks the layer of the elements that are not selected. (If nothing is selected, all 

project layers will be locked.)

• The Undo Quick Layer Actions command undoes the last Quick Layer action (up to 10 actions).

• The Redo Quick Layer Actions command redoes the last undone Quick Layer action (up to 10 actions).
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Layer Combinations

Layer Combinations are named sets of Layer settings.

For example, you can set up a “Show All, Lock 3D Elements” Layer Combination, in which all the layers are 

visible, yet all Layers assigned to 3D model elements are locked, making those elements uneditable. You 

might use this Layer Combination when working with 2D only functions, such as dimensioning, to prevent 

inadvertent modifications to the building elements.

Each view can have a different Layer Combination, set in View Settings.

See View Settings Dialog Box.

ARCHICAD comes with a default set of Layer Combinations. Layer Combinations are listed on the left panel 

of the Layer Settings Dialog Box; individual Layers are listed on the right.

The currently active Layer Combination is shown as selected.

Apply a Layer Combination

To apply a Layer Combination to the project, do one of the following:

• Use the Layer Combination pop-up control from the Quick Options Bar at the bottom of the model window. 

• Open the Layer Settings Dialog Box. Select a Layer Combination from the list in the left panel, then click 

OK to close the dialog box.

• Go to Document > Layers and click on any of the Layer Combinations listed there.
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Create New Layer Combination

To create a new Layer Combination:

1. Open the Layer Settings Dialog Box.

2. As needed, set the state (locked/unlocked, shown/hidden, solid/wireframe) of the individual layers, listed 

on the right. Use the sorting and selection controls to set the state of several layer at the same time.

See Layer Settings Dialog Box for details on these controls.

3. Click the New button (below the list of Layer Combinations) and give the new set a unique name in the 

appearing dialog box.

Modify Layer Combination

To modify an existing layer combination:

1. Select the Layer Combination from the list on the left

2. Make the necessary adjustments to individual layers on the right

3. Click the Update button.

Note: This function is also available in Attribute Manager: See Layer Combinations and Layers (Attribute 

Manager).

Modify Layer’s Status in Multiple Layer Combinations

By selecting an individual Layer from the Layer list (on the right side of the Layer Settings dialog box), you can 

modify its state in the various defined Layer Combinations (on the left).

For example, below we selected the Interior - Stair Layer on the right. In the left, you can now see the layer 

states for the Interior - Stair Layer as defined for each Layer Combination.
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On the Layer Combination side, you can directly change the Interior - Stair layer’s state (e.g. from Show to 

Hide) in any or all Layer Combinations: just go down the list of Layer Combinations one after the other, and 

click the Interior - Stair Layer’s status icons as necessary. The Layer Combinations are now redefined 

accordingly. (You don’t have to click Update.)

Note: This function is also available in Attribute Manager: See Layer Combinations and Layers (Attribute 

Manager).

Find and Select Elements based on Layer Combination

The Find and Select function (Edit > Find and Select) enables you to set up criteria by which to find and 

select elements in the project.

See Find and Select Elements.

One such criterion you may use is “Layer Combination”. In the Find and Select dialog box, add the criterion 

“Layer Combination” and then choose one of the defined Layer Combinations of your project. This means the 

program will find and select the elements which are visible according to the Layer Combination you have 

chosen.
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Use Layers to Prevent Intersections

You can use Layers to control element intersections. 

Intersecting elements that belong to the same Layer Intersection Group will connect to each other, provided 

they are drawn correctly. 

Elements on different Layer Intersection Groups will not connect.

Exception for 0: Elements which are both on intersection group 0 (whether on the same or different 

layers) will NOT intersect.

By default, every layer is set to Group 1, so all intersecting elements will be joined according to the regular 

connection rules for ARCHICAD.

Edit Layer Intersection Group Number

Go to the Layers panel of Layer Settings (Document > Layers > Layer Settings)

Edit the value under the intersection icon. All elements on this Layer use this Layer Intersection Group.

Note: Layer Intersection numbers have nothing to do with element priorities; they serve merely as tags or 

labels (e.g. 1 or 2) for grouping elements.

Note: Two elements that are both set to intersection group 0 will NOT intersect.

Prevent Element Connections: Assign Separate Layer Intersection Groups 

You may want to prevent element connections - for example, to show the details of composite walls. In this 

case, place the intersecting walls on different layers, and then give one of these a layers a different Layer 

Intersection Group number.
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Wall Layers Have Different Intersection Group Numbers: No Connections

Wall Layers Have Identical Intersection Group Numbers: Walls Connect

Note on Intersection with Hidden Layer: Elements having identical intersection groups will intersect even 

if one of the layers is hidden. This may result in “missing” lines, indicating an intersection with an element 

on a hidden layer. To avoid this, go to Layer Settings, select one of the layers, and assign it any different 

intersection group.

Related Topic:

Line Elimination Between Model Elements
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Use Separate Layer Settings for the Layout Book

While each ARCHICAD project has only one Layer set, the settings of any particular layer (for example its 

show/hide or locked/unlocked status) can be different in the Layout Book and in Model Views. The settings 

variation you see in the Layer Settings Dialog Box (either Layout Book or Model Views) depends on which 

window is active when you open Layer Settings. Both the Layer Settings command and the dialog box are 

labeled accordingly.

See Layer Settings Dialog Box.

Important: Layer settings for the Layout Book serve to show/hide elements directly placed on layouts, 

such as lines, texts and drawings as a whole. Layout Book layers do not affect the drawing content, which 

is determined by the layers of its associated view.
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Place All Elements on a Single “Active Layer” (Simulate AutoCAD Work 

Methods)

If you wish to simulate AutoCAD work methods, the Active Layer command is an easy way of assigning a 

single default layer to all tools, instead of than using ARCHICAD’s default layer set-up.

Choose Document > Layers > Layer Extras > Active Layer from the menu and choose the One Active 

Layer for all Element Types option from the appearing palette.

This will set the default layer of all element types to the layer of the currently active tool (regardless of any 

selection). All Tool Settings dialog boxes will now use the same default Layer definition and successive 

elements will all be placed on that layer, regardless of type.

You can override this setting manually for selected elements.

If you wish to return to the previous layer state, choose the Individually Set Layers option. The last set of 

manually defined layers will be used.
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Lines

Lines are assigned to each ARCHICAD construction element in its own Tool Settings dialog box, depending 

on the element type.

For example, when defining how a Column should be displayed in a 2D window, you will apply different lines 

for its core outline, for its overhead display and for its crossing symbol.

The line types available in the element Settings dialog boxes are defined and managed as the project’s Line 

attributes, in Options > Element Attributes > Lines.

Use the Lines Dialog Box to modify the standard lines (solid, dotted, dashed, etc.) and define customized 

lines.

See Lines Dialog Box.

Read More on Help Center
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Line Weight Display

By default, all lines will be displayed at Hairline width, at one pixel wide.

In addition, you can enable Bold Cut Lines (View > On-Screen View Options); this will show all Cut lines as 

bold (two pixels wide, regardless of the line’s true pen weight). All other lines will be shown at Hairline width.

The alternative to Hairline weight is display each pen’s True Line Weight: enable Line True Weight in View > 

On-Screen View Options. Each line’s pen weight (depending on its pen weight value as defined in the Pens 

and Colors dialog box) will be displayed accurately.

See On-Screen View Options.
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Fills

ARCHICAD includes a predefined set of default fills.

Use the Options > Element Attributes > Fills dialog box to define and/or edit fills and patterns, and determine 

the category of each particular Fill (Drafting Fill, Cut Fill, and/or Cover Fill).

Related Topics:

Fills

Full Set of Project Fills

Defining Fill Availability in Pop-Ups

Fill Categories

Create New Solid Fill

Edit Vectorial Fill Pattern

Set Orientation of Vectorial or Symbol Fill Patterns

Create Symbol Fill

Using Gradient Fills

Create or Edit Image Fill

Delete and Replace Attributes in a Model
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Building Materials

A Building Material is a “super attribute”, a combination of multiple attributes having defined properties. All 

model elements use Building Materials instead of Cut Fills.

Building Materials are also available for Stairs, Railings, profile elements, and certain Library Parts (in the INT 

Library: those in the Building Structures Folder and RoofMaker Library Folder).

Building Materials are defined globally, in the Building Materials dialog box, then applied to construction 

elements in their own Settings dialog boxes, or used as components of Composite Structures and Complex 

Profiles. Editing the Building Material attribute makes changes throughout the model.

Building Materials can be Classified, and properties can be assigned to them.

A number of Element-level overrides are available to allow for flexibility in the display of individual Elements, 

including:

• Element Cut Fill Pen overrides, including background, foreground or both

• Surface overrides on each face (including an extrusion override for Profiled elements)

For more information, see Override Surfaces With Surface Painter.

The Building Material combines the following:

• Cut fill

• Cut fill pens (foreground/background)

• Intersection Priority
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• Fill orientation (if used for a composite or complex element)

• Surface

• Classifications and Properties, including Physical Properties

Use Options > Element Attributes > Building Materials to define, edit, duplicate, rename or delete Building 

Materials.

Related Topics:

Building Materials Dialog Box

Exempt Building Material from Collision Detection

Line Elimination Between Model Elements

Delete and Replace Attributes in a Model

Watch the Video
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Composite Structures 

Walls, Slabs, Roofs and Shells can be defined as composite structures.

Assign a Composite Structure to a Wall, Slab, Roof or Shell

1. Open the Element Settings dialog box for the element type.

2. In the Geometry and Positioning Panel, define the element’s structure as a composite by clicking on the 

“Composite” icon.

3. Use the pop-up below to choose a composite structure. Notice the icon that indicates whether the 

selected composite contains a Core or not. (In this image, the icon indicates “No Core”.)

Note: Composite Structures are defined for specific element types: Wall, Slab, Roof, and/or Shell, by the 

“Use With” control, in the Options > Element Attributes > Composites. The composite structure pop-up 

in element Settings shows only those Composite Structures whose “Use With” control includes the 

element type you are defining. Composites are defined at Options > Element Attributes > Composites

See Composite Structures Dialog Box.
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• You can also edit a selected composite by accessing its settings from its context menu:

4. The chosen composite structure is applied to the currently selected or created element.

Note: The view’s model’s Partial Structure Display settings will affect the display of composite elements.

See Partial Structure Display.

Components of Composite Structures

The layers of the composite element are called “skins”; a composite structure can have up to 48 skins.

The skins are separated by “separator lines”; and the outline of the composite is the “contour line.”

Composite elements can include one or more structural skin called a Core, although defining a Core skin is 

not required.

The skins you define as “Core” or “Finish” will also affect views in Partial Structure Display.

See Partial Structure Display.

Assign these definitions in the Options > Element Attributes > Composites.

See Composite Structures Dialog Box.

Note: This function is also available in Attribute Manager: See Composites (Attribute Manager).
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Pen Sets

ARCHICAD comes with several predefined Pen Sets. These are listed and managed Options > Element 

Attributes > Pens & Color. 

or

Document > Pen Sets > Pens & Color.

You can just use the default pen set, or you can apply a different Pen Set for your project, depending on the 

purpose of the current output.

The Layout and Model can refer to different pen tables. This means that you can define a separate set of pens 

to use on Layouts for the best printing and plotting results.

Note: The Layout’s Pen Set affects elements placed directly on the Layout (such as Master Layout items 

like the Title Block). The Drawing’s pen set affects the content of placed drawings and is assigned in 

Drawing Settings.

To assign a pen to an element, open the pencolor pop-up (in the element settings dialog box or in the Info 

Box of a selected element) and choose the desired pen for the element or one of its components - such as the 

cut line pen assigned to the slab in the following image:

The available pens in these pop-ups are derived from the Pen Set currently applied for this project.

Apply a Pen Set

Redefine a Pen Set

Pens & Color Dialog Box

Read More on Help Center
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Apply a Pen Set

To choose and apply a pen set, do one of the following:

• Use the Pen Set pop-up from Quick Options:

• Options > Element Attributes > Pens & Colors 

• Document > Pen Sets > Pens & Colors

Select a pen set from the “Available Pen Set” list and click OK.

See also Pens & Color Dialog Box.

Apply a Separate Pen Set for the Layout Book

You can use a separate pen set for your Model Views and your Layout Book: the name of the dialog box 

includes either “Model Views” or “Layout Book”, depending on which type of window is active.

The Pens & Colors (Layout Book) settings are applied only to items placed onto the Layout (such as Autotext 

and Master Layout items), but not to the content of placed Drawings.
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Apply a Pen Set to a Drawing

When you place a view onto a Layout, it becomes a Drawing. By default, the Drawing placed in the Layout 

Book uses its own pen set (the one saved in the source view’s View Settings - by default, the pen set defined 

for the project’s Model Views). However, you can override this pen set in the Size and Appearance Panel of 

Drawing Settings. Click the Pen Set drop-down menu and choose a different pen set, for this drawing only.

See Drawing Size and Appearance Panel.

Drawings that have their source in external files - such as DWG/DXF/PDF files placed using ARCHICAD’s 

Drawing tool - can be assigned pen sets the same way: click the Pen Set drop-down menu and choose a 

different pen set, for this drawing only.

Alternatively, you can change the source view’s pen set: go to its View Settings Dialog Box and choose a 

different Pen Set from the pop-up.

See View Settings Dialog Box.
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Redefine a Pen Set

The predefined Pen Sets shipped with ARCHICAD are based on common workflows.

See Pen Sets for an overview of the logic behind predefined pen sets.

However, you can use the Pens & Colors Dialog Box to

• redefine or rename any pen set together with its description 

• redefine any pen’s line weight or color, using the Edit Color control

See Pens & Color Dialog Box.

Note: This function is also available in Attribute Manager: See Pen Sets and Pens (Attribute Manager).

Pen numbers remain constant even if you change pen sets.

After redefining a color or changing the Pen Set, the ARCHICAD construction elements immediately change 

to the new colors on the Floor Plan. The 3D window, 3D Document and Section/Elevation/IE/Worksheet 

windows may require that you rebuild the view.
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Surfaces

The following sections describe how to work with Surfaces in ARCHICAD:

About Surfaces

Override Surfaces With Surface Painter

Override Surfaces in Element Settings

Align 3D Texture

Default Texture Alignments/Reset Texture

Display of Surfaces in Renderings

Surfaces Dialog Box
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About Surfaces

To display your plan realistically, you can apply surfaces to your elements. Surfaces contain color, texture and 

light effects. Surfaces can be displayed in the 3D Window, Section/Elevation/IE and 3D Document windows, 

and in PhotoRenderings.

The ARCHICAD Library contains hundreds of preconfigured surfaces for every need. You can also access 

additional surfaces on BIM Components, using the Surfaces dialog box.

See Create, Load and Share Surfaces (All Engines).

Surfaces can be created or modified in the Surfaces Dialog Box (Options > Element Attributes > Surfaces). 

Surfaces defined here are then assigned to construction elements through Building Materials (which include a 

Fill and a Surface).

Note: Surface definition is also available in Attribute Manager: See Surfaces (Attribute Manager).

Once you assign a Building Material to an element, the element will use the Surface of the Building Material. 

You can, however, override the Surface at the element level (use either Surface Painter or the Override 

Surface controls in the Model panel of element settings).

See Override Surfaces With Surface Painter and Override Surfaces in Element Settings.

Some surfaces have vectorial hatching and/or textures as part of their definition, as indicated by icons. This 

surface, for example, can display either a vectorial hatching or a texture:
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Assign a Vectorial Hatching to a Surface

Vectorial Hatching is a vectorial fill pattern used with a Surface. In the Vectorial Hatching panel of Surface 

Settings, choose a vectorial hatching from one of the project’s defined vectorial fill types.

See Surface Vectorial Hatching Panel (Basic Engine).

Note: When assigning a 3D Vectorial Hatching in the Surfaces dialog box, you can access only fills 

defined as Cover Fills.

Assign a Texture to a Surface

Textures are image files that can be assigned to surfaces to give them a more realistic look and feel. They 

are displayed in PhotoRenderings, and in the 3D window using the OpenGL Engine.

By default, many ARCHICAD surfaces have textures assigned to them (such surfaces will have a texture icon 

next to their name.) You can load additional textures from the ARCHICAD library, or load other custom 

images. Textures are assigned and edited in the Texture Panel of Surface Settings.

For information on using textures with Cineware surfaces, see Textures (Cineware Surfaces).

To edit the display of visible Textures in the 3D window, see Align 3D Texture.

See also Default Texture Alignments/Reset Texture.

How to Display Vectorial Hatching and Textures in 3D Window

To display Vectorial Hatching:

• use the Vectorial Engine (View > 3D View Options)

• the Vectorial Hatching checkbox in 3D Styles must be On

To display Textures:

• use the OpenGL engine (View > 3D View Options)
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• make sure the Textures box is checked in OpenGL options (click Advanced Options from 3D Styles).

Note: You can customize the orientation and origin of textures in 3D views.

See Align 3D Texture.

Note on the GENERAL Surface

The GENERAL Surface is only available for Building Materials, Element Surfaces and GDL. When a Surface 

is defined as “GENERAL”, it will display a solid color based on an Elements’ Uncut Line Pen.

By default, this General Surface will be assigned to new Building Materials and to new Surface parameters 

added within GDL. It is used to avoid assigning to an incorrect Surface or creating a missing attribute. It is 

hard coded into ARCHICAD and is not available in the Surfaces dialogue or Attribute Manager.
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Override Surfaces With Surface Painter

For a model element, the surface setting depends on its Building Material, which includes a surface.

See Building Materials.

You can override a construction element’s Building Material surface definition, and assign a different surface 

(or surfaces).

Although GDL objects do not use Building Materials, you can still change their surface definitions.

There are two workflows for overriding an element surface:

• Use Element Settings (see Override Surfaces in Element Settings)

• Use the Surface Painter palette, described below.

Note: Before using the Surface Painter feature, make sure you are not working in “legacy” intersection 

mode. (Uncheck this option at Options > Project Preferences > Legacy.)

Watch the Video

Override Single Element with Surface Painter

1. Activate the 3D window.

2. Open the Surface Painter palette (Window > Palettes > Surface Painter).

For more information on the palette and its controls, see Surface Painter Palette.

3. Choose the surface you want to use as an override. Do one of the following:

– In the content pane of Surface Painter, click on a surface to select it

– Alternatively, click the Pick up Surface icon in Surface Painter, then click on any element surface in 

the 3D window to select it in Surface Painter.
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4. By selecting the surface to use as override, you automatically enter Paint mode (the paintbrush icon at the 

top of the palette is enabled).

Note: The default Paint Mode means that you will exit Paint Mode automatically after a single painting 

interaction. If you wish to paint multiple items without exiting Paint Mode, use the Infinite Paint mode: See 

“Infinite” Paint Mode, below.

Note: While you are in Paint mode, click Alt at any time to enable the Pick up Surface function. This way, 

you can paint using a picked-up surface.

See also Search for Surface.

5. Hover your cursor over the surface you wish to override. Notice the feedback:

– The hovered face of the element whose surface will be overridden is highlighted.

– Next, the highlighted face changes temporarily, to give you a preview of what it will look like after you 

click.
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– The Info Tag shows which surface will override which. As needed, click Tab to cycle among the faces, 

or to select all faces/edges.

Note: If the clicked element has faces using several different surfaces, you can choose “All Similar 

Faces”: that is, you will override not just the clicked face, but all element faces which use the same 

surface. 

 

 

6. Click with the paint cursor to override the surface of the clicked element (or one of its faces).

The result is also shown in the PhotoRendering Palette preview (if the preview is set to Auto Refresh).

7. You now automatically exit Paint Mode. 

Note: If want to keep painting without exiting automatically, you should use the “infinite” Paint Mode, 

described below.

Further Notes on Surface Painter Overrides

• If you override edges, all the edges are overridden uniformly, including any custom edges of a roof or slab.

• If you change any surface in a GDL object, all parts of the GDL object which use that surface will be 

changed uniformly. In other words, you cannot paint only a particular face of a GDL object; only the “All 

Similar Faces” option applies.

• GDL objects whose surface depends on a custom Model View Options definition cannot be overridden 

using Surface Painter.

• For Profile elements: The same override options are available as in the Model panel of element Settings: 

“Extrusion surface” and “Ends surface.” Varying extrusion or end surfaces cannot be overridden 

individually.
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“Infinite” Paint Mode

Before beginning to paint, set the Paint Mode icon to its “infinite” mode.

Use this Paint Mode if you want to paint a whole series of elements using Surface Painter. This way, you will 

not exit Paint Mode until you do so explicitly.

Exit Paint Mode

Do one of the following:

– press Esc

– press Cancel from the context menu

– click the Paint mode toggle in Surface Painter

You only need to exit if you are in “infinite” Paint Mode. If you use the default Paint Mode, you will exit 

automatically.

Paint mode is temporarily suspended while you navigate (zoom, pan, orbit) in the window.

Override Multiple Selected Elements with Surface Painter

1. Activate the 3D window.

2. Open the Surface Painter palette.

For more information on the palette and its controls, see Surface Painter Palette.

3. Select the elements whose surface you wish to override. Do one of the following:

– From the 3D window, select each element you need, one after the other, or

– Alternatively, select all project elements that use a particular surface: right-click the surface from the 

content list and use the Select all elements using... command.
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Note: To find a particular surface in the Surface Painter content list, you can use the Pick Up Surface 

function on an element which uses that surface.

4. All surfaces of all selected elements are now listed in the Selection Panel of Surface Painter. (The number 

of selected elements, and the number of surfaces, is shown.)

5. From the Content Panel (listing all project surfaces), choose the desired new surface. 

6. In the Selection Panel, click the surface that you wish to override. 
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That surface is now overridden on all selected elements.

7. Exit Paint mode. (See Exit Paint Mode.)

Remove Surface Overrides from Selected Elements

To remove surface overrides and return the elements to using the surfaces defined in their Building Materials:

1. In the 3D window, select all the elements from which you want to remove overrides.

2. From the Surface Painter’s Selection Panel, click the black arrow and use the Remove All Surface 

Overrides command.

Note: GDL-object type elements do not use Building Materials. Consequently, any overrides applied to 

those objects are not affected by the Remove All Surface Overrides command. To change their 

surfaces, use Object Settings.
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Surface Painter Palette

Use the Surface Painter as an easy way to override the surfaces of your project elements.

For a step-by-step workflow, see Override Surfaces With Surface Painter.

Watch the Video

Open Surface Painter

Open the Surface Painter palette from one of the following locations:

• Window > Palettes > Surface Painter

• Document > Creative Imaging > Surface Painter

• the Surface Painter command of the 3D Visualization toolbar

Note: Before using the Surface Painter feature, make sure you are not working in “legacy” intersection 

mode. (Uncheck this option at Options > Project Preferences > Legacy.)

Content Panel of Surface Painter

By default, the Content Panel of Surface Painter (at left in the image below) lists all the surface attributes of 

the current project.

The content displayed can vary if you have entered a search term. (See Search for Surface.)
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Double-click any surface to open its Surfaces dialog box.

Content Panel Lists All Surfaces of Current Project

• The Paint mode icon is active when you are in Paint mode. (See Override Surfaces With Surface 

Painter.)

• Use the Pick Up Surfaces command to click any project element to select its surface in the Surface 

Painter.

• Use the Search field to narrow the set of displayed surfaces and/or to add new surfaces to your project. 

(See Search for Surface and Add Surface to Project, below.)

• Use the commands of the pop-up menu to customize palette display. (See Customize the Surface 

Painter Palette, below.)

Selection Panel of Surface Painter

When any element is selected in the project, all surfaces of all selected elements are displayed in the 

Selection Panel of Surface Painter (at right, in the image below).

The number of selected elements and the total number of their overridable surfaces is also shown. 
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Double-click any surface to open its Surfaces dialog box.

Selection Panel Lists All Surfaces of All Selected Elements

You may not be able to override a particular selected surface: for example, if the element or its layer is locked. 

In this case, a yellow info warning appears.
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Open/Close Selection Panel

Double-click the splitter bar between the two panels to open/close the selection panel (or click the black arrow 

at the top of the splitter bar).

Customize the Surface Painter Palette

Use the options in the pop-up to customize the display of the Surface Painter:

• Display surface previews for either Cineware or OpenGL engines

• Choose preferred size of surface icons

• Choose how to arrange the two panels: horizontal or vertical
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Search for Surface

Use the search field at the top of the palette to locate a particular surface. Depending on the pop-up control at 

right, the engine will search in one of these ways:

• Search Project: Searches among all the surface attributes of this project

• Search Loaded Catalogs: Searches in surface catalogs added to the Library Manager

• Search BIM Components - Searches only on BIM Components, an interactive depository of objects and 

surfaces contributed by ARCHICAD users or uploaded by GRAPHISOFT.

For more information, see BIM Components.

The last four searched items are listed in the search history.

Click Clear Search to return to the full content panel.

Add Surface to Project

If you choose a surface from a loaded catalog (marked with a folder icon), click the appearing Add to Project 

button. 

Note: In Teamwork, the Add to Project function is available only if you have the “Create Surface” 

permission. 
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This action does the following:

• Adds the surface to your project’s surface attributes

Note: Since a surface also includes a vectorial hatching, adding a new surface to the project might result 

in adding a new fill attribute, too: if a fill with the exact same name is not already part of the project, it will 

be added as a new one.

• Enters Paint mode

To add a surface found from the BIM Components Portal (marked with a globe icon), click the appearing 

Download and Embed button.

Note: In Teamwork, this function is available only if you have the “Create Surface” permission. 

For more information, see Results from BIM Components Portal.
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Override Surfaces in Element Settings

For a model element, the surface setting depends on its Building Material, which includes a surface.

See Building Materials.

However, for any model element, you can override the Building Material surface definition, and assign a 

different surface (or surfaces).

GDL objects do not use Building Materials, but you can override their surface definitions.

There are two workflows for overriding an element surface:

• Use the Surface Painter palette (See Override Surfaces With Surface Painter)

• Use Element Settings as follows:

1. Select a placed element, or open the Default Settings dialog box for the element type.

2. In the Model panel, under Override Surfaces, click the toggle button of any or all of the surface pop-ups. 

Each pop-up corresponds to a face or edge of the element.

Note: Clicking the Chain icon (“Link Surfaces”) means that all of faces/edges will use a single surface 

override. To set a separate surface for any single face/edge, unlink the surface definitions by clicking the 

chain again.

To remove an override, just click the toggle button again. The surface defined in the Building Material is now 

used again.

See also Remove Surface Overrides from Selected Elements.
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Align 3D Texture

Use the commands at Document > Creative Imaging > Align 3D Texture to edit the origin and direction of 

construction element textures in 3D views.

These commands are only available in the 3D Window on selected construction elements whose Surface 

attribute includes a Texture assignment (Options > Element Attributes > Surfaces).

Notes:

- Not available for Shells.

- Texture realignment on elements with a Complex Profile might produce unexpected results.

For extra texture editing options on Morph faces, see Morph Texture Mapping and Alignment.

See also Default Texture Alignments/Reset Texture

Topics in this Section:

Set Texture Origin

Set Texture Direction

Reset Texture

Align Edge Texture (Walls Only)

Set Texture Origin

In this example, the brick wall texture originally looks like this:

To reset the texture origin to the corner of the wall - so that the brick pattern starts from the corner - do the 

following:

1. Select the wall

2. Use Document > Creative Imaging > Align 3D Texture > Set Origin. 

3. Click on the corner and view the result.
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The texture origin will affect all of the elements’ surfaces. You cannot, for example, use a different origin for 

the inside and outside surfaces of a wall.

Set Texture Direction

1. Select one or several elements.

2. Use Document > Creative Imaging > Align 3D Texture > Set Direction.

3. Click on a surface of a selected element. You must click a “main” surface, not an edge. (For Columns, the 

editable “main” surface are the top and bottom surfaces.)

4. In the dialog box that opens, choose to either define the texture’s angle graphically or numerically. 

5. Click OK.

6. If you chose to define the angle graphically, draw the desired vector for the texture orientation. You can 

snap to element hotspots.

7. If you define the angle numerically, it will be applied relative to the default orientation of the Texture and 

measured counterclockwise.

Note: For Slabs and Roofs, texture direction will change automatically if you edit the element shape. 
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Reset Texture

To return to the default Texture settings, select the element, open its Settings dialog box and go to the Model 

panel. The Custom Texture information text is active. Click the Reset Texture button to discard the 

customization.

You can also select several elements and choose the Reset command in the Document > Creative Imaging 

> Align 3D Texture hierarchical menu.

To remove all texture customization of the elements of the 3D Window, do not select any of them and choose 

Document > Creative Imaging > Align 3D Texture > Reset All.

See also Default Texture Alignments/Reset Texture.

Align Edge Texture (Walls Only)

You can align the texture of a Wall edge only: Use the “Align Texture to Wall Edges” checkbox in the Model 

panel of Wall Settings.

See Wall Model Panel.

Note: Using the Align Texture command (Document > Creative Imaging) will override any other Wall 

texture settings, including the Align Texture to Wall Edges checkbox.
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Default Texture Alignments/Reset Texture

Default texture alignments vary by element.

The “Reset Texture” command is available for selected elements if you have changed their texture 

alignments, either by using the Align 3D Texture command, or (as with Slabs and Roofs) by editing element 

shape.

The following table indicates how textures are aligned (by default and after reset).

Related Topics:

Align 3D Texture

How to Display Vectorial Hatching and Textures in 3D Window

Element Default Texture Alignment “Reset Texture” Result

Wall/Beam Parallel to Reference Line Parallel to Reference Line

Column Perpendicular to Reference Line Perpendicular to Reference Line

Slab Aligned with longest edge Realigns with longest edge

Mesh Aligned with longest edge Realigns with X Axis

Single-plane Roof • Parallel to Pivot Line 

The tile texture on a slanted roof 

always faces downward (as you 

draw the pivot line from A to B, the 

right-hand side is “downward”).

• Realigns automatically after 

editing Roof contour

For angled roof: Realigns parallel to Pivot 

Line

For flat roof: Realigns to longest edge

Zone • Aligned with longest edge

• Realigns automatically after 

editing Roof contour

N/A
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Display of Surfaces in Renderings

Different Rendering Engines have different capabilities for displaying surfaces. Choose your intended 

Rendering Engine in the Surfaces dialog box.

See Surfaces Dialog Box.

This way, only those controls will be available in Surfaces that will actually affect the final rendered 

appearance.

Important: All surfaces are specific to the engine for which they are set up. If you change a surface 

parameter for one engine, those modifications will not take effect for the same surface parameter if you 

switch to another engine.

Commands are available to synchronize basic surface appearances between engines.

See Match Cineware Settings with Basic Engine.

Related topics:

Surfaces (Cineware)

Match Settings with Cineware Surfaces

Surface Exposure to Light Panel (Basic Engine)

Surface Vectorial Hatching Panel (Basic Engine)

Surface Texture Panel (Basic Engine)
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Attribute Manager

Open the Attribute Manager from Options > Element Attributes > Attribute Manager.

Use this dialog to

• List and edit the attributes of your current project

• Import attributes from another project or XML file; edit and add them to current project attributes

• Save any set of attributes as an XML file

Topics in this section:

View Attribute Lists by Type

Temporary List in Attribute Manager (Right Side)

Associated Attributes

Attribute Index Number

Checked Attributes

Search for Attributes

Attribute Management Commands

Save Attribute List

Revert Changes in Attribute Manager

Attribute Manager: Editable Attribute Parameters

View Attribute Lists by Type

Attribute Manager displays each attribute type on a separate tab page. 

Click an icon at the top of the dialog box to switch to the corresponding attribute list. 
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For example, click the Fill icon to list the current project’s Fills, on the left side of the Attribute Manager:

Display Fills of Current Project (left side)

• To sort an attribute list by a particular criterion, click the top of the desired column. For example, you can 

display pens by line width, or cities by latitude.

• The All tab combines all the project attributes into one list

• The Changes tab lists all pending changes to the current Project’s attributes, as long as you have not yet 

closed Attribute Manager. (See Revert Changes in Attribute Manager.)

• Clicking OK (in any tab of Attribute Manager) brings up a warning to confirm and apply the changes.
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Associated Attributes

Fills, Surfaces, Building Materials, Composites, and Profiles have other attributes associated to them (e.g. a 

Building Material with its Fill and Surface definitions). For each attribute type, the full hierarchy of these 

associated Attributes is also listed in Attribute Manager:

Associated attributes are read-only in Attribute Manager, but if you click on one, the relevant Attribute tab 

opens immediately.

Attribute Index Number

Elements refer to attributes by their index number. To edit it, click Reindex.

Checked Attributes

A listed attribute has a checkmark if it is used in the current project:

• by placed elements

• by Favorite and Tool Default Settings

• in other Attributes (e.g. a Fill used in a Building Material)
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Note, however, that an attribute shown as unused (without a checkmark) may in fact be referred by the GDL 

script of a placed object.

The “used with” checkmark is not available for the following Attributes: Layer Combinations, Pen Sets, Pens, 

Cities.

See also Purge (Project Attributes only).

Temporary List in Attribute Manager (Right Side)

The right side of Attribute Manager is the “Temporary” list of attributes. Use this interface (on the right side) to 

transfer Attributes to and from the current project’s attribute set (on the left side).

You can edit and manage attributes in the Temporary list similarly to those of the Project list.

See Append/Overwrite Attributes Between Lists.

However, the Temporary list is cleared after you close Attribute Manager. 

Search for Attributes

Enter any search term to locate Attributes on the current tab page, on either or both sides of Attribute 

Manager. This does not search among the Associated Attributes.

Note: To search for specific layers, make sure you first click in the “Layers” list to make it active.

Use the icons at the left of the Search field to filter: Search Both Sides, or Right/Left Side Only.
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Click the X button to clear the search.

Search for Attributes: Both Sides
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Attribute Management Commands

Use the command button in the middle of the dialog box to manage attributes from the lists on both sides of 

Attribute Manager.

Any changes you make in Attribute Manager which affect the current project’s attribute set are listed on the 

Changes tab and can be reverted, until you close Attribute Manager.

See Revert Changes in Attribute Manager. 

Clicking OK (in any tab of Attribute Manager) brings up a warning to confirm and apply the changes.

Attribute Manager commands apply to either the Project Attribute list (on the left) or the Temporary List (on the 

right) depending on which list is active.

Commands to Manage Project Attribute List (left side)
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Commands to Manage Temporary Attribute List (right side)

Append/Overwrite Attributes Between Lists

Use the following three commands to add Attributes from the Project List to the Temporary List and vice versa.

Append

Adds the attribute from one list to the bottom of the other list, with a new index number. If an attribute of the 

same name already exists, a (1) will be appended to its name.

By Index

Overwrites the attribute in the other list that has the same index number. If the index doesn’t exist, a new item 

will be created with the same index number.

By Name

Overwrites the attribute in the other list that has the same name. If the name doesn’t exist, the attribute will be 

appended.
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• Include All Associated Attributes: For each of the three transfer commands (Append/By Index/By 

Name), you can check this to also add its associated attributes.

• Include All Associated Layers: For each of the three transfer commands on the Layer Combinations 

page: check this to include the Layers.
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Import Attributes to Temporary List

From the Temporary List side of Attribute Manager:

1. Click the Import button.

2. Browse for a file containing the ARCHICAD attributes you need (e.g. XML, .aat, or ARCHICAD project).

3. Click Open. 

The attributes of the imported file now appear, by type, on the right side (Temporary list) of the corresponding 

pages of Attribute Manager. 

Note: Remember, the Import command does not add any attributes to your current project.

Note on Import of Building Materials

When you import a file via Attribute Manager:
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The incoming Building Material attributes may include Classifications and Properties that already have 

defined values. 

But these values cannot be added to the host ARCHICAD project unless the referenced Classifications and 

Properties already exist in the host project.

Therefore, before importing such Building Materials, review their incoming Classifications and Properties, and 

ensure that they already exist in your project (use Classification Manager and Property Manager).

If they do not exist, you can create the missing Classifications and Properties, and then import the Building 

Materials. All the referenced values will come into the project.

Otherwise, the assigned values are lost.

Export Attributes to XML File

From the Temporary List side of Attribute Manager:

1. Select one or more attributes to export.

2. Click the Export button.

Duplicate

The Duplicate command adds the selected attribute - with a unique Index number - to the bottom of the 

current attribute list, where you can edit it further.

Delete/Delete and Replace

For items in the Temporary list (right side): Deletes attribute(s) from the Temporary list. 

For Project attributes (left side): Deletes attribute(s) from the project. 
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The Delete... button opens the Delete and Replace dialog for the following project attributes:

• Layers

• Lines

• Fills

• Surfaces

• Building Materials

• Profiles

• Zone Categories

Here, you can choose a replacement attribute in one step.

See Delete and Replace Attributes in a Model.

Notes: 

– Deleting a Pen Set means that all Pens that it contains become Undefined, in all Pen Sets. 

– Deleting a Pen from the Temporary list will make it undefined.

Purge (Project Attributes only)

Regardless of selection, this command removes all attributes in the list that are not currently used in your 

project - that is, all attributes that are listed without a checkmark.

The Purge command is grey 

• if all the attributes of the current type are in use

• for attribute types that don’t have checkmark feedback in Attribute Manager: Layer Combinations, Pen 

Sets, Pens, and Cities. 

Reindex

Elements refer to attributes by their index number. To edit it, click Reindex.

Save Attribute List 

Click Save as TXT to save the currently open page of attributes as a text file.

Note: The text file can be useful for using the Replace Attributes by File function, which automates the 

process of deleting and replacing attributes. This function requires generation of a text file in a particular 

format, and running a command that calls this file.

See a description of this process at Attribute Migration article on Help Center.
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Revert Changes in Attribute Manager

While you work in Attribute Manager, you can open the Changes tab to see all pending changes to the current 

Project’s attributes.

This tab is only active if there are changes pending.

Clicking OK (in the Changes tab or any other tab) brings up a warning to confirm and apply the changes.

Revert

If needed, select any or all changes, then click Revert to undo, as long as you have not yet closed Attribute 

Manager.

Apply All

This will finalize your pending changes, without closing Attribute Manager. A warning appears before changes 

are applied.
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Attribute Manager: Editable Attribute Parameters

In addition to managing the attributes (add/delete), you can use Attribute Manager to edit the properties 

themselves, as you would in the individual Attribute dialogs. This section describes the parameters editable in 

Attribute Manager, by type.

Click an icon at the top of the dialog box to switch to the corresponding attribute list.

Layer Combinations and Layers (Attribute Manager)

Pen Sets and Pens (Attribute Manager)

Lines (Attribute Manager)

Fills (Attribute Manager)

Surfaces (Attribute Manager)

Building Materials (Attribute Manager)

Composites (Attribute Manager)

Profiles (Attribute Manager)

Zone Categories (Attribute Manager)

Cities (Attribute Manager)

MEP Systems (Attribute Manager)

Operation Profiles (Attribute Manager)

Hints for Editing Attributes in Attribute Manager

• Multi-select attributes for faster editing of certain parameters, such as Color.

• Associated Attributes are listed where applicable, for info purposes, but not editable there. Double-click an 

associated attribute (e.g. an associated Fill) to open its relevant page in Attribute Manager, and edit it 

there.

• For attribute pages that contain two lists (top and bottom, e.g. Layer Combinations and Layers), dialog 

feedback helps you keep track of what you are editing. 

For example: If you select a Layer Combination (top half), this title is shown in bold: the focus of the dialog 

is now on the Layer Combinations list. The commands (e.g. Duplicate, Append) apply to the selected 

Layer Combination(s).

When you select a Layer (bottom half of dialog), the Layers title is now shown in bold: the focus of the 

dialog is on the Layers list, and the commands (e.g. Duplicate, Append) apply to the selected Layer(s). 

(The selected Layer’s Layer Combination is also shown in bold.)
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Layer Combinations and Layers (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

Layer Combination (Top half of dialog)

• Edit Name (single selection only)

• View Layer states in the bottom list

Layers (Bottom half of dialog)

Select one or more Layers to edit their parameters for the currently highlighted Layer Combination(s) 

(highlighted and shown in bold in the top list of Layer Combos):

• Edit Layer state (Locked/Unlocked, Show/Hide, Solid/Wireframe display in 3D)

• Edit Layer Intersection Number
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If multiple Layer Combinations are selected, some Layers may have various Layer states, as indicated by the 

icon:

If you assign a Layer state here (e.g. set it to Show), it will be applied for this Layer in all selected Layer 

Combinations.

Notes: 

– The ARCHICAD Layer cannot be deleted.

– Layers support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Layers.
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Pen Sets and Pens (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

Select a Pen Set to display its pens in the bottom half of the dialog. 

Every Pen Set must contain 255 Pens. 

Pen Sets (Top half of dialog)

• Edit Name (single selection only). Use context menu to copy/paste text.

• View the Pens it contains in the bottom list (Pens).

Save Pen Set in STB Format

Use Save as STB to save any single selected pen set in the format of AutoCAD Plot Style Table (*.stb). 

The Plot Style Table is used by AutoCAD to map each color in your drawing to line widths on printed/plotted 

output.
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Pens (Bottom half of dialog)

For a selected Pen Set (highlighted and bold in the list above), view and edit its Pens in the list below.

• Edit Name (single selection only). Use context menu to copy/paste text.

You can multi-select Pens to edit them together:

• Color: Double-click the Color swatch to edit.

• Edit Description

• Pen Weight: Set in either mm or pt, as defined in the Options > Element Attributes > Pens Colors dialog. 

Notes: 

– The attribute management commands are not available for individual Pen attributes of the project.

– You can delete a Pen from the Temporary list: this will make it undefined, and shown in grey.

– The project must contain at least one Pen Set.

See also Pens & Color Dialog Box.
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Lines (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

• Edit Name (single selection only)

• Scale: Enter a scale, if you want to save a scale for this Line. Otherwise, the Line will be scale-

Independent. 

Notes:

– The Solid Line cannot be deleted.

– Lines support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Lines Dialog Box.
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Fills (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

• Edit Name (single selection only)

• Fill Category: Use the three icons (Drafting Fill/Cover Fill/Cut Fill) to edit the Fill’s Category. This setting 

determines the Fill’s availability in Fill chooser pop-ups throughout the ARCHICAD interface. See also 

Defining Fill Availability in Pop-Ups.

Notes: 

– The following Fills cannot be deleted:

- 25%, 50%, 75%

- Background

- Foreground

- Linear Gradient Fill

- Radial Gradient Fill

– Fills support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Fills.
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Surfaces (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

• Color: Double-click the Color swatch to edit (multi-select available).

• Edit Name (single selection only)

• Fill: Click the pop-up arrow to assign the vectorial hatch

• Texture: Click the pop-up arrow to see the name of the assigned Texture, to remove it, or to browse for a 

different one

– Surfaces with a missing texture are indicated with a red texture icon

Associated Attributes of a selected Surface:
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• Vectorial hatch of the Surface

Notes: 

– The project must contain at least one Surface.

– Surfaces support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Surfaces Dialog Box.
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Building Materials (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

Select one or more Building Materials.

• Edit Name (single selection only)

• Edit Fill and Surface: Click the respective pop-up arrows to choose among Fills or Surfaces

• Edit Intersection Priority

Associated Attributes of each selected Building Material:

• Cut Fill 

• Surface

– Vectorial hatch (Fill)

Notes:

– The project must contain at least one Building Material.

– Building Materials support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Building Materials Dialog Box.
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Composites (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

Select one or more Composites. 

Each Composite’s “Use With Element type” definition (Wall, Slab, Roof, Shell) is shown in the columns to the 

right, where you can edit them (multi-select available).

Associated Attributes for every skin of each selected Composite are listed at the bottom of the dialog:

• Building Materials

– Cut Fill

– Surface

- Vectorial hatch (Fill)

• Line of separator and contours

Notes:

– The project must contain at least one Composite.

– Composites support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Composite Structures Dialog Box.
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Profiles (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

Select one or more Profiles. 

Each Profile’s “Use With Element type” definition (Wall, Beam, Column, Railing, GDL object) is shown in the 

columns to the right, where you can edit them (multi-select available).

The Associated Attributes of each selected Profile:

• Building Materials

– Cut Fill

– Surface

- Vectorial hatch (Fill)

• Line

Notes:

– The project must contain at least one Profile.

– Profiles support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Profile Manager.
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Zone Categories (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

• Edit Color swatch

• Edit Code

• Edit Name

• Associated Zone Stamp (click the pop-up to choose another Zone Stamp) (single selection only)

Notes:

– The project must contain at least one Zone Category.

– Zone Categories support Delete and Replace. See Delete and Replace Attributes in a Model.

See also Zone Categories.
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Cities (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

Data from Cities attributes can be used as Location Data and to set Sun Position for 3D Projection Settings 

and Cameras.

See Use Predefined City as Location Data.

The following parameters can be edited for one City at a time

• Edit Name

• Latitude-Longitude data

• Time Zone (click arrow to choose from list)

Note: The project must contain at least one City.
ARCHICAD 24 Reference Guide 350



Attributes Configuration
MEP Systems (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

This page is available if you are using the MEP Modeler. (Activate the MEP Modeler Work Environment 

Profile.)

• Edit Name (single selection only)

Note: The project must contain at least one MEP System.
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Operation Profiles (Attribute Manager)

(Parent topic: Attribute Manager: Editable Attribute Parameters)

These are used with the EcoDesigner add-on.

• Edit Name (single selection only)

Note: The project must contain at least one Operation Profile.

See also Operation Profiles (Energy Evaluation).
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Missing Attributes

Although attributes are saved with the project, it can still happen that your project contains elements which 

refer to missing attributes. You will notice this in the element’s Settings dialog box, as in the case of the 

missing line type referenced by this door:

Missing attributes may occur:

• if you have copy-pasted elements from a different project using a different set of attributes

• if you have placed objects whose GDL script refers to attributes missing from your project

• if you have removed used attributes from your project via Attribute Manager

• if you have removed used attributes via Delete and Replace Layer

To locate elements referring to missing attributes, use Find and Select.

See Find and Select Elements with Missing Attributes.
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Find and Select Elements with Missing Attributes

Although attributes are saved with the project, it can still happen that your project contains elements which 

refer to missing attributes.

See also Missing Attributes.

To locate such elements easily, use Find and Select.

See also Find and Select Elements.

1. In the Criteria field of the Find and Select dialog box, choose a specific element type, or All Types.

2. Add “Attributes” as the next criterion, and set its value to “Missing.”

3. Click the Plus button to select all the elements that fit these criteria.

In this example, a slab has been identified and selected as using one or more missing attributes. In that Slab’s 

Settings dialog box, it becomes clear that the missing attribute is a cover fill.

The easiest solution is to assign a different cover fill, from the fills that are available to the project, by clicking 

the Cover Fill attribute pop-up. Here we have chosen to use the Carpet fill.
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Alternatively, if you know the location of the missing attribute you need (e.g. if it is part of another ARCHICAD 

project), you can use Attribute Manager to transfer the needed attribute from the other project to the current 

one.

See Attribute Manager.
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Custom Attributes of GDL Objects

Some GDL object scripts include custom attributes. These attributes may be defined either as part of their 

individual object scripts or defined in the MASTER_GDL script.

When you load such objects into a project, their custom attributes are automatically merged into the project’s 

attribute set as follows: 

• If the Attribute definition is contained in the MASTER_GDL script, then once the library containing the 

MASTER_GDL script is loaded, the attributes are merged into the ARCHICAD project attributes. 

Attributes with the same names are not replaced.

• If the Attribute definition is contained in the individual library part scripts, then

- Fills and Lines are merged into the ARCHICAD project.

- Surface and Texture attributes are not merged into the ARCHICAD project attributes.
ARCHICAD 24 Reference Guide 356



Attributes Configuration
Delete and Replace Attributes in a Model

When migrating a file, using file merge or working with hotlinks, you may need to get rid of the unneeded 

attributes. For many attribute types, you can use Delete and Replace in one step, to avoid missing attributes.

Delete and Replace is available for the following attributes:

• Layers

See Delete Layer/Move Elements.

• Lines

• Fills

• Surfaces

• Building Materials

• Composites

• Profiles

• Zone Categories

To Delete and Replace one or more attributes, do one of the following:

• Open its respective dialog box (at Options > Element Attributes)

• Open its tab page in Attribute Manager.

Select one or more attributes from the list, then click Delete...

You have two choices:

• Delete. This can result in missing attributes for model elements or for other attributes which are using the 

deleted item. 

If so, you will see a warning icon. Click Details to show the number of elements and/or attributes that will 

have “Missing” attributes as a result of the deletion. For further detail on these items, click Show Details 

in Browser.
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Note: Only elements and attributes that will be shown as “Missing” are listed under Details. Elements that 

will have a missing attribute within its Composite or Profile are not listed. This is because the Composite/

Profile will not be missing, just one of its components. 

 In Teamwork, Details will show the number of elements or attributes that will result in “Missing” attributes 

which are not reserved by you.

• Delete and Replace

When deleting an attribute, you have the option to replace it with a different one. Choose this option, and 

choose the replacement attribute.

Watch the Video

Watch the Video

Delete Layers and Move Elements

If you delete a layer, you have the option to move its elements onto a different layer (instead of losing those 

elements forever)
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Libraries

Each version of ARCHICAD is shipped with a standard object library containing hundreds of preconfigured, 

editable objects (also known as GDL objects or Library parts). 

When creating a new project, ARCHICAD will load the library contained in the template used for the new 

project. Each subsequent version of ARCHICAD comes with an updated ARCHICAD Library. There are 

different Libraries corresponding to different national standards.

You can also add additional libraries to the project as needed.

View and manage your project’s libraries in the Library Manager (File > Libraries and Objects > Library 

Manager).

Library Manager

Recommendations for Using Libraries

Embedded Library

Linked Libraries

BIMcloud Libraries

Remove Library from Project

Troubleshooting Library Issues

Missing Library Parts

Library Container File

Updates for ARCHICAD
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Library Manager

Use Library Manager to view and manage project libraries.

Library Manager (File > Libraries and Objects > Library Manager) also provides feedback on any missing 

or outdated Libraries or Library Parts, and provides information about how to resolve these issues.

Topics in this Section

Open Library Manager

List of Project Libraries

View Contents of Selected Library

Access and Manage Library Contents

Open Library Manager

Do one of the following:

• Use the File > Libraries and Objects > Library Manager command

• Right-click any Library Part in its Settings dialog box and use Show in Library Manager

• In the Action Center (File > Info > Action Center), click on the Libraries item for feedback on Library-

related issues, then click Library Manager
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• Open Library Manager from the Info Box pop-up of any Library Part

• Use the Library Manager icon at the bottom of any Library Part Settings dialog box

• With a library part selected, use File > Libraries and Objects > Show in Library Manager

List of Project Libraries

The Libraries in Project tab lists each library with its location, size and server status (where relevant).

The icon indicates the type of Library (Linked, Embedded, or BIMcloud Library).

Note for Teamwork users: Reserving the Library List on the Libraries in Project tab page enables you 

to add or delete libraries to/from this list. It does not allow you to modify any library’s contents. (To do so, 

go to the content tab of a selected library. Select and reserve the specific content you wish to modify.)
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Select any library, and/or the Info icon, to view information about it.
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View Contents of Selected Library

To see a library’s contents:

1. Select the name of the library from the list on the Libraries in Project tab.

2. Double-click to open the right-side tab (or click on the content tab) to see the selected library’s contents, in 

icon view or list view:

Note: Filenames that consist only of a file extension (such as “.gsm” or “.DS_STORE) are not visible in 

Library Manager
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Click Info to see a large-sized preview of a library part.
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Access and Manage Library Contents

Linked Library folders cannot be edited from the Content tab. All of the management commands, except the 

Duplicate, Export and Info buttons, are grayed out. Use a file manager interface, outside of Library Manager, 

to manage these Linked Library folders.

However, you can use Duplicate or Export to copy a Library Part file (such as a surface) to an accessible 

folder, then edit it in an external application (e.g. Photoshop). Then use Add to add it back to your library.
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Note for Teamwork users: To modify any library item, you must reserve the item in the Content tab of a 

selected library. Select and reserve the specific content you wish to modify.
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• Library Parts reserved by you are shown with a green dot. Newly added library parts or folders that have 

not yet been sent to the server are displayed in green.
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See also Open and Edit Library Part.

For details on each type of item listed in Library Manager, see the links below:

Embedded Library

Linked Libraries

BIMcloud Libraries

Remove Library from Project

Recommendations for Using Libraries

Troubleshooting Library Issues

Library Container File
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Embedded Library

The Embedded Library stores custom, project-specific objects in the project itself (rather than in your file 

system or on the BIMcloud), to ensure that they are always available and editable.

The Embedded Library may contain:

• Object files you create and save yourself (e.g. Patch, Stair, Trusses, Custom Object, Custom Door/

Window components)

• Image files loaded for use as Surface textures or other purposes

• Any object file that you browse for, choose and add to this library, including Web Objects downloaded from 

BIMcomponents.com

• Loaded .txt files that function as macros

Note: List Schemes (from the Calculation function) will function in Teamwork projects only if you save 

them to the Embedded Library.

Restrictions:

• The Embedded Library cannot contain any .lcf file (Library Container File)

• An archive (.pla) folder used as a Linked Library will not be mounted unless the folder functions as a 

library root (i.e. at the top of the library hierarchy). Any .pla files at a deeper level of the hierarchy will not 

be mounted.

Click on any folder listed in the Embedded Library Content tab to see its contents on the right side of the 

Library Manager.
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Embedded objects exist only in that particular project and can be used only in that project. (In contrast, objects 

of a linked or BIMcloud library can be used in many projects.) If you delete an object from the Embedded 

Library, it is gone. If you edit the script of an embedded object, that modification will occur right there, in the 

Embedded Library of that particular project.

For any selected object(s), view its information below (e.g. Name, number of placed instances).

Related Topics:

Open and Edit Library Part

Add Objects to Embedded Library

Manage Embedded Objects

Embedded Objects in Teamwork

Recommendations for Using Libraries
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Add Objects to Embedded Library

An object can be added to the Embedded Library in several ways. These are described in the following 

sections:

Embed Object Using Library Manager

Embed Placed Objects from a Library

Add Custom Object to Embedded Library

Load Object File to Embedded Library

Add Library of a Hotlinked Module

Embed Object Using Library Manager

Use Library Manager to add any folder or library-type file to your Embedded Library.

In a Solo Project:

1. Go to Library Manager.

2. Select the Embedded Library tab page.

3. Click “Add new file” or “Add new folder” from the command icons.
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4. Browse for the desired library folder or file, select it, then click Choose. (To view and choose items within 

a folder while browsing the directory dialog box in Windows, you must double-click the folder.)

The chosen library file or folder, with its contents, now appear in the Embedded Library in Library Manager.

Use Drag and Drop

From any location on your computer, drag and drop the file into the Embedded Objects folder of Library 

Manager.

Embed Placed Objects from a Library

Use this feature to embed all the objects placed from a linked library or BIMcloud Library into the project. This 

function is useful to ensure that the objects you need will always be available in this project, because they will 

be embedded.

Note: Embedding an object will also automatically load any needed macros along with it.

If you use this command, the original linked library or BIMcloud Library will be removed from the project.

Important: Embedding a library does not embed the entire contents of the library; it will only embed those 

objects which have been placed into the project.
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To embed a library’s placed objects into your project:

1. Select the library folder from the Libraries in Project list in Library Manager.

2. Click the Embed icon. (If no objects from the selected library have been placed, you get an alert that there 

is nothing to embed.)

3. The appearing dialog box gives you two options associated with the embedding process:

• Do Not Embed Duplicates: Click this to avoid duplicates when embedding objects. Any objects that 

already exist in other linked libraries will not be embedded.

• Also embed surfaces, zone stamps and property objects. This is usually relevant only if you are trying 

to embed objects from an ARCHICAD library. Surfaces, zone stamps and property objects are accessory 

GDL library parts that have been written into certain objects. Check this box to embed these parts as well.

Note: It is usually unnecessary to embed objects from an ARCHICAD library; the Consolidate function is 

a better technique for streamlining your ARCHICAD libraries.

See Consolidate Multiple ARCHICAD Libraries.
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4. Click Embed.

Notes for Teamwork Users

Only the objects in your current local copy of the project will be embedded.

It is possible that other users have placed objects from a BIMcloud library that you want to embed. If the other 

users have not yet sent these changes to the server, those placed objects will not be embedded, because 

they are not available to your local copy of the project. But since the library folder will be removed as part of 

the embed process, those objects will consequently be shown as “Missing.”

To avoid this situation, ensure that all users have sent in their changes before you embed a BIMcloud Library 

of a Teamwork Project.

Add Custom Object to Embedded Library

Objects saved using File > Libraries and Objects > Save Selection as will save the resulting files as 

embedded objects by default.

See Create Custom Library Parts and Components.

Similarly, objects created by you (e.g. using TrussMaker or RoofMaker) will be added to your project’s 

Embedded library by default. 

Load Object File to Embedded Library

Individual objects not part of the project libraries can be used in your projects via the Load Other Object 

commands in the corresponding tool settings dialog boxes. Such objects are automatically stored as 

Embedded Objects.
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Note: The Load Other Object command is also available from the Info Box pop-up of Library Parts.

Add Library of a Hotlinked Module

Placing a Hotlink module (ARCHICAD file formats) will add the source file’s entire Embedded Library to your 

host file’s Embedded Library. The newly added Embedded Library can be seen in your Library Manager, 

inside the automatically created “Hotlinks” folder of your Embedded library.

See also Library Parts in Hotlink Modules.
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Manage Embedded Objects

Open the Embedded Library folder of Library Manager to see the embedded objects.

Use the icons below to:

• Create a new folder within the Embedded Library folder.

• Add new folder to the Embedded Library (browse for an existing network or local folder)

• Add new object file to the selected Embedded Library folder

See Embed Object Using Library Manager.

• Duplicate the object. The new object, with a new name and assigned a separate GUID, appears 

alongside the original object in the Embedded Library folder.

• Move the object from one folder to another in the Embedded Library. Select the object and click the Move 

icon. Use the appearing dialog to browse for a location to which to move the object.

• Delete the object.
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Important: Deleting an object from the Embedded Library means that all placed instances of that object 

file will disappear from your project and be replaced by a dot. The object is deleted for good. You cannot 

retrieve it unless you earlier saved it to another location (in that case, you can Add it again to the 

Embedded Library)
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Linked Libraries

Linked Libraries include the standard ARCHICAD library loaded by default, as well as any other libraries you 

add. In contrast to the objects of the Embedded Library, these libraries are linked folders, or .lcf or .pla files.

Note for Teamwork Users: In Teamwork mode, there are no linked libraries - only the Embedded Library, 

and BIMcloud Libraries.

Add a Linked Library

To add a linked library to your solo ARCHICAD project:

1. Open Library Manager.

2. From the Libraries in Project tab page, click Add, or click Add Linked Library from the Add button’s pop-

up list. Recent Libraries are also listed: click to Add.

3. Browse for the desired folder, select it, then click Choose. 

Note: If you add a folder containing a .pla file to your Linked Libraries folder, be aware that the library 

parts in the .pla file at the top of the hierarchy will be loaded. However, if the folder contains additional. pla 

files at a deeper level of the hierarchy, those .pla files will not be loaded. The solution is to add these .pla 

files to your project as separate files, rather than adding the folder that contains them.

• Use Drag and Drop. From any location on your computer, drag and drop a library file or folder into the 

Linked Libraries folder of Library Manager.

The chosen folder is now listed in the Library Manager.
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When you are finished, click OK to reload project libraries and close the Library Manager.

Alternatively, you can reload libraries without closing Library manager: click Reload and apply.

Feedback at the bottom of the Library Manager provides

• the selected item’s Path

• the number of placed objects from this library

• the number of placed instances.

If the selected linked library is unavailable, the number of the project’s missing objects and instances which 

originate from this unavailable library are also listed.
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BIMcloud Libraries

BIMcloud Libraries are located on the BIMcloud, but added to your project. You can add a BIMcloud Library 

to any project, either solo or Teamwork (provided that you can access the server).

To use a BIMcloud Library in either a Teamwork project or a solo project, do the following:

1. Upload the library to a BIMcloud

2. Add the library to the project using ARCHICAD’s Library Manager.

Advantages of using BIMcloud Libraries

• Whenever a BIMcloud library is updated and refreshed, this update occurs for all users, both solo (after 

reloading the library) and Teamwork (after doing a Send and Receive).

• Updates from the server occur with “delta logic,” that is, only the changes are sent. 

• A BIMcloud library’s contents are cached on a Teamwork user’s machine and are read locally. In contrast, 

a linked library is always read through a network.

Related Topics:

Add BIMcloud Library

Manage BIMcloud Libraries

Upload a Library to BIMcloud

Upload Individual Objects to BIMcloud

Libraries in Teamwork
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Add BIMcloud Library

Once it has been uploaded to a BIMcloud, a library can be added to any ARCHICAD project, whether solo or 

Teamwork.

For information on uploading to the server, see Upload a Library to BIMcloud.

You can access libraries on BIMcloud even if you are currently working on a solo project, as long as you have 

a valid user name and password enabling access to the server.

Note: In a Teamwork project, you must also have the access right of “Libraries - Add/Remove” in order to 

add or remove BIMcloud Libraries from the project.

To add a BIMcloud Library to your project, do the following: 

1. Open Library Manager (File > Libraries and Objects > Library Manager).

2. From the Libraries in Project tab page, click Add BIMcloud Library from the Add button’s pop-up list.

Note for Teamwork Users: To access the Add commands, you must first Reserve the Library List on the 

Libraries in Project tab page.

• At any time: use File > Info > Action Center
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3. The Choose BIMcloud Libraries dialog box appears.

4. Log in to the BIMcloud if needed. 

See Log in to BIMcloud.

5. Select a library and click Add.

The library will now appear in the BIMcloud Libraries folder of the Library Manager.

6. In Library Manager, click OK to reload project libraries and close the Library Manager.

Alternatively, you can reload libraries without closing Library manager: click Reload and Apply.

See Manage BIMcloud Libraries for information on managing the uploaded libraries.

Synchronizing with the Server Library

• When you add a library, a local copy of the library will be created on your computer (regardless of whether 

you are working in solo or Teamwork mode).

• If you are working in Teamwork mode, this copy is synchronized with the server data every time you Send 

or Receive changes.

• If you are working in solo mode, this copy is refreshed every time you click Reload and Apply in Library 

Manager. This reloading also occurs if you have made modifications in the Library Manager, then click OK 

to close the Library Manager.

Note: The Windows operating system has a limit of 260 on the number of characters that the library path 

name can contain. Consequently, you may encounter a warning that the program is unable to save a local 

copy of the BIMcloud library, because the library path is too long.

For details, see Library Path Too Long.

See also Libraries in Teamwork.
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Manage BIMcloud Libraries

Use the Manage BIMcloud Libraries dialog box to view, upload and otherwise manage the libraries on any 

BIMcloud.

To use a BIMcloud Library in a project (either solo or Teamwork), that library must first be uploaded to the 

BIMcloud, using this dialog box.

Note: In a Teamwork project, you must be a Project or Server Administrator to use this dialog box.

To open this dialog box, do one of the following:

• use File > Libraries and Objects > Manage BIMcloud Libraries

• From Library Manager, click the Manage BIMcloud Libraries icon

At the top of the dialog box, use the pop-ups to choose a BIMcloud and to log in.

See Log in to BIMcloud.

Click the green Refresh button as needed to refresh the library list and user pop-up information shown in this 

dialog box.

Use either the Tree view, or switch to a Flat list using the icons at top right.
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Tree view

The tree view displays not only libraries, but also their position within the hierarchy of BIMcloud Manager 

(Projects root). 

Both projects and libraries are listed by default. To show the libraries only, uncheck Show All Items.

In Tree view, use Create Folder to create a new one on the Projects root.

Required permission:

• Simplified Management: Project or Server Administrator

• Detailed Management: Modify details and Modify folder content for the destination folder

The folder is created immediately; you can delete or otherwise manage it only through the browser-based 

BIMcloud Manager. (Click the Manage Folders link from the New Folder drop-down button to access the 

Projects page of the BIMcloud Manager.)

If a library of the same name already exists within a folder on the BIMcloud, you cannot upload it: any given 

library can exist only once in a given BIMcloud location.

Flat View

BIMcloud Libraries are listed with upload date and the address of the host server.
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Update BIMcloud Library

Use this command to update a selected library (already uploaded to the BIMcloud) with a newer library of the 

same name.

1. Select the library to update.

2. Click Update.

3. Browse for the library with which to replace the selected library. It must be a newer library of the same 

name.

4. Click Choose.

5. The feedback tells you the result of the update.

Upload a Library to BIMcloud

Required permissions:

• Simplified management: Project or Server administrator

• Detailed management: 

- Modify folder content

- Modify details for Libraries root
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If you do not have permission to upload to a particular folder, you are prompted to choose the default folder.

1. Go to File > Libraries and Objects > Manage BIMcloud Libraries.

2. Click Upload.

3. Browse for the library you wish to upload. Uploaded libraries can include .pla or .lcf files, or any folders. 

You cannot upload individual gsm files; you can only upload .lcf or .pla files, and regular folders.

4. Click Open.

5. Check Host Server: The default host server is shown, where the library will be uploaded.

 To upload a library to a different BIMcloud Server (other than the default), click the pop-up.

Required permissions:

• Simplified management: Server administrator

• Detailed management: Modify hosted data on BIMcloud Server

6. Click Upload.

Once libraries are uploaded, individual users can add these BIMcloud Libraries to projects, either solo or 

Teamwork.

See also Add BIMcloud Library.

Upload Individual Objects to BIMcloud

To upload individual objects to the BIMcloud, first place them into a folder, then upload the folder, as described 

above (Upload a Library to BIMcloud). The result is a BIMcloud Library.

You can also upload individual object files and folders from the BIMcloud: 

From the Projects Page of BIMcloud Manager, use the Upload Files/Upload Folders command. The result is 

individual files and folders uploaded to BIMcloud’s file system.

See the BIMcloud User Guide for details.
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Download Library from BIMcloud

Use the Download command to download the selected library to the location of your choice.

Delete Library from BIMcloud

Click Delete from the Manage BIMcloud Libraries dialog.

Required permissions:

• Simplified management: Project or Server administrator

• Detailed management: Delete/Remove content for library root
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Remove Library from Project

Select any Linked Library or BIMcloud Library from the Library Manager. (File > Libraries and Objects > 

Library Manager).

Click the Remove icon to remove the library.
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As a result of removing a library, you may end up with missing library parts. These are listed in the Warnings 

panel of Library Manager, in the “Missing Objects” folder. In the project model, they will be represented by 

fuzzy dots.

Removed libraries can be re-linked to your project at any time; then the missing objects will be found.

Note: The number of missing objects is minimized by automatic replacement with their updated 

counterparts, where available. For example: if both ARCHICAD Libraries 16 and 17 are loaded, and 

ARCHICAD Library 16 is then removed, then the ARCHICAD 17 Library will automatically replace the 

missing placed objects from the AC Library 16 with their updated counterparts from AC Library 17. If you 

subsequently re-link AC Library 16, the placed instances which were automatically replaced with AC 17 

counterparts will remain as-is.

See also Troubleshooting Library Issues.
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Recommendations for Using Libraries

It is recommended to organize your libraries as follows:

• Upload all your company’s libraries to a dedicated BIMcloud. This enables one-step updates which are 

then available to all users, including solo and Teamwork project users.

• The Embedded Library should serve as your project library, containing project-specific objects that are 

always available and editable, and saved with the project.

• Any project-specific object that you modify frequently should be placed in the Embedded Library.

• Only embed those objects that are project-specific. Try to keep the Embedded Library small.

• If you want to use a custom object in several projects, it is better to place it into a Company Library stored 

on a BIMcloud that is accessible to all users, rather than save it to an Embedded Library.

• When you archive a project, use the PLA file format. It is NOT recommended to save all objects in the 

Embedded Library.

See also Troubleshooting Library Issues.
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Troubleshooting Library Issues

From the following list, click on the specific library-related issue for more information:

Missing Library Parts

Objects Temporarily Missing

Unsupported Objects

Find and Select Missing Library Parts

Duplicated Library Parts

Substituted Objects

Consolidate Multiple ARCHICAD Libraries

Remove Unused Linked Libraries

Library Path Too Long

Missing Library Parts

The Library Manager indicates any Missing Library Parts.

Missing library parts cannot be displayed in the project. (The place of missing library parts is indicated by 

fuzzy dots.)

Missing library parts are listed in the Warnings Panel of the Library Manager, together with:

• the name of the source library if any, with its last known location, from which the missing objects originate.
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• number of missing object, plus the number of placed instances of each missing object. For each missing 

object, the number of its placed instances is shown in parentheses.

Items in the Missing Library Parts folder of the Library Manager are missing from the project

• either because they were embedded objects, and have been deleted (you cannot retrieve them, since 

they no longer exist)

• or because they were located in libraries that have been deleted from the project or moved to a different 

location.

To retrieve these objects, use the Add command in Library Manager to add the missing libraries, then click 

Reload & Apply.

Note: Some Favorites include a GDL object (such as a Favorite Zone that includes a Zone Stamp). If that 

GDL object becomes Missing (i.e., its library is not loaded), the Library Manager lists all missing objects 

from Favorites.

Objects listed under “Missing from unknown library” are missing objects about which no other information is 

available - their source library (or libraries) are not known.

Objects Temporarily Missing

In a Teamwork project, you may encounter a category in the Library Manager entitled “Temporarily Missing.” 

This may occur when a user makes changes in a BIMcloud Library that result in placed objects being updated 

in some way. If those objects are reserved by any user, then all users joined in to the project will encounter the 

“Temporarily Missing” category.

This will be resolved as soon as the user(s) who have reserved the objects do a Send & Receive; then the 

objects will no longer be missing.

Unsupported Objects

These files reference unsupported image formats.

Find and Select Missing Library Parts

To find and select missing library parts in the active window, use the Find & Select function.

See also Find and Select Elements.

1. In the first “Criteria” row in the Find and Select dialog box, choose a GDL object type element.

2. In the next row, for the next criterion, choose “Library Part Missing.”

3. As the value, select “True”.

Note: You can also choose “False” as the value; this will select all instances of the defined GDL Object 

types, except for the ones whose library object is missing.

4. Click the Plus button to execute the Find & Select function.
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Missing Libraries

If you have modified the name of a library folder, or changed its location in the file hierarchy, then the next time 

you open ARCHICAD, the library folder listed in the Library Manager dialog box will be shown as Missing.

Placed objects from unavailable libraries are listed in the “Missing Library Parts” folder of Library Manager. In 

the project model, they are represented by fuzzy dots.

The solution is to click Add Linked Library from the Library Manager’s Add button, and browse for the library 

file under its new name or location.
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Duplicated Library Parts

Any Duplicated Library Parts are listed in the Warnings Panel of the Library Manager. Each such library part is 

followed by the name and path of the project libraries that contain it.

Click More Info at the bottom of Library Manager for detailed information on the duplicates:

In the Information box, click the black arrow to choose the list format you need:

• List placed duplicates

• List all duplicates

• List all placeable duplicates

• List all non-placeable duplicates

Watch the Video

Avoid Duplicate Library Parts

The problem with having a lot of duplicate objects in your projects is twofold: every time you load your 

libraries, you will be loading many superfluous objects and/or libraries, causing unnecessary slowdowns; and 

the presence of duplicates can lead to further ambiguities if you should modify a duplicate library object or 

save it under a new name.

See Substituted Objects.

There are several possible strategies to resolve the issue of duplicates:

• If the Libraries with Duplicate Objects are ARCHICAD Libraries, it is best to Consolidate.

See Consolidate Multiple ARCHICAD Libraries.
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• If all the placed objects from one of the libraries are duplicates (i.e. these objects also exist in the other 

library), you can remove the first library altogether.

• If the duplicated libraries are not ARCHICAD libraries, you might consider comparing the two libraries’ 

contents manually (open the library folder at its source and view the objects), and then delete the 

duplicates from one of the libraries.

• If the duplicate placed objects are project-specific, you should embed them into the project. This will also 

eliminate the library from the project.

See Embed Placed Objects from a Library.

Substituted Objects

An object in this category has been placed in the project, but several possible substitutes for this object (that 

is, objects with the same GUID as the placed object, though they may be named differently) exist in at least 

two linked libraries. ARCHICAD randomly uses one or the other source for the object’s placed instances.

To avoid this situation, you should manually replace the instances of the “substituted object” with a single one 

of its possible duplicates from the loaded libraries.

(To do this, you can use Find & Select to locate the placed instances of the substituted object. Then choose a 

specific library object from the loaded libraries to replace it.)

Consolidate Multiple ARCHICAD Libraries

Any time you add an additional ARCHICAD library to a project that already has one, ARCHICAD will 

recognize the presence of older-version ARCHICAD libraries (versions 10 and later). In this case, the yellow 

Consolidate button appears in Library Manager.

Note: The Consolidate button appears in Library Manager any time that at least one outdated ARCHICAD 

Library - that is, a Library which is not the latest one - has been added to the project.
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Consolidating ARCHICAD libraries is recommended because:

• it replaces the old ARCHICAD libraries with the latest library

• it loads the requisite Migration Libraries so that you still have access to any now-obsolete library parts that 

may still be placed in the project

• Migration Libraries are much smaller than the full ARCHICAD libraries, so you will avoid superfluous 

objects

• you avoid errors that can result from placing identically named library parts that are present in several 

loaded libraries 
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Remove Unused Linked Libraries

Library Manager tells you whether you have actually placed any objects from your linked libraries. If not, you 

don’t need that library and you can remove it from the project. In this example, there are no objects placed 

from the selected ARCHICAD library; you can remove it.

To remove a library folder, select it from Library Manager and click the “Remove” icon with the blue X.

Library Path Too Long

The Windows operating system has a limit of 260 on the number of characters that the library path name can 

contain. Consequently, you may encounter a warning that the program is unable to save a local copy of the 

BIMcloud library, because the library path is too long.

To resolve this problem, try one of these solutions:

• Simplify the library’s file structure. 

Go to File > Libraries and Objects > Manage BIMcloud Libraries.

Download the BIMcloud library to a folder on your hard drive. 

In this folder, do one of the following:

– Create a container file (.lcf) out of the library folder, using File > Libraries and Objects > Create 

Container.

See also Library Container File.

– Alternatively, create a different, simplified folder structure for the library (e.g. move the library folder to 

a higher position in the folder hierarchy so that the file path becomes shorter). 

Go to File > Libraries and Objects > Manage BIMcloud Libraries and use Update to overwrite the 

server library with the .lcf file, or the restructured folder. 

• Move the Local Data folder.

Your local copies of BIMcloud libraries are stored in your Local Data Folder on your hard drive. 

If this location results in a file path that is too long, move the Local Data folder:

See Move Local Teamwork Data to a Different Folder.

The new location should be at a higher level of the folder hierarchy, thus making the path shorter.
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Library Container File

The extension .lcf identifies a “Library Container file”. The default ARCHICAD Library is stored in an.lcf, but 

you can also create your own Library Container file, or extract its contents, using the File > Libraries and 

Objects > Create/Extract a Container command.

Since the Library Container file is a single file, yet contains all the objects used in your project, it lets you keep 

all the objects used in your projects in one place, while keeping hierarchies intact within the.lcf.
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Favorites

Use Favorites to save and apply tool settings configurations that you use frequently.

Favorites are saved with your project file, and can be imported and exported between projects.

The ARCHICAD package includes some predefined tool Favorites.

You can access and apply Favorites from three places in the interface:

• Favorites Chooser in the Toolbox or Info Box

• Favorites Palette (Window > Palettes > Favorites)

• Tool Settings Dialog box

Which Parameters Are Applied with Favorites?

A Favorite’s stored parameters include:

• All of the element’s dimensions that can be entered in the settings dialog boxes for the element, e.g., wall 

thickness and height (but not length)

• Classification and Properties data

• for Fill Favorites: the style of its Fill Text, when “Show Area Text” is on

• for Library Parts: the name of the Library Part

Apart from the above, you can customize and save sets of additional parameters (“Transfer Sets”) to be 

applied with Favorites.

For details, see Element Transfer Settings.

Topics in this section:

Apply a Favorite

Search Favorites

Create New Favorite

Redefine Favorite

Edit Settings of One or More Favorites

Missing Content in Favorite

Favorites Palette

Import/Export Favorites

Related Topic:

Element Transfer Settings

Watch the Video
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Apply a Favorite

Apply a stored Favorite to selected element(s), or apply it as default Tool settings (if nothing is selected).

Favorites can be applied from three different locations, each shown below:

• Favorites Chooser in the Toolbox or Info Box

• Favorites Palette (Window > Palettes > Favorites)

• Tool Settings Dialog box

For information on Favorites controls in Library Part tool dialog boxes, see Settings of Library Part Elements.

In every case, select the Favorite, then double-click to apply to a selected element.

Or select a Favorite and click Apply (button or context menu).

Text-type Tools

Text tool Favorites can be applied to any text-type items when Dimensions, Labels, and Fills with Area Text 

are selected.

Line-Type Tools

Favorites of any of the four Line-type tools (Line, Arc, Polyline, Spline) can be applied to any of the other Line-

type elements. For example, apply a Line Tool Favorite to a selected Arc.

From Favorites Chooser (Toolbox/Info Box)

This is the fastest way to apply Favorites to a selected element as you work.

1. Access the Favorites Chooser by doing one of the following:

• Click and hold the Tool icon (Toolbox only)

• Click the arrow from the Toolbox or Info Box

Note: If no Favorites are defined for a tool, the Chooser will not appear from the Tool Box.

Note: To switch on the fly between the 3D and 2D preview of any Favorite, hover your cursor over the 

preview and press Shift.
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2. Search or browse, then double-click the desired Favorite.

See also Search Favorites.

Note: The folder tree view is not available from the Favorites Chooser.

From Favorites Palette

From the Favorites Palette (Window > Palette > Favorites), search and browse, then do one of the following:

• Double-click the desired Favorite, or

• Select a Favorite and click Apply

From Tool Settings

1. Open the Tool Settings dialog box.

2. Click the Favorites (star) button at top left.
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3. Search and browse, then do one of the following:

• Double-click the desired Favorite, or

• Select a Favorite and click Apply

See also Search Favorites.

4. Click OK to close the Tool Settings dialog.

Apply a Different Transfer Set

To see the list of the project’s stored Transfer Sets:

• Use the Apply button’s pop-up, or

• Click Apply Transfer Settings from a selected Favorite’s context menu

The Transfer Set defines the list of parameters applied with the Favorite. 

Change to a different Transfer Set, if needed: click on any Set name to apply it. 
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• Define and manage Transfer Sets here: Element Transfer Settings

• One of the sets is tagged (checked star icon) as the default to use when applying Favorites.
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Search Favorites

When using Favorites, you can use the search function to find the one you need. Search Favorites is available 

in all of the Favorites interface locations:

• Favorites Palette

• Favorites Chooser (Info Box)

• Tool Settings dialogs

Filter the list of displayed favorites as you type, by using the Search field at the top. A found item displays its 

folder location in the info tag.

To return to the previous view, delete the Search term or use the Clear Search command from the Favorites 

Additional Settings pop-up menu.

Use Search to instantly filter the list of Favorites, not just by name, but also by information contained within the 

Favorite, including:

• Favorite Name

• Library Part name - such as for Door, Window, Object Settings

• ID

• Text values from Properties (does not include numerical fields or name of Property)

• Default text stored in a Text label

Use quotation marks around a phrase to search for exactly that phrase, rather than the individual words.

Folder names are ignored.

See also Search for Library Part.
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Create New Favorite

Based on Selected Element:

1. Select an element that you want to store as a Favorite

2. Click the New Favorite icon at the bottom of the Favorites Palette

3. Enter a name in the New Favorite dialog box that appears and click OK.

In Tool Settings:

Use this method to store the current default or selected Tool Settings.

1. Click the Favorites (star) button to open the Favorites pop-up

2. Click the New Favorite icon

3. Enter a name in the New Favorite dialog box that appears and click OK.
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Your new Favorite is now listed, as applicable, everywhere that Favorites are available.

Within the Tool Settings Favorites pop-up, you can drag and drop Favorites among folders.

Favorite Name Conflict

If the name you give already exists as a Favorite, you are alerted, and the OK button is grey. Enter a different 

name to immediately dismiss this tool tip warning.

See also Redefine Favorite.

For general information, see Favorites.
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Redefine Favorite

Based on Selected Element:

1. Select one element from the model.

2. Select a Favorite (whose settings you want to change) from the Favorites Palette. (The Favorite must be 

the same tool type as the selected element.)

3. Right-click the Favorite and choose Redefine.

This Favorite is now redefined based on the selected element.

In Tool Settings:

Use this method to redefine the current default or selected Tool Settings.

1. Click the Favorites (star) button to open the Favorites pop-up.

2. Right-click a Favorite and use Redefine from the context menu.
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With an element selected: Select a Favorite and click the Redefine command icon.

For general information, see Favorites.

Watch the Video
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Edit Settings of One or More Favorites

Use this workflow to adjust particular settings in multiple Favorites (e.g., add the same new Property definition 

to all of your Wall Favorites at once). This workflow is available only using the Favorites Palette.

1. In the Favorites Palette, select one or more Favorites, of the same Tool Type.

2. From the context menu, click Edit.

3. The Tool Settings dialog box opens. (In case of multi-selection, the settings of the last-selected element 

are shown.)

Note that the dialog box is named, e.g., “Wall Favorite Settings”, and shows the name (“Various” if 

multiple) and number of the Favorites being edited.
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When editing a Favorite of a Library Part, the Favorite name (“Various” if multiple) is followed by the name 

of its Library Part in parentheses (or that of the last-selected Library Part, in case of multi-selection).

When editing a single Favorite, you can edit its name simply by clicking on it and typing into the field:

4. Adjust the settings as needed and click OK: the Favorites are redefined accordingly. Only the modified or 

new Settings definitions are changed, for each Favorite in the selection set.

For general information, see Favorites.

Note: Favorites content and the Favorites pop-up are disabled in Tool Settings while you are editing 

Favorite(s).

Watch the Video
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Missing Content in Favorite

Some Favorites include a GDL object (such as a Favorite Zone that includes a Zone Stamp).

If that GDL object becomes Missing (i.e., its library is not loaded):

• the Favorite is shown in the project and Favorites Chooser with a question mark

• Library Manager lists all missing objects from Favorites

You cannot apply a Favorite that has missing content. However, you can still delete/rename/redefine or edit it, 

using the Favorites Palette or Tool Settings.

For general information, see Favorites.
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Favorites Palette

Open this Palette at Windows > Palettes > Favorites.

Use the Favorites Palette to

• Organize and manage Favorites (see below)

• Apply Favorites (see Apply a Favorite)

• Create a new Favorite (see Create New Favorite)

• Import and Export Favorites between projects (see Import/Export Favorites)

• Customize Favorite Parameters (see Apply a Different Transfer Set)

• Access Favorite Parameter Settings

• Edit the settings of multiple Favorites simultaneously (see Edit Settings of One or More Favorites)

Show All Favorites/Show Active Tool Favorites Only

Choose Filter to Active Tool Only from the Settings pop-up (this option is active by default):

If the Arrow or Marquee tool is active, then all Favorites are listed, including those of sub-components such as 

Curtain Wall Frame and Panel.

Filter Folders

Enable Filter Folders Automatically to hide any folder that has no visible content.
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Organize Favorites

Add new folders using the New Folder button.

Also available from the context menu in the folder tree view.

• Drag and drop Favorites or folders from the list into any folder. (Press Alt/Ctrl to drag a copy.)

Rename or Delete a Favorite or Folder

1. From the Favorites Palette, select a Favorite, or a folder.

2. Use the context menu:

– Rename

– Delete (also available for multi-selection)
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Delete is also available with the red X icon at the bottom of the palette. 

A warning appears, informing you of the number of Favorites being deleted, including Favorites that are not 

currently displayed (if display is limited to the currently active tool).

Resize Panels

Resize the two panels vertically as needed. Drag the splitter to the top to make the top panel disappear, or 

double-click the splitter to open/close panels:

Display Preference

Choose List View, or Medium or Large Icons

(Available from Additional Settings pop-up in every Favorites chooser interface.) 
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Expand the Palette horizontally to also access these options as buttons.

2D or 3D Previews

Use the Additional Settings pop-up (from any Favorites interface):

• To switch on the fly between the 3D and 2D preview of any Favorite, hover your cursor over the preview 

and click Shift.

• If no 3D content is available, then 2D Previews are used.
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Notes: 

– The 3D Previews are OpenGL-based and automatically generated from generic elements. Some 

settings (e.g. Beam/Column/Wall slant angle) are ignored to improve clarity.

– To see contours on the 3D Preview, make sure the Work Environment option is checked: Show 

Contours on Favorites and Library Part Preview. (Options > Work Environment > On-Screen Options).

See also Previews and Pictures in the Interactive Schedule.

Search for Favorites

See Search Favorites.

Watch the Video
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Import/Export Favorites

Use the Import/Export Favorites dialog box, available from the Favorites Palette Additional Settings pop-up.

Importing Favorites

• If you choose Folder: browse for a folder containing Favorite XML files.

• If you choose File: browse for Favorites PRF file, or for any ARCHICAD project (PLN Solo project, PLA 

archive, or TPL template) to import its Favorites.

Note: When importing from an earlier ARCHICAD version, it is recommended to use an AC project as the 

source file. PRF and XML files from older-version ARCHICADs may not be imported correctly.

The Import Favorites dialog box appears.

For general information, see Favorites.

– For any Favorite you don’t want to import, uncheck the box at the left. The “Selected to Import” 

number, shown at top right, is updated accordingly.

– Imported Favorites are compared (based on Favorite name) with the host project’s list of Favorites. 

- If the imported Favorite does not exist in the project yet, it will be appended to the list of project 

Favorites.

- If an imported Favorite’s name already exists in the project, a house icon appears at the end of the 

row. You can either Overwrite the exiting Favorite with the imported Favorite, or Append the 

imported Favorite to the project’s Favorites: in this case, the appended Favorite gets a name 

extension. 

– Select multiple Favorites to check/uncheck or Overwrite/Append them simultaneously.
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• Import Folders: Checked by default. If you uncheck it, then the import process will ignore any folder 

hierarchy within the imported file, and the imported Favorites will simply be added to the top of the 

project’s Favorite list.

Click Import.

• Delete Before Import...: Under the Import button, optionally choose Delete all before Import to erase all 

Favorites and folders in the host project before a clean import of Favorites (as selected in the Import 

Favorites dialog). A warning appears before the delete.

Watch the Video

Exporting Favorites

• If you choose Folder: a separate XML file will be created in this folder for each Favorite that you export

• If you choose File: a single binary file will be created out of the exported Favorites

Check Selected Favorites only to limit the export to the Favorites you have selected.

Note: Empty folders will not be exported.

Watch the Video
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Interaction
Interaction

This section of the ARCHICAD Reference Guide includes information on how to navigate around the 

ARCHICAD project, and how to select and edit project elements. It also describes the many special 

ARCHICAD aids that make input and editing more intuitive.

Navigation

Origins

Selection

On-Screen Input Aids

Editing Elements

Virtual Trace: Using References to Edit and Compare Model Views and Drawings

Consolidate Lines and Fills in Drawing Windows
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Navigation

The following sections describe how to navigate among and within ARCHICAD windows. Primarily, you will 

use the Tab Bar and Pop-up Navigator.

This section also details the controls of the Navigator/Organizer Palette, from where you can access every 

project item and its settings.

How to Navigate Among ARCHICAD Views

Tab Bar

Pop-up Navigator

Zoom

Fit in Window

Set Orientation

Navigator Preview (2D)

Navigation in the 3D Window

Navigator Palette

Organizer Palette
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How to Navigate Among ARCHICAD Views

Do any of the following:

• Use the Tab Bar to switch among open windows

See Tab Bar.

• Use the Pop-up Navigator to open new items.

See Pop-up Navigator.

• Use the Window > Navigate hierarchical menu or the Window menu commands 

• Use the Mini-Navigator toolbar (Windows > Toolbars) 

• Use the maps in the Navigator Palette: double-click on the item you want to open

See Navigator Palette.

Navigation Shortcuts

You can use keyboard shortcuts to navigate among windows:

• Floor Plan Window: F2

• 3D Window: F3

• 3D Window (Perspective): Shift+F3

• 3D Window (Axonometry): Ctrl+F3

• last Section window: F6

• last Layout: F7

You can pan and zoom the window within the full drawing space to obtain the best view of the work you are 

currently doing, by using the shortcut icons next to the bottom scrollbar or the commands of the View > Zoom 

menu.

For more information, see Navigator View Map.
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Pop-up Navigator

The Pop-up Navigator is accessible at the right end of the Tab Bar.

To open it: click the icon, or use the Ctrl/Cmd + Shift + N shortcut. 

The Pop-up Navigator closes after any click, so it does not take up screen space when not in use.

Use it primarily to navigate among views and viewpoints of the Virtual Building. For each item, context menu 

commands make it easy to use relevant commands and functions. 

The Pop-up Navigator replicates many of the functions of the Navigator Palette familiar from older versions of 

ARCHICAD. The Navigator Palette (and the Organizer) remain available at Window > Palettes (or open 

them using the context menu commands of the Pop-up Navigator).

For details on their specific functions, see Navigator Palette and Organizer Palette.

Open a Tab with the Pop-up Navigator

With the Pop-up Navigator open, do any of the following:

• Double-click an item to open it

Note: When you open a new view or new layout, they can either replace the opened one (of the same 

type, in the case of views), or be opened in a separate new tab. You can change this tab-opening 

preference in Options > Work Environment > More Options.

Exception: You can have only one Floor Plan and one 3D window open at a time.

• Right-click an item to access the Open commands from the context menu

• Select an item, then the desired Open or Open in New Tab command from the bottom of the Pop-Up 

Navigator
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Navigator Maps

The Pop-up Navigator displays the whole project’s tree structure in three maps.

Choose a Map from the buttons at the top:

• The Project Map provides a tree structure of the viewpoints of your Virtual Building Model. A viewpoint 

represents a window onto a particular part of your project.

See Tab Bar.

• The View Map lists saved views. A view is a stored version of a viewpoint; each view is defined by its 

adjustable View Settings that you configure for a particular purpose as you construct your Virtual Building.

See Navigator View Map.

• The Layout Book contains the layouts and drawings of the architectural project. A view placed on a 

Layout is called a Drawing.

See The Layout Book.

Show/Hide Navigator Items

Use the Chooser pop-up at top left to show or hide the following:

• Navigator Palette

• Organizer

• Drawing Manager

• Change Manager
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Navigator Project Map

The Project Map of the Pop-up Navigator provides a tree structure of the viewpoints of your Virtual Building 

Model.

Note: The Pop-up Navigator replicates many of the functions of the Navigator Palette familiar from older 

versions of ARCHICAD. The Navigator Palette (and the Organizer) remain available at Window > 

Palettes. For details on their specific functions, see Navigator Palette and Organizer Palette.

What is a Viewpoint?

A Viewpoint represents a window onto a particular part of your project. Viewpoints are listed in the Navigator 

Project Map, organized into folders (one folder named for each type of viewpoint). These folders are a fixed 

list of item types; you cannot add or delete folders here.

In both the Navigator and Tab Bar, a viewpoint’s icon has a black outline.

Note: Once you save a viewpoint’s settings, it becomes a view (listed in your View Map) and can then be 

placed onto a Layout for editing.
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Project Name

The project gets a name once you save the project file, but if you assign a Project Name in File > Info > 

Project Info, that is the name that will be shown in the Navigator.

Folders of the Project Map

The Stories folder contains all the Stories defined for the project.

The Sections, Elevations, Interior Elevations, Worksheets, Details and 3D Documents folders contain 

the list of corresponding windows. If there is no plus sign in front of a folder, this means that no such viewpoint 

has been created yet in the project.

See ARCHICAD Model Views for information about each of these viewpoint types.

The 3D folder contains elements for the various projection and camera types.

• By default, two items are present on starting the project: Generic Perspective and Generic Axonometry.

• When you place Cameras in the Project, their names appear in the 3D folder of the Project Map, grouped 

under the Path.

See Camera Tool Settings.

The Schedules folder contains the interactive schedules (Elements and Components) created as part of the 

project documentation. The Interactive Schedule serves as a basis for ordering doors, windows, and other 

construction elements from the manufacturers and for checking the consistency of elements based on a set of 

criteria.

See Interactive Schedule.

The Project Indexes folder contains sets of table of content-type items, such as a view list indexes, layout 

sheet and drawing list.

See Project Indexes.

Note: These commands (e.g. Create New Story; Create New Independent Detail) are also available from 

the context menu if you select the corresponding Project Map item.

The Delete button will remove the selected viewpoint. All linked markers to this viewpoint will be deleted.
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Navigator View Map

The second map of the Navigator is the View Map: the list of saved Views in your project.

Views can be created within the active project or imported from other ARCHICAD projects.

Note: The Pop-up Navigator replicates many of the functions of the Navigator Palette familiar from older 

versions of ARCHICAD. The Navigator Palette (and the Organizer) remain available at Window > 

Palettes. For details on their specific functions, see Navigator Palette and Organizer Palette.

What is a View?

A View is a stored version of a Viewpoint; each view is defined by its adjustable View Settings that you 

configure for a particular purpose as you construct your Virtual Building.

The project’s views are listed in the Navigator View Map. In both the Navigator and Tab Bar, a view’s icon has 

a blue outline.

Settings Stored with the View

Once you save the view, it will store the combination of the following settings:

• Layer Combinations

• Scale

• Partial Structure Display

• Pen Set

• Model View Options Combination

• Graphic Override

• Renovation Filter

• Floor Plan Cut Plane

• Dimensions
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• Zoom and Rotation

• Image Settings (for 3D Window views): these include 3D projection settings (including zooming), filtered 

elements in 3D, 3D Style, 3D cutting planes, 3D Cutaway and PhotoRendering Settings.

• Existing selection (3D only)

See View Settings Dialog Box.

Set up a View

To set up a new view, open a project window (Floor Plan, Section/Elevation/IE, 3D Document, Detail, 

Worksheet, 3D, Interactive Schedule, or List) and adjust any or all of its settings as needed.

It is convenient to use the Quick Options controls of the bottom scrollbar.

See Quick Options Bar.

Even if the project content changes, the settings of your saved views - will remain unchanged unless you 

expressly modify them.

Note: You can create a dynamic connection between project viewpoints and views if you clone a folder.

For more information, see Clone a Folder in the View Map.

Save View

To save a view, do one of the following:

• Click Save View from the tab’s context menu

• Click Save Current View from the viewpoint’s context menu in the Pop-up Navigator

The View Settings Dialog Box appears, allowing you to modify the settings before saving the view. Click 

Create to save the view.
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Notice that the tab bar icon (blue) now indicates that the tab is a saved view.

• Use the Save View and Place on Layout command

See Save View and Place on Layout.

• In the View Settings Dialog Box, click Get Current Window’s Settings to overwrite the original view 

settings with those of the active window.

Related Topics

Restore View Settings

Transfer Settings Among Tabs

Save as View from Tab Bar

Use this command to save an open view with its current settings, without overwriting previous view settings.

1. With a view open, use the Save as View command to open View Settings. 

2. Adjust the settings and give it a new name, then click Create.
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Zoom

Set the window’s Zoom using the controls at the bottom of the window.

When you save a view, its View Settings include the current Zoom value. 

Zoom to Selection

Right-click anywhere on the screen to access this command and zoom in to the last-selected item:

Previous/Next Zoom

Click these shortcuts to move back and forth among the window’s recently used Zoom values. Up to 20 

Zooms are stored.

Zoom with Mouse Scroll Button

If you have a mouse with a scrolling button, use it for zooming in on (or out of) the area where the cursor is 

located.

Note: In Work Environment, you can set a different preference for using the scroll-wheel (with or without 

the Alt button) for Zoom and Pan. See Input Constraints and Guides Dialog Box.

Zoom with Keyboard

You can use numeric keypad shortcuts to achieve the scrolling zoom effect: press the ‘+’ key for zooming in 

and the ‘-’ key for zooming out.
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Zoom Scrollbar Button

1. Click the Zoom button on the bottom scrollbar.

2. Draw a rectangle around the detail you want to enlarge.

Note: To double the current zoom level, double-click the Zoom button.

See also Zoom and Rotate.

Zoom with Menu Commands

• Choose View > Zoom > Zoom In or Zoom Out.

Note: If these commands are not available in the View menu, you can use Options > Work Environment 

> Menus to add them.

For more information, see Customizing Menus.

Home Zoom

If you need to return frequently to a part of your project, you can define it as the home zoom by choosing the 

View > Zoom > Set Home Zoom command. 

Return to this view with View > Zoom > Home Zoom. 

The home zoom is saved with the project.

Predefined Zooms

Click the Zoom pop-up to choose one of the predefined zoom values.

Use the pop-up commands to save, rename and delete predefined zooms.

See Save Zooms, below.
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Home Zooms are not included in the list of saved zooms.

Save Zooms

Click the Zoom pop-up, then choose Save Current Zoom.

In the appearing dialog box, give the saved zoom a name.

By default, this zoom will be available only for the current story. To have this zoom available in all stories, click 

Across All Stories.
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Custom-saved zooms you name here can be applied to any view, from the Zooming pop-up list in the 2D/3D 

Documents Panel of View Settings.
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Fit in Window

Choose the View > Fit in Window command or click the corresponding option from the Quick Options bar at 

the bottom of the active window.

Another shortcut: Double-click the middle mouse button to Fit in Window.

If the current view has been rotated, the rotation remains intact.

See Set Orientation.

If you wish, you can save a window’s Fit in Window setting as part of any view’s View Settings: choose Fit in 

Window from the Zooming pop-up in the 2D/3D Documents Panel of View Settings.

See View Settings 2D/3D Documents Panel.

Listing windows have an additional shortcut in their bottom scrollbar allowing you to Fit the Width of the 

generated list to the current window size.
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Set Orientation

Use this function to rotate the entire view on your screen to a preferred position.

See Reset Orientation, below.

You can reorient the Floor Plan, Worksheet, Detail and 3D Document windows. The orientation value is saved 

as part of the “Zoom” value of every saved view, and on the published output created from that view.

Orienting the view does not rotate the project as such; the project coordinates remain unchanged. It just turns 

the window contents so that they are displayed at a more convenient angle on your monitor.

Note: There is a checkbox in View Settings: Ignore zoom and rotation when opening this view. If this 

is checked, then the displayed view will not use the saved zoom value, but rather the window’s last-used 

zoom value. Consequently, the rotation will not be seen either. Uncheck the box if you wish to see the 

saved zoom value in the window, together with the rotation. (Views placed on layouts will always display 

their saved zoom/rotation.)

Topics in this Section:

Reset Orientation

Set Orientation Graphically

Rotate to Nearest Orthogonal Position

Zoom and Rotate

Grids in Oriented View

Text in Oriented View

Reset Orientation

1. Click the Orientation pop-up button at the bottom of your screen, or the Set Orientation shortcut button.

2. Choose from the list of predefined and recent orientation values.

Note: ARCHICAD stores the last four of your custom orientation values in a Preferences file (the stored 

values are not project-specific, and not stored in your project file). If you set another (fifth) orientation, it 

will replace one of the stored ones.
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Set Orientation Graphically

1. Click either the Set Orientation button, or Set Orientation Graphically pop-up command.

2. On screen, draw a rotation vector with two clicks.

3. Drag your mouse to rotate the screen contents to the desired angle, or enter a numerical rotation angle 

into the Tracker. Click a third time to complete.

The pair of arrows in the window’s lower left corner also indicates the rotation.

Rotate to Nearest Orthogonal Position

1. Click either the Set Orientation button, or Set Orientation Graphically pop-up command.

2. Move the cursor to an element edge.

3. Ctrl+click on the edge.

4. The window contents will rotate to the nearest orthogonal orientation.

Zoom and Rotate

To rotate the view and zoom in or out at the same time:

1. Click the Zoom icon from the bottom of your screen.

2. Press Ctrl.

3. Using three clicks, draw the zooming rectangle on screen at the desired angle.

When you complete the rectangle with the third click, the view will zoom in/out and be rotated simultaneously.

Grids in Oriented View

The on-screen Grid, if it was orthogonal to begin with, remains orthogonal after the rotation. If it was a rotated 

Grid, that Grid will rotate along with the view, its project coordinates remaining unchanged after the rotation.

Text in Oriented View

Text blocks

The way a Text Block behaves in a rotated view is set in Text Tool Settings in the Text Block Formatting Panel. 

See Text Block Formatting Panel.
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Text Labels

See Text Label Panel.

Dimension text

Dimension text is automatically adjusted to ensure that it will remain easily legible regardless of the view’s 

orientation. (If you set a custom angle for dimension text, however, that angle will prevail.)

For dimensions whose text is set to “Horizontal” in Dimension Tool Settings, the text will remain horizontal with 

respect to the screen regardless of any rotation of the view.

See Dimension Tool Settings.

Fill Area text

Will always be displayed horizontally on screen, regardless of the view’s orientation.

See Add Area Text to a Fill.

(If you set a custom angle for fill area text, however, that angle will prevail.)

Text of GDL Objects in Rotated View

GDL Object-type elements may contain text that is affected by a rotated orientation. For example, options for 

Text Orientation on Symbol include:

• Readable: As the view is rotated, the object text rotates too, but is flipped as necessary to ensure text 

readability.

• Align with Symbol: Text rotates together with the symbol, with no other adjustments.

• Always Horizontal: Text remains fixed in a horizontal position on screen, regardless of the view’s 

orientation.

Marker Text in Section/Elevation/Detail/Worksheet

In the Settings dialog box (Marker Panel), use the Marker Text Rotation parameter. This may include the 

following values, depending on the marker type:

• Always Horizontal and Always Vertical values will display text horizontally/vertically on screen, 

regardless of the view’s orientation.

• Align with Section Line will keep the text lined up with the Section line, following any view rotation, and 

will flip the text if necessary to ensure readability.
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• Align with Section Line - No Flip will keep the text lined up with the Section line, following any view 

rotation, without any “flip” adjustment for readability.

Text of Door/Window Markers

The text orientation parameter may include the following values, depending on the marker type:

• Standard: Text is always parallel to the wall, and is automatically readable (that is, flipped if necessary 

after rotation of the view).

• Align with Marker Line: Text remains fixed in line with the marker line and is automatically readable.

• Horizontal/Vertical: Width/Height/Sill/Fire Rating/Acoustic Rating texts are automatically readable.
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Navigator Preview (2D)

The Navigator Preview Palette makes it easier to locate and zoom in on certain parts of your project, 

especially when working on larger projects.

For details on these controls, see The 2D Navigator Preview Palette Controls.

To display the Navigator Preview Palette, use Window > Palettes > Navigator Preview.

For 2D Windows, the Preview Palette displays a miniature copy of the entire contents of the current view. The 

frame inside the Preview Palette represents the active window at its current zoom. Use this frame to zoom 

and pan within the Preview Palette; this has the same effect as zooming and panning in the active window, 

while simultaneously giving you an overview of the entire window contents.

If the current zoom of the active window includes a rotated orientation, the preview shows the project in its 

original view, but the frame is rotated to match the angle of orientation.

See Set Orientation.

(The two heavier arrows of the frame indicate the bottom left corner of the screen.)
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When previewing a 2D window in the Navigator Preview, you have the following zooming and panning 

options:

• To change the location of the frame, drag its enclosed area with the Hand Cursor (this lets you pan in the 

active window).

• To change the size of the frame, drag its sides or corners (this has the effect of zooming in and out within 

the active window).

• At the bottom of the palette, the plus and minus buttons and a sliding switch are additional zooming 

techniques: they allow you to zoom the current view in and out. Click the buttons or drag the slider to 

adjust the zoom.
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• At the bottom right corner, a pop-up menu contains options for controlling the zooming techniques of the 

Navigator Preview. The default is Real-time zoom: as you move the cursor, the zoom is adjusted. Auto 

zoom will adjust the zoom after you finish moving the cursor. Double-click to zoom means you must 

double-click or press the Go button at top right to execute the chosen zoom.

 

• Use Redraw Preview if you have made changes in the current window that are not yet reflected in the 

Navigator Preview.

For information on saving this data, see Save Navigator Preview Data with Project files.
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Navigation in the 3D Window

Note: For general information on accessing the 3D window, and how to set up Perspective and 

Axonometric (Parallel) views, see 3D Window.

The 3D window can be navigated using most of the basic 2D navigation methods. The keyboard, mouse scroll 

button, Fit in Window, Pan, Zoom, and command-based techniques all work the same way as in 2D.

See Fit in Window, Zoom.

The 3D window also contains unique navigation possibilities for exploring the model and orbiting around in it. 

These are described in the following sections.

Accessing 3D Navigation Commands

Explore Model (3D Navigation)

Orbit (3D Navigation)

Navigator Preview (3D)

3D Connexion Enabler
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Accessing 3D Navigation Commands

The 3D Navigation commands are available only in the 3D Window.

Use Window > Toolbars > 3D Visualization

 or Window > Toolbars > Simple 3D to display these toolbars as needed. 

If the 3D window is active, the Quick Options Bar contains shortcuts to the Orbit and Explore commands.

Note: The 3D Navigation controls from earlier versions of ARCHICAD can be accessed by choosing 

Window > Toolbars > Classic 3D Navigation toolbar.

Related Topics:

3D Navigation Extras

Classic 3D Navigation Toolbar
ARCHICAD 24 Reference Guide 442



Navigation Interaction
Explore Model (3D Navigation)

In Perspective views only, you can explore the model either by choosing the View > Explore Model or access 

the same command from a toolbar, or from the bottom scrollbar of the 3D window.

In Explore mode, use the mouse and the arrow keys of the keyboard for navigation (as when playing a video 

game on a PC.) When in this mode, you cannot edit the model or use any of the commands. The “Fly” option 

and speed slider also appear at the bottom of the screen as long as you are in Explore mode.

 

To exit Explore mode, click with the left mouse button or use the Esc key.

Note: Exploring the model is optimized for the OpenGL engine.

When choosing the Explore Model command, an informational dialog box opens to give you a visual prompt 

on what you can expect from your various actions with the mouse and the keyboard.

Note: If you don’t need to see this information every time you enter Explore mode, check Do not show 

this information next time at the bottom of the dialog box. To enable this or any other dialog box you 

have marked as “do not show,” use the Enable all informational messages command at Options > 

Work Environment (bottom of menu).
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“Rotate” camera in Explore mode

Moving the mouse around will rotate the camera in the directions indicated by the arrows next to the camera 

on the picture above.

“Walk” forward and backward in Explore mode

Pressing the arrow keys, or the W-A-S-D keys, will walk you forward/backward and laterally in the directions 

indicated by the arrows in the picture above. Note that the Up arrow brings the model closer to you while the 

Down arrow moves it further away.

“Fly” around the model

In Explore mode, click “F” for Fly mode. Again, use the arrow keys or the W-A-S-D keys to move around, but 

this time the Fly mode combines the lifting effect with the rotating and lateral movements to simulate a walking 

movement on a horizontal plane or in space.

“Lift” the model up and down

Use the PageUp (shortcut: spacebar) and PageDown (shortcut: C) keys to simulate a lifting effect.

 

Speed Up/Slow Down in Explore Mode

Click the Plus and Minus keys on your numeric keypad to change the speed in which you explore the model. 

For a temporary speed increase, press Shift, then release it to return to your basic speed.
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Orbit (3D Navigation)

For Orbit mode, choose View > Orbit, or access the same command from a toolbar or from the bottom 

scrollbar of the 3D window.

Once you enter Orbit mode, press the left button and drag the mouse to turn the model around its centerpoint 

(axonometry) or target point (perspective).

If you are in Orbit mode, you cannot edit the model. Click ESC to exit Orbit mode and return to editing mode.

Temporary “Orbit” Effects While in Editing Mode

While in editing mode (not in Orbit mode), you can temporarily simulate Orbit mode by pressing Shift together 

with the mouse scrolling button to orbit the model. Release the keys to stop orbiting.

This type of temporary Orbit requires the model to be redrawn and can result in slowed-down navigation.
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Navigator Preview (3D)

To display the Navigator Preview Palette, click the shortcut button in the bottom scrollbar of any window; or 
use Window > Palettes > Navigator Preview.

This palette allows you a quick way to modify your 3D Projections, whether perspective or parallel 

(axonometric).

See 3D Projections.

The options of the Navigator Preview depend on whether you are looking at a Perspective or Axonometric 

view.

For Perspective 3D views, edit the camera and target positions directly by clicking them in the Preview 

window and dragging them to a new location.

Note: Make sure that Show from Top is chosen from the pop-up menu in the Preview’s lower right corner.
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If you choose Show from Side view from the Preview options pop-up, you can easily re-set the camera 

height relative to the stories of the project: just click in the Navigator Preview and move the camera up or 

down.

Or you can change the view cone, using the sliding switch or the small icons at its ends, in 5 degree 

increments.
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For Axonometric (parallel) projections, the 3D Navigator Preview has two pop-up menus at the bottom right. 

From the left button, choose one of the 12 predefined projections to quickly switch to that view.

(These are the same predefined axonometries available from 3D Projection Settings).

To customize the projection, use the right-side pop-up button, then move the small camera icon inside the 

Preview window to set up a custom view.

For detailed information, see The 3D Navigator Preview Palette Controls and 3D Projections.

For information on saving this data, see Save Navigator Preview Data with Project files.
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3D Connexion Enabler

The 3D connexion Enabler is an add-on functionality that allows you to use your 3Dconnexion device for 

navigating in ARCHICAD’s 3D window.

If you are using a 3Dconnexion device, use one of the two options at View > 3D Navigation Extras > 

3Dconnexion:

• Camera mode: Move the device to navigate in the model by moving the camera position.

• Object mode: As you move the device, the model is moved accordingly. The camera viewpoint is fixed, 

while the model moves.
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Navigator Palette

The Navigator Palette (Navigator) is a tree structure that lets you build up the entire logical structure of your 

project and navigate within it.

Show/Hide the Navigator Palette using one of the following: 

• Window > Palettes > Navigator

• Context menu commands from the Project Chooser or header area of the Pop-up Navigator, or the 

Navigator Palette itself
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The Navigator Palette is not shown by default. Nearly all the navigation and view management functions of 

the Navigator Palette are also found in the Pop-up Navigator.

See Pop-up Navigator.

Important: Operations involving Pop-up Navigator and Navigator/Organizer items (such as drag and drop 

between Navigator maps, deleting items from the Project Map or View Map, or adding items to the 

Publisher set) are not added to the undo queue, and are not undoable.

Unique Functions of the Navigator Palette

The Navigator Palette (and Organizer, as applicable) contain a number of additional functions that are not 

available from the Pop-up Navigator:

• Use the Publisher from the Navigator Palette to set up the items you want to publish, and set the 

publishing method and format. Each Publisher item refers directly to a View or to a Layout.

See Publisher Function.

• Use the Navigator’s Project Chooser to access views and layouts from external ARCHICAD files and 

place them into the Layout Book of your current project

See Access Views/Layouts from External ARCHICAD Project.

• To drag and drop Navigator items onto a Layout, you must use the Navigator Palette

• The Navigator Palette has a special double-tree mode, called the Organizer, which makes it easier to 

move items from one map to the other (See Organizer Palette.)

• Feedback: the currently opened Navigator item is shown in bold

• The Clone a Folder command is available only from the Navigator Palette’s View Map

See Clone a Folder in the View Map.
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• The Layout Book’s tree view options are available only from the Navigator Palette

• The Lists folder of the Project Map contains three items: Elements, Components and Zones, containing 

predefined list schemes

• The Info folder of the Project Map contains the Project Notes and Report items (also available from the 

Window menu)

For more information, see Project Notes and Session Report Window.

Accessing Commands from the Navigator Palette

In addition to the context menu commands (as in the Pop-up Navigator), the Navigator Palette offers 

additional ways to access commands. At the bottom of any of the Navigator Palette maps:

• Click Settings to view a selected item’s settings

• Use the command buttons to create and manage Navigator items

• View/edit a selected item’s Properties

Note: In the Project Map, the Story ID is not editable. A Story ID is identical to its Story Number, which can 

be set in Story Settings.
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Restore View in Navigator Palette

If the current view that you are editing no longer matches its saved View Settings, a yellow “warning” icon will 

appear at the bottom of the Navigator, next to the changed settings, alerting you that the currently active 

view’s settings no longer correspond to the original view settings. 

For example, the image below indicates that the current tab’s scale and layer settings are different than in the 

saved view.

To restore the view’s saved status, double-click either the tab, or the view item in the Navigator.
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Organizer Palette

The Organizer is related to and opened from the Navigator Palette. It houses essentially the same controls, 

but has a double-tree structure to make it easier to move and copy views and layouts from one map to the 

other.

It is possible to display an external ARCHICAD project’s tree structure in the Organizer and copy any of its 

views or Layouts into the active project.

See Access Views/Layouts from External ARCHICAD Project.

Display the Organizer

Show/Hide the Organizer using one of the following: 

• Window > Palettes > Organizer

• Context menu commands from the Project Chooser or header area of the Pop-up Navigator, or the 

Navigator Palette or the Organizer itself

Organizer Modes

Depending on the mode of the Organizer Palette, you can add or copy the appropriate item (view or layout) 

from the left side to the right-side tree structure (View Map, Layout Book or Publishing Set.)

Click the desired map icons on both sides of the Organizer to bring up one of the three modes of the 

Organizer: 
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• View Editor mode (Project Map on the left, View Map on the right): Save views by selecting a viewpoint 

from the Project Map and clicking Save view, or drag and drop it into the View Map. 

Organizer’s View Editor Mode: Drag and Drop, or click Save View

In View Editor mode, you can access the View Settings and Storing Options below the Project Map. 

Use the pop-ups to change the settings of the selected Project Map viewpoint.

• Layout Editor mode (Layout Book on the right): Place Drawings onto Layouts by selecting a view from 

the Project or View Map (on the left), then clicking Place Drawing, or drag and drop it onto a Layout (on 

the right).
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• Publisher (Publisher on the Right): To add a view or layout (on the left) to a Publisher set (on the right), 

select a view or layout and click Add Shortcut.

If you select a Subset in the Layout Map, the Add Shortcut button will create a folder in the Publisher Set 

which corresponds to that Subset: if you change or add items in the original subset, the Publisher Set 

folder will reflect these changes automatically. However, if you drag and drop a Subset into the Publishing 

Set, a folder is created, but this folder is not linked to any subsequent modifications to the Subset.

See Publisher Function for more information.
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Notes on the Organizer Modes

• The Project Map is available only on the left side.

• Certain combinations are not possible, and ARCHICAD will always adjust to one of the three possible 

Organizer modes. (For example, if you choose the Publisher on the right, then the left side will switch from 

Project Map to View Map, because you cannot place items directly from the Project Map to the Publisher.)

• If you have the same map shown on both sides of the Organizer Palette, the Copy Shortcut button will 

duplicate the selected item on both sides (since both trees represent a single identical map).
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Clone a Folder in the View Map

Cloning a folder means that you recreate a Project Map folder inside the View Map.

Consequently, for each new viewpoint you create in the Project Map, a counterpart new view will be created in 

its cloned folder in the View Map.

For example, if you have cloned the Project Map’s Stories folder, then the cloned folder in View Map will 

always show all Stories of the Project, even new ones added after the creation of the clone folder.

The Clone a Folder command is available in the Navigator Palette or Organizer’s View Map (not in the Pop-

up Navigator).

How to Clone a Folder

1. Click the Clone Folder at the bottom of the View Map (in the Navigator or Organizer). This opens the 

Clone a Folder dialog box.

2. The top of the Clone a Folder dialog box lists all the folders of the Project Map. Choose the folder whose 

clone you want to create in the View Map.

3. The rest of the controls are identical to those of View Settings. The settings you define here will be initially 

applied to every view in the cloned folder.

4. Click Clone.
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The resulting cloned folder in the View Map is identified by the “clone” folder icon.

How to Clone a Folder (Drag and Drop)

Another way to create a clone is to drag the folder from the Project Map to the View Map, using Ctrl+Shift 

(Windows) or Opt+Cmd (Mac) within the Organizer’s View Editor.
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Navigator Layout Book

The Layout Book is a tree view of the Layouts defined for the entire project, plus the Drawings on the Layouts.

See The Layout Book.
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Navigator Publisher

Use this map of the Navigator Palette/Organizer to set up the items you want to publish, and set the 

publishing method and format.

Access the Publisher in one of these locations:

• the Navigator Palette

• the Organizer

• the Document > Publisher > Publish menu command.

.

For detailed information, see Publisher Function.
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Access Views/Layouts from External ARCHICAD Project

Use this function to place Layouts or views from an external ARCHICAD projects onto a Layout of the active 

project.

1. Open the Organizer of the active project.

2. Click the Browse Project or Browse Teamwork Project command in the Project Chooser.

3. Choose the ARCHICAD project whose content you want to use in the active project.

Note: If you choose Browse Teamwork Project, you will be prompted to choose a server on which the 

Teamwork Project is found.

4. Click Open.

The external project is now displayed on the left side in the Organizer tree structure, and the active project’s 

Layout Book on the right:

The external project name is now also listed in the Project Chooser. (If this project is also open in another 

ARCHICAD, it is listed in the Project Chooser as “Running”.)
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5. Drag the desired item into the Layout Book of the active project, shown on the right side of the Organizer.

Note: You can access external projects the same way by using the Project Chooser with just the 

Navigator open (without the Organizer). In this case, once you have browsed the desired external project 

and see its tree structure, add any of its views or layouts to the active project by dragging and dropping it 

directly onto the Layout in the active window.

To open the external project in a separate ARCHICAD, double-click any of its items in the Navigator Palette.
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Origins

In ARCHICAD, as in any coordinate system, all measurements are made in reference to an origin. The 

location of the origin is always interpreted as (0, 0).

ARCHICAD defines three coordinate system origins:

Project Origin

The Project Origin is a constant location which remains fixed for the life of your Project. The Project Origin of 

the coordinate system, marked with an X, is close to the lower left corner of the Floor Plan window, when 

using the default view of the default template. (The Coordinates Palette shows the coordinates as (0, 0).

In Floor Plan and other 2D views, the origin is always marked by a bold X.

In 3D Views, the origins and their X, Y and Z axes are displayed with bold black lines.
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Edit Origin

The Edit Origin appears automatically when you click to begin input. It is a temporary origin that appears as 

an x during drafting and editing operations only.

In the Tracker, coordinates are measured from the Edit Origin by default: these are Relative Coordinates.

Note: Use the Tracker menu from the Standard Toolbar to toggle the Relative Coordinates in Tracker 

preference on or off.

User Origin

By default, the User Origin is located at the Project Origin. However, the User Origin can be moved to any 

location, allowing you to “reset the zero point” to any location.

There are three ways to reposition the User Origin:

• At any element node: click Alt + Shift (Mac: Opt + Shift).

• At any location in a model window: Click the Move User Origin button from the Standard toolbar (or the 

Coordinates palette), then click at any point in the window. The origin is instantly relocated there.

See also Editing Plane in 3D Window.

• Use a Snap Reference point as the User Origin:

When you snap to a Snap Guide during input, the User Origin is automatically relocated to the nearest 

Snap Reference point. A temporary blue X appears, indicating the User Origin for the current input.
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Note: If you have manually relocated the User Origin, the Snap Reference is not used as a User Origin.

Return User Origin to Default Position

To return the User Origin to the Project Origin, double-click the User Origin button in the Standard Toolbar.
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Elevation Values in the Tracker

During input, refer to the Tracker’s Z field to check the elevation of the newly created element.

You must activate Show Z in Tracker from the Tracker’s drop-down menu in the Standard toolbar. (This 

command is available during editing/input.).

If you are inputting a Wall, Column, Beam or Object using the Gravity function, the Z value will reflect the 

elevation of the underlying Slab/Shell/Roof/Mesh.

See Gravity.

If you switch the Show Tracker control to Always in Options > Work Environment > Tracker and 

Coordinate Input, then the Tracker’s Z field will display elevation values even if input is not yet underway; 

just move the cursor to get feedback.

The Tracker can display elevation values in one of three different forms depending on your choice: 

• from the Project Zero

• from the current Story (or in 3D, the User Origin)

• or one of the two optional Reference Levels defined in Options > Project Preferences > Reference 

Levels.

See Reference Levels Preferences.

To determine which reference level the Tracker’s elevation (Z) feedback should use:

1. Open the drop-down menu of the Tracker icon from the Standard toolbar.

2. Go to the Elevation Value Origin sub-menu.

3. Choose the desired reference level.

Define Reference Levels at Options > Project Preferences > Reference Levels.

See Reference Levels Preferences.

Related Topics:

Element Input Using Tracker Coordinates
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Selection

Apart from obvious techniques, ARCHICAD provides many intuitive selection aids to make it easy to select 

exactly the elements you need, even if they overlap.

Selecting Elements

Find and Select Elements

Selection Feedback

Selection Highlight and Element Information Highlight

Element Information Pop-up (Info Tags)

The Intelligent Cursor

Edit Selection Set

Store Selection Sets in Selections Palette

Marquee Area
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Selecting Elements

With the Arrow tool active: Point at the desired element and click; or drag the mouse to draw a shaded 

rectangle around the element you want to select.

With any other tool active: Press Shift, then point at the desired element and click; or drag the mouse to draw 

a rectangle around the element you want to select.

For more information on cursor shapes, see The Intelligent Cursor.

Select All Elements (in Window or in Marquee)

To select all elements on screen (either in the entire window or inside a previously defined Marquee area) with 

the Arrow or Marquee Tool active, use the Ctrl/Cmd+A shortcut or the Edit > Select All command.

Note: Select All will only select elements on the currently displayed story.

See also Marquee Area.

Select All Elements of a Single Type

To select all elements of a single type (for example, all Walls, or all Windows), activate the corresponding tool, 

then use the Ctrl+A shortcut.

To learn about additional Arrow tool selection options, see Select Multiple Elements With Selection Polygon.

Select Elements Based on Multiple Criteria

Use the Find & Select function to select elements defined by a wide variety of criteria.

See Find and Select Elements.

Add/Remove Elements to/from Selection

You can add elements to the selection by shift-clicking them. Shift-clicking an already selected element will 

deselect it.

Zoom to Selection

Use this command (View > Zoom > Zoom to Selection) to move in on only selected elements.

This command is also available from the context menu, if you right-click in an empty space on the screen.

Deselect Elements

To deselect one or more selected elements, do one of the following:

• Press Esc.

• Click with any tool (including the Arrow) on an empty part of the project to deselect all the selected 

elements at once.

• Click a selected element while holding down the Shift key.

• With the Arrow tool active, hold down the Shift key, and click or draw a selection rectangle around the 

elements you want to deselect.
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Selection Type (to select Morph Sub-Elements)

See Morph Selection.

Related Topics:

Quick Selection of Surface Areas

Select Multiple Elements With Selection Polygon
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Quick Selection of Surface Areas

Quick Selection is the easiest way to select single elements which have a surface area (such as slabs and 

roofs).

To activate Quick Selection as the default working mode, turn on the Quick Selection icon in the Arrow 

tool’s Info Box.

 

Now, to use Quick Selection, either the Arrow tool must be active, or you must press the Shift key.

Move the cursor over any surface of the element you want to select. You will note that every time the cursor 

hovers over a selectable element, it will change shape. Click to select.

Quick Selection works on all construction and text elements, fills and objects.

To temporarily suspend the Quick Selection method while the icon is activated, press the Spacebar with the 

Arrow Tool active, or Shift-spacebar if any other tool is active.

Quick Selection is active by default, but it can be deactivated in the Arrow tool’s Info Box by releasing the 

button.

To use Quick Selection on a temporary basis (while the Quick Selection icon is deactivated in the Arrow 

Tool’s Info Box), press Spacebar with the Arrow Tool active (or Shift+Spacebar with any other Tool).

Click and Drag with Quick Selection

With the Arrow Tool and Quick Selection active, you can drag any element by clicking on it and holding down 

the button while you drag it, without having to use the Drag command. (With any other tool active, press Shift, 

then click and drag.)

Note: All selected elements will be dragged simultaneously.
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Select Multiple Elements With Selection Polygon

1. Activate the Arrow tool.

2. Click on the screen and draw the selection rectangle/polygon.

This will select all the elements inside the area, and deselect all other currently selected elements. Keep the 

Shift key pressed to select additional elements. 

Note: To select an area instead of explicitly selecting elements, use the Marquee tool.

See Marquee Area.

You can fine-tune your selection logic using the various Selection Methods and options, explained below.

Selection Methods

The Info Box offers three selection methods when using rectangular or polygonal area selection. 

To access these options, do one of the following:

• Activate the Arrow Tool

• With any other tool active, press Shift

• With the first selection method, you only have to include one node, edge or curve of an element to select 

that element. 

• With the second, all nodes/edges must be inside the selection area for the element to be selected.

• With the third, direction-dependent selection method, the selection logic will depend on the direction in 

which you draw the rectangle.

– If you draw the selection rectangle from right to left, then the first selection method is in effect: that is, 

any element with at least one node inside the rectangle will be selected.
ARCHICAD 24 Reference Guide 472



Selection Interaction
– If you draw the selection rectangle from left to right, then the second selection method is in effect: 

that is, any element with all nodes inside the rectangle will be selected.

Selection Area Shapes

To access these options in the Info Box, do one of the following:

• Activate the Arrow Tool

• With any other tool active, press Shift

Selection area shape options are Polygonal, Rectangular and Rotated Rectangular.

Related Topics:

Selection Type (to select Morph Sub-Elements)

Watch the Video
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Selection Feedback

Selection Dots

Explicitly selected elements display selection dots (or reference points). Selection dots represent the points of 

the element by which you can modify the element.

Note: Elements selected by Marquee do not display selection dots.

The location of the selection dots depends on the type and the geometry of the element.

In the case of GDL Object type elements, the number of selection dots depends on the number of hotspots 

defined in the object.

Some GDL objects have special hotspots that enable you to graphically edit the object.

See Graphical Editing Using Editable Hotspots.
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Selection Dot Variations

Single elements have small solid selection dots which are black by default.

To change the color of selection dots, use the color chooser in Options > Work Environment > Selection 

and Element Information.

Editable selection dots are diamond-shaped and appear on GDL objects whose parameters can be edited 

graphically.

For more information, see Graphical Editing Using Editable Hotspots.

Grouped elements display larger circles. Each subsequently selected group gets a different color 

automatically.

Elements that belong to a Hotlinked Module or an XREF are shown with hollow squares, whose color is 

automatically defined.
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Locked elements’ selection dots appear in faded form.

Elements are locked (and display “locked” selection dots) in four cases:

• The element is placed on a locked Layer.

• The element has been explicitly locked with the Edit > Locking > Lock command.

• The elements belong to a Hotlinked Module or an XREF.

In all cases, locked elements can be selected, but they cannot be edited. (You will be informed of this if you try 

to edit a locked element.) You can open the settings dialog boxes of these elements, but you cannot edit their 

parameters.
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Selection Highlight and Element Information Highlight

Selection highlights are shown on the contour and/or surface of selected elements.

Element information highlights are used to assist in selection (pre-selection highlight) and identifying 

associated elements e.g. for labels, dimensions and Railings (associated elements highlight).

All these highlights can be configured in Options > Work Environment > Selection and Element 

Information, or you can turn off selection highlights altogether.

See Selection and Element Information.

Suspend Selection Highlight

Even if you leave the Selection Highlight function on, you may want to disable it temporarily - for example, if 

you want to see the actual display colors of lines and fills. To suspend Selection highlight, use the Ctrl/Alt + 

spacebar shortcut.

Note: Surface highlights in 3D are available only when using the OpenGL 3D engine.

Pre-Selection Highlight

ARCHICAD helps you identify elements by highlighting them before you select them, and when using the 

Magic Wand. 

The pre-selection highlight appears when you hover the cursor over a selectable element, then press Shift.

Note: If the Arrow tool is active, the highlight appears on its own, without your having to press Shift.
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When working in 3D, you will notice that the informational highlight acts on the entire outline of the element: 

even hidden lines of its contour are shown. Grouped elements are highlighted individually.

Associated Elements Highlight

During dimensioning, labeling, and placement of Railings and Door/Window elements, the contours of related 

elements will be highlighted to help you identify which element you are working on.

The related elements highlight also works with the Parameter transfer functions (Pick Up Parameters and 

Inject Parameters commands): the information highlight appears along with the eyedropper/syringe cursors 

right before you complete the parameter transfer. You do not need to press Shift to see the related elements 

highlight when using the Parameter Transfer function.

See Parameter Transfer.

Feedback on Overlapping Elements

You may have to select or annotate elements that overlap with other elements.

The same is true when placing an associated Railing which can follow multiple paths along the associated 

element.

To choose one of several overlapping elements (paths), hover over the elements, then press Tab to cycle the 

highlight among the elements.

When you are satisfied that the appropriate element is highlighted, click with the cursor to select or edit it.

In the following image, the related elements highlight and Info Tag tell you that the linear dimension you are 

placing will be associated to the highlighted column, not to the wall.
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If you’d rather associate the dimension to the wall, click the Tab key until the wall is highlighted, then place the 

dimension.

See Selection and Element Information.
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Element Information Pop-up (Info Tags)

If you move the cursor over an element and press Shift, an element information pop-up appears.

Note: If the Arrow tool is active, the element information pop-up appears on its own (along with the 

highlight), without your having to press Shift.

The Element Information Pop-up displays the following information:

• The element’s type

• The element’s basic properties (structural fill for Walls, name for Objects, thickness for Slabs, type for 

Lines, and so on)

• The element’s elevation (for 3D shapes only)

• The element’s Layer

• In 3D and Section/Elevation/IE and 3D Document windows, the Story the element belongs to.

• In Teamwork, the reservation status of the element (e.g., Editable, Free for Reservation, Reserved by).

Some additional information is displayed in the bottom section of the pop-up:

• If more than one element has a selectable part at the given location (node, edge, or surface if Quick 

Selection is active), the caption Multiple Elements (TAB) is shown in the Info Tag to inform you that you 

can cycle through selected and selectable elements by hitting the TAB key as many times as needed.

See also Feedback on Overlapping Elements.

• If the element is selected, the mention (Selected) appears in brackets.

Element information highlights, including the time interval before it appears on screen, can be configured in 

the Options > Work Environment > Selection and Element Information.
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Find and Select Elements

Use the Find & Select Palette to select and deselect elements based on defined criteria.

Open this palette from Edit > Find & Select;

or click the Find & Select shortcut from the Standard Toolbar:

The Find & Select palette can remain open as long as you wish on top of all windows.

Set up Criteria for Find & Select

To set up the Find & Select Criteria, you can use predefined Criteria Sets, or set up the criteria manually, as 

described in these sections:

Predefined Criteria Sets

Define Element Criteria

Define Criteria Based On Selected Elements

Click Plus to Select

Once you set up the criteria, click the Plus button. All elements that fit your defined criteria are selected.

• Elements are selected on the visible layers of the currently active window.

• The Selected and Editable values at bottom left give you feedback on the currently selected elements in 

the project.

Deselect Elements

Click the Minus button to deselect all the elements that fit the current criteria in the Find & Select Palette.
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Define Criteria Based On Selected Elements

Use this feature if you have added a number of criteria (e.g. Element Type, Layer, Surface) in the Find and 

Select dialog box and want to define their values based on an existing element. This is a quick way to define 

a Find & Select criteria set.

1. In the Find & Select dialog box, define the criteria you want to search by (e.g. Element Type, Layer).

2. Click the Pick up Settings button to activate it.

3. In the project, Alt+click an element whose settings you want to load.

4. The Element Type and Layer values of the clicked element are now loaded in the Find & Select dialog 

box.

Use Marquee in Find & Select

If you have placed a Marquee, then the Find & Select includes the Marquee criterion automatically. You can 

then opt to search either inside or outside the Marquee.

Copy Settings

If any elements are selected, the second button - Copy Settings - becomes active. Click the button to load 

the settings of the last selected element into the Find & Select dialog box.
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Related Topics:

Find and Select Text Blocks/Labels

Search for Elements by Label Text

Find and Select Missing Library Parts

Find and Select Elements with Missing Attributes

Define Element Criteria using IFC Data

Find and Select Element or Building Materials: By Property and Classification
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Define Element Criteria

In several ARCHICAD functions, you specify a group of elements by criteria before carrying out the function:

• Find & Select

• Graphic Override Rules

• Collision Detection

• Reserve Elements by Criteria (Teamwork)

• Interactive Schedule Schemes

You can set up these criteria either manually, or by using predefined Criteria Sets. (see: Predefined Criteria 

Sets)

This section describes manual criteria definition. 

Criteria definition is largely identical in all four dialogs (Find & Select, Graphic Override Rules, Collision 

Detection, Reserve Elements by Criteria).

Topics in this section:

Define First Element Type

Define Additional Element Type

Define Additional Criteria: Parameters & Properties

Define First Element Type

1. In the Criteria column, the first line is always Element Type. Click to select it.

2. In the Value column, click the pop-up and choose an Element Type from the list (e.g. Wall).
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Define Additional Element Type

To add one or more additional Element Types: 

1. Click the Add pop-up 

2. Select “Element Type” from the list. (Use the search field at the top to help locate an item.

3. Double-click, or click the list’s Add button to add it to your Criteria List.

4. In the Value column, click the pop-up and again choose the Element Type from the list (e.g. Slab).

5. Use the and/or control to further define the Element Type criteria.
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Define Additional Criteria: Parameters & Properties

To narrow the scope, add more criteria.

1. Click the Add button to bring up a list of Parameters & Properties.

2. Choose a criterion (use the search field at the top to find it more quickly), then click Add (or press Enter) 

to add it to the criteria list.

3. For each added criterion, define its Value from the pop-ups.

Available criteria depend on the Element Type(s) defined in the row(s) above. 
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For example, you can narrow the criteria based on the element’s Structural Function Classification (e.g. Load-

Bearing or Non-Load-Bearing.)

Note: Defining a “Layer” or “Layer Combination” as a criterion means that the program will find and select 

the elements which are visible according to the given Layer Combination.

Use IFC Properties or Library Part Parameters as Criteria

From the Add button’s pop-up, access additional parameter/property types:

• IFC Properties

See Define Element Criteria using IFC Data.

• Library Part Parameters (Interactive Schedule Schemes only)

See Additional Criteria and Fields: Library Part Parameters

Related Topics

Find and Select Elements

Graphic Override Rules

Collision Detection

Reserve Elements by Criteria (Teamwork)

Scheme Settings Dialog Box (Interactive Schedule)
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Predefined Criteria Sets

Several ARCHICAD functions require that you specify elements by criteria. You can set up these criteria 

manually. But to streamline the search for elements, you can use built-in or customized Criteria Sets instead, 

in the following functions:

• Find & Select

• Collision Detection

• Reserve Elements by Criteria (Teamwork)

Built-In Criteria Sets

From the Criteria Set Name pop-up, optionally choose a Built-In Criteria Set:

• All Elements

• All 2D Elements

• All 3D Elements

• All elements on unlocked and visible layers

• Inverted elements

See Inverted Elements.

• Invalid stairs

See Toplinked Stairs and Changed Story Height.

Built-in Criteria Sets cannot be modified.

Note: The built-in “All elements on unlocked and visible layers” Criteria Set is designed to fit a 

workflow in which the project manager sets up views especially defined for Teamwork usage. You can 

create several views out of a single viewpoint, then vary the layer states in each view: set the layers of 

elements that logically belong together to be visible and editable (with the rest of the non-relevant 

elements locked), then name the view accordingly. For example, a view entitled “Ceiling Plan” might place 

all the paneling and mechanical structures onto visible and editable layers. This way, the designated user 
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would reserve elements from the Ceiling Plan view by using the built-in “Elements on unlocked and visible 

layers” criteria set.

Public Criteria Sets (Teamwork) and My Criteria Sets are listed if you have already defined and saved 

custom criteria sets (see below).

Define and Store Your Own Criteria Sets

To store a Criteria Set:

1. Set up the criteria as desired. The Criteria Set name is now “Custom.”

2. Next to the Criteria Set Name field, click the pop-up button to access the relevant commands. Click Store 

as.

3. In the appearing dialog box, give a name to the Criteria Set and click Store.

In Teamwork: Choose either Public Criteria Set (to make it available to all project users) or My Criteria 

Set (if you do not wish to share it).

Your customized Criteria Sets are now stored in the Criteria Set pop-up, under “My Criteria Sets.”
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Use the commands from the pop-up to manage your Criteria Sets: Rename, Delete, Export or Import them 

(as.xml files).

Public Criteria Sets in Teamwork

In a Teamwork Project: These are criteria sets that you have created and stored a Public Criteria Set (see 

above). These criteria sets are part of the shared Teamwork project. 

Public Criteria Sets can be reserved through the Find & Select dialog box: click Reserve Public Criteria Sets 

from the Criteria Name pop-up. Public Criteria Sets are shown as underlined if they have not yet been sent to 

the server.

This reservation means that you alone have the right to modify any of the stored Criteria Sets. However, any 

user - regardless of reservation status - can create, use and store new Criteria Sets.

Note: “My Criteria Sets” are not shared, and cannot be reserved.

Related Topics

Find and Select Elements

Collision Detection

Reserve Elements by Criteria (Teamwork)
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Edit Selection Set

Use this dialog box (Edit > Element Settings > Edit Selection Set) to edit specific attributes (layers, 

pencolors, classifications and properties) for a collection of dissimilar element types simultaneously, without 

affecting any other settings of these elements.

If you change any of these attributes in the Edit Selection Set dialog box, all the selected elements will take 

on the new values.

Note: The pen setting affects all cut pens of the selected elements (cut fill pens, cut line pen).

• Modify Associated Window & Door Color: Check this box to also modify the Pencolor/Penweight of 

Window and Doors contained in any selected Walls.

Note: If not checked, the openings will retain their individual Pencolors/Penweights.

• The pencolors of GDL Object-type elements can only be changed if the object is not set to be displayed 

with its own Symbol Pens (defined in the 2D symbol of the GDL Object). When editing the object, the 

standard Pen Color radio button will be preset to the edited Pen Color.

• All parts of composite elements, such as Walls, Dimension chains or Markers (made up of lines, 

Arrowheads and Text), are modified together.

• Selected/Editable: This area displays the number of elements of each type currently selected on the 

Floor Plan and in 3D.
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Store Selection Sets in Selections Palette

Use the Window > Palettes > Selections palette to create saved, frequently accessed sets of selections that 

are stored with the Project.

The controls of the Selections Palette allow you to save any selection made on the Floor Plan, 3D window, 

Section/Elevation/IE window, or a Detail/Worksheet drawing. You can delete a selection or sort saved 

selections by name or by window of origin.

Use Add Selection to save this selection (you will be prompted to name it.) 

Use Redefine to update any Selection Set based on current element selection.

Click the list headers to sort the items by name or the window they originate in.

The bottom part of the palette displays the contents of the selection set.

Use the X, - and + controls as follow:

• Click X function to select, in the project, only the elements in the highlighted selection set.

• Click - to deselect, in the project, the elements of the highlighted selection set.

• Click + to select all the elements of the highlighted selection set (in addition to any other current selection).

The operation is always performed on the currently active window.
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Marquee Area

The Marquee tool is used to define areas for selection, editing and visualization.

Place Marquee

1. Select the Marquee tool.

2. Click in the project and define the Marquee area.

A Marquee area does not display selection dots on the included elements; the marqueed area is shown by a 

dashed line.

For more options, see Marquee Area Definition.

Remove Marquee

Do one of the following:

• Press Esc

• Use Remove Marquee from the context menu 

• Begin drawing a new Marquee

• Double-click in the window outside the marquee area with the Marquee tool selected.

If you have explicitly selected further elements within the Marquee, pressing Esc will deselect these elements 

in reverse order, and finally remove the Marquee.

If you choose another tool, the Marquee area will not be removed.
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When to Use Marquee Selection

• Define a smaller area in which to select all of elements of a given type

• View only a certain part of the project in 3D

• To move or resize several elements simultaneously

• Save only part of the view in PDF or DWG format

The Marquee is available in all project windows. 

In PhotoRendering or picture windows, and the GDL Object’s 3D view, the only operation available for a 

marquee selection is Copy.

Select All Elements in a Marquee

To select all elements inside a Marquee area with the Marquee Tool active, use the Ctrl/Cmd+A shortcut or 

the Edit > Select All in Marquee command.

View Marquee Area in 3D

Define the Marquee area, then use the View > Elements in 3D View > Show Selection/Marquee in 3D 

command; or select the same command from the context menu.

Any part of an element that falls inside the Marquee area will be included in the 3D view, even if there is no 

selection node or hotspot on this part of the element.

Note: If your plan includes both explicitly selected elements and a marquee selection, this command will 

disregard the marquee and show only the explicitly selected elements.

To further define how Marqueed elements are shown in 3D, use the “Marquee Effects” controls of the View > 

Elements in 3D View > Filter and Cut Elements in 3D dialog box.

To use the Marquee to define Photorendering output: see Render Marquee Options.

Marquee Color

The color of the Marquee is the same as that of Selection dots: set this color at Options > Work Environment 

> Selection and Element Information > Selection Dots and Marquee color.

.

Topics in this Section:

Marquee Area Definition

Save Marquee Area as PDF or DWG

Copy/Paste Marquee Area from Project Window

Stretching with the Marquee Tool

Use Marquee in Find & Select

Other Editing Operations within the Marquee
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Marquee Area Definition

Single Story or All Stories

The Marquee tool has two definition methods available in the Info Box (Floor Plan only).

• Single Story method (thin contour): Marquee elements on the current Story only.

• All Stories method (thick contour): Marquee elements on all Stories.

Marquee Area Geometry

Choose one of the Geometry Methods from the Info Box. (If you are working in the 3D Window, four options 

are available; otherwise there are three options).

• Polygonal: Only straight segments are possible.

• Rectangle method: Click twice to define.

• Rotated Rectangle: Click three times to define.

• In the 3D window: Use the Polygonal, Rectangle or Rotated Rectangle methods to first define the base 

of the marquee area, then click again to define the height of the selected space. (In perspective view, the 

marquee base must be underneath the horizon.)

• The fourth option (3D window only) allows you to draw a 2D marquee in order to copy elements from the 

3D Window in the form of pictures.

For more information, see Copy/Paste Marquee Area from Project Window.
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Save Marquee Area as PDF or DWG

When saving a project view in PDF or DWG format, you may use the Marquee to delimit the part you wish to 

save.

After placing the Marquee, use the Save As... PDF or Save As... DWG command as usual. Only the Marquee 

area will be saved to the file, rather than the entire window contents.

Save Document in PDF Format

Saving DWG/DXF Files
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Copy/Paste Marquee Area from Project Window

You can use the Marquee tool to copy and paste an area of the 3D Window, a Section/Elevation/IE or 3D 

Document window, or a Model Picture Window.

1. Generate the view you need.

2. Use the Marquee tool to select the area you wish to copy (if you are selecting from the 3D window, make 

sure that the 2D Marquee option is active).

3. Choose Edit > Copy.

If you are copying from the 3D window using the OpenGL 3D Engine, all images will be pasted in pixel 

format.

If you are copying from the 3D window using the Vectorial 3D Engine, a dialog box appears during the 

Copy operation giving you options for how the image will be displayed on the screen.

For more information, see Copy Dialog Box.

Note: If you are copy-pasting construction elements, they will be placed as 2D elements (points, lines and 

fills.)

You may find that the “exploded” 2D elements generated from the model often contain superfluous 

elements (extra line segments, overlapping or superfluous fills) that make such editing difficult. To make 

editing easier, use the Linework and Fill Consolidation functions on selected items in the window.

For more information, see Consolidate Lines and Fills in Drawing Windows.

4. Move to the Floor Plan and choose Edit > Paste.

Note: You can paste into other 2D model windows, but the pasted elements will behave as 2D drawing 

elements only, not model elements.

5. Position the image on your Floor Plan using the Trident cursor.
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6. Click outside the selection rectangle to complete the operation.

• Elevations are pasted to the Floor Plan as full-sized 2D elements.

• Parts of Model Pictures are pasted as screenshots.
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Other Editing Operations within the Marquee

If you wish to Cut, Copy, Clear, Drag, Mirror, Rotate, Elevate or Duplicate elements, they must have at 

least one node inside the Marquee area in order to be selected. The edit operations will act on the whole 

element.

To use Edit commands on a placed Drawing, include at least one node of the Drawing (i.e. one of the 

Drawing’s corners) inside the Marquee.

Note: In Section/Elevation/IE, 3D Document, Detail and Worksheet windows, some editing commands 

are available only for 2D drawing elements.

See also Stretching with the Marquee Tool.
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On-Screen Input Aids

The following sections describe ARCHICAD functions that assist in precise element input.

The Intelligent Cursor

Selection Feedback

Tracker

Ruler

Measure Tool

Set up Construction Grid

Set up Snap Grid

Snap to Grid

Snap Guides

Guide Lines

Snap Points

Editing Plane in 3D Window

Magic Wand

Gravity

Mouse Constraints

Coordinate Constraints

Relative Construction Methods

Snapping to Existing Elements

Cursor Snap Range
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The Intelligent Cursor

The cursor changes shape as you work, depending on the tool you are using, and whether an editing/input 

operation is underway or not. Cursor variations help you identify particular nodes and edges, as an aid in 

editing.
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Line

Other 

Edge

Other Edge - 
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Line

Other 
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Transfer 
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Other Cursors

Cursor Description

Empty space: No selectable objects at this location

Quick Selection option (for surface selection with Arrow tool)

Drag/Rotate/Mirror Element Copy

Drag/Rotate/Mirror Multiple Element Copies

Appears during element input/editing, when several options are available. E.g.:

• set direction of Roof pitch

• when splitting element: choose which part of element should remain selected

• set Limited depth of a Section

• curved Walls placed with tangential method - choose preferred placement. 

Fill Handle

Place Dimension/Zone Stamp/Fill Area, or Close Polygon

Paste, then move contents of Marquee/Clipboard

Choose Plane (Place Dimension in a 3D Document)

Choose Line/Edge (Place Linear Dimension - Any Direction)
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Tracker

Coordinate values are displayed in the Tracker, which follows your mouse movements and is available in any 

editable window type.

The Tracker gives you dynamic feedback on such values as edited lengths, angles, and hotspot values for 

GDL Object editing.

Also use the Tracker to input elements by defined values.

See Element Input Using Tracker Coordinates.

Show Tracker

Activate the Tracker toggle on the Standard toolbar

or check Show Tracker in Options > Work Environment > Tracker and Coordinate Input:

• By default, the Tracker appears On-demand: that is, only during coordinate input and editing operations.

• To show/hide the Tracker if you have not yet begun element input: use the N shortcut. The Tracker will 

pop up and display the cursor position.

• Alternatively, choose Always to display the Tracker continuously. This means that the Tracker will follow 

your cursor even if you are not inputting anything, providing feedback on the cursor position.

Tracker options (including colors, contents and behavior) can be set in Options > Work Environment > 

Tracker and Coordinate Input.

Some Tracker options are commands accessible from the pop-up arrow next to the Standard toolbar’s Tracker 

toggle.
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Origins of Coordinate Values in Tracker

By default, the Tracker displays Relative coordinates.

• Relative Coordinates are measured from the Edit Origin.

Use the Tracker menu from the Standard Toolbar to toggle the Relative Coordinates in Tracker preference 

on or off.

When you snap to a Snap Guide during input, the User Origin is automatically relocated to the nearest 

Snap Reference point. A temporary blue X appears, indicating the User Origin for the current input.

• Absolute coordinates are measured from the User Origin. (If you haven’t reset the User Origin, this is the 

same as the Project Origin). The Tracker displays Absolute coordinates if you have turned off the 

“Relative Coordinates in Tracker” toggle.

See Origins.

A temporary dashed line is drawn between the origin and the cursor to indicate that you are using 

absolute coordinates.

For information on Elevation values, see Elevation Values in the Tracker.
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Element Input Using Tracker Coordinates

When placing a new element, you can define its coordinates in the Tracker during input.

With the Tracker displayed, do one of the following:

• Start typing a value for the default parameter (the one shown in bold.) The cursor will automatically jump 

to the Tracker and enter the value.

Note: This input method works if the “Enable direct input into Tracker fields” box is checked in Options > 

Work Environment > Tracker and Coordinate Input. This is the default setting.

• Press Tab as many times as needed to activate the required Tracker field, then type in the desired 

number.

• Click a field in the Tracker to activate it, then type in the desired number.

• Type a shortcut (X, Y, Z or D/R or A) to activate the corresponding Tracker field, immediately followed by 

the value. For example: X3 or Y-4. 

Notes:

– This input method works if the “Coordinate Shortcuts prefer Tracker” box is checked in Options > 

Work Environment > Tracker and Coordinate Input. This is the default setting. 

– The + prefix is optional for positive values.

– You can type coordinate values in any order.

– If the Tracker is displayed in its compact form, typing the shortcut for a hidden parameter (or clicking 

Tab) will display it.

For another method of coordinate input, see Coordinates Palette.

Complete Element Input

Press Enter or click the checkmark icon in the Tracker.

Display Snap Guides at Coordinate

Click the crosshair icon in the Tracker. The edited element will then jump to that coordinate value and, if Snap 

Guides are active, the applicable Snap Guides will appear.

For more information, see Pin or Place a Snap Guide Manually.

Cancel the last operation

Press Esc.

Add to or Subtract from Current Value

Type + or – after the value. For example, typing x3+ will add 3 to the x value shown in the Tracker box.
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Notes for users of U.S. dimensions: 

– Two dashes are required for subtraction of whole feet because the first dash is interpreted as an 

indication that inches are to follow.

– When 3 is entered, ARCHICAD assumes you mean three feet. Typing 3’6, 3’6’’, or 3-6 will enter three 

feet, six inches.

Copy-Paste Coordinate Values

Coordinates can be copied and pasted using the clipboard. The Cut, Copy and Paste menu items are 

inactive during numeric input, so you must use the standard shortcuts or the context menu.

Parameters Shown in Tracker

The parameters appearing in the Tracker vary depending on the type of editing action that is underway. For 

example, if you select a straight segment and choose the Curve edge command from the pet palette, then the 

Tracker shows the “Arc Radius” parameter.

The Tracker always shows one of its parameters in bold; this is the default parameter.

Depending on your choices in the Tracker pop-up menu in the Standard Toolbar, the Tracker will display only 

the XY or the DA (distance/angle) coordinate pair (switch from one to the other by clicking “Prefer XY 

Coordinates/Prefer Polar Coordinates” during editing/input), and will show or hide the names of the 

coordinates (“Show/Hide Parameter Tags”).

Hint: To switch between DA and XY coordinates on the fly, use the / (slash character) shortcut.

As a rule, the parameters in the Tracker will be listed in order of relevance, with D/A coordinates followed by 

X, Y and Z coordinates.

If you have activated the Expand Tracker Automatically option from the drop-down Tracker menu, then all 

the parameters will be shown as soon as you enter the Tracker (by entering a value or by pressing Tab).

Note: The same option, “Expand Tracker automatically during numeric input,” is also available as a 

checkbox in Options > Work Environment > Tracker and Coordinate Input.

Otherwise, if you want to expand the Tracker, enter the Tracker by pressing Tab, then click the arrow at the 

bottom of the Tracker to expand it.
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Coordinate Input Logic: Expert Options

Special Tracker options are available to let you further customize the Tracker function, using the Coordinate 

Input Logic checkboxes in Options > Work Environment > Tracker and Coordinate Input.

For information on all these options, see Tracker and Coordinate Input.

Related Topics:

Elevation Values in the Tracker
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Ruler

The Ruler is an editing aid that can be placed at the top and left side of the screen in every ARCHICAD 

window, except the 3D Window and Schedules.

Use the Ruler as an aid in navigation: it lets you know where you are in the project, at the current zoom.

Show/Hide Ruler

Use the View > Ruler toggle to show or hide the Ruler.

You can also hide a ruler by right-clicking it and clicking the Ruler toggle.

As you move the cursor on screen, feedback on the ruler shows you the vertical and horizontal position of the 

cursor relative to the User Origin (or, if no User Origin has been created, relative to the Project Origin).

See Origins.

Every time you create a new User Origin, the measurements shown on the Ruler change accordingly. The 

measurement units are the Model Units you set in Options > Project Preferences > Working Units.

Place Orthogonal Guide Line Parallel to Ruler

At any time, click on the Ruler, then drag your cursor to anywhere in the window: a Guide Line parallel to the 

Ruler will be created.

See also Guide Lines.

Ruler Commands

The Ruler’s context menu (right-click anywhere on the Ruler) gives you a quick way to access related 

commands:

• Click the Ruler toggle to hide the Ruler

• Click Cursor Projection toggle to include projection lines from the Ruler to the cursor position. (This will 

also turn on Cursor Projection in the 3D window.)

• Click Options > Project Preferences > Working Units to access this dialog box, where the Model Unit 

option determines the Ruler’s measurement units.
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Measure Tool

The Measure tool, located in the Standard toolbar, allows you to measure distances and areas in the project.

It is a temporary, on-screen function for quick feedback.

To use the Measure Tool, activate its icon in the Standard Toolbar, or use the M shortcut. Click on a starting 

point (the top left corner of the rectangular wall, in the image below) and start to trace the wall. The Tracker 

displays the horizontal, vertical and radial distance measured from the starting point, as well as the angle.

You can Measure any number of segments in sequence: each click represents a new starting-point from 

which the next distance will be measured. After two or more clicks, the Tracker also shows a cumulative 

distance and the area (shown by a temporary gray area on screen). The image below shows the Measure tool 

feedback after three clicks, as you approach the last corner of the rectangular wall.

You can also use the Measure tool while creating elements. When you start drawing a Wall, for example, you 

can activate the Measure tool on the fly, measure (or even edit) a value with the fields it displays and then hit 

Enter to transfer this value into the appropriate field of the Tracker.
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Set up Construction Grid

Grids can be defined separately for the Floor Plan and any individual Section/Elevation/IE, 3D Document, 

Detail/Worksheet, or Layout window. Note that, in Floor Plan window, the same Grid settings will be used for 

all Stories.

Note: You can also create, place and use custom local structural grids of different sizes and shapes using 

the Grid Tool.

See The Grid Tool.

Show/Hide Construction Grid

Do one of the following:

• Toggle the View > Construction Grid Display command

• Use the Standard Toolbar’s Grid pop-up menu

• Open View > Grid & Editing Plane Options > Grids & Background, and check Show Construction 

Grid.
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Define Construction Grid and Auxiliary Grid

1. Open View > Grid & Editing Plane Options > Grids & Background.

2. Enter Spacing values to define the horizontal and vertical distances between grid lines.

Note: Spacing values also define the Nudge distance: use the Nudge shortcut to move elements by a 

predefined factor. (use Alt + Shift + an arrow key to move the element left, right, up or down). See Nudging 

Elements.

Add Optional Auxiliary Grid

The Auxiliary Grid can be used if you want to create periodic or stepped grids. For example, to indicate the 

thickness of concrete walls or foundation footings.

To use it, set separate Spacing and Steps values for the Main Grid and the Auxiliary Grid.

Step values define the number of times to display the grid line before displaying the Auxiliary grid line, in both 

the horizontal and vertical directions. If the “Steps” value for any of these grid lines is 0, those lines will not be 

displayed.

In this example, you display one main grid line (spacing 2000), followed by two Auxiliary grid lines (spacing 

1000); then the pattern repeats.

Note: All the values in this dialog box are based on the current measurement units defined in Options > 

Project Preferences > Working Units.

View the preview of the Construction grid (both the Main grid lines and Auxiliary grid lines). Use the 

percentage and Zoom In/Zoom Out controls (below the preview window) for zooming in the preview window.

Note: The grid is automatically hidden if it would be too dense on the screen, that is, if the smallest 

distance between two adjacent grid lines would be smaller than 3 pixels.

Rotate Construction Grid

1. Go to the View > Grid and Editing Plane Options > Grids and Background dialog box.

2. Check the Rotate Grid box.

3. Specify X and Y values to specify a Local Origin that is different from the Project Origin.
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4. Define a Rotation Angle.

To define a rotated grid by hand: first, choose Set Rotated Grid from the Standard Toolbar, then draw a vector 

on screen or click on an existing straight segment: this vector will represent the rotated grid angle relative to 

the horizontal axis.

To display the rotated Construction Grid, make sure the Construction Grid is visible, then activate Rotated 

Grid button from one of the following locations:

• View > Grid & Editing Plane Options > Rotated Grid 

• Use the Standard Toolbar’s Grid pop-up menu

• Open View > Grid & Editing Plane Options > Grids & Background, and check Rotate Grid.

Related Topics:

Set up Snap Grid

Snap to Grid

Set Window Background and Grid Line Color
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Set up Snap Grid

The Snap Grid is an invisible grid that you can use optionally to make input easier, by having the cursor snap 

to a predefined distances. 

To define a Snap Grid:

1. Open View > Grid & Editing Plane Options > Grids & Background.

2. Use the controls under Snap Grid/Nudge to define the intervals (horizontal and vertical directions) to 

which the cursor will snap when Snap Grid is activated.

You will usually enter the smallest unit of measurement relevant to your Project. You can set different 

horizontal and vertical Snap Grid increments, allowing you to reflect the unique geometry of your Project.

Note: The Snap increments you define here can also be used for the Nudge shortcut - to easily move any 

element by a small defined factor, using a keyboard shortcut. See Nudging Elements.

Related Topics:

Set up Construction Grid

Snap to Grid

Set Window Background and Grid Line Color
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Snap to Grid

The Grid Snap function (Alt+S) assists in the precise graphic alignment of elements, even at low zoom levels. 

When grid snap is active, the cursor always snaps to the nodes of either the Construction Grid or the Snap 

Grid.

Activate Grid Snap

Do one of the following:

• From View > Grid Snap Options: Select Snap to Snap Grid or Snap to Construction Grid.

• Use Snap to Snap Grid or Snap to Construction Grid from the grid menu in the Standard Toolbar, or 

from the Coordinates Box.

• Select one of the three Snap buttons at View > Grid & Editing Plane Options > Grids & Background.
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– No snap

– Snap to Snap Grid

– Snap to Construction Grid

Use the Shift+S shortcut to toggle among these three options.

• Use the View > Grid Snap menu command. The Snap function will use the last grid type used, either 

Construction or Snap grid. (Shortcut: Alt+S)

Deactivate Grid Snap

Do one of the following:

• Use the Alt+S shortcut key

• Use the View > Grid Snap menu command (deactivate the toggle).

Related Topics:

Set up Construction Grid

Set up Snap Grid
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Snap Guides

 Snap Guides are temporary lines and arcs that appear along existing elements, to assist accurate element 

placement.

Unlike Guide Lines, Snap Guides are temporary and disappear automatically when the cursor is no longer in 

the vicinity. However, you can make a Snap Guide remain in place by pinning it.

You can also control which Snap Guides appear by marking particular points or edges as Snap References.

See the sections below on how to use Snap Guides:

Lock Input to Snap Guide

To constrain your input to the desired Snap Guide, do one of the following: 

• Press Shift during input

• From the context menu, use Lock to Guide Line/Snap Guide

Turn Snap Guide Function On/Off

To activate/deactivate Snap Guides, do one of the following:

• Click the Snap Guides and Points toggle from the Standard Toolbar
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• Use the Snap Guides command in the toolbar dropdown

• Use View > Snap Guides

Activate Snap References

To make Snap Guides appear in more places that are relevant to your input, you can define any edges or 

points as Snap References.

Activate a Snap Reference (a dynamically appearing blue highlight) by hovering the cursor over element 

edges or points:

You can activate any number of Snap References simultaneously. Once you have defined Snap References, 

you will see additional Snap Guides appear which are relevant to those References as well as your current 

input vector.

See Appearing Snap Guides.

Again, to lock your input vector to any Snap Guide, press Shift.

Snap References stay in place, even if you move the cursor away, until you do one of the following:

• Complete input

• Click ESC

• Hover over the existing Snap Reference until it disappears, or click Q (see Force Snap Reference 

(Shortcut), below).

Watch the Video

Watch the Video
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Force Snap Reference (Shortcut)

Click Q on any edge or point to “Force Snap Reference”, to highlight an edge or node as a Snap Reference 

instantly (regardless of the timer set in the Work Environment).

Note: The predefined Shortcut for this command is the Q key, but may vary depending on your localized 

version of ARCHICAD.

Appearing Snap Guides

During input, Snap Guides will pop up automatically and temporarily.

Which Snap Guides will appear?

• Snap Guides which are relative to the location of your cursor (e.g. Horizontal/Vertical, Parallel to Grid, a 

fixed Incremental Angle), depending on the options set at Options > Work Environment > Input 

Constraints and Guides.

• Snap Guides relative to any Snap References you have marked, and to the relations among those Snap 

References.

Where applicable, icons on the Snap Guide indicate the relation:

• Tangent

• Parallel

• Perpendicular

• Angle Bisector (if applicable)

• The line connecting two circles’ centerpoints (if applicable)

Pin or Place a Snap Guide Manually

Unlike the automatically appearing Snap Guides, a pinned or explicitly placed Snap Guide is infinitely long 

and will remain visible, without fading out, until input is complete - even if you move the mouse away.

To pin a Snap Guide so that it does not disappear until input is complete, or to place one manually, do one of 

the following:

• From the context menu of an existing Snap Guide, use the Pin Snap Guide command:

• From the context menu during element input, use the Place Snap Guide/Snap Circle command:
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• During Tracker input, click the crosshair icon in the coordinate field. The edited element will then jump to 

that coordinate value and the applicable Snap Guides will appear.

Options for Snap Guides and Snap References

Options for Snap Guides/References are set at: Options > Work Environment > Input Constraints and 

Guides.

The color of the Snap Reference is the same as the Snap Guide color.
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Guide Lines

Guide Lines (and Guide Circles) are drafting aids which help you find special points and projections, to ensure 

precise input in both 2D and 3D windows. 

Unlike Snap Guides, Guide Lines are explicitly placed by you. They are always “permanent”, that is, they 

remain in place until you remove them.

Turn Guide Line Display on or off

Do one of the following:

• Use the toggle button in the Standard toolbar

• Use a shortcut key to toggle Guide Lines on and off

Note: The predefined Shortcut for this command is the L key, but may vary depending on your localized 

version of ARCHICAD.

• Use the View > Guide Lines toggle

Lock Input to Guide Line

Once you have placed Guide Lines, use them to assist in precise element creation. To constrain your input to 

the desired Guide Line, do one of the following: 

• Press Shift during input

• From the context menu, use Lock to Guide Line/Snap Guide

Place Guide Lines

1. Make sure Guide Lines are On.

See Turn Guide Line Display on or off, above.

2. The window will display Guide Line tabs on all four sides of the screen.

3. Click any tab, then drag the appearing Guide Line to any location in the viewpoint.
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4. Let go to place the Guide Line.

• If you place it along any existing edge, the Guide Line snaps to that edge.

• If you place it on a curved element, a corresponding Guide Circle appears.

• If you place it at a point, the Guide Line is placed at the corresponding main direction.

• You can also place it without snapping it to any existing element.

Other Ways to Create Guide Lines

• It is possible to draw a straight or curved Guide Line segment anywhere in the window, with two clicks. 

See Create Guide Line Segment.

• If you are using the Ruler, click on the Ruler, then drag your cursor to anywhere in the window: a Guide 

Line parallel to the Ruler will be created. See Ruler.

Cancel Guide Line Placement

During Guide Line placement, do one of the following:

• Press Esc

• Drag the Guide Line back to any Guide Line tab, which is now shown as a garbage can.

Create Guide Line Segment

Use this command to create a Guide Line segment anywhere with two clicks.

1. Right-click any Guide Line tab, or click the Guide Lines pop-up menu from the Standard Toolbar.

2. Choose Create Guide Line Segment.
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Note: This command is also available at View > Guide Line Options.

3. A pet palette appears. Choose a preferred line segment option, then draw the Guide Line or Guide Circle 

(arc).

Drag/Offset Guide Lines or Guide Circles

1. Hover over a Guide Line until its handle (the orange dot) appears.

2. Click-and-drag the handle to drag the Guide Line to a new location. (Or use the Tracker to define its new 

location numerically.)

With a Guide Circle, this operation becomes a radial stretch (as also indicated by the icon). 

If you drag the Guide Circle onto a linear edge, it is transformed into a straight Guide Line, and vice versa.

Remove Single Guide Line

Hover over a Guide Line until its handle (the orange dot) appears, then do one of the following:

• With the cursor over the Guide Line handle, press Esc.

• Click-and-drag the handle to drag the Guide Line to the nearest garbage can.

• Right-click, then choose Remove Guide Line from the context menu.
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Erase Guide Lines

Use this command to remove several Guide Lines in a single operation:

1. Right-click any Guide Line tab in the window, or click the Guide Lines pop-up menu from the Standard 

Toolbar.

2. Choose Erase Guide Lines.

Note: This command is also available at View > Guide Line Options.

3. The Erase cursor appears.

4. Click anywhere on any Guide Line, one after the other, to erase them instantly.

Alternative, drag the Eraser cursor across the screen. Any Guide Line it touches is erased instantly.
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5. When you are done, press Esc or double-click to exit Erase mode.

Remove All Guide Lines

This command removes all Guide Lines from ALL viewpoints in the project.

Do one of the following:

• Right-click any Guide Line tab, or click the Guide Lines pop-up menu from the Standard Toolbar. Then 

choose Remove All Guide Lines.

Note: This command is also available at View > Guide Line Options.

• Right-click on any single Guide Line to open the context menu. Then choose Remove all Guide Lines.

Guide Line Color

Set the Guide Line color at Options > Work Environment > Input Constraints and Guides.
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Snap Points

Snap Points are temporary hotspots that appear at particular intervals (defined by you) on elements, to help 

you place and draw new elements more accurately.

Activate Snap Points

1. Do one of the following:

– Activate the Snap Guides and Points toggle on the Standard toolbar

– Turn on Snap Points from the Snap Guides and Points drop-down menu

– Click View > Snap Points

Using Snap Points

Hover your cursor over the element on which you want to see the Snap Points.

The Snap Points appear. Their number and position depend on the options set by you.

See Define Snap Point Intervals, below.

The Snap Points act as a temporary hotspot - you can snap to them with your cursor, and they also serve as 

Snap Reference points. (See Activate Snap References.) You can start drawing new elements from these 

points or use them for editing other elements in relation to them.

Snap Points will disappear after about 5 seconds. However, if they are located along a Snap Reference 

segment, they will remain visible as long as that Reference does.

Note: To have the snap points remain visible until you either place an element or change views: disable 

the “Autohide Snap points” checkbox in Options > Work Environment > Input Constraints and Guides.

Another way to use snap points is to draw a temporary vector that displays the defined Snap Points.

See Snap Points on Temporary Vector.
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Define Snap Point Intervals

Click the Snap Guides and Points drop-down menu from the Standard Toolbar.

The same commands are available from View > Snap Point Options menu, or from the Control Box.

• Half: Divides an edge into two equal parts.

• Divisions: Divides an edge into the set number of segments. Range: 3-100.

• Percent: Divides an edge into two parts according to the set percentage.

• Distance: Divides an edge into segments that are the set distance apart.

• Best Division by Distance: Snap points will divide the edge into equal parts that are as close as possible 

in length to the distance defined here.

Note: Define your preferred divisions, percentage, etc. in the Snap Point Values Dialog Box.

See Snap Point Values, below.

When using the Percent or Distance interval, you have two further options:

• Start from Endpoint: the Snap point is placed at the given percent/distance as measured from the 

element’s endpoint that is closest to the cursor.
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• Start from Midpoint: the Snap point is placed at the given percent/distance as measured from the 

element’s midpoint.

In either case, feedback shows starting point from which the element is marked.

Snap Point Values

From the Snap Points menu in the Standard Toolbar (or the View menu), click the Set Snap Values 

command.

In the appearing dialog box, define the values for your divisions, percentage, and/or distance.
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Snap Points Options

From the Snap Points menu in the Standard Toolbar (or the View menu), choose one of three options for 

setting your Snap Points:

• Between Nodes: Snap points appear only on the chosen segment (between the neighboring nodes).

• Along Entire Element: Snap points appear at the defined intervals along the whole element (including 

polygon elements), regardless of any intersecting elements.
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• Between Intersection Points: Snap points are placed on the chosen element only from one intersection 

point to the next.

Snap Point Color

To customize the color of your Snap Points, use the control in Options > Work Environment > Input 

Constraints and Guides.
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Snap Points on Temporary Vector

You can display Snap Points on a temporary vector used while drawing elements. The method can be 

activated with the Snap Point icon among the relative construction icons in the Control Box.

See Control Box.

In the following example, you will draw a Wall that starts at one- fourth of the gap between two endpoints of 

two other Walls.

1. Start by choosing the Divisions option in Snap Point Settings, then type 4 as the number of Divisions.

2. Make sure that Grid Snap is inactive. (View > Grid Snap is off.)

3. Activate the Wall tool. 

4. Choose the Special Snap Point icon in the Control Box, and click it to activate.

5. Draw reference vector from one Wall endpoint to another.

6. Snap Points are now available along the vector, at each of four divisions, as defined in the Control Box.

Click at the desired location to start drawing the new Wall.
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Editing Plane in 3D Window

When you open the 3D window, an editing plane automatically appears: new elements will be placed onto this 

editing plane. 

If you begin element input by snapping to an existing element hotspot or surface, the editing plane will 

automatically move to that position. 

You can reposition the editing plane manually at any time. 

During editing, the editing plane may adjust itself automatically. For example, as you drag this roof ridge, the 

editing plane automatically becomes the vertical plane on which you drag the cursor.

Topics in this section:

Editing Plane Display

Reposition Editing Plane
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Editing Plane Display

The Editing Plane is shown by default in the 3D window. To hide it, use the toggle at View > Editing Plane 

Display.

Note: Regardless of the state of this toggle, the Editing Plane will be temporarily displayed whenever 

necessary: for example, after you choose a plane for Ruled Shell input.

Display Editing Plane During Editing Operations Only

1. Go to Options > Work Environment > On-Screen Options.

2. Check the box to Display Editing Plane during Editing Operations Only.

If you check this box, the Editing Plane will appear only during the time you are actively editing in the 3D 

window (provided that the “Editing Plane Display” toggle is turned on.) When you are done with the operation, 

the Editing Plane disappears.

3D Editing Plane: Color and Grid

The 3D Editing Plane has a grid system that is the same as the one on the Floor Plan, and reflects the X-Y 

coordinate plane.

1. Activate the 3D window.

2. Go to View > Grid and Editing Plane Options > Grids and Background to set up your grid and color 

preferences.
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Reposition Editing Plane

Use Editing Plane commands to change the default editing plane position, either before or after beginning 

element input. The available commands vary depending on your editing situation.

Note: The Offset and Snap to Story commands are available only before you begin input.

Where To Find Editing Plane Commands

To reposition the editing plane in the 3D window, either before or during editing, use the commands from one 

of the following places:

• Click the square-shaped editing plane “Grip”. 

• Right-click to bring up a Context menu, then choose Editing Plane.

• Access the commands from the Drafting Aids Toolbar. 

• Access the commands from View > Grid and Editing Plane Options.

Snap Editing Plane to Story

Use this command prior to element input.

To snap the editing plane to a specific level corresponding to a project story:

1. Bring up the Editing Plane commands.

2. Choose Snap to Story. 
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3. From the appearing dialog box, choose the project story to which you want to move the editing plane.

Offset Editing Plane

Use this command prior to element input.

1. Bring up the Editing Plane commands.

2. Choose Offset.

3. Use the cursor to drag the editing plane to the desired position, or define the offset distance numerically. 

Notice that a Snap Guide appears marking the story positions, to make it easier to place the editing plane.

Other Editing Plane Commands

Choose one of the options for your preferred editing plane orientation (the available options vary depending 

on the orientation of the current editing plane).

– Next Plane: Click this to switch to the next editing plane that makes sense in the editing context.

– Pick Plane.

See Pick Plane.

– Horizontal: Rotates the editing plane to a horizontal position.

– Vertical: Rotates the editing plane to a vertical position.

– Offset.

See Offset Editing Plane.

– Look to Perpendicular: Sets up the 3D window so that it is perpendicular to the Editing Plane.
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– Projection to Editing Plane.

See Cursor Projection onto Editing Plane.

– Lock to Plane.

See Lock to Plane.

Pick Plane

Once you click this command, the gray rectangle “plane chooser” feedback appears.

Do one of the following to pick the desired plane for the editing plane:

• Move the cursor onto any plane of an existing element. A rectangle will help you see the plane.

• Click on any three points in space (such as three element hotspots) to define a plane.

• Click on an element edge plus another point (in either order) to define a plane.

Cursor Projection onto Editing Plane

By default, as you perform graphical editing, your cursor is moving on the editing plane. If needed, you can 

redefine the direction of this cursor projection.

To change the cursor projection with respect to the editing plane:

1. Begin the editing operation.

2. From the context menu, select Projection to Editing Plane.

Alternatively, click on the Editing Plane Grip to bring up the same commands.

3. Choose one of the projection options:

• Vertical

• Horizontal
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• Perpendicular to Editing Plane

• Perpendicular to Result Plane

Lock to Plane

Use this command lock input to the existing editing plane before you start creating the new element.

This is useful, for example, if you wish to create an element on the existing editing plane, by tracing the shape 

of an existing element (e.g. roof) on another plane.

1. Bring up the Editing Plane commands.

2. From the Projection to Editing Plane sub-menu, choose the Lock to Plane toggle.

The new element will be placed onto the editing plane, even if your cursor is on another plane.
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Magic Wand

The Magic Wand (shortcut: Spacebar) saves you work by finding and tracing a linear or polygon shape from 

among existing elements, and then generating a new element based on that polygon.

• If you click on an edge or node, the Magic Wand traces the element and/or element chain.

• If you click in empty space, or on a surface, the Magic Wand traces the closed geometric area formed by 

the nearest elements.

Related Topics:

How to Create an Element with the Magic Wand

Using the Magic Wand to Add/Subtract Polygon Shapes

Magic Wand Settings

How to Create an Element with the Magic Wand

1. From the Toolbox, select the type of the new element you want to create.

2. Activate the Magic Wand by doing one of the following:

– Press the Spacebar

– Click the Magic Wand icon in the Control Box 

– Choose Design > Outline Polygon with Magic Wand

3. View the graphical feedback to see the potential result(s). (See below).

4. Click to automatically find and trace a polygon shape.
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Graphical Feedback

While the spacebar is pressed, move the cursor around to view feedback on the possible resulting elements. 

Here, if you are using the Magic Wand to create Walls atop two intersecting slabs, the feedback shows you 

the possibilities:

Note: The Magic Wand preview highlight color can be set in the Work Environment settings.

See Selection and Element Information.
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Magic Wand Cursor Icons

The Magic Wand has three different shapes for identifying:

Magic Wand Examples

• Activate the Roof tool (Multi-plane method) and click with the Magic Wand on the edge of the Wall to 

instantly create a Roof whose pivot line traces the Wall polygon.

Watch the Video

nodes

 

edges

 

empty space and surfaces
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• Activate the Fill tool, then click with the Magic Wand inside the empty area denoted by the curved line, to 

create a Fill of that shape.

Hints and Tips 

• New elements use the current default settings of the corresponding tool. You should always check that 

these are correct either before or after using the Magic Wand, especially if the elements are intended to 

have a specific relationship to each other, such as a roof resting on a Wall.

• You can refine the Magic Wand function by selecting one or more elements. In this case, the Magic Wand 

will only take the selected elements into account when searching for chained elements or a bounded area.

• When creating curved Walls and polygon-type elements based on Arcs, Circles and Splines, the 

approximation is defined in Magic Wand Settings.

See Magic Wand Settings.

• The new elements are not linked to the originals and can be manipulated independently.

• If Offset or Multi-Offset has been activated, you can complete the offset function after the Magic Wand has 

created the new polygon.

• If you are creating a single Roof, you must first draw a pivot line and define the pitch before creating the 

polygon with the Magic Wand.

• If you are creating a Fill with a custom origin, you will first generate the polygon with the Magic Wand, then 

draw the fill orientation vector.

Using the Magic Wand to Add/Subtract Polygon Shapes

Use the Magic Wand to add or subtract the shape of an existing polygon (of the same or a different element 

type).

1. Select the polygon from which you wish to subtract another shape. In this example we want to subtract a 

polygon from a slab.

2. Choose the “Subtract from Polygon” icon in the pet palette.

3. Move the cursor onto the polygon that you want to subtract and activate the Magic Wand (press the 

spacebar).
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4. Click to complete.
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Magic Wand Settings

Use the Design > Magic Wand Settings command to open this dialog box.

When creating curved Walls and polygon-type elements based on Arcs, Circles and Splines, the 

approximation is based on the state of the Magic Wand Settings dialog box.

With the two radio buttons on the right, you can choose between two tracing methods.

• Best Match: Curved segments (when applicable) will follow as best as possible the natural form of 

Circles, Arcs and Splines.

• Prefer Linear Segments: Only linear segments are used.

The four radio buttons on the left allow you to choose from a set of options to approximate curves with linear 

segments.

• Deviation from Curves: Enter a value to define the maximum deviation of the polygon from the original 

curved element.

• Segments Along Arcs: Define the number of segments along an Arc.

• Segments Along Circles: Define the number of segments along a Circle. In this case, arcs will be 

transformed into a number of segments corresponding to the part of the circle they represent.

• Segment Length: Enter a value to define the segment length for transformations resulting in segments of 

uniform length.

Note: If you choose the Best Match method and real curves cannot be created, ARCHICAD will try to 

approximate curves in the hierarchical order represented in this dialog box.
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Gravity

When placing a new Wall, Column, Beam or Object-type element (including a Level Dimension), you can use 

the Gravity function to automatically place the new element directly on top of a Slab, Roof, Shell or Mesh on 

the same story, thus taking on the elevation of the element it is placed on.

Gravity is useful if you are placing elements on the Floor Plan. (In the 3D window, the Surface Snap feature 

achieves this same effect. See Surface Snap in 3D.)

To choose an option, use the Gravity controls in the Standard toolbar or the icons of the Coordinates palette.

Note: Gravity only affects newly created elements and cannot be used for editing existing ones.

For example, to place trees on top of a Mesh, activate the Object tool, choose the tree, then select “Gravitate 

to Mesh” from the Gravity pop-up in the Standard toolbar. When you then place the trees, they will gravitate to 

the elevation of the Mesh at the point of placement.
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Level Dimensions placed with Gravity On, above Slabs, Roofs, Shells or Meshes, are associated to them.

If the Gravity function is on (activate Gravity icon) while you are placing a new element, but there is no 

underlying Slab, Roof, Shell or Mesh, then the new element will be placed as usual, at the elevation defined in 

its Tool Settings.
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Mouse Constraints

ARCHICAD’s Mouse Constraints are editing aids that can be used as an alternative to Snap Guides and 

Guide Lines.

See Snap Guides and Guide Lines.

The angle pairs they define can be used to lock the cursor at a particular drawing angle, by pressing Shift 

during input. The mechanism can only be engaged while drawing or editing an element, as indicated by the 

thick rubber band line shown in the Floor Plan or the ghosted element contour shown in the 3D Window. It 

temporarily locks the cursor’s polar angle value in the Coordinates Palette using one of the angle pairs 

defined in the Options > Work Environment > Input Constraints and Guides.

See Input Constraints and Guides Dialog Box.

Using Mouse Constraints

Projection of Cursor with Mouse Constraints

Using Mouse Constraints

Constraining the drawing direction helps you precisely align or connect new elements. To use the orthogonal 

direction sets for drawing a new element:

1. Make sure the Grid Snap Function is disabled.

See Snap to Grid.

2. Click to start drawing an element.

3. Move the cursor from this starting point and hold down the Shift key. ARCHICAD will search for the closest 

enabled constraint direction.

Projection of Cursor with Mouse Constraints

When the drawing direction is constrained by pressing Shift, a dotted line connects the unfinished element 

with the location of the cursor.

To switch among these options:

1. Display the Control Box. (Window > Palettes > Control Box)

2. Draw an input vector on screen.

3. Press Shift to enable a constraint.

The Cursor Snap Variants pop-up is now active in the Control Box. Move your cursor to this pop-up and 

choose the cursor snap variant you need.

See Control Box.
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• Perpendicular to the constrained direction

• Horizontal from the constrained direction

• Vertical from the constrained direction
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Coordinate Constraints

You can lock a cursor coordinate and thereby restrict the movement of the cursor by pressing Alt (Windows) 

or Opt (Mac) and either X, Y, A, or R/D on the keyboard.

If the Snap Guides and Snap Points function is active:

• Alt/Opt + X produces a vertical Snap Guide.

• Alt/Opt + Y produces a horizontal Snap Guide.

• Alt/Opt + A (having defined the Angle value numerically or drawing in a sample direction) produces a 

corresponding Snap Guide.

• Alt/Opt + R produces a Snap Guide Circle whose radius is determined numerically or graphically.

To unlock the constraint, just press the same key combination (e.g. Alt/Opt + X) again.

If the Snap Guides and Snap Points function is inactive, the locking function works the same way, but you will 

not see the Snap lines/points.
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Relative Construction Methods

In addition to Guide Lines and Snap Guides, the relative construction methods also constrain the element 

construction direction to a constant angle or offset. They are accessible from the Drafting Aids toolbar:

They can also be accessed from the third button of the Control Box.

Note: The Control Box is not visible by default. It is available at Window > Palettes.

See Control Box for more information.

Each Relative Construction Method is described in the following sections:

Parallel and Perpendicular Constraints

Angle Bisector Constraint

Offset and Multiple Offset Constraints (Relative Construction Methods)

Aligning Elements to a Surface in 3D

Snap Points on Temporary Vector
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Parallel and Perpendicular Constraints

Use these commands to draw new elements that are either parallel to or perpendicular to a reference line or 

existing element edge.

The Parallel and Perpendicular constraint commands are accessible from the Drafting Aids toolbar:

They are also accessible from the Control Box.

Note: The Control Box is not visible by default. It is available at Window > Palettes.

See Control Box for more information.

1. Make sure that the Grid Snap Function is inactive.

See Deactivate Grid Snap.

2. Choose the Perpendicular or Parallel icon and click it to make it active.

3. Select a line or an element edge as a reference by clicking it (the Mercedes feedback will indicate an 

edge), or draw a temporary reference line using the cursor. The cursor icon will indicate which method 

(parallel or perpendicular) is active.

4. Draw the new element, which will be perpendicular or parallel to the reference line.
ARCHICAD 24 Reference Guide 549



On-Screen Input Aids Interaction
Angle Bisector Constraint

Using the Angle Bisector relative construction method, you can draw elements bisecting the angle formed by 

other elements or temporary reference vectors.

 This command is accessible from the Drafting Aids toolbar:

It is also accessible from the Control Box.

Note: The Control Box is not visible by default. It is available at Window > Palettes.

See Control Box for more information.

You can either start drawing the new element before activating the Angle Bisector method and defining the 

reference vectors, or the other way round. Before using Angle Bisector constraint, make sure that Grid Snap 

is disabled.

Click the Angle Bisector icon, then define the reference vectors by either clicking on two existing element 

edges or lines, or drawing two temporary lines. While you are clicking or drawing the reference lines, the 

cursor icon will show that you have activated the angle bisector constraint.

The mouse is constrained to the bisecting angle between the two reference lines.
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Offset and Multiple Offset Constraints (Relative Construction Methods)

The Offset Constraint and Multiple Offset Constraint methods help you create elements offset from a 

reference line, using any tool that has a linear or polygonal input method.

1. Activate the tool with which you want to draw the new element.

2. Choose or activate the Offset command using one of the following methods:

• the drop-down menu of the Drafting Aids toolbar

• the Control Box 

See Control Box.

3. Draw a reference line (e.g. parallel to an existing element). The cursor displays the offset or multiple offset 

icon.

Note: You can also create this reference line using the Magic Wand.

See Magic Wand.

4. A rubber band outline appears; drag the cursor to the final location of the new element.

5. If you are using the regular Offset command: Click once to place the element.

6. If you are using Multiple Offset: drag and click as many times as the number of elements you wish to 

place; double-click, or click Cancel in the Control Box, to place the final element.
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Aligning Elements to a Surface in 3D

The Align to Surface relative construction method is only active when working in the 3D Window. It enables 

you to fit elements onto non-horizontal planes when working in 3D views.

Note: The 3D Editing Plane enables you to do the same functions graphically.

See Editing Plane in 3D Window.

Using the Constraint when Creating New Elements

1. Open the 3D Window.

2. Choose the tool for the element you wish to add.

3. Adjust your User Origin if necessary.

4. Activate the Align to Surface Relative Construction method in the Control Box.

5. Click on the surface to which you want to align your new element.

6. Finish drawing the element in the usual way.

Using Align to Surface with Existing Elements

1. Activate the 3D Window.

2. Adjust the User Origin if necessary.

For more information, see Origins.

3. Select the element you wish to edit.

4. Choose the Edit command you wish to execute, e.g., stretch an edge of a slab to the intersection of a roof 

and the User Origin.

5. Click a reference point or edge to start editing.

6. Select the Align to Surface icon.

7. Finish editing the element.
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Snapping to Existing Elements

Element Snap

ARCHICAD helps you to move or reshape elements by snapping them to existing ones as part of a move 

operation.

The Element Snap function can be enabled and disabled using the View > Element Snap toggle command. 

(This command is also available on the Standard Toolbar.) 

Element Snap can be toggled on and off while you work using the E shortcut.

Note: Element Snap can only be used when Grid Snap is disabled.

If you select an element and then start moving it with Element Snap active, you will see that its special points 

change to small squares.

These special points include:

• The selection dot points of the element including anchor points

• The division points of the element (if Snap Points are enabled.)

See Snap Points.

• The tip of the cursor

When one of these selection dots encounters a node, anchor point or edge of another element where the 

cursor changes its shape to indicate a special relation, that selection dot becomes larger showing that the 

element is attracted to the sensitive point. You can then click to join the two elements without having to place 

the cursor at the actual joining point.

If more than one snapping point touches an eligible point on the other element, use the spacebar to cycle 

through possible points. 
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Surface Snap in 3D

Surface Snap is enabled by default, with the View > Surface Snap toggle.

Your cursor will snap to any surface (as well as edges and points) in the 3D window - for easy input among 

elements in space. 

For example, with Surface Snap On, it is easy to place the Wall Lamp in the right place:

(You can achieve the Surface Snap effect in 2D windows, too, by using the Gravity feature. See Gravity.)
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Cursor Snap Range

To help locate hotspots on the screen, the cursor gravitates toward edges and nodes. The attraction of the 

cursor by elements is defined in pixels in the bottom section of the Options > Work Environment > Input 

Constraints & Guides dialog box.

Cursor Snap Range can be set between 1 and 9 pixels. 3-4 pixels is a comfortable setting, but at small zoom 

levels you may hit hotspots that you did not wish to snap to. If you have good pointing skills, use 1 pixel and 

you will not be forced to zoom in.
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Editing Elements

The following sections describe all aspects of ARCHICAD element editing, including moving elements and 

modifying their size. 

Basic Editing Operations

Edit Selection Set

Cancel Operations (ESC Key, Backspace)

Pet Palettes

Move Elements

Offset All Edges

Intersect Two Elements

Align Elements

Distribute Elements

Modify Element Sizes

Explode into Current View

Duplicate Elements

Drag & Drop

Parameter Transfer

Element Transfer Settings

Group Elements

Lock/Unlock Elements

Display Order

Consolidate Lines and Fills in Drawing Windows
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Basic Editing Operations

Topics in this section:

Cut

Copy

Paste

Copy/Paste Elements Between Stories

Copy/Paste Elements Between Projects

Delete

Undo/Redo

Cut

The Edit > Cut command removes selected elements from a Project and places them on the Clipboard for 

future use via the Paste command. It can also be used for dialog box or Coordinates Palette numeric field 

contents.

Note: The Cut command is not available in the 3D Window.

The selection can be made with either the Arrow or the Marquee tool, or by Shift+clicking.

If you cut a construction element from a Model-type Section/Elevation/IE window or a 3D Document, the 

element is also cut from the Floor Plan.

In Text type windows, you can use the Cut command as in any word processor.

Copy

The Edit > Copy command puts the selected construction or text elements on the Clipboard, but the selected 

elements are not removed from the original document.

The selection can be made with either the Arrow or the Marquee tool, or by Shift+clicking.

You cannot create new construction elements in Section/Elevation/IE or 3D Document windows using Copy/

Paste. (The only exception is if you use the “Drag a copy” command in a model-type Section window.)

Note: To Drag, Rotate, or Mirror a Copy, press Ctrl while executing the regular Drag, Rotate or Mirror 

command.

In the 3D window, the Copy command is only available with the Marquee tool.

Paste

Use Edit > Paste command to insert the contents of the Clipboard onto the current Project or a text Window.

When pasting cut elements into a Section/Elevation/IE, 3D Document or Detail/Worksheet window, the 

elements are pasted as drawing primitives (points, lines and fills).

You cannot create new construction elements in Section/Elevation/IE or 3D Document windows using either 

Cut/Paste or Copy/Paste.

The Paste command is not available in the 3D window.

If you Cut/Copy and then Paste a selection between stories at the same zoom level with no Panning 

operations in between, the contents of the Clipboard are pasted into the same position they were originally cut 

or copied from.

If there are several possible options for locating the pasted Clipboard contents, the Paste Options dialog box 

appears. (The dialog box appears if the pasted elements cannot appear in their entirety in the Window at the 
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current zoom level, or if it is possible to locate the pasted elements relative to either the Active view or a 

Reference view.)

See also Paste Options Dialog Box.

Copy/Paste Elements from Locked or Hidden Layer

You cannot paste elements that are on a locked or hidden layer. If you try it, the following dialog box appears:

Choose one of the options to manage this situation (either skip those elements, unlock/unhide the layers, or 

define another layer to place them on), then click Continue to paste.

Copy/Paste Elements Between Stories

The Edit Elements by Stories Dialog Box provides a quick way to copy elements from one story to another 

without having to redraw them for each story.

Copy/Paste Elements Between Projects

When pasting elements to another project, remember that element attributes are identified by name.

• If the pasted elements refer to attributes that do not exist in the target Project, the necessary attributes will 

be appended.

• If the elements refer to attributes that do exist in the target project but are different from those of the 

original project, they will take on the attributes of the target project.

The Clipboard can be used not only to hold ARCHICAD elements for pasting, but also to import bitmap 

graphics and other types of information. You can paste multi-line texts from word-processing applications into 

ARCHICAD.

Delete

The Edit > Delete command removes selected items from Project or text Windows. The deleted elements are 

not preserved on the Clipboard. They are easily retrieved by Undo.
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The keyboard equivalent of Delete is hitting the Backspace or Delete key. Deleting construction elements in 

any model window (Floor Plan, 3D, model-type Section/Elevation/IE, or 3D Document) will also clear these 

elements from all the other windows.

Note: Deleting any additional (i.e. manually added) elements from a model-type Section/Elevation/IE 

window or a 3D Document, or any elements from a drawing-type Section/Elevation/IE window will leave 

all other windows unchanged.

Undo/Redo

The Undo and Redo commands allow you to undo (revert to a previous step) and redo a large number of 

construction operations. The name of the command to be undone is displayed in the menu along with the 

Undo or Redo command.

The number of steps that can be undone and redone (the “undo queue”) is set using in the Options > Work 

Environment > Data Safety & Integrity dialog box (Undo Limit). 

Warning: The undo queue is cleared entirely whenever you do the following operations:

– Delete or add a story, or change story height

– Update a Hotlinked module

– Send/Receive commands in Teamwork

In text type windows, only the last editing step can be undone/redone. (Text-type windows include all Listing 

windows created with the Calculation function, GDL script windows, Project Notes, and Report windows.)

Important: Operations involving Navigator/Organizer items (such as drag and drop between Navigator 

maps, deleting items from a map, or adding items to the Publisher set) are not added to the undo queue, 

and are not undoable.

See also Cancel Operations (ESC Key, Backspace).
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Cancel Operations (ESC Key, Backspace)

By successively pressing the Esc key, you will achieve the following actions:

1. Exit numeric input

2. Exit navigation (Orbit, Explore)

3. Remove fixing

4. Remove Snap Reference

5. Exit input

6. Deselect all

7. Remove Marquee

8. Change to Arrow tool

During input, pressing the Backspace key will cancel the operation.

Warning: Pressing Backspace with any items selected will delete those items!
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Move Elements

You can move elements individually or collectively. You can “nudge” them in increments; you can drag, rotate 

or mirror them along a horizontal plane and through vertical displacement, that is, by changing their 

elevation values.

Note: To Drag, Rotate, or Mirror a Copy, press Ctrl while executing the regular Drag, Rotate or Mirror 

command.

To move elements, you can:

• Select them and choose the corresponding menu command from the Edit > Move menu (with any tool 

active in the Toolbox) or the Move commands in the context menu of a selected element:

• With any tool active, click on a node and then choose the desired shortcut in the appearing pet palette.

Nudging Elements

Dragging Elements

Rotating Elements

Mirroring Elements

Elevating Elements
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Nudging Elements

A quick way to move elements on the screen is to use “Nudge” feature to move the selected element(s) left, 

right, up or down (in 3D, along the horizontal plane). The Nudge distance is defined in View > Grids & 

Editing Plane > Grids & Background.

To “Nudge”, use the shortcut Shift + an arrow key. The value is defined under Snap Grid/Nudge.

To Nudge in a larger increment, use the shortcut Shift + Alt/Opt + an arrow key. The element will be nudged 

using the value defined for the Construction Grid spacing.
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Dragging Elements

To drag one or more elements to a new location: 

1. Select one or more elements, then do one of the following:

– select the Drag icon from the pet palette

– select Move > Drag from the context menu

– use the Drag command shortcut (Ctrl+D)

– select Edit > Move > Drag 

2. Move the cursor to drag all selected elements to a new location.

3. Click to place.

In the 3D window, dragged elements are constrained to the current 3D Editing Plane. You can change this 

plane as needed.

See Reposition Editing Plane.

Drag a Copy

To Drag a Copy, select one or more elements, then do one of the following:

• press Ctrl while executing the regular Drag command

• select Edit > Move > Drag a Copy

• select Move > Drag a Copy from the context menu

Drag and click to place a copy. The original element(s) remain in place.

Drag Multiple Copies

To drag several copies of an element:

1. Select one or more elements, then do one of the following:

– press Ctrl (Cmd) + Alt while executing the regular Drag command

– select Edit > Move > Drag Multiple Copies

– select Move > Drag Multiple Copies from the context menu

2. Drag, then click to place a copy. 

3. Repeat as many times as needed. 

4. Double-click to complete. 
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Rotating Elements

You can rotate selected elements in the Floor Plan or in the 3D Window.

In Section/Elevation/IE, 3D Document, and Detail/Worksheet window, you can rotate drawing elements only.

In the 3D Window, rotation is performed across a horizontal plane.

Note: Some elements - Curtain Walls, Shells, Morphs - can be free-rotated (that is, on a plane that is not 

horizontal).

See also Rotating Beam and Columns

1. Select one or more elements, then do one of the following:

– select the Rotate icon from the pet palette

– select Edit > Move > Rotate

– select Move > Rotate from the context menu

– use the Rotate command shortcut Ctrl (Cmd) + E.

2. Click to define the center of rotation of the selected elements.

3. Click to define the starting point of the rotation arc and its radius.

• Move the cursor and click to complete the rotation.
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Rotate a Copy

1. Select one or more elements, then do one of the following:

– press Ctrl while executing the regular Rotate command

– select Edit > Move > Rotate a Copy

– select Move > Rotate a Copy from the context menu.

2. Click to define the center of rotation of the selected elements.

3. Click to define the starting point of the rotation arc and its radius.

4. Move the cursor and click to complete the rotation.

The original element(s) remain in place.

Rotate Multiple Copies

To rotate several copies of an element:

1. Select one or more elements, then do one of the following:

– press Ctrl (Cmd) + Alt while executing the regular Rotate command

– select Edit > Move > Rotate Multiple Copies

– select Move > Rotate Multiple Copies from the context menu

2. Click to define the center of rotation of the selected elements.

3. Click to define the starting point of the rotation arc and its radius.

4. Move the cursor and click to complete the rotation. Repeat as many times as needed. 

5. Double-click to complete. 

The original element(s) remain in place.

Rotating Shell Profiles

Shell profiles can also be rotated graphically, using the Rotate Profile command from the pet palette of 

selected Shells.

See Graphical Editing of Shells.
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Mirroring Elements

Mirroring creates a mirror image of selected elements on the Floor Plan or in the 3D Window.

To Mirror an element:

• Select the Element(s) you want to mirror. Here, we want to place the table and chairs in the facing 

direction, at the other side of the room.

• Select the Edit > Move > Mirror command, or choose the Mirror command from the context menu or the 

pet palette.

• Define the mirroring axis with two clicks, as if you were drawing a Line.

The mirrored elements will be placed after the second click.

Notes:

– To Mirror a Copy, press Ctrl while executing the regular Mirror command.
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– Any number of Doors and Windows can be mirrored at a time. The mirrored Door/Window will always 

be in line with the wall that contains the original. Select the Door/Window; click once. This click is the 

axis of the mirroring action.

– Text, Line arrowheads and Dimensions will not be mirrored, only their bounding box.

– Mirrored Text blocks, Labels, Dimensions and Fill polygon area labels are always readable from the 

bottom and the left side of the drawing.

– Zone stamps cannot be mirrored.
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Elevating Elements

The Elevate command allows you to move selected elements vertically along the Z axis.

For information on elevating Mesh points: see Edit Elevation of a Mesh Point.

In the Floor Plan and Section/Elevation/IE windows:

1. Select the element.

2. Choose the Edit > Move > Elevate command, or the Elevate command from the pet palette.

 This brings up the Elevate dialog box.

3. Type the value by which you wish to raise or lower all selected elements.

4. To allow the element’s Home Story to be automatically reset to reflect its new elevation, check Set Home 

Story by Elevation.

5. Click OK.

This command is well-suited to changing the elevations of large numbers of similar elements (i.e., walls, 

landscaping objects, floor tiles, and lighting fixtures). It is the best way to preserve the vertical relationships 

between objects while moving them.

Note: In the Section/Elevation/IE window, you can also elevate elements simply by clicking and dragging.

See also Change Home Story by Elevation.

In the 3D Window (Using Drag):

1. Select the element.

2. Choose the Drag command from the pet palette. 

3. Drag the element to its new position along the Z axis, or define the distance numerically. Notice that a 

Snap Guide appears, marking the story positions, to make it easier to place the element.
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In the 3D Window (Using Elevate command):

1. Choose the Edit > Move > Elevate command.

 This brings up the Elevate dialog box.

2. Type the value by which you wish to raise or lower all selected elements

3. To allow the element’s Home Story to be automatically reset to reflect its new elevation, check Set Home 

Story by Elevation.

4. Click OK.
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Offset All Edges

Use the Edit > Reshape > Offset command to offset all edges of an existing element. This function works on:

• all elements that are polygonal (these include splines as well as the more obvious polygon-type elements)

• multiple connecting elements of a single type, provided they are all selected: for example, two line 

segments that meet at a point

See also Offset Edge - Fixed Area.

1. Select the element(s) you wish to offset.

2. Choose the Offset all edges command in one of the following ways:

– the offset icon from the Pet Palette (click a node, an edge, or a reference line endpoint of the selected 

element);

– from the Edit > Reshape menu;

– from the Edit Elements toolbar;

3. A ghost contour of the proportionally increased or reduced element follows the movements of the cursor. 

Click when you are satisfied with the new element size.

Use Offset to Create One or More Element Copies

1. As described above, select the original element and activate the Offset command.

2. Click the Ctrl key (Mac: Opt) and drag the cursor to the offset location.

To create multiple copies: Click the Ctrl+Alt keys (Mac: Cmd+Opt), then drag the cursor.

3. Click to place the new element(s).

Offset Constraint

See Offset and Multiple Offset Constraints (Relative Construction Methods).
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Intersect Two Elements

You can intersect two selected elements with each other by having them meet at their endpoints’ nearest 

point.

This command works on Lines/Polylines, Arcs, Walls, and Beams.

1. Select the two elements.

2. Choose the Edit > Reshape > Intersect command.

Notes:

– This command can work only if the two elements are visible on the same story. They do not have to 

have the same Home Story, but they must be at least visible on the same story. (If the elements have 

different Home Stories, and their visibility is set to “Home Story Only,” this command will not work.)

– When intersecting Lines or Polylines: if only one ends intersects after the first Intersect command, 

repeat the command to intersect the other ends as well.

Related Topics:

Intersect Single-plane Roofs

Intersect Morph Faces (Generate Edges within a Morph)
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Align Elements

Use this menu (Edit > Align) to align selected elements with each other, or to a custom-drawn target line, 

using a variety of criteria:

• Align elements right or left;

• Align elements to the top or bottom;

• Center elements vertically or horizontally;

• “Special”-align elements to any point on an existing element, or to a temporary line/arc drawn by you.

Watch the Video

The Align commands are only active if you have selected at least two elements.

When using the Align commands, the expression “right” refers to the rightmost element on the x-axis in the 

window you are looking at (e.g. Floor Plan, Section, 3D). The expression “left” refers to the left-hand direction 

on the x-axis.

Similarly, “top” means the element with the highest y-coordinate in the current window, and “bottom” is the 

element with the lowest y-coordinate.

ARCHICAD identifies an element’s right/left/top/bottom/center point according to an (invisible) bounding box 

around the element.

For example, suppose you want to align the following Corner Table object with other furniture:

ARCHICAD will use the centerpoint of the table’s bounding box (here, illustrated in red):

Note: If you want to use a different anchor point of the elements you are aligning, use the Special Align 

options (Edit > Align > Special Align).

How to Align Elements

1. Select the elements you wish to align.

2. Go to Edit > Align and choose one of the following operations:
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Left: If you choose Edit > Align > Left, all selected elements will be aligned to the leftmost bounding-box 

point of the element that is located farthest to the left.

In this example, we want to align the three windows shown in Section view.

Select all three windows and use Edit > Align Left.

Right: If you choose Edit > Align > Right, all selected elements will be aligned to the rightmost bounding-box 

point of the element located farthest to the right.

• In the illustration below, the arc wall is the rightmost element; the rest of the walls (their rightmost points) 

are aligned to the rightmost point on the arc wall’s bounding box.

Top/Bottom: If you choose Edit > Align > Top or Bottom, all selected elements will be aligned to the 

topmost (or bottommost) point on the element that is the top (or bottom) element of the selected group.

• In the example below, we want to move up the window on the left, so that it lines up with other two 

windows.
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• To achieve this, we select all the windows, then use Edit > Align > Top to obtain the desired result.

Center Horizontally: If you choose Edit > Align > Center Horizontally, ARCHICAD will determine the 

selected elements’ top and bottom y-coordinates, and then align all the elements horizontally (using each 

element’s centerpoint), along a horizontal line halfway between the top and bottom elements.

Center Vertically: If you choose Edit > Align > Center Vertically, ARCHICAD will determine the selected 

elements’ leftmost and rightmost x-coordinates, and then align all the elements vertically, along a vertical line 

halfway between them.

• For example, in the following Floor Plan, we will center the selected furniture vertically.

Special Align

The options in Edit > Align > Special Align give you great flexibility in lining up selected elements. You can 

choose which point to align, and you can choose what to align the elements to: a temporary line/arc drawn 

by you, or any existing line/edge.

In this example, we wish to align the selected tree objects to the edge of the garden path.
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Go to Edit > Align > Special Align and choose the Nearest Point option: each tree will line up along the path 

using each tree’s bounding box point that falls closest to the path.

Choose the Click an existing line or element edge option.

Click OK to close the dialog box, then click the edge of the path (here, the edge of the mesh). The trees line 

up along the path.
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Distribute Elements

Use this menu (Edit > Distribute) to evenly distribute selected elements using a variety of criteria:

See also the Distribute option of the Multiply command, at Multiply Elements.

The Distribute commands are only active if you have selected at least two elements.

ARCHICAD identifies an element’s right/left/top/bottom/center point according to an (invisible) bounding box 

around the element.

For example, suppose you want to distribute elements that include the following Corner Table object:

ARCHICAD will use the centerpoint of the table’s bounding box (here, illustrated in red):

Note: If you want to use a different anchor point of the elements you are distributing, use the Special 

Distribute options (Edit > Distribute > Special Distribute).

Along X: The two selected elements at either end will remain in place; the rest will be evenly distributed 

between them.

For example, suppose you have three windows distributed evenly along a wall.

• As a result of a design change, the wall is lengthened and you add two more windows.

To ensure they are all distributed evenly, select all the windows and use Edit > Distribute > Along X.
ARCHICAD 24 Reference Guide 576



Editing Elements Interaction
Along Y: The two selected elements at either end (vertically) will remain in place; the rest will be evenly 

distributed between them.

For example, suppose you want to distribute chairs evenly against the back wall of the room. Select them, 

then use Edit > Distribute > Along Y.

Along XY: The two selected elements at either end (at top left and bottom right) will remain in place, and the 

rest will be distributed evenly along an XY diagonal.

For example, you have nine desks in the classroom placed roughly in a V formation.

To distribute the desks precisely, select a group of 5 desks and use Edit > Distribute > Along XY.
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First group:

Repeat with a second group of five chairs.

Final result:
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Special Distribute

The options in Edit > Distribute > Special Distribute let you choose which point to distribute and along 

what to distribute the elements: a temporary line/arc drawn by you, or any existing line/edge.

Suppose you want to distribute potted plants in a circle around a hexagonal soil holder object:

Use Edit > Distribute > Special Distribute. Choose the “Draw a line or arc” option, then click OK to close the 

dialog box. Click to start drawing and choose the “Arc by centerpoint” pet palette option. You will create a 

temporary circle around the hexagonal object. As you complete the circle, the potted plants will be distributed 

around it.
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Modify Element Sizes

Different element types have different characteristic dimensions: length, width, height, thickness, opening 

angle, etc. Some of these are easiest to modify numerically, by selecting the given element, opening its 

settings dialog box and adjusting the relevant values.

Some dimensions, however, cannot be modified numerically (for example, the length of linear elements or 

edges), while some others need to be fitted exactly to other elements (walls to roofs, for example) which may 

make numeric adjustment a tedious calculation task. You may also need to change the overall dimensions of 

several elements at the same time while keeping their relative proportions.

In such cases, ARCHICAD allows you to modify element sizes using splitting, stretching and trimming 

operations.

Most of the operations can be performed in three ways:

• Edit menu command

• Keyboard Shortcuts

• Commands from Pet Palettes

In some cases, only the pet palette is available.

Some general considerations:

• You cannot stretch Hotspots, Cameras or Detail Markers.

• Some GDL Object type elements are programmed to allow only specific sizes, or include smart editing 

hotspots to edit their shape graphically.

• Stretch is available for most types of selected elements in both the Floor Plan and the 3D Window. Only 

drawing elements can be stretched in the Section/Elevation/IE, 3D Document and Detail/Worksheet 

windows.

• The Stretch command cannot be used on polygonal elements, but you can stretch their edges or displace 

any of their nodes graphically.

Trim Elements Using Scissors

Reshaping Polygons and Chained Elements

Stretching with the Marquee Tool

Stretch Height

Resize (Enlarge or Reduce) Elements

Offset All Edges

Splitting Elements

Adjusting Elements

Adjust Elements to Slabs

Intersect Two Elements

Create a Fillet or Chamfer

Adding Element Nodes

Move Nodes

Curve/Straighten Element Edge
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Reshaping Polygons and Chained Elements

Move Polygon Node

To move a node of a selected polygon (including a polygonal wall), click the node and use the pet palette’s 

Move node option.

The two neighboring edges will follow the stretching movement and the shape of the polygon will change 

accordingly.

Offset Polygon Edge

To apply an offset on a whole side of a selected polygon, click an edge and use the pet palette’s Offset edge 

option. This will stretch the neighboring edges.

This offset feature is available for chained elements as well as polygons. Selected elements will be treated 

temporarily as a polygon, and all polygon reshaping pet palette options will be available.

Offset Edge - Fixed Area

This option is available for Zone polygons only.

See Offset Edge - Fixed Area.
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Adding and Subtracting Polygonal Shapes

You can use the pet palette to add to the shape of a polygonal element, or subtract new polygons from it. (This 

will work on multiple selected elements, too.)

To add a new polygon to the existing one:

Select the polygon and click it either on an edge or a node. From the pet palette, choose the icon with the + 

sign (Add to Polygon).

Draw the new polygon shape. It must intersect with the selected one or at least they should have a common 

edge.
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Click to finish drawing the new shape, which will be automatically added to the original one.

The process is the same for subtracting a shape from a polygon, but choose the Subtract from Polygon 

icon.

You can also use the Magic Wand for adding/subtracting a polygon shape.

See Using the Magic Wand to Add/Subtract Polygon Shapes.

See also Graphical Editing of Roof Geometry and Create a Hole in a Roof.
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Stretching with the Marquee Tool

You can stretch multiple polygons or linear elements along a particular vector by using the Marquee tool.

To stretch elements inside a Marquee area:

• Draw a Marquee so that the nodes or endpoints you want to stretch fall inside the Marquee. Any nodes 

you want to keep intact should be outside the Marquee.

• Define a stretch vector: with the Marquee tool active, click on a node or endpoint inside the Marquee area, 

then click on a second point.

• Alternatively, choose the Edit > Reshape > Stretch command, and then define the stretch vector by 

clicking any two different points.

The shape of all linear elements that have one of their endpoints inside the Marquee area, and polygonal 

elements that have nodes inside the marquee area, will be stretched along this vector.

Note: If you don’t want to stretch an element whose node is inside the Marquee, lock the element (select 

it, then use Edit > Locking > Lock; or lock the element’s layer.).

• If all the nodes of a polygon are inside the Marquee area, the polygon will be dragged instead of stretched.

• Stretching nodes in a Marquee area is not available in the 3D Window.

• Columns, Objects and Lamps cannot be stretched with the Marquee. If any of their hotspots fall inside 

the Marquee area, the whole object/column will be dragged along when the Marquee area is repositioned.

• When stretching Arcs or curved Walls with the Marquee, their central angle (i.e. the arc/chord ratio) will 

remain unchanged.
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Stretch Height

In the 3D, Section/Elevation and IE windows, you can modify the height of selected elements graphically 

with Stretch height command of the pet palette.

Click a node of a selected element and choose the vertical stretch icon in the pet palette. A ghost contour of 

the element follows the cursor. Click to set the new height of the element.
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Resize (Enlarge or Reduce) Elements

The Edit > Reshape > Resize command lets you enlarge or reduce selected elements using numeric or 

graphical input.

This feature is available only in the Floor Plan and 3D windows, and - for 2D drawing elements only - in the 

Section/Elevation, 3D Document and Detail/Worksheet windows.

The Resize dialog box offers additional options for resizing the thickness of Walls/Columns, GDL Objects, text 

elements, arrowheads and markers.

1. Select the elements you wish to transform and choose Resize.

2. In the appearing dialog box, enter a value into any one of the resize ratio fields. (Make sure the Define 

graphically checkbox is unchecked.)

 

• Resize ratio: Use any one of the three ways to define the resize ratio you want. (If you enter a value in one 

field, the other two will be filled in automatically.)

• Resize wall, column thickness: For walls, columns and beams, the thickness will be resized as well as the 

length/height.

• Resize library parts: Any selected library parts will be resized.

• Resize all text entities: All texts and labels are resized.

• Resize all arrows and markers: The size of all arrows/markers are modified.

3. Click OK.

4. Click in the window to define which point or edge of the elements should remain in its original location. 
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To perform the operation graphically:

1. Open the Resize dialog box.

2. Check the Define Graphically checkbox.

3. Draw a transformation vector to define both the resizing ratio and the location of the resized elements.

Note: Resizing does not affect grouped elements. To resize grouped elements, ungroup them first or 

choose Suspend Groups.

See Group Elements for more information.
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Splitting Elements

You can split many selected elements (Walls, Beams, Lines, Slabs, Roofs, Meshes, Fill and Zone Polygons, 

Lines, Arcs, Polylines and Splines) along a line segment, arc or element edge.

The Split command is available in the Floor Plan and 3D Window, and - for drawing elements only - in 

Section/Elevation/IE and 3D Document windows, and Details and Worksheets.

Note: You cannot split a polygon - such as a Roof element - with an arc.

The splitting plane is always perpendicular to the Floor Plan.

Exception: If you are splitting a Morph, you have more freedom: the splitting plane can be set 

perpendicular to the current editing plane.

1. Select the elements you wish to split.

2. Choose the Edit > Reshape > Split command, or the hatchet icon from the Info Box.

3. Draw a temporary splitting line, or click on an existing Line, Arc, Wall or polygon edge.

In the 3D window, a red splitting plane is shown as feedback.

4. Click on either side of the splitting line/arc/edge with the Eyeball cursor.
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Note: When splitting walls, the split takes place at the point where the splitting line intersects with the 

reference line(s) of the selected elements.

5. Elements on the clicked side will remain selected, while elements on the other side will be deselected. 

The selected group of elements can be edited in the usual ways.

If the selected element is intersected by an element in several locations, the Split command will split the 

selected element at every intersection point.

Splitting is also available in the 3D Window. You can split the selected element with a vertical plane into two 

segments. This feature works the same way as on the Floor Plan. The splitting line is drawn in the plane of the 

User Origin.

Note: When no elements are selected, the Split command will let you split a wall at the clicked location 

along any of its sides or reference line.

Related Topics

Split Intersecting Curtain Walls

Split Stair Structure

Read More on Help Center

Watch the Video
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Adjusting Elements

Use the Adjust command to extend or trim the endpoints of selected Walls, Beams, Arcs and Lines to a Line, 

Arc segment or element edge.

Note: It is also possible to adjust Roof planes to each other or to other elements.

See Intersect Single-plane Roofs and Cropping with a Remote Roof.

1. Select the elements you wish to adjust.

2. Choose the Edit > Reshape > Adjust command.

3. Draw a line segment, or click an existing line, wall, polygon edge or arc/circle. The endpoints of the 

selected walls and lines will be adjusted (lengthened or shortened) to meet the drawn or clicked line or 

curve. Only those elements will be affected that intersect (or would intersect) with the chosen line/arc/

edge.

Note: If the clicked edge is that of a Slab, the workflow is the same as the Adjust Elements to Slabs 

workflow. 

See Adjust Elements to Slabs.

The Adjust command is available in the Floor Plan and 3D Window, and - for drawing elements only - in 

Section/Elevation/IE and 3D Document windows, and Details and Worksheets. In 3D view, you can adjust the 

selected Wall or Beam to a vertical plane.
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Split and Adjust Shortcut

A simple shortcut lets you adjust short elements and split long ones by the same edge.

1. Select all the elements that you wish to split or adjust. The active tool must be one of those that created 

the selected elements.

2. Press the Ctrl (Windows) or Cmd (Mac) key and click the edge you wish to use for splitting/adjusting.

3. The operation is immediately performed. All transformed elements will remain selected.
ARCHICAD 24 Reference Guide 591



Editing Elements Interaction
Adjust Elements to Slabs

Use this function (Edit > Reshape > Adjust Elements to Slabs) to easily adjust elements (Walls, Columns, 

or horizontal Beams) to specific levels of one or more Slabs that are located above and/or below them.

1. Select the element(s) (Walls, Columns or horizontal Beams) to be adjusted.

Note: If there is more than one Slab above or below the selected element(s), then you should also select 

the particular Slab that you want to adjust to. Otherwise, the closest Slab will be automatically considered 

the target.

2. Use the Edit > Reshape > Adjust Elements to Slabs command.

3. In the appearing dialog box, define whether you want to adjust the selected elements to the Slab that is 

above or below the element(s), or both. Again, if you select Slab(s), then the adjustment will target the 

selected Slab(s) only.

4. From the drop-down menus, choose the level of the Slab (top or bottom, or - for composites - Core Top or 

Core Bottom) to which to adjust the element(s).

5. Click OK.

Note: If a Door/Window is linked to the bottom of a Wall, the Adjust Elements to Slabs command will 

automatically recalculate the offset to retain the opening’s position.

Note: The same workflow is available by using the Edit > Reshape > Adjust command. In that case, you 

must select the elements to be adjusted, then click on the targeted Slab. (The cursor indicates that you 

are clicking a Slab, as illustrated below.) The Adjust Elements to Slabs dialog box appears, and the 

workflow continues as described above. (Elements are adjusted to the clicked Slab only.)
ARCHICAD 24 Reference Guide 592



Editing Elements Interaction
Adjust Elements to Slabs: Example

In this project, there are problems in the junctions of Walls to Slabs: the internal Walls only extend to the top of 

the carpeting, while the external (profile) Walls have gaps.

The Adjust Elements to Slabs command can help.

1. Select all Walls.

2. Use the Adjust Elements to Slabs command and set the options to “Core Bottom” and “Core Top”. This 

way, the Walls on top of the Slabs will be extended to reach to the Slab core.
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3. As a result, the internal dividing Walls are now correctly joined to the Slabs.

 

The external, profiled Walls are still a problem: each needs to meet the Wall above it without stopping at the 

bottom of the Slab core.
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4. Use Find and Select to select the external Walls only.

5. Again, use Adjust Elements to Slabs, but this time, all of the selected Walls should extend all the way up 

to the Slab core top, to eliminate the gaps.
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6. Now the external Walls are correctly joined, too.
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Create a Fillet or Chamfer

Use the Edit > Reshape > Fillet/Chamfer command to fillet or chamfer the intersection of two straight lines/

polylines, walls, or the corner(s) of a polygon element.

For special fillet/chamfer options available with Morphs, see Basic Morph Editing: Fillet/Chamfer a Morph.

To open the Fillet/Chamfer dialog box, select the two lines, or the polygon element.

Then do one of the following:

• Choose the Edit > Reshape > Fillet/Chamfer command, or

• If the selected element is a polygon, choose the Fillet/Chamfer icon from the pet palette.

Choose either Fillet or Chamfer:

• Fillet joins the endpoints of two straight segments endpoints with an Arc.

• Chamfer joins the endpoints of two straight segments with a straight segment, cutting off corners.

• Enter a radius for the fillet/chamfer. (The chamfer does not have a radius, but it will be drawn as the chord 

of arcs of the specified radius.)

Note: If filleting the arc with the current radius would extend any of the neighboring vertices, the radius will 

be limited automatically so that the filleting arc contains the closer neighboring vertex.

• Click OK.

Note: The Fillet, Chamfer and Intersect commands are not effective on grouped elements, unless 

Suspend Groups is on.

See Suspend Groups.

Apply to All Corners

To apply the Fillet or Chamfer to all corners of the selected polygon, check the Apply to All Corners 

checkbox.

Note: This checkbox is applicable only if the selected element is a polygon. 

If you have selected a polygon and then the Edit > Reshape > Fillet/Chamfer command, the checkbox is 

selected by default and uneditable; the fillet/chamfer will apply to all nodes.

To apply the Fillet/Chamfer to a single node of the polygon, click on that node and use the pet palette 

command to open the Fillet/Chamfer dialog box.
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Trim Elements Using Scissors

Use the Trim command to remove the part of an element extending beyond its intersection point with another 

element, or to cut out part of the element between two intersection points. 

Trimmable elements: Walls, Beams, Lines, Circles, Arcs, Polyline and Splines.

Do the following:

• Choose the Edit > Reshape > Trim command, or press the Ctrl (Windows) or Cmd (Mac) key.

• The Scissors cursor appears. Move it to a trimmable element and click the segment you want to trim.

Note: In the 3D window, you can also click on a Wall or Beam surface for trimming.

• The clicked part of the element between the two nearest intersection points will be deleted.

For example, here we will trim part of the beam - the part that falls between the first two walls on the left.

Trim Elements to Roof or Shell

Cropping with a Remote Roof
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Adding Element Nodes

You can add new nodes to elements using the pet palette.

Adding a node to a straight linear element creates an additional element.

Adding a node to a polygon-type element increases the number of its edges.

In the 3D Window, you can add nodes only to polygonal elements.

To add a node to an element:

1. Select the element.

2. Click an edge of the element to bring up the pet palette.

3. Choose the Insert new node icon.

4. Click to define the location of the new node.

To insert a new node without moving it, double-click on a polygon edge. (The Insert node option must be 

active in the pet palette.)

Note: You cannot add a new node to a curved element or segment; if you click Insert new node on a 

curved element, the curved element will be straightened out.
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Move Nodes

With the Move node icon of the pet palette, you can reposition the node of a polygon type element.

Also, the Move Node command is used to stretch objects, doors and windows.

See Stretching Objects.

• You can eliminate a node by merging it into one of its neighbors.
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Curve/Straighten Element Edge

With the pet palette’s Curve edge function, you can curve a segment of a straight element - such as a wall or 

beam - by dragging its edge or reference line.

 

Note: If the bent segment of a polygon intersects any of the other polygon edges, ARCHICAD will 

regularize the polygon’s shape, which may result in cutting the polygon into several parts.

To straighten a curved element edge, select the curved element, then select the Insert New Node command 

from the pet palette.

For more information on editing curved elements, see Stretching Curves.
ARCHICAD 24 Reference Guide 602



Editing Elements Interaction
Explode into Current View

This command is available in different forms depending on the selected items:

For Selected Construction Elements

For Placed Drawings (Source is not a PDF)

For Placed Drawings (Source is a PDF)

For Selected Construction Elements

Choosing Edit > Reshape > Explode into Current View will turn selected elements (Floor Plan and other 2D 

windows only) into 2D drawing primitives (Lines without arrowheads, Circles, Arcs, Elliptic arcs, Splines, 

unframed Fills, single-line Texts).

In the appearing dialog box, you have the option to keep original elements. If you uncheck this box, the 

original elements will be deleted, and only the exploded primitives will remain in the project.

Note: The Explode command will not affect grouped or locked elements. Turn on Suspend Groups 

before exploding grouped elements.

Note: If you explode a construction element with the “Keep Original Elements” box unchecked, then that 

element will no longer exists as a construction element. Consequently, it will disappear from other model 

views (model-type Sections, Elevations, IEs, 3D Documents).

Some examples:

• Slabs, Roofs and Meshes are exploded into lines

• Walls and Columns are exploded into Lines and Fills (Doors and Windows inserted into Walls are also 

exploded)

• Doors and Windows (if selected without the Wall they are placed into) are exploded into 2D elements and 

replaced by empty hole openings

• Dimensions are exploded into Lines, Texts and the basic elements of arrowheads (Lines, Circles, Arcs, 

Fills)

• Polylines are exploded into Lines and Arcs
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• GDL Objects are exploded into basic 2D drawing elements

Explode has no effect in the following cases:

• In Section/Elevation/IE and 3D Document windows, cut construction elements cannot be exploded

• Section/Elevation/IE lines and Cameras

• Basic 2D elements

For Placed Drawings (Source is not a PDF)

This dialog box appears if you select and explode a Drawing that has layers (that is, if it is a DWG file or if it is 

derived from an ARCHICAD view), and does not have a PDF document as its source.

Attribute Conversion Options

Note for Teamwork users: If you choose an option that creates new attributes, you must first have the 

needed access right (e.g. Create Layers). If you do not have the right, a warning appears, and the option 

is grayed out.

Choose the Layer on which to place the drawing primitives that will result from the Explode:

• Use Drawing’s Layer: All resulting drawing primitives will be placed on the same Layer as the Drawing is 

on.

• Import Embedded Layers: This option means that the drawing primitives will be placed on layers 

corresponding to their layer assignment in the Drawing source (e.g. DWG file). Those embedded layers 

will be imported into your ARCHICAD project.

For Placed Drawings (Source is a PDF)

This dialog box appears if you select and explode a Drawing that has a PDF document as its source. The 

Attribute Conversion and Override options allow you to control the appearance of the resulting elements. 
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However, be aware that the elements from the PDF might not look exactly the same after Explode - e.g. what 

appears to be a fill in the PDF document may be composed of lines, and will be exploded as lines in 

ARCHICAD.

Attribute Conversion Options

Note for Teamwork users: If you choose an option that creates new attributes, you must first have the 

needed access right (e.g. Create Layers). If you do not have the right, a warning appears, and the option 

is grayed out.

Layers: Choose the Layer on which to place the drawing primitives that will result from the Explode:

• Use Drawing’s Layer: All resulting drawing primitives will be placed on the same Layer as the Drawing is 

on.

• Import Embedded Layers: This option means that the drawing primitives will be placed on layers 

corresponding to their layer assignment in the Drawing source (the PDF document). Those embedded 

layers will be imported into your ARCHICAD project.

Lines: Choose a method for defining the drawing primitives’ lines.

• Use Project’s Attributes: No new Lines will be imported from the Drawing’s source file; the project’s 

existing lines will be used. If there is no perfect match, then the drawing primitives will use the one of four 

basic Lines - solid, dashed, dotted-and-dashed, or dotted - which corresponds to the exploded element’s 

original Line.

• Substitute With Similar: New Lines are imported only if the drawing primitive does not correspond to any 

of the four basic Lines.

• Import All: All Lines from the PDF source are imported and added to the ARCHICAD project attributes.

Fill Types: Choose a method for defining the drawing primitives’ fill types.

• Use Project’s Attributes: No new Fill Types will be imported from the Drawing’s source file. Any fills in 

the drawing primitives that have no counterpart among the project’s attributes will be transformed into 

solid fills.

• Generate Symbol Fills: For any fills in the drawing primitives that have no counterpart among the 

project’s attributes, a new vectorial fill attribute will be created.

– Vectorial fill patterns will be transformed to symbol fills without any text or image

– Text or image content and gradient fills will be transformed into image fills

• Generate Image Fills: For any fills in the drawing primitives that have no counterpart among the project’s 

attributes, a new image fill attribute will be created.

Note: If an image fill is generated, then an image file is added to the project’s Embedded Library. If you 

are working in a Teamwork project, you must have the needed access right: Library Parts - Create.

Override Options

• Use Uniform Pen: Check this box to use a single pen defined here for all texts, fill contours and lines.

• Use Uniform Font: Check this box to use a single font defined here for all texts.
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Fine-Tune View After Explode

After an Explode function, you may wish to fine-tune the view before final output. 

You will find that the “exploded” lines and fills often contain superfluous elements (extra line segments, 

overlapping or superfluous fills) that make such editing difficult. To make editing easier, first use the Linework 

and Fill Consolidation functions on selected items in the window.

For more information, see Consolidate Lines and Fills in Drawing Windows.
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Duplicate Elements

You will often need to create exact duplicates of a particular element. Often, the simplest way to duplicate is to 

use Copy/Paste.

See Basic Editing Operations.

Copy/Paste Elements Between Stories

The Story Settings dialog box provides a quick way to copy elements from one story to another without having 

to redraw them for each story.

See Story Settings Dialog Box.

It is also easy to use graphical editing to drag, rotate, or mirror one or more copies of a selected element, or to 

use the multiply function. These are described in the following sections:

Drag, Rotate, Mirror Element Copies

Multiply Elements

Offset All Edges
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Drag, Rotate, Mirror Element Copies

To Drag, Rotate, or Mirror one copy of an element, select it, then do one of the following:

• Choose the desired command from the Edit > Move menu or the context menu.

• Choose Drag/Rotate/Mirror from the pet palette, then press Ctrl (Windows) or Alt/Opt (Mac). (This adds a 

small + sign to the cursor; press Ctrl again to undo the Copy feature). Click to place the copy, which will 

now be selected instead of the original.

• To Drag or Rotate multiple copies of an element, select the element, choose the desired command from 

the Edit > Move menu or the context menu (or use Ctrl + Alt (Windows) or Cmd + Opt/Alt (Mac) as a 

shortcut). You will see a “++” sign appear. Click the element to drag or rotate its copy to its new position. 

You can place any number of copies. Double-click to finish placing copies.

Note: When rotating copies, they will all be placed along the same rotation axis.

This feature works in the Floor Plan, Section/Elevation/IE windows and the 3D Window. In Detail Drawings, 

you can use it on any drawing elements. In the 3D Window, Drag/Rotate/Mirror is available only for added 

Drawing elements.
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To create one or more copies of an element that are offset from (rather than exact duplicates of) the original: 

See Offset All Edges.
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Multiply Elements

Multiply creates any number of exact copies of selected elements, according to the pattern and method 

defined by you. Set up the options in the Multiply dialog box.

To open the Multiply dialog box, select the element(s), then do one of the following:

• Move > Multiply command from the pet palette 

• Edit > Move > Multiply

Topics on this page:

Choose An Action (Drag, Rotate, Elevate, Matrix)

Choose Graphical Input Method

Pick Path/Arc before Input

Vertical Displacement

Choose An Action (Drag, Rotate, Elevate, Matrix)

At the top of the Multiply dialog box, choose a multiplying action:

• Drag multiplies the copies along a drawn straight path or clicked polyline 

• Rotate multiplies the copies along an arced path

• Elevate stacks the copies with a vertical displacement. (Available only in Floor Plan and 3D Window.)

• Matrix places the copies in a rectangular matrix defined by two perpendicular reference lines.

Below, define an optional Vertical Displacement between the multiplied copies.

See Vertical Displacement.

With Drag and Rotate, you also have the option to pick a path/arc along which to place the multiplied copies. 

See Pick Path/Arc before Input.
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Choose Graphical Input Method

Choose one of the four input methods for placing your multiples. The input method determines the number of 

copies and the space between them (increment).

Increment and Spread

With this method, both spacing and copies are defined graphically. 

Note: Not available for Elevate in the Floor Plan.

1. Click Increment and Spread, then OK to close the dialog box.

2. The first click defines the start point. 

3. The next click defines the increment (distance between each multiplied copy).

4. Next, drag the cursor for any distance. Each copy will be placed at the defined increment. 

5. Click to complete the operation.
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Increment

With this method, you predefine the number of copies, but you define their spacing graphically.

1. Click Increment, then enter the number of copies you want to make, then OK to close the dialog box.

2. The first click defines the start point. 

3. Drag to define the spread and direction - the distance for Drag, the angle for Rotate - of the set number of 

copies.

4. Click to place the multiplied copies.
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Spread

With this method, you predefine the spacing, but you define the number of copies graphically.

1. Click Spread, then enter the fixed spacing between each multiplied copy, then OK to close the dialog box.

2. The first click defines the start point. 

3. Drag to begin placing any number of copies, at the specified distance (for Drag) or angle (for Rotate).

4. Click to place the multiplied copies.

Distribute

With this method, the number of copies is predefined, and they are spaced evenly up to the endpoint you 

define graphically.

1. Click Distribute, then enter the number of copies to place between two points. Optionally, activate the -1 

checkbox to add an additional space within the same distribution distance (no copy will be placed at the 

end).

Click OK to close the dialog box.
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2. The first click defines the start point. 

3. Drag to evenly distribute the set number of copies to the desired point in the project, then click to place.
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Pick Path/Arc before Input

This option is available in the Multiply dialog box with the Drag or Rotate methods.

1. From the Multiply dialog box, activate the Pick Path or Pick Arc checkbox, then OK to close the dialog 

box.

2. Hover with the cursor over any edge to auto-detect and highlight the path. 

Press spacebar inside a closed area to auto-detect the boundaries.

3. Then click, defining the path or arc along which to place the multiplied copies.

(If no path is found, the input will proceed without a predefined path - as if the checkbox were off.)
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4. Click on or near the selected element to multiply: this defines the rotation and reference point of the 

elements, and the start point of the multiply from this point.

5. Drag along the path/arc to input the copies as usual (defining increments and/or copies according to the 

Graphical Input Method you chose in the Multiply dialog box).

6. You can still modify the final Distance, Spacing or number of copies in the Tracker before you click to 

complete.

Note: For a closed polygon path, the start point can be used as the finish point if the cursor has moved 

around the entire path.
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Rotation of Copies

With the Drag or Rotate actions, set a preferred option for rotating each copy:

None

No rotation will be applied to the copies, every copy will have the same orientation and rotation as the original 

element(s).

Rotate to Path

For the Picked Path or Rotate input methods, each copy will rotate the original selected element(s) to be 

perpendicular along the path/arc in relation to the start point of the input.
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Randomize

Each copy will randomly rotate the original selected element(s) along the path/arc in relation to the start point 

of the input.

This can be useful for multiplying landscape elements, such as trees.

Vertical Displacement

In the 2D window:

Use this field to enter a value that is added to the elevation of each subsequent copy of the multiplied object.
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In the 3D window:

Optionally check the Vertical Displacement box.

When you close the Multiply dialog box and then carry out the Multiply operation, you will define the vertical 

displacement vector graphically, as shown with this slab:

Set Home Story by Elevation

Check this to assign a Home Story to newly created elements based on their respective story locations. If you 

do not check this box, new elements will have the same Home Story as the original element you are 

multiplying.

See Change Home Story by Elevation.

Watch the Video
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Drag & Drop

Dragging and Dropping Text

The following possibilities exist for transferring text:

• From any ARCHICAD Text Window or from a Text Window of any other Drag & Drop-capable application 

to any other ARCHICAD Text Window

• From any Text Window to any 2D Window (Floor Plan, Section/Elevation/IE, 3D Document, Detail/

Worksheet, Library Part 2D Symbol) with the default parameters

• Moving or copying text within the same Text Window

• Creating text type clipping files in the File Manager

• Pasting clipping files into a text type Window

• Dropping plain text files into a text type Window (with some restrictions)

Dragging and Dropping Drawings

The easiest way to add a Drawing from an external ARCHICAD file is to open the external project structure in 

the Navigator, select a View or Drawing in the Navigator, and drag it onto the Layout in the Layout Window of 

the current project.

For more information, see Placing Drawings Onto the Layout.

Dragging and Dropping Pictures

The following possibilities exist for transferring picture type data:

• Dropping a picture file into a GDL Object Preview Window

• Dropping a picture file into the Floor Plan to paste it as a Figure

• Creating picture type clipping files in the Mac Finder

• Pasting clipping files into the GDL Object Preview Window

Dragging and Dropping GDL Object Files

You can drag and drop GDL Object files from the Mac Finder or the file manager directly into ARCHICAD 

Projects, the Object Settings dialog box or the Embedded Objects folder of the Library Manager.

Dropping an Object into the Floor Plan activates the corresponding tool in the Toolbox and the newly placed 

element becomes the default element for the given Object type.

• It is possible to place several GDL Objects at the same time using Drag & Drop.

• Windows and Doors can only be dropped into a Wall.

Dragging and Dropping Floor Plan Elements

If there is a selection on the Floor Plan defined either with a Marquee area or through individual selection with 

the Arrow, pressing the mouse button and dragging the cursor out of the ARCHICAD Floor Plan Window will 

initiate a Drag & Drop operation.

The following can be copied:

• Floor Plan elements (in module format)

• Selected elements on the Floor Plan in picture format (for example, into the Project Preview Window)

See Project Preview.

• The 2D and/or the 3D script of the selected elements in text format
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3D GDL script is only generated if the drop is made into the 3D Script window. The 2D script of the selected 

element can be dropped into any other text type window.

Dragging and Dropping DWG/DXF Objects

Drag & Drop is available as a way to download DWG/DXF objects from the web. 
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Parameter Transfer

Use this function to pick up the parameters of one element and transfer them to another element of the same 

type.

Note: Line, Arc, Polyline and Spline elements are of the same type.

Certain basic parameters are always transferred. 

You can also control the set of additional settings (“Transfer Set”) which should be transferred: configure sets 

at Element Transfer Settings, and apply the Set you need during Parameter Transfer (see below). 

Related Topics:

Element Transfer Settings

Parameter Transfer Shortcuts

Pick Up/Inject Parameters

Pick Up/Inject Morph Parameters

Parameter Transfer Shortcuts 

Parameter Transfer commands are also available:

• From the Standard Toolbar

• At Edit > Element Settings > Pick Up Parameters and Inject Parameters.

Pick Up/Inject Parameters

1. Move the cursor over the element whose parameters you wish to transfer. (The Element Information 

Highlight tells you which element you are focusing on.)

2. Press and hold Alt. The cursor changes to Pick Up (eyedropper) form.

Alt to Pick Up Parameters

To do this: Click this key:

Pick Up Parameters

 

Alt 

Inject Parameters Ctrl+Alt
or

Alt/Opt-Cmd (Mac)
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3. Click the element. All its parameters are now the default for that element type.

4. Move the cursor to the target element.

5. Press and hold Ctrl+Alt (Alt+Cmd on Mac). 

• The cursor changes to the Inject (syringe) cursor.

• The name of the last used Transfer Set appears: this Set defines which parameters will be transferred 

when clicking to inject. 

Ctrl/Cmd + Alt to Inject Parameters

6. Before injecting parameters, change to a different Transfer Set, if needed: 

– Click on the Set name to bring up the full list of Transfer Sets, then click on another Set to apply it. 
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- The Set you choose here becomes the default Transfer Set for the next parameter transfer 

operation.

- Define and manage Transfer Sets here: Element Transfer Settings.

Notes: 

- The transferred attributes are loaded into the Find & Select Palette’s corresponding fields, provided 

that the Find & Select Palette is open during the parameter transfer.

- The transferred parameters will be the default setting when opening any of the corresponding 

Attributes dialog boxes (Lines, Pens & Colors, Fills, Surfaces, Composites, Zone Categories).

- When injecting a GDL object, the transferred line type attributes will take effect only if you are 

overriding the object's GDL attribute definition. That is, make sure you have checked the Override 

Object's Lines checkbox in the Floor Plan and Section panel of its Settings dialog box.

Watch the Video

Watch the Video
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Pick Up/Inject Morph Parameters

Watch the Video

To do this: Click this key:

Pick Up Morph Face Parameters Alt+click on a Morph Face

Pick Up Morph Default Parameters

Custom Morph Edge parameters cannot be 

transferred.

Alt+click on a Morph Edge or Node

Inject Morph Parameters to Morph Face Ctrl+Alt+click on a Morph Face

Inject Morph Parameters to Entire Morph Ctrl+Alt+click on a Morph Edge or Node
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Element Transfer Settings

Use the Element Transfer Settings dialog box (Edit > Element Settings) to customize which settings should 

be injected

• when using Parameter Transfer (when using the syringe)

• when applying Favorites

The left side of the dialog box lists the named Transfer Sets. During Parameter Transfer, and when applying a 

Favorite, you can choose any one of these sets.

One of the sets is tagged as the default to use when applying Favorites. 

See Set as Default for Favorites.

Note: Element Transfer Settings and the named Transfer Sets are stored with the project. However, the 

Favorite default is a user preference and stored locally.

Open Element Transfer Settings

The dialog box is available from:

• Edit > Element Settings > Element Transfer Settings

• All locations where you can access Element Transfer sets

– The Favorite Palette’s Additional Settings pop-up menu
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– From a Favorite’s Apply button (in the Favorites interface of Tool Settings)

– When injecting parameters with the syringe cursor. 

See Pick Up/Inject Parameters.

Settings to Include for Parameter Transfer

Sort the list by either Tool or by Setting:
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Check the settings or groups that you want to be transferred during Element Transfer and when applying 

Favorites. Settings not listed here will always transfer.

Manage Sets

Import/Export

Use the Import/Export buttons at the bottom of this dialog box to transfer one or more selected sets of 

Element Transfer Settings from one project to another, in XML format.

New

Use the New button at the bottom to define a new set of Element Transfer Settings.
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Set as Default for Favorites

Choose one of the sets to use as the default when applying a Favorite: click in the right column next to the set 

you want:

This set will be used when you apply any Favorite (double-click the Favorite, or click the Apply button). You 

can see this preference if you click the Apply Transfer Settings pop-up in the Favorites interface:

The Favorite default is a user preference and stored locally.

Of course, when applying a Favorite, you can click any other set in the list to apply that set of preferred 

parameters.

Watch the Video

Watch the Video
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Group Elements

To create a Group, select elements and do one of the following: 

• Use the Edit > Grouping > Group command

• Use the shortcut: Ctrl/Cmd + G

• Click the Group command from the Arrange Elements toolbar.

Several groups can, in turn, be grouped together into a single higher-level group.

Grouped elements can then be selected and modified as a group, (unless you temporarily suspend the group 

to allow editing of individual elements).

See Suspend Groups.

Grouped elements are distinguished by their large, empty selection dots. If you select several groups 

simultaneously, each group’s selection dots will have a different color.

The following element types cannot be grouped: any of the Dimension types, Zones, Labels, Section/

Elevation/IE lines, Cameras. Doors and Windows can only be grouped along with the Wall they are placed 

into.

Suspend Groups

You may need to perform an operation on only one particular element in a group. In this case, ungrouping 

them all is burdensome, since you will have to select all the elements again to recreate the group after you 

have finished the operation.

The solution is to temporarily suspend groups by choosing the Suspend Group toggle icon in the Standard 

Toolbar, or at Edit > Grouping > Suspend Groups (shortcut: Alt/Opt+G).

(The Suspend Groups icon is also available in the Control Box.)

By activating Suspend Groups, you can select and modify grouped elements separately. Activating Suspend 

Groups means that ALL groups are temporarily rendered inactive: single elements can be selected and edited 

individually, even if they are part of a complex group hierarchy.

To re-activate the Group function, just toggle Suspend Groups to OFF again.
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Note: To change the settings of a single element in a group without using Suspend Groups, use 

Parameter Transfer. This parameter transfer will affect only the clicked element, and not the rest of the 

elements in the group.

See Parameter Transfer.

Ungroup

To make all elements constituting a group independent again, choose Edit > Grouping > Ungroup (shortcut: 

Ctrl/Cmd+Shift+G).

Ungroup is also available from the Arrange Elements toolbar.)

• Clicking Ungroup with the Suspend Groups toggle ON will detach any selected elements from their 

groups and break down all groups into single independent elements, no matter how complex the nested 

grouping is.

• Clicking Ungroup with the Suspend Groups toggle OFF, for a selection consisting of lower-level groups, 

the selected group will first be divided into the sub-groups it comprises.

Thus, you may need to repeat the Edit > Grouping> Ungroup command several times before an 

element can be selected and edited individually.

Autogroup

Edit > Grouping > Autogroup, a toggle command (shortcut: Alt+G), lets you group elements at the same 

time you create them (instead of creating elements first and then grouping them).

The Autogroup toggle command is also available in the Standard Toolbar and in the Arrange Elements 

toolbar.

If the Autogroup command is on, chained polygonal and rectangular elements will automatically be created as 

a group. Components of exploded elements will also be grouped.

Autogroup is activated by default.

Operations on Grouped Elements

The following operations can be performed simultaneously on all the elements constituting the group:

• Selection

• The following Edit menu functions: Drag, Rotate, Mirror, Multiply

• Delete

Note: If any elements in the selected group are on a hidden layer, they will also be deleted!

Other operations (such as Unify and Fillet/Chamfer) can be performed on individual elements only, after the 

elements are ungrouped or the group is suspended.

Groups and Layers

Grouping elements does not change their attribute assignments, which means that each element remains on 

its own Layer.

If some elements of a Group are on a hidden Layer:

• Elements on the hidden Layer will be invisible.

• When editing the group (by drag, rotate, mirror, multiply, delete), elements on hidden layers will also 

change their position - or will be deleted - along with the rest of the group.
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If some elements of a Group are in a locked Layer, see Lock/Unlock Elements.

• Elements on the locked Layer will be visible on the Floor Plan, but they will cause the entire group to be 

locked. The group will not be affected by drag, rotate, mirror and multiply.

• When selecting the group, all of its elements will be selected, but with gray dots. Use the Suspend 

Groups command to edit those grouped items that are not in a locked layer.
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Lock/Unlock Elements

The Edit > Locking > Lock command locks the selected items to prevent them from being accidentally 

modified. Locked elements can still be selected and used for relative construction; Snap Guides are still 

available; and you can pick up their settings through parameter transfer.

See Parameter Transfer Between Objects.

Note: Locking a layer will have the same effect - it locks all elements which are located on that layer.

The Edit > Locking > Unlock command unlocks the selected item(s).

With the Unlock All command, you can unlock all locked elements, even if they are not selected. You can 

also use the relevant buttons of the Arrange Elements toolbar for these actions.
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Display Order

When drawing a Project with ARCHICAD, overlapping elements will be drawn according to a specified 

stacking order. By default, elements are stacked in an order typically used in architectural drawings.

By default, stacking order is determined by element classes, of which there are six. Regardless of the 

sequence in which elements are placed, those in the first class will be placed in the foreground, second class 

in the level behind it, and so on.

The element classes are in descending order of class:

1. Annotation (Text, Labels, all Dimension types, Zone Stamps)

2. 2D artwork (Lines, Circles, Splines, Hotspots)

3. Library Parts (Objects, Lamps, Stairs)

4. 2D Fills

5. 3D structures (Walls, Beams, Slabs, Doors, Windows, Columns, Roofs, Meshes)

6. Zones

7. Figures

Display Order of Overlapping Elements

Overlapping within the same class depends on the order in which you place the elements, although walls with 

the same fills will display clean intersections.

When selecting overlapping elements within the same class, you can select them in sequence using Tab.

See Feedback on Overlapping Elements.

Custom Stacking Order

ARCHICAD’s default stacking order is appropriate in most cases, but you may wish to place elements in a 

different overlapping position. For instance, for a Fill to overlap a 2D element or an Object, a set of commands 

in Edit > Display Order hierarchical menu or the relevant buttons of the Arrange Elements toolbar let you 

override the default stacking order element by element.
ARCHICAD 24 Reference Guide 634



Editing Elements Interaction
On newly placed elements, the commands work as follows:

• Bring Forward: On this command, selected element(s) will overlap all the unchanged elements of their 

own and any lower classes, but will still stay below the elements of higher classes.

• Bring to Front: On this command, selected element(s) will overlap all other existing elements.

• Send Backward: On this command, selected element(s) will be overlapped by (sent behind) all the 

unchanged elements of their own and higher classes, but will overlap the elements of lower classes.

• Send to Back: On this command, selected element(s) will become overlapped by all other existing 

elements.

• Reset Default Order: This command restores the default overlapping order described previously.

Mechanism of the Stacking Order

Both the default stacking order and the customization commands are based on two ordering mechanisms: 

classes and stack levels.

ARCHICAD places elements in 14 stack levels. Each level can contain any of the element types. The final 

stacking order you see on screen and on printouts is based on stack level and element class. All elements on 

a level will overlap elements on lower stack levels, regardless of class.

New elements are always placed into the preferred stack level of their own class. Stack level preference is as 

follows:

1-4: Void by default

5: Annotation

6: 2D Artwork

7: Library Parts

8: 3D Structures

9: 2D Polygons

10: Figures

11-14: Void by default

By default, the upper and lower 4 stack levels are empty. You can bring or send elements of any type into 

these stack levels with the Edit > Display Order commands detailed above.

The Bring to Front and Send to Back commands move the selected elements until they overlap (or are 

overlapped by) all of the existing elements. This is not necessarily the 1st or the 14th level, which means that 

in most cases it will still be possible to place other elements above or below them.

Text or Dimensions brought up to the top stack level cannot be overlapped. For example, if you want a Fill to 

overlap them, you will have to send the Text one level backwards.

When moving several elements placed at different stack levels forward or backward, each element will only 

move one level.

When bringing to front or sending to back elements of different types, they will overlap (or be overlapped by) 

all existing elements, and will retain their stacking order in relation to each other.

Zones and Fills are compound elements consisting of components of two different classes (Zone Polygons 

and Zone Stamps, Fills and their area texts). These two components always keep their order according to 

their classes, for instance area texts always overlap their fills. Although you can change their overlapping 

order separately, Fills and Zone Fills can never overlap their own area texts and zone stamps and vice versa, 

forcing the other component to move with them if necessary.
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In DXF/DWG output, all elements will be transparent, meaning that hidden or partially overlapped elements 

will be entirely visible.
ARCHICAD 24 Reference Guide 636



Virtual Trace: Using References to Edit and Compare Model Views and Drawings Interaction
Virtual Trace: Using References to Edit and Compare Model Views 

and Drawings

In ARCHICAD, you can opt to display two different views concurrently in any model or layout window:

• the Active Content - the actual model or drawing you are currently working on (“Active”)

• the Trace Reference (“Reference”), optionally placed alongside, on top of or underneath the currently 

Active content. This acts as a kind of underlay, making it easy to compare multiple model views/drawings 

on the same screen.

The Trace Reference is essentially a temporary editing aid that is tied to the currently active window. The 

chosen Reference appears in a predefined default position (appropriate to the type of the Active Content and 

the Reference item).

Three item types can be chosen as a Reference:

1. Viewpoints. Any item in the Navigator’s Project Map (except 3D window items and list-type items) can be 

set as a Reference. The Reference Viewpoint will always reflect the current settings of the active window.

2. Views. Any view in the Navigator’s View Map (except 3D window items and list-type items) can be set as 

a Reference. The Reference’s view settings are independent of the active window. For example, if you 

change the layer combination in the active window, the Reference won’t change. If a view is deleted from 

the view map, its Reference is no longer available.

3. Layouts (and their drawings).

For example, you can draw a roof detail in a Detail window (the Active Content) while seeing the relevant wall 

section as a Reference.

A Section shown as a Reference next to another Section
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A Floor Plan shown as a Reference beneath a Detail

Any given window can display only one Reference at a time. However, as you navigate among your project 

windows, you can display a different Reference in each:

• The Floor Plan window has a single current Reference for all stories

• Each Section, Elevation, Interior Elevation, 3D Document, Worksheet, Detail, Layout and Master Layout 

can have its own unique Reference.

Reference settings are saved along with the window (for example, each Section in your project can have a 

Reference of a different color and filter different elements).

References are also saved with the project file. All user-defined Reference-related parameters, such as the 

list of recent References and recently chosen Reference colors, are saved together with the project file.

When using the Print command to output a model window or a Layout, you can opt to print the currently 

visible Reference as well.

When you place a Drawing onto a Layout, the Drawing content will not include the Reference.

The user can offset and rotate the Reference as needed, though logical default Reference settings for each 

combination of Active/Reference views will usually align them correctly for the particular context.

On-Screen View Options (View menu) affect the Reference just as they affect the Active.

The cursor is sensitive to elements in the Reference. Consequently:

• You can use the Pick Up Parameters command (Alt +C) on Reference elements, then transfer the 

parameters to an element in the Active.

• You can use the Trim command, the Magic Wand, and snap points with elements in the Reference to 

edit Active elements.

Topics in this section:

Choose a Trace Reference

Show/Hide Trace Reference

Set Color of Reference Elements

Show/Hide Elements in Reference
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Move/Rotate/Reset Reference

Switch Reference with Active: Access Elements within the Reference for Editing or Copying

Activate Reference

Rebuild Trace Reference

Compare Reference with Active
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Choose a Trace Reference

Use one of the following methods to choose a Trace Reference.

Show Navigator Item as Trace Reference

Browse for Trace Reference

Choose Trace Reference from Menu

Choose Reference from Trace & Reference Palette

View Context of Hotlinked Module while Editing Module Content

Show Navigator Item as Trace Reference

1. Select the item from the Navigator and right-click to bring up its context menu.

2. Choose Show as Trace Reference.

Browse for Trace Reference

Click the “Browse for Trace Reference” sub-command from one of these locations:

• The “Choose Reference” command in the Trace Reference drop-down menu of the Standard Toolbar

• The chooser button at the top of the Trace & Reference Palette
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• View > Trace Options > Choose Reference > Browse for Trace Reference

The Choose Trace Reference dialog box appears. This is a Navigator-like structure, with only those items 

available which are eligible to use as a Trace. (In the View Map, View Properties are also displayed.) Choose 

the desired Trace Reference and click OK to display it as a Trace.

Choose Trace Reference from Menu

Do one of the following:

• From the Standard Toolbar, activate the Trace button, then open the drop-down menu to choose an item 

from the Choose Reference list.
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• From the context menu in any model window, click Trace, then choose an item from the Choose 

Reference list:

• The same commands are available from View > Trace Options.

The “Choose Reference” list is dynamic. It includes recently used references, and also depends on the type of 

the current tab/window.

Choose Reference from Trace & Reference Palette

Click the button atop the Trace & Reference Palette to access a list of possible Reference items. Click the one 

you need to show it as a Trace Reference.

View Context of Hotlinked Module while Editing Module Content

You may wish to edit a Hotlinked Module at its source, then update it in the host file.

While you edit the source file, it can be helpful to see the module’s Floor Plan context in the host file. In this 

case, use the “Trace” function: 

1. In the host file, save the Floor Plan (in the host file) as a view and place it onto a Layout. 

2. In the source file, use the Organizer to access the host file and copy the Layout into the source file. 

3. In the source file, select this Layout from the Navigator and choose “Show as Trace” from its context 

menu.
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Show/Hide Trace Reference

Click the Trace toggle button to show or hide the Trace Reference in the current window.

The Trace toggle button is available:

•  in the Standard Toolbar

• in the context menu of any window - right-click in an empty space

• in the Trace & Reference Palette

• in the View menu

Set Color of Reference Elements

1. Open the Trace & Reference Palette. (Use Window > Palettes > Trace & Reference, or choose Trace & 

Reference from the list of Trace Reference commands.)

2. Click the pop-up to choose a uniform color, if desired, for Reference elements.

Show/Hide Elements in Reference

1. Open the Trace & Reference Palette. (Use Window > Palettes > Trace & Reference, or choose Trace & 

Reference from the list of Trace Reference commands.)

2. Click the pop-up to open a checklist of element types. Uncheck any that you do not wish to display in the 

Reference.
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Change you make here apply to the Reference of the current window only. However, to apply the settings in 

this pop-up to all References in the project, click the Apply Settings to All References button.
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Move/Rotate/Reset Reference

These three command icons are available from the Trace & Reference palette:

From left:

• Move: Click drag the Reference to another location.

• Rotate: Click to rotate the Reference.

• Reset: Use this icon if you want to reset the Reference to its original default position after you have 

moved it.

Note: The same commands are available from the context menu by right-clicking into any window 

showing a Reference; and from the Standard Toolbar’s pop-up list of Reference commands.

In the image below, a Section viewpoint is displayed as a Reference and rotated alongside the Floor Plan that 

contains the Section marker:

Drag/Rotate commands applied to the Reference will be reflected in the Tracker’s coordinate data 

(coordinate data are calculated according to the Active’s coordinate system, not the Reference’s.)
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Switch Reference with Active: Access Elements within the Reference for 

Editing or Copying

Elements on the Reference cannot be selected or edited.

However, by switching the Reference and Active views temporarily, you can select and edit elements in the 

Reference. For example, you can use the Switch Reference with Active command if you need to paste 

certain Reference elements into the Active view:

First, use the Switch Reference with Active command (from the list of Trace Reference commands, or the 

Trace & Reference palette.)

This changes the Reference into the Active (now you can edit its elements), and the Active into a 

Reference.

Note: This command is not available if a Drawing Section is active and its own Model-based Section is the 

Reference.

3. Select, edit and/or copy the required elements.

4. Once again, use the “Switch Reference with Active” command and return to the original Active content.

5. If you copied elements to the clipboard, now you can paste these into the Active.

Note: When pasting into a drawing-type window (such as a Worksheet), construction elements will be 

“exploded” into their 2D components.
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Activate Reference

The Activate Reference command is available from View > Trace Options, and from the list of Trace 

Reference commands (from the Standard Toolbar or the context menu of an ARCHICAD window.)

Activate Reference will change the active window to the Viewpoint that is currently the source of the Trace 

Reference. This active window, in turn, will use the same Trace Reference definition that was previously set, 

IF it applies and makes sense.

For example: Ground Floor is active and Floor Above (First Floor) is set to be the Trace Reference. If you 

activate the Reference, then the First Floor will be the active, and Second Floor will be shown as Trace 

Reference.

If the current Reference definition has no meaning in the activated viewpoint, then no Reference will be 

shown.

For example: The South Elevation is shown as Trace Reference under the Ground Floor Plan. If you use 

the Activate Reference command, the program will switch to the South Elevation Viewpoint and no 

Reference will be shown.
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Rebuild Trace Reference

Use the Rebuild command (available from the Trace & Reference Palette or among the Trace Reference 

commands) to rebuild the Reference to reflect any changes in the source view.

In some cases, the Reference will be rebuilt automatically as a result of certain other user actions, such as 

navigating to another window and panning inside a window.

However, editing a model view will not necessarily rebuild the Reference; you must use the Rebuild 

Reference button.

Note the following:

• If the Reference is an Auto-Rebuild Model, it is possible that you make changes in the Active, yet these 

are not reflected in the Reference, even after you navigate or pan, because - to avoid slowing down the 

program - you have unchecked “Update Autorebuild Model Viewpoints continuously” in Options > Work 

Environment > Model Rebuild Options. Use the Rebuild Reference button when needed.

• If the Reference contains an Auto-update Drawing, such a Reference will not be continuously rebuilt, to 

avoid slowing down the program. Use the Rebuild Reference button when needed.
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Compare Reference with Active

ARCHICAD provides several functions to help you identify and understand differences between the 

Reference and the Active content, especially when the Reference is on top of the Active content, or vice 

versa, and you need additional help to see the differences clearly. The best way to compare the two will 

depend on your particular task. You can use several of these functions at the same time to get the most 

accurate information. All the Compare functions can be used “on the fly” while editing your Active content. 

They are on-screen only functions, with no effect on output.

To access these functions, use the Trace & Reference Palette, from Window > Palettes > Trace & 

Reference.

Each of the techniques below can be useful in visually comparing the Reference with the Active. Try them out 

to see which works best.

Tip 1: Use Separate Colors for Active and Reference 

You can set separate display colors for the Reference and the Active content: a custom color for each, or 

else retain the original colors.

You may want to set two sharply different, custom colors for each of the views - say, red and blue - to make it 

easy to distinguish one from the other.

To set the colors, use the pop-up icons (one each for Reference and Active) in the middle of the Palette.

Note: Even if you’ve set separate colors, the background fills of one view may obscure the underlying 

elements in the other view.
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Tip 2: Make Fills and Zones Transparent

Note the Make Fills and Zones Transparent toggle at the bottom of the Trace & Reference Palette: 

activate this to make fills and zones transparent in both the Reference and Active views. This way you will 

“uncover” information that otherwise might have been covered up by a fill in the top view.

This switch has only a temporary effect and does not affect the settings of the model elements.

Tip 3: Reverse Display Order of Reference and Active

When comparing the Reference to the Active, it may help to switch their display order.

Click the “Reference on Top” button at the bottom of the Trace & Reference Palette.

If your Reference was previously underneath the Active, this command will change them around.

Tip 4: Optimize Intensity of Reference vs. Active 

A simple way to make an initial visual comparison is to use the Intensity sliders of the Reference and Active.

Note: This method works best if the Active is shown in its original colors, and the Reference in a different 

color.

Pull the Reference intensity slider back and forth. On screen, the effect will be to flash the Reference “on” and 

“off”, allowing you to identify places on screen where there are differences from the Active View.

Then you can zoom in on these locations and analyze the differences.
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Tip 5: Use the Splitter Bar to “Turn the Page”

This function is useful for identifying differences between the Reference and Active when they overlap. You 

will drag a Splitter bar across the window, with the Reference on one side and the Active on the other. The 

effect is like turning the “page” of an overlay to see what is beneath.

To activate the Splitter function, click the Splitter icon from the Trace & Reference Palette.

Four “splitter handles” appear, one on each edge of the screen. Choose any one of them and move it in a 

perpendicular direction, to create either a horizontal or vertical splitter bar.
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As you drag it, the content on either side of the splitter changes dynamically.

Once you let go of the mouse button, the splitter bar returns to its original position.

Tip 6: Move the Reference Over Temporarily (Displace Reference)

Use this function when you have zoomed in to an area where the two views are different, and you want to 

quickly check what is on the view underneath.

Click the Temporarily Displace Reference button in the Trace & Reference Palette.

Click in the window. The cursor changes to the hand shape, allowing the user to nudge the Reference 

temporarily (i.e. to move it “out of the way”).

Click again, and the Reference jumps back to its original position.
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Consolidate Lines and Fills in Drawing Windows

Several ARCHICAD features involve the creation of “exploded” elements. Model-based Details, Worksheets 

and Drawing Sections create 2D elements (lines, fills) out of the model construction elements. Also, imported 

DWG drawings appear in ARCHICAD in 2D form, as a large collection of lines and fills.

In these Drawing-type windows, you may wish to fine-tune the view before final output. You will find, however, 

that the “exploded” lines and fills often contain superfluous elements (extra line segments, overlapping or 

superfluous fills) that make such editing difficult.

To make editing easier, first use the Linework and Fill Consolidation functions on selected items in the 

window.

Line and Fill Consolidation are separate functions and are executed independently of each other. Select the 

elements, then execute either the Linework Consolidation or the Fill Consolidation command. (Edit > 

Reshape > Linework/Fill Consolidation). The two commands are briefly described below.

Linework Consolidation

In the window, select at least two line-type elements you wish to include in the Linework Consolidation 

process. Line-type elements are straight-lines, polylines, arcs and circles.

Note: Linework Consolidation does not affect any line-type element having an arrowhead.

The Linework Consolidation command (Edit > Reshape > Linework Consolidation) brings up the Linework 

Consolidation Wizard.

This command is also available from the Edit Elements toolbar.

Now page through the wizard (click “Next” at the bottom of every screen) and check the boxes of every Line 

Consolidation option that you wish to execute as part of the consolidation process.

For details, see Linework Consolidation Settings.

On the last screen, click “Consolidate” to execute Linework Consolidation.

Following the linework consolidation, a report appears, listing the number of elements (if any) that have been 

deleted or merged for each type of line consolidation.
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At the bottom of this page, a checkbox gives you the option of using the simplified Linework Consolidations 

Settings (rather than the Wizard) the next time you issue the command.

Linework Consolidation Settings contains the same options as the Wizard, but all options are accessible in a 

single dialog box.

Fill Consolidation

In the current window, select at least two fills that you wish to include in the Fill Consolidation process.

The Fill Consolidation command (Edit > Reshape > Fill Consolidation) brings up Fill Consolidation Settings.

See details at Fill Consolidation Settings.

Read More on Help Center
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Elements of the Virtual Building

This section of the ARCHICAD Reference Guide describes each of the ARCHICAD construction elements 

found in the ARCHICAD Toolbox: their parameters, characteristics and variations, and how they work with 

each other. 

This chapter also describes Parametric Objects, which are placed as library parts from your loaded or project-

embedded libraries, and Openings, which provide an easy-to-use way to handle engineering breakthroughs in 

certain elements.

Construction Elements

Parametric Objects

Dedicated Object Tools: Doors, Windows, Skylights, Wall Ends

Openings

TrussMaker

Solid Element Operations

The Virtual Building refers to the physical, architectural model. ARCHICAD also includes tools and workflows 

for efficient collaboration with structural engineers and analysis programs. Please see details here:

Structural Analytical Model
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Construction Elements

Construction Elements are the virtual equivalents of actual three-dimensional building components. Each of 

these elements has a dedicated tool in the ARCHICAD Toolbox.

Place a Construction Element in ARCHICAD

Home Story

Define Top Link for Wall, Column, Zone or Stair

Element Display in Floor Plan and Section

Walls

Columns

Beams

Complex Profiles

Roofs

Shells

Slabs

Meshes

Zones

Curtain Wall

Stairs

Railings

Morphs

Model Element Connections

Element Intersections
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Place a Construction Element in ARCHICAD

Use the Toolbox

The typical steps in element creation using the Toolbox are: 

1. Select the element’s tool in the Toolbox and open its settings dialog box.

2. Adjust the settings offered by default to suit your particular situation or purpose. You can choose a 

Favorite - a predefined element configuration - using the button on top of the Tool Settings dialog box, or 

from the Toolbox.

See Favorites.

3. Use the panels of the element Settings dialog box (or Info Box) to assign parameters.

4. Where applicable, choose a Geometry Method from the Info Box allowing you to create plain, curved, 

chained, rotated or polygonal variations of the elements.

5. Draw or place the element in the Floor Plan or 3D window.

Other Ways to Create an Element

Other methods of element creation include: 

• Use the Favorites Palette: double-click on stored Favorite settings for the relevant tool, then click to 

place an element with those settings.

• Use the Magic Wand to create new elements that automatically match the shape of an existing element 

(e.g. create a Roof that fits exactly over your exterior Walls).

See Magic Wand.

• Create duplicates of existing elements.

See Basic Editing Operations.

• RoofMaker and TrussMaker from the Design > Roof Extras or Design > Design Extras menu.

See TrussMaker and Create Special Roof Objects with RoofMaker.

Gravitate Elements onto a Slab, Roof, Shell or Mesh

To make placement more accurate, you can use the Gravity function to place Wall, Column, Beam and Object 

type elements directly onto a Slab, Roof, Shell or Mesh.

See Gravity.
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Home Story

A new element placed in a 2D model window is at the level of its Home Story (plus or minus any optionally 

defined offset). 

Each construction element and object-type element is physically linked to its Home Story and moves together 

with it.

• On the Floor Plan, a new element’s Home Story is the one defined in its Tool Settings dialog box: by 

default the current story, but you can choose a different Home Story. In any case, the element will be 

placed onto its Home Story.

• If you place the element in the 3D Window, the Home Story depends on the element’s elevation: the 

closest story below the element’s bottom elevation, at the time the element is placed, will be its Home 

Story. (If the 3D Window is active, the Home Story control and the offset from Home Story field in the 

Default Tool Settings dialog are grayed out. However, you can still set the bottom elevation from Project 

Zero in the Tool Settings dialog boxes.)

• If you redefine an element’s Home Story (e.g. from 0. Story to 1. Story), the element will change its 

position and move onto its new Home Story (from 0. Story to 1. Story).

Note: For reasons of compatibility with older ARCHICAD versions, you can redefine the Home Story in 

such a way that the element stays in place. See Relink Home Story.

• If you move the element onto a different story (e.g. with the Elevate command), its Home Story will, by 

default, change to match the element’s new location. (See Change Home Story by Elevation.)

• If you modify the Home Story itself (e.g. redefine the story level in Story Settings), the linked element will 

move along with it (while respecting the defined offset, if any).

• If you delete an element’s Home Story, that element will be deleted!

Other uses for the Home Story:

• The Home Story helps define which part of an element will be displayed, according to the Show on 

Stories control in the Tool Settings dialog box. (See Show On Stories.)

• The Home Story can be used in listing criteria.
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Define Home Story (Elements Placed on Floor Plan)

Before placing a new element on the Floor Plan:

In the element’s Tool Settings dialog box, or its Info Box, choose a Home Story onto which to place the 

element on the Floor Plan.

• Default: The element’s Home Story will be the current story.

• Alternatively, choose a different story from this pop-up, or (if there are too many stories to list here) click 

Select Story to bring up the full list of stories. Choose one onto which to place the element: this will be its 

Home Story.
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If the current story is the Ground Floor, yet you choose the 2. Story as the Home Story, the new element will 

be placed onto its Home Story (that is, 2. Story) - you will not see it on the current story. You will get a 

message telling you this.

Relink Home Story

Although elements “follow” their home story - if you change an element’s Home Story, the element will move 

onto its new Home Story - there is a way to relink the element to a different Home Story so that the element 

still remains physically located on its original story.

Use the Edit > Element Settings > Relink Home Story command to redefine a selected element’s Home 

Story. The element will stay in place even as its Home Story changes.

For selected elements, this command is also available in the context menu.
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Watch the Video

Home Story in the 3D Window

If you place the element in the 3D Window, the Home Story will be defined not according to the Settings 

dialog box (where the control is grayed out), but rather by elevation: that is, the story beneath the element’s 

reference point, at the time the element is placed.

Note: For a Shell, this reference point is the first point used to draw the Shell (not the bottommost point).

Change Home Story by Elevation

If you move a placed element to a different story, the element’s Home Story can change to match the 

element’s new location.

As you elevate the element, the “By Elevation” text in the Tracker indicates that the Home Story changes to 

match the element’s new elevation:

Notice that a Guide Line appears marking the story positions, to make it easier to place the element.

Alternatively, use Tracker controls to choose a different Home Story for the selected element, regardless of its 

elevation:
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Similarly, in either 2D or 3D windows, you can automatically reset an element’s Home Story as its elevation 

changes if you use the Elevate or Multiply commands, by checking the Set Home Story by Elevation box:

If you uncheck the box, the element’s Home Story as set in the Tool Settings (Info Box) will remain in effect 

regardless of the elevation change.

See also Elevating Elements and Multiply Elements.
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Define Top Link for Wall, Column, Zone or Stair

You have the option to link the top of certain elements (Wall, Column, Zone, Stair), to a story. This top link is 

defined relative to element’s Home Story (Home+1, Home+2, etc.).

(By default, the element top is linked to one story above its Home Story).

If you later modify the positions and heights of stories in your projects, the heights of any top linked elements 

will follow automatically. Elements that you have not top linked are therefore fixed-height elements.

Stairs have some additional Toplinking options.

See Stair Geometry Controls.

Top Link controls are located in the Geometry and Positioning panels of Tool Settings for the Wall, Column, 

Zone and Stair (as well as the Info Box).

• If you don’t want to top link, choose “Not linked”.

• Optionally, define an offset for the element top from the element’s top linked story: the element height will 

change accordingly, but the link to a particular story remains.

If you top link an element to a particular story, and if you later modify this story’s position, the height of the 

linked element will automatically change accordingly:

If you delete the story which is the top link, then the story above takes its place.

Watch the Video

Watch the Video

Watch the Video
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Inverted Elements

Changing story heights may result in inverted elements: their top elevation will fall below the bottom elevation.

This can occur, for example, if your project contains stories of varying heights, and you are placing a series of 

top linked walls with certain offsets which may not “fit” onto a particular story.

Such elements are displayed as having zero height (e.g. such a wall is displayed as a straight line in section 

view), and are highlighted so that you can easily find and correct them.

Find Inverted Elements

Or use the built-in Inverted elements criteria set from Edit > Find & Select to find and select any inverted 

walls, columns and/or zones.

Note: Use the Check for Inverted Elements command to find and list any inverted elements in your 

project. This command is not available by default in the ARCHICAD Work Environment. To use this 

command, customize your Work Environment menus to include it.

See Menu Customization Dialog Box.

Inverted Elements Highlight Color

To set the highlight color of inverted elements, use the control at Options > Work Environment > On-Screen 

Options. (This color is also used for invalid Stairs.)

Watch the Video
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Walls

In ARCHICAD, you can draw walls that are straight, curved, trapezoidal and polygonal. 

Wall structure can basic (of a single component), or composite (composed of several components). You can 

also create complex walls (Profile Wall) of any custom shape and with a combination of components. Like 

other construction elements, a Wall’s essential structure derives from its Building Material.

Certain parametric objects such as Doors, Windows, and Wall Ends can only be placed into Walls.

A Curtain Wall is constructed with a separate, dedicated Curtain Wall tool.

See Curtain Wall.

Wall parameters are set in Wall Tool Settings. The bottom of every Wall (like other elements) is linked to its 

Home Story; you can also top-link the Wall to any story above it in the project. As needed, define offsets from 

its top link or Home Story; this will affect the Wall Height. Alternatively, just enter a fixed Wall height, without a 

top link.

Certain Walls can be included in a Structural Analytical Model generated in ARCHICAD.

For details, see Structural Analytical Model.

Display of Walls

Use Wall Settings to choose attributes for the display of your wall in the various 2D and 3D windows, and to 

define its Building Material.

Use the Floor Plan Cut Plane, combined with element projection preferences, to determine which parts of the 

placed wall should be displayed.

While a Wall’s surface is defined as part of its Building Material, you can override a Wall’s surfaces on the 

Wall’s “outside” (reference line side), edge, and “inside” surfaces, using the controls in the Model Panel of 

Wall Settings.

Some aspects of Wall display depend on the current settings in View > On-Screen View Options.

• Clean Wall & Beam Intersections can be set on and off.

• Fill patterns can be shown as Vectorial Hatching or bitmap.

To use Graphical Overrides for Wall fills: 

See Graphic Override Rules.

Related Topics:

Wall Reference Line

Create a Straight Wall

Create a Curved Wall

Create a Chain of Walls

Create a Rectangle of Walls

Create a Trapezoid Wall

Composite Structures

Create a Polygon Wall (PolyWall)

Stretching Walls

Create a Slanted or Double-Slanted Wall

Modify Slanted Wall

Create a Log Wall
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Complex Profiles

Walls and Other Elements

Modify Wall Reference Line

Invert Wall Direction

Wall Tool Settings

Define Top Link for Wall, Column, Zone or Stair

Structural Analytical Model
ARCHICAD 24 Reference Guide 666



Construction Elements Elements of the Virtual Building
Wall Reference Line

Each Wall has a reference line and a direction. The Wall reference line is visible on the Floor Plan if you 

switch on: 

View > On-Screen View Options > Walls & Beams Reference Lines

In the 3D window, the reference line of a selected Wall is shown in a separate color: you can change this color 

using the “Reference Lines in 3D” setting at Options > Work Environment > Selection and Element 

Information.

Change Wall Reference Line Position

Use the Info Box or Geometry and Positioning Panel of Wall Settings to choose a reference line position. Click 

the “C” shortcut to cycle through the reference plane options in the Wall Info Box.

Reference Line of a Basic Wall

A basic Wall has three possible reference lines: running along the outside face, inside face, or the center.

By default, the reference line runs along the “outside face”.
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Reference Line of a Composite Wall

A composite Wall has six possible reference lines: outside/inside/center of the Wall, plus outside/inside/center 

of the Wall core.

Note: If the chosen composite structure has no core, then the core-related Reference Line choices are 

grayed out.

By default, the reference line runs along the “outside face”.

For a composite, the “outside” surface is the first listed skin of the composite, in Composite Settings.
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Watch the Video

Reference Line of a Trapezoid Wall

A Trapezoid wall has two possible reference line locations: Outside Face or Core Outside (if it has a core).

See also Create a Trapezoid Wall.

Reference Line of a Polygon Wall

Reference line controls in Wall Settings do not apply to Polygon walls. (Polygon wall reference lines can be 

moved graphically via the pet palette.)

Reference Line of a Profile (Complex) Wall

The reference line of a Profile (complex) wall depends on the user origin defined in Profile Manager/Editor.

Reference Line Offset: If using an “outside” or “inside” reference line, enter a positive offset to move the 

reference line toward the center (or center of core) of the Wall. A negative offset will move the reference line 

away from the center (or core center). (No offset is available if the reference line is in the center.)

As you adjust the reference line location, notice that the body of the Wall moves laterally. The reference line 

stays in place.

Note: In contrast, to move the reference line while retaining the Wall’s position intact, and/or mirror the 

openings, use the Modify Wall Reference Line command. 

See Modify Wall Reference Line.

Flip Wall Along Reference Line

This command flips (or mirrors) a selected Wall along its reference line. The reference line stays in place, but 

the body of the Wall flips to the other side. Notice that the openings do not change their opening direction.

The command is available in the Wall Info Box, and in the Geometry and Positioning Panel of Wall Settings.
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Note: To move the reference line while retaining the Wall’s position intact, and/or mirror the openings, use 

the Modify Wall Reference Line command. 

See Modify Wall Reference Line.

Reference Line in Interactive Schedule/Find & Select

In the Interactive Schedule, you can Find & Select the Walls in your project, or list them in the Interactive 

Schedule, based on the location of their reference lines:

Uses for Reference Line

• The reference line helps you achieve the precise connection of Walls for clean intersections. Associating 

the reference line to the core allows finishes to be edited without moving the core’s position.

• The reference line establishes hotspots and edges for selecting, moving and transforming Walls. Some 

Pet Palette editing commands are accessible only by clicking on the reference line of the selected Wall, as 

shown in the two images here:
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• The reference line position determines the Wall’s “outside” and “inside” surfaces. (The reference line is on 

the outside of the Wall.) Separate surface materials can be applied to the Wall’s “outside” and “inside” 

surfaces, using the controls in the Model Panel of Wall Settings.

Wall Direction

The direction of the Wall, indicated by the arrow on the reference line, is defined by the order in which you 

define the wall’s endpoints.

Note: The directions of curved Walls and polygon Walls are fixed and cannot be reversed.

Note: With the commands at Edit > Reference Line and Plane, you can modify the Reference Line 

position and the direction of selected Wall type elements.

See Modify Wall Reference Line and Invert Wall Direction.
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Create a Straight Wall

The Single Straight Wall method produces one straight wall element at a time.

With the Wall Tool selected, choose the Straight Wall Geometry method from the Info Box and draw the wall 

segment on the plan.

In both Floor Plan and 3D, you define the length of Wall segments by clicking at their endpoints.

Note: This CAD-like drawing method is the default method of drawing segments in ARCHICAD, but you 

can change it in Options > Work Environment > Input Constraints & Guides.

Walls can be stretched using either menu commands or pet palette commands.
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Create a Curved Wall

With the Wall Tool selected, choose one of the three Curved Wall Geometry Methods from the Info Box.

• Centerpoint and radius

– Click to define centerpoint.

– Move the cursor to define the radius, then click a second time.

– Move the cursor to draw the length of the Wall, then click to complete.

Note: To draw a full circular Wall, double-click when defining its radius.

• Circumference

– Click on three points of the Wall’s circumference (e.g. other elements or intersections, or special snap 

points).

– Click a fourth time to define the length of the Wall.

• Tangential: Define a full circular Wall based on three tangential edges or points.

Note: Not available in 3D window.

– Select three initial points: these can be a tangent edge, a node, or a free-floating point.

The next step depends on the geometric situation.

- If there is only one solution, the circular Wall is automatically drawn.

- If there are multiple solutions, the Eyeball cursor appears and the ghost contour of the Wall flips 

from one position to the other as you move the cursor around. Click when it is at the right place to 

complete the circular Wall.

- If there is no solution, (for example, if you define three parallel edges for tangency), no circle will be 

made.

Note: Since Walls need to have two endpoints, the fully closed circular Wall that you draw will in fact 

consist of two half-circles. Walls in the forms of full ellipses, elliptic arcs or splines cannot be created 

directly, but you can trace the shapes of plain drawing elements with the Magic Wand.

Related Topics:

Stretching Curves

Curve/Straighten Element Edge

Board in Curved Wall

Board in Polygon Wall

Doors/Windows in Curved Wall
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Create a Chain of Walls

A chained wall is a sequence of connected straight or curved wall elements.

With the Wall Tool selected, choose the Chained Wall method from the Info Box. (Pop out the small black 

arrow on the Straight Wall Method button.)

As soon as you start drawing the Wall, a pet palette appears with geometry options for each segment:

• A straight segment

• A curved segment tangential to the previous one (cannot be used for the first segment)

• A curved segment tangential to a line you define before actually drawing the segment

• A curved segment passing through two points

• A curved segment defined by its centerpoint, radius and length

Click to place each successive segment using any of the geometry methods. 

Double-click to complete the Wall. 

• Click Backspace to undo just the last input segment.

• Click Cancel or Delete to undo the entire Wall.

• If you change the Wall’s attributes in the Info Box during the creation process, all created Wall segments 

will have the modified attributes (reference line position, line type, etc.).

This input method is analogous to creating a chained Beam.

See Chained Beam.
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Create a Rectangle of Walls

With the Wall Tool selected, choose the Rectangle Wall method from the Info Box. (Pop out the small black 

arrow on the Straight Wall Method button.)

Draw the diagonal of the rectangular wall and click to define its length. The rectangle wall is created.

Its four sides are always aligned orthogonally with the Normal Grid and are not affected by the use of a 

Rotated Grid.

The Rotated Rectangle Wall method produces four wall elements as with the previous method, except that 

you first define a rotation vector for the rectangle’s base reference line. Then drag the cursor to define the 

rectangle.
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Create a Trapezoid Wall

The Trapezoid or Non-Parallel method allows you to draw straight Walls whose thickness is not constant.

You draw this type of Wall as a straight Wall, except that you will first enter the thickness of the Wall at its two 

endpoints, using the Wall Thickness fields in the Info Box or in Wall Settings.

Composite Trapezoid Wall

When drawing a trapezoid Wall with a composite fill, only the last Core skin’s thickness reflects the trapezoidal 

shape of the Wall. In the image below, two of the skins are marked as Core, but only the Concrete Block core 

skin - the last Core skin listed in the dialog box - has a trapezoid shape.

See also Reference Line of a Trapezoid Wall.

If the composite structure has no core, then the composite’s thickest skin gets the trapezoid shape. (If several 

skins are equally thick, then the last of those skins listed in the dialog box gets the trapezoid shape.)

See also Composite Structures.
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Create a Polygon Wall (PolyWall)

To define a polygonal wall block of free shape, choose the Polygon Wall Geometry Method in the Info Box. 

Polygon Walls can contain Doors or Windows. For Polygon Walls, only simple fills are available (no 

composites).

Note: If your polygon wall contains a window with a board, an option in Window Settings lets you set the 

board edge to either follow the wall polygon (Parallel to Wall Polygon) or to stay parallel with the window.

See Board in Polygon Wall.

Draw the contour of the Polygon Wall, using pet palette segment options as needed (as when drawing a 

chained wall). Both straight and curved edges are allowed.

Once you have closed the polygon, click with the hammer cursor to complete the wall.

You can also transform a regular wall into a polygon wall: select the wall, then choose the Polygon Wall 

geometry method.

Now use the Pet Palette commands to model the wall shape as desired.

If you define a polygon whose edges intersect themselves, ARCHICAD will warn you about this, but the wall 

will still be drawn.

The wall’s edges will include one reference edge (like a straight wall’s reference line).

To make another edge the reference edge, select an endpoint of the current reference edge. The pet palette 

contains a command with which you can move the reference edge endpoints to other nodes of the polygon 

wall.
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When you override surfaces of a polygon wall in the Model panel of Wall Settings, the surfaces are assigned 

depending on the location of the reference edge.

• The “Outside Face” is the reference-edge surface; here, in red.

• The “Edge Surface” is assigned to the two surfaces adjacent to the reference edge; here, in gold.

• The “Inside Face Surface” surfaces are assigned to all other edges (those which are opposite the 

reference edge), here, in blue.

To edit polygon walls, click the nodes and edges of the selected Walls and use the pet palette.

When connected to other, plain walls, wall polygons keep their original contour by default.

For more information, see PolyWall Corners.
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Stretching Walls

To stretch/shrink the length of straight Walls with the menu command:

1. Select a wall.

2. Choose the Edit > Reshape > Stretch menu command, or the Stretch command from the pet palette.

3. Click the reference line endpoint and move it.

4. Click again to either define the new endpoint as an extension (or reduction) of the previous length or 

define an entire different new location. The wall is stretched or shrunk and, if needed, rotated according to 

the new endpoint. The other endpoint will remain at its original position.

Note: Multiple Walls, Lines and Arcs with overlapping endpoints can all be stretched at the same time with 

the Stretch menu command, or by using the Marquee.

For more information, see Stretching with the Marquee Tool.

When using the pet palette:

1. Select a wall.

2. Click one of the wall’s reference line endpoints. The pet palette appears. Choose the stretch icon.

Click to define the new endpoint.

3. You can stretch a curved wall by using a special angular or radial stretch commands.

See Stretching Curves.
ARCHICAD 24 Reference Guide 679



Construction Elements Elements of the Virtual Building
To stretch a Trapezoid wall, you can use the special Stretch Trapezoid Wall command from the pet palette: 

this will increase/decrease the width of the wall proportionally as you stretch it from either end.

See also Stretching or Shrinking Lines; Stretching Objects.
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Create a Slanted or Double-Slanted Wall

To draw a wall whose vertical axis is slanted on either or both sides:

1. Go to Wall Settings (Geometry and Positioning panel).

2. Click the desired Slanted Wall Icon.

3. Enter the desired wall angle(s).

A slanted wall tilts in one direction; its two faces are parallel to each other. A double-slanted wall has faces 

which are not parallel.

The height of either type of slanted wall is the distance between its lowest and highest point. When setting the 

angles of a double-slanted wall, you are constrained by the minimum thickness of the top of the wall. For a 

basic structure, this can be zero. The top of a composite wall, however, has to be wide enough to 

accommodate all of the skins.

When entering a height value of a double-slanted wall, you face the obvious constraint that the wall’s width at 

the top cannot be negative (i.e. once the two faces meet, you can’t go any higher.)

The thickness of a slanted wall is its thickness perpendicular to its slant vector (as indicated by the icon in the 

Info Box):

The thickness of a double-slanted wall equals the width of the wall base.

If you switch from one kind of slant to another, the wall is transformed as follows:

• If you transform a single-slanted into a double-slanted wall, the new wall’s width (i.e. its wall base) will take 

on the width of the old, single-slanted wall.

• Similarly, if you have a double-slanted wall and change it to either a vertical or single-slanted wall, the new 

wall will have the same width as that of the old, double-slanted wall.
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Double-Slanted Wall in Section view

In Section view, a double-slanted wall is trapezoid in shape. 

If the wall has a composite structure, its skin geometry corresponds to that of a Composite Trapezoid Wall. 

See Composite Trapezoid Wall.

See also Modify Slanted Wall.
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Modify Slanted Wall

Slanted walls can be stretched and/or their slant angle can be modified with pet palette commands in 3D and 

Section views.

In 3D, you can:

• Slant a wall or change the slant angle by selecting its corner point and dragging it along the horizontal 

plane. (Use Modify Angle in the pet palette.)

Note: You cannot slant a wall whose reference line is centered.

• Stretch a slanted wall by moving its top or bottom edge up or down along the wall plane (Use Stretch 

slanted height.)

• Stretch a slanted wall vertically. (Use Stretch height in the pet palette.) As you change the wall height, the 

wall thickness remains the same but its slant angle is adjusted accordingly.

In Section view, you can use the same functions. (“Modify Slant Angle” is possible only if the wall’s reference 

line is perpendicular to the section line.) In Section view, the Tracker’s “Distance” field provides a way to edit 

the wall inclination using its offset (e.g. Distance) value.)

Double-Slanted Wall Editing

You can edit double slanted walls in 3D or Section in four different ways:
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Create a Log Wall

You can create straight walls constructed from logs. Log details appear in both the 3D Window and Section/

Elevation/IE Windows.

Clicking the Log Details button in the Model panel of Wall Settings provides a number of geometry and 

texture options.

Note: Log construction is only available for basic straight walls. When determining the log’s height, 

remember that if you enter a value that is larger than the wall’s width parameter, the logs will not rest on 

each other.

See Log Details Dialog Box.
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Walls and Other Elements

For information on how intersections (junctions) work among construction elements:

See Element Intersections.

The following other features also affect Wall intersections:

• Columns and Walls

See Columns and Walls.

• The Connect commands can trim Walls to Roofs or Shells. 

See Trim Elements to Roof or Shell.

• You can also crop a Wall to a Single-plane Roof.

See Crop Elements to Single-plane Roof.

• The Adjust Elements to Slabs function lets you adjust Walls to specific levels of one or more Slabs that 

are located above and/or below them.

See Adjust Elements to Slabs.

• Walls can be connected to Curtain Walls using the Design > Connect > Join Wall(s) to Curtain Wall. 

The same command is available under Design > Modify Curtain Wall.

See Join Wall to Curtain Wall.

• Relation to Zones: In the Model Panel of Wall settings, define how the Wall should behave in relation to 

zones: as a zone boundary (delimiter), or whether its area/volume should be subtracted from the zone it is 

in, or whether it should have no effect at all on a zone.

See Relation to Zones.

PolyWall Corners

When connected to other, plain walls, wall polygons keep their original contour by default.

You can override this default setting.

In the following example, a Single Wall is connected to a Wall Polygon.

Now, check the PolyWall Corners Can Change box in the Geometry and Positioning section of the Wall 

Settings dialog box (available when a PolyWall is selected).

This effect is visible if you turn on View > On-Screen View Options > Clean Wall & Beam Intersections.
ARCHICAD 24 Reference Guide 685



Construction Elements Elements of the Virtual Building
Modify Wall Reference Line

Use the commands of the Reference Line and Plane hierarchical menu to modify the Reference Line 

position and the direction of selected Walls. By default, this menu is at: Edit > Reference Line and Plane.

This command moves the reference line without changing the Walls’ position on the Floor Plan

The Modify Wall Reference Line command brings up the following dialog box:

• Mirror Walls in Place: Check this box to flip the wall’s reference line around the central axis of the wall 

(direction remains unchanged).

Doors and Windows remain unchanged (unless you also check the following box):

• Mirror Doors and Windows in Walls: Check this box to reverse the opening direction of the Wall’s Doors 

and Windows.
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Edit Reference Line Location: Check this box, then use the controls to move the reference line of the 

selected Walls without changing the Walls’ position on the Floor Plan.

Note: Modifying the reference line location here has no effect on Complex Profile Walls.

Edit Offset: Check this box, then enter an offset distance (if any) of the reference line from its defined 

location. A positive number moves the reference line toward the center of the Wall core; a negative number 

moves it away. (The Wall itself does not move.)

Offset is not available if the reference line is at the Center or Core Center.

Watch the Video
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Invert Wall Direction

With the Invert Wall Direction command (Edit > Reference Line & Plane), you can change the direction of 

the reference line. (The Wall direction is visible when the Wall & Beam Reference Line command toggle is 

On.)

Note: The directions of curved Walls and polygon Walls are fixed and cannot be reversed.

See also Wall Reference Line.
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Columns

Place a Column

Create a Slanted Column

Create a Multi-Segment Column

Define Column/Segment Structure

Rotate Join Angle

Tapered Column or Segment

Editing Columns

Edit Mode for Multi-Segment Columns

Core and Veneer

Columns and Other Elements

Column Tool Settings: Preview and Positioning

Column End Cuts and Reference Axis

Column Model Display

Column Display on Floor Plan and Section

Related Topics:

Columns can be included in a Structural Analytical Model generated in ARCHICAD.

For details, see Structural Analytical Model.

For information on the Structural Analytical Parameters Panel of Column Tool Settings:

See 1D Members (Column and Beam)
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Place a Column

Before placing a Column, go to Column Settings to adjust its core geometry, height, positioning and end cuts.

See Column Tool Settings: Preview and Positioning

To place a Column, choose one of the four Geometry Methods (input methods) from the Info Box.

Simple Column

Place the Column (straight or slanted) with one click. The Column axis will be projected from the Floor Plan.

For a slanted Column: see Create a Slanted Column.

Two-Click Column Input

Use this to freely define the column slant during input. 

No need to define a slant angle before input.

1. Click to place the Column base.

2. Click again to complete the Column. 

• The second click defines the Column’s slant angle and (in the 3D window) its height.

– In Floor Plan, the height is fixed, and you defined the slant angle graphically (as shown in the Tracker.)

– In the 3D window, you can snap to existing elements, and/or click Shift to constrain input to an editing 

plane.
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Rotated Column

1. Click to place the Column base.

2. Click again to define its rotation angle.

Slanted and Rotated

Slanted column only.

1. Click to place the Column base.

2. Click again to define its rotation angle.

3. Revolve it around its slanted axis, and click to complete.
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Create a Slanted Column

Use Column Settings, or use the two-point method to define Column slant graphically in the 3D window.

Set Slant Angle in Column Settings

Define Slant Angle in Settings

1. From Column Settings (Column page, Placement panel) or the Info Box, choose the Slanted icon.

2. Enter a slant angle in degrees.

3. Choose a Placement Method from the Info Box, then place the column.

Two-Click Column Input

Use this to freely define the column slant during input. This is easiest in the 3D window. 

Do not define a slant angle before input.

1. Click to place the Column base.

2. Click again to complete the Column. 

– In the 3D window, you can snap to existing elements, and/or click Shift to constrain input to an editing 

plane.

     

• The second click defines the Column’s slant angle and (in the 3D window) its height.

• When creating a two-click Column on the Floor Plan, the Column height is fixed.

Related Topics:

Place a Column
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Create a Multi-Segment Column

Set up a Column that consists of multiple segments, with a configurable “Join” component between them.

To create Column segments, use either the Settings dialog or graphical interactions. Both methods are 

described below.

Watch the Video

Notes:

– Each segment has its own Classifications and Properties settings and its own Element ID. However, 

Category definitions (e.g. Renovation status) are inherited from the element level.

– Find & Select, Labels, Info Box, and Interactive Element Schedule fields can use segment-specific 

data

Watch the Video

Use Column Settings

1. Open Column Settings and go to the Segment page.

2. Click the Multi-Segment column icon.

3. Click Add to add as many segments as needed. 

– A “Join” component is automatically added between each segment.

4. View the Structure list to see segments and Joins. Select or multi-select to edit.

5. View the preview. The segment currently selected in the list is highlighted.

Multi-Segment Column
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Create Graphically

1. Select a Column in the 3D window.

2. From the pet palette of the Column axis, choose Split Segment.

3. Click anywhere on the Column axis: the Column is split at that point into segments. Repeat to create more 

segments as needed.

• To edit the segments individually and graphically, you can use Edit mode.

See Edit Mode for Multi-Segment Columns.

• To define attributes for each segment, use the Settings dialog.

See Define Column/Segment Structure.

Related Topics:

Delete Column Segment or Beam Segment
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Delete Column Segment or Beam Segment

For a multi-segment Column or Beam, delete a particular segment:

Use Element Settings

1. Select the element.

2. Open Column or Beam Settings - Segment page.

3. Select a segment and click Remove.

Remove Segment Graphically

1. Select the element.

2. Click the Join hotspot (on the reference axis or reference line).

3. From the pet palette, use Move Segment Join.

4. Drag the join until you reach the end of the segment.
ARCHICAD 24 Reference Guide 695



Construction Elements Elements of the Virtual Building
Define Column/Segment Structure

Select a Column or Column segment.

Use the Structure panel of Column Settings (Segment page) to define its structure properties and length (fixed 

or flexible).

For a selected segment: these Settings are also available in Column Edit mode.

Cross Section

Click an icon to define segment cross-section.

• Rectangular

• Circular

• Complex Profile
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Building Material

For a Rectangular or Circular Column:

• Use the pop-up to choose its Building Material.

• Add an optional veneer. (See also Core and Veneer.)

For a Complex Profile column:

• Use the pop-up to choose its Profile.

Note: This pop-up shows only those Profiles whose “Use With” control includes Columns. Profiles are 

defined at Options > Element Attributes > Profile Manager.

Segment Length (Fixed or Flexible)

For each selected segment: Define its length as either fixed or flexible, by clicking the corresponding icon in 

the Structure panel. 

• For fixed-length segment: Define length. This length will remain unchanged even if the Column stretches. 

(You can also enter a selected segment’s length in the Structure list.)

Core Cross Section and
Building Material

Add Veneer and
Building Material
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• For a flexible segment: Define its length as a percentage of all the flexible segments. (The flexible 

segments together add up to 100%.) Segment length will stretch accordingly if the Column stretches.

Segment Length - Edit in 3D

1. Select the Column in the 3D window.

2. Click the Join hotspot (on the Column reference axis).

3. From the pet palette, use Move Segment Join to adjust segment length.

Note: If you drag the hotspot onto adjoining hotspot segment, this eliminates the segment entirely. 

Flexible (yellow) segments stretch with the 
column.

Fixed (red) segment does not stretch.
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Related Topics:

Tapered Column or Segment

Delete Column Segment or Beam Segment

Rotate Join Angle

Core and Veneer
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Rotate Join Angle

In Column Settings:

For a Join component selected in the list (at the top of Column Segment Settings): use the Segment Join 

panel (below) to define its angle as horizontal, vertical or custom. 

Note: Vertical Join available for slanted Column only.
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In 3D Window:

Joins can be edited graphically:

1. Select the Column in the 3D window.

2. Click the Join hotspot (on the Column reference line).

3. From the pet palette, use Rotate Join Angle to adjust the Join angle

Related Topic:

Define Column/Segment Structure
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Tapered Column or Segment

You can created a tapered Column, or taper any single Column segment. 

Use the Segment page of Column Settings. (For a multi-segment Column, select the segment to taper.)

1. In the Structure panel, choose Tapered geometry.

2. Use the pop-up to define the cross-section dimensions of the tapered Column (segment) at its top and at 

its bottom.

– Use the chain icon to make the height/width dimensions equal

– Use the arrow button to reverse the tapering direction
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Related Topic:

Define Column/Segment Structure
ARCHICAD 24 Reference Guide 703



Construction Elements Elements of the Virtual Building
Editing Columns

Stretch Height/Modify Angle

In the 3D or Section window and/or Column Edit mode:

Use the Pet Palette commands at the Column’s Reference Axis endpoint. Available commands depend on 

Column geometry.

• Stretch height

• Stretch height with fixed angle

• Modify angle

Stretch Edge(s) of Column Profile

In the Floor Plan or 3D window, use the Pet Palette commands to stretch a Column by its edges - either the 

core, or the veneer (if any).
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Depending on the position of the Reference axis, you can stretch the profile edge in both directions:

Stretching the core will not affect the veneer thickness. 

Related Topics:

Edit Mode for Multi-Segment Columns

Watch the Video
ARCHICAD 24 Reference Guide 705

https://youtu.be/-cIUejXxjzY


Construction Elements Elements of the Virtual Building
Edit Mode for Multi-Segment Columns

For a multi-segment Column, use Edit mode to edit each segment separately. Edit mode is ideal for fine-

tuning segment geometry graphically.

Enter Edit Mode

Select a multi-segment Column in any model view, then do one of the following:

• Click the Edit button which appears.

• Use Design > Enter Column Edit Mode.

Using Edit Mode

• In Edit mode, the regular ARCHICAD toolbox is replaced by just selection tools and a display palette.

• Use Environment toggle in the display palette to show/hide the rest of the building model (i.e. everything 

apart from the selected Column). In Edit mode, you cannot edit the rest of the model.

• From the display palette, the full Column Settings dialog is available.

• From the Info Box, you can open a limited, segment-specific Settings dialog.
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For example, edit the Profile Modifiers of a profiled Column segment:

Exit Edit Mode

Do one of the following:

• Click Esc

• Click Exit Edit Mode from the display palette.

• Use Design > Exit Column Edit Mode

Click Column Settings from the display palette to access the settings dialog for the selected segment.

See Define Column/Segment Structure.
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Core and Veneer

Columns in ARCHICAD are made up of two components: the load-bearing core and the optional veneer, used 

to simulate fire proofing or any kind of sheathing around the core. The veneer has its own building material, 

and thus its own intersection priority.

Set a Veneer for any Column or Column segment.

Note: Veneer not available for Profile Columns (segments).

Add/Remove Veneer

1. Go to the Structure Panel of Column Settings (Segment page).

2. Use the Add/Remove Veneer toggle button.

3. Define a uniform veneer thickness in the field to the right.

4. Use the pop-up to choose a Building Material for the veneer.

Veneer Structure: Core, Finish, Other

The veneer component can be defined as either “core”, “finish” or “other”.

Note: The Finish option is not available for wrapped columns. (See Columns and Composite Walls: 

Wrapped or Unwrapped.)
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Partial Structure Display settings takes the Veneer structure into account, in both 2D and 3D views.

Column with a veneer, with varying Partial Structure Display settings. This veneer is defined as a “Finish”

See Partial Structure Display.
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Columns and Other Elements

Columns and Walls

The display of their intersections depends on the Intersection priority of the Building Materials: the higher 

number will prevail.

Note: Each Building Material has a separate Intersection Priority, set in the Building Materials dialog box.

• If two identical Building Materials meet, the separator line will be hidden.

See also Element Intersections.

Columns and Composite Walls: Wrapped or Unwrapped

Use the wrapped/unwrapped icons from the Column Info Box or the Column Settings dialog box to determine 

how the columns interact with composite walls.
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Unwrapped

Unwrapped (freestanding) Columns do not modify the shape of the Wall - they cut out a place for themselves, 

breaking through all Wall skins.

The separator line between Wall skins and the Column are removed where their Building Materials match.

Wrapped

Wrapped Columns break through the core skins of straight, vertical, composite Walls. 

The other (non-core) Wall skins wrap around the Column, thus adding this thickness to the column.

• The composite Wall must have at least one skin that is core and one skin that is non-core (which will wrap 

around)

• The Column must intersect the core skin(s) of the composite Wall

Note: For composite Walls, the core skins are defined in Options > Element Attributes > Composites.

• Wrapping is not available for:

– Columns that are slanted, profiled, tapered, or multi-segmented

– Columns whose veneer is defined as “Finish” (see Veneer Structure: Core, Finish, Other)

– Columns that intersect with curved, slanted, or polygonal Walls

– Columns with an End that is angled
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3D Display of Wrapped Columns

In 3D view, Columns placed with the Wrapped Construction Method will inherit the Surface of the connecting 

Walls, even if the wall is not a composite wall, and even if there are no wall skins configured to actually wrap 

around the Columns.

Unwrapped columns retain their own surfaces in 3D.
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Related Topics:

Columns can be trimmed to Roofs or Shells.

See Trim Elements to Roof or Shell.

You can crop a Column to a Single-plane Roof.

See Crop Elements to Single-plane Roof.

Use Adjust Elements to Slabs to adjust Columns to specific levels of one or more Slabs that are located 

above and/or below them.

See Adjust Elements to Slabs.

For Columns inside a Zone: 

See Relation to Zones.
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Column Tool Settings: Preview and Positioning

The Column Settings dialog box is divided into five pages.

The Preview section remains visible on all pages, and reflects your settings modifications. 

Navigate among the pages using the tree structure on the left:

Core Width/Height

For a simple (single-segment) Column, enter the core’s horizontal and vertical dimensions. 

Note: For Columns with a rectangular cross-section, use the chain icon to constrain them to the same 

value.

For a circular column, enter a diameter.

Column height

Shows the Column’s total height. 

• For an unlinked Column, set its height here.

• For a top linked Column: this field is not editable. Column height depends on the settings in the 

Positioning panel below. 
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Column Positioning Panel

By default:

• The Column top is linked to one story up

• The Home Story is the current story.

Top Link

Use this control to do one of the following:

• Top link the Column relative to its Home Story (Home+1, Home+2, etc.)

If you later modify the positions and heights of stories in your projects, the heights of any linked Columns will 

follow automatically.

• Choose Not linked to make it a fixed-height Column. Define its height in Column height field above.

Offset from Top Linked Story

You can offset the Column top from its top linked story. 

• The offset value can be positive, negative or zero.

• The offset field is not available if the Column has no top link.

You can also offset the Column bottom from the Home Story, in either direction.

• The Column height value (seen in the Preview section of Column settings) is affected by the top and 

bottom offsets, if any. 

Home Story

See Home Story.
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Bottom Elevation [to Reference level]

Calculates the current elevation of the Column’s reference line, as measured from the Reference level (by 

default, this Reference level is Project Zero). 

Click the pop-up arrow to change the Reference level, if needed.

Note: Reference levels are defined at Options > Project Preferences > Reference Levels.

For general information on levels, see Reference Levels Preferences.

Note: This is a calculated value, not a link. If you change the Reference level, the Column will not change 

its position.

Column Slant Angle

See Create a Slanted Column.

Wrapping Method

See Columns and Composite Walls: Wrapped or Unwrapped.

Relation to Zones

See these topics:

Calculating Zone Area and Zone Volume

Relation to Zones
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Column End Cuts and Reference Axis 

End Cuts

Define the angle of the Column’s Top and Bottom surfaces: horizontal, vertical or custom. 

Note: Vertical available for slanted Beam only.

You can also edit this geometry graphically: 

– Select a Column in 3D. Click on its end surface, then choose Rotate Join Angle from the pet palette.

 

Reference Axis of Core

Choose one of the nine points to serve as the Column’s Reference Axis. 

If you modify the Reference axis: the axis stays in place while the Column moves accordingly.

Note: Available only if at least one Column segment has a rectangular or circular cross-section. Not 

available for complex profiles.
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Axis Rotation: Set a rotation angle for the Column around its axis.

See also Rotating Beam and Columns.
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Column Model Display

Use the Model Panel of Column Settings (Segment page) to override Column surface(s).

Override Surface: Click to override the surfaces assigned to this column or segment in its Building Material:

• Top and Bottom Surfaces

• Side (Extrusion) Surfaces

Note: For Columns placed with the Wrapped method, the choice you make here is overridden by the 

surfaces of the Walls that they intersect. (See 3D Display of Wrapped Columns.)

Note: For a Profile Column, you can also apply a Custom surface to any edge(s) of the profile element. 

(See Apply Custom Surface or Line to Profile Edge.)

Custom Texture Alignment: If this message is activated, it indicates that the currently selected column 

(already placed in the project) has been assigned a custom 3D texture.

• In this case, you can click Reset Texture to restore the origin of the Texture of the selected column or 

segment.

For more information, see Align 3D Texture.
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Column Display on Floor Plan and Section

Use the Floor Plan and Section page of Column Settings.

See Element Display in Floor Plan and Section.

Hidden Lines

Define Hidden Line attributes. Hidden Lines are used for Columns under Slabs if this is turned on at Model 

View Options.

See Model View Options for Construction Elements.
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Column Underneath Slab: Use Hidden Line

Floor Plan Symbol

Symbol Type: Plain, Slash, X, or Crosshair

Note: For a profiled column, only the Plain and crosshair symbols are available. The crosshair symbolizes 

the column’s axis and will revolve along with the column cross section.

Crosshair has two additional settings: Distance From Center and Length Outside Column

Although the crosshair is a graphic symbol and not part of the model, the crosshair will be resized (together 

with the column itself) if you change the drawing’s scale.

Set display (on or off) of column floor plan symbols by view at Document > Model View > Model View 

Options.

Cover Fills

See Assign a Cover Fill.

Columns with Cover Fills
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Slanted Column with Cover Fill (Orientation: 3D Distortion)
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Beams

ARCHICAD Beams are horizontal or slanted construction elements. Basic beams have a rectangular cross-

section, but you can also use a Complex Profile. 

Beams can be curved, either on a horizontal plane or vertically. Like other construction elements, a Beam’s 

essential structure derives from its Building Material, defined in Beam Tool Settings.

Place a Beam

Create a Slanted Beam

Curve a Beam Vertically

Create a Multi-Segment Beam

Define Column/Segment Structure

Rotate Join Angle

Tapered Column or Segment

Editing Beams

Create a Hole in a Beam

Selecting and Modifying Beam Holes

Beams and Other Elements

Beam Tool Settings: Preview and Positioning

Beam End Cuts

Beam Model Display

Beam Display on Floor Plan and Section

Rotating Beam and Columns

Related Topics:

Beams can be included in a Structural Analytical Model generated in ARCHICAD.

For details, see Structural Analytical Model.

For information on the Structural Analytical Parameters Panel of Beam Tool Settings:

See 1D Members (Column and Beam)
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Place a Beam

Before placing a Beam, go to Beam Settings to adjust its core geometry, height, positioning and end cuts.

See Beam Positioning Panel

To place a Beam, choose one of Geometry Methods (input methods) from the Info Box. 

Single Beam

1. Choose the Single Beam method from the Info Box. 

Note: If you are drawing a slanted beam, only the Single Beam method is available.

2. Click twice to place each end of the Beam.

3. In the 3D window:

– Snap the endpoints to existing elements

– Click Shift to constrain input to an editing plane.

Note: If the Beam already has a defined slant angle (in Settings or Info Box), the slant angle prevails, 

regardless of the constraint.

For a slanted Beam: see Create a Slanted Beam.

Chained Beam

1. Choose the Chained Beam method from the Info Box. 

2. Click in succession to place segments of a chained Beam. 

This input method is analogous to creating a chained Wall.

See Create a Chain of Walls.

In the 3D window:

– Snap the endpoints to existing elements

– Click Shift to constrain input to an editing plane.
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Rectangle/Rotated Rectangle Beam

Choose one of these methods from the Rectangle Beam icon’s pop-up:

• For a regular rectangle beam, click twice to define its two opposite corners. 

• For a rotated rectangle, click twice to define a side of the rectangle, including the rotation vector, then drag 

and click again to complete.

Horizontal Curved Beam

To create a horizontally curved Beam, do one of the following:

Curved Beam Input from Info Box

Choose one of the three curved input methods. These methods are analogous to creating a curved Wall.

See Create a Curved Wall.

Other Ways To Create Horizontal Curved Beams

• Create curved Beam segments as part of a Chained Beam.

• Select a straight Beam on the Floor Plan, then use the pet palette commands to curve it, or edit using 

tangent.

• Magic Wand: Trace the shapes of curved drawing elements with the Magic Wand.
ARCHICAD 24 Reference Guide 725



Construction Elements Elements of the Virtual Building
Watch the Video

Watch the Video

Related Topic:

Curve a Beam Vertically
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Create a Slanted Beam

Use Beam Settings, or use Beam slant graphically in the 3D window.

Set Slant Angle in Beam Settings

1. From Beam Settings (Beam page, Positioning panel) or the Info Box, choose the Slanted icon.

2. Enter a slant angle in degrees.

The value must be between -89° and +89°, and is measured from the starting point of the Beam. 

3. Choose a Placement Method from the Info Box, then place the column.

Two-Click Beam Input

1. Choose the Single Beam method from the Info Box. 

1. Click twice to place each end of the Beam.

2. In the 3D window:

– Snap the endpoints to existing elements

– Click Shift to constrain input to an editing plane.
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Note: If the Beam already has a defined slant angle (in Settings or Info Box), the slant angle prevails, 

regardless of the constraint.

An existing, vertically curved Beam can also be slanted. 
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Curve a Beam Vertically

In the 3D or Section/Elevation window:

1. Select a Beam 

2. Use the pet palette commands to curve the edge vertically, or edit using tangent.

A Beam’s vertical curve cannot curve in on itself. 

A given Beam cannot curve in both vertical and horizontal directions.

• For a straight beam: its curve height cannot be larger than the radius of the curve. 

• For a slanted beam: the arc's start and end points cannot be lower than the arc's origin

• For a vertically curved Beam, the Radial Stretch command is also available:

Alternatively, in Beam Settings or the Info Box: click the Curved icon and define the Chord/Arc Height.

• Negative value is possible
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• If the initial Beam was horizontally curved, then clicking the Curved icon will assign a vertical curve and 

eliminate the horizontal curve.

Related Topic:

Horizontal Curved Beam
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Create a Multi-Segment Beam

Set up a Beam that consists of multiple segments, with a configurable “Join” component between them.

To create Beam segments, use either the Settings dialog or graphical interactions. Both methods are 

described below.

Watch the Video

Notes:

– Each segment has its own Classifications and Properties settings and its own Element ID. However, 

Category definitions (e.g. Renovation status) are inherited from the element level.

– Find & Select, Labels, Info Box, Interactive Element Schedule fields and Dimensions/Labels can use 

segment-specific data

Watch the Video

Use Beam Settings

1. Open Beam Settings and go to the Segment page.

2. Click the Multi-Segment beam icon.

3. Click Add to add as many segments as needed. 

– A “Join” component is automatically added between each segment.

4. View the Structure list to see segments and Joins. Select or multi-select to edit.

5. View the preview. The segment currently selected in the list is highlighted.
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Multi-Segment Beam

Create Graphically

1. Select a Beam in the 3D window.

2. From the pet palette of the Beam axis, choose Split Segment.

3. Click anywhere on the Beam axis: the Beam is split at that point into segments. Repeat to create more 

segments as needed.
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• You can adjust segment length graphically by dragging the Joins:

See Rotate Join Angle.

• To edit the segments individually and graphically, you can use Edit mode.

See Edit Mode for Multi-Segment Columns.

• To define attributes for each segment, use the Settings dialog.

See Define Column/Segment Structure.

Related Topics:

Delete Column Segment or Beam Segment
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Define Beam/Segment Structure

Select a Beam or Beam segment. 

Use the Structure panel of Beam Settings (Segment page) to define its structure properties and length (fixed 

or flexible).

For a selected segment: these Settings are also available in Beam Edit mode.

Cross Section

Click an icon to define segment cross-section.

• Rectangular

• Circular

• Complex Profile
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Building Material/Profile

Use the pop-up to choose a Building Material or Profile for the Beam or Beam segment.

Note: The pop-up shows only the Profiles whose “Use With” control includes Beams. Profiles are defined 

at Options > Element Attributes > Profile Manager.

Segment Length (Fixed or Flexible)

For each selected segment: Define its length as either fixed or flexible, by clicking the corresponding icon in 

the Structure panel. 

– For fixed-length segment: Define the length. It will remain unchanged even if the Beam stretches. (You 

can also enter a selected segment’s length in the Structure list.)

– For a flexible segment: Define its length as a percentage of all the flexible segments. (The flexible 

segments together add up to 100%.) Segment length will stretch accordingly if the Beam stretches.
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Segment Length - Edit in 3D

1. Select the Beam in the 3D window.

2. Click the Join hotspot (on the Beam reference line).

3. From the pet palette, use Move Segment Join to adjust segment length

Note: If you drag the segment hotspot into the adjoining segment, this eliminates the dragged segment 

entirely. 

Flexible (yellow) segments stretch with the Beam.

Fixed (red) segment does not stretch.
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Related Topics:

Tapered Column or Segment

Rotate Join Angle

Core and Veneer

Delete Column Segment or Beam Segment
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Define Join Geometry

In Beam Settings:

For a Join component selected in the list (at the top of Beam Segment Settings): use the Segment Join panel 

(below) to define its angle as horizontal, vertical or custom. 

Note: Vertical Join available for slanted Beam only.

In 3D Window:

Joins can be edited graphically:

1. Select the Beam in the 3D window.

2. Click the Join hotspot (on the Beam reference line).

3. From the pet palette, use Rotate Join Angle to adjust the Join angle

Related Topic:

Define Beam/Segment Structure
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Tapered Beam or Segment

You can created a tapered Beam, or taper any single Beam segment. 

Use the Segment page of Beam Settings. (For a multi-segment Beam, select the segment to taper.)

1. In the Structure panel, choose Tapered geometry.

2. Use the pop-up to define the cross-section dimensions of the tapered Beam (segment) at its Start and End 

surfaces.

– Use the chain icon to make the height/width dimensions equal

– Use the arrow button to reverse the tapering direction

Related Topic:

Define Beam/Segment Structure
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Editing Beams

Stretch Length/Modify Angle

Use the Pet Palette commands at the Beam’s Reference Axis endpoint.

• Stretch length

For a slanted Beam:

• Stretch length with fixed Pitch

• Modify angle

Stretch Beam Cross-Section

For a non-curved, non-segmented Beam:

In the Floor Plan or 3D window, use the Pet Palette commands to stretch the Beam’s cross-section 

dimensions.

Note: Beams can also be stretched in Section view, if the Beam reference line is perpendicular to the 

Section line.

Alternatively, use Edit > Reshape > Stretch.
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Edit Slanted Beam on Floor Plan

1. Select the slanted Beam on the Floor Plan.

2. From the pet palette of the reference line, click the endpoint height command.

3. In the Beam End Height dialog, enter the new height of the selected Beam endpoint.

Related Topics

Stretching Curves

Watch the Video
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Create a Hole in a Beam

Holes are defined after the Beam has been placed. 

1. Select the desired Beam and make sure the Beam tool is active.

2. Click on an edge or the reference axis.

3. In the appearing pet palette, click the Hole icon. 

4. The Beam Hole Settings dialog box appears.

 

Click OK to apply the beam hole settings; the Hole will immediately appear in the Beam.

Related Topics:

Selecting and Modifying Beam Holes
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Selecting and Modifying Beam Holes

Modify Single Hole

1. Do one of the following:

• With Arrow tool active, click in the center of the hole.

• With any other tool active, Shift-click in the center of the hole.

Now the hole is selected.

2. Open Beam Selection Settings - Hole Panel to modify the selected hole’s shape and size (or use the 

controls in the Info Box).

• Shape: Rectangular or circular

• Contours on Plan: Choose floor plan symbol: show outline, or show axis only

• Size: Enter the horizontal and vertical dimensions of the Hole. For a circular hole, you will enter a 

diameter.
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• Position: Distance of the center of the Hole from the top surface of the Beam.

Modify all Holes

1. Select the Beam. All of the Beam holes are selected, too. 

2. Open Beam Selection Settings - Hole Panel to modify all Beam holes simultaneously (or use the controls 

in the Info Box).

Move Beam Hole Graphically

• Move a hole laterally along the Beam (Floor Plan or 3D)

• Move a hole up and down along the Z axis (3D)
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Holes in Curved Beams

Suppose you have placed holes into a straight beam (at the given distances from either end of the beam), and 

then you curve the beam (as in the picture below). 

The Beam Openings’ Position dialog box allows you to choose how to handle the holes’ new position in the 

curved beam:

Keep distance: The holes’ measured distances from the nearest beam end (as measured along the center 

beam arc) remain unchanged.

Keep proportion: The holes remain at the same proportional distance from the beam ends as before.

Watch the Video
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Beams and Other Elements

Auto-Intersection of Beams with Other Beams

When a Beam intersects another Beam, ARCHICAD automatically cleans crossings, T and L intersections of 

Beams if the Options > Auto Intersection feature is turned on.

If one end of the joining Beam falls within the contour of the other Beam, the end of the joining Beam will 

automatically adjust to the reference axis. Their appearance in 3D will be “cleaned up” accordingly, provided 

that the beams have the same intersection priority.

Beam intersections are also cleaned up if the crossing or joining Beams run at different elevations. If Beams 

pass each other in space, without intersecting reference lines, the intersection will be cleaned up depending 

on their respective intersection priorities.
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Cover fills of beams on floor plan

See Use Layers to Prevent Intersections.

Related Topics:

Beams can be trimmed to Roofs or Shells.

See Trim Elements to Roof or Shell.

You can crop a Beam to a Single-plane Roof.

See Crop Elements to Single-plane Roof.

Use Adjust Elements to Slabs to adjust horizontal Beams to specific levels of one or more Slabs that are 

located above and/or below them.

See Adjust Elements to Slabs.

For information on how intersections (junctions) work among construction elements:

See Element Intersections.
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Beam Tool Settings: Preview and Positioning

The Beam Settings dialog box is divided into five pages.

The Preview section remains visible on all pages, and reflects your settings modifications. For a multi-

segmented Beam, the Preview section includes its Structure settings.

Navigate among the pages using the tree structure on the left:

For a simple (single-segment) Beam, enter its geometry values: 

Beam Width/Height

• Use the chain icon to constrain them to the same value

Beam Length

• Default (segment) length
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Beam Positioning Panel

Offset to Home Story

Offset the Beam’s reference axis from the Home Story.

Home Story

See Home Story.

Reference Line Elevation [to Reference level]

Calculates the current elevation of the Beam’s reference axis, as measured from the Reference level (by 

default, this Reference level is Project Zero).

For slanted Beams, this elevation is measured from the starting point of the Beam’s reference axis. 

Click the pop-up arrow to change the Reference level, if needed.

Notes:

– Reference levels are defined at Options > Project Preferences > Reference Levels.

– This is a calculated value, not a link. If you change the Reference level, the Beam will not change its 

position.

For general information on levels, see Reference Levels Preferences.

Horizontal or Slanted

See Create a Slanted Beam.

Flat or Curved

Beam geometry in the Z-direction.

• For a vertically curved Beam, enter its Arc/Chord height.

See Curve a Beam Vertically.

Junction Order

A higher Junction Order number takes priority over the lower.
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Junction Order is relevant 

• when two Beams meet whose Building Materials have the same priority

• when 3 or more Beams meet in a junction: Junction Order determines which two Beams are joined first
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Beam End Cuts

Go to Beam Settings - End Cuts and Reference Axis Panel, or the Start/End angle controls in Beam Info Box.

Define the Start and End edges of the Beam as angle as horizontal, vertical or custom. 

Note: Horizontal available for slanted Beam only.

You can also edit this geometry graphically: 

– Select a Beam in 3D. Click on its end surface, then choose Rotate Join Angle from the pet palette.
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Beam Reference Axis

The Reference axis serves the precise connection of Beams for clean intersections, and establishes hotspots 

and edges for selecting, moving and transforming Beams. Its direction determines the beam’s “left” and “right” 

surfaces for the purpose of applying surfaces in the Model Panel of Beam Settings.

See Beam Model Display.

The direction of the reference axis follows your cursor as you drag it to draw the beam. (To see the arrow on 

the beam that indicates the axis direction, turn on View > On-Screen View Options > Walls and Beams 

Reference Lines.)

The reference axis of a selected Beam is shown in a separate color: you can change this color using the 

“Reference Lines” setting at Options > Work Environment > Selection and Element Information.

In Beam Settings or Beam Info Box, choose one of the nine points to serve as the Beam’s Reference Axis.

Note: Available only if at least one Beam segment has a rectangular or circular cross-section. Not 

available for complex profiles.

If you modify the Reference axis: the axis stays in place while the Beam moves accordingly.

Display/Hide Reference Axis

Use the Floor Plan and Section panel of Beam Settings. See Symbols.

Reference Axis Offset

Optionally, enter a value to offset the Reference Axis from the middle of Beam. 
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Axis Rotation

Set a rotation angle for the Beam around its axis.

See also Rotating Beam and Columns.
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Beam Model Display

Use the Model Panel of Beam Settings (Segment page) to override Beam surface(s).

Override Surfaces:

Each side of the Beam is listed. Click the icon of the Beam side(s) to override that surface (assigned via its 

Building Material).

• For a rectangular Beam: Override left side, right side, top, bottom, and/or the ends.

• For a circular Beam: You can override the Ends surfaces only.

Note: Left side is defined by the left hand, looking from the first point to the next point of the Reference 

Axis of the Beam.

• For a profile Beam: Override the Extrusion surface and/or the Ends surface.

Note: You can also apply a Custom surface to any edge(s) of the profile element. 

See Apply Custom Surface or Line to Profile Edge.

Click the chain icon to assign the last override surface to all the selected faces/edges. Deselecting the chain 

icon will restore the surfaces that you originally set for each face/edge. 

For more information, see Surfaces.

See also Override Surfaces With Surface Painter.

Custom Texture Alignment: If this message is activated, it indicates that the currently selected beam 

(already placed in the project) has been assigned a custom 3D texture.

• In this case, the Reset Texture button is also activated. Click to restore the origin of the Texture of the 

selected beam.

For more information, see Align 3D Texture.
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Beam Display on Floor Plan and Section

Use the Floor Plan and Section page of Beam Settings.

See Element Display in Floor Plan and Section.

Watch the Video

Projection Mode

Once you have set Floor Plan Display, use Projection Mode to fine-tune each displayed component 

(Overhead, Uncut) of the Beam: as either Symbolic or Projected.

Cut parts of the Beam always use Projected display.
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• Available options depend on the Floor Plan Display you chose above; some components may be invisible, 

and you cannot set a display mode for those.

Outlines

• Always Show Outline: Check this to display the contour of this Beam even if the Model View Option is 

set to hide Beam contours.

Hidden Lines

Define Hidden Line attributes. Hidden Lines are used for Beams under Slabs if this is turned on at Model View 

Options.

See Model View Options for Construction Elements.
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Beam Underneath Slab: Use Hidden Line

Symbols

Use these controls to define settings for the beam’s symbolic components.

• Beam End Lines: These options let you show or hide one or both end lines of the beam. (The end line is 

the contour line perpendicular to the longitudinal axis of the beam.)

• Always Hide Reference Axis: Check this to hide the Reference Axis of this Beam even if the Model View 

Option is set to show them.

• Choose a Line type and Pen color for the Beam Reference axis.

Cover Fills

See Assign a Cover Fill.
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Rotating Beam and Columns

Rotate Vector

The regular Rotate command rotates the Beam/Column element together with its extrusion vector (i.e. the 

Beam reference line or the Column axis.)

Rotate Profile

Do one of the following:

• Use the Rotate Profile (Beam) or Rotate on Axis (Column) command from the pet palette of the selected 

element in the 3D window. 

• Enter a value in the Axis Rotation field in Beam or Column Settings (End Cuts and Reference Axis panel)
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Complex Profiles

A Complex Profile element is composed of a cross-sectional profile that is extruded perpendicular to the 

profile’s plane. 

You can use or modify a predefined profile, or create a new one.

Complex Profiles are available for Walls, Columns, Beams, Railing components or Library Parts.

Note: Profiles for Library Parts are available only for GDL elements that include a profile selection option - 

such as Curtain Wall and Stair components.

Like other construction elements, a Profile’s essential structure derives from its Building Material. Various 

surface overrides are available on an element-level basis.
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For example, the following image shows two curved walls to which the “Brick Wall with Footing” profile has 

been applied. The back wall uses element-level surface overrides on the extruded surfaces and ends.

A saved Complex Profile is handled as an attribute of the element (e.g. Wall or Railing). Saved profiles appear 

in the Settings dialog box of the respective tool. 

You can apply a custom profile to any selected element in the model window on a one-time basis without 

having to save it as an attribute.
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Wall, Column and Beam profiles can have defined Edge Offset Modifiers: these edges can be adjusted 

individually at the element level, even if all the elements use the same profile.

Block Wall Profile: Offset Brick Veneer for Each Placed Element

Special pet palette commands are available to stretch and rotate profile elements.

Related Topics:

Create Complex Profile from Parallel Elements

Use Standard Steel Column or Beam Profile

Profile Manager

Create or Edit Complex Profile

Offset Modifiers
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Create Complex Profile from Parallel Elements

A quick way to create a complex profile is to use the Edit > Reshape > Merge Walls/Columns/Beams.

To use this command, draw multiple walls, columns or beams in the model window. The elements must be of 

the same type and must be parallel to each other. (In the case of curved walls or beams, they must be 

concentric.)

Executing the command will create a new profile element, which will replace the original elements. The new 

profile element will be as long as the combined length of the original elements, and will inherit the attributes of 

the original as well as any wall openings.

By default, the new profile is named “custom” but can be opened in the Profile Editor, modified and saved with 

a new name.

To merge two or more parallel Straight Walls, use the Merge Walls command (Edit > Reshape menu) on 

them. The Walls will become the same length, and the cross section of the resulting Wall will be a unity of the 

cross sections of the two Walls. The bodies of the two Walls do not need to touch, they may be at a distance 

from each other. This command does not work for Trapezoid or Polygonal Walls.

The Merge Columns command (Edit > Reshape menu) allows you to merge two or more Columns whose 

axes are parallel to each other. If this condition is met, all types of Columns (Vertical, Slanted, Custom Profile) 

may be merged. More than two Columns may be merged at the same time.

Use the Merge Beams command (Edit > Reshape menu) to merge two or more Beams (whether Horizontal, 

Slanted, or Custom Profile) whose axes are parallel to each other. (In the case of curved Beams, they must be 

concentric).
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Related Topics:

Apply Profile to Selected Element

Create or Edit Complex Profile

Profile Manager
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Use Standard Steel Column or Beam Profile

If you exchange data with structural softwares, it can be helpful to use standard elements as your profile 

Columns or Beams. During the data exchange process, those structural engineering programs will recognize 

and identify such standard elements accurately and completely, without requiring any settings adjustments.

Use the Options > Complex Profiles > Import Standard Steel Profile command.

This brings up the Standard Steel Profile Database.

Profile Database

In this image, our list of Project Profiles (the list window on the right) is empty, so we must add selected 

profiles from the database.

From the non-editable Available Profiles list on the left, you can access thousands of standard profiles. (If 

needed, sort the list columns by Name or by specific dimension.) Use the Country Code and Geometry 

controls to help find the profiles you need.

Select these, then click Add Profile to the Project.
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The selected structures now appear in the list to the right. 

• From the pop-up at the top, assign a Building Material to the structures as needed.

• Click Remove to remove a project profile from the import list.

Click Import. The selected profiles are now available for use in your ARCHICAD project.

Place Structural Profile Element

Choose the Complex geometry method in the Geometry and Positioning Panel of Column or Beam Settings.

In the Profile pop-up, choose the profile you need.
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When placing the structural Column or Beam, note that its insertion point is the center of the object’s bounding 

box. However, an additional hotspot is located at the element’s center of gravity.

These predefined steel profile Beams and Columns can be listed by name in the Interactive Schedule: just 

include “Complex Profile” or “Building Material/Composite/Profile/Fill” in the Fields panel of Interactive 

Schedule Scheme Settings.
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Profile Manager

Open the Profile Manager from:

• Options > Complex Profiles > Profile Manager

• Options > Element Attributes > Profile Manager

Use Profile Manager to edit or create Complex Profiles in the Profile Editor window, or to choose and manage 

profile elements in the model.

For the workflow, see Create or Edit Complex Profile.

This section describes the controls of Profile Manager.

Create New/Duplicate/Rename/Delete Profiles

These icons are in the Manage Profiles panel of Profile Manager.

See also Delete and Replace Attributes in a Model.

“Use With” - Define Profile Element Types

In Profile Manager, the Use with buttons, like those in other Attribute Settings dialog boxes, determine which 

ARCHICAD tools can be used to place the current profile.

Click Edit, then click on the Use With tool icons:

Note: Profile “Use With” definition is also available in Attribute Manager: See Profiles (Attribute Manager).
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Design Layers Panel

Use this panel to show or hide elements in the Profile Editor window.

This panel is active only if the Profile Editor is open.

Construction

Show/hide Fill or Hotspot elements in the Profile Editor window. These will be saved and used as part of the 

profile.

Drafting

Show/hide elements drawn with any other drafting tool (e.g. Lines, Arcs, Polylines).

These will be saved as part of the profile attribute, but they will not be visible in the placed profile.

Stretch Modifiers

Show/hide Stretch Modifiers in Profile Editor window.

See Stretch Modifiers.
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Nominal Width/Height

Show/hide the dimensions indicating the profile’s Nominal Width and Height, in the Profile Editor window.

The Nominal Width/Height - a listable element parameter - will be displayed in the placed element’s Settings 

dialog. The values are editable if Width and/or Height Stretches are enabled in the Modifiers panel.

See Nominal Width/Height.

In contrast, the Total Width/Height also includes element-level adjustments via Offset Modifiers, and reflects 

the overall bounding box size of the element. The Total Size is not editable in the element’s Settings dialog, 

due to the constraints of Offset Modifiers.

Nominal Width and Height dimensions can be repositioned by clicking and dragging on their dimension lines. 

Their lengths can be modified and aligned to another part of the profile - including outside of the Profile 

bounding box, by clicking on the ends of the nominal dimensions. If the lengths are not modified, their lengths 

will automatically resize to follow the bounding box of the Fills as defined in the Profile Editor.

Nominal Dimension ends, like Offset Modifiers, can be associated to Fill nodes, but this may cause an over-

constraint. In this case, a warning will appear.

Offset Modifiers

Show/hide the dimensions and assigned edge/node highlights of Offset Modifiers.
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Even if this is set to “hide”, an Offset Modifier currently selected in the Modifiers list will always be shown.

See Offset Modifiers.

Opening Reference

• Check this box to display lines representing the reference line at which doors/windows will be placed, 

once you place the profile wall on the plan.

• Click the eye icon to show/hide the Opening Reference lines in the Profile Editor window. 

• If necessary, edit, extend or break the lines to conform to the shape of the profile, so that openings will be 

placed and oriented in the correct location. 

If you do not switch on Opening Reference, doors/windows will be placed along the profile element’s 

bounding box.

Modifiers Panel

See:

Stretch Modifiers

Offset Modifiers
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Components Panel

Select a Fill component in the Profile Editor window.

Use the Components Panel of Profile Manager to edit the following parameters:

Component Type

Define the selected component as either Core, Finish or Other. This definition will affect the Partial Structure 

Display of the complex element.

See details at Partial Structure Display.

Override Surfaces

Check Override Surfaces to choose a new surface from the pop-up. Otherwise, the selected component will 

use the surface defined in the Fill’s Building Material. 

If you override an individual Fill edge with a custom surface in Profile Editor, this will be reflected as “Various” 

in this panel.

Show Cut End Lines

Check this to display Cut End Lines.

Define Line Type and pen of the selected Profile Fill component. This line type and pen are used for end lines 

when the element is cut.

List Component Area by

Choose either Base Line or Base Circle to define how ARCHICAD should calculate surface area for this 

component, in an Interactive Schedule of Components.

To view and edit the Base Line or Base Circle in Profile Editor, make sure you have turned on View > On-

Screen View Options > Component Area Base Line/Circle.

For more information, see Component Listing Parameters in the Interactive Schedule.
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Uniform Contours Panel

Apply uniform lines and pen colors to cut lines and to all separator lines at once. (This panel is active only if 

the Profile Editor window is open.)

These settings will be applied to the placed profile, and reflect any changes made by Offset Modifiers.

Click Save, then view the feedback in the Preview window of Profile Manager.

Contours: Choose a uniform line type and pen color for all contour lines (outer lines) of the profile element.

Separators: Choose a uniform line type and pen color for all of the separator cut lines (inner lines) of the 

profile element.

Notes:

– Lines that separate two fills having the same Building Material will not be eliminated.

– Edges customized to Off (Show Cut Line is Off; see below) will not apply uniform contour settings.

See also Apply Custom Surface or Line to Profile Edge.
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Create or Edit Complex Profile

To create or edit a Complex Profile, you will use the Profile Editor window - a separate 2D editing window 

which opens automatically whenever you open a Profile to edit, or when you create a new one.

It is always open in conjunction with the Profile Manager palette, which contains controls specific to the Profile 

Editor environment.

For a New Profile

1. Open Profile Manager (Options > Element Attributes > Complex Profiles)

2. Click the New command. 

3. Name the new Profile.

The Profile Editor window opens, where you can start creating the Profile element.

See Create/Edit Profile Components, below.
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To Edit a Profile

Do one of the following:

• From Profile Manager, choose a Profile from the pop-up:

Notice the icon that indicates whether the selected profile contains a core component, or not. (In this 

image, the icon indicates “No Core.”) See also Partial Structure Display.
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• From the model window, select an existing Complex Profile Element, then click Edit Selected 

Composite/Profile from the context menu. 

The selected Profile opens in the Profile Editor.
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Open Profile Editor (From Model Window)

If you switch out of Profile Editor to a model window, the Profile Manager remains open, but its editing controls 

are not available. To open Profile Editor again, choose a Profile from the pop-up and click Edit.

Create/Edit Profile Components

Use the Fill tool to draw or edit the cross-section of the complex profile, with the usual 2D techniques, to 

achieve the desired shape.

In Profile Editor, only 2D drawing tools are available.

Use Fill Selection Settings to assign Building Material and Cut Line type.

Notes:

– Your cross-sectional profile can contain multiple fill shapes (components); they will all be saved 

together as a single profile. 

– Overlapping fills are supported, and will be cut out based on their Building Material Priority at the 

placed element level. 

– Profile attribute definition is also available in Attribute Manager: See Profiles (Attribute Manager).

– The Profile Origin is a significant reference point. See Profile Origin in Profile Editor Window.
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• Only Hotspots, and Fills drawn with the Fill tool, will be part of the saved profile. 

• Other 2D elements added to the Profile Editor window (lines, dimensioning, etc.) can be used as local 

drafting aids, but will have no effect on the final appearance of the complex profile. These drafting aids are 

located on the “Drafting” Design Layer of Profile Manager. 

See Design Layers Panel.

Use the other controls of Profile Manager to edit the Profile geometry and behavior:

Components Panel

Uniform Contours Panel

Stretch Modifiers

Offset Modifiers

Save Named Profile

Do one of the following:

• Click the Save button in the Profile Manager, or

• Switch to another profile and choose “Save” from the appearing dialogue.

See also Save Custom Profile.
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Apply Profile to Selected Element

1. Select one or more Wall, Column or Beam element(s) in the active model window.

2. In Profile Manager, select from the Choose Profile pop-up.

3. Click Apply.
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Capture Selected Element for New Profile

To create a new profile using the shape of selected elements (Walls, Columns or Beams) in the active model 

window:

Select the element, then do one of the following:

• Click Capture button in Profile Manager

• Options > Complex Profiles > Capture Profile of Selection

The new profile is called “Custom”.

Save Custom Profile

After editing a captured Custom profile in the Profile Editor window, make sure you click Save Profile to save 

your edits and name the new Profile, before closing the window. 

Alternatively, click Apply to apply a one-off custom to a selected Wall, Beam or Column.

Note: Custom profiles are not directly assigned to elements from the Profile Manager, but locally stored in 

the element.
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Apply Custom Surface or Line to Profile Edge

By default, all sides of a Profile element use the surface defined in the Fill’s Building Material.

However, you can apply a different surface or line type to any edge of any Profile component.

1. Select a profile component fill in the Profile Editor window.

2. Choose the Custom Edge Settings pet palette icon.

3. Edit the controls in the appearing Custom Edge Settings dialog box. 

To switch off the contour line of the selected edge, uncheck Show Cut Line.

These custom edge settings will be applied to the edge from which you opened the Pet Palette (Clicked 

Edge), or to all edges. If needed, you can apply a different custom edge surface/contour line to each individual 

edge.
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If you are using a custom line type or pen for any edge(s) of the profile, the Fill Selection Settings will indicate 

this with a custom icon:
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Profile Origin in Profile Editor Window

The Origin shown in the Profile Editor window is a significant reference point.

You cannot move the Profile Origin, but you can move the profile shape itself, so that it correctly positioned 

with respect to the origin.

Wall Profile

• If the profile is a Wall, the origin represents the location of the Wall’s reference line. 

Column or Beam Profile

• For a Column or Beam, the origin represents the location of the element’s axis.

• In case of profiled Beams used in a Stair structure: for correct connections, make sure that the Profile 

Origin is defined at the top of the profile. (Alternatively, choose a top location for the Anchor Point).

See also Beam Anchor Point.

Curtain Wall Components

This applies if the Profile is set to be “used with” Library Parts, and if the Library Parts for Curtain Wall 

components are set up to use Profiles (as in the AC 24 Library).

• If the profile is a Curtain Wall Frame, the origin is located on the inside of the glazed surface. The 

downward direction in the profile represents the inside direction of the Frame. Generally, the Profile Origin 

will be located at the upper midpoint of the profile.

• If the profile is a Curtain Wall Corner Frame, the origin is located on the inside of the glazed surfaces at 

their intersection. 

• If the profile is a Curtain Wall Frame Cap, the origin is located on the inside of the glazed surfaces at 

their intersection.

Frame Corner Frame
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• If the profile is a Curtain Wall Corner Cap, the origin is located on the outside of the glazed surface. The 

upward direction in the profile represents the outside direction of the Frame.

See also Curtain Wall Corner Frames.

Frame Cap Corner Cap
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Stretch Modifiers

These controls are in Profile Manager (Options > Element Attributes).

In the Modifiers Panel, switch on Width Stretch and/or Height Stretch. This enables you to resize (increase or 

decrease the width/height) of the cross-section of the placed profile element.

• To show/hide Stretch lines in Profile Editor, use the Stretch Modifiers control in the Design Layers panel. In 

this image, they are highlighted in yellow.

• The Stretch Modifiers mark the boundaries of the geometry that will stretch or contract. 

– For a Wall, its height or thickness

– for a Beam, its height or width

– for a Column, its cross-section height or width
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When you graphically stretch the placed element in either direction, the Stretch Modifiers appear in the model 

window as feedback. 

Stretch Feedback on Stretched Part of Placed Profile

The element’s Settings reflect the stretch in its Height/Width parameter values (hover to see the Nominal and 

Total values):

See also Nominal Width/Height.

Note: Stretch Modifiers only support profiled Walls, Beams and Columns.
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Offset Modifiers

These controls are in Profile Manager (Options > Element Attributes).

Offset Modifiers are optional controls added to a Profile, used to offset or control individual or multiple edges 

at the element instance level. 

For each Profile, Offset Modifiers (if any) are listed in the Modifiers panel.

They are shown in Profile Editor if their visibility is switched on in the Design Layers panel.

Profile Editor: Element with Offset Modifier

• A single profile can be manipulated and edited at the element instance level, decreasing the need to 

create and manage multiple similar Profiles

• Manipulate the profile numerically via its settings dialog, or graphically in Floor Plan, Section and 3D

• Parametric modifiers and their values can be labeled, scheduled and used in Expression-type properties

Note: Offset Modifiers only support profiled Walls, Beams and Columns.

Related Topics

Create New Offset Modifier

Edit Offset Modifier

Offset Modifiers: Tips and Tricks
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Create New Offset Modifier

Related Topics

Edit Offset Modifier

Offset Modifiers: Tips and Tricks

Create Offset Modifiers to allow a placed Profiled element instance to be customized and modified locally.

A Profile can include multiple Offset Modifiers, and one Offset Modifier can include one or multiple dimensions 

(of the same length). Also, a single dimension can control multiple edges.

The following examples illustrate these features.

In this example, create a profile called Concrete Slab Edge Footing. You will add a modifier called “Base 

Width” to certain edges of this profile: after you place the element, you can graphically modify the Base Width 

edge.

1. In Profile Editor, draw the cross-section using the Fill Tool.

The Nominal Height and Nominal Width is shown. (The Nominal Width/Height display is turned on in 

the Design Layers panel.)

The Stretch Modifiers are also shown. (The Stretch Modifiers display is turned on in the Design Layers 

panel.) By default, the Stretch Modifiers coincide with the Nominal Height/Width dimensions.

Now, create an Offset Modifier called Base Width on particular profile edges.

2. In the Modifiers panel, click New Modifier.

3. In the New Profile Modifier dialog, give it a name: Base Width. 

Or choose an existing name from the popup list, if this parameter has already been defined in another 

Profile in the same project.
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The newly created modifier appears in the Modifiers list. The initial warning triangle indicates that this modifier 

has no definition yet.

4. In the Profile Editor window, you are in dimension input mode. (If you are not in dimension input mode, 

click the Add Offset Dimension button in the Modifier panel as shown here.) 

You have several options for defining the Dimension and anchoring it:

• Edge with Node Anchor

• Two Edges to Two Nodes (Anchored by Automatic End Nodes)

• Node and Node (with Neighboring Edge)

During input, available edges that can be offset are shown in black; when hovering, they will be shown with 

blue highlight.
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Edge with Static Node Anchor

1. Click the edge to be offset. 

2. Now drag the cursor: the modifier’s parameter name appears, and you are dragging its dimension line. 

3. Click a Fill node (this is the anchor), then drag the resulting dimension line and click again to place it. 

The result: You created an edge offset parameter that can be offset in the given direction, anchored from the 

clicked node.

The dimension end is a circle, indicating that its anchor is a node (rather than a static point).

Modifier: Offset Single Edge, Anchored to Fill Node

The anchor is associated to the Fill node, so if the profile’s Fill geometry changes, the anchor point (and 

thereby the modifier) will follow these changes.
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Edge with Static Anchor

Alternatively, click anywhere in the Profile Editor to create a static point anchor (here, to the profile origin). 

Then drag the resulting dimension line and click again to place it. 

The dimension end is a square, indicating that its anchor is a static point (rather than a node).

Two Edges to Two Nodes

Click the edge to be offset, then click a second edge. As you move the cursor, the dimension automatically 

finds the nearest end nodes to anchor to. 

Then drag the resulting dimension line and click again to place it. 

The result: You created an offset parameter with two edges. Modifying this parameter modifies both edges.
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Modifier Offsets Two Opposite Edges

The two clicked edges do not have to be parallel.
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Node and Node with Neighboring Edge

Use this method to create a Modifier whose anchoring Dimension is not necessarily perpendicular to the 

offset edge.

Click two nodes representing the Dimension.

Then click the edge to be offset. The edge need not be perpendicular to the Dimension, but it must be 

adjacent to one of the clicked nodes.

The result: The edge is offset perpendicularly, but is measured from the Dimension you specified.
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Edit Offset Modifier

Topics in this section

Edit Dimension Ends

Add/Remove Edges to One Offset Dimension

Add Dimensions to One Offset Modifier

Two Connected Modifiers

Remove Edges or Entire Dimension

Delete Modifier

Rename Modifier

Related Topic

Create New Offset Modifier

Offset Modifiers: Tips and Tricks

Edit Dimension Ends

1. In the Modifiers list of Profile Manager, click the offset Modifier to activate it; or click a grey Offset 

Dimension to activate and select it.

2. Hover over the Dimension and see the feedback on its anchor node/edge.

3. Click the Dimension end you want to redefine.

4. Move to another node or edge and click to reassign the Dimension anchor.
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Add/Remove Edges to One Offset Dimension

You can link multiple edges to a single Dimension. All edges will move together, at the same time.

In this example, the existing Modifier is called “Top”. 

1. In the Profile Editor window, hover over the Dimension or an assigned edge of the Top modifier to see the 

grip.

2. Click the appearing grip: Add/Remove Edge.

3. As you move the cursor, the eligible edges (initially shown in black) are highlighted in blue. Click to choose 

an edge. 

4. A second click defines its direction.
ARCHICAD 24 Reference Guide 794



Construction Elements Elements of the Virtual Building
5. The second edge is added to the existing Dimension.

Add Dimensions to One Offset Modifier

You can add multiple dimensions to the same Offset Modifier. Every subsequent dimension will have the 

same length. This allows different edges in the same Modifier to have dedicated anchors - in the case where 

those anchors are moved by other Modifiers.

1. In Profile Manager, select the existing Modifier (Top).

2. Click the Add Dimension icon.
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3. As you move the cursor, the eligible edges and anchor nodes are highlighted in blue. Click to choose an 

edge, then anchor the dimension in the usual way. Its dimension length is the same as the existing one 

defined in the Modifier (set by the first dimension).

4. The resulting single Modifier controls two, separately anchored edges.
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Two Connected Modifiers

In this example, the “Top” Offset Dimension on the left side is anchored to an edge which itself is another 

Modifier (Base). Note that the right-side “Top” dimension has its own anchor.

If an anchor moves, so will the dimension which it anchors. In this case, if the Base is offset, the left-side Top 

dimension (anchored to the Base) also moves.

The right-side Top edge, however, remains in place: its anchor was not moved.

Remove Edges or Entire Dimension

1. In Profile Manager, activate the Modifier you want to edit; or click a grey Offset Dimension to activate and 

select it

2. In the Profile Editor window, hover over the edge or dimension.
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3. Click the appearing grip: Add/Remove Edge.

4. Hover over the edge so that it turns red: click to delete.

The edge is deleted.

If you hover over the last edge or dimension, the entire dimension and edge will be highlighted in red. When 

all dimensions in a modifier are deleted, that Modifier gets a warning notice in Profile Manager. 
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If needed, click Add Offset Dimension to create a new Dimension and assigned edge for that Modifier.

Delete Modifier

1. In Profile Manager, select the Modifier to be deleted.

2. Click Delete.

All Offset Dimensions and assigned edges in that Modifier will be deleted.

Rename Modifier

In the Modifier list, double-click its name to edit in place.
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Offset Modifiers: Tips and Tricks

When creating or editing Offset Modifiers, it’s worth keeping the following situations in mind.

Curved edges of Fills cannot be used in Offset Modifiers.

Only straight segments are supported.

Non-horizontal and non-vertical Fill edges that cross Stretch Modifier lines cannot be 

used in Offset Modifiers.

This is because Stretch Modifiers break these edges to allow stretching/compression to 

occur between Stretch lines.

In an Offset Modifier, two parallel Offset edges that face the same direction can prevent 

the Offset from working.

A warning will appear when Storing the Profile. The Profile is saved, but this Modifier 

can’t be used until the issue is resolved.

To resolve it, try flipping the direction of one of the edges.

Two Offset Modifiers connected to each other will cause an over-constraint, preventing 

either Offset from moving.

A warning will appear when Storing the Profile. The Profile is saved, but this Modifier 

can’t be used until the issue is resolved.

To resolve it, try moving one Offset Modifier anchor to another point.

Offset Modifiers do not affect or modify the Nominal Size of a profiled element.

The Total Size is calculated from the entire bounding box of a profiled element, including 

Offset Modifiers.

Modifying a profiled element’s size (such as height, width or thickness) affects both 

Nominal Size and Stretch Modifiers.

Offset Modifier values won’t be affected, to maintain their constraint and distance to 

anchor point.

An Offset Modifier that is adjacent to another edge will create a new edge when offset. 

This newly created edge will take its properties from the Fill as defined in the Profile 

Editor.

Offset Modifiers can remove geometry, such as if you set a thickness to zero. This is 

supported and valid.

However, if the entire element will disappear as a result, the action will be invalid, and the 

value will be reverted – to avoid a profiled element with no geometry.
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Offset Modifiers can cause geometry to flip, such as if you set a negative value. This is 

supported and valid.

Overlapping Fills in the Profile Editor are supported.

The geometry will be regularized at the element level based on the Building Material 

Intersection Priority of each Fill.
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Roofs

ARCHICAD’s flexible Roofs can be used to create both standard and abstract 3D shapes meeting a wide 

variety of needs.

What’s Covered:

About Roofs

Create a Single-plane Roof on the Floor Plan

Create a Single-plane Roof in the 3D Window

Create a Multi-plane Roof

Examples of Multi-plane Roofs

Editing Roofs

Crop Elements to Single-plane Roof

Create Special Roof Objects with RoofMaker

Trim Elements to Roof or Shell

Roof Tool Settings

Related Topics:

Single-plane Roofs can be included in a Structural Analytical Model generated in ARCHICAD.

For details, see Structural Analytical Model.
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About Roofs

Choose either the Single-plane or Multi-plane construction method to create a Roof element. 

Like other construction elements, a Roof’s essential structure derives from its Building Material, defined in 

Roof Tool Settings.

The Multi-plane Roof is a single element despite its multiple planes. When you edit one of the planes, the 

rest of the planes are automatically adjusted to the new geometry. You can edit each plane separately, 

changing its pitch or surface as needed. A Multi-plane Roof can have more than one level, yet such a Roof 

always remains a single element in ARCHICAD even after you edit its components.

A Multi-plane Roof can be split up into Single-plane Roofs: select the Multi-plane Roof and use the Edit > 

Reshape > Split into Single-plane Roofs command or Design > Roof Extras > Split into Single-plane 

Roofs.

Connecting Roofs to Other Elements

For information on how intersections (junctions) work among construction elements, including Roofs:

See Element Intersections and Merge Elements: Roofs, Shells, Morphs.

Roofs in ARCHICAD (along with Shells) can serve as trimming elements: the Connect commands enable you 

to use Roofs to trim other construction elements, and then remain connected to those elements even if you 

edit them later.

The Connect commands let you trim several separate Roof elements to each other, combining them into a 

more complex structure.

See Trim Elements to Roof or Shell.

Pivot Line

The roof’s elevation is measured by the elevation of the pivot line or pivot polygon, a horizontal non-printing 

line that you draw when creating the roof. A Roof’s pivot line or pivot polygon can be edited to graphically 

change Roof geometry, which is especially powerful with Multi-plane Roofs.

In the 3D window, pivot lines are shown with a specific color to make editing easier. You can change this color 

(“Reference lines in 3D”) in Options > Work Environment > Selection and Element Information.

In most cases, you will want the pivot line of the roof to coincide with a Wall Reference Line or a Slab edge.

Note: You can hide all pivot lines on the Floor Plan, by disabling the Roof Pivot Lines option in View > On-

Screen View Options.

The Pivot Line elevation is shown in the roof’s info box.

This is the same value as the Roof’s Pivot Line Offset to Home Story, in Roof Settings.
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Roof Pitch

The Roof Pitch is measured from the pivot line.

The Roof Pitch value is also shown in the Info Box.

See also Modify the Roof Pitch.

Display of Roofs on Floor Plan

Use Roof Settings to define the parameters of your roof.

Use the Floor Plan Cut Plane, combined with element projection preferences, to determine which parts of the 

placed roof should be displayed.

See Floor Plan Cut Plane (Global Setting).

For Roofs, the default Floor Plan Display option is “Projected with Overhead”.

For more information on Floor Plan display of roofs, see Element Display in Floor Plan and Section.

In ARCHICAD 15 and later, all Roofs are displayed on the Floor Plan as a true 3D projection, showing all 

visible contours - including, for example, the edge of the hole in a pitched roof plane, as shown below.

If you prefer to display Single-plane Roofs as they were in ARCHICAD 14 and earlier - that is, in Symbolic 

mode with their top surface only - you can switch this as a Project Preference: go to Options > Project 

Preferences > Legacy, and choose “Symbolic” as your preferred display mode. This affects Single-plane 

Roofs plus any Skylights they contain.

Gravitate New Elements onto a Roof

Use the Gravity control to place Wall, Column, Beam and Object type elements relative to the elevation of a 

Roof.

See Gravity.

All Visible Contours Top Surface Only
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Create a Composite Roof

You can apply or customize a composite structure for a Roof.

For more information, see Composite Structures and Assign a Composite Structure to a Wall, Slab, Roof or 

Shell.

(Remember that the model’s Partial Structure Display settings will affect the display of composite Roofs.)

See Partial Structure Display.

You can edit a selected composite by accessing its settings from its context menu:

If the structure of the Roof is a composite, then the Roof’s thickness is defined in Options > Element 

Attributes > Composites, and equals the sum of the skins’ thicknesses.

For a composite Roof, the “top” surface is the first listed skin of the composite, in Composite Settings.
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Create a Single-plane Roof on the Floor Plan

Note: Apart from drawing a new Roof as described below, you can also select a Multi-plane Roof and split 

it into several Single-plane Roofs, using Edit > Reshape > Split into Single-plane Roofs or Design > 

Roof Extras > Split into Single-plane Roofs.

1. Select the Roof Tool. 

2. In Roof Settings or the Info Box, adjust the main roof parameters (e.g. pitch, surfaces).

3. Choose the Single-plane construction method from the Info Box or from Roof Settings.

4. Choose one of the three geometry methods in the Info Box (Polygon, Rectangle, Rotated Rectangle)

5. On the Floor Plan, click twice to define the Roof’s pivot line.

In most cases, you will want the pivot line of the roof to coincide with a wall Reference Line or a slab edge.

6. The eyeball cursor appears. Click on the side of the pivot line where you want the roof plane to rise (or, in 

the case of a negative roof pitch, slope downward).

7. Draw the contour of the roof by clicking on each of the new roof’s nodes. Or use the Magic Wand: click on 

an existing element to serve as the pattern for the roof’s contour.

See also Magic Wand.
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Create a Single-plane Roof in the 3D Window

Note: Apart from drawing a new Roof as described below, you can also select a Multi-plane Roof and split 

it into several Single-plane Roofs, using Edit > Reshape > Split into Single-plane Roofs or Design > 

Roof Extras > Split into Single-plane Roofs.

Use this method if you want to place a roof that snaps to existing elements in the 3D window.

1. Select the Roof Tool.

2. In Roof Settings or the Info Box, adjust the main roof parameters (e.g. pitch, surfaces, eaves overhang) 

3. Choose the Single-plane Construction method from the Info Box.

4. Choose one of the three Geometry Methods in the Info Box (Polygon, Rectangle, or Rotated Rectangle).

5. In the 3D window, define the roof plane by clicking on three points. The first two points constitute the pivot 

line.
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6. Draw the contour of the roof. The Hammer cursor appears when you return to the first node. Click to close 

the polygon.
ARCHICAD 24 Reference Guide 809



Construction Elements Elements of the Virtual Building
7. ARCHICAD will generate the Roof.
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Create a Multi-plane Roof

On the Floor Plan or 3D Window:

1. Select the Roof Tool.

2. In Roof Settings or the Info Box, adjust the main roof parameters (e.g. pitch, surfaces, eaves overhang).

3. Choose the Multi-plane method from the Info Box or from Roof Settings.

4. Choose one of the construction Methods from the Info Box: 

• Complex

• Hip

• Gable

• Rotated Hip

• Rotated Gable

5. Start drawing the pivot polygon of the Multi-plane roof - usually, along the outline of your building structure.

6. Close the polygon to complete the Multi-plane roof.
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7. Alternatively, use the Magic Wand (space+click) on an existing Wall to instantly place the pivot polygon 

and the resulting Multi-plane roof.

The result is a single roof element, consisting of multiple planes. You can further edit the roof plane by plane 

(for example, assign a custom surface or pitch to any plane), but the roof always remains a single element.

See Customize Roof Plane.

Even after the roof is created, you can easily change the roof geometry by graphically editing the pivot 

polygon or the roof ridge.

See Graphical Editing of Roof Geometry.

You can divide a Multi-plane Roof structure into multiple horizontal levels or segments, e.g. to make a 

mansard Roof.

See Add Roof Level.
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Examples of Multi-plane Roofs

The following sections show you how to create the following roof types, step by step:

Hip Roof

Complex Roof

Gable Roof

Pyramidal Roof

Mansard Roof

Gablet Roof

Gambrel Roof

Add a Tower to the Roof

Cross-Gable Roof
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Watch the Video
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Hip Roof

1. Draw the Floor Plan outline of your building (i.e. external walls).

2. Activate the Roof Tool, and use the Multi-plane Construction method and the Hip geometry method.

3. In Roof Settings, adjust the main roof parameters (e.g. pitch, eaves overhang) 

4. Click twice to place the rectangle-shaped pivot line of the Roof, or use the Magic Wand (Space+click) on 

the edge of the Wall outline to quickly create a Multi-plane roof.

5. The created Roof is a single, Multi-plane roof element.
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Complex Roof

1. Draw the Floor Plan outline of your building (i.e. external walls).

2. Activate the Roof Tool, and use the Multi-plane construction method and the Complex geometry method.

3. In Roof Settings, adjust the main roof parameters (e.g. pitch, eaves overhang) 

4. Trace the outline the building; or use the Magic Wand (Space+click) on the edge of the Wall outline to 

quickly create a Multi-plane roof.

5. The created roof is a single, Multi-plane roof element.
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Gable Roof

1. Draw the Floor Plan outline of your building (i.e. external walls).

2. Activate the Roof Tool, and use the Multi-plane construction method and the rectangular Gable geometry 

method (this is found in the pop-up next to the Hip geometry method).

3. In Roof Settings, adjust the main roof parameters (e.g. pitch, eaves overhang) 

4. Click twice to place the rectangle-shaped pivot line of the Roof.

5. The created Gable roof is a single, Multi-plane roof element.

Watch the Video

Change a Roof Plane into a Gable

In the 3D window: 

1. Select the Multi-plane roof.

2. Find the pivot line on the roof plane that you want to change into a gable.

3. Click to bring up the Pet Palette, and choose the Custom Plane Settings option.
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4. In the appearing dialog box, choose Gable to define the selected plane as a gable.

Another method:

1. In the 3D window, select the endpoint of the roof ridge.

2. From the Pet Palette, use the Stretch Horizontal Ridge option to drag the ridge endpoint until the plane 

on that end becomes vertical. (The cursor will snap to the vertical position to make this easy.) 
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Pyramidal Roof

Try two ways of making a pyramid roof:

• On the Floor Plan, use the Roof Tool - Multi-plane construction method, with the Rectangular Hip 

geometry method, to draw a square roof outline.

• Another way is to select the ridge of an ordinary hip roof in the 3D Window. Use the “Stretch Ridge 

vertically” command from the pet palette, and move the cursor up until the ridge endpoints meet in the 

middle.
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Mansard Roof

To create a Mansard Roof, you want a Multi-plane Roof that has two different levels to accommodate two 

different pitches.

1. Begin with a regular Hip Roof.

2. Select the Roof.

3. In the Multi-plane Geometry panel of Roof Settings, click Add to add a new Roof level.

4. Adjust the pitches of each level. In this example, the first, steeper level is 60 degrees. The top, flatter level 

is 30 degrees.
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5. Adjust the elevation of Level 1 so that it ends (and Level 2 begins) at 2000 mm.

6. In the Model panel of Roof Settings, adjust the surfaces as desired.

7. Change any other Roof Settings as needed. In our example, we have set the eaves overhang offset to 0.

8. Click OK to close Roof Settings. The Mansard Roof is complete.

As needed, define custom attributes for the individual planes of the mansard roof by changing the parameters 

in the Custom Plane Settings, available from the pet palette during editing.

See Customize Roof Plane.

For example, you can gable a roof plane at each end of the upper Roof level to create a Gablet roof.

See Gablet Roof.

You can further edit the geometry of Roof levels.

See Edit Roof Levels.
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Gablet Roof

1. Begin with a regular hip roof.

To see how to make a hip roof, see Hip Roof.

2. Make this roof into a two-level roof: open Roof Settings and go to the Multi-plane Geometry tab page.

• Click Add to add a second level.

• Enter the elevation at which the first level ends (and the second level begins). The pitch can be the same 

for both levels.

Click OK to close Roof Settings.

3. View the two-level Roof in 3D. Since the pitch is uniform for both levels, you must select it to see where 

the second level begins.
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4. Gable each end of the second level.

See Change a Roof Plane into a Gable.

5. View the final Roof.
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Gambrel Roof

The Gambrel Roof is like the Mansard, except that it is gabled at both ends.

1. Begin with a Gable Roof.

2. Select the Roof.

3. In the Multi-plane Geometry panel of Roof Settings, click Add to add a new Roof level.

4. Adjust the pitches of each level. The first, steeper level should be 50 degrees. The top, flatter level should 

be 25 degrees.
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5. Adjust the elevation of Level 1 so that it ends (and Level 2 begins) at 1500 mm.

6. In the Model panel of Roof Settings, adjust the surfaces as desired.

7. Click OK to close Roof Settings. The Gambrel Roof is complete. The additional roof level is indicated by a 

dotted line on the Floor Plan.
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Cross-Gable Roof

Create this by trimming two separate gable roofs to each other.

1. Start by creating two roofs gabled at each end, and placed atop each other, like this:

To see how to make a gable roof, see Gable Roof.

You can adjust the pivot line elevations of each roof as needed to achieve the correct geometry.

2. Before doing the trim, make the trimming bodies visible at View > On-Screen View Options > Trimming 

Bodies. This shows you how the roofs will cut each other.

3. Select both roofs. From the context menu, choose Connect, then Trim Elements to Roof/Shell.
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4. Since you want both selected Roofs to do the trimming, leave the option as-is in the appearing dialog box 

and click Trim.

5. View the result. We see that some bits have been left out of the trim.

The reason is that the trimming body for both Roofs is the part inside of the pivot line and going downward: 

this is defined in the Model panel of the Roof Settings dialog box:

For this reason, any parts of the trimmed Roofs that fall outside of that trimming body are not trimmed.
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6. To fix this, just change the trimming body definition of both Roofs to “Contours Down.” See how the 

trimming geometry changes.

You do not have to re-do the Trim command; the trimming relationship is updated automatically.

See also Trim Multiple Selected Elements: Automatic Trim.
ARCHICAD 24 Reference Guide 828



Construction Elements Elements of the Virtual Building
Editing Roofs

The following sections describe specific roof-related editing techniques.

Graphical Editing of Roof Geometry 

Modify the Roof Pitch

Add Roof Level

Edit Eaves or Gable Overhang

Edit Roof Contour

Edit Roof Ridge

Customize Roof Plane

Customize Edge of Roof or Roof Hole

Create a Hole in a Roof

Create an Atrium

Add a Tower to the Roof

Create Roof Level Lines

Intersect Single-plane Roofs
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Graphical Editing of Roof Geometry

To graphically edit the geometry of a selected Roof, edit any of the following:

• the pivot line

• a ridge line

• the Roof level dividing line, if your Roof has several levels

• the Contour line

To edit the pivot line, use the familiar polygon editing commands in the pet palette:

As you can see in 3D, editing the pivot line adjusts the geometry of the roof plane and of the adjoining planes 

as needed:
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Below, we have added an extrusion to the roof using the Add to Polygon editing command of the pet palette. 

The resulting roof geometry is modified, with each roof plane adjusted as needed, and the roof remains a 

coherent single element.

Watch the Video

Related Topics

Edit Roof Ridge

Edit Roof Levels

Skylight Constraint Relative to Roof
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Modify the Roof Pitch

For a Single-plane Roof:

Once you’ve drawn a roof and selected it, you can modify its pitch in any one of the following ways:

• Change the roof pitch in the Info Box or in Roof Settings.

• In the 3D window, select the roof, click on any point that is not on the pivot line, then select the Change 

Roof Pitch command from the pet palette and graphically adjust the roof angle (or enter a Pitch value into 

the Tracker.) The roof will rotate around the pivot line.

• In the Floor Plan or 3D Window, select the roof, then Ctrl+click (Mac: Cmd+Click) at any point on the 

roof plane to bring up the Roof Elevations dialog box. Enter a numerical value in the top field: this value 

will be the elevation value of the roof plane at the point at which you clicked it. Altering this elevation value 

has the same effect as modifying the roof pitch.
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For a Multi-plane Roof:

Modify the roof pitch in one of the following ways:

• Change the roof pitch in the Info Box or in Roof Settings.

• Use the Custom Plane Settings dialog box to set a custom pitch for any selected plane.

See Customize Roof Plane.

• Use the Pet Palette editing commands (e.g. Elevate Horizontal Ridge) to alter the geometry of the 

selected plane(s), including the Pitch.
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Add Roof Level

You may wish to add additional levels to your Multi-plane Roof: for example, in creating a mansard roof, you 

want two roof levels, each with a different pitch.

1. Select the Roof.

2. In the Multi-plane Geometry panel of Roof Settings, or from the Info Box, click Add to add a new Roof 

level.

3. Adjust the pitches of each level.

4. Adjust the elevation of any roof level. For example, the elevation value for Level 1 indicates the elevation 

at which Level 1 ends (and Level 2 begins).

For examples, see Mansard Roof and Gambrel Roof.
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Edit Roof Levels

For a multi-level Roof, select the line indicating the Roof level, then use pet palette commands to edit the 

vertical position or geometry of the Roof level.

Edit Level Height

Drag Level Horizontally

Choose the Drag Level Horizontally command from the pet palette to move the level horizontally.

If you drag the level all the way to the edge of the Roof, that edge is gabled:
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Edit Eaves or Gable Overhang

The offset of the eaves (or the gable) from the pivot line can be set:

• For the selected Roof as a whole in Roof Settings:

• For any single panel of a Multi-plane Roof:

Click on the pivot line of the panel whose eaves overhang you wish to customize. Use the Customize Roof 

Plane dialog box to enter an offset for that roof panel only:

If the selected Roof plane is gabled, the control is called Gable Overhang Offset.
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Notice that the value in the Eaves Overhang control in Roof Settings has not changed - it still reflects the 

overhang value set for the roof as a whole. However, the yellow patch indicates that at least one roof panel 

now has a different, customized overhang value.

If you change the shape of the Roof contour by editing it manually, the Eaves overhang control changes to 

“Manual”.

See Edit Roof Contour.
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Edit Roof Contour

The Roof contour may be edited graphically. Select the contour line in Floor Plan or 3D and use the available 

pet palette commands.

Editing the contour (as opposed to editing the pivot line - does not change the overall geometry of the roof, 

just the shape of the roof’s edge.

See Graphical Editing of Roof Geometry.
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Edit Roof Ridge

You can modify the roof geometry of a Multi-plane roof by grabbing the ridge line at either endpoint or 

anywhere along the ridge line.

The pet palette offers three ways to edit the roof:

Stretch Horizontal Ridge

This option has a built-in “snap” when you get to the vertical point. If you click then, you will end up with a 

gabled roof plane.

Elevate Horizontal Ridge
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Drag Horizontal Ridge

Watch the Video
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Customize Roof Plane

For a Multi-plane Roof, you can customize any of its planes so that its surfaces, eaves overhang, and pitch 

are different from the Roof Settings in effect for the roof as a whole.

To open the Custom Plane Settings dialog box:

1. Select the Roof.

2. Click the pivot line of the roof plane which you want to customize.

3. From the pet palette, choose Custom Plane Settings:

Here, set one or more of the following custom settings: 

• Pitch 

• Eaves overhang

• Top or Bottom Surface (available for plane of Pitched Roof only)

Note: To apply a custom Edge Surface, use Custom Edge Settings. 

See Customize Edge of Roof or Roof Hole.

• Cover Fill
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Apply Changes

Apply changes to: Choose to apply the custom settings to:

• Clicked Plane (this is the default)

• Clicked Level (all planes of the current Roof Level; this is meaningful only if you have a multi-level roof.)

See Add Roof Level.

• All Planes

Custom Values in Roof Settings

In Roof Settings, the values shown for roof pitch, eaves overhang, surface and/or curve resolution will not 

change, because they reflect the settings of the roof as a whole.

However, a yellow patch appears next to those controls for which at least one roof panel or edge has a 

different, customized setting.

If you later change the one of these values in Roof Settings while the dialog box is still open, the yellow patch 

(indicating “custom plane”) gets a red shadow. This means that a Roof plane setting is going to change: do 

you want to apply this change to your customized plane too? If so, check the box at the bottom of Roof 

Settings (Apply changes to custom planes/edges too). If you do not check the box, your custom planes 

remains the way you set them.

Watch the Video
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Customize Edge of Roof or Roof Hole

You can customize the surface and/or angle of any edge of a Roof, or the edge of a hole in a Roof. Once you 

set the customized surface/angle options, you can choose to apply them to the clicked edge only, to all edges 

of the clicked polygon (hole), or to all roof edges.

1. Select the Roof.

2. Click on the Roof’s contour line (not the pivot line!) to bring up a pet palette.

3. Select the Custom Edge Settings icon to open the dialog box.

Watch the Video

Custom Roof Edge Angle

Angle: Choose an angle (vertical, horizontal, perpendicular, custom) for the roof edge. If you choose custom, 

enter the desired angle value in the field at right.

Note: You can set a horizontal edge angle only if the selected edge is parallel to the pivot line, on a roof 

that is not flat.

Note: If you have clicked an edge that is the common joint of two selected single-plane roofs, an 

additional, “Mitered” option is available. Choose this to create a mitered joint along the selected roof 

edges.
ARCHICAD 24 Reference Guide 843

https://youtu.be/QZddrgtEIJA


Construction Elements Elements of the Virtual Building
If you apply an edge angle here that is different from the default roof edge angle (set in Roof Settings), the 

Geometry and Positioning Panel of Roof Settings will indicate that a custom edge angle has been applied.

If you later change the Edge angle setting in Roof Settings while the dialog box is still open, the yellow patch 

(indicating “custom edge”) gets a red shadow. This means that the Roof’s edge angle is going to change: do 

you want to apply this change to the custom-angle edges too? If so, check the box at the bottom of Roof 

Settings (Apply changes to custom planes/edges too). If you do not check the box, your custom edge angles 

remain the way you set them.

Custom Roof Edge Surface

Note: By default, the Surface material applied to a Roof edge derives from the Building Material assigned 

to the Roof. You can override all edge surfaces of the Roof, using the controls in the Model Panel of Roof 

Settings. The Custom Edge Settings offers a further way to customize the surface of any one or more 

Roof Edges.

Surface: Click the Surface override button, then choose a custom surface for the roof edge(s). 

If you apply a surface here to any edge that is different from the edge surface defined in the Model Panel of 

Roof Settings (or Building Material), the Model Panel will indicate (with a yellow patch) that a custom edge 

surface has been applied.
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If you override the Roof edge surface in Roof Settings while the dialog box is still open, the yellow patch 

(indicating “custom edge”) gets a red shadow: this means that the Roof’s general edge setting is going to 

change: do you want to apply this override to all edges, including the custom edge(s) too?

If so, check the box at the bottom of Roof Settings (Apply changes to custom planes/edges too). If you do 

not check the box, your custom edge surfaces remain the way you set them.

Custom Roof Edge Type

Edge Type: Optionally, choose a type for the roof edge.

The Roof Edge type you define here can be used as a parameter in all of ARCHICAD’s listing functions. For 

example, you can add “Eaves Length” and “Gables Length” as parameters of an Interactive Schedule that 

lists roofs.

For an explanation of edge types, see Roof Listing Parameters.

Apply Changes

Apply Changes to: Once you have set the options as needed, choose the edges to which to apply these 

changes:

• Clicked Edge will apply the options you choose below (angle, surface, edge type) only to the edge you 

clicked when bringing up the pet palette.

• Selected Polygon will apply the chosen options to the edges of the roof only or the edges of the hole 

only, depending on which one is selected.

• All Edges will apply the chosen options to all edges of the roof as well as all edges of its holes.

Click OK to apply changes.
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Create a Hole in a Roof

There are two ways to create a hole in a Roof.

Method 1

1. Select the Roof in the Floor Plan or the 3D window.

2. From the contour polygon (not the pivot polygon!), bring up the pet palette and choose the Subtract from 

Polygon command.

3. Draw the hole in the Roof.

4. View the result in 3D.

Method 2

1. Select a Roof.

2. With the Roof tool active, draw a new contour within its boundaries. The new contour will be interpreted as 

a hole in the Roof.

Note: If you create a hole whose outline intersects the host Roof’s contour or the outline of other holes in 

the same polygon, ARCHICAD will display a warning message, but the outline of the hole will still be 

created.

Watch the Video
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Create an Atrium

To create an atrium in a Multi-plane roof:

1. Select the Roof in the Floor Plan or the 3D window.

2. From the pivot polygon (not the contour polygon!), bring up the pet palette and choose the Subtract from 

Polygon command.

3. Draw the atrium shape in the Roof.

4. View the result in 3D.

Watch the Video
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Add a Tower to the Roof

1. Begin with a regular hip roof.

2. In the Floor Plan or 3D, select the pivot line on the plane where you want to add the tower.

3. Chamfer the polygon to create an additional roof plane.

4. In this new plane, again select the pivot line and use polygon editing to add a curve to the edge and create 

a tower shape.

The number of divisions in all the arced planes of your Roof are distributed either by arc or by circle, as set in 

the curve resolution control of Roof Tool Settings (Multi-plane Roof panel).

See Curve resolution.

You can customize this arc resolution method for any specific arced plane (such as the tower), using the 

Customize Plane dialog box.

See Customize Roof Plane.
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For example, you can specify that the tower consist of six divisions: choose By arc, then enter 6.

This way, if the geometry of the surrounding roof planes changes, the arced planes of your tower still remain 

divided into six.
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Create Roof Level Lines

Use this command (Design > Roof Extras > Create Roof Level Lines) to place a Line on a selected Roof at 

the height value you specify.

After you place the Roof Level Line, you can place a Level Dimension there to indicate the elevation.

Note: Roof Level Lines can be placed on both single-plane and multi-plane roofs. However, with multi-

plane roofs, make sure you are not using legacy intersection mode. (Go to Options > Project Preferences 

> Legacy, and make sure that the “Use Legacy Intersection methods” checkbox is not active.)

1. On the Floor Plan, select a Roof.

2. Use Design > Roof Extras > Create Roof Level Lines,

3. Set preferences in the appearing dialog box, then click OK.

– On Top/On Bottom: Choose whether you want to measure the height value to the top or to the 

bottom surface of the roof.

– Specify Roof Level Lines height level: Use either input field - the current story level or Project Zero 

- to define the height of the desired roof level lines.

– Omit Lines Outside Roofs: Check this box to omit level lines that fall outside the floor plan polygon of 

the roof they belong.

If the checkbox is disabled, all resulting lines will be drawn. In this case, lines that fall outside the roof 

polygon will be drawn to be of equal length to the pivot line of the roof they belong to.

– Group with Roof: Check this box to group level lines with the roofs they belong to.

Note: This option is grayed if the Suspend Groups toggle is active.

See also Level Dimensions.
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Intersect Single-plane Roofs

You may need to adjust Single-plane roof panes to each other.

To have these two roof planes intersect:

Select one of the Roofs on the Floor Plan, and Ctrl-click (Windows) or Cmd-click (Mac) the ridge line of the 

other.

Now select the other roof plane and Ctrl-click (Windows) or Cmd-click (Mac) the ridge line of the lower one.
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The two faces have been adjusted to each other.

See also Cropping with a Remote Roof.
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Crop Elements to Single-plane Roof

To adjust other elements to a single-plane roof, you can use the crop function, described in the following 

sections:

Using the Crop to Single-plane Roof Function

Undo Roof Crop

Effect of Roof Crop on Wall/Column Height Settings

Use Roof Crop to Create Complex-Shaped Walls, Beams and Columns

Cropping Slabs with a Roof

Cropping with a Remote Roof

Using the Crop to Single-plane Roof Function

To crop an element to a Single-plane roof, use the Design > Roof Extras > Crop to Single-plane Roof 

command.

The Crop to Single-plane Roof function is not associative. Crop to Roof, available for Single-plane roofs 

only, creates a changed Wall geometry which is static.

To create associative trims between Roofs and other elements, see Trim Elements to Roof or Shell.

Roofs can crop either the top or the bottom of 

• Walls

• Beams

• Columns

• Slabs

• Library Parts (Doors, Windows, Objects)

Note: A similar function is the Crop Zone command, which crops Zone volume using surrounding 

elements, including single-plane Roofs.

See Crop Zone to Another Element.

Elements are cropped only if they intersect a Single-plane roof at any point, and only if you check its element 

type in the Crop to Single-plane Roof dialog box.

It is usually easiest to use Crop to Roof in the 3D window, where you can see the spatial relationships of roofs 

to other construction elements.

The Crop to Single-plane Roof command is available only if at least one roof or one element of the above 

types is selected.

To crop elements to a roof, follow these steps:

1. Do one of the following:

• Select the elements you wish to crop. (Remember, only elements which intersect a roof at any point can 

be cropped); or

• Select the roof(s) to which you want to crop elements; or

• Select both elements and roof(s).

Selection of roofs and/or elements narrows the scope of the crop:

• If you select only a roof, all eligible elements are cropped

• If you select only elements, they will be cropped to all the eligible roofs.
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2. Go to Design > Roof Extras > Crop to Single-plane Roof to bring up the Crop to Single-plane Roof 

dialog box.

3. Check the element type(s) you want to crop. (If you have already selected certain elements before 

bringing up the dialog box, these checkboxes are grayed.)

4. Click the preferred cropping option, depending on which part of the eligible element(s) you want to crop: 

• Crop Element Top: Crop the part of the element(s) above the roof

• Crop Element Base: Crop the part below the roof.

5. Click Crop and view the result.

The crop remains in effect even if you hide the Roof or the cropped elements, move them away from each 

other or even delete the Roof that is executing the crop.
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If you crop a Wall with a roof that crosses the Wall entirely, the original Wall will be cut into two: one Wall that 

is cut by the cropping Roof, and a second wall that is separate and uncut.

Undo Roof Crop

Cropping an element can either be temporary, for visual display only, or definitive.

You can restore elements after a temporary crop-to-roof. If an element has been cropped to a Roof, the Undo 

All Crops command becomes active:

• in the selected element’s context menu, and

• at Design > Roof Extras

Exception: A crop on a Slab can only be undone through the regular ARCHICAD Undo function (Edit > 

Undo).

Effect of Roof Crop on Wall/Column Height Settings

By default, cropping a Wall or Column to a Roof does not alter the cropped element’s height. As seen in this 

image, the cropped Wall’s selection dots are still where they used to be before the crop.
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If you want to recalculate the cropped element’s height to reflect the cropped geometry, then click the 

checkbox:

Set Wall/Column Top to highest Point at the bottom of the Crop to Single-plane Roof dialog box.

(If you chose Crop Element Base, the checkbox refers to the Wall/Column’s base elevation (lowest point)).

If the box is checked, the height of a cropped wall or column is recalculated to equal the maximum of its 

cropped height (if you cropped the top) or the minimum cropped base height (if you cropped the bottom).

In this crop, the checkbox is checked. This means that the Wall’s actual height (as shown by the selection 

dots) has changed to the highest point of the cropped Wall.
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The Undo All Crops command will have a different effect depending on the checkbox status: 

• If you set the Crop operation to recalculate the Wall/Column’s height value (if the checkbox was active), 

then the Undo All Crops will only recreate the Wall/Column up to the maximum cropped height, as shown 

in this image:

• If you did not check the box, then Undo All Crops will recreate the original Wall height.

Use Roof Crop to Create Complex-Shaped Walls, Beams and Columns 

You can cut complex shapes into walls, beams and columns by cropping them to Roofs. The wall will always 

follow the shape of the roof(s) above them, no matter how many roof segments you have.

Cropping Slabs with a Roof

Slabs can also be cropped by the lower or upper slope of roofs with the help of the Design > Roof Extras > 

Crop to Single-plane Roof command.

While other elements can be partly cropped, slabs are always cut along the whole section line of the roof and 

the slab. Moreover, the cropped edge of the slab is always vertical even after being cropped by a slanted roof.

You can, however, manually adjust the slab edge angle.

See Set Custom Slab Edge Angle and Edge Surface.
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Cropping with a Remote Roof

You can use remote roofs, and even roofs on other stories whose outline is shown on the given story, to crop 

elements to the plane of that particular roof. In this case, the Crop to Single-plane roof command does not 

work (it only works if the elements intersect each other.) However, you can use a keyboard shortcut when 

cropping with a remote roof.

1. Make sure the Roof tool is selected.

2. Select the elements you intend to cut, then Ctrl-click (Cmd-click) an edge or a node of the roof you want 

to cut them with. The reverse procedure will also work: select the roof you want to cut with and Ctrl-click 

(Cmd-click) the individual elements you want to be cut.

Note: The Wall/Beam/Column is cut whether it is under a Roof or not. Be sure to set a sufficient height for 

the original rectangular Walls/Beams/Columns so that they are cut correctly.

See also Intersect Single-plane Roofs.
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Create Special Roof Objects with RoofMaker

RoofMaker allows you to add GDL Object-based elements to specific parts of your design in order to enhance 

them in 3D views and Section/Elevation/IE windows. RoofMaker can be accessed from the Design > Roof 

Extras menu. Technically, RoofMaker is an ARCHICAD Add-On and is loaded with ARCHICAD on startup.

After placement, roof construction elements behave like ordinary Objects and can be modified.

The Roof Wizard is a RoofMaker function that allows you to create entire roof constructions quickly and easily.

For more information, see Using the Roof Wizard.

We recommend that you begin modeling the roof construction with the purlins and continue with the hip 

rafters/valley rafters before placing the rafters. This way you can easily keep track of all the connecting 

elements. (When placing ridges, you already know the thickness of the purlin; when placing rafters you 

already know the thickness of purlins, hip and valley rafters, etc.)

To place rafters, ridges or purlins (beams), select a roof surface or Multi-plane roof.

If single-plane roofs are grouped, you must first ungroup them (Edit > Grouping > Ungroup), or Suspend 

Groups (Edit > Grouping > Suspend Groups). You will then be able to select roof surfaces individually.

Although the placement of roof construction elements using RoofMaker works using other methods, we 

strongly recommend setting the reference line of the roof to the upper exterior edge of the wall beneath (as 

handled by ARCHICAD’s Complex Roof Placement Method). The definition of elements, with or without 

overhang, uses this reference line as a basis.

We recommend setting the roof thickness equal to the general cross-section height of the rafters. This way, 

you can use the roof to cut elements that are standing upon the rafters (e.g., Posts).

To place a trimmer (blocking), a collar beam or a tie beam, two corresponding rafters must be selected 

(opposite rafters for a collar beam or a tie beam, and rafters in the same roof surface for a trimmer).

After choosing the command for the placement of an object, a dialog box opens in which certain parameters 

concerning the object itself can be set. Surfaces and a layer can be assigned to all elements. The current 

pencolor set for the Object is used by default. If you change the current pencolor, all the subsequently placed 

elements will have the new color.

The object is then placed with one or more clicks, or is placed automatically, depending on the object type.

To display the RoofMaker commands in a separate floating toolbox, choose Design > Roof Extras > 

RoofMaker > Show RoofMaker Toolbox.
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Each command is described in the sections below:

Create a rafter

Create multiple rafters

Create hip or valley rafter

Create a trimmer

Create a purlin

Create an eaves purlin

Create collar beams

Create tie beams

Using the Roof Wizard

Create a rafter

When creating rafters, the bottom plane of the roof serves as a reference plane. Rafters will be automatically 

placed on top of it.

Select a reference roof surface on the floor plan. Choose Create a rafter from the Design > Roof Extras > 

RoofMaker menu (or select the first icon from the RoofMaker toolbox).

Use the appearing Rafter Settings dialog box to set parameters.

See Rafter Settings Dialog Box.

Clicking OK returns you to the floor plan with the reference roof surface still selected. Click inside the selected 

roof surface. (If you click outside, an error message appears.)

A rafter is placed with its axis going through the specified point. By definition, rafters are perpendicular to the 

reference line of the roof.

After the rafter is placed, you can select it and open its Object Settings dialog box. Among others, the 

parameters include profile and profile thickness. The rafter may have a rectangular (default) profile as well as 

I-beam, L-beam or C-beam profiles.

Create multiple rafters

Select a reference roof surface on the floor plan. Choose Create multiple rafters from the Design > Roof 

Extras > RoofMaker menu (or select the second icon from the RoofMaker toolbox.

Set the desired parameters. You will set the same controls as for a single rafter, but the placement controls for 

multiple rafters are also active.

See Multiple Rafters Dialog Box.

Clicking OK returns you to the floor plan with the reference roof surface still selected. Click twice inside the 

selected roof surface to define a placement line. (If you click outside, an error message appears.)
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Several rafters are placed along the placement line, with the axis of the first rafter going through the point 

defined with the first click, and the axis of the last rafter going through the point defined with the second click. 

By definition, rafters are perpendicular to the reference line of the roof.

Create hip or valley rafter

The hip rafter usually lies between two neighboring roof polygons. Select the roof surface where the hip rafter 

connects to a purlin instead of another hip rafter; other methods may cause errors.

Choose Create a hip rafter or valley rafter from the Design > Roof Extras > RoofMaker menu (or click the 

third icon of the RoofMaker toolbox).

See Hip or Valley Rafter Settings.

After adjusting those settings, click OK to return to the floor plan with the reference roof surface still selected. 

Click along one of the edges of the selected roof that is NOT parallel or perpendicular to the reference line.

A Hip or a Valley Rafter (or a Valley Rafter without Overhang) is placed along the specified edge of the roof, 

depending on the position of the edge to the roof’s reference line.

Hip and Valley Rafters can also be placed with two roof surfaces selected previously. It is then not necessary 

to click afterwards to specify an edge; the object will be placed along the common edge of the two surfaces. 

The difference between the two methods lies in the shape of the resulting objects; the top cut in the latter 

method makes the object suitable for steeple type roofs.

Create a trimmer

In order to place a trimmer, you must first select the two rafters the trimmer is going to be placed between. The 

two rafters have to be within the same roof polygon. (This also means that they have the same pitch angle 

and they are both perpendicular to the reference line of the roof.)

Choose Create a Trimmer from the Design > Roof Extras > RoofMaker menu. The Trimmer Settings dialog 

box appears.

For more information, see Create a Trimmer (or Blocking).

A trimmer is placed at the same height as the rafters. It can be vertical or rotated to a position perpendicular to 

the pitch angle of the roof. The 2D symbol also shows the current position.

Clicking OK, you return to the floor plan with the two rafters still selected. Click between the rafters. (If you 

click outside them, an error message will appear.)

A trimmer is placed between the two rafters, the axis going through the specified point. Trimmers are always 

parallel to the reference line of the roof and thus perpendicular to the rafters.

Create a purlin

Select a reference roof surface on the floor plan and choose Create a Purlin from the Design > Roof Extras 

> RoofMaker menu (or click the fifth icon from the RoofMaker toolbox). The Purlin Settings dialog box 

appears in which purlin parameters can be set.

For more information, see Create a Purlin (or Beam).

By default, the purlin is placed under the reference plane defined by the roof, since a purlin generally supports 

the rafters from below. However, an elevation value can be set for the purlin so that it can be higher or lower 

than the reference plane. Set the values for the width and the height of the cross-section.

The purlin can also be perpendicular to the rafters and be on the top of them as well. If the purlin is placed on 

top, the cross section height of the rafters has to be set.
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Clicking OK returns you to the floor plan with the reference roof surface still selected. Click either an edge of 

the selected roof, or inside the roof polygon. (Clicking outside the polygon produces an error message.)

If you click on an edge, a purlin is placed with its axis along the edge. If the edge is not parallel to the 

reference line of the roof, the endpoints of the axis of the purlin will be at different heights - as indicated in the 

“Height difference” parameter of the library part - and the purlin will be inclined.

If you click inside the polygon, the axis of the beam will pass through the clicked point parallel to the reference 

line of the roof.

Create an eaves purlin

Select a reference roof surface on the floor plan and choose Create an eaves purlin from the Design > Roof 

Extras > RoofMaker menu (or click the sixth icon in the RoofMaker toolbox). The Eaves Purlin Settings 

dialog box appears in which eaves purlin parameters can be set.

For more information, see Create an Eaves Purlin (or Plate Beam).

This type of purlin is placed under the reference plane defined by the roof, supporting the rafters from below. 

However, an elevation value can be set for the eaves purlin so that it can be higher or lower than the 

reference plane. You can also set the values for the width and the height of the cross section.

Clicking OK returns you to the floor plan, with the reference roof surface still selected. You need to click either 

one of the edges of the selected roof, or inside the roof polygon. (If you click outside the polygon, an error 

message appears.)

If you click on an edge, the purlin is placed inside the polygon, with its side along the edge. If the edge is not 

parallel to the reference line of the roof, the two endpoints of the axis of the purlin will be at different heights, 

as indicated in the “Height difference” parameter of the library part, and the purlin will be inclined.

If you click inside the polygon, the axis of the purlin will pass through the clicked point, parallel to the reference 

line of the roof surface.

By default, a background fill is assigned to the 2D symbol of purlins because purlins usually have to cover 

posts placed underneath. These posts are generally displayed as a larger circle to indicate that there is some 

kind of supporting structure. You can use the Bring to Front and Send to Back commands to ensure the 

accurate positioning of elements.

Create collar beams

In order to place a collar beam you must first select two rafters to place it between. The axes of the two rafters 

must be along the same line and meet at the top, otherwise you will get an error message.

Choose Create a collar beam from the Design > Roof Extras > RoofMaker menu (or the seventh icon in the 

RoofMaker toolbox). The Collar Beam Settings dialog box appears in which different parameters of the collar 

beam can be set.

For more information, see Create Collar Beams.

A collar beam can be double- or single-sided. Set its cross-section dimensions and elevation, calculated 

either from Project Zero or the current story elevation.

Clicking OK returns you to the floor plan with the two rafters still selected. If a double-sided collar beam has 

been selected, it is placed automatically in the appropriate position. If a single-sided collar beam is selected, 

click once more to determine on which side of the rafters the collar beam will be placed.
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Create tie beams

In order to place a tie beam, you must first select two rafters to place it between. The axes of the two rafters 

must be along the same line and meet at the top, otherwise you will get an error message.

Choose Create a tie beam from the Design > Roof Extras > RoofMaker menu (or eighth icon in RoofMaker 

Toolbox). The Tie Beam Settings dialog box appears in which different parameters of the tie beam can be set.

For more information, see Create Tie Beams.

In addition to the dimensions of the cross section, an elevation value must be set, calculated either from 

Project Zero or the current story elevation.

Clicking OK returns you to the floor plan with the two rafters still selected. The tie beam is placed 

automatically in the appropriate position.

Using the Roof Wizard

The Roof Wizard allows you to create entire roof constructions quickly and easily. You can place rafters, 

purlins, trimmers, collar or tie beams in one step.

To begin, select all the roof surfaces in the project that you wish to add structural elements to. Choose the 

Roof Wizard command from the Design > Roof Extras > RoofMaker menu (or the last icon in the 

RoofMaker Toolbox).

See Roof Wizard Dialog Box.

Clicking OK returns you to the floor plan. The roof construction elements you have specified are placed 

automatically in the appropriate position.
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The placement of the rafters is optimized to meet the specified requirements. The objects now behave as 

ordinary Objects and can be modified as such.
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Trim Elements to Roof or Shell

The Trim to Roof/Shell command allows you to connect Roofs or Shells with each other or with other model 

elements in any ARCHICAD model window. The result is a more complex structure whose elements are 

trimmed precisely to each other, although they remain separate elements. 

Elements trimmed to each other using this command will also be merged, and will intersect based on their 

skins intersection priorities.

See also Basic Intersection Principles.

The trimming element is always either a Roof or a Shell. A Roof or Shell can trim any model element (e.g. 

Wall, Beam, Column).

Roofs and Shells trimmed to each other act as a single body when trimming other model elements.

Elements trimmed to each other are associative: a change to any element will immediately affect all the 

connected elements. For example, if you change the Roof pitch, the Wall that it trims will change accordingly.

Note: In contrast, the Crop to Single-plane Roof function (known as Trim to Roof in earlier ARCHICAD 

versions), is not associative. Crop to Roof, available for Single-plane roofs only, creates a changed Wall 

geometry which is static.

For more information, see Crop Elements to Single-plane Roof.

Once you have created a trimming relationship, the elements involved are connected. If you want to change 

this relationship, you don’t have to undo the connection; just do the Trim operation over again.

What’s Covered

Define Trimming Bodies

Trim Multiple Selected Elements: Automatic Trim

Trim Elements to Roof: Manual Trim

Merge Trimming Elements

Managing Element Connections

Trim Elements Using Scissors
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Define Trimming Bodies

The trimming element is always either a Roof or a Shell. The Roof/Shell has a “trimming body” attached, 

which represents the direction and shape in which it will execute the trim on the other element(s).

Since a Roof/Shell shape is often quite complex in itself, it may be difficult to visualize exactly what will 

happen when you embark on a Trim operation. To see these trimming bodies while you work (in the 3D 

window only), turn on Trimming Bodies in the View > On-Screen View Options menu.

Note that all the trimming bodies (except the “editable” one for Shells), in fact represent bodies that are 

extended infinitely upward or downward (this is not shown in the feedback).

By default, the Roof’s trimming body is “Pivot lines down”, that is, the pivot line is the boundary of the trimming 

body, and the body extends downward from there.

For a Shell, the default body is defined as “downward extrusion” from the Shell membrane.

However, you can change the geometry of this trimming body in Roof or Shell Settings: use the “Trimming 

bodies” control in the Model panel of Shell (Roof) Settings.
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The trimming body options are illustrated here for both Roofs and Shells:

Pivot Lines down - Contours down

Downward extrusion - Upward extrusion - Editable

Editable Trimming Body (Shell)

For a Shell whose trimming body is set to “Editable”, the selected Shell will show a line connecting the two 

ends of the Shell profile. (This line represents the limit of the trimming body.) This line is editable, allowing you 

to change the shape of the trimming body.
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Note: If you created a profile that is a closed polygon, you cannot edit this bottom line.
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Trim Multiple Selected Elements: Automatic Trim

Use the automatic Trim workflow if you want to trim selected multiple elements to each other using the default 

trimming logic, without any special requests for which pieces should remain and which to eliminate, and 

without specifying which Roof or Shell should do the trimming job.

For a more specific workflow in special situations, see: Trim Elements to Roof: Manual Trim.

For the regular element trimming command, see: Trim Elements Using Scissors.
The default trimming logic works as follows:

1. You select multiple elements which include one or more Roofs or Shells.

2. Select the Design > Connect > Trim Elements to Roof/Shell command (or use context menu).

3. From the Trim Elements dialog box, choose the default Use Roofs/Shells from current selection and 

click Trim.

4. ARCHICAD will automatically use all Roofs and Shells in the selection to trim each other, and other 

selected model elements, as follows:

• Roofs and Shells trim each other so that any element parts that fall inside of the other’s trimming body are 

eliminated. That is, the outside parts remain; what falls inside is cut out (The intersection priority among 

trimmed Roofs and Shells is determined by their respective Building Materials.)

• The trimming bodies of the involved Roofs and Shells are merged into a single trimming body.

• This single trimming body proceeds to cut the non-Roof and non-Shell model elements (e.g. Walls) such 

that what falls outside the Roof/Shell structure is eliminated.

This process is carried out automatically and immediately without any further input from you.
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See the following descriptions:

Automatic Trim: Example 1

Automatic Trim: Example 2
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Automatic Trim: Example 1

Suppose we have the two intersecting Shells shown here and wish to trim them to each other.

Before you start, you can turn on the trimming bodies if you want to see them while you work. (View > On-

Screen View Options > Trimming Bodies)

1. Select both Shells.

2. From the context menu, go to Connect and view the available commands.

3. Choose Trim Elements to Roof/Shell.

4. In the appearing dialog box, click Trim.
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5. View the result in 3D. The internal parts of both elements that coincided with each other’s trimming body 

have been eliminated. Note that the trimming bodies of the two Shells have been merged into a single 

trimming body.
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Automatic Trim: Example 2

Suppose you have the following Shells and Walls:

1. Select all the elements shown (Roof, Shell, Walls).

2. From the context menu, go to Connect and choose Trim Elements to Roof/Shell.

3. In the appearing dialog box, click Trim.

4. View the result in 3D:

For another example of an automatic trim, see Cross-Gable Roof.
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Trim Elements to Roof: Manual Trim

Use the manual Trim workflow if you want to trim one or more model elements to a specific Roof or Shell while 

deciding which parts (e.g. inside or outside) of the trimmed elements should remain.

For the automatic trim logic, to trim several selected elements automatically in one step, see: Trim Multiple 

Selected Elements: Automatic Trim.

For the regular element trimming command, see: Trim Elements Using Scissors.

Manual Trim: Example

Suppose you have two intersecting Shells as shown. (A V-shaped Shell and a tunnel-shaped Shell running 

through it.) You wish to trim them so that

• only that part of the tunnel-shaped Shell that is inside the V-shell should remain; and

• the outside parts of the tunnel should be chopped off; and

• the V-shaped Shell should be cut to make holes for the tunnel

The automatic trimming logic will not suffice; you would end up with the inside part missing, which is not what 

you want:

See Trim Multiple Selected Elements: Automatic Trim.

Instead, use the following trimming workflow:

1. Select the Shell you want to trim (the tunnel).

2. From the context menu, choose Connect > Trim Elements to Roof/Shell.

3. Now you must select the trimming element.

Note that the cursor has changed to a little roof. Use it to click the element to use as the trimming element 

(here, the V-shaped shell, with red feedback).
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Note: If Trimming Bodies are not on, they will appear here automatically for the duration of the trimming 

operation.
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• Now you must select the part of the tunnel that you want to retain. Move the cursor over the parts of the 

tunnel (inside and outside of the V-shell) and see how the blue feedback identifies them: this indicates the 

options for which parts of the tunnel can be retained after the trim:

4. You want to retain the part that is inside, so click on that part. The trim is executed.

Note: Alternatively, Ctrl-click one of the parts to eliminate it. The feedback will always show in blue the 

part that will be retained.

Now you must trim the other element, the V-shaped Shell, to cut holes for the tunnel. Repeat the trimming 

process:

1. Select the Shell you want to trim (the V-shell).

2. From the context menu, choose Connect > Trim Elements to Roof/Shell.

3. Now, with the little roof cursor, you must choose the trimming element: in this case, the tunnel. It will now 

be shown with red feedback.

4. Now select the part of the V-shell that you want to retain. Move the cursor and see how the blue feedback 

identifies the options for which parts can be retained after the trim:
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5. Click on the part of the V-Shell to be retained. The trim is executed.
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Merge Trimming Elements

Suppose you start with the following two-Shell design, and then run a Wall through it.

You want to trim the Wall in such a way that it does not extend above either Shell. Yet the Shells themselves 

should remain intact.

The solution is to combine the trimming bodies of the two Shells, without trimming the Shells themselves. 

Then you will use the combined trimming bodies to trim the Wall in one step.

1. Select both Shells.

2. From the context menu, choose Connect > Merge Elements (or Design > Connect > Merge Elements).

You have merged the Shells’ trimming bodies, without trimming off any parts of the Shells themselves.

Now, using this merged but intact Shell complex as the trimming element, you can do the automatic trimming 

procedure on the Wall:

1. Select the Wall and the Shells together.

2. From the context menu, choose Connect > Trim Elements to Roof/Shell.

3. In the appearing dialog box, click Trim.
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4. View the result in 3D.
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Merge Elements: Roofs, Shells, Morphs

Use the Connect > Merge Elements command to enable priority-based intersections among any number of 

Roof/Shell/Morphs and other elements. (At least one of the merged elements must be a Roof, Morph or 

Shell.)

Note: Alternatively, you can use Roofs and Shells to trim other elements (not just merge them): this is 

another way to enable priority-based connections for Roofs/Shells, as well as physically trimming the 

target element. 

See Trim Elements to Roof or Shell.

Merge Elements: Example

1. Suppose you have two colliding construction elements: a Morph and a composite Slab.

2. Select the Morph.
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3. Use Design > Connect > Merge Elements. You are prompted to choose the element you want to merge 

it with.

4. Click on the target element. The two elements are now merged, with their priority-based skin intersections 

correct.

Note: You can also select both elements before using Design > Connect > Merge Elements. In this 

case, you don’t have to specify any more elements, and the merge occurs in one step.

For general information on how intersections (junctions) work among construction elements:

See Element Intersections.

For information on managing merged elements:

See Managing Element Connections.
ARCHICAD 24 Reference Guide 881



Construction Elements Elements of the Virtual Building
Managing Element Connections

Connected elements can involve the following operations (located by default in the Design menu):

• Trim to Roof/Shell

• Merge Elements

• Join Wall to Curtain Wall

• Solid Element Operations

Elements connected to each other are associative: a change to any element will immediately affect all the 

connected elements. Thus, it can be important to keep track of which elements are connected to which.

The Connections icon and the Connections List provide in-place interface to help you manage these 

relationships.

The following examples involve Trimming relationships, but the feedback works the same way for Solid 

Element Operations, Merged Elements and joined Curtain Walls.

Managing Trims

If you select a single model element that is part of a Trim relationship, you will see a Connections icon appear:

Note: The Connections icon will not appear if you have selected multiple elements.

If you move your cursor on top of this icon, any connected element will be highlighted in blue.

If the selected element (such as the Roof, below) is involved in multiple Trim relationships, click the icon to 

view each connection relationship in a list.

If Roof A is connected to Roof B, and Wall A is trimmed by Roof A, then Wall A will be trimmed by Roof B as 

well.

Wall A’s connection grip will list only Roof A, since only they have direct connections.
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Move your cursor through the list: as you hover over any listed item, that connected element is shown with a 

highlight in the project (e.g. the gable Wall in the image below).

To highlight all of the elements connected to the selected element, hover over the header (e.g. Trim) in the 

connection list:

If the list includes connections to elements not visible in the current view (e.g. it is on a hidden layer, or on a 

different story), that connection item is listed in italic type.

Wall A (Selected)

Roof A (Highlighted from the grip) Roof B (Cuts Wall A, but not listed in grip)
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To clear a connection (that is, to sever the associative relationship and undo the Trim), click the X icon next to 

that connection in the list. The connection is cleared. To clear a whole group of Connections, click the X next 

to the header in the list (e.g. Trim).

To clear multiple connections all at once, select one or more model elements. From the context menu, choose 

Connect > Clear All Connections. All connections of the selected element(s) are cleared.
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Shells

The Shell in ARCHICAD is a real building element with a wide range of creative uses. Use the Shell tool to 

model elements ranging from a building’s entire exterior to a single custom object.

About Shells

Extruded Shells

Revolved Shells

Ruled Shells

Sample Workflows for Shell Creation

Graphical Editing of Shells

Create Hole in Shell

Edit Shell Hole

Define Shell Contour

Customize Edge of Shell or Edge of Shell Hole

Trim Elements to Roof or Shell

Shell Tool Settings
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About Shells

Basic Shell Creation

Shells can be created in either the Floor Plan or 3D Window. Use one of three basic shapes: 

• Extruded

• Revolved, or

• Ruled

Creating a basic Shell of any of these types is easy. Then you can develop the Shell further by graphically 

editing it, freely rotating it, adding openings or cutting its contour into any shape.

See Graphical Editing of Shells.

Shell Structure

Like other construction elements, a Shell’s essential structure derives from its Building Material, assigned in 

Shell Tool Settings.

A Shell (like a Wall, Slab or Roof) can have a composite structure. If the structure of the Shell is a composite, 

then the Shell’s thickness is defined in Options > Element Attributes > Composites, and equals the sum of 

the skins’ thicknesses.

For a composite Shell, the “Reference Side” surface is the first listed skin of the composite, in Composite 

Settings.

Note: You can edit a selected composite by accessing its settings from its context menu:

The Shell is constructed out of a membrane (the Reference side) plus a Shell body attached to one side of the 

membrane. The Shell body is “grown downwards,” with the Reference side on top.

The Reference side of the Shell is significant when:

• calculating surface area of the Shell or its skins
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• overriding surfaces as needed, in the Model Panel of Shell Settings. 

Use Flip (from Shell Settings or the Info Box) if you want to move the Shell body to the other side of Shell 

membrane.

Shell Display on the Floor Plan

• Shell display on the Floor Plan is based on its real 3D geometry. Thus, you will see the effects of Solid 

Element Operations on Shells on the Floor Plan.

• Shells can display a cover fill, which - as with Roofs - can be set to reflect the vectorial hatching of the 

Shell’s surface, either as defined in the Building Material or (if the override is on) its top surface override. 

(Enable the Use Fill from Surface checkbox under the Cover Fill settings, in Shell Settings.)

Shell Connections

For information on how intersections (junctions) work among construction elements, including Shells:

See Element Intersections and Merge Elements: Roofs, Shells, Morphs.

Like Roofs, Shells are trimming elements and participate in associative model connections. This means you 

can trim Shells to other elements to achieve precise geometries and complex structures.

See Trim Elements to Roof or Shell.

Shell Openings

Holes and Skylights can be placed into Shells.

See Create Hole in Shell and Skylights.

Gravitate to Shell

ARCHICAD’s Gravity feature works on Shells. That is, when placing a new Wall, Column, Beam or Object-

type element, the Gravity function lets you place it directly on top of an existing Shell, thus taking on the 

elevation of the element it is placed on.

See also Gravity.
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Extruded Shells

Use the extruded method to create a Shell by drawing its profile on a plane (either freehand polygon or a 

default shape), then extruding the profile. For example, you can extrude a Shell over the walls of a building.

See the following sections for basic creation of Extruded Shells:

Simple Extruded Vault: Parallel to the Floor Plan

Simple Extruded Vault: Perpendicular to the Floor Plan

Extruded Shell with Freely Defined Profile

For more examples, see Sample Workflows for Shell Creation.

Watch the Video
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Simple Extruded Vault: Parallel to the Floor Plan

Use this method to place a vault-shaped Shell profile, then extrude it graphically.

The Shell’s profile here is always a half-circle (vault). (You can edit the profile later.)

1. Activate the Shell Tool and choose the extruded geometry method with simple input method.

On the Floor Plan or 3D Window:

2. Click twice to define the Shell’s extrusion length.

3. Click a third time to define the width of the Shell Profile.

4. The Shell is complete.
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Simple Extruded Vault: Perpendicular to the Floor Plan

Use this method to place a vault-shaped Shell profile, then extrude it up or down (perpendicular to the Floor 

Plan).

The Shell’s profile here is always a half-circle (vault). (You can edit the profile later.)

On the Floor Plan:

1. Activate the Shell Tool and choose the extruded geometry method with simple input method.

2. Double-click at the place you want to place the Shell. (A temporary profile appears.) Its base elevation 

depends on the value set in Shell Settings.

3. In the appearing dialog box, enter the length of the Shell’s extrusion. A positive number will extrude the 

Shell upward (toward you). A negative number will extend the vector away from you. Click OK to close the 

dialog box.

4. Move the cursor to define the Shell position, then click to define the width of its profile.
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5. The Shell is complete.
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Extruded Shell with Freely Defined Profile

Use this method to define the Shell profile with a polyline, then extrude it perpendicularly to the editing plane. 

Two examples are shown here.

1. Activate the Shell Tool and choose the extruded geometry method with detailed input method.

On the Floor Plan:

2. Draw the Shell profile - a polyline or a closed polygon - with the usual polygon input method.

3. Double-click to complete the polyline or polygon.

4. In the appearing dialog box, enter the length of the Shell’s extrusion. A positive number will extrude the 

Shell upward (toward you). A negative number will extend the vector away from you. The extrusion is 

always perpendicular to the Floor Plan. Click OK.

5. The Shell is complete. View it in 3D. (In the 3D window, the profile line of a selected Shell is displayed in a 

separate color.)

Note: You can change this color using the “Reference Lines in 3D” setting at Options > Work 

Environment > Selection and Element Information.
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In the 3D Window:

1. Choose the input plane. Either click to find the default plane, or choose another input plane based on 

existing elements.

• If you click in “empty space”, the default input plane is at the base elevation defined in Shell Default 

Settings (here, 500).

• To place an input plane defined by points or surfaces of an existing element, choose it by clicking on any 

points and/or edges or surfaces: the automatic feedback (a gray square) will show you where the potential 

input planes are. When you get the plane you want, click to make it appear.
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2. Draw the Shell profile - a polyline or a closed polygon - with the usual polygon input methods. (Here, two 

different examples are shown.)

3. Complete the polygon.

4. Extrude the Shell by dragging the cursor. It will be extruded perpendicular to the input plane.

5. Click to complete.
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Revolved Shells

Use the revolved method to create a Shell by defining its profile (either a default shape or a freehand profile), 

then revolving the profile around an axis.

What’s Covered

Revolved Shell: Simple Input

Revolved Shell with Freely Defined Profile

Sample Workflows for Shell Creation

Segment Surface Along Rotation

Watch the Video
ARCHICAD 24 Reference Guide 895

https://youtu.be/8wD-GPi5aEQ


Construction Elements Elements of the Virtual Building
Revolved Shell: Simple Input

In the Floor Plan or 3D window:

1. Activate the Shell Tool and choose the revolved geometry method with simple input method.

2. Click to define the Shell axis at the center of the dome. (The initially placed axis is always vertical, though 

you can edit the axis slant later.)

3. Drag the cursor to define the size (width) of the Shell. Click where you want to begin revolving it around 

the axis.

4. Drag the cursor and click to complete the angle of revolution.

 

5. View the result in 3D.
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Revolved Shell with Freely Defined Profile

1. Activate the Shell Tool and choose the revolved geometry method with detailed input method.

On the Floor Plan:

2. Draw the Shell profile - a polyline or a closed polygon - with the usual polygon input method.

3. Double-click to complete the polyline or polygon.
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4. Click twice to draw the revolution axis. The initially placed revolution axis is always parallel to the Floor 

Plan, though you can edit it later.

5. In the appearing dialog box, enter the Shell’s revolution angle. A positive number will revolve the Shell 

toward you. A negative number will revolve the Shell away from you.

6. Click OK to complete the Shell. View it in 3D.

In the 3D Window:

1. Choose the input plane. Either click to find the default plane, or choose another input plane based on 

existing elements. This is the plane on which you will draw the profile and then its revolution axis.

• If you click in “empty space”, the default input plane is at the base elevation defined in Shell Default 

Settings.

• To place an input plane defined by points or surfaces of an existing element, choose it by clicking on any 

points and/or edges or surfaces: the automatic feedback (a gray square) will show you where the potential 

input planes are. When you get the plane you want, click to make it appear.
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2. Draw the Shell profile - a polyline or a closed polygon - with the usual polygon input methods.

3. Complete the polygon.

4. Click to define the center of the revolution axis.

5. Move the cursor to complete the revolution axis. (Navigate in the 3D view to find the best angle for seeing 

the feedback.)
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6. The Shell is complete.
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Ruled Shells

A Ruled Shell requires two separate profiles in any two planes.

Each of the two profiles, like line-type elements, consists of segments and intermittent nodes. To create a 

ruled Shell, ARCHICAD will draw connecting lines between the respective segments and nodes of each of the 

two profiles. The Shell is then “grown” onto the resulting geometry.

Ruled Shell Morphing

The logic (called “Morphing rules”) by which the two profiles are connected can take two forms. Choose the 

desired icon from the Info Box or the Geometry and Positioning Panel of Shell Settings, with the Ruled 

Construction method selected.

• Paired: Profiles are connected by mapping each segment/node on one profile to a single segment/node 

on the other profile. If the segments/nodes cannot be matched up one-to-one, then they are paired off 

proportionately.

• Smooth: Profile polygons are connected by joining the respective segments that are of proportionate 

lengths, without calculating the position of nodes. This may be advantageous if you have drawn the 

profiles based on a spline, which creates a large number of seemingly random nodes.

See the following section on the basic creation of Ruled Shells.

What’s Covered

Ruled Vaulted Shell
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For more examples, see Sample Workflows for Shell Creation.
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Ruled Vaulted Shell

To create a Ruled Shell with the simple input method, you will define two profiles on parallel planes. With this 

input method:

• The first profile is always a vault shape.

• The second profile is always a straight line.

Here we will place a vaulted ruled Shell atop this wall complex.

1. Choose the Shell tool’s Ruled geometry method and the Simple input method.

On the Floor Plan:

2. Click on each endpoint of the lower wall segment to define the width of the first, vault-shaped profile.

3. Drag the cursor to the opposite wall segment, then click on each endpoint of that wall to define the width of 

the second, straight-line profile.
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4. The Ruled vault-shaped Shell is complete. View in 3D.

In the 3D Window:

Here we will place a vaulted ruled Shell atop two pairs of columns of different heights.

1. Choose the Shell tool’s Ruled geometry method and the Simple input method.

2. Click on each of the two taller columns to define the width of the first, vault-shaped profile.
ARCHICAD 24 Reference Guide 904



Construction Elements Elements of the Virtual Building
3. Drag the cursor to the opposite, shorter columns and click on each to define the width of the second, 

straight-line profile.

4. The Ruled vault-shaped Shell is complete. View in 3D.

Watch the Video
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Sample Workflows for Shell Creation

The following sections show you how to create the following Shell types, step by step:

Extruded Shell: Wavy Canopy Roof

Revolved Shell: Arced Triangular Roof Complex

Revolved Shell: Define Contours in Section

Ruled Shell: Tennis Court Shell

Ruled Shell: Twisted Tower
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Extruded Shell: Wavy Canopy Roof

1. Activate the Shell Tool and choose the extruded geometry method with detailed input method.

2. In the 3D window, click on a surface, or click three points, to define an input plane onto which to draw the 

profile.

3. Draw the desired profile, in this case a wavy line, with the usual pet palette options. Click to complete.

4. Next, extrude the profile: extend it back to the far wall and click to place it. View the result.

5. Raise the Wall height so that the it intersects the Shell, so that you can trim the Wall to the Shell.
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6. Select the Wall and Shell which you want to trim. From the context menu, choose Connect > Trim 

Elements to Roof/Shell.

For more information on Shell connections, see Trim Elements to Roof or Shell.

View the result.
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Revolved Shell: Arced Triangular Roof Complex

1. On the Floor Plan, activate the Shell Tool and choose the Revolved geometry method with simple input 

method.

2. Create a Revolved Shell with a 45-degree angle of revolution.

3. With the Shell selected, choose Define Shell Contour from the context menu.

4. Define a square contour with which to cut the edge of the Shell, as shown. View the result in 3D.

5. Back on the Floor Plan, mirror a copy of this Shell.
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6. Move the second Shell so that it is alongside the first one.

7. Move the second Shell slightly upward on the Y-axis so that it slightly overlaps the first Shell (this will 

make it easier to trim the elements to each other.) View it in 3D.

8. Return to the 2D window. Create two Curtain Walls, each facing in the opposite direction, running between 

the two Shells as shown.

9.  View in 3D.
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10. Edit the position of the Curtain Walls into the right place: elevate the Curtain Wall, then stretch its top 

corner to the right height.

11. Now select each Curtain Wall in turn and trim it to each of the Shells to achieve the desired geometry, by 

following these steps.

• Select one of the Curtain Walls and use the Connect > Trim Elements to Roof/Shell command.
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• Trim the selected Curtain Wall to each of the two Shells.

• Now select the other Curtain Wall, and trim it to each of the two Shells.

• Multiply the resulting structure as needed.
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Revolved Shell: Define Contours in Section

Here, you draw several revolved Shells having a common endpoint for their profiles, but slightly offset from 

each other.

Then, in the Section window, select each Shell separately and draw its contour in the shape of a rectangle - 

use progressively smaller rectangles. The result is several overlapping Shell segments, each of a slightly 

different size.

1. Ensure that the default Shell elevation is 0.

2. Draw the first revolved Shell on the Floor Plan as shown.

3. Draw two more revolved Shells using the same profile starting point, but each slightly larger and offset 

from the previous one.
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4. View the result in 3D.

5. Now create a Section for these Shells and open the Section window.

6. Select the Shell closest to you. From the context menu, choose Define Shell Contour.

7. Draw the contour as a rectangle.
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8. Select the other two Shells and define rectangular contours for them.

9. View the result in 3D and fine-tune as needed.
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Ruled Shell: Tennis Court Shell

Create a Shell atop a tennis court stadium.

1. Place the Tennis Court object.

2. Draw a rectangle of walls around it at 45 degrees to the stadium; this wall will serve as the reference for 

the Ruled Shell’s profiles (it will be deleted later).

Place a Ruled Shell on top:

1. Go to the 3D window and activate the Shell tool, with the Ruled geometry method and Detailed input 

method.

2. Define the first input plane on one side of the wall rectangle, by clicking on the outside surface of the wall.
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3. Draw a line from one top corner to the other and double-click to complete the first profile: a straight 

diagonal line as shown.

4. In the 3D window, turn the view so that the opposite wall is now closest. Define the second input plane on 

the outside of this opposite wall, by clicking on the wall’s outside surface.

5. On this plane, draw the second profile, relying on the feedback to see how the Ruled Shell will be formed. 

In this case, you will draw a diagonal, straight line. Double-click to complete.

The initial Shell is completed.

You can delete the wall rectangle and view the result.
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Next, define the Shell contour:

1. Go to the Floor Plan.

2. Use the circle tool to draw an ellipse in the desired shape of the stadium roof.

3. Select the Shell. From the context menu, choose Define Shell Contour.
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4. With the Magic Wand (press the spacebar), click on the ellipse to define the Shell’s contour in the ellipse 

shape. (You can then delete the ellipse element.)

5. View in 3D.

6. Place surrounding walls to make a stadium as needed, and trim them to the Shell.
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Ruled Shell: Twisted Tower

1. Choose the Shell tool’s Ruled geometry method and the Detailed input method.

2. On the Floor Plan, draw the shape of your first profile polygon (its plane is flat on the Floor Plan). In this 

case, we draw a square. Double-click to complete the first profile polygon.

3. In the appearing dialog box, enter the distance between the two planes of your Ruled Shell profiles 

(between i.e. the first profile, already placed, and the second one, which you are about to draw.)

4. Now draw the polygon of the second profile, whose plane is parallel to the first. We draw a skewed square 

(here, shown in red). The feedback shows the ruled Shell taking shape.

5. Double-click to complete the polygon and the Shell.

6. View the result in 3D.
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Graphical Editing of Shells

In Floor Plan, Section and 3D view, a wide range of editing possibilities are available for the Shell. Select your 

Shell and try out the pet palette commands: twist, turn, and rotate your Shell into the shape and position that 

you need.

In the 3D window, the editable profiles, axes and extrusion vectors are shown in a different color, so it is 

easy to find them.

Note: You can change this color using the “Reference Lines in 3D” setting at Options > Work 

Environment > Selection and Element Information.

See images for each type of Shell when selected in 3D:

• An Extruded Shell has a profile and an extrusion vector; both are editable.

• A Revolved Shell has a profile and an axis.

• A Ruled Shell has two profiles, on any two planes, connected by the Shell body. The profiles can be 

edited and rotated. You can also rotate either or both of the profile planes.

As you edit the Shell, any cutting bodies it may contain will remain in place in the global coordinate system. 

This means that after the editing is done, the holes may be located in a different part of the Shell.

See Edit Shell Hole.

Options for Editing Extruded Shells

Options for Editing Revolved Shells

Options for Editing Ruled Shells
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Options for Editing Extruded Shells

About the Extrusion Vector

• One end of the extrusion vector (its initially placed point) is distinguished by a larger hotspot; this 

represents the Shell’s base height.

• The extrusion vector can be located apart from the Shell body itself.

Edit Extrusion Vector

Click on either end of extrusion vector to bring up these commands on the pet palette.

• Edit Extrusion Length: Edit the length of the extrusion vector. Its slant and its other geometric 

parameters remain unchanged.

• Edit Extrusion Slant: Edit the slant of the extrusion vector. The extrusion length, as well as the Shell 

starting/ending angles and the distortion angle, remains unchanged.
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• Stretch: Edit the length of the extrusion vector and its rotation. You can also rotate its slant, if you join the 

vector endpoint to an existing element. The starting/ending angles and the distortion angle remain 

unchanged.

If you stretch the Shell to reach a point on another existing element, the Shell slant changes accordingly:

• Drag Extrusion Vector: Drag the Shell’s extrusion vector to another location. Click anywhere on the 

Extrusion vector to bring up this command from the pet palette.

If you drag the extrusion vector, two things happen:

• The Shell’s base elevation changes to the new location of the vector
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• The Shell’s start and end angles are now editable based on this new vector location. (The vector serves 

as the axis of rotation for the Shell start/end angles.)

Edit Profile of Extruded Shell

Select the Shell and use the familiar pet palette commands to edit the profile. Note that even if you move the 

profile, the extrusion vector remains in place.

• Drag, Rotate, Mirror Profile

These three commands operate on the Shell profile on its own plane (the plane is displayed in the 3D window 

while you edit):
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• Insert New Node

• Curve Edge

• Set Distortion Angle

Select the Shell profile and use the pet palette command to set the distortion angle graphically. This can be 

useful, for example, to “flatten” your vault-shaped Shell into more elliptical form.

View the resulting distortion angle in the Tracker, the Info Box or Shell Settings.

• Continue Profile

If you select the endpoint of the Shell Profile, the Continue Profile command is available in the pet palette. 

Use this add one or more segments to the profile, as if you were extending a polyline (double-click to 

complete the polyline, or click on the other profile endpoint to create a closed profile.)
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Remove profile Edge: For a closed Shell Profile, the Remove edge command is available in the pet palette 

from any selected profile edge. Click to remove that segment.
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Options for Editing Revolved Shells

Select the axis or the profile of the Revolved Shell. One end of the axis is distinguished by a larger hotspot; 

this represents the Shell’s base height.

• Edit Revolution Angle

Click anywhere on the profile of the selected Shell to bring up this command in the pet palette. Choose Edit 

Revolution Angle.

To bring up the next two commands in the pet palette, click on the endpoint of the Revolution Axis.

• Distort Axis

• Slant Axis

Watch the Video
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• Move Profile Node

• Continue Profile
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• Rotate Profile

Select the Rotate profile command from the Pet Palette. Then (as when rotating other elements) click on a 

point, then draw a rotation axis. Click to complete the rotation.

• Curve Edge

Click anywhere along the Shell profile to bring up this command on the pet palette.
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Options for Editing Ruled Shells

The Ruled Shell has two profiles. One end of the first profile is distinguished by a larger hotspot; this 

represents the Shell’s base height.

Here are some editing possibilities for either profile:

• Continue Profile

For example, extend the straight-line profile to make that end of the Shell wider.

• Curve Edge

• Drag Profile

Use this command to drag the profile within its own plane, in horizontal and/or vertical directions, to a new 

location.
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• Rotate Profile

Use these commands to rotate the selected profile in space.

• Elevate Profile Plane

Here you move the entire plane of the profile in the vertical direction.

• Drag Profile Horizontally

Here you take the profile plane and drag it horizontally.

• Turn Profile Plane
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Click to enter the turning point. Then move your cursor to define the turn direction, and click to complete.
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Create Hole in Shell

On the Floor Plan or Section window:

1. Select any Shell on the Floor Plan or Section.

2. From the context menu, choose Create Hole in Shell.

3. Draw the desired polygon onto the Shell. (The opening’s plane is the Floor Plan, but you can edit this 

later.)

See Edit Shell Hole.

4. View the result in 3D:
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In the 3D Window:

1. Select the Shell.

2. From the context menu, choose Create Hole in Shell.

3. Choose an input plane on which you want to draw the hole: use the feedback to choose the desired plane 

location. (Choose a plane anywhere in the model; it does not have to be on top of the Shell.)

4. Draw the desired polygon onto the input plane. You can edit this later.

See Edit Shell Hole.

5. View the result.

Watch the Video

Listing Shell Holes in the Interactive Schedule 

Properties of Shell Holes (e.g. Holes Surface and Perimeter) can be listed in an Interactive Schedule. As with 

other elements, you can set a preference (“Calculation Rules”) for the size of holes which should be taken into 

account when calculating Shell volume or surface.

For details, see Conditional Parameter Setup Rules.
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Edit Shell Hole

For information on customizing Shell edge surface, see Customize Edge of Shell or Edge of Shell Hole.

The Shell hole is created by an editable cutting body. The cutting body is visible when you select the hole 

itself, not the Shell.

To select the hole, zoom in on the hole and click its edge.

Note: When selecting the hole, you must click the hole on the side of the Shell that coincides with the 

profile line. Hole edge selection is not available on the side of the Shell opposite to the profile line.

Each cutting body is specific to its own Shell and cannot cut any other elements. However, a Shell that bends 

back upon itself is automatically cut twice (or more) by the single cutting body.

When you move the Shell as a whole from one place to another, the cutting body moves with it. However, 

editing the Shell itself (e.g. its profile or drawing its contour) will not affect the hole geometry.
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Edit Extrusion Length of Cutting Body

To limit the extent of the hole’s cutting body, select the hole and use the Edit Extrusion Length command 

from the pet palette to change the length of the cutting body. This way, for example, you can eliminate a hole 

created by a cutting body that runs through both sides of your Shell.

Edit Hole Contour

Select the hole so that you see its cutting body. Edit either the hole edge itself, or the contour of the cutting 

body (the result is the same). Use the familiar polygon editing commands from the pet palette.

Edit Hole on its Own Plane

The cutting body that creates the hole has its own plane. When you select the hole, you can edit the hole on 

this plane using the pet palette commands marked here. Then the hole plane is also displayed.
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• Turn Hole Plane: This command rotates the hole plane, and thereby changes the hole geometry within 

the Shell. You can also rotate the hole itself.

See Rotate cutting body to change hole geometry.

Select the Turn Hole Plane command. Define the rotation arc, then move the cursor to rotate the plane.

• Drag, Rotate, Mirror Hole: These edits move the hole on its own plane.

Edit Hole on Horizontal/Vertical Project Planes

• Drag or Drag a Copy Horizontally/Vertically
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These commands drags the hole itself (or a copy) on the project’s horizontal/vertical planes.

Rotate cutting body to change hole geometry

One way to change the hole geometry is to free-rotate its cutting body.

1. Select the hole.

2. Use the Free Rotate command from the pet palette.

3. Define a rotation axis with two clicks.

4. Define the starting point of the rotation arc with a third click, then free rotate the cutting body to its desired 

location.

5. Click to complete.

Watch the Video
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Define Shell Contour

Suppose we have a ruled Shell like the one above.

You can trim it, or any Shell geometry, to the desired shape by defining its contour.

1. Go to the Floor Plan or Section window.

2. Select the Shell.

3. From the context menu, choose Define Shell Contour.

4. Draw the desired polygon: in this case, an ellipse. (Or use the Magic Wand on an existing polygon.) 

5. Click to complete the polygon. The Shell is trimmed.

See also Edit Shell Contour Polygon.
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Edit Shell Contour Polygon

The Shell’s contour polygon, and the plane of this contour polygon, are editable.

Select Contour Polygon

To edit the contour, you must select the contour polygon itself, not the Shell. Move the cursor to the edge of 

the contour and make sure that the Info Tag indicates that the Shell’s Inner Polygon is going to be selected.

Offset Contour Polygon

Before you edit the Shell contour, it may be helpful to offset the contour polygon, so that it is easier to do your 

editing. Select the Shell contour, then choose Offset Contour Polygon from the pet palette. Offset to the 

desired location.
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Turn Contour Plane

By default, the plane of the contour polygon is parallel to the Floor Plan. Use the Turn Contour Plane pet 

palette command to change this polygon plane. This may also affect the geometry of the Shell contour.

Drag Contour Polygon

Rotate, Mirror Contour Polygon
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Watch the Video

Watch the Video
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Customize Edge of Shell or Edge of Shell Hole

You can customize the surface and/or type of any edge of a Shell, or the edge of a hole in a Shell.

Once you set the customized surface/type options, you can choose to apply them to the clicked edge only, to 

all edges of the clicked polygon (hole), or to all Shell edges.

1. Select the Shell.

2. Click on an edge to bring up the pet palette.

3. Select the Customize Edge settings icon to open the Custom Edge Settings dialog box.

4. Use the controls to adjust the Surface and Edge Type as needed.

Custom Shell Edge Surface

Note: By default, the Surface material applied to a Shell edge derives from the Building Material assigned 

to the Shell. You can override all edge surfaces of the Shell, using the controls in the Model Panel of Shell 

Settings. The Custom Edge Settings offers a further way to customize the surface of any one or more 

Shell Edges.

Surface: Click the Surface override button, then choose a custom surface for the Shell edge(s) or end 

surfaces.

If you apply a surface here to any edge that is different from the edge surface defined in the Model Panel of 

Shell Settings (or in the Building Material), the Model Panel will indicate (with a yellow patch) that a custom 

edge surface has been applied.
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If you override the Shell edge surface in Shell Settings while the dialog box is still open, the yellow patch 

(indicating “custom edge”) gets a red shadow: this means that the Shell’s general edge setting is going to 

change: do you want to apply this override to all edges, including the custom edge(s) too?

If so, check the box at the bottom of Shell Settings (Apply changes to custom planes/edges too). If you do 

not check the box, your custom edge surfaces remain the way you set them.

Custom Shell Edge Type

Edge Type: Optionally, choose a type for the Shell edge.

The Shell Edge type you define here can be used as a parameter in all of ARCHICAD’s listing functions. 

For an explanation of edge types, see Shell Listing Parameters.

Apply Changes

Apply Changes to: Once you have set the options as needed, choose the edges to which to apply these 

changes:

• Clicked Edge will apply the options you choose below (surface, edge type) only to the edge you clicked 

when bringing up the pet palette.

• Selected Polygon will apply the chosen options to the extruded ends of the Shell only or the edges of the 

hole only, depending on which one is selected.

• All Edges will apply the chosen options to all edges of the Shell as well as all edges of its holes.
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5. Click OK to apply changes.

Watch the Video
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Slabs

Slabs are the basic horizontal building blocks in ARCHICAD. They are typically used for modeling floors, split 

levels or ceilings.

Attributes for each part of the Slab’s representation are set in the Slab Settings dialog box. 

Like other construction elements, a Slab’s essential structure derives from its Building Material.

Note: The Floor Plan outlines of Meshes and Slabs on remote stories (if they are shown on stories other 

than their home stories) are displayed using the line type set at Project Preferences > Legacy.

While a Slab’s surface is defined as part of its Building Material, you can override each of the three Slab 

surfaces (top, bottom and side) surfaces in the Model Panel of Slab Settings.

It is also possible to assign a separate surface and a separate edge angle to each edge of the Slab.

To aid in precise element placement, each Slab has a Reference Plane that helps you control connections to 

other elements.

The Gravity function also works for Slabs: turn on the Gravitate to Slab command as an aid in placing 

elements onto the surface of the Slab.

What’s Covered

Slab Reference Plane

Creating Slabs

Placing Holes in Slabs

Set Custom Slab Edge Angle and Edge Surface

Slab Tool Settings

Adjust Elements to Slabs

Gravity

Related Topics:

Slabs can be included in a Structural Analytical Model generated in ARCHICAD.

For details, see Structural Analytical Model.
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Slab Reference Plane

Each Slab has a reference plane which plays a role in intersections with other elements. The ability to flexibly 

assign a Slab reference plane helps you to align intersections easier and to control the changes that result if 

you alter the Slab structure.

If you redefine an existing Slab’s reference plane, the entire Slab will change its position accordingly. This 

way, the connections previously made to the slab will remain intact.

Note: To modify the Slab reference plane while keeping the Slab position unchanged, use the Modify Slab 

Reference Plane command.

See Modify Slab Reference Plane, below.

Define Slab Reference Plane

Use the Info Box or Geometry and Positioning Panel of Slab Settings to choose a reference plane. Click the 

“C” shortcut to cycle through the reference plane options in the Slab Info Box.

A basic Slab has two possible reference planes: either the top or the bottom plane. 

A composite Slab has four possible reference planes: the top or the bottom of the Slab core, or the top or 

bottom of the Slab.

Note: If the chosen composite structure has no core, then the core-related reference plane choices are 

grayed out.

For a composite Slab, the “top” surface is the first listed skin of the composite, in Composite Settings.

Notice that the Info Box elevation icons and fields vary depending on the location of the Slab’s reference 

plane.
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Thus, Walls can join Slabs by connecting to the top of the slab core, rather than the top of the Slab finish.

Use Cases

• When a Slab is used to model a ceiling: the reference plane can be placed at the Slab base, rather than 

the top.

• If you redefine an existing Slab’s Reference Plane from Core Top to Core Bottom, the entire Slab will 

change its position accordingly. This way, the connections previously made to the slab will remain intact.

Here, the Walls are connected to the Slab’s Core Top and Bottom, respectively.
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Watch the Video

Reference Plane in Interactive Schedule/Find & Select

In the Interactive Schedule, you can list Slab elements using separate fields for the element’s top and bottom 

elevation; but the “Elevation to Project 0” and “Elevation to Story” refer to the elevation of the Slab reference 

plane (not the elevation of the Slab top).

It is also possible to Find & Select slabs in your project, or list them in the Interactive Schedule, based on the 

position of their reference planes:
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Editing Slabs by Reference Plane

In 3D view, the Slab Reference Plane is shown as a thick blue line. Its shape is a projection of the top of the 

Slab; to edit the Slab, you can click either on the Reference Plane line or the Slab’s top outline, or any of the 

nodes.

Adjust Elements to Slabs

Use this function (Edit > Reshape > Adjust Elements to Slabs) to easily adjust elements (Walls, Columns or 

horizontal Beams) to specific levels of one or more Slabs that are located above and/or below them.

See Adjust Elements to Slabs.

Modify Slab Reference Plane

This command (at Edit > Reference Line and Plane > Modify Slab Reference Plane) enables you to modify 

the Slab reference plane of one or more selected Slabs, while keeping the Slab position unchanged.

Note: If the selection includes one or more basic Slabs, then choosing the “Core Top” option here will 

result in a “Top” reference plane for these basic Slabs.
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This function can be helpful if you use basic structures to model during the sketching phase, then later convert 

basic Slabs to composites. In such a case, you can adjust the reference plane to the core top rather than the 

top, as needed.

When migrating older-version files, you may find it useful to use this function to change the Slab reference 

plane from the top to other locations.

Watch the Video
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Creating Slabs

Set Slab parameters in Slab Settings.

See Slab Tool Settings.

New Slabs can be created in either the Floor Plan or the 3D Window.

Depending on the structure you choose for the Slab (either a basic or a composite slab), you have varying 

construction method options for the Slab Reference Plane:

See Slab Reference Plane.

Slab Geometry

Choose one of the three Slab Geometry Methods from the Info Box.

• With the first icon on the left, you can create a Polygonal Slab. Just like for Walls, the pet palette appears 

and allows you to draw straight and curved segments for the Slab’s outline.

• The second and third icon allow you to create a Rectangular or a Rotated Rectangular Slab. The 

rectangle is defined by placing two opposing corner nodes. A rectangle Slab is always aligned 

orthogonally with the normal grid. The Rotated Rectangular method requires that you first define a rotation 

vector, then drag the cursor in a perpendicular direction to complete the slab.

Create a Composite Slab

You can apply or customize a composite structure for a Slab.

For more information, see Composite Structures and Assign a Composite Structure to a Wall, Slab, Roof or 

Shell.

(Remember that the model’s Partial Structure Display settings will affect the display of composite Slabs.)

See Partial Structure Display.

If the structure of the slab is a composite, then the slab’s thickness is defined in Options > Element 

Attributes > Composites, and equals the sum of the skins’ thicknesses.

Note: You can edit a selected composite by accessing its settings from its context menu:

You have four options for the reference plane of a composite Slab: top of slab, bottom of slab; top of core, 

bottom of core.

See also Slab Reference Plane.
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Placing Holes in Slabs

You may need to make holes in Slabs to accommodate objects such as staircases, or for an open atrium 

space.

1. Select the existing Slab.

First Select the Existing Slab

2. With the Slab tool active, draw a new contour within the Slab’s boundaries. 
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3. This new contour will be interpreted as a hole in the Slab.

See also Selecting Slab Hole.
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Set Custom Slab Edge Angle and Edge Surface

To customize a slab edge angle, and to apply a custom surface to the edge(s) of a slab and/or its holes, select 

the slab (or just its hole) and click on an edge with the Mercedes cursor to bring up a pet palette. Select the 

Custom Edge settings icon to open the dialog box.

Customize Slab Edge Angle

Angle: Choose an angle (Vertical or Custom) for the slab edge. If you choose Custom, enter the desired 

angle value in the field at right.

If you apply an edge angle here that is different from the default edge angle (set in Slab Settings), the 

Geometry and Positioning Panel of Slab Settings will indicate that a custom edge angle has been applied.

If you later change the Edge angle setting in Slab Settings while the dialog box is still open, the yellow patch 

(indicating “custom edge”) gets a red shadow. This means that the Slab’s edge angle is going to change: do 

you want to apply this change to the custom-angle edges too? If so, check the box at the bottom of Slab 

Settings (Apply changes to custom planes/edges too). If you do not check the box, your custom edge angles 

remain the way you set them.

Custom Slab Edge Surface

Note: By default, the Surface material applied to a Slab edge derives from the Building Material assigned 

to the Slab. You can override all edge surfaces of the Slab, using the control in the Model Panel of Roof 

Settings. The Custom Edge Settings offers a further way to customize the surface of any one or more Slab 

Edges.

Surface: Click the Surface override button, then choose a custom surface for the slab edge(s). 
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If you apply a surface here to any edge that is different from the edge surface defined in the Model Panel of 

Slab Settings (or Building Material), the Model Panel will indicate (with a yellow patch) that a custom edge 

surface has been applied.

If you override the Slab edge surface in Slab Settings while the dialog box is still open, the yellow patch 

(indicating “custom edge”) gets a red shadow: this means that the Slab’s general edge setting is going to 

change: do you want to apply this override to all edges, including the custom edge(s) too?

If so, check the box at the bottom of Slab Settings (Apply changes to custom planes/edges too). If you do 

not check the box, your custom edge surfaces remain the way you set them.
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Apply Changes

Apply changes to:

• Clicked Edge will apply the options you choose below (angle, surface) only to the edge you clicked when 

bringing up the pet palette.

• Selected Polygon will apply the chosen options to the edges of the slab only or the edges of the hole 

only, depending on which one is selected.

See Selecting Slab Hole below.

• All Edges will apply the chosen options to all edges of the slab as well as all edges of its holes. (If the 

selected slab has no holes, then Selected Polygon and All Edges have the same effect.)

Selecting Slab Hole

To customize the Slab Hole edge or angle, you must select the hole, rather than the entire slab.

To ensure that you have selected the hole, make sure the Info Tag says “Inner polygon of” the selected Slab:

To apply the customized values to the hole only, then choose Selected Polygon from the Apply On pop-up.
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Meshes

Meshes are surfaces of any form created by defining the elevation of their characteristic points and 

interpolating between them.

A Mesh is created on the foundation of the Mesh Reference Plane and the ridges of the Mesh.

Like other construction elements, a Mesh’s essential structure derives from its Building Material.

To aid in precise element placement, you can turn on the “Gravitate to Mesh” command to place additional 

elements onto the surface of the Mesh.

For information on converting Surveyors’ data into an ARCHICAD Mesh, see Surveyors’ data (.xyz).

What’s Covered

Display of Meshes

Create a Mesh

Edit Elevation of a Mesh Point

Add New Points to the Mesh

Create a Hole in the Mesh

Mesh Tool Settings
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Create a Mesh

New Meshes can be created in either the Floor Plan or the 3D Window.

See also Surveyors’ data (.xyz).

The Mesh has four geometry methods in the Info Box. You can create Polygonal, Rectangular and Rotated 

Rectangular shapes or a Regular Sloped Mesh.

In all cases, you will draw a Mesh polygon at the elevation of the Mesh reference plane defined in the Settings 

dialog box.

• The Polygonal and Rectangular/Rotated Rectangular Mesh geometry methods work the same as 

similar controls for the Slab tool.

• The Regular Sloped Mesh method helps you quickly create regular Meshes with plane surfaces.

After defining the rectangle contour of the Mesh, the Regular Sloped Mesh dialog box opens 

automatically.

– Divisions: In the first part of the dialog box, set the number of divisions in either coordinate direction.

– Mesh Corner Elevation: Set the elevation values of three corner points of the Mesh; the fourth one is 

generated automatically.

If needed, select the Mesh and edit its points, add new points, or create a hole.
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Related topics:

Edit Elevation of a Mesh Point

Add New Points to the Mesh

Create a Hole in the Mesh
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Edit Elevation of a Mesh Point

1. Select the Mesh.

2. With the Mesh tool active, click a Mesh Point to bring up the pet palette.

3. Choose the Elevate Mesh Point command from the pet palette.

If you are in the Floor Plan, this opens the Mesh Point Height dialog box.

4. Enter a new height value in the text field.

Checking the Apply to All box will set all Mesh points to this new height.

Changing the elevation of a single point will not affect the elevation of the neighboring points.

The arrow below the text field opens a pop-up menu in which you can choose a reference level for the 

modified height.
ARCHICAD 24 Reference Guide 961



Construction Elements Elements of the Virtual Building
Add New Points to the Mesh

To add points to an existing Mesh, draw a line or polygon onto the existing Mesh using either the Mesh tool or 

the Line/Polyline tools. The workflow is a little different for each:

Use Mesh Tool

1. Select the Mesh.

2. Activate the Mesh tool.

3. Draw a closed polygon or a straight segment within the Mesh polygon.

(If you draw outside of the contour of the first polygon, only points within the contour will constitute the Mesh.)

The New Mesh Points dialog box opens.

Continue by choosing an option for the new points (see below).

Use Line or Polyline Tool

1. Activate the Line or Polyline Tool.

2. Draw a line or polygon to create a set of points on the existing Mesh.

3. Select the Mesh.

4. Activate the Mesh tool.

5. With the Magic Wand method (Spacebar + click), click on the newly drawn line/polyline.

The New Mesh Points dialog box opens.

Continue by choosing an option for the new points (see below).

New Mesh Points Options

1. Choose the Add New Points radio button. (If you drew a two-point line rather than a polygon, this is the 

default and only choice.)

2. Choose an option from the drop-down menu to define the relationship between the newly created points 

and existing ones.

• If you choose No Surface Fitting, the new points will be added with the height value currently set in the 

Mesh Settings dialog box. Intersected user-defined ridges will keep their height. 

• If you choose Fit to User Ridges, the new points will be placed on the current surface of the Mesh, and 

only user-defined ridges will keep their height. (The internal triangulation of the current Mesh will be 

altered.)

• If you choose Fit to All Ridges, the new points will be placed on the current surface of the Mesh, and all 

ridges will keep their height. (The internal triangulation of the current Mesh will be unaffected.) This 

method is the most precise one, but it may generate a rather large number of ridges.
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Create a Hole in the Mesh

1. Select the existing Mesh.

2. With the Mesh tool, draw a closed polygon that falls entirely within the Mesh polygon.

3. The New Mesh Points dialog box opens.

4. Choose the “Create Hole” radio button.

5. Choose an option from the drop-down menu to define the relationship between the newly created points 

and existing ones.

– No Surface Fitting: the slopes of the Mesh will be connected to the bottom elevation of the Mesh.

– Fit to User Ridges or Fit to All Ridges: With these options, no slopes will be connected to the bottom 

of the Mesh, allowing you to place your building exactly into the excavated site.
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Display of Meshes

Mesh Structure

In the Floor Plan, only the outline and the ridges of the Mesh are shown.

Note: The Floor Plan outlines of Meshes and Slabs on remote stories (if they are shown on stories other 

than their home stories) are displayed using the line type set in Project Preferences > Legacy.

In 3D, depending on the construction method chosen in the Info Box or Mesh Settings, the Mesh can be 

displayed in three ways:

• Surface Only

• Surface with Skirt

• Solid Body

Display of Ridges

There are two types of ridges in a Mesh: user-defined and generated ridges. Each generated ridge 

connects two Mesh points at different heights that are not already connected by a user-defined ridge.

• User-defined ridges are always displayed.

• If the Show All Ridges option is selected, ARCHICAD will also show the ridges generated through the 

connecting Mesh nodes. (This control is located in Mesh Tool Settings). Generated ridges are shown only 

if they connect points that differ in elevation.
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3D Appearance

The controls of the Model panel of Mesh Settings defines whether the Mesh ridges are displayed as smooth 

or sharp.

• All Ridges Sharp: Show the Mesh in the 3D window with sharply connecting triangles.

• User Defined Sharp: Show the Mesh surfaces with sharply connecting user defined ridges, and with 

smoothly connecting surfaces everywhere else.

• All Ridges Smooth: Show the Mesh with smoothly connecting surfaces.

If you choose All Ridges Smooth, only user-defined ridges will appear in 3D view.
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Zones

Zones are spatial units in your project, created with the Zone tool. 

Zones usually represent rooms; wings of a building; blocks of a housing estate; or functional areas of a 

building. Zones in 3D can also be used for simple mass modeling; and they form the basis of the Model 

Review process in the Energy Evaluation function.

The bottom of every Zone (like other elements) is linked to its Home Story; you can also top-link the Zone to 

any story above it in the project. 

As needed, define offsets from its top link or Home Story; this will affect the Zone height. Alternatively, just 

enter a fixed Zone height, without a top link.

Creating Zones

Zone Categories

2D Display of Zone Backgrounds

Zone Stamps

3D Display of Zone Spaces

Crop Zone to Another Element

Calculating Zone Area and Zone Volume

Updating Zones

Zone Tool Settings
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Creating Zones

 Manual Zone Construction

Use one of the manual methods when your Zone’s boundary is not clearly surrounded by elements (e.g. when 

doing space planning).

1. Activate the Zone tool.

2. In the Info Box, choose a Manual creation method: Polyline, Rectangular or Rotated Rectangular

3. In the Floor Plan or 3D window, draw the Zone contour.

4. Click with the appearing Hammer cursor to define the location of the Zone Stamp. (The Zone Stamp does 

not necessarily have to be placed inside the Zone polygon.)

See also Edit Zone Polygon.

See Automatic Recognition Zone Construction.

Note: Columns cannot serve as the enclosing border of a zone. However, you can choose whether the 

area covered by the column should be included when calculating Zone area and volume.

See also Relation to Zones.
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Automatic Recognition Zone Construction

Most Zones are surrounded by Walls and the only openings in them are Doors and Windows. In this situation, 

the easiest way to create a zone is to use one of the automatic recognition methods: Inner Edge or 

Reference Line. 

1. Activate the Zone tool.

2. In the Info Box, choose the Inner Edge or Reference Line method.

• Inner Edge method: ARCHICAD defines the zone area by the inner edges of walls.

Zone Created with Inner Edge Method

• Reference Line method: ARCHICAD considers the reference lines of the walls as the boundaries of the 

zone. Not available for slanted or complex Walls.

Note: To set the Floor Plan display of a Zone created with the Reference Line method, use the Gross or 

Net option in Zone Settings. The Zone area remains unchanged, only the polygon is displayed differently.
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Zone Created with Reference Line Method

3. In the Floor Plan or 3D window, click within a closed polygon that consists of Walls and/or Curtain Walls.

4. Click with the appearing Hammer cursor to define the location of the Zone Stamp. (The Zone Stamp does 

not necessarily have to be placed inside the Zone polygon.)

See “Zone Polygon” at Zone Name and Positioning Panel.

Exclude a Wall as a Zone Boundary

By default, the Relation to Zones setting in the Model Panel of Wall Settings is set to “Zone Boundary.” 

This means that all walls enclosing a closed space are considered zone boundaries by default.

To exclude any wall as a zone boundary, just change the Relation to Zones setting to No Effect on Zones.

See also Relation to Zones.

Zone Reference Point

If you place the Zone Stamp with one of the automatic recognition methods, a cross appears inside the Zone 

at the location that you first clicked to define the Zone’s area. This cross indicates the reference point of the 

Zone.

This point is used as the starting point of boundary recognition for subsequent updating actions.
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Edit Zone Polygon

Use the familiar pet palette commands to edit the zone polygon.

See Reshaping Polygons and Chained Elements, and Offset All Edges.

Offset Edge - Fixed Area

Use this pet palette command to offset the clicked edge so that the original Zone area does not change. This 

is useful if you are doing space planning based on defined areas.

In this example, you offset the right side of the zone - and the shape is automatically constrained so that the 

area stays constant (as seen in the tracker):
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Create a Manual Zone Boundary 

If the Zone has openings that are not Doors or Windows, ARCHICAD will continue searching for boundaries 

outside the spatial unit that you wished to identify as a Zone. In this case, the result may not be what you 

expect.

To resolve this, do one of the following:

• use the Manual construction method

• place an Empty Opening Door object into the Wall which is the same height as the Wall - the Wall is not 

shown in 2D, but it does serve as a Zone Boundary
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• draw a Line, Arc or Spline to serve as a zone boundary: check the Zone Boundary box in its Settings.

If your desired zone boundaries also encompass freestanding shapes or walls, you may get a warning 

message when clicking to place the zone stamp. In this case, you must click closer to the bounding elements. 

Then the zone will be created correctly.

Related Topics:

Updating Zones

Relation to Zones

Calculating Zone Area and Zone Volume
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Zone Categories

Each zone you create in your project is assigned a Zone category in the Zone’s Settings dialog box. Zone 

Categories are ARCHICAD attributes.

This Zone Category defines:

• the color of the zone background, and

• the Zone Stamp object used for the zone.

The main function of zone categories is to use colors to visually distinguish different types of spaces in your 

project: for example, you can assign the “Office” category to all your office space, which will all be displayed in 

pink; and the “Communication and Access” category to the hallways, which will all be displayed in white.

For other ways to display zone fills, see 2D Display of Zone Backgrounds.

Zone Categories Dialog Box

To define or redefine Zone Categories, go to Options > Element Attributes > Zone Categories.

Note: Zone Category attribute definition is also available in Attribute Manager: See Zone Categories 

(Attribute Manager).

Use the pop-up at top to choose a zone category from list of predefined zone categories. Either edit its 

properties directly, or choose one of the following commands:

• New: Click this button to create a new zone category by creating a copy of the selected zone category 

under a new name and editing its properties.

• Rename: Click this button to rename the currently selected zone category.

• Delete: Click this button to remove the selected zone category from the project.

See Delete and Replace Attributes in a Model.

Zone Stamp pop-up: Choose a Zone Stamp for use with this zone category. Zone Stamps are GDL objects. 

From the pop-up, choose one of the zone stamps from your loaded library.

Color: Choose a color for the selected Zone Category. By default, all zones belonging to this category will be 

displayed in this category color in the project.

A preview window helps you visualize the zone stamp parameters.
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2D Display of Zone Backgrounds 

By default, zone backgrounds are displayed in the color of their zone category.

See Zone Categories.

If you like, you can assign a different Zone fill using any cover fill.

1. Go to the Floor Plan panel of Zone Settings.

2. Activate the Cover Fill icon at the left.

3. Choose a fill pattern from the fill pop-up menu.

If you have assigned a Zone fill, it will be displayed in Floor Plan by default.

Note: Zone backgrounds (and other fills) can use Graphic Overrides.

See Graphic Override Rules.

Display of Zones with Slanted Walls

Zones bounded by one or more slanted walls will accurately consider the slanted geometry. Such zones are 

displayed on the Floor Plan with two separate zone polygons: 

• the polygon with editable selection dots, which delimits the visible part of the zone on the Floor Plan (while 

you can edit this polygon, such editing has no effect on the true 3D zone), and

• the polygon with regular selection dots, which indicates the true extent of the base of the 3D zone (you 

cannot edit the zone shape by editing this polygon.)
ARCHICAD 24 Reference Guide 974



Construction Elements Elements of the Virtual Building
Zone Stamps

Zone stamps are intelligent parametric GDL Objects whose look, contents and behavior can be fitted to local 

architectural practice. They reside in the ARCHICAD Library.

The zone stamp object assigned to your zone depends on the Zone Category you have chosen.

See Zone Categories.

Each zone stamp contains textual information about the zone, including its name, number, area, and other 

optional parameters; the exact content of your Zone Stamp depends on the parameters you set in the Zone 

Stamp Panel of Zone Settings.

See Zone Tool Settings.

Note: To set the units for the Zone Area display on this Zone Stamp, use Options > Project Preferences 

> Dimensions, and select Area Calculation units.

2D Display of Zone Stamps

Zone stamps are displayed by default on the Floor Plan.

If you do not wish to display any zone stamps in the project, uncheck the Show Zone Stamp box in 

Document > Model View > Model View Options (Construction Element Options panel).
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Moving Zone Stamps

Zone Stamps can be moved independently of the Zone:

• Click on a node of the Zone stamp.

• Choose the Move Sub-Element icon from the pet palette.

• Drag the Zone Stamp to the desired location.
ARCHICAD 24 Reference Guide 976



Construction Elements Elements of the Virtual Building
3D Display of Zone Spaces

To view zone spaces in 3D:

Go to View > Elements in 3D View > Filter and Cut Elements in 3D and make sure the “Zone” checkbox is 

selected.

Use the Model Panel of Zone Settings to choose a Surface for the Zone in 3D.

See Zone Model Panel.

Note: You may wish to display 3D Zones as solid bodies in shading mode, and all other elements types in 

wireframe mode. To achieve this effect, apply the predefined “Show 3D Zones as Solid” Layer 

Combination.
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Crop Zone to Another Element

Zone spaces can be cropped to single-plane roofs, slabs and beams with the Design > Roof Extras > Crop 

Zone command.

You can either select an element (Roof, Slab, Wall, Column, Beam, Curtain Wall or Library Part) and crop a 

Zone to it if the element protrudes into the Zone, or select a Zone and then choose which element types to 

crop it to.

Note: Zone space will be cropped by any multi-story element with which it intersects, on any story.

Note: The Crop Zone command can crop to single-plane roofs only. If you have a multiplane roof, you 

can use the associative trim function instead.

See Trim Elements to Roof or Shell.

When cropping a zone to a single-plane roof, a checkbox gives you the option of ignoring holes (that is, to 

include any hole in the roof as part of the roof for the purposes of a zone boundary.)

You can choose between cropping the base or the top of zone spaces. Check the corresponding boxes to 

define which elements you wish to crop to the zone.

The crop will be executed by clicking the Crop button in the dialog box.

If you select only one type of cropping element in the project (e.g. Roof), all the checkboxes are grayed.

Zone space crops can be undone by selecting the cropped zone space and pressing the Undo All Crops 

command from the selected Zone’s context menu, or at Design > Roof Extras.

Note: You can also opt to undo the Crop when updating modified Zones.

For more information, see Updating Zones.
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Calculating Zone Area and Zone Volume

Zone area and volume calculation depends on several different settings:

• Relation to Zones options chosen for Walls, Columns, and Curtain Walls, which can affect the Zone’s 

area and/or volume

• Zones Preferences, at Options > Project Preferences > Zones, containing global controls for 

calculating Door/Window recesses in Walls, and for refining the area calculation of Walls or Columns in 

some cases

• The Area Calculation Panel of Zone Settings, which allows you to check the measured area of the Zone 

and refine the calculated values.

Note: To see the effect of any changes in Zone calculation settings, you must execute the Design > 

Update Zones command.

See Updating Zones.

Related Topics

Relation to Zones

Zone Area Calculation Panel

Zones Preferences
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Relation to Zones

This setting is available for Walls, Curtain Walls, and Columns. It is relevant if the element is located within a 

Zone polygon: Zone area calculation depends on the element’s Relation to Zones setting. That is: should the 

Zone area include or exclude the area of this element?

For each Wall, Curtain Wall and Column, define its Relation to Zones using the pop-up in Element Settings.

• for Walls: use the Model Panel

• for Columns: use the Positioning Panel

• for Curtain Walls: use the Member Placement Panel of Curtain Wall System Settings

Note: To see the effect of any changes in Zone calculation settings, you must execute the Design > 

Update Zones command.

See Updating Zones.
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Zone Boundary

A Wall or Curtain Wall inside the Zone, if set to “Zone Boundary”, delimits the zone. Thus, the Zone boundary 

extends up until the Wall/Curtain Wall. If the Wall/Curtain Wall is slanted, the zone’s geometry is slanted 

accordingly.

• The Wall/Curtain Wall, if located inside the zone area, is not included in the Measured Area (Zone 

parameter).

• A vertical Column set to “Zone Boundary” is not included in the Measured Area (Zone parameter).

• A slanted Column cannot be set to “Zone Boundary”. For a slanted Column, use the Subtract from Zone 

setting.

Vertical Column Set to “Zone Boundary”: Excluded from Measured Area (Zone Listing Parameter)

Note: Any line-type element can also be set as “Zone Boundary” in its Settings dialog box. Such a line 

acts as a 2D delimiter of the zone.

 Reduce Zone Area Only

• Area of the element is excluded from the Measured Area

• Volume of the element is included in the Zone volume

Note: If you have set a Wall or Column to “Reduce Zone Area”, you may prefer to ignore this setting for 

very small-sized walls or columns. To set the minimum limit for excluding such walls and columns, go to 

Options > Project Preferences > Zones.

To see how much of a zone’s area has been reduced due to Wall/Column reduction, select the zone and 

view the data in the Area Calculation Panel of Zone Settings.

Subtract from Zones

• Area of the element is subtracted from the Measured Zone Area and the Net Area. Unlike the Zone 

Boundary setting, this setting is available for slanted Columns.

• Volume of the element is subtracted from the Zone volume
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Slanted Column Set to “Subtract from Zones”: Excluded from Measured Area (Zone Listing Parameter)

No Effect On Zones

The element has no effect on zone calculation: the zone area and volume will include the area and volume 

occupied by the element.

Example

In this example, the zone area is 100 square meters, with a height of 2.70 meters. The zone includes a square 

1-meter Column.
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Related Topics

Zone Area Calculation Panel

Zones Preferences

Relation to Zones Measured Area Volume

Zone Boundary 99 m2 267.3 m3

Reduce Zone Area Only 99 m2 270 m3

Subtract from Zones 99 m2 267.3 m3

No Effect on Zones 100 m2 270 m3
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Updating Zones

When you modify your design, automatically created zones do not automatically adjust themselves to the 

changes, so they may require you to use the Update Zones command.

To adjust Zones to your updated design and recalculate the Zone area:

Go to Design > Update Zones. This dialog lists the Zones in your project. Selecting a Zone in the list selects 

it in the project, and vice versa.

• If any Zone is selected, click Update Selected Zones.

• If none is selected, click Update All Zones.

Successfully updated Zones are shown with a checkmark, with the added (or subtracted) zone area resulting 

from the update.
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Possible Status Problems when Updating Zones

Icons in the Update Zones dialog box alert you to any problems:

• The Zone was created manually and cannot be automatically updated.

• The layer on which the Zone resides is locked. Unlock the layer in the Layer Settings dialog box and 

repeat the update process.

• As a result of the changed model (e.g. moved Wall), the automatically created Zone is no longer 

surrounded by a closed polygon, and can’t be updated. 

Check the Zone by selecting it in the list, and clicking the Zoom to Selected Zones button. Fix the problem 

and repeat the update process.
ARCHICAD 24 Reference Guide 985



Construction Elements Elements of the Virtual Building
Curtain Wall

Create a Curtain Wall in the Floor Plan, Section/Elevation/IE, or 3D window.

Related Topics:

Working with Curtain Walls: Overview

Curtain Wall Components

Curtain Wall Frames

Curtain Wall Frame Settings

Curtain Wall Panels

Place Door- or Window-Type Panel in Curtain Wall

Curtain Wall Panel Settings

Curtain Wall Scheme Settings

Set up Grid Pattern in Scheme Settings

Create Grid Pattern Graphically

Curtain Wall Input Methods

Model View Options for Curtain Walls

Curtain Wall Edit Mode

Edit Grid and Grid Lines in Edit Mode

Graphical Editing of Curtain Wall

Add Additional Curtain Wall Boundary

Curtain Wall Junctions

Curtain Wall Accessories

Curtain Wall System Settings

Curtain Walls and Other Elements
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Working with Curtain Walls: Overview

The Curtain Wall is a single element consisting of Frame, Panel, Accessory and Junction components: these 

are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined and editable 

Scheme.

The Base Surface can be planar or spherical; other curves are not supported.

To control the whole hierarchy at once, use Curtain Wall System Settings to define the overall scheme and 

configure the Curtain Wall members. 

Creating a Curtain Wall involves a simple graphical input. Activate the Curtain Wall tool, choose a geometry 

method, and then draw a reference line, polyline, contour or arc.

If you use the Boundary method, then your input defines the entire geometry of the Curtain Wall.

If you draw a Reference Line/Arc/Polyline, then the Curtain Wall will be extruded from this line/polyline/arc. 

For details on Curtain Wall geometry methods in different windows, see Curtain Wall Input Methods.

Curtain Walls consist of a set of Members (such as Frames, Panels and Junctions). Each Member’s 

parameters are defined on its respective page in Curtain Wall Settings.

See Curtain Wall Components.

You can edit the Curtain Wall at two levels: 

System-Level Editing

Select the Curtain Wall; open Curtain Wall Settings; and edit any of its System-level settings again.

Click OK to redefine the Curtain Wall according to the modified settings.

See Curtain Wall System Settings.

Edit Individual Curtain Wall Members

Select the Curtain Wall; go into Edit mode.

See Curtain Wall Edit Mode.

In Edit mode, you cannot place additional Curtain Walls, but you can edit any members of the selected Curtain 

Wall or add additional members to it. In Edit mode, each member (Scheme, Frame, Panel, Accessory, 

Junction) has its own Dialog box and its own Tool, enabling you to change settings and place new Members in 

this Curtain Wall.

To customize the settings of any member of the Curtain Wall, select it and use the dialog box to change its 

settings. For example, select a panel and change its surfaces. Changing the settings of a selected member 

will transform that member into a “Custom” member. You can have any number of different customized 

members. Once a member has Custom settings, the System-level settings no longer apply to it.
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In Edit mode, you can create additional members for your Curtain Wall, using the Scheme, Frame, Panel, 

Junction and Accessory Tools. When using any of these tools to create a new member, you have the choice of 

using the System-level default settings, or else defining custom settings.

Additional Curtain Wall Commands

The Design > Modify Curtain Wall menu contains a collection of commands which are specific to Curtain 

Wall functions. These functions are described elsewhere in this documentation.
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Curtain Wall Components

Reference Line

The Reference Line is the original input line/polyline/arc you draw in the window. If you use a Boundary 

method to create a Curtain Wall, the first drawn segment of the Boundary is the Reference Line.

You can Flip the Curtain Wall orientation relative to the Reference Line, using the Flip command in the Info 

Box.

The Reference Line is part of the Curtain Wall Scheme (together with the Scheme Grid pattern, the Boundary, 

and the Base Surface.)

Later, you can edit the Reference Line of a placed Curtain Wall.

See Edit Curtain Wall Reference Line.

Reference Surface

The Reference Surface is an imaginary plane or arced surface automatically created by ARCHICAD by 

extruding the input line (polyline, arc) you have drawn. Often, you will place your input line along an existing 

ARCHICAD element (e.g. slab); the Reference Surface is extruded from this input line.

Base Surface

The Base Surface defines the shape and orientation of the Curtain Wall. It is the surface in which the physical 

members of the Curtain Wall (Frame, Panels) lie. The Base Surface may coincide with the Reference Surface; 

more likely, you will offset it. When you move or rotate the Curtain Wall as a whole, it is the Base Surface 

which you are moving; the Reference Line and Reference Surface move along with the Base Surface.

The Base Surface of Curtain Walls is an infinite plane - except if it is based on a curved shape. (The Base 

Surface of a curved Curtain Wall is cylindrical, and is infinite only in the direction of the cylinder’s axis.)

A Curtain Wall’s infinite Base Surface gives you great freedom in connecting the Curtain Wall to other 

elements, and in adding multiple, bounded Curtain Wall portions to any Curtain Wall.

See Add Additional Curtain Wall Boundary.
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Boundary

The Boundary is a simple polygon on the Base Surface, which represents the physical limits of the Curtain 

Wall.

The Boundary is part of the Curtain Wall Scheme (together with the Scheme Grid, the Base Surface and the 

Reference Line).

Depending on the geometry method used to create the Curtain Wall, the Boundary is either drawn by you or 

created by ARCHICAD in accordance with input parameters.

You can draw additional boundaries on an existing Curtain Wall - this gives you freedom to separate the 

Curtain Wall into parts, while still keeping it as a single element: all parts of the Curtain Wall use the identical 

Scheme.

See Add Additional Curtain Wall Boundary.

The Curtain Wall’s Boundary Frame always coincides with this Boundary polygon.

You can edit the Boundary of the Curtain Wall like any other polygon.

Scheme

The Scheme contains the essential geometry definitions (Base Surface, Scheme Grid, Reference Line) of the 

Curtain Wall.

Use Scheme Settings to arrange the grid line pattern in two directions (“row” and “column”). The Scheme also 

defines the classes to which frames and panels within this basic pattern belong.

See Curtain Wall Scheme Settings.

All other members of the Curtain Wall (Frames, Panels, Accessories, Junctions) are attached to the Scheme.

Scheme Grid

The Base Surface is crisscrossed by a Scheme Grid (grid lines in rows and columns, defined as part of the 

Curtain Wall Scheme.) 

The Scheme Grid defines the default location and arrangement of Frames and Panels in the Curtain Wall. You 

can edit the Scheme Grid (delete, add grid lines, move or rotate it). Changes to Scheme Grid geometry will 

change the geometry of its Frames and Panels accordingly.

See Edit Grid and Grid Lines in Edit Mode.
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Frame

Each Frame class (e.g. Boundary, Mullion, Transom, or any other user-defined class) has unique settings. 

Frames are attached to the Scheme Grid when you create the Curtain Wall, so if you move or delete a Grid 

Line, you move or delete the Frame. (In Curtain Wall Edit mode, you can place additional Frames 

independent of the Scheme Grid.)

See Curtain Wall Frames.

Panel

Panels are the flat surfaces - generally glazed - of the Curtain Wall. Curtain Walls have two predefined 

classes: Main and Distinct, plus any user-defined Panel classes. Panels are always placed between Frames.

See Curtain Wall Panels.

Junction

A Curtain Wall Junction is an optional structure that serves to connect panels to the Frame. In ARCHICAD, a 

Junction is a GDL object, and can be placed either one by one, or automatically at every intersection.

See Curtain Wall Junctions.
ARCHICAD 24 Reference Guide 991



Construction Elements Elements of the Virtual Building
Accessories

Accessories are optional, non-load-bearing members - such as a sun shade - attached to the Curtain Wall. 

These are GDL objects placed at any Frame of an existing Curtain Wall.

See Curtain Wall Accessories.
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Curtain Wall Frames

Frames are placed along the Scheme Grid when you create the Curtain Wall.

The Curtain Wall’s pattern of Frames and Panels can be defined in Scheme Settings. (See Set up Grid 

Pattern in Scheme Settings.)

• A Frame must be joined to another Frame at both ends (it cannot “float” independently).

• A Frame with adjoining Panels always divides two separate Panels (it cannot bisect a single Panel).

• In a multi-segment (Chained) Curtain Wall, a Frame is always placed where two adjacent Curtain Wall 

segments meet. Such a Frame cannot be deleted, although you can make it invisible.

• A Boundary Frame cannot be renamed or removed. The edges of a Curtain Wall always use a Boundary 

Frame.

Frame Classes

Edit Curtain Wall Frames

Add New Frame to Curtain Wall

Copy Cell Pattern in Curtain Wall

Curtain Wall Frame Intersections

Curtain Wall Corner Frames

Corner Frames: Complex Profiles

Create Common Frame for Overlapping Curtain Walls

Curtain Wall Frame Settings

 Frame Classes

By default, a Curtain Wall has four classes of Frames: Corner, Boundary, Mullion and Transom. 

You can also create other Frame classes: see Curtain Wall Frame Settings.

• Boundary Frames are placed along the Curtain Wall Boundary.

• Mullion and Transom Frames are placed along either the Columns or Rows of the grid lines

• Division Frames are invisible, but they serve to divide panels (they can replace a deleted Frame). See 

“Division” Frame Class.

In this image, the Frames in the Boundary class are red; the Frames in the Mullion class (coinciding with the 

grid columns) are blue; and the Frames in the Transom class (coinciding with the grid rows) are green.
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Edit Curtain Wall Frames

1. Select the Curtain Wall.

2. Enter Edit mode.

3. Select a Frame.

4. Do any of the following:

• Open Frame Selection Settings and change them

• Stretch, Drag, Mirror, Rotate or Multiply the Frame

• Delete the Frame

Notes: 

– Deleting a Frame is only possible if the two panels on either side of the Frame are both in the same 

plane. On a non-planar Curtain Wall surface, you must first delete the grid line which runs between 

them. The Frame is deleted along with the grid line.

– If you move or delete a grid line, you move or delete the Frame. 

See also Multi-selection of Frames and Panels.

Add New Frame to Curtain Wall

1. To add an additional Frame, enter Curtain Wall Edit mode.

2. Activate the Frame Tool. 

3. Use the Info Box to define the Frame type and the Frame class whose parameters it should use (e.g. 

Mullion).

4. Draw a new Frame on the Curtain Wall in Edit mode.
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• If you draw the Frame on a Grid line, then the Frame will be attached to the grid line. Moving the Scheme 

Grid will move the Frame.

• If you draw a new Frame that crosses an existing grid line, the Frame will be cut into multiple Frames 

automatically where it crosses the grid line.

Copy Cell Pattern in Curtain Wall

To copy the Frame pattern of any cell in the grid to another cell: 

1. Make sure you are in Curtain Wall Edit mode, with the Frames visible.

2. Use Design > Modify Curtain Wall > Copy Cell Pattern.

3. Click in the cell whose Frame pattern you wish to copy.
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4. Click in the cell to which to copy the Frame pattern. The Frame pattern is duplicated.

Curtain Wall Frame Intersections

When two or more Frames meet in a Curtain Wall, the Frame with the higher intersection priority will cut the 

other one.

Note: While a Curtain Wall Frame does have a Building Material, the Building Material’s intersection 

priority is ignored in this case.

Frame Priorities are defined for each class on the Frames page.

However, you can change the intersection priority of any single selected Frame. In Curtain Wall Edit mode, 

select the Frame whose intersection priority you want to change. Go to Frame Selection Settings and adjust 

the slider to the desired level. Changing the Frame’s intersection level - as when changing any other Frame 

parameter - will result in a Custom Frame.
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Curtain Wall Corner Frames

Corner Frames are a separate Frame Class. You cannot rename or remove the Corner Frame class.

When you place a Curtain Wall with multiple segments, the Frame used by the Corner Frame class is placed 

at the place where each segment joins the next one. (Corner Frames are not placed at curved segments.)

You can technically choose any Curtain Wall Frame as your default Corner Frame, but the ARCHICAD library 

includes specific Corner Frame objects, such as:

• Regular Double Frame with Cap

• Regular Double Butt-Glazed Frame

• Block Frame with Cap

• Block Butt-Glazed Frame

• Diagonal Butt-Glazed Frame
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• Diagonal Frame with Cap

Depending on the selected Corner Frame type, set options and variations in Curtain Frame Settings:
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Each Corner Frame uses separate building materials for its components: Frame, gasket and panel, where 

applicable. You can override surfaces for each as needed.

Corner Frames: Complex Profiles

By default, ARCHICAD includes Profile Corner Frames. You can create custom Profile Frames using the 

usual methods in Profile Editor. Note that the predefined Profiled Frames include a user origin which ensures 

the expected behavior for these Frames if the Curtain Wall geometry changes.

See Profile Origin in Profile Editor Window
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Create Common Frame for Overlapping Curtain Walls

If two Curtain Walls’ Schemes join or overlap, use this command to clean up the join/overlap. One of the two 

overlapping Frames will be transformed into a corner-like Custom Frame, and the other will be transformed 

into an Invisible Frame.

Select both Curtain Walls and use Design > Modify Curtain Wall > Create Common Frames (or the same 

command from the context menu).

Choose the preferred orientation for the common frame (mitered or parallel to an existing frame).
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Curtain Wall Frame Settings

The Frames page of Curtain Wall Settings contain the settings for each Frame Class. 

Frame Tool Settings (in Edit mode) contains nearly identical controls. 

List of Frame Classes

The top of the dialog lists the available Frame classes, by name and type. By default, Frame classes include: 

Corner, Boundary, Mullion and Transom.

The selected class is highlighted in the preview window. The preview window also displays the Frame’s 

surface color.

Add Frame Class

1. Click the Add button.
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2. In the appearing dialog:

• New: Creates a new Frame class based on the default Frame (e.g. Built-in)

• Duplicate: Duplicates the currently selected Frame class under a new name

• Favorite: Click the popup to choose a Frame Favorite: the new Frame class will use these Favorite 

definitions.

Add Frame Class Based on Customized Frame (Edit Mode)

Another way to create a new Frame Class is to customize a single Frame in Edit Mode, then save its settings 

as a new Frame class.

1. Select the Curtain Wall and enter Curtain Wall Edit mode.

2. Select a Frame to customize it. Its class is now “Custom.”

3. From the Frame Class popup in the Info Box, click Add Frame Class from Custom...

4. Use the upcoming dialog to create a new Frame class.

Rename Frame Class

Double-click the Class in the list, and rename as needed.

Copy-Paste Frame Settings Between Classes

In Frame Settings, right-click the name of any Frame to copy its settings. 
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Right-click any other Frame to insert the copied settings for that Frame.

Remove Frame Class

1. Select one or more Frame Classes to remove.

2. Click Remove.

Note: The Boundary and Corner Frame classes cannot be removed.

3. In the appearing dialog:

• Choose how to convert the Frames in the class that is being removed:

– None: Merge Panels: Frames will be deleted, and the adjoining panels merged together.

– Division: Frames will be deleted, but the adjoining panels will remain divided.

– Convert to Another Frame Class: Choose another, existing Frame Class.

“Division” Frame Class

Division Frames are a predefined class, with fixed settings. They function as an invisible Frame; the adjoining 

Panels remain divided. You cannot edit Division Frames on this page; this class cannot be deleted.
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Division Frames are available 

•  as an optional replacement whenever you delete a Frame Class (replace the deleted Frames with a 

Division), and

• in Scheme Settings, as a Frame class option for a selected Frame in the Grid Pattern

Select Frame Type and Geometry

For the Class selected in the list at the top of the dialog: choose a Frame Type from the pop-up list, in the 

Frame Type and Geometry panel.

Then set its geometric parameters as applicable.

• Invisible Frame: This Frame exists as an object, but it is not visible. 

– Use this Frame if you want two neighboring panels to remain separate, but without displaying a Frame 

between them.

– Set an optional gap between the two adjoining Frames. 

– Invisible Frames are also appropriate when you don’t want to burden the model with the Frame 

details, or when other structures (e.g. junctions) are used to support the panel connections. A 

seamless panel surface can be achieved if Frames are deleted from grid lines.

• Built-in Frame: This is the most common type of Frame, with a rectangular profile. From the outside of 

the wall, a “cap” is visible. Assign its Building Material in Frame Settings (the panel below).

• Butt-Glazed: A rectangular profile, used for inner support of a butt-glazed Curtain Wall surface. The 

panels will connect to each other in the front of a butt-glazed Frame, so the Frame will not be visible on 

that side (unless the panels are transparent or a gap is specified.) Assign its Building Material in Frame 

Component Settings (the panel below).
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• Modular Frame: Add an additional module to this Frame: a custom-created frame or cap profile object 

that you draw and save as a specialized component.

See Example: Create Custom Frame or Cap Profile for Curtain Walls.

See also Curtain Wall Corner Frames.

Frame Intersection Priority

See Curtain Wall Frame Intersections.

Frame Component Settings

For the chosen Frame type, you can set various parameters, as usual for GDL-type components.

Note that you can override the Model View Options settings for its 2D and 3D Detail Levels, as applicable.
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Curtain Wall Panels

Panels are the flat surfaces - generally glazed - of the Curtain Wall. Panels are automatically placed between 

Frames and onto the Base Surface. 

A Curtain Wall has two predefined classes of panels, Main and Distinct. However, you can add more Panel 

classes as needed: see Curtain Wall Panel Settings.

Panel Classes and their properties (type, surface, width) are defined in Curtain Wall Panel Settings. 

The Curtain Wall’s pattern of Frames and Panels can be defined in Scheme Settings. (See Set up Grid 

Pattern in Scheme Settings.)

Most of your Curtain Wall panels will be “fixed” glazed surfaces. However, you can insert object-type Panels 

which serve as Door or Window openings.

When a Panel is selected in Edit mode, you can

• Open Panel Selection Settings and change them

• Delete the Panel

• Edit its parameters to create a Custom Panel class

• Create a new, named Panel Class based on a customized Panel

Related Topics:

Place Door- or Window-Type Panel in Curtain Wall

Curtain Wall Panel Settings
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Place Door- or Window-Type Panel in Curtain Wall

You can place a GDL-based panel which behaves like a window or a door. Some of these are predefined in 

ARCHICAD and are listed in the Type pop-up list in the Panel Type and Geometry panel:

Even though these Curtain Wall Panels function as Doors or Windows, they do not use Door/Window 

Markers. However, you can use the Label tool to place a Curtain Wall Panel Label.

See Labeling Curtain Walls.

You can define opening-type Panels as part of the Curtain Wall’s pattern, using Scheme Settings. (See Set up 

Grid Pattern in Scheme Settings.)

In an already placed Curtain Wall, use Edit Mode to replace regular panels with Door- or Window-Type 

panels, as described below.
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To place a door-type panel into a Curtain Wall: 

1. Select the Curtain Wall and go into Edit mode.

2. At the place where the Door should go, merge two existing panels by deleting the Frame between them:

3.  Select the newly merged panel.
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4. In the Info Box, from the Member Type pop-up, select the desired Door Type. (You can narrow the choices 

by name, by typing “Door” into the search field.)

The selected panel is replaced with a door-type panel, which you can open and close like other GDL 

doors. 

Note that this door-type Panel object has an editable parameter called “Top Direction.” This lets you 

redefine the “top” of the door by 90 degree increments in case you later free-rotate the Curtain Wall and 

the “top” of the door changes its position.
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Curtain Wall Panel Settings

The Panels page of Curtain Wall Settings contain the settings for each Panel Class. 

Panel Tool Settings (in Edit mode) contains nearly identical controls. 

List of Panel Classes

The top of the dialog lists the available Panel classes, by name and type. 

Panel Classes are user defined (or provided by default - e.g. Main, Distinct). New Panel classes can be added 

or removed.

The selected class is highlighted in the preview window. The preview window also indicates the Panel’s color.
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You can add or delete Panel classes - see below.

Add Panel Class

1. Click the Add button. In the appearing dialog:
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• New: Creates a new Panel class based on the default (e.g. Built-in)

• Duplicate: Duplicates the currently selected Panel Class under a new name

• Favorite: Click the popup to choose a Panel Favorite. The new Panel class will use the Favorite settings.

Rename Panel Class

Double-click the Class in the list, and rename as needed.

Copy-Paste Panel Settings Between Classes

In Panel Settings, right-click the name of any panel to copy its settings. 

Right-click any other panel to insert the copied settings for that panel.

Add Panel Class based on a Customized Panel

Another way to create a new Panel Class is to customize a single Panel in Edit Mode, then save its settings as 

a new Panel Class.

1. Select the Curtain Wall and enter Curtain Wall Edit mode.

2. Select a Panel to customize it. Its class is now “Custom.”

3. From the Panel Class popup in the Settings dialog or Info Box, click Add Panel Class from Custom...
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4. Use the upcoming dialog to name the new Panel class.

Remove Panel Class

1. Select one or more Panel Classes to remove.

2. Click Remove.

3. In the appearing dialog:

• From the popup, choose how to convert the Panels in the class that is being removed:

– Deleted Panel

– Convert to Another Panel Class: Choose an existing Panel Class.
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Select Panel Type and Geometry

For the Panel Class selected in the list at the top of the dialog: choose a Type from the pop-up list, in the 

Panel Type and Geometry panel.

Then set its geometric parameters as applicable.

• Some Panels are designed to behave like doors and windows.

See Place Door- or Window-Type Panel in Curtain Wall.

See also Create Custom Components for Doors, Windows, Curtain Wall, Stair, Railing.

Available settings in the panel below depend on the chosen Panel type.
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Panel Component Settings

For the chosen Panel type, you can set various parameters, as usual for GDL-type components.

Note that you can override the Model View Options settings for its 2D and 3D Detail Levels, as applicable.
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Curtain Wall Scheme Settings

This is a page of Curtain Wall Settings. Use these controls to define the pattern of the Curtain Wall Scheme 

Grid, by columns and rows. You can also set the class of any or all Frames and Panels here.

This section reviews the controls of the Scheme Settings page. For details and examples of Grid Pattern 

setup, see Set up Grid Pattern in Scheme Settings.

Topics in this Section:

View/Edit Pattern in Preview Window

Select Frame or Panel in Preview Window

Set Frame or Panel Class

Edit Panel Size

Add/Delete Row or Column

Scheme Width/Height

Add Crossing Frame

Clear Pattern
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View/Edit Pattern in Preview Window 

The preview window displays one unit of the Curtain Wall pattern, consisting of Frames and Panels. The 

pattern shown here will be repeated horizontally and vertically within the Curtain Wall boundary, when it is 

placed in the project.

See details and examples at Set up Grid Pattern in Scheme Settings.

The Grid pattern’s precise starting point, and the logic by which it should be repeated, are defined in the 

Pattern Origin panel of this Scheme Settings dialog.

Select Frame or Panel in Preview Window

Click on any Frame or Panel in the Preview: the clicked item is highlighted and a tag displays the item’s class 

(e.g. Distinct Panel). 

For a selected Panel, its position by Column and Row is also highlighted at left. 

Here, the selected Panel is in the Distinct Class. The Panel is located in Column A, Row 3.

• Use shift-click to multi-select items in the Preview (i.e. when modifying a Frame or Panel class). In this 

case, the first-selected item is highlighted at left.
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• Use the shortcut multi-select buttons at bottom right to select all the Frames or Panels in the same 

column (vertically) and/or the same row (horizontally) as the selected one:

Shortcuts: Multi-Select Panels and Frames
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Set Frame or Panel Class

Use the pop-up below the Preview to change the selected Panel’s or Frame’s class, if needed.

Panel and Frame Classes are defined on the corresponding pages (Frames/Panels) of Curtain Wall Settings 

(where you can also define new classes as needed.) 

To access these pages from here, click the “Go to Settings” button.

Edit Panel Size

Enter values for the width and height of selected Panel(s). Notice how the Preview image changes 

accordingly.
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Add/Delete Row or Column

To create a new Column or Row of Panels, or to delete a selected one, click the Plus/Minus sign.

The new Column/Row duplicates the currently selected one, and is inserted in front of it.

Rotation

Enter a Rotation value for the Rows of panels, relative to the Columns.
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Note: Rotation angle will not be reflected in the Preview window.

Scheme Width/Height

These values indicate the width and height of the Scheme Grid pattern. The placed Curtain Wall, depending 

on its final width and height, will repeat this Scheme pattern as many times as needed, and based on the logic 

defined in the Pattern Origin panel.

See details and examples at Set up Grid Pattern in Scheme Settings.

Add Crossing Frame

1. In the Scheme Preview, click on a Panel.

2. Click a Crossing Frame icon to add it.

Limitation: One diagonal frame per pattern cell. 
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Clear Pattern

In the upper corner of the Preview window, click the X button to clear all Frames and Panels. This results in a 

Curtain Wall with an empty Boundary.
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Set up Grid Pattern in Scheme Settings

Use the Scheme page of Curtain Wall Settings to set up a Grid pattern in advance, before you place the 

Curtain Wall.

Note: Another approach is to place an empty Curtain Wall boundary and define the pattern graphically. 

See Create Grid Pattern Graphically.

There are three main Pattern Distribution options for both rows and columns: 

• Fixed Size

• Best Division

• Number of Divisions

Each logic is described below.

Topics in this Section:

Fixed-Size Rows and Columns

Define Infill for the “Leftover” (Fixed Size Row and/or Column)

“Best Division” Pattern Distribution

Set Number of Divisions

Pattern Origin (for Fixed Size patterns)

End with (Column/Row)
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Fixed-Size Rows and Columns

For the Scheme’s Rows and/or Columns: choose the Fixed Size option. (This Pattern Distribution logic is the 

same as in pre-22 versions of ARCHICAD. Set each Column width and/or each Row height to an exact size.)

The resulting Curtain Wall in 3D, with fixed-size rows and columns:

The fixed pattern is repeated to the extent of the Boundary and then cut off.
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Define Infill for the “Leftover” (Fixed Size Row and/or Column)

If either Columns or Rows is set to Fixed Sizes, use the “Infill with” control to define what to do with the 

“leftover” inside the Boundary, if the end of the pattern does not coincide with Boundary.

• Partial Pattern cuts off the pattern where it falls, at the end of the Curtain Wall Boundary.

• Or choose a Panel class: the leftover segments (in the horizontal and/or vertical directions) will be filled in 

with this panel type.

• The Pattern Origin setting affects the arrangement of the Infill (see examples below).

Examples of Infill Settings 

This Curtain Wall uses a Grid pattern with fixed-size columns and rows:

Curtain Wall Grid Pattern

See what happens with various Infill and Pattern Origin settings. 
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The blue line represents the Curtain Wall Boundary. 

The red dashed line represents the repeated pattern.

Infill with: Partial Pattern

Pattern Origin: Left Bottom

Infill with: Distinct Panel

Pattern Origin: Bottom Left
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Infill with: Distinct Panel

Horizontal Pattern Origin: Align to Center

Vertical Pattern Origin: Bottom

Infill with: Distinct Panel

Pattern Origin: Align to Center (both directions)

“Best Division” Pattern Distribution

With this logic, the Curtain Wall pattern will exactly coincide with the end of the Curtain Wall segment, without 

any “leftover”. 

For the Scheme’s Rows and/or Columns: choose the Best Division option.

• Set each Column width and/or each Row height to the desired size, then use the lock icons for each Row/

Column to set whether its size should be fixed, or flexible.

• At least one Row or Column must be set to flexible. This means it might be stretched or shrunk relative to 

the size you entered. 

• If you set a value to “flexible”, the resulting Row or Column will be sized as close as possible to this value. 

Several flexible values (e.g. two flexible column widths of 300 and 600) will maintain their relative sizes - 

that is, one flexible column will always be twice the width of the other. 
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As you input a Best-Division Curtain Wall, the feedback shows you that the column and row patterns are 

automatically distributed evenly.
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Use the “End With” control here, to use a different panel in the last column:

Best Division (End with Column B)

Best Division (End with Column A)

To get feedback on how the flexible row or column (e.g. Column A set to 900 mm, flexible) was actually sized 

in the resulting Curtain Wall:

go to Curtain Wall Selection Settings, and switch the pattern to “Fixed Sizes” to see the value (here, Column A 

is actually 945 mm).
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Set Number of Divisions

Use this option to specify that the pattern be repeated a fixed number of times within the Curtain Wall 

segment.

You must set at least one row/column to have a flexible size, to allow it to stretch.

Here, all the rows and columns are flexible. No matter how high and how wide the Curtain Wall is drawn, the 

pattern (three rows by three columns) will be repeated exactly once.

End with (Column/Row)

For both Columns and Rows, choose one to end the pattern with.

For example: Your pattern contains two column types - A and B.
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Set End Column to B. 

When you place the Curtain Wall, the AB pattern will be repeated using their fixed sizes, but the segment’s 

last column will be the B column. (followed by the Infill, if applicable).

End Pattern with Column B
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End Pattern with Column A - Then the Infill
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Pattern Origin (for Fixed Size patterns)

The Pattern Origin definition locks the origin of the grid pattern (in both the horizontal and vertical directions) 

to a specific point on the Curtain Wall segment, plus or minus an optional offset.

Consult the tool tips and icons to pick the one you need. 

Note: Pattern Origin controls not available if the row/column logic is set to “Best Division” or “Number of 

Divisions”.

Horizontal Pattern Origin

• Origin at the start of the segment

• Origin at the middle of the segment. The horizontal pattern will begin at the center of the segment, and will 

be distributed outward in both directions. (The center of the Curtain Wall will always have a vertical 

gridline running through it.)

• Pattern midpoint is at the segment midpoint

• Origin at the end of the segment

Vertical Pattern Origin

• Origin at the bottom of the segment

• Origin at the middle of the segment

• Pattern midpoint at the segment midpoint

• Origin at the top of the segment

See Examples of Infill Settings for illustrations.
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Create Grid Pattern Graphically

Use this workflow to graphically create a custom Curtain Wall grid pattern, in the 3D or Section-type window 

(using Edit mode).

Note: Another approach is to predefine the pattern in Curtain Wall Scheme Settings before placing the 

Curtain Wall. See Set up Grid Pattern in Scheme Settings.

Place Frames and Panels in any pattern of Frames and Panels on the Scheme Grid. Then activate the 

Pattern box, and use it to define the extent of the pattern. The pattern will be automatically repeated within the 

Curtain Wall segment. 

See the detailed workflow below.

1. Place a new Curtain Wall without any Frames or Panels. 

• Use the Curtain Wall Scheme Favorite “Empty” or “Empty with Grid”. (For a curved Curtain Wall, use 

“Empty with Grid”.)

or draw a Curtain Wall Boundary in Section view. 

2. From the 3D window or Section view, open the Curtain Wall in Edit mode.
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3. From the Edit mode display menu, make sure the Scheme Grid is visible.

4. Use the Frame and Panel tools to draw Frames and place Panels in any pattern, anywhere within the 

Boundary. (To place a Panel, activate the Panel tool and click inside a Frame.)

Note on Temporary Frames

All Frames must be connected at both ends to another Frame. If you place a Frame that is unconnected to 

another Frame at either end, a temporary Frame is automatically placed - as shown in the image below.

Temporary Frames disappear as soon as the Frame is connected to another one. If the Frame remains 

unconnected, the temporary Frame remains, and acts as a Division Frame: adjoining Panels will be 

divided at the Division Frame.
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5. In the Edit mode display menu, click the Pattern item to display it. An editable red Pattern Box appears on 

your Curtain Wall.

6. Use the Arrow tool to select the Pattern box edges and drag them (use Pet palette editing commands) to 

define the limits of the Pattern that you want to repeat. 

7. Snap the Pattern box edges to Frame nodes. Frames and Panels within the Pattern box will constitute the 

Scheme Grid pattern.
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Notes: 

– To make it easier to snap the Pattern box, use a Model View Options Combination in which Curtain 

Wall components are displayed as Schematic or Simplified, or (for Frames) Axis only.

– Even with the Pattern Box visible, you can continue to edit any Curtain Wall components as usual.

– On a multi-segment Curtain Wall: in Edit mode, the Pattern box is used on one segment at a time. As 

you move your cursor over the different segments, the Pattern box jumps to the current segment. 

However, once you finish the Pattern, you can apply it to all segments with one click - see below.

8. When the Pattern Box encloses the pattern you need, click Apply.
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For a multi-segment Curtain Wall: You have the option to apply this pattern to all segments.

9. The pattern is now repeated over the Curtain Wall segment (or the entire Curtain Wall).
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Curtain Wall Pattern Box

The Pattern Box is displayed on two sides with solid lines, and two sides with dotted lines. 

With the box, the Frames that coincide with the solid lines will be repeated, while those that coincide with the 

dotted lines will be discarded. (This is relevant if the Pattern Box includes Frames with different settings.)
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Curtain Wall Input Methods

The Curtain Wall is placed on or relative to the input plane.

• In the Floor Plan, the input plane is the Story level.

• In Section/Elevation/IE, the input plane is identical to the Section plane.

• In 3D, the default input plane for Curtain Walls (as for any construction element) is Project Zero or the 

User Origin, but you may use several methods for defining any other input plane.

See Curtain Wall Input Plane in 3D Window.

Topics in this section:

Create Curtain Wall on the Floor Plan

Draw Curtain Wall Boundary in the Section Window

Create a Curved Curtain Wall: Geometry Methods

Positioning Curtain Wall in Section

Curtain Wall Input Plane in 3D Window

Create Curtain Wall in the 3D Window

Extrude Curtain Wall from a Slanted Input Plane
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Create Curtain Wall on the Floor Plan

1. Activate the Curtain Wall tool.

2. Choose the Polyline - Single geometry method from the Info Box.

3. Draw a Reference Line representing the length of the Curtain Wall. 

Note: If your Scheme has a fixed-size grid pattern, the ghost feedback and pencil/snap point indicate 

where the next pattern segment will be complete. 

4. Click to complete the Reference Line. 

5. View the result in the 3D window.

Chained Curtain Wall

Use the Chained geometry method to create a multi-segment Curtain Wall. The reference line is a polyline. 

• For each segment, you can set up a separate Scheme, with a distinct pattern for each - in Edit mode.

• A Frame is always placed where two adjacent segments are joined. Such a Frame cannot be deleted. (If 

you wish, you can set its type to Invisible, by selecting the Frame in Edit mode and adjusting its Type in 

Frame Settings.)
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Draw Curtain Wall Boundary in the Section Window

In this example, create a Curtain Wall by drawing a freehand Boundary in Section.

1. Go to the Floor Plan.

2. Draw a Section Line in the Floor Plan to define the Curtain Wall’s input plane.

3. Open the Section. 

4. With the Curtain Wall tool active, choose the Boundary geometry method from the Curtain Wall Info Box.

5. Draw the Curtain Wall Boundary along the desired contour, clicking at each node as when drawing any 

polyline. 

6. Double-click to close the polygon.

Note: The Reference Line of this Curtain Wall is the first Boundary segment you draw.

Related Topic:

Positioning Curtain Wall in Section
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Create a Curved Curtain Wall: Geometry Methods

You can create a curved Curtain Wall in the Floor Plan, Section/Elevation/IE window, or 3D window.

When defining the geometry of a curved Curtain Wall, you must first define the cylindrical Base Surface, 

then mark off the parts of this cylinder onto which the Curtain Wall will be placed.

Note: Curved Curtain Walls are always regularly shaped: the axis of its cylindrical Base Surface is either 

horizontal or vertical to the input plane when you create it, although subsequently you can tilt it in any 

direction.

Choose one of the four geometry methods for a curved Curtain Wall. For the most part, these are the same 

methods used to draw circles or arc walls in ARCHICAD.

1. Centerpoint and Radius: 

– Click to place the centerpoint. 

– Click a second time to define the radius and one of the endpoints of the Curtain Wall. 

– Click a third time to define the other end of the wall.

2. Three Points: Click three times in succession to define the beginning point, another point, and the 

endpoint of the Curtain Wall. By defining these three points, the reference cylinder’s radius and 

centerpoint are also calculated.

3. Tangential: Use this geometry method to place a Curtain Wall that forms a full circle. Click three times in 

succession to define three points on the Curtain Wall. By defining these three points, the reference 

cylinder’s radius and centerpoint are also calculated. A temporary reference circle appears.

If the three tangential points enable more than one geometrical possibility for a full-circle, the eyeball 

cursor appears. Move the cursor to view the possibilities, then click to choose which geometry you need.

4. Radius and Axis: Use this geometry method to create a regular arc-shaped Curtain Wall. This Curtain 

Wall will always be a half-cylinder shape placed on the input plane.

The first two clicks define the Curtain Wall’s beginning and endpoints.

Click a third time to define the extrusion length of the arc.
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Create Curtain Wall in the 3D Window

Input the Curtain Wall using the usual methods for a construction tool.

Note: If your Scheme has a fixed-size grid pattern, the ghost feedback and pencil/snap point indicate 

where the next pattern segment will be complete. 

In the 3D window, the default Curtain Wall input plane is the same as the current 3D input plane.

To define other input planes, see Curtain Wall Input Plane in 3D Window.

Polyline Method

1. With the Curtain Wall tool active, choose the Polyline - Single geometry method and the Default Input 

Plane from the Info Box.

2. Click to begin drawing the Curtain Wall Reference Line.

In our example:
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3. Click at the two front corners of the building to define the Reference Line length. 

View the result.

Boundary Method

1. With the Curtain Wall tool active, choose the Boundary geometry method and the Intelligent Input Plane 

Method from the Info Box.

2. Define the Input Plane by a series of clicks. 

3. Begin drawing the desired Curtain Wall Boundary on the input plane, clicking at each node as when 

drawing any polyline.

Note: The Reference Line of this Curtain Wall is the first Boundary segment you draw.

4. Double-click or click with the Hammer cursor to close the polygon.

View the result.

Related Topics:

Curtain Wall Input Plane in 3D Window
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Curtain Wall Input Plane in 3D Window

In the 3D window, the Curtain Wall Info Box provides the following options for defining the Curtain Wall’s input 

plane:

Default Input Plane

Intelligent Input Plane (Choose a plane)

Use one of the following “intelligent” methods to define an input plane by a series of clicks:

• Surface: Click any surface: the plane of the surface will be your input plane.

• Edge plus point: Click any edge (Mercedes cursor) to define a line.

A plane appears on screen, rotating around the line as its axis. Then click a point (arrow cursor) to fix the 

input plane.

• Point plus edge: This is just the reverse of the method above. Click a point, then an edge to define the 

input plane.

• Three points: Click any three points to define the input plane.

Horizontal Input Plane
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Click on a point to place a horizontal input plane at that point.

Vertical Input Plane

Click on a point to locate a vertical input plane, then click again to define the plane’s orientation.

Normal Input Plane

Define a slanted input plane by defining a vector that is perpendicular (“normal”) to the desired plane.

1. Click two points to define the normal vector to the input plane, or

click on an edge to define the normal vector to the input plane.

2. Then click a point through which the input plane will run.

For an example, see Extrude Curtain Wall from a Slanted Input Plane.
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Extrude Curtain Wall from a Slanted Input Plane

In the 3D Window, you can define any input plane.

See Curtain Wall Input Plane in 3D Window.

Consider the following model in 3D:

Suppose you want to draw the Curtain Wall so that it is extruded perpendicularly to an input plane which 

corresponds to the shape of the building. You need an input plane perpendicular to the building’s slant.

1. Activate the Curtain Wall tool and choose the Single geometry method combined with the Normal Vector 

input plane method:

2. In the 3D window, draw a Normal Vector corresponding to the slanted shape of the building (you want the 

input plane to be perpendicular to this vector). Here, we draw the vector joining the southwest corners of 

the top and bottom slabs: 
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3. When you complete the normal vector, an input plane appears which is perpendicular to it.

4. Click anywhere to place the input plane.

5. Now you are ready to draw the input line. The input line (as indicated by the rubber band line) is 

constrained and is projected perpendicularly to the input plane. Click at the two points where you want the 

Curtain Wall to begin and end: in our case, at the two front corners of any of the slabs.
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Positioning Curtain Wall in Section

Use this workflow in a Section-type window when extruding a Curtain Wall from a Reference Line.

The input plane in the Section window coincides with the Section Plane. 

1. Activate the Curtain Wall tool 

2. Choose an input method from the Info Box.

3. Draw the Reference Line as usual.

4. the Place Curtain Wall on Section dialog box appears. Choose an option:

• Freely position the extrusion starting point relative to the input plane. The first field is the absolute length 

of the extrusion; the third field is its offset from the input plane. (The sum of the two values is shown in the 

middle field.)

• To extrude the Curtain Wall “away” from you, starting from the input plane (Section line): choose the 

second method and enter the length of extrusion. There is no offset (the Curtain Wall begins right at the 

input plane).

• To extrude the Curtain Wall “toward” you, starting from the input plane (Section line): choose the fourth 

method and enter the length of extrusion.
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• To place the midpoint of the extrusion vector at the input plane, choose the third option. Enter the total 

extrusion length in the first field below.
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Model View Options for Curtain Walls

Use Model View Options to define view-based Curtain Wall display. 

Using Model View Options, show/hide Curtain Wall members separately in each view, and set a separate 

display preference for each.

Go to Document > Model View > Model View Options. 

Go to the Curtain Wall Options panel:

Show/Hide Components

By default, all Curtain Wall components (Frames, Panels, Junctions, Accessories) are displayed. Uncheck 

any component if you do not wish to display it in this Model View Options Combination. 

Detail Level Display (by Component)

For each component, click an icon to define its display: Detailed, Simplified, or Schematic.

Frames have an additional option: Display with Axis only.

• Detailed: Entire geometry (e.g. of profiled components, with intersecting Building Materials) are 

displayed.

Curtain Wall in Full Detail
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• Simplified: Displayed as rectangular boxes, using a single Building Material. 

Detailed Frames/Panels, Simplified Accessories

• Schematic: Displays the scheme only (Gridlines and Boundary).

Curtain Wall in Schematic View (Floor Plan)
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Curtain Wall in Schematic View (3D/Elevation)

Override MVO Definition

For any individual Curtain Wall member or Member Class, you can override its MVO-defined 3D Detail Level 

in its component-level Settings dialog:
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Curtain Wall Edit Mode

Use Edit mode to access and change the individual members of a selected Curtain Wall, or to add new 

custom members to it.

In Edit mode, each Curtain Wall member (Scheme, Frame, Panel, Accessory, Junction) has its own Settings 

dialog box and its own tool, so you can modify settings and place new members in a selected Curtain Wall. 

(You cannot create a new Curtain Wall in Edit mode.)

Once you change the parameters of any selected Curtain Wall member in Edit mode, that member is no 

longer tied to Curtain Wall System Settings; it is a Custom member, and its parameters are locally defined, in 

its individual tool settings dialog box (e.g. Scheme, Frame, Panel, Junction, and Accessory Settings). Custom 

parameters are set in Edit mode only.

Enter Edit mode from Floor Plan, Elevation, Section and 3D Window. You can remain in Edit mode even when 

switching between views. 

Enter/Exit Curtain Wall Edit Mode 

Enter Edit Mode

To enter Edit mode, select a single Curtain Wall in any model view, then do one of the following:

• Click the Edit button which appears.

• Use Design > Modify Curtain Wall > Enter System Edit Mode.

Exit Edit Mode

Do one of the following:

• Click Esc

• Click Exit Edit Mode from the display palette.

• Use Design > Modify Curtain Wall > Exit System Edit Mode
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Edit Mode Display Palette

Once you are in Curtain Wall Edit mode, the regular ARCHICAD toolbox is replaced by a special Curtain Wall 

toolbox and display palette

Edit Mode Palette - in Floor Plan and 3D Windows

View Options in Edit Mode

When you enter Edit Mode from the Floor Plan, the Curtain Wall uses Floor Plan Symbol view option by 

default. It looks the same as in the regular Floor Plan view.

Note: These Edit Mode viewing options are for editing purposes only.

To get a better view of your editing results, you may prefer a different view options:

Symbolic Top View
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Projected Top View

Show/Hide Items in Edit Mode

Use the Edit mode display palette to show/hide Curtain Wall elements as needed (click the eye icons to open 

or close them), even in the middle of an editing operation.

To show a particular Curtain Wall Member while hiding the rest: Right-click the item you want to remain visible 

(e.g. “Scheme Grid”). The other members are hidden.

Show/Hide Environment

“Environment,” in this display palette, refers to the rest of the building model, which you can show or hide as 

needed to assist in editing. Preselection tags will identify the Environment’s model elements in dimmed form, 

but you cannot edit them.

Note: If you have trouble identifying the edges of these model elements shown as the Environment, try 

checking Show Contours in View > 3D View Options > 3D Styles.

Edit Curtain Wall System Settings

To edit the System-level Settings without leaving Edit mode, click Curtain Wall Settings at the bottom of the 

display palette.
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Multi-selection of Frames and Panels

When you select a single Frame or Panel of a Curtain Wall in Edit mode, a “Grip” appears with shortcuts for 

selecting multiple Frames or Panels.

• Select all Frames/Panels along the selected Row/Column.

Select All Frames Along Grid Column/Row
ARCHICAD 24 Reference Guide 1059



Construction Elements Elements of the Virtual Building
Select All Panels Along Grid Column/Row

Watch the Video
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Edit Grid and Grid Lines in Edit Mode

In Curtain Wall Edit mode, the available operations with the Scheme Grid include:

• Move or delete a selected Grid Line

• Rotate all the Grid Lines of one of the Grid directions

• Add a new Grid Line

• Rotate or Move the Scheme Grid as a whole

Note that moving or rotating a Scheme Grid or Grid Lines means that the Frame(s) assigned to that Scheme 

Grid or Grid Line are moved or rotated along with it.

To make editing the Scheme Grid easier in Edit mode, make sure that the Scheme is visible (and turn off the 

other members’ visibility as needed).

Topics in this section:

Move Grid Line

Move Scheme Grid

Rotate Parallel Grid Lines

Rotate Entire Scheme Grid

Delete a Grid Line

Add a New Grid Line

Move Grid Line

Enter Edit mode.

1. Select an individual Grid Line with the Mercedes cursor. 

2. Choose the Move Grid Line command from the appearing pet palette:

3. Drag the Grid Line to its new position (it will remain parallel to its original position). 
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4. Click to place.

Move Scheme Grid

Enter Edit mode.

1. Select either a Grid Line or the entire Grid.

Note: To select the entire Scheme, click any node.

2. From the pet palette, use the Move Grid command.

Rotate Parallel Grid Lines

Enter Edit mode.
ARCHICAD 24 Reference Guide 1062



Construction Elements Elements of the Virtual Building
To rotate all the Grid Lines of one direction (e.g. all the Grid Line rows):

1. Select one of the Grid Lines you want to rotate.

2. From the pet palette, choose the Rotate Parallel Grid Lines command.

Note: If the Curtain Wall is Curved or Chained, you cannot rotate the column grid lines, just the rows.

3. Draw a rotation vector or enter a rotation angle in the Tracker.

4. Click to complete the transformation.

Rotate Entire Scheme Grid

Note: Not available for curved or chained Curtain Walls.

Enter Edit mode.

1. Select one Grid Line or select the entire Grid.

Note: To select the entire Scheme, click any node.

2. From the pet palette, choose the Rotate Grid command.

3. Draw a rotation vector or enter a rotation angle in the Tracker.

4. Click to complete the transformation.

Delete a Grid Line

In Curtain Wall Edit mode: Select the Grid Line and press Delete.

You cannot delete the Grid as a whole.

Note: Deleting a Grid Line deletes the Frame on it. The Panel(s) will change in size to conform to the 

resulting new Frame pattern.
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Add a New Grid Line

Enter Edit mode.

1. Activate the Scheme tool.

2. In the Info Box, select the Grid Input method:

Click on the place at which you want to place a grid line. Move the cursor around the point you clicked: use the 

feedback and click either of the orthogonal grid lines to place it:
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Graphical Editing of Curtain Wall

To edit a placed Curtain Wall graphically, select it in Section or the 3D window, and use the pet palette 

commands. These are analogous to the commands used to graphically edit walls. (Some commands are not 

available in every window type.)

Stretch Height/Extrusion

As you change the Curtain Wall height, its thickness remains the same but its slant angle is adjusted 

accordingly. The Curtain Wall’s Reference Line stays in place.

Stretch Slanted Height

The Curtain Wall is stretched along its plane; its slant angle remains constant.

Modify Angle

The Tracker fields reflect the new slant angle as well as the horizontal distance that the selected Curtain Wall 

edge is moved. The Curtain Wall is slanted, pivoting around its Reference Line.

Another graphical option is to free-rotate the Curtain Wall, available in the 3D and in Section/Elevation-type 

windows.

Edit Curtain Wall Reference Line

Select the Curtain Wall, then click the Reference Line to edit it.

You can only select and edit the Reference line if it is on a plane that is perpendicular to the model view.

(In Curtain Wall Edit mode, make sure that Scheme visibility in Edit mode is switched to On, since the 

Reference Line is part of the Scheme.)
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Editing the Reference Line will change the shape of the Curtain Wall Base Surface. (Grid Lines, Boundary, 

Panels and Frames will be modified accordingly.) 

You can Flip the Curtain Wall orientation relative to the Reference Line, using the Flip command in the Info 

Box.
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Add Additional Curtain Wall Boundary

A single Curtain Wall can include several Boundaries. The advantage is that you can create several separate 

shapes or sections within a single Curtain Wall, yet use an identical Scheme for all of them.

1. Draw a straight Curtain Wall on one of the surfaces using the usual methods.

2. Select the Curtain Wall and go into Edit mode. Make sure that the Environment display option is switched 

On.

3. Select the Scheme tool and the Boundary Input method.

Now click on the desired Curtain Wall segment in which you wish to draw.

4. Start drawing a new Boundary. You are drawing on the Base Surface of the currently edited Curtain Wall.

Note: Because the Base Surface of any Curtain Wall can be infinite in one or more directions, you always 

have “space” to draw any number of new Boundaries while still working on the same single original 

Curtain Wall.

5. Try editing a selected grid line, or edit the Panel pattern. Note that both “parts” of the Curtain Wall are 

handled in sync, because they are built upon a single Base Surface and a single Scheme.
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Curtain Wall Junctions

A Curtain Wall Junction is an optional structure that serves to connect panels to each other, to support or 

(more often) to substitute for Frames, resulting in a seamless, more lightweight structure than the traditional 

Framework. 

Junctions are placed at one or more grid points. Moving the grid lines will also move the Junction. 

When a Junction is selected in Edit mode, you can

• Open Junction Selection Settings and change them

• Drag the Junction to another panel connection point (3D Edit mode only)

• Delete the Junction

Junctions are placed on the inside of the Curtain Wall by default. You can flip the Junction to the opposite side 

of the Curtain Wall (use the Flip button in Junction Tool Settings or Info Box).

Place Junctions at All Grid Points

Junctions can be placed either one by one or automatically at every intersection. 

To place them at all Grid points, choose this option under Member Placement in Curtain Wall System Settings.
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Add New Junction to the Curtain Wall

1. Enter Curtain Wall Edit mode from the 3D window.

2. Activate the Junction Tool. 

3. To use Custom parameters, open the Junction Settings page and adjust the parameters as needed.
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4. To use the Junction as a substitute for Frames: select the Frames at a desired panel connection point and 

switch them to “Invisible” type.

5. With the Junction tool active, click the hotspot in the middle of the connection.

6. Click to define which side of the Curtain Wall you want to place the Junction. It will be placed at the 

nearest panel connection point to your click.

Note: To reverse its orientation, select the Junction and click Flip from the Info Box.
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Curtain Wall Accessories

A Curtain Wall Accessory is an optional non-load-bearing member - such as a sun shade, a decoration strip or 

a canopy - attached to the Curtain Wall at any Frame.

In ARCHICAD, accessories can be placed one by one, in Curtain Wall Edit mode only, using the Accessory 

Tool. 

An Accessory can be configured in Edit mode with custom properties, but you can also set Accessories to use 

the System-level Accessory settings from Curtain Wall Settings.

Moving Grid Lines or Frames will move the Accessory along with them.

Add New Accessory to Curtain Wall

1. Enter Curtain Wall Edit mode in the 3D window.

2. Activate the Accessory Tool.

3. Use the Info Box or Accessory Settings to define the Accessory type and Class.

4. Click on a Frame or a Frame endpoint - the endpoint closest to your click is the Accessory startpoint.

5. Drag the cursor and click to define the endpoint.
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6. Click with the eyeball cursor to define its direction: outside or inside the Curtain Wall.

Customize an Individual Accessory

When an Accessory is selected in Edit mode, you can

• Open Accessory Selection Settings and change it

• Drag the Accessory onto another Frame (in 3D Edit mode only)

• Flip the Accessory to the opposite side of the Curtain Wall (Use the “Flip” button in Accessory Tool 

Settings or the Info Box)

• Delete the Accessory

Set the visibility to make your work easier (for example, turn off the visibility of everything except for 

Accessories, Frames and the Scheme.)
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Curtain Wall System Settings

Use System-level editing to set up or edit the Curtain Wall element as a whole, using a single dialog box.

Open Curtain Wall Default Settings by double-clicking on the Curtain Wall Tool. 

Geometry and Positioning Panel

• Curtain Wall Height

• Bottom Offset to Home Story

• Bottom Elevation [to Reference level]

For a Curtain Wall with a non-horizontal Reference Line: elevation at the Curtain Wall’s lowest point.
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• Home Story: The Curtain Wall’s reference line is physically linked to its Home Story. If you later modify 

the Home Story’s position (e.g. redefine the floor level), the Curtain Wall will change its position.

If you change an element’s elevation so that its reference line is moved to a different story, you have the 

option to make the Home Story change to match the element’s new location:

See Change Home Story by Elevation.

Nominal Thickness

Distance from the Reference Surface to the opposite side of the Curtain Wall. 

This Nominal Thickness value is used by elements connected to the Curtain Wall: Adjoining Zones and 

connecting Walls will extend to the Nominal Thickness by default.

See also Join Wall to Curtain Wall.

Slant Angle

Not available for multi-segment Curtain Walls.

Vertical Reference Line Offset

Flip Curtain Wall on Reference Line

Available for a selected Curtain Wall, or during input in the Info Box.

Click the Flip button to flip (or mirror) a selected Curtain Wall along its Reference Line: the body of the Curtain 

Wall flips to the other side. The Reference Line stays in place, and the pattern is not affected.
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Distance from Panel (or Frame) to CW Reference Line

Use the popup and consult the image to define the offsets between the Reference Surface and each class of 

Frames (e.g. Boundary, Mullion and Transom Frames); or the center of the Panel.

The offset values here are interrelated; changing one will change all the rest.

Note: Frame geometry is defined, for each Frame class, on the Frame page of Curtain Wall settings.

See Curtain Wall Frame Settings.
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Curtain Wall Settings: System Page: Floor Plan and Section Panel

Use these controls to define the appearance of the Curtain Wall: its Floor Plan Display; its Cut Elements 

(appearance of cut frames and cut panels); and its Outlines.

Show on Stories

• All Relevant Stories: Display and edit on all stories which the element intersects. 

• Home Story Only: Display on its Home Story only.

Floor Plan Display

Use this popup to define which parts of the Curtain Wall are displayed on Floor Plan.

• Projected 
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– Cut part of 3D model (i.e., as cut at the level of the Floor Plan Cut Plane)

– Uncut (downward) part

• Projected with Overhead: 

– Same as Projected, plus Overhead part (above the Floor Plan Cut Plane)

• Cut Only: displays only the cut part, as cut by the Floor Plan Cut Plane.

• Outlines Only: the entire element’s outline is shown using uncut attributes.

• Overhead All: the entire element’s outline is shown using overhead attributes.

Projection Mode

Once you have set Floor Plan Display, use Projection Mode to fine-tune the displayed components 

(Overhead, Cut, Uncut) of the Curtain Wall:

• Projected

• Symbolic

• Projected with Symbolic Panels (for cut components only). Here, Cut Panels are Symbolic, while Cut 

Frames are Projected.

Consult the preview to visualize the result for each option. The Projection Mode is “Hybrid” by default - that is, 

it uses various settings for the three component types.

• Available options depend on the Floor Plan Display you chose above; some components may be invisible, 

and you cannot set a display mode for those.

• If Floor Plan Display is set to Outlines Only or Overhead All, then the Projection Mode becomes All 

Symbolic, and there are no further options.

• Curtain Wall display is also determined by Model View Options.

See Model View Options for Curtain Walls.

Show Projection

For projected parts of the Curtain Wall: the range of the projection. This control is only available if the 

element’s Floor Plan Display is set (using the Floor Plan Display pop-up) to either “Projected” or “Projected 

with Overhead.”

• Entire Element: Element is displayed on all relevant stories.

• to Floor Plan Range: Show the Curtain Wall on a range of stories (the current story, plus a given number 

of stories above and below it).

Set the desired range in Floor Plan Cut Plane Settings.
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• to Absolute Display Limit: Set a fixed lower limit (by default, this is Project Zero), then show all parts of 

the Curtain Wall above this limit.

Set the Absolute Display Limit in Floor Plan Cut Plane Settings.

See Floor Plan Cut Plane Settings Dialog Box.

Cut Elements

Override Frame Type’s Attributes: Check this box to override the attributes defined in the GDL object, using 

the two controls below.

• Frame Cut Lines

• Frame Cut Line Pens

Override Panel Type’s Attributes: Check this box to override the attributes defined in the GDL object, using 

the controls below. 

• Panel Cut Lines

• Panel Cut Line Pen

Override Cut Fill Pens: If needed, override the fill foreground/background pens of this element (defined by 

default in the Building Material). To do this, choose Foreground, Background or Both from the Override Cut Fill 

Pens pop-up to access the respective controls.

Outlines

Select Lines and Pens for the Uncut and Overhead lines of the Curtain Wall, as displayed on Floor Plan and 

Section.
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Curtain Wall Settings: System Page: Member Placement Panel

Lines

Use the controls on this panel to define:

• how to place Junctions on your Curtain Wall, and

• where the Boundary Frame should be positioned relative to the grid.

Place Junctions

•  At all Grid Points: Place Junctions automatically at all points of the grid.

This works if a valid Junction Type is defined on the Junction page of Curtain Wall Settings.

•  One by one: Place Junctions manually, using the Junction tool. (This is done in Edit mode only, after you 

have placed and selected a Curtain Wall.)

Related Topic:

Curtain Wall Junctions

Place Boundary Frames

• Center on Boundary: This is the default setting. The Boundary Frame centerline coincides with the grid 

line.

Note: The Curtain Wall Grid Pattern is defined on the Scheme page of this dialog box.

• Inside Boundary: Offsets the Boundary Frame to the inside of the Boundary grid line.

• Outside Boundary: Offsets the Boundary Frame to the outside of the Boundary grid line.

Relation to Zones

See these topics:

Calculating Zone Area and Zone Volume

Relation to Zones
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Curtain Walls and Other Elements

The following sections describe how Curtain Walls can interact with other elements.

Join Wall to Curtain Wall

Managing Curtain Wall Joins

Curtain Walls and Adjacent Zones

Split Intersecting Curtain Walls

Create Common Frame for Overlapping Curtain Walls

Join Wall to Curtain Wall

A Curtain Wall may be joined to one or more walls. 

• If you move or rotate the Curtain Wall, then the joined wall will stretch accordingly.

• The Join command is also helpful in adjusting wall geometry to a slanted Curtain Wall.

To join a wall to a Curtain Wall:

1. Select the wall(s) and the Curtain Wall. (You may select any number of walls, but only a single Curtain 

Wall.)

2. Use the Design > Modify Curtain Wall > Join Wall(s) to Curtain Wall... command

or the Connect > Join Wall(s) to Curtain Wall command from the context menu.

3. The Join Wall(s) to Curtain Wall dialog box appears. Use this dialog box to specify the exact connection 

point of the wall(s) to the Curtain Wall. 

See details below.

4. Click Join.

5. If the ends of the wall and Curtain Wall do not coincide, the eyeball cursor appears: click to define which 

end of the wall you want to join to the Curtain Wall. 

As you move the cursor to either end of the wall, a double-arrow appears on the wall, to indicate that this 

is the end that will be joined if you click now.
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Join Wall to Curtain Wall Dialog Box

• Join at Curtain Wall Thickness: This is the default choice. These Inside and Outside offset values total 

the Curtain Wall’s Nominal Thickness, as defined in Curtain Wall System Settings Geometry and 

Positioning Panel. In our example, the Nominal Thickness is set to 400.

• The Outside value: this defines the point at which walls coming from the “Outside” direction of the Curtain 

Wall will be joined to this Curtain Wall.

• The Inside value: this defines the point at which walls coming from the “Inside” direction of the Curtain 

Wall will be joined to this Curtain Wall.

Both the Inside and Outside wall joining points are expressed as offsets from the Base Surface, as shown in 

the “Join Wall to Curtain Wall” dialog box.

For the purposes of offsetting joined walls from this Curtain Wall, the “Inside” portion of this Nominal 

Thickness is equal to the Panel offset from the Reference Surface (in our example, 250); the “Outside” portion 

is what remains of the Nominal Thickness (in our example, 150).

• Custom Offset: Click this to stop the adjoining wall(s) at points other than the Curtain Wall’s nominal 

thickness. Enter values for the offset from the Curtain Wall’s Base Surface to the Outside and Inside wall 

connection points.

To redefine the offset for an already joined wall, join it again.

Managing Curtain Wall Joins

Selected elements that participate in a join between a Curtain Wall and Wall(s) are shown with a “grip”. Click 

the grip to see a list of the Connections (including Solid Operations and Trims, as well as joined Walls/Curtain 

Walls) which involve the selected element. Use this list to manage these relationships.
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For more information, see Managing Element Connections.

Curtain Walls and Adjacent Zones

Adjacent Zones extend up to the Curtain Wall’s Nominal Thickness, as defined in the Nominal Thickness field 

of Curtain Wall System Settings (Geometry and Positioning Panel).

As with walls and columns, you have several options for defining how to calculate Curtain Walls which are 

bounded by Zones or which serve as a Zone boundary. Use the Relation to Zones pop-up on the Member 

Placement Panel of Curtain Wall Settings to define how to calculate these Zones.

See Relation to Zones.

Split Intersecting Curtain Walls

One way to precisely connect two Curtain Walls is to make them intersect, then split off the “extra” parts, using 

the Design > Modify Curtain Wall > Split Curtain Wall command.

This command works only for splitting one or more Curtain Walls with another Curtain Wall. It is available in 

any model window (but not in Curtain Wall Edit mode). It is analogous to the Edit > Reshape > Split 

command, which works on other ARCHICAD elements.
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In this example, the two Curtain Walls intersect on the Floor Plan.

1. Select the curved Curtain Wall.

2. Use Design > Modify Curtain Wall > Split Curtain Wall, or the same command from the context menu.

3. Click on the other Curtain Wall.

4. The eyeball cursor appears. Click either side of the curved Curtain Wall to define which part will remain 

selected after the Split takes place.

The curved Curtain Wall has been split into two separate Curtain Walls.
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5. Now you can delete the one you don’t need, and the remaining Curtain Walls are joined exactly.

6. Repeat the process to split off, then delete the protruding part of the straight Curtain Wall.

The result on the Floor Plan, and in 3D:

In such a case, the two adjoining Curtain Walls’ Frames may overlap. To remedy this, create a common 

Frame for both of them.

See Create Common Frame for Overlapping Curtain Walls.
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Stairs

Topics in this Section

About the Stair Tool

Stair Input

Graphical Editing of Stair Scheme

Stair Turning Type

Stair Segment Type

Stair Tool Edit Mode

Automatic “Solver” Options to Resolve Geometric Conflicts

Stair Settings (Main Element Settings)

Toplinked Stairs and Changed Story Height

Tread and Riser Finishes

Flight and Landing Structures

Split Stair Structure

Custom Sub-Elements for Stairs and Railings

Stair Endings and Connections

Model View Options for Stairs

Detail Level of Stair and Railing Symbols

Floor Plan/Reflected Ceiling Plan Display (Stair Settings)

Labeling Stairs

Related Topics:

Ramp Object
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About the Stair Tool

Use the Stair Tool to design and document any typical or unique Stair, up to 1:50 design scale. 

Input is available on the Floor Plan and in the 3D window, using methods similar to polyline or Wall input. 

During the polyline path input, instant graphical feedback shows what the resulting Stair will look like. 

• A Stair has one or more Segments, with Turnings (nodes) between them.

• Like the Curtain Wall, the Stair is a hierarchical element. 

• The main Stair element consists of multiple components: Treads, Risers and Structures. 

• Stair components are GDL elements, which use Building Materials and/or Custom profiles. 

• Use Edit mode to access and customize the individual components of a selected Stair.

• Customizable Rules and Standards provide the constraints, and describe local regulations. The user can 

choose the rules that apply to his/her project, and set the allowed ranges. As the user places the Stair with 

graphical input, the algorithm automatically adjusts certain geometric values of the stair, within the user-

provided ranges.

• In some cases, the input values and the polyline path cannot result in an adequate Stair. If such a conflict 

or error occurs, the ‘Solver’ pops up to help resolve it. The Solver presents multiple possible solutions to 

modify the Stair so as to meet regulations. 

• Stairs can be linked to Stories, and so can follow changes in floor height.

• Stair Structure

– Four structure types: monolithic, beam, cantilevered, and/or stringer. 

– Structure for flights and landings can be defined individually

– Customize each structure for size, building material, profile, 2D appearance

• Stair Finish

– Components include Treads and Risers. Treads and Risers for Flights and Landings can be defined 

individually, and any individual Tread and Riser can be customized in Edit mode.

– Optionally define custom components and save them using one of the predefined Stair subtypes. 

• Stair 2D sub-elements

– Break Mark, Walking Line, Numbering, etc.

– Symbols are 2D GDL components, completely separate from the 3D structure

– Use Model View Options to define which 2D sub-elements should appear on the Stair and how to 

display them. 

Watch the Video
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Stair Input

Basic Stair Input

To get a feel for the Stair Tool, start placing Stairs in the plan using the default settings, or one of the Stair 

Favorites. 

Input is available on the Floor Plan and in the 3D window, using methods similar to polyline or Wall input. 

During the polyline path input, instant graphical feedback shows what the resulting Stair will look like. 

The Stair is input along a Baseline. Note some of the key input preferences in the Info Box:

Input Methods (Info Box)

Stair Baseline Position: Left, Right Center

Input Stair Upward/Downward

Add Railing to Stair (Right, Left, Both sides)

Example 1: Entrance Stair

1. Open the Stair Settings dialog box, and review the Geometry and Positioning Settings. 

This Stair is not toplinked, and it has a fixed number of 8 risers. It will be a straight stair with no turning, so the 

turning type is not relevant.

In the Floor Plan or 3D window:

1. Click to begin inputting the Stair.

2. Note the feedback: Since the number of risers is fixed, the length of the Stair is shown as a ghost outline 

during input.
ARCHICAD 24 Reference Guide 1087



Construction Elements Elements of the Virtual Building
3. Double-click to complete the Stair.

Watch the Video
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Example 2: Top-Linked Staircase

Here, we create an interior Staircase up to the next floor.

Set up the Stair Settings as shown. This Stair’s top is linked to the story above, and it has a fixed number of 18 

risers. This Stair will have Landings, and the Landing type is set to Automatic Landing.

In the Floor Plan or 3D window:

1. Click to begin inputting the Stair along the Walls, as when drawing a polyline.

2. Click at each of the two Wall corners, then double-click to complete the Stair. The ghost feedback shows 

you that 18 risers will be placed in any case, according to the predefined settings.

The Stair is complete. The Turning type you defined (Landing) was placed at both turnings (points on the input 

baseline) automatically.
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Turnings and Segments

Stairs consist of Turnings and Segments.

• Set Turning Type for the Stair as a whole in Stair Settings. (Choose Automatic Landing or one of two 

Winders.)

See Stair Turning Type.

• Segment Type is always “Flight” by default. You can change the segment type on the fly, for each 

segment, during input.

See Stair Segment Type.

• You can customize Turning Type options - for any particular segment or any particular Turning - after Stair 

input.

See Edit a Stair’s Turning Type.

Create Stair with Magic Wand

Use the Magic Wand method (Spacebar + click) to automatically generate a Stair along the clicked edge or 

polygon. 

• Click at the point where you want the Stair to begin.

• The clicked point will be the bottom of the Stair (even if the input method is Downward).

• The Stair Baseline is placed along the traced polygon/polyline.

Change the Baseline if needed in the Info Box or in Stair Settings (Left, Right or Middle of Stair). This allows 

you to vary the Stair placement (inside or outside of the clicked polygon/polyline).
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• To create a Stair around a free-standing Wall: click into the Wall.

Watch the Video
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Graphical Editing of Stair Scheme

The following functions let you adjust overall Stair geometry on the Floor Plan, without having to use Edit 

mode.

Rearrange Steps

Use this pet palette command to graphically rearrange the symmetry of a U-shaped stair:

Edit Stair Baseline

The Stair Baseline is created during input. Use Stair Settings or the Info Box to set the Baseline position and 

any offset (either before or after input). 

See also Stair Baseline.

To show/hide the Stair Baseline on the Floor Plan, turn on View > On-Screen View Options > Stair 

Baselines.
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You can edit the Stair Baseline in any window (regardless of Edit mode).

Use the pre-selection highlight tag to make sure you select the Baseline (not the Boundary).
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Baseline editing changes the overall Stair geometry, including the Walking Line.

Walking Line Follows Baseline Editing

Continue Stair

To continue a Stair Baseline (in Edit mode or in a model view), use the Continue Stair command from the 

selected Baseline’s pet palette.
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Edit Stair Boundary

Select any part of the Boundary to highlight it.

You can edit the Stair Boundary in any window (regardless of Edit mode).

Use the TAB button and the pre-selection highlight to make sure you select the Boundary, not the Baseline.

Edit the Stair boundary graphically, using the same pet palette commands as when editing a Fill.

Boundary editing changes the outer shape of the Stair, but the Walking Line and Baseline stay put. 

Edit Stair Boundary (Walking Line Unaffected)
ARCHICAD 24 Reference Guide 1095



Construction Elements Elements of the Virtual Building
Show/Hide Boundary Segment on Floor Plan

For any selected Stair segment, use the Boundary Segment Settings pet palette command to open this dialog 

box. 

Show or hide the selected segment (or apply to all or other Stair segments) as needed.

For example: you can add two nodes to a Stair segment, then hide the Stair Boundary between those two 

points.

Insert Two Nodes to Create New Stair Segment... Then Select and Hide Segment

See also Hide Any Edge of a Single Tread.
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Edit Stair Boundary - Example

In this example, you can edit the Stair boundary to cut out enough room for a protruding Wall segment.

Watch the Video
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Stair Turning Type

As a rule, set the Stair’s Turning Type (Landing or a Winder) in Stair Settings, and define its options. The 

selected Turning Type is placed at each turning (each point you click while placing the Stair baseline), 

between any two Stair Flight segments.

All Turnings will thus have the same settings. However, for a placed Stair, you can customize each Turning 

type separately.

See Edit a Stair’s Turning Type, below.

Define Turning Type in Stair Settings

In Stair Settings or the Info Box, choose a preferred Turning Type for the entire Stair. 

• Automatic Landing

• Winder with Equal Angles 

• Winder with Equal Goings

Note: In the USA version of ARCHICAD, “Goings” are known as “Runs”. 

For each type, click the pop-up to adjust its specific settings. The settings differ for each Turning Type: 

Landing: Turning Type Options

Winder with Equal Angles: Turning Type Options

Winder with Equal Goings

Landing: Turning Type Options

Riser Offsets from Corner

• Set the Landing offsets (for Lead and Trail Edge, respectively) from the corner. 
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• Define the offsets as either Fixed or a Minimum. (If you pick Minimum, the program will have some leeway 

to increase the offset, to fit the Stair input geometry.)

• Click the chain icon for a symmetrical landing (same offsets on both ends).

Note: The chain icon will ensure a symmetrical landing for each turning of the Stair. However, a Stair with 

multiple landings may use different offset values at different landings (if offset values are defined as a 

“minimum” rather than fixed).

• Define the offset value in terms of either Model Units, or as a certain number of Goings.

Winder with Equal Angles: Turning Type Options

Set Division Method

Choose a method for dividing the Winder:

• Optimum Going Width: The program automatically finds a Going Width for the Winder which is as close 

as possible to the Going Width on the Stair’s straight flight.

• Maximum Number of Goings: The program automatically inserts the maximum number of goings into 

the Winder, within the limits of the current Stair Settings.

• Fixed Number of Goings: In the field below, enter a fixed number of Winder divisions. The Winder will be 

divided accordingly, regardless of any other rules set in Stair Settings.
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Just as for the Landing, set riser offsets at either end of the winder, defined as a fixed or minimum value.

See Riser Offsets from Corner, above.

Read More on Help Center

Winder with Equal Goings

Equal Goings means that all goings in the Stair are equal, both on the straight and the winding steps.

Note: In the USA version of ARCHICAD, “Goings” are known as “Runs”. 

• Within a single Stair, all the Equal-Going Winders always use the same Winder Type (e.g. all are “Two 

Point” winders).

• For any Equal-Going Winder, you can offset the Calculated Walking Line, which affects Going depth. See 

Offset Walking Line on Turning (Winder with Equal Goings)

• For any Equal-Going Winder, you can set the Walking Line to be either Straight or Curved.

The four Equal-Going winder types here differ in how the winders are constructed. For each, consult the 

illustrations in the dialog for an indication of how it works.

The Equal-Going Winders are more fully explained here:

Winder Types for Equal-Going Winders

Read More on Help Center
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Turning Type vs Segment Type

Stair segments - not just Turnings - can be defined as Landing or Winder-type segments (as well as Flight 

segment). Segment type is set not in Stair Settings, but on the fly, during Stair input. 

See Stair Segment Type.

These Segment definitions can produce different Turning Types than the one you set in Stair Settings.

In any case, you can customize Turning Type options - for any particular segment or any particular Turning - 

after Stair input.

See below.

Edit a Stair’s Turning Type

For a placed Stair, you can adjust Turning Type Settings for any specific turning, using the pet palette.

Note: Within a single Stair, all the Equal-Going Winders must use the same Winder Type. The only 

editable option for a selected Equal-Going Winder is the number of winders.

1. Select the Stair on the Floor Plan.

2. Click on a turning point, then choose Turning Type Options from the pet palette.

3. In the appearing dialog box, select the desired Turning type, and the options which apply.

Apply changes to: From the pop-up, select either the specific clicked Turning, or all turnings of the entire 

Stair.

Related Topic:

Stair Segment Type
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Winder Types for Equal-Going Winders

Equal Goings means that all goings in the Stair are equal, both on the straight and the winding steps.

In Stair Settings-Geometry and Positioning Panel:

Choose one of four types of Equal-Going Winders from the pop-up: Single Point, Two Points, Principal Lines, 

and Auxiliary Walking Line. 

As applicable, choose either Riser or Tread in the Middle for your winding type:

Winder with Equal Goings: Construct with Riser or Tread in the Middle

All except the Single Point method have two versions, depending on whether the center of the Winder is a 

Riser or a Tread. 

Single Point Method Two Points Method

Riser in the Middle Tread in the Middle
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Each method is described below:

Single Point Method

Two Points Method - Riser in the Middle

Two Points Method - Tread in the Middle

Principal Lines Method - Riser in the Middle

Principal Lines Method - Tread in the Middle

Auxiliary Walking Line Method - Riser in the Middle

Auxiliary Walking Line Method - Tread in the Middle

Single Point Method

1. Equal goings are measured along the walking line, starting from the bottom of the stair. The going closest 

to the turning point is considered the Center Tread of the Winder.

2. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

3. Start and End lines are extended, their intersection point forms the centerpoint of the Winder.

Principal Lines Method Auxiliary Walking Lines Method

Riser in the Middle Tread in the Middle Riser in the Middle Tread in the Middle
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4. The equal going points measured along the walking line are connected to the centerpoint, these lines form 

the risers of the winding steps.
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Two Points Method - Riser in the Middle

1. Center of the Winder is constructed:

– A single Riser is constructed in the bisector of the turning.

2. Equal goings are measured along the walking line, in both directions, starting from the point where the 

bisector intersects the walking line.

3. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

4. Start and End lines are extended, their intersection points with the bisector form the two centerpoints of 

the Winder.

5. The equal going points measured along the walking line are connected to corresponding one of the two 

centerpoints. These lines form the risers of the winding steps.
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Two Points Method - Tread in the Middle

1. Center of the Winder is constructed:

– A single Going is measured along the walking line, symmetrical to the bisector of the turning.

– The Tapered Tread Minimum Width value is measured on the inner edge of the turning, symmetrical to 

the bisector.

– The points on the inner edge and the points on the walking line define the Center Tread.

2. Equal goings are measured along the walking line, starting from the point where the edges of the Center 

Tread intersect walking line.

3. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

4. Start and End lines are extended. Edges of the Center Tread are also extended. The intersection points of 

these lines form the two centerpoints of the Winder.

5. The equal going points measured along the walking line are connected to corresponding one of the two 

centerpoints. These lines form the risers of the winding steps.
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Principal Lines Method - Riser in the Middle

1. Center of the Winder is constructed:

– A single Riser is constructed in the bisector of the turning.

– Equal goings are measured along the walking line, in both directions, starting from the point where the 

bisector intersects the walking line.

– The Tapered Tread Minimum Width value is measured on the inner edge of the turning, in both 

directions.

– The points on the inner edge and the points on the walking line define the two Center Treads.

2. Equal goings are measured along the walking line, in both directions, starting from the Center Treads.

3. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

4. Start and End lines (the Principal Lines) are extended. Edges of the two Center Treads are also extended.

5. The points where the First Center Tread Edge and the Bisector intersect the Start line define the distance 

X.

6. Distance X is measured multiple times along the Start line. These points are connected to the respective 

equal going points measured along the walking line. These lines form the risers of the starting half of the 

winder.

7. The points where the Last Center Tread Edge and the Bisector intersect the End line define the distance 

Y.
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8. Distance Y is measured multiple times along the End line. These points are connected to the respective 

equal going points measured along the walking line. These lines form the risers of the ending half of the 

winder.

Principal Lines Method - Tread in the Middle

1. Center of the Winder is constructed:

– A single Going is measured along the walking line, symmetrical to the bisector of the turning.

– The Tapered Tread Minimum Width value is measured on the inner edge of the turning, symmetrical to 

the bisector.

– The points on the inner edge and the points on the walking line define the Center Tread.

2. Equal goings are measured along the walking line, in both directions, starting from the Center Tread.

3. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

4. Start and End lines (the Principal Lines) are extended. Edges of the Center Tread are also extended.

5. The points where the Center Tread Edges intersect the Start line define the distance X.

6. Distance X is measured multiple times along the Start line. These points are connected to the respective 

equal going points measured along the walking line. These lines form the risers of the starting half of the 

winder.

7. The points where the Center Tread Edges intersect the End line define the distance Y.

8. Distance Y is measured multiple times along the End line. These points are connected to the respective 

equal going points measured along the walking line. These lines form the risers of the ending half of the 

winder.
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Auxiliary Walking Line Method - Riser in the Middle

1. Center of the Winder is constructed:

– A single Riser is constructed in the bisector of the turning.

– Equal goings are measured along the walking line, in both directions, starting from the point where the 

bisector intersects the walking line.

– The Auxiliary Walking Line is constructed, by offsetting the Walking Line to 200mm from the inner 

edge.

– 2/3 of the Going is measured along the Auxiliary Walking Line, in both directions.

– The points on the walking line and the points on the Auxiliary Walking Line define two Center Treads.

2. Equal goings are measured along the walking line, in both directions, starting from the Center Treads.

3. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

4. Start and End lines (the Principal Lines) are extended. Edges of the two Center Treads are also extended.

5. Going length is measured multiple times along the Start line, starting from the point where the First Center 

Tread Edge intersects the Start Line.

6. These points are connected to the respective equal going points measured along the walking line. These 

lines form the risers of the starting half of the winder.

7. Going length is measured multiple times along the End line, starting from the point where the Last Center 

Tread Edge intersects the End Line.

8. These points are connected to the respective equal going points measured along the walking line. These 

lines form the risers of the ending half of the winder.
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Auxiliary Walking Line Method - Tread in the Middle

1. Center of the Winder is constructed:

– A single Going is measured along the walking line, symmetrical to the bisector of the turning.

– The Auxiliary Walking Line is constructed, by offsetting the Walking Line to 200mm from the inner 

edge.

– 1/2 of the Going is measured along the Auxiliary Walking Line, symmetrical to the bisector of the 

turning.

– The points on the walking line and the points on the Auxiliary Walking Line define the Center Tread.

2. Equal goings are measured along the walking line, in both directions, starting from Center Tread.

3. Start and End lines of the Winder – aka the last and first straight step – are constructed, based on the 

Number of Winding Steps parameter.

4. Start and End lines (the Principal Lines) are extended. Edges of the Center Tread are also extended.

5. Going length is measured multiple times along the Start line, starting from the point where the First Center 

Tread Edge intersects the Start Line.

6. These points are connected to the respective equal going points measured along the walking line. These 

lines form the risers of the starting half of the winder.

7. Going length is measured multiple times along the End line, starting from the point where the Last Center 

Tread Edge intersects the End Line.

8. These points are connected to the respective equal going points measured along the walking line. These 

lines form the risers of the ending half of the winder.
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Winder Segments

In case of a Winder Segment, the midpoint of the Winder part of the walking line is considered the starting 

point of the Winder.

• Bisectors are constructed as the perpendicular to the walking line through this point.

• Equal Goings are measured starting from this point.

• Tapered Tread Minimum Widths are measured starting from this point’s projection onto the inner edge.
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Stair Segment Type

A Stair segment can be defined as Flight, Landing, or one of two Winder types.

When you start inputting a Stair, the default segment is always “Flight”. You can change the segment type on 

the fly, for each segment, during input.

When inputting a Stair, you can select a different Stair Segment type (Landing, Winder, Flight) for each 

segment as you click to place it. These types determine the Turning that is placed at the end of each segment.

For example, a Flight segment connected to a Landing-type segment will use a Landing-type turning.

For a placed Stair - after input is complete - you can edit any of its Turning Types individually.

See Edit a Stair’s Turning Type.

Define Segment Type (Flight, Landing, Winder) During Stair Input

During Stair input, the pet palette appears with available Segment Types: Flight, Landing, or one of two 

Winder types. You can change this Segment type on the fly during Stair input. After each click, set a Segment 

type for the next input segment.

For example:

1. Click to start placing the first Stair segment: the pet palette shows that the current segment type is set to 

Flight, which is what you want.

2. Click to complete the Flight segment.

3. As you drag to input the next segment, choose Landing from the pet palette. 

4. Click to complete the Landing segment.

5. As you drag to input the next and final segment, choose Flight from the pet palette.

6. Click to complete the Stair.
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Switch Segment Types During Input: Flight – Landing – Flight

Redefine Segment Type: Landing, Flight, Winder

If you input a Stair whose default Turning Type is set to Landing in Stair Settings (see Stair Turning Type), you 

may find that two adjacent Landings within a single Stair segment have an unwanted Riser:
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Turning Types = Landings, Segment Type = Flight

The reason is that the Stair segment that connects the two Landings is a Flight-type segment, which inserts a 

Riser between the two landings.

To resolve this, redefine the Stair segment as a Landing:

1. Select the Stair on the Floor Plan.

2. Click on the segment with the landings and choose Select Segment Type from the pet palette.

3. In the appearing dialog box, switch the segment type to Landing.

Change Stair Segment Type
ARCHICAD 24 Reference Guide 1114



Construction Elements Elements of the Virtual Building
The Stair segment is now a Landing, and its two Landing-type turnings meet in the middle.

Segment Type = Landing

Related Topic

Stair Turning Type
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Stair Tool Edit Mode

Use the Edit mode of the Stair tool to access and edit any one or more Stair components: Treads, Risers, and 

Structures.

Note: You can edit the Stair’s Baseline and Boundary regardless of Edit mode.

• Enter Edit mode from Floor Plan, Elevation, Section and 3D Window. You can remain in Edit mode even 

when switching between views.

• In Edit mode for the Stair (unlike Curtain Wall Edit mode) you cannot add new Treads, Risers or Structures 

- you can just edit existing ones, either graphically or through their component Settings dialogs.

Exception: In Edit mode, you can extend the Stair using Continue Stair from the Baseline’s pet palette.

Enter Edit Mode

To enter Edit mode, select a Stair in any model window, then do one of the following:

• Click the Edit button which appears.

• Use Design > Enter Stair Edit Mode.

Exit Edit Mode

Do one of the following:

• Use ESC (with nothing selected)

• Click Exit Edit Mode from the display palette (see below).

• Use Design > Exit Edit Mode.

Edit Mode Display Palette

Edit mode has its own Display Palette, which varies depending on the window you are in (2D, 3D, Section/

Elevation).
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Edit Mode Display Palette

Use the Edit mode Display Palette to show/hide the Stair components as needed (click the eye icons to open 

or close them), even in the middle of an editing operation.

Right-clicking any of the components (e.g. “Tread”) in the display palette means that component will be 

displayed and the rest hidden. 

Schematic vs. Symbol View (2D Edit mode)

The 2D view of Stair Tool Edit mode has two options to display the Stair for optimal editing:
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• Schematic: shows the Stair as a simplified 3D transparent surface. Use this mode to select Structures, as 

well as Treads and Risers (use Tab to cycle among multiple highlighted elements):

• Symbol: Use this to access the Stair’s the 2D symbol elements (e.g. Walking Line)

Use Symbol View to Edit Walking Line or Break Mark

Related Topics

Edit Stair Symbol Components Graphically

Walking Line Symbol: Position and Display Settings
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Select Stair Component for Editing

In Edit mode, select a Tread, Riser or Structure component to edit it graphically and to access its settings.

• Use the Element Info tag to make sure you select the component you need. In case of multiple 

overlapping elements, use the Tab key to cycle among selection options.

• The selected component’s Settings are available from the Info Box (click Settings) and the context menu. 

Note: Unlike Curtain Wall Edit mode, there is no Stair toolbox available from Edit mode, because you 

cannot create new Stair components in Edit mode. 
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• When selecting a Structure component in 3D Edit mode, you may have to navigate “underneath” the Stair, 

or turn off the display of Treads/Risers.

Multi-selection of Treads and Risers

When you select a single Tread or Riser in Edit mode, a “Grip” appears with shortcuts for selecting multiple 

Treads or Risers.

Click on one of the Grip options to select one or more Treads/Risers, in addition to the selected one:

• all Treads/Risers above

• all Treads/Risers below

• all Treads/Risers altogether
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A Riser in 2D Edit mode is shown as a single line. (Hover your cursor and use Tab if you have trouble clicking 

on the Riser line.)

Selected Riser (Line) in 2D Edit Mode

Show/Hide Environment

“Environment,” in this display palette, refers to the rest of the building model, which you can show or hide as 

needed to assist in editing. Preselection tags will identify the Environment’s model elements in dimmed form, 

but in Stair Edit mode, you can edit only the components of the Stair you selected to enter Edit mode.
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Note: If you have trouble identifying the edges of these model elements shown as the Environment, try 

checking Show Contours in View > 3D View Options > 3D Styles.

Access Stair Settings from Edit Mode

To edit the System-level Settings without leaving Edit mode, click Stair Settings at the bottom of the display 

palette.

Watch the Video
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Automatic “Solver” Options to Resolve Geometric Conflicts

If the Stair input geometry is not compatible with the Rules of the current Stair Settings, the Solver feedback 

appears automatically, with multiple possible solutions to modify the Stair.

The Solver may appear during or after input - e.g. when you enter or modify Stair geometry values or the 

Rules and Standards, in Stair Settings.

It can also appear when you change a Turning Type or a Segment Type.

Hover over each solution in the Solver dialog to see how it will change the Stair. Note the feedback on the 

Stair itself, as well as within the dialog box:

• Read the pop-up note to find out exactly what will be altered for each solution.

• The colored fill and/or line indicates the part of the Stair that will be altered.

Click the checkmark of the solution you prefer: the result is a Stair whose geometry has been altered, using 

the solution you choose, to conform to the Rules and Standards. 

See Stair Settings: Rules and Standards.
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Stair Settings (Main Element Settings)

Choose the main Stair node from the tree structure at left to access these settings.

Related Topics:

Stair Settings: Geometry and Positioning

Stair Settings: Rules and Standards

Winder Types for Equal-Going Winders
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Stair Settings: Geometry and Positioning

Use this panel of the main Stair Settings page to define essential Stair geometry.

Stair Toplink

• Use this control to toplink the Stair to a particular Story.

If you later modify the positions and heights of stories in your projects, the heights of any linked Stairs will 

follow automatically, if the change still allows the Stair to follow its Rules and Standards. If there is a 

conflict, you are prompted to resolve it.

See Toplinked Stairs and Changed Story Height.

• Offset: Optionally offset the Stair top from its top linked story (the Stair height changes accordingly). This 

offset value can be positive, negative or zero.

The offset field is not available if the Stair has no top link.

• Not Linked: Choose this to make it a fixed-height Stair instead of toplinked.

• Flexible: This option is available before you begin Stair input (not for an existing Stair). The Stair is not 

linked, and the Stair height is not defined; it will depend on your input.

Use this option, for example, if you are creating a Stair using a fixed Riser height, but the number of Risers 

will be determined when you are done with input.

Stair Height

Value is affected by the top and bottom offsets, if any. 

For a toplinked Stair, this field is not editable.

Bottom Offset

Offset the Stair bottom in either direction.

Home Story

Choose one of the following Home Story settings. The bottom of the Stair (where the Stair reference line is) is 

physically linked to its Home Story. If you later modify the Home Story’s position (e.g. redefine the floor level), 

the Stair will change its position (while respecting the defined offset, if any).

• Current story: Home Story is the current story, on which the Stair is placed.

• Click Select Story to bring up the full list of stories in the project, if they are not all shown in the list.

• Optionally, define an offset for the Stair bottom from its Home Story.
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If you delete the Stair’s Home Story, the Stair will be deleted, along with all other elements located on the 

story.

If you change a Stair elevation so that its reference line is moved to a different story, you have the option to 

make the Home Story change to match the element’s new location.

See Change Home Story by Elevation.

Bottom Elevation [to Reference level]: Calculates the current elevation of the Stair’s baseline, as measured 

from the Reference level (by default, this Reference level is Project Zero). Click the pop-up arrow to change 

the Reference level, if needed.

Note: Reference levels are defined at Options > Project Preferences > Reference Levels.

For general information on levels, see Reference Levels Preferences.

Stair Geometry Controls

Use these fields to set essential Riser/Tread geometry (each setting is described below). Available values are 

tied to the range, if any, set in the Treads & Risers section of the Rules and Standards panel below.

Stair Tread/Riser Settings Depend on Ranges Set in Rules & Standards

Stair Width

Enter a value for the Stair width.

Number of Risers

Choose a value from the drop-down list. The available values depend on the ranges you set in the Rules and 

Standards panel, below, and on the Riser Height setting.

Note: If the Stair is being placed with Flexible Stair Height, the Riser Height control is greyed.
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Riser Height

Choose a value from the drop-down list. The available values depend on the ranges you set in the Rules and 

Standards panel, below, and on the number of Risers.

Going Depth

Note: In the USA version of ARCHICAD, “Goings” are known as “Runs”. 

Choose either Flexible or Fixed.

• Flexible: the Going value will be defined by ARCHICAD automatically, based on the input geometry, and 

within the range (if any) set for the Going in the Rules and Standards panel.

• Fixed: Enter a fixed Going value here, within the range (if any) set for the Going in the Rules & Standards 

panel.

Start/End Stair with Tread or Riser

Use the pop-up controls to define how to begin and end the Stair: with a Tread or a Riser.

You can also switch this preference at any time on a placed Stair.
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Riser Geometry: Straight or Slanted

Choose either Straight or Angled for the Riser. 

For angled: Define the angle value in the field at right, either with an Angle degree (of slanted Riser, relative to 

horizontal) or by Distance (that Riser bottom is set back from Riser top).

Turning Type

Choose a Turning Type for the Stair, then click the pop-up at right to set its specific geometry options.

• Automatic Landing

• Winder with Equal Goings
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• Winder with Equal Angles

For details, see Stair Turning Type.

Calculated Walking Line

The Stair’s Walking Line position is calculated automatically, and is normally in the center: its offset is half the 

Stair Width value. This is the Calculated Walking Line. 

Note: To show/hide the Calculated Walking Line, use View > On-Screen View Options > Stair 

Calculated Walking Line.

For a Stair Winder with Equal Goings, you have the additional option to offset the Calculated Walking Line:

Offset Walking Line on Turning (Winder with Equal Goings)

Use the pop-up to specify an offset for the Calculated Walking Line from the right or left edge of the tread, on 

the Stair Turning. This offset will affect Tread geometry. 

This control is editable only if the turning is set to “Winder with Equal Goings”.

The Walking Line offset range is defined by the Rules & Standards for Walking Line Calculation. 

Note: If you set a range for the Walking Line Offset (in the Rules and Standards panel below), then the 

Stair width has to be greater than or equal to two times this offset. 

Stair Baseline

Define the Stair’s Baseline (Reference Line) position, and an optional offset. 

The Baseline serves as the basis for the Stair’s Home Story, and as a reference for editing Stair geometry.
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To show/hide the Stair Baseline on the Floor Plan, to make editing easier, turn on View > On-Screen View 

Options > Stair Baselines.

See also Edit Stair Baseline.

Watch the Video
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Stair Settings: Rules and Standards

Use this panel of the main Stair Settings page to optionally set a preferred range of values for Stair geometry 

variables, e.g. to meet local Stair regulations. 

During Stair input, ARCHICAD will automatically create a Stair that adheres to Rules and Standards you 

define here.

Treads & Risers

These values define the range of possible input values in the Geometry and Position Panel - for example, you 

cannot input a Riser Height value that is less than the minimum you define in Rules and Standards.

In case these defined Rules & Standards conflict with the Stair geometry you input graphically or via Settings 

dialogs, ARCHICAD will automatically propose alternatives and let you pick one.

See Automatic “Solver” Options to Resolve Geometric Conflicts.

Walking Line Calculation and Symbol

The Walking Line Offset Range defined here limits the values you can enter when defining an offset for the 

Calculated Walking Line.

See Offset Walking Line on Turning (Winder with Equal Goings).

Headroom

Set rules for displaying a Headroom symbol in 3D and Section/Elevation.

• Method: Choose to define the height either vertically, or perpendicular to the walking line.

• Headroom Height

• Offsets from Stair edges
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Turn Headroom display on/off at Model View Options.

See Model View Options for Stairs.

You can run Collision Detection to locate headroom conflicts.

See Collision Detection.

Save Rules and Standards in Project Template

The Rules and Standards settings are part of an ARCHICAD Template file. Thus, you can set up company-

specific and/or region-specific settings here, and re-use them via a template on any number of projects.

Stair Rules and Standards: Project Preferences

Use the Visibility (show/hide) icons at Options > Preferences > Stair Rules and Standards to show or hide 

particular rules for your project.

Any item that is set to be hidden (in Preferences) will not appear in the Rules & Standards panel of Stair 

Settings, provided that the rule is not in use.
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If you hide a Stair Rule name in Project Preferences, yet the Rule still appears in the Rules and Standards 

panel of Stair Settings, there is a reason for it:

• The Rule has values assigned (to remedy this, uncheck the Min/Max values for that Rule in Stair 

Settings), or

• The Rule is in use by an existing Stair in the project

Watch the Video
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Toplinked Stairs and Changed Story Height

Like Walls, Stairs can be linked to Stories, and so can follow changes in floor height.

See Stair Toplink.

If the Story height changes only by a small amount, the Stairs will follow automatically (the number of risers 

will remain fixed, and only the height of the risers will increase – within the set Rules).

If Story heights change by a significant amount, then ARCHICAD highlights the affected Stairs in the whole 

project until the user changes any of the given data (e.g. number of steps or Riser heights).

Note: To set the highlight color of invalid Stairs, use the control for Inverted elements at Options > Work 

Environment > On-Screen Options. 
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Stair Settings provides feedback that indicates the changed parameters:

To make the Stair valid (i.e. to extend to the upper story), enter the original offset value into the Settings 

dialog, then change the number of Risers if necessary.

Find Invalid Stairs

To easily locate Invalid Stairs in a project, use the built-in Invalid Stairs Criteria set with Find & Select.
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Tread and Riser Finishes

From Stair Settings, select Finish from the tree to open this page. 

Check Finish to add Tread/Riser Finish components to the Stair.

Below, click the components you need:

• Flight Finish: Apply to Tread, Riser, or both

• Landing Finish: Apply to Tread, Riser, or both

The components you choose appear in the tree structure: a separate settings page for each of the Tread/

Riser/Landing/Flight finishes.
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Uniform Finish on Flight and Landing

Check this option to use the same Finish settings for all the Stair’s Treads and Risers, on both Flights and 

Landings. The number of settings pages is thus reduced.

Tread and Riser Settings: Choose Component

On the Tread and Riser Settings pages, as applicable, choose a GDL component from the pop-up to serve as 

the Finish:

Choose Component as Tread Finish

Choose Component as Riser Finish

Riser on Tread: Check this to place the Riser on top of the Tread. (If this is unchecked, the Riser extends to 

the bottom plane of the Tread - see the diagram.)
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Tread and Riser Component Settings

Use the Component Settings panel to specify the shape and appearance of the chosen finish. The settings 

vary depending on the chosen component:

Choose Tread Profile and Building Materials
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Choose a Separate Accessory Tread Profile 
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Edit Individual Treads or Risers

Use Edit mode to edit individual Tread and Riser components. You must edit Treads and Risers separately.

For example, edit the shape of certain Treads and Risers of a Stair that has a built-in cabinet structure.

1. Select the Stair and enter Edit mode. (See Enter Edit Mode.) Here, use the Schematic view.

2. Select each Tread individually. Use the familiar pet palette commands to edit them.
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3. Switch to the 3D window: note that you are still in Edit mode.

4. Continue editing the Stair components - here, edit the Risers individually.
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5. When the Stair is complete, use Solid Element Operations to connect it to the Wall.

Define Custom Tread Segment: Front, Back, Left, Right

When you edit a Tread to change its shape, the Tread accessories - such as the nosing - might not extend to 

the customized parts.

In this case, you can customize any Tread segment to behave like the front, back, left or right side of the 

standard tread shape.

1. Select the Stair, then enter Edit mode.

2. Select a Tread, then click on one of its side segments.

3. From the pet palette, choose Custom Tread Polygon Settings.
ARCHICAD 24 Reference Guide 1142



Construction Elements Elements of the Virtual Building
4. Set tread polygon segment as “Front”. 

Note: To change all tread segments, choose All Segments from the Apply changes to pop-up.

5. The customized Tread segment now behaves like the front of the Tread and also displays the nosing.

Edit Individual Riser Heights in Edit Mode (Section/Elevation)

To edit the height of each Riser separately, you can use Edit mode from the Section or Elevation window.

(For example, to document a historic Stair with Risers of various heights.)

1. Select the Stair in the Section/Elevation window, then enter Edit mode.

2. Select a Tread.
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3. Drag the top of the Tread to the desired location.

The Riser Height is adjusted. Note that the entire Stair shape is affected (including the connecting Structure).

Hide Any Edge of a Single Tread

You may wish to hide a tread line in 2D. For example, you can hide the top tread line, if the last tread is on the 

same level as the slab of the landing.

1. Select the Stair in the Floor Plan window, then enter Edit mode.

2. Make sure that Edit mode is using the Schematic view

3. Select a Tread, then click on one of its side segments.
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4. From the pet palette, choose Custom Tread Polygon Settings.

5. Click Hide Segment.

Note: To hide all segments: Choose All Segments from the Apply changes to pop-up.

6. View the result in Symbol view.

See also Walking Line End Symbol: End at Second to Last Tread.

Watch the Video

Watch the Video

Watch the Video
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Flight and Landing Structures

In Stair Settings, select the Structure node in the tree to open the Structure tab page.

Use this page to select Structure types for the Stair Flights and for the Landings.

Check the Structure box to use a Stair Structure.

Note: You can turn the Structure on or off for any single selected Flight or Landing, using Edit Mode. (See 

Select Stair Component for Editing.)

Choose Structure Type

Structure types include Monolithic, Beam, Cantilevered, or Stringers Only. 

Note that the contents of the Settings tree structure reflect your choices here. 

As a rule, it is recommended to use the same structure type for both Flight and Landing: this will ensure that 

all Stair sub-elements will be documented correctly.

Note: It is also possible to use two different Structure types for a single Flight.

See Split Stair Structure.
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Add Stringers

Optionally, add Stringers to the Left and/or Right side of the Flight or Landing. Notice that Stringers can be 

added to every other Structure type. Stringers tab pages are added to the Structure node accordingly.

In the tree structure, click on a component (Flight or Landing) to open the respective Structure Settings page. 

The settings here correspond to the Structure type (e.g. Monolithic) you chose on the main Structure page.

What’s Covered

Monolithic Flight and Landing Structures

Beam Flight Structure

Beam Landing Structure

Cantilevered Flight and Landing Structure

Stringers Flight and Landing Structure
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Monolithic Flight and Landing Structures

These settings are available if you chose a Monolithic Structure type for the Flight and/or Landing.

See Choose Structure Type.

Monolithic Flight Structure: Choose Shape

Use the four buttons to choose a shape for the bottom of a Monolithic flight. From left:

• Flat

• Stepped

• Variable Thickness (at each end)

• Filled

Below, enter values for the thickness/offset variables as applicable. Note the feedback in the Preview window.
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Monolithic Flight Shapes

Monolithic Support Component Settings

Use this panel to set attributes, including Building Material, for the Monolithic Flight/Monolithic Landing.

Check Uniform Flight and Landing Attributes to apply the same attributes to both Monolithic structures 

(Flight and Landing).

Note: The “Uniform attributes” checkbox applies only to Structure attributes, not its thickness.
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Draining on Flight/Draining on Landing

This panel is available for Monolithic structures only.

Check Draining to place a Draining on the left and/or right side of the Stair structure (available for both Flight 

and Landing).
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Check Uniform Draining Settings on Flight and Landing to apply settings to both Stair structures.

For Draining on Flight:

• Choose Draining Type (Flat or Stepped) for both Flight and Connections. This setting will be used for the 

Draining on Landing, if any.

Set Draining width/depth values as applicable, and an optional offset.

If needed, apply a Surface override to the Draining.
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Monolithic Stair with Draining on Both Sides
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Beam Flight Structure

These settings are available if you chose a Beam Structure type for the Flight.

See Choose Structure Type.

Beam Structures are GDL elements: choose a component from the pop-up to serve as the Beam support. 

Components include a general Beam; profiled Beam; and Open Stringer (see below).

For details, see Custom Sub-Elements for Stairs and Railings.

Use Open Stringer (Beam Flight Structure)

An “Open Stringer” structure is available from the Beam - Flight component pop-up list.
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Use Beam Component Settings to position the Stringers. Note the options to match Riser Width to either the 

Stringers (if they are offset) or the Stair Boundary. 

Choose Shape

In Beam Flight Settings, choose a Beam Structure shape: either flat or stepped. Profile components are also 

available.
ARCHICAD 24 Reference Guide 1154



Construction Elements Elements of the Virtual Building
Below, enter a value for the Beam thickness. Note the feedback in the Preview window.

Beam Flight Structures: Flat, Stepped, Profiled

Beam Component Settings

Use this panel with its tab pages to set the Beam component’s settings.

Beam Anchor Point

The Anchor Point is at the top of the beam: choose Top Left, Top Middle or Top Right.

Important: For a profiled Beam, the default Anchor is the Profile Origin. For correct connections, make 

sure the Profile Origin is defined at the top of the profile! Alternatively, set the Anchor Point to one of the 

“Top” options in the pop-up.
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See also Profiled Stringer: Special Options.

For Profile definition, see Profile Origin in Profile Editor Window.

Set Number of Beams

Use this control (Style and Dimensions page of Beam Component Settings) to add multiple Beams (up to 

10) to serve as the Stair’s support structures on all flights.

Notes: 

– Number of Beams must be set (on separate Settings pages) for both Flight and Landing.

– In Edit mode, you can customize the number of beams per Flight or per Landing, as needed.
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Beam Attributes and Representation

Depending on the Beam component, set its Building Material and/or choose a Profile. Adjust its values as 

needed.

Note: 

– Beam attributes must be set separately for Flight and Landing.

– The “Uniform Building Materials” checkbox enables a single Building Material for the listed Beam 

components (e.g. Beam, End Plates, Secondary Support).

Add Tread Plates and/or End Plates to Beams

See also Add Tread Plates at Beam Landing.
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Tread Plate Follows Tread Polygon
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End Plates at Top and Bottom

Add Secondary Supports to Beams

For a Beam Flight Structure, you can add additional components to support the Treads. 

Go to the Secondary Support tab page, and enable the Secondary Support checkbox.

From the pop-up, choose and set the desired component.

You can control the number of supports at either end of the beam, using the Add or Remove pop-ups:
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Beam Flight Support, with Secondary Supports
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Beam Landing Structure

These settings are available if you chose a Beam Structure type for the Landing.

See Choose Structure Type.

Choose a Landing Support structure for the Stair, which can be Beam-type or Frame-type. Profiled Landing 

components are also available.

On the panel below, set up the chosen structure.

Primary and Secondary Landing Beams

• Primary Landing Beams will connect automatically to the Flight beams, as defined at Flight Structure 

Settings. 

See Stair Endings and Connections.

• Secondary (Additional) Beams can be added parallel to the sides of the landing. Secondary Beams do 

not connect automatically to Flight Beams.

For more information, see Add/Edit Secondary Beams.
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Landings with Primary and Secondary Beams

The Primary Beam generally follows the Stair Centerline, but you can also choose a different Beam path (use 

the Primary Beams - Style and Dimensions tab page):

PRIMARY BEAMS POSITION

Follow Centerline Lead/Trail End to Boundary
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Landing Frame (Primary Beam)

You can choose a Frame to support the Stair Landings. Like other primary beams, the Landing Frame 

component connects automatically to Flight support, as defined at Flight Structure Settings.

See Stair Endings and Connections.

Follow Centerline - Expand to Boundary Follow Centerline - Expand to Boundary 
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Use Beam Component Settings to configure the chosen Landing Frame:

• By default, the Landing Frame follows the Landing outline.

• However, you can use Beam Settings to adjust the outline so it ignores Landing segments that are shorter 

than a certain length:
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Custom Landing Beam (Primary Beam)

Use this function when the Stair Flight below the Landing uses a different number of Beams than the Flight 

above the Landing. (You can define beams for each Flight structure separately in Edit mode.)

To place a custom Landing Beam:

1. Choose Custom from the Beam Settings page (Primary Beams - Style and Dimensions tab page).

2. Switch to the Placement and Positioning tab page.

3. Enter the number of Beams to place.

4. Enter position and offset values for the custom landing Beam(s).
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Since these custom Beams are Primary Beams, they can connect to the Flight supports.

Add/Edit Secondary Beams

To add additional (Secondary) Beams, you must use Edit mode. (Secondary Beams are positioned to an 

existing Landing’s geometry, and thus must be added to a placed, selected Stair.)

1. Select the Stair and enter Edit mode. (See Enter Edit Mode.)

2. Select the Landing Structure, and open Structure Settings.

3. In the Beam Component Settings panel, open the Additional Beams tab.
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4. Check Enable Secondary Beams (if it is not checked already).

Add Secondary Beams in Edit Mode
ARCHICAD 24 Reference Guide 1167



Construction Elements Elements of the Virtual Building
5. Use the checkboxes and settings to add Secondary Beams to one or more segments of the Landing 

polygon.
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The secondary beam(s) are placed. Use Edit mode to stretch and move them as needed, using the editable 

hotspots.

Modify Secondary Beam Graphically in Edit Mode

Add Tread Plates at Beam Landing
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Tread Plate at Beam Landing
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Cantilevered Flight and Landing Structure

These settings are available if you chose a Cantilever Structure type for the Flight and/or Landing.

See Choose Structure Type.

Choose a Cantilever Component type - e.g. Bracket or Block.

Use the Cantilevered Component Panel to configure the chosen structure:

• Set cantilever structure on left, right, or both sides of Stair

• Add an optional Tread Plate
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Use Edit Mode to add an optional Wall Fixing to Flight or Landing, as shown below: 

Add Wall Fixing to Cantilever Flight (Select and Edit Flight Structure in Edit Mode)
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Add Linear Fixings to Cantilever Landing Segments (Select and Edit Landing Structure in Edit Mode) 
ARCHICAD 24 Reference Guide 1173



Construction Elements Elements of the Virtual Building
Stringers Flight and Landing Structure

This page is shown in the Stair Settings tree structure

• if the Flight or Landing Structure is set to Stringers Only, or

• if the Stair has any other Flight Structure that uses Stringers

See Choose Structure Type.

Select Stringer to Edit

Edit the left and right stringer separately, as needed.

Alternatively, check Uniform Stringers on Left and Right, to apply the same settings to both Stringers. 

Notes: 

– Stringers attributes must be set separately for Flight and Landing.

– The Connection and Ending settings are included in the “uniform” settings. If you want to use identical 

Stringers but with varying connections (e.g. to the Landing), you must uncheck the Uniform box!
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Stringer Structure Settings

For a Flight Stringer: Choose a shape for the Stringer, either flat or stepped.

Stringer Support Component

Choose a GDL component from the pop-up to serve as the Stringer. 

Note: The Open Stringer is available as a Beam. On the Structure page, choose Beam as the Flight 

Structure, then choose the Open Stringer component from the Beam-Flight node.

See Use Open Stringer (Beam Flight Structure).
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Add End Plates

End plates can be placed at Stair top and/or bottom (for a Flight Stringer), or at Lead End and/or Trail End (for 

a Landing Stringer).

The chosen Stringer’s settings are in the panel below.

Profiled Stringer: Special Options

• The profile Stringer can be mirrored: For example, place mirror-image Z-shaped profile stringers on both 

sides of the Stair. 

Z-Profile Stringers - Mirrored

• Adjust the Profile’s Anchor point (by default, it is the point defined as the Profile Origin) using the pop-up.
ARCHICAD 24 Reference Guide 1176



Construction Elements Elements of the Virtual Building
• Important: If using the Profile Origin as Anchor Point, make sure that the Profile Origin is defined at the 

top of the profile, to ensure correct connections. (Alternatively, set the Anchor Point to one of the “Top” 

options in the pop-up.)
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Winder Stair with Stringers

If a winding Stair uses Stringers on both sides, the inside Stringer cannot automatically follow the steeply 

rising Stair geometry. In this case, ARCHICAD will disconnect the inside Stringer, so that you can adjust it 

manually as needed.

(The Column at the inside of the Stair is a separate element.)

1. Select the Stair in the 3D window and enter Edit mode.

2. Select each end of the disconnected Stringer, and use the editing hotspots to drag them into position.
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3. Now the Stringers are in position.
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Split Stair Structure

Use this function to obtain multiple Structure types for a single Stair flight.

This command is available in Edit mode, in the 3D window only:

1. Select the Stair in the 3D window.

2. Enter Edit mode.

3. Select the Flight structure. (See Select Stair Component for Editing.)

4. From the context menu, choose Split Stair Structure.
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5. Based on the on-screen feedback, drag the cursor and click to split the Structure at the desired point. (The 

split always occurs at a Riser.)

6. Proceed to select and customize each part of the structure separately, as needed. Split the structure as 

many times as needed.
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Custom Sub-Elements for Stairs and Railings

Stairs and Railings include GDL sub-elements. Many pre-defined sub-elements are available by default, 

through the element and component settings dialogs. Each such GDL sub-element can be configured with its 

own Building Material and/or Custom Profile.

To create your own sub-element, you can customize an ARCHICAD element and save it as a specialized 

Library Part.

For more information on this function, see Create Custom Library Parts and Components.

For Stairs and Railings, use this function to create custom Treads and Risers (Stairs), and custom Panels and 

Posts (Railings). 

Some examples follow.

Create Custom Stair Tread

1. Select the Stair and enter Edit mode.

2. Select a Tread.
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3. From the context menu, use Convert Selection to Morph. The selected sub-element is now a Morph, 

and no longer part of your Stair.

Note: It is also possible to start with any Morph element; it is not necessary to transform an existing Tread 

to a Morph first.

4. Exit Edit mode.

5. Edit the Morph as needed - here, use the Bulge command to create small recesses on either end.
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6. With the Morph selected, use File > Libraries and Objects > Save Selection as...

7. Select Stair Tread as the predefined sub-type, and save it to the Embedded Library.

8. A Stair-like ghost feedback appears to help you orient the new Tread object: 

• Click once to define the midpoint of the Tread’s top edge (without nosing)

• Click a second time, on the edge, to define its horizontal position.
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Click at Tread Midpoint, then Tread Edge to Define Position

9. Select the Stair and open Tread Settings. 

10. The dialog indicates a custom Tread, because the Tread you converted into a Morph is now missing. Click 

the Reset Custom Treads button to resolve this.
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11. The new custom Tread is available as a Component of Tread Settings: Select this Tread to apply it to the 

entire Stair.

Watch the Video
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Stair Endings and Connections

Stairs are not associative to other 3D elements. To join a Stair to a Slab or to a Wall, use Solid Element 

Operations.

See example at Solid Element Operations.

However, you can use Stair Settings (Flight Structure):

• to define the endings of Stair structures

• to create connections between a Stair’s Flights and Landings. You can use different connections within a 

single Stair.

To set Endings and Connections for the Stair, go to the Flight Structures Settings page, and the Support 

Connections Panel. This panel is available in both Stair Settings (Flight Structure) and for a selected Flight 

Structure in Edit mode.

• All the Stair’s Flight and Landing connections and endings are handled here:

– Flight-Start

– Flight-End

– Flight-Landing

– Landing-Flight

– Flight-Flight
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• In the Preview, hover and click to choose the connection or ending you want to edit.

• From the pop-up, choose the desired Connection type. This is a fixed set of options, which vary 

depending on the structure and connection/type. 

• The Automatic options require no additional settings from the user.

Landing-Flight Connection: Automatic Cut
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Beam Flight Ends: Horizontal and Vertical

Monolithic Flight End: Horizontal with Bearing Nib
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Monolithic Flight End: Adjust Vertical Cut

Landing-Flight Connection: Bisector
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Landing-Flight Connection: Horizontal

Use the following connection type to make a space for an added element (e.g. Column):

 Flight-Landing Stringer Connection: Adjust Vertical Cut to Add Gap
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Model View Options for Stairs

Model View Options affect the on-screen and output display of Stairs in 2D and 3D. They set the detail level of 

Stairs in Sections, Elevations and 3D views, as well as their plan-specific display (Floor Plan or Reflected 

Ceiling) in 2D.

Watch the Video

Stair Options

This panel is at Document > Model View > Model View Options.

Stair Detail Level in 3D and Section

Choose either Full or Schematic, to define the display and output of Stairs in Sections/Elevations, and in the 

3D and 3D Document windows (including Edit mode). 

• In Full mode, the complete Stair appears: all 3D sub-elements can be seen in full detail.

• In Schematic mode, a continuous membrane surface is used to indicate the top surface of the steps.

– For Schematic: Click Attributes to customize surface and line options for Stairs displayed in 3D and 

Section views.

• Headroom: Check to show or hide the display of Headroom in 3D and Section. 

Note: To define Headroom rules: use the Rules and Standards panel of Stair Settings. (See Headroom.)
ARCHICAD 24 Reference Guide 1193

https://youtu.be/ncle0l_JYXM


Construction Elements Elements of the Virtual Building
Stair Symbol: Choose Floor Plan Display or Reflected Ceiling Plan

Set this control for the Stair Floor Plan Symbol: either “Floor Plan Display” or “Reflected Ceiling Plan 

Display”.

Each Stair (in its own Stair Settings dialog) has two groups of settings, defining display preferences for each of 

these two symbol types. Switch this Model View Option (Stair Floor Plan Symbol) to control which group of 

settings to use, by Model View.

See also Floor Plan/Reflected Ceiling Plan Display (Stair Settings).

Show/Hide Stair Symbol Components (by Model View Options)

Use the checkboxes at Model View Options > Stair Options to control which items should be used in Stair 

symbols, by Model View.

You can override these settings for any single Stair, in Stair Settings.

See Stair Settings: Symbol Components.
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To fine-tune Symbol display (based on a Stair’s Visible/Hidden parts), use the “Detail Level” panel of the 

Model View Options dialog box: 

Detail Level of Stair and Railing Symbols

Model View Options for Stairs: Examples

The Model View Options for Stairs provide great flexibility for fine-tuning the 2D display of Stairs according to 

different Model Views.

The following three Stairs are shown on the Ground Floor, at various scales. From left: An Entrance Stair; 

Stairs between Stories; and a Staircase.

Construction Plan 1:50

Reflected Ceiling Plan 1:50
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Building Permit 1:100

Site Plan 1:500
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Detail Level of Stair and Railing Symbols

This panel is at Document > Model View > Model View Options.

The list includes Stair Symbol Components and Railing Symbol Components.

Note: Components are listed here only if they are checked in the “Symbol Components” list, in the Stair 

Options or Railing Options panels of the same dialog box.

Set the Detail level of each Symbol component, as applicable:

• None

• Visible Parts Only

• Hidden Parts Only

• Visible & Hidden Parts

Visible Parts and Hidden Parts

A Stair’s “Visible Parts” represent the Stair’s primary appearance, and are displayed using the “Visible” line 

type defined in Stair Settings (usually a solid line).

A Stair’s “Hidden Parts” represent the Stair’s secondary appearance, and are displayed using the “Hidden” 

line type defined in Stair Settings (usually a dashed line).

See Set Attributes for Each Stair Symbol Component.

Visible parts are usually under the Break Mark; Hidden parts are usually above the Break mark.

Related Topics:

Model View Options for Stairs

Model View Options for Railings
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Floor Plan/Reflected Ceiling Plan Display (Stair Settings)

Each Stair has two groups of settings, defining display preferences for the Stair Symbol (and its components) 

on Floor Plan and on Reflected Ceiling Plan. 

Note: Switch the Stair’s display by view, using Model View Options. See Stair Symbol: Choose Floor Plan 

Display or Reflected Ceiling Plan.

What’s Covered

Stair Display Layouts (Show on Stories)

Choose the stories on which the Stair’s 2D symbol should be displayed.

Layout On (Stair Display On Each Story)

Vary a stair’s symbol display, story by story. 

Stair Settings: Symbol Components

Show or hide each symbol component of the Stair. (Overrides the show/hide definitions at Model View 

options.)

Stair Settings: Symbol Overrides

Apply overrides to the display of the Stair’s entire 2D symbol (lines, pens, fills).

Set Attributes for Each Stair Symbol Component

Set attributes and choose symbol type for any Symbol component (e.g. Break Mark, Walking Line, 

Numbering).
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Stair Display Layouts (Show on Stories)

Use the pop-up to define the Stories on which the Stair’s 2D symbol should be displayed.

The stories you define (for example, “All Relevant & One Story Up”) are listed in the field below (under “Layout 

On”).

Relevant Story

A Relevant Story is one which the Stair physically intersects. When defining Stories for Stair display, multistory 

Stairs can have, for example:

• a Relevant Bottom Story

• one or more Relevant Middle Stories

• a Relevant Top Story

Layout On (Stair Display On Each Story)

Under Layout On: Click on each Story name, then choose how to display the Stair on that story:

• Break Mark: With or without a Break Mark

• Visible vs. Hidden Attributes: To use either Visible or Hidden attributes on the displayed parts of the 

Stair. The set of attributes (for hidden and visible parts) is defined for each symbol component on its own 

settings page. See below.
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Use the Preview to get an idea of the Stair’s 2D display on each story.

Note: If the Stair has an associated Railing, you can apply these same Display settings to the Railing: Use 

the checkbox in Railing Settings (see Railing Display Layouts (Show on Stories).)

Stair Layout Examples

Stair Layout on Ground Floor: With Break Mark, Use Visible Line Type (Below) and Hidden Line Type (Above)
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Stair Layout on First Floor: No Break Mark, Use Visible Line Type

Additional Layouts are available for multistory Stairs, with multiple Break Marks. 

See also Relevant Story.

On a given Story, you can just display the part between Break Marks.

Stair Layout on Middle Stories: Display Between Break Marks Only
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Stair Layout on Middle Stories: None (below Break Line1) - Visible (Between Break Lines) 

- Hidden (Above Break Line 2)

Stair Settings: Symbol Components

These controls are available for both the Floor Plan Display node and the Reflected Ceiling Plan Display node 

of Stair Settings.

Symbol Components: By Model View Options

Check this to show/hide the Stair’s 2D components as defined at Document > Model View > Model View 

Options.

See Show/Hide Stair Symbol Components (by Model View Options).
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Symbol Components: Customize in Stair Settings

Uncheck “by Model View Options” and use the list below to specify which symbols to show or hide. The Grid 

and Break Mark cannot be hidden.

For example: If you have both an existing and a new Stair in the same view, you may prefer to display the 

existing one with less detail. 

Select that Stair, open its Settings, and uncheck By Model View Options.

From the list below, uncheck the items (e.g. Description, Numbering) that you don’t need to see on that Stair.

Note: This Stair, for which you customized the visibility of its Symbol components, will always appear as 

you set it, regardless of the current Model View Options setting!

Stair Settings: Symbol Overrides

Available for both the Floor Plan Display node and the Reflected Ceiling Plan Display node of Stair Settings. 

These settings are independent of Model View Options.

Use them to optionally apply overrides to the display of the Stair’s entire 2D symbol (lines, pens, fills). 
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• To apply a Line/Pen/Fill override: Check the respective Override box, then select an attribute from the 

controls below.

Set Attributes for Each Stair Symbol Component

Available for both the Floor Plan Display node and the Reflected Ceiling Plan Display node of Stair Settings. 

These settings are independent of Model View Options.

To set attributes, choose a Symbol component (Break Mark, Walking Line, etc.) from the Stair Settings tree 

structure, to access its settings. 

For each Symbol Component:

• Choose a Component type from the pop-up menu

• Set the Component’s attributes in the bottom panel - separately for the Visible and Hidden parts of the 

symbol, as applicable.

See also Visible Parts and Hidden Parts.
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• View the Preview to get an idea of how the component will look.

Structure Component Settings

Use these controls to set the 2D display of Stair Structures (Flight and Landing), depending on the Structure 

type you are using.

Note: Stair Structure components are selected on the Structure node of Stair Settings. See Flight and 

Landing Structures.

Attributes vary for the structure’s Visible and Hidden parts.

Break Mark Symbol

• Choose a Break Mark Symbol (e.g. Zigzag)

• Set Break Mark position by Height or at a particular Riser number

• Set Break Mark angle (to Vertical/Horizontal, or define the number of goings that it should span)

• Apply an optional extension to the Break Mark lines
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• Set Break Mark attributes (Break Mark Component Settings), including the width of the “Motif” (e.g. 

zigzag) if any

You can edit the Break Mark symbol graphically, after selecting it in Edit mode (Symbol view).

See also Edit Break Mark Symbol.

Walking Line Symbol: Position and Display Settings

The Walking Line Symbol Position refers to the Symbol, whose position you can edit manually, either here or 

in Edit mode.

(In contrast, the Calculated Walking Line, defined in the Geometry and Positioning panel of Stair Settings, 

affects Tread geometry, and can be edited in Stair Settings only. See Offset Walking Line on Turning (Winder 

with Equal Goings).

In the Display Settings shown here:

• “Default” setting means that the Walking Line Symbol is at the same location as the Calculated Walking 

Line, defined in Stair Settings - Geometry and Positioning panel

• “Center” places the Walking Line Symbol at the center of the Stair

• “Custom” means that the Walking Line has been edited graphically to a new position

For details on Symbol editing, see Edit Stair Symbol Components Graphically.
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Walking Line End Symbol: End at Second to Last Tread

Check this option to end the Walking Line at the tread before the last one.

Walking Line End Symbol: Edit Arrow Width/Height

When choosing an End symbol for the Walking Line, note that the “automatic” options mean that the arrow 

endpoints are fixed, to exactly one Going width. 

To edit arrow endpoints, choose a Custom symbol type. You can edit the arrow graphically, too, in Edit mode.
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See also Edit Walking Line Arrow and Edit Walking Line Symbol Position.

Numbering Symbol: Show Numbers on Stories

Use these controls to set the Numbering preferences for the Stair, including story-dependent display, as 

needed.

Numbering: Choose Risers or Treads.

Placement: Choose which Treads/Risers should be numbered.

Other options let you define where to begin and/or end the Numbering, or to restart Numbering at Landings.

You can edit (move or rotate) the numbers graphically, after selecting them in Edit mode (Symbol view).

See Edit Stair Numbering Items.

You can also use special Stair Labels to number Treads and Risers: See Labeling Stairs.
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Edit Stair Symbol Components Graphically

Use Edit mode to edit the Stair’s symbolic components graphically, after selecting the component in Edit mode 

(Symbol view).

For example:

Edit Break Mark Symbol 

Edit Walking Line Arrow

To edit arrow endpoints graphically in Edit mode, you must be using a Custom symbol type.
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Choose the Walking Line End Symbol in the Floor Plan Display or Reflected Ceiling Plan pages of Stair 

Settings.

See Walking Line End Symbol: Edit Arrow Width/Height.

Edit Walking Line Symbol Position

Make sure you are in Symbol mode, then select and graphically edit the position of the Walking Line symbol.

Edit Stair Numbering Items

You can edit (move or rotate) the numbers graphically.

Related Topics:

Set Attributes for Each Stair Symbol Component

Walking Line Symbol: Position and Display Settings

Watch the Video
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Railings

What’s Covered

About the Railing Tool

Place Railing: Basic Polyline Input

Place Associative Railing

Working with Railing Segments and Nodes

Railing Reference Line

Railing Tool Edit Mode

Railing Settings: Overview

Railing Settings: Geometry and Symbol Display

Segment Settings (Railing Tool)

Toprail Settings (Railing Tool)

Handrail Settings (Railing Tool)

Rail Settings (Railing Tool)

Inner Post Settings (Railing Tool)

Baluster Settings (Railing Tool)

Panel Settings (Railing Tool)

Node Settings (Railing Tool)

Post Settings (Railing Tool)

Connection Settings (Toprail, Handrail, Rail)

Railing Ends (Toprail, Handrail, Rail)

Model View Options for Railings
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About the Railing Tool

The Railing Tool lets you create any typical or unique Railing, which is a 3D building element. A Railing can be 

associative to the following 3D elements: Stairs, Slabs, Walls, Roofs and Meshes.

Railing input is similar to polyline input, and consists of Nodes and Segments. On the Floor Plan, Railing 

interactions are similar to those of a polyline.

The interactive Pattern Editor helps you assemble a Railing pattern specific to each Segment.

Like the Stair and Curtain Wall, the Railing Tool is a hierarchical element made up of a main scheme plus its 

components: various posts, rails, and/or panels. These are GDL components that use Building Materials and/

or Custom profiles.

Watch the Video

Railing Components

• The Toprail sits on top of the Segment.

• The Railing can contain up to two Handrails, each of which can be doubled to the two sides of the Railing. 

(The two handrails can have different cross sections).

• Rails are general horizontal elements. You can offset them perpendicular to the Railing Segment or set 

them at any height. Rail cross sections can be different for each.

• All horizontal elements (Toprail, Handrails, Rails) can have Connections and Endings added to either 

end. 

• You can add multiple Inner Posts to the pattern.

• Balusters are a pattern within the pattern

• Panels can fill the area between the Toprail, Rails, Inner Posts or Segment boundaries.
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• For Panels and Posts, you can choose not just built-in GDL components, but also custom ones, saved 

using a predefined Railing subtype. 

Railing Display

Model View Options provides three Detail Levels (Full, Simplified and Schematic) to display and output 

Railings in Sections/Elevations, the 3D and 3D Document windows.

See Railing Options.
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Place Railing: Basic Polyline Input

Railing input is similar to polyline input, and consists of Nodes and Segments along a Railing Reference Line.

1. Activate the Railing Tool from the Toolbox or Info Box. Choose a Favorite, if desired.

2. In the Floor Plan or 3D window, draw a polyline representing the Railing Reference Line. Each click 

represents a Node.

3. Double-click to complete.

See also Place Associative Railing.

Watch the Video
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Place Associative Railing

By default, a new Railing is set to be associative to another model element. ARCHICAD Railings can be 

associative to one or more Stairs, Slabs, Walls, Roofs or Meshes.

This means that if any of these element geometries is modified (such as the Stair on which you placed the 

Railing), the associated Railing geometry will move with it. If you delete the parent element, the Railing is 

deleted too.

You can associate a Railing to the following elements:

• Stair (Railing is associated to the Stair Boundary)

• Reference Plane of Slab and Roof

• Reference Line of a Wall

• Nodes and ridges of a Mesh (e.g. fencing)

 

Associate Railing to 3D Model Elements

See the examples below.
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Associative Railing on a Stair

1. Activate the Railing Tool from the Toolbox or Info Box.

2. Click at both ends of the Stair Boundary line, which is highlighted during associative Railing input. 

 

3. Double-click to complete the Railing, which is associated to the Stair. The Railing will automatically follow 

changes to Stair boundary line (curve/straighten edge, insert/remove Node).

 

Railing Associative to Stair
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Add Railing Automatically to New Stair

Before placing a Stair, you can choose to add a Railing to it automatically: click one or both “Add Railing” 

options in the Stair Info Box. This way, you place two elements at once (Stair plus Railing).

Stair Info Box: Add Railing(s) when Placing Stair (Right, Left, Both sides)

Associative Railing on a Slab

1. Activate the Railing Tool from the Toolbox or Info Box.

2. Click on two Nodes of the Slab.

3. Slab outline feedback indicates which edges of the Slab will be used for the Railing. Since the Slab is a 

polygon, there can be more than one solution. Click Tab to see feedback for the alternative Railing paths:

Press Tab to Choose Railing Path Around Slab
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4. Double-click to place the Railing, which is associated to the Slab.

Associated Railing Follows Edits to “Parent” Slab

Flip Segment (Redefine Railing Polyline)

If the Railing is associated to one part of a polygon element, you can flip it to other parts of the parent element.

Note: This is only available if the parent element is a polygon (e.g. a Slab). It is not available for Railings 

on a Stair.

For a selected Railing Segment, use the Segment Type pet palette control. Check the Flip Segment control to 

flip the Railing to another part of the parent element polygon:
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Flip Railing Segment Along Parent Element Polygon

Associative Railing with Magic Wand

Place Railings on associated elements (Stair, Slab, Morph, Wall, Roof) using the Magic Wand.

With Railing tool active, press the Spacebar, then click any element to automatically trace its edge or polygon 

shape and place an associated Railing.

Watch the Video

Watch the Video
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Working with Railing Segments and Nodes

Segments

A Segment is the part of the Railing between two Nodes (like a segment of a polyline). The Segment has its 

own settings, which include the Railing Pattern and Segment Height.

One Railing, Two Segments

You can easily see Segments and Nodes in Edit mode: Turn on the Segments and Nodes visibility.

Segments and Nodes in Edit Mode
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Within a Segment, all component instances are clones of each other. You can see this in Edit mode: selecting 

a Baluster or an Inner Post selects all of its instances within the Segment.

Edit Mode: All Inner Post Instances Are Selected 

Edit Mode: All Baluster Instances Are Selected

Create Independent Segments and Nodes

You may wish to create independent Segments from the Segments of a selected, associative Railing.

Select the Railing and use the pet palette command:
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One Railing, Two Independent Segments

Nodes

Nodes are generated at the points of the Railing polyline. One or more Posts are located at each Node.

Associative Nodes

The visible Nodes of an associative Railing are round dots, generated at each point that you click to define 

the Railing.

See also Place Associative Railing.

Visible Associative Nodes

A Node may also be invisible: When you place an associated Railing, its Nodes may be generated 

automatically, even if you didn’t explicitly click: for example, when you click on two opposite corners of a 

polygon. 
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These are also associative Nodes, although they do not appear as dots.

Automatically Generated, Associative Node (Invisible)

Static Node (Square Dot)

A Railing’s static Node has a square shape.

Add New Static Node

Associative and Static Nodes of Railing along a Slab

Related Topics

Node Settings (Railing Tool)

Segment Settings (Railing Tool)
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Change Associative Segments/Nodes to Static

Change Associative Segment to Static

1. Select the Railing.

2. Click on a Segment. 

3. Use the Railing Segment Type command from the pet palette to open the Segment Type dialog box.

4. Choose Static Segment.

Now the Segment has been disassociated from the Slab. 

You can now edit the two geometries (e.g. Slab and Segments) independently.

Railing Segment Type: Static or Associative

Another method:

1. Select the Railing.

2. Enter Edit mode.

3. Select the Segment.

4. Use the Info Box or open the Segment Settings dialog to change its Associativity to Static.

Change Associative Railing Node to Static

1. Select the Railing.

2. Select the associative Node. 

3. Do one of the following:
ARCHICAD 24 Reference Guide 1224



Construction Elements Elements of the Virtual Building
– Drag an associative Node away from its parent element, to a new position. 

– Use the Railing Node Type command from the pet palette to open the Node Type dialog box, then 

check Static Node.

4. Now the Railing Node has been disassociated from the Slab node. Note the Node shape: it is now 

rectangular.

You can now edit the two geometries (Slab and Railing Nodes) independently.

Railing Node Type: Change to Static

Another method:

1. Select the Railing.

2. Enter Edit mode.

3. Select the Node.

4. Use the Info Box or open the Node Settings dialog to change its Associativity to Static.

Watch the Video
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Railing Reference Line

View Railing Reference Line

To see the Reference Line on the Floor Plan: Turn on View > On-Screen View Options > Railing Reference 

Line. (The arrows indicate the Railing input direction, which determines the Railing’s “left” and “right” sides - 

this is relevant for defining the Handrail position.)

Flip Railing

To flip the Railing to the other side of the Reference Line: Use the Flip Railing command from the context 

menu:

Offset Railing Reference Line

A quick way to edit Railing geometry: Select the Reference Line, then use the offset commands to edit the 

Reference line position (either one segment, or all segments):
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Related Topics:

Offset Railing Segment from Reference Line

Flip Segment (Redefine Railing Polyline)
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Railing Tool Edit Mode

Use Edit mode and its dedicated component tools to access and change the individual components of a 

selected Rail (Posts, Inner Posts, Balusters, Toprail, Handrails, Rails and Panels).

When you select a component (e.g. Inner Post), all its pattern instances are selected, too. When opening the 

component settings, only the relevant geometry is highlighted and you can edit all instances at once.

Watch the Video

Watch the Video
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Railing Settings: Overview

Click the Railing Tool icon to open its main Settings page, whose left side displays a detailed tree. 

Each control of this main page is described at Railing Settings: Geometry and Symbol Display.

The two main components, listed in the tree, are Segments and Nodes. Set the parameters specific to 

Segments and Nodes on their respective pages.

• A Segment is the part of the Railing between two Nodes (like a segment of a polyline). A Segment has its 

own settings, which include the Railing Pattern and Segment Height.

See Segment Settings (Railing Tool).

• Nodes are the points that divide the Railing Segments (like points on a polyline). One or more Posts are 

located at each Node.

See Node Settings (Railing Tool).
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The sub-pages under Segment and Node allow you to further specify the Railing components (e.g. Rails, 

Posts, Panels).

Watch the Video

Related Topics

Railing Settings: Geometry and Symbol Display

Segment Settings (Railing Tool)

Toprail Settings (Railing Tool)

Handrail Settings (Railing Tool)

Rail Settings (Railing Tool)

Inner Post Settings (Railing Tool)

Baluster Settings (Railing Tool)

Panel Settings (Railing Tool)

Node Settings (Railing Tool)

Post Settings (Railing Tool)

Connection Settings (Toprail, Handrail, Rail)

Railing Ends (Toprail, Handrail, Rail)
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Railing Settings: Geometry and Symbol Display

The top level page in the Railing Tool Settings hierarchy controls the Railing as a whole. 

On this Settings page, you set its Home Story information and any offset, as well as its Floor Plan and Break 

Mark display.

What’s Covered

Railing Geometry and Positioning

Choose the stories on which the Railing’s 2D symbol should be displayed.

Railing Display Layouts (Show on Stories)

Vary a Railing’s symbol display, story by story. 

Railing Floor Plan Symbol Components

Show or hide each symbol component of the Railing (optionally overriding the show/hide definitions of Model 

View options.)

Railing Settings: Floor Plan Symbol Overrides

Apply overrides to the display of the Railing’s entire 2D symbol (lines, pens, fills).
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Break Mark Settings

Define Break Mark appearance.

Set Attributes for Each Railing Component

How to set the attributes and choose a symbol type for any Railing component.

Railing Geometry and Positioning

Home Story

Choose one of the following Home Story settings: 

• The current story: The Railing’s Home Story will be the current story, on which it is placed.

• Choose a story to which to link the bottom of the Railing. Click Select Story to bring up the full list of 

stories in the project, if they are not all shown in the list.

Offset Railing from Home Story

Optionally, define an offset for the Railing bottom from its Home Story. (For associative Railings, the offset 

field is grey, because the Railing follows the Home Story of its parent element.)

Bottom Elevation [to Reference level]

Note: For associative Railings, this field is grey, because the Railing follows its parent element. 

Calculates the current elevation of the Railing’s reference line, as measured from the Reference level (by 

default, this Reference level is Project Zero). 

As with Morphs, the Railing’s Bottom Elevation value shows the current elevation of the Railing’s lowest point. 

The Railing’s height is measured from this value.

Click the pop-up arrow to change the Reference level, if needed.

Note: Reference levels are defined at Options > Project Preferences > Reference Levels.
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Railing Display Layouts (Show on Stories)

Use this panel to define how to display the Visible/Hidden parts of the Railing symbol on each story.

Use Break Mark Settings of Associated Stairs

This box is checked by default. If the Railing is associated to a Stair, then it will be displayed on the same 

stories as the Stair, using the same Layout options, and the same Break Mark settings. 

These options are defined for the Stair at Stair Display Layouts (Show on Stories).

Show on Stories

Use the pop-up to define the Stories on which the Railing’s 2D symbol should be displayed.

The stories you define (for example, “All Relevant & One Story Up”) are listed in the field below (under “Layout 

On”).

A Relevant Story is one which the Railing physically intersects. 
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Layout On (Railing Display On Each Story)

Under Layout On: Click on each Story name, then choose how to display the Railing on that story:

• Break Mark: With or without a Break Mark

• Visible vs. Hidden Attributes: To use either Visible or Hidden attributes on the displayed parts of the 

Railing. The set of attributes (for hidden and visible parts) is defined for each symbol component on the 

Floor Plan Symbol Components panel (see below).

Visible Parts and Hidden Parts

A Railing’s “Visible Parts” represent the Railing’s primary appearance, and are displayed using the “Visible” 

line type (usually a solid line).

A Railing’s “Hidden Parts” represent the Railing’s secondary appearance, and are displayed using the 

“Hidden” line type (usually a dashed line).

Visible parts are usually under the Break Mark; Hidden parts are usually above the Break mark.
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Railing Floor Plan Symbol Components

Use this panel to control the display (on or off) of the Railing’s 2D symbol components.

Show/Hide Symbol Components: By Model View Options

Check this to show/hide the Railing’s 2D components, as defined at Document > Model View > Model View 

Options (Railing Options).

See Model View Options for Railings.

Show/Hide Symbol Components: Customize in Railing Settings

Uncheck “by Model View Options” and use the list below to specify which symbols to show or hide for this 

Railing.
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Railing Settings: Floor Plan Symbol Overrides

Use this panel to optionally apply overrides to the display of the Railing’s entire 2D symbol (lines, pens, fills). 

• To apply a Line/Pen/Fill override: Check the respective Override box, then select an attribute from the 

controls below.

Break Mark Settings

Use these controls to define Break Mark display for the Railing.
ARCHICAD 24 Reference Guide 1236



Construction Elements Elements of the Virtual Building
Note: For a Railing associated to a Stair: Check Use Display and Break Mark Settings of Associated 

Stairs to apply the applicable settings to this Railing.

• Position: Place the Break Mark at the Floor Plan Cut Plane, or else define a Custom Height using the two 

fields.

• Distance between the two Break Mark segments; and the segment Angle (defined to Horizontal or to 

Vertical) 

• Extensions to the Break Mark segments

• Attributes (Line Type, Pen Color) of the Break Mark’s upper and lower line.
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Set Attributes for Each Railing Component

To set attributes, choose a Symbol component (e.g. Balusters) from the Rail Settings tree structure. 

For each Component:

Use the 2D Representation and 3D Representation pages of the Component Settings Panel to set its 

attributes - separately for the Visible and Hidden parts of the symbol, as applicable.

See also Visible Parts and Hidden Parts.
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Segment Settings (Railing Tool)

A Segment is the part of the Railing between two Nodes (like a segment of a polyline). 

A Segment has its own settings, which include the Railing Pattern and Segment Height.

Use this page to configure the overall Segment parameters (including Segment height) and to set up a 

Pattern, consisting of various Rails, Posts, and Panels.

What’s Covered

The Pattern Editor (Railing Tool Settings)

Segment Settings (Page of Railing Tool Settings)

Segment Pattern Settings (Panel of Railing Tool)
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The Pattern Editor (Railing Tool Settings)

The Pattern Editor is the graphical interface at the top of the Segment settings page and all of the Railing 

component settings pages.

Use the Pattern Editor to assemble a unique Railing pattern specific to each Segment. The pattern can be 

repeated within each Segment, according to a distribution logic defined by you.

The Pattern Editor is a symbolic representation of this pattern. It may consist of Toprail, Handrails, Rails, Inner 

Posts, Balusters and Panels.

The white part of Pattern Editor interface represents the pattern itself, which is placed (repeatedly, as needed/

depending on distribution settings) over the whole length of the Segment. This white section - that is, the 

Pattern Length - extends to the last (rightmost) Inner Post within the pattern (marked with a dotted line in the 

image below):

Pattern Length

See also Pattern Length, below.

Watch the Video

Selection in Pattern Editor

To select a component from the pattern, hover over it to see the feedback:
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Click on a component to select it. Notice that the component type is also selected in the tree structure, and its 

settings are available in the dialog box.

Add Component in Pattern Editor

To add a Railing component to the Pattern Editor:

1. Select the component (e.g. Handrails) from the tree structure

Note: You must select a specific Railing component, not the Segment page.

2. Click the Plus sign.

3. Drag the appearing symbol into place on the Pattern Editor.

4. Click to place.
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Example: Add Inner Post in Pattern Editor

1. Select Inner Posts from the tree structure.

2. Click the Plus sign, then drag the appearing post symbol into place on the Pattern Editor.

Delete Component from Pattern Editor

To delete a component from Pattern Editor:

Select it in the pattern, then do one of the following:

• Click the Minus sign

• Click Delete

• Click Backspace

Pattern Length

The pattern extends to the rightmost Inner Post within the white area of the Pattern Editor. 
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To change Pattern Length, select the Inner Post and adjust the Distance from Previous value in the Settings 

below.

Pattern Length

For more information on Inner Posts, see Inner Post Settings (Railing Tool).

Convert Pattern to Segment Length

For a placed Railing:

Select the Railing, and use Convert Pattern to Segment Length from the context menu.

You can also fit the Pattern Length to Stair Tread width:
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Railings on Associated Stairs

• Set pattern length to a specific number of treads:
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Segment Settings (Page of Railing Tool Settings)

Segment Height and Vertical Offset

Enter the Segment height.

The position of other Railing components can depend on the Segment height: 

• The height of the Toprail equals the Segment height (this is not true for Handrails or Rails).

• The tops of Railing Posts, Inner Posts, Balusters and Panels can be defined as offset from the Segment 

top.

Optionally, add a vertical offset (positive or negative) to the Segment height.

Segment Associativity

A Railing Segment is associative by default, but you can change any Segment to Static.

See Working with Railing Segments and Nodes.
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Slant and Skew Railing Segment

Slant the Segment by entering a slant degree, measured perpendicularly to the Segment plane.

Slanted Railing Segment

Optionally, skew the Segment. Set the skewing angle: either relative to vertical, or perpendicular to the Railing 

reference line.

Skew Railing (to Vertical or Perpendicular Plane)

You can also skew or slant the Segment graphically, by modifying the Toprail angle in Edit mode.

See Slant or Skew Railing in Edit Mode.
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Offset Railing Segment from Reference Line

As needed, offset the Segment from either side of the Railing Reference Line. Enter the offset value in the 

Reference Line field of Segment Settings.

In Edit mode, you can offset any or all Railing segments graphically (Reference Line remains in place, e.g. 

with associated element)

For other Reference Line uses, see Railing Reference Line.
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Segment Pattern Settings (Panel of Railing Tool)

Use these controls to define how to distribute the Pattern within the Railing Segment.

For information on setting up the pattern, see The Pattern Editor (Railing Tool Settings), above.

Note: Pattern distribution settings affect the pattern within a Segment. To continue the pattern over 

multiple Segments (without stopping at Nodes), see: Pattern Continuity at Node Settings.

Pattern Distribution and Position

Choose one of the three Pattern Distribution options:

• Fixed Pattern Length: The pattern will be distributed, with its length fixed and unchanged, over the length 

of the Segment. The pattern will be cut off at the end of the Segment.

With this option, the pattern is not stretched.
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Fixed Pattern Length (Cut off Pattern As Needed)

Pattern length is not editable here. Pattern Length extends to the rightmost Inner Post within the white 

area of the Pattern Editor. 

See also Pattern Length.

• Divide Segment Into Divisions: Enter the number of Segment divisions (e.g. 2). The pattern will be 

stretched so as to fit exactly into each division.

With this option, the pattern is stretched, and the distance between Balusters may change.

Inner Posts may change position. To fix an Inner Post (so that it doesn’t move as a result of the Pattern 

stretch), lock its Distance from Previous value at Inner Post Settings. (See Inner Post Settings (Railing 

Tool).

Segment With Two Divisions (Stretch Pattern to Fit)

• Equally Distribute Pattern: The pattern is distributed equally over the length of the Segment. The Pattern 

Length is adjusted (stretched) as needed so that the pattern is not cut off at the end of the Segment. Enter 

a maximum Pattern Length.
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Distribute Pattern Equally Over Full Segment (Stretch Pattern to Fit)

Note: With this option, even if the Pattern is stretched, the gap between Balusters is unaffected. The 

Baluster gap is set in Baluster Settings (see Baluster Settings Panel).

Related Topic

Pattern Continuity
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Toprail Settings (Railing Tool)

Each Segment has a single Toprail which sits atop the Segment: Toprail height is therefore equal to the 

Segment height (defined in Segment Settings. See Segment Height and Vertical Offset.)

You cannot edit Segment height in Toprail Settings.

You add a total of one Toprail to a Segment. (Click the Plus sign to place it.)

Choose a GDL component as the Toprail, or choose Invisible from the pop-up (if you do not want to place a 

physical Toprail).

To define settings for the GDL component, use the panel below. See Rail Component Settings (Toprail/

Handrail/Rail).

Slant or Skew Railing in Edit Mode

1. In Edit Mode, select the Toprail.

2. From the pet palette, use the Modify Angle command to adjust the Slant angle graphically.

The entire Railing Segment follows - this is equivalent to changing the Segment’s Slant angle.
ARCHICAD 24 Reference Guide 1251



Construction Elements Elements of the Virtual Building
Similarly, you can skew the Railing graphically: select the Toprail in Edit mode and use Modify Angle along the 

vertical editing plane.
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Handrail Settings (Railing Tool)

The Segment pattern can contain up to two Handrails. (Each can be doubled - see Use Double Handrails, 

below.)

To add or delete Handrails, use the Plus or Minus sign in the Pattern Editor.

See also Add Component in Pattern Editor.

For each Handrail selected in the Pattern Editor, define its parameters in Handrail Settings:

• Choose a GDL component as the Handrail.

To define settings for the GDL component, use the panel below. See Rail Component Settings (Toprail/

Handrail/Rail).

• Choose to place the Handrail on the left or right side of the Railing (“left” and “right” are based on the 

Railing input direction), or on both sides (see below). 

• Horizontal Offset: Define the lateral offset of the Handrail(s).
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Two Handrails

Use Double Handrails

Each of the two Handrails can be doubled to the other side of the Railing, for a total of four physical Handrails: 

choose the “Both Sides” option from the Handrail Settings:

Two Handrails, Doubled
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Connect Ends of Double Handrails

To connect the ends of the doubled Handrails, use the Ends page of Railing Settings:

See also Railing Ends (Toprail, Handrail, Rail).
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Rail Settings (Railing Tool)

Rails are general horizontal elements. You can offset them from the Railing Segment, and set them at any 

height. Rail cross sections can be different for each.

Rails can also be used as a reference point when positioning Panels and Balusters.

To add or delete Rails, use the Plus or Minus sign in the Pattern Editor. There is no limit to how many Rails 

you can add to the pattern.

For more information, see The Pattern Editor (Railing Tool Settings).

For each Rail selected in the Pattern Editor, define its parameters in Rail Settings:

• Choose a GDL component as the Rail, or choose None from the pop-up (if you do not want to place a 

physical Rail).

To define settings for the GDL component, use the panel below. See Rail Component Settings (Toprail/

Handrail/Rail).

• Set the Rail Height, defined as Absolute (from the Segment Bottom), or as a Percentage of the total 

Segment height (e.g. 50%).

• Horizontal Offset: Define the lateral offset of the Rail.

• Note that a newly placed Rail will intersect any Balusters, and can divide these Balusters into separately 

editable Baluster components, if Baluster heights are defined with reference to the Rail height. 
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Horizontal Rail Intersects and Splits Balusters

Of course, you can define the Baluster top/bottom to extend to the Segment top/bottom, instead of the Rails.

Note: Segment height is defined in Segment Settings. See Segment Height and Vertical Offset.
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Rail Component Settings (Toprail/Handrail/Rail)

This panel is available in the Settings dialogs of all Rail-type Railing components: Toprail, Handrails and Rails.

Available controls depend on the selected Rail component (e.g. Built-in, Profiled).

You must set up Component Settings for each horizontal Rail type separately (Toprail, Handrail, or Rail). 

Make sure you are in the particular dialog box of the Rail component you need (e.g. to edit the Handrail, use 

Rail Component Settings from the Handrail Settings dialog).

Rail 2D Symbol Type

Select a Symbol Type on the 2D Representation tab page of Rail Component Settings.

Rail 2D Symbol Display

Set 2D display preferences for the Rail component, using the controls below (for Visible and Hidden parts of 

the Railing).

Show/Hide Rail’s 2D Symbol

By default, the visibility of Railing components is defined at Document > Model View > Model View Options 

> Railing Options. 

Customize Rail Symbol visibility in Railing Settings. (See Railing Floor Plan Symbol Components.)
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Fixing Settings

Use the Fixing tab page of Rail Component Settings to access the settings, including size and Building 

Material. The Profiled Rail Fixing, for example, can consist of a Wall Plate, Railing Plate or both.

Fixing Distribution

Use the Fixing Distribution tab page of Rail Component Settings to define how to place the Fixings along the 

Rail.

Choose a Distribution method:

• Distribute by Posts: Place a Fixing at each Post and Inner Post.

Handrail Fixings at Posts and Inner Posts

• Distribute by Divisions 

– In the Number of Divisions field, enter the total number of Fixings to place along the Segment length.

– Distance from Ends refers to the gap between the first/last Fixing and the end of the Rail.
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• Distribute by Pattern

– Distribute the fixings evenly within the Pattern Length you specify

– Check Automatic Layout (best fit), or

– Choose a startpoint for distributing the Fixings.

- Segment Start or Segment End

- Center of Segment: One Fixing is placed in the center, and then rest distributed, at set intervals, on 

each side.

- Center of Segment with Best Fit: Fixings are distributed at the set interval, so as to be symmetrical 

over the length of the Segment.

- Custom Position: Enter the startpoint (distance from Segment start)

Evenly Spaced Handrail Fixings: Start from Custom Position
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Inner Post Settings (Railing Tool)

Use these Settings to add and define any number of Inner Posts in the Pattern Editor.

Inner Posts are located between Segment Nodes (as opposed to Posts, which are located at the Nodes.)

Inner Posts can also be used as a reference point when positioning Panels or Rails.

To add or delete Inner Posts, use the Plus or Minus sign in the Pattern Editor.

See also Add Component in Pattern Editor.

Choose a GDL component as the Inner Post, or choose None from the pop-up (if you do not want to place a 

physical Inner Post).

To define settings for the GDL component, use the panel below. See Post Component Settings (Posts/Inner 

Posts/Balusters).

In addition to predefined content, you can save a custom component as a Post.

For details, see Custom Sub-Elements for Stairs and Railings.

Distance from Previous

For the Pattern’s first Inner Post: Enter a value for the Inner Post’s distance from the left edge of the Pattern.
ARCHICAD 24 Reference Guide 1261



Construction Elements Elements of the Virtual Building
For each additional Inner Post: the offset is defined as the distance from Inner Post to its left.

Click the lock icon to fix the Inner Post at the defined position. This is relevant if the Pattern Distribution would 

enable the pattern to be stretched. Inner Posts that are locked will not move.

See Pattern Distribution and Position.

At least one Inner Post has to be flexible (remain unlocked). Use this option if your pattern contains panels of 

fixed size.

For the Inner Post that is at the right edge of the white part of the Pattern Editor: this Distance also represents 

the Pattern Length, as shown here:

Inner Post at Right Edge of Pattern Editor = Pattern Length

See also Pattern Length.
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Duplicate Inner Posts

Use this control to double the selected Inner Post, with a defined offset between them:

Railings with Glass Panelings, Supported by Duplicated Inner Posts

Inner Post Top/Bottom Offset

Enter a bottom and top offset value for the Inner Post.

Use the pop-up to define how to calculate the offset:

• Segment Top: Set the offset value relative to the Segment height.

Note: Segment height is defined in Segment Settings. See Segment Height and Vertical Offset.

• Absolute: Enter the Inner Post’s absolute height. The Inner Post is then offset from the Segment top 

accordingly.

• Rail 1/2...: If you have any Rails in the pattern, you can define the top or bottom offset from the height of a 

particular Rail.
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Baluster Settings (Railing Tool)

Balusters are a pattern within the pattern. By default, the pattern contains two sets of Balusters; selecting one 

Baluster selects all its instance copies in the Pattern Editor. 

Balusters do not have fixings; they can be placed in the spaces between Rails/Toprails, or the Segment top/

bottom.

To add or delete Balusters, use the Plus or Minus sign in the Pattern Editor.

See also Add Component in Pattern Editor.

The number of Balusters you can add to the Pattern may be constrained by:

• the Baluster Distance from Previous value, which is set on the Baluster Settings Panel (see below), and

• the Baluster Pattern Distribution, as when the Pattern is constrained to a maximum Pattern Length.

Baluster Pattern Settings

Baluster Top/Bottom Offset
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Enter a bottom and top offset value for the set of Balusters.

Use the pop-up to define how to calculate the offset:

• Segment Top: Set the offset value relative to the Segment height.

Note: Segment height is defined in Segment Settings. See Segment Height and Vertical Offset.

• Rail 1/2...: If you have any Rails in the pattern, you can define the top or bottom offset from the height of a 

particular Rail.

Horizontal Offset

Define a lateral offset for the Balusters.

Left/Right Offset

Enter optional left/right offsets for the Baluster Pattern. Offsets are measured from the left and right ends of 

the pattern.

Baluster Pattern Offsets: Horizontal, Left, Right

Pattern Distribution and Position (Balusters)

These options define the Baluster Pattern distribution.

Note: The Baluster Pattern Length can be seen on the Segment page of Railing Settings: the black 

Balusters represent the Baluster Pattern. (In contrast, the Segment Pattern Length runs to the first Inner 

Post.)

Baluster Pattern Length (shown in Pattern Editor, at Segment Settings)

Choose one of the four Pattern Distribution options:

• Equally Distribute Pattern: The Baluster pattern is repeated over the Segment Pattern. The Pattern 

Length is adjusted (stretched) as needed.

Enter a Maximum Length for the Baluster Pattern:
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• Fixed Pattern Length: The Baluster Pattern Length is fixed and unchanged.

The Baluster Pattern Length is the sum of the Baluster sets’ Position values, defined in Baluster Settings 

below.
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• Divide Segment Into Divisions: Divide the Baluster Pattern Length into divisions (enter the number of 

divisions in the field, e.g. 5). The Baluster Pattern will be stretched so as to fit exactly into each division.

• Baluster Pattern Length = Tread Width: For Railings associated to a Stair. (Choosing this option 

overrides any other Baluster Pattern distribution option.)

See also Railings on Associated Stairs in Segment Settings.

Baluster Settings Panel

Choose a GDL component as the Baluster.

To define settings for the GDL component, use the panel below. See Post Component Settings (Posts/Inner 

Posts/Balusters).

In addition to predefined content, you can save a custom component as a Post, and use it as a Baluster.

For details, see Custom Sub-Elements for Stairs and Railings.
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Baluster Position

For each Baluster set selected in the Pattern Editor: define the Baluster’s position as the distance from the 

previous. (If you have more than one Baluster Set, the sum of the two values is the Baluster Pattern Length).
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Post Component Settings (Posts/Inner Posts/Balusters)

This panel is available in the Settings dialogs of all Post-type Railing components: Posts, Inner Posts and 

Balusters.

Available controls depend on the selected Post component (e.g. Built-in, Profiled, Revolved). Some of the key 

controls are described here.

Post 2D Symbol Type

Select a Symbol Type on the 2D Representation tab page of Post Component Settings.

Post 2D Symbol Display

Set 2D display preferences for the Post component, using the controls below (for Visible and Hidden parts of 

the Railing).

See Railing Settings: Geometry and Symbol Display

Show/Hide Post’s 2D Symbol

By default, the visibility of Railing components in 2D views is defined at Document > Model View > Model 

View Options. 

Customize Post Symbol visibility in Railing Settings. (See Railing Floor Plan Symbol Components.)

Show Fixing

Note: Not available for Balusters.

Use a fixing to attach the Post with a simple console. Click Fixing on the Fixing Settings tab page of Post 

Component Settings to access the settings, including size, profile and Building Material. (You can also open 

Fixing Settings from the Style and Dimensions tab page.)
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Revolved Post Options

For a Revolved Post, you have many customization options. View the Preview to get the idea.

• Choose a Profile (Middle Profile) for the center part of the Revolved Post

• Choose a Geometry method
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• Add top and bottom parts to the post in a chosen Style

• For each part of the post (Top, Middle, Base):

– Set an absolute height for each post part, or

– Click the Stretch icon for one or more of the post parts (Top, Middle, and/or Base) to stretch it by a 

certain percentage of the whole. (The total stretching will equal 100 percent.) 
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Panel Settings (Railing Tool)

Use these Settings to add/remove and define Railing Panels in the Pattern Editor. 

Add Panels to Pattern Editor

To add or delete Panels, use the Plus or Minus sign in the Pattern Editor.

See also Add Component in Pattern Editor.

You can add a Panel into the empty space between two Inner posts or Rails. If the field already contains 

Balusters, you cannot also add a Panel.

Panels Divided by Inner Post

Panels Divided by a Rail

Panel Settings

From the pop-up, choose a GDL component as the Panel.

To define settings for the GDL component, use the settings in the panel below. See Railing Panel Component 

Settings.
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In addition to predefined content, you can save a custom component as a Panel.

For details, see Custom Sub-Elements for Stairs and Railings.

Define Panel Position

• Define the top and bottom offset of the Panel with reference to the Segment top/bottom, or to a Rail, if the 

Pattern contains them.

Note: Segment height is defined in Segment Settings. See Segment Height and Vertical Offset.

• Define left and right offsets from the Inner Posts.

Note: Positive offset values mean that the panel size shrinks.

• Horizontal Offset: Define the lateral offset of the Panel (if any)

Railing Panel Component Settings

Panel 2D Symbol Type

Select a Symbol Type on the 2D Representation tab page of Panel Component Settings.

Panel 2D Symbol Display

Set 2D display preferences for the Panel component, using the controls below (for Visible and Hidden parts of 

the Railing).

Show/Hide Panel’s 2D Symbol

By default, the visibility of Panel components in 2D views is defined at Document > Model View > Model 

View Options. 
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Customize Panel visibility in Railing Settings. (See Railing Floor Plan Symbol Components.)

Show Fixing

Click Fixing on the Style and Dimensions tab page of Railing Panel Component Settings to access the 

settings, including type, size, profile and Building Material, and number.

The controls depend on the type of Fixing you choose (Brackets, Point fixings, or Channel fixing).
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 Node Settings (Railing Tool)

Nodes are the points that divide the Railing Segments (like points on a polyline).

One or more Posts are located at each Node.

Use the Node page of Railing Settings to define the number and position of Posts at the Nodes, and how to 

handle the connection of two Segments when they meet at a Post.

Vertical Offset

Available in Edit Mode only.

Set an optional elevation (vertical offset) for the Nodes (this is relevant for static Nodes).
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Number of Posts per Node; Offset from Node

Set the number of posts per Node (one post at the Node, or two posts on either side of the Node, or all three 

posts).
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Node with Two Posts and Three Posts

If the Node has more than one post, set the offset distance of the posts on either side of the Node.

Smooth (Tangential) Connections - Post Offset

This is relevant for Posts located where two Railing Segments connect tangentially.

• To adjust the post position, choose either Automatic or Manual (use the first pair of icons)

– Automatic: The post is moved to its new position automatically. 
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At Smooth Segment Connection: Post Moves Automatically

You can further define the connecting Post as Vertical or Tilted. (use the second pair of icons)

– Manual: You define the Post position, entering the desired offset
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At Smooth Segment Connection: Offset Post Manually

Segments at Non-Smooth Connections

This option is relevant for two Railing Segments of differing heights, which connect at an angle (non-smooth) 

at a node.

Use the icon pair to choose how to join the two segments: either leave them “stepped” at the node, or else 

adjust their geometry to connect at a point past the node.
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Stepped Segments at Non-Smooth Connection
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Adjusted Segments at Non-Smooth Connection

Ending Node Offset

Optionally, enter an offset for the Railing's Ending nodes. (This will offset the Railing from both ends of its 

Reference Line.)

Pattern Continuity

If two neighboring Segments use the same pattern: choose whether the pattern should end at the Node and 

start over, or else continue without interruption.

For information on setting the Railing Pattern, see The Pattern Editor (Railing Tool Settings).
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At Nodes: Crop Segment, or Continue Pattern
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Post Settings (Railing Tool)

From the popup, choose a GDL component to be placed as a Post at each Node of the Railing, or choose 

None from the pop-up (if you do not want to place a physical Post).

To define settings for the GDL component, use the panel below. See Post Component Settings (Posts/Inner 

Posts/Balusters).

In addition to predefined content, you can save a custom component as a Post.

For details, see Custom Sub-Elements for Stairs and Railings.

Post Top/Bottom Offset

Enter a bottom and top offset value for the Post.

Use the pop-up to define how to calculate the offset:

• Segment Top: Set the offset value relative to the Segment height.

Note: Segment height is defined in Segment Settings. See Segment Height and Vertical Offset.

• Absolute: Enter the Post’s absolute height. The Post is then offset from the Segment top accordingly.
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Connection Settings (Toprail, Handrail, Rail)

For each type of Rail (Toprail, Handrails, regular Rails), use these settings pages to define the geometry at 

connecting Segments, for each rail type. 

You can display the connection segment using a different surface from the connecting rails (use the Override 

Surfaces control).

Rail Connection Types

Choose how to connect the selected Rail type between segments, using one of the three connection types:

• Disconnected: Rails of the adjoining segments will not connect. Add an optional extension (positive or 

negative) to each.

• Gooseneck: Adjoining Rails are connected with a gooseneck consisting of horizontal and vertical parts. 

In the editable fields on the right, set the extension (positive or negative) and fillet values for each part of 

the gooseneck connection.

Note that the preview highlights the part you are editing.
ARCHICAD 24 Reference Guide 1284



Construction Elements Elements of the Virtual Building
• Direct Connection: Connect the two adjoining rails by extending each one, then joining them together. In 

the editable fields on the right, set the extension (positive or negative) values, and a fillet value for the 

curved parts that curve off the horizontal parts.

Edit Connections

• In Edit Mode, use the Info Box or End Settings to adjust settings of any selected Connection.
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Sloped Railing (Connection) - Ending Geometry

• Choose the geometry for the ends of a connecting segment for a Sloped Railing: perpendicular, vertical, 

or horizontal.

Sloped Railing (Connection) - Tangential to Segment or Horizontal

• Switch this option to add a horizontal segment to the Connection, where a sloped railing meets a 

horizontal turn.

• Enter the length of the added segment and an optional fillet. 
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The resulting segment in Edit mode:
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Railing Ends (Toprail, Handrail, Rail)

Each type of Rail (Toprail, Handrails, regular Rails) can have one or more Extension segments at their ends. 

In Railing Settings (Ends page), set ending parameters separately for each Rail type by choosing one from 

the pop-up list:

Define Rail End Geometry

The Rail Ending consists an Extension that can take the form of a single straight Extension, a Curve, or Full 

Return.

Choose the ending you prefer from End Settings. The Extension lengths are set in the fields at right.

Notes: 

– If you do not want to use the ending, set the Extension Length to 0.
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– Only a single extension is available for plain Rails.

– For doubled handrails: Use a fourth option to connect the handrail with its twin on the opposite side.

See Connect Ends of Double Handrails.

Edit Rail Ends

The End Settings defined in Railing Settings are applied to both ends of the Rail (Toprail/Handrail), but you 

can customize either end in Edit mode.

• Edit the endings graphically in Edit mode, using the hotspots to edit Extension length, Radius, and/or 

angle of the selected Ending. Where a node has multiple editing possibilities, the pet palette appears with 

the options:

Edit Rail Endings Graphically in 3D and Section

• Use the Info Box or End Settings to adjust settings of any selected Rail ending.
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Sloped Railing: Ending Geometry

In Info Box or Railing Settings, choose the ending geometry of a Sloped Railing: perpendicular, vertical, or 

horizontal.
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Sloped Railing End: Tangential to Segment or Horizontal

• Switch this option to end a sloped Railing with a horizontal segment.

• Enter the length of the added segment and an optional fillet.

Override Surfaces

Display the end component using a different surface.

Add Ending Component to Rail End

The End component is added to the rail’s Extension segment.

1. From the End Component Panel, choose the desired Rail End object if needed.

2. Use Rail End Component Settings panel to set its parameters.
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Model View Options for Railings

Railing Options

This panel is at Document > Model View > Model View Options.

Railing Detail Level in 3D and Section

• In Full mode, the complete Railing appears: all 3D elements can be seen in full detail.

• In Simplified mode, the complete Railing appears: all 3D elements can be seen, but in a simplified view: 

bounding box of sub-elements are shown.

• In Schematic mode, a continuous membrane surface is shown to indicate the path of the Railing.

– For Simplified or Schematic: Click Attributes to customize surface and line options for the Railings 

displayed in 3D and Section views.
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Show/Hide Railing Floor Plan Symbol Components

Use the checkboxes to show/hide the Railing’s Floor Plan symbol components.

To show/hide individual Railing Symbols, use Railing Settings.

See Railing Floor Plan Symbol Components.

To fine-tune Symbol display (based on a Railing’s Visible/Hidden parts), use the “Detail Level” panel of the 

Model View Options dialog box:

See Detail Level of Stair and Railing Symbols.
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Morphs

Use the Morph tool to create freeform elements within ARCHICAD, so you don’t have to import special 

shapes from other programs.

The Morph tool is fully integrated into ARCHICAD, and works with a familiar logic and interface. Like other 

construction elements, a Morph’s essential structure derives from its Building Material.

You can enable priority-based connections between Morphs and other elements. 

Watch the Video

Morph Geometry and Sub-Elements

• Compared to traditional construction elements, the Morph has practically no geometric limits: every edge 

and every surface can be moved and shaped in any direction, so you can create exactly the element you 

need to fit project-specific situations.

• Morphs consist of one or more sub-elements: these can include faces and/or edges. For any Morph, you 

can edit the entire element as a whole, or any of its sub-elements separately, or in combination. A new 

selection logic is available to enable you to edit sub-elements.

• A selected Morph has only a single hotspot, which represents the point of its elevation value.

Morph Creation

• In addition to familiar input methods, the Convert Selection to Morph command enables the quick creation 

of a new single Morph out of existing elements.

• The Magic Wand is especially powerful with Morph creation: tap any surface (e.g. a Mesh) to create a 

Morph.

• Unlike other construction elements, 2D Morph shapes can be created in the 3D window (lines and 

planes). These can be used for sketching or documenting purposes.

Morph Settings

• In Morph Settings, you will notice that there are no numerical geometric parameters, apart from its default 

elevation. 

• The Floor Plan and Section controls are similar to those of the Shell Tool. By default, Morphs (as well as 

Shells) are displayed on the Floor Plan in true 3D projection mode. 

• Morph Selection Settings varies depending on whether you have selected an entire Morph, or any 

combination of its sub-elements (e.g. faces, edges). In sub-element selection, only the Model panel is 

available, and only the relevant controls are available, depending on whether you have selected edges, 

faces or a combination thereof. 

Graphical Editing

• Morph creation and editing is most intuitive in the 3D window. Graphical interface uses familiar methods 

and interactions: select any edge, grab any point or surface, or any combination of their sub-elements, to 

modify the Morph with the help of the pet palette and real-time feedback. Notice that Fillet and Chamfer 

are available for Morphs in the 3D window, applied to any or all edges or corners.

• Morphs (like Shells) can be input onto any plane of the 3D window, and with many editing interactions, 

you can also switch the editing plane as you go, so that there are few constraints.
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• There are separate Solid Operation commands for Morphs. Unlike Solid Element Operations, which 

create connections, Solid Morph Operations are not associative - the final result of the operation is 

permanent.

• Morphs can participate in priority-based connections with other elements, provided that you merge them 

using the Design > Connect > Merge Elements command.

Morph Smoothing

Morph surfaces are defined by faces, and as you edit the Morph, its many segments are automatically 

smoothed to create curved surfaces. In addition, a number of commands allow you to transform the Morph 

with a single click, by smoothing or subdividing its sub-elements, and also gives you some control over the 

smoothing mechanism. These commands and controls include:

• Smooth & Merge Faces

• Curve & Merge Edges

• Modify Segmentation

• Hard or Soft Edges: in the Info Box or Morph Settings, any edges can be individually re-set to be “hard” or 

“soft”. By default, they are hard; if you reset an edge to be “soft,” then its adjacent faces will behave as 

though merged into a single, flexible face. A soft edge is an internal sub-element that divides segmented 

faces. Such faces are displayed (in OpenGL and rendering) as smooth and curved.

Texture Mapping for Morph Faces

As with other 3D elements, if you have applied a surface that includes a texture, you can use the Align 3D 

Texture command to fine-tune the origin and rotation of the texture pattern. For the Morph, these options are 

also available individually and separately for each face.

Related Topics:

Morph Selection

Create a 2D Morph

Create a Revolved Morph

Create a Box Morph

Create Morph from Existing Elements

Basic Morph Editing

Useful Commands for Transforming Morphs

Morph Edge Type: Hard, Hidden, Soft

Boolean Operations with Morphs

Morph Texture Mapping and Alignment

Fix Modeling Errors: Check and Solidify Morphs

Pick Up/Inject Morph Parameters

Merge Elements: Roofs, Shells, Morphs
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Morph Selection

Morphs consist of multiple sub-elements (faces and edges).

Select Entire Morph

• Click on any part of the Morph to select the entire Morph element (including its sub-elements).

A selected Morph has only a single hotspot, which represents the point of its elevation value.

• Check the Info Tag to see the sub-elements that make up the selected Morph.

Area selection will select the entire Morph.

Select Morph Sub-Element

Use Ctrl+Shift to select just a sub-element (an edge or a face) of the Morph. (The cursor changes to a white 

arrow to indicate that you are selecting a sub-element.)

In this case (with Ctrl + Shift pressed):

• the pre-selection highlight shows you exactly what will be selected when you click

• use the tab key to cycle among the pre-selected sub-elements

• area selection will select only sub-elements

When a sub-element is selected, all the pet palette commands will work on that sub-element only. For 

example, using the Move command on a selected face will move the face in space (and the connected parts 

of the rest of the Morph along with it) - it does not move the whole Morph element.

This is also reflected by in the Info Box and Morph Selection Settings, where only those controls are available 

that can be applied to the selected sub-element. The number of editable sub-elements is also shown.
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Sub-Element Selection by Default

If you are editing Morphs, you may wish to select only Morph sub-elements (faces and edges) by default, 

rather than the entire Morph. To do this, activate the Sub-Element selection method for the Arrow tool.

This only works for Morph selection. If Sub-Element selection is on, and you try to select other element types, 

you get a “Do Not Enter” cursor, and selection is not possible unless you use the modifier key (Ctrl + Shift).

If you have activated Sub-Element Arrow selection by default, then the usual selection logic is reversed: sub-

elements are selected by just plain clicking, while to select an entire Morph, you have to use the modifier key 

(Ctrl + Shift).
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Change the Sub-Element Selection Modifier Key

Use the Work Environment’s Shortcut page to assign a different modifier key for the “Sub-Element Selection 

Modifier” command, which toggles between entire element/sub-element selection of Morphs.
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Create a 2D Morph

Choose the Morph Tool from the Toolbox, then choose a Geometry Method from the Info Box.

Use the following methods to create 2D lines, polylines, curves and closed polygons on the Floor Plan or in 

the 3D Window.

• Polygonal

• Rectangular and Free-Rotate Rectangular

• Curved - Centerpoint and Radius

• Curved - Circumference

The input process with these geometry methods works just like ARCHICAD’s 2D drawing tools.

The result, however, is a Morph face or a Morph line, rather than a 2D polygon or line: it is displayed in the 3D 

window, but has no geometric parameters (e.g. thickness). You can use the resulting 3D lines and surfaces for 

sketching or documenting purposes in the 3D window.

Free-Rotate Rectangle

The Free-Rotate Rectangle input method of the Morph tool allows you to draw the rectangle on any plane in 

space.

1. In the 3D window, choose the Free-Rotate Rectangle method.

2. Click twice to draw the first edge of the rectangle. You can draw this edge on any plane in space.

3. Click to place the opposite corner of the rectangle. You can snap to any point in space.
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Create a Box Morph

Activate the Morph Tool and choose the Box geometry method.

In the 3D Window:

1. Choose the input plane. Either click to find the default plane, or choose another input plane based on 

existing elements or using the Editing Plane controls.

See Reposition Editing Plane.

If you click in “empty space”, the default input plane is at the base height defined in Morph Default 

Settings.

2. Click twice to define the rectangular base of the Box Morph. (The base is always aligned with the grid. You 

can rotate the grid to place the box at a different angle, or you can place it and then rotate it afterwards.)

3. Drag the cursor to define the height of the Box Morph.

4. Click to complete.

On the Floor Plan or in Section:

1. Choose the Box geometry method from the Info Box.

2. Click twice to define the rectangular base of the Box Morph.

3.  Enter an extrusion vector length - the distance that will be the height of the Box Morph.
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Create a Revolved Morph 

Use the Revolved method to create a Morph by defining its profile (either a default shape or a freehand 

profile), then revolving the profile around an axis.

Activate the Morph Tool and choose the revolved geometry method.

On the Floor Plan or in Section:

1. Draw the Morph profile - a polyline or a closed polygon - with the usual polygon input methods. (The 

resulting Morph will have as many faces as the number of polygon segments.)

Note: You can use the Magic Wand to trace any closed polygon as your profile.

2. Double-click to complete the polyline or polygon.

3. Click twice to draw the revolution axis.

4. In the appearing dialog box, enter the Morph’s revolution angle. A positive number will revolve the Morph 

toward you. A negative number will revolve the Morph away from you.
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5. Click OK to complete the Morph. View it in 3D.

In the 3D Window:

1. Choose the input plane. Either click to find the default plane, or choose another input plane based on 

existing elements or using the Editing Plane controls.

See Reposition Editing Plane.

This is the plane on which you will draw the profile and then its revolution axis.

If you click in “empty space”, the default input plane is at the base height defined in Morph Default 

Settings.

2. Draw the Morph profile - a polyline or a closed polygon - with the usual polygon input methods.

Note: You can use the Magic Wand to trace any closed polygon as your profile.
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3. Complete the polygon.

4. Click twice to define the revolution axis.

5. Move the cursor to complete the revolution axis. (Navigate in the 3D view to find the best angle for seeing 

the feedback.)
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6. The Morph is complete.
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Create Morph from Existing Elements

Convert Selection to Morph(s)

Use this command to create multiple Morphs out of selected elements: each selected element will become a 

separate Morph.

1. In any model window, select the elements to change into Morphs.

2. Use Design > Convert Selection to Morph(s).

3. The selected elements, provided that they have a 3D representation, will be turned into Morphs.

Watch the Video

Example: Convert GDL Object to Morph

When you convert a GDL object to Morphs:

• GDL objects will be converted into independent Morphs.

• GDL sub-element components of other elements (e.g. door, window, wall end, skylight) will be converted 

into independent Morphs themselves.

• Similarly, the sub-elements of complex roofs and curtain walls are converted into independent Morphs.

Note: If the resulting Morph is very complex, you may run into editing and performance problems.

Notes on Attributes of Newly Created Morphs:

– If the transformed element was an object, its surface is added to the project’s set of surface attributes, 

if the surface doesn’t exist there already. Such a newly added surface attribute automatically receives 

a suffix of _from Converted Object, though this string is not considered when the program checks for 

duplicate names. (If the converted object’s surface already exists in the project, the new Morph uses 

the existing surface.) Any texture attached to the surface is added to the embedded library.

– In Teamwork, creation of Surfaces and Fills requires the appropriate access right. If you do not have 

this right, you will see a warning message. The Morph will still be created, but the surface/fill/texture 

will not be added to the project, and the Morph may thus look different than expected.
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Basic Morph Editing

When you work with the Morph tool, you will typically place a standard shape, then graphically edit it into its 

final form.

Select the entire Morph, or select one of its sub-elements.

You can edit the Morph graphically using one of its sub-elements (face or edge). When you drag a face or 

edge, all of its connecting faces and edges move along with it.

The best way to learn this is to simply try out the editing options from the pet palette, using the 3D window. 

Don’t forget that, in many situations of Morph editing, you can reset the editing plane to any position.

Basic Morph Editing: Push-Pull

Basic Morph Editing: Bulge

Basic Morph Editing: Add

Basic Morph Editing: Tube

Transforming Morphs: Custom Face Settings

Morph Edge Type: Hard, Hidden, Soft

Basic Morph Editing: Offset Morph Edge(s)

Basic Morph Editing: Curve Edge

Basic Morph Editing: Move Morph Sub-Element

Basic Morph Editing: Add Node to Morph

Basic Morph Editing: Fillet/Chamfer a Morph

Custom Resolution for Fillet
ARCHICAD 24 Reference Guide 1306



Construction Elements Elements of the Virtual Building
Basic Morph Editing: Push-Pull

1. Click on the flat face of a Morph. (Multi-select sub-elements to edit them simultaneously.) 

2. From the pet palette, choose the Push-Pull command.

3. Drag the face (the one you clicked) to extend the Morph shape perpendicularly to the clicked face: pull to 

extend the Morph; push to “compress” it.

Create a Morph-Shaped Hole in Another Morph

This method works if you push a Morph all the way through another Morph, provided that both ends of the 

“host” Morph are parallel faces.

For other kinds of geometries, use Boolean Operations on Morphs.

See Boolean Operations with Morphs.

1. On an existing Morph, use the Add command to draw a new Morph in the shape of the hole you want.

See Basic Morph Editing: Add.

The new Morph becomes a sub-element of the existing Morph (since you used the Add command to draw 

it.)

2. Click on the sub-element.

3. Use Push-Pull to push the sub-element through the Morph.

4. Click the cursor on an opposite edge to complete the Push.
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5. The hole is created.
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Basic Morph Editing: Bulge

1. Click on any face of a Morph.

Note: Choose the clicked point carefully, because it will be the centerpoint of the circle out of which you 

will draw the bulge.

2. From the pet palette, choose the Bulge command.

3. Drag the cursor to define the radius of the bulge.

• A small radius will give you a smaller, sharper outcropping.

• Use a larger radius for a more gentle rounded result.

4. Click to complete the radius.

5. Now drag the cursor to bulge the Morph in or out.
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Basic Morph Editing: Add

Use the Add command to expand an existing Morph by drawing an additional Morph shape onto it. The result 

will be a single Morph that behaves as a single element.

Note: Alternatively, you can draw a separate Morph onto an existing one, without using the Add 

command; in this case, the new Morph will operate independently of the old one. Later, if needed, you can 

use Create Morph from Selection or the “Union” Solid Morph Operation to merge these separate 

Morphs into one.

1. Click anywhere on a Morph or its sub-element. The new Morph input will begin at the point you clicked.

2. From the pet palette, choose the Add command.

3. Choose a geometry method from the Morph Info Box.

4. Draw the desired Morph.
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Basic Morph Editing: Tube

Use the Tube command to extend any Morph face into a tube, changing directions and planes as many times 

as you like.

1. Click anywhere on a Morph face.

2. From the pet palette, choose the Tube command.

3. Start drawing the Tube, clicking to place each segment in turn.

Note: The first segment must be drawn perpendicular to the clicked face.

– You can use the Magic Wand to trace a path for the Tube around a closed polygon (provided that the 

polygon plane and the tube profile plane are not in the same plane.)

– Change the editing plane as needed.

– To undo the last segment, use the Go back command from the pet palette.

4. Double-click to complete the Tube.
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Tube Reference Point

The point you clicked on the Morph face to bring up the pet palette is the reference point of the Tube (the point 

by which you drag the tube).

However, once you select the Tube command from the pet palette, you can click anywhere else on the face 

(or its contour) to use that newer clicked point as the reference point:
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Basic Morph Editing: Offset Morph Edge(s)

1. Select a Morph.

2. From any edge, bring up the Pet Palette and choose “Offset Edge”.

3. Drag the cursor, or choose a different editing plane. The Morph edge, plus its adjoining faces, will move 

along the chosen editing plane.

4. Click to complete.

Offset All Morph Edges

1. Select a Morph.
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2. From any edge, bring up the Pet Palette and choose “Offset All Edges.”

3. Drag the cursor, or choose a different editing plane (only the adjoining planes are available). The face 

adjoining the clicked edge (the face that lies on the editing plane) will be offset on all sides along the 

chosen editing plane.

4. Click to complete.
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Basic Morph Editing: Curve Edge

1. Select a Morph.

2. Click the edge you want to curve to bring up the Pet Palette, and choose “Curve Edge.”

3. Drag the cursor, or choose a different editing plane. The clicked edge, plus the adjoining face, will be 

curved along the chosen editing plane.
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Here, the same operation done on a different Editing Plane:
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Basic Morph Editing: Move Morph Sub-Element

Use this command to transform the Morph by dragging it by its sub-element(s).

1. Select a sub-element.

2. Use the Drag command from the pet palette.

3. Move the sub-element (and its connected faces/edges) along the editing plane. Change editing plane if 

needed.

While moving, you can snap to the direction that is perpendicular to the editing plane.
ARCHICAD 24 Reference Guide 1317



Construction Elements Elements of the Virtual Building
Basic Morph Editing: Add Node to Morph

1. Bring up the pet palette on the edge of a selected Morph (or on a selected edge).

2. Use the Add Node command from the pet palette.

3. Move the node (and its connected faces/edges) along the editing plane. Change editing plane if needed.
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Basic Morph Editing: Fillet/Chamfer a Morph

You can fillet or chamfer the corners and edges of Morphs, in 2D or 3D windows.

Note that a fillet or chamfer operation has the effect of created one or more new Morph faces. These new 

faces will always “inherit” the default surface of the original Morph.

Fillet/Chamfer a Morph Corner

1. Select a Morph and bring up the pet palette at one of its corners.

2. Choose the Fillet/Chamfer Corner command and apply the desired options.

Check the box to apply to all corners of the Morph:
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Fillet/Chamfer Morph Edges

1. Bring up the pet palette on the edge of a selected Morph (or on one or more selected edges).

2. Choose the Fillet/Chamfer Edge(s) command and apply the desired options.

If you have selected an entire Morph, you can check the box to apply the fillet/chamfer to all edges:
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Custom Resolution for Fillet

By default, the Fillet resolution is set to 4 (this is best displayed in wireframe):

For different results, adjust the Fillet resolution up or down:
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Useful Commands for Transforming Morphs

As you edit the Morph into the shape you need, try out the following commands:

Transforming Morphs: Smooth & Merge Faces

Intersect Morph Faces (Generate Edges within a Morph)

Transforming Morphs: Curve & Merge Edges

Combine Morph Faces for Smooth Editing Effect: Use “Soft” Edges

Transforming Morphs: Box Stretch a Morph

Transforming Morphs: Cover with Faces
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Transforming Morphs: Smooth & Merge Faces

Use this command if you have done a basic angular-shaped model, and wish to achieve a more rounded 

effect with just one click.

Smooth A Non-Solid Morph

For example, we start with the following hollow Morph.

To achieve a smoother effect:

1. Select the Morph or a sub-element.

2. Use Design > Modify Morph > Smooth & Merge Faces.

3. The Smooth & Merge Faces dialog box appears.

Since the current (non-solid) Morph has outer boundaries (edges that are not adjoined by any faces), you 

can choose how to treat these boundaries:
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• Smooth boundaries means that the bounding edges of the selected element(s) or sub-elements will also 

take part in the smoothing:

• Preserve boundaries means that the bounding edges of the selected element(s) or sub-elements will 

stay intact, and only the inner parts are smoothed.

• Subdivision level: Use the slider to adjust how much triangulation (subdivision) you wish to achieve. Be 

aware that a higher subdivision level, used on complex or multiple Morphs, can lead to a high polygon 

count that can affect model size and ARCHICAD performance.

Smooth a Solid Morph

With a solid Morph, you have no free-hanging edge boundaries, so all selected parts take part in the 

subdivision:
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Intersect Morph Faces (Generate Edges within a Morph)

While editing a Morph, its shape may be transformed such that a single face is intersected by other parts of 

the Morph. At this point, the new (self-)intersection is not yet delimited by any edges.

If you henceforth want to treat such intersecting faces separately, use the Design > Modify Morph > 

Intersect Morph Faces command.

This command works on a single selected Morph only.
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Transforming Morphs: Curve & Merge Edges

Use this command to segment one or more straight Morph edges to achieve a smoother, curved effect.

This feature is also useful to merge multiple curved Morph edges.

1. Select one or more Morph edges; or select one or more faces.

2. Use Design > Modify Morph > Curve & Merge Edges.

3. If needed, use Design > Modify Morph > Modify Segmentation to correct the effect.

Vary Smoothness Level of Morph Edges

If you want to vary edge smoothing within a single Morph, you can adjust the Smoothing Level of individual 

Morph edges: select an edge, then use the Design > Modify Morph > Modify Segmentation command. This 

will reset the Smoothness behavior of the selected Morph edge only.
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Combine Morph Faces for Smooth Editing Effect: Use “Soft” Edges

Morph editing often involves selecting and editing a sub-element (edge, node or face), which in turn affects 

the connecting faces of the Morph.

As the Morph changes shape, the connected faces, joined by a “hard” edge by default, behave as individual 

units, retaining their own geometries.

However, if you want the connected faces to “morph” smoothly, you can combine the distinct faces so that 

they henceforth behave as a unit while you edit them.

To do this, change the Edge settings (for any selected edges) from Hard (the default) to Soft. The easiest way 

to do this is to select any Edges, then click the Soft icon from the Info Box.
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Faces connected by a “soft” edge behave as a single surface in Morph editing operations, and the smoothing 

algorithm is applied to them as a whole, resulting in a different editing effect:
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Transforming Morphs: Box Stretch a Morph

Use this command from the pet palette of a selected Morph, to stretch the entire Morph by its bounding box.

1. Select a Morph.

2. From the pet palette, choose the Box Stretch command.

A bounding box appears around the Morph.

3. Click on an edge, face or node of the bounding box.

A “stretch” pet palette appears with three options.

4. Choose one of these three stretch varieties: Stretch, Stretch from Center, or Skew.

5. Then drag to transform your Morph.

Watch the Video

Depending on which part of the box you clicked, the stretching result will vary:

The plain Stretch (clicked on box face):
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The plain Stretch (clicked on a box node):

The Stretch from Center (clicked on box face):

The Skew:
ARCHICAD 24 Reference Guide 1330



Construction Elements Elements of the Virtual Building
Transforming Morphs: Cover with Faces

Use this command (Design > Modify Morph > Cover with Faces) to add faces onto an existing Morph. 

Select a Morph, or a series of Morph edges that form a closed polygon (this polygon can lie on any planes in 

space.

Use Design > Modify Morph > Cover with Faces.

From the appearing dialog box, choose whether the new faces should be based on

• Sharp edges

• Smooth surface

On an entire Morph:

If you have closed holes in the Morph, faces are generated to cover these holes.

On a series of selected edges forming a polygon:

• A Morph face is generated.

While you can also use the Add command from the pet palette, the Generate Faces command is different 

because it works on any plane in space.

Watch the Video
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Transforming Morphs: Custom Face Settings

You can apply custom surface and texture mapping settings to one or more Morph faces.

Note: By default, the surface applied to all Morph faces derives from the Building Material assigned to the 

Morph. You can override all Morph faces, using the Override Surface control in the Model Panel of Morph 

Settings. The Custom Face Settings offers a further way to customize the surface of any one or more 

Morph faces.

1. Select the face(s), or the entire Morph.

2. From the pet palette, choose the Custom Face Settings command.

3. Choose a custom surface and/or a different texture mapping:

Surface: Click the Surface override button, then choose a custom surface for the selected Morph face(s).

Texture: Choose a different texture mapping for the selected Morph face(s).

4. Apply Changes to: Once you have set the options as needed, choose the faces to which to apply these 

changes:

Note: These options are only available if you selected the entire Morph before bringing up the pet palette. 

If you selected only one or more faces, then your changes are applied only to the selected faces, and you 

have no other options here.

• Clicked Face will apply the chosen options (surface, texture mapping) only to the face you clicked when 

bringing up the pet palette.

• All Similar Faces will apply the chosen options to all faces in the selected Morph which had the same 

initial surfaces as the one you changed. For example, if you change the of a face from yellow to red, all 

faces in this Morph whose surface was yellow will also change to red.

• All Faces will apply the chosen options to all faces of the selected Morph.

5. Click OK to apply changes.
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Custom Morph Surface: Feedback in Morph Settings

If you have customized any of the Morphs’s Face surfaces (in the Custom Face Settings dialog box), a yellow 

“custom” icon appears alongside the surface setting control in Morph Settings, indicating that one or more 

face surfaces have been changed from the general setting.

If you later change the Surface setting in Morph Settings while the dialog box is still open, the yellow patch 

(indicating “custom face”) gets a red shadow. This means that the Morph’s surface setting is going to change: 

do you want to apply this override to the custom faces too? If so, check the box at the bottom of Morph 

Settings (Apply changes to custom faces/edges too). If you do not check the box, your custom faces remain 

the way you set them.
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Morph Edge Type: Hard, Hidden, Soft

• Morph edges, if hard, can be selected and edited.

• Hidden edges are simply hard edges that you have manually selected and set to be hidden.

• Soft edges are automatically generated during editing and smoothing operations, and within any curved 

Morph shapes; they are hidden by default and cannot be selected.

• Soft edges can also be defined manually by the user, as when you combine two faces into one by 

softening the dividing edge.

• A soft edge is an internal sub-element that divides segmented faces. Such faces are displayed (in 

OpenGL and rendering) as smooth and curved.

See Combine Morph Faces for Smooth Editing Effect: Use “Soft” Edges.

Watch the Video

Hard vs. Soft Edges: Show Hidden Morph Geometry

As you edit a Morph, you may wish to redefine an edge to be hard instead of soft, so that you can select it to 

modify the Morph shape.

To view (and be able to select) all edges, including soft ones:

Use Design > Modify Morph > Show Hidden Morph Geometry.
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Change Edge Type

You can change the Edge type of any selected edge(s) of a Morph.

For more information on using this function, see Combine Morph Faces for Smooth Editing Effect: Use “Soft” 

Edges.

1. Select the edge(s), or the entire Morph.

2. Choose a different Edge type (Hard, Hidden, or Soft) using one of the following controls:

• From the Info Box, or

• From the pet palette, by choosing the Custom Edge Settings command.

When you apply an Edge type that is different from the default Morph edge type, the Model Panel of 

Morph Settings will indicate that a custom edge type has been applied.

3. Apply Changes to: Once you have set the options as needed, choose the edges to which to apply these 

changes:

Note: These options are only available from the Custom Edge Settings dialog box, if you selected the 

entire Morph before bringing up the pet palette. If you selected only one or more edges, then your 

changes are applied only to the selected edges, and you have no other options here.

• Clicked Edges will apply the chosen edge type only to the edge you clicked when bringing up the pet 

palette.
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• All Similar Edges will apply the chosen options to all edges in the selected Morph which had the same 

initial setting as the one you changed. For example, if you change the Edge type from “Hard” to “Hidden,” 

all of this Morph’s hard edges change to hidden.

• All Edges will apply the chosen type to all edges of the selected Morph.

4. Click OK to apply changes.
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Boolean Operations with Morphs

Three Boolean operations are available from the Design > Modify Morph menu (or the context menu of 

selected Morphs):

• Union

• Subtract

• Intersect

Note: You can also enable priority-based connections between Morphs and other elements. For 

information on how intersections (junctions) work among construction elements, including Morphs.

Morph Boolean Operations: Intersect, Subtract, Union

See Element Intersections and Merge Elements: Roofs, Shells, Morphs.

These commands are available if the last selected is a Morph; these operations can only involve Morphs. (If 

you want to operate on non-Morph elements, first convert those elements to Morphs.)

Unlike Solid Operations on other ARCHICAD elements, these operations are not associative - the final result 

of the operation is permanent.

Union

1. Select the Morphs you wish to merge.

2. Issue the Boolean Operations > Union command.

Note: If you have only selected one Morph, it is considered the operator. You are prompted to click 

another (Target) Morph with which to merge it.
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3. As a result of this command, the Morphs in the selection will be merged into a single Morph element.

The resulting Morph will use the attributes of the last selected Morph.

Subtract

Use this Solid Morph Operation to subtract one Morph from another.

1. Select the Morph(s) you wish to subtract.

2. Issue the Boolean Operations > Subtract command (from the context menu) or Design > Modify 

Morph > Subtract.

Note: If your original selection contains any non-Solid Morphs, you are warned of this. You can either 

proceed anyway - this will leave the non-solid Morphs out of the operation - or ask to Show non-Solid 

Elements.

3. You are prompted to “Click a Morph from which to subtract the selection.” (The clicked target Morph can 

be a surface; it need not be solid.)

Note: If you try to click a target element that is not a Morph, the cursor changes to the “Do not Enter” sign 

and you get a warning to that effect.

4. After the Subtract operation is completed, the Operator elements are deleted. The result is always a 

Morph.

Intersect

Use this command to intersect multiple solid Morphs and end up with a single Morph.

1. Select the Morphs you wish to intersect.

2. Issue the Boolean Operations > Intersect command (from the context menu) or Design > Modify 

Morph > Intersect.

Note: If you have only selected one Morph, that element is considered the operator. You are prompted to 

click another (Target) Morph with which to intersect it.
ARCHICAD 24 Reference Guide 1338



Construction Elements Elements of the Virtual Building
3. As a result of this command, the intersecting portion of the originally selected Morphs are retained, 

resulting in a single solid Morph.

The resulting Morph will use the attributes of the last selected Morph.
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Morph Texture Mapping and Alignment

Texture Mapping

If your Morph uses a surface that includes a texture, you can control how that texture is displayed on the 

Morph surfaces.

The Texture Mapping definition (either Box or Planar) is shown in the Model Panel of Morph Selection 

Settings.

Box Mapping: this is the default, and the only option available if you have selected an entire Morph (see Box 

Mapping below).

Planar: This option can only be chosen if your selection includes one or more faces. The “Planar” definition 

means that you can vary the plane from which the texture is projected onto the selected face, as well as set 

an individual texture alignment and origin for the face.

Box Mapping

For a Morph selected as a whole, and for default Morphs, the texture mapping is always “Box.”

“Box” means the pattern is projected onto the Morph from six planes (as from a box). Any given plane gets its 

texture from the direction of the closest of the six planes.

The origin of the texture is at Project Zero.

Set Origin of Box Mapping

1. Select one or more Morphs.

2. Use Document > Creative Imaging > Align 3D Texture > Set Origin.

3. Click at the point (e.g. a corner) where you want the texture pattern to originate.
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4. The origin is set. (If you selected multiple Morphs, the texture origin is in effect for all selected Morphs.)

Set Direction of Box Mapping Texture

1. Select one or more Morphs.

2. Use Document > Creative Imaging > Align 3D Texture > Set Direction.

3. In the appearing dialog box, enter a rotation angle or draw a vector to reset its direction.

Reset Box Mapping

For Box Mapping, “reset” means that the texture origin returns to Project Zero.

1. Select one or more Morphs.

2. Do one of the following:

• Use Document > Creative Imaging > Align 3D Texture > Reset.

• Click Reset Texture in Morph Selection Settings (Model Panel), or click the Reset button alongside 

Custom Texture in the Info Box.

3. The texture origin is reset.

Planar Mapping

This option can is available only if your selection includes one or more Morph faces. The “Planar” definition 

means that you can vary:

• the plane from which the texture is projected onto the selected face

• the texture origin separately for any face

• the texture alignment separately for any face

Set Texture Projection by Plane

1. Select one or more Morph faces.

2. Choose Document > Creative Imaging > Align 3D Texture. (The Texture Mapping control in Morph 

Selection Settings automatically changes to “Planar.”)
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3. Choose one of the following commands: Set Origin/Set Direction.

4. An editing square appears on the Morph face, representing a unit of the texture pattern.

5. Vary the editing plane to vary the texture projection.

Set Origin or Alignment by Plane

1. Select one or more Morph faces.

2. Choose Document > Creative Imaging > Align 3D Texture. (The Texture Mapping control in Morph 

Selection Settings automatically changes to “Planar.”)

3. Choose one of the following commands: Set Origin/Set Direction.

4. An editing square appears on the Morph face, representing a unit of the texture pattern.

5. Click anywhere on the square. A pet palette appears with the “Move” and “Rotate” options.

6. Do one of the following:

• Drag the square and click to place. The clicked point represents the origin of the texture pattern on that 

face.

• Choose the Move icon to drag the texture and realign its origin (same effect as above).

• Choose the Rotate icon to rotate the texture direction on that face.
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7. Click anywhere outside the square with the hammer cursor to complete the operation.

Watch the Video
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Fix Modeling Errors: Check and Solidify Morphs

What is a Non-Solid Morph?

A Morph is non-solid if it includes any edge segment that is not adjoined by exactly two faces. A Morph with a 

free-standing edge, or faces that do not connect precisely, will be non-solid.

Often, you cannot see the non-solid error if you are looking at a complex model.

This may cause problems:

• if you calculate Morph volume in lists, a non-solid Morph will have a volume of zero;

• only solid Morphs can have a cut fill; a non-solid Morph in Section is shown without a fill.

How To Fix a Non-Solid Morph: Use Solidify Command

To find and fix such modeling problems, do the following:

• Check the Info Box or Settings of any selected Morphs to see if they are solid.

• Select any or all Morphs, then use the Check Solidity command from the context menu (or the same 

command from Design > Modify Morph).

• If any of the selected Morphs is not solid, you get a warning, and the problematic Morphs and edges are 

highlighted in the model, as shown in the image below.
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• To try to fix the error, click Solidify.

If the Solidify Command Cannot Fix The Error

If the Solidify command could not fix the non-solid Morph automatically, you get a warning.

The problematic Morphs and edges are highlighted in the model.

Try to fix the problem with graphical editing, adding Morph edges to fill in the gaps:

• Use the Add to Morph command (pencil icon) from the pet palette to add one or more new Edges where 

the gap is. Each time you add a new Edge, ARCHICAD will automatically try to create adjoining solid 

faces within the Morph.

• In some cases, it is useful to draw another Edge on top of an existing Edge where the gap is, to generate 

automatic faces.

• When you are done adding edges, select the Morph and use Check Solidify again to see if the edits 

worked.

Watch the Video
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Model Element Connections

ARCHICAD enables you to create complex structures by combining model elements with each other.

There are several types ways to connect elements:

• Automatic Priority-Based Junctions: Colliding construction elements will generally create correct 

intersections in all views, based on the elements’ (or skins’) respective Intersection priorities, as defined in 

their Building Materials.

• Trim (use a Roof or Shell to trim any model element geometrically)

• Merge Elements (to connect Roofs, Shells and Morphs with other elements, enabling priority-based 

junctions to take effect)

• Solid Element Operations (SEO)

• Join (between one or more Walls and a Curtain Wall)

What all of these functions have in common is that they create an associative connection between two 

elements. “Associative” means that even though the connected elements remain separate elements, if you 

change one element’s geometry, then the connected element will automatically adjust itself as needed.

Each function is described in detail in the following sections:

Element Intersections

Trim Elements to Roof or Shell

Join Wall to Curtain Wall

Solid Element Operations

Merge Elements: Roofs, Shells, Morphs

Managing Element Connections
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Element Intersections

When they intersect each other, ARCHICAD model elements will “clean up” in predictable, largely automatic 

ways. The following sections explain how model elements intersect in ARCHICAD:

Basic Intersection Principles

Specific Element Intersections and Junctions

How to Make Sure Elements Collide for Best Cleanup Results

Intersecting Elements That Don’t Clean Up

Best Practices for Intersections: Conceptual Design Phase

Fine-Tune Intersections

Legacy Intersection Mode for Older-Version Projects
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Basic Intersection Principles

In ARCHICAD, the basic principle of intersections (or junctions) is that the construction elements must collide 

in space. All construction elements will clean up correctly in all views, provided that they collide.

– In the case of Shells, Morphs and Roofs, they must collide, and they must also be merged or 

trimmed via the commands of the Connect menu. 

See Merge Elements: Roofs, Shells, Morphs and Trim Elements to Roof or Shell.

The resulting intersection depends on the elements’ Building Material priorities, set in the Building Materials 

dialog box. The element (or skin) with the higher-priority Building Material will cut the one of a lower priority.

See Change Intersection Priority.

This works for the following elements: Wall, Beam, Column, Slab, Roof, Shell, Morph – whether basic, 

complex profile, or composite. (All these elements use at least one Building Material.)

Automatic Intersections in ARCHICAD

• Intersections are model-based: the connections physically modify the geometry down to the skin level. 

This means that they will be correct in all model views, including the 3D window and in lists or schedules, 

as well as on Floor Plan and Section

Note: Intersections that include elements in symbolic display in Floor Plan may not match the 3D model 

representation; elements whose display is based on their 3D projection will be correct.

• Layer Intersection Groups provide an additional means of control: elements whose layers have differing 

intersection numbers never intersect.
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Note: Layer Intersection numbers have nothing to do with element priorities; they serve merely as tags or 

labels (e.g. 1 or 2) for grouping elements.

See Use Layers to Prevent Intersections.

Junction cleanup based on skin priority
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Specific Element Intersections and Junctions

See the following sections for specifics on element intersections:

Wall-Wall Intersections

Beam-Beam Intersections

Wall-Beam; Wall-Column; Column-Slab; Column-Beam, Wall-Slab

Wall-Slab Intersection: Slab Finishes and Opening Thresholds

Intersections involving Shell, Roof, or Morph

Intersecting Elements with Identical Priorities

Line Elimination Between Model Elements

Curtain Wall Frame Intersections

Wall-Wall Intersections

Requires Reference Line intersection

For Wall-Wall junctions, it is not enough that they collide: their reference lines must also intersect. The 

element (or skin) with the higher-priority Building Material will cut the one of a lower priority.

For Equal-Priority Walls: Set Junction Order

If two or more Walls meet (their reference lines intersect), use Junction Order to control the element level 

junction. Changing Junction Order determines which two Walls meet first, before others join the intersection.

Set Junction Order in the Model Panel or Info Box of Wall Settings.

Watch the Video
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Beam-Beam Intersections

Requires Geometry Collision or Reference Line intersection.

For maximum flexibility in Beam-Beam intersections, make sure their reference lines intersect. In this case, 

the Beams do not actually have to collide. The Beams will auto-stretch into each other along their reference 

lines. 

You can also intersect beams by simply colliding them, even if the reference lines do not intersect. In this 

case, however, the Beams will stop each other; the Beams will not auto-stretch further along their reference 

lines. The element (or skin) with the higher-priority Building Material will cut the one of a lower priority.

Watch the Video

If two or more Beams meet (their reference lines intersect), then use Junction Order to control the junction.

Here, the Beams use Junction Orders as follows:

• Transparent Beam = 8

• Weaker green Beam = 7

• Stronger blue Beam = 9
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Wall-Beam; Wall-Column; Column-Slab; Column-Beam, Wall-Slab 

Requires Geometry Collision.

The element (or skin) with the higher-priority Building Material will cut the one of a lower priority.

Exception for Wrapped Column intersections with Composite Walls: 

When placing a “Wrapped” Column that intersects a composite Wall, the Column will break through the core 

skins of the composite Wall regardless of skin priorities. 

Wrapping Wall skins will be added to the column veneer in 3D. However, they will not be calculated in listings.

Watch the Video

Wall-Slab Intersection: Slab Finishes and Opening Thresholds

A special case pertains, to allow continuous finishes between rooms within an interior openings threshold.
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When an Opening (Door or Window) in a Wall is flush with the top of a Slab, then the Slab's finish skins will 

continue through the Wall regardless of skin intersection priorities (down to the Slab’s core skin). If the 

Opening is not flush with the Slab, then the regular priority-based connections are in effect.

In the image:

Left: Window and Door are flush with the Slab’s top. Therefore, the Slab's finish skins do not form priority-

based junctions with the Wall's skins. Instead, the Slab’s finish skins remain continuous.

Right: Window and Door are not flush (they are elevated above the Slab), so the usual rules for priority-

based connections are in effect between the Slab and Wall skins.

Intersections involving Shell, Roof, or Morph

Requires Geometry Collision, and Trim or Merge command.

If your intersection includes a Shell, Roof or Morph, you must use Design > Connect > Merge Elements to 

ensure correct intersections. 

If a Shell or Roof acts as a trimming element (Design > Connect > Trim Elements to Roof/Shell) it will be 

merged with the trimmed element; you do not need to use the Merge Elements command again to achieve 

correct intersections.

Once merged, the element (or skin) with the higher-priority Building Material will cut the one of a lower priority.

Related topics:

Trim Elements to Roof or Shell

Merge Elements: Roofs, Shells, Morphs
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Intersecting Elements with Identical Priorities

When various, colliding construction elements have the same intersection priority (for example, elements that 

have the same building material), the following intersection order will prevail:

Morph > Column > Beam > Slab > Wall > Shell > Roof > Mesh

Line Elimination Between Model Elements

If two elements (same or different construction element types) meet in a model view, such as Section, 

Elevation and 3D Document, then the following line elimination rules apply. 

Notes: 

– These rules don’t apply on the Floor Plan, where all lines of will be drawn. To determine which line is 

visible, you can use Display Order. See Display Order.

– For Composite and Complex Profile elements, line control is customizable by the user in the attribute 

settings dialogs.

The following rules apply to construction elements when cut:

• Same Building Material: Both lines will be eliminated, and the hatches will visually merge

• Same Fill but different Building Materials, or Different Building Materials: One line will be eliminated based 

on the following rules: 

– Different Line Weight: The line with the thicker pen will remain, regardless of Line Type

– Same Line Weight, different Lines: The solid line will be kept, and the other lines are eliminated.
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Walls in Section - from left: 

Same Building Material; Different Building Materials but same Cut Fill; 

Solid Line vs. Dashed Line; Solid Lines (different Line weights)

If one or both elements do not use a Building Material (e.g. two objects), the above logic is applied to the Cut 

Fills (as opposed to Building Materials). Thus, identical Cut Fills between two objects will eliminate both lines.

Wall/Slab and Kitchen Cabinet in Section - from left:

Cabinet has different Cut Fill; Cabinet has the same Cut Fill.

• If you want to retain the dividing line, change the Layer Intersection Group number of one of the elements. 

See Use Layers to Prevent Intersections.

In Elevations and 3D views, dividing lines will always be eliminated between two elements when:

• they have the same surface, and

• the surfaces are co-planar.
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Walls/Slab/Roof in 3D - from left: Same Surface, co-planar; Different Surfaces, co-planar; Same Surfaces, in 

different planes
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How to Make Sure Elements Collide for Best Cleanup Results

Use the following techniques and features to ensure that your elements collide as needed.

Define Wall/Slab Core as the Reference Line/Plane

Place the Slab reference plane at the top of the core.

Place the Wall reference line along the Wall core (outside or inside).

You can assign a Slab’s reference plane, or a Wall’s reference line, to run along the element core, in addition 

to its faces.

This way, when you edit the Wall or Slab (e.g. adds skins or changes the thickness), the Wall/Slab core 

connections remain constant, and the elements’ positions relative to their reference line remain unchanged.

Related topics:

Wall Reference Line

Slab Reference Plane

Link Wall/Column/Zone Tops to Story Above

You can link the tops of Walls, Columns and Zones to a story. Use this feature to ensure that these elements 

stay properly connected to the structure or ceiling above them even after you edit story heights.

See Define Top Link for Wall, Column, Zone or Stair.

Adjust Elements to Slabs

Use this function (Edit > Reshape > Adjust Elements to Slabs) to easily adjust elements (Walls, Columns, 

or horizontal Beams) to specific levels of one or more Slabs that are located above and/or below them.

Suppose you are migrating an older-version ARCHICAD file in which the Wall bases are placed on the tops of 

Slabs. As of ARCHICAD 17, the Walls can extend past the Slab’s finish level to its core, which is what you 

want. To speed up this process, select multiple Walls and then use the Adjust Elements to Slabs command 

to extend them all to the Slab core with a single click.

See Adjust Elements to Slabs.

The intersections will now clean up nicely, provided that your Building Materials are consistent. The element 

(or skin) with the higher-priority Building Material will cut the one of a lower priority. 

Note: If a Door/Window is linked to the bottom of a Wall, the Adjust Elements to Slabs command will 

automatically recalculate the offset to retain the opening position.
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Anchor Door/Window to a Story

When placing new Doors/Windows, it is best to anchor them to a Story level rather than to the base of the 

Wall, to ensure they remain in place.

However, if your Door/Window is linked to the bottom of a Wall, the Adjust Elements to Slabs command will 

automatically recalculate the offset to retain the opening position.

Let the Cursor Help You

When you work with composite elements, the cursor can snap to each separate skin and component in all 

model views. This way you can make sure that you are aligning elements correctly to the core of other 

elements. 
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Intersecting Elements That Don’t Clean Up

• Wall-Wall intersections clean up only if their reference lines intersect. (Collision is not supported.)

• Column-Column intersections do not clean up when they collide.

• Use a profiled column or the Merge Profiles function to achieve special Column intersections.

• When placing a Column that will intersect a Composite wall, your choice of Geometry method – wrapped 

or unwrapped – will affect the display of the wall/column in the Floor Plan.

• Slab-Slab intersections do not clean up when they collide.

• Mesh is not supported.

• Objects are not supported.

On Floor Plan In Section
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Best Practices for Intersections: Conceptual Design Phase

In this phase, you often can only estimate what the final structure will be. For maximum flexibility, and to avoid 

modeling errors as the design undergoes changes (e.g. structures are replaced or composite layers are 

edited), try the following:

Use Composite Slabs with At Least Two Skins

This way, you can add finishes to the structures on either side, without the details falling apart.

Note: In the early design phase, a composite that consists of a single skin will also work well, if the top of 

the monolithic structure is considered as the core top)

Use Wall Reference Lines Consistently

• Flip Wall along Reference Line: This command flips (or mirrors) a selected Wall along its reference line. 

The reference line stays in place, but the body of the Wall flips to the other side. The openings do not 

change their opening direction.

For example, you may use this command if you initially modeled the project using single-skin Walls to 

represent core structures, then start adding additional skins at a later design phase.

See Flip Wall Along Reference Line.

• Modify Reference Line: This command moves the reference line without changing the Walls’ position on 

the Floor Plan.

For example, use this command if you are migrating an older project in which a Wall Reference Line was 

set to Outside Face: modify the reference line to Core Outside, without moving the geometry of the Wall 

itself.

See Modify Wall Reference Line.
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Anchor Door/Window Reveal to Wall Core

Anchor the Door/Window reveal to either the Wall face or the Wall core. 

For example, you anchor a window to a composite Wall’s core. If you later make changes in the composite 

structure (e.g. thicker insulation), the reveal depth will automatically adjust to maintain the window’s distance 

relative to the Wall’s core skin.

See Anchor Reveal.

On the right, the window position adjusts automatically to the change in Wall thickness, because it is anchored 

to the Wall core
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Fine-Tune Intersections

To adjust the intersection of elements (or their skins/components), you can do one of the following: 

Change Building Material Priority (Affects All Project Elements)

Select the element that is problematic. Then open the Building Materials dialog box. Notice that the Building 

Material(s) of the element(s) you selected are marked, so they are easy to find in the list (available for any 

element that contains Building Materials – Composites, Profiles as well, from any view). Select that Building 

Material, then use the Intersection Priority slider (at right) to change the priority.

You can sort the list by priority to understand how the current change might affect other Skins in the project. 

Once the list is sorted by Priority, you can drag Building Materials up and down to change their priority.

Be aware that Building Material definitions are global; any changes you make here will affect all project 

elements which use that Building Material – not just the selected elements!

Duplicate Building Material (Apply to Single Element)

If you want to adjust the priority in just one element of the project, you can create a duplicate Building Material 

with a different priority.

Select the element that is problematic. Then open the Building Materials dialog box. Notice that the Building 

Material(s) of the element you selected are marked, so they are easy to find in the list. Select that Building 

Material.

Click New and make sure you are creating a Duplicate. Give the duplicate Building Material a new name.
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In the Building Material dialog box, the newly created duplicate is selected in the list. Adjust its priority as 

needed, then assign this new Building Material to the problematic element.
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Legacy Intersection Mode for Older-Version Projects

If you open an older-version project (ARCHICAD 16 or earlier), the Legacy Mode for element intersections will 

be turned on by default to maintain the appearance of your model.

In Legacy Mode, the automatic and Building Material priority-based intersections implemented as of 

ARCHICAD 17 will not take effect in 3D. Connection methods used in ARCHICAD 16 and earlier versions will 

be used. You may prefer this when working on an older project, to ensure that your existing intersections 

remain intact. 

Legacy Mode is controlled in Options > Project Preferences > Legacy.
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Parametric Objects

When you place an Object (as opposed to other elements in ARCHICAD), you are placing an instance of an 

external file located in an object library. ARCHICAD is shipped with a standard object library containing 

hundreds of preconfigured, editable objects (also known as GDL objects or Library parts). For the most part, 

you will use ARCHICAD tools to place objects from this standard library.

Objects are parametric. This means that you can freely configure the placed instance, using the Object 

Settings dialog box, or the dialog boxes associated with the object-type tools, without actually modifying the 

source file for the object.

See Settings of Library Part Elements and Object Tool Settings.

What’s Covered

About Parametric Objects

Where to Find Objects for Use in ARCHICAD

BIM Components

Search for Library Part

Placing an Object

2D and 3D Representation of Objects

Selecting a Placed Object

Stretching Objects

Parameter Transfer Between Objects

Graphical Editing Using Editable Hotspots

About GDL Object Subtypes

Create Patch Object

Create Custom Library Parts and Components

Open and Edit Library Part

Scripting Custom Objects

Further Resources on GDL Object Creation

Related Topics:

Ramp Object
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About Parametric Objects

Objects can be placed in the Project

• using one of ARCHICAD’s dedicated tools (Object, Lamp, Door, Window, Skylight, Corner Window, Wall 

End, Curtain Wall Accessory or Junction)

• automatically by specific commands or Add-Ons (Markers, Labels, RoofMaker and TrussMaker elements)

See Settings of Library Part Elements.

When you open an ARCHICAD Project, ARCHICAD automatically runs a check to ensure that all needed 

libraries and library parts are up to date and available. If there are any issues, the Action Center or Library 

Manager provides information.

See Troubleshooting Library Issues.

You will find most of the objects you need for your project in the ARCHICAD Library - the factory-shipped 

library of standard objects. The objects are organized into folders and sub-folders to make it easy to locate 

what you need. The ARCHICAD Library is comprehensive, although localized versions of ARCHICAD 

libraries will contain special objects which are localized for the standards of particular countries.

When you activate a tool that is dedicated to a particular Object subtype (i.e. Door), the Settings Dialog box 

accesses only the relevant part of the ARCHICAD Library. For example, activating the Window Tool gives you 

access to all the Windows in the ARCHICAD Library, but not Doors or Mechanical Objects.

See also About GDL Object Subtypes.

All of these files can be opened in ARCHICAD with the File > Libraries and Objects > Open Object command 

and they can be created in ARCHICAD with the File > Libraries and Objects > New Object command. You 

can also create objects graphically, using other ARCHICAD elements, and then saving them as an Object file.

See Create Custom Library Parts and Components.
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Where to Find Objects for Use in ARCHICAD

• The standard ARCHICAD library, shipped as part of your program, contains hundreds of predefined 

standard objects.

• Using ARCHICAD’s Library Manager, you can load additional libraries or add individual library parts as 

embedded objects at any time. You can also access libraries from BIMclouds.

For more information, see Library Manager.

• Through the Settings dialog box of Library Part elements, as well as Surfaces, you can access BIM 

Components (BIMcomponents.com) while browsing for library parts. BIM Components is a searchable 

and interactive depository of objects and surfaces contributed by ARCHICAD users.

For more information, see Search for Library Part and BIM Components.

For information about importing surfaces, see New from Catalog (at Surfaces).

• On the Internet, you will find a growing number of websites dedicated to GDL Objects. See especially the 

GDL Center, GRAPHISOFT’s GDL knowledge base, at gdl.graphisoft.com.

• A number of third party programs or Add-Ons let you create or edit GDL Objects. These objects contain 

GDL scripts as well as other, application dependent data. Consult your dealer for availability information.

• DXF libraries are widespread in the CAD world and cover almost every area of engineering and design. 

Many manufacturers offer symbols or models of their products in DXF format. ARCHICAD can easily 

import these libraries.

• You can use existing elements within ARCHICAD to create and save custom objects.

For more information, see Create Custom Library Parts and Components.

• In some cases, you can sculpt in other 3D applications and import the 3D model.

For more information, see add-on specific documentation in the GRAPHISOFT Documentation folder.

• If you want to try your hand at GDL scripting, start with Scripting Custom Objects. See also the GDL 

Center at gdl.graphisoft.com.
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BIM Components

BIM Components, at BIMcomponents.com, is a public website containing GDL objects and surfaces. Anyone 

can access the portal to browse, search, view and even download these files for free.

To upload, comment on, and rate the objects or surfaces, users must first register using a valid email address. 

It is not necessary to be an ARCHICAD user to access or upload to BIM Components.

What Can You Do On BIM Components?

• Search. Find specific objects or surfaces, using an interface just like that of ARCHICAD Object Settings.

Objects/surfaces are shown with preview picture, description and an interactive 3D preview, with which 

you can rotate the object and modify its parameters.

• Browse. If you like, use the “tag cloud” (word cloud) to browse the most popular items.

• Register. The process is simple - provide your email address or an existing GRAPHISOFT ID. After 

successful registration, you will receive a Registration Number, which you will need in order to share an 

object or surface from ARCHICAD.

• Share. You can share both individual GDL Objects and LCF (Library Containment) files, as well as surface 

attributes. (Use LCF if you want to share a whole family of objects at once.) As part of the Share process, 

you can specify an attribute set by selecting your language template, ensuring that the object will work for 

others the way it works for you.

• Participate. Comment on and rate the items you find to help other users find the most suitable one, and to 

help developers create even better content.

For more information on all these functions, go directly to the BIM Components Portal at 

BIMcomponents.com.

Obtain BIMcomponents.com Registration Number

Before sharing an object to BIMcomponents.com, you must obtain a registration number. Once you receive 

the registration number, you need only enter it once; after that, ARCHICAD will remember it. (It is also listed in 

the License Information dialog box, available from the ARCHICAD Help menu.)

Share Object on BIM Components

Note: Before sharing an object to BIMcomponents.com, you must obtain a registration number. (See 

above.)

To share an object on BIM Components, do one of the following:

Select an object from the Settings dialog box (Library view), then use the Share Object command from one of 

these places:

• the context menu

• the icon at the bottom of the dialog box

• the File > Libraries and Objects > Share Object command

• The Share Object command from the context menu of a placed object.
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The Share Selected Element dialog box appears.

Note: Before the Share process can proceed, a background check is run to ascertain that the object’s 

parameters (e.g. copyright definition) and the user’s license information are correct.
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Edit the following information as needed:

1. Enter an Author. (If you leave this blank, the name you used to register on BIMcomponents.com will be 

used as the author.)

2. Assign a License. The following license options are available (for a complete description of any license 

option, click the Info button from the dialog box)

–  Public Domain Dedication 1.0. An element with this license belongs to the public domain; anyone 

can copy, modify or distribute it without permission.

–  Attribution-NoDerivs 3.0. An element with this license can be copied and distributed, even for 

commercial purposes, but only with attribution, and the object cannot be modified.

– Attribution-NoDerivatives 4.0: This is a newer version of the Attribution-NoDerivs 3.0 license. 

– Attribution 4.0: An element with this license can be further shared (copy and redistribute the material 

in any medium or format) and adapted (remix, transform, and build upon the material for any purpose, 

even commercially)

– Attribution-ShareAlike 4.0: An element with this license can be further shared (copy and redistribute 

the material in any medium or format) and adapted (remix, transform, and build upon the material for 

any purpose, even commercially), but the contributions must be distributed under the same license as 

the original.

Note: Another type of copyright, “Commercial,” can be assigned from the GDL Editor window. Objects 

with a commercial copyright, however, cannot be shared to BIMcomponents.com.

See GDL Object Editor.

3. Password (not available with Public Domain license). Click Set Password to define an optional 

password. Such objects can be freely viewed and downloaded, but the user cannot open the object to edit 

or copy its script without a password. If the object already has a password, the Change Password button 

allows you to modify it.

4. Description and Keywords. Enter a description and Keywords to describe the object. ARCHICAD’s 

object search function will search (among other fields) these fields for the entered search terms. While 

optional, a detailed description is recommended, including the functions and purpose of the object, so that 

other users will be able to locate it.

5. When you are ready, click one of the following:

• Share; or

• Share and Save. (This saves any changes to the object data in your Embedded Library as well as to 

BIMcomponents.com.) 

Note: the Share and Save command is not available in the following cases:

– if you are working in Teamwork but have not reserved the object, or

– if the object has been opened from a Library Container File (.lcf)
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During the Share process, you cannot keep working in ARCHICAD. A dialog box shows the progress.
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Search for Library Part

To search for library parts, use the search field at the top left of the browser section of its Settings dialog box.

This search function is available in the Object Settings dialog box, as well as the Settings of any tool that 

places Library Parts: Window, Door, Skylight, Wall End, Corner Window, Lamp, MEP tools.

For information on searching for Favorites from other dialog boxes:

See Search Favorites.

For information on searching and loading surfaces from catalogs, using the Surfaces dialog box:

See New from Catalog.

Enter Search Mode

Do one of the following:

• Click into the Search field

• Click the Search icon (magnifying glass)

• Click Ctrl+e (Mac: Cmd+e)

Define Scope of Search

Use the pop-up control at right to define where to search (at least one of the three options must be checked):

• Search Active Library: Search in linked libraries, the Embedded Library, and BIMcloud Libraries you 

have downloaded

• Search Favorites: Search only among the saved Favorites for this tool

• Search BIM Components Portal: Search only on BIM Components Portal, a searchable and interactive 

depository of objects contributed by ARCHICAD users or uploaded by GRAPHISOFT.

For more information, see BIM Components.
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Start Search

Enter any string of characters to search for. 

Once you press Enter or end your input (no input for 1 second), the search process will begin.

The search engine will search for the string in the following locations:

• Library Part name

• Library name

• Description 

• Subtype

• Name of author of Library Part

• Keywords

See also Search Favorites.

Hints for Using Search Terms

• Use quotation marks around a phrase to search for exactly that phrase, rather than the individual words

• From the context menu of a Library Part in the Settings dialog box, use Search for Name from the context 

menu. This will copy the name and add it to the Search field. For example, use this to search for Favorites 

based on a particular Library Part.

Display of Found Library Parts

The Found Library Parts panel in the browser area displays your search results. 

Only those library parts are found which are used by the active tool. In other words, if you are searching in the 

Object Settings dialog box, Objects will be found - no Doors or Windows.

Depending on your where the library parts were found (see Define Scope of Search), the options differ:
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Results from Active Library:

• Click a library part to apply its settings and see them in the panels on the right

• Hover the cursor over a library part to see its name and the library where it is located

 

– Use Select in Library to switch to the library view and see this in the context of its library hierarchy
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Results from Favorites

• Favorite search results are displayed with a star icon

Results from BIM Components Portal

• Found BIM Components are displayed with a globe icon.

Exception: Some of the BIM Components-based hits will be marked with a key. Such objects are 

available only to users with some type of premium service agreement. (This may vary by market; contact 

your distributor.)

Note: The “Found Library Parts” section will display a maximum of 50 of all the library parts found on BIM 

Components; if more are found, you can see the remaining hits by clicking on the More elements... link at 

the bottom of the dialog box.

• Hover the cursor over the component to see its name.
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• Click to see its Preview and Information the panel on the right.

• Context menu commands:

– Go to BIM Components Portal: Click to enter BIMcomponents.com.

See BIM Components for more information about this web page.

– Download and Embed: Click to download the library part to your Embedded Library.

You can access this same command from the Preview and Information panel at right.
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While the download is underway, you cannot work in ARCHICAD. Click Cancel to abort the download 

process.

Exit Search Mode

To exit search mode, do one of the following:

• Click on either of the other two icons at the top (Library view or Favorites view).

• Close the Settings dialog box

Even after you exit Search mode, ARCHICAD will remember the last-used Search and its results, which will 

be shown the next time you enter Search mode.

To clear the Search, use Clear Search from the pop-up menu:
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Placing an Object

Typically, you will follow these steps when placing an object:

1. Select the corresponding tool in the Toolbox and open its settings dialog box by double-clicking the tool’s 

icon.

2. Browse for the appropriate element in the available library folders.

3. Adjust the default settings default to suit your particular situation or purpose. The external file is not 

affected in any way by the changes you make in the Object (Lamp, Door, etc.) Settings dialog box.

4. Click at the desired location and place the customized instance of the object.

Note: Objects can be placed in a Section/Elevation window, but they are considered as graphic symbols 

only. (No corresponding 3D model element is generated.)

See also 2D and 3D Representation of Objects.

Placement Anchor

The primary hotspot (object’s placement anchor) can be defined on the Preview and Positioning Panel of 

Object Settings. Before placing the Object or Lamp, make sure that you have selected the appropriate hotspot 

to serve as the anchor.

See Object Preview and Positioning Panel.

Placement Aids

When the Object or Lamp tool is active and you place your cursor inside a construction window, the ghost 

bounding box of the element is shown and it follows the movements of the cursor. This also allows you to 

check the active hotspot used for positioning the Object or Lamp. You can switch this ghost box feature off in 

Options > Work Environment > On-Screen Options.
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When positioning the Object or Lamp, you can use numerical input, gravitation, mouse constraints or the 

grids. This allows you to fit fixtures or furniture to corners, specific positions, or to each other with great 

accuracy.

Geometry Methods

Four geometry methods are available in the Info Box for placing Object and Lamp type Library Parts.

• The Orthogonal method automatically places Library Parts in alignment with the normal grid lines unless 

you specify a rotation angle in the Settings dialog box before placement.

• To place a Rotated Library Part, first define a reference point by clicking any point Use the resulting 

rubber band line to place the rotation vector. This rubber band line can be constrained using any of the 

drafting modifiers or enabled Mouse Constraint angles.

• The Diagonal input method works like the rectangle geometry method used for polygonal elements.

• The Rotated diagonal input method works like the rotated rectangle method used for walls, slabs, etc.

The last two methods let you define the A and B parameters of the Object or Lamp graphically. (For most 

objects, these parameters represent the Length and Width of the object on the Floor Plan.) Note that they are 

only available if the GDL Object can be freely stretched; some Objects may have fixed or proportionally set 

dimension parameters.

The result of this technique also depends on the primary hotspot (anchor). As a rule of thumb, if a hotspot at 

the corner of the object is selected, you can define both the A and B parameters graphically. If the hotspot is 

along a side of the object, you can only define one of the parameters graphically and the other parameter will 

be taken from the Settings dialog box. When choosing a hotspot within the bounding box of the symbol, none 

of the parameters can be set graphically and the element will be placed as if using the simple orthogonal or 

rotated methods.

Selecting a Placed Object

Use the regular selection techniques, including the Find & Select function, to select objects or groups of 

objects.

Unlike when selecting walls or other elements constructed on the fly, the cursor can only snap to predefined 

hotspots of the object symbol. Objects can be placed, selected, and fitted to other elements by these hotspots.
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2D and 3D Representation of Objects

Model View Options for Library Parts

Depending on which libraries your project has loaded, use Model View Options (Document > Model View > 

Model View Options) to assign global preferences for the display of certain library parts and their 

parameters.

See Miscellaneous Settings for Library Parts.

By default, Objects and Lamps use the detail level settings defined in Model View Options (By MVO). For a 

specific object/lamp, if the control is available, you can override its detail level in Element Settings (use the 2D 

or 3D Representation controls).

3D Detail Level

Where available, this control lets you overwrite the MVO-based settings for an object: Choose Schematic, 

Simplified, or Full.

If you choose Off, the object is not shown in 3D. 

2D Detail Level

• If you choose Scale-sensitive, the object’s display varies with the scale setting in Document > Floor Plan 

Scale.

• If you choose Symbolic, the Symbol Type parameter becomes available, where you can choose a fixed 

symbol to display the object in 2D views regardless of the scale.
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2D vs. 3D Objects

Plants, People and Vehicles can be found both in the 2D Elements and the Visualization folders. The People 

and Plants in the 2D Elements folder are shown in elevation view and are meant to be placed in Section/

Elevation/IE windows. Using these simple representations saves time.

Vehicles are also 2D only elements, but they have two or more View Types: a top view for the Floor Plan and 

side, front and/or rear views for Sections/Elevations.

The counterparts of these elements in the Visualization folder are full 3D representations meant to appear in 

the 3D Window and especially in PhotoRendered pictures. The Visualization folder also contains a couple of 

Picture elements used for texture mapping. They are displayed as simple fills in shaded views and only 

appear in photo-renderings. If you place and activate a Camera, the picture will always face this camera to 

avoid distortion.
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Some complex elements may take a long time to display in fully detailed 3D - for example, realistic trees and 

other plants that consist of a very large number of polygons.
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Stretching Objects

Objects, including Doors and Windows, can be stretched by their hotspots.

Select the Object to display its hotspots.

You can either use the Stretch command (Edit > Reshape > Stretch) or the pet palette’s Move Node icon to 

stretch/shrink the Object by a node.

Note that you stretch the A and B parameters of the symbol, not its bounding box. Using parametric 2D 

scripts, you can easily create objects whose symbol size will not match the A and B parameters. If you make 

such a symbol, make sure that you define hotspots at the corner of an A*B sized rectangle. These will enable 

you to stretch that symbol.

See also Graphical Editing Using Editable Hotspots.

Stretch Door/Window to Reference Point

When stretching Doors & Windows, you can use reference points outside the host wall. The endpoint of the 

stretch vector will be projected perpendicularly or orthogonally (depending on what you have set for in the 

Control Box) to define the new opening edge.

See Projection of Cursor with Mouse Constraints.

This allows you to position a Door or Window with respect to an element within a room, or in another room, as 

shown below.
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Parameter Transfer Between Objects

After you have adjusted an object’s parameters, Parameter Transfer offers a way to transfer your edits to a 

different object of the same subtype (e.g. transfer parameters between two window objects).

See also Parameter Transfer for other ways to use this feature.

To transfer parameters between objects of the same type, do the following:

1. In the object’s Settings dialog box, make parameter modifications as needed, then place the object.

In our example, we modify the Triple Sash window by adding shutters, then place the window.

2. Use the Parameter Transfer shortcut (Alt+click) to pick up the parameters of the placed object (here, the 

Triple Sash window).

3. Open the Settings dialog box.

4. Move your cursor to the next object you wish to place (here, the Double Sash window) - and press Ctrl+Alt 

(Mac: Cmd+Opt). The cursor will change to a syringe shape.
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5. Now click on the object to transfer the parameters. Parameters of your originally modified object (Triple 

Sash window) will be transferred to the newly activated object (the Double Sash window).

6. Place the object using the changed parameters.

In our example, the Double-Sash window has inherited the parameters of the Triple-Sash window, 

including the shutters.

These modifications to the object are in effect only until you close the dialog box and place the object; the 

object’s default settings will not change.
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Graphical Editing Using Editable Hotspots

Depending on their programming, GDL Objects can have smart editable hotspots (selection dots). You can 

recognize an editable GDL hotspot by its diamond shape. If you select such an object, click an editable 

hotspot and choose the stretch or Move Node icon in the pet palette (whichever is appropriate). Clicking an 

editable GDL hotspot produces the Tracker displaying the editable parameter. Click Tab to enter a value for 

the GDL parameter.

The color of editable GDL hotspots can be set in Options > Work Environment > Selection and Element 

information.

The diamond-shaped hotspot serves to alert you that in addition to graphical editing, direct numerical editing 

through the Tracker (for example, setting a window’s sash-opening width by typing it in) is also available 

through that hotspot (provided that the applicable pet palette option has been selected). In the image below, 

the Tracker pops up showing the “Sash Opening Width” parameter if the Stretch icon is chosen from the pet 

palette.
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The diamond-shaped hotspot and associated editing palette is also available in the 3D window. In the image 

below, you must choose Move Node from the pet palette to activate the Sash Opening Width parameter.

Note: The diamond-shaped hotspot appears only for editing options that produce a specific parameter 

editing possibility in the Tracker. No other type of function is necessarily associated with this type of 

hotspot.
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Create Patch Object

With the Document > Annotation > Create Patch command, you can save the area enclosed by the 2D 

Marquee as a parametric 2D Library element. You can later use this to “sticker” your plans in order to provide 

the necessary detail in Floor Plan and Section views while saving time on modeling.

To create a Patch:

1. Define a marquee area in the Floor Plan window.

2. Use Document > Annotation > Create Patch. 

3. In the appearing dialog box, specify the location and name of the created element. 

Note: The Place Patch Now option is checked by default; the new patch object is placed automatically.

Note: Objects created this way will be enhanced with parametric behavior, specified by a special template 

in the ARCHICAD Library. If this template is missing from the loaded libraries you will still be able to save 

patches, but they will be plain stickers with no special intelligence. If ARCHICAD fails to locate the Patch 

Template, it will notify you, and you will have the option to either proceed or cancel the operation.
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About GDL Object Subtypes

All GDL Objects have a subtype, organized in a tree hierarchy that generally corresponds to the IFC (Industry 

Foundation Classes) entity structure.

Note: IFC stands for Industry Foundation Classes. To read more about IFC, see Working with IFC, or 

download the GRAPHISOFT IFC Reference Guide from 

http://www.graphisoft.com/support/ifc/downloads/

Subtypes allow you to organize your library parts into a logical system. Add-Ons also use subtypes to identify 

their corresponding library parts.

Locate Element by Subtype

In the Object Settings dialog box, select Subtype View to browse by object subtype.

Changing an Object’s Subtype

To change the subtype of a placed object, select it, open it (File > Libraries and Objects > Open Object) and 

click the Select Subtype button at the top of the dialog box.

Changing the Object’s subtype modifies its behavior and adds the parameters and functionality needed for the 

new subtype.

More about Subtypes 

ARCHICAD subtypes are controlled by subtype object templates. When you create a new GDL Object, 

ARCHICAD will allow you to choose one of the available subtypes for your element.

Each subtype has a set of compulsory parameters that define the behavior or functionality of the elements 

that belong to it. When you use the Parameter Transfer between objects, this will only work between two 

objects of the same subtype.

See Parameter Transfer Between Objects.

Some of the subtypes include additional features called handlers. These define whether the elements that 

belong to the subtype can be accessed as general objects by clicking the Object tool’s icon and choosing 

them in the Object Settings dialog box, or as specific objects that either have their own tool icon in the Toolbox 

(for example Door, Window, Corner Window, Skylight, Label) or are placed by special commands or functions 

(for example Zone stamps and RoofMaker objects).
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Related topics:

Subtype Hierarchy Dialog Box (GDL Master Window)

Settings of Library Part Elements

Search for Library Part
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Create Custom Library Parts and Components

If you cannot find the library part you need, you can create your own GDL object. You need not do any 

programming; a few techniques using familiar ARCHICAD tools lets you draw and save a customized object 

easily, using regular construction elements as custom building blocks (regardless of their originally intended 

purpose).

Custom components are sub-parts of library parts, such as doorknobs. These, too, you can create graphically 

and save for use with existing library parts.

Tracery of a Gothic window modeled with slabs and roofs

What’s Covered

Save 2D Symbols as Objects

Save 2D Elements as Label

Save 3D Elements as Objects

Save Rectangular Doors and Windows from 3D Model Elements

Save Custom-Shape Doors or Windows

Create Custom Components for Doors, Windows, Curtain Wall, Stair, Railing

Create Custom Components: Example Workflows
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Save 2D Symbols as Objects

If you find that you need to place a 2D pattern many times in a project, you may wish to create a 2D symbol, 

then save it as an object.

1. Draw the desired 2D symbol in the project using 2D tools (line, text, fill etc.).

2. Put hotspots on each point where you want the cursor to find the object.

3. Select the desired drawing elements.

4. Use File > Libraries and Objects > Save Selection as, and choose Object.

5. In the Save Object dialog which appears, enter a name and choose the desired folder location for the 

object:

– to the Embedded Library (default choice. It is recommended to save customized, project-specific 

objects to your Embedded Library.)

– browse for a linked library

– to a BIMcloud library that has been added to the project

Note: In Teamwork, you must reserve the BIMcloud Library folder before saving to it.

Optionally, click New Folder to create a new folder within the selected library folder.

6. Place the object with the Object tool. Note that the created object is stretchable, but will be distorted after 

stretching since it was not scripted using parametrics.

For information on editing the resulting GDL library part, see Editing Custom Library Parts and Components.
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Save 2D Elements as Label

Use this function to create your own symbol Label, consisting of any combination of symbols or custom text, 

including Autotext.

1. Use the Text tool to place a Text box.

2. Insert the desired text.

Use Autotext as needed to display element-specific information (e.g. #NumberofWindows).

3. If the Label should have a frame, use a 2D tool (e.g. Line tool) to create a frame of any shape around the 

text.

Hints: 

– If the label contains Autotext, consider the estimated size of the resulting Autotext value (e.g. number 

of digits or length of expected text), and draw the frame accordingly.

– It may be a good idea to make the centerpoint of the text block and the frame element coincide, and to 

use a center anchor point for the text block.

4. Select all the 2D elements.
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5. Use File > Libraries and Objects > Save Selection as, and choose Label.

6. In the Save Label dialog which appears, enter a name and choose the desired folder location for the 

object:

– Embedded Library (default choice. It is recommended to save customized, project-specific objects to 

your Embedded Library.)

– A BIMcloud library that has been added to the project

Note: In Teamwork, you must reserve the BIMcloud Library folder before saving to it.

– A linked library

Optionally, click New Folder to create a new folder within the selected library folder.

7. The Change Label’s Basic Settings dialog box appears. Here, you can define the new Label’s Fills and 

Pens. Even after placing the Label, you can further fine-tune these attributes in Label Settings.

To add information to the new Label (for example, keywords to make it easy to search for), click Change 

Details at bottom left.

8. Click OK to close the dialog box.
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9. Place the new Label. If associated to an element, its Autotext information is shown as applicable.

Example: Fixed Glass Symbol Label

In this example, the custom label consists of a simple line drawing to indicate fixed glass. This label has no 

frame. 

It is applied to all the fixed-glass panels of a Curtain Wall (using Documentation > Annotation > Label 

Components of Selected Elements).

See also Labeling Curtain Walls.
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Save 3D Elements as Objects

1. Create the desired 3D elements within the project using ARCHICAD construction tools (slab, wall, mesh, 

roof etc.).

For example, you can create a table whose tabletop is made from a slab and legs are made with the column 

tool.

2. Select the desired elements either on the Floor Plan or in the 3D window.

Note: In the 3D window, unless you set up a special 3D projection (e.g. axonometry side view), the object 

will always be saved using its top view.

To use a special projection, see Setting an Object’s 3D Projection.

Note: If you do not want to show all the lines of the model in the 2D symbol, use the hidden line or the 

shading representation from View > 3D View Options.
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3. Select, then save the object with the File > Libraries and Objects > Save Selection as command, and 

choose Object.

When saving an object from the 3D window, you are reminded that its top view will be used as the floor 

plan view when you place it, unless you set up a special 3D projection (e.g. axonometry side view).

To use a special projection, see Setting an Object’s 3D Projection.

4. In the Save Object dialog which appears, enter a name and choose the desired folder location for the 

object:

– to the Embedded Library (default choice. It is recommended to save customized, project-specific 

objects to your Embedded Library.)

– browse for a linked library

– to a BIMcloud library that has been added to the project

Note: In Teamwork, you must reserve the BIMcloud Library folder before saving to it.

Optionally, click New Folder to create a new folder within the selected library folder.
ARCHICAD 24 Reference Guide 1398



Parametric Objects Elements of the Virtual Building
5. Click Save.

6. The Change Object’s Basic Settings dialog box appears. Here, you can define the new library part’s 

default Surfaces, Fills and Pens. Even after placing the library part, you can further fine-tune these 

attributes in Object Settings.

Also, to add information to your new library part (for example, keywords to make it easy to search for in 

Object Settings or BIM Components), click Change Details at bottom left.

7. Click OK.

8. Place the object with the Object tool. Note that the created object is stretchable, but will be distorted after 

stretching since it was not scripted parametrically.

For information on editing the resulting GDL library part, see Editing Custom Library Parts and Components.

Watch the Video
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Setting an Object’s 3D Projection

In the View > 3D View Options > 3D Projection Settings dialog box (Parallel projection), set the desired 

projection. ARCHICAD will automatically rotate the library part according to this setting.

For example, if your model is lying on its side (see the chair object below) set the following: side view, 

azimuth=90°.
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Save Rectangular Doors and Windows from 3D Model Elements

1. Create the desired 3D model of the door or window in the project using ARCHICAD construction tools 

(slab, wall, mesh, roof etc.). It is recommended to draw the element on the XY plane at zero level.

2. Select the elements in the 3D window. You can use any 3D projection settings.

To use a special projection, see Setting an Object’s 3D Projection.

3. In the 3D window, save the selected elements with the File > Libraries and Objects > Save Selection as 

command, and choose Window or Door.

4. You are prompted to specify which plane of the model represents the host wall plane (elevation plane), 

into which the new Door/Window will be rotated: either the current editing plane or the horizontal plane. 

(This is significant if, for example, you are saving an edited Morph element which was originally a door, 

and which is therefore not lying in the horizontal plane of your model.)
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5. In the Save Door (or Save Window) dialog which appears, enter a name and choose the desired folder 

location for the new opening:

– to the Embedded Library (default choice. It is recommended to save customized, project-specific 

objects to your Embedded Library.)

– to a BIMcloud library that has been added to the project

Note: You must reserve the BIMcloud Library folder before saving to it

– browse for a linked library

Click New Folder to create a new folder within the selected library folder.

6. Click Save.

7. The Change Object’s Basic Settings dialog box appears. Here, you can define the new library part’s 

default Surfaces, Fills and Pens. Even after placing the library part, you can further fine-tune these 

attributes in Object Settings.

Also, to add information to your new library part (for example, keywords to make it easy to search for in 

Object Settings or BIM Components), click Change Details at bottom left.

8. Click OK.

9. Place it with the Window (or Door) tool. Note that the created object is stretchable, but will be distorted 

after stretching since it was not scripted parametrically.

For information on editing the resulting GDL library part, see Editing Custom Library Parts and Components.
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Save Custom-Shape Doors or Windows

Use this method to create a door or window having a custom shape.

For rectangular shapes, see Save Rectangular Doors and Windows from 3D Model Elements.

In this process, you must create

1. a custom shape that will serve as the door/window itself, and

2. another shape that will be serve as the hole or niche into which the custom door/window will be placed.

The shape of the hole is defined by a freely drawn slab or a roof, which is then assigned an ID of Wallhole or 

Wallniche. Slabs and roofs bearing these IDs will be displayed as a hole or a niche in the wall. (Wallhole and 

Wallniche are GDL commands used to create holes or niches in walls.)

To save a custom-shape door or window, do the following:

1. Create the 3D model of your custom shape window or door on the floor plan as described at the previous 

section.

See Save Rectangular Doors and Windows from 3D Model Elements.

2. Using the Slab or Roof tool, create another element whose contour matches the outer contour of the 

desired wall hole or wall niche.

3. Select this Slab or Roof and open its settings dialog.

4. Go to the Classification and Properties panel and change the ID field to Wallhole if you want to make a 

hole and Wallniche if you want to make a niche in the wall.

Note: The Wallhole-type element - regardless of its thickness - will always cut through the wall into which 

it is placed. The Wallniche-type element, however, will cut into the Wall to an extent that depends on its 

thickness, as set in Slab/Roof Settings. If you are making a Wallniche, be sure to set the element’s 

thickness to the desired value.
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5. Move the Wallhole (Wallniche) element onto your custom window elements.

6. Select all the elements that will compose your custom-shaped door/window: that is, the door/window 

element(s) plus the hole/niche element.

7. Save the selection using the File > Libraries and Objects > Save Selection as command, and choose 

Window or Door.

8. You are prompted to specify which plane of the model represents the host wall plane (elevation plane), 

into which the new Door/Window will be rotated: either the current editing plane or the horizontal plane. 

(This is significant if, for example, you are saving an edited Morph element which was originally a door, 

and which is therefore not lying in the horizontal plane of your model.)

9. In the Save Door (or Save Window) dialog which appears, enter a name and choose the desired folder 

location for the new opening:

– to the Embedded Library (default choice. It is recommended to save customized, project-specific 

objects to your Embedded Library.)

– to a BIMcloud library that has been added to the project

– browse for a linked library

Click New Folder to create a new folder within the selected library folder.
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10. Click Save.

11. The Change Object’s Basic Settings dialog box appears. Here, you can define the new library part’s 

default Surfaces, Fills and Pens. 

Note: You can further fine-tune these attributes in Object Settings after you place the library part.

Also, to add information to your new library part (for example, keywords to make it easy to search for in 

Object Settings or BIM Components), click Change Details at bottom left.

12. Click OK.

13. Place the newly created Window/Door with the Window or the Door tool. Note that the created object is 

stretchable, but will be distorted after stretching since it was not scripted parametrically.

You can combine multiple slabs or roofs to create complex holes or niches. Since you can define inclination 

angle for the roofs, you can even cut non-perpendicular holes in walls.

For information on editing the resulting GDL library part, see Editing Custom Library Parts and Components.
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Create Custom Components for Doors, Windows, Curtain Wall, Stair, Railing

Doors, Windows, and the hierarchical design elements (Curtain Wall, Stair, Railing) are GDL objects with 

many parameter choices. For example, doors in the ARCHICAD library offer you a variety of choices for door 

panels and doorknobs:

However, your design may need a different kind of door component - one which is not available in your library. 

In this case, you can draw a model element and save it as a library part, defining it as a custom component 

(e.g. door handle) that can then be used with your placed doors.
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The possible custom components are listed under File > Libraries and Objects > Save Selection as:

For example, you can save a slab as a custom door leaf. The resulting GDL object is saved as a Door Leaf in 

the project’s Embedded Library. All Doors that use Door Leafs will be able to use this custom Door Leaf.

• When applying the custom component, ARCHICAD will automatically resize it, if necessary. For example, 

you may create a Door Leaf-type Custom Component that is 1000 by 2000 mm in size. If you have a Door 

that is 800 by 2000 mm in size, with its Trim Width 50 mm on all sides, the Door Leaf will be resized to 700 

by 1950 mm. The program will stretch/shrink all parts of the Door Leaf Custom Component 

proportionately to fit this size.

• The automatic resize is NOT applicable to Custom Components saved as Stair and Railing sub-

components. For Stair and Railing components, you must create the component in the precise size that 

you wish to use it in the project.

See Create Custom Components: Example Workflows

Watch the Video
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Create Custom Components: Example Workflows

The following sections walk you through some common custom component creation workflows.

Example: Create Custom Door Leaf

Example: Create Custom Frame or Cap Profile for Curtain Walls

Custom Sub-Elements for Stairs and Railings
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Example: Create Custom Door Leaf

Suppose you wish to create a custom leaf for a door. Follow these steps:

1. Using ARCHICAD Construction Elements (such as Slabs), draw the desired door leaf on the Floor Plan or 

in the 3D window.

2. In case of Door/Window custom panels, what you draw in the X-Y plane of the Floor Plan Window will be 

‘stood upright’ in the Window/Door library part (rotated 90 degrees around the X axis – as described in the 

GDL Reference Guide). For other custom component types, this condition does not apply.

The centerpoint of the resulting object is the center of the drawn elements’ bounding box.

Note: You should set the attributes (Pen, Surface etc.) values of the drawn elements to the desired values 

prior to saving it. These values will be applied to the custom component when it is actually used later in 

the Project.
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3. Select the drawn element(s) and choose the File > Libraries and Objects > Save Selection as > Door 

Leaf.

(If you have no elements selected, the command is gray.)

4. The Save Door Leaf Dialog comes up.

5. Specify a name for the new library part, and choose the desired folder location in which to save it:

– to the Embedded Library (default choice. It is recommended to save customized, project-specific 

objects to your Embedded Library.)

– to a BIMcloud library that has been added to the project

Note: You must reserve the BIMcloud Library folder before saving to it
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– browse for a linked library

Click New Folder to create a new folder within the selected library folder.

6. In the Door Settings Dialog, set the Door Leaf style to Custom Leaf.

7. From the Custom Panel Name pop-up, choose the custom leaf you wish to use (if there is only one 

custom component defined, the parameter will be automatically set to that value). Then press OK to 

accept changes.

The custom Door leaf is applied to your Door.

For information on editing the resulting GDL library part, see Editing Custom Library Parts and Components.
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Example: Create Custom Frame or Cap Profile for Curtain Walls

Suppose you wish to customize the profile of your Curtain Wall Frame, or to add a custom Cap. Follow these 

steps:

1. Using ARCHICAD construction elements, draw the custom Curtain Wall frame on the Floor Plan or in the 

3D window.

2. Select the drawn element(s) and choose the File > Libraries and Objects > Save Selection as > 

Curtain Wall Frame.

3. The Save Curtain Wall Frame dialog box comes up.

4. Specify a name for the new library part, and choose the desired folder location in which to save it:

– to the Embedded Library (default choice. It is recommended to save customized, project-specific 

objects to your Embedded Library.)
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– to a BIMcloud library that has been added to the project

Note: You must reserve the BIMcloud Library folder before saving to it

– browse for a linked library

Click New Folder to create a new folder within the selected library folder.

5. Select the Curtain Wall whose Frame you wish to customize.

6. In Curtain Wall Selection Settings (either “Mullion” or “Transom”), choose Modular Frame.

7. In the Curtain Wall Frame Settings panel, select “Custom Frame” and/or “Custom Cap” from the Type pop-

ups.

Your saved custom library parts are listed in the pop-ups below.

Click OK to replace the selected Frames with the custom component(s).
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Editing Custom Library Parts and Components

There are two ways to edit a GDL object saved from ARCHICAD elements: either edit the script, or edit the 

original elements:

Edit the Script

See Open and Edit Library Part.

Edit the Original Elements

Edit the original ARCHICAD elements from which you have saved the GDL library part, then re-save the 

library part (overwriting its previous version.)

To keep the original ARCHICAD elements, you can do one of the following.

• place them on a separate layer, then hide that layer

• save them in a separate PLN file

• save and export them as a module (.mod file) 

See Save Selected Elements as Module.
ARCHICAD 24 Reference Guide 1414



Parametric Objects Elements of the Virtual Building
Open and Edit Library Part

1. Go to File > Libraries and Objects > Open Object.

2. In the Open Library Part dialog box, select the library part. (In Teamwork, you must reserve the library 

part.)

3. If it is an editable GDL Object: Click to Open the GDL Object Editor. (Reserve the editing window, if it is 

not reserved already), and make the necessary edits.

See GDL Object Editor.

4. If it is a non-editable GDL Object (e.g. located in a linked library): Click View to see its settings in GDL 

Object Editor. You cannot modify the object settings here. Use Library Manager to extract the library part 

to a local folder, then edit it and reload it to the project. 

5. If it is another type of editable library part: Click the dropdown to choose the application in which to open 

and edit the selected library part.

Watch the Video
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6. Close the window and save the modifications.

Teamwork users will update their projects with the modified BIMcloud library data as soon as they do a Send 

& Receive.

Solo users will update their projects with the modified BIMcloud library data as soon as they do a Reload & 

Apply from Library Manager.

Access Library Part in BIMcloud Library

You can access a library part in a BIMcloud Library only if:

• You have reserved the object

• Your access rights include “Library Part – Delete/Modify”

• The library part is located in a regular folder, and is not a PLA or LCF file

Note: In Library Manager, the contents of PLA and LCF files are shown expanded into a tree view. To 

access the contents (a library part), select the item, choose Duplicate or Export, and provide a folder 

location. The folder is then opened, with the content available for editing.

Otherwise, the Object Editor window of such an object is Read-Only.

Edit a Placed GDL Object

To edit the parameter script of a GDL object already placed in your plan, select it, then use File > Libraries 

and Objects > Open Object

Use the appearing GDL Object Master Window to modify existing objects in a single environment. In this 

window, you can add or edit the Parameters, Components, Descriptors, Scripts and the 2D Symbol of the 

GDL Object.

For details, see GDL Object Editor.
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Scripting Custom Objects

The easiest way to create custom objects is graphically, using ARCHICAD tools: 

See the topics at Create Custom Library Parts and Components.

However, another option is to create custom objects using GDL programming language and ARCHICAD’s 

scripting environment. This may be your option if you want to go beyond all of the above possibilities, or if you 

need Library Parts for which the shape can be controlled with user-definable parameters.

See the GDL Center, GRAPHISOFT’s GDL knowledge base, at gdl.graphisoft.com.

When editing object parameters, you may wish to activate the Edit GDL Library Parts toolbar (Window > 

Toolbars > Edit GDL Library Parts) for quick access to frequently used commands. You can add it to your 

ARCHICAD menu structure using the Work Environment dialog box.

The creation of new Objects and the modification of existing ones is handled in a single environment: the GDL 

Master Window. In this window, you can add or edit the Parameters, Components, Descriptors, Scripts 

and the 2D Symbol of the GDL Object.

For more details, see GDL Object Editor.

Each GDL Object can include a scale-sensitive symbol representing it in floor plan view, a set of parameters 

defining the possible variations of the product family and a 3D script describing the complex geometry of the 

element. The 3D view of the GDL Object is generated from the 3D script that takes into account the parameter 

choices made by the user.

Scripting in GDL is not limited to geometry; you can create elements with many useful attributes, including 

cost, availability, and texture.

For information on how ARCHICAD projects handle custom attributes of imported GDL objects, see Custom 

Attributes of GDL Objects.

Some GDL Objects do not contain any geometric data. For example, macros can be text-only files that other 

Objects can refer to, without needing to include the same script in all of these Object files, while Property 

Objects contain descriptive data only that is used to calculate element quantities.

For information on Property Objects, see the ARCHICAD Calculation Guide.

To modify an object already placed in your plan, select it, then choose File > Libraries and Objects > Open 

Object. The GDL Object Master Window appears.

For Further Information

See Further Resources on GDL Object Creation.
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Further Resources on GDL Object Creation

Books and documentation are available on GDL and object library development.

• See the GDL Center, GRAPHISOFT’s GDL knowledge base, at gdl.graphisoft.com.

• The GDL Reference Guide will help you learn to apply ARCHICAD’s powerful Geometric Description 

Language for dressing up your Project with objects, ornaments and other details of your own design. It 

includes a section on Basic Technical Standards.

See its PDF version in the ARCHICAD > Documentation folder or in the ARCHICAD Help > 

Documentation menu. 

• GRAPHISOFT has created an Interactive Training Guide on “Building Objects Creation,” available at 

http://www.graphisoft.com/learning/training_materials/. 

• David Nicholson Cole’s GDL Cookbook, aimed at both entry-level and advanced GDL programmers, is 

available free at http://www.nottingham.ac.uk/~lazwww/cookbook/.

• See the GDL Handbook by Andrew Watson for novice and experienced users.

• GDL Advanced Technical Standards contains GRAPHISOFT’s official standards for professional library 

developers; this information is part of ARCHICAD’s Basic Library documentation, and can be 

downloaded free of charge from GRAPHISOFT’s website at:

http://www.graphisoft.com/support/developer/downloads/
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Dedicated Object Tools: Doors, Windows, Skylights, Wall Ends

The following object-type tools in ARCHICAD are analogous to the general Object tool, but have a number of 

specific parameters and behaviors.

Doors/Windows

Openings

Corner Windows

Skylights

Wall Ends

Related Topics:

Openings

Ramp Object

Save Custom-Shape Doors or Windows

Create Custom Components for Doors, Windows, Curtain Wall, Stair, Railing
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Doors/Windows

The handling and behavior of Windows and Doors are quite similar, therefore they will be described together.

In ARCHICAD, Doors and Windows simulate the look and behavior of real-life Windows and Doors. They are 

always placed into walls.

Doors and Windows cut real, see-through openings into the wall, so that 3D visualizations are more accurate 

and lifelike. The glass surface lets light in and you can look through the Windows and glass Doors in 

PhotoRendered views. In elevations, glass panes are represented as solid shapes.

The geometry of the Window or the Door is defined by the information included in the Library Part. While 

some generic elements allow a large amount of freedom in modifying the size and shape of the Window or 

Door before or after placing it in the project, more specific designs corresponding to real-life manufacturer 

catalog items can only be placed as defined, with restricted variation possibilities.

To choose a door or window, open Door or Window Settings, where you can choose Doors and Windows from 

the loaded libraries. Use the Settings dialog to adjust the parameters as needed.

For information on setting parameters of Doors and Windows, see Door/Window Tool Settings.

ARCHICAD has separate tools for Corner Windows and Skylights. See these sections:

Corner Windows

Skylights

What’s Covered

Placing Doors or Windows

Floor Plan Display of Doors/Windows

Setting the Window/Door Plane in Slanted or Complex Walls

Sill or Header Heights

Sill Height Using Subfloor Thickness

Anchor Reveal

Creating an Empty Opening

Moving Wall Openings
ARCHICAD 24 Reference Guide 1420



Dedicated Object Tools: Doors, Windows, Skylights, Wall Ends Elements of the Virtual Building
Doors/Windows in Curved Wall

Door/Window Tool Settings
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Placing Doors or Windows

Windows and Doors can only be inserted into Walls; they cannot be placed independently in the project.

Follow these steps:

1. In the Floor Plan or 3D Window, activate the Window or Door Tool, and choose the desired Window/Door 

object from the library.

2. As you move the cursor over the target Wall, you will see a preview of the opening at its current location.

Note: If you hover the cursor in a place where several Walls intersect, click Tab to toggle among them until 

the one you want is highlighted.

3. The sun icon and thick line represent the “outside” (reveal side) of the Wall

To switch the reveal side, just move the cursor to the opposite side of the Wall.
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4. Click to place the opening at the desired place.

The Anchor Point determines whether you will place the Window or Door by its centerpoint or either side.

As you place the opening into a Wall, you can switch Geometry Methods on the fly (use the Anchor Point 

control in the Info Box, or its shortcut.)

5. Next, you will choose the opening direction: toward the inside or outside of the wall, either on the right or 

the left: each possibility is shown by an arrow on screen.

– Move the cursor around to any of these four positions; the feedback shows you what you will get when 

you click.

– The sun icon represents the reveal side that you chose with the first click. You can still change the 

reveal side now: press Tab to toggle the two reveal sides for this opening.

6. Click to place the opening.

Flip Opening Direction

The Flip button (in the Info Box or Door/Window Settings) switches the opening direction of a selected door/

window from one side to the other, while keeping the frame in place.
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In Section/Elevation/IE Windows:

You can create new construction elements only by duplicating existing ones, using the Multiply or Drag a 

Copy functions.
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Previews in Door/Window Settings

The Preview picture in Door/Window Settings uses some Wall settings to provide useful context.

For example:

• For an Empty Opening, the 3D Preview picture also indicates the thickness and surfaces of the 

surrounding Wall, to provide some context. (In default Door/Window Settings, the default Wall parameters 

are used for the Preview.)

• When showing Casing, Frame and/or Sill in the 2D/3D Previews, the thickness of the Wall setting is used.
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Floor Plan Display of Doors/Windows

Floor Plan Display: Symbolic vs. Projected

Use the Floor Plan Display control in Door/Window Settings to define how to display the opening:

• Symbolic (default setting): This is the object’s standard symbol.

• Overhead All: the entire element’s outline is shown with its overhead attributes.

Note: Define Overhead attributes (line type, pen) in the Floor Plan and Section panel of Door/Window 

Settings.

In case of a slanted wall, however, you might prefer a more realistic display of the cut window: choose either 

Projected or Projected with Overhead to see all parts of the window in a slanted wall.

• Projected: shows cut part of element’s 3D model, plus its uncut (downward) part.

• Projected with Overhead: shows cut part of element’s 3D model, plus the element’s overhead part (i.e. 

the part of the element that is above the Floor Plan Cut Plane, plus its uncut (downward) part.

Attributes of Doors/Windows

There are two ways to define the attributes (line type, pen, fill) of Doors/Windows on the Floor Plan:

1. Use the GDL attributes (line type, pen, fill) defined in Door/Window Settings (Parameters panel or the 

Custom Settings panel of the Graphical Interface). This method gives you a great many line/fill 

parameters, giving you greater control over the precise and detailed display of the opening and each of its 

components separately.

2. Use the 2D attributes set for the opening on the Floor Plan and Section panel of Door/Window Settings. 

This method involves a reduced number of parameters for simplicity.

For details, see Override GDL Object Attributes of Doors/Windows.

Model View Options for Doors and Windows

The Door Options and Window Options settings in the Construction Elements panel of Model View Options 

(Document > Model View > Model View Options) allow you to show Doors and Windows on the Floor Plan 

in full, with contours only, or as empty openings, or to show or hide their dimensions or markers.

See Model View Options for Construction Elements.

To define the display of Door/Window handles and opening lines, use the Options for GDL Objects panel of 

Model View Options.

See Miscellaneous Settings for Library Parts.
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Setting the Window/Door Plane in Slanted or Complex Walls

Windows and Doors can be placed in any type of wall, including polygonal, slanted and complex shapes.

If your project contains slanted walls, use the Door/Window Opening Plane icons (Door/Window Preview and 

Positioning Panel) to make the plane of your openings either associated to the wall plane or remain vertical.

• Associated to Wall: the slant of the Window/Wall will be associated to the Wall into which they are 

placed. In slanted Walls, the Window/Door slants at the same angle as the Wall. In Double Slanted Walls, 

the Window/Door slants at the same angle as the side of the Wall into which the Window/Door was 

placed. Thus, if you move the Window/Door to the other side of the Wall, its slope will change accordingly.
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• Vertical: the Window/Door will be vertical regardless of the type of Wall it is placed into.

In Complex Profile Walls, the slant of the Window/Door is determined in the Profile Manager: use the 

Opening Reference Layer in the Design Layers panel to define the slant of Windows/Doors set into the 

Complex Wall.

For more information, see Complex Profiles.
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Sill or Header Heights

Use the Preview and Positioning Panel of Door/Window Settings, or the Info Box, to set the height and width 

of a door/window.

Every time you change a window/door height, the change will affect either the sill or the header Depending on 

how you choose to anchor the opening, sill or header height can be measured from the wall base, the wall top, 

or a given story height.

In the Preview and Positioning panel, the pop-up lets you choose any one of these as a point of reference 

for the sill/header value.

• Sill to Wall Base

• Sill to Wall Top

• Sill to (current) Story: the height of the Sill will be measured relative to the level of the Current Story (the 

last story open on the Floor Plan). To choose a different Story, click the Select Story option and choose a 

story from the dialog box.

• Header to Wall Base

• Header to Wall Top

• Header to Story: same method as the Sill to Current Story options, but you must provide the Header 

height. To choose a different Story, click the Relink Anchor Story option and choose a story from the 

dialog box

• Relink Anchor Story: If you choose this option (select the Story name from the list in the appearing 

dialog box), the chosen story’s height will serve as the Anchor from which the Window/Door should be 

measured. This option may be used, for example, when a Glass Curtain Wall is created and all individual 

panes must have their heights set to a common height.
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Sill Height Using Subfloor Thickness

Use the Subfloor Thickness field, in the Dimension Marker Panel of Door/Window Settings (or the Info Box), to 

fine-tune the marker display of your sill height value if your floor level takes into account carpeting or parquet 

flooring, and if your wall base is not at this floor level.

ARCHICAD measures the height of a door/window sill from the wall base (or a given Story level, as set in the 

Preview and Positioning Panel.) But if you want the marker display of this value to reflect the real floor level, 

enter this additional thickness in the Subfloor Thickness field.

ARCHICAD will still measure the sill value from the wall base, but the door/window marker will show a sill 

height value that subtracts the subfloor thickness from the entered sill value.

For example, say the Wall Base is at -100 mm below the floor level (Subfloor Thickness is 100 mm). The 

window sill (parapet) height is 1000 mm, but your effective Sill Height, for the purposes of construction 

documentation, is really 900 mm from the floor. So the window’s sill height, as displayed in the Floor Plan 

marker, will show 900 mm.

Note: Entering a value into the Subfloor Thickness field does not affect the actual positioning of the door/

window within the wall; it is merely an alternate way to display sill/header height in the door/window 

marker.
ARCHICAD 24 Reference Guide 1430



Dedicated Object Tools: Doors, Windows, Skylights, Wall Ends Elements of the Virtual Building
Note: Sill height markers use dimension units set specifically for this type of value: go to Options > 

Project Preferences > Dimensions, and choose Sill Height Dimension.

Some markers have a checkbox to display the Nominal Sill Height (e.g., the displayed Sill value does not 

take subfloor thickness into account). The illustration below shows the effects of unchecking and checking this 

box.
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Anchor Reveal

Anchor the Door/Window reveal to either the Wall face or the Wall core (the closest core skin, if there are 

several core skins). This is relevant if you are using a composite Wall which has a core.

You may wish to anchor openings to the Wall core if

• you later make changes in the Wall’s composite structure (e.g. thicker insulation). The reveal depth will 

automatically adjust to maintain the window’s distance relative to the Wall’s core skin.

• you place openings into several similar composite Walls (that only differ in the finishes, e.g. a brick finish 

and a plastered wall). The openings will be aligned; you don’t have to adjust Reveal depths in order to 

keep them aligned.
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Note: If you place an opening whose reveal is anchored to the wall core, then change the composite Wall 

so that it no longer has a core, then the reveal anchor will change to “Wall Face,” and the reveal depth will 

be automatically recalculated to retain the opening in its original location.
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Creating an Empty Opening

To create a simple opening without placing a library part type Door or Window, click the Empty Opening button 

at the bottom of the Library Part Settings dialog box (or from the Info Box.)

Place the opening in the wall, as you would a Window or Door. Adjust the size and other parameters of the 

selected opening in the Preview and Positioning Panel of its Settings dialog box.
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For empty openings of varying shapes, with extensive parameters, choose a window from the ARCHICAD 

library’s Empty Openings folder.
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Moving Wall Openings

Use the Drag, Rotate, Mirror and Elevate commands to move wall openings (i.e. Doors and Windows). All 

these operations are available in the Floor Plan, Section/Elevation/IE windows and the 3D Window, for 

slanted and straight Walls only.

Door/Windows do not need to be dragged by their hotspots. After selecting the Window/Door, choose the 

drag, move or multiply command, then click anywhere in the view to define the starting and ending points of 

the operation’s vector.

Windows/Doors may be dragged/moved/copied along with other Element types in one step. In the following 

image you can see that the Column is dragged. The Windows, selected together with the column, will also be 

dragged within their Wall by a distance that equals the component of the Drag vector.

• Windows/Doors may be moved across multiple Wall elements. You can drag or copy a Window from one 

Wall and end up in another Wall element.

Moving an opening across multiple elements works only if the Wall elements involved have their reference-

side wall planes all in the same plane. If there are two vertical Walls involved, their Reference Lines must be 

aligned in a single vertical plane. If they are slanted Walls, their Reference Wall sides must align in a single 

slanted plane. The thicknesses and other attributes of these Walls, however, do not need to be identical; the 

Walls involved do not even need to be connected to each other.
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Also, when you stretch a Wall with the Marquee, the Windows/Doors included in the Marquee will also be 

dragged/copied, so they retain their position relative to the end of the Wall.

Rotating a Window or Door

To rotate Doors and Windows, select the opening and click the Rotate command (from Edit menu or pet 

palette). The selected opening will rotate by 180 degrees around its center (there is no need to draw any 

vector). Any number of openings can be rotated at the same time.

Note: Rotated text blocks, labels, dimensions and fill polygon area labels are always readable from the 

bottom and the right side of the drawing.

Mirroring a Window or Door

To mirror a Door or Window, select the opening and click the Mirror command (from Edit menu or pet palette, 

or use Ctrl+M). The pencil cursor appears. Click either on an edge of the host wall or outside the wall. The 

Door/Window will be mirrored (with its opening direction flipped laterally) along the axis where you click. If you 

click outside the host Wall, the mirroring axis is the line perpendicular to the Wall at the clicked point. (With 

trapezoidal walls, the mirroring axis is perpendicular to the reference axis.)

• Mirroring can create an opening that falls entirely beyond the end of the wall. You can then select and 

move it in the same plane as the original host wall.

Stretching Doors and Windows

See Stretching Objects.
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Doors/Windows in Curved Wall

Suppose you have placed windows into a straight Wall (at the given distances from either end of the Wall), 

then later curve the Wall (as in the picture below). 

The appearing Openings’ Position dialog box allows you to choose how to handle the openings’ new 

position in the curved Wall:

Keep distance: This option will ensure that the openings’ distance from the nearest Wall end remains 

unchanged. (Openings are measured from their center point.)

Note: The Wall segment that you click to curve will be the segment that is stretched.

Keep proportion: This option will keep constant the position of the openings relative to the Wall length.
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Corner Windows

ARCHICAD has a separate Corner Window tool.

(For INT users: By default, the Corner Window tool is located in the “More” section of the Toolbox.)

The Corner Window Settings dialog box is similar to the Door and Window Settings dialog boxes. 

For more information, see Door/Window Tool Settings.

There is no separate object type associated with the tool; most of the windows in the standard ARCHICAD 

library can be placed using the Corner Window tool.

Corner Windows are placed at straight wall corners.

Please note:

• Corner Windows cannot be placed in a Profiled Wall.

• Corner Windows cannot be placed in trapezoid or curved Walls.

When you wish to place a Corner Window at a wall corner, you can click anywhere on the wall: ARCHICAD 

will automatically snap the window to the nearest corner of the wall and create a mirrored copy of it on the 

adjoining wall. The second window’s parameters and properties are identical to those of the first. Their angle 

and position are automatically adjusted.

• You can only place one pair of corner windows at any given corner.

• The angle between the two walls cannot be equal to either 0 or 180 degrees.

• The placed windows can be stretched manually and individually without breaking the link between the two 

windows.

• Corner Windows turn into simple Windows if:

• You drag away, mirror or rotate any of the two placed Windows.

• The angle between the two Walls is changed to 0 or 180 degrees.
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• One of the Walls is elevated (since Windows are part of the host Walls, the two Windows’ elevations 

become different).

• One of the connecting Walls is deleted or dragged away.

For more information, see Door/Window Tool Settings.
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Skylights

Skylights are analogous to Doors and Windows. They can be intelligently placed into Roofs and Shells, using 

the dedicated Skylight tool.

The Skylight placed on the surface of a Roof or Shell will be automatically inserted into the parent element. 

When placed into a Roof, it is adjusted to the correct Roof pitch angle.

The panels of Skylight Settings are similar to those of the Window/Door, Object and Lamp tools.

See Skylight Tool Settings.

Skylight Display on Floor Plan

• The Floor Plan display of Skylights placed in ARCHICAD 15 and later is based on a 3D projection, not a 

symbolic depiction.

Exception: Skylights migrated together with older-version projects to ARCHICAD 15 and later will be 

displayed, by default, using “symbolic” attributes for their Floor Plan display.

• Skylights are displayed using the Floor Plan Display settings (e.g. Show on Story) of the host Roof or 

Shell.

• Pens and lines are set for each Skylight, as for Doors/Windows, in the Floor Plan and Section panel of 

Skylight Settings.
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• Model View Options (Construction Element Options) include options for Skylights, analogous to those of 

Doors/Windows.

What’s Covered

Placing and Moving a Skylight

Skylight Constraint Relative to Roof

Skylight Tool Settings
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Placing and Moving a Skylight

Skylights can be inserted into Roofs or Shells in the Floor Plan or in 3D view.

Select the Skylight tool and click to place it on either a Roof or a Shell. It will be placed by its anchor point as 

defined in the Skylight Info Box.

When you drag (or drag a copy of) a Skylight within a Shell, or from one Roof plane to another, the Skylight 

will automatically adjust itself to the new location.

Position Skylight to Curved Roof Plane

When you place or move a Skylight within a curved Roof segment (having a curved pivot line), ARCHICAD 

can adjust the Skylight placement using one of two logical approaches:

• Assume that the Roof plane you modeled really represents a curved Roof plane

• Assume that the Roof plane you modeled really represents one of several adjacent flat segments

Depending on the assumption, the Skylight may be placed in a slightly different way.
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The option, in Roof Settings (or the Info Box), is Skylights treat segments as curves. By default, it is 

checked. This means that ARCHICAD assumes that a Roof plane with a curved pivot line represents a curved 

Roof plane.

• When you place or move a Skylight in a curved segment of a Roof, the Skylight geometry will be adjusted 

to reflect a curved surface.

• If you uncheck this option, the Skylight position will reflect that of a Skylight on a flat plane.
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In many cases, this option is not relevant. If your curved Roof segment consists of just a few large flat Roof 

planes, or else many small planes, the Skylight placement will be as expected.
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Skylight Constraint Relative to Roof

This feature is applicable to Skylights in Roofs only (not to Skylights in Shells).

If you change the geometry of a Roof that contains Skylight, the Skylight will adjust itself to the new geometry, 

but you have to decide how to constrain the Skylight position in the modified Roof plane: 

• either Horizontally (the Skylight will retain its position as seen on the Floor Plan)

• or Vertically (the Skylight will retain its vertical elevation regardless of its Floor Plan position.)

Change this Constraint in Roof setting in Skylight Settings or the Info Box.

Use the Horizontal constraint if you want the Skylight to remain in the same place when viewed from above 

(that is, on the Floor Plan) even after the host Roof plane geometry changes. This option is useful if your 

Skylight is the kind that lets in light from the top of the building.

Use the Vertical constraint if you want the Skylight to remain at a constant elevation even after the host Roof 

plane geometry changes. This option is useful if you need a Skylight at a particular vertical position (e.g. as a 

lookout window in the attic).
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Wall Ends

The Wall End tool allows you to create a correct wall end profile with a single click.

1. Activate the Wall End Tool. 

2. From Wall End Settings or the Info Box, choose the desired Wall End object.

3. Click on a hotspot at either end of a wall to place the Wall End.

Wall Ends are parametric GDL objects, similar to window and door objects. Wall End parameters (such as 

width and height) can be customized using Wall End Settings.

See Wall End Tool Settings.

Wall Ends are counted as objects in list schedules. Depending on its type, a wall end might reduce the wall’s 

surface or volume, but does not add to it. During a Crop to Roof operation, Wall Ends are handled as part of 

the wall, just like windows.

See Crop Elements to Single-plane Roof.

Wall Ends also remain in place if a Stretch, Drag or Split command is executed.
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Ramp Object

The ARCHICAD Library includes parametric Ramp objects (Straight and Curved.)

Watch the Video

Use these to create standard Ramps displayed in the format you need.

As needed, define separate Transition segments at the top and bottom of the Ramp.

Straight Ramp

Slope

Use the Ramp Settings panel (Dimensions page) to define the slope of the Ramp.

• Enter the slope using either Gradient, Percentage, or Degree
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• Alternatively, check Define Slope By Dimensions: then enter Height and Dimension values in the fields 

below, to automatically calculate the slope.

Text

Use the Text page of Ramp Settings to optionally display one or two lines of text on the 2D Ramp, in the 

format you choose. For a slope displayed e.g. as 1:X, you can use any character or text as the separator.

Slope displayed as Gradient

Define Slope Directly Define Slope by entering Ramp Length/Height
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Slope displayed in Degrees

Transitions

On the Ramp Settings panel (Dimensions 1 and 2 pages):

• Check Ramp Transitions to create and define transitional segments at the top and bottom of the Ramp.

• For each segment, define its slope (either directly or by Dimensions). (Click the chain icon to use equal 

values for both top and bottom transition.)

• Additional dimension fields are available on the Dimensions 2 page: enter or calculate length and height 

values for each transition segment. 

Note: Straight Ramps can be stretched graphically, using the Move Node or the Stretch command of the 

pet palette. When you stretch, the middle segment is modified (not the transitions).
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Curved Ramp

For the Curved Ramp object, additional dimension values are available.

• Adjust Ramp width and two radius values (inner and outer)

• The full Ramp length is indicated

• Check Ramp Transitions to create and define transitional segments at the top and bottom of the Ramp

Ramp Total Length

Width and Angle
Inner and Outer 
Radius

Height of Transition 
Segments

Ramp Length by Segment

Height of Center Ramp 
Segment
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Openings

Use the Opening Tool to place an Opening element in a Wall, Slab, Mesh, or Beam.

An Opening is a hole that provides space for engineering items such as elevators and MEP elements. A 

limited-depth Opening can be defined, e.g. to create a Wall niche or Slab recess.

Every ARCHICAD Opening is associated to an element: Wall, Slab, Mesh or Beam. The Opening’s position is 

relative to that associated element, and moves along with it. 

A single Opening can cut multiple elements at once. For example, a suspended ceiling modeled from three 

separate elements can be cut by a single Opening.

Like any other model element, each Opening has ID, Classification, and Property data. Schedule and Label 

these values as needed.

Set the show/hide status of Openings using Model View Options (similar to Door/Window).

Related Topics

Create Opening

Opening Display on Floor Plan

Use Limited Opening to Create Niche or Recess

On-Screen View Options for Openings

Edit Opening

Manage Opening Connections

Edit Openings in Teamwork

Import/Save Openings with IFC

Create Openings from Selection

Watch the Video
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Create Opening

Watch the Video

1. Activate the Opening tool.

2. In Opening Settings or the Info Box, define the Opening’s basic geometry, shape and anchor point, as 

needed. (Settings are described in detail below.)

3. Hover over the associated element (e.g. Wall) into which to place the opening. The pre-placement 

highlight indicates the geometry of the Opening and its associated element.

If the cursor is above several potential associated elements, use Tab to cycle the highlight among them.

Note: Opening geometry is measured relative to its associated element, and moves along with it.

4. Click once or twice to place the Opening, depending on its Orientation (see below): Aligned, Vertical, 

Horizontal or Custom. 

Orientation

In the Info Box, the Orientation defines the Opening extrusion relative to the associated element.

Aligned (default)

Click once to place an Opening that is perpendicular to the host element’s reference line or plane. The 

“Aligned” Opening is automatically placed in the most logical direction depending on the host:

Dimensions

Shape 

Orientation of Opening in host 
element

Infinite or Limited 
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• Opening in a Slab or Mesh is vertical

• Opening in a straight Wall or Beam is horizontal

• Opening in a slanted Wall is perpendicular

An Opening placed with the Aligned method remains connected to the host element’s reference line or plane.

Vertical

Click once to place a vertical Opening:

Horizontal

Click once to place the horizontal Opening, then click again to define extrusion direction:
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Custom

Drag, mirror or rotate an existing Opening into any position.

• Available for a selected, existing Opening. (Not available as default input method.)

• You can change a selected Custom-oriented Opening, then change its orientation to Aligned, Vertical or 

Horizontal. However, the previous Custom orientation is now lost.
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Infinite or Limited Opening

By default, an Opening extends infinitely - as set at the Limits option in Info Box or Opening Settings. 

An “infinite” Opening means that its length does not depend on the cut element’s geometry: if Wall thickness is 

increased, the Opening still cuts through it.

An Opening can also be defined as limited on one or both sides. 

See Use Limited Opening to Create Niche or Recess.

Anchor Point

Position the Opening’s Anchor Point at any of the 9 points on the bounding rectangle.

In 3D, the blue extrusion vector indicates the anchor point’s position.

• The anchor remains fixed when you numerically resize the Opening dimensions. 

• When the Opening is graphically stretched, its centerpoint remains fixed - regardless of the Anchor Point.

Opening Elevation

The Opening’s elevation is measured from the associated element’s Home Story to the Opening’s   Anchor 

point. This is the anchor height value.

• In 3D: Click to place the opening graphically at any elevation.

• On Floor Plan: 

– Opening’s anchor height in a vertical element (e.g. Wall) is measured to the associated element’s 

home story.
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– When placing an Opening placed in a Beam, anchor height is indicated from the story above.

– For an Opening placed in a Slab or Mesh: anchor height follows the elevation of the host element.
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Opening Display on Floor Plan

Use Opening Settings to fine-tune the display of Openings on the Floor Plan, including its symbol, attributes, 

and Reference Axis.

Note: Openings are visible only if at least one of its Cut Elements is visible too.

Watch the Video

Topics in this Section:

Floor Plan Symbol

Opening Display in Cut Elements

Divided Openings: Separated or Unified

Cut Surfaces

Opening Outlines on Floor Plan

Opening Cover Fills

Opening Reference Axis

Floor Plan Symbol

Watch the Video

An Opening can have two Floor Plan Symbols: one each for Cut and Uncut openings. Choose a default for 

each, using the Symbol panel of Opening Settings.
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Fine tune your preferences and geometry preferences for any Symbol, using the Symbol Custom Settings 

panel:

Cut symbol, with offset and contour
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Uncut symbol, with offset and contour

Opening Display in Cut Elements

In Opening Settings: Use the Floor Plan Display controls to display openings in cut elements.

Note: Openings in Uncut/Overhead elements are always shown as Symbolic.

• Symbolic Cut: Always use Cut attributes (regardless of the Opening’s vertical position)

• Symbolic: Use either Cut, Hidden or Overhead lines, based on the Opening’s vertical position

• Overhead All: Always use Overhead attributes (regardless of the Opening’s vertical position).
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Divided Openings: Separated or Unified

For an Opening that cuts through multiple elements, or a composite element, separated by air space:

• Separated: 

– Inner contours (inside the air space) are visible.

– Cut lines and cover fill are not shown.

• Unified: 

– Inner contours (inside the air space) are not visible. 

– Cut lines and cover fill are displayed.

Openings Divided by Air Space: Separated vs. Unified
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Cut Surfaces

For the element surfaces cut by the opening: check the box to Use Lines of Cut Elements. Otherwise, the 

Opening’s own cut lines (defined in this dialog box) will be used.

Use Lines of Cut Elements
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Use Opening’s Own Cut Lines

Opening Outlines on Floor Plan

Contours on Open Edges

“Open Edges” are Opening contours that do not intersect any other element, and do not coincide with another 

element’s edge.

Openings with Open (1) and Bound (2) edges
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Display these Open Edges as Uncut, Overhead or Hide:

Open Edges as Uncut - Show as Overhead - Hide

Open Edges as Uncut - Show as Overhead - Hide

Note: This setting has no effect on Openings that coincide with e.g. a Slab edge. Such edges are “Bound 

edges,” and their display (Overhead or Uncut) depend on the Slab’s contour display.

Opening Contours

Define attributes for Uncut and Overhead contours. You can Use Contours of Cut Elements. Otherwise, the 

Opening’s own Uncut/Overhead attributes (defined in this dialog box) will be used.

Opening Cover Fills

See Assign a Cover Fill.
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– For “separated” display of divided openings, the cover fill is not shown in the air space.

– The Opening’s symbol is placed on top of the opening (including its cover fill, if any.)

Opening Reference Axis

Use these controls to define the Reference Axis of the Opening as shown on Floor Plan and Section.

Note: To show/hide Opening Reference Axes by view, use Model View Options. See Model View Options 

for Construction Elements.
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Use Limited Opening to Create Niche or Recess

A limited Opening can be used, for example, as a Wall Niche or a Slab Recess.

Limit One Side

1. In Opening Settings or the Info Box, choose Limit One Side.

2. Click on the associated element into which to place the opening. 

3. Move the eyeball cursor to see the placement options (e.g. on either side of the host Wall’s reference 

line). 

4. Click to place. The Opening’s limited side coincides with the host’s reference line/plane.
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Offset Host Element’s Reference Line/Plane

Do one of the following:

• Use Offset from Reference Plane command from pet palette 

• Enter offset in Settings or Info Box

Limit Both Sides

1. In Opening Settings or the Info Box, choose Limit Both Sides.

2. Optionally, offset the Opening from the host’s reference line/plane (enter positive or negative offset in 

Settings or Info Box).

3. Enter the desired Opening length, or edit it graphically.
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Move Opening’s Reference Line/Plane

For Openings placed with the Horizontal or Vertical method (but not the Aligned method): You can use the 

Drag command from the pet palette to reposition the Opening’s reference line/plane.

Flip Opening

To reverse the direction of a limited Opening, click Flip in Opening Settings or the Info Box.
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On-Screen View Options for Openings

Watch the Video

Turn these options with one of the following:

• View > On-Screen View Options

• the On-Screen View Options toolbar.

Opening Cutting Bodies

Opening Reference Planes

 This toggle ensures that an Opening will have an on-screen display on the Floor Plan, even if it is located 

entirely outside of its associated host element.
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Edit Opening

Watch the Video

Drag-Rotate-Mirror

As with other construction elements, use Drag, Rotate and Mirror to freely modify the Opening position in 

any view. As a result, the Opening orientation setting (seen in the Info Box) may change to “Custom”.

Use pet palette commands to graphically edit Opening geometry. 

Copy or Duplicate Opening

You can only copy/paste an Opening if you also copy/paste its associated element.

To duplicate an Opening (without moving or copying the associated element), use Drag a Copy

Offset Edge(s)
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Stretch Ellipse/Radius
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Manage Opening Connections

Manage an Opening and its cut elements using the commands of the Connections grip. (Each Opening is 

associated to a single element, but a single Opening can cut multiple elements at once).

Note: Opening geometry is measured relative to its associated element, and moves along with it.

Topics in this Section:

Cut Additional Element (Command)

Cut Additional Element (Use Connection Grip)

See List of Elements Cut by the Opening

Redefine Opening’s Associated Element

Delete Cut Element Relationship

Cut Additional Element (Command)

1. Select the Opening.

2. From the pet palette or context menu (Connect submenu), choose Cut Additional Element with 

Opening.

3. Move your cursor to the next element you wish to cut. Eligible elements are shown with a pre-selection 

highlight.

4. Click to cut the element. 

Cut Additional Element (Use Connection Grip)

1. Select the Opening.

2. Click the Connections grip.
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3. Hover over the list header (Cut Elements) and click the Plus sign.

4. Move your cursor to the next element you wish to cut. Eligible elements are shown with a pre-selection 

highlight.

5. Click to cut the element. It is added to the Opening’s Cut Elements list.

See List of Elements Cut by the Opening

1. Select a single Opening. The Connections grip appears. 

Note: The Connections grip does not appear if multiple elements are selected.

2. Click the Connections grip to display a list of the elements cut by the Opening.

3. Pinned Element: this is the Opening’s associated element. Opening geometry is measured relative to 

this associated element, and moves along with this element. Reassign the pin to any of the listed 

elements. (See Redefine Opening’s Associated Element.)
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4. Move your cursor through the list: As you hover over any listed item, the corresponding cut element is 

highlighted in the project

To highlight all of the project elements cut by the selected Opening, hover over the header (Cut Elements) in 

the connection list.

If the listed cut element is not visible in the current view (e.g. it is on a hidden layer, or on a different story), 

that item is listed in italic type.

Redefine Opening’s Associated Element

To redefine an Opening’s associated element:

1. Select the Opening.

2. Click the Connections grip.

3. In the list, hover over the Cut element that you want to redefine as the Opening’s associated element.

Note: Opening geometry is measured relative to its associated element, and moves along with it.

4. Click the Pin icon.

Redefine Opening’s Associated Element

Delete Cut Element Relationship

1. Select the Opening.

2. Click the Connections icon.
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3. In the list, hover over the element whose Cut you want to delete, and click X

Delete Cut

Note: If you delete the Opening’s cut to its associated element (the one with the pin), then the Opening is 

deleted. 
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Edit Openings in Teamwork

To edit the geometry and settings of an Opening element, you must first reserve the Opening. 

For example, the following interactions require that you reserve the Opening:

• Cut additional element

• Delete Cut element relationship

• Redefine the Opening’s associated element (reassign Pin)

However, you do not have to reserve its associated or cut elements. For example, you can create new 

Openings in elements that are part of a Hotlinked Module without reserving them.
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Import/Save Openings with IFC

Import IFC Openings as ARCHICAD Openings

Imported IFCOpeningElements are converted to Openings in ARCHICAD 24 provided that:

• The ARCHICAD host element is a Wall, Slab, Mesh, or Beam

• The incoming Opening is empty (does not contain a Door/Window)

• The incoming Opening shape is rectangle, circle or ellipse

IFC Openings that do not meet these conditions are converted to a Morph, which is in a Solid Element 

Operation with the host element.

Convert IFC Provision for Void to ARCHICAD Opening

An IFC Provision for Void is a simple Building Element Proxy with a special IFC Attribute (Provision for Void) 

assigned to it. An IFC Provision for Void cannot contain a Door or Window.

Architects receive Provisions for Voids from other design disciplines as an IFC model. This model might 

contain other model elements, or just the Provision for Voids.

The Building Element Proxies that represent IFC Provisions for Voids are imported to ARCHICAD as Morphs, 

and classified as Provisions for Voids.

See also Create Openings from Selection.

Export ARCHICAD Openings to IFC

As IFC Opening Element

Each ARCHICAD Opening is exported as a single IFC Opening Element (IfcOpeningElement), with a single 

host element.

If the ARCHICAD Opening cuts multiple elements, then:

• The Opening part cut from the host (associated) element is exported as an IfcOpeningElement. It inherits 

all metadata (classification, properties, ID).

• The Opening parts cut from additional elements are represented in IFC by holes (created by solid element 

subtraction).

As IFC Provision for Void

Provisions for Voids that are modeled using Morphs in ARCHICAD can be classified and exported to IFC as 

Provisions for Voids.

Exporting Host Elements to IFC

When exporting the host (associated) elements of Openings (e.g. Wall/Slab) to IFC, you can choose to export 

their gross geometry - that is, without the holes. To do this, use the “Export gross geometry” checkbox in the 

IFC Translator for Geometry Export. The opening elements are exported separately (IfcOpeningElement), and 

the exact subtraction can be carried out in IFC by the receiving application (e.g. for more accurate cost 

calculation).

See Export gross geometry of elements (Export holes separately).
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Create Openings from Selection

Watch the Video

Use this command to transform selected ARCHICAD construction element(s) into Openings. 

A selected ARCHICAD element will turn into an Opening if it collides with an eligible element (Wall, Slab, 

Mesh, Beam).

For example: Morphs, MEP elements, and Stair elements (with headroom On) are typically transformed into 

Openings.

Note: If the two intersecting elements do not collide (i.e. because of automatic intersection or Solid 

Element Operation), no Opening is created.

For example, an imported file may contain a multi-story Morph representing mechanical voids.

1. Select the element (here, the Morph).

2. Use the Create Openings from Selection command

– from the context menu

– from Design > Connect menu
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3. Set options in the appearing palette, then click Create Openings at the bottom of the palette.

Shape

• Automatic: Openings will match the original element geometry as closely as possible

• Rectangular or Circular

Offset

Optionally, add an offset to the Opening.

Keep Original Elements

Uncheck to delete the original elements.

Merge Nearby Openings

Check this to merge Openings that are closer than the tolerance distance defined here. 

• Merge lengthwise: This can be useful in parallel Walls that are close together, or Slabs on top of one 

another.

• Merge sideways: For example, with MEP pipework, in which parallel pipes are very close to each other.
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If you do not check this box, then a separate Opening is created in each host element.

Element ID

For the newly created Opening element(s):

• Retain the ID of the original element (e.g. MORPH-002), or

• Assign a new ID based on Opening Tool defaults

Merge nearby Openings Do not merge nearby Openings
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TrussMaker

TrussMaker is a built-in tool allowing you to create girder and truss objects for visualization purposes. It is 

accessed from the Design > Design Extras menu. Technically, TrussMaker is an ARCHICAD Add-On and is 

loaded with ARCHICAD on startup.

What’s Covered

Creating Trusses in the Floor Plan

Editing Trusses

Creating Trusses in Section/Elevation/IE Windows
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Creating Trusses in the Floor Plan

Start by drawing the framework of the truss in the Floor Plan window with the Line and Arc/Circle tools. Use 

different pen colors for the different parts of the truss, as seen below. Pen thicknesses have been exaggerated 

for clarity.

When you are satisfied with your design, select the lines making up the truss and choose the Create Truss 

command from the TrussMaker hierarchical menu (Design > Design Extras).

Use TrussMaker Settings to choose a shape and define options for creating the truss.

See TrussMaker Settings.

When you have finished customizing your truss, click the Save button at the bottom right of the dialog box. 

You will then be prompted to name the new truss object and place it in your Embedded library.

The new truss appears on the Floor Plan on the baseline of the contour. Go to the 3D window to visualize it, 

and then drag it into its final location.
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Editing Trusses

The framework drawn on the Floor Plan is not associated to the truss after it has been created and placed 

(and can only be used to create new trusses). Modifying this outline has no effect on placed trusses.

TrussMaker offers you an additional method for editing placed trusses.

Select a truss and choose the Edit Truss command from the TrussMaker menu (Design > Design Extras) 

or the TrussMaker palette.

An alert will appear, prompting you to create a new Section window. Draw a simple section line with the 

Section/Elevation/IE tools, open the new Section/Elevation/IE window and then choose Continue Editing 

from the TrussMaker menu or palette. The original framework will appear in the window and you will be able 

to edit it.

When you have finished making your changes, choose the Create Truss command again.

The TrussMaker Settings dialog box will appear, with the same options as seen above. The only difference is 

that in addition to the Save button, a Save as button appears.

• If you click Save, TrussMaker will display a warning telling you that you are about to save a library part 

under an existing name. Clicking Overwrite will replace the previous truss, while clicking Cancel will abort 

the whole process.

• If you click Save as, a new truss object will be created. TrussMaker will prompt you to name this object.
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Creating Trusses in Section/Elevation/IE Windows

You can create a truss in a Section/Elevation/IE window:

1. Draw a Roof on the Floor Plan and add a Section Line.

2. Open the corresponding Section/Elevation/IE window.

3. Fit the framework of the truss to the roof. Draw the outline with lines as you would on the Floor Plan.

4. Select the framework’s elements and choose Create Truss from the TrussMaker hierarchical menu. 

(Design > Design Extras > TrussMaker)

5. Make the appropriate settings in the TrussMaker Settings dialog box and save the object.

An alert will be displayed, informing you that the new truss object has been created on the Floor Plan. The 

truss is placed on the same line as the section line and will therefore appear in the Section/Elevation/IE 

window as an element that was cut on its edge.
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6. Display the new truss with the roof in 3D or in another Section window.
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Solid Element Operations

Solid Element Operations allow you to create complex shapes using Boolean operations, including 

subtraction, addition and intersection. The result is associative: if you modify the location or the attributes of 

the elements that participate in the operation, the linked elements will be updated accordingly.

What’s Covered

About Solid Element Operations

Solid Operation Types

Solid Operations: Element Display and Calculation

Solid Operation Example

Managing Solid Element Connections

Solid Element Operations Palette

See also Boolean Operations with Morphs.
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About Solid Element Operations

Solid Operations can be performed on elements in any model window by choosing one of the following:

• Design > Solid Element Operations

• Connect > Solid Element Operations from an eligible selected element’s context menu.

For details on these controls, see Solid Element Operations Palette.

Solid Element Operations distinguish two roles:

• A Target is an element whose geometry will be modified by the solid operation.

• An Operator is an element that affects the geometry of the element it is linked to.

The operation does not modify or delete the Operator element. You can hide the layers of the Operator 

elements after the operation has been performed without resetting the modified shape. You can also set the 

Operator’s layer to be shown as Wireframe, which allows you to still see the Operator element’s contour and 

adjust it as necessary.

In the illustration below, a Target Wall’s shape was modified by subtracting a Roof type Operator shape. On 

the left, both elements are shown; in the middle, the Roof’s layer has been hidden; on the right, the Roof’s 

layer has been set to Wireframe.
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An Operator can work on multiple Targets, and a Target can be affected by multiple Operators. Each element 

can be a Target and an Operator at the same time, which permits nested Solid Element Operations. The 

operation remains in effect as long as the involved elements are present. If you wish to keep the obtained 

shape permanently, save it as a GDL Object from the 3D Window.

See Save 3D Elements as Objects.

Restrictions and Remarks

Bypass automatic intersections: Solid Operations do not affect the results of automatic intersections, if the 

elements are included in the same Layer intersection group. Before performing a Solid Operation on such 

elements, change the Layer intersection number of one of them.

See Use Layers to Prevent Intersections.

Beams: If you intend to apply an operation between Beams, the Operator must have at least the same 3D 

Intersection Priority number as the Target. If the Target’s priority number is higher, the operation will appear to 

have no effect.

See Beams and Other Elements.

Nested operations: If the desired shape can be only be obtained through a number of nested operations, pay 

attention to the order in which you apply them. For example, an Operator element may affect a Target that is 

also an Operator affecting another Target, and so on.

Morphs: There are separate Boolean operation commands for Morphs. Unlike Solid Element Operations, 

which create connections, Boolean operations on Morphs are not associative - the final result of the operation 

is permanent.

See Boolean Operations with Morphs.
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Solid Operation Types

Five types of operations can be performed. The illustration below shows the effect of each: the starting Wall 

shape is shown at far left, followed by each of the five operations. The Operator element is shown in 

Wireframe mode.

• Subtraction cuts out the shape of the Operator from Target.

• Subtraction with upward extrusion cuts out both the shape of the Operator from the Target and its 

vertical projection from the bottom of the Operator shape to the top of the Target.

• Subtraction with downward extrusion cuts out both the shape of the Operator from the Target and its 

vertical projection from the top of the Operator shape to the bottom of the Target.

• Intersection keeps only the common part of the Target and the Operator.

• Addition adds the shape of the Target to the shape of the Operator.

Solid Operations: Element Display and Calculation

The solid operation affects the model shape, that is, the 3D view and the generated Section/Elevation/IE 

model and Detail Drawing view. Below is the Section view of the elements shown above. The Operators are 

shown in Wireframe, above, and their layers are hidden, below.

The Floor Plan view of both Target and Operator elements is unaffected. Putting the Operator element on a 

Wireframe layer does not affect its display. If the Operators’ layer is hidden, then they will not appear in the 

Floor Plan, but you will not be able to edit them until you make the layer visible again.

Note: If you select only the Target on the Floor Plan and display the selection in 3D view, the modified 

shape will be shown, but without displaying the Operator.

If you perform a Solid Operation on a Section/Elevation/IE view, you need to rebuild the window’s contents to 

see the results.

Solid Element Operations in Interactive Schedules

Element lists display elements according to the parameters you specify in each Schedule’s Scheme Settings. 

Many elements include separate listing parameters for “Net” and Gross” values: for example, the Net volume 
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of a column vs. the Gross volume of a column. As a rule, “Net” and “Gross” in these element listing 

parameters means:

• Net: takes any Solid Element Operations into account.

• Gross: does not take any Solid Element Operations into account.

See Element Parameters for more information.
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Solid Operation Example

In this example, we will connect a Stair with a Slab. 

1. Open the dialog box using the Design > Solid Element Operations command (also available from the 

context menu of either selected element).

For details on these controls, see Solid Element Operations Palette.

2. Collide the two elements.

3. Select target element: the Slab.
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4. Click Get Target Elements.

5. Deselect the Slab.

6. Select the operator element: the Stair.

7. Click Get Operator Elements.
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8. Choose an operation type: Subtraction with upwards extrusion.

9. Click Execute. The Solid Element Operation is complete.

10. View the result in 3D.
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With the Stair shown in wireframe:
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Managing Solid Element Connections

On any selected element that is part of a Solid Element Operation, a “connection grip” appears, listing the 

elements to which it is connected.

You can highlight each connected element and clear any connection as needed.

For details, see Managing Element Connections.
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Properties and Classification Systems

What are Properties?

Properties are optional, user-defined data assigned to an element or Building Material to provide additional, 

searchable information. 

Examples of properties:

• General Ratings (e.g. Fire Resistance Rating, Thermal Transmittance)

• Openings (e.g. fire exit, security rating)

• Product Information (e.g. model, serial number, price)

Use the Property Manager (Options > Property Manager) to create and delete properties and customize 

their availability. Property availability depends on the Classification of each element/material. 

What you can do with Properties

• List and manage them in the Interactive Schedule

• Display them in Labels, Zone Stamps, Door/Window Markers

• Display elements by property, using Graphic Overrides

• Import and export them among applications

• Export data structure to spreadsheet, then import property data from spreadsheets into ARCHICAD 

elements or materials

What is Classification?

Classification is used:

• To organize project elements/materials and their related data

• To define which properties are available to an element or Building Material (available properties depend 

on its Classification)

• To provide mandatory deliverables based on international Classification Standards

• To ensure accurate data exchange with other applications, e.g. using the IFC standard

• To Find & Select elements or materials by Classification: for example, search for all elements classified 

as Ramps within the UniClass classification system

• To apply Graphic Override Rules based on Classification

Use the Classification Manager (Options > Classification Manager) to manage Classifications and 

Classifications Systems, and to customize their available properties.

ARCHICAD comes with a default Classification System, but depending on your working methods and local 

standards, you may want to use different or additional Classification Systems.

The following sections describe ARCHICAD functions related to working with Properties and Classifications:

Assign Classification

Assign Classifications/Properties in Element Schedule

Show Property Data in Labels and Markers

Default Property Value

Expression-Defined Element Properties

Expression-Defined Properties: Examples

Properties in Hotlinks
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Property Manager

Classification Manager

Import/Export Property Data via Spreadsheet

Import BIM Content
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Assign Classification

Classifying an element or Building Material determines which properties are available to it. 

To assign Classification(s), open the Classification and Properties panel (Element Settings or Building 

Materials dialog box).

Select Classifications from Classification System(s) at the top of the list:

• If your project contains multiple Classification Systems, they are all listed. Check the name of the 

System(s) you will use. An element/material can be classified in several classification systems 

simultaneously. 

• To change or assign the item’s classification within any of the Systems, click the pop-up arrow at the right:
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Use the search field if needed to locate the desired classification(s).

Note: A “branch” classification and a “leaf” classification are each a single classification (the “branch” is a 

more general grouping than the “leaves” it contains.)
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• Available properties (listed below) depend on the classification(s):
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Available Properties Depend on Classification
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Assign Custom Property Value

To assign custom property values to a selected ARCHICAD element or material, open the Classification and 

Properties panel (Element Settings or Building Materials dialog box).

All available properties are listed here. Available properties depend on the Classification(s).

For each property, the chain icon indicates that its value is linked to the default for this property. (Default value 

of each property is defined in Property Manager.)

Click on any property in the list to assign a custom property value for this item.

If the default value is <Undefined>: click the chain popup. Then choose Custom Value to unlink the default 

value, and enter a custom property value instead.
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Depending on the property’s data format, you can choose from a list, enter text, or simply type in a value.

The custom value can also be set as “Undefined” for this item.

• Click the chain popup.

• Choose Set Custom as Undefined. 

This undefined value is not linked to the default, and will not be updated in case you change the default value.
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Default Property Value

The default value of a Property is defined in Property Manager, in the Value Definition panel.

The default can be any text or value, or even an expression: a function consisting of operations and variables. 

Regardless of the default, you can assign a custom value to any Property for any element or material. 

If you edit a property’s default value in Property Manager, all linked property values are updated accordingly at 

the element/material level.

Under the Default Value control, choose an option that defines the Property’s Default Value.

• Undefined: The Property value is <Undefined> by default. It is up to the user or external consultant to set 

its custom value for each item.

• Value: This is a user-defined, static value that remains fixed until you change it. All items using this 

Property are assigned this value. 

• Expression: This Property value is calculated uniquely for each item. An expression-defined value is a 

function of other data (e.g. element parameters), or a function of other properties (e.g. mapped 

properties). For example, the value is based on its model parameters (e.g. element Height), or derived 

from the value of another Property.

See Expression-Defined Element Properties.
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Link Property to Default Value

For each property listed in an item’s Classification/Properties panel, the chain icon indicates that its value is 

linked to the default for this property.

Property Linked to Default

Note: Defaults are defined in Property Manager. If you edit a property’s default value in Property Manager, 

all linked property values are updated accordingly at the element/material level. 

If you overwrite a value in Element Settings or the Building Material dialog, its link to the default is broken.

Property Unlinked from Default
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To re-link and restore the default value, click the chain icon and choose Default value.
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Property Manager

Use the Property Manager (Options > Property Manager) to create and manage the set of properties for this 

project, define Property values, and customize Property availability for the various classifications.

Property Manager can also be opened from the Classification Manager dialog box.

Search Property List

The left side of the Property Manager lists all the properties available in the project. 

Click the Search icon, then start typing text into the search field. All property and group names containing the 

search term are shown.
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To view the full list of properties again, delete the text from the Search field, or click the tree hierarchy icon.

Create New Property or Group

1. Open the Property Manager dialog box at Options > Property Manager, or from Classification Manager.

2. Do one of the following:

• Click anywhere in the Property list and use the context menu

• Click the New button at the bottom of the dialog box

• Click the Plus sign to the right of any Group name

3. In the New Property/Group dialog box: Choose a radio button for either a new Property or Group, then 

enter its name.

The Property Name must be unique within its Group.

4. Add to Group: For a new property, choose the group into which it should be placed.

5. Click OK.
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Duplicate Property

Select a Property.

From the context menu or drop-down list under the New button, click Duplicate to add a duplicate of that 

Property to the list.

Property Description

Optionally, enter any further information here to guide the user in assigning a value to this property. For 

example, its format or measurement unit: “minutes” for the Fire Resistance Rating Property, or “W/m2K” for 

Thermal Transmittance.

In the item’s Classification and Properties panel, this description is visible when hovering over the property 

name:
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Data Type

The property’s Data Type determines the format of the value(s) that can be assigned to it. 

1. Select a property from the left side of the Property Manager (e.g. Thermal Transmittance).

2. Choose a Data Type from the right side of Property Manager:

A property’s Data Type is relevant for the syntax of Expressions, when you define an Expression-based 

Property.

• String: Can use any text or non-unit number (e.g. for the “Manufacturer” property)

• Number: Can use any non-unit number expressed in decimals (e.g. for the “Purchase Price” property). 

The displayed number of decimals depends on the Numbers without Units setting in Options > 

Working Units.

• Integer: A whole number (e.g. for the “Sound Transmission Class” property)
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Data with Unit Values

The next four data types are Unit values:

• Area

• Length

• Angle

• Volume

• Tags List: Can be a tag or series of tags (e.g. Building A, Floor 2, Common Use, Kitchenette)

– This data type cannot be used for an Expression-based property.

• Option Set: Provides a fixed set of options (e.g. for the “Fire Resistance Rating” property)

– This data type cannot be used for an Expression-based property. However, Option Set-type properties 

(without Multi-Choice) can be used within an Expression.

For details, see Options Setup below.

• True/False (e.g. for the “Combustible” property)

For information on setting Default Value and Expression-defined Values, see:

Default Property Value

Expression-Defined Element Properties

Options Setup

This button is active only if the Data Type is “Option Set”.

– Not available for Expression-defined Properties. However, Option Set-type properties (without Multi-

Choice) can be used within an Expression

Click to open the Options Setup dialog box.

Use Options Setup to list a set of specific values that the user can choose from when defining this property 

for a particular element or material.
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• Click Add to add a new option (type a value into the New Option line).

• To delete an option, select it and click Remove.

• Check Allow multiple choices to enable the user to choose more than one value for this property (in 

Property Manager, the Settings dialog, or the Info Box).

 

Default Value: Multi-Choice Option Set, Defined in Property Manager
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Multi-Choice Property Values in Element Settings
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Property Availability for Classifications

Use these controls in Property Manager to define which properties go with which Classification.

• Select one or more Properties or Groups from the list on the left.

• If you select a group, the Availability definition is applied to all properties in that group.

• All: The groups or properties selected on the left will be available for all classified items in the project.

• None: The groups or properties selected on the left will not be available for any elements or materials in 

the project. (You might set certain properties to None if the current project does not use them, yet you still 

want to use them in other phases of the same project, or other projects, e.g. in a template).

• Custom: Click this option, then click Edit to select the Classifications that should use this property or 

group.
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For example, the Precast concrete components property (selected at left) is available to items that have one 

of the Classification groups selected at right.

 

Apply Availability to All Sub-Items

1. In the Availability dialog box, click on a parent item.

2. Right-click to bring up the context menu: click Select Branch.

3. All sub-items of the parent item are now enabled.
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Find and Select Element or Building Materials: By Property and Classification

• By Property value or Property availability, or Defined/Undefined value:

• By Classification:

– Items classified within (“IS UNDER”) or directly underneath (“IS DIRECTLY UNDER) a particular 

Classification branch

– Items having (“IS/IS NOT”) a particular Classification within the given Classification System
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Transfer Availability

To transfer a property’s Availability definition to another property or group, use the Transfer buttons in 

Property Manager:

1. From the Property list at left, select the property whose Availability definition you want to transfer.

2. Click the “Pick up” icon.

3. Select a property or group to which to transfer the availability data.

4. Click the “Apply Availability” icon.

The availability data of the selected group (or property) is customized accordingly.

Changes in Property Manager

• After making edits in Property Manager, click OK to accept the changes and close the dialog box. At this 

point, you can use Undo/Redo to undo/redo the Property Manager edits.

• If you edit a property’s Data Type in Property Manager, all the project items that use this property will 

retain their assigned values as far as possible. For example, if you change the Combustible property’s 

True/False data type to the General data type, an element’s Combustible property value that was set to 

False will stay that way, except it now becomes editable, as a General data type.

Data Type Changed from True/False to “General”

• From Property Manager, you can open the Classification Manager directly, without losing your 

modifications in Property Manager: click the Classification Manager button.

Make the changes you need in Classification Manager, then click OK to return to Property Manager. 

Property Manager is updated with the latest Classification changes.
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Assign Classifications/Properties in Element Schedule

Use the Element Schedule as a convenient way to edit Classifications and Properties for a set of items.

In the Schedule’s Scheme Settings, add the Properties and Classifications you wish to edit (here, Fire 

Resistance Rating):

See also Schemes Fields Panel.

The Properties and Classifications now appear in the Schedule and can be edited.
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Show Property Data in Labels and Markers

As needed, set up Labels to display any element or Building Material properties (generally the Property Label 

or the Classification and Properties Label):

Watch the Video
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Expression-Defined Element Properties

Create functional Expressions which automatically evaluate element Property values, based on one or more 

of the following:

• Built-in and custom properties and parameters

• An element’s model environment (e.g. data from the surrounding Zone, or that of its parent Hotlink 

Module)

• Global settings (e.g. Project Info).

Use a wide range of function types (many will be familiar from Excel) to generate the property values you 

need. Display the property values in schedules, labels, and Zone Stamps.

Note: Expressions cannot be evaluated for properties assigned to Building Materials.

Related Topics:

Create a New Expression-Defined Property: Step By Step

Using Expression Editor: Context-Sensitive Help

Evaluate Expression-Defined Property

Errors in Expressions and How to Fix Them

Expression-Defined Properties: Examples

Read More on Help Center
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Create a New Expression-Defined Property: Step By Step

1. Open Property Manager (Options > Property Manager).

2. Create a New Property.

3. In the Value Definition panel, activate Expression. The Expression Editor dialog appears.

 

4. Define the Expression with the help of the pop-up lists: Parameters & Properties; Units; Functions.

5. Double-click any item in these lists to add it to the Expressions Editor 

For example, start with a Function: use CONCAT to “concatenate” (or join) multiple string-type data items 

into a single item.
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Data types of Parameters and Properties are indicated by their icon:

See the Examples below to get the idea: Expression-Defined Properties: Examples.

For information on how each parameter works, see: Element Parameters.

6. In the Value Definition panel, choose a Data Type that corresponds to the property expression. Note the 

Data Types that have unit values: Length, Area, Volume, Angle. (ARCHICAD will help you choose the 

right ones – see the following section on Context-Sensitive Help.)

7. Don’t forget to set Availability for Classifications when you define a new Property!

8. Check the generated Property value as needed.

See Evaluate Expression-Defined Property.
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Using Expression Editor: Context-Sensitive Help 

• Hover over any item in the Functions pop-up to see its description and syntax.

• When you add a Function to the Expression Editor, an example of the syntax appears, as a guide. (Delete 

this part when you no longer need it.)

• The required separator (comma or semi-colon) is also shown – this automatically corresponds to your 

computer’s location settings.

• When you add a Function to Expression Editor, you can hover it to see its description, syntax, and the 

Data Type required for each Argument. For example, in this CONCAT function, the “text1” and “text2” 

arguments must be of the String type.

For more help on how each Function works, see:
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Functions in Expressions

For explanations of Error messages, see:

Errors in Expressions and How to Fix Them
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Evaluate Expression-Defined Property

Expression-defined properties are evaluated for model elements in schedules, labels and Zone Stamps, for 

example.

You can also check the property value for any selected element in the following ways:

Check Property Value in Info Box

To evaluate a selected element’s expression-defined Property: Open the Property list from the Info box, and 

click the calculator icon for that property.

(Expression-defined properties are also listed in Element Settings, but the actual values cannot be shown.)

Evaluate a Property in Property Manager

If it is a new Property: You must first click OK to close Property Manager and save the new Property.

1. In the model, select one or more elements

2. Open Property Manager to the new Property.
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3. Click Evaluate.
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Expression-Defined Properties: Examples

Example 1: Simple Mapping

Example 2: Modify Element Parameter, Using an Operator

Example 3: Expand Property with Descriptive Text String

Example 4: Calculate a Quantity and Round Up

Example 5: Calculate a Length and Add Overhang

Example 6: Round Up to Standard Beam Length

Example 7: Display Regulation-Compliance Data for an Element

Example 8: Generate Expanded ID for Openings

Example 9: Calculate Number of Tiles to Purchase

Example 10: List the Total Cost of a Structure in Dollars
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Example 1: Simple Mapping

Create a new property that automatically maps existing element parameter values. No functions are needed 

for this; just identify the set of existing parameters that you want to evaluate for model elements.

1. In Property Manager, create a New Property called Structure.

2. Set its Data Type to String.

3. Select the Expression option. The Expression Editor appears.

Use the Parameters & Properties pop-up to add a sequence of Expressions, each one returning a Structure-

type parameter (Building Material, Fill, Composite Structure, Complex Profile). Each Expression in the 

sequence must have the same Data Type (in this case, String.)

– Click Parameters & Properties to search for the “Building Material” parameter

– Double-click the parameter, or click Add to add it to the Expression Editor.

– Click OK to close Expression Editor.

– Click Add to add the next Expression (the Fill Type parameter), and so on for all parameters in the 

sequence.

– Finally, add an expression consisting of the string “NONE”
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ARCHICAD will evaluate these Expressions in sequence for each element, returning the first valid value 

for each element. Once a value is returned, the subsequent expressions are not considered for that 

element.

If none of the definitions apply to an element, that element will list “NONE”.

4. Make sure you set the property’s Availability for Classifications.

5. Click OK to close Property Manager and save the new property.

6. List the property in Interactive Schedule to see the results for model elements:
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Example 2: Modify Element Parameter, Using an Operator

Define a new property for Zones that returns a value of 30 cm below the Zone height.

1. In Property Manager, create a New Property called Suspended Ceiling Height.

2. Set its Data Type to Length.

3. Select the Expression option. The Expression Editor appears.

4. Use the Parameters & Properties pop-up to add HEIGHT as the first expression.

5. Use the Function pop-up to choose the Subtract operator (or just type a minus sign), then type 30.

6. Use the Unit pop-up to choose cm as the unit (or type it in). 

Your function can be run using any of the units listed here. (However, the calculated property value will be 

shown on the ARCHICAD interface according to the Calculation Units in effect).

7. The resulting Expression:
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8. Define the Property Availability for all Space-classified elements.

9. Click OK to close Property Manager and save the new property.

10. Display the “Suspended Ceiling Height” property value in the Zone Stamp.
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Example 3: Expand Property with Descriptive Text String

To the Suspended Ceiling Height property value (created in Example 2: Modify Element Parameter, Using an 

Operator), add a text string that explains this property wherever it is displayed (e.g. on a Zone Stamp).

1. In Property Manager, create a New Property called Suspended Ceiling.

2. Set its Data Type to String.

3. Select the Expression option. The Expression Editor appears.

4. Start by adding the CONCAT function. As indicated in the Function description, CONCAT is used to join 

two strings together.

5. When you add the CONCAT function, you can hover over it to see an example of the syntax, as a guide.

In this case, the CONCAT function requires a series of string-type arguments, with parentheses on the 

outside.

6. For the first argument, add the Suspended Ceiling Height property. (Click Parameters and Properties, 

then search for this property and add it.)

7. For the second argument, enter a Text string in quotes. 
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8. ARCHICAD warns you that there is a problem:

The Data Type of one of your arguments is wrong. The CONCAT function requires two string-type 

arguments, yet your first argument – the Suspended Ceiling Height property – is a Length-type argument.

The solution is to convert the Suspended Ceiling Height value from a Length-type to a String-type value. 

For this purpose, use the STRCALCUNIT function (see its description in the Function list pop-up):
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9. Now you will edit the CONCAT expression in Expression Editor. (If the Editor is not open, select the 

expression in Property Manager and click Edit; or double-click the expression in the Sequence window).

10. Within the existing expression, apply the STRCALCUNIT function to the Suspended Ceiling Height 

property.

Make sure to enclose the STRCALCUNIT function, together with its value, in parentheses. (Hover over 

STRCALCUNIT function to see the example in the pop-up).

11. You can add spaces and parentheses to the second string, within the quotation marks, to set it off from the 

first argument.
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12. Click OK to close Expression Editor.

13. Define the Property Availability for all Space-classified elements.

14. Click OK to close Property Manager and save the new property.

15. Display the “Suspended Ceiling” property value in the Zone Stamp.
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Example 4: Calculate a Quantity and Round Up

Round up a calculated quantity to conform to standard material (e.g. brick) size

• Determine the number of bricks you need to order (by rounding up to the next whole number)

• The standard size of a brick (IS Standard) is 190 mm ×90 mm ×90 mm

1. Create a Property called “Number of Bricks”. 

2. Use an expression to find the number of bricks by dividing the element’s Net Volume by the standard brick 

volume. (A volume divided by a volume results in a Number.)

3. Create another property called “Number of Bricks to order.”

4. This property rounds up the “Number of Bricks” property (created above) to a whole number. Use the 

MROUNDUP function for this purpose.

 

See Round Up to Multiple [MROUNDUP] for information on this function’s arguments and data types.
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Example 5: Calculate a Length and Add Overhang

Calculate required Beam length, taking into account the extra ledge length (20 cm) needed for each.

To do this, create a property that expands the existing “Length Right” Beam parameter, by adding 20 cm.
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Example 6: Round Up to Standard Beam Length

Round up the Beam length with overhang (using the Property created in Example 5), so that the Beam 

lengths conform to a standard beam size (length divisible by 30 cm).

– Use the MROUNDUP function for this purpose.

See Round Up to Multiple [MROUNDUP] for information on this function’s arguments and data types.
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Example 7: Display Regulation-Compliance Data for an Element

Given a regulation that a zone area must include 40% glazed area: Calculate the glazed area of a given Zone 

and display it in the Zone stamp.

1. Create a property (“Glazed Area”) that shows total glazed area (door plus window). Here, you add two 

existing element properties together.

– Adding two areas produces a Data Type which is also an Area.

2. Create another property (“Glazed Area Ratio to Zone”) that shows the ratio of the glazed area to the 

Zone’s Measured Net Area.

– Here, you divide an area by an area: this produces a Data Type which is a Number.
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3. Create another property (“Mandatory Glazed Area”) that defines the glazing area regulation (40 percent). 

This is a fixed value (not an expression.)

4. Create another property (“Display Glazing Compliance”) to return one of two strings for each zone: meets/

does not meet minimum glazed area regulation. 

– Use the IF function for this purpose.

See If Multiple [IFS] for information on this function’s arguments and data types.
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5. Add the text from this property (“Display Glazing Compliance”) to the Zone Stamp.
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6. You can also create and display another property: Glazed Area Percentage of Zone. The resulting value 

will be a String which includes the percentage symbol.

In this new Expression:

– Start with the existing “Glazed Area Ratio to Zone” property. This property expresses the resulting 

number as a decimal (with Data Type of Number). To convert this decimal to a percentage, multiply it 

by 100:

– Now convert this Number-type value to a String, using the STR function:

– Change the property’s Data type to String.

– Finally, use CONCAT to join this String to another String (the second String is the percentage sign, 

which you must put into quotation marks):
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See Convert to String [STR] and Merge Strings [CONCAT] for information on these functions’ 

arguments and data types.

– Add this property to the Zone Stamp
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Example 8: Generate Expanded ID for Openings

Automatically generate an expanded ID for all Doors and Windows that includes: 

• Element ID

• Home Story Number

• Opening Direction (Orientation)

In the Expression shown below, the CONCAT function joins these three data into a single String. This will be 

the new ID property (called “Door/Window Full Element ID”).

Note: Since Home Story Number is not a String-type data, you must convert it to a String using the STR 

function.

See Convert to String [STR] and Merge Strings [CONCAT] for information on these functions’ 

arguments and data types.
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Example 9: Calculate Number of Tiles to Purchase

For a given Slab, how many tiles are needed to cover it?

1. Define three Properties for Tile dimensions: Tile Dimension 1 and Tile Dimension 2, and the Grouting 

dimension. 

– These are fixed Length-type values (not Expressions).

2. Define an expression called “Number of tiles - not rounded”, using the three dimensions you defined in 

Step 1, to calculate the number of tiles needed to cover the slab: 
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Take the Top Surface Area of the Slab and divide it by the area of the tile, including grouting. (For tile 

area: Add the grouting length to each tile dimension, then multiply them.)

Evaluate for the selected Slab to see the resulting Property value:
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3. Define another expression (using the expression you defined in Step 2) that rounds up the number of tiles 

to a whole number.

See Round Up [ROUNDUP] for information on this function’s arguments and data types.
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Example 10: List the Total Cost of a Structure in Dollars

1. Define a Property that defines the cost of a particular structure type. This is a fixed value - here, it is 45.

2. Define another Property to do the following:

– Express the Cost Per Unit property (defined above) as a volume unit (divide the Cost value by cubic 

meters): Cost Per Unit / 1 m3

– Multiply this cost by the actual volume of the structure (its Conditional Volume)
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3. Define another property which adds the string “USD” to the result.

4. To do this, use the CONCAT function to join String-type data into a single String. Add a space before the 

“USD” string.

Note: Since the Total Cost Volume property is not a String-type data, you must convert it to a String using 

the STR function, as shown here.
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Errors in Expressions and How to Fix Them

When you work with Expressions in Property Manager, ARCHICAD automatically compares the Property’s 

defined Data Type with the result of the Expression. These must match. 

If there is a discrepancy, ARCHICAD automatically gives you a Warning. Click it to see the error message.

The following are the possible error messages and what you can do to fix them.

Result Conflicts with Data Type

All Arguments Must Use the Same Data Type and Compatible Units

Argument’s Data Type is Not Correct

Data Type Not Available in ARCHICAD

Mathematical Error

Incorrect Sign and/or Number Type

Data Type Cannot be Changed

Does Not Contain Numeric Characters
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Result Conflicts with Data Type

If you get this error message, you must change the Data Type so that it matches the result of your expression.

Example 1: Area Divided by Area: Requires Data Type of “Number”

This Expression-based property divides an area-type property (no. 1) with another area (the product of two 

lengths, no. 2).

The Property’s Data Type is set to Area, but this is incorrect, because an area divided by an area is a Number.

Set the Data Type to Number. The error is corrected.
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Example 2: Cost-Per-Volume Multiplied by Volume: Requires Data Type of “Number”

In this Expression-based property:

– The first argument (no. 1) is a number-type property (Cost per Volume). 

– To express this as a volume unit: divide the first argument (no. 1) by 1 cubic meter (no. 2): Cost Per 

Volume / 1 m3.

– Now you can multiply this cost-per-volume by the actual volume of the structure (its Conditional 

Volume, argument no. 3).

The Property’s Data Type is set to Volume, but this is incorrect, because a Cost-per-volume multiplied by a 

volume is a Cost - that is, a non-unit Number. 
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Set the Data Type to Number. The error is corrected.
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All Arguments Must Use the Same Data Type and Compatible Units

If you get this error, make sure all arguments in the Expression have the same Data Type.

Example: Add a Number to a Length?

SUM (1, 2m)

This is incorrect, because the two arguments use two different data types: 1 is a Number, 2m is a Length.

Yet n the SUM Function, all arguments must use identical data types. (You can see this by opening Expression 

Editor and hovering over the SUM item.)

Solution

Change the expression so that both arguments use an identical Data Type (here, Length in meters). 

SUM (1m, 2m)

The resulting Property is also a Length. Make sure the Property’s Data Type is set to Length.
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Argument’s Data Type is Not Correct

If you get this error, check to see which data types are required by each argument in the Function.

Example 1: Check Required Data Types for Each Argument 

This Expression uses the LEFT function with two Arguments. However, the error message indicates a 

problem with the Arguments’ Data Type(s). 

In Expression Editor, hover over the LEFT function name. 

Check the pop-up to see the required data types:

You see that the first (Text) argument must be a string, and the second (NumberOfCharacters) argument must 

be an integer.

But your expression contains two strings, which is incorrect:

LEFT (“The quick brown fox”, “The quick”)

Solution

Change the second argument to an integer.

LEFT (“The quick brown fox”, 9)
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Example 2: Check Required Data Types for Each Argument

This Expression uses the POWER function with two Arguments. However, the error message indicates a 

problem with the Arguments’ Data Type(s). 

In Expression Editor, hover over the POWER function name. 

Check the pop-up to see what data types are required by each argument in this Function:

You see that the second (Exponent) argument must be an integer or number.

Your expression contains two Lengths, which is incorrect:

POWER (2m, 3m)

The second argument (Exponent) must be an integer or a number, without a unit.

Solution

POWER (2m, 3)

Example 3: Check Required Data Types for Each Argument

This Expression uses the CONCAT function with two Arguments. However, the error message indicates a 

problem with the Arguments’ Data Type(s). 
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In Expression Editor, hover over the CONCAT function name. 

Check the pop-up to see what data types are required by each argument in this Function:

In the CONCAT function, all arguments must be strings. A text is a string if it is in quotation marks.

In your expression, the first argument is a number, which is incorrect:

CONCAT (1, “a”)

Solution

Change the first argument to a string by doing one of the following:

• by enclosing text within quotation marks:

CONCAT (“1”, “a”)

• or by using the STR function:

CONCAT (STR (1),“a”)
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Data Type Not Available in ARCHICAD

This error appears if the function produces a result whose Data Type does not exist or is not supported in 

ARCHICAD.

Solution

Correct the function so that it produces a result that corresponds to an existing Data Type.
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Mathematical Error

Problem

This error appears if a mathematical function uses arguments that are mathematically impossible to calculate 

- such as division by zero, or the square root of a negative number.

Solution

Review the arguments and adjust their values to make the function mathematically correct.
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Incorrect Sign and/or Number Type

Problem

This error appears if

• you entered a value with the wrong sign - e.g. you have a negative number for an argument that requires 

a positive one

• you entered a value with the wrong number type - e.g. you used a decimal number for an argument that 

requires a whole number (integer).

Solution

Review the arguments and adjust their values.
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Data Type Cannot be Changed

For this Property, you cannot change the Data Types to one that uses model units (Length, Area, Volume, 

Angle). These Data Types are greyed out in the list.

This can occur in the following scenarios:

• you have assigned a custom Property value to one or more elements or materials that use this Property. 

• In a Teamwork project, this Property was created by another user.

Reason: When you change a property’s Data Type, ARCHICAD attempts to convert the existing property 

values. However, a Property value that has a model unit (e.g. a Length value) cannot be converted to a 

different unit (e.g. an Area value). 

In this situation, switching Data Types is not allowed.

Similarly, you cannot edit the unit-based Data Type of a Property created by another user (in Teamwork).

Solution

• For item(s) with a custom value assigned for this Property, revert the Property value to its default

– Hint: Use Find & Select to locate such items: as the criterion, set “Property name”, with “custom value”

• Alternatively: In Property Manager, create a duplicate Property and set its Data Type as needed

• In Teamwork, you cannot change a Property’s data type if it was created by a different user.
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Does Not Contain Numeric Characters

The STRTONUM function extracts numeric data from the beginning of a string, and returns the numbers as 

Number-type data.

This error message occurs if:

• the string provided contains no numeric characters, or

• the string’s numeric characters are not at the beginning of the string

SOLUTION

Make sure the string provided contains numerical character(s) at the beginning of the string. 
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Properties in Hotlinks

It is recommended that everyone working on a particular project use the same set of Properties, and that one 

person be in charge of managing them. 

Use Import/Export Properties to ensure that everyone uses the same Property set.

See Export/Import Properties Between Projects.

However, if a Hotlink Module does contain different properties than the host file, then you can manage them 

based on the following use cases:

Hotlink Module Contains New Properties

Hotlink Module Contains Identical Property, With Conflicting Definition

Hotlink Module Contains New Properties

If the Hotlink Module contains new properties (or groups) which don’t exist in the host project, these are 

appended to the list in Property Manager, and are shown in gray.

Properties from Hotlink Modules

• Are searchable, like any property

• Can be scheduled, like any property

• Cannot be edited or deleted in the host project; they can be edited only in the external file.

For each such property or group, you have the option to merge it into the host project: click the Merge icon at 

the end of the row in Property Manager.
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Once the property is merged, it becomes a fully editable part of the host project. 

A merged property loses its connection to the external file: any changes to this property in the external file will 

not be reflected in the host file.

Hotlink Module Contains Identical Property, With Conflicting Definition

Properties are considered identical if they have the same name and are in the same group.

However, a Hotlink Module might contain an identical property as the host file, but with a conflicting property 

definition. For example, the two properties have the same name (e.g. “Fire Resistance Rating”), but with a 

different data type (e.g. Tag List instead of Option Set) or availability.

In this case, the Hotlink Module’s property is in conflict with that of the host file: the conflicting property is 

appended to the list in Property Manager, but is shown only if you check Show conflicts with Properties in 

Hotlinks. 

For each such property or group, you can do one of the following:

• Click the Merge icon at the end of the row in Property Manager. The property from the Hotlink Module, 

with its definitions, will override the corresponding property in the host file.

• Open the hotlink’s source file, and edit its property definition so that it matches that of the host file. Then, 

in the host file, update the Hotlink Module to eliminate the conflict.

• Do nothing. In this case, the hotlink property availability and value will be used in the hotlinked elements, 

and those of the source file will be used in the source file’s elements. 

– Exception: If the properties differ only in their data type, then the host project property’s data type will 

prevail. (The hotlinked element’s property will be converted to use the data type of the host project 

property).

Watch the Video
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Export/Import Properties Between Projects

Use the buttons at the bottom of Options > Property Manager to export and import a project’s Property set 

(either all properties or just selected ones) between ARCHICAD Projects, from either an XML file or an 

ARCHICAD file.

Exported data includes the Property Name, Group name, type, default value, and availability. A property’s 

defined Option Set, if any, is also exported.

Export Properties

1. Select any properties or groups in Property Manager. 

2. Click the Export button.
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3. Set preferred options in the dialog box:

Include Classifications

Check this to export Classifications as well as Properties.

Choose a preferred export option:

• All from Project: Export all Classification Systems.

• Linked to Exported Properties: Export only those Systems having available properties among the 

properties you are exporting. 

4. Click OK.

Import Properties

1. In Property Manager, click the Import button.

2. In the Open file dialog box, browse for the XML file or ARCHICAD file that contains the properties you 

need, then click OK.

3. Set preferred options in the dialog box:

Include Classifications

• All from Project: Import all Classification Systems.

• Linked to Exported Properties: Import only those Systems having available properties among the 

properties you are importing. 
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4. Click OK.

If the imported properties, Classifications and/or Classification Systems already exist in the target project, a 

dialog box gives you a choice for how to handle them:

Duplicate Properties: If you choose Append, the duplicate properties are imported with a suffix added to 

their name.

Duplicate Classifications Systems: If you choose Merge, then incoming Classifications that do not yet exist 

in the project are added to the project. In case of duplicate Classifications, a dialog box again gives you a 

choice for how to handle them.

Import BIM Content

Property definitions are also imported to your project if you use the Import BIM Content or Download BIM 

Content commands.

See Import BIM Content.
ARCHICAD 24 Reference Guide 1568



Properties and Classification Systems Elements of the Virtual Building
Classification Manager

Use Classification Manager (Options > Classification Manager)

• To create and manage the Classification Systems and Classifications for this project

• To customize the set of properties available to each Classification

Classification Manager is also available from Property Manager.

The left side of the Classification Manager lists all the Classifications available in the project. 

Search List

Click the Search icon, then start typing text into the search field. All classifications containing the search term 

are shown.

To view the full list again, delete the text from the Search field, or click the tree hierarchy icon.
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Create New Classification

1. Open the Classification Manager dialog box at Options > Classification Manager, or from Property 

Manager.

2. Select an item in the Classification list: the new classification will be created subordinate to the selected 

item.

3. Do one of the following:

– Click anywhere in the Classification list and use the context menu

– Click the New button at the bottom of the dialog box

– Choose the hierarchical level of the new Classification, relative to what is selected in the tree: 

- New Classification adds it to the bottom of the tree list within the current System

- New Classification in Branch adds it to the currently selected level of the tree

- New Classification System adds the new System to the bottom of the tree

4. In the New Classification dialog box:

– Define an ID, Name, and optional Description for the new Classification.

5. Click OK to create the new Classification.

Watch the Video
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Duplicate Classification or System

Select a Classification (or System) from the list in Classification Manager.

From the context menu or drop-down list under the New button, click Duplicate to create a duplicate, then 

adjust its settings.

Available Properties

Use these controls to define which properties should be available for a given Classification.

• Select one or more Classifications from the list on the left.

• All: All properties in the project are available for the selected classification(s).

• None: No properties are available for the selected classification(s).

• Custom: Click Custom, then click Edit to select the Properties to be available for the selected 

classification(s).
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See also Transfer Availability.

Import/Export Classifications

Use the buttons at the bottom of Options > Classification Manager to export and import a project’s set of 

Classifications (either all classifications or just selected ones) between ARCHICAD Projects, from either an 

XML file or an ARCHICAD file.

The process and options are analogous to Import/Export Properties.

See Export/Import Properties Between Projects.

Import BIM Content

Classifications, with associated Property and IFC Mapping definitions, are also imported to your project if you 

use the Import BIM Content or Download BIM Content commands.

See Import BIM Content.
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Views of the Virtual Building

This section of the ARCHICAD Reference Guide explains the different model views of the Virtual Building: e.g. 

Sections, 3D views, schedule views. The guide explains how to instantly create the desired view, and how to 

control which elements will appear in the view and with which effects.

On-Screen View options let you toggle certain screen-only aids on and off.

The Renovation feature lets you control element display from the point of view of their status in a renovation 

project. Finally, use the Graphic Overrides feature to convey view-by-view information at a glance.

ARCHICAD Model Views

Model View Options

On-Screen View Options

Partial Structure Display

Renovation

Graphic Overrides

For information on managing the Navigator View Map:

See Navigator View Map.
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ARCHICAD Model Views

You can approach the Virtual Building model from several different model views. Model views have two main 

uses. First, you will work in model views to modify the Virtual Building. Second, saved model views are the 

basis for creating architectural drawings (placed onto Layouts) for the final documentation of the Virtual 

Building.

Related Topics:

Model View Options

Floor Plan Window

Stories

Floor Plan Cut Plane (Global Setting)

Element Display in Floor Plan and Section

3D Window

Sections

Elevations

Interior Elevations (IE)

3D Document

Details

Worksheets

Managing Markers in ARCHICAD

Interactive Schedule

Project Indexes

For information on managing the Navigator View Map:

See Navigator View Map.
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Floor Plan Window

The Floor Plan Window is the basic construction area where most editing operations take place. It shows a 

representation of the current project as a traditional architectural drawing. When you start ARCHICAD, the 

first window you see is the Floor Plan. Each story of the Virtual Building has its own Floor Plan.

ARCHICAD gives you the freedom to replicate 3D-like aspects of construction elements in the Floor Plan 

window, using Cut Plane settings and element-level display and projection options. These options let you 

visualize parts of multi-story elements that are located on a different floor plan, or to project parts of the 

element that are above or below the cut plane.

See the sections below for how these options work.

The visibility and accessibility of elements on the Floor Plan depends on:

• chosen options in the element’s Tool Settings dialog box, including multi-story display and projection 

settings;

• the Floor Plan Cut Plane;

• Layer Settings (elements on invisible layers will not be displayed; elements on locked layers cannot be 

edited).

Modifications to the model in the Floor Plan window will be updated accordingly in the 3D, Detail/Worksheet 

and Section/Elevation/IE and 3D Document windows. The converse is also true: changes made in other 

windows are automatically displayed on the Floor Plan when activated. The updates can take place either 

manually or automatically depending on the Detail or Section/Elevation/IE update settings you choose.

For more information, see Updating Sections and Updating the Detail Window.
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Stories

Stories in ARCHICAD, just as in real buildings, serve to divide space vertically and replicate the story structure 

of your real building.

Related Topics:

About Stories

Home Story

Define Top Link for Wall, Column, Zone or Stair

Show On Stories

Navigate Among Stories

Defining Story Display in 3D

Defining Story Display in Section/Elevation/IE

Create or Delete or Rename Stories

Story Settings Dialog Box

Story Level Lines

Edit Elements by Stories Dialog Box
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About Stories

Story names and levels are defined in Story Settings.

See Story Settings Dialog Box.

Each story in the project is listed:

• in the Navigator’s Project Map 

• in the Tab bar’s pop-up Navigator 

• in the Tab bar’s Floor Plan context menu

The elevation of new construction elements placed on the Floor Plan are calculated relative to the element’s 

Home Story. Some elements (Wall, Column, Zone) can also be top linked to any story in the project.

For more information, see Home Story and Define Top Link for Wall, Column, Zone or Stair.
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Navigate Among Stories

To navigate among stories, do one of the following: 

• In the Tab bar, click the context menu of the Floor Plan to access a list of stories

• In the Tab bar, use the Project Map of the pop-up Navigator (at the right edge of the Tab bar)

• In the Navigator Project Map, double-click the Story you wish to open

• Activate a story from the Story Settings dialog box (Design > Story Settings, or right-click any story from 

the Project Map): click on its name, then click OK to close the dialog box and display the selected story on 

the Floor Plan

• Use predefined keyboard shortcuts to jump among stories

• Use the Mini-Navigator Toolbar

Story Shortcuts in Mini-Navigator Toolbar

Use the story shortcuts located in the predefined “Mini-Navigator” toolbar.

If you attempt to go to a story that does not exist, the Create New Story dialog box appears.

See Create or Delete or Rename Stories.

 Go To Story: Jump directly to an existing Story by entering a Story number.
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Defining Story Display in 3D

In the 3D window, all Stories are projected by default, but you can limit the projection using the Stories to 

Show in 3D controls at View > Elements in 3D View > Filter and Cut Elements in 3D. 

See Filter and Cut Elements in 3D Dialog Box.
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Defining Story Display in Section/Elevation/IE

In Section/Elevation/IE views, you define a vertical range that can include entire Stories or only parts of them. 

Also, Story Level Lines can be optionally displayed in these views.

Horizontal/Vertical Range of Section Viewpoint

Show/Hide Story Level Lines in Section/Elevation/IE
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Create or Delete or Rename Stories

Use Story Settings (Design > Story Settings) to create and delete stories.

See Story Settings Dialog Box.

Story Settings (and some story-related commands) are also available:

• in the Tab bar’s Floor Plan context menu

• from the context menu if you have selected a Story in the Navigator’s Project Map or View Map

• from the Mini-Navigator Toolbar

See Story Shortcuts in Mini-Navigator Toolbar.

Delete a Story

Use the Navigator or Story Settings (as described above) to delete one or more stories. 

Warning: If you delete a Story, all elements that had that story as their Home Story will also be deleted!

Warning: The undo queue is cleared entirely whenever you delete or add a story, or change story height.

Create a New Story

1. Go to Design > Story Settings.

2. Click “Insert Above” or “Insert Below” to insert a new story above or below the story name selected in the 

dialog box list.
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3. Click OK. The new story appears above or below the selected story. The numbering is automatically 

updated.

See also Update of Story Level Dimensions.

There is no limit to the number of stories.

See also Story Settings Dialog Box.

Warning: The undo queue is cleared entirely whenever you delete or add a story, or change story height.

Alternatively:

1. Select a Story in the Navigator’s Project Map.

2. Use the context menu’s “Create New Story” command.

Rename a Story

1. Go to Design > Story Settings.

2. Click the name of the story you wish to rename, and type the new name.

Alternatively:

1. Right-click the story name in the Navigator, and choose the Rename Story command.

Copy/Move Elements Between Stories

When creating a new Story, you may wish to copy elements onto it which already exist on another Story.

Go to 

• Design > Edit Elements by Stories, or

• Edit > Move > Edit Elements by Stories

For more information, see Edit Elements by Stories Dialog Box.
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Story Level Lines

Story Level Lines indicate the vertical location of stories in Sections, Elevations and Interior Elevations. Their 

values are defined at Design > Story Settings.

See Story Settings Dialog Box.

Story Levels can be set to appear in Section/Elevation/IE views. In this case, each story level line included in 

the Section/Elevation/IE range will appear in the window.

You can place associative dimensions onto Story Level Lines. 

The story line markers are library parts. The Story Marker parameters and position can be edited in Section/

Elevation/IE Settings dialog boxes.

For more information, see Story Levels Panel.

Show/Hide Story Level Lines in Section/Elevation/IE

For each individual Section/Elevation/Interior Elevation, you can hide, show and/or output Story Level Lines 

and their markers.

To set these options, open the Section/Elevation/IE Settings Dialog box, go to the Story Levels panel, and use 

the “Show Story Levels” pop-up.

See Story Levels Panel.

Show/Hide Story Level Lines Throughout the Project

For any story, it is possible to turn off level line display throughout the project (in every Section/Elevation/IE 

view). 

Go to Design > Story Settings, and for any selected story, uncheck the “Story Level Line” box. This story’s 

level line will henceforth not appear in any model window in the project.
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Any associative dimensions of the Story Level Line will be deleted.

Dimension Story Level Lines

You can place associative Dimensions on Story Level Lines.

For example, use the Elevation type of the Linear Dimension tool.

• Dimension a Single Story Level Line

Click on a Story Level Line endpoint, then double-click to place the dimensions.
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• Dimension All Story Level Lines

Click on the Story Level Line itself, then double-click to place the dimensions.

Display of Story Level Dimensions

If you turn off Story Level display (in Section/Elevation Settings), the Dimensions remain in place.

Update of Story Level Dimensions

If you delete a Story, its Story Level Dimension is also deleted. The rest of the Story Level dimensions are 

updated automatically.

If you modify a Story height, the rest of the Story Level dimensions are updated automatically.

However, If you insert a new Story, you must place its Story Level dimension manually. 

Edit Story Levels

You can edit the elevation of any given story or set of stories using Story Editing Mode:

1. Choose the Design > Edit Story Levels command, or the same command from the context menu that 

appears by right-clicking inside the Section window.

2. The Story Editing Mode palette appears. As long as the palette remains open on screen, you are in Story 

Editing mode and can move the story level lines.
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3. Choose a mode from this palette by clicking one of the four buttons:

• Adjust only the selected story

• Adjust the selected story and all stories below

• Adjust the selected story and all stories above

• Adjust all stories

4. Move the cursor onto the Story Level Line you wish to move. The cursor will assume the Mercedes shape. 

Click and drag the story level line to edit its elevation.

5. Click OK to apply changes and exit Story Editing Mode. Associative elevation markers will be updated too.

The elements that are on the given stories will retain their elevation respective to their Home Story, as you will 

see when the view is updated after you click OK.
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Floor Plan Cut Plane (Global Setting)

3D construction elements on the Floor Plan (Walls, Curtain Walls, Columns, Beams and Roofs) are displayed 

as if they were cut horizontally along a theoretical plane; this is the Floor Plan Cut Plane.

The default height of the Cut Plane, measured from the base of the current story, depends on local 

architectural conventions, but you can set any Floor Plan Cut Plane for the current window using the Floor 

Plan Cut Plane dialog box.

To set the Cut Plane, go to Document > Floor Plan Cut Plane

See also Floor Plan Cut Plane Settings Dialog Box.

Note: The Cut Plane does not affect the display of Mesh, Slab or Object elements. However, GDL Objects 

can be programmed to display themselves according to the Floor Plan Cut Plane Settings.

Enter a value for “Cut Plane Height to Current Story.”

If you wish to display all construction elements in their entirety, on all stories (the default settings for 

construction elements), the rest of the settings in the Floor Plan Cut Plane dialog box are not relevant.

The Relative Floor Plan Range and Absolute Display Limit - the other Floor Plan Cut Plane Settings - are only 

relevant if any of your construction elements are defined as having a limited projection.

The Floor Plan Cut Plane settings are global; the current settings apply to all the stories of the project. Once 

you set the global Floor Plan Cut Plane, you can further fine-tune the Floor Plan display of individual 

construction elements (Walls, Columns, Beams and Roofs only) in their element Settings dialog boxes.

For more information, see Element Display in Floor Plan and Section.
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Set Separate Floor Plan Cut Planes in Different Views

For every view, you can define a unique Floor Plan Cut Plane, if required, using the Floor Plan Cut Plane 

controls accessible from View Settings.
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Element Display in Floor Plan and Section

Relevant for Wall, Beam, Column, Slab, Roof, Shell, Morph, Mesh.

Use the Floor Plan Display settings in each element’s Tool Settings Dialog Box.

Show On Stories

Floor Plan Display (Element Settings)

Show Projection

Cut Surfaces and Outlines (Element Settings)

For specifics on other elements, see: 

Floor Plan Display of Doors/Windows

Floor Plan/Reflected Ceiling Plan Display (Stair Settings)
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Show On Stories

Relevant for Wall, Slab, Roof, Shell, Morph, Mesh, Beam, Column.

Use the Show on Stories pop-up in the Floor Plan and Section Panel of Tool Settings to control the display 

of construction elements by story. 

The available options differ by element.

All Relevant Stories

The element will be shown and editable on all stories which it physically intersects. When available, this will be 

your preferred option most of the time.

All Stories

The element outline - regardless of its actual location - will be shown on every story of the project.

Home Story Only

The element will be shown only on its Home Story. (If the element is drawn so that it does not physically 

intersect its Home Story, then the only way the element will be shown on the Floor Plan is if you set its Floor 

Plan Display to one of the symbolic options: Symbolic Cut, Outlines only, Overhead all.)

See Home Story.

Home story plus one story up and/or down

One Story Up/One Story Down

Beams, Columns and Objects have a unique display option: One Story up and One Story Down. This way, 

you can opt to not display these elements on their Home Story at all.

Custom

Choose this option to set separate display combinations for the element’s outline and fill in Show on Stories: 

Custom Settings. Once you set these Custom Settings, use the Edit Custom option to edit them.
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Floor Plan Display (Element Settings)

Relevant for Wall, Beam, Column, Roof, Shell, Morph.

Use the Floor Plan Display pop-up from the Floor Plan & Section panel of the element’s Tool Settings dialog 

box.

Options vary depending on the element.

Projected with Overhead

Shows cut part of element’s 3D model (e.g., as cut at the level of the Floor Plan Cut Plane), plus the element’s 

overhead part (i.e. the part of the element that is above the Floor Plan Cut Plane), plus its uncut (downward) 

part.

Note: “Projected with Overhead” is the default display setting for slanted or complex columns and walls, 

and for all roofs and beams.

Projected

Shows cut part of element’s 3D model, plus its uncut (downward) part.

If you choose either of these “projected” options (Projected with Overhead or Projected), you can then further 

define the extent of the projection, using the Show Projection options.

For more information, see Show Projection.

Cut Only

Displays only the cut part, as cut with the Floor Plan Cut Plane. (Available for construction elements; not 

available for windows or doors.)

Some additional abstract display options are available:

Symbolic Cut

(Available only for simple straight walls, Openings, and for vertical or complex columns.) 

The whole floor plan projection will be displayed as cut, using their cut line and cut fill attributes, regardless of 

the elements’ vertical position. 

This option is available only if the Show on Story control is set to Home Story only. The Floor Plan Cut Plane 

settings do not affect the display of these elements.
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Outlines Only

The entire element’s outline is shown using its uncut attributes. (Uncut attributes are set for each element 

using the “Outline” controls of the Floor Plan and Section panel of its Settings dialog box.)

Overhead All

The entire element’s outline is shown using its overhead attributes. (Overhead attributes are set for each 

element using the “Outline” controls of the Floor Plan and Section panel of its Settings dialog box.)
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Show Projection

Relevant for Wall, Beam, Column, Roof, Shell, Morph.

The Show Projection pop-up provides options for setting the range within which an element should be 

displayed. 

This control is only available if the element’s Floor Plan Display is set to either “Projected” or “Projected with 

Overhead.” 

Exception: For Morph elements, Show Projection options are available regardless of the Floor Plan 

Display.

Entire Element

The entire projection will be displayed on the applicable stories.

However, you may prefer not to show the entire element.

In this case, you have two other ways to set its display in the Show Projection pop-up:

To Floor Plan Range

Show the element on a range of stories (the current story, plus a given number of stories above and below it, 

and an optional offset.)

This element will be shown on the stories defined as the Relative Floor Plan Range (i.e. the number of stories 

on which to show this element in either direction) in Document > Floor Plan Cut Plane.

By Absolute Display Limit

Set a fixed lower limit (by default, this is Project Zero), then show all parts of the element above this limit.

The Absolute Display Limit option enables you to ensure that the Floor Plan will never display any part of the 

model that falls below the level you define here in absolute terms (independent of story levels). 

For example, you can enter the level of the terrain or the water level, so that anything below this level is not 

shown on the Floor Plan. Or, if you want to show a rooftop terrace without displaying the garage below it, 

enter the terrace level as the Absolute Display Limit.
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If you choose this option, then the Absolute Display Limit set in Floor Plan Cut Plane Settings determines this 

element’s lower display limit.

In certain situations, the current Floor Plan Cut Plane and Relative Floor Plan Range settings may conflict:

• The Cut Plane level may be outside the current Floor Plan Range (e.g. an extremely small story height as 

compared to the default Cut Plane level). In this case, the Cut Plane will be automatically relocated to the 

upper limit of the Floor Plan Range (or to its lower limit, if the Cut Plane would fall below the lower limit).

• The lower Floor Plan Range limit may be higher than the upper limit. In this case, the lower limit will be 

considered as both the lower and upper limit of the Floor Plan Range (which will also equals the Cut Plane 

level, as described above.)
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Cut Surfaces and Outlines (Element Settings)

Relevant for Wall, Slab, Roof, Shell, Morph, Mesh, Beam, Column.

Cut Surfaces

Set the attributes displayed for cut surfaces both in Section and on the Floor Plan.

• For a basic element:

◦ Define the cut line and pen

• For a basic, composite or complex profile element:

◦ If needed, override the fill foreground/background pens of this element (defined by default in the 

Building Material). To do this, choose Foreground, Background or Both from the Override Cut Fill 

Pens pop-up to access the respective controls.

Outlines

Use these settings to define lines and pen colors to element outlines that fall above (Overhead) and/or below 

(Uncut) the Floor Plan Cut Plane. 

• Overhead Lines will be displayed if the Floor Plan Display pop-up is set to “Projected with Overhead” or 

“Overhead All”.

• Uncut Lines will be displayed if the Floor Plan Display pop-up is set to “Projected” or “Outlines Only.”
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3D Window

The 3D window displays your model in real perspective or axonometry: this gives the best overall view of what 

the final building will really look like, inside and out.

In the 3D window, you can directly edit your model, and create new construction elements, in either 

perspective or parallel view, using any of the construction tools.

The 3D window is directly linked to the Floor Plan and to the Section/Elevation/IE windows: any changes 

made on the Floor Plan or in a Section/Elevation/IE window will be visible in the 3D window and vice versa.

3D Documents can be derived from either a 3D Window source or the Floor Plan. If you change the 

projection, the cutting planes, the zoom level or the selected/marqueed/filtered items of the 3D source 

window, you can redefine the 3D Document accordingly.

Special navigation techniques in the 3D Window let you explore the model much more freely than in other 

windows.

The 3D display of individual construction elements is controlled by the options of the Model panel in their 

Settings Dialog box.

General settings affecting the parameters for displaying the 3D window are in 3D Styles.

The commands that affect the set of elements displayed in 3D are in the View > Elements in 3D View and the 

View > 3D View Options hierarchical menus.

These commands are also accessible in the 3D Visualization toolbar.

Open the 3D Window

To open or activate the 3D window, do one of the following:

• press the F3 key

• use the Window > 3D Window command

• press the 3D window control on the 3D Visualization toolbar or the Mini-Navigator toolbar

• use context menu commands from right-clicking on blank space in the current window:

Show All in 3D

To show the entire model in 3D, regardless of any current selection, use the View > Elements in 3D View > 

Show All option; or use the same command from the context menu.

This command’s shortcut is Ctrl + F5.
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The full model display resulting from the Show All command may be limited by filtering criteria in the Filter 

and Cut Elements in 3D dialog box.

See Filter and Cut Elements in 3D Dialog Box.

Default Display in 3D

If you simply switch to the 3D window, without using any specific 3D display command, the 3D window will 

display the contents last shown in the 3D window, irrespective of what might be selected in any other window.

Related Topics

Show Selection/Marquee in 3D

Filter and Cut Elements in 3D Dialog Box

Save Contents of 3D Window as a View

3D Engines

3D Styles

3D Projections

Navigation in the 3D Window

3D Navigation Extras

3D Cutting Planes

Editing Plane in 3D Window
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Show Selection/Marquee in 3D

For a 3D display of only the items selected explicitly or by Marquee:

• Right-click to access the Show Selection/Marquee in 3D command; or

• Use View > Elements in 3D View > Show Selection/Marquee in 3D

(Or use the 3D Visualization toolbar control for this command.)

If your plan includes both explicitly selected elements and a marquee selection, this command will disregard 

the marquee and show only the explicitly selected elements.

Show Selection/Marquee in 3D also works if you are already in the 3D Window and make an explicit 

selection there, then execute the Show Selection command. The caption of the 3D Window will include the 

“Selection” mention and the name of the Home Story of the selected element(s).

If the 3D Window’s content is based on explicit selection and you add elements to it, these will be preserved in 

the 3D Window as long as you continue to work in it.

Show Stored Selection in 3D

Do one of the following to display the last 3D view generated by the Show Selection/Marquee command:

• Right-click to access the Show Stored Selection in 3D command; or

• Use View > Elements in 3D View > Show Stored Selection in 3D

(Or use the 3D Visualization toolbar control for this command.)
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Marquee Area in 3D

If the selection is a Marquee area, the caption of the 3D Window will include the “Marquee” mention.

For more information on defining a marquee area, see Marquee Area.

By default, elements inside the Marquee are displayed in 3D.

To change this, use the Marquee Effect controls in View > Elements in 3D View > Filter and Cut Elements 

in 3D.

See Filter and Cut Elements in 3D Dialog Box.

Elements in a Marqueed 3D Window

If you create an element in the 3D Window which is delimited by a marquee, the new element will only appear 

in the 3D Window if you draw it inside the marquee area.

If you place a new element outside the boundaries of a Marquee-based 3D view, or drag an existing element 

outside the Marquee boundaries, that element will disappear immediately from the 3D Window.

When you go to the Floor Plan, however, you will see the elements. Change your marquee area (or remove it) 

and return to the 3D Window to check it.

If you select one or more elements in a trimmed 3D view, resulting from either a Marquee area or a 3D 

Cutaway, some elements will be only partially visible, but selection dots of the whole element will be displayed 

and all the nodes and edges can be found with the cursor.
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Save Contents of 3D Window as a View

If you save the contents of your 3D window as a view, the 3D Only panel of its View Settings dialog box will 

provide feedback on whether that view is a result of a filter or a marquee selection.

3D view settings include: 3D projection settings (including zooming), filter elements in 3D, 3D Styles, 3D 

cutting planes, 3D cutaway and photo rendering settings.

If you change any of these settings in the 3D window, then use the 3D Only panel of View Settings to redefine 

the view accordingly: check Redefine Image Settings with current.
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3D Engines

3D Engines are built-in configurations which control the generation of the 3D model in ARCHICAD. By default, 

two engines are offered:

• Vectorial Engine

• OpenGL Engine

To choose an engine, go to View > 3D View Options > 3D Styles.

The choice of engine affects the 3D display effects available, and thus the appearance of the model in 3D. Set 

up your 3D display preferences in the 3D Styles dialog box.

See 3D Styles.
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3D Projections

ARCHICAD can display parallel (axonometric) projections and perspectives.

Axonometric projections automatically show the entire model in the center of your view. Perspectives are 

defined by a viewpoint and a specific target.

When the 3D window is active, the 3D Navigator Preview Palette contains a miniature representation of the 

entire project view. This allows you a quick way to modify your 3D Projection Settings, whether perspective or 

parallel (axonometric); you can adjust the view cone or change the axonometry while retaining an overview of 

the whole project.

See Navigator Preview (3D).

3D Projection Settings

To open these settings, do one of the following:

• Use the context menu from the 3D window or the tab bar

• Use the 3D Visualization or Simple 3D toolbars

• Use the commands of the View > 3D View Options menu

The name and contents of the dialog box depend on the projection type:

• Parallel Projection Settings or

• Perspective Projection Settings.

You can easily switch from one settings dialog to the other with the button at the top right corner of Projection 

Settings.
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How to Switch Between Axonometric and Perspective Views

Do one of the following:

• Use the tab bar of the 3D window

• Predefined shortcuts: 

Ctrl+F3 = Axonometry

Shift+F3 = Perspective

• Commands available from View > 3D View Options:

• 3D Visualization toolbar:

• Mini-Navigator toolbar
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• Navigator:

How to Store a 3D Projection

To store projections that you set up in the 3D Window, you can:

• Use the usual Save View commands from the context menu of the Navigator or tab bar. This will create a 

view (perspective or axonometric) based on the currently set up projection in the 3D window. The new 

view will be added to your Navigator View Map.

• Add the current perspective to your Project Map, using the View > 3D Navigation Extras > Place a 

Camera into the path command. A camera capturing the current perspective will also appear on the 

Floor Plan.

See also Cameras.

• Add the current axonometric (parallel) projection to the series of Pre-Set views, using the View > 3D 

Navigation Extras > Add Current Projection command.

See also Pre-Set Projections and 3D Navigation Extras.
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3D Navigation Extras

Other controls useful in modifying the 3D view are available from the View > 3D Navigation Extras (or a 

toolbar containing 3D window commands). These controls allow you to:

• Interactively set the target point for the perspective (Look to).

• Click on a surface to switch to a view perpendicular to the clicked point (Look to Perpendicular of 

Clicked Surface).

Note: When using this command in a parallel projection (axonometry), ARCHICAD defines the new 

projection based on your click (direction) and the previous view rectangle (extent of projection plane). If 

this produces unexpected results, redefine the view rectangle (e.g. with Fit in Window), then try again.

• Reset the roll angle to zero to rapidly return from a bizarre view obtained during navigation (Reset Roll 

Angle).

• Return with a single command to a horizontal view of the model (Horizontal View).

• Edit pre-set projections and Add current projection: These commands are available if you are viewing 

an axonometric (parallel) projection.

• Put a camera into the path (for perspectives). This command adds the current perspective to the Project 

Map, if no camera is selected on the Floor Plan. If you have cameras on the Floor Plan already that define 

an animation path, the new camera will be added after the active camera in the active path, which is 

marked by its view cone on the Floor Plan.

If you are in perspective view, with a camera selected, the following commands are also available from View > 

3D Navigation Extras:

Note: As you use these commands to change the camera selection, the selected item in the Navigator 

Project Map also changes accordingly.

• Go to the previous/Go to the next: Use these commands to navigate to the perspective views of the 

previous and next cameras in the active path, and to select the camera.

• Modify the selected: The selected camera will be updated to reflect the perspective view that you 

currently see in the 3D window. Use this when you have changed the view in the 3D window.

• Revert view to the selected: Discards all changes you made manually and shows the 3D model as the 

selected camera sees it.

• Insert a new camera after the selected one: A new camera is added to the path to define the current 

perspective view, and will be selected.

Related Topics:

Navigation in the 3D Window

Cameras

Pre-Set Projections

Classic 3D Navigation Toolbar
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3D Cutting Planes

3D Cutaway is an imaging mode in ARCHICAD that allows flexible visualization of building spaces.

3D Cutaway works by applying Cutting Planes to the model (Floor Plan, Section, or 3D window).

 

The 3D Cutaways you define are stored within the project, so you can see them when opening the project in a 

future session. You can apply up to 9 Cutting Planes at a time.

3D Cutaways are saved with views, so if you wish to keep Cutting Planes over the long term, save a 3D view.

To see the cutaway view of your model, turn on Show 3D Cutaway. To see the full model, turn it off.

Related Topics:

Show or Hide 3D Cutaway

Create a 3D Cutaway on the Floor Plan or Section

Create a 3D Cutaway in the 3D Window

Edit Cutaway

3D Cutaway Attributes

Hide 3D Cutting Planes

Delete Cutting Planes
ARCHICAD 24 Reference Guide 1606



ARCHICAD Model Views Views of the Virtual Building
Show or Hide 3D Cutaway

Do one of the following:

• Click the 3D Cutaway toggle on the Standard Toolbar.

• Use the following toggle command: View > Elements in 3D View > 3D Cutaway

When 3D Cutaway is on (show), you see the cutaway view of your model, plus the 3D Cutaway interface. 

When it is off, you see the full model.
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Create a 3D Cutaway on the Floor Plan or Section

1. Make sure 3D Cutaway is On.

See Show or Hide 3D Cutaway.

2. The window will display Cutting Planes handles on all four sides of the screen.

3. Click and drag one or more tabs to the desired location. By default, you will drag the Cutting Plane 

orthogonally.

4. Click to place the Cutting Plane at the desired location.

To cancel the operation: Note that the tabs on all four sides change into garbage cans: if you change 

your mind while dragging, just move the Cutting Plane back into one of the garbage cans (or press Esc) to 

cancel the operation.
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5. View the resulting 3D Cutaway.

To hide the Cutting Plane:

See Hide 3D Cutting Planes.

Use Section Line as Cutting Plane

It may be convenient to use an existing Section as the basis for your 3D Cutaway.

Select the Section line, and choose Create Cutting Plane Here.

The Cutting Plane coincides with the Section Line, but is independent of it. You can now move and edit the 

Cutting Plane if needed; the Section remains unchanged.

Create Custom Cutting Plane on Floor Plan or Section

If you wish to cut the model from a different direction than the predefined orthogonal directions, create a 

custom Cutting Plane.

1. From any of the four Cutting Plane tabs, click to bring up the context menu.

2. Choose Create Custom Cutting Plane.

Note: This command is also available from the Standard Toolbar.
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3. Click twice to define the cutting line.

4. Click on the cutting line, then drag it to the desired location to create the Cutaway.

5. View the resulting 3D Cutaway.

Watch the Video
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Create a 3D Cutaway in the 3D Window

1. Make sure 3D Cutaway is On.

See Show or Hide 3D Cutaway.

2. The window will display Cutting Planes tabs on all four sides of the screen.

3. Hover over any of the tabs to see the orthogonal Cutting Plane in that position.
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4. As soon as you click one of the tabs, you will see the model’s bounding box. The predefined Cutting 

Planes will cut the model on planes that are parallel to this bounding box.

5. Drag the tab to cut the 3D model orthogonally.

See also Create Custom Cutting Plane in 3D Window.

To cancel the operation: Note that the tabs on all four sides change into garbage cans: if you change 

your mind while dragging, just drag the Cutting Plane into one of the garbage cans (or press Esc) to 

cancel the operation.
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6. Click when the Cutting Plane is in the right place. The Finalize floating command appears.

7. Click Finalize, or Cancel to undo the operation.

8. View the resulting 3D Cutaway.

To hide the Cutting Plane:

See Hide 3D Cutting Planes.

Create Custom Cutting Plane in 3D Window

If you wish to cut the model from a different direction than the predefined orthogonal directions, you can 

create a custom Cutting Plane.

Make sure 3D Cutaway is On.

1. From any of the four Cutting Plane tabs, click to bring up the context menu.

2. Choose Create Custom Cutting Plane.

Note: This command is also available from the Standard Toolbar.
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3. Define the custom Cutting Plane orientation by doing one of the following:

• Use an element’s plane (e.g. a Roof top plane)

– Click on the plane surface of an existing element to define the Cutting Plane angle. A rectangle will 

help you see the plane.

– Click again to define the Cutting Plane position

• Use an edge as a rotation axis of the plane

– Click on an existing edge with the Mercedes cursor, to define the rotation axis

– Click on any point that the Cutting Plane should touch; this defines the Cutting Plane position

• Click on any three points (such as three element hotspots) to define a plane

– Click on two points to define the rotation axis

– Click on any point that the Cutting Plane should touch; this defines the Cutting Plane position

4. Click when the Cutting Plane is in the right place. The Finalize floating command appears. Click Finalize 

if you are satisfied with the Cutting Plane.

5. View the resulting 3D Cutaway.

Watch the Video
ARCHICAD 24 Reference Guide 1614

https://youtu.be/LSDmESzbdAs


ARCHICAD Model Views Views of the Virtual Building
Edit Cutaway

Once you have created a 3D Cutaway, you can still edit it at any time. 

Make sure 3D Cutaway is activated, and Show Cutting Planes is on.

See Show or Hide 3D Cutaway.

Offset Cutting Plane

Grab the plane (click on any of its edges) and offset it to the desired location. Click to place, then click 

Finalize.

Note: After the initial offset, before you click Finalize, you can click anywhere on the plane surface to 

adjust the offset further.

Rotate Cutting Plane

Right-click the edge of a Cutting Plane. Choose Rotate Cutting Plane from the context menu.

Then rotate the plane as you would other elements.

See Rotating Elements.

Watch the Video
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Reverse Cutting Plane Direction

Right-click the edge of a Cutting Plane. Choose Reverse Cutting Plane Direction from the context menu.

The Cutaway is now created on the opposite side of the selected Cutting Plane.
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3D Cutaway Attributes

Use the Cut Surface Display controls in the following dialog box:

View > Elements in 3D View > Filter and Cut Elements in 3D
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Hide 3D Cutting Planes

Do one of the following: 

• Right-click the Cutting Plane to bring up its context menu, and deactivate the Show Cutting Planes 

toggle 

• Deactivate the Show Cutting Planes toggle from the drop-down 3D Cutaway menu of the Standard 

toolbar.

The 3D Cutaway is in effect, but the Cutting Plane and the tabs are hidden, except for the tab at the top of the 

screen.

To show the Cutting Planes again, click the toggle command or the eye icon at the top of the screen.
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Delete Cutting Planes

At any time, with 3D Cutaway on, grab an existing Cutting Plane or line and drag it into the nearest garbage 

can to delete it.

To delete all Cutting Planes, use the Delete All Cutting Planes command from the Standard toolbar

or from View > Elements in 3D View > 3D Cutting Planes.

Watch the Video
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3D Window Size

Use the controls at Set Window Size:

• from the 3D Window context menu

• from the 3D Window tab context menu

Enter the horizontal and vertical size of the 3D Window in pixels (maximum 16,000)

Click the Chain icon to keep the proportion locked.
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Sections

Use the Section tool to generate a sectional viewpoint of the Virtual Building, with an accompanying marker. 

The Section marker can take one of three different forms:

1. a source marker, which generates a section viewpoint

2. a linked marker, which does not generate a section viewpoint, but acts as a reference to any other view, 

viewpoint or drawing.

3. an unlinked marker containing custom text

Note: Another type of Section viewpoint is the Independent Section (with or without a marker), having no 

model source.

See Create an Independent Section Viewpoint.

Sections can be saved as Views and placed on a Layout as Drawings; the contents of a Section window can 

also be published directly.

In the Section window, you can view and modify elements but you cannot create new construction elements. 

(The only exception is if you use the “Drag a copy” or Multiply command.) If you paste an element into a 

Section window, it will be reproduced as drawing primitives (points, lines, fills).

Objects can be placed in a Section window, but they are considered as graphic symbols only. (No 

corresponding 3D model element is generated.)

Related Topics:

Create a Section Viewpoint

Open a Section Viewpoint

Horizontal/Vertical Range of Section Viewpoint

Define Marker Reference for Source Marker

Floor Plan Display of Section Markers

Model Display in the Section Window

Editing Section/Elevation/IE Lines on Floor Plan

Place a Linked Section Marker

Place Unlinked Marker

Create an Independent Section Viewpoint
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Assign Section Rebuild Status

Updating Sections

Summary of Rebuild Commands
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Create a Section Viewpoint

Note: The creation process is identical for Elevations.

1. Activate the Section tool.

2. In the Info Box or Section Default Settings, make sure that “Create new section viewpoint” is selected.

3. Choose an input method (either Single or Staggered) from the Info Box and draw a Section line on the 

Floor Plan.

• Single: Click twice to define each end of the line.

• Staggered: Click as many times as needed to define each segment of the Section line. Double-click to 

complete the input line.

The Eyeball cursor appears.

4. With the eyeball cursor, click on either side of the line to set the orientation of the Section. The place 

where you click also defines the Section’s limit line, if you have chosen a “Limited” horizontal range in 

Section Tool Settings.

5. The new Section source Marker is automatically placed after the section line is completed. (If you are 

placing a Section of limited horizontal range, the limit line is also placed automatically.) 

6. A new Section viewpoint is created and listed in the Navigator Project Map.

Distant Area Limit

Check the Marked Distant Area box in Section Settings (Model Display Panel) to create an optional “distant” 

area of your Section viewpoint, with separate colors/effects. The Distant Area limit line is then displayed as 

part of your Section, and is editable.

See Model Display Panel.
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Related Topics

Open a Section Viewpoint

Horizontal/Vertical Range of Section Viewpoint

Editing Section/Elevation/IE Lines on Floor Plan

Define Marker Reference for Source Marker

Model Display in the Section Window
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Open a Section Viewpoint

To open a Section viewpoint, do one of the following:

• Double-click its name in the Navigator

• Select the Section line on the Floor Plan and use one of the “Open” commands from the context menu

• Use a menu command (Window > Navigate > Sections > Open Section)

By default, each Section is opened in a new tab of the Tab Bar (or a new window, if you are not using the Tab 

Bar.)
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Horizontal/Vertical Range of Section Viewpoint

Horizontal Range

The horizontal range is the depth of the Floor Plan that will be included in the Section window. (Available for 

source-type Section markers only.)

Define the horizontal range in the Info Box/Section Settings:

• Infinite: All elements behind the Section Line will be shown in the Section window, provided that they are 

not hidden by other elements.

• Limited: Only the elements between the Section Line and the limit (depth) line will be shown in the 

Section window. (The limit line is defined when you click with the Eyeball cursor after you finish drawing 

the Section line.) You can select and edit the limit line as necessary

Note: The limit (depth) line is a display-only Marker item, and is not shown on the Layout.

See Display of Marker Range Lines.

• Zero Depth: Only the parts of the model actually cut by the Section Line will be shown, at the cut location 

only. (For Elevations and Interior Elevations, there is no “zero depth” option.)

Vertical Range

The vertical range of the project to be included in the Section window. (Available for source-type Section 

markers only.)

Define the vertical range in the Info Box/Section Settings.

• Infinite: Shows all stories of the model.

• Limited: The Section is confined to a limited vertical range. Enter the elevation values for the upper and 

lower limits of the Section. Elements above and below these limits will not appear.
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Click the black arrow to choose the reference for the elevation values: to Project Zero, or to a particular 

story.

Edit Range or Limit Lines Graphically

With the Section/Elevation/Interior Elevation window active:

1. Turn on the Range feedback from the context menu, or using Design > Section/Elevation Range.
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2. Marks appear in the Section window, in shades of dark grey, to indicate the horizontal/vertical boundaries 

and break lines, if any. The grey fill represents the area of the model outside of the Section range.

3. Hover over any mark to display its tag and editing handle. Drag the line as needed: this will modify the 

horizontal/vertical range, break mark, or distant area limit as applicable.

To remove a break, drag the break line outside of the horizontal range.

Note: Horizontal range cannot be edited in the Interior Elevation window.

Watch the Video
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Define Marker Reference for Source Marker

Follow these steps to define reference information for source-type Section, Elevation, Interior Elevation, Detail 

and Worksheet markers.

When placing a new source marker on the Floor Plan to create a viewpoint, the tool’s Default Settings gives 

you two choices for defining the Marker Reference:

• the viewpoint, or

• the first placed drawing of the viewpoint. (“First” means the topmost eligible drawing in the Navigator 

Layout Book.)

For example, the following Section has been defined to display the information of the first placed drawing 

created out of this viewpoint.

If you choose “first placed drawing,” and no drawing has been placed yet, the marker will display autotext 

(such as #DrgID), and once the drawing is placed, this autotext will be replaced by the relevant information.

The same marker information is shown in the Marker Panel in the Section Settings dialog box.

If you select an already placed source marker and open the tool’s Selection Settings or Info box, you have 

two additional choices, because the viewpoint may already have multiple drawings or views created out of it:

• the selected drawing

• the first placed drawing of the selected view
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Choosing either of these two options will bring up a directory dialog box showing the Navigator Layout Book or 

the Navigator View Map. Eligible drawings/views are available for selection (i.e., those which have been 

created from the selected Section viewpoint); other items are grayed and cannot be selected.

Note: The option to refer to a view is available in case the desired Drawing is located in a different 

project’s Layout Book (and is therefore not listed in the “Define Marker Reference” dialog box).

See Import View(s) from External ARCHICAD Project (Solo or Teamwork).

Since you cannot refer to the actual drawing, you can refer to the View (in the current project) from which 

the Drawing was created (in the other project). The marker will display the drawing data of the first 

drawing created out of this view as autotext (e.g. #Drawing Name, #DrgID). Once the Layout Book that 

contains the reference drawing is opened alongside the project containing the marker, the marker will fill in 

the correct drawing data.

The link information that will appear in the marker is previewed in the Reference to text field, as long as 

the referred item (such as a drawing) already exists in the project.
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Floor Plan Display of Section Markers

Display of Section Line and Marker

To customize the attributes of the Section Line and marker, use Section Settings.

See Marker Panel and Marker Symbol and Text Panel.

Highlight Source Markers

 Source markers are distinguished on screen by an optional semi-transparent fill. (Use View > On-screen 

View Options > Highlight Source Markers to enable or disable this distinguishing fill for all source markers. 

The color of this fill can be set in Options > Work Environment > On-Screen Options.)

Display of Limit Lines and Distant Area Lines

Both the Section limit line and the Distant Area line are on-screen-only elements which indicate “Marker 

Range”.

• To show or hide the Section limit lines and Distant Area limit lines on the Floor Plan, use the toggle control 

in View > On-Screen View Options > Marker Range.

• To change these lines/colors, use the control in Options > Work Environment > On-Screen Options.

For more information, see Display of Marker Range Lines.
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Model Display in the Section Window

Note: The controls for the display of elements is nearly identical for Elevations and Interior Elevations, 

and for 3D Documents based on the Floor Plan.

Controls of the Model Display panel in Section Settings define the appearance (fills, contours, surfaces) of:

• Cut Elements

• Uncut Elements

• Sun and Shadows

• Marked Distant Area

• Element Contours at Section Boundary

in the Section window.

The following are brief descriptions of these display features.

For an individual description of each control, see Model Display Panel.
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Cut Elements

By default, cut elements are shown using their element-level line and pen definitions. You can customize the 

appearance of cut elements in a Section window by checking the Uniform Pen for Cut Elements checkbox in 

the Model Display Panel of Section Settings, then assigning the lines and colors, for the display of cut 

elements in this Section only.
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Uncut Elements

Surface colors and vectorial hatching can be displayed only on uncut surfaces of elements in the Section/

Elevation/IE windows.

These options in the Model Display Panel of Section Settings enable you to apply surfaces (shaded or 

unshaded) to the uncut elements shown in the Section window:

Sun and Shadows

The following elevation is displayed with Vectorial Hatching “on” (as shown by the brick wall) and with Sun 

Shadow “on” (as shown by the shadow cast by the roof overhang.)
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Another effect is to display uncut surfaces in “shaded” mode - that is, to reflect rounded contours. You can 

combine the two effects (cast shadows and shaded effect) in a single Section display:

Marked Distant Area

Consider the following Section line on the Floor Plan:
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Note that this Section includes the west face of the building, close to the section line, as well as parts of 

the far end of the building that extends northward. In this Section view, the close and distant areas are 

displayed identically, so you cannot tell which is which:

To differentiate the “close” from the “distance” elements, reconfigure the section so that it contains a Marked 

Distant area: check the Marked Distant Area box in the in the Model Display Panel of Section Settings and 

specify a different color for the contours of the “distant” elements.

Return to the Floor Plan and notice that a new line segment representing the Distant Area has appeared.

Select this line and drag it as shown:

Note: The Distant Area line is a “Marker Range Line”.

See also Display of Marker Range Lines.
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Now re-open the Section. The distant elements are distinguished from the closer ones.

Element Contours at Section Boundary

“Element Contours” can be applied to elements shown in the Section, Elevation or Interior Elevation window 

which extend beyond the horizontal limits of the Section.

Use The Element Contours at Section Boundary settings from the Model Display Panel of Section Settings to 

define this boundary.

Here, the left edge of the wall on the left does not fall within the section, and the displayed parts are shown as 

unfinished, without contours.

However, you can choose to display boundary contours - that is, to draw a line at the element’s boundary as it 

is shown in the section, even though the element does not really end there. 
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At Add Element Contours, choose “Own Contours” to display these contours using the uncut pen chosen for 

these elements in their own Settings dialog boxes; or “Override Contours” to use a pen of your choice:
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Editing Section/Elevation/IE Lines on Floor Plan

You can stretch, offset and break all types of Section/Elevation lines on the Floor Plan:

• the main Section line, and any break lines

• the Marked Distant Area line, if any

• the limit line (Depth break), if the Section/Elevation’s horizontal range is limited

Offset Section Line Segment

1. Select Section line.

2. Click anywhere on the line segment to be offset.

3. From the pet palette, choose Offset Edge.

4. Drag and click to offset.

Break and Offset Line

1. Select the Section line. 

2. Click at the point where you want to insert the break.

3. From the pet palette, choose Insert Break and Offset.

4. Drag and click to offset the broken segment.
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Break All Section Lines

If the Section has a displayed Limit Line and/or Distant Area line, use the pet palette command: Insert Break 

on All Lines to break and offset all lines simultaneously.

Stretch Line

1. Select the Section line.

2. Click an endpoint of any segment.

3. From the pet palette, choose Stretch. 

Note: In Interior Elevations, the endpoints of the IE line cannot be stretched, because its length depends 

on the Room Boundary.

See Display and Edit Interior Elevation Marker Lines and Marker Range.

Remove Break

To remove a break in the line, select the segment and do one of the following:

• Use the Offset pet palette command to realign it with another line of the same type

• Select the break edge, and drag it outside of the Section/Elevation horizontal limit
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Related Topic:

Edit Range or Limit Lines Graphically

Watch the Video
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Place a Linked Section Marker

Note: This process is identical for Elevations, Details and Worksheets.

A linked marker is for reference purposes only. It has no model source and does not generate a new 

viewpoint. 

To place a linked Section marker, use the Section tool in any of the following windows: Floor Plan; Section; 

Elevation; Interior Elevation; 3D Document; Worksheet; Detail. Then link the marker to an existing viewpoint, 

view or drawing whose information is displayed in the marker.

Define Reference for Linked Marker

Follow these steps to define reference information for linked Section, Elevation, Detail and Worksheet 

markers.

1. Activate the Section tool.

2. In the Marker Type control of the Info Box or Section Default Settings, select “Place Linked Marker”.

3. In the appearing dialog box, define the Marker Reference.

 For a new linked marker, or to redefine an already placed selected marker, you have these choices:

• the selected viewpoint (i.e., the viewpoint you select from the directory list after choosing “Browse”)

• the selected drawing (i.e., the drawing you select from the directory list after choosing “Browse”)

• the first placed drawing of the selected viewpoint (i.e., the first drawing created from the viewpoint you 

select from the directory list after choosing “Browse.”). “First” means the topmost eligible drawing in the 

Navigator Layout Book.

• the first placed drawing of the selected view (i.e., the first drawing created from the view you select 

from the directory list after choosing “Browse.”). “First” means the topmost eligible drawing in the 

Navigator Layout Book.

Choosing any of these reference options will bring up a directory dialog box showing the relevant view of the 

Navigator (Project Map, View Map, or Layout Book). Choose the desired viewpoint, view or drawing. The 

chosen item’s information will be displayed in the linked marker.

Thus, a linked marker can refer to any viewpoint, view or drawing in the project.

Note: The option to refer to a view is available in case the desired Drawing is located in a different 

project’s Layout Book (and is therefore not listed in the “Define Marker Reference” dialog box). Since you 

cannot refer to the actual drawing, you can refer to the View (in the current project) from which the 

Drawing was created (in the other project). The marker will display the drawing data of the first drawing 

created out of this view as autotext (e.g. #Drawing Name, #DrgID). Once the Layout Book that contains 
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the reference drawing is opened alongside the project containing the marker, the marker will fill in the 

correct drawing data.

See Import View(s) from External ARCHICAD Project (Solo or Teamwork).

After the marker is placed, you can still go back and change its marker information at any time.

Linked Section Example

For example, you might create a Wall Section that functions like a Detail: 

First, place a source Detail marker in the Section window;

then place a linked Wall Section marker on the Floor Plan which is linked to this Detail.
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Place Unlinked Marker

An unlinked marker can be useful in your published documentation, for example, if you want to refer (with a 

page number) to the location of an external drawing that is not integrated into the ARCHICAD project.

Follow these steps to place an unlinked marker with the Section, Elevation, Detail or Worksheet tool.

1. In Default Settings or the Info Box, choose “Placed Unlinked Marker.” 

Such a marker displays no linked information.

2. Define any custom text for the marker using the Custom text fields in the parameter list in the Marker 

Symbol and Text Panel of the Settings dialog box.

3. Draw a line or boundary (depending on the tool) and place a marker in any of the following windows: Floor 

Plan; Section; Elevation; Interior Elevation; Worksheet; Detail; 3D Document.
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Create an Independent Section Viewpoint

Note: This process is identical for Independent Elevation Viewpoints.

“Independent” sections, with or without a marker, can be created in some windows. These viewpoints have no 

model source; they are listed as “Independent” viewpoints in the Navigator.

In an independent section, you can use 2D tools to create or add new content. Use copy-paste to transfer 

selected items from a Trace Reference into the drawing window in 2D form for further editing.

To create an independent Section without a marker, use the “Create New Independent Section” command. 

This creates an empty viewpoint without a marker, but listed in the Navigator.

This command is accessible:

• from the context menu of a Section item in the Navigator Project Map. Right-click on this folder and 

choose the “New Independent Section” command from the context menu

• from the Document > Documenting Tools submenu

• by clicking the New Viewpoint icon at the bottom of the Navigator Palette Project Map, if a Section is 

selected in the Project Map.

If you wish this independent Section viewpoint to be linked to a marker, place a linked Section marker into 

the project and link it (“Marker Reference to”) to the existing independent Section.
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Assign Section Rebuild Status

Note: The process for assigning a status is identical for Sections, Elevations and Interior Elevations. 3D 

Document status can be either Auto-rebuild or Manual Rebuild, but not Drawing.

When creating each new Section, you assign it a status in the General panel of Section Settings. A Section 

can have one of three statuses: Auto-rebuild Model, Manual-rebuild Model, and Drawing.

Each Section’s status defines the link between the Section and the model on the Floor Plan, and its rebuild 

method.

• In the two Model statuses (Auto-rebuild and Manual-rebuild), the window consists of construction 

elements; any changes made in a Model Section window can be updated in the Floor Plan window, as 

well as in the 3D window and in other Section windows, and vice versa.

• In a Section of Drawing status, construction elements are exploded into 2D fills, arcs and lines. Changes 

made in this kind of window are not updated in other windows. You can, however, update the drawing to 

reflect recent changes made to the model.

Construction elements are editable in both Autorebuild and Manual-rebuild section windows. You cannot 

create new model elements of most types here, but you can duplicate, view and modify them. You can, 

however, create new Morphs and Curtain Walls in these windows.

Note: Clearing a construction element from a Section Window of model status (either Autorebuild or 

Manual-rebuild) will also clear it from both the Floor Plan and the 3D model.

Regardless of a section’s status, you can add 2D graphics, annotation and dimensioning.

For more information, see Updating Sections.
ARCHICAD 24 Reference Guide 1646



ARCHICAD Model Views Views of the Virtual Building
Updating Sections

Note: The updating process is identical for Sections, Elevations, Interior Elevations and 3D Documents.

Each Section’s status defines the link (and rebuild method) between the Section and the model on the Floor 

Plan.

For further information, see Assign Section Rebuild Status.

Updating an Autorebuild Model Section

An Autorebuild Model Section is linked to the Floor Plan model and can be edited interactively. If the Floor 

Plan has changed, a Section in Autorebuild Model status will be automatically rebuilt every time it is opened.

Note: If background processing is on (see the Background Updating controls at Options > Work 

Environment > Model Rebuild Options), then the rebuild will occur in the background, even without 

opening the window.

Changes to existing construction elements in the Section window (including associative dimensions) will 

automatically be updated in other windows in the background. The update process works on construction 

elements only; 2D elements added to either the Floor Plan or Section window will not be reflected in the other 

window.

If you are in Autorebuild status and you are editing elements inside the Section window, the rebuild function is 

continuous and immediate within this window. However, in large plans, continuous auto-rebuild can cause 

slowdowns. If you prefer that your Section window be rebuilt only when it is opened or brought to the front of 

the screen, go to the Options >Work Environment > Model Rebuild Options dialog box and uncheck the 

“Update Auto-rebuild Model viewpoints continuously” checkbox.

While an update is underway, switching to another window or tab will cancel the update, so you can tab 

through successive views without waiting for the updates to finish.

If you nevertheless need to Rebuild manually, the View > Refresh > Rebuild from Model command is 

available. (The plain View > Refresh > Rebuild command, used to refresh 2D drawing elements, is not 

available for Autorebuild Model windows.)

Note: Some complex changes to the plan (e.g., modifying a Library Part) do not appear automatically in 

Model Section Windows. For a Manual-rebuild section, use the View > Refresh > Rebuild command; for 

an Autorebuild section, use View > Refresh > Rebuild from Model to see these changes reflected 

properly.

Updating a Manual-Rebuild Section

A Section having Manual-Rebuild Model status is not rebuilt automatically. It can be rebuilt from the model 

only by using the View > Refresh > Rebuild from Model command in the menu.

While a rebuild is underway, you receive feedback on the progress. Click the progress window to cancel the 

rebuild.

Updating a Drawing Section

Not applicable for 3D Documents, which are either Autorebuild or Manual-Rebuild type documents.

• To rebuild a Drawing-status Section, use View > Refresh > Rebuild. These commands refresh the view 

as a 2D drawing, fixing any potential temporary display errors.

• For a complete refreshing of a Drawing-status Section window, choose View > Refresh > Rebuild from 

Model. This will refresh the contents of these windows to fully reflect the current state of the Virtual 
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Building model. In the process, all 2D elements originating from the model will be removed and an up-to-

date view will be generated. This means that any manual editing of these 2D elements will be lost. 

Manually added 2D elements will remain in place.
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Summary of Rebuild Commands

The View > Refresh > Rebuild command is available in all construction windows. It rebuilds the model in the 

currently active window.

Additional Rebuild commands in the View > Refresh menu are available if the active window is a Section/

Elevation/IE, 3D Document, or a Detail or a Worksheet.

Rebuild from Model: Use this command to rebuild the active window; this will refresh the window information 

to reflect modifications in the Floor Plan.

Rebuild from Source View: This command is available only in the Detail and Worksheet windows.

The following commands might not be visible in the View > Refresh menu by default. You can customize your 

menu (Options > Work Environment > Menus) to include these commands if needed.

See Customizing Menus.

Also, these commands are available from the context menu of the folders in the Navigator Project Map and 

View Map.

Rebuild All from Model: Use this command to rebuild all Section/Elevation/IE windows in your project.

Rebuild All Model Sections from Model: Use this command to rebuild all the Section windows of Model 

status (either Autorebuild Model or Manual-Rebuild Model).

Rebuild All Drawing Sections from Model: Use this command to rebuild all Drawing-status Section 

windows.
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Elevations

ARCHICAD has a separate tool for creating Elevation viewpoints and linked or unlinked Elevation markers.

In contrast to Sections:

• Elevations generally do not “slice through” the structure, but rather create a cross-section view of the 

structure from a distant point.

• There is no “zero depth” option for the Elevation’s horizontal range.

• Elevation markers are conventionally different from Section markers; consequently, the Marker options in 

Elevation Settings vary from their counterparts in Section Settings.

• Unlike the Section Line, the Elevation line is an on-screen-only Marker item, and is not shown on the 

Layout.

See Display of Marker Range Lines.

In all other respects, the Elevation Tool works the same way as the Section Tool.

• To create an Elevation viewpoint, you must place a source-type Elevation marker on the Floor Plan.

• The resulting Elevation viewpoint has a Status (Model or Drawing) which determines its update process.

• The Elevation Settings Model Display Panel defines the display of the Elevation viewpoint, while the 

Marker and Marker Head panels determine the content and display of the Elevation marker.

• A linked-type Elevation marker, containing reference information only (without creating a viewpoint), can 

be placed in the Floor Plan, Section, Elevation, Interior Elevation, 3D Document, Detail or Worksheet 

Window.

• Unlinked Elevation markers can also be placed.

For more information, see the following topics:

Create a Section Viewpoint

Horizontal/Vertical Range of Section Viewpoint

Assign Section Rebuild Status

Model Display in the Section Window

Define Marker Reference for Source Marker

Place a Linked Section Marker
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Place Unlinked Marker

Create an Independent Section Viewpoint

Updating Sections

Floor Plan Display of Section Markers

Editing Section/Elevation/IE Lines on Floor Plan

Section and Elevation Settings

Moving an Elevation Marker

This option is available only for Elevation and Interior Elevation markers.

Select the Elevation line; the marker will be selected and will display a node.

Click on this node and choose the Move Elevation Marker command from the pet palette, then drag the 

marker to the desired position.

The marker will retain this position even if the elevation is dragged or rotated to a new position.
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Interior Elevations (IE)

This dedicated ARCHICAD tool is optimized for creating interior elevations of interior spaces.

Topics in this section:

About Interior Elevations

Create Interior Elevation Group

Create Single Interior Elevation Viewpoint

Interior Elevation Horizontal Range

Interior Elevation Vertical Range

Display and Edit Interior Elevation Marker Lines and Marker Range

Interior Elevation IDs and Names

Delete/Restore IE Viewpoint
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About Interior Elevations

Interior Elevations (IEs) work similarly to Sections and regular Elevations: choose an input method; define the 

view and its limits; and place a marker with custom-defined marker reference information.

Each Interior Elevation is a separate viewpoint in the Navigator Project Map.

Unlike the Section and Elevation tools, the Interior Elevation tool is used to create new viewpoints only; you 

cannot place a linked, reference-only IE marker.

Many other aspects of Interior Elevation viewpoints - status, display, marker reference, and updating - work 

the same as in Section viewpoints.
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Create Interior Elevation Group

Interior Elevations are typically created in groups (e.g. four IE’s created by placing a four-segment polyline 

around a single room).

An IE created using one of the polyline or rectangle input methods will have a separate IE viewpoint for each 

segment of the line; each view is created perpendicular to the segment.

1. Activate the Interior Elevation tool.

2. Use the rectangular or polyline input method to draw the Room Boundary, or space-click on a Zone.

The resulting rectangle/line/polyline represents the Room Boundary of the Interior Elevation group.
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3. Move the cursor to the desired standpoint. The arrows on the feedback indicate the view direction of the 

resulting Interior Elevation viewpoint.

4. Click to place the IE marker(s).

Interior elevations use a dedicated IE marker, a GDL object with editable parameters.

IE marker(s) are placed at the middle of each segment of the IE line or at the center of the room.

To define the Marker style and Position, use the controls in the Marker Panel of Interior Elevation Settings. 

For any or all of the viewpoints, you can opt not to show a marker, by choosing the No Marker option in 

this panel.

See Interior Elevation Marker Panel.

5. The new group of viewpoints is created and listed in the Project Map.

Each new IE viewpoint is assigned to an IE Group, even if there is only one viewpoint in the Group.

The IE Group is automatically listed in its own subset in the Project Map.
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You cannot move individual IE viewpoints from one Group to another.

IE’s are handled as a group for purposes of numbering, display, Show on Stories, Layers, Trace functions, and 

placement on a layout.

Typically, you will use the Master Layout’s “Auto Arrange Setup” options - in Master Layout Settings - to fine-

tune the appearance of IE views on the Layout.

To select an Interior Elevation group, select any of its Room Boundary lines.

 However, the settings of any single segment are accessible individually.
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Create Single Interior Elevation Viewpoint

1. Use the single line input method to draw the Room Boundary.

2. Move the cursor to the desired standpoint. The arrow on the feedback indicates the view direction of the 

resulting Interior Elevation viewpoint.

3. Click to place the IE marker.

To define the Marker style and position, use the controls in the Marker Panel of Interior Elevation Settings.

See Interior Elevation Marker Panel.

4. A new IE viewpoint is created and listed in the Project Map. It is assigned its own IE Group, even if there 

is only one viewpoint in the Group.

Many other aspects of Interior Elevation viewpoints - status, display, marker reference, and updating - work 

the same as in Section viewpoints.

Related:

Assign Section Rebuild Status

Model Display in the Section Window

Define Marker Reference for Source Marker

Updating Sections
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Interior Elevation Horizontal Range

The Horizontal Range can be either Infinite or Limited.

The default choice is Limited. In this case, the IE view will extend horizontally until the Room Boundary line. 

If the Room Boundary is a Wall, then the view automatically extends to the depth of the Wall; you can see this 

by the Marker Range highlight, which overlaps the Wall area.

To adjust the horizontal range, select the Room Boundary line and stretch or shrink it using the commands of 

the pet palette. (Stretch/shrink modifications to this segment will affect the neighboring line segments 

accordingly, as when editing any polyline.)

An Infinite Horizontal Range means that the Interior Elevation viewpoint will extend horizontally to include all 

visible parts of the model.
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Add Bounded Areas (Interior Elevation Default Settings)

To include connected enclosed areas in the Interior Elevation viewpoint, choose Add bounded areas. This 

checkbox is available

• in Interior Elevation Default Settings (you must set it before you place the IE; you cannot set this control 

for an already placed IE)

• if the Limited option is checked for Horizontal Range

This way, if the room contains an odd-shaped alcove, the IE viewpoint will include structures that fall beyond 

the Room Boundary Line, but still fall inside the room.

The following two illustrations show the result of the checkbox setting:
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Interior Elevation Vertical Range

Define the Interior Elevation’s vertical range either manually (in Settings), or graphically, in the Interior 

Elevation window.

Define IE Vertical Range in Settings

An IE viewpoint’s vertical range is set manually by the user in the General Panel of Interior Elevation 

Settings, or the Info Box.

See Interior Elevation (IE) Tool Settings.

Each IE view (i.e. each segment of the IE Room Boundary polyline) can have a separate, custom vertical 

range value, if desired: choose the Limited option as the Vertical Range and enter the desired elevation 

limits.

Use the pop-up to define whether this vertical range should be measured from Project Zero, or from the 

Interior Elevation’s Home Story (the story onto which it was placed).

Detect and Fit to Zones

If you want the Interior Elevation geometry to correspond to a zone, choose the Detect and Fit to Zones 

Vertical Range option from the General Panel of Interior Elevation Settings.

If a zone is detected, its height will be used as the vertical range of the selected Interior Elevation viewpoint.
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Zones edited by Solid Element Operations are also calculated accurately, provided that you also check the 

Consider Solid Operations box. For example, a single zone trimmed to a slanted roof will have several 

different zone heights. These are accurately reflected in each viewpoint of the Interior Elevation group.
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Display and Edit Interior Elevation Marker Lines and Marker Range

You can vary the display of Interior Elevation lines/range using the following two options at View > On-Screen 

View Options:

• Marker Range: displays the interior elevation limit line and Room Boundary line

• Highlight Source Markers: displays a highlight that indicates the range of the viewpoint. The color of this 

fill can be set in Options > Work Environment > On-Screen Options.

Edit Room Boundary

1. Select the IE or the IE Group:

Note: If the IE group uses a single, common marker, select the marker to select the entire IE group.

2. Use pet palette commands to edit the line.

Note: Inserting a new node will create a new IE viewpoint.

Marker Range On (Limited IE Viewpoint) Marker Range On (Infinite IE Viewpoint)
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Interior Elevation IDs and Names

To assign IDs and names to IE Groups and their viewpoints, use the General Panel of Interior Elevation 

Settings. The options in the General Panel vary depending on whether you are defining Settings for an IE 

Group:

or for an individual IE viewpoint:

Each new IE viewpoint is automatically assigned to an IE Group (even if there is only one viewpoint in the 

group). 

In each individual viewpoint’s IE settings, the Reference ID and Name fields are set to “By IE Group” by 

default.

This means that each IE viewpoint will have the same ID and Name as its parent IE Group.

ARCHICAD’s default IE Settings further define the ID and Name of each IE viewpoint to include Autotexts.

Use Autotext to Create Meaningful IDs/Names for Interior Elevation Group

You can define a logical naming convention for your IE Groups by including an Autotext in the parent IE 

Group’s ID and Name.

This way, each individual Interior Elevation contained in the group will display a logical Autotext value that can 

vary for each elevation.
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By default, ARCHICAD’s IE Group ID adds an Autotext of <Number> to the ID of each viewpoint in the IE 

group.

Also, the default IE Group Name adds an Autotext of <Orientation> to each viewpoint Name. Consequently, 

each viewpoint name consists of its specific orientation, which automatically assigned using Autotext (North, 

South, East, West...).

For an IE Group, use the General Panel of IE Settings to define any other Autotext to include in the IE 

viewpoints’ name and/or ID. For example, you can set the Interior Elevation Group’s ID to be the Zone 

Number:

1. Click the Autotext button next to the ID field in General Settings and choose Zone Number from the list.

2. In the Navigator, note that the ID of the Group is now equivalent to the number of the zone contained in 

the Interior Elevation.

This ID is inherited by all of the viewpoints in the Group.

(Naturally, assigning a Zone Number autotext works only if the Interior Elevation includes a zone.)

Customize IDs and Names

You can give a customized ID and/or Name to any IE Group or individual viewpoint:

• Select the IE limit line.

• Open Interior Elevation Settings.

If it is an individual IE Viewpoint, make sure the pop-up is set to Custom.

• Enter the desired ID and/or Name.
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You can also use the Navigator Palette to change IDs and Names for an IE Group.
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Delete/Restore IE Viewpoint

If you have selected an individual IE viewpoint, you can delete that single viewpoint with the context menu’s 

Delete command.

Alternatively, if you have selected the entire IE group, use the Delete Segment command from the pet 

palette. The segment that you clicked to select the IE group will be deleted.

Note: To select an Interior Elevation group, select any of its Room Boundary lines.

You can restore this viewpoint even after deleting it: In the Navigator or in the project, select the IE group to 

which it belongs, then use the Restore all Interior Elevations in Group command from the context menu.

Note: This command regenerates the IE viewpoint, but any 2D edits you made in this viewpoint before 

deleting it have been lost.
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Display of Elements in Interior Elevation

Use the Model Display controls in Interior Elevation Settings to define the appearance of cut and uncut 

elements in the view.

These options are largely identical to those in the Model Display panel of Section Settings.

See Model Display in the Section Window.

Interior Elevations do not have a “Marked Distant Area” display option.

Extra display options are available for the display of cut elements in Interior Elevations:

Transparency

Check this box to give see-through Surfaces (e.g. glass) a transparent effect in this Interior Elevation.

Exclude View Blocking Walls

Check this box if you do not want intervening walls to be displayed in your Interior Elevation viewpoint.

Hide Cut Elements

If this option is checked, elements that are cut by the Interior Elevation Line will not be displayed.

See also Model Display in the Section Window.
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3D Document

The 3D Document allows you to use either the Floor Plan or the 3D view of the model as the basis for creating 

a document, to which you can add dimensions, labels and additional 2D drawing elements.

Topics in this section:

About the 3D Document

Create a 3D Document

Redefine the 3D Document

Model Display of the 3D Document
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About the 3D Document

3D Document: Floor Plan Projection

Create this type of 3D Document based on a projection of the Floor Plan. Define the projection by setting a 2D 

cut plane height and defining projection direction either upwards (toward the ceiling) or downwards (to the 

floor). This is useful, for example, to display the load-bearing structures on a slab plan, or a reflected ceiling 

plan. Use it also to create shaded Floor Plan views for presentation/interior design.

3D Document: 3D Projection

This 3D Document has its source in the 3D window. Specific parameters and options affecting 3D window 

display (such as projection and filtering/selection of elements) will affect 3D Document display.

To add dimensions, just use ARCHICAD’s dimensioning tools, plus certain dimensioning functions that are 

available only for 3D Documents.

The 3D Document Viewpoint

The 3D Document is a viewpoint which appears in the Navigator Project Map.

You can also access 3D Documents through the Go command of the Mini-Navigator Toolbar, or from the 

Window > Navigate > 3D Documents menu, or from the Window menu.

In many respects, the 3D Document is analogous to the Section viewpoint: it is an integral part of the 

ARCHICAD model, and its model elements are rebuilt automatically or manually, depending on its status.

In the 3D Document, you can select model elements and access their settings dialog boxes to make changes 

in the model, but you cannot edit them graphically or create new model elements.

However, like other model views, the 3D Document has its own 3D Document Settings dialog box, where 

you can set parameters that are specific to the 3D Document: these include fill/pen display of element 

surfaces (including cut composite elements) and contours, transparency, 3D hatching, shading, shadow and 

sun effects.

Note: The display of composite elements in the 3D Document window also depends on the Partial 

Structure Display settings.

See also Partial Structure Display.
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In the 3D Document, you can display the materials of cut surfaces in a 3D-like display to graphically 

communicate composite structures:

Related Topics:

Create a 3D Document

3D Document Settings

Model Display of the 3D Document

Linear Dimensions in the 3D Document Window
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Create a 3D Document

From the 3D window:

1. In the 3D window, set up the desired 3D view of the model: the perspective or projected 3D view; use 3D 

Cutting Planes; filter or select elements; use Marquee as needed, or perform solid element operations.

2. Create a new 3D Document by doing one of the following:

• Use New 3D Document from 3D... from the context menu of the Navigator’s 3D Documents folder.

• Use New 3D Document from 3D command from the context menu of the 3D window

• Use a menu command (Document > Documenting Tools > New 3D Document).

From the Floor Plan:

1. On any story of the Floor Plan, set up the model view you want to see in your 3D Document.

2. If needed, you can limit the view using Selection or Marquee. (View settings for the 3D window, such as 

Filter and Cut Elements in 3D, have no effect on 3D Documents created from the Floor Plan window.)

3. With the Floor Plan window open, use the New 3D Document from Floor Plan... from one of the 

following locations

• Floor Plan context menu 

• context menu of the Navigator’s 3D Document folder

• context menu of any Story from the Project Map.

• a menu command (Document > Documenting Tools > New 3D Document).

New 3D Document Dialog Box

The New 3D Document dialog box appears.

Enter a Reference ID and Name for the new 3D Document; click Create.

Note: Optionally, the name of the source view can be set as the default 3D Document Name.

To set naming defaults, see 3D Document General Panel.

The 3D Document is created and opened in its own window. It is listed in the 3D Document folder in the 

Project Map of the Navigator.
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To adjust the content, settings and display of the 3D Document, you can adjust its source view and/or its 

display settings, and then redefine it.

See the following for more information:

Redefine the 3D Document

Model Display of the 3D Document
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Redefine the 3D Document

There are three ways to redefine a 3D Document after you have created it. Each method is described below:

Redefine 3D Document: Open and Edit Source Window

Redefine 3D Document Based on Current (3D or Floor Plan)

Redefine Using 3D Document Settings

Redefine 3D Document: Open and Edit Source Window

If the 3D Document window is in front: use Open 3D Source (for 3D projections) or Open Source Story (for 

Floor Plan Projections) from the context menu to open the source window.

Or right-click the 3D Document viewpoint or view from the Navigator, then click the Open Source View 

command:

Make your changes in the source window:

• Edit elements, layer settings, orientation or projection

• Change element visibility using Selection/Marquee

• If the source is a 3D Window, you can also change the Filter Elements settings (View > Elements in 3D 

View > Filter and Cut Elements in 3D) and adjust Cutting Planes

Then use the Redefine command by doing one of the following:

• Context menu of the 3D Document in the Navigator Project Map

• Context menu of the 3D window or Floor Plan
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This brings up the Redefine 3D Document dialog box.

Choose the 3D Document which you want to redefine based on the current 3D window or current Floor Plan 

window. 

A warning reminds you that this Redefine operation is not undoable.

Click Redefine Anyway to proceed.

Redefine 3D Document Based on Current (3D or Floor Plan)

Access this command by doing one of the following:

• Context menu of the 3D Document window

• Context menu of the 3D Document in the Navigator Project Map
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• In 3D Document Settings, check the box to Redefine the projection, cutting planes, and visible 

elements of the 3D Document based on the current 3D window (available for 3D Documents based on a 

3D projection.)

For a 3D Document Based on 3D Projection:

The Redefine based on Current command redefines the 3D Document according to the following settings of 

the current 3D window:

• The current 3D projection, including zoom

• Filter and Cut Elements to Show in 3D (View > Elements in 3D View)

• Selection/Marquee limitations

• Cutting Planes

Note: The current window is not necessarily the same as the original source of your 3D Document. 

“Current” is the one currently open, or the one that was last open.

For a 3D Document based on a Floor Plan Projection:

The Redefine based on Current command redefines the 3D Document according to the following settings of 

the current Floor Plan:

• Selection/Marquee limitations

• Orientation

• Zoom

• Story

Redefine Using 3D Document Settings

For a 3D Document Based on 3D Projection:

If you want to redefine an existing 3D Document without having to open the source 3D window, an easy way 

to do it is to use its 3D Document Settings.
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The controls in the 3D Projection panel allow you to access dialog boxes to modify the 3D Document and its 

3D window source, without having to open or change the current 3D window:

Make any or all of the following changes:

• Click Redefine 3D Projections to bring up the Perspective or Parallel Settings dialog box which reflects 

the 3D Document’s source 3D window. Make any adjustments needed, such as sun position, and click OK 

to leave the projections dialog box.

• Click Redefine Filter Elements to access the Filter and Cut Elements in 3D dialog box. Make any 

adjustments needed, and click OK to leave the dialog box.

Changes in your 3D Document will take effect when you click OK to leave 3D Document Settings. The current 

3D window remains unchanged.

For details on these controls, see 3D Document 3D Projection Panel.

For a 3D Document based on a Floor Plan Projection:

The same Redefine function is available for a Floor Plan-based 3D Document: click the Redefine checkbox on 

the Floor Plan Projection panel, and click OK.
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Model Display of the 3D Document

While the 3D Document derives many of its settings from its 3D window source, several important settings for 

the 3D Document’s model appearance are derived from 3D Document Settings.

See 3D Document Model Display Panel.

Use the 3D Document Settings Model Panel to set:

• Fills and pens for element surfaces and contours, and for cut elements

• Transparency

• Vectorial 3D hatching

• Sun and Shadow effects

• Hidden Edges

• Boundary Contours (for Floor Plan-based 3D Documents)

Important: These settings apply to the 3D Document and are independent of its source window.
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Details

The Detail tool is used to generate a Detail drawing from the model. Although the contents of the Detail 

viewpoint consist of 2D items, a Detail can be updated from the model.

Topics in this section:

About Details

Create a Detail Drawing Viewpoint with Model Source

Contents of the Detail Viewpoint

Place a Linked Detail Marker

Place Unlinked Marker

Create an Independent Detail Viewpoint

Display of Detail/Worksheet Boundary

Update Detail/Worksheet Marker Boundary

Updating the Detail Window
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About Details

The Detail tool is used to generate a Detail drawing viewpoint from the model by placing a Detail marker in 

any of the following windows: Floor Plan; Section; Elevation; Interior Elevation; 3D Document; Worksheet; 

Detail window. It is also used to place linked Detail markers, as a reference to any viewpoint, view or drawing.

The Detail Marker (a GDL object) is displayed according to the settings you made in the Detail Settings dialog 

box. You can also create an independent Detail drawing, with or without a marker.

Detail viewpoints are displayed in a dedicated Detail Drawing Window and listed in Navigator Project Map.

Detail viewpoints generated from existing elements in the project are 2D-only copies of these elements. The 

viewpoints can be updated to reflect changes in the plan. You can add additional 2D elements, text, labels and 

objects to a Detail Drawing.

You may wish to fine-tune the Detail Drawing before final output. You will find, however, that the “exploded” 2D 

elements generated from the model often contain superfluous elements (extra line segments, overlapping or 

superfluous fills) that make such editing difficult. To make editing easier, first use the Linework and Fill 

Consolidation functions on selected items in the window.

For more information, see Consolidate Lines and Fills in Drawing Windows.

To open the Detail Drawing in its own window, double-click the detail view name in the Navigator.
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Create a Detail Drawing Viewpoint with Model Source

To create a Detail with its source in the model, place an area-based Detail marker in any of the following 

windows: Floor Plan, Section/Elevation/Interior Elevation, 3D Document, Worksheet or Detail.

1. Activate the Detail tool.

2. In the Info Box or Detail Default Settings, make sure that “Create new detail viewpoint” is selected.

3. Choose an area-based geometry method from the Info Box: Polygonal, Rectangular, or Rotated 

Rectangular. (The first, “No Boundary” geometry method, creates a marker linked to an independent 

viewpoint having no model source.)

4. Draw the Detail boundary and click to complete.

5. After drawing the detail boundary, click with the hammer cursor to place the Detail Marker. The X 

represents the Detail’s origin.

Note: Source-type Detail markers are distinguished on screen by an optional semi-transparent fill. (Use 

View > On-screen View Options > Highlight Source Markers to enable or disable this distinguishing fill 

for all source markers. The color of this highlight can be set in Options > Work Environment > On-

Screen Options.)

6. A new Detail Drawing viewpoint is created and listed in the Navigator Project Map.

To define the reference information displayed in a source-type Detail marker:

See Define Marker Reference for Source Marker.

Other information about the new Detail viewpoint - its Markers and Reference information - can be defined in 

Detail Settings.
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Contents of the Detail Viewpoint

The source-based detail drawing consists of only 2D lines/fills, including the 2D exploded representations of 

all construction elements inside the detail boundary. By default, only construction elements are transferred; 

annotations and dimensions are not transferred to the Detail viewpoint. (You can change this setting using a 

checkbox in the General Panel of Detail Settings.)

For information on what happens to annotation elements cut by the Detail boundary, see Annotations, 

Dimensions and Markers Cut by the Boundary.

Only 2D tools are available in the Detail window. All types of 2D information can be added to the Detail 

Drawing: Lines, Fills, Hotspots, Text, Figures, Dimensions and 2D Symbols of Objects.

The Detail Drawing will include a line representing the Detail Boundary you drew on the plan.

See Display of Detail/Worksheet Boundary.

Section Details (Detail viewpoints created from a Section) reveal the elevation of the original construction, 

which means that Elevation Dimensioning placed on Detail viewpoints shows correct elevation values, unless 

you displace drawing elements vertically. (The same is true for Elevation Dimensions in Details generated 

from Elevations and Interior Elevations.)

Related Topics:

Worksheet vs. Detail
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Place a Linked Detail Marker

To place a linked detail marker without creating a viewpoint:

1. Activate the Detail tool.

2. In the Info Box or Detail Default Settings, make sure that “Place Linked Marker” is selected.

3. Define the Marker Reference using the appearing dialog box.

See Define Reference for Linked Marker.

4. Choose any of the Detail geometry methods to place the marker.

• If you use the No Boundary geometry method: click once to place the marker

• If you use any of the area-based methods: draw a Detail boundary, then click with the hammer cursor to 

place the marker.

Such a marker has no model source and does not generate a new viewpoint. To define the reference 

information displayed in a linked Detail marker:

See Define Reference for Linked Marker.
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Create an Independent Detail Viewpoint

An Independent Detail drawing is one whose content you create yourself, starting with an empty detail 

viewpoint. You can then use 2D drawing tools or paste an object or existing drawing.

An Independent Detail drawing is not generated from existing project elements and so is unlinked to any 

modifications that take place in your plan.

You may wish to create an Independent Detail for your documentation which depicts something that does not 

otherwise exist in the model - for example, detail of a fence.

These independent Detail Drawings always appear in the Navigator tree structure. They can be marked or 

unmarked: Independent marked details have a corresponding detail marker on the plan. Independent 

unmarked details do not have a detail marker on the plan, but they exist as viewpoints which you can open 

from the Navigator.

Create an Independent Detail viewpoint with a marker

1. In Detail Settings or the Info Box, choose “Create New Detail Viewpoint.”

2. Define the Marker Reference:

• the viewpoint, or

• the first placed drawing of the viewpoint

The link information of the chosen viewpoint/drawing will appear in the “Reference to” text field.

After the marker is placed and the new Detail is created, you can still go back and change its marker 

information at any time.

3. Choose the single-click geometry method (the first icon among the Info Box geometry methods) and click 

to place a detail marker on the plan.

4. A new, empty Detail viewpoint is created (“independent marked detail”) and listed in the navigator. This 

viewpoint has no model source.

To open the independent Detail viewpoint, double-click its name in the Navigator or access it with the “Open 

Detail Drawing” in the marker’s context menu. Use the available 2D drawing tools, place objects, text, labels, 

or paste an existing drawing into the detail drawing window.

Create an Independent Detail viewpoint without a marker

Use the New Independent Detail command from one of the following locations:

• Context menu of the Detail folder in the Navigator Project Map
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• New Viewpoint icon at the bottom of the Navigator Palette Project Map, if a Detail or the Detail folder is 

selected

• Document > Documenting Tools > Create Independent Detail command. 

Independent unmarked details are listed in the Navigator, though they have no associated marker.

Later, if needed, you can attach a Independent Detail viewpoint to a marker: place a linked marker and point 

the marker to your Detail viewpoint.
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Display of Detail/Worksheet Boundary

When you create a new Detail or Worksheet viewpoint using a polygon input method, the resulting drawing 

will show the Boundary as a dashed line. If you do not want this boundary included in the Drawing window, 

disable the relevant checkbox in Options > Work Environment > More Options.
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Update Detail/Worksheet Marker Boundary

If you redraw the boundary of a source detail or worksheet marker, any markers linked to this marker’s 

viewpoint will not be updated until you issue the Update Linked Markers’ Boundaries command from the 

Detail/Worksheet viewpoint item’s Navigator context menu.

This command affects the shape of marker boundaries only, not any associated model content.
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Updating the Detail Window

If the source view of a Detail viewpoint has been modified, update its contents with the Rebuild from Source 

View command (from context menu of the detail drawing listed in the Navigator, or from the View > Refresh 

sub-menu).

For more information, see Summary of Rebuild Commands.
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Worksheets

The Worksheet window provides a dedicated environment for 2D model-based drawings, such as partial floor 

plans and partial sections, and for drawings created entirely in 2D.

Topics in this section:

About Worksheets

Worksheet vs. Detail

Create a Worksheet Drawing with Model Source

Contents of the Worksheet Window

Editing in the Worksheet Window

Create an Independent Worksheet Viewpoint

Place a Linked Worksheet Marker

Place Unlinked Marker
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About Worksheets

The Worksheet window provides a dedicated environment for 2D model-based drawings, such as partial floor 

plans and partial sections, and for drawings created entirely in 2D. Worksheets can be used as a dedicated 

environment for finishing drawings using 2D tools, and for working with consultants limited to 2D methods.

You might want use a Worksheet to add a diagram or organizational chart, which is totally independent of your 

model, yet useful for your documentation.

As in the Detail window, elements on the Worksheet consist of 2D-only duplicates of any construction 

elements in “exploded” form (e.g. 2D lines and fills). Only 2D tools are available in the Worksheet window.

You may find that the “exploded” 2D elements generated from the model often contain superfluous elements 

(extra line segments, overlapping or superfluous fills) that make such editing difficult. To make editing easier, 

first use the Linework and Fill Consolidation functions on selected items in the window.

For more information, see Consolidate Lines and Fills in Drawing Windows.

The user can link any type of marker to the Worksheet.

You can place a Section marker onto a Worksheet to create a Drawing-type section. You can also place a 

Detail marker onto a Worksheet to create a Drawing-type Detail. Such Drawing Sections and Drawing Details 

cannot be refreshed based on the content of the Worksheet window.

The Worksheet tool is active in any window. It has marker and linking options similar to those of the other 

ARCHICAD marker tools (Section, Detail).

To open a Worksheet window, double-click its name in the Navigator. (You can also access Worksheets 

through the Go command of the Mini-Navigator Toolbar, or from the Window > Navigate > Worksheets 

menu, or from the Window menu.) Use the available 2D drawing tools, place objects, text, labels, or paste an 

existing drawing into the drawing window.
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Worksheet vs. Detail

While creating a Worksheet based on the source model is similar to creating a model-based Detail, the 

Worksheet is optimized for creating partial floor plans and partial sections.

Unlike the Detail tool, the Worksheet tool has a single-click “capture” geometry method which reproduces the 

entire contents of the current window as 2D elements in the Worksheet viewpoint.

Consequently, when transferring all or part of a source model view to a Worksheet window:

• Annotation elements and dimensions will, by default, appear in the resulting Worksheet, in addition to 

construction elements exploded into 2D components. (In contrast, a Detail viewpoint created from the 

model will - by default - contain the 2D-only copies of construction elements only, without the source 

model’s annotation/dimension elements.)

• The resulting Worksheet will have the same scale as the source. (In contrast, a Detail is created, by 

default, at half the scale of the original.)
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Create a Worksheet Drawing with Model Source

To create a Worksheet with its source in the model, place a Worksheet marker in any of the following 

windows: Floor Plan, Section/Elevation/Interior Elevation, Worksheet or Detail.

1. Activate the Worksheet tool.

2. In the Info Box or Default Settings, make sure that “Create new Worksheet viewpoint” is selected.

3. Choose any of the geometry methods from the Info Box.

• Capture Screen input method: Use the single-click method: the first input method in the Worksheet info 

box. Choose this icon, then click anywhere in the active project window. You will create a Worksheet 

based on the entire contents of the window.

• Area-based input method: Use one of the polygonal or rectangular/rotated rectangle geometry methods 

to define the Worksheet area.

4. Draw the Worksheet boundary and click to complete.

5. After drawing the Worksheet boundary, click with the hammer cursor to place the Worksheet Marker.

Note: Source-type Worksheet markers are distinguished on screen by an optional semi-transparent fill. 

(Use View > On-screen View Options > Highlight Source Markers to enable or disable this 

distinguishing fill for all source markers. The color of this highlight can be set in Options > Work 

Environment > On-Screen Options.)

6. A new Worksheet viewpoint is created and listed in the Navigator Project Map.

To define the reference information displayed in a source-type Worksheet marker.

See Define Marker Reference for Source Marker.

Other information about the new Worksheet viewpoint - its Markers and Reference information - are defined in 

Worksheet Settings.

See Worksheet and Detail Tool Settings.
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Contents of the Worksheet Window

A project-based Worksheet only contains drawing primitives, that is, lines and fills. These originate from the 

construction elements on the Floor Plan or Section/Elevation/IE, or 3D Document.

Section/ Elevation and Detail/Worksheet markers within the Worksheet boundary are “live” markers: they 

continue to function as markers.

When transferring all or part of a model view to a Worksheet window, annotation elements and dimensions 

will, by default, also appear in the resulting Worksheet.

To copy construction elements only, without annotations/dimensions, check the “Copy construction elements 

only” box in Worksheet Settings.

The resulting Worksheet will have the same scale as the source, if any. (If the source has no scale, the 

Worksheet will be shown at a default scale value.)

Annotations, Dimensions and Markers Cut by the Boundary

If the Worksheet boundary intersects annotation elements, dimensions or marker-type elements (Section/

Elevation markers; Detail/Worksheet markers), then these will be transferred to the Worksheet window if they 

meet the relevant criteria, as follows.

Note: The following also apply to Detail drawings. (However, by default, Detail drawings do not include 

annotations or dimensions at all, unless you uncheck “Copy Construction elements only” in Detail 

Settings.)

Figures and Drawings: if at least one reference point is inside the worksheet boundary, the entire Figure or 

Drawing will be included in the Worksheet.

Labels: Arrowhead must be inside the boundary.

Dimensions: The relevant reference point(s) or the dimension’s endpoints must be inside the boundary.

• Dimensions with two endpoints must have both endpoints inside.

• Dimension chains will be transferred by segment: if both endpoints of any segment are within the 

boundary, that segment is included in the Worksheet.

If any part of the Wall falls within the boundary, then all Doors, Windows, and Door/Window markers in that 

Wall are also included in the Worksheet.

Detail markers: If a detail viewpoint’s origin (the “X”) or endpoint of a marker falls within the boundary, the 

entire marker is included in the Worksheet.

Section and Elevation Markers: If any part of a Section or Elevation line is included in the boundary, the 

Section/Elevation marker (a GDL object) will be included in the Worksheet, although the line’s geometry may 

be different (the line may be shorter) if the boundary includes only part of the Section/Elevation line.

Note: Interior Elevation markers, unlike Section/Elevation markers, are cut by the boundary and appear in 

the Worksheet as exploded line/fill components.

Related Topics:

Display of Detail/Worksheet Boundary

Update Detail/Worksheet Marker Boundary
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Editing in the Worksheet Window

Only 2D tools are available when the Worksheet window is active.

All types of 2D information can be added to the Worksheet: Lines, Fills, Hotspots, Text, Figures, Drawings, 

Dimensions and 2D Symbols of Objects.

You can add content to your Worksheet window in several ways:

• Select any element(s) from any window and paste them into the Worksheet window. All elements, 

including construction elements, will be pasted in 2D form.

• To transfer elements from a Trace Reference, first switch the Reference with the active window, then 

copy-paste from there into the Worksheet (in exploded form) 

• Draw all new 2D elements into the Worksheet window.
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Create an Independent Worksheet Viewpoint

An independent worksheet is one which you create yourself, starting with an empty worksheet viewpoint. You 

can then use 2D drawing tools or paste an object or existing drawing.

An independent worksheet is not generated from existing project elements and so is unlinked to any 

modifications that take place in your plan.

Independent Worksheets without a marker are also listed in the Navigator. However, you can subsequently 

link a marker to such a Worksheet as needed.

Create an Independent Worksheet without a marker

Use the New Independent Worksheet command from one of the following locations:

• Context menu of the Worksheet folder in the Navigator Project Map

• New Viewpoint icon at the bottom of the Navigator Palette Project Map, if a Worksheet or the Worksheet 

folder is selected

• Document > Documenting Tools > Create Independent Worksheet command. 
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Place a Linked Worksheet Marker

To place a linked Worksheet marker without creating a viewpoint:

1. Activate the Worksheet tool.

2. In the Info Box or Default Settings, make sure that “Place Linked Marker” is selected.

3. Choose any of the Worksheet geometry methods to place the marker.

Such a marker has no model source and does not generate a new viewpoint.

To define the reference information displayed in a linked Worksheet marker:

See Define Reference for Linked Marker.
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Managing Markers in ARCHICAD

Several ARCHICAD tools that create a view use markers. The behavior and management of these markers is 

analogous for all tools with markers:

• Section

• Elevation

• Interior Elevation

• Worksheet

• Detail

Topics in this section:

About Markers

Display of Marker Range Lines

Source Marker Highlight

Changing Marker Type

Transfer Marker Parameters

Copying a Marker

Find Linked Markers

Check Markers Palette

Deleting a Viewpoint/View/Drawing with a Marker

Deleting a Source Marker
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About Markers

Markers can be placed using any of the following tools: 

Sections

Elevations

Interior Elevations (IE)

Worksheets

Details

With any of the Marker tools, you can opt to place a source marker. A source marker creates a new viewpoint 

(e.g. a Section, Elevation, Worksheet, Detail) involving the model as their source.

Any of the Markers - except Interior Elevation - can optionally be defined as a linked marker. Such markers 

have no model source and do not generate a new viewpoint. Instead, they are placed in the project, then 

linked by the user to an existing viewpoint, view or drawing. This information is displayed in the marker, which 

can be used to navigate to the referred item.

An unlinked marker has no model source and displays no linked information. You cannot use it to navigate 

among markers, but you can define any custom text for it.

Topics in this section:

Display of Marker Range Lines

Source Marker Highlight

Changing Marker Type

Transfer Marker Parameters

Copying a Marker

Find Linked Markers

Check Markers Palette

Deleting a Viewpoint/View/Drawing with a Marker

Deleting a Source Marker
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Display of Marker Range Lines

After you draw an input line or polygon with any of the marker-type tools, or the Change tool, these input lines 

will remain displayed on screen when you place the Marker. Marker Range items include:

• Elevation, Interior Elevation Line

• Section/Elevation Limit Line (for Sections and Elevations of limited depth)

• Distant line (for Sections and Elevations with a Marked Distant Area)

• Interior Elevation Limit lines

• Polygons defining area-based Details and Worksheets

• Polygons defined with the Change tool

These Marker Range items are on-screen elements only; and never present on printouts.

You can choose to show or hide Marker range items of all types using the View > On-Screen View Options > 

Marker Range toggle.

To customize the line type/color of these Marker Range lines, use the controls in Options > Work 

Environment > On-Screen Options.

Related Topics:

On-Screen View Options

Display of Detail/Worksheet Boundary

Update Detail/Worksheet Marker Boundary
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Source Marker Highlight

Source markers are distinguished on screen by an optional semi-transparent fill. This option makes it easy to 

tell at a glance which of your markers on screen are source markers.

To toggle this highlight on or off for all source markers, use the View > On-Screen View Options > Highlight 

Source Markers command.

To change the color of the source marker highlight, use the color chooser in Options > Work Environment > 

On-Screen Options.

Related Topics:

Display of Detail/Worksheet Boundary

Update Detail/Worksheet Marker Boundary
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Changing Marker Type

You can change the type of an already placed marker, so long as all the Marker references point to items that 

originate with a Marker tool.

To change a linked marker to a source marker:

1. Select the marker.

2. Open the marker’s Settings dialog box and choose the Source Marker option

The linked marker becomes the source marker, while the original source marker becomes a linked marker.

This function is available for:

• Linked markers which are linked to a viewpoint/view/drawing that is located within the current project. The 

linked marker must have been placed using the same tool as the item to which it was linked (e.g. a 

Section marker linked to a Section viewpoint).

Note: A viewpoint’s cut/model attributes are defined by its source marker. If a linked marker becomes the 

source of a section, that marker’s cut/model attributes are now applied to the viewpoint.

Note: If you change a linked detail marker into a source detail marker, the viewpoint’s defining polygon will 

change to reflect the new source detail marker’s polygon.

• Linked markers linked to an independent viewpoint of the same type.

The independent viewpoint is deleted and replaced by a source viewpoint. (If the original linked marker 

had no boundary, the source will take on a default boundary value.)

Markers linked to an external drawing cannot be changed to a source marker.

To change a source marker to a linked marker:

1. Select the marker.

2. Open the marker’s Settings dialog box and choose the Linked Marker option

The original source marker becomes a linked marker containing the same reference information as before.
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Transfer Marker Parameters

You can use the Pick Up Parameters and Inject Parameters commands between markers.

If you Pick Up Parameters from a source marker and inject them into another marker, the second marker will 

take on all of the first marker’s parameters except its link information, and except for its geometry (e.g. the 

range of a section marker.) 

If you Pick Up Parameters from a linked marker and inject them into another marker, the second marker will 

become identical to the first: a second linked marker with the same parameters, and containing the identical 

reference information, as the first.

See also Parameter Transfer.
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Copying a Marker

Any interaction (Copy/Paste, Drag/Rotate/Mirror Copy/Copies) that results in creating a new copy of a marker 

will have the following results:

• Copying a source marker (Section/Elevation/IE or Worksheet) results in a second source marker. This 

creates a new viewpoint having the same parameters as the viewpoint associated with the original 

marker. The new viewpoint’s name, however, will be different. Moreover, the Marker Link information is not 

copied.

• Copying a source Detail marker will create a new linked Detail marker, which is linked to the original detail 

viewpoint.
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Find Linked Markers

To find all the markers linked to a particular viewpoint/view/drawing, select the item from the Navigator. Use 

the Find Linked Markers command from the item’s context menu.

The Find Linked markers dialog box lists all the linked markers:

• By marker type (shown as an icon)

• Placed to: ID and name of the viewpoint in which the marker is placed. (If it is a source marker, the 

viewpoint name is underlined.)

Clicking either column header will sort the list accordingly.

Click Marker Settings to open the Tool Settings dialog box of the selected marker.

Click Go to Selected to zoom to the selected marker. (The button is disabled if multiple markers are 

selected.)
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Check Markers Palette

The Check Markers function lists which marker-referred items are missing from the project.

The Check Markers Palette is available:

• from Window > Palettes > Check Markers

• by clicking the Check Markers command on the Layouts and Drawings toolbar

To list undefined marker references, click the Check Markers button at the top of the palette.

The palette lists all the markers in the project which the user has automatically or manually linked a viewpoint, 

drawing or view, but whose referred viewpoint/drawing/view has since been deleted from this project. (In this 

case, the marker will display Autotext in place of the missing data.)

Markers are listed, and can be sorted, according to the following:

• By marker type (shown as an icon)

• Placed to: ID and name of the viewpoint in which the marker is placed.

• Selected item: Name and ID of the marker’s referenced item (i.e. the viewpoint/view/drawing one you 

chose when defining the marker reference). If this referenced item has been deleted from the project, this 

column will show “N/A”.

• Approve: Editable checkbox for each marker.

You can sort items by any of these properties by clicking on its column header. You can then perform a 

secondary sorting function: clicking a second column header will further sort within the hierarchy obtained by 

the first sorting.

An icon at the bottom of the palette allows the user to zoom to the selected marker. (The zoom button is 

disabled if multiple markers are selected.)

For each problematic marker listed (or multiple selected markers), the user can click Marker Settings to re-

link the marker(s) or otherwise modify them.

The user may decide that the marker is OK the way it is (even though it continues to display undefined 

Autotext). In this case, the Approve checkbox can be used as a sorting criterion; check the box for these 

markers. (For example, if you know that the undefined Autotext refers to an external project that has not yet 

been loaded.)
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If you don’t want the palette to re-list these approved markers as problems the next time you click the Check 

Markers button, use the Hide Approved Markers option from the pop-up at top right of the dialog box.

Otherwise, use the List all items option.
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Deleting a Viewpoint/View/Drawing with a Marker

If you delete a viewpoint, the program will first check whether its source/linked markers are located on a 

locked layer or in a different Teammate’s workspace, or whether the marker elements themselves have been 

locked. These markers include:

If none of these markers is locked or reserved, then the program displays a Warning dialog box informing you 

that proceeding with the Delete procedure will delete all of the following:

• The viewpoint (even if its source marker displays the data of a different viewpoint)

• Any views created out of the viewpoint

• All its source/linked markers

If you delete a view, any markers linked to that view will remain in place. However, they will no longer display 

any linked information, just an undefined Autotext. These markers will be listed as problematic the next time 

you run the Check Markers function.

Markers linked to the deleted drawing with “first drawing from viewpoint” will henceforth be linked to the next 

drawing created out of the same viewpoint.

If you delete a drawing, any markers linked to that drawing will remain in place. However, they will no longer 

display any linked information, just an undefined Autotext.
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Deleting a Source Marker

If you delete a source marker, a dialog box appears informing you that deleting a source marker will also 

delete the viewpoint and any markers linked to it.

However, the same dialog box gives you a different option: delete the source marker, but keep the viewpoint 

as an independent viewpoint with no model source.

Deleting a linked marker has no effect on any other element.
ARCHICAD 24 Reference Guide 1709



ARCHICAD Model Views Views of the Virtual Building
Interactive Schedule

Use the Interactive Schedule function to generate schedules. The Interactive Schedule not only displays 

quantities and other parameters - you can actually edit it. Any changes you make in these fields of the 

Schedule are automatically and instantly reflected in the Floor Plan and in other views, when activated. 

Conversely, all changes made on these elements in the Floor Plan or another editable view are updated in the 

Schedule when you return to it.

Schedules are viewpoints, which you can save as views and output as drawings on a Layout, or save in 

various other file formats.

See Save from Schedule Window (Interactive Schedule).

A formatted schedule can be placed into any 2D window (typically a Worksheet), by using Copy/Paste. The 

contents of the schedule, after pasting, will consist of lines and text, which you can freely edit, but will no 

longer be associative to the model.

Topics in this section:

Types of Interactive Schedules

Units in Interactive Schedules

Open and View a Schedule

Show Schedule Data for Selected Floor Plan Items

Editing and Updating Schedule Items

Select Schedule Items on Floor Plan/3D

Define Schedule Content Using Scheme Settings

Create Schedule of Surfaces

Format Options (Interactive Schedule)

Previews and Pictures in the Interactive Schedule

Restructure Schedule to Fit Layout

Split Schedule into Multiple Layouts

Related Topics:

Element Parameters

Component Listing Parameters in the Interactive Schedule

For Teamwork Users:

See Reservation in Interactive Schedules (Teamwork).
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Types of Interactive Schedules

There are three categories of Interactive Schedules:

•  Element Lists show characteristics of basic construction elements

An illustrated list of the parameters, divided by element type, is available here:

See Element Parameters.

• Component Lists are optimized to list information about each component of composite, profile or basic 

elements: walls, slabs, roofs, morphs, meshes, and/or multi-component profile elements).

See Component Listing Parameters in the Interactive Schedule.

See also Component Areas of Complex Profiles.

• Surface Lists list elements by their exposed surfaces.

See Create Schedule of Surfaces.
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Units in Interactive Schedules

An editable value (such as wall height) is shown on the Interactive Schedule in the units defined on the 

Dimensions page of Project Preferences.

See Dimensions Preferences.

A calculated value (such as wall volume) is listed in the Interactive Schedule using the units defined on the 

Calculation Units page of Project Preferences.

See Calculation Units and Rules Preferences.
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Open and View a Schedule

ARCHICAD comes with predefined Schedules, such as Door List; Wall List; Window List. To open any of 

these schedules to list the elements in the current project, double-click the Schedule name in the Navigator.

You can also access Schedules through

• the Mini-Navigator Toolbar 

• Document > Schedules 

• Window > Navigate > Schedules 
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The Schedule window opens. Formatting options are in the left column. To display the schedule only, without 

the formatting panel, click the black arrow on the dividing line.

Navigating in the Interactive Schedule Window

To navigate among fields in the Interactive Schedule window, use familiar keyboard shortcuts:

Move right or left: Enter, Shift+Enter

Move down or up: Tab, Shift+Tab
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Show Schedule Data for Selected Floor Plan Items

To view a Schedule that shows data only for selected Floor Plan items:

1. Select the desired elements (on the Floor Plan only). Use Find and Select if needed.

See also Find and Select Elements.

2. Select the desired Schedule in the Navigator Project Map or View Map.

3. Right-click the schedule name and choose “List Floor Plan Selection Only” to view schedule data for the 

selected items only.

This is a quick way to filter elements for editing as a group, by taking advantage of the Interactive Schedule 

capabilities. You cannot save a view out of the displayed data.
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Editing and Updating Schedule Items

To work on an item of the Interactive Element Schedule, click its column (or row). You will see that some of the 

cells of this column become editable, while others cannot be modified. 

Any changes you make in these fields of the Schedule are automatically updated in the Floor Plan and in 

other views, when activated. Conversely, all changes made on these elements in the Floor Plan or another 

editable view are updated in the Schedule when you return to it.
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Select Schedule Items on Floor Plan/3D

For any selected item in the Schedule Window, click the Select on Floor Plan icon to view it in the Floor Plan 

window.

The icon to its right, Select in 3D, takes you to the 3D Window and zooms onto the selected item.

If nothing in the Schedule is selected, these commands will select all scheduled elements in the Floor Plan/3D 

window.

Note: You cannot edit or select scheduled elements that are on a locked or hidden layer.

See Scheduled Elements on Locked or Hidden Layer.
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Define Schedule Content Using Scheme Settings

The contents of your Interactive Schedule are defined in the Scheme Settings dialog box.

To access this dialog box, do one of the following:

• Click Scheme Settings from the opened Schedule window

• Use the Schedule’s context menu in the Navigator

• In the Navigator Palette, select a Schedule, then click the “Settings” button at the bottom of the Navigator.

• Use Document > Schedules > Scheme Settings

The left panel lists the project’s schemes, grouped by type (e.g. Element Schemes, Component Schemes). 

Select the scheme you want to edit, or use the buttons at the bottom to create, duplicate, delete, import and 

export schemes.

For details, see Schemes Panel.
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The right side shows the Criteria and Fields of the selected Schedule.
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Use the Criteria Panel of Scheme Settings to define the elements/components/surfaces to be listed in the 

schedule.

See Criteria Panel.

In the Fields Panel of Scheme Settings, choose which parameters of the chosen criteria should be displayed 

in your schedule.

See Schemes Fields Panel.
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Create Schedule of Surfaces

The Surface Schedule is the third type of interactive schedule, alongside Element Lists and Component Lists.

Note: Before using the Surface Schedule feature, make sure you are not working in “legacy” intersection 

mode. (Uncheck this option at Options > Project Preferences > Legacy.)

The predefined schemes for Surface Schedules are optimized to list finishes and their exposed areas in 

several formats.

In this template:

• All Finishes lists every visible surface in the model with its total exposed area.

• Finishes of Elements lists the visible surfaces used by each element type, with their respective exposed 

areas. 

The checkbox refers to whether the listed surface differs from that of the element’s Building Material 

surface - i.e., whether it has been “painted over”.
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• Finishes of Openings lists the surfaces (excluding glass) of Doors and Windows. That is, the schedule 

lists the surfaces used for frame, casing, and accessories such as shutters, board, and sill).
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In Scheme Settings, use the available fields as needed to adjust the content of your Surface lists.

For details on setting up a scheme, see Scheme Settings Dialog Box (Interactive Schedule).

Exposed Area is just that: that part of an element’s surface that would be covered by a paint bomb. In the 

follow diagram, the dark blue area is considered as “Exposed”, the light blue areas are considered as 

“Covered”. 

You can define exactly what counts as exposed, using the Reduced Exposed Area control in the Scheme 

Settings of your Surface List (see below). 
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Reduce Exposed Area

In Scheme Settings, click the three-dot button to the right of the field name to bring up the Reduce Exposed 

Area dialog box.

 

Use this dialog box to narrow the definition of what counts as “exposed” when listing Exposed Area in a 

Surface schedule.

In the Reduce Exposed Area dialog box, define criteria for elements that should be considered as covering 

the surface.

For example: normal construction elements are positioned by design, and if they overlap a wall’s surface, that 

wall’s surface area is reduced accordingly.

However, in this example, objects, lamps and zones should not affect a wall’s exposed area, so they are 

expressly excluded.
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Hide Surfaces with Zero Exposed Area: This is checked by default. Areas that are unexposed and 

therefore have zero visible area are not shown in the schedule.
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Format Options (Interactive Schedule)

Use the formatting controls at the left side of the Schedule Window to format the current schedule.

Topics in this Section

Resize Rows/Columns

Adjust Zoom/Fit to Current Window

Display by Rows or Columns

Merge Uniform Items

Apply Format Options to:

Show Headline

Text Style

Cell Borders

Add Printable Footer

Undo/Redo Format Change

Scheduled Elements on Locked or Hidden Layer

Related Topics

Select Schedule Items on Floor Plan/3D
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Resize Rows/Columns

Do one of the following:

• To adjust Schedule Cell Size, click the three buttons at the top of the schedule and use the dialog box.

Use the Resize buttons to automatically adjust rows and columns to fit the content, or enter width/height 

values as needed (multi-select available for the listed items).

• Set the Row Heights field

• To adjust individual row or column heights, manually drag the cell boundaries on the top and left side of 

the schedule.
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• Double-click the row or column edge to fit its contents.

Double-Click: Fit Width to Cell Contents

Adjust Zoom/Fit to Current Window

• Adjust the Zoom using the pop-up from the bottom scrollbar

• To fit the schedule to the current window size, click the Fit to Width icon

Display by Rows or Columns

From the two Style buttons, choose to display the Schedule fields by either rows or by columns.
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Merge Uniform Items

Check this box to group the Schedule’s uniform items in a single record. 

If it is unchecked, all items will be listed individually. 

For items to be uniform, their “core” values must be identical (e.g. same element type, surface, orientation). 

Core values are typically the values that you define in a Settings dialog.

If the only difference between two elements is a calculated value (e.g. area, volume), they are still considered 

uniform.

Length values are more complicated:

• Element length is not a core value; it is usually calculated based on graphical input. Thus, Wall length 

differences are ignored:  identical Walls that have different lengths are merged in the Schedule.

• Element height is a core value; it is usually defined in settings. Thus, Wall height differences are 

considered: identical Walls with different heights are not merged in the Schedule.

• Expression-defined properties that return a Length-type value are always considered “core values”. 

Elements with such length-type properties are not merged unless these property values are identical.

Apply Format Options to:

Choose the items that you will format using the controls below. 

The Preview refers to the element Preview pictures, if any, in the Schedule. (See Format Preview Picture.)

Show Headline

This option lets you display data from one or more schedule fields in a separate row, above (or to the left) of 

the rest of the element data.
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Click Edit to open Headline Settings, to define the content and appearance of the headline data:

• Source of the headline: The first (or first two, or first three) field(s) of the schedule can be displayed in 

the headline. 

If the records are displayed by rows, the headline data appear in a separate column to the left of the other 

fields.

• Insert separator row before headlines: Check this box to insert an empty row before each headline row.

• Add Header text to headlines as prefix: Check this box to add the Column/Row header name as a 

prefix to its value in the headline row. 

• Customize the text format of Headline data, as needed: at Apply Format Options to, choose the Headline 

item.
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See also Schedule Headers, below.

Text Style

Set text format options for the item type selected at Apply Format Options to:

Note: Not available if you have selected “Preview”.
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Text Favorite: Click the pop-up to apply Favorites saved with the Text Tool.

See also Apply a Favorite.

Font Size: Enter the font height, in mm (metric units) or points (imperial units), depending on the choice 

defined in Options > Project Preferences > Working Units.

Font Style: Choose Bold, Italic, Underline, or Crossthrough.

Note: The font styles of Header cells can be customized individually. (All other cells are modified 

collectively, by type.)

Leading: This control modifies the leading value (vertical line spacing), as a percentage. Enter a number or 

use the up-and-down arrows to change the value in increments of 25 percent.

Width: Modify the text character width by entering a percentage value.

Spacing: Modify the spacing between text characters.

Wrap text: Check this option to automatically wrap text so that it fits into the column width.
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Cell Borders

Set cell border options for the item type selected at Apply Format Options to:

• Choose one of three icons to set which cell borders should be displayed.

– None: No border will be drawn.

– Separators Only: The selected line type selected is displayed below each item. If the records are 

displayed by columns, the line is displayed on the right.

– All Borders: Selected line type is displayed on all sides of the cell.

• Choose a Line Type and Pen for the cell border lines.

See Previews and Pictures in the Interactive Schedule.
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Add Printable Footer

1. Check the Enable Print Footer box to add a print-only footer to the Schedule. 

2. Click Edit to open Footer Settings and define the Footer.

– Content: Check the items that should appear in the print footer. Use the arrows on the left to modify 

the order of footer items.

– Text Properties: Set the text format options for the printable footer. Use the preview at the bottom as 

a guide.

3. Click OK.
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Undo/Redo Format Change

Use these buttons to undo/redo the last changes made to the formatting of the Interactive Schedule. 

Scheduled Elements on Locked or Hidden Layer

You cannot edit or select scheduled elements that are on a locked or hidden layer. 

This information is displayed for selected elements in the Information panel:

See also Select Schedule Items on Floor Plan/3D.
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Schedule Headers

The Main Header field is generated automatically at the top of the Schedule: its content is the name given to 

the Schedule in Scheme Settings.

Column Headers are also generated automatically, at the top (or the left) of the columns (or rows) of data. 

Their content comes from the respective field names.

To change a header text, just click into the field and type.

Topics in this Section:

Format Headers

Show/Hide Headers

Insert Header Cell

Freeze Schedule Header
ARCHICAD 24 Reference Guide 1736



ARCHICAD Model Views Views of the Virtual Building
Format Headers

To format header text, make sure that “Header” is selected from the Apply To pop-up, then choose text 

formatting options.

To select multiple cells, use Shift-click.

Show/Hide Headers

From the Settings pop-up, click Show/Hide Main Header or Show/Hide Column Header.

Insert Header Cell

Use this command to create a new header cell above any set of selected column headers. For example, 

select three column headers that refer to Wall dimensions, and create a new header cell above these three 

columns, entitled “Dimensions”.

1. Select two or more column headers (use Shift-click to select multiple cells). 

2. Choose Insert Merged Header Cell Above from Header Options.

Note: Not available unless you have selected at least two adjoining header cells!
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3. A new cell (named “merged” by default) appears above the selected headers. 

4. Type in any header text and format as usual. Any number of header cells can be created in a hierarchical 

order.

• Delete Merged Cell: This is only active if you have manually created a new merged header cell, and have 

selected that cell for deletion. Not available in any other cell.

Freeze Schedule Header

This command ensures that the main header and/or row/column headers rows remain visible on top when you 

scroll down the schedule. 
ARCHICAD 24 Reference Guide 1738



ARCHICAD Model Views Views of the Virtual Building
Previews and Pictures in the Interactive Schedule

Interactive Schedules can include 2D or 3D previews pictures:

Topics in this Section:

Annotate Preview

Automatic Dimensioning of Schedule Previews (Doors/Windows)

Format Preview Picture

Annotate Preview

You can add associative dimensions to these previews in the Schedule.

1. Double-click the cell you wish to annotate, or

Select the cell, then click on Annotate.

2. The view opens in a separate tab/window entitled Element Preview.
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3. Use the available 2D tools to annotate it: dimensions, labels, text. You can also add annotations from 

available libraries, using the Object tool.

4. Click OK from the menu at the top left to close this tab/window and apply the annotations to the selected 

view; or click Cancel to close without applying any changes.
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Automatic Dimensioning of Schedule Previews (Doors/Windows)

For Schedules showing Door/Window previews, the Schedule Options include the Add automatic 

dimensions option.

Check this box to add automatic dimensions to the selected picture. 

Then click Dimension Settings to set dimensioning options for the picture, in the appearing Automatic 

Dimensions dialog box.
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Format Preview Picture

This panel is available if Apply Format Options to is set to Preview, or if a preview cell is selected in the 

Schedule.

Enable Element’s Pen: Check to use the pencolors defined for the element for its preview picture in the 

schedule. 

– If it is unchecked, choose a pencolor in the Contour Pen field below.

Scale: Set the optimal scale for the schedule’s Preview pictures. To fit ensures that the picture will fit in the 

cell, by scaling the preview down if needed (will not scale up). 

Align to: Align the preview pictures in this schedule within their cells: Center, Top or Bottom of the cell, or (for 

2D previews only) to correspond to their relative elevations from the chosen reference level (Story Zero, 

Project Zero, or other defined reference level.)

Note: Not available when Scale is “To Fit”.

Add Automatic Dimensions: Add dimension information Previews in this schedule. Dimensions are 

associative; if the element is modified in the project, the dimensions will be updated.

Note: You can add dimensions manually to any Preview picture by double-clicking its cell, or clicking the 

on-screen “Annotate” command.
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Restructure Schedule to Fit Layout

Note: This function is also available for Project Indexes placed on Layouts.

Use the Restructure Table command to automatically split up large Drawings (e.g. based on Schedules) 

which exceed the Layout size, and to lay out the parts next to each other.

The following image shows a Window Schedule that does not fit onto an A4 sized sheet.

Follow these steps:

1. Make sure that the Schedule (on which the Drawing is based) is using the “Records by Columns” format 

(see Display by Rows or Columns.)

2. Make sure that the Drawing uses the “Fit Frame to Drawing” option (see Drawing Frame).

3. On the Layout: select the Drawing.

4. From the Pet Palette, choose the Restructure Table command, then manually resize the Drawing frame. 
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The result: the Schedule is split in two portions which are placed under each other.

Note: If the selected Drawing is set to Split Drawing into Multiple Layouts, then the Restructure Table 

command will place part of the Schedule onto an additional Layout.

See Split Schedule into Multiple Layouts.
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Split Schedule into Multiple Layouts

Note: This function is also available for Project Indexes placed on Layouts.

If a Schedule-based Drawing does not fit onto a single Layout - as can easily happen with a long Schedule - 

use this feature to quickly and easily split up a long Schedule and place it onto multiple Layouts, so that all 

data on the Schedule can be published.

This feature is available only for Drawings created from Element Schedules and Project Indexes.

1. For the selected Drawing on the Layout: Use the Restructure Schedule pet palette command to 

graphically resize the Drawing’s enclosing rectangle, to enable it to fit on the Layout.

See Restructure Schedule to Fit Layout.

2. In Drawing Selection Settings: go to the Frame Panel and check Split Drawing among Multiple 

Layouts. 

Note: This checkbox is available whenever you place a Drawing based on an Element Schedule onto a 

Layout. For Drawings with any other source, the checkbox is gray.

3. Now ARCHICAD will create as many Layouts as needed to display the entire contents of the Schedule.

In this example, the Window List has been placed on the Layout. The Split Drawing feature has placed the 

total Window List onto three Layouts. In the Layout Window, Layout is drawn to indicate that it consists of 

multiple pages:
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In the Navigator Layout Book, only one Layout is shown, but it has a “multi-page” icon, different from the 

single Layout icon, and the total number of Layouts used for this Drawing is displayed after the Drawing 

Name.

If a Layout Window displays a multi-Layout Drawing, the Window’s title bar shows the range of Layouts which 

display the Drawing.

In the Layout Book, you can navigate between Layout pages as usual, using the navigation arrows at the 

bottom of the Layout Window.
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Project Indexes

Project Indexes are table of contents-type items listed in the Project Map of the Navigator. 

Use Project Indexes to make lists of revisions, issues, views, layout sheets and drawings, based on 

customized criteria.

To open an index, go to the Navigator palette and double-click its name.

Project index content is based on Project Index Schemes.

Like Interactive Schedules, Project Indexes can be saved as views, and you can edit project data directly from 

the Project Index window.
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Index of Published Items

Suppose you are publishing a number of Layouts in a Publisher Set, and you want to include a Sheet Index 

which indicates which items have been published. (The same is available for published views.)

One way to do this is to add the field “Published” to the Index.

This places a field called “Published” on the Sheet Index. Its checkbox will be activated for those items which 

you have published, but only in the published copy of the Index (not while you work in ARCHICAD).

For example, if you publish Elevation layouts, as well as this Sheet Index, then the published Sheet Index 

Layout will look like this:

Related Topics:

Index Settings Dialog Box

Change List and Transmittal History
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Model View Options

The display and output of Model View elements can be set globally in Document > Model View > Model 

View Options.

Model View Options affect the on-screen and output display of construction elements and certain GDL objects 

throughout the project.

Model View Options can be applied to each view. Saved Model View Options Combinations are part of View 

Settings.

Topics in this section:

Define Model View Options

Model View Options Combinations
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Define Model View Options

Use the following panels at Document > Model View > Model View Options:

Construction Element Options

Stair Options

Railing Options

Detail Level of Stair and Railing Symbols

Detail Level of Door, Window and Skylight Symbols

Miscellaneous Settings for Library Parts
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Model View Options Combinations

The list of pre-set Model View Options Combinations is available at Document > Model View > Model View 

Options.

Model View Option Combinations can be applied to individual views depending on their purpose (for example, 

for use as Drafting plans or Site plans).

The active Model View Options Combination is displayed in the Quick Options Bar of the ARCHICAD model 

window. 

Apply a Model View Options Combination to the Project

To apply a Model View Options Combination to a currently active view, do one of the following: 

• Use the MVO Combinations pop-up from the Quick Options Bar at the bottom of the window

• Use the Document > Model View menu 

• Use the View Settings dialog box

• Open Document > Model View > Model View Options and choose one of the defined Model View 

Options Combinations from the top panel. 

• Use View Settings and Storing Options (at the bottom of the Project Map in the Organizer)

• Use the pop-up list in the Properties section of the Navigator Palette (where available)
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Apply a Model View Options Combination to a Saved View

When saving a view from any model window, the view’s current Model View Options Combination is also 

saved. To apply a different Model View Options Combination to any single view, use View Settings.

Use Model View Options Combination in Another Project

You can export and save your stored combination as an.xml file, so you can import and use it in another 

project.

In the Model View Options Combinations panel, click Export to export the selected Model View Options 

Combination as an .xml file to the desired location.

To use it any other ARCHICAD project, open the project and click Import from the same panel to browse for 

accessible .xml files to import as Model View Options Combinations.

Create and Delete Model View Options Combinations

On the left side of the Model View Options dialog box, use the following functions:

New

Creates a duplicate of the currently selected Model View Option Combination, with a new name.
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Delete

Click this button to delete the selected Model View Options Combination. This operation is not undoable.
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On-Screen View Options

The View > On-Screen View Options command produces a list of items (generally aids in editing) that can 

be shown or hidden on screen, depending on your preferences. Other items in this list let you toggle between 

line weight options and vectorial vs. bitmap display of fills.

Most of these options affect element display on the Floor Plan only.

Click any item to toggle its status.

This status has no effect on whether the item will be displayed on your output; it affects only on-screen 

display.

For a quick way to access these commands, activate the Window > Toolbars > On-Screen View Options 

toolbar.

On-Screen View Options Commands

Use the View > On-Screen View Options command to access these options (for a quick way to access these 

commands, activate the Window > Toolbars > On-Screen View Options toolbar).

• Clean Wall & Beam Intersections: Toggles the clean wall and beam intersection mode on and off.

• Walls & Beams Reference Lines: Toggles between displaying walls and beams with their reference lines 

and their contour lines.

• Roof pivot Lines

• Stair Baselines

• Stair Calculated Walking Line
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• Railing Reference Lines

• Opening Reference Planes: This toggle ensures that an Opening will have an on-screen display on the 

Floor Plan, even if it is located entirely outside of its associated host element.

• True Weight: Use this option to toggle the True Weight display of Lines on or off. If it is off, lines will be 

displayed in Hairline, and the following option (Bold Cut Lines) is not applicable.

Note: The Hairline option in On-Screen View Options affects on-screen display only. For hairline output, 

use the Hairline checkbox in the Print or Plot dialog box.

• Bold Cut Lines: Use this option to specify whether Construction Elements are displayed with bold cut 

lines.

• Vectorial Hatching: Use this option to turn Vectorial Hatching display on or off. If it is off, then fills will be 

displayed in their bitmap patterns. This control affects on-screen display only for all Fills (regardless of fill 

type).

• Marker Range: Toggle the on-screen display of Marker Range items - e.g. the input line or polygon 

placed with any of the marker-type tools and the Change tool.

See Display of Marker Range Lines.

• Highlight Source Markers: Toggle the on-screen display of source marker highlights. Source markers 

are those which create a viewpoint when you place them. The color of source marker highlights is set in 

Options > Work Environment > On-Screen Options.

• Drawing Frames: Use this option to show/hide Drawing Frames on the layout.

• Master Items on Layout: Use this option to specify whether Master Items are displayed on the layout. If 

you want a uniform for all Master items, set this in Options > Work Environment > On-Screen Options.

• Dimension Reference Lines: Show/Hide a Dimension Line (on-screen only) while using the Dimension 

Text Only setting.

• Show/Hide Drafting & Editing Aids: Use this option to show or hide all available drafting aids. Drafting 

aids include Fill Handles, Figure Handles, Text Boxes, and Bézier Spline handles.
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Use the next four toggles to show or hide each of these drafting aids individually.

Note: When the Profile Editor window is active, the Fill Handles toggle changes to Component Area 

Base Line/Circle.

See Components Panel of the Profile Editor.

• Trimming Bodies: Use this option to turn the display of Trimming Bodies on or off. Trimming Bodies can 

be shown in the 3D Window only, for Shells and Roofs.

• Opening Cutting Bodies: Turn the display (in both 2D and 3D windows) of Openings’ Cutting Bodies on 

or off. 

• Hidden Morph Geometry: Use this option to show hidden Morph geometry, and thus be able to select all 

Morph edges, including “soft” ones.
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Partial Structure Display

The Partial Structure Display function allows you to display construction elements in various ways depending 

how you define the components of elements.

For example, when collaborating with other designers or with engineers, you may prefer to ignore non-load-

bearing walls, and to display/output only the load-bearing components of complex elements.

To switch the preferred Partial Structure Display Option, do one of the following:

• Use the Partial Structure Display pop-up from the Quick Options Bar at the bottom of the window

• Use Document > Partial Structure Display to set these preferences; they will be applied to the current 

window and can be saved separately for each view.

Use the first three options to display or hide the components of composite or complex elements, and column 

veneers, depending upon how you have defined those components.

See How to Define Components as “Core” or “Finish”.

1. Entire Model: this is the default setting. All parts of the model are displayed.

2. Without Finishes: Model is displayed without:

– skins/components that are defined as “Finish” and 
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– column veneers that are defined as “Finish”

3. Core Only: Displays only the structures defined as “Core” (applicable to complex or composite structures, 

and columns having a veneer)

See also Dimension Skins of Composite/Profile Element Automatically.

4. Core of Load-Bearing Elements Only: The fourth option considers all construction elements (not just 

composite/complex). This option will hide any elements you have classified as “non-load-bearing” or 

“undefined”.

The “Core of Load-Bearing Elements Only” option has three effects:

- Elements classified as “Non-Load-Bearing” or “Undefined” will be hidden; all elements classified as 

“Load-Bearing” are displayed

- Load-bearing composite and complex structures are shown with their Core only

- Column veneers defined as “Core” in Column Settings will be shown in addition to the Column 

cores

Topics in this section:

Applying Partial Structure Settings to Model Windows

Save Partial Structure Settings by View
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How to Define Components as “Core” or “Finish”

Visualizing the Entire Model

Partial Structure Display Settings: Effect on Elements

Partial Structure Display Settings in Windows Based on a Source Marker
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Applying Partial Structure Settings to Model Windows

Unlike Model View Options, which affect 2D windows only, Partial Structure Display affects the display of 

elements in 2D and 3D windows alike.

Partial Structure Display settings can be assigned in the following window types:

• Floor Plan (a single Partial Structure setting is in effect for every Floor Plan window)

• 3D Window (one setting for the 3D window)

• Section/Elevation/Interior Elevation/3D Document: Each instance of these window types can have its 

own Partial Structure Display setting (i.e. you can have three Section windows with three different Partial 

Structure settings).

Exception: You cannot set a Partial Structure Display setting for a Drawing-type Section or Elevation, or 

for any Independent viewpoint.

See Partial Structure Display Settings in Windows Based on a Source Marker.

• Worksheet and Detail: If the source viewpoint is in the Floor Plan or is an Auto-update viewpoint, then 

you can set Partial Structure Display settings for Worksheets and Details (separate ones for each window, 

if needed.)

For a quick way to assign Partial Structure Display to the current window, use the Partial Structure pop-up in 

the Quick Options Palette.
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Save Partial Structure Settings by View

You can save different Partial Structure Display settings on a view-by-view basis; thus, your settings will affect 

the content of published views and layouts.

This means you can save different Partial Display Settings for each view: for example, you can save two 

different views of the same Section, each having a different Partial Structure Display.

Exception: You cannot set a Partial Structure Display setting for a Drawing-type Section or Elevation, or 

for any Independent viewpoint.

See Partial Structure Display Settings in Windows Based on a Source Marker.
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How to Define Components as “Core” or “Finish”

Composite Elements

For composite elements (Wall, Slab, Roof, Shell): skins can be defined as either Core, Finish, or Other in the 

Composite Structures Dialog Box. 

This is relevant if you wish to display the model elements depending on their structure type: this is the Partial 

Structure Display function.

For information, see Partial Structure Display.

1. Open the Composite Structures dialog box from Options > Element Attributes > Composites.

You can also edit a selected composite by accessing its settings from its context menu:

2. Click on a skin in the list to select it.

3. In the Type column, click the pop-up and choose Core, Finish, or Other.

Notes:

– You can define multiple skins as Core, but these skins must be adjacent to each other.

– You can define multiple adjacent skins as Finish, but they must include one or both of the outermost 

skins.
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Column Veneers

Each veneer can be defined as Core, Finish or Other, in Column Tool Settings.

See Core and Veneer.

Profile (Complex) Elements

For Profile elements (Wall, Beam, Column): Components can be defined as Core, Finish, or Other in Design 

> Profile Manager.

See also Components Panel of the Profile Manager.
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Visualizing the Entire Model

Even if you are using a Partial Display option, ARCHICAD gives you several types of feedback to help you 

identify the entire original structure if needed.

You can always choose the Entire Model Display option for your Trace Reference:

1. Activate the Trace function.

2. From the Trace drop-down menu, use Choose Reference, and select Entire Model Display as the 

Trace Reference.

In this Section, the composite walls are displayed with Core-Only settings, but the “Entire Model Display” 

reference (in red) indicates the full wall structure.

When selecting a partially displayed element, hotspots will appear at their original location. The selection 

highlight, however, is shown only on the displayed parts of the elements.

Preselection feedback will also help you identify the entire as well as the partially displayed parts of the 

elements. The pre-selection highlight is shown only on the displayed components, but the cursor recognizes 

the reference line even if it is not on a displayed part of the element - as shown by the bold Mercedes cursor 

in this image.
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The Info Tag displays the Thickness of the original, entire element, even if it is currently only in Partial 

Display:
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Partial Structure Display Settings: Effect on Elements

This page contains element-specific information on the effect of Partial Structure Display.

Columns In Partial Structure Display

Zones and Partial Structure Display

Floor Plan Cover Fills in Partial Structure Display

Dimensions in Partial Structure Display

Intersections of Partially Displayed Elements

Columns In Partial Structure Display

Each veneer can be defined as Core, Finish or Other, in Column Tool Settings.

See Core and Veneer.

For Columns “wrapped” by walls: No wrapping occurs if you are using Core only display.

Zones and Partial Structure Display

Regardless of which Partial Display option is in effect, zones are not affected: zones that extend to an “Inner 

Edge” are calculated to include the “finish” component of a surrounding structure, even if the finishes are 

hidden according to the current Partial Structure Display Setting.

Floor Plan Cover Fills in Partial Structure Display

The Partial Structure Display setting has no effect on cover fills.

If you have assigned a Cover Fill to any composite or complex element (this might be a Roof, Slab, or Mesh), 

then the Cover Fill will appear regardless of the Partial Display option that is in effect.

Note: Cover Fills can use Graphic Overrides.

See Graphic Override Rules.

Dimensions in Partial Structure Display

Each Partial Display mode has its own set of dimensions: you can have a set of dimensions in your Core Only 

view, and other sets of dimensions in your Entire Model and Without Finishes views. If you switch between 

Partial Structure Display settings, the dimensions associated with the earlier Display setting will not 

be visible. To see the Dimensions again, switch back to the Partial Structure Display setting in which the 

Dimensions were placed.
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This wall is displayed with the Core Only display setting:

If you now switch the display setting to Entire Model, the dimension shown in Core Only disappears, and the 

other dimension - the one previously created with the Entire Model display setting - appears.

You can copy-paste dimensioned elements between two views whose Partial Structure Display settings are 

dissimilar. However, if you try to paste dimensioned elements that do NOT appear in the given Partial 

Structure display, those dimensions will be lost after you paste. 

Intersections of Partially Displayed Elements

Intersections will behave just as they do when the entire model is displayed: No further skin intersections will 

be cleaned up as a result of changing to partial display.
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Partial Structure Display Settings in Windows Based on a Source Marker

Often, you will be working in a model view (Section, Elevation, Interior Elevation, Detail or Worksheet) in 

which the elements have their source in a different model window.

However, if a your source viewpoint is a Manual-Rebuild or Drawing-type view/viewpoint, you would run into 

problems if you tried to change the derived view’s Partial Structure Display Settings, because the source 

viewpoint might not be in updated condition. Therefore, ARCHICAD does not let you change the Partial 

Structure Display settings for views derived from Manual-Rebuild or Drawing-type sources.

The following view settings belong to a view whose source is a Manual-Rebuild model; the Partial Structure 

Display settings cannot be changed.

The solution: go back to the source view (or make a copy of it) and change its update type to Auto-update.

In the opposite case: Suppose you have an Auto-update viewpoint with several views derived from it. Then 

you change the viewpoint to “Manual Update” or “Drawing type.” This is possible, but be aware that the views 

deriving from this source - even if you’ve already created these views - will, when rebuilt, change their Partial 

Display settings to match those of the source viewpoint.

If you do change the Partial Structure Display settings of a source viewpoint which is of Manual Rebuild type 

(even though its derived views are based on an Auto-Rebuild source), ARCHICAD warns you of the 

consequences for the derived views: the views’ Partial Structure Display and Graphic Override settings might 

change:
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You can go ahead and continue Rebuild, or you can cancel the process. Again, the solution is to go back to 

the source view (or make a copy of it with the Partial Display Structure/Graphic Override settings you need) 

and change its update type to Auto-update.
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Renovation

Use the Renovation feature set to create views that provide visual feedback on the status of each element at 

a particular stage of a renovation project.

To achieve this, each element is assigned one of three Renovation Statuses:

• Existing;

• To be Demolished;

• or New.

Note: By default, all elements have a Renovation Status of “Existing.” New elements that you add to the 

project are also set to “Existing.”

You can then assign view settings, called Renovation Filters, to display the project at various stages: such 

as “Demolition Plan” or “New Construction.” Renovation Filters show/hide elements and/or provide graphical 

highlighting (Graphic Override) depending on their status, to convey information on their renovation status.

ARCHICAD comes with predefined Override Rules for each of the three Renovation Statuses. If you have 

different style preferences, use the Graphic Override Rules dialog box to redefine them.

Since the Renovation Filter is saved with the view, it also affects the appearance of the Drawings in your 

documentation.

Watch the Video

Related Topics:

Assign Renovation Status to Elements

Renovation Filters

Graphic Overrides By Renovation Status

Best Practices for Creating Renovation Views

Workflows for Tricky Renovation Situations

Reset Renovation Status
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Assign Renovation Status to Elements

See also Reset Renovation Status.

Use Renovation Palette to Set Default 

1. Open the Renovation Palette from Window > Palettes > Renovation.

2. With nothing selected, choose a Status to assign to all newly placed elements:

Use Renovation Palette to Change Renovation Status

1. Select one or more elements to which you want to assign a different renovation status.

2. From the Renovation Palette, click the icon representing the status you need.

• Existing Element: to be retained

• New Element: to be built during the current renovation process

• To Be Demolished Element: to be demolished during the current renovation process

For example, in an existing project, select all the elements to be demolished, then click the “To be 

Demolished” icon. This way, you change the status of all those elements to “To Be Demolished” with a single 

click.

Use Element Settings to Change Renovation Status

Change the renovation status of selected elements (if they are all of the same type) in the Classification and 

Properties panel of the element Settings dialog box:

Note: If you have several element types selected, use the Renovation Palette or the Edit Selection Set 

palette to change their Renovation Status simultaneously.
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The Renovation controls in the Settings dialog box are active only for selected elements.

(If nothing is selected, the Renovation controls in the tool Default Settings are gray; use the Renovation 

Palette to set a default Renovation Status for all elements.)

Choose Default Renovation Status for Newly Placed Elements

By default, all elements have a Renovation Status of “Existing.” New elements that you add to the project are 

also “Existing.”

However, you can reset this default for all subsequently placed elements, using the Renovation Palette.

1. With nothing selected, click the icon of the Renovation Status you wish to be the default - for example, 

“New.”

2. Now, all elements you place - regardless of which tool you use - will automatically be assigned the “New” 

status.

It may be useful to set a default (e.g. New) before you begin to place additional elements in an existing 

project. This will save you the step of having to define those elements’ status as “new” retroactively.
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Renovation Filters

Use Renovation Filters to display your project to reflect different stages of renovation

The given Renovation Filter (such as Demolition) defines how or whether elements are displayed in the 

project, depending on their Renovation Status.

• Show the elements with their default display, or

• Hide the elements, or

• Show the elements with an Override.

Since the Renovation Filter is saved with the view, it also affects the appearance of the Drawings in your 

documentation.

Exception: You cannot set a Renovation Filter setting for views that are based on Drawing-type or 

Manual-Rebuild Section or Elevation markers.

ARCHICAD comes with several predefined Renovation Filters, but you can change the options at 

Document > Renovation > Renovation Filter Options.

Topics in this section:

Apply Renovation Filter

Show an Element in a Single Renovation Filter Only

Renovation Filter Options

Examples of Renovation Filters
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Apply Renovation Filter

To apply a different Renovation Filter to the current tab/window, do one of the following:

Use Quick Options

• Use the Renovation Filter pop-up from the Quick Options Bar at the bottom of the window

Use Renovation Palette:

From the Renovation Palette, click the desired filter from the Renovation Filter pop-up:
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Show an Element in a Single Renovation Filter Only

During the course of your Renovation project, you may wish certain specific elements to be visible only if a 

particular Renovation Filter is in effect.

To achieve this, you must define the selected element(s) as specific to the current Renovation Filter. The filter-

specific element(s) will be shown only in that single Renovation Filter, and will not exist in any other 

Renovation Filter.

Note: Of course, the filter-specific element will be shown in that Renovation Filter only if its Renovation 

Status would ordinarily be shown in that Renovation Filter.

You can define a selected element as “filter-specific” either on the Renovation Palette, or in its Selection 

Settings (Classification and Properties Panel).
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Renovation Filter Options

Use this dialog box (Document > Renovation > Renovation Filter Options) to define which elements (by 

Renovation Status) should be shown, hidden, or overridden in a Renovation Filter.

You can change the settings of existing filters, or create new Renovation Filters.

Renovation Filter Options are stored with the project.

See also Examples of Renovation Filters.

Open Renovation Filter Options Dialog Box

Do one of the following:

• Click the Reno Filter Options icon from the Quick Options Tab

• Go to Document > Renovation > Renovation Filter Options

• Click Renovation Filter Options from the pop-up in the Renovation Palette.
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Choose a Filter to Edit

Use the pop-up at the top of Renovation Filter Options to choose the Filter you want to view or edit.

• Duplicate: Create a new Renovation Filter by duplicating the selected filter under a new name and editing 

its properties.

• Rename: Rename the currently selected Renovation Filter.

• Delete: Remove the selected Renovation Filter from the project.

• Import: Add a saved Renovation Filter (.xml file) to your project.

• Export: Save the selected Renovation Filter (.xml file) to an external location. It can then be imported to 

another ARCHICAD project.

Define Show/Hide/Override By Renovation Status

For the selected Renovation Filter, define which elements, depending on their Renovation Status, should be 

shown, hidden, or overridden whenever this Renovation Filter is in effect.
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For each Renovation Status, choose either Show, Hide, or Override.

• Show: Elements of this Status will be shown using the fills/colors/lines as set in their Settings dialog box.

• Hide: Elements of this Status will not be shown at all.

• Override: Elements of this Status will be shown, using the Override Style defined in the Graphic Override 

Rules dialog box.

Note: To open this dialog box, click the button at the bottom of Renovation Filter Options, or use 

Document > Graphic Overrides > Graphic Override Rules.

For more information, see Graphic Overrides By Renovation Status.

Add Additional Overrides to the Renovation Filter

Additional Override options are available for “Existing” elements, for “To be Demolished” elements, and for 

Annotation Elements.

These extra options help you meet local standards or make your Renovation views easier to interpret.

Check the box of any of the Additional Overrides you wish to add to your Renovation Filter definitions:

For “Existing” Elements:

• Hide Opening Dimension Marker (if you don’t need to see dimensions of openings already in place)

• Solid Cut Fill (if you don’t need to see the structure of walls already in place)
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• Do not Intersect (use this to ensure that intersections among New or Demolished walls do not interfere 

with existing wall intersections)

For “To Be Demolished” Elements:

• Hide Opening Dimension Marker (if you don’t need to see dimensions of openings that will soon no 

longer exist)

• Hide Door/Window/Skylight/Opening Symbol (if you don’t need to see openings that will soon no 

longer exist, especially if they are part of walls to be demolished anyway)

• Hide Zone (if you don’t want to see information for zones that will be eliminated)

• Hide Objects (since most furnishings will not really be demolished; and they don’t need to be visible on 

the Demolition Plan)
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• Solid Cut Fill (if you don’t need to see the structure of walls that will be demolished)

• Transparent Fill (to indicate the place of a demolished element with just lines, no fill)

• Do not Intersect (to ensure that intersections among New or Demolished walls do not interfere with 

existing wall intersections)

• Mark Openings with “X” Symbol: Place an X on Doors and Windows to be demolished.

For Annotation Elements:

• Do not Override Dimensions/Texts/Labels

• Do not Override Drafting Fills/Lines

Use these checkboxes to exclude Annotation Elements - Dimensions, Texts and Labels, and/or Drafting Fills 

and Lines - from the filter settings.

For example, this way you can make sure your labels and texts continue to be shown normally (as in the 

image on the right), even on a Demolition Plan:
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Examples of Renovation Filters

The following are examples of how different Renovation Filters can affect the display of your project.

1. Change Plan: Here, existing elements are shown in their default display (“Show”), while new elements 

and elements to be demolished are highlighted with their respective Graphic Overrides (here, red and 

yellow).

2. Existing Plan: In this filter, “New” elements are hidden. Other elements (with a status of either “Existing” 

or “To Be Demolished”) are all shown with their own settings. In this Existing Plan filter, you get no visual 

information on demolition plans.

3. Demolition Plan: Here, elements with a status of “To Be Demolished” are shown with Overrides, so you 

see at a glance what is to be demolished, and what is to remain. (“New” elements are not seen at all - the 

New Elements setting is “Hide”).
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4. After Demolition: This is just like the Demolition Plan filter, except that the “To Be Demolished” elements 

are gone. Only Existing elements are shown.

One way to use this filter is to help determine the total quantities of new and demolished construction 

materials in the project.

See Listing Material Quantities for Renovation Projects.

5. Planned Status: This filter is used to show the project’s final status. New elements and Existing elements 

are all shown with their default display (“Show”). Demolished elements are not shown at all (“Hide”).
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Related topics:

Graphic Overrides By Renovation Status

Openings By Renovation Status: Override Examples
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Graphic Overrides By Renovation Status

ARCHICAD comes with predefined Override Styles for each of the three Renovation Statuses. 

To change these default styles, use the Graphic Override Rules dialog box (Document > Graphic 

Overrides > Graphic Override Rules).

See Graphic Override Rules.

Note: The Graphic Override Rules dialog box is also available from the Renovation Filter Options dialog 

box (click the “Graphic Override Rules” button).

The first three Rules (at the top left of the dialog box) correspond to the three Renovation Statuses: New, 

Existing, and To be Demolished.

Select the Rule for which you want to redefine the override style.

For Renovation-based rules, the “Criteria” panel is not editable. (Renovation Status is assigned to model 

elements individually, rather than by criteria.)

Use the Override Style panel to adjust the style settings for each Renovation Rule:

• Line type

• Line/Marker/Text pen

• Fill type

• Fill foreground pen

• Fill background pen
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• Surface

For details, see Define Override Style.

See also Exceptions: When Overrides Don’t Apply.

In addition to the override settings listed here, you may wish to include one or more additional override 

settings in your Renovation Filter. These can be chosen in the Renovation Filter Options dialog box.

See Add Additional Overrides to the Renovation Filter.

Watch the Video
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Openings By Renovation Status: Override Examples

Examples of default display of walls with windows shown with Override:

NEW wall in red (-> window is also red for NEW, no demolition)

TO BE DEMOLISHED wall in yellow (-> window is also yellow for TO BE DEMOLISHED)

Window MOVED from right to left

To communicate a modified element with the Renovation feature - such as a window that is moved - you must 

model the window twice: in its original location and in its new location.

Select the original window and set its Renovation Status to To be Demolished. Note that the window frame is 

yellow (it will be demolished), but the wall beneath it is red (it will be rebuilt).

Select the window in its new location and set its Renovation Status to New. Note that the window frame is red 

(it will be built as new), but the wall beneath it is yellow (it will be demolished to make room for the window).

ARCHICAD automatically displays any overlap (between the window’s old locations) in white.

• On the right: the yellow window frame must be demolished. The red part - formerly the window opening - 

is new wall.

• On the left: the yellow wall part must be demolished to make room for the opening. The red frame is the 

new frame.

• In the middle: the white part was part of the opening before, and remains part of the opening after.
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Best Practices for Creating Renovation Views

Save Filter Options with Project Template

Renovation Filter Options are stored with the project. Save the project as a template file, then use that 

template when creating new projects to ensure that your preferred renovation options are available by default.

Export Configured Filter Options to Another Computer

From the Renovation Filter Options dialog box, export your preferred settings as an XML file. You can then 

import this file to be able to use your Renovation Filter Options on another computer.

Building Modeling

1. While you are working in Existing Plan view, keep the Renovation Status setting on “Existing”. This way, 

all new elements are classified as Existing.

2. Next, switch the Renovation Filter to “New Construction” or “To be Demolished”. Select the elements to be 

demolished, then use the Palette icons to switch their Renovation Status from Existing to “To Be 

Demolished.” 

3. Finally, before you start modeling the new elements, make sure you are in the “New Construction” 

Renovation Filter. Switch the default Renovation Status to “New”. All new elements you create now get a 

Renovation Status of “New.”
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Workflows for Tricky Renovation Situations

ARCHICAD’s Renovation feature depends on assigning the proper Renovation Style to individual elements, 

and then displaying them in the different filters corresponding to the different stages of the renovation process. 

In most cases, once you have assigned element styles and defined filter options, you can see the graphical 

feedback just by clicking from view to view - from Existing Plan to New Construction to Planned Status. The 

display of elements changes automatically.

However, some renovation processes involve element components - not just discrete elements - and so their 

style cannot be conveyed just by switching from one view to another. There are ways to get around this 

constraint: by recreating the needed elements separately in each view, and assigning their correct renovation 

status.

You can use the Renovation palette’s “Show on current Renovation Filter Only” function to restrict the display 

of any element to a certain Filter - so that the element is visible only in a particular view filter.

See Show an Element in a Single Renovation Filter Only.

You can set up views for Interactive Schedules that help you determine the total quantities of new building 

components to be acquired, and of demolished building materials to be carted away.

See the examples below:

Adding Insulation to Walls: Renovation Workflow

Adding New Door Panel to Existing Door Frame: Renovation Workflow

Zone Stamps for Renovated Rooms: Renovation Workflow

Listing Material Quantities for Renovation Projects
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Adding Insulation to Walls: Renovation Workflow

If you want to add a layer of insulation to an existing wall, you simply add an insulation skin to the composite 

wall. However, you cannot assign “New” status to just a single component of a wall - only to the wall itself.

To distinguish (for Renovation Filter purposes) the new insulation added to the original wall, the following 

workflow is recommended:

Existing Plan View

1. In the Renovation Palette, assign the original wall (Wall 1) a status of “Existing”.

New Construction View

In this view, you want to show both the Existing and the New components of the wall.

2. Alongside Wall 1, place another wall (Wall 2) alongside it to represent insulation. Define Wall 2 as “New”.

This way, only the new part of the Wall - the insulation part - is displayed as “New” in this view.

Planned Status View

3. Here, both Wall 1 and Wall 2 are shown with their own original attributes.

Note: Door and Window openings must be added to each separate Wall layer that is modeled in this 

workflow.
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Adding New Door Panel to Existing Door Frame: Renovation Workflow

If you are adding a new door panel to an existing frame, the following workflow can be used for your 

Renovation filters:

Existing Plan View

In the Renovation Palette, assign the original frame (Door 1) a status of “Existing”, but set it to be shown on 

the current filter only (i.e. Existing Plan).

New Construction View

In this view, you want to show both the Existing frame and the New door panel to be added to it. In the place 

of the original door frame (which was displayed only in Existing Plan), place an identical door frame (Door 2) 

with a status of “Existing”.

To represent the new door panel, draw an opening line and assign this line a “New” status.

Both elements (Door 2 - “Existing” and the opening line - “New”) should be Filter-specific for the current filter.

This way, only the new part of the door is displayed as “New” in this view.

Planned Status View

Here, place the final Door (Door 3), complete with frame and panel, with a status of “Existing”, and filter-

specific for current (Planned Status) filter.
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Zone Stamps for Renovated Rooms: Renovation Workflow

This workflow is used to reflect the renovation process in Zone Stamps.

Suppose you have a zone that represents a closet, and it is to be transformed into a bathroom.

In Existing Plan View (the starting point) and in Planned Status view (the ending point), place Zone Stamps 

accordingly:

• The first Zone Stamp, in Existing Plan, has a status of “Existing” and is filter-specific. (It shows data for the 

closet.)

• The final Zone Stamp, in Planned Status view, has a status of “New” and is filter-specific. (It shows data for 

the bathroom.)

There is no way to use a single Zone Stamp to express two renovation styles (demolish the closet, build a new 

bathroom), so in the interim New Construction view, you should use two text boxes instead of a Zone Stamp:

• The first text box shows the closet’s data and has a status of “Demolish.”

• The second text box shows the bathroom’s data and has a status of “New.”

This way, in this view only, the first text box, for the item to be demolished, will be displayed in yellow (the 

override style for “Demolish.”). Below it, the second text box, for the item to be built, will be displayed in red 

(the override style for “New”).
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Listing Material Quantities for Renovation Projects

This workflow explains how to set up views for Interactive Schedules that help you determine the total 

quantities of demolished building materials to be carted away, and of new building components to be 

acquired.

Note: The Renovation Filters cited below refer to filters whose settings are described at: Examples of 

Renovation Filters.

List Quantities of Demolished Materials

1. Use the Interactive Schedule to set up two separate Component Lists. Both Component Lists should use 

identical Scheme Settings, listing the parameters you need for the relevant construction elements (e.g. 

Walls, Slabs, Columns, Roofs).

Note: Component Lists are recommended here (rather than Element lists), because they allow you to 

disregard non-material components such as air space in the calculation. Component Lists also lets you 

categorize demolished components (e.g. recyclable, hazardous waste, etc.)

2. Save these Component Lists as views.

3. In one view, apply the Existing Plan Renovation Filter.

4. In the other view, apply the After Demolition filter.

5. Compare the two lists to determine the differences in material quantities.

For Doors/Windows and other non-construction elements:

1. Use the Interactive Schedule to set up two separate Element Lists using identical Scheme Settings, listing 

the parameters you need for Doors and Windows. (You cannot make Component lists for Doors and 

Windows.)

2. In one view, apply the Existing Plan Renovation Filter.

3. In the other view, apply the After Demolition filter.

4. Compare the two lists to determine the differences in quantities.

List Quantities of New Materials:

This workflow is almost the same as the one detailed above, except that you will use different Renovation 

Filters in the views to be compared:

• In one view, apply the After Demolition Renovation Filter.

• In the other view, apply the Planned Status filter.

Compare the two lists to determine the differences in material quantities.
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Reset Renovation Status

When a renovation project is finished, you will need to update all elements’ renovation status: for example, 

those that were “To be Demolished” can now be deleted; those that were “New” are now “Existing.” 

The reset will be applied to all elements in all views, including your annotations. 

To do this, use Document > Renovation > Reset Renovation Status.

In the appearing dialog box, use the pop-ups to redefine element status for each of the three Renovation 

Statuses (or keep them as is).

Note: To ensure that all of your elements have their status redefined, make sure you check the “Show All 

Elements on All Relevant Filters” box. Elements that remain pinned to a particular filter (“Show on specific 

Renovation Filter only”) cannot be reset to a status that is not visible on that specific filter.
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Graphic Overrides

Use Graphic Overrides to apply a predefined appearance (color, fill) to model elements by view, to convey 

information at a glance.

For example: 

• Display elements in different colors based on their Renovation Status

• Display all plaster walls in blue

• Highlight all elements having a specific acoustic rating or fire rating

• Highlight a group of zones which belong together (e.g. unheated areas)

• Check the consistency of the model

Zones by Fire Rating

The element’s Info Tag lists the Graphic Override Rules, if any, in effect for this element:

There are two ways to assign a Graphic Override to a model element:

• By Graphic Override Combination: A Graphic Override Combination (a View Setting) is a collection of 

Override Rules applied, in a defined order, to the elements that fit the Rule(s). 

• By Renovation Filter: The Renovation Filter (a View Setting) defines which elements (by Renovation 

Status) should be displayed with an override. 

In any view, the Rules of the Graphic Override Combination are applied first. The Rules applied by the 

Renovation Filter are the lowest priority.

Some elements might be subject to several Rules: for example, “all plaster walls have a blue override and “all 

elements with “New” Renovation status have a red override.”
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In this case, a wall that fits both of these Rules gets the blue override, because the Rules of the Graphic 

Override Combination are applied first.

Related Topics:

Graphic Override Rules

Graphic Override Combinations

Exceptions: When Overrides Don’t Apply
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Graphic Override Rules

A Graphic Override Rule consists of two parts:

• Criteria (which elements should get an override?)

• Override Style (what should the override look like?)

Graphic Override Rules Dialog Box

To create and edit Rules, use the Graphic Override Rules dialog box, available from:

• Document > Graphic Overrides > Graphic Override Rules

• the Graphic Override Combinations dialog box: click the Edit Rules button

• the Renovation Filter Options dialog box: click the Graphic Override Rules button 

Watch the Video

Rules are listed on the left side of the dialog box.

Select any Rule to see its definition in the Criteria and Override Style panels on the right.

To help you identify Rules quickly, icons next to each Rule name indicate the Line Type, Fill Type, Foreground 

and Background Pens, and the Surface (if any) defined for this Rule. 

The first three Rules correspond to the three Renovation Statuses: Existing, To be Demolished, and New.
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Create New Rule

1. Click the New button at the bottom of the Graphic Override Rules dialog box.

2. In the New Rule dialog box, enter the Rule name.

Optionally, check “Duplicate Rule” to duplicate the definition of an existing rule (from the drop-down list) 

under a new name.

Note: The Rules for the three Renovation Statuses cannot be duplicated.

3. Click OK to create the new Rule.

Next, use the panels on the right side of the dialog to define Rule’s Criteria and Override Style. These 

controls are detailed below:

Define Rule Criteria

Use the Criteria panel to define which elements the selected Rule should apply to.

Note: Criteria for the three Renovation Statuses cannot be edited. (Renovation Status is assigned to 

model elements individually.)
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1. In the Criteria list, the first line is always Element Type. (Sub-elements, such as Curtain Wall Panel or 

Morph face, are not available here.)

2. Select this first line, then click the black arrow at the end of the row to choose a value for this criterion from 

the pop-up (that is, the element type(s) to which this Rule should apply).

3. To define additional criteria, click the Add... button to bring up a list of Parameters & Properties. Choose 

criteria (use the search field at the top to find it more quickly), then click Add (or press Enter) to add it to 

the list.

4. You can add additional Element Types, plus any more criteria as needed. The list of available criteria 

depends on the element(s) defined in the row(s) above.

Note: This interface is similar to that of the Find and Select dialog box, but IFC Properties are not 

available here.

See Define Additional Criteria: Parameters & Properties.

Note: Defining a “Layer” or “Layer Combination” as a criterion means that the override can affect 

elements which are visible according to the given Layer Combination.

Watch the Video

Watch the Video
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Define Override Style

Use the Override Style panel to define how to display elements which fit this Rule’s criteria.

Check the boxes of the attributes you want to override. 

For each such attribute, define the type (e.g. pen color, line type) as applicable.

• For Fill-related controls (Fill Type, Fill Pen, Fill Background Pen): Click one or more icons to the right 

of the control to choose which category (Drafting Fill, Cover Fill, Cut Fill) should be affected by the 

override. (At least one fill category is always activated.)

• For Surface: Click one or both icons to apply the override to Cut and/or Uncut Surfaces.

Note: In addition to the override settings listed here, you can include additional override settings in your 

Renovation Filter. Set these in the Renovation Filter Options dialog box.

Watch the Video

Related Topics

Assign Renovation Status to Elements

Graphic Override Combinations

Renovation Filter Options

Apply Renovation Filter
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Apply Graphic Override Rules

Rules are applied in two ways: 

• By Graphic Override Combination: A Graphic Override Combination (a view setting) is a collection of 

Graphic Override Rules, applied in a particular order to the elements that match the Rule’s criteria.

• By Renovation Filter: The Renovation Filter (a View Setting) defines which elements (by Renovation 

Status) should be displayed with an override

Watch the Video
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Graphic Override Combinations

A Graphic Override Combination (a View Setting) is a collection of Graphic Override Rules, applied to the 

elements of the model view in a particular order.

To see which Graphic Override Combination is currently in effect for the active tab/window:

• Check the Quick Options Bar or Quick Options Palette

• Go to Document > Graphic Overrides, where the current Combination is checked in the list.

To manage these settings, use the Graphic Override Combinations dialog box at Document > Graphic 

Overrides > Graphic Override Combinations.

Watch the Video

The left side of the dialog box lists the project’s defined Graphic Override Combinations. The top one, No 

Overrides, is predefined and not editable.

Click New to create a new Graphic Override Combination and assign Rules to it.

The right side contains the Name of the Graphic Override Combination.

Below, the Rules contained in this Graphic Override Combination are listed in the order they are applied to 

elements.

Add, Remove or change the order the Rules as needed. (See Order of Rules, below.)

To edit a Rule, do one of the following to access the Graphical Override Rules dialog box:

• Double-click on a Rule
ARCHICAD 24 Reference Guide 1801

https://youtu.be/kb8S3lO5twU


Graphic Overrides Views of the Virtual Building
• Select the Rule, then click the Edit Rule button at the end of the row 

• Click the Edit Rules button at the bottom of the dialog box 

Order of Rules

Rules in a Graphic Override Combination are applied in the order that they are listed. This is important, 

because some elements might be subject to several Rules, and if the Rules conflict (e.g. all plaster walls are 

blue, and all elements with a Fire Rating of 30 min are red), then a wall that fits both of these Rules will get the 

override from the Rule that is higher up in the list.

Remember that an element will be affected by all the Rules which are not in conflict. For example, all 

elements have an empty fill, and all walls use a red pen: both are applied to all the walls.

Use the up/down arrows at the left of each Rule to drag it to a new position as needed.

Note that Rules applied by Renovation Filter is at the bottom of the list (lowest priority), and its position in 

the Graphic Override Combination cannot be changed.

Apply a Graphic Override Combination

To apply a Graphic Override Combination to the active tab/window, do one of the following: 

• Use the Graphic Override Combination pop-up from the Quick Options Bar at the bottom of the window

• In the Graphic Override Combinations, select a Combination listed on the left; click OK to close the 

dialog box 

• Choose a Combination from Document > Graphic Overrides menu 

• Use View Settings and Storing Options (at the bottom of the Project Map in the Organizer)

The current Graphic Override Combination is saved along with the view. 
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Export/Import Graphic Override Combination

Click Export to export the selected Graphic Override Combination as an .xml file to the desired location.

To use it in any other ARCHICAD project, open the project and click Import from the same dialog box to 

browse for an .xml file to import as a Graphic Override Combination.

The imported Combination and all of the Rules it contains are merged with those of the project.

If an imported Rule has the same name as a Rule already in the project:

• If the two Rules’ contents are exactly the same, no duplicate is created

• If the two Rules’ contents differ, then the imported Rule is merged to the project, and its name gets a new 

suffix.
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Exceptions: When Overrides Don’t Apply

Line Type override does not apply to:

• Dimension Lines

• Column Symbol lines

• X Symbol used for Openings

• Frames of Drawings, Text boxes and Labels

• Fill handles, Spline handles

Fill Type override does not apply to:

• Opaque fill of Texts and Labels

• Figures, Drawings, PDFs

Fill Background Pen override does not apply to:

• Transparent (0) background pens
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Element Parameters

The following sections list the general and tool-specific parameters available for the fields of Element 

Schedules.

General Listing Parameters

Beam Listing Parameters

Column Listing Parameters

Column Segment Listing Parameters

Curtain Wall Listing Parameters

Curtain Wall Accessory Listing Parameters

Curtain Wall Frame Listing Parameters

Curtain Wall Junction Listing Parameters

Curtain Wall Panel Listing Parameters

Window/Door Listing Parameters

Fill Listing Parameters

Lamp Listing Parameters

Mesh Listing Parameters

Morph Listing Parameters

Object/Lamp Listing Parameters

Opening Listing Parameters

Railing Listing Parameters

Railing Segment Listing Parameters

Railing Members Listing Parameters

Shell Listing Parameters

Skylight Listing Parameters

Roof Listing Parameters

Shell Listing Parameters

Skylight Listing Parameters

Slab Listing Parameters

Stair Listing Parameters

Stair Finish Listing Parameters

Stair Structure Listing Parameters

Wall Listing Parameters

Zone Listing Parameters

Component Listing Parameters in the Interactive Schedule

Related Topic:

Interactive Schedule

Component Listing Parameters in the Interactive Schedule
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General Listing Parameters

Parameter Short Description Long Description

2D Cross Section 

Preview

  

2D Plan Preview   

3D Axonometry   

3D Back View Shaded 3D Symbol of the 

GDL element (Object, 

Lamp, Skylight, CW Panel, 

CW Frame).

3D Symbol of the Frame.

Back = inside of the Curtain Wall

3D Front View Shaded 3D Symbol of the 

GDL element (Object, 

Lamp, Skylight, CW Panel, 

CW Frame).

3D Symbol of the Frame (from the front, that is, the outside of the Cur-

tain Wall).

Front = outside of the Curtain Wall

3D Holes Perime-

ter

Total Perimeter of all the 

holes in the Shell or Roof. 

Does not take SEO's into 

account.

Relevant for Roof or Shell.

3D Left Side View Shaded 3D Symbol of the 

Object/Lamp or CW Junc-

tion/Accessory.

Cross-section of the Accessory viewed from its left side.

3D Length Maximum 3D length of con-

struction element

Available for

- Wall

- Beam/Beam Segment

- Column/Column Segment

- Railing/Railing Segment

- Stair Structure

3D Perimeter Total perimeter of the 3D 

shape of the element, 

including the perimeter of 

any holes.

Relevant for Roof, Shell, CW Panel

3D Right Side View Shaded 3D Symbol of the 

Object/Lamp or CW Junc-

tion/Accessory.

Cross-section of the Accessory viewed from its right side

Absolute Top Link 

Story

Name of the element's top-

linked story.

Relevant for Wall/Column/Zone/Stair

For example: 1. Story

ARCHICAD IFC ID The Globalid IFC attribute 

automatically assigned by 

ARCHICAD to each ele-

ment
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Area For most elements: area 

includes the full extent of 

the element surface geom-

etry (net of any holes) 

viewed from the top, as 

projected down to the floor 

plan.

For a Column (or column segment): Area of the column's bottom poly-

gon only, as projected to the floor plan.

For a Wall: Area of the Wall's bottom polygon only, as projected to the 

floor plan.

Building Material Name of the element's 

Building Material

For non-composite, non-complex profile elements

Building Material / 

Composite / Pro-

file / Fill

Name of the element's 

Building Material, or its 

composite structure, or its 

profile, or its fill

 

Building Materials 

(All)

Lists all of the element's 

Building Materials in a sin-

gle Schedule cell

 

Colliding Zones The name of the Zone with 

which the element collides 

in 3D.

Elements must intersect the Zone to be considered as "Colliding". Bor-

dering the Zone is not considered collision.

For Columns: If its Relation to Zones option is set to "Zone Boundary" 

or "No Effect on Zones", it is not considered collision, even if it is 

located in the Zone.

Complex Profile For a complex profile ele-

ment: Name of the profile

 

Composite Struc-

ture

For a composite element: 

Name of the composite 

attribute

 

Conditional Vol-

ume

Volume of Construction 

element (Beam, Roof, 

Shell, Slab, or Wall).

This volume may be condi-

tioned on a defined Calcu-

lation Rule.

Condition: subtracts the volume of any openings that exceed a given 

size, as defined in Options > Project Preferences > Calculation Units & 

Rules ("Reduce element volume by…").

Reduced by trims and SEO's.

Cover Fill Name of the Cover Fill 

assigned to the element (if 

any).

Cover Fills are available for Zone, Mesh, Slab, Roof, Column, Beam, 

Morph, Opening.

Cross Section 

Area at Bottom/

Start

Area of the element's bot-

tom cross section.

Relevant for Beams and Columns and their segments

For Columns: Includes the area of the Veneer, if any.

Cross Section 

Area at Top/End

Area of the element's top 

cross section.

Relevant for Beams and Columns and their segments

For Columns: Includes the area of the Veneer, if any.

Cross Section 

Height at Bottom/

Start (cut)

Height of the element's bot-

tom cross section.

Relevant for Beams and Columns and their segments.

Parameter Short Description Long Description
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Cross Section 

Height at Bottom/

Start (perpendicu-

lar)

new Relevant for Beams and Columns and their segments.

Cross Section 

Height at Top/End 

(cut)

Height of the element's top 

cross section.

Relevant for Beams and Columns and their segments.

Cross Section 

Height at Top/End 

(perpendicular)

new Relevant for Beams and Columns and their segments.

Cross Section 

Width at Bottom/

Start (cut)

Width of the element's bot-

tom/top cross section.

Relevant for Beams and Columns and their segments.

Cross Section 

Width at Bottom/

Start (perpendicu-

lar)

new Relevant for Beams and Columns and their segments.

Cross Section 

Width at Top/End 

(cut)

Width of the element's top 

cross section.

Relevant for Beams and Columns and their segments.

Cross Section 

Width at Top/End 

(perpendicular)

new Relevant for Beams and Columns and their segments.

Element ID Lists Element ID. For each element: editable ID field is located on the Classification and 

Properties panel of construction tools, Fill and Zone tools.

Element Type Type of AC element  

Elevation to 1st/

2nd Reference 

Level

Element's elevation relative 

to the project's 1st and/or 

2nd Elevation Level.

Elevation levels are defined at Options > Project Preferences > Refer-

ence Levels.

Element's elevation value (measured from its reference line/point) is 

displayed in its Info box or Settings.

Elevation to 

Linked/Home 

Story

Element's elevation relative 

to its linked story (Door/

Window) or Home Story 

(other elements).

Relevant for Doors/Windows. Value is the door/window elevation from 

its linked (anchor) story to its sill height.

Elevation to Proj-

ect Zero

Element's absolute eleva-

tion, measured from zero.

Project Zero is always at zero for the purposes of measuring actual 

element elevation. To set other reference levels, use Options > Project 

Preferences > Reference Levels.

Element's elevation value (measured from its reference line/point) is 

displayed in its Info box or Settings.

Elevation to Sea 

Level

Element's elevation relative 

to Sea Level (Altitude of the 

Project Location).

Define Sea Level value (Altitude) at Options > Project Preferences > 

Project Location.

Element's elevation value (measured from its reference line/point) is 

displayed in its Info box or Settings.

Parameter Short Description Long Description
ARCHICAD 24 Reference Guide 1808



General Listing Parameters Element Parameters
External IFC ID The Globalid IFC attribute 

assigned to each element 

upon IFC import (either 

Merge or Hotlink IFC)

 

Fill Type Name of the Fill attribute 

assigned to the element

To list the type of the Fill pattern (e.g. Solid, Vectorial, Symbol, Image) 

instead: Use the Fill Type parameter in the "General" parameter group.

Floor Plan Holes 

Perimeter

Total Perimeter of all the 

holes in the element.

Relevant for Slab, Mesh, Zone

Floor Plan Perime-

ter

Perimeter of the element, 

including hole perimeters. 

Measured according to the 

element's 2D polygon

Relevant for Wall, Slab, Mesh, Morph

For Wall: Perimeter can vary depending on its Floor Plan Projection 

settings (e.g. Cut Only vs. Projected with Overhead)

Wall intersections have no effect on the perimeter value.

From Zone Name of the Zone from 

which the element opens.

Relevant for Door, Window, Skylight, CW Panel

CW Panel: Zone (if any) from which the Panel faces outward. (The 

Zone that abuts the panel's inside surface.)

From Zone Num-

ber

Number of the Zone from 

which the element opens.

Relevant for Door, Window, Skylight, CW Panel

CW Panel: Number of the Zone (if any) from which the Panel faces 

outward. (The Zone that abuts the panel's inside surface.)

GDL Preview Pic-

ture

Preview picture, of GDL 

Object type elements only.

 

Gross Volume Volume of the element Wall: Includes Volume of Openings, doors and windows.

Column: Includes Volume of both Core and Veneer.

Roof/Shell/Slab: Includes the volume of any holes. Reduced by trims.

See also the Slab parameter: "Gross Volume of the Slab, Minus the 

Holes"

Height  D-W: Height of the window/door, as defined in the "Height" field of the 

opening's Settings dialog box or Info Box.

Height of the panel, not including the panel's extrusion into the sur-

rounding frames.

Curtain Wall: defined in Curtain Wall System Settings or the Info Box

Curtain Wall Panel: Height of the panel, not including the panel's extru-

sion into the surrounding frames.

Zone: Height of the Zone body measured from the Zone's bottom ele-

vation. Defined in the Name and Positioning Panel of Zone Settings.

Skylight: Height parameter in the Preview and Positioning Panel (or 

the Skylight Settings Panel)

Home Offset Offset of element from its 

Home Story.

For Door/Window: The sill 

height, measured from the 

host Wall's home story.

 

Parameter Short Description Long Description
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Home Story Name Name of element's Home 

Story

As defined in Element settings.

Openings: Home Story depends on the opening's vertical position in 

the host element.

Skylight: Home Story is the same as the host Roof/Shell.

Home Story Num-

ber

Number of element's Home 

Story

As defined in Element settings.

Door/Window: Home Story depends on the opening's vertical position 

in the host element.

Skylight: Home Story is the same as the host Roof/Shell.

Hotlink and Ele-

ment ID

If element is part of a 

Hotlink: Lists the Hotlink's 

Master ID as well as the 

Element's ID

 

Hotlink Master ID If element is part of a 

Hotlink: Lists the Hotlink's 

Master ID only

 

ID of Connected 

Openings

IDs of opening(s) con-

nected to this element.

 

IFC Assignment Name of IFC Assignment (if 

any) to which element 

belongs.

IFC Assignment takes place in IFC Project Manager. Assignments 

include e.g. IFC Group, IFC Zone, IFC System.

IFC Type Name of element's IFC 

Type

Classification of ARCHICAD elements for IFC is displayed in Element 

Settings (Classification and Properties panel), and in IFC Project Man-

ager. IFC Type depends on "Type Mapping for Export" setting of the 

current Preview Translator (IFC Translators dialog box)

IFC Type Product Lists the element's IFC 

Type Product Type and IFC 

Type Product Name.

IFC Type Product is defined in the "Type Mapping for Export" setting of 

the current Preview Translator (IFC Translators dialog box), and is dis-

played in IFC Project Manager.

Insulation Skin 

Thickness

Thickness of Wall, Roof, or 

Shell skins whose structure 

is defined as "Insulation"

Insulation Skin (Wall, Roof, Shell) is defined at Options > Project Pref-

erences > Calculation Units & Rules.

Issue Date (of last 

Change)

  

Issue ID (of last 

Change)

  

Issue Name (of 

last Change)

  

Layer Layer of element.  

Length Length of element.  

Library Part Name Name, of GDL Object type 

elements only.

 

Parameter Short Description Long Description
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General Listing Parameters Element Parameters
Linked Changes If element or sub-element 

is linked to a Change: lists 

the number of the linked 

Change(s)

 

Locked Element's locked/unlocked 

status

This is a toggle (yes/no) value expressed as a checkbox in the Sched-

ule field.

Net Volume Net volume of the element. 

Reduced by volume of 

holes and Solid Element 

Operations .

Column: (including the volume of the core and of the veneer, if any).

Roof-Shell-Slab-Mesh: is reduced by the surface of any holes. 

Reduced by trims and SEO's.

Wall/Beam/Morph: reduced by holes and SEO's

Door-Window: Volume of the opening cut by the Door/Window. (Vol-

ume calculation based on hole that results from cutting the GDL open-

ings out of the Wall.)

Number of Open-

ings

Number of Opening ele-

ments.

Opening elements only (not Doors, Windows, or Skylights).

Number of Seg-

ments

(new)  

Parent ID Element ID of the listed ele-

ment's parent element

Relevant for sub-elements (e.g. Tread of Stair, or Panel of Curtain 

Wall, or Segment of a Beam/Column, or Door/Window/Skylight/Open-

ing)

Position Value of element's "Posi-

tion" classification

Possible values: Interior, Exterior, Undefined

Position is set in Classification and Properties panel of Element Set-

tings. Used for IFC data exchange.

Property Object 

Name

Name of property object (if 

any) linked to this element.

Property Objects can be linked to elements using the Listing panel of 

Element Settings. (This panel is hidden by default. Consult the Calcu-

lation Guide for details.)

Quantity For a particular listed ele-

ment, displays the number 

of scheduled elements.

 

Parameter Short Description Long Description
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General Listing Parameters Element Parameters
Related Zone 

Name

Name of the element's 

related Zone, if any.

In general: the Zone which 

the element borders or 

intersects in 2D.

Related Zone definitions 

vary by element. See 

Description.

An element can have only 

one Related Zone. (If multi-

ple Zones apply, the first 

created Zone is listed.)

(To identify the Zone with 

which an element inter-

sects in 3D, use the "Collid-

ing Zones" parameter.)

Wall: The Zone which it borders, or the Zone which the Wall's 2D poly-

gon intersects

Door/Window: Related Zone of the host Wall.

Curtain Wall: The Zone which it (or at least one of its segments) bor-

ders

Curtain Wall Frame/Panel: The Zone which its CW segment borders, 

and which the Frame/Panel touches.

Curtain Wall Junction: All of the connecting subelements (at the Junc-

tion's gridpoint) border the Zone; or two of the connecting Frames (at 

the Junction's gridpoint) border the Zone

Curtain Wall Accessory: The Zone bordered by the Accessory's parent 

Frame.

Shell/Roof: The Zone to which it connects via SEO, or by which it is 

cropped

Object, Light, Morph, Stair, Railing: The Zone that has the same Home 

Story as the element. For an Object: the centerpoint of its 3D bounding 

box is within the Zone polygon.

Beam: The Zone which the Beam's Reference line intersects in 2D. 

The Beam must be visible on this related Zone's home story.

Skylight: The Zone to which its parent Roof or Shell connects via SEO, 

or by which it is cropped.

Column: The Zone polygon intersected by any corner of the Column. 

The Column must be visible on this related Zone's home story.

Tread, Riser, Stair Structure: The related Zone of its parent Stair

Railing subelements: The related Zone of its parent Railing

Related Zone 

Number

Number of the element's 

related Zone, if any. See 

explanation for Related 

Zone Name, above.

 

Relative Top Link 

Story

Relative position of ele-

ment's top-linked Story.

Relevant for Wall/Column/Zone/Stair

For example: Home + 1

Renovation Status Existing, To Be Demol-

ished, or New

As set in element's Classification and Properties panel, or Renovation 

palette

Show On Renova-

tion Filter

Renovation Filter on which 

this element is shown

As set in element's Classification and Properties panel, or Renovation 

palette

Slant Angle Angle of slanted or inclined 

element.

For Wall: Same as Wall Outside Slant Angle. (See also Wall-specific 

Inside Slant Angle parameter).

Beam: Angle of an inclined Beam

CW Frame or Panel: Slant angle measured to the horizontal plane.

Structural Func-

tion

Load-bearing, or Non-load 

-bearing, or undefined

As set in element's Classification and Properties panel

Structure Type Basic, Composite, or Com-

plex Profile

 

Parameter Short Description Long Description
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General Listing Parameters Element Parameters
Surface (All) List of all surfaces used in 

the element, including any 

overrides

 

Surface Area Generally: the sum of all 

surfaces of an element.

Beam: The sum of all Beam surfaces (top, bottom, ends)

Column: Surface area of the Column's cross-section

Shell: Net surface area of the Reference Side

Thickness Element Thickness, as 

defined in Element Set-

tings.

 

To Zone Name of the Zone toward 

which the element opens.

Relevant for Door, Window, Skylight, CW Panel

CW Panel: Name of the Zone (if any) that abuts the panel's outside 

surface.

To Zone Number Number of the Zone toward 

which the element opens.

Relevant for Door, Window, Skylight, CW Panel

CW Panel: Name of the Zone (if any) that abuts the Panel's outside 

surface.

Top Link Story Element's top-linked Story, 

expressed as both relative 

and absolute.

Relevant for Wall/Column/Zone/Stair

For example: Home + 1 (2. Story)

Top Offset Offset from element's 

Toplink Story

Applicable to elements with a top link: Wall, Column, Zone, Stair

Top/Bottom Eleva-

tion to Reference 

Level

Elevation of the element's 

topmost (or bottom) point in 

3D space (regardless of its 

reference line or anchor 

point).

Use the parameter corresponding to the desired reference level for the 

measured elevation: First/Second Reference Level, Home Story, Proj-

ect Zero or Sea Level.

Define levels at Options > Project Preferences > Reference Levels.

Unique ID Automatically generated ID 

that is conserved through-

out the life of the project

Also known as the element's ARCHICAD  "Global unique identifier" 

(GUID).

Width Element Width parameter, 

as defined by its geometry 

or in Element Settings.

Object: Width of the Object as defined in the "Dimension 1" field of the 

Preview and Positioning Panel of Object Settings.

Column: Width of the column: Core Dimension 1 value, plus the width 

of any veneer.

Parameter Short Description Long Description
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Beam Listing Parameters Element Parameters
Beam Listing Parameters

Parameter Short Description Long Description

Beam Cross 

Section

Rectangular, Pro-

filed or Rounded

Shape of the Beam's cross-section as 

defined in the Beam Settings dialog box.

Beam Slant 

Angle

Angle of an inclined 

Beam.

 
 

Bottom Sur-

face

Name of the Sur-

face assigned to the 

bottom of the Beam.

Defined in Beam Settings (via Building 

Material, or Override in Model Panel)

Bottom Sur-

face Area

Area of the Surface 

of the bottom of the 

Beam.

Reduced by any SEO's or holes.

End Surface Name of the Sur-

face assigned to the 

two ends of the 

Beam.

Defined in Beam Settings (via Building 

Material, or Override in Model Panel)

End Sur-

face Area

Area of the Sur-

faces of both ends 

of the Beam.

Area of the Surfaces of both ends of the 

Beam.

Extrusion 

Surface

Name of the Sur-

face assigned to the 

Beam extrusion.

Use with round and profiled beams, which 

use a single surface on all sides of the 

extrusion. (Same value as the Left Side 

Surface parameter.)

 

Hole Height Height or diameter 

of the first-placed 

hole in the Beam).

Same value as "Hole Height or Diameter", 

on the Hole panel of Beam Tool Settings
ARCHICAD 24 Reference Guide 1814



Beam Listing Parameters Element Parameters
Hole Num-

ber

Total number of 

holes in the Beam.

 

Hole Posi-

tion from 

Reference 

Line

Distance of the cen-

terpoint of the first-

placed hole from the 

Beam Reference 

Line.

Same value as Position, on the Hole 

panel of Beam Tool Settings.

Hole Width Width of the first-

placed hole in the 

Beam.

Same value as "Hole Height", on the Hole 

panel of Beam Tool Settings.

Holes Edge 

Surface 

Area

Total edge area of 

all Beam holes.

 

 

Holes Sur-

face Area

Total area of the 2D 

Surface of all holes, 

as calculated on 

one Side of the 

Beam.

 

Holes Vol-

ume

Total volume of all 

holes in the Beam.

Multiplies Beam Width by Holes Surface 

Area.

Left Side 

Surface

Name of the Sur-

face assigned to the 

left Side of the 

Beam.

Defined in Beam Settings (via Building 

Material, or Override in Model Panel).

"Left" and "Right" are determined based 

on the direction of the Beam's reference 

axis. The axis direction is the direction in 

which you drag the cursor to draw the 

Beam.

Left Side 

Surface 

Area

Area of the Surface 

of the left Side of 

the Beam.

Reduced by any SEO's or holes.

"Left" and "Right" are determined based 

on the direction of the Beam's reference 

axis. The axis direction is the direction in 

which you drag the cursor to draw the 

Beam.

Parameter Short Description Long Description
ARCHICAD 24 Reference Guide 1815



Beam Listing Parameters Element Parameters
Length Left Length of the Beam 

on its left Side.

"Left" and "Right" are determined based 

on the direction of the Beam's reference 

axis. The axis direction is the direction in 

which you drag the cursor to draw the 

Beam.

To list the Beam's Reference Length, use 

the 3D Length parameter (General cate-

gory).

 

Length 

Right

Length of the Beam 

on its right Side.

"Left" and "Right" are determined based 

on the direction of the Beam's reference 

axis. The axis direction is the direction in 

which you drag the cursor to draw the 

Beam.

To list the Beam's Reference Length, use 

the 3D Length parameter (General cate-

gory).

Offset Beam offset dis-

tance from refer-

ence line.

By default, this value is zero. Entering an 

offset value offsets the Beam from its ref-

erence axis.

Right Side 

Surface

Name of the Sur-

face assigned to the 

right Side of the 

Beam.

Defined in Beam Settings (via Building 

Material, or Override in Model Panel)

"Left" and "Right" are determined based 

on the direction of the Beam's reference 

axis. The axis direction is the direction in 

which you drag the cursor to draw the 

Beam.

Right Side 

Surface 

Area

Area of the Surface 

of the right Side of 

the Beam.

Reduced by any SEO's or holes.

"Left" and "Right" are determined based 

on the direction of the Beam's reference 

axis. The axis direction is the direction in 

which you drag the cursor to draw the 

Beam.

Top Surface Name of the Sur-

face assigned to the 

top of the Beam.

Defined in Beam Settings (via Building 

Material, or Override in Model Panel)

Parameter Short Description Long Description
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Beam Listing Parameters Element Parameters
Top Sur-

face Area

Area of the Surface 

of the top of the 

Beam.

Reduced by any SEO's or holes.

Parameter Short Description Long Description
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Beam Segment Listing Parameters Element Parameters
Beam Segment Listing Parameters

Parameter Short Description Long Description

Bottom Surface Name of the Surface 

assigned to the bottom of 

the Beam Segment.

Defined in Beam Settings (via Building Material, or Override in Model 

Panel)

Bottom Surface 

Area

Area of the Surface of the 

bottom of the Beam Seg-

ment.

Reduced by any SEO's or holes.

Cross Section Rectangular, Profiled or 

Rounded

Shape of the Beam Segment's cross-section as defined in the Beam 

Settings dialog box.

Ends Surface Name of the Surface 

assigned to the two ends of 

the Beam Segment.

Defined in Beam Settings (via Building Material, or Override in Model 

Panel)

Ends Surface Area Area of the Surfaces of 

both ends of the Beam 

Segment.

Area of the Surfaces of both ends of the Beam Segment.

Extrusion Surface Name of the Surface 

assigned to the Beam Seg-

ment extrusion.

Use with round and profiled beams, which use a single surface on all 

sides of the extrusion. (Same value as the Left Side Surface parame-

ter.) 

Left Side Surface Name of the Surface 

assigned to the left Side of 

the Beam Segment.

Defined in Beam Settings (via Building Material, or Override in Model 

Panel).

"Left" and "Right" are determined based on the direction of the Beam's 

reference axis. The axis direction is the direction in which you drag the 

cursor to draw the Beam.

Left Side Surface 

Area

Area of the Surface of the 

left Side of the Beam Seg-

ment.

Reduced by any SEO's or holes.

"Left" and "Right" are determined based on the direction of the Beam's 

reference axis. The axis direction is the direction in which you drag the 

cursor to draw the Beam.

Right Side Surface Name of the Surface 

assigned to the right Side 

of the Beam Segment.

Defined in Beam Settings (via Building Material, or Override in Model 

Panel)

"Left" and "Right" are determined based on the direction of the Beam's 

reference axis. The axis direction is the direction in which you drag the 

cursor to draw the Beam.

Right Side Sur-

face Area

Area of the Surface of the 

right Side of the Beam Seg-

ment.

Reduced by any SEO's or holes.

"Left" and "Right" are determined based on the direction of the Beam's 

reference axis. The axis direction is the direction in which you drag the 

cursor to draw the Beam.

Structure Type   

Top Surface Name of the Surface 

assigned to the top of the 

Beam Segment.

Defined in Beam Settings (via Building Material, or Override in Model 

Panel)

Top Surface Area Area of the Surface of the 

top of the Beam Segment.

Reduced by any SEO's or holes.
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Column Listing Parameters Element Parameters
Column Listing Parameters

Parameter Short Description Long Description

Column 

Cross Sec-

tion

Rectangular, Circu-

lar or Profiled.

Defined in Column Settings

Core Height 

/ Diameter

For a rectangular or 

profiled Column: 

One of the dimen-

sions of the Column 

in cross-section. 

(The other dimen-

sion is "Core 

Width".)

Does not include 

veneer. (To include 

veneer, use the 

General "Width" 

parameter.)

For a circular Column: the diameter of the 

Column.

Core Width For a rectangular or 

profiled Column: 

One of the two 

dimensions of the 

Column in cross-

section. (The other 

dimension is "Core 

Height / Diameter".)

Does not include 

Veneer. (To include 

veneer, use the 

General "Width" 

parameter.)

For a circular Column: the diameter of the 

Column.

End Surface Surface assigned to 

Column Ends.

Defined in Column Settings (via Building 

Material, or Override in Model Panel)
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Column Listing Parameters Element Parameters
Extrusion 

Surface

Surface assigned to 

Column Extrusion.

Defined in Column Settings (via Building 

Material, or Override in Model Panel)

Gross Sur-

face Area of 

the Core 

(without 

Top/Bot-

tom)

Gross Surface Area 

of the Column Core 

on all sides.

Surfaces of the Column top/bottom are 

ignored.

Solid Element Operations are ignored.

Gross Sur-

face Area of 

the Core 

Bottom

Surface area of the 

cross-section of the 

Core at the bottom 

of the Column.

Does not take any Solid Element Opera-

tions into account.
 

Gross Sur-

face Area of 

the Core 

Top

Surface area of the 

cross-section of the 

Core at the top of 

the Column.

Does not take any Solid Element Opera-

tions into account.

Gross Sur-

face Area of 

the Veneer 

(without 

Top/Bot-

tom)

Gross Surface Area 

of the Column 

Veneer on all sides.

Surfaces of the Veneer top/bottom are 

ignored.

Solid Element Operations are ignored.

Gross Sur-

face Area of 

the Veneer 

Bottom

Surface area of the 

cross section of the 

Veneer at the bot-

tom of the Column.

Does not take any Solid Element Opera-

tions into account.
 

Parameter Short Description Long Description
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Column Listing Parameters Element Parameters
Gross Sur-

face Area of 

the Veneer 

Top

Surface area of the 

cross section of the 

Veneer at the top of 

the Column.

Does not take any Solid Element Opera-

tions into account.

Gross Vol-

ume of the 

Core

Gross Volume of the 

Column Core.

Solid Element Operations are ignored.

Gross Vol-

ume of the 

Veneer

Gross Volume of the 

Column Veneer.

Solid Element Operations are ignored.

Maximum 

Height of 

the Column

For a Column cut 

e.g. by a slanted 

Roof: the highest 

point of the Column.

For a straight or slanted Column: equiva-

lent to Height (General field).

Minimum 

Height of 

the Column

For a Column cut 

e.g. by a slanted 

Roof: the lowest 

point of the Column.

Parameter Short Description Long Description
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Column Listing Parameters Element Parameters
Net Surface 

Area of the 

Core (with-

out Top/Bot-

tom)

Net Surface area of 

the Column Core on 

all sides (but not the 

top or bottom).

Surfaces of the Column top/bottom are 

ignored.

Reduced by Solid Element Operations.

Net Surface 

Area of the 

Core Bot-

tom

Surface area of the 

cross-section of the 

Core at the bottom 

of the Column.

Reduced by Solid Element Operations.

Net Surface 

Area of the 

Core Top

Surface area of the 

cross-section of the 

Veneer at the top of 

the Column.

Reduced by Solid Element Operations.

Net Surface 

Area of the 

Veneer Bot-

tom

Surface area of the 

cross-section of the 

Veneer at the bot-

tom of the Column.

Reduced by Solid Element Operations.

Net Surface 

Area of the 

Veneer Top

Surface area of the 

cross-section of the 

Veneer at the top of 

the Column.

Reduced by Solid Element Operations.

Parameter Short Description Long Description
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Column Listing Parameters Element Parameters
Net Volume 

of the Core

Net Volume of the 

Column Core.

Reduced by Solid Element Operations.

Net Volume 

of the 

Veneer

Net Volume of the 

Column Veneer on 

all sides.

Reduced by Solid Element Operations.

Perimeter of 

Column 

Profile (Bot-

tom)

Perimeter of the 

Column profile at 

the bottom of the 

Column.

Profile plane is perpendicular to the Col-

umn axis.

Perimeter of 

Column 

Profile (Top)

Perimeter of the 

Column profile at 

the top of the Col-

umn.

Profile plane is perpendicular to the Col-

umn axis.
 

Veneer 

Building 

Material

Name of Building 

Material assigned to 

Veneer

Defined in Column Settings

Parameter Short Description Long Description
ARCHICAD 24 Reference Guide 1823



Column Listing Parameters Element Parameters
Veneer Sur-

face Area

Net Surface area of 

the Column Veneer 

on all sides

Surfaces of the Veneer top/bottom are 

ignored.

Reduced by Solid Element Operations.

Veneer Type Core, Finish or 

None

Defined in Column Settings

This setting affects the display of the Col-

umn, depending on Partial Structure Dis-

play Settings.

Parameter Short Description Long Description
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Column Segment Listing Parameters Element Parameters
Column Segment Listing Parameters

Parameter Short Description Long Description

Core Height / 

Diameter

For a rectangular or pro-

filed Column Segment: 

One of the dimensions of 

the Segment in cross-sec-

tion. (The other dimension 

is "Core Width".)

Does not include veneer. 

(To include veneer, use the 

General "Width" parame-

ter.)

For a circular Column Segment: the diameter of the Segment.

Core Width For a rectangular or pro-

filed Column Segment: 

One of the two dimensions 

of the Segment in cross-

section. (The other dimen-

sion is "Core Height / Diam-

eter".)

Does not include Veneer. 

(To include veneer, use the 

General "Width" parame-

ter.)

For a circular Column Segment: the diameter of the Segment.

Cross Section Rectangular, Circular or 

Profiled.

Defined in Column Settings

Ends Surface Surface assigned to Col-

umn Segment Ends.

Defined in Column Segment Settings (via Building Material, or Over-

ride in Model Panel)

Extrusion Surface Surface assigned to Col-

umn Segment Extrusion.

Defined in Column Segment Settings (via Building Material, or Over-

ride in Model Panel)

Gross Surface 

Area of the Core

Gross Surface Area of the 

Column Segment Core on 

all sides.

Surfaces of the Column Segment top/bottom are ignored.

Solid Element Operations are ignored.

Gross Surface 

Area of the Core 

Bottom

Surface area of the cross-

section of the Core at the 

bottom of the Column Seg-

ment. 

Does not take any Solid Element Operations into account.

Gross Surface 

Area of the Core 

Top

Surface area of the cross-

section of the Core at the 

top of the Column Seg-

ment. 

Does not take any Solid Element Operations into account.

Gross Surface 

Area of the Veneer

Gross Surface Area of the 

Column Segment Veneer 

on all sides.

Surfaces of the Veneer top/bottom are ignored.

Solid Element Operations are ignored.
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Column Segment Listing Parameters Element Parameters
Gross Surface 

Area of the Veneer 

Bottom

Surface area of the cross 

section of the Veneer at the 

bottom of the Column Seg-

ment. 

Does not take any Solid Element Operations into account.

Gross Surface 

Area of the Veneer 

Top

Surface area of the cross 

section of the Veneer at the 

top of the Column Seg-

ment. 

Does not take any Solid Element Operations into account.

Gross Volume of 

the Core

Gross Volume of the Col-

umn Segment Core.

Solid Element Operations are ignored.

Gross Volume of 

the Veneer

Gross Volume of the Col-

umn Segment Veneer. 

Solid Element Operations are ignored.

Net Surface Area 

of the Core

Net Surface area of the 

Column Segment Core on 

all sides (but not the top or 

bottom).

Surfaces of the Column Segment top/bottom are ignored.

Reduced by Solid Element Operations.

Net Surface Area 

of the Core Bottom

Surface area of the cross-

section of the Core at the 

bottom of the Column Seg-

ment.

Reduced by Solid Element Operations.

Net Surface Area 

of the Core Top

Surface area of the cross-

section of the Veneer at the 

top of the Column Seg-

ment. 

Reduced by Solid Element Operations.

Net Surface Area 

of the Veneer Bot-

tom

Surface area of the cross-

section of the Veneer at the 

bottom of the Column Seg-

ment. 

Reduced by Solid Element Operations.

Net Surface Area 

of the Veneer Top

Surface area of the cross-

section of the Veneer at the 

top of the Column Seg-

ment.

Reduced by Solid Element Operations.

Net Volume of the 

Column Core

Net Volume of the Column 

Segment Core.

Reduced by Solid Element Operations.

Net Volume of the 

Veneer

Net Volume of the Column 

Segment Veneer on all 

sides. 

Reduced by Solid Element Operations.

Veneer Building 

Material

Name of Building Material 

assigned to Veneer

Defined in Column Settings

Veneer Surface 

Area

Net Surface area of the 

Column Segment Veneer 

on all sides

Surfaces of the Veneer top/bottom are ignored.

Reduced by Solid Element Operations.

Parameter Short Description Long Description
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Column Segment Listing Parameters Element Parameters
Veneer type Core, Finish or None Defined in Column Settings

This setting affects the display of the Column Segment, depending on 

Partial Structure Display Settings.

Parameter Short Description Long Description
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Curtain Wall Listing Parameters Element Parameters
Curtain Wall Listing Parameters

Parameter Short Description Long Description

Curtain Wall 

Slant Angle

Slant Angle of the 

Curtain Wall

Same value as the General "Slant Angle" 

parameter.
 

Length Length of element.   

Number of 

Panels

Number of panels in 

the Curtain Wall.

 

Pattern 

Angle

Rotation angle of 

the row Grid Lines 

measured clockwise 

from the column 

Grid Lines. This 

angle is defined in 

the Curtain Wall 

Scheme Settings/

Grid Pattern panel, 

under Rows.

 

Surface 

Area Includ-

ing Bound-

ary

Surface area of Cur-

tain Wall, including 

the surface area of 

its Boundary 

Frames.

If the Boundary Frames are placed 

"Inside Grid" (Curtain Wall Settings/Cur-

tain Wall System/ Member Placement: 

Place Boundary Frames "Inside"), then 

this parameter is equal to the general Sur-

face Area parameter for the Curtain Wall.

If the Boundary Frames are placed "Out-

side Grid" or "Centered on Grid", then the 

value of this parameter will exceed the 

general Surface Area parameter, because 

the Boundary Frames hang out over the 

boundary line.

If you use an Invisible type Frame for your 

Boundary Frames (Curtain Wall Settings/

Curtain Wall System/Frames: Boundary), 

then the value of this parameter will be 

less than that of the general Surface Area 

parameter.
ARCHICAD 24 Reference Guide 1828



Curtain Wall Listing Parameters Element Parameters
Total 

Length of 

Contour 

Frames

  

 

Total 

Length of 

Custom 

Frames

  

 

Total 

Length of 

Frames

Total of the lengths 

of all frames in the 

Curtain Wall. If the 

shape of the Frame 

is not uniform, then 

the value of the 

Frame length is cal-

culated by taking 

the average of its 

shortest and longest 

lengths.

 

Total 

Length of 

Frames 

Belonging 

to the Main 

Axis

  

 

Total 

Length of 

Frames 

Belonging 

to the Sec-

ondary Axis

  

 

Total Panel 

Surface 

Area

Total surface area of 

all the Curtain Wall 

panels. This value 

does not include the 

surface of the 

frames between the 

panels. Total Panel 

Surface Area is 

seen if you look at 

the Curtain Wall in 

Edit mode, with just 

the Panels visible.

 

Parameter Short Description Long Description
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Curtain Wall Listing Parameters Element Parameters
Total Sur-

face Area of 

Panels Fac-

ing East

  

 

Total Sur-

face Area of 

Panels Fac-

ing North

  

 

Total Sur-

face Area of 

Panels Fac-

ing North-

East

  

 

Total Sur-

face Area of 

Panels Fac-

ing North-

West

  

 

Total Sur-

face Area of 

Panels Fac-

ing South

  

 

Total Sur-

face Area of 

Panels Fac-

ing South-

East

  

 

Total Sur-

face Area of 

Panels Fac-

ing South-

West

  

 

Total Sur-

face Area of 

Panels Fac-

ing West

  

 

Parameter Short Description Long Description
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Curtain Wall Accessory Listing Parameters Element Parameters
Curtain Wall Accessory Listing Parameters

Parameter Short Description Long Description

Length Length parameter of 

the Accessory

Measured along the plane of the Curtain 

Wall

Accessory 

Class

System or Custom Accessories from the "System" class use 

the settings at the Curtain Wall System 

Settings level.

Accessories from the "Custom" class 

have been individually customized using 

Junction Settings, accessible through 

Curtain Wall Edit Mode.

Accessory 

Type

Name of the Acces-

sory Type

Defined at Accessory Type in Curtain Wall 

Settings - Accessory page.
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Curtain Wall Frame Listing Parameters Element Parameters
Curtain Wall Frame Listing Parameters

Parameter Short Description Long Description

Curtain Wall 

Frame Slant 

Angle

Frame's slant angle 

in the plane of the 

Curtain Wall

E.g. 0 or 90 degrees for orthogonally 

positioned frames, other angles for diago-

nal frames (regardless of whether the 

Curtain Wall itself is slanted.)

 

Frame 

Class

Boundary, Mullion, 

Corner, Transom, or 

Custom

Assign Frame Class by clicking the 

frames in the Preview window of the Grid 

Pattern and Preview panel of Curtain Wall 

System Settings - Scheme Page.

Frames from the "Custom" class have 

been individually customized using Frame 

Settings, accessible through Curtain Wall 

Edit Mode.

Frame 

Depth

Depth of the Frame 

profile.

Defined in the Frame Type and Geometry 

panel of CW Frame Settings.

Frame 

Length

Length of the 

Frame.

 
 

Frame Type Frame Type (e.g. 

Butt-glazed, 

Generic)

Defined in the Frame Type and Geometry 

panel of CW Frame Settings.  

Location Frame's position as 

related to the Cur-

tain Wall: Contour, 

Vertical, Horizontal, 

or Diagonal.

 

Profile 

Height

Frame profile's 

height.

If the Frame Type is a profile element 

(e.g. Profiled Butt-Glazed Frame).
 

Profile 

Width

Frame profile's 

width.

If the Frame Type is a profile element 

(e.g. Profiled Butt-Glazed Frame).
 

Profile WxH Frame profile's 

width and height 

dimensions.

If the Frame Type is a profile element 

(e.g. Profiled Butt-Glazed Frame).  
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Curtain Wall Frame Listing Parameters Element Parameters
Surface Surface assigned to 

the Frame.

From Frame's Building Material. Can be 

overridden in Curtain Wall Frame Set-

tings.

Parameter Short Description Long Description
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Curtain Wall Junction Listing Parameters Element Parameters
Curtain Wall Junction Listing Parameters

Parameter Short Description Long Description

Junction 

Class

System or Custom. Junctions from the "System" class use the 

settings at the Curtain Wall System Set-

tings level.

Junctions from the "Custom" class have 

been individually customized using Junc-

tion Settings, accessible through Curtain 

Wall Edit Mode.

Junction 

Type

Name of the Junc-

tion Type

Defined at Junction Type in Curtain Wall 

Settings - Junctions page.
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Curtain Wall Panel Listing Parameters Element Parameters
Curtain Wall Panel Listing Parameters

Parameter Short Description Long Description

Abbrevia-

tion of Ori-

entation

Facing direction of 

the panel (using 

abbreviation).

 

Angle from 

North

Facing direction of 

the panel, in 

degrees measured 

from North.

 

Curtain Wall 

Panel Slant 

Angle

Slant of the Curtain 

Wall Panel.

Equals the slant of the Curtain Wall

 

Edge Sur-

face

Surface of the Panel 

edge as defined in 

the Model Panel of 

CW Panel Settings.

For panels which are GDL Objects, the 

surface is defined in its GDL script.
 

Inside Sur-

face

Panel's inside sur-

face as defined in 

the Model Panel of 

CW Panel Settings.

For panels which are GDL Objects, the 

surface is defined in its GDL script.

Nominal 

Height

Height of the panel. Does not include the panel's extrusion 

into the surrounding frames
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Curtain Wall Panel Listing Parameters Element Parameters
Nominal 

Width

Width of the panel. Does not include the panel's extrusion 

into the surrounding frames

For generic panels, this is the same as 

the regular Width parameter.

For GDL panels, this value can be defined 

in the panel's parameters.

Orientation Lists the direction 

(Left or Right) of 

Panels which act as 

Doors/Windows.

 

Outside 

Surface

Surface of the Panel 

outside surface as 

defined in the Model 

Panel of CW Panel 

Settings.

For panels which are GDL Objects, the 

surface is defined in its GDL script.

Panel Area 

with Clamps

Gross surface area 

of the panel.

For rectangular-shaped panels. Includes 

the panel's extrusion into the surrounding 

frames (the "depth" value defined in the 

Frame Type and Geometry panel of CW 

Frame Settings.)

Panel Area 

without 

Clamps

Surface area of the 

panel.

For rectangular-shaped panels. Does not 

include the panel's extrusion into the sur-

rounding frames

Parameter Short Description Long Description
ARCHICAD 24 Reference Guide 1836



Curtain Wall Panel Listing Parameters Element Parameters
Panel Class Main, Distinct, or 

Custom.

Assign Panel Class by clicking the panels 

in the Preview window of the Grid Pattern 

and Preview panel of Curtain Wall System 

Settings - Scheme Page.

Panels from the "Custom" class have 

been individually customized using Panel 

Settings, accessible through Curtain Wall 

Edit Mode.

Panel Func-

tion

Either Fixed, Win-

dow, or Door, 

depending on the 

Panel Type chosen.

Defined in the Panel Type and Geometry 

panel of CW Panel Settings.

Panel Type Name of the Panel 

Type.

Defined at Panel Type and Geometry in 

Curtain Wall Panel Settings.

Parameter Short Description Long Description
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Window/Door Listing Parameters Element Parameters
Window/Door Listing Parameters

Parameter Short Description Long Description

Egress 

Dimensions

(For Doors only.) 

Width and Height of 

egress, as defined 

in Door Settings 

(Custom Settings, 

Nominal Sizes and 

Tolerance page).

 

 

Frame 

Thickness

Frame Thickness, 

as defined in Win-

dow Settings (Cus-

tom Settings, Frame 

and Sash page).

 

 

Leaf Dimen-

sions

(For Doors only.) 

Width and Height of 

leaf, as defined in 

Door Settings (Cus-

tom Settings, Nomi-

nal Sizes and 

Tolerance page).

 

Nominal W 

X H Size

Displays dimen-

sions as "Height x 

Width".

The Height and Width parameters that 

are "Set as Nominal" in the Settings dia-

log box (Custom Settings, Nominal Sizes 

and Tolerance page).

Nominal W 

X H x T Size

Displays dimen-

sions as "Height x 

Width x Wall Thick-

ness".

The Height and Width parameters that 

are "Set as Nominal" in the Settings dia-

log box (Custom Settings, Nominal Sizes 

and Tolerance page), and the thickness of 

the Wall in which the W/D is located. 

(Same as the W/D Opening  Nominal Vol-

ume.)
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Window/Door Listing Parameters Element Parameters
Nominal W/

D Opening 

Height on 

the Reveal 

Side

Wallhole Height, 

reduced by the 

head+sill of the 

Reveal.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

Nominal W/

D Opening 

Height on 

the Side 

Opposite to 

the Reveal 

Side

Wallhole Height, 

reduced by the 

head+sill of the 

Reveal.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

Nominal W/

D Opening 

Surface 

Area on the 

Reveal Side

Height between sill 

and head x Width 

between Side 

jambs.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

Nominal W/

D Opening 

Surface 

Area on the 

Side Oppo-

site to the 

Reveal Side

Wallhole Height x 

Wallhole Width.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

Nominal W/

D Opening 

Width on 

the Reveal 

Side

Wallhole Width, 

reduced by the Side 

jambs of the 

Reveal.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

Parameter Short Description Long Description
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Window/Door Listing Parameters Element Parameters
Nominal W/

D Opening 

Width on 

the Side 

Opposite to 

the Reveal 

Side

Wallhole Width. Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

Orientation L for Left, or R for 

Right.

The direction in which the door or window 

is opened. Orientation is also indicated by 

the Opening line on the Floor Plan.

 

Reveal 

Dimensions

Width and Height of 

the window.

The Height and Width parameters defined 

for Reveal Dimensions, in the Door/Win-

dow Settings dialog box (Custom Set-

tings, Nominal Sizes and Tolerance page)

Sill/Header 

Value

Distance from the 

header (or from the 

sill) to the Wall Base 

(or to the current 

Story), as defined 

by the user.

Sill or header value as defined in Preview 

and Positioning panel of the Settings Dia-

log box.

Unit Dimen-

sions

Width and Height of 

door/window unit, 

as defined in Set-

tings dialog box.

The "unit" is the door/window frame; it is 

the equivalent of the Wallhole less the tol-

erance value.

View from 

Opening 

Side

View of the door/

window from the 

Opening Side.

 

 

Parameter Short Description Long Description
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Window/Door Listing Parameters Element Parameters
View from 

Reveal Side

View of the door/

window from the 

Reveal Side.

 

View from 

Side Oppo-

site to 

Opening 

Side

View of the door/

window from the 

Side Opposite to the 

Opening.

 

 

View from 

Side Oppo-

site to 

Reveal

View of the door/

window from the 

Side Opposite to the 

Reveal.

 

W/D Head 

Height on 

the Reveal 

Side

Distance from Wall 

base to the header.

Defined as the sum of the sill Height plus 

the door/window Height, taking the 

Reveal geometry into account.

Parameter Short Description Long Description
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Window/Door Listing Parameters Element Parameters
W/D Head 

Height on 

the Side 

Opposite to 

the Reveal 

Side

Distance from Wall 

base to the header 

on the Opposite to 

the Reveal Side.

Defined as the sum of the sill Height plus 

the door/window Height, taking the 

Reveal geometry into account.

W/D Nomi-

nal Head 

Height

Distance from Wall 

base to the header, 

taking the Reveal 

geometry into 

account. Defined as 

the sum of the sill 

Height plus the 

door/window 

Height, taking the 

Reveal geometry 

into account.

 

W/D Nomi-

nal Sill 

Height

Distance from Wall 

base to the top of 

the sill. Includes the 

sill value plus the sill 

Height (if any) of the 

Reveal.

 

W/D Open-

ing Height 

on the 

Reveal Side

Wallhole Height, 

less the head+sill of 

the Reveal.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is OFF.

Parameter Short Description Long Description
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W/D Open-

ing Height 

on the Side 

Opposite to 

the Reveal 

Side

Wallhole Height. Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is OFF.

W/D Open-

ing Nomi-

nal Surface 

Area

Wallhole Height x 

Wallhole Width.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is ON.

W/D Open-

ing Nomi-

nal Volume

Volume, calculated 

by "Height x Width x 

Wall Thickness".

These are the Height and Width parame-

ters of the Opening size defined as "Nom-

inal" in the opening's Settings dialog box, 

and the thickness of the Wall in which the 

Opening is located. (Same as the W/D 

Opening  Nominal Volume.)

W/D Open-

ing Surface 

Area on the 

Reveal Side

Height between sill 

and head x Width 

between Side 

jambs.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is OFF.

W/D Open-

ing Surface 

Area on the 

Side Oppo-

site to the 

Reveal Side

Wallhole Height x 

Wallhole Width.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is OFF.

Parameter Short Description Long Description
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Window/Door Listing Parameters Element Parameters
W/D Open-

ing Width 

on the 

Reveal Side

Wallhole Width, less 

the Side jambs of 

the Reveal.

Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is OFF.

W/D Open-

ing Width 

on the Side 

Opposite to 

the Reveal 

Side

Wallhole Width. Relevant for openings from the ARCHI-

CAD 10 library, if the "Nominal Size = 

Jamb Inner Size" parameter is OFF.

W/D Sill 

Height on 

the Reveal 

Side

Distance from Wall 

base to the sill, tak-

ing the sill jamb 

depth of Reveal into 

account.

 

W/D Sill 

Height on 

the Side 

Opposite to 

the Reveal 

Side

Distance from Wall 

base to the sill, 

regardless of sill 

jamb depth of 

Reveal.

 

Wall Struc-

ture

Name of Building 

Material or Profile of 

the Wall in which 

the door/window is 

placed.

 

 

Wall Thick-

ness

Thickness of the 

Wall in which the 

door/window is 

placed

 

 

Parameter Short Description Long Description
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Wallhole 

Dimensions

Width and Height of 

the door/window 

Wallhole as defined 

in Settings dialog 

box (Parameters 

panel or Custom 

Settings panel).

The "Wallhole" is the Opening that is cut 

into the Wall, and is composed of the 

dimensions of the unit (frame) plus any 

tolerance values.

Parameter Short Description Long Description
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Fill Listing Parameters Element Parameters
Fill Listing Parameters

Parameter Short Description Long Description

Fill Category As set in Fill Settings dia-

log:

- Drafting fill

- Cover fill

- Cut fill

- Cut fill - Building Material

Fill Categories are used to group fills according to their function in the 

project. May be useful if you want to retain fill's physical properties 

(use Cut Fill/Building Material), for DXF/DWG Conversion, and for 

Energy Evaluation.

Fill Holes Perime-

ter

Perimeter of all holes in the 

Fill element

 

Fill Perimeter Perimeter of the Fill ele-

ment

 

Fill Type Type of the Fill pattern (e.g. 

Solid, Vectorial, Symbol, 

Image)

To list the name of the Fill type instead: Use the Fill Type parameter in 

the "General" parameter group.

Holes Surface 

Area

Surface area of all holes in 

the Fill element

 

Image name Name of the image-type file 

(for Fills with Fill type of 

"Image")

Defined in the Fill Texture panel of the Fills dialog box, if the Fill type is 

Image

Transparency For transparent Solid Fills, 

lists the percentage trans-

parency.

E.g. 25%, 50%, 75%. All other fills have zero Transparency.
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Lamp Listing Parameters Element Parameters
Lamp Listing Parameters

Parameter Short Description Long Description

Color Blue Blue component of 

the lamp light.

Based on RGB value in the Color field of 

the Parameters Panel of Lamp Settings.

Color Green Green component 

of the lamp light.

Based on RGB value in the Color field of 

the Parameters Panel of Lamp Settings.

Color Red Red component of 

the lamp light.

Based on RGB value in the Color field of 

the Parameters Panel of Lamp Settings.

Light Inten-

sity [0-100]

Light intensity value, 

as set using the 

Main Intensity slider 

in Light Settings 

(Basic Light Param-

eters).

 

Light is on 

(Yes/No)

Light's on/off setting Set with the lightbulb icons in Light Set-

tings (Basic Light Parameters). Affects 

PhotoRenderings.
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Mesh Listing Parameters Element Parameters
Mesh Listing Parameters

Parameter Short Description Long Description

Bottom Sur-

face

Name of surface 

assigned to the bot-

tom of the Mesh.

 

Bottom Sur-

face Area

Surface area of the 

bottom of the Mesh, 

subtracting the area 

of any holes.

Listed for Solid only. (Skirted and surface-

only meshes do not have a bottom.)

Edge Sur-

face Area

Surface area of the 

edge of the Mesh, 

including the sur-

faces of all hole 

edges.

Listed for Solid and Skirted meshes only. 

(Surface-only meshes do not have an 

edge.)

Holes Sur-

face Area

Total top (2D) sur-

face area of all the 

holes in the Mesh

 

Mesh Type Construction 

method used to cre-

ate Mesh:

Surface only, Surface with Skirt or Solid 

Body
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Mesh Listing Parameters Element Parameters
Side Sur-

face

Name of the surface 

assigned to the side 

of the Mesh.

 

Skirt Level For Meshes with a 

skirt, the height of 

the skirt (difference 

between the base 

and top values as 

shown in the Info 

Box.)

 

Top Surface Name of the surface 

assigned to the top 

of the Mesh

 

Top Sur-

face Area

Surface area of the 

top of the Mesh, 

subtracting the sur-

face area of any 

holes.

 

Parameter Short Description Long Description
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Morph Listing Parameters Element Parameters
Morph Listing Parameters

Parameter Short Description Long Description

Area (by 

Story)

Area of the Morph 

broken down by 

Story

 

Cast 

Shadow

On or Off Set checkbox in Morph Settings Model 

Panel.

Classifica-

tion by DIN

Available only if you 

are using the 

Flächenberech-

nung (Area List) 

Add-On (used in 

German-speaking 

markets).

Set this value in Morph Settings - Classifi-

cation and Properties Panel

Receive 

Shadow

On or Off Set checkbox in Morph Settings Model 

Panel.

Surface Name of the surface 

assigned to the 

entire Morph.

 

Volume (by 

Story)

Volume of the 

Morph broken down 

by Story
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Object/Lamp Listing Parameters Element Parameters
Object/Lamp Listing Parameters

Parameter Short Description Long Description

3D Front 

Axonometry

Shaded 3D Symbol 

of the Object.

 

Length (A) Length of the Object 

as defined in the 

"Dimension 2" field 

of the Preview and 

Positioning Panel of 

Object Settings.

 

Rotation 

Angle

Rotation of the 

Object from its 

default position

Rotation either by rotation angle in the 

Preview and Positioning Panel of Object 

Settings, or rotating it graphically in the 

project.

Surface Surface of the 

Object as assigned 

in the Model tab 

page of Object Set-

tings.
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Opening Listing Parameters Element Parameters
Opening Listing Parameters

Parameter Short Description Long Description

Center Height to 

Home Story

For opening in Wall or 

Beam.

Home Story is the same as that of the opening's associated element.

Center Height to 

Project Zero

For opening in Wall or 

Beam.

 

Center Height to 

Wall Bottom

For opening in Wall.  

Center Height to 

Wall Top

For opening in Wall.  

Cut Symbol Name Name of the Symbol for the 

opening's cut display

Opening Settings, Symbol panel

Header Height to 

Home Story

For opening in Wall or 

Beam.

 

Header Height to 

Project Zero

For opening in Wall or 

Beam.

 

Header Height to 

Wall Bottom

For opening in Wall.  

Header Height to 

Wall Top

For opening in Wall.  

IDs of Cut Ele-

ments

ID(s) of all the elements cut 

by this opening.

Use "Parent ID" to list the opening's associated element.

Limits Infinite, or limited on one or 

both sides

 

Number of Cut Ele-

ments

Number of elements cut by 

this opening

 

Orientation Direction of the opening relative to its associated element: Aligned, Vertical, Horizontal or Custom 

angle

Shape Square or Circle  

Sill Height to 

Home Story

For opening in Wall or 

Beam.

Home Story is the same as that of the opening's associated element.

Sill Height to Proj-

ect Zero

For opening in Wall or 

Beam.

 

Sill Height to Wall 

Bottom

For opening in Wall.  

Sill Height to Wall 

Top

For opening in Wall.  

Total Thickness Combined thickness of all elements physically cut by this opening.

Uncut Symbol 

Name

Name of the Symbol for the 

opening's uncut display

Opening Settings, Symbol panel
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Railing Listing Parameters Element Parameters
Railing Listing Parameters

Parameter Short Description Long Description

Number of Balus-

ters

  

Number of Hand-

rails

  

Number of Inner 

Posts

  

Number of Panels   

Number of Posts   

Number of Rails   

Number of 

Toprails

  

Reference Line 

Horizontal Length
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Railing Segment Listing Parameters Element Parameters
Railing Segment Listing Parameters

Parameter Short Description Long Description

Number of Balus-

ters (in a Segment)

  

Number of Hand-

rails (in a Seg-

ment)

  

Number of Inner 

Posts (in a Seg-

ment)

  

Number of Panels 

(in a Segment)

  

Number of Rails 

(in a Segment)

  

Number of 

Toprails (in a Seg-

ment)
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Railing Members Listing Parameters Element Parameters
Railing Members Listing Parameters

Parameter Short Description Long Description

Member Index 

(Inside a Segment)

  

Segment Index   
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Roof Listing Parameters Element Parameters
Roof Listing Parameters

Parameter Short Description Long Description Parameter

Bottom Sur-

face

Name of Surface 

assigned to the 

Roof bottom.

Assign surfaces in the Model panel of 

Roof Settings

Conditional 

Bottom Sur-

face Area

Surface area of the 

bottom of the Roof - 

this area may be 

conditioned on a 

defined Calculation 

Rule.

Condition: Subtracts the area of holes 

only if they exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Roof surface by…")

Reduced by trims and SEO's.

Conditional 

Top Sur-

face Area

Surface area of the 

top of the Roof - this 

area may be condi-

tioned on a defined 

Calculation Rule.

Condition: Subtracts the area of holes 

only if they exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Roof surface by…")

Reduced by trims and SEO's..

Dome Con-

nection 

length

Length of edges 

whose Type is set to 

"Roof Transition - 

Dome" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge of two adjacent Roof 

planes forming a convex angle.

Eaves 

Length

Total length of all 

edges whose Type 

is set to "Eaves," in 

the Custom Edge 

Settings dialog box.
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Roof Listing Parameters Element Parameters
Edge Sur-

face

Name of the Sur-

face assigned to the 

Roof edge.

Lists the Roof's default edge surface (as 

defined in its Building Material). Not listed 

for composite Roofs.

To list all Surfaces, including custom ones 

and those of composite elements, use a 

Surface-type list (e.g. All Finishes).

End Wall 

Connection 

Length

Total length of all 

edges whose Type 

is set to "End Wall" 

in the Custom Edge 

Settings dialog box.

Typically, this is an edge which joins a 

Wall and slopes down along the Wall.

 

Gables 

Length

Total length of all 

edges whose Type 

is set to "Gable" in 

the Custom Edge 

Settings dialog box.

 

 

Geometry 

Method

Single Plane, Multi-

plane

Roof Geometry method

Gross Sur-

face Area of 

the Bottom

Surface area of the 

bottom of the Roof, 

including the sur-

face of any holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Roof 

Edges

Surface area of the 

Roof edges, includ-

ing the surface of 

any holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Top

Surface area of the 

top of the Roof, 

including the sur-

face of any holes.

Reduced by trims. SEO's are ignored

Parameter Short Description Long Description Parameter
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Roof Listing Parameters Element Parameters
Hips Length Length of edges 

whose Type is set to 

"Hip" in the Custom 

Edge Settings dia-

log box.

Typically, the edge of two adjacent planes 

that meet as a hip

Holes Sur-

face Area

Total surface area of 

all holes in the Roof.

 

Hollow Con-

nection 

Length

Length of edges 

whose Type is set to 

"Roof Transition - 

Hollow" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge of two adjacent Roof 

planes forming a concave angle.

Net Surface 

Area of the 

Bottom

Surface area of the 

bottom of the Roof

Reduced by holes, trims and Solid Ele-

ment Operations.

Net Surface 

Area of the 

Edge

Total surface of all 

edges of the Roof

Reduced by holes, trims and Solid Ele-

ment Operations.

Parameter Short Description Long Description Parameter
ARCHICAD 24 Reference Guide 1858



Roof Listing Parameters Element Parameters
Net Surface 

Area of the 

Top

Surface area of the 

top of the Roof

Reduced by holes, trims and Solid Ele-

ment Operations.

Number of 

Holes

Number of holes in 

the Roof

Holes are either created in the Roof man-

ually, or they are cut by Skylights placed 

in the Roof.

Number of 

Skylights

Number of Sky-

lights placed into 

the Roof.

 

Openings 

Surface 

Area

Total surface area of 

all Skylights placed 

in the Roof.

 

Peaks 

Length

Length of edges 

whose Type is set to 

"Peak" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge at the top end of a sin-

gle-plane Roof.

Pitch Pitch of the Roof. Pitch is set in the Geometry and Position-

ing Panel but can be customized for any 

Roof Plane.

Parameter Short Description Long Description Parameter
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Ridges 

Length

Length of edges 

whose Type is set to 

"Ridge" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge of two adjacent Roof 

planes that meet to form a ridge.

Roof Level In case of a multi-

level Roof, indi-

cates the Roof 

Level to which the 

listed Roof plane 

belongs.

Roof Level numbers can be seen in the 

Geometry and Positioning panel of Roof 

Settings or the Info box.
 

Side Wall 

Connection 

Length

Total length of all 

edges whose Type 

is set to "Side Wall" 

in the Custom Edge 

Settings dialog box.

 Typically, a Roof edge which joins a Wall 

and runs along the Wall horizontally.

 

Thickness Roof thickness, 

measured perpen-

dicularly from the 

reference surface.

Thickness value is set in the Geometry 

and Positioning panel of Roof Settings or 

the Info box. (Can be displayed either as 

a perpendicular or vertical measure).

Top Surface Name of the Sur-

face assigned to the 

Roof top.

Assign surfaces in the Model panel of 

Roof Settings

Trimming 

Body

Pivot Lines Down or 

Contours Down

Set in the Model Panel of Roof Settings.

Determines the geometry of the Trimming 

Body which acts upon other elements 

when they are trimmed by this Roof.

Parameter Short Description Long Description Parameter
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Valleys 

Length

Length of edges 

whose Type is set to 

"Valley" in the Cus-

tom Edge Settings 

dialog box.

 

Vertical 

Thickness

Roof thickness 

measured vertically 

from the reference 

surface.

Thickness value is set in the Geometry 

and Positioning panel of Roof Settings or 

the Info box (Can be displayed either as a 

horizontal or vertical measure).

Parameter Short Description Long Description Parameter
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Shell Listing Parameters

Parameter Short Description Long Description Parameter

Conditional 

Surface 

Area of the 

Opposite to 

Reference 

Side

Surface area of the 

side opposite the 

Reference side of 

the Shell - this area 

may be conditioned 

on a defined Calcu-

lation Rule.

Reference side: The Shell membrane (the 

"top" of the Shell.) For a Composite Shell: 

The first listed skin of the composite struc-

ture, in Composite Settings.

Condition: Subtracts the area of holes 

only if they exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Shell surface by…")

Reduced by trims and SEO's.

Conditional 

Surface 

Area of the 

Reference 

Side

Surface area of the 

Reference side - 

this area may be 

conditioned on a 

defined Calculation 

Rule.

Reference side: The Shell membrane (the 

"top" of the Shell.) For a Composite Shell: 

The first listed skin of the composite struc-

ture, in Composite Settings.

Condition: Subtracts the area of holes 

only if they exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Shell surface by…")

Reduced by trims and SEO's.

Distortion 

Angle For an Extruded 

Shell: Angle of the 

Shell profile, mea-

sured to the Shell 

plane. By default: 

90 degrees, but 

changing it enables 

you to extrude the 

Shell profile at a 

angle, creating a 

distorted Shape 

Shell.

For a Revolved 

Shell: Angle of the 

axis of the revolved 

Shell, measured to 

the Shell plane 

angle.

Distortion angle value is set in the Extru-

sion Properties or Revolution Properties 

panel of Shell Settings or in the Info box.
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Dome Con-

nection 

length

Length of edges 

whose Type is set to 

"Roof Transition - 

Dome" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge of two adjacent Shell 

planes forming a convex angle.

 

Eaves 

Length

Total length of all 

edges whose Type 

is set to "Eaves," in 

the Custom Edge 

Settings dialog box.

 

Edge Sur-

face

Name of the Sur-

face assigned to the 

Shell edge.

Lists the Shell's default edge surface (as 

defined in its Building Material). Not listed 

for composite Shells.

To list all Surfaces, including custom ones 

and those of composite elements, use a 

Surface-type list (e.g. All Finishes).

End Angle For an extruded 

Shell only. Angle of 

the Shell profile, 

measured to the 

Shell's inclination 

angle, at the second 

end of the extruded 

Shell. End angle 

value is set in the 

Extrusion Properties 

panel of Shell Set-

tings or in the Info 

box.

 

End Wall 

Connection 

Length

Total length of all 

edges whose Type 

is set to "End Wall" 

in the Custom Edge 

Settings dialog box.

Typically, this is an edge which joins a 

Wall and slopes down along the Wall.

Parameter Short Description Long Description Parameter
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Gables 

Length

Total length of all 

edges whose Type 

is set to "Gable" in 

the Custom Edge 

Settings dialog box.

 

Geometry 

Method

Geometry method 

used to create the 

Shell: Extruded, 

Revolved, or Ruled

 

Gross Sur-

face Area of 

the Edges

Surface area of the 

Shell edges, includ-

ing the surface of 

any holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Oppo-

site to Ref-

erence Side

Surface area of the 

side opposite the 

Reference side, 

including the sur-

face of any holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Refer-

ence Side

Surface area of the 

Reference side of 

the Shell, including 

the surface of any 

holes.

Reference side: The Shell membrane (the 

"top" of the Shell.) For a Composite Shell: 

The first listed skin of the composite struc-

ture, in Composite Settings.

Reduced by trims. SEO's are ignored.

Hips Length Length of edges 

whose Type is set to 

"Hip" in the Custom 

Edge Settings dia-

log box.

Typically, the edge of two adjacent planes 

that meet as a hip

 

Parameter Short Description Long Description Parameter
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Holes Sur-

face Area

Total surface area of 

all holes in the 

Shell.

 

Hollow Con-

nection 

Length

Length of edges 

whose Type is set to 

"Roof Transition - 

Hollow" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge of two adjacent Shell 

planes forming a concave angle.

 

Net Surface 

Area of the 

Edges

Total surface of all 

edges of the Shell

Reduced by holes, trims and Solid Ele-

ment Operations.  

Net Surface 

Area of the 

Opposite to 

Reference 

Side

Surface area of the 

side opposite the 

Reference side of 

the Shell

Reduced by holes, trims and Solid Ele-

ment Operations.

Net Surface 

Area of the 

Reference 

Side

Surface area of the 

Reference side of 

the Shell

Reference side: The Shell membrane (the 

"top" of the Shell.) For a Composite Shell: 

The first listed skin of the composite struc-

ture, in Composite Settings.

Reduced by holes, trims and Solid Ele-

ment Operations.

Number of 

Holes

Number of holes in 

the Shell

Holes are either created in the Shell man-

ually, or they are cut by Skylights placed 

in the Shell.

Parameter Short Description Long Description Parameter
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Number of 

Skylights

Number of Sky-

lights placed into 

the Shell.

 

Openings 

Surface 

Area

Total surface area of 

all Skylights placed 

in the Shell.

 

Peaks 

Length

Length of edges 

whose Type is set to 

"Peak" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge at the top end of a sin-

gle-plane Shell.

 

Revolution 

Angle

For a Revolved 

Shell only. Angle by 

which the Shell is 

rotated around its 

axis. Revolution 

angle value is set 

graphically, when 

creating the Shell, 

or in the Revolution 

Properties panel of 

Shell Settings or in 

the Info box.

 

Ridges 

Length

Length of edges 

whose Type is set to 

"Ridge" in the Cus-

tom Edge Settings 

dialog box.

Typically, the edge of two adjacent Shell 

planes that meet to form a ridge.

 

Parameter Short Description Long Description Parameter
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Side Wall 

Connection 

Length

Total length of all 

edges whose Type 

is set to "Side Wall" 

in the Custom Edge 

Settings dialog box.

 Typically, a Shell edge which joins a Wall 

and runs along the Wall horizontally.

Start Angle For an extruded 

Shell only. Angle of 

the Shell profile, 

measured to the 

Shell's inclination 

angle, at the starting 

end of the extruded 

Shell. Start angle 

value is set in the 

Extrusion Properties 

panel of Shell Set-

tings or in the Info 

box.

 

Surface of 

the Shell on 

the Oppo-

site to Ref-

erence Side

Name of the Sur-

face assigned to the 

side opposite the 

Reference side.

Assign surfaces in the Model panel of 

Shell Settings

Surface of 

the Shell on 

the Refer-

ence Side

Name of the Sur-

face assigned to the 

Reference side.

Reference side: The Shell membrane (the 

"top" of the Shell.) For a Composite Shell: 

The first listed skin of the composite struc-

ture, in Composite Settings.

Assign surfaces in the Model panel of 

Shell Settings

Parameter Short Description Long Description Parameter
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Trimming 

Body

Downward Extru-

sion, Upward Extru-

sion, or Editable.

Set in the Model Panel of Shell Settings.

Determines the geometry of the Trimming 

Body which acts upon other elements 

when they are trimmed by this Shell.

Parameter Short Description Long Description Parameter
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Skylight Listing Parameters

Parameter Short Description Long Description

Acoustic 

Rating

Acoustic rating 

value (if any), as 

defined in Window 

Settings (Custom 

Settings, Descrip-

tions page).

 

 

Constraint 

in Roof

Either "Horizontal" 

or "Vertical", as set 

in the Preview and 

Positioning Panel of 

Skylight Settings.

Defines how the Skylight will be con-

strained as it shifts position if the underly-

ing Roof geometry is modified.

Curb Height Distance by which 

Skylight frame 

extrudes out of the 

Roof/Shell plane.

A value of 0 means the Skylight lies flat 

on the plane.

Fire Rating Fire rating value (if 

any), as defined in 

Window Settings 

(Custom Settings, 

Descriptions page).

 

 

Header 

Height

Vertical Height of 

the Skylight header

Header or Sill Height is measured from 

the Anchor (e.g. Story 0), as defined in 

Preview and Positioning Panel.

Marker Text The Marker Text 

specified in the Set-

tings dialog box, in 

the Dimension 

Marker Panel, under 

Customize Texts- 

Marker Texts 

parameter.

This text is equivalent to the element's ID 

number by default, but a custom text may 

be assigned here.
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Shell/Roof 

Opening 

Area

Surface area of the 

opening cut by the 

Skylight.

 

Shell/Roof 

Opening 

Dimen-

sions 

(ARCHI-

CAD 20)

Width x Height of 

the opening cut by 

the Skylight.

 

Shell/Roof 

Opening 

Volume

Volume of the open-

ing cut by the Sky-

light.

Volume calculation based on hole that 

results from cutting the GDL openings out 

of the Shell/Roof.

Shell/Roof 

Opening W 

x H Size

  

Shell/Roof 

Opening W 

x H x T Size

  

 

Shell/Roof 

Thickness

Thickness of the 

parent Roof/Shell in 

which the Skylight is 

placed.

 

Parameter Short Description Long Description
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Sill Height Height of the Sky-

light Sill, as shown 

in the Preview and 

Positioning Panel

Header or Sill Height is measured from 

the Anchor (e.g. Story 0), as defined in 

Preview and Positioning Panel.

Sill/Header 

Value

Sill/header height 

value as defined in 

Preview and Posi-

tioning panel of the 

Settings Dialog box. 

(Value measures 

the distance from 

the header or from 

the sill, to the Roof 

Pivot Lines, to the 

current Story or 

another story, as 

defined by the user.)

 

Unit Dimen-

sions 

(ARCHI-

CAD 20)

Width and height of 

the Skylight unit, as 

defined in Settings 

dialog box (Parame-

ters panel or Cus-

tom Settings panel).

 

Vertical 

Anchor

Vertical Anchor as 

defined in the Pre-

view and Position-

ing Panel. Header 

and Sill heights are 

measured to the 

vertical anchor.

Not relevant for Skylights placed in 

Shells.

Parameter Short Description Long Description
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Slab Listing Parameters Element Parameters
Slab Listing Parameters

Parameter Short Description Long Description

Bottom Sur-

face

Name of the Sur-

face assigned to the 

Bottom Surface of 

the Slab.

Defined in Slab Settings

Bottom Sur-

face Area

Area of the Surface 

of the Slab Bottom

Reduced by any trims, SEO's or holes.

Conditional 

Surface 

Area of the 

Bottom

Surface Area of the 

Bottom of the Slab - 

this Area may be 

conditioned on a 

defined Calculation 

Rule.

Condition: Subtracts the Area of holes 

only if they exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Slab Surface by…")

Reduced by trims and SEO's.

Conditional 

Surface 

Area of the 

Top

Surface Area of the 

Top of the Slab - this 

Area may be condi-

tioned on a defined 

Calculation Rule.

Condition: Subtracts the Area of holes 

only if they exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Slab Surface by…")

Reduced by trims and SEO's.

Edge Sur-

face

Name of Surface 

assigned to Slab 

edges.

Lists the Slab's default edge surface (as 

defined in its Building Material). Not listed 

for composite Slabs.

To list all Surfaces, including custom ones 

and those of composite elements, use a 

Surface-type list (e.g. All Finishes).

Edge Sur-

face Area

Area of the Surface 

of the edge of the 

Slab

Reduced by trims and SEO's.
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Elevation 

Bottom

Elevation of the Bot-

tom of the Slab

 

Elevation 

Top

Elevation of the Top 

of the Slab

 

Gross Sur-

face Area of 

the Slab 

Bottom

Area of the Surface 

of the Bottom of the 

Slab, including the 

Surface of any 

holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Slab 

Bottom with 

holes

Area of the Surface 

of the Bottom of the 

Slab, subtracting 

the Surface of any 

holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Slab 

edges

Area of the Surface 

of all the Slab 

edges. Hole edges 

are ignored.

Reduced by trims. SEO's are ignored

Parameter Short Description Long Description
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Gross Sur-

face Area of 

the Slab 

edges with 

holes

Area of the Surface 

of all the Slab 

edges, including the 

edges of any holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Slab 

Top

Area of the Surface 

of the Top of the 

Slab, including the 

Surface of any 

holes.

Reduced by trims. SEO's are ignored

Gross Sur-

face Area of 

the Slab 

Top with 

holes

Area of the Surface 

of the Top of the 

Slab, reduced by 

the Surface of any 

holes.

Reduced by trims. SEO's are ignored

Holes Sur-

face Area

Total Top Surface 

Area of all holes in 

the Slab, measured 

according to the 

Slab's 2D polygon.

SEO's are ignored

Reference 

Plane Loca-

tion

Top or Bottom.

For a composite 

Slab, can also be 

Core Top or Core 

Bottom

Reference Plane location as defined in 

Slab Settings.

 

Top Surface Name of Surface 

assigned to the Top 

Surface of the Slab.

 

Parameter Short Description Long Description
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Top Sur-

face Area

Area of the Surface 

of the Top of the 

Slab.

Reduced by any trims, SEO's or holes.

Parameter Short Description Long Description
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Stair Listing Parameters Element Parameters
Stair Listing Parameters

Parameter Short Description Long Description

Default 

Going 

Depth

Going depth as 

defined in Stair Set-

tings.

 

Default 

Riser Height

Riser Height as 

defined in Stair Set-

tings

 

Default 

Riser Slant 

Angle

As defined in Stair 

Settings

 

Default Stair 

Width

Width of the Stair as 

defined in Stair Set-

tings.

 

Front Sur-

face Area

Total Surface area 

of the Stair from the 

front
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Maximum 

Going (by 

Rule)

As defined in Stair 

Settings (Rules & 

Standards Panel)

 

Maximum 

Riser Height 

(by Rule)

As defined in Stair 

Settings (Rules & 

Standards Panel)

 

Minimum 

Going (by 

Rule)

As defined in Stair 

Settings (Rules & 

Standards Panel)

 

Minimum 

Riser Height 

(by Rule)

As defined in Stair 

Settings (Rules & 

Standards Panel)

 

Number of 

Risers 

(total)

  

Parameter Short Description Long Description
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Number of 

Risers by 

Flights

  

Number of 

Treads 

(total)

  

Number of 

Treads by 

Flights

  

Required 

Head-

room Heigh

t

As defined in Stair 

Settings (Rules & 

Standards Panel)

 

 

Stair Pitch   

Parameter Short Description Long Description
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Walking 

Line Length

Length of Calcu-

lated Walking Line.

Calculated Walking Line: defined in the 

Geometry and Positioning panel of Stair 

Settings.

(Can differ from length of graphically 

edited Walking Line.)

Parameter Short Description Long Description
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Stair Finish Listing Parameters

Parameter Short Description Long Description

Back Width   

Flight Index The Flight number 

to which the Tread/

Riser belongs.

(A Tread/Riser on a Landing has a Flight 

Index of 0.)

Front Sur-

face Area

Surface area of the 

front of the tread 

(based on its verti-

cal projection)

The visible part of 

the Riser viewed 

from the front

 

Front Width   

Segment 

Type

Landing, Run, 

Divided Landing, 

Winder Turn
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Step Index The Step number to 

which the Tread/

Riser belongs

 

Total Sur-

face Area

Total Surface area 

of the Riser

 

Tread Flight 

Length

Going depth plus 

Tread Nosing

 
 

Tread Going Going depth  

Tread Nos-

ing

Length of nosing's 

horizontal protru-

sion

 

Tread Top 

Surface 

Area

Surface area of the 

top of the tread

 

Parameter Short Description Long Description
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Stair Structure Listing Parameters

Parameter Short Description Long Description

Construc-

tion Type

Type of Stair Struc-

ture: Monolith, 

Beam, Stringers, or 

Cantilevered

 

 

Drain 

Length

Length of Draining 

(Monolith Structure 

only)

 

Drain Posi-

tion

Position of Draining 

(Right and/or Left, 

relative to direction 

of Stair baseline).

Assign in "Draining on Flight" Panel of 

Stair Settings (Monolithic Structure only)

Profile 

Height

Profile dimension of 

the supporting 

Structure.

Not relevant for Monolithic structure.

Profile 

Width

Profile dimension of 

the supporting 

Structure.

Not relevant for Monolithic structure.
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Profile WxH Profile dimension of 

the supporting 

Structure.

Not relevant for Monolithic structure.

Secondary 

Thickness

As in Settings - rele-

vant for Monolithic 

Flight Structures 

using a Stepped or 

Variable shape.

 

Shape Type Shape of Stair bot-

tom, as defined in 

Flight Structure Set-

tings.

Flat, Stepped, Variable, or Filled (for 

Monolithic Flight Structures)

Straight or Stepped (for Beam-type 

Flights)

Stair Struc-

ture 3D 

Height

Height of Stair struc-

ture in 3D

Measured from the flight's lowest to high-

est z-point  

Stair Struc-

ture Flight 

Index

Flight number Flight structures are numbered consecu-

tively  

Stair Struc-

ture Land-

ing Index

Landing number Landing structures (if any) are numbered 

consecutively  

Stair Struc-

ture Posi-

tion

For Stringers: Left 

or Right position. All 

other Structures are 

listed as "Under 

Stair."

 

Parameter Short Description Long Description
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Thickness Thickness of Struc-

ture element (as in 

Settings).

 

 

Parameter Short Description Long Description
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Wall Listing Parameters

Parameter Short Description Long Description

Air Skin 

Thickness

Thickness of Wall 

skin whose struc-

ture is defined as 

"Air skin"

Air Skin is defined at Options > Project 

Preferences > Calculation Units & Rules.

Analytic 

Surface 

Area of 

Openings 

on the 

Inside Face

Surface Area of all 

Wall Openings (win-

dows, doors, empty 

Openings) on the 

Wall's Inside Face.

Surface calculation is based on hole that 

results from cutting the GDL Openings 

out of the Wall.

Analytic 

Surface 

Area of 

Openings 

on the Out-

side Face

Surface Area of all 

Wall Openings (win-

dows, doors, empty 

Openings) on the 

Wall's Outside 

Face.

Surface calculation is based on hole that 

results from cutting the GDL Openings 

out of the Wall.

Analytic 

Volume of 

the Open-

ings

Volume of all Wall 

Openings (windows, 

doors, empty Open-

ings).

Volume calculation based on hole that 

results from cutting the GDL Openings 

out of the Wall.

Does not take SEO's into account.

Combined 

Width of 

Doors

Sum of the nominal 

widths (as defined 

in Door Settings) of 

all doors placed in 

the Wall.
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Combined 

Width of 

Windows

Sum of the nominal 

widths (as defined 

in Window Set-

tings) of all windows 

placed in the Wall

 

Conditional 

Length on 

the Inside 

Face

Length of Wall along 

its Inside Face - this 

Length may be con-

ditioned on a 

defined Calculation 

Rule.

Condition: Subtracts the Length of any 

Openings that exceed a given Length, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Wall Length by…").

Conditional 

Length on 

the Outside 

Face

Length of Wall along 

its Inside Face - this 

Length may be con-

ditioned on a 

defined Calculation 

Rule.

Condition: Subtracts the Length of any 

Openings that exceed a given Length, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Wall Length by…").

Conditional 

Surface 

Area on the 

Inside Face

Surface Area of 

Wall on its Inside 

Face - this area may 

be conditioned on a 

defined Calculation 

Rule.

Condition: Subtracts the surface of any 

Openings that exceed a given area as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Wall surface by…").

Reduced by trims and SEO's.

Conditional 

Surface 

Area on the 

Outside 

Face

Surface Area of 

Wall on its Outside 

Face - this area may 

be conditioned on a 

defined Calculation 

Rule.

Condition: Subtracts the surface of any 

Openings that exceed a given area as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Wall surface by…").

Reduced by trims and SEO's.

Parameter Short Description Long Description
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Conditional 

Wall Skin 

Volume on 

the Inside 

Face

Volume of skin on 

the Wall's Inside 

Face - this Volume 

may be conditioned 

on a defined Calcu-

lation Rule.

Condition: subtracts the Volume of any 

Openings that exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Wall Volume by…").

Reduced by trims and SEO's.

Conditional 

Wall Skin 

Volume on 

the Outside 

Face

Volume of skin on 

the Wall's Outside 

Face - this Volume 

may be conditioned 

on a defined Calcu-

lation Rule.

Condition: subtracts the Volume of any 

Openings that exceed a given size, as 

defined in Options > Project Preferences 

> Calculation Units & Rules ("Reduce 

Wall Volume by…").

Reduced by trims and SEO's.

Edge Sur-

face

Name of Surface 

assigned to Wall 

edges.

Lists the Wall's default edge surface (as 

defined in its Building Material). Not listed 

for composite Walls.

To list all Surfaces, including custom ones 

and those of composite elements, use a 

Surface-type list (e.g. All Finishes).

End Thick-

ness of the 

Wall

End thickness of 

trapezoid Wall.

Second thickness, assigned in Wall Set-

tings to a trapezoid Wall.

Geometry 

Method

Uniform, Trapezoid 

or Polygonal.

 
 

Gross Sur-

face Area of 

the Wall on 

the Inside 

Face

Gross Surface Area 

of the Wall - includ-

ing the surfaces of 

any Openings - on 

the Inside Face.

Reduced by trims. SEO's are ignored.

Parameter Short Description Long Description
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Gross Sur-

face Area of 

the Wall on 

the Outside 

Face

Gross Surface Area 

of the Wall - includ-

ing the surfaces of 

any Openings - on 

the Outside Face.

Reduced by trims. SEO's are ignored.

Inside Face 

Surface

Name of the surface 

assigned to the 

Wall's Inside Face.

 

Length of 

Reference 

Line

Length of the Wall's 

Reference Line.

 

Length of 

the Wall at 

the Center

Length of the Wall, 

as measured from 

end to end along 

Wall's centerline.

 

 

Length of 

the Wall on 

the Inside 

Face

Length of the Wall, 

as measured from 

end to end along 

Wall's Inside Face.

 

Length of 

the Wall on 

the Outside 

Face

Length of the Wall, 

as measured from 

end to end along 

Wall's Outside 

Face.

 

Parameter Short Description Long Description
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Maximum 

Height of 

the Wall

Height of Wall at its 

highest point.

Roof crops are considered.

Trims and SOE's are ignored.

Maximum 

Height of 

the Wall 

Skin on the 

Inside Face

Height of Wall skin, 

at its highest point, 

on the Wall's Inside 

Face.

Roof crops are considered.

Trims and SOE's are ignored.

Maximum 

Height of 

the Wall 

Skin on the 

Outside 

Face

Height of Wall skin, 

at its highest point, 

on the Wall's Out-

side Face.

Roof crops are considered.

Trims and SOE's are ignored.

Minimum 

Height of 

the Wall 

Skin on the 

Inside Face

Height of Wall skin, 

at its lowest point, 

on Wall's Inside 

Face.

Roof crops are considered.

Trims and SOE's are ignored.

Minimum 

Height of 

the Wall 

Skin on the 

Outside 

Face

Height of Wall skin, 

at its lowest point, 

on the Wall's Out-

side Face.

Roof crops are considered.

Trims and SOE's are ignored.

 

Net Surface 

Area of the 

edges

Sum of the areas of 

all Wall edges. 

Reduced by trims 

and Solid Element 

Operations.

 

Parameter Short Description Long Description
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Net Surface 

Area on the 

Inside Face

Surface Area of the 

Wall on the Inside 

Face.

Reduced by Openings, trims and Solid 

Element Operations.

Net Surface 

Area on the 

Outside 

Face

Surface Area of the 

Wall on the Outside 

Face.

Reduced by Openings, trims and Solid 

Element Operations.

Number of 

Columns

Number of Col-

umns that intersect 

the Wall

 

Number of 

Doors

Number of Door ele-

ments in the Wall

 

Number of 

Holes (Num-

ber of 

Empty 

Openings)

Number of Empty 

Opening Objects in 

the Wall

 

Parameter Short Description Long Description
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Number of 

Windows

Number of Window 

elements in the Wall

 

Outside 

Face Sur-

face

Name of the surface 

assigned to the 

Wall's Outside 

Face.

 

Reference 

Line loca-

tion

As defined in Wall 

Settings (Outside 

Face, Inside Face 

or Center).

For composite Walls: can also be Core 

Outside, Core Inside or Core Center.
 

Wall Inside 

Slant Angle

Angle of a slanted 

Wall from the per-

pendicular to its 

Inside Face.

 

Wall Out-

side Slant 

Angle

Angle of a slanted 

Wall from the per-

pendicular to its 

Outside Face.

Same as the General "Slant Angle" 

parameter

Wall Skin 

Thickness 

on the 

Inside Face

For Composite 

Walls: Thickness of 

the skin on the 

Wall's Inside Face.

Each skin thickness is defined in Options 

> Element Attributes > Composite Struc-

tures.

Parameter Short Description Long Description
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Wall Skin 

Thickness 

on the Out-

side Face

For Composite 

Walls: Thickness of 

the skin on the 

Wall's Outside 

Face.

Each skin thickness is defined in Options 

> Element Attributes > Composite Struc-

tures.

Wall Skin 

Volume on 

the Inside 

Face

Net Volume of the 

skin on the Wall's 

Inside Face.

Subtracts Volumes of Openings within the 

skin

Reduced by trims and SEO's.

Wall Skin 

Volume on 

the Outside 

Face

Net Volume of the 

skin on the Wall's 

Outside Face.

Subtracts Volumes of Openings within the 

skin

Reduced by trims and SEO's.

Wall Slant 

Type

Straight, Slanted, or 

Double-slanted.

As defined in Wall Settings, Geometry 

and Positioning Panel

Parameter Short Description Long Description
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Zone Listing Parameters

Parameter Short Description Long Description

Area 

Reduce-

ment

The Calculated 

Area as a percent-

age of the Reduced 

Area.

In Zone Settings - Area Calculation Panel: 

If you check "Reduce by" a certain per-

centage, the result is the Calculated Area.

(For example: If "Reduce by" is 20 per-

cent, the "Area Reducement" is 80 per-

cent.)

 

Calculated 

Area

The Zone's area 

after the Reduced 

Area is further 

reduced by the per-

centage value set in 

the Area Calculation 

panel of Zone Set-

tings.

In Zone Settings - Area Calculation Panel: 

check "Reduce by", and enter a percent-

age to subtract that from the Reduced 

Zone area. The result is the Calculated 

Area.

Doors Sur-

face Area

Total surface area of 

all Doors in the 

Zone.

A Door is in the zone if any part of its 2D 

polygon is inside of, or coincides with the 

edge of, the Zone's 2D polygon.

Doors 

Width

Total width of all 

Doors in the Zone.

A Door is in the zone if any part of its 2D 

polygon is inside of, or coincides with the 

edge of, the Zone's 2D polygon.

Extracted 

Column 

Area

Column area sub-

tracted from Mea-

sured Zone area.

Relevant if the zone polygon contains 

Column(s). If Relation to Zones = 

"Reduce Zone Area Only" AND the Col-

umn's area exceeds the minimum defined 

in Zones Preferences, then the Zone is 

reduced by the percentage set in Zones 

Preferences.
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Extracted 

Fill Area

Fill area subtracted 

from the Measured 

Zone area.

Relevant if the zone polygon contains 

Fill(s). If Subtract from Zones is enabled 

for the Fill (see Fill Settings - General Set-

tings), then the Zone area is reduced by 

the defined percentage.

 

Extracted 

Low Area

Low ceiling area 

subtracted from 

Measured Zone 

area.

 If the Zone is trimmed by a Roof or Shell: 

The zone area is reduced by the "Area 

reduction under Low Ceiling" as defined 

in Zones Preferences.

 

Extracted 

Wall Area

Wall area sub-

tracted from Mea-

sured Zone area.

Relevant if the zone polygon contains 

Wall(s). If Relation to Zones = "Reduce 

Zone Area Only" AND the Wall's area 

exceeds the minimum defined in Zones 

Preferences, then the Zone is reduced by 

the percentage set in Zones Preferences.

 

Floor Thick-

ness

Subfloor Thickness 

value.

Defined in the Name and Positioning 

Panel of Zone Settings.

Measured 

Area

Total area of the 

Zone polygon. Can 

include the area of 

bounding walls up 

to their reference 

line.

Bounding Walls are included in Measured 

Area if the Zone extends to their refer-

ence line.

Measured 

Net Area

Total area of the 

Zone polygon. Does 

not include the area 

of any bounding 

walls.

Zone Area may be 

further reduced by 

area of certain ele-

ments within Zone 

polygon.

The Net Area excludes the footprint of 

construction elements within the zone

whose "Relation to Zones" option is set to 

"Zone Boundary".

Relation to Zones is available for

- Walls and Columns: Settings dialog, 

Model Panel

- Curtain Wall: Settings dialog, Member 

Placement Panel

 

Parameter Short Description Long Description
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Number of 

Beams

Number of Beams 

in the Zone.

A Beam is in the zone if any part of its 2D 

polygon is inside of, or coincides with the 

edge of, the Zone's 2D polygon.

Number of 

Columns

Number of Col-

umns in the Zone.

A Column is in the zone if any part of its 

2D polygon is inside of, or coincides with 

the edge of, the Zone's 2D polygon.

Number of 

Concave 

Corners

Concave corners of 

the Zone polygon.

 

 

Number of 

Corners

Total number of cor-

ners of Zone poly-

gon.

 

 

Number of 

Doors

Number of Doors in 

the Zone.

A Door is in the zone if any part of its 2D 

polygon is inside of, or coincides with the 

edge of, the Zone's 2D polygon.

Number of 

Lamps

Number of Lamps in 

the Zone.

A Lamp is in the zone if any part of its 2D 

polygon is inside of, or coincides with the 

edge of, the Zone's 2D polygon.

Parameter Short Description Long Description
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Number of 

Objects

Number of Objects 

in the Zone.

An Object is in the zone if any part of its 

2D polygon is inside of, or coincides with 

the edge of, the Zone's 2D polygon.

Number of 

Wall Parts

Wall part: a Wall 

which runs along a 

Zone border.

 

Number of 

Windows

Number of Windows 

in the Zone.

A Window is in the zone if any part of its 

2D polygon is inside of, or coincides with 

the edge of, the Zone's 2D polygon.

Reduced 

Area

The Zone's area 

after the Measured 

Net Area is reduced 

by certain element-

level reductions, 

subject to Zone 

Preferences.

Construction elements: if Relation to 

Zones = "Reduce Zone Area Only" AND 

the Wall/Column's area exceeds the mini-

mum defined in Zones Preferences, then 

the Zone is reduced by the percentage 

set in Zones Preferences.

Fills: If Subtract from Zones is enabled for 

the Fill (see Fill Settings - General Set-

tings), then the Zone area is reduced by 

the defined percentage.

If the Zone is trimmed by a Roof or Shell: 

The zone area is reduced by the "Area 

reduction under Low Ceiling" as defined 

in Zones Preferences.

 

Parameter Short Description Long Description
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Related Ele-

ment(s) 3D

The ID of the ele-

ment(s) with which 

the Zone collides in 

3D

The counterpart (General) listing parame-

ter is "Colliding Zones," which lists the 

names of a Zone's colliding elements.
 

Surface Surface assigned to 

the Zone.

 

Total 

Extracted 

Area

Total of Wall/Col-

umn/Curtain Walls/

Fills/Low ceiling 

area subtracted in 

calculating the Zone 

area.

Relevant if the zone polygon contains cer-

tain elements.

Zone area calculation varies depending 

on Relation to Zone settings of elements 

within Zone polygon, and Zones Prefer-

ences.

 

Uniform 

Surface

Checkbox On or off 

indicates whether 

the Zone uses a uni-

form surface.

If checkbox is off, then the Zone faces 

inherit the surfaces of the surrounding 

Zone boundaries.

This value is set in the Model Panel of 

Zone Settings. Select a surface for the 

Zone, then choose either: "Use this Sur-

face on All Zone Faces", or "Inherit 

Boundary Wall and Cropping Element 

Surfaces."

 

Wall Inset 

Back Side 

Surface 

Area

Surface Area of 

Zone's Wall inset on 

the back

Wall Insets are created via Opening 

geometry: Reveals, Wall Inset, and/or 

Wall Niche. If these geometries affect the 

Zone (e.g. if the inset size exceeds the 

minimum as set in Zone Preferences, 

and/or the opening's reference line coin-

cides with that of the Zone), then these 

parameters give you the areas of the 3D 

inset's top, sides and back.

 

Wall Inset 

Side Sur-

face Area

Surface Area of 

Zone's Wall inset on 

the side

 

 

Wall Inset 

Top Sur-

face Area

Surface Area of 

Zone's Wall inset on 

the top

 

 

Parameter Short Description Long Description
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Walls 

Perimeter

Perimeter of the 

Walls bounding the 

Zone.

 

Walls Sur-

face Area

Surface area of 

Walls in the Zone.

A Wall is in the zone if any part of its 2D 

polygon is inside of, or coincides with the 

edge of, the Zone's 2D polygon.

Windows 

Surface 

Area

Surface area of 

Windows in the 

Zone.

A Window is in the zone if any part of its 

2D polygon is inside of, or coincides with 

the edge of, the Zone's 2D polygon.

Windows 

Width

Total width of all 

Windows in the 

Zone.

A Window is in the zone if any part of its 

2D polygon is inside of, or coincides with 

the edge of, the Zone's 2D polygon.

Zone Cate-

gory

Name of the Zone 

Category assigned 

to this Zone.

Defined in the Name and Positioning 

Panel of Zone Settings.  

Zone Cate-

gory Code

Number of the Zone 

Category assigned 

to this Zone.

Depends on Zone Category. Zone Cate-

gory Codes are assigned to Zone Catego-

ries at Options > Element Attributes > 

Zone Categories (click Rename to access 

the Code field).

 

Parameter Short Description Long Description
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Zone Gross 

Perimeter

Perimeter of the 

Zone, correspond-

ing to the Zone poly-

gon at the bottom of 

the Zone body.

For a Zone created with the Reference 

Line method, the perimeter is measured 

along the Reference Lines of the bound-

ary Walls.

 

Zone Name Name of the Zone 

as defined in the 

Name and Position-

ing Panel of Zone 

Settings.

 

 

Zone Net 

Perimeter

Perimeter of the 

Zone, measured 

along the inner 

edges of the sur-

rounding Walls 

(regardless of the 

position of the 

Walls' Reference 

line).

 

Zone Num-

ber

Number of the Zone 

as defined in the 

Name and Position-

ing Panel of Zone 

Settings.

 

 

Parameter Short Description Long Description
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Component Listing Parameters in the Interactive Schedule

Use these parameters in the Component lists of the Interactive Element Schedule.

Related Topics:

Calculation of Projected Component/Skin Area

Element Parameters

COMPONENT FIELD DESCRIPTION

Component Cross Section Area Area of the Component cross-section

Component Type Core, Finish, or Other

Embodied Carbon As defined for the component's Building Material

Embodied Energy As defined for the component's Building Material

Mass Calculated based on component's volume and the Building 

Material's Density value

Skin Thickness As defined in the component

Projected Component/Skin Area The projection onto the virtual plane that runs through the 

center of the skin/component. 

See Projected Skin Areas of Basic and Composite Elements 

and Component Areas of Complex Profiles.

Rectangular Component Height Height of rectangular component in 2D

Rectangular Component Width Width of rectangular component in 2D

Skin/Component Fill Outline Pen Pen number

Skin/Component Volume Volume of the skin or component
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Calculation of Projected Component/Skin Area

Use the Projected Component/Skin Area field to calculate the area of any components of basic, composite or 

profiled elements.

Note: Morphs and basic non-veneer columns are an exception: skin area cannot be calculated for these 

elements.

Both Skin/Component Volume and Area are available as GDL Requests for use in listing and property objects. 

Skin/Component Volume and Area, however, cannot be displayed as parameters in placeable elements such 

as Labels.

Related Topics:

Projected Skin Areas of Basic and Composite Elements

Component Areas of Complex Profiles

Projected Skin Areas of Basic and Composite Elements

For most elements, the calculated area is that of the projection onto the virtual plane that runs through the 

center of the skin/component.

Watch the Video

Watch the Video

The following table gives more details about area calculation for each element type.

Basic or Composite 

Element

Which Plane is used to Calculate Projected Component/

Skin Area?

Regular Straight Wall The vertical plane that runs 

through the center of the skin.

Slanted Wall The slanted plane that runs 

through the center of the skin.
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Curved Wall The plane of the vertical 

cylinder that runs through the 

center of the skin.

Curved Slanted Wall The plane of the cone that runs 

through the center of the skin. 

Double Slanted Wall The plane of the variable-

thickness skin that is closest to 

the wall's reference line.

Trapezoid Wall The plane of the variable-

thickness skin that is closest to 

the wall's reference line.

Polygon Wall The plane(s) of the vertical 

polygon(s) defined by the 

reference edge(s).

Basic or Composite 

Element

Which Plane is used to Calculate Projected Component/

Skin Area?
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Roof Plane of the roof.

Slab Plane of the slab.

Shell The plane of the skin that is 

closer to the Shell reference 

plane

Mesh The Mesh reference plane

Straight Beam The Beam's vertical plane

Basic or Composite 

Element

Which Plane is used to Calculate Projected Component/

Skin Area?
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Component Areas of Complex Profiles

For complex profiles, the projected area of each component skin can be calculated.

Column without Veneer No skin/component area is calculated.

Column with Veneer 

(circular)

Circular column with veneer: 

The plane of the centerline of 

the veneer component.

Column with Veneer 

(rectangular)

The program calculates the 

veneer as if it were divided into 

four parts as shown, and the 

vertical plane of each is used.

Morph No skin/component area is calculated

Basic or Composite 

Element

Which Plane is used to Calculate Projected Component/

Skin Area?
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When listing these areas for a profile element, you can control:

• which components should be included in listing the projected component areas

• for each component, which plane should be used as the basis for area calculation

These features are described below.

Choose Profile Components for Area Listing

1. In the Profile Editor window, select a component.

2. In the Profile Manager (Options > Complex Profiles > Profile Manager), activate the List Component 

Area checkbox for each component whose area you want to list.

In this example, we are editing the Brick Wall w Footing element. The veneer's checkbox is on, and its 

area will be included in the schedule. The footing area, however, is not relevant and its checkbox is off. 

List Component Area: On for Veneer, Off for Footing

3. Click Store Profile to save changes.

4. The area of the concrete footing component is not included in the schedule.
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Adjust Calculated Area of Profile Components

To adjust how the component's projected area is calculated, you can graphically edit its Base Line or Base 

Circle in the Profile Editor, if needed.

• Use the Base Line to calculate the component area as projected onto the flat surface represented by the 

line. By default, the base line is located along the longest segment of the profile.

• Use the Base Circle to calculate the area as projected onto an arched component.

Note: To keep all the Base Lines visible in Profile Editor, regardless of component selection, make sure 

you have turned on View > On-Screen View Options > Component Area Base Line/Circle.

In this example, you need the area of the Generic Column on its horizontal surface. 

1. In Profile Editor, select the component.

2. Activate the List Component Area checkbox.

3. The component's base line is vertical, which is not the area you need. In the Profile Editor window, select 

the base line and rotate it to a horizontal position.
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4. Click Store Profile to save changes.

5. The horizontal area of the column is included in the schedule.

For general information on editing in the Profile Manager, see Profile Manager.
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Functions in Expressions

The constants, operators and functions described in this section can be used to create Expression-defined 

Properties for ARCHICAD elements.

CONSTANTS

OPERATORS

LOGICAL FUNCTIONS

MATHEMATICAL FUNCTIONS

TRIGONOMETRICAL FUNCTIONS

STATISTICAL FUNCTIONS

TEXT EDITING FUNCTIONS

DATA CONVERSION

Related Topics

Expression-Defined Element Properties

Expression-Defined Properties: Examples

Read More on Help Center
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CONSTANTS Functions in Expressions
CONSTANTS

Note: The required separator (comma or semi-colon) automatically corresponds to your 
computer’s location settings.
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CONSTANTS Functions in Expressions
Pi [PI]

Value

3.141592654
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CONSTANTS Functions in Expressions
True[TRUE] False[FALSE]

Returns TRUE or FALSE in a function where the argument requires True or False data.

Example

The Join Strings [TEXTJOIN] function has the option to ignore empty fields.

TEXTJOIN (“Delimiter”, IgnoreIfEmpty, “Text1”, “Text2”, ...)

In the following TEXTJOIN expression, we insert TRUE for the IgnoreIfEmpty argument, which is a True/False 

data type. 

Expression

TEXTJOIN (“, ”, TRUE, Renovation Status, Related Zone Name)

The expression will therefore ignore empty fields.

See Join Strings [TEXTJOIN] for an example.
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OPERATORS

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.
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Add [+]

Adds two arguments (operands).

Syntax

[+]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

Same as Arguments’ Data Type

Example

Return the sum of a Stair’s Riser Height and Going Depth.

Expression

Default Riser Height + Default Going Depth

Result

Adds the two length-type values to get a length-type result (e.g. 0.50)

Notes

See also Sum [SUM].
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Divide [/]

Divides two arguments (operands).

Syntax

[/]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle

Data Type of the Result

Depends on Arguments’ Data Types

Example

Calculate the glazed ratio of a zone by dividing its Windows Surface Area parameter by its Net Area.

Expression

Windows Surface Area/Net Area

Result

Divides two area-type values for a numerical result (e.g. .31)

Notes

Both Arguments are area-type values. This expression divides them and results in a number with no units (the 

ratio of the two areas).
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Equals [=]

Compares two arguments (operands). Returns True if their values are identical, False if they are not equal.

Syntax

[=]

Data Types of the Arguments

True/False, Integer, Number, Length, Area, Volume, Angle, or String (Must be identical for all operands)

Data Type of the Result

True/False

Example

Check whether a Zone is classified as Residential Space. 

The two arguments being compared (Classification and Residential Space) are both string-type data.

Expression

ARCHICAD Classification-24 = “Residential Space”

Result

True for Zones classified as “Residential Space”, otherwise False
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Greater Than [>]

Compares two arguments (operands). 

Returns True if the first value is greater than the second, otherwise False.

Syntax

[>]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

True/False

Expression

Identify whether the element’s Purchase Price (an existing Number-type property) is greater than 30.

Expression

Purchase Price > 30

Result

True for elements whose price is over 30, otherwise False
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Greater Than or Equal to [>=]

Compares two arguments (operands). Returns True if the first value is greater than or equal to the second, 

otherwise False.

Syntax

[>=]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

True/False

Example

Check whether the glazed ratio of zones (an existing property) complies with (is greater than or equal to) the 

mandatory glazed ratio (a fixed value, here .40).

Expression

Zone Glazed Ratio >= .40

Result

True for zones whose glazing rate is at least 40 percent, otherwise False
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Less Than [<]

Compares two arguments (operands). Returns True if the first value is less than the second, otherwise False.

Syntax

[<]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

True/False

Example

Identify whether the element’s Purchase Price (an existing Number-type property) is less than 30.

Expression

Purchase Price < 30

Result

True for elements whose price is less than 30, otherwise False
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OPERATORS Functions in Expressions
Less Than or Equal to [<=]

Compares two arguments (operands). Returns True if the first value is less than or equal to the second, 

otherwise True.

Syntax

[<=]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

True/False

Example

Identify whether a zone’s Subfloor Thickness (an existing Length-type property) is less than or equal to 20 cm.

Expression

Subfloor Thickness <= 20 cm

Result

True for Zones with Subfloor Thickness equal or less than 20 cm, otherwise False

Notes

Both arguments must have the same data type - here, they are both Length. 

The Length values must have a unit. Choose a Length unit from the Units pop-up of Expression Editor. 
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Multiply [*]

Multiplies two arguments (operands). 

Syntax

[*]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle

Data Type of the Result

Depends on Arguments’ Data Types

Example

Find the area of a given tile based on its fixed property values, with Length data types: Horizontal 

Dimension (20 cm) and Vertical Dimension (30 cm).

Expression

Tile Dimension H * Tile Dimension V

Result

600

Notes

In this example, the arguments are both lengths. Multiply them to get an area: set the resulting property’s 

Data Type to Area.
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Not Equal [<>]

Compares two arguments. Returns True if their values are not equal, otherwise False.

Syntax

[<>]

Data Types of the Arguments

True/False, Integer, Number, Length, Area, Volume, Angle, or String (Must be identical for all arguments)

Data Type of the Result

True/False

Example

Zone classifications include e.g. Office, Hallway, Meeting Room, and Smoking Area.

Smoke alarms are required in all zones except those classified as “Smoking Area”. 

For each Zone, determine if its Classification is not equal to “Smoking Area”.

In this expression, both arguments are strings.

Expression

ARCHICAD Classification 24 <> “Smoking Area”

Result

True for all Zones that are not Smoking Areas. (Smoke alarm required in all such zones.)
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Power [^]

Syntax

[^]

or use the Power [POWER] function.

Data Types of the Arguments

Base: Integer, Number, Length, Area, Volume, or Angle

Exponent: Integer or Number

Data Type of the Result

Depends on Arguments’ Data Type. (See Note, below).

Expression

5^2

Result

25

Note

If the Base argument’s data type is Length, then

• an Exponent of 2 will return a property whose Data Type must be Area.

• an Exponent  of 3 will return a property whose Data Type must be Volume.
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OPERATORS Functions in Expressions
Subtract [-]

Syntax

[-]

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

Same as Arguments’ Data Type

Example

Subtract a Length-type expression from another Length-type expression. 

The result is also a Length (its unit depends on Calculation Units for Length: here, meters).

Expression

Suspended Ceiling level - Raised Floor level

Result

2.2

Note

In this example, the arguments are both lengths. The resulting value is also a length.
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LOGICAL FUNCTIONS

And [AND]

Checks whether every item in a series of conditions (logical arguments) is true.

If all the arguments are true, then AND returns TRUE.

If any of the arguments is false, then AND returns FALSE.

Syntax

AND (Logical1, [Logical2],...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

True/False

Data Type of the Result

True/False

Example

Determine if both Beam length properties (Length Left and Length Right) exceed a given length. 

Expression

AND (Length Left > 480 cm, Length Right > 480 cm)

Result

True or False. True for all Beams where both Beam lengths exceed the value, otherwise False.

Note

The AND function examines a series of arguments. Within the parentheses, each item must be a logical 

argument that can be either true or false.
ARCHICAD 24 Reference Guide 1924



LOGICAL FUNCTIONS Functions in Expressions
Or [OR]

Checks whether at least one in a series of conditions (Logical arguments) is true.

If at least one of the arguments is true, then OR returns TRUE.

If none of the arguments is true, then OR returns FALSE.

Syntax

OR (Logical1, [Logical2],...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

True/False

Data Type of the Result

True/False

Example 1

Determine if either one of the Beam length properties (Length Left or Length Right) exceeds a given 

length. 

Expression

OR (Length Left > 480 cm, Length Right > 480 cm)

Result

True or False. True for all Beams where at least one Beam length exceeds the value, otherwise False.

Example 2

Determine if a Wall is fire resistant. To be fire-resistant, the wall must meet at least one of two possible 

conditions: its Building Material is “Reinforced Concrete - Structural”, and/or it is at least 50 cm thick. 

Expression

OR (Building Material = "Reinforced Concrete - Structural", Thickness >= 50 

cm)

Result

True or False. True for all Walls whose Building Material is Reinforced Concrete, and/or whose thickness 

is at least 50 cm. 

Note

The OR function examines a series of arguments. Within the parentheses, each item must be a logical 

argument that can be either true or false.
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Not [NOT]

Changes False result to True and vice versa.

Syntax

NOT (Logical)

Data Types of the Arguments

True/False

Data Type of the Result

True/False

Example

An existing property returns “True” for all elements whose Model property is undefined. To change these 

results to False, use NOT.

Expression

NOT (ISUNDEFINED (Model))

Result

False for every element whose Model property is <Undefined>
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If [IF]

Returns a specified value if the given logical argument is true.

and another specified value if the argument is false.

Syntax

IF (Logical, ValueIfTrue, ValueIfFalse)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Logical: True/False

ValueIfTrue, ValueIfFalse: Any Data Type, but Data Type must be identical for both Values

Data Type of the Result

Same Data type as the Values.

Example

Define the Beam Overhang standard depending on Beam length.

If the Beam is shorter than 480 cm, then the overhang should be 10 cm. 

If it is longer than 480 cm, then the overhang should be 12 cm.

Expression

IF (Length Left <=480cm, 10 cm, 12 cm)

Result

10 for the shorter beams, 12 for the longer beams

Note

To test multiple conditions, it may be easier to use the IFS function.

See If Multiple [IFS].
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If Multiple [IFS]

Use this function to test a series of logical conditions, then return the value for the first true condition.

IFS can take the place of multiple nested IF statements.

Syntax

IFS (Logical1, Value1, [Logical2, Value2]...)

You can define up to 127 logical conditions.

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Logical: True/False

Value: Any Data Type, but Data Type and units must be identical for all Values

Data Type of the Result

Same Data type as the Values.

Example 1

Provide the mandatory percentage of glazed area for each Zone depending on its Classification.

Expression

IFS (ARCHICAD Classification - 24 = "Residential Space","25%", ARCHICAD 

Classification - 24 = "Office Space", "30%”,

ARCHICAD Classification - 24 = "Storage Space", "10%")

Result

Returns the glazed-area percentage required for each Zone depending on its classification. The Values 

and the Results all have the same data type (here, String).

If None of the Conditions is True

If none of the conditions applies, the function returns “Undefined.” 

However, you can also specify a default result value, if none of the logical conditions is met: enter TRUE for 

your final logical condition, followed by the default value. 

Remember that this default result value must be the same data type as the other result values in the function. 

IFS (Logical1, Value1, [Logical2, Value2],...[TRUE,DefaultValue])

Example 2

Categorize Beams as Long (longer than 6 m) or Short (shorter than 2m). Any Beam that does not fall into 

those categories is Medium.

Expression

IFS (Length Left > 600 cm, "Long", Length Left < 200 cm, "Short", TRUE, 

"Medium" )

Result

Beams longer than 6 m: Long
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Beams shorter than 2 m: Short

Beams with lengths in between: Medium
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Exclusive Or [XOR]

Returns True if there is an uneven number of True logical arguments. 

In the case of two arguments: either one or the other is true, but not both.

Syntax

XOR (Logical1, [Logical2],...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

True/False

Data Type of the Result

True/False

Example

Office decor items of various sizes must be boxed up. Three box sizes are available. 

Items whose height and width are both more than 1m go in the large boxes.

AND (Width > 1m, Height > 1m)

Items whose height and width are both less than 1m go in the small boxes.

AND (Width < 1m, Height < 1m)

Items with either height or width is more than 1m go in the medium boxes.

Use a property to determine which items require the medium sized box.

Expression

XOR (Width > 1m, Height > 1m)

Result

True for all items whose width OR height (but not both) exceeds 1m.
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Undefined [ISUNDEFINED]

Checks whether the value of a given Property is Undefined.

Syntax

ISUNDEFINED (value)

Data Types of the Argument

True/False, Integer, Number, Length, Area, Volume, Angle, or String

Data Type of the Result

True/False

Example

Determine whether an element’s string-type “Model” property is undefined. ISUNDEFINED is a logical value.

Expression

ISUNDEFINED (Model)

Result

True for every element whose Model property is <Undefined>
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MATHEMATICAL FUNCTIONS

Absolute Value [ABS]

Absolute value.

Returns the absolute value of the number.

Syntax

ABS (Number)

Data Types of the Arguments

Integer, Number, Length, Area, Volume, Angle

Data Type of the Result

Same as Argument’s Data Type

Expression

ABS (-4)

Result

4
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e Exponent [EXP]

Exponential function of e.

Returns "e" raised to the power of the given number.

The base “e” is a constant - the base of the natural logarithm.

Syntax

EXP (Number)

Data Type of the Arguments

Number, Integer

Data Type of the Result

Number

Expression

EXP (2)

Result

7.39

Notes

The approximate value of e is 2.71828183.

EXP is the inverse of Natural Logarithm [LN] (the natural logarithm of number).

To calculate powers of other bases, use the operator ^.

See Power [^].
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Natural Logarithm [LN]

Returns the natural logarithm of the given number.

Syntax

LN (Number)

Data Types of the Argument

Number, Integer

Data Type of the Result

Number

Expression

LN (86)

Result

4.45

Notes

LN is the inverse of the e Exponent [EXP] function.

This function works on positive numbers only. 
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Base Logarithm [LOG]

Returns the base logarithm of the given number.

Syntax

LOG (Number, Base)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Number, Integer

Data Type of the Result

Number

Expression

LOG (8,2)

Result

3

Notes

This function works on positive numbers only. 
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Base 10 Logarithm [LOG10]

Returns the base 10 logarithm of the given number.

Syntax

LOG10 (Number)

Data Types of the Arguments

Number, Integer

Data Type of the Result

Number

Expression

LOG10 (10)

Result

1

Notes

This function works on positive numbers only. 
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Remainder [MOD]

Modulo operation. Finds the remainder after dividing the Number by the Divisor. 

Syntax

MOD (Number, Divisor)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Number, Integer

Data Type of the Result

Number

Expression

MOD (3,2)

Result

1

Notes

To return the quotient (without the remainder), use Quotient [QUOTIENT].

See also Divide [/].
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Nth Root [NTHROOT]

Calculates the degree-th root of the given argument.

Syntax

NTHROOT (Number, Degree)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Number: Number, Integer, or other data type compatible with root function

Degree: Number, Integer

Data Type of the Result

Depends on Arguments’ Data Types

Example

Find the cube root of the given number.

Expression

NTHROOT (125, 3)

Result

5

Notes

For square root: See Square Root [SQRT].
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Power [POWER]

Returns the given number raised to the given power.

Syntax

POWER (Base, Exponent)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Base: Integer, Number, Length, Area, Volume, Angle 

Exponent: Number, Integer

Data Type of the Result

Depends on Arguments’ Data Types

Expression

POWER (5,2)

Result

25

Notes

Works the same as Power [^] (Operator).
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Quotient [QUOTIENT]

Returns integer portion of a division.

Syntax

QUOTIENT (numerator, denominator)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for both arguments)

Data Type of the Result

Number

Example

Divide a slab’s Top Surface Area property with its Tile Area property. 

The Quotient function returns only the whole (integer) portion of the resulting number.

Expression

QUOTIENT (Top Surface Area, Tile Area)

Result

1974

Both properties are Area-type data. Dividing them returns a number. 

Notes

To return the remainder (without the quotient), use Remainder [MOD].

See also Divide [/].
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Sign [SIGN]

Returns +1, 0, or -1.

If the Number is positive, the result is +1.

If the Number is zero, the result is 0.

If the Number is negative, the result is -1.

Syntax

SIGN (Number)

Data Types of the Arguments

Integer, Number, Length, Area, Volume, Angle

Data Type of the Result

Number

Example

For a profile construction element with an editable Base Width offset parameter: 

Determine if its Base Width value is positive or negative.

Expression

SIGN (Base Width)

Result

-1 for a negative Base Width

1 for a positive Base Width

0 for a Base Width of zero.
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Square Root [SQRT]

Square root. 

Calculates the square root of the given argument.

Syntax

SQRT (Number)

Data Types of the Argument

Integer, Number, Area

Data Type of the Result

Depends on Argument’s Data Type

Expression

SQRT (16)

Result

4

Notes

To take other roots: See Nth Root [NTHROOT].
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Sum [SUM]

Calculates the sum of the given arguments.

Syntax

SUM (Number1, [Number2],...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, Angle (Must be identical for all Arguments)

Data Type of the Result

Depends on Arguments’ Data Type

Example

Add the results of two properties together.

Expression

SUM (Raised Floor Level, Sub Floor Thickness)

Result

.30

Both arguments are length-type data. The added result is also length-type.

Notes

See also Add [+].
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Round to Multiple [MROUND]

Rounds the given number to the desired multiple.

Syntax

MROUND (Number, Multiple)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, Angle (Must be identical for all Arguments)

Data Type of the Result

Depends on Arguments’ Data Type

Expression

MROUND (2567, 10)

Result

2670

Notes

If the remainder is greater than or equal to half of the multiple, then MROUND rounds up.

To always round up to a certain multiple, use Round Up to Multiple [MROUNDUP].

To always round down to a certain multiple, use Round Down to Multiple [MROUNDDOWN].

To round numbers to specific decimal places: use Round [ROUND], Round Up [ROUNDUP], Round 

Down [ROUNDDOWN]. 
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Round Down to Multiple [MROUNDDOWN]

Rounds the given number down to the desired multiple.

Syntax

MROUNDDOWN (Number, Multiple)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, Angle (Must be identical for all Arguments)

Data Type of the Result

Depends on Arguments’ Data Type

Example

The “Beam Length” property calculates the exact length of existing Beam elements in the model (e.g. 2,044). 

The “Prefab Beam Length” property is a fixed value (e.g. 300)

Create an expression to round the Beam Length down to the Prefab increment.

Expression

MROUNDDOWN (“Beam Length”, 300)

Result

1,800 (for a sample Beam Length of 2,044)

Notes

See also: Round to Multiple [MROUND], Round Up to Multiple [MROUNDUP].

To round numbers to specific decimal places: use Round [ROUND], Round Up [ROUNDUP], Round 

Down [ROUNDDOWN]. 
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Round Up to Multiple [MROUNDUP]

Rounds the given number up to the desired multiple.

Syntax

MROUNDUP (Number, Multiple)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, Angle (Must be identical for all Arguments)

Data Type of the Result

Depends on Arguments’ Data Type

Example

The “Beam Length” property calculates the exact length of existing Beam elements in the model (e.g. 2,044). 

The “Prefab Beam Length” property is a fixed value (e.g. 300)

Create an expression to round up the Beam Length to the Prefab increment.

Expression

MROUNDUP (“Beam Length”, 300)

Result

2,100 (for a sample Beam Length of 2,044)

Notes

See also: Round to Multiple [MROUND], Round Down to Multiple [MROUNDDOWN].

To round numbers to specific decimal places: use Round [ROUND], Round Up [ROUNDUP], Round 

Down [ROUNDDOWN]. 
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Round [ROUND]

Rounds a number to a specified number of digits.

Syntax

ROUND (Number, NumberOfDigits)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Number: Integer, Number

Number of Digits: Integer

If the Number of Digits argument is positive, rounding takes place to the specified number of decimal 

places. See Expression 1 below.

If the Number of Digits argument is zero, the number is rounded to the nearest integer. See Expression 2 

below.

If the Number of Digits argument is negative, rounding takes place only to the left of the decimal point 

(decimal values are disregarded). See Expression 3 below.

Data Type of the Result

Number

The number of decimal places displayed in the result depends on Preferences > Working Units.

Examples

Expression 1

ROUND (46.9855, 2)
Result

46.99
Expression 2

ROUND (46.9855, 0)
Result

47.00
Expression 3

ROUND (46.9855, -1)
Result

50.00

Notes

To always round up, use Round Up [ROUNDUP]. To always round down, use Round Down 

[ROUNDDOWN]. 

To round to a certain multiple, use Round to Multiple [MROUND] (or Round Up to Multiple 

[MROUNDUP] or Round Down to Multiple [MROUNDDOWN]).
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Round Down [ROUNDDOWN]

Rounds a number down to a specified number of digits.

If the Number of Digits argument is positive, rounding takes place downward to the specified number of 

decimal places. 

If the Number of Digits argument is zero, the number is rounded downward to the nearest integer.

If the Number of Digits argument is negative, rounding down takes place to the given number of places, to 

the left of the decimal point.

Syntax

ROUNDDOWN (Number, NumberOfDigits)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Number: Integer, Number

Number of Digits: Integer

Data Type of the Result

Number

Example

Expression 1

ROUNDDOWN (46.9855, 2)
Result

46.98
Expression 2

ROUNDDOWN (46.9855, 0)
Result

46.00
Expression 3

ROUNDDOWN (46.9855, -1)
Result

40.00

Notes

See also: Round [ROUND], Round Up [ROUNDUP]. 

To round to a certain multiple, use Round to Multiple [MROUND] (or Round Up to Multiple 

[MROUNDUP] or Round Down to Multiple [MROUNDDOWN]).
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Round Up [ROUNDUP]

Rounds a number up to a specified number of digits.

If the Number of Digits argument is positive, rounding takes place upward to the specified number of 

decimal places. 

If the Number of Digits argument is zero, the number is rounded up to the nearest integer.

If the Number of Digits argument is negative, rounding up takes place to the given number of places, to 

the left of the decimal point.

Syntax

ROUNDUP (Number, NumberOfDigits)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Number: Integer, Number

Number of Digits: Integer

Data Type of the Result

Number

Example

The “Number of Tiles” property divides a Slab’s top surface area by the area of a single tile. The result is 

371.35. 

Create another property which rounds up this result to a whole number.

Expression

ROUNDUP (Number of tiles, 0)

Result 

372 (where the Number of Tiles result is 371.35)

Notes

See also: Round [ROUND], Round Down [ROUNDDOWN]. 

To round to a certain multiple, use Round to Multiple [MROUND] (or Round Up to Multiple 

[MROUNDUP] or Round Down to Multiple [MROUNDDOWN]).
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TRIGONOMETRICAL FUNCTIONS

Arccosine [ACOS]

Returns the arccosine of a number.

Syntax

ACOS (Number)

Data Type of the Argument

Number, Integer. Must be between -1 and 1.

Data Type of the Result

Angle

Expression

ACOS (-0.5)

Result

120 deg

Notes

Angle unit of the result (e.g. degrees, radians, grad) depends on what you set in Project Preferences – 

Calculation Units and Rules – Angle Units.
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Arccotangent [ACOT]

Returns the arccotangent of a number.

Syntax

ACOT (Number)

Data Type of the Argument

Number, Integer

Data Type of the Result

Angle

Expression

ACOT (2)

Result

27 deg

Notes

Angle unit of the result (e.g. degrees, radians, grad) depends on what you set in Project Preferences – 

Calculation Units and Rules – Angle Units.
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Arcsine [ASIN]

Returns the arcsine of a number.

Syntax

ASIN (Number)

Data Type of the Argument

Number, Integer. Must be between -1 and 1.

Data Type of the Result

Angle

Expression

ASIN (-0.5)

Result

-30 deg

Notes

Angle unit of the result (e.g. degrees, radians) depends on what you set in Project Preferences - Angle Units.
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Arctangent [ATAN]

Returns the arctangent of a number.

Syntax

ATAN (Number)

Data Types of the Arguments

Number, Integer

Data Type of the Result

Angle

Expression

ATAN (1)

Result

45 deg

Notes

Angle unit of the result (e.g. degrees, radians) depends on what you set in Project Preferences - Angle Units.
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Cosine [COS]

Returns the cosine of an angle.

Syntax

COS (Angle)

Data Type of the Argument

Angle

Data Type of the Result

Number

Expression

COS (60 D)

Result

0.5

Notes

The argument’s angle value must be expressed as a unit (Degree, Radian, Grad). Choose an angle unit from 

the Units pop-up of Expression Editor. 
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Cotangent [COT]

Returns the cotangent of an angle

Syntax

COT (Angle)

Data Types of the Arguments

Angle

Data Type of the Result

Number

Expression

COT (30D)

Result

1.73

Notes

The argument’s angle value must be expressed as a unit (Degree, Radian, Grad). 

Choose an angle unit from the Units pop-up of Expression Editor. Here, it is Degree (D).
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Sine [SIN]

Returns the sine of an angle.

Syntax

SIN (Angle)

Data Type of the Argument

Angle

Data Type of the Result

Number

Expression

SIN (30D)

Result

0.50

Notes

The argument’s angle value must be expressed as a unit (Degree, Radian, Grad). 

Choose an angle unit from the Units pop-up of Expression Editor. Here, it is Degree (D).
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Tangent [TAN]

Returns the tangent of an angle.

Syntax

TAN (Angle)

Data Types of the Arguments

Angle

Data Type of the Result

Number

Expression

TAN (0.785 R)

Result

1.00

Notes

The argument’s angle value must be expressed as a unit (Degree, Radian, Grad). 

Choose an angle unit from the Units pop-up of Expression Editor. Here, it is Radian (R).
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STATISTICAL FUNCTIONS

Average [AVG]

Calculates the average of the given arguments.

Syntax

AVG (Number1, [Number2], ...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

Same as Arguments’ Data Type

Example

Columns are cut by a slanted Roof, so that each Column has both a maximum and a minimum height.

For any column, use AVG to find its average height. 

Expression

AVG (Maximum Height of the Column, Minimum Height of the Column)

Result

3.08 (for a given column with a maximum height of 3.11 and a minimum height of 3.04)

Note

Both arguments are Length type data, so the Property’s data type must also be set to Length. 
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Maximum [MAX]

Calculates the maximum of the given arguments.

Syntax

MAX (Number1, [Number2], ...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

Same as Arguments’ Data Type

Example

A Beam intersects with another Beam, and thus has different lengths on either side. 

Use MAX to return the longer of the two lengths. 

Expression

MAX (Length Left, Length Right)

Result

3.86 (for a given Beam with side lengths of 3.86 and 3.56)
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Minimum [MIN]

Calculates the minimum of the given arguments.

Syntax

MIN (Number1, [Number2], ...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Integer, Number, Length, Area, Volume, or Angle (Must be identical for all arguments)

Data Type of the Result

Same as Arguments’ Data Type

Example

A Beam intersects with another Beam, and thus has different lengths on either side. (3.86 and 3.56).

Use MIN to return the shorter of the two lengths. 

Expression

MIN (Length Left, Length Right)

Result

3.56 (for a given Beam with side lengths of 3.86 and 3.56)
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TEXT EDITING FUNCTIONS

Compare [COMPARE]

Compares two strings. 

Returns 0 if they are equal

Returns -1 if text1 precedes text2 in alphanumeric order

Returns +1 if text1 comes after text2 in alphanumeric order.

The alphabetical order is case sensitive: a comes before A.

Syntax

COMPARE (“text1”, “text2”)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

String

Data Type of the Result

Integer

Example

Suppose that an element’s FireRating property can have a value from A through F. 

If FireRating is A, B or C: it is standard-compliant.

If FireRating is D, E, or F: it is non-compliant.

In this expression, use COMPARE to compare the element’s FireRating category to “C”. 

In addition, use an IF function to return one of two strings based on the result of the COMPARE function. 

Expression

IF (COMPARE (FireRating, “C”) < 1, “Standard-compliant”, “Non-Compliant”)

If the result is 0, this means that FireRating equals C. This is standard-compliant.

If the result is -1, this means that FireRating comes before C alphabetically: it is either A or B. This is also 

standard-compliant.

If the result is 1, this means that FireRating comes after C alphabetically: it is either D, E or F. This is non-

compliant.

Result

“Standard-compliant” for values of 0 or -1, otherwise “Non-compliant”
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Merge Strings [CONCAT]

Joins two or more text strings into one.

Syntax

CONCAT (“text1”, [“text2”], ...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

String

Data Type of the Result

String

Example

Create a property called “Door Context ID”, consisting of a door’s Hotlink Master ID plus its Related Zone 

Number. (Both are String-type properties.) 

The two strings should be separated by a dash.

Expression

CONCAT (Hotlink Master ID,”-”, Related Zone Number)

Result

Room 213-6

Notes

Don’t forget that a Property can be applied to an element (including Hotlink elements) only if the Property 

is available to that element.

The Evaluate function (from Property Manager) does not work on Hotlink Elements. However, the 

expression involving Hotlink element properties is correctly evaluated in Interactive Schedule, in Element 

Settings, on the Element Information Palette, and any other interface, provided that the Property is valid 

and available.

CONCAT is similar to Join Strings [TEXTJOIN]. Use Join Strings [TEXTJOIN] if you want to 

specify an automatic delimiter between all text strings, and to ignore empty strings.

For another example using CONCAT, see Example 3: Expand Property with Descriptive Text String.
ARCHICAD 24 Reference Guide 1962



TEXT EDITING FUNCTIONS Functions in Expressions
Contains [CONTAINS]

Checks whether a specified string is contained within a text. 

Returns True if the string is present

Returns False if the string is not present

Case sensitive by default. (Otherwise, enter False for the CaseSensitive argument.)

Syntax

CONTAINS (“FindText”, “WithinText”, [CaseSensitive])

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

All Texts: String

Case sensitive (optional) True/False

Data Type of the Result

True/False

Example

Based on the text of a manufacturers catalog: Display the appropriate length unit (either cm or inches) for 

a chair’s Height value.

Here, the catalog text (a string) is a predefined property value called HeightInString. 

This string is transformed into a number (using STRTONUM).

It is then multiplied by the appropriate length unit (either cm or inches, depending on whether the string 

contains the “cm” tag: this is determined by the CONTAINS function). 

The result is a Length-type property.

Expression

STRTONUM (HeightInString) * IF (CONTAINS (“cm”, HeightInString), 1 cm, 1 

in)

Result

For a HeightInString property string value of “150 cm”, displays a length value of “150 cm”.
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Find String [FIND]

Returns the position of a text string (“FindText”) within another text string (“WithinText”).

Search starts at first character by default. (Otherwise, search starts at the character at Position.)

Search is case-sensitive by default. (Otherwise, enter False for the CaseSensitive argument.)

Syntax

FIND (“FindText”, “WithinText”, [Position], [CaseSensitive?])

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

All Texts: String

Starting Position (Optional): Integer

Case-sensitive? (Optional): True/False

Data Type of the Result

Integer

Example

Find the position of the dash character within the Element ID (e.g. “DOO - 007”).

Expression

FIND (“-”, Element ID)

Result

5 (for an Element ID of “DOO - 007”)
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String from Left [LEFT]

Returns a specified number of characters from the start of a text string.

Syntax

LEFT (“Text”, NumberOfCharacters)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text: String

Number of Characters: Integer

Data Type of the Result

String

Example

Starting at the left end of the given text string, return the first nine characters.

Expression

LEFT (“The quick brown fox”, 9)

Result

The quick
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Length of String [LEN]

Returns the number of characters (including spaces) in a string.

Syntax

LEN (“Text”)

Data Types of the Arguments

String

Data Type of the Result

Integer

Expression

LEN (“The quick brown fox”)

Result

19
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Lower Case [LOWER]

Converts all characters of a text string to lower case.

Syntax

LOWER (“Text”)

Data Types of the Arguments

String

Data Type of the Result

String

Expression

LOWER (“BRICK WALLS”)

Result

brick walls
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String from Position [MID]

Returns a specified number of characters starting from a specified position within a text string.

Syntax

MID (“Text”, Position, NumberOfCharacters)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text: String

Starting Position: Integer

Number of Characters: Integer

Data Type of the Result

String

Example

From the given text string, start at the 11th position and return the next five characters.

Expression

MID (“The quick brown fox”, 11, 5)

Result

brown
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Replace in String [REPLACE]

Replaces a given number of characters within a string with another string, starting from a specified position.

Syntax

REPLACE (“OldText”, Position, NumberOfCharacters, “NewText”)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Old and new text: String

Starting Position: Integer

Number of Characters: Integer

Data Type of the Result

String

Example

In the string “2017”, start at position 3, and replace two characters with “18”

Expression

REPLACE (“2017”, 3, 2, “18”)

Result

2018

Notes

Use Substitute Strings [SUBSTITUTE] to replace one string with another, in all instances or a 

particular instance.

Use REPLACE to change a particular string to another string, with a given starting position.
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Repeat String [REPT]

Repeats a string a specified number of times.

Syntax

REPT (“Text”, NumberOfTimes)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text: String

Number of times: Integer

Data Type of the Result

String

Example

Display an asterisk and a dash 3 times.

Expression

REPT (“*-”, 3)

Result

*-*-*-
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String from Right [RIGHT]

Returns a specified number of characters (including spaces) from the end of a text string.

Syntax

RIGHT (“Text”, NumberOfCharacters)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text: String

Number of Characters: Integer

Data Type of the Result

String

Example

Return the final nine characters from the (right) end of a text string.

Expression

RIGHT (“The quick brown fox”, 9)

Result

brown fox
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Split String [SPLIT]

Splits a string into parts at a given delimiter and returns the specified part.

Syntax

SPLIT(“Text”, “Delimiter”, PartIndex)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text and Delimiter: String

Part Index: Integer

Data Type of the Result

String

Example

A Wall’s “Brick dimensions” Property is a string: “92mm x 57 mm x 194 mm”.

Use SPLIT to get just the second item (the width) from this string: split the string at the “x” delimiters and 

return the second part. 

Expression

SPLIT (Brick Dimensions, “x”, 2)

Result

57 mm
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Split String to Left [SPLITLEFT]

Splits a string into parts at a given delimiter.

Returns the specified part and all parts to its left.

Syntax

SPLITLEFT (“Text”, “Delimiter”, PartIndex)
Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text and Delimiter: String

Part Index: Integer

Data Type of the Result

String

Example

Given an ARCHICAD Element ID, such as TREAD-018 (a string-type data): 

Get the part of the string that is on the left of the delimiter.

The delimiter, which separates the Element ID into parts, is a dash. 

The part number (index) you want is 1 (the first part).

Expression

SPLITLEFT (Element ID, “-”, 1)

Result

TREAD (for an Element ID of “TREAD-018”)
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Split String to Right [SPLITRIGHT]

Splits a string into parts at a given delimiter.

Returns the specified part and all parts to its right.

Syntax

SPLITRIGHT (“Text”, “Delimiter”, PartIndex)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Text and Delimiter: String

Part Index: Integer

Data Type of the Result

String

Example

Given an ARCHICAD Element ID, such as TREAD-018: 

Get the numerical part of the ID.

The delimiter, which separates the Element ID into parts, is a dash. 

The part number (index) is 2 (the second part).

Expression

SPLITRIGHT (Element ID, “-”, 2)

Result

018 (for an Element ID of “TREAD-018”)
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Substitute Strings [SUBSTITUTE]

Replaces a string with another string, in the specified instance (or all instances).

Syntax

SUBSTITUTE (“Text”, “OldText”, “NewText”, [InstanceIndex])

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

All Texts: String

InstanceIndex (Optional): Integer

If InstanceIndex value is omitted, then all instances of the OldText are replaced.

Data Type of the Result

String

Example

A Wall’s “Brick dimensions” Property is a string: “92mm x 57 mm x 194 mm”. 

Use SUBSTITUTE to extract just the numbers from this string (e.g. for use in another expression). 

(For the OldText “mm” strings, substitute a NewText of nothing.) 

Expression

SUBSTITUTE (Brick Dimensions, “mm”, “”)

The InstanceIndex is not provided. Thus, all instances of the OldText will be substituted.

Result

92 x 57 x 194

Notes

Use SUBSTITUTE to replace one string with another, in all instances or a particular instance.

Use Replace in String [REPLACE] to change a particular string to another string, with a given starting 

position.
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Join Strings [TEXTJOIN]

Joins two or more text strings into one string, separated by a given delimiter.

If IgnoreIfEmpty is True, the result will ignore empty strings.

Syntax

TEXTJOIN (“Delimiter”, IgnoreIfEmpty, “Text1”, “Text2”, ...)

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Delimiter and Text: String

Ignore if Empty: True/False

Data Type of the Result

String

Example

For each element, list its ID plus Zone Name plus Renovation Status.

The Delimiter consists of a comma and a space.

Expression

TEXTJOIN (“, ”, TRUE, Element ID, Related Zone Name, Renovation Status)

Result

SW-002, Kitchen, To Be Demolished

Notes

TEXTJOIN is similar to Merge Strings [CONCAT]. 

Compared to CONCAT, TEXTJOIN has the following additional features:

- add a specific delimiter character between each string automatically

- option to ignore empty strings
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Trim [TRIM]

Removes duplicate spaces, and the spaces from the start and end of a text string.

Syntax

TRIM (“Text”)

Data Types of the Arguments

String

Data Type of the Result

String

Example

The text string has unneeded spaces at the beginning and the end, and multiple extra spaces between each 

word.

Use TRIM to remove these unneeded spaces.

Expression

TRIM (“ Q4  2017  Earnings  Report ”)

Result

Q4 2017 Earnings Report
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Upper Case [UPPER]

Converts all characters of a text string to upper case.

Syntax

UPPER (“Text”)

Data Types of the Arguments

String

Data Type of the Result

String

Expression

UPPER (“client address”)

Result

CLIENT ADDRESS
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DATA CONVERSION

Convert to String [STR]

Converts a non-unit numeric value or a True/False value into a string. 

The resulting string shows two decimal places by default. 

Syntax

STR (Value, [NumberOfDecimals])

Note: The required separator (comma or semi-colon) automatically corresponds to your computer’s 

location settings.

Data Types of the Arguments

Value: Integer, Number, True/False

Number of Decimals (optional): Integer

Data Type of the Result

String

Example

Convert the Home Story Number element property (a number-type value) to a string. 

Make sure the result is a whole number showing zero decimal places.

Expression

STR (Home Story Number, 0)

Result

2 (for a Beam with Home Story of 2)

Notes

The result string is displayed with two decimal places by default. If you do not want any decimals (as in the 

Home Story Number example), add 0 as the Number of Decimals argument.

To convert a unit value (e.g. a Length) to a string, use the Convert Unit to String 

[STRCALCUNIT] function.

For another example using STR, see Example 10: List the Total Cost of a Structure in Dollars.
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Convert Unit to String [STRCALCUNIT]

Converts a unit value to a string, based on the Calculation Units and Rules settings in Project Preferences.

Syntax

STRCALCUNIT (value)

Data Types of the Arguments

Length, Area, Volume, Angle

Data Type of the Result

String

Example

Convert the Insulation Skin Thickness (a Length) into a String

Expression

STRCALCUNIT (Insulation Skin Thickness)

Result

25

Notes

To convert a non-unit value (e.g. Home Story Number) to a string, use the Convert to String [STR] 

function.

For another example using STRCALCUNIT, see Example 3: Expand Property with Descriptive Text String.
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Number from String [STRTONUM]

Extracts numerical character(s) from the initial position in a string.

(Only numerical characters at the beginning of the string are considered. Numerical characters within the 

string are not found.)

Syntax

STRTONUM ("Text")

Data Types of the Arguments

String

Data Type of the Result

Number

Example

Extract the number which is the first character of the element’s ARCHICAD IFC ID (a string-type parameter). 

(e.g. “3MtfJD8lf96mvn65fX2qo”)

Expression

STRTONUM (ARCHICAD IFC ID)

Result

3 (for an element whose ID is “3MtfJD8lf96mvn65fX2qo”)
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Documentation

This section of the ARCHICAD Reference Guide describes each of the ARCHICAD tools used in project 

documentation, e.g. Labels, Dimensions, texts. It describes the Layout Book workflow and how to create and 

update drawings on layouts, and how to publish them in various formats. The optional Revision workflow is 

also described here - it helps you keep track of changes and Transmittal Sets automatically. Finally, the 

Calculation feature is introduced for those who prefer this listing method to the Interactive Element Schedule.

Fills

Drafting

Annotation

Drawings in Model Views

The Layout Book

Drawings in the Layout Book

Revision Management

Publishing

Element Information

ID Management

Calculation (Legacy)
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Fills

Fills are geometric 2D hatching patterns that help you distinguish and decorate the elements of your project

As vectorial hatching, fills can also be used to embellish surfaces in the 3D Window and in 3D Documents.

ARCHICAD includes a predefined set of default fills.

Access Fills from the Options > Element Attributes > Fills, where you can define, edit, duplicate, rename or 

delete them.

Related Topics:

Full Set of Project Fills

Defining Fill Availability in Pop-Ups

Fill Categories

Assign a Cut Fill

Assign a Cover Fill

Draw a Drafting Fill

Create New Solid Fill

Add Area Text to a Fill

Fill Display Mode: Vectorial vs. Bitmap

Edit Vectorial Fill Pattern

Display of Vectorial Fill

Set Orientation of Vectorial or Symbol Fill Patterns
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Create Symbol Fill

Using Gradient Fills

Create or Edit Image Fill

Delete and Replace Attributes in a Model
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Full Set of Project Fills

The full set of fills used in the current ARCHICAD project is available in the Fills  Dialog Box (Options > 

Element Attributes > Fills).
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Fills in the pop-up are grouped according to type: Solid, Vectorial, Symbol, Gradient and Image.

You can modify this set manually or by importing items with the Attribute Manager.

Not all of the project’s fills are available in every fill pop-up.

For more information, see Defining Fill Availability in Pop-Ups.
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Defining Fill Availability in Pop-Ups

To avoid dealing with so many fills at a time, the Fill chooser pop-ups, located in dialog boxes throughout the 

ARCHICAD interface, do not contain the full set of all project fills - only those fills which belong to a Fill 

Category that makes sense in that context.

For example:

• A Fill Type must be set to “Cover Fill” if you want it to be available as a Cover Fill choice in (for example) 

Slab or Roof settings.

• Only fills defined as “Cut Fills” are available for use in Building Materials.

Edit Category of Fill Type Attribute

1. Open the Options > Element Attributes > Fills dialog box and view the Fill Availability and Screen-Only 

Pattern panel.

2. Select the Fill to edit.

3. Activate one or more of the Use with icons to define its Fill Category.

• Drafting Fills: Drafting fills are not applied to construction elements; they are drawn by hand using the Fill 

tool.

Note: If this box is not checked, the current fill type will not be available in the Fill Settings dialog box.

• Cover Fills: Check this box to include the current fill type in Beam, Column, Slab, Roof, Shell, Mesh, 

Zone, Opening, and Object settings dialogs and on the 3D hatching panel in Surfaces dialog.

• Cut Fills: Check this box to include the current fill type in the settings dialogs of GDL elements (which use 

cut fills), or in the Building Materials Dialog box.

Note: There are some restrictions. For example, Image Fills cannot be used as cut fills.

Related Topics

Fill Categories

Change Category of 2D Fill Element

Use Fill Categories to Control Fill Display with Graphic Overrides

Use Fill Categories to Optimize Export to DXF/DWG
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Fill Categories

Fill Categories are used to group fills according to their function in the project: Cut Fill (two types), Cover Fill, 

Drafting Fill.

1. Cut Fills (two variations):

• For construction elements (Wall/Slab/Beam/Column/Roof/Shell/Morph/Mesh/Opening): Cut fills are 

assigned via the Building Material attribute. When such an element is exploded (e.g. in a Detail Drawing), 

the resulting fill will be in the Cut Fill - Building Material category. A detail Fill in this category retains the 

Physical properties of the original construction element.

Assign this Fill category to fills in details used for the Thermal Bridge analysis in the EcoDesigner STAR 

add-on product. 

• For GDL-based elements (Objects, Curtain Walls), or for a freehand Fill drawn using the Fill Tool, Cut Fills 

are assigned in their Fill Settings dialog boxes. When such an element is exploded, the resulting fill will be 

in the Cut Fill category (without any associated physical properties).

Cut fills can be optionally placed onto their own layer during DXF/DWG conversion functions.

2. Cover Fills: Cover fills can be used to display Beam, Column, Slabs, Roofs, Meshes, Shells, Openings, 

Morphs and Zones on the Floor Plan: use the Cover Fills controls in the element’s Settings dialog box. 

When such an element is exploded (e.g. in a Detail Drawing), the resulting fill will be in the Cover Fill 

category.

Cover fills can be optionally placed onto their own layer during DXF/DWG conversion functions.

See Assign a Cover Fill.

3. Drafting Fills: Drafting fills, like the other categories, can be assigned to display elements, or are simple 

2D Fills drawn by hand in any model window. However, you may wish to assign such a fill to the “cover fill” 

or “cut fill” category, for display or export purposes. (See below.)

Change Category of 2D Fill Element

1. Select the Fill element in the project.

2. Go to the Fill Tool Info Box (or Fill Tool Settings.)

3. Change its Fill Category.

For example, if you draw a fill as a detail patch, to be used as a cut fill, change its category from “Drafting” to 

“Cut Fill - Building Material”. This way, this fill will behave like the Building Materials of construction elements 

in the project, if you choose to export them to a DWG layer.
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Change Category of Fill Attribute

Each fill in the Fills dialog box has one or more assigned Fill Categories; this will filter the fills available in the 

fill pop-ups available throughout the interface. 

See Defining Fill Availability in Pop-Ups.

Use Fill Categories to Control Fill Display with Graphic Overrides

By default, each fill in the project will be displayed the way you define it in element settings or Fill Settings.

However, you can use Graphic Overrides to override these settings-level definitions with rule-based overrides, 

which can apply fill overrides by category.

Use Document > Graphic Overrides > Graphic Override Rules.

See Graphic Overrides.
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Use Fill Categories to Optimize Export to DXF/DWG

This can be useful when exporting the ARCHICAD project to DXF/DWG format: during the export process, 

you can define Custom Layers for the exported fills based on fill category.

See Custom Layers.

For example, you might have drawn 2D Fills over a Wall/Slab intersection in Section/Elevation. You probably 

want these fills to go to the same layers in the resulting DWG/DXF file as the fills generated from the model. 

So the newly drawn 2D Fill (a Drafting Fill by default) should be placed in the Cut Fill - Building Material 

category, just like the fills generated from the section of the Wall and Slab.
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Assign a Cut Fill

• For construction elements (Wall / Slab/ Beam/ Column / Roof / Shell / Morph / Mesh): Cut fills are 

assigned via the Building Material attribute. The construction element will use the cut fill defined for the 

assigned Building Material.

See Building Materials.

• For GDL-based elements (Objects, Curtain Walls), or for a freehand Fill drawn using the Fill Tool, Cut Fills 

are assigned in their Settings dialog boxes.

To define a default cut fill for a GDL-based element, such as an Object:

1. Activate the Object tool; or select the placed Object.

2. Go to the Floor Plan and Section panel of its Settings (or click Floor Plan and Section button in the Info 

Box.)
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3. For the listed Cut Fill parameter, click the fill name or icon to access the list of available fills, and choose 

one.

Note: Only those Fills defined as Cut Fills in Options > Element Attributes > Fills are available here.
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Assign a Cover Fill

In ARCHICAD, cover fills can be applied to Beams, Columns, Slabs, Meshes, Roofs, Shells, Openings, 

Morphs and Zones.

For all of these element types except Zones:

1. Go to the Floor Plan and Section panel of its Settings (or click Floor Plan and Section button in the Info 

Box.)

2. Check the Cover Fills box.

3. Click the Cover Fill parameter pop-up to access the list of available fills, and choose the desired fill.

Note: Only those Fills defined as Cover Fills in Options > Element Attributes > Fills are available here.

– Use Fill from Surface: Check this to use the surface of the element’s Building Material instead.

4. Using the cover fill controls that follow:

– Choose Pen and Background attributes for the Cover Fill.

– Use the Cover Fill Orientation parameter to define the orientation of the fill pattern.

See Set Orientation of Vectorial or Symbol Fill Patterns.

For Zones:

1. Activate the “Cover Fill” button in Zone Settings (Floor Plan panel) by clicking it.

2. Click the fill name or icon to access the list of available fills, and choose the desired fill from the pop-up 

list.

3. Choose a radio button to define the orientation of the fill pattern.
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4. If the Zone’s Building Material uses a surface that has a vectorial hatching, you have the option to display 

that instead: check Use Fill from Surface.

See Set Orientation of Vectorial or Symbol Fill Patterns.
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Draw a Drafting Fill

To draw a Drafting fill, first activate the Fill tool in the Toolbox and choose one of the three Geometry 

Methods from the Info Box.

Drawing Fills with either the Polygon, the Rectangle or the Rotated Rectangle method is similar to the process 

for drawing walls.

For an illustration of this process, see Create a Chain of Walls and Create a Rectangle of Walls.

Drafting fills, like the other categories, can be assigned to display elements, or are simple 2D Fills drawn by 

hand in any model window. 

However, you may wish to assign such a fill to the “cover fill” or “cut fill” category, for display or export 

purposes.

For more information, see Fill Categories.
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Add Area Text to a Fill

Enable the Show Area Text checkbox in the General Settings panel of Fill Settings. When you create the Fill, 

the Hammer cursor will appear, prompting you to position the area text with a click.

The text block is created by calculating the area of the Fill. The text settings will be the same as the default 

values set in Dimension Text Settings. This text will always be displayed horizontally on screen, even if the fill 

is rotated or mirrored, or the view itself is rotated.

See Set Orientation.

Note: If the fill contains holes, they are subtracted from the fill area.

To modify the font settings or even the content of the area text, select the text only (not the Fill itself) and edit 

the Dimension Text Settings (in this case, the last command of the Edit menu changes to Dimension Text 

Settings). The style of the Fill Text, if displayed, is stored as part of the Fill’s Favorite settings.

See also Dimension Text Settings.

Note: Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill 

Text.

The measurement unit and accuracy of the area value are defined in Dimensions (Options > Project 

Preferences > Dimensions).

Fill Area text will always be displayed horizontally on screen, regardless of the view’s orientation.
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Fill Display Mode: Vectorial vs. Bitmap

Each fill type has two faces or display modes: vectorial and bitmap.

By default, all fills in your project are set to be displayed as Vectorial Hatching, at View > On-Screen View 

Options.

If you turn this control off, fills will be displayed on screen in bitmap mode. However, when printing or plotting 

fills, the vectorial face will be used even if the on-screen display is set to bitmap.

The bitmap versions of all predefined fill patterns approximate their vectorial equivalents. If you change a 

vectorial pattern or generate a new symbol type pattern, you will need to create its bitmap version manually.

Screen-Only Fill Pattern

Use the Availability and Screen Only Panel of the Fills  dialog box to view or edit the Fill’s bitmap pattern.

This pattern is used:

• to identify the fill in the fill pop-up menus

• for on-screen fill display if you disable the “Vectorial Hatching” on-screen view option (View > On-Screen 

View Options).

To edit this screen-only pattern, click with the arrow cursor in the pattern window to turn pixels on or off.
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Edit Vectorial Fill Pattern

This panel appears in the Fills  Dialog Box (Options > Element Attributes > Fills) if you are editing a 

vectorial fill.

To change the vectorial pattern, select the fill you want to modify in the pop-up list at the top of the dialog box.

Edit its properties in the Edit Vectorial Pattern panel using the controls described below:

Show Pattern Unit: Check this box to place a highlight over the symbol unit in the preview window.

Scale window: Enter view scale in percent in this box to control the view in the vectorial hatching area.

To determine the relationship between fills and project scale, use the two radio buttons.

See also Scale of Fills.

Zoom Out: Click this button to Zoom Out the view in the vectorial hatching area

Zoom In: Click this button to Zoom In the view in the vectorial hatching area.

Spacing: Enter values in this section for spacing the vectorial hatching pattern horizontally and vertically.

Angle: Enter a value here to rotate the vectorial hatch shown in the Sample Window.

Click OK when you are finished. All elements using this fill pattern will now display the modified one.
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Scale of Fills

To determine the relationship between fills and project scale, use the two radio buttons:

• Scale with plan (Model size): Use this option to ensure that the current Fill type will be displayed at the 

same scale as the model on every output.

Scale with Plan

Note: Avoid editing a scaled fill type if the project scale is different than that of the fill type, as it will be 

distorted.

• Scale-independent (Paper size): Use this option to display, plot and print the current Fill type definition at 

a fixed size, regardless of output scale.

Scale Independent
ARCHICAD 24 Reference Guide 1999



Fills Documentation
Display of Vectorial Fill

Vectorial Fills use a hatching pattern, and can be used to represent the cut surfaces or top covers (cover fills) 

of construction elements. You can also assign Vectorial Fills to Surfaces, which are displayed in the 3D 

window.

On the Floor Plan

Elements will display the hatching of a vectorial fill on the Floor Plan only if you have activated View > On-

Screen View Options > Vectorial Hatching. (Otherwise, the on-screen display will show the fill’s bitmap 

face.)

In the 3D Window

Construction elements in the 3D Window are displayed using the Surfaces assigned to them via their Building 

Material. These Surfaces can be overridden at the element level, using the Model panel of the element’s 

Settings.

If these Surfaces include a Vectorial Hatching, it will be visible in the 3D Window only if you switch Vectorial 3D 

Hatching “On” in 3D Styles, and only if you are using the vectorial 3D Engine.

See also Surface Vectorial Hatching Panel (Basic Engine).
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In the Section/Elevation/IE and 3D Document Windows

Section/Elevation/IE and 3D Document windows will display vectorial hatching only if you have checked the 

Vectorial 3D hatching box in the Model Display panel of the Settings dialog box.

For more information, see Model Display Panel and 3D Document Model Display Panel.

Vectorial hatching settings have no effect in rendered views.

Related Topics:

Fill Display Mode: Vectorial vs. Bitmap

Set Orientation of Vectorial or Symbol Fill Patterns
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Set Orientation of Vectorial or Symbol Fill Patterns

Use the Orientation Method controls to manually define or change the orientation of a vectorial or symbol fill 

pattern.

Where to Choose a Fill Orientation Method for an Element

• For Fill elements that use a vectorial or symbolic cover fill, use the “Construction Method” options in the 

General Settings panel of Fill Settings.

• For Zones that use a vectorial or symbolic cover fill, use the radio buttons in the Floor Plan panel of Zone 

Settings.

• For Cover Fills assigned to a Beam, Column, Mesh, Slab, Roof, Opening, Morph or Shell, use the 

controls under Cover Fill in the Settings dialog box.

See also Assign a Cover Fill.
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• For cut fills used in components of complex or composite elements, Fill Orientation settings derive from 

their Building Material.

Fill Orientation Methods

Link to Project Origin

Link to Fill Origin

Place Fill Element with Linked Pattern

3D Distortion

Custom Distortion

Distorted Fill for Roofs

Symbol Fills as Skins of Composite Elements: Fit to Skin

Radial Distortion (Symbol Fills only)

Link to Project Origin

With this option, hatching orientation is always orthogonal from the Project Origin, independently of the 

transformations made on the element.

Link to Fill Origin

Use the Link to Fill Origin to fine-tune the angle of the fill pattern. 

A single handle appears on the placed fill to show the orientation of the fill.

Note: Fill handles are visible only if you enable Fill Handles (Drafting and Editing Aids) in View > On-

Screen View Options.
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Now drag the Fill Handle to realign the fill pattern as needed. Make sure the Move Sub-Element icon is active 

on the pet palette.
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Place Fill Element with Linked Pattern

When placing a Fill element:

1. First set the Link to Fill Origin option in Fill Settings.

2. Draw the fill polygon.

The cursor changes to the shape of a fill handle arrow:

3. Click twice to define the origin and direction of the fill pattern. 

Note that the handle does not necessarily have to be located inside the Fill. You can drag the handle out 

of the body of the fill after placing it.
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3D Distortion

Available for Beam, Column, Shell and Morph.

This option distorts the cover fill, simulating the 3D view of a curved surface on the Floor Plan.

Custom Distortion

This option displays a double fill handle at the fill origin.

Manipulate the hatching pattern by modifying the length of either handle and the angle closed by the two 

handles. 
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Distorted Fill for Roofs

Set the Roof’s cover fill Orientation to Link to Roof Pitch with Distortion.

The cover fill is automatically distorted to follow the Roof pitch. 

Symbol Fills as Skins of Composite Elements: Fit to Skin

If a composite element includes a symbol fill as part of the Building Material, you can adjust that fill to “fit to 

skin”, so that the fill pattern is adjusted to the shape of the skin. This is especially useful when modeling soft 

insulation, plywood, metal decking or any directional fill.

To do this, use the controls in the Building Materials dialog box (Options > Element Attributes > Building 

Materials.)

1. Go to the Fill Orientation control in the dialog box.

2. Choose Fit to Skin.

The symbol fill pattern is now adjusted to fit the contour of the element.
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Radial Distortion (Symbol Fills only)

The Radial Distortion Fill construction method (Fill Tool) lets you graphically adjust the vector’s radial 

distortion. This is available only for a selected symbol fill and only if:

• the symbol fill was used as a skin of a composite or complex structure; and

• the skin’s Fill Orientation was defined as Fit to Skin in its Building Material; and

• you have selected this symbol fill after exploding a curved composite/complex wall.

See Explode into Current View.

Note: The use of many radial distorted fills in your project may decrease project performance.

Here is a curved composite wall with a symbol fill (orientation: Fit to Skin) as one of the skins, after the 

composite wall has been exploded. Each fill can now be selected separately. The symbol fill displays a fill 

handle and the Distorted Radial Fill construction method is available. Adjust the fill handle to adjust the fill’s 

distortion or the pattern’s origin as needed.
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Create New Solid Fill

Solid Fills include

• the Foreground Fill: You see only the Foreground, because it covers up the Background.

• the Background Fill: You see only the Background, because the Foreground is set to zero.

• Three fills whose foregrounds are of predefined Opacity (25%, 50%, 75%).

These percentages can be adjusted by hand in Options > Element Attributes > Fills, by entering a new 

percentage value in the Opacity field.

In the Fills Dialog Box (Options > Attributes > Fills), click New, and choose Solid fill from the New Fill dialog 

box.

In the Fill Appearance panel, enter an Opacity percentage (or use the slider) - in this case, 65. The new Fill 

Type will henceforth appear in the fill pop-up.

You can create a new solid fill type with any translucence value you wish.

View the result in the Preview window.
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Create Symbol Fill

Create a symbol fill based on a sketch drawn in any 2D window, with the following steps:

1. Draw a pattern using Lines, Arcs and Hotspots.

 

2. Select all the components of the pattern and choose Edit > Copy.

3. Go to Options > Element Attributes > Fills.

4. Click the New button.

5. Enter a name for the new fill.

6. Choose the Symbol fill radio button, then click OK.

7. In the Edit Symbol Pattern panel, click Paste.

Note: The pasted selection can include only Lines, Arcs and Hotspots.

8. The pattern appears in the Preview window. 

9. Check Show Pattern Unit to highlight a single unit of the pattern in the preview window of this dialog box.
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10. Use the controls under Edit Symbol Pattern to set the size, pattern and rotation angle for the symbol fill.

Strokes: Use these four fields to set the vectors of rows which compose the symbol pattern.

First note the Motif size of the symbol unit (shown at the bottom of this panel.) This is the absolute size of the 

Symbol unit on the Floor Plan.

• X1 and Y1: These values determine the horizontal (X1) and vertical (Y1) distance between the symbol 

units for the first vector of the pattern. For example, if the Motif size is 1000 mm, then an X1 value of 1500 

for the vector pattern means that the symbol units are placed alongside each other with a 500 mm gap.

• X2 and Y2: These values determine the horizontal (X2) and vertical (Y2) distance between the symbol 

units for the second vector of the pattern. For example, if the Motif size is 1000 mm, then an X2 value of 

750 means that the next row of symbol units is staggered back by 750 millimeters compared to the first 

horizontal vector (at 1500 millimeters).

Angle: Enter an angle in degrees if you wish to skew the fill pattern.

Scale: Enter scale factors by which to “stretch” the Symbol unit both horizontally and vertically. (By default, 

this factor is 1.0, that is, the symbol unit is not stretched.)

The percentage field and the zoom buttons below the preview window refer to the image in the preview 

window only. The preview displays the symbol pattern at the given percentage as compared to its appearance 

on the Floor Plan.

To determine the relationship between fills and project scale, use the two radio buttons.

See also Scale of Fills.

Edit Symbol Fill

1. In the Fills dialog box, select the symbol to be edited.

2. Click Copy button.

By pasting the symbol fill back into the window, it becomes editable once more.
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Symbol fills used in composite elements have particular orientation options so you can fine-tune their 

appearance:

Symbol Fills as Skins of Composite Elements: Fit to Skin

Radial Distortion (Symbol Fills only)
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Using Gradient Fills

Gradient Fills are Drafting fills only, and thus are available only from the Fill Tool’s pop-up. (Drafting fills are 

drawn by hand, using the Fill Tool.)

The purpose of Gradient Fills is to enhance architectural graphics; they do not indicate any physical 

properties, and so they are available for 2D fills created with the Fill tool (Drafting fills) only. Gradient Fills 

cannot be applied to construction elements (i.e. they are not available as Cut Fills or Cover Fills).

To get a linear gradient fill, choose two different pen colors (foreground and background) on the General 

Settings panel of Fill Settings.

When placing the Fill, you will see that the pattern is a mix of the two colors with a transition area between 

them.

The location, angle and the size of the transition area can be modified with the fill handle provided that you 

enable Fill Handles (Drafting and Editing Aids) in View > On-Screen View Options.

 

The other type of the gradient fill is radial, that is, of basically circular shape. In this case, the two pen colors 

(foreground and background) define respectively the inner (next to the core) and outer colors of the gradient 

fill.
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With the fill handle, you can modify the origin of the gradient fill and the extent of both colors as well as that of 

the transition area.

Note: When moving the fill handle, make sure you select the Move Sub-element icon on the pet palette.
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Create or Edit Image Fill

Image Fills can be used as the foreground part of Drafting fills or Cover fills.

Your ARCHICAD default template provides predefined Image fills, but you can define your own.

Create New Image Fill

1. Go to Options > Element Attributes > Fills. 

2. Click New.

3. In the Add New Fill dialog box, choose Image fill.

4. The Fills dialog box appears. In the Availability and Screen only Pattern Panel, define the new Image fill 

as a Drafting and/or Cover fill.

5. In the Fill Texture Panel, click Browse to bring up a library directory dialog box. Browse for the desired 

image and click OK to load it.
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6. In the Sample field, set the number of texture units displayed in the Preview.

7. Use the Image Size controls to fine-tune the size and pattern of your Image fill.

Keep Original Proportion: Check this box if you want to link the Horizontal and Vertical Size values so 

that the image is not distorted when editing its size.

Angle: Enter an angle if you want to rotate the image pattern from the horizontal.
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8. Choose a Mirroring Method to set up the repeating patterns within your Image fill: choose to mirror the 

pattern vertically, horizontally, both, or none.

To determine the relationship between fills and project scale, use the two radio buttons.

See also Scale of Fills.

9. Click OK to save the newly created fill as a project attribute.
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Drafting

Drafting Elements are strictly two-dimensional: they include Lines, Hotspots, Figures and Drawings. With the 

exception of Drawings, they do not appear in list views.

Drafting elements have various uses:

• Details that you did not wish to model fully with construction tools.

• Positioning and drawing aids for the placement of construction elements.

• Their outlines can be used to generate complex 3D shapes using the Magic Wand tool.

• Decoration purposes or elaborating on details, especially in the Section/Elevation/IE and 3D Document 

windows or on Details and Worksheets.

The Floor Plan and Section/Elevation/Interior Elevation and 3D Document display of drafting elements 

depends on the attribute choices made for them in their respective Tool Settings dialog boxes. Attribute sets 

for Drafting Elements (pencolors, lines, fills) are managed from the dialog boxes in Options > Element 

Attributes.

For faster display or output, the 2D appearance of some of the attributes can be modified using the 

commands at View > On-Screen View Options.

Topics in this section:

Lines

Hotspots

Figures

Drawings in Model Views

See also:

Fills
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Lines

The following straight and curved line elements can be created in ARCHICAD using the different Line tools 

and geometry methods.

• Single straight line segments, series of Chained straight and Curved line segments, Rectangles and 

Rotated Rectangles.

• Circular Arcs and full Circles

• Elliptical Arcs and full Ellipses

• Straight or Curved Polylines

• Natural Splines, Bézier curves and Freehand curves 

Double-clicking any of the Line type tools will open a dialog box in which you can adjust the settings of the 

given tool.

Available Lines are an attribute, defined for the project globally.

See Lines Dialog Box.

In each of these dialog boxes, the Uniform Settings for Line Tools checkbox allows you to apply the 

settings made in this dialog box to all line-type tools: Line, Arc/Circle, Spline, Polyline.

Favorites of any of the four Line-type tools (Line, Arc, Polyline, Spline) can be applied to any of the other 

Line-type elements.

For more information, see Line Tool Settings, Arc/Circle Tool Settings, Spline Tool Settings and Polyline Tool 

Settings.

Topics in this section:

Line Categories

Drawing a Single Straight Line Segment

Stretching or Shrinking Lines

Drawing Arcs and Full Circles

Stretching Curves

Editing an Arc Using its Tangent

Drawing Elliptical Arcs and Full Ellipses

Convert Ellipse to Circle

Drawing Splines

Editing Splines

Drawing Freehand Curves

Drawing Polylines and Chained Lines

Editing Polylines
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Line Categories

ARCHICAD allows you to assign categories to your lines. (Use the Properties Panel of the Line Settings 

dialog box.) You can then use line categories to fine-tune Graphic Overrides and export settings for lines 

depending on their category.

ARCHICAD has three line categories:

• Drafting line: Simple 2D drafting line. Lines drawn with the Line tool will be in this category by default.

• Cut line: Contour line of a 3D element on a cutting plane.

Note: You can choose to display lines in the Cut line category in boldface: In View > On-Screen View 

Options, choose Bold Cut Lines.

• Skin Separator Line: Separator line between skins of composite structures, including walls, columns, 

slabs and roofs.

Line categories can be useful if, for example, you have exploded a composite wall into its constituent lines 

and fills. By default, in the Line Tool’s Properties Panel, all the contour lines are put into the “Cut line” 

category, while all the skin separator lines are put into the “Skin Separator” category.

All other lines are placed into the Drafting category by default. However, if you draw lines by hand into a Detail 

Window, Worksheet, Patch, Section/Elevation/IE or 3D Document window, you can assign categories to these 

lines according to their function in the plan. This way, even hand-drawn lines can be considered Cut lines or 

Skin Separator lines.

Assigning line categories can also be useful if you save your file in DXF/DWG format: the DXF/DWG 

Translation Setup dialog box allows you to define a separate Custom Layer onto which Skin Separator lines 

can be exported.

See Custom Layers.
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Drawing a Single Straight Line Segment

To draw a single straight Line segment, choose the Line tool in the Toolbox and the Single Line geometry 

method in the Info Box.

The Line segment is defined by clicking at its two endpoints.

Note: This CAD-like drawing method is the default method for drawing segments in ARCHICAD, but you 

can change it in Options > Work Environment > Input Constraints & Guides.
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Stretching or Shrinking Lines

To stretch/shrink a straight line with the menu command:

1. Select a line.

2. Choose the Edit > Reshape > Stretch command.

3. Click an endpoint of the selected line and move it.

4. Click again to either define the new endpoint as an extension (or reduction) of the previous length. The 

line is stretched or shrunk and, if needed, rotated according to the new endpoint. The other endpoint will 

remain at its original position.

Note: Multiple Lines with overlapping endpoints can all be stretched at the same time using the Stretch 

menu command or with the Marquee tool.

For more information, see Stretching with the Marquee Tool.

When using the pet palette:

1. Select a line.

2. Click one of the line’s endpoints. The pet palette appears. Choose the stretch icon: 

3. Click to define the new endpoint.
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Drawing Arcs and Full Circles

To draw an arc or a full circle, choose the Arc/Circle tool in the Toolbox and one of the Geometry Methods 

offered by the first icon in the Info Box (Centerpoint, Three Points or Tangent Point).

Note: These methods are identical for drawing curved walls.

These methods use different basic points to define the arc.

• Centerpoint and radius

– Click to define centerpoint.

– Move the cursor to define the radius, then click a second time.

– Move the cursor to draw the length of the arc, then click to complete.

Note: To draw a full circle, double-click when defining its radius.

• Circumference

– Click on three points of the arc’s circumference (e.g. other elements or intersections, or special snap 

points).

– Click a fourth time to define the length of the arc.

• Tangential: Define a full circle based on three tangential edges or points.

– Select three initial points: these can be a tangent edge, a node, or a free-floating point.

The next step depends on the geometric situation.

- If there is only one solution, the circle is automatically drawn.

- If there are multiple solutions, the Eyeball cursor appears and the ghost contour of the arc flips from 

one position to the other as you move the cursor around. Click when it is at the right place to 

complete the circle.

- If there is no solution, (for example, if you define three parallel edges for tangency), no circle will be 

made.

Note: Unlike circular Walls, Circles can be fully closed. You will obtain a single element, not two half-

circles.
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Stretching Curves

You can modify the circumference or radius of Curved Walls, Beams, Arcs and Circles with either the Stretch 

command or the pet palette icon.

Angular Stretch

• Use the Angular Stretch icon to change the element’s arc length by dragging its endpoint (or reference 

line endpoint, in case of a curved wall) along the curve.

• Alternatively, transform an Arc into a full Circle or the other way around.

Note: A curved Wall stretched into a full circle will be transformed into two half-circular elements.

Radial Stretch

Use the Radial Stretch icon to increase or decrease the element’s radius by dragging its edge or reference 

line.
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Stretch Ellipse

You can modify the shape of a closed ellipse or full circle by stretching it.

• Select the ellipse or circle.

• Click on a node to bring up the pet palette.

• Choose the Stretch Ellipse icon.

• Drag the cursor to stretch the ellipse along its axis or stretch the circle into an ellipse.

• Click to complete.
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Editing an Arc Using its Tangent

Edit an arc from any point along its edge using the tangent to the nearest arc endpoint.

• Click on the edge of any arc and choose the Edit segment using tangent icon from the pet palette.

• The tangent to the nearest arc endpoint appears on the plan. Move the cursor to edit the tangent line by 

choosing a new tangent endpoint. A rubber band line indicates the shape of the resulting new arc. Click to 

place.
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Drawing Elliptical Arcs and Full Ellipses

To draw an elliptical arc or a full ellipse, choose the Arc/Circle tool in the Toolbox and one of the Geometry 

Methods offered by the second icon in the Info Box (Diagonal Ellipse, Semi-Diagonal Ellipse, Ellipse Radii).

The Diagonal Ellipse method creates an Ellipse constrained into a rectangle.

This method stretches the ellipse of an invisible rectangle held by the two points of its diagonal.

1. Click the starting point of the imaginary rectangle.

2. By stretching the imaginary diagonal, you get ellipses of different sizes drawn into the invisible rectangle.

3. With the second click you choose the ellipse of the appropriate size.

The Semi-Diagonal Ellipse method works in the same way as the Diagonal method but here you define the 

imaginary rectangle by its centerpoint and the endpoint of its semi-diagonal.

The Ellipse Radii method defines an elliptical arc by the major and another radius of an ellipse and the angle 

of the arc.

1. Click the centerpoint of the ellipse.

2. Choose the orientation of the major radius, by clicking again.

3. You get the rubber band line of the second radius, which you can stretch to different sizes and angles. 

Notice the accompanying ellipse that fits the length of the two radii. If you stretch the minor radius too far 

away or right in line with the major radius, you cannot draw the ellipse.

4. In the final phase, ARCHICAD holds the ellipse while you define the side angle of the arc. First, you use a 

rubber band line to define the side where the angle starts from. Then you define a different side that 

closes the angle, while ARCHICAD follows the angle with the Elliptical Arc. Neither side of the angle 

remains visible when the final arc is drawn.
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Convert Ellipse to Circle

To convert an ellipse to a circle:

• Select the ellipse.

• Choose one of its nodes to bring up the pet palette.

• Choose the Convert Ellipse to Circle icon.

The ellipse will be transformed into a circle, whose radius is equal to that of the ellipse at the clicked node.
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Drawing Splines

To draw a natural Spline or a Bézier curve, choose the Spline tool in the Toolbox and the first (natural spline) 

or the second (Bézier curve) Geometry Method icon in the Info Box.

Natural splines can be defined by placing nodes, which the program automatically connects, thereby 

generating a smooth custom curve. The angle of the tangent and the shape of the spline generated with it is 

affected by each subsequent node defined. You can conclude this operation by double-clicking on the last 

node or by clicking the OK button in the Control Box. Clicking OK always results in a closed spline.

Bézier splines are somewhat more complex in nature, but they allow more accurate reproduction of specific 

custom shapes. Bézier splines are defined by nodes, just like natural splines, but they also have editable 

tangent handles on either side of these nodes, plus one tangent handle at each end (if it is an open spline). 

The shape of the Bézier spline is affected by the direction of the tangent and the length of each tangent 

handle.

When defining Bézier splines, click once to place a node, and keep the mouse button depressed. By moving 

away from the node in any direction, you are in effect defining the initial tangent, and the length of the handle 

that defines the curvature. If you release the mouse button, ARCHICAD will assume that you wish to jump to 

the definition of the next node with your next click. Keep the mouse button depressed, and then define the 

next tangent and node as above. You can conclude this operation by double-clicking the last node or by 

clicking the OK button in the Control Box. Clicking OK always results in a closed spline.
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You can edit Bézier splines by varying the length of each handle separately: use the pet palette command for 

Move tangent handle.

Note that there is only one angle associated with both handles of a node, but the length of each handle 

may be different. The longer the editing handle, the smoother the curve will be at the control point.

You can pull out the handles from sharp nodes to turn them into curved ones.

Note: The visibility of the editing handles of Bézier splines depends on the status of the View > On-

Screen View Options > Spline Handles toggle. If this toggle is set to “Show,” then all editing handles are 

visible on the Floor Plan. If the toggle is set to “Hide”, then only the editing handles of the spline last 

selected will be visible; if the selection is removed, no editing handles will be visible.
ARCHICAD 24 Reference Guide 2030



Drafting Documentation
Editing Splines

Select a Spline, then edit it in the following ways.

Offset Spline

Choose the Offset command from the Pet Palette to offset the spline.

See also Offset All Edges.

Insert new node

Click a spline with the Mercedes cursor to bring up the Pet Palette; then use the Add new node to Spline 

command from the pet palette.

Move or delete a node

Click a node of the spline to bring up the Pet Palette. Choose the Modify Spline path command.

- Drag the node onto its neighboring node to delete it, or

- Drag the node to a new location.

Unify a series of connected splines

• Select the splines.

• Choose the Edit > Reshape > Unify command.
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Drawing Freehand Curves

To draw a freehand curve, choose the Spline tool in the Toolbox and the third Geometry Method icon in the 

Info Box.

This method is particularly useful to mark up documents. 

The Freehand method always creates natural Splines.
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Drawing Polylines and Chained Lines

By combining the capabilities of the various line type tools, you can create a series of chained straight and 

curved line segments using the Polyline tool or the Chained geometry method of the Line tool.

The difference between the two options is the result they produce.

• Polylines are single elements drawn using the Polyline tool.

• Chained lines are a set of connected line segments drawn with the Line tool. Each line segment is a 

separate element, although they can be grouped before or after they are created. To group a chained line, 

activate the Edit > Grouping > Autogroup command before you start to draw Chained lines, or select the 

set of Chained lines you have drawn and activate the Edit > Grouping > Group command.

To draw a Polyline, choose a geometry method for the Polyline tool: Polyline method, Rectangle method or 

Rotated Rectangle method.

To draw a Chained line, choose a geometry method for the Line tool: Chained method, Rectangle method, or 

Rotated Rectangle method.

With either method (Polyline or Chained Line) you produce a series of straight or curved line segments 

joined at their endpoints.

• Draw a line segment and click to complete the segment.

• As you click to complete one segment, you simultaneously begin the next one.

• Click the OK button in the Control Box or double-click the last endpoint to complete the polyline or 

chained line.

For an illustration of this process, see Create a Chain of Walls.

• To cancel the last-drawn segment of a polyline or chained line, use the Backspace key.

Continue a Polyline

You can extend a completed Polyline from either end:

• Select the existing polyline.
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• Click on either endpoint of the polyline.

• Choose the Continue Polyline icon from the appearing pet palette.

• Draw additional line segments, then double-click (or click OK in the Control box) to complete the polyline.

Note: When extending the original polyline, you can backspace to delete the last drawn segments, but 

you cannot delete segments of the original polyline.

Create Rectangles with Line or Polyline Tool 

Using the Rectangle method with the Line tool will produce four individual Line segments, grouped by default. 

Using the Rectangle method with the Polyline tool will produce a single Rectangle.

With the Rotated Rectangle method, you first define a rotation vector for the rectangle’s reference line. The 

rotation vector also defines the length of the two segments parallel to it. By hitting the Shift key once, you can 

unlock the length component constraint and use only the rotation angle component of the rotation vector.
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Editing Polylines

Unify Drafting Elements into Polyline

Connected Lines, Arcs, and Polylines can be transformed into a single Polyline.

• Select all connecting elements.

• Choose the Edit > Reshape > Unify command.

The attributes of the last selected element will be applied to the unified set of elements.

You can unify multiple sets of selected, connected items with a single Unify command.

Note: To unify items that are Grouped, you must first Suspend Groups.

See also Intersect Two Elements.

Open a Closed Polyline

To open a closed polyline by deleting one of its segments:

• Activate the Arrow tool.

• Ctrl-click (Cmd-click) the line segment you wish to delete.

Note: Use the same method to cut a polyline having at least 3 segments into two independent polylines.

Explode a Polyline

1. Select the Polyline.

2. Use Design > Explode into Current View.

The resulting lines and arcs are grouped. Ungroup them as needed.

See also Explode into Current View.

Dashed Polylines: by Segment or Continuous

For Polylines only, if you are using a dashed line type, choose a preference in Polyline Settings for how to 

handle the dashed pattern at polyline nodes.

Distribute Dashed Pattern Over Entire Polyline
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Distribute Dashed Pattern By Segment
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Hotspots

Hotspots are simple points indicated by a small cross. Their main role is to help position elements in 2D views. 

Hotspots do not appear on printed and plotted outputs and can be deleted when they are not needed 

anymore.

For more information, see Hotspot Tool Settings.

Note: The Guide Lines function can also locate intersection points and other useful snap points and 

directions.

See Snap Guides and Guide Lines.

Placing Hotspots

When you have made your Pen Color and Layer choice in the Hotspot Settings dialog box, you are ready to 

place Hotspots. Just click at the desired location. In some situations, you may need to continue construction 

starting exactly on a given point of an element at a location where it has no hotspot or special point. The solution 

is to generate hotspots that will allow you to snap to this point.

Place Hotspot at Intersection of Two Elements

1. Activate the Hotspot Tool.

2. Select an existing Wall, Slab, Roof, Fill edge or line.

3. Ctrl-click (Cmd-click) the edge of any other existing element.

4. A hotspot will be generated at the intersection of the selected edge and the clicked edge.

Project Perpendicular Hotspot onto Selected Element

1. Activate the Hotspot Tool.

2. Select an existing Wall, Slab, Roof, Fill edge or line.

3. Ctrl-click (Cmd-click) any element hotspot or any empty space.

4. A hotspot will be generated on the selected element at the perpendicular projection of the clicked location.

Place Hotspot at Remote Tangential Point

1. Activate the Hotspot Tool.

2. Select the arc(s) and Ctrl-click (Cmd-click) with the checkmark cursor on the node of any other element.
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3. A tangential hotspot will be generated on the selected arcs or curved edges, or their extensions.

Place Hotspots Parallel to Existing Element

1. Activate the Hotspot Tool.

2. Select an existing Hotspot.

3. Ctrl-click (Cmd-click) with the Mercedes cursor on any Wall, line or element edge.

4. A second hotspot will be generated, so that the line joining the two hotspots is parallel to the clicked 

element.
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Figures

Figures are image files imported and then embedded into the ARCHICAD project file. They can be inserted in 

any of the 2D windows (Floor Plan, Section/Elevation/IE and 3D Document window, Detail, Worksheet, 

Layout). Figures are placed and manipulated by the dedicated Figure tool.

For more information, see Figure Tool Settings.

A placed Figure can serve as a background image to the ARCHICAD model by using the Align View function.

See Align View.

You can also place the cropped content of an ARCHICAD window in the plan as a figure.

Note: Drawings, in contrast to Figures, are assigned ID numbers and (optionally) titles. Drawing frames 

can be manually adjusted. Unlike Figures, Drawings represent linked files that can be updated.

For more information, see Drawings in Model Views.

Figures can be displayed either with or without handles or as simple placeholders. This setting is global, that 

is, it affects all placed Figures. The choice can be made using the Figure Handle toggle under View > On-

Screen View Options.

Note: Regardless of the import method, the images of Figure type elements are embedded in the Project 

and can make the file quite large. Use sizes and resolutions only as needed to prevent overloading the 

Project.

Placing Figures

When you have made your choices in Figure Settings, just click with the cursor to place the Figure. If the 

result does not satisfy you (for example, the image is too small or too large), open the Figure Settings dialog 

box again, and adjust the size, resolution or other settings before placing the Figure again.

You can also stretch the placed Figure, using the Shift key to constrain the diagonal and keep the image’s 

proportions. If desired, however, you can stretch the Figure’s X and Y dimensions independently.

Before you place the Figure, its ghost contour follows the movements of your cursor showing its proportional 

size. The ghost contour’s anchor point is sensitive to element nodes and edges. To make this option inactive, 

go to Options > Work Environment > On-Screen Options > Show Ghost Bounding Box of Objects, 

Columns, Figures and Drawings.
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You can also place Figures in ARCHICAD directly, without using the Figure tool, by pasting bitmaps 

originating either from another ARCHICAD window (for example a PhotoRendered Model picture) or another 

image-processing software. The pasted element will be handled as a Figure by ARCHICAD.

Note: Images imported by this method are always pasted pixel by pixel in the current zoom.
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Drawings in Model Views

Use the Drawing Tool to place Drawings into your project.

Drawings placed into Model views are external files (such as DWG, PDF files and image files). They cannot 

include ARCHICAD views.

Drawings can be placed into any model view except a 3D Window or a Schedule view. 

Placing a Drawing into a model can be useful if, for example, you receive a standard roof structure detail 

drawing from a manufacturer in PDF format. You can place this PDF document as a Drawing into your Detail 

window, add your own alterations or markups as needed, then place it as a modified detail onto a Layout.

Similarly, an external DWG file can be placed as a Drawing into your model as a vectorial drawing. This is a 

simpler solution for accessing DWG files in ARCHICAD, as opposed to attaching the DWG file as an XREF.

If you place a DWG, DXF or DWF file as an ARCHICAD drawing, you have the option of showing or hiding the 

drawing contents based on the source file’s layers.

Images placed with the Drawing tool in a Model view can be preferable to placing images with the Figure tool, 

since such a Drawing retains its source file information and can be updated. You can customize the size, title 

and framing options for your drawings. (Figures, in contrast, do not have these features.)

Drawings placed into a model view (as opposed to onto a Layout) are scale-independent.

Place Drawing into Model window

1. Activate the Drawing Tool.

2. Do one of the following:

– Click in the model window

– use File > External Content > Place External Drawing

3. Browse for the desired file and click Open.

Note: If you are importing a multi-page PDF document, a dialog box prompts you to choose which of the 

pages you wish to place.

4. The Drawing is placed by the anchor point defined in Drawing Settings.

Delete Drawing

To delete a drawing, select it and delete it like any other ARCHICAD element. Note that deleting a drawing is 

not undoable EXCEPT if the active window is the same type (e.g. Floor Plan or Layout window) as the window 

which contained the deleted drawing.

Related Topics

Drawings in the Layout Book

Working with PDF Documents

Drawing Settings

Managing and Updating Placed Drawings

Embedded Layers

Drawing Frame
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Annotation

Annotation Elements display numeric or textual data in 2D views, either about the elements they refer to or as 

standalone informative elements.

• Dimensions are added to construction elements and drafting elements in the Floor Plan and the Section/

Elevation/IE, 3D Document, and Worksheet/Detail windows using Dimension tools.

• The Grid Tool allows you to place Grid elements individually or in a Grid System. Grid elements are part 

of the model and serve as an editable framework for placing multiple elements or for identifying locations 

in the model.

• Texts are inserted using the Text tool, in text blocks accompanied by a flexible formatting options.

• Autotext is a text element containing a definition filled in automatically by the program. Autotext can be 

placed in both Model Views and Layouts.

• Labels allow you to link text information or a symbol to construction elements and 2D Fills. Independent 

(non-associative) Labels are also available.

Topics in this section:

Dimensioning

The Grid Tool

Text Blocks

Autotext

Labels

Pointer Line

Find and Select Text Blocks/Labels

Text Editing in ARCHICAD
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Dimensioning

Dimensions can be placed in the Floor Plan, the Section/Elevation/IE, the 3D Document, and the Detail and 

Worksheet windows.

Many dimensions are associative, which means that dimension values will be updated automatically if the 

element they are associated to is modified.

Note: “Static” Dimensions are not associative.

See Static Dimensions.

The 3D Document window has some unique dimensioning options.

See Linear Dimensions in the 3D Document Window.

The following dimensioning tools are available: 

• Linear Dimensions display element lengths, both curved and straight.

• Elevation Dimensions (a construction method of the Linear Dimension tool) display height values in 

Section/Elevation/IE and 3D Document views.

• Level Dimensions display height values on the Floor Plan.

• Radial Dimensions display the radius of curved elements.

• Angle Dimensions display the angle in degrees between pairs of lines or edges.

Related Topics:

Dimensioning Standards

Glossary of Dimensioning Terms

Static Dimensions

Linear Dimensions

Dimension Tool Settings

Dimension Text Settings

Pointer Line

Dimension Wall or Slab Thickness

Linear Dimensions in the 3D Document Window

Elevation Dimensions

Radial Dimensions

Level Dimensions

Angle Dimensions

Edit Dimensions

Secondary Dimensions (Add-On)

Automatic Exterior Dimensioning
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Automatic Interior Dimensioning
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Dimensioning Standards

Use Options > Project Preferences > Dimensions to apply a Dimensioning standard or to create a 

customized standard.

For more information, see Dimensions Preferences.
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Glossary of Dimensioning Terms

Reference points are temporary nodes that you create on ARCHICAD elements during the dimensioning 

process; they disappear after you click to place the dimension chain.

• Round reference points: Resulting dimension points will be associative.

• Rectangular reference points: Resulting dimension points will be static (dimension values are not updated 

automatically).

See also Static Dimensions.

The Dimension Chain appears after you click the hammer cursor at the end of the dimensioning process.

A dimension chain consists of 

• a dimension line along the length of the element;

• witness lines (perpendicular to the dimension line), if Dimension Settings are set to display them;

• dimension points (where the dimension line intersects with the witness lines).

A dimension segment connects two adjacent dimension points and includes dimension text.

Show Dimension Text Only

With Linear, Radial and Angle dimensions, you have the option to Show Dimension Text Only.

For such dimensions, you can display a reference line (on-screen only) as an aid in editing: turn it on at View 

> On-Screen View Options > Dimension Reference Lines.
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Static Dimensions

Static Dimensions are not associative.

When a static dimension is placed, its reference point is rectangular.

To make an existing linear or level dimension into a static dimension, select the dimension and enable the 

Static Dimension checkbox in Dimension Settings.

Once a dimension has been made static, it cannot be made associative again.
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1. Activate the Linear Dimension tool. 

2. Move your cursor to the element you wish to dimension. Highlighted feedback lets you know which 

element will be dimensioned.

If your cursor is hovering over multiple elements, the Info Tag prompts you to click Tab to cycle the 

highlight through the elements.

3. Click along the element you want to dimension to place temporary reference points where dimension 

segments should begin and end. As you proceed, the element to which the reference point belongs is 

highlighted.

4. If needed, revoke any reference point by clicking it again.

5. Double-click after placing the final reference point.

6. Click the black hammer cursor where you want the dimension chain to appear.

Related Topics

Dimension Wall or Slab Thickness

Linear Dimension Geometry Methods

Linear Dimension Tool Settings
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Dimension Wall or Slab Thickness

For Walls in Floor Plan/Section, and for Slabs in Section:

1. With the Linear Dimension tool active, click the contour line of the element to be dimensioned.

2. Reference points appear on the faces, skins and/or reference line (depending on the settings at 

Dimension Details - see below).

3. Double-click to complete the dimension chain and place it with the Hammer cursor.

In Section, you can dimension Slab thickness the same way:

If you place a series of wall-thickness dimension markers along a chained wall, only the dimension points 

located on walls perpendicular to the dimension chain will be displayed.

Related Topic:

Single-Click Thickness
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Dimension Skins of Composite/Profile Element Automatically

To dimension the individual skins and/or reference lines of composite or profile elements automatically: 

1. Go to the Dimension Details panel of Dimension Settings (or the corresponding controls in the Info Box).

2. Choose the Automatic Method, then check options to be dimensioned. 

Use one or more checkboxes in combination to get all the dimensions you need.

Dimension Outer Faces
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Dimension Core Faces

Dimension Reference Lines

Watch the Video
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Linear Dimension Geometry Methods

Geometry Methods for Linear Dimensions are set in the Info Box.

The Geometry Method you choose applies to the entire dimension chain, and cannot be set unit by unit.

Note: There are additional Geometry Methods for the 3D Document window.

See Linear Dimensions in the 3D Document Window.

Topics on this page:

Any Direction Geometry Method

X-Y Only Geometry Method

Arc Length Geometry Method

Single-Click Thickness

Any Direction Geometry Method

The default Any Direction method enables you to create dimension chains at a variety of positions relative to 

the element’s position: either parallel to the first two reference points placed, or horizontal/vertical, or parallel 

to another edge/surface of your choice.

Move the cursor around to get feedback on the possibilities, which vary depending on the dimension points’ 

position.

An additional dimension line vector is also available: After the black hammer cursor appears, you can move 

this cursor to any straight line/edge in the project.

Note: In the 3D Document window, you must align the dimension to the edge of a construction element - 

line segments do not work.
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Example

Suppose you want to dimension the roof using the vector parallel to the diagonal, instead of parallel to the 

roof. 

1. Click the two dimension nodes on either end of the roof.

2. Move the cursor over the diagonal. The cursor then changes to the “Mercedes + parallel dimension” 

cursor shape, to indicate that it has found an edge, to which the dimension line can be parallel:

3. Click to constrain the dimension line to be parallel to this line/edge.

4. Drag the dimension line to its final position and click with the black hammer to place the dimension chain.

X-Y Only Geometry Method

The X-Y Only method restricts the dimension line zones to horizontal and vertical only, relative to the screen.
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Arc Length Geometry Method

Use this method to dimension curved elements.

1. With the Linear Dimension tool active, choose the Arc Length Geometry Method from the Info Box.

2. Click with the Mercedes cursor on a circular arc or a curved edge - you don’t have to find the end points, 

you can click anywhere on the curve.

3. ARCHICAD automatically marks the end points of the arc or the edge. This is the edge that arc length will 

be measured on. You may click any other points you want to add to the dimension chain.

4. Double-click anywhere in the workspace with the Empty Pencil cursor or click the OK button in the 

Control Box to finish selecting arc points for dimensioning.

5. Click with the Hammer cursor to place the dimension chain.

Single-Click Thickness

Enable the Single-Click Thickness control in the Linear Dimension Tool Info Box, to dimension Wall and 

Slab thickness with a single click.

1. With the Linear Dimension tool active, move the cursor to the Wall or Slab contour line.

If you click any other element, the one-click option does not work, and you have to place the dimension 

line as usual.

2. Click once to place the thickness dimension(s), depending on the settings at Dimension Details:

– In Automatic Mode, depending on the Outer/Core/Reference Line Settings, this will result in multiple 

dimension points in the chain.

Note: If only the Reference Line option is active, the one-click option does not work.
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– In Manual Mode, this will result in a chain dimensioning all skins of the walls and slabs. 

For more information, see Dimension Wall or Slab Thickness.
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Linear Dimensions in the 3D Document Window

In the 3D Document window, use the Linear Dimension tool to place dimensions as needed. All the options for 

Linear Dimensions are available except Arc Length.

In the 3D Document window only, you can constrain the plane in which the dimension line is to be placed. 

(see below)

Choose Dimension Plane in 3D Document Window

To choose a plane constraint for linear dimensions in the 3D Document window, choose among the options in 

the Linear Dimension Tool Info Box:

• the horizontal plane

• the vertical plane

• any other plane

The default is the “Any Plane” option, which gives you the most freedom.

Example

Suppose we wish to dimension the width of the roof in a 3D Document.

Activate the Linear Dimension tool. Select the “Any Plane” geometry method in the Info Box, as well as the 

“Any Direction” option.

As usual, click at both ends of the roof, then double-click. 

Next, choose the plane in which you wish to measure the dimension. To do this, move the cursor onto the roof 

plane. The feedback indicates the direction of the dimension plane; click to define the desired plane.
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Now the cursor will move only in this defined plane. Click one more time to place the dimension line at the 

desired location.

Offset Dimension Plane

Once you have placed a dimension line in the 3D Document window, you can offset it within its current plane. 

This option is available for dimensions in the 3D Document only: 

The usual dimension line editing options are also available from the pet palette (insert/merge dimension point, 

drag or align dimension line.)

See Edit Dimensions.
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Elevation Dimensions

A special case of the linear Dimension tool is the Elevation Dimensioning construction method. Elevation 

Dimensions allow you to place height markers in Section/Elevation/IE and 3D Document windows.

Note: On the Floor Plan or Worksheet/Detail windows, use Level Dimensions. See Level Dimensions.

Elevation Dimensioning is calculated based on the Dimension Origin, which you can set as needed in 

Elevation Dimension Settings.

A series of Elevation Dimensions behaves as an associative dimension chain.

Place Elevation Dimension Chain

1. Activate the Dimension tool, with the Elevation Dimension construction method.

2. In the Section/Elevation/IE or 3D Document window: click the series of points where you need Elevation 

Dimensions.
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3. Double-click (or click OK in the Control Box) and use the Hammer cursor to place the chain.

In Section/Elevation/IE windows, you can dimension all Story Level Lines in one step. 

See Dimension Story Level Lines.
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Select Elevation Dimensions

Shift-click on the invisible axis of the chain (where the cursor changes to Mercedes with Arrow).

Elevation Dimension Settings

Most of the settings in this dialog box are identical to those at: Dimension Tool Settings

The following describes the controls which are unique to Elevation Dimension Settings.

Marker Type: Click the pop-up to choose a Marker/Dimension text arrangement for the Elevation Dimension.
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Click one of these icons to choose proportions for the Elevation Dimension Marker.

Click one of these icons to choose a direction for the Elevation Dimension Marker.

Click one of these buttons to choose outline or solid Marker.

Choose a Dimension Origin from the pop-up list:

• Project Zero

• Sea Level (defined at Options > Project Preferences > Reference Levels)

• A Reference Level (defined at Options > Project Preferences > Reference Levels)

• Current User Origin: this option only appears for selected Elevation Dimension chains and indicates that 

the User Origin has been changed since the dimension chain was placed and the dimension chain has not 

been updated.
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Radial Dimensions

Radial Dimensions display the value of the radius of a curved element.

Radial dimensions have two main parts: the Dimension (pointer) Line and the text.

1. Click on a point of the curved element.

2. Draw the dimension line, either toward the centerpoint of the curve or in the opposite direction. The radial 

dimension must always originate from a curved element.

3. Click again to place the text, which shows the value of the radius.

Text orientation can be defined in Radial Dimension Settings. (See below.)

Stretch or Move Radial Dimension

You can adjust a placed radial dimension with the aid of the pet palette:

Use the Stretch Radial Dimension icon to stretch the dimension.

Use the Move Radial Dimension icon to move it.

Radial Dimension Settings

The following controls are unique to Radial Dimensions:
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Radial Dimension Type Panel

Dimension Type: Specify the type of the radial dimension here.

• Dimensions with centerpoints: Mark the centerpoint of the arc with a crosshair.

• Dimensions without centerpoints.

Pointer Line & Text:

Choose an option for orienting the pointer line and the associated text.

Prefix: Enter an optional prefix for the dimension text here.
ARCHICAD 24 Reference Guide 2063



Annotation Documentation
Level Dimensions

Level Dimensions are point-level elevation markers that display the story height or an element’s vertical 

height along the Z-axis. They are available in the Floor Plan and in Worksheet/Detail windows.

Level Dimensions are associative to the following elements:

• Slab

• Mesh

• Roof (single-plane and multi-plane)

• Shell

• Stair (and Stair sub-components)

Note: In Section/Elevation/IE windows, use Elevation Dimensions. See Elevation Dimensions.

1. Select the Level Dimension tool.

2. Hover your cursor over the element or space whose elevation you wish to dimension.

– If your cursor is hovering over multiple elements, the Info Tag prompts you to click Tab to cycle 

through the elements.

– Highlighted feedback over dimensionable elements lets you know which element will be dimensioned.

– The cursor will not detect overhead surface planes (except for Slabs and Meshes).

– If Gravity is on, the cursor will gravitate only to the respective element type. See below.

3. Click to place the Level Dimension.

Level Dimension on a Roof plane

Level Dimension on a Slab

Level Dimensions on Tread, Landing, or Landing Structure

As you place a Level Dimension on a Stair Component, use TAB to ensure that you highlight the right 

component, then click to place.

Note: Stair components can be highlighted and selected only if their symbols (Grid Going and Grid Fill) 

are turned on (visible) in Model View Options or Stair Settings. 
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Level Dimensions with Gravity On

If Gravity is on, the Level Dimension can be placed only onto the particular element that is using gravity (either 

Slab, Roof, Shell or Mesh).

For more information, see Gravity.

Associativity of Level Dimensions

Level Dimensions remain linked to the elements they were placed on top of, even if they are no longer inside 

the contour of these elements. If a Level Dimension falls outside the contour of the element it is associated to, 

its value changes according to the following rules:

• With Slabs, there is no change: the value is the same as if the Level Dimension were still inside the Slab’s 

contour.

• With Roofs, the value displayed is calculated by a projected extension of the roof (that is, what the value 

would be).

• With Meshes, it is the Story’s height that will be displayed (but the Level Dimension remains associated to 

the Mesh).
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Level Dimension Tool Settings 

Level Dimension Type Panel

Enter a height for the Level Dimension Marker.

Rotation angle: Enter a rotation angle for the Level Dimension Marker. The text will rotate with it, maintaining 

its original relationship to the marker symbol.

Marker Type: Click the pop-up to enter a Marker type for the Level Dimension.

Level Dimension Text Style Panel

See More Text Style Controls (Dimension, Label).

Hide with Associated Element

By default, a Level Dimension will be hidden if its associated element is hidden (e.g. on a hidden layer). To 

display the Level Dimension regardless of whether its associated element is visible, uncheck this box.
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Angle Dimensions

Angle Dimensions display angle values

• between a pair of lines or linear edges

• or the angle of a curved element

Note: Angle dimensions are not available in the 3D Document Window.

Angle Dimension Construction Methods

The Angle Dimension has two construction methods (choose from the Info Box or Angle Dimension Settings):

• Inner Dimension (acute) construction method:

• Outer Dimension (obtuse) construction method:

Place Angle Dimension Between Two Edges

To dimension an angle between two edges:

1. Click an edge or line.

2. Click a second edge or line.
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3. Click a third time to place the dimension of the angle. 

You can also click on any four locations in the window or on a Guide Line, to define two vectors. Click again to 

place the angle dimension between the two vectors: in this case, the angle dimensions is not associative.

Place Angle Dimension on Curved Element

1. Select the Angle Dimensioning tool in the Toolbox.

2. Click the curved element. The two endpoints of the arc will be automatically marked.

3. Click with the Hammer cursor to place the dimension.

Angle Dimension Settings

Most of the settings in this dialog box are identical to those at: Dimension Tool Settings

Number Orientation

Choose a position for the dimension numbers: horizontal, perpendicular or parallel.
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Edit Dimensions

Topics in this section:

Select Dimension

Insert New Dimension Point

Delete Dimension Point

Move Dimension Point

Delete Dimension Segment

Move Dimension Line Segment

Break and Offset Dimension Line

Split Dimension Line

Merge Dimension Chains

Drag/Rotate/Mirror Dimension Chain

Align Dimension Line to an Edge

Stretch or Move Radial Dimension

See also:

Edit Text Box

Modify the Witness Line

Dimension Text Settings

Select Dimension

Select Dimension Chain

Click at any “free spot” on the dimension line with the Checkmark with Mercedes cursor.

Select Dimension Segment 

Click at its midpoint with the Checkmark with Arrow cursor.

Select Dimension Text

• Use the Quick Selection cursor.

• Click on the lower left corner of the text with the Checkmark with Arrow cursor. 

See Dimension Text Settings. See also Edit Text Box.

Insert New Dimension Point

1. Select the whole dimension chain (click at a “free spot” on the dimension line). 

2. Do one of the following:

– From the pet palette, choose the Insert/Merge Dimension Point command, then click on the element 

whose dimension you want to add, or anywhere outside the line.
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– Select the Dimension Tool, then Ctrl/Cmd-click on the element whose dimension you want to add, or 

anywhere outside the line. 

Edit Dimension Point 

Click the point. Then do any of the following:

• Click again to access Pet Palette.

• Access Dimension Settings for the selected point: the only available option is to edit the length of the 

witness line.

Delete Dimension Point

Select the Dimension point, then delete it.

Alternatively:

1. Select the entire dimension chain (click at a “free spot” on the dimension line).

2. Ctrl (Cmd)+Click any individual point to delete it. 

Move Dimension Point

1. Select the dimension point.

2. Do one of the following:

– From the pet palette, choose Move Dimension Point. Drag the selected dimension point to its new 

location.

– Ctrl (Cmd)+Click at a new location to move the dimension point there.

Delete Dimension Segment

Do one of the following:

• Ctrl + click on a segment to delete it:
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• Select a Dimension Text and delete it.

Move Dimension Line Segment

1. Select the whole dimension chain (click at a “free spot” on the dimension line). 

2. Click on the segment you want to move.

3. From the pet palette, choose Move Dimension Line Segment.

4. Drag the segment to its new position. The original dimension chain is split accordingly.

Watch the Video

Break and Offset Dimension Line

This command is available on an internal point or segment of a linear dimension line.

1. Click at the point or segment where you want to break the line. 

2. From the pet palette, choose Break Dimension Line.

– If you clicked a segment: The dimension line is broken at the closest endpoint of the segment you 

clicked. You can drag the newly split line to a new position.

 

– If you clicked on a point: The dimension line is broken at the point. Click with the eyeball cursor on the 

side that you wish to offset.
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Split Dimension Line

This command is available on an internal point of a linear dimension line.

1. Click on the point at which you want to split the dimension line.

2. From the pet palette, choose Split Dimension Line.

3. Click with the eyeball cursor on the side of the line that you want to keep selected.

Watch the Video

Merge Dimension Chains

To merge two separate dimension chains (whether straight or curved), do one of the following:

• Select one of the chains (click at a “free spot” on the dimension line), then Ctrl/Cmd-click on the other 

dimension chain.

• Select one of the chains (click at a “free spot” on the dimension line), bring up the Insert/Merge 

Dimension Point command from the Pet Palette, then click on the other dimension chain to merge it.

Watch the Video
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Drag/Rotate/Mirror Dimension Chain

1. Select the entire dimension chain (click at a “free spot” on the dimension line).

2. Use the Drag, Rotate or Mirror command from the pet palette.

Notes:

– You can drag or rotate a dimension chain as a whole. Units or points cannot be dragged, rotated or 

mirrored away from the parent dimension chain.

– Associative Dimension chains can only be dragged along the direction of their witness lines.

– After a rotation, all the reference points will automatically be redimensioned and projected along the 

new direction.

Align Dimension Line to an Edge

1. Select the entire dimension chain (click at a “free spot” on the dimension line).

2. Bring up the Align dimension line command from the Pet Palette

3. Click on a straight edge or line. The selected Dimension chain will align itself with the clicked edge.

Stretch or Move Radial Dimension

You can adjust a placed radial dimension with the aid of the pet palette:

Use the Stretch Radial Dimension icon to stretch the dimension.
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Use the Move Radial Dimension icon to move it.
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Modify the Witness Line

To choose a Witness line style, use Linear Dimension Settings.

See Witness Line Format.

Edit Length of All Witness Lines

1. Select the entire dimension chain (click at a “free spot” on the dimension line).

2. Bring up the Edit Length of Witness Line command from the Pet Palette

3. Drag the cursor to the desired spot.

Dynamic witness lines will never extend beyond the reference node of the dimensioned element.

Edit Length of Single Witness Line

1. Select the dimension point.

2. From the pet palette, choose Edit Length of Witness Line.

3. Drag the selected witness line of the selected point to its new location.
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Edit Text Box

The following applies to positioning text boxes and pointer lines (if any) used in Dimensions, Fill Area texts, 

and Labels.

Select Text Box

Select Text Box Plus Pointer Line

Copy-Paste Dimension Text

Select Text Box

To select a Dimension or Label text box, do one of the following:

• Use the Quick Selection cursor

• Click on a corner of the text with the Checkmark with Arrow cursor

Select Text Box

Once you select a text box, you can change its position and/or orientation using Edit functions (e.g., Drag, 

Rotate, Mirror).

Note: If the Text box also has a Pointer Line, the Lock Angle control affects the range of graphical editing. 

If it is ON, the Pointer Line’s starting angle remains fixed, limiting the edit possibilities.

Delete Text Box

Deleting the Dimension Text deletes the corresponding Dimension segment too.

Select Text Box Plus Pointer Line

If you click the Pointer line, both the line and the text box are selected, enabling additional editing options.
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Watch the Video

Watch the Video

Watch the Video

Automatic Dimension Text Placement in Linear Dimensions

ARCHICAD automatically adjusts crowded Dimension Texts to enhance readability. The default method is 

usually satisfactory. For more control over how dimension texts are distributed, use the options at in 

Dimension Settings:

See Dimension Text Placement Method.

Copy-Paste Dimension Text

Only simple text items can be copied; superscripts will not be copied.

1. Select the dimension text only (not the dimension line itself)

2. Use the Copy command (Edit > Copy or Ctrl/Cmd + C)

3. Paste the dimension text (Edit > Paste or Ctrl/Cmd + V) - for example, to a text box or onto a Layout.

Related Topics:

Dimension Text Settings

Pointer Line

Text/Autotext Label Content

Show Dimension Text Only
ARCHICAD 24 Reference Guide 2077

https://youtu.be/jzryc6ot47M
https://youtu.be/b-Nvc8nSKxI
https://youtu.be/5U4c9kQzu0g


Annotation Documentation
Pointer Line

Available for Text Label and Dimension Texts.

Watch the Video

Click the Pointer button to assign a pointer line and activate the rest of the settings on this panel.

Define a Line type and Pencolor for the pointer line.

Connect Pointer to Text Box

Use these controls to connect the Pointer Line to the Text Box (top, middle, or bottom).

If needed: Extend the pointer line to run underneath the text row.

Connect Pointer to First/Last Text Row

Use these controls to connect the Pointer Line to the First or last row of text (aligned with the top, middle or 

bottom of the row): 

Choose whether the pointer should have a straight, curved or inverted pointer line.

Enter the Pointer Starting Angle using a value from 0 to 90 (the default is 90 degrees). The angle is 

measured from the dimension line. Click the lock icon to prevent the angle from being modified graphically 

(e.g. by accident).
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Note: The Lock Angle control affects the range of graphical editing. If it is ON, the Pointer Line’s starting 

angle remains fixed, limiting the edit possibilities.

Choose a style and pencolor, and enter the size of the Arrowhead.

Hide Arrowhead from: Check this box if you want to hide the pointer line arrowheads on views which exceed 

a certain scale (enter the desired scale in the field to the right).

See also Edit Text Box.

Automatically Appearing Pointer Line (Dimension Text Only)

Even if you have not turned on a Pointer Line for a Dimension text, a Pointer Line will automatically appear if 

you drag the Dimension text box beyond a certain range.

This automatically added Pointer line will disappear if you do any of the following: 

• Turn the Pointer Line off in Dimension Text Settings

• Drag the dimension text back within range

• Check Revert to Automatic Position in Dimension Text Settings

Related Topic:

Custom Settings for Symbol Labels
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Automatic Exterior Dimensioning

Use this function to add automatic associative linear Dimensions to selected Walls or Curtain Walls on the 

Floor Plan. 

1. On the Floor Plan, select the Walls or Curtain Walls to be dimensioned.

Go to Document > Annotation > Automatic Dimensioning > Exterior Dimensioning. Set the desired 

options.

See Automatic Exterior Dimensioning Dialog Box.

2. Define the direction of the dimension lines. Do this in one of two ways:

– Click the side edge of any element (the dimension direction will follow the element direction); or

– Click in an empty area, then click a second time to define the dimension direction.

3. Click with the hammer cursor to place the dimension line(s).

Automatic Dimensioning will automatically place the dimension lines (up to four types) depending on the 

options you have chosen in the dialog box. If any of these dimension lines are unnecessary (e.g., there are no 

openings, or the facade is straight), it is ignored.

The display of automatic dimensions depends on the options chosen in Dimension Tool Settings.
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Automatic Exterior Dimensioning Dialog Box

Open the dialog box from Document > Annotation > Automatic Dimensioning > Exterior Dimensioning.

Check one or more Dimension options to use:

Overall Dimension

A single dimension line that runs the length of the selected element set.

Dimension External Geometry

The linear dimensions of extruding elements, such as a facade.

Dimension Structures

The linear dimension of the element itself, such as wall thickness

Dimension Openings

Check this box to include the dimensions of openings (doors and windows). 

Choose where to place the dimension for openings:

• Opening Center

• Opening Endpoints
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Choose separate dimensioning preference for doors and for windows.

Note: If you automatically dimension doors placed from the ARCHICAD 12 or ARCHICAD 11 libraries, 

and if you choose Leaf or Egress size as the preferred door dimension, the door’s height value will not be 

shown unless you choose Leaf or Egress as the Nominal value in Door Settings. (Door widths will be 

dimensioned without any problem.) If you automatically dimension doors placed from earlier ARCHICAD 

versions, only the Wallhole and Nominal Size options will work.

Dimension Walls by

Choose a preference for dimensioning composite Walls.

• Outer Faces

• Core Faces

Distance Between Dimension Lines

Enter a distance using the working units currently set in ARCHICAD.

Place Dimensions on Four Sides

Check this box to automatically place dimension lines on all four sides of the bounding box of the selected 

elements.
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Automatic Interior Dimensioning

Use this function to quickly dimension a set of selected Columns and composite or profile (complex) elements 

on the Floor Plan.

1. Select one or more Columns or Composite/Profile elements to be dimensioned.

Note: Profiled Columns will be ignored.

2. Open the dialog box from Document > Annotation > Automatic Dimensioning > Interior 

Dimensioning.

3. Choose preferred dimensioning options.

Column Dimension Preference

• Column Center: Dimension the axis of the column

• Column Endpoints: Dimension the endpoints of the column.

Note: A circular column will always be dimensioned at its center regardless of this checkbox.

Composite and Profile Elements

Choose an option:

• All Skins: Each skin of the composite/profile element is dimensioned separately. (If this is unchecked, a 

single dimension is applied to the total width of all the skins.)

• Automatically dimension Walls and Slabs: Dimension points are placed at the faces and/or reference 

lines depending on the options checked below (at least one category must be checked):

– Outer faces

– Core faces

– Reference lines

Note: These options have the same effect as Automatic Method of Dimension Details (Dimension Tool 

Settings).

See Dimension Details Panel.

4. Drag the cursor to draw a temporary line across the selected elements to be dimensioned. 

– Walls, Columns, Beams, and Slab, Roof and Mesh edges perpendicular to or crossing the drawn line 

will be dimensioned. The line can consist of several segments. 
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5. Double-click to finish drawing the line.

6. Click to place the dimension chain. 
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Secondary Dimensions (Add-On)

The Secondary Dimensions function allows you to add metric unit equivalents to dimension values 

displayed in feet and inches, and vice versa. The Secondary Dimensions menu is located at Document > 

Annotation.

Note: If your program does not display the Secondary Dimensions menu, you can add it to your work 

environment.

For more information, see Menu Customization Dialog Box.

Use the Document > Annotation > Secondary Dimensions > Convert Dimensions dialog box to set the 

unit and the number of decimals of the converted dimension value.

Click OK, and the secondary values will appear on the opposite side of the dimension line.

 

The new values will be placed as a text block, and can be edited as any other text block.

• If nothing is selected on the Floor Plan, all placed dimensions will be converted.

• If there are selected dimensions, only their values will be converted.

Changes made to dimensioned elements do not automatically update the converted dimensions.

Choose Document > Annotation > Secondary Dimensions > Refresh converted dimensions to update 

both the value and the location of the dimension. Again, this command will work on either all dimensions (if 

nothing is selected) or selected ones.

If you do not need equivalents any more, simply choose Remove converted dimensions from the 

Secondary Dimensions menu.

For more information, see Convert Dimensions Dialog Box (Add-On).
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The Grid Tool

The Grid Tool allows you to place Grid elements individually or in a Grid System; it is a tool in the ARCHICAD 

Toolbox.

Grid elements are part of the model and serve as an editable framework for placing multiple elements or for 

identifying locations in the model.

The Grid Tool creates a custom local structural grid. (In contrast, the Construction and Snap Grid set in the 

View > Grid Options > Grids and Background is a global, equally distributed net covering the whole 2D 

window, and is used as an input and editing aid.)

The grid created by this tool is interactive, so you can edit grid elements even after placing them. Grid 

elements can be edited using Grid Settings.

See Grid Tool Settings.

Grid elements can be placed in either the Floor Plan or the 3D window, but they can be displayed in Sections, 

Elevations, Interior Elevations and the 3D Document as well.

A Grid element marks a vertical location in the model. Like other model elements, Grid elements are saved 

along with views.

Grid element on the Floor Plan
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Grid element in the 3D window

To place a whole scheme of horizontal and vertical gridlines in one step, use the Design > Grid System 

command. The follow-up Grid System Settings dialog allows you to configure the system of Grid Elements 

and to place dimensions, beams, columns or optional library parts at the grid intersection points.

See Grid System Settings.

This image shows a Grid System in 3D with Beams and Columns placed at intersections:

Related Topics:

Components of a Grid Element

Visibility of a Grid Element

Creating a Straight Grid Element

Creating a Curved Grid Element

Editing a Grid Element

Editing Grids in Teamwork

Place a Grid System
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Components of a Grid Element

A Grid Element has two main components: Grid Marker and Grid Line.

The Grid line can be displayed in three different formats to suit your documentation needs.

Grid Markers can be switched on and off optionally at both ends of the Grid Line, in the Grid Settings Floor 

Plan panel.

You can stagger grid markers away from the Grid line graphically, using a pet palette command.

See Editing a Grid Element.

When you stagger the grid markers sideways, a certain line segment will be staggered together with the 

markers. The length of this line segment is the Staggering value.

The default Staggering length for any Grid element can be set in both the Floor Plan and Section/Elevation 

panels of Grid Tool Settings.
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Visibility of a Grid Element

Provided that their layer is visible, Grid elements are visible on:

• the Floor Plan, on any or all stories: Use the Show on Story pop-up in the Grid Settings Floor Plan panel.

• the Section/Elevation windows, if the Section or Elevation settings allow: Use the Show Grid Elements 

checkbox on the Grid Tool Panel of Section Settings.

There are two sets of filtering criteria for display of Grid elements on this Section: You can filter by Grid 

element Story, and/or you can filter by Grid element Name.
ARCHICAD 24 Reference Guide 2089



Annotation Documentation
• 3D window and 3D Documents, if the Grid element is set to appear in 3D: Use the Display in 3D view 

checkbox in the 3D View panel of Grid Tool Settings.

Detail and Worksheet windows will not display the grid elements, just their exploded views.

By default, Grid elements are displayed in 3D as lines only, and are not displayed in renderings. However, you 

can choose to display Grid elements as model elements in 3D so that they appear in renderings, with a cross-

section and surfaces: to do so, adjust the options in the 3D View panel of Grid Settings.
ARCHICAD 24 Reference Guide 2090



Annotation Documentation
Creating a Straight Grid Element

Grid elements can be created in the Floor Plan or 3D window. The Straight Grid Element method produces 

one straight Grid Element at a time.

After setting up the element settings or choosing a Favorite, select the Grid Tool. Choose the Straight Grid 

Element geometry method from the Info Box. Click to place the endpoints and to define the length of Grid 

Element.

The moment you start drawing the Grid Element, a ghost contour appears and it follows the cursor until you 

click at the second endpoint.
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Creating a Curved Grid Element

After setting up the element settings or choosing a Favorite, select the Grid Tool. Choose one of the two 

Curved Grid Element Geometry methods from the Info Box.

The first option defines the curved Grid by the arc’s centerpoint and radius. Your first click defines the 

centerpoint.

A ghost contour of the circular grid follows your cursor until you click a second to time to define the radius. 

After that, only a partial ghost curved segment is shown, until you click a third time to define the length of the 

arc grid’s circumference. When all three points are defined, the ghost contour is replaced by the fully 

displayed Grid Element.

The second option defines the curved Grid by three points on the arc’s circumference. You will probably place 

first two points so that they connect other elements, grid intersections or special snap points. Next, a ghost 

circle follows the cursor until you click a third time to define the third point.
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A fourth click is needed to define the length of the arc segment. The ghost arc is now replaced by the fully 

displayed Grid Element.
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Editing a Grid Element

Edit Length of Grid Line

Any Grid elements can be stretched with Pet palette commands: select the Grid Element, then choose the 

Stretch icon.

Stagger Markers Away from Grid Line

Select a Grid element. Click on the editing hotspot which represents the staggered part of the Grid marker, 

and then drag the Marker, together with the staggering length, to a new position.

Edit Grid Position

The horizontal position of a grid element can be edited on the Floor plan and 3D window only. Select the Grid 

Element and use the familiar pet palette commands and shortcuts to Drag, Mirror or Rotate the Grid 

element, or copies of it.

The vertical position (Z-value) of a grid element can be edited 

• in the 3D window 

• at the 3D View Panel of Grid Settings, or

• in the Info box.
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Editing Grids in Teamwork

Note: The word “Section” in this document is understood to include Sections, Elevations and Interior 

Elevations.

When editing Grids in the Section window in Teamwork, certain procedures will require an extra reservation. 

Context-based pop-up bubbles will inform you of what to do as you work. The extra reservation is required in 

three cases, detailed below.

Editing Grids in Section

You can reserve a Grid element in Section with the usual reservation methods. However, even after reserving 

the Grid element, you cannot edit it until you also reserve it on the Floor Plan. The Info Tag notifies you of this 

if you try to edit a reserved Grid element in Section:

You must go to the Floor Plan and reserve the Grid element in question. Now you may edit it in Section as 

usual.

Note: If you reserve and edit a Grid Element on the Floor Plan, the Section will be rebuilt as expected, 

including the Grid elements; no additional steps are necessary.
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Place a Grid System

To lay out a complete orthogonal or curved grid mesh, use the Grid System function. The Grid System 

command can save you a lots of time by automating the task of placing multiple Grid Elements in one step, 

following a defined scheme, and even placing elements on dedicated positions. You can also place 

dimensions throughout the Grid system in one step.

A Grid System is a collection of Grid Elements; each Grid element continues to act as a distinct element, even 

though they are placed as part of a system.

Select Design > Grid System. Adjust the settings.

See Grid System Settings.

The number of horizontal and vertical grid lines to be placed in this Grid System depends on what you set in 

the Grid Positions panel: click the plus and minus signs to add or remove individual Grid lines from the Grid 

System.

The number of Grid lines is shown in the “axes” field below.

Click in the Distance field of any Grid line to define its distance from the previous Grid line:
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If you do not know the distance you will need between your Grid lines, check the Distribute box for either or 

both Grid line directions (i.e. horizontal and/or vertical grid lines). This will enable you, when you place the 

Grid system, to set the beginning and endpoints of the Grid system in the given direction, divided into the 

number of Grid lines defined in the list.

When you are satisfied with Grid System Settings, click OK.

You will see a ghost grid system at the cursor, which you can place with two to four clicks:

• the first click defines the location of the anchor point you selected in the settings 

• the second click defines the rotation of the grid system 

• if you selected the Distribute function as well, then one or two additional clicks are required to define the 

full distances for distribution in one or both directions, depending whether you checked Distribute for one 

or both directions.

Note: You can select and edit all or selected elements of a placed grid system by selecting them using 

any of the ARCHICAD selection methods.

Place Object, Column or Beams with Grid System

Use the General Settings panel of Grid System Settings to place an Object or Column automatically at every 

Grid intersection point; and/or to place a Beam along every Grid line of the Grid System.

Note: If you are placing a curved grid system, you have the additional option to place either straight or 

curved beams along the gridlines.

The Settings button next to each checkbox will take you to the relevant Tool Settings dialog box (Column, 

Object, Beam).

For details on these controls, see Grid System General Settings Panel.

Although these checkboxes mean that Beams, Columns or objects are placed at each Grid intersection, these 

elements are independent of the Grid and will not be moved or rotated along with the Grid System.
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Watch the Video

Dimension Grid System

Two additional checkboxes in the General Settings panel of Grid System Settings enable you to automatically 

dimension each Grid line segment in the system, and/or to place a single total dimension for each Grid line.

These dimensions are associated to the Grid system.

The Settings button to the right of the Dimension checkboxes take you to Dimension Default Settings, where 

you can set the options for the chosen Dimension type for your Grid System. For example, you can set all of 

the individual Grid line dimension text to be displayed in italic, while the Total Dimension values are displayed 

in bold type.

Note that if you would like to use uniform Dimension settings for both dimension lines, then you can use the 

Chain button to link them together, in the General Settings panel of Grid System Settings.
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Text Blocks

Using the Text tool, you can create multi line texts with full-scale font options, multiple styles and alignment in 

any direction. Text blocks can be created in the Floor Plan, in Section/Elevation/IE and 3D Documents, and in 

Detail and Worksheet windows, and on Layouts. You can format the content of text blocks as a whole (using 

Tool Settings or Info Box), and you can also individually format characters within the text block (using the Text 

Editor).

Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill Text.

Text blocks are always readable from left to right even after a mirroring.

The advantages of freely editable text elements are available for the Label tool as well as the Text tool. (Rich 

text functions are not available for other textual items in ARCHICAD.)

Depending on the state of the Textbox Handles toggle in View > On-Screen View Options, all text blocks can 

be framed with brackets at each corner handle.

This makes text blocks easy to locate and edit, while keeping the text readable.

Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill Text.

Related Topics:

Placing Text Blocks

Formatting Text Blocks As a Whole

Resizing Text Graphically

Applying Favorite Text Settings

Formatting Individual Components of Text Blocks

Formatting Palette and Text Editor Controls
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Placing Text Blocks

Before starting to type into a text block, you can determine whether it will be a “breaking” or “non-breaking” 

text block.

• A breaking text block’s width remains fixed, with the line of text “breaking” automatically to the next line 

when it reaches the limit during input. 

• A non-breaking text block’s width depends on how much text you enter. Use a non-breaking text block if 

you are not sure in advance how long the text will be.

To place a breaking text block:

1. Choose the Text tool.

2. Draw a rectangle to define the text block width.

A Text Editor window and a Formatting Palette appear on the screen.

For more information, see Formatting Palette and Text Editor Controls.

3. Type the desired text into the Text Editor. 

Note: The style and formatting of a newly placed Text Block depend on the settings in the Text Settings 

dialog box and Info Box. If you want different style or formatting for particular characters or paragraphs 

you are typing, use the Formatting Palette.

– In addition to typing in text, you can use the controls of the Text Editor to add the following predefined 

items to the text block

- Autotext

- Favorites

- Symbols: Click this button to access a Character Map (Character Palette on Mac) to choose and 

insert a symbol.

– Once you reach the end of the text block, additional text will be automatically entered on the next line.
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– You can start a new line at any time by hitting the Return key on your keyboard.

– Click Cancel (Control Box) to cancel the text editing operation.

4. To complete the Text box, do one of the following

– click on an empty space in the window

– click OK in the Control Box

– press Ctrl-Enter (Cmd-Enter).

To place a non-breaking text block:

1. Choose the Text tool.

2. Double-click in the view. An editing window and a formatting palette appear on the screen.

3. Type the desired text into the Text Editor. 

– The text block will extend indefinitely as long as you keep typing.

– Start a new line by pressing Enter.

–

4. To complete the Text box, do one of the following

– click on an empty space in the window

– click OK in the Control Box

– press Ctrl-Enter (Cmd-Enter).
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Formatting Text Blocks As a Whole

Use Text Settings and the Info box to format the Text Block as a whole.

See Text Tool Settings.

To open Text Tool Settings: Double-click the Text tool. The dialog box has two panels:

• Text Style Panel: These settings apply to the appearance of your text characters.

• Text Block Formatting Panel: These settings apply to the shape and appearance of the text block.

To stretch a Text Block, select it and reshape it using any of its corner nodes. A rubber band box provides 

feedback as you stretch; the text in the block will automatically rearrange itself according to the new outline.
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Resizing Text Graphically

You can change the size of the text inside the text block using a Stretch technique. Select the text block and 

stretch it with either the Stretch menu command or the pet palette. Move the cursor along the text block’s 

diagonal, and press the Shift key to constrain it to the diagonal.

With Shift still pressed, click to define the new size. The font size will grow or shrink proportionally.
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Applying Favorite Text Settings

To apply Favorite settings to the entire text block:

Select the text block, then do one of the following:

• Switch to a Favorite in Text Settings, and click OK

• Double-click the desired Favorite from the Favorites palette

Note: Favorites of the Text tool can be applied to the text-type items in the following elements:

• Dimensions

• Labels

• Fill Text

• Section/Elevation, Interior Elevation

• Detail, Worksheet

• Story Level Markers

• Grid

• Door/Window Markers

• Drawing Title

• Zone Stamp

See also Favorites.
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Formatting Individual Components of Text Blocks

To format individual characters, lines and paragraphs that have been typed into your text block, or to switch 

styles while typing, use the Formatting Palette and the indent/tab controls of the Text Editor.

The Text Editor and Formatting Palette appear as soon as you click on the Floor Plan (with the Text tool 

active) and begin typing into the text box.

The controls of the Formatting Palette and Text Editor apply only to the text you are entering in the Text Editor, 

or to selections inside the Text Editor.

See Formatting Palette and Text Editor Controls.

Note: Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill 

Text.
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Autotext

An Autotext is a text element containing a definition filled in automatically by the program. After you insert an 

Autotext definition, the program will fill in the data that apply in the current context. This data - which can be 

text, a numerical value, or element-specific parameters - is automatically updated in accordance with the 

changes made to the model, layout or drawing.

You can add Autotext:

• in any window where the Text tool is active

• as part of the Text/Autotext Label

• in GDL objects, including Markers

• in the folder/item name fields of Publisher items

• as part of the ID of Interior Elevation viewpoints

The style of the Autotext can be formatted the same way as for any manually typed text.

Related Topics:

How to Insert Autotext

Autotext Reference Drawing

Autotext Keywords

Text/Autotext Label Content
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How to Insert Autotext

1. Activate the Text tool 

2. Click on screen. The Formatting Palette and Text Editor appear.

3. Do one of the following:

– Click the Insert Autotext button in the Formatting Palette

– Right-click at the insertion point in the Text Editor and choose the appropriate command from the 

Insert Autotext hierarchical menu:

4. Choose one or more Autotext items. Double-click, or click Add to add them to the Text Editor.

If the information is already available, the appropriate text will appear in the Text Editor after you have 

selected it.
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If the referenced information is not available, you will see a placeholder text.

When the missing information becomes available, the placeholder text is immediately updated with the 

relevant data.

You can add any number of Autotexts, and type additional static text, in the same text block.

The current Text Settings will be applied. To format individual characters or parts of text within a text block, 

use the controls of the Formatting Palette and Text Editor.

See Formatting Palette and Text Editor Controls.

Autotext Sources

There are several sources of Autotext:

Project-specific information such as the name of the project (not necessarily the same as the file name), the 

name of the architect, the date of Transmittal Set or any other piece of information entered in the File > Info > 

Project Info dialog box.

See also Project Info.

• Layout-specific information such as the name or ID of the layout, the name or ID of the subset, the number 

of layouts in the layout book.

• Drawing-specific information including the name, drawing scale and magnification factor of the drawing.

• Information that comes from a specified drawing (one which you define as an Autotext Reference 

Drawing.

See also Autotext Reference Drawing.

• System-dependent information (file name, path, date of creation and modification, etc.).

Adding Autotext to GDL Objects

You can use Autotext when scripting GDL objects.

For example, if you use a GDL object-type Title block placed on a Master Layout, you can script the Title block 

to show the Project Name.

In a GDL script window, the Text Editor interface (with its lists of Autotext entries) is not available, so you must 

use the corresponding formatting codes.

For a list of Autotext keywords for use in GDL scripts, see Autotext Keywords.
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Autotext Reference Drawing

ARCHICAD lets you set a particular drawing as an Autotext reference. This means that your Autotext does not 

necessarily have to refer to the view or layout onto which you are placing the text.

To set a drawing as Autotext reference:

1. Select a drawing in the Navigator or Organizer or on the layout.

2. Right-click to display a context menu and choose the Set as Autotext Reference command. (The same 

command is also available from the Drawing Manager.)

Once defined as an Autotext Reference, this drawing will appear as a choice in the Insert Autotext list.

See How to Insert Autotext.

The Autotext entries that use the Reference as source will then show values based on the reference drawing.
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If you later define a different drawing as Autotext Reference, earlier Autotexts referring to the original drawing 

will remain unchanged.
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Autotext Keywords

The following Autotext Keywords are available when using the Autotext commands.

Use the keywords in the right-hand column to insert Autotext items into GDL scripts.

To show this Autotext: Type this Keyword

Project Details

Project Name <PROJECTNAME>

Project Description <PROJECT_DESCRIPTION>

Project ID <PROJECT_ID>

Project Code <PROJECT_CODE>

Project Number <PROJECTNUMBER>

Project Status <PROJECTSTATUS>

Keywords <KEYWORDS>

Notes <NOTES>

Project Custom created dynamically

Site Details

Site Name <SITE_NAME>

Site Description <SITE_DESCRIPTION>

Site ID <SITE_ID>

Site Full Address <SITEFULLADDRESS>

Site Address1 <SITEADDRESS1>

Site Address2 <SITEADDRESS2>

Site Address3 <SITEADDRESS3>

Site Postal Box <SITEPOSTBOX>

Site City <SITECITY>

Site State <SITESTATE>

Site Postcode <SITEPOSTCODE>

Site Country <SITECOUNTRY>

Site Gross Perimeter <SITEGROSSPERIMETER>

Site Gross Area <SITEGROSSAREA>

Site Custom created dynamically

Building Details

Building Name <BUILDING_NAME>

Building Description <BUILDING_DESCRIPTION>

Building ID <BUILDING_ID>

Building Custom created dynamically
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Contact Details

Contact Full Name <CONTACT_FULLNAME>

Contact Prefix Title <CONTACT_PREFIXTITLE>

Contact Given Name <CONTACT_GIVENNAME>

Contact Middle Name <CONTACT_MIDDLENAME>

Contact Family Name <CONTACT_FAMILYNAME>

Contact Suffix Title <CONTACT_SUFFIXTITLE>

Contact ID <CONTACT_ID>

Contact Role <CONTACT_ROLE>

Contact Department <CONTACT_DEPARTMENT>

CAD Technician Full Name <CAD_TECHNICIAN_FULLNAME>

CAD Technician Prefix Title <CAD_TECHNICIAN_PREFIXTITLE>

CAD Technician Given Name <CAD_TECHNICIAN_GIVENNAME>

CAD Technician Middle Name <CAD_TECHNICIAN_MIDDLENAME>

CAD Technician Family Name <CAD_TECHNICIAN_FAMILYNAME>

CAD Technician Suffix Title <CAD_TECHNICIAN_SUFFIXTITLE>

Contact Company <CONTACTCOMPANY>

Contact Company Code <CONTACT_COMPANYCODE>

Contact Full Address <CONTACTFULLADDRESS>

Contact Address1 <CONTACTADDRESS1>

Contact Address2 <CONTACTADDRESS2>

Contact Address3 <CONTACTADDRESS3>

Contact Postal Box <CONTACTPOSTBOX>

Contact City <CONTACTCITY>

Contact State <CONTACTSTATE>

Contact Postcode <CONTACTPOSTCODE>

Contact Country <CONTACTCOUNTRY>

Contact E-mail <CONTACTEMAIL>

Contact Phone Number <CONTACTPHONE>

Contact Fax <CONTACTFAX>

Contact Web <CONTACTWEB>

Contact Custom created dynamically

Client Details

Client Full Name <CLIENT_FULLNAME>

Client Prefix Title <CLIENT_PREFIXTITLE>

Client Given Name <CLIENT_GIVENNAME>

To show this Autotext: Type this Keyword
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Client Middle Name <CLIENT_MIDDLENAME>

Client Family Name <CLIENT_FAMILYNAME>

Client Suffix Title <CLIENT_SUFFIXTITLE>

Client Company <CLIENTCOMPANY>

Client Full Address <CLIENTFULLADDRESS>

Client Address 1 <CLIENTADDRESS1>

Client Address 2 <CLIENTADDRESS2>

Client Address 3 <CLIENTADDRESS3>

Client Postal Box <CLIENTPOSTBOX>

Client City <CLIENTCITY>

Client State <CLIENTSTATE>

Client Postcode <CLIENTPOSTCODE>

Client Country <CLIENTCOUNTRY>

Client E-mail <CLIENTEMAIL>

Client Phone Number <CLIENTPHONE>

Client Fax <CLIENTFAX>

Client Custom created dynamically

Layout

Approved by <LAYOUTCUSTOMPAR6>

Checked by <LAYOUTCUSTOMPAR5>

Comment <LAYOUTCUSTOMPAR3>

Layout ID <LAYOUTID>

Layout Name <LAYOUTNAME>

Layout Number <LAYOUTNUMBER>

Layout Number in Current Transmittal 

Set

<LAYOUTNUMBERINCURRENTISSUE>

Layout Number in Subset <LAYOUTNUMBERINSUBSET>

Modified by <LAYOUTCUSTOMPAR4>

Number of Layouts <NUMOFLAYOUTS>

Number of Layouts in Current Transmittal 

Set

<NUMBEROFLAYOUTSINCURRENTISSUE>

Status <LAYOUTCUSTOMPAR1>

Status Code <LAYOUTCUSTOMPAR2>

Subset ID <SUBSETID>

Subset Name <SUBSETNAME>

Layout Revision

To show this Autotext: Type this Keyword
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Current Revision ID <CURRENTREVISIONID>

Current Revision Transmitted By <CURRENTTRANSMITTEDBY>

Current Revision’s Transmittal Set Date <CURRENTTRANSMITTALSETDATE>

Current Revision’s Transmittal Set ID <CURRENTTRANSMITTALSETID>

Current Revision’s Transmittal Set Name <CURRENTTRANSMITTALSETDESCRIPTION>

Drawing

Drawing ID <DRAWINGID>

Drawing Name <DRAWINGNAME>

Drawing Scale <DRAWINGSCALE>

Magnification <MAGNIFICATION>

Original Scale <ORIGINALSCALE>

Renovation Filter <RENOVATIONFILTER>

Reference Available if a Drawing has been defined as the Autotext Reference 

Drawing. See Autotext Reference Drawing.

Drawing ID ref. <DRAWINGID_R>

Drawing Name ref. <DRAWINGNAME_R

Drawing Scale ref. <DRAWINGSCALE_R>

File Name ref. <FILENAME_R>

File Path ref. <FILEPATH_R>

Layout ID ref. <LAYOUTID_R>

Layout Name ref. <LAYOUTNAME_R>

Layout Number ref. <LAYOUTNUMBER_R>

Magnification ref. <MAGNIFICATION_R>

Original Scale ref. <ORIGINALSCALE_R>

Renovation Filter ref. <RENOVATIONFILTER_R>

Subset ID ref. <SUBSETID_R>

Subset Name ref. <SUBSETNAME_R>

System autotexts Note: File-dependent system autotexts will be undefined until you 

save your project file at least once.

Date (Long) <LONGDATE>

Date (Short) <SHORTDATE>

Day of Month <DAYOFMONTH>

Day of Week <DAYOFWEEK>

File Name <FILENAME>

File Path <FILEPATH>

Last saved at <LASTSAVEDAT>

To show this Autotext: Type this Keyword
ARCHICAD 24 Reference Guide 2114



Annotation Documentation
Note: Your Drawing Scale, if you customize it in Drawing Settings, is distinct from its Original Scale (the 

scale of the Drawing’s source view).

Last saved by <LASTSAVEDBY>

Month (name) <MONTHNAME>

Month (number) <MONTHNUMBER>

Time <TIME>

Year (short) <YEARSHORT>

Year (long) <YEARLONG>

Other Autotexts These are available in the Rename Publisher Items dialog box 

only. See Rename Publisher Items.

Folder Name <FolderName>
(Renames the item using the folder name in which it is located)

Folder Structure Name <FolderStructureName>
(Renames the item using the entire folder path of the item’s 

location in the Publisher Set)

Publisher Set Name <PublisherSetName>

Source Item ID <SourceID> 
(Renames the item using View ID or Layout ID, depending on the 

source of the Publisher item.)

Source Item Name <SourceItemName> 
(Renames the item using View Name or Layout Name, depending 

on the source of the Publisher item.)

To show this Autotext: Type this Keyword
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Labels

An element can have any number of Labels.

ARCHICAD comes with a set of built-in Labels, with highly customizable content. 

You can also create your own Label by saving 2D drawing elements, including Autotext.

See Save 2D Elements as Label.

Label Geometry Methods: Associative and Independent

 There are two ways to place a label with the Label tool:

• Associative labels are placed by clicking an element. The label remains associated to the element even 

after you move or modify the element. As applicable, any parameter values are automatically updated in 

the label.

Associative Label

Notes:

– If you delete an element, its associated labels are also deleted.

– By default, a Label will be hidden if its associated element is hidden (e.g. on a hidden layer). To 

display the Label regardless of whether its associated element is visible, uncheck “Hide with 

Associated Element” in Label Tool Settings.

– Multi-story elements must be labeled on each story separately.
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• Independent labels are not associated to any element. Typically, you will use an independent label to 

display information that does not come from the model (e.g. “install snow picks here”).

Independent Label

Watch the Video

Label Placement Methods: Simple and Detailed

• The Simple method places the Label with one click, using the arrowhead and pointer line type/starting 

angle (if activated) as defined in the Info Box or Label Settings.

Simple Placement

• The Detailed method requires three clicks (or two, if the pointer line’s starting angle is locked), giving you 

more control over pointer line placement.

Detailed Placement

See Pointer Line for details on Pointer Line settings.

See also Edit Text Box.

Related Topics:

Place an Associative Label

Place an Independent Label

Convert Associative Label to Independent Label

Label Tool Settings

Text/Autotext Label Content

Symbol Labels for Element Information

Custom Settings for Symbol Labels

Label Multiple Selected Elements

Labeling Curtain Walls

Labeling Stairs

Search for Elements by Label Text

Find and Select Text Blocks/Labels

Save 2D Elements as Label

Watch the Video
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Place an Associative Label

1. Activate the Label Tool.

2. Make sure its Geometry Method is set to associative in the Info Box (this is the default setting): 

3. In Label Settings or the Info Box, choose the label type you wish to use.

4. Move your cursor to the element you wish to label. Highlighted feedback lets you know which element will 

be labeled. 

If your cursor is hovering over multiple elements, the Info Tag prompts you to click Tab to cycle through the 

elements. 

5. When the desired element is highlighted, click to place the label.

Note: Depending on the Label type and its Placement method, this will require one or more clicks. 
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Related Topics:

Text/Autotext Label Content

Label Multiple Selected Elements

Symbol Labels for Element Information

Custom Settings for Symbol Labels
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Text/Autotext Label Content

In this example, the default Text/Autotext Label contains the labeled element’s Hotlink ID (if any) and Element 

ID.
ARCHICAD 24 Reference Guide 2120



Annotation Documentation
Change Default Content of Text/Autotext Label

1. In Default Label Settings, go to the Text Label panel and click Clear Text to delete whatever text is 

currently the default.

2. Place the (empty) Text/Autotext Label in the project.

3. In the Text editor, type in the desired label text, including Autotext as needed. For example, type in “Fire 

Rating:”, followed by the Autotext entry for Fire Resistance Rating. This way, you can create simple text 

labels that display associative data about the element they are attached to.

See How to Insert Autotext.

4. Click to place the Label.

5. Do one of the following:

– Use the Pick Up Parameters command or shortcut (Alt+Click) on the Label to make it the default.

– Save the Label as a Favorite: the text in the Label Text field is saved as part of the Favorite. Use the 

Favorite to place Labels with a predefined text. (See Create New Favorite.)

To set up the Pointer or Leader line and its connection to the Text box, use the Pointer Panel of Label Settings.

See Pointer Line.

To format individual characters, lines and paragraphs in your label text block, or to insert text symbols, use the 

controls of the Formatting Palette and Text Editor.

Note: Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill 

Text.

See Formatting Palette and Text Editor Controls.

Watch the Video
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Symbol Labels for Element Information

Symbol Labels can display all kinds of element information on the drawing, for example the skins of a 

composite Wall.

Symbol Labels are GDL objects. Along with Text/Autotext Labels, they are available from the Label Tool pop-

up and Label Tool Settings.
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The following are the standard Symbol Labels available in the ARCHICAD INT Library. Labels provided in 

other localized ARCHICAD libraries may vary, to meet local standards.

Classification and Properties Label Element parameters

Classification and Properties

IFC Properties

Component Classification and 

Properties Label

Classification and Properties of Element Components

Composite or Profile Name Element / Hotlink ID

Dimension Label Dimensions

Area

Volume

Door Window Stamp Element/Hotlink ID

Dimensions

Surfaces 

Elevation Label Elevation dimensions

Generic Label Element / Hotlink ID

Name

Elevation dimensions

Dimensions

Area

Volume

Skin list

Composite / Profile / Bldg Material name

Surfaces

Opening Label Door/Window ID

Dimensions

Properties

Property Label Element / Hotlink ID

Name

Property values

Skin List Label Building Material properties

Element / Hotlink ID

Dimensions

Skin list
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See also Labeling Curtain Walls.

Watch the Video

Watch the Video

Watch the Video

See also Select Surface (for Surface Label).

Not every label can be placed on every element type. For example, if you inadvertently attach a Door Window 

Stamp to a Column, a “placeholder” text will inform you of the mistake.

Note: For each label, Custom Label Settings provides information on which element types it can be 

applied to.

For more details, see Custom Settings for Symbol Labels.

You can also create your own Label by saving 2D drawing elements, including Autotext.

See Save 2D Elements as Label.

Stair Description Label Dimensions

Parameters

Stair Dimension Label Stair-Specific Dimensions (Width, Riser Height, Going 

Depth, Number of Risers)

Surface Label Surfaces
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Custom Settings for Symbol Labels

Each Symbol Label has a Custom Settings panel in the Label Tool Settings dialog box. The parameters are 

divided among 3-5 tab pages, as shown here:

Use these tab pages to set preferences for label content, positioning and format. 

Note: Not every tab page is available for every label type.

• To make repositioning easier, many labels have a reference point, which remains in place even after you 

change the label size or content.

• Many labels have several header formats available, and the leader line can be turned off, where 

applicable.

Most of the settings are self-explanatory. The following sections contain some additional tips for using these 

controls:

Define Content of Symbol Label

Defining Dimension Units in Labels

Select Surface (for Surface Label)

Label Frame Shape

Pointer Line vs. Leader Line

Information Tab Page
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Define Content of Symbol Label

Use the Content Setup tab page to define the information displayed in the label.

For the Generic and Dimension labels, the available element types - and therefore the list of possible 

parameters - is very extensive, and the Content Setup tab page looks like this:

Since you can attach the label to different element types, the label content may vary, depending on which 

element it is attached to.

• Show parameters for the following tools: This control filters the content list in the bottom part of the 

dialog box. Select the tool(s) whose element parameters you want to choose from. (By default, all tools 

are selected.) The more tools you select, the greater the number of available parameters.

Note: If a particular tool is not selected in the “Show parameters for” section, you can still place this label 

on such elements, provided the element has a value that can be displayed by the label. 

• Define Label Content: Select the parameters whose values you want to display in the label.

– If you don’t see a tool-specific parameter in the list, make sure that the corresponding tool icon is 

selected in the “Use with” section above.

– Parameters shown with the circle marking are not relevant for one or more of the selected element 

types (in the “Use With” section). Thus, label content might vary, depending on the element type to 

which it is attached.
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Defining Dimension Units in Labels

When specifying dimension units for label display, many labels include the option “By Project Preferences”. 

This means the dimension will be displayed in the units defined for it at Options > Project Preferences.

• For volume dimension data shown in labels, set the units at Options > Project Preferences > 

Calculation Units and Rules.

• For all other dimension data shown in labels, set the units at Options > Project Preferences > 

Dimensions, using the relevant dimension type options. See Choose Dimension Type.

Select Surface (for Surface Label)

The Surface Label displays the name of the element’s selected surface. You must first select the particular 

element surface in Label Settings:

Watch the Video

Label Frame Shape

For labels having a frame, you can select among different shapes.
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Set this option in the Custom Settings panel, in the Label Frame Style or the Label Geometry tab page.

The Frame Shape control is only available if you have activated a Frame, in the Text Style panel (as shown 

below).

Watch the Video

Watch the Video
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Pointer Line vs. Leader Line

If you have activated a Label’s Pointer Line, in the Pointer Panel, then these Pointer Line settings will prevail 

(the Label will not use the Leader Line defined on the Custom Settings panel.)

If you are not using the Pointer Line (the Pointer button is off), then the Leader Line (defined in the Custom 

Settings panel) will be used. The line and pen settings of the Leader Line are also set on the Pointer Panel.

Related Topic:

Pointer Line
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Information Tab Page

This is an information-only page. It shows which element types the selected Label is available for.
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Label Multiple Selected Elements

To place multiple labels with one click:

1. Select the elements you wish to label.

2. Choose Document > Annotation > Label Selected Elements.

The current default label is attached to all selected elements.

 

ARCHICAD 24 Reference Guide 2131



Annotation Documentation
Labeling Curtain Walls

Like any other element, you can label a Curtain Wall or any of its visible members individually, on the Floor 

Plan as well as in Section view.

Curtain Wall with ID Label

Curtain Wall Frame with ID Label
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Curtain Wall Panel Label

Label All Curtain Wall Members

If you need labels on all Members, or all of a certain class of Members:

1. Select the Curtain Wall.

2. Click Document > Annotation > Label Components of Selected Elements to bring up the dialog box.

3. From the pop-up, choose a Label Type: the current default Label, or any of the Label Favorites.
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4. Check the boxes of all the component types to which you would like to attach a Label. The Labels will be 

associative.

5. Click Label to place.
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Labeling Stairs

Stair Description and Stair Dimension Labels

These symbol-type Labels are available from Label Tool Settings.

Related Topic:

Symbol Labels for Element Information

Label Stair Components

1. Select the Stair.

2. Click Document > Annotation > Label Components of Selected Elements to bring up the dialog box.

3. From the pop-up, choose a Label Type: the current default Label, or any of the Label Favorites.

4. Check the boxes of all the component types to which you would like to attach a Label. The Labels will be 

associative.

Related Topic:

Level Dimensions
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5. Click Label to place.
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Place an Independent Label

1. Choose Independent Label from the pop-up options in the Label Info Box:

2. In Label Settings or the Info Box, choose the label type you wish to use. (See also Text/Autotext Label 

Content.)

3. Choose a preferred Label Placement Method. (See Label Placement Methods: Simple and Detailed.)

4. With the Label Tool active, click anywhere in the workspace to place the independent label.

Convert Associative Label to Independent Label

1. Select the associative label.

2. From the context menu, choose Convert to Independent Label.
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Search for Elements by Label Text

You can use the Find & Select function to select elements depending on the text content of their associated 

labels.

See also Find and Select Elements.

1. In the Find & Select dialog box, choose the Element type you wish to find.

2. As the next criterion, choose “Label Text.”

3. As the value, enter any desired text string.

Click the Plus button to execute the Find & Select function. All Elements whose associated Label text matches 

or contains the entered text will be selected.
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Find and Select Text Blocks/Labels

Use the Find & Select function to locate text blocks or label texts whose content matches or contains any 

given text string.

See Find and Select Elements.

1. In the Find & Select dialog box, choose either Text or Label as the Element criterion.

2. As the next criterion, choose “Text Content.”

3. As the value, enter any desired text string.

– to find and select text fragments, choose “contains.”

– to find exact text matches, choose “is.”

4. Click the Plus button to execute the Find & Select function. In this example, all Text Blocks or Labels in 

the active window which contain the entered text will be selected.

See also Search for Elements by Label Text.
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Text Editing in ARCHICAD

Search and Replace Text

Spell Checker

Editing Commands in Text-Type Windows

For information on placing and editing Text Blocks using ARCHICAD’s dedicated Text tool, see Text Blocks.
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Search and Replace Text

The Search and Replace Text function is available for the following text-type elements in ARCHICAD:

• Text blocks placed with the Text tool

• Labels

• Dimensions

• Zone Stamps

• Parameters of GDL Objects

Go to Edit > Search and Replace Text. Use this function to search texts in all eligible element types. It works 

on the Floor Plan and in Section/Elevation/IE, and Detail and Worksheet windows. It does NOT work for 

Autotext items.

See Search and Replace Text Dialog Box.

Note: The Search and Replace text function is not available for text-type windows. (Text-type windows 

include all Listing windows created with the Calculation function, GDL script windows, Project Notes, and 

Report windows.) In text type Windows, the Find & Replace command offers similar functions.

For more information, see Editing Commands in Text-Type Windows.
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Spell Checker

The Document > Annotation > Spell Checker command allows you to check the spelling of your 

ARCHICAD project. 

Note: Spell Checker is not available for text-type windows.

See Editing Commands in Text-Type Windows.

On Windows, Spell Checker uses Microsoft Word’s Spelling Check, which means that you must have 

Microsoft Word installed on your computer together with the dictionary of the language you are using. In 

Microsoft Word, use File > Options > Language to set your desired preferences.

On Mac, Spell Checker uses MacOS system preferences. Set these at System Preferences > Language & 

Region.

ARCHICAD’s Spell Checker will use these preferences.

Warning: Spell Checker relies on Microsoft technology. ARCHICAD can only locate Word’s Spell Checker 

if its pointer is correctly written in the Windows Registry. If you have properly installed Microsoft Office, 

Spell Checker will work without any problem. If you have manually modified the location of Microsoft 

Word, ARCHICAD will not be able to use its spell checking features. Moreover, the Spelling commands 

must be installed with Word.
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Editing Commands in Text-Type Windows

Text-type windows include all Listing windows created with the Calculation function, GDL script windows, 

Project Notes, and Report windows.

Only a single editing step can be undone/redone in a text-type window.

When a text-type Window is active, most of the Edit menu commands change in order to provide you with 

basic word processing features.

Note: Search/Replace Text and Spell-check do not work for text-type windows.

The Text Style command opens a dialog box determining how your text will look both on screen and for 

printing.

The commands in the bottom section apply to GDL scripts, and are active only if a GDL script window is 

active.

For more information, see Text Editing Commands in GDL Script Windows.
ARCHICAD 24 Reference Guide 2143



The Layout Book Documentation
The Layout Book

Each ARCHICAD project file includes a Layout Book whose content is displayed in a tree structure in the 

Layout Book Map of the Navigator or Organizer Palette. 

Click the Layout Book map in the Navigator or Organizer to access the project’s Layout Book. 

In the Layout Book, you can organize Layouts into subsets (represented by folders). Every Layout is 

associated with a Master Layout that defines its size and some other attributes. This helps automate such 

tasks as the inclusion of a company logo.

Layout Book View Formats (Navigator Palette/Organizer)

In the Navigator Palette/Organizer only, you can view the Layout Book in three formats:

• Tree by Subset (the default display) lists layouts according to the Subsets you have created - a freely 

defined logic. (The primary function of Subsets is to enable you to assign a customized numbering 

system.) The Tree also shows the names of the drawings that belong to each Layout.

See Subsets.
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• Tree by Master lists the Layouts according to their Master Layouts.

• Tree by current Transmittal Set lists only the Layouts that have been added to the latest Transmittal Set.

See also Revision Management.

Moving Layout Book Items

You can move and rearrange elements using the drag and drop technique to:

• Create hierarchical Subsets

• Move a Layout from one Subset to another

• Apply a Master Layout to a Layout

• Move a Drawing from one Layout to another Layout
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Note: In this case, the proportionate distance of the Drawing from the Layout origin remains unchanged.

While you are editing the elements of your Layout Book, the Navigator or Organizer palette keeps track of 

which element you are working on.

• Elements selected within the Navigator will be highlighted.

• When you move over and work in the Layout window, the highlight changes to a box.

Important: Operations involving Navigator/Organizer items (such as drag and drop between Navigator 

maps, deleting items from a map, or adding items to the Publisher set) are not added to the undo queue, 

and are not undoable.

Settings and Commands of Layout Book Items

To access the settings and related commands of any item of the Layout Book:

• Use context menu of the selected Layout Book item

• Select it in the Organizer or Navigator Palette, then click the Settings button at the bottom of the 

Properties section

• Use the command buttons of the Navigator Palette/Organizer. These are active or grayed depending on 

the item selected in the Layout Book (Layout Book, Subset, Layout, Drawing, or Master Layout):
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– New Layout

– New Master Layout

– New Subset

– Update: Updates the status of the selected Drawing (or the Drawing(s) on the selected Layout).

– Delete selected item

• Use commands of the Document > Layout Book menu 

Note: Another way to gain an overview of Layouts or Drawings in your project, or to sort them by criteria, 

is the Project Index function.

See Project Indexes.

Layout Book Properties (Navigator Palette/Organizer only)

Select an item (Layout Book, Subset, Layout, Master Layout or Drawing, or any folder) in the Layout Book to 

view its Properties in the Properties section below.

Layout Book Properties include the Project Name and Path are shown in read-only fields.

Subset Properties include the Subset ID and Subset name. These properties are editable.

Layout Properties include:

• the Layout ID and Layout Name. These properties are editable.

• the Master Layout assigned to this Layout. Use the list to assign a different Master Layout if needed.

• the Size of the Layout.

• the Layout’s latest Layout Revision number and the name of the Transmittal Set it belongs to (if any).

Drawing Properties include:

• Drawing ID and Drawing Name. These properties are editable.

• the Path of the source of the Drawing

• the Drawing Scale and the Drawing Size
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Work Environment for the Layout Phase

ARCHICAD allows you to fit your work environment to the tasks and skills required for the current phase of the 

project development. This means that you can choose a dedicated Work Environment Profile (Layouting), 

which concentrates only on the features that you currently need for constructing the layout book.

When a Layout window is active, only the relevant menu commands and tools are available.

Note for ARCHICAD 9 users: ARCHICAD 9 included PlotMaker as a stand-alone application to handle 

layouts and documentation. As of ARCHICAD 10, these functions are all integrated into ARCHICAD. 

You may wish to activate the Layouts and Drawings toolbar (from Window > Toolbars) to have quick 

access to frequently used commands.

When the Layout Book is active, you can assign a separate pen set applicable to the Layout Book only. When 

defining these attributes, the Options > Pens and Colors command indicates that these attributes apply to 

elements placed on layouts in the Layout Book, rather than for the project’s Model Views.

There is a single Layer set for the entire Virtual Building, but you can define separate layer settings for the 

Layout Book and for Model views.

Note: Layer settings for the Layout Book serve to show/hide elements directly placed on layouts, such as 

lines, texts and drawings as a whole. Layout Book layers do not affect the drawing content, which is 

determined by the layers of its associated view.
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Working with Layouts

Open a Layout

To open a particular layout in a new tab or Layout Window, do one of the following:

• Double-click its name Navigator Layout Book or the Organizer palette’s Layout Editor.

• Click the Layout’s name from the Window menu

• Click the Open Layout command from the Layout drop-down in the Mini-Navigator Toolbar. Activate the 

desired Layout from the appearing Open Layout list.

(To open a Layout in the same tab or window as the open one, select the Layout in the Navigator and choose 

Open from the context menu.)

The contents of the layout windows are saved with the project.

• The white area represents the usable print area of the paper delimited by a blue frame.

• The gray area represents the non-printing area (margins) of the paper.

The displayed size and the margins of the Layout are defined by the Master Layout.

See Master Layouts.

When printing the Layout, you can fit it to the actual paper size used by the device, with the Fit to Page 

control of the Print Layout dialog box.

See Print Layout.

You can place, arrange and transform drawings in the Layout window, and manually add 2D elements as well 

as Autotext items.

For more information, see Drawings in the Layout Book.

Navigate Among Layouts

To navigate sequentially among Layouts in the Layout Book:

• Click the Layout navigation arrows in the Quick Options Bar at the bottom of the Layout window. 

To access the Go to Layout command:

• Click the button showing the current Layout number.
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Create New Layout

To create a new Layout, do one of the following:

• Use the New Layout command from the context menu of any Layout Book item in the Navigator.

• Choose the Document > Layout Book > New Layout command. The new layout will be listed at the 

bottom of the Layout Book.

• Click the New Layout icon in the Navigator Palette or the Organizer

In the Navigator’s Tree by Subsets view, the new Layout will be listed directly underneath the currently 

highlighted element.

• If a Layout window is currently open, the new Layout will now be opened in its place.

• If a Subset is currently highlighted in the Navigator palette, the new Layout will be placed as the last 

element inside the Subset folder.

• If the Layout Book is currently highlighted in the Navigator palette, the new Layout will be placed as the 

last element in the Layout Book.

You can also create new Layouts automatically when placing and importing drawings.

See Drawings in the Layout Book.

Delete Layouts

You can delete any Layout in the Layout Book except the last one: the Layout Book must always contain at 

least one Layout.
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Master Layouts

The Master Layout is like a template which defines the size of the Layouts (pages) of the Layout Book. Each 

Layout is assigned a Master Layout.

The graphic and text items that you place on a Master Layout (“Master items”) will appear on every Layout 

that uses it as a template.

Master Layouts are found in the Masters folder of the Layout Book and can be given distinctive names.

ARCHICAD includes several predefined Master Layouts. You can use one of these predefined Master 

Layouts, or customize your own.

Most of these options are set in Master Layout Settings.

See Master Layout Settings.

Open a Master Layout

To open a Master Layout, double-click its name in the Layout Book.

By default, all Layouts and Master Layouts open in a new tab or window.

When you open a new layout or Master Layout, it can either replace the opened one, or be opened in a 

separate new tab. You can change this tab-opening preference in Options > Work Environment > More 

Options.

Default Master Layout

One of the Master Layouts will be applied by default to newly created Layouts. The default Master Layout is 

shown as dog-eared.

To change the default Master Layout for your Layouts:

Select the desired default Master Layout in the Navigator or Organizer, then do one of the following:

• From the context menu, choose Set as Default

• Open Master Layout Settings and check the Set as Default for New Layouts box.

Apply Master Layout

To apply another Master Layout to any Layout, do one of the following:

• Drag and drop any Master Layout onto the selected Layout
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• Drag and drop a Layout onto any Master Layout

• Select a Layout, then choose another Master Layout from the pop-up menu at the bottom of the Navigator 

Palette or in the Settings dialog box of the selected Layout.

Create New Master Layout

To create a new Master Layout, do one of the following:

• Use the New Master Layout command from the context menu of any item of the Navigator’s Masters 

folder.

• Choose the Document > Layout Book > New Master Layout command.

• Click the New Master Layout icon in the Navigator or the Organizer.

Master Layout Title Block

The default Master Layouts include commonly used title blocks which are composed of 2D drawing elements 

and text items, including Autotext. Autotext consists of special predefined text items automatically generated 

by the program.

See also Autotext.
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For example, the Title Blocks of the Master Layout template pictured below includes Autotext items for the 

Project Name, Drawing Name, Project Status and Layout ID, among others, as well as text items and a logo.

You can edit or create a title block by opening the Master Layout and using the 2D editing and text tools to add 

or modify the content.

Display of Master Layout Items

To assign a uniform color to all Master items, configure this at Options > Work Environment > On-Screen 

Options. Otherwise, Master items are displayed in their original colors.

To display Master items below or above the Layout, click your preferred option in the Name and Size panel of 

Master Layout Settings.

You can choose to hide the on-screen display of Master elements on all Layouts by turning off View > On-

Screen View Options > Master Items on Layout. This option also affects Master items on Layouts used as 

Traces.

If you show a Layout as Trace, all Master Layout items will be shown as part of the Trace.
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Subsets

A subset is a folder inside the Layout Book. Subsets allow you to easily organize your layouts and to define 

numbering rules for them. When working in the Navigator or Organizer, you can place any Layout into a 

Subset simply by dragging and dropping it into place.

If you create a new layout in the Organizer palette when right-clicking the name of a subset, it will be placed 

automatically in this subset. A Subset is indicated by a folder icon, with tick on it.

Subsets are not required; you can place a Layout into the Layout book without placing it into a Subset. 

However, subsets are useful in organizing large-scale projects with multiple sets of documentation. When 

assigning IDs to Layouts, you can reflect the subset hierarchy as part of the Layout ID system, to make it 

easier to find the right Layout when needed.

Subsets can be named upon creation and renamed in the Navigator palette Properties section.

For more information on IDs, see Layout and Drawing IDs.

When setting up the contents of a Publisher Set, you can add a shortcut to any Layout Book Subset: this 

means Publisher Set items are created which are linked to the Subset folder and to its contents. This means 

that any changes to the contents of the Subset in the Layout Book are also reflected in the contents of the 

Publisher Set.

See Add Items to Publisher Set.
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Drawings in the Layout Book

Drawings are ARCHICAD views and external files that have been placed onto a Layout.

Drawings can be created out of views from the current project file, or imported from external ARCHICAD 

project files. External drawing and picture files as well as PDF files can also be placed on the layout. All these 

placed items are collectively called Drawings.

Note: Drawings can also be placed into Model Views. (See Drawings in Model Views.)

You can customize the size, scale, title and framing options for your drawings in the Drawing Settings dialog 

box.

See Drawing Settings.

Topics in this section:

Placing Drawings Onto the Layout

Drawing Frame

Arranging Multiple Drawings on the Layout

Importing PDF Files As Drawings

Drawing Titles

Managing and Updating Placed Drawings
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Placing Drawings Onto the Layout

Drawings can be placed on layouts separately or collectively in the following ways.

Drag and Drop View onto Layout (Navigator Palette or Organizer)

Place Drawing from External Application

Place Drawing Using Layout Editor

Place Single Drawing Using the Drawing Tool

Save View and Place on Layout

Import View(s) from External ARCHICAD Project (Solo or Teamwork)

When placed, the Drawing’s size and Anchor Point are defined in Drawing Settings (Size and Appearance 

panel). 

Related Topics

Drawing Size and Appearance Panel

Drawing Frame
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Drag and Drop View onto Layout (Navigator Palette or Organizer)

With the Layout window active, go to the Navigator Palette or Organizer, and drag and drop one or several 

items (viewpoints, views or views originating from external ARCHICAD files) directly onto the layout. When 

added to a Layout, viewpoints are converted to views with their current settings. The newly created view is 

added to the View Map, and the newly placed Drawing is added to the Layout Book.

Note: When placing several items from the Navigator/Organizer simultaneously onto a Layout, the 

placement obeys the rules (such as “Auto Arrange”) set in the Drawing Placement section of Master 

Layout Settings.

Related Topics

Master Layout Settings

Access Views/Layouts from External ARCHICAD Project

Arranging Multiple Drawings on the Layout

Place Drawing from External Application

1. Use the File > External Content > Place External Drawing from File command.

2. From the appearing Place Drawing dialog box, select a drawing file from the file system. (The PDF 

format, many image formats, DXF and DWG are among the available formats.) Click Open.

3. Use the cursor to place the drawing in the ARCHICAD window.

To import only certain layers of DWG/DXF/or DWF drawings:

See “Enable Partial Open” at Open Options (DXF/DWG Translation Setup).

To show/hide the source layers of imported DWG drawings placed in ARCHICAD:

See Embedded Layers.

Use the controls in Drawing Settings to define the drawing’s appearance and behavior.

See Drawing Settings.

See also Importing PDF Files As Drawings.
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Place Drawing Using Layout Editor

In the Organizer’s Layout Editor, drag and drop viewpoints, views and external files from the appropriate 

hierarchy list on the left side into the Layout Book on the right side. (Or use the Place Drawing command on 

the left side of the Organizer.)

See Organizer Palette.

See also Access Views/Layouts from External ARCHICAD Project.

The placement of the drawings obeys the following rules:

• If you drop an item on the name of an existing layout, the drawing will be added to that layout.

• If you drop an item on the name of a subset or the Layout Book itself, the drawing will be placed on a new 

layout created automatically inside the subset (or at the topmost level of the Layout Book.

Use the controls in Drawing Settings to define the drawing’s appearance and behavior.

See Drawing Settings.

Place Single Drawing Using the Drawing Tool

With a Layout window active, activate the Drawing tool from the Toolbox, then click on the Layout.

From the appearing Place Drawing dialog box, choose one of the following options as the Drawing source:

• an internal view: The current project’s View Map is shown in the dialog box. Select a view, then click 

Place. (The properties of any selected view are displayed in the View Properties panel below.)

• Local file system: Click Browse to locate the Drawing file.

If you choose an ARCHICAD project file, the Place Drawing dialog box appears again, listing the View 

Map of the chosen project. Select a view, then click Place to place it on the active Layout window.

• BIMcloud: Click Browse. In the appearing Select Teamwork Project dialog box, choose the server and 

the project you need. The Place Drawing dialog box appears again, listing the View Map of the chosen 

project. Select a view, then click Place to place it on the active Layout window.
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Important: To access the server and its projects, your user name must be present on the Teamwork 

project’s User list.

See the BIMcloud User Guide for details.

Use the controls in Drawing Settings to define the drawing’s appearance and behavior.

See Drawing Settings.

Save View and Place on Layout

Note: This command not available in every localized ARCHICAD version.

With the Save view and place on Layout command, the new view will appear both in the View Map and in 

the Layout Book. 

The command is available:

• from the active window’s context menu

• from the view/viewpoint’s context menu in the Pop-up Navigator (in case of a view, the command is called 

simply Place on Layout) 

• from the Document menu

The layout window will become active (opening the most recently active Layout, or the first Layout in the 

Layout Book).

Click to place the drawing.

Import View(s) from External ARCHICAD Project (Solo or Teamwork)

Import from a solo ARCHICAD project

1. File > External Content > Place External Drawing

2. From the appearing dialog box, choose an ARCHICAD project (PLA or PLN).

3. Click Open.
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4. The Import views from ARCHICAD Project dialog box appears. Choose the view(s) to import and a 

method for adding them to the Layout Book.

5. Click Select. The views are added to the Layout Book.

Import from a Teamwork project

1. File > External Content > Place External Drawing from BIMcloud:

2. In the appearing Select Teamwork Project dialog box, choose the server and the project you need.

Note: To link a drawing from a Teamwork project, that source Teamwork project must have the same 

version number as the host project.

3. Click Select.

Important: To access the server and its projects, your user name must be present on the Teamwork 

project’s User list.

4. The Import views from ARCHICAD Project dialog box appears. Choose the view(s) to import and a 

method for adding them to the Layout Book.

5. Click Select. The views are added to the Layout Book.

Placing a view from another ARCHICAD project file will launch another instance of ARCHICAD.

Note: If you do not wish to launch ARCHICAD with each view placement, go to Options > Work 

Environment > More Options and check “Do not launch new instance of ARCHICAD.”

Once you have placed a view from an external ARCHICAD project file into the current one, the view map and 

Layout Book structure of this source file will be at your disposal in the Project Chooser, and you will be able to 

place additional drawings easily into the current project’s Layout Book.

Related Topics

BIMcloud User Guide

Import Views from ARCHICAD Project

Note on External Drawing Update (Drawing placed from BIMcloud)

Access Views/Layouts from External ARCHICAD Project
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Arranging Multiple Drawings on the Layout

You can arrange and manipulate placed Drawings on the Layout as needed. (Although you can place any 

number of ARCHICAD views on a Layout, you cannot embed views within each other.)

When placing multiple Drawings onto a layout, the Drawings will arrange themselves according to the 

Drawing Placement logic defined in Master Layout Settings.

If the layout is defined (in Master Layout Settings) as using the Auto Arrange feature, the drawings will be 

placed according to these definitions in Master Layout Settings.

Note: The default logic is “Auto Arrange.” If you are placing only a single drawing on the Layout, it will be 

placed in the center of the Layout.

For more information, see Auto Arrange New Drawings.

If the layout onto which you are placing the drawings uses a Grid for Drawing IDs, the drawings will be placed 

in the appropriate cells.

For more information, see Align and Assign Drawings to a Grid.
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Drawing Frame

Each placed Drawing has a Frame. Use it in two ways:

• Fit Frame to Drawing to include the full content of its source view

• Manually Resize the Frame to limit the visible content (and optionally crop it out)

Why Crop the Drawing Content?

If you resize a Drawing Frame, you can optionally crop out the unseen Drawing content and delete it from the 

Drawing cache. Cropped content no longer has to be checked or refreshed (until it is restored). Thus, 

cropping Drawing content reduces file size and can speed up Drawing update.

Frame editing and Drawing crop features work the same for all types of Drawings, including those with an 

external source.

Cropped content can be restored at any time, as long as its source remains available.

Topics in this section:

Fit Frame to Drawing

Resize Frame and Crop Content

Restore Cropped Content

Crop Drawing(s) to Frame Command

Uncrop Drawing(s) Command
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Fit Frame to Drawing

By default, the Drawing Frame fits to the full Drawing content: the Fit Frame to Drawing control is active, in 

Drawing Settings or Info Box.

This Drawing Frame is shown with a solid line: it is not cropped.

Fit Frame to Drawing (Solid Line)

Resize Frame and Crop Content

1. Select any edge of the Frame and use pet palette editing commands to modify it.

2. The Manually resized frame button is now activated (in Drawing Settings or the Info Box).

3. By default, Crop Drawing to Frame is also checked: as you resize the Frame, the Drawing content is 

cropped accordingly. 

The Drawing Frame of a cropped Drawing is shown with a dotted line. 
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Cropped content can be restored at any time, as long as its source remains available. (see below)

Cropped to Frame (Dotted Line)
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Restore Cropped Content

On a selected cropped Drawing:

1. Drag the Frame to the desired position.

2. The cropped content is indicated by the shaded area. The Update to Frame command appears.

3. Click Update to Frame. The masked (cropped) drawing content is now restored.

4. If you continue editing the Frame, the command changes to Full Update.

– Click Full Update to update the full Drawing content in the background. All of the masked-out content 

is now displayed, so you do not have to keep updating while you edit the shape of the Frame.
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 Crop Drawing(s) to Frame Command

For a selected Drawing with a Manually resized Frame, which is not cropped:

Use the Crop Drawing(s) to Frame command from: 

• Context menu of the Drawing or the Drawing’s Navigator item

• Context menu of the Layout tab

• Info Box

• Document > Drawings menu

• Drawing Settings (Frame panel)

The Drawing status is now Cropped (as shown in the Info Box and Drawing Manager.) Any Drawing content 

that falls outside the current extent of the Frame is deleted from the Drawing cache.

The Drawing Frame of a cropped Drawing is shown with a dotted line. 

Note: Cropped status can be set as the Drawing Tool default, in Drawing Settings or the Info Box. 

Uncrop Drawing(s) Command

For any selected, cropped Drawing(s): 

Use the Uncrop Drawing(s) command from: 

• Context menu of the Drawing, or the Layout tab

• Info Box

• Document > Drawings menu

• Drawing Settings (Frame panel): Uncheck Crop Drawing to Frame

The Drawing status is now Uncropped (as shown in the Info Box and Drawing Manager.) Its Frame is now 

Manually Resized.

– For an Auto-update Drawing: The Uncrop Drawing(s) command restores previously cropped 

content to the Drawing

– For a Manual-update Drawing: To restore cropped content, use the Uncrop Drawing(s) command, 

then update the drawing. 
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A Manually Resized Drawing Frame is shown with a dashed line:

Manually Resized Frame (Dashed Line) - Drawing in Uncropped Status
ARCHICAD 24 Reference Guide 2168



The Layout Book Documentation
Importing PDF Files As Drawings

As when importing any other external file, use the File > External Content > Place External Drawing from 

File command. If the PDF file being imported is password-protected, you will have to provide a password 

when prompted.

If you are importing a multi-page PDF document, a dialog box prompts you to choose which of the pages you 

wish to place.

You can also place PDFs into ARCHICAD 2D windows through drag-and-drop. In the case of multi-page 

PDFs, the dialog box that prompts you to choose a page will also appear.

A PDF file placed on the Layout, like any other item, becomes a Drawing. The Drawing name consists of the 

PDF file name. The page numbering is displayed in the Source View field of the drawing.

Like any other external linked drawing, placed PDFs can be automatically or manually updated in ARCHICAD.

See also Working with PDF Documents.
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Drawing Titles

Each Drawing placed on a Layout can have a title containing graphic elements and information referring to the 

drawing data, such as Drawing ID, Name, and Scale.

Note: Drawings placed in Model Views do not have Titles.

The actual drawing title is based on a Title Type. Title Types are GDL Objects that can be assigned to 

Drawings by default (automatically) or assigned manually to selected Drawings.
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To assign a title to a Drawing, select the Drawing and open the Drawing Settings dialog box. In the Title panel, 

select a Title type from the pop-up menu.

To assign a title by default to each newly placed Drawing, open Drawing Default Settings (the Default settings 

come up if no Drawing is selected) and choose a Drawing title.

Drawing Titles are laid out automatically with the associated drawing. A Drawing Title is a sub-element of the 

drawing. 

Create a New Title Type

In the Layout window, use the available 2D tools (e.g. lines, text blocks) to design a Title Type to fit your 

needs. Select the components of this new Title Type. Use File > Libraries and Objects > Save Selection as 

> Drawing Title to save this object. Once saved, your Title Type is available from the pop-up in the Title panel 

of Drawing Settings.

You can subsequently edit this custom-created Title Type graphically: Use File > Libraries and Objects > 

Open Object. From the directory dialog box, select the Title Type you want to edit. Click “2D Symbol” to 

access the graphical editing window for this object. Make your changes using 2D tools.

Note: Make sure the scale of the GDL 2D symbol window is set to 1:1, to make editing easier.

Back Reference to Layout Containing Source Marker

The Title Panel of Drawing Settings gives you access to the Back Reference function.

See Title Panel.
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Back Reference allows you to add Layout ID information to the Drawing Title: specifically, the ID of one or 

more Layouts that contain a Drawing that shows the source marker of the current Drawing. Back Reference is 

useful if the current Drawing is based on a Section, Elevation, Interior Elevation, Detail or Worksheet.

Click Back Reference to bring up the dialog box of the same name.

This dialog box lists every Layout that displays the source marker of the current drawing.

First check the Enable Back Reference box, then select one or more of the Layouts whose ID you wish to 

display. (Check Select All available if you want the Drawing Title to display the ID’s of all Layouts listed here.)

Click OK to close the dialog box and return to Drawing Settings.

The Drawing Title Preview shows an Autotext in the place where the Drawing Title will contain the Layout ID 

information.

In this example, if you have checked “Select All available,” the final Drawing title looks like this:
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Note: Make sure that the parameters of the Drawing Title object you are using have enabled the Back 

Reference function:
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Managing and Updating Placed Drawings

All drawings placed in the ARCHICAD project belong to one of the two following types:

• Automatic update. The drawing placed on the layout will be updated automatically when the layout is 

activated (brought to front or selected for output). Automatic updates also occur before publishing. If an 

auto-update drawing comes from a different source than the currently opened project file, then 

ARCHICAD will check whether it requires updating or not, and perform an update if necessary.

Note on Auto-Update Drawings in Teamwork: In a Teamwork project, an auto-update Drawing with an 

external source (e.g. external project, PDF, DWG, PNG) will be updated only if you have reserved that 

Drawing.

• Manual update. The drawing is frozen in the state its source view or file was in when placed on the layout 

or updated. This can be useful if you wish to keep the drawings untouched until they are approved or you 

are ready to move on to the next stage in your work. Manual-update Drawings are updated only if you 

issue an update command.

Note on Manual-Update Drawings in Teamwork: If you have reserved a manual-update Drawing, then 

you alone have the right to update that Drawing.

For any placed Drawing, set its default update type in Drawing Settings.

Use the Drawing Manager to check the status of all drawings in the project, modify their update type, 

reestablish, repair or change links.

You can also check Drawings and access Drawing Manager through the Action Center. (File > Info > Action 

Center)

Related Topics:

Drawing Manager

Action Center

Update Linked Drawings

When opening a project with drawings whose sources have been modified, the Drawings page of the Action 

Center will alert you.

To update selected Drawings, do one of the following:

• In the Navigator, Organizer or Drawing Manager: 

– Select the drawing(s), then use Update from the context menu, or the palette’s Update button.
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• In the Layout window: Select the drawing(s), then use Update from the context menu

Re-Link PMK File

If the Layout Book contains Drawings whose source is a linked PMK file (created in the Publisher out of an 

ARCHICAD model view), you can re-link all these PMK-based drawings back to their original model view. 

Select the PMK files in the Drawing Manager (multi-selection is available) and use the following command 

from the context menu: Link to original Model View.

See the workflow description at Layout Workflow: Larger Projects.

Note on External Drawing Update (Drawing placed from BIMcloud)

Once you place a Drawing whose source is an external Teamwork project, a copy of the Drawing is created on 

your machine. When you subsequently update the Drawing, ARCHICAD will automatically synchronize your 

local copy with the project on the server to ensure that the Drawing in your host project is fully updated.

There is one case in which ARCHICAD will not update the Drawing placed from an external Teamwork 

project. This occurs if you are logged into the source Teamwork project, from your current computer, and if 

you have any unsent changes in that Teamwork project. In this case, ARCHICAD detects that the Drawing 

may not be in fully updated condition on the server, and will not update it. You will be warned if this occurs. In 

this case, send in any unsent changes from the source Teamwork Project, then update the placed Drawing 

again from the current project.
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Layout and Drawing IDs

Both Layouts and Drawings have IDs assigned to them, as an aid in organizing, navigating and outputting 

your project. The primary use of assigning Layout IDs is to achieve the automatic numbering of the Layout 

Book. While an automatic logic can be applied to the whole Layout Book, ARCHICAD provides maximum 

flexibility in customizing the assignment of IDs to meet your preferences.

Topics in this section:

Simple Layout Numbering

Automatic Layout ID Assignment

Book Settings Dialog Box

Custom Layout/Subset IDs

Drawing IDs

Simple Layout Numbering

The simplest way to number your Layouts is to number each layout sequentially, like the pages in a book. To 

do this, you do not need to consider Layout IDs; just place an Autotext for “Layout Number” in the Master 

Layout. The Layout Number is a number assigned to each layout in the order it is created; it is shown at the 

bottom of your Layout Window. Through the Autotext, this number will appear on each Layout.

However, if you want to use a “smart” numbering system that accounts for adding and removing Layouts in 

the Layout Book hierarchy, you should use the Automatic Layout ID Assignment logic.

Automatic Layout ID Assignment

Due to the complexity of most architectural projects, and to enable you to retain the desired numbering 

sequence even after Layouts are added and removed from the Layout Book, most users will prefer to use an 

automated method which assigns an ID to each layout. The smart ID assignment system automatically 

adjusts itself whenever the Layout Book is changed (for example by the addition of new Layouts, changes in 

the Layout order or in the document structure).

“Layout ID” is available as an Autotext entry, so if you add the Layout ID Autotext to the Master Layout’s Title 

block, then each Layout will be numbered with this ID.

Go to Document > Layout Book > Book Settings. Choose your preferred method for assigning Layout IDs:

• Use Hierarchy (Tree view by subset): Use this method if you want your Layout IDs to reflect the Layout’s 

location in a particular subset. IDs will reflect the tree structure hierarchy: Layout IDs will “inherit” the IDs 

of the subsets in which they are located - as in the illustration below.
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Both the prefix and the style (1-2-3, A-B-C, etc.) of the layout/subset ID can be customized. The resulting 

layout ID is usually a letter-number combination, such as A-03/a.

See Book Settings Dialog Box.

Note: At any level of ID assignment (Book Settings, Layout Settings or Subset Settings), you can choose 

a style of “No ID”. As part of the automated ID system, every sub-item in that group (e.g. every layout in 

that subset) will be assigned an “empty” ID, which is like no ID at all.

• Use Flat Layout Order: This method will assign an ID to Layouts only (not taking subsets into account), 

from top to bottom in the Navigator Layout Book. Layouts will receive sequential IDs regardless of their 

hierarchical position - as in the illustration below. If you change the order of Navigator items, their IDs will 

change accordingly.
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Custom Layout/Subset IDs

Even if you use the Automatic Layout ID Assignment logic defined in the Book Settings Dialog Box, you can 

still assign a custom ID to any Layout or Subset.

In Layout or Subset Settings, assign a custom ID to the selected layout or subset. The Layout/Subset will still 

“count” as part of the ID sequence (e.g., if the previous Layout is A-02, the custom Layout might be Suppl.-02, 

and the following Layout will be A-03.)

• If you do not want the custom ID to be counted in the automatic ID sequence, check the “Do not include 

this Layout (Subset) in ID sequence” box.
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Once you have customized a Subset ID, you then have the further choice: in the ID of Items in this Subset 

panel, you can make the IDs of Layouts in this subset either follow the new logic (incorporating the subset’s 

custom ID), or else retaining the ID logic of the overall Layout Book structure irrespective of the customized 

subset ID.

Another way to assign a custom Layout or Subset ID is by typing it directly into the Properties panel of the 

selected Layout (Subset) in the Navigator Layout Book.

Drawing IDs

Each drawing placed onto a layout is automatically assigned a Drawing ID. The Drawing ID appears in front 

of the Drawing Name in the Navigator and the Organizer palette. The method of ID assignment is defined in 

Drawing Settings. Note that the Drawing Name and the Drawing ID are defined separately.

In the Drawing Identification Panel of Drawing Settings, choose one of these options for defining the 

Drawing’s ID:

• By View ID: The Drawing will have the same ID as its source view. This option is often the most useful if 

your Layouts contain one Drawing each. (This option is only available if the Drawing’s source is an 

ARCHICAD view.)

• By Layout: The Drawing will get an ID based on its “Parent” Layout: the Drawing ID will have the Prefix/

Style you define in Layout Settings, in the “IDs of Drawings on this Layout” panel. This option is most 

useful if your Layouts contain multiple Drawings.

• Custom: Assign any custom ID to this Drawing.

You can also use the Grid for Drawing IDs feature of Master Layout Settings to automatically place drawings 

in cells and assign IDs in a matrix or a flat structure.
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Layout Workflow Schemes

ARCHICAD’s Integrated Workflow Control ensures optimal workflow for projects of any size, complexity and 

type (single-user or shared project). The following outline introduces some workflow models you might use in 

various situations.

Topics in this section:

Layout Workflow: Smaller Projects

Layout Workflow: Larger Projects
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Layout Workflow: Smaller Projects

Smaller projects typically mean smaller design teams (or solo practices) and smaller drawing sets. Smaller 

practices tend to be less structured, and more often than not the same architect takes care of the entire 

design process, including the layout phase.

In such cases, the project usually consists of a single file which contains all the drawings that make up the 

documentation, with the possible exception of a number of external files such as pictures, PDF format tables 

and descriptions, and standard details.

When using the single-file model, you can build up the structure of your layout book by defining the necessary 

number of subset folders and adding to them the viewpoints and views set up previously in the project file.

If the placed drawings are defined as automatically updated, the layout book will be continuously in synch with 

the design work. The activated layout will reflect the latest changes made on the plans, sections and other 

drawings.
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Layout Workflow: Larger Projects

In larger architectural practices which handle large, multi-building projects, it may be more practical to break 

down the large project into smaller entities. Each of these subordinate entities (for example, buildings located 

on the same site) will then constitute a project file, which can still refer to a single set of templates, modules 

and libraries.

However, the documentation will probably extend to the entire project, taking drawings from all the project 

files.

In this case, it makes sense to define a single Layout Book that will accommodate views and files originating 

from all of the project files that make up the project.

There are basically three solutions:

Single File Containing Model and Layout Book

If there is a large main file in the project with one or two smaller additional files, you can opt to build up the 

structure of the layout book in the larger file as you would in the single file model above, and then also open 

the smaller files, locate their views in the Organizer, and add them to the Layout Book.

See Import View(s) from External ARCHICAD Project (Solo or Teamwork).

See also Access Views/Layouts from External ARCHICAD Project.

Multiple Project Files, with Separate File for Layout Book Only

If there are many project files of about the same size and complexity, it may make sense to create an 

additional project file that does not contain any construction elements, just the Layout Book. You can then 

open the other files one by one and add their views to the Layout Map, possibly by creating a subset folder for 

each of them or by defining another custom hierarchical structure.

When a layout is activated in the multiple file model, ARCHICAD checks whether it contains drawings that 

originate from project files other than the active one. If there are, it will then start updating those drawings that 

are set to be updated automatically. If the file containing the given drawing is open in another ARCHICAD 

session, the update occurs instantly. If the file containing the given drawing is not currently open, then another 

ARCHICAD session will be launched to open it.
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Multiple Project Files, Separate Layout Book, Separate Drawings (PMK Files)

This workflow can be appropriate if several individuals are working concurrently on the model and 

documentation through a network.

In this workflow, as in the previous one, the model is located in one or more project files, and the Layout Book 

in a separate project file. The Layout procedure, however, is different: Layouts will contain Drawings whose 

source is in an external file, rather than directly linked to project views.

The model designer will create views as usual in the ARCHICAD file. Instead of placing these views directly 

onto the Layout, s/he will use the Publisher function to save the views in PMK format, a native ARCHICAD 

drawing format which takes up relatively less hard drive space than many other formats.

See Defining Publisher Output Format.

The architect responsible for the Layout Book will then place these PMK drawings on the Layout, using the 

Drawing Tool and the Place Drawing dialog box, or the File > External Content > Place External Drawing 

from File command.

See Place Single Drawing Using the Drawing Tool.

These placed Drawings, like any other Drawing, are either Auto-update or Manual-update. Their source is the 

PMK file. Consequently, it is the model designer’s responsibility to ensure that every time an ARCHICAD view 

is modified, the PMK file created from that view is also replaced, so that the Drawings linked to these PMK 

files can be updated.

Advantages of this workflow:

• Updating documentation may be quicker, because it involves updating a single, small-sized drawing file at 

a time.
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• Opening the Layout Book might take less time, since the PMK files serving as the Drawing sources are 

located outside the project file.

• If the PMK-based Drawings are set to Auto-update, then they will be automatically updated when the 

Layout is published.

If necessary, you can break the Drawing’s link to the PMK file and re-link the Drawing to its original model 

view. To do this, select the PMK file(s) in the Drawing Manager (multi-selection is available) and use the 

following command from the context menu: Link to original Model View.
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Revision Management

During the course of an ARCHICAD project, you will probably issue several sets of Layouts at different times. 

Between each such Transmittal Set, the model changes, and so do the Layouts. Revision Management helps 

you keep track of changes, Layout revisions, and Transmittal Sets.

Revision Management Workflow

Revision Management: Default Schemes in the Template

Working with Changes

Feedback on Layout Revisions

Revision IDs

Managing Transmittal Sets

Change List and Transmittal History

Revisions in the Publisher

Changes from External Files
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Revision Management Workflow

This chart, and the summary that follows, describe a Revision management workflow which takes advantage 

of ARCHICAD features that automate your Layout Revisions. For this automation to work, you must place 

Changes that are connected to model elements. This way, all Layouts affected by these Changes are 

automatically given a new Revision number. 

Phases of the Workflow:

First Transmittal Set

• Create the First Transmittal Set. This typically includes all the Layouts in your project.

• Close the Transmittal Set.

Changes and Revisions

ARCHICAD automatically tracks your changes on Layout Revisions, provided that your Changes are linked to 

elements, and provided that Drawings on the Layouts are up to date. 

• As the project develops, create Change entries and link them to elements in the model (use Markers and/

or Clouds if desired).
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• These Changes are automatically added to the Layout Revision History of every Layout affected by the 

Change: that is, every Layout containing an element that is linked to a Change.

• A new Layout Revision is created automatically as soon as a new Change appears on a Layout since its 

last Transmittal Set.

• A Change will appear on every Layout that is affected, but on only one single Revision of a given Layout. 

• Changes of any nature can also be added manually to a Layout Revision.

• Only the latest Revision of any given Layout is editable. The Revision data (and changes) of any earlier, 

already transmitted Layout cannot be modified.

Subsequent Transmittal Sets

• Do a Drawing Update for the entire Layout Book.

• Create the next Transmittal Set. All Layouts having a new Revision since the previous Transmittal Set, 

plus any new Layouts, are automatically included in the Second Transmittal Set.

• Remove any unneeded Layouts from the second Transmittal Set.

Close and Publish Transmittal Set

• Close the Transmittal Set. Layout Revisions are now finalized.

• Review the contents of the Transmittal Set. If you see problems, you can reopen the Transmittal Set, fix it, 

then close it again.

• Publish Transmittal Set contents from the Publisher (either every affected Publisher Set, or just the 

changed Layouts in the current Publisher Set.)

• Continue working on the model. Any further change on a Layout will automatically generate a new Layout 

Revision.
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Revision Management: Default Schemes in the Template

To help you get the full benefit of the Revision feature, the ARCHICAD template for each language version 

includes predefined defaults for the Revision-related interface. Among these:

• Master Layout with Revision History object

• Default data for the Change Tool, Change Scheme and Transmittal Set Scheme

• New default Project Indexes: Change List, Transmittal History

If you are using your own company template instead of the ARCHICAD template, you will not see these items 

in your project by default. You can do the following: 

To access the Revision History (a GDL object)

• Make sure you migrate your library, or that you can otherwise access the Revision History object (from 

Object Tool Settings), and place it on a Master Layout as needed.

To access default Change Scheme or Transmittal Set Scheme data fields:

1. Open the ARCHICAD 24 template file.

2. Open the Edit Scheme dialog:

• for Change Scheme: from Change Details

• for Transmittal Set Scheme: from Book Settings

3. Click Export to save the Change/Transmittal Set Scheme to a location on your computer.

4. Open your own project/template.

5. From Edit Change Scheme (or Edit Transmittal Set Scheme), click Import to bring in the Scheme.

To access the Change List and Transmittal History (Project Indexes):

1. Open the ARCHICAD 24 template file.

2. Open Document > Project Indexes > Index Settings to access the predefined Project Indexes.
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3. For each desired Index file (e.g. Change List, Transmittal History), click Export to save it to a location on 

your computer.

4. Open your own project/template.

5. From Index Settings, click Import to bring in the Indexes.
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Working with Changes

Create a Change to mark and/or describe a change in the project.

A Change can be placed into the project either with the Change Tool; or you can create and list a change 

using the Change Manager.

If you want ARCHICAD to detect Changes automatically on every affected Layout, then you must link your 

Changes to one or more elements or Change Markers (placed with the Change Tool).

These functions are described below.

Change Manager Palette

Create Change

Link/Unlink Change Elements

Add/Remove Changes on Layout Revisions

Change Details

Archive Changes in Change Manager
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Change Manager Palette

Keep track of your changes in the Change Manager Palette, available here:

• Window > Palettes > Change Manager

•  Show Change Manager from the pop-up menu at the upper left corner of the Navigator/Organizer

The top of the Change Manager lists all Changes in the project.

Note: Change Markers placed as “unlinked” are not listed in Change Manager. Unlinked Change Markers 

are graphical elements that are not linked to anything, but you can link them at any time to existing 

Changes.

• Untransmitted Changes: A Change on the currently active Layout that has not yet been transmitted is 

also listed in blue type in the Change Manager. (The Layout window must be open for this feedback to be 

visible.)

• Transmitted Changes: Changes that have been transmitted on at least one Layout revision have a green 

Transmittal Set icon on it. (These changes can still be added to other Layout revisions.)

• Archived Changes: Optionally, you can archive some or all of your transmitted changes and list them 

separately in the Change Manager. (See Archive Changes in Change Manager.)

• Changes in external files: Changes (except Archived Changes) that arrive in the host file via a Hotlink or 

external drawing are shown with a lock icon. (See Changes from External Files.)
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Use the context menu of any selected Change to access relevant commands. Note that these differ for 

transmitted and for untransmitted Changes. (Transmitted Changes cannot be deleted from the project, but 

they can be archived.)

Zoom to Linked Element

From the linked element(s) at the bottom of the Change Manager, select any element and double-click to 

zoom to that element in the open window (if it is visible) or in the source view (if it is not currently visible).

Watch the Video
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Create Change

Create Change from Change Manager Palette - With Elements Selected

Create Change from Change Manager Palette - With No Elements Selected

Create New Change Using Change Tool

Place New Change Marker Linked to Existing Change

Create New Change on a Layout Revision

Create Change from Change Manager Palette - With Elements Selected

1. In any model window, select element(s) involved in the Change that you wish to document.

2. In Change Manager, click Create New Change.

3. The New Change dialog box appears. Enter a Change ID (required), name, and any custom data as 

needed. 

See Edit Change Scheme to Define Custom Data.
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4. Click OK to create the Change.

The new Change is listed in the Change Manager. The selected elements are linked with the Change and 

listed in the panel below.

Create Change from Change Manager Palette - With No Elements Selected

1. On the Change Manager, click Create New Change.

2. The New Change dialog box appears. Enter an ID, name, and other information as needed. 

3. Click OK to create the Change.
ARCHICAD 24 Reference Guide 2195



Revision Management Documentation
The new Change is listed in the Change Manager. Note that it is not linked to any elements in the project; no 

Linked Elements are listed at the bottom of the Change Manager. Consequently, this Change will not show up 

automatically on any Layout Revision.

If you want ARCHICAD to detect Changes automatically on every affected Layout, then you must link these 

Changes to one or more elements.

See Link Element to Change.

Create New Change Using Change Tool

Use the Change tool to place a Change Marker (cloud and/or marker) in any of the following windows: Floor 

Plan; Section; Elevation; Interior Elevation; 3D Document; Worksheet; Detail; or Layout window.

• The Change element (cloud and/or marker) can either be linked to a new or existing Change, or is an 

unlinked graphical element. If it is linked, then the Change Marker is listed in Change Manager, and is 

added automatically to every affected Layout Revision.

• Visibility of Change Markers is defined globally for each Transmittal Set, in the Transmittal Set Details 

dialog box.

See Show or Hide Change Markers in This Transmittal Set

1. Activate the Change Tool

– from Document > Documenting Tools, or

– from the ARCHICAD toolbox
ARCHICAD 24 Reference Guide 2196



Revision Management Documentation
2. In Change Tool Settings, enter the Change ID and Change name.

Marker type: By default, the Change Tool is set to create a new Change (The other options - also 

available in the Info Box - are to place a linked or unlinked marker).

3. From Change Tool Settings or the Info Box, choose the component(s) you want to place: a Cloud plus a 

Marker Head, or just one or the other.

4. From the Info Box, choose a geometry method for the Cloud part of the Marker (if you are using a Cloud):

– Polygonal

– Rectangular

– Rotated Rectangular

– Circular

5. Place the Change Marker in the project.

6. A new Change appears immediately in the Change Manager. The Change Marker is linked to the Change 

you just placed.
ARCHICAD 24 Reference Guide 2197



Revision Management Documentation
Note: The cloud component includes an on-screen only polygon. If needed, you can hide this polygon 

with View > On-Screen View Options > Marker Range.

The new Change is listed in the Change Manager.

Watch the Video

Place New Change Marker Linked to Existing Change

1. Activate the Change Tool and adjust its settings as described above.

2. From the Info Box, choose Place linked marker.

3. In the Info Box pop-up, choose the Change that you wish to link the new Change marker to; or click Select 

Change.

4. In the appearing Select Change dialog box, choose the Change and click OK.

5. Place the Change Marker into the project. It is linked to the Change you selected.

Watch the Video
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Create New Change on a Layout Revision

You may wish to note a Change on a Layout Revision manually. For example, if a new Drawing was added to 

the Layout; or the Drawing order on the Layout has been changed; or if the Master Layout has changed.

1. In the Revision History panel of Layout Settings, click New Change.

2. In the New Change dialog box, enter data for the change as needed. (See New Change Details.)

3. Click OK to create the Change and add it to the Layout Revision.

The new Change is listed in the Change Manager. Note that it is not linked to any elements in the project; no 

Linked Elements are listed at the bottom of the Change Palette.

Another way to do the same thing:

1. Open the Layout.

2. Use the Change Tool to create a new Change, with a marker, directly on the Layout. Again, it is listed in 

the Change Manager and added to the open Layout Revision.
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Link/Unlink Change Elements

Link Element to Change

Unlink Element from Change

Link Element to Change

1. Select one or more elements.

2. In the Change Manager, select the Change to which you want to link the selected element(s). 

3. Do one of the following: 

– Click the Link Selection to Change button in Change Manager

– Select a Change in the Change Manager. From the Floor Plan, drag and drop the selected 

construction element into the Change Manager to link it. (Make sure you keep the mouse button 

pressed throughout the drag-and-drop.)
ARCHICAD 24 Reference Guide 2200



Revision Management Documentation
4. The linked element(s) appear at the bottom of the Change Palette.

Unlink Element from Change

1. Select that item from the Linked Elements list in the Change Manager Palette.

2. Click Unlink Selection from Change.

Watch the Video
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Add/Remove Changes on Layout Revisions

Add an Existing Change to a Layout

Remove Change from Layout Revision

Add an Existing Change to a Layout

Do one of the following:

• In the Revision History panel of Layout Settings, click Add Change. From the appearing dialog box, select 

the Change you want to add to this Layout’s Revision History and click OK.

• From the Change Manager, drag and drop the change onto the Layout (either its item in the Navigator, or 

onto the Layout itself).

• With the Layout window active, right-click a Change in the Change Manager to add it to the currently 

active Layout.

The new Change is now shown in the Revision History, both in Layout Settings and on the Layout itself.

See also Revision History Data on Layout and in Layout Settings.
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Remove Change from Layout Revision

At any time, you can remove a Change from an open Layout Revision. Do one of the following:

• In Layout Revision History (Layout Settings), just select the unneeded Change and click the blue X to 

remove it from the Layout Revision. The Change will not appear again on this Layout unless you add it 

back manually (using Add Change).

• With the Layout window active, right-click a Change in the Change Manager to remove it from the 

currently active Layout.

You cannot remove Changes from the Revisions of closed Transmittal Sets.
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Change Details

New Change Details

Edit Change Scheme to Define Custom Data

Import/Export Change Scheme

Modify Change Details

Modify Details of Transmitted Change

New Change Details

The following data are defined in the New Change dialog box.

Change ID: This value is mandatory and must be unique for each Change. With each new Change, the last 

number is automatically increased by one.

Name: This optional value will serve as the name of the Change. By default, the previous Change Name is 

shown here, but you can modify it as you like.

Last Modified: Time/date of last modification of the Change Details. Linking or unlinking elements or markers 

does not count as a Change modification. (Once a Change is transmitted, you can no longer edit this field.)

Last Modified by: User name who carried out the last modification (relevant for Teamwork projects). (Once a 

Change is transmitted, you can no longer edit this field.)

Edit Change Scheme to Define Custom Data

Use this Scheme to define any Custom data types for all Changes in this project.

Click Scheme from the New Change or the Change Details dialog box to open the Edit Change Scheme 

dialog box.

The Scheme contains the set of four fixed Change data items for the project; you cannot redefine these:

• ID
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• Name

• Last Modified

• Last Modified By

Below these fields, you can define any number of additional fields.

1. Click Add to add another field.

2. Type in any custom field name (e.g. Reviewed by).

3. Click Add to add another custom field, or Delete to delete it.

4. Use the arrows at the left to change the order of the custom fields (the four fixed fields are always at the 

top of the list).

Import/Export Change Scheme

Click Export to save your Change Scheme as an xml file.

Then you can Import it for use in other project files.

Modify Change Details

To modify these data, select one or more Changes in the Change Manager.

1. Access Change Details: right-click and select the Change Details command, or double-click on the 

Change, or click the Change Details button.

2. Edit the fields as needed.

Note: Details of Changes from external projects cannot be edited.

Note: In Teamwork, you must reserve the Change Manager before modifying Change Details. Without 

reserving, you can only modify the details of Changes which you created and which have not yet been 

sent to the server.
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Modify Details of Transmitted Change

If the selected Change is transmitted (or Archived), the Change Details dialog box has a lock on it. It is not 

advisable to edit such changes. If you must modify a transmitted or an archived Change anyway, click the icon 

to unlock it. 

You can edit the ID, Description, and any custom fields, but you cannot edit the Last Modified date or user 

name.

Once you leave the dialog, the Change is locked once more.
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Archive Changes in Change Manager

Any transmitted Change can be optionally archived (for example, if your list of Changes is very long, and you 

have many transmitted Changes that are no longer relevant for the current Transmittal Set).

In Change Manager, select any transmitted Change(s) from the list and click the Archive Change button, or 

the context menu command.

Archived Changes, identified with this icon, are placed in their own folder in the Change Manager, which you 

can hide with the Show/Hide Archived Changes button.

The data of transmitted or Archived Changes can only be modified to a limited extent.
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Feedback on Layout Revisions

Important: This feedback is up to date only if the Drawing(s) on the Layout are up to date!

Blue Layouts

A Layout name is shown in blue if its current Revision has not been transmitted yet.

That is: 

• the Layout has never been transmitted before (it’s a new Layout), or

• the Layout contains new Changes since its last Transmittal Set

Layout names can be listed in blue in the following locations:

• the Navigator

• the Transmittal History

• the Add Layout dialog box

The blue Layout feedback can be particular useful in when you are adding Layouts to the current Transmittal 

Set.

See Add Layout to Current Transmittal Set.
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Note: In the Publisher Set, Layouts that are part of the current Transmittal Set are listed in green. 

See Revisions in the Publisher.

Blue Changes

A Change is listed in blue type in the Change Manager if this Change has not yet been transmitted on the 

currently active Layout. (The Layout window must be open for this feedback to be visible.)

Watch the Video
ARCHICAD 24 Reference Guide 2209

https://youtu.be/h92jUZ8fY5s


Revision Management Documentation
Revision History Data on Layout and in Layout Settings

Each Layout can display a Revision History.

This is a GDL object which must be placed on a Master Layout or directly onto a Layout. (It is available in your 

ARCHICAD Library, in the Graphic Symbols folder.) Use the Object Settings to customize its content and 

style.

The Revision History object has two predefined styles: Simple and Detailed.
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Even if the Revision History object is placed on the Master Layout, its content is specific to each Layout. In 

other words, data in the Revision History are updated based on the current status of the particular Layout.

Note: If you place the Revision History object onto a Layout in the form of a Drawing, the Revision History 

data will not be “smart”. Place the object onto a Master Layout or directly onto a Drawing.
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The Revision History (its detailed view) lists the Layout’s Revisions, plus all Changes associated with each 

Revision. 

The same data is available in the Revision History panel of Layout Settings.

Watch the Video

With the Layout window active, you can access the current Layout’s Revision History panel from the Change 

Manager, too:
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Revision IDs

By default, any Layout affected by a new Change (since the last Transmittal Set was closed) automatically 

gets a new Revision ID. This is shown in the Revision History panel of Layout Settings, in the Navigator, and 

in the Revision History stamp of the Layout.

See also Revision History Data on Layout and in Layout Settings.

Use the New Transmittal Set or the Transmittal Set Details dialog box to define the logic for numbering the 

Layout Revisions for the current Transmittal Set. Two checkbox control this function.
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Revision IDs for the Project’s First Transmittal Set

For the project’s very first Transmittal Set, the second checkbox is always activated. All Layouts of the project 

are “new” (all are listed in blue), and all are added to the Transmittal Set. This means that all Layouts will be 

assigned a Revision ID.

Default Revision Numbering for All Subsequent Transmittal Sets

For subsequent Transmittal Sets, by default, neither box is checked. This means that a new Layout Revision 

(with a new Revision ID) is created only if a Change has been added to the Layout (either by hand, or 

automatically when a change is linked to an element shown on this Layout). 

Override Layout Revision Numbering Logic

The two checkboxes provide different methods of Layout Revisioning.

• Create New Revision in all included Layouts: Every Layout that is added to this Transmittal Set is 

assigned a new Revision ID (even if it doesn’t contain any Changes).

In other words, if you add a Layout to the Transmittal Set, it gets a new Revision number. This is a 

simplified Revision numbering logic that is independent of any Changes.

• Override Revision ID of all included Layouts: Use the Transmittal Set ID as the Revision ID for all 

Layouts in this Transmittal Set.

In other words, all Layouts in this Transmittal Set get a single, uniform ID, which is the same as the 

Transmittal Set ID. This can be useful at a stage of the project when you want a different, simplified 

Revision numbering logic.

Watch the Video

Modify Revision ID

Revision IDs can be modified in the Revision History and the Navigator only if

• the Layout Revision has not been transmitted yet

• the Revision ID has not been overridden by the Transmittal Set ID (using the first checkbox in Transmittal 

Set Details)
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Managing Transmittal Sets

Create New Transmittal Set

Transmittal Set Details

Show or Hide Change Markers in This Transmittal Set

Add Layout to Current Transmittal Set

Remove Layout from Current Transmittal Set

Close Transmittal Set

What Happens When A Transmittal Set Is Closed?

Reopen Last Transmittal Set

Delete Transmittal Set

A Transmittal Set is a set of Layouts that is transmitted at a given time.

Typically, you will create a Transmittal Set when the required Layout set is considered complete.

To create and manage Transmittal Sets, use the Transmittal History panel of Layout Book Settings.

You can also access Transmittal History via the button at the bottom of Change Manager.

Here, all project Transmittal Sets (both the closed Transmittal Set and the currently open Transmittal Set) are 

shown with the list of Layout Revisions they contain.
ARCHICAD 24 Reference Guide 2215



Revision Management Documentation
Create New Transmittal Set

This command is only available if no other Transmittal Set is currently open. Only one Transmittal Set can be 

open at a time.

Watch the Video

Every time you create a New Transmittal Set, all open Layout Revisions - that have not yet been transmitted 

(and are listed in blue) are automatically added to the new Transmittal Set.

1. Update Drawings as needed. You should do a Drawing Update in the Drawing Manager before the New 

Transmittal Set is created. (Otherwise, some Layouts with new Changes may not be added to the 

Transmittal Set.)

2. Use the New Transmittal Set command.

– from Layout Book Settings:
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from the Navigator, using the context menu of the Layout Book
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3. In the New Transmittal Set dialog box, enter the needed data to identify the new Transmittal Set.

See also Revision IDs and Show or Hide Change Markers in This Transmittal Set.

4. Click OK to create the new Transmittal Set.

– The Project’s First Transmittal Set: For the project’s very first Transmittal Set, all Layouts of the 

project are “new”, and so all the Layouts are added to the Transmittal Set.

Note: A Layout listed in blue means that it has not been transmitted yet in its current form.

– All Subsequent New Transmittal Sets: Every time you create a New Transmittal Set after the first 

one, all open Layout Revisions - that have not yet been transmitted (and are listed in blue) are 

automatically added to the new Transmittal Set. (You are free to remove any Layouts that you don’t 

need from the Transmittal Set. See Remove Layout from Current Transmittal Set.)
ARCHICAD 24 Reference Guide 2218



Revision Management Documentation
Transmittal Set Details

Transmittal Set Details are defined in the New Transmittal Set dialog box when you first create it, but you can 

modify these details at any time for the currently open Transmittal Set.

Access Transmittal Set Details by clicking the icon from Transmittal History (in Layout Book Settings):

When the project has a Transmittal Set open, Transmittal Set Details is also accessible from the Navigator 

Layout Book context menu.

For information on the Revision ID-related checkboxes in Transmittal Set Details, see: Revision IDs.

Show or Hide Change Markers in This Transmittal Set

Use the Show Markers pop-up of the New Transmittal Set or Transmittal Set Details dialog box to define how 

to show or hide the project’s Change Markers on the Layouts included in this Transmittal Set.
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• Of latest Revision only: Only the Markers that are part of the latest Revision will appear on the Layouts 

of this Transmittal Set. (Markers associated with previous Revisions will not be shown on the Layout.)

• All: All Change Markers are shown.

• None: No Change Markers are shown on any Layout.

• Since a particular Transmittal Set: Change Markers are shown from all the Revisions starting with the 

Transmittal Set chosen here.

Watch the Video

Add Layout to Current Transmittal Set

Layouts that have gotten a new Revision since the last Transmittal Set are automatically added to the current 

Transmittal Set (provided that the Layout Drawings are up to date).

To add any other Layout:

Click Add Layout from the Transmittal History panel:
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Note: Layouts listed in gray text in the Add Layout dialog box have already been added to the Transmittal 

Set; you cannot add these. You can add the ones in black type (not yet in the Transmittal Set) and/or 

those in blue (untransmitted Revisions that are not yet in this Transmittal Set).

or from the Navigator Layout Book in “Tree by current Transmittal Set” mode:

In the Organizer’s Layout Editor, with the right side in “Tree by current Transmittal Set” mode, drag and drop 

Layouts into the Layout Book to add them to the current Transmittal Set:
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Remove Layout from Current Transmittal Set

1. Select the Layout from the Transmittal History panel of Layout Book Settings.

2. Click the blue delete icon to remove it from the Transmittal Set.

or from the Navigator Layout Book in “Tree by current Transmittal Set” mode:

You cannot remove Layouts from closed Transmittal Sets.
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Close Transmittal Set

Use the Close Transmittal Set command:

• from the Transmittal History panel of Layout Book Settings

• from the context menu of the Layout Book in the Navigator

What Happens When A Transmittal Set Is Closed?

• The icon in the Transmittal History panel of Layout Book Settings changes to “closed”.

• The Transmittal Set Date is finalized (no longer indicates “Work in Progress”)
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• Data in Transmittal Set Details are read-only and can no longer be modified. The Transmittal Set Details 

dialog box displays a lock icon.

• The current Revision of each Layout included in the Transmittal Set is closed

– The Revision ID can no longer be modified

– The WIP (Work in Progress) suffix is removed

– No Changes can be added or removed from this Layout Revision

– Any new Change to the Layout results in a new Revision being created

• All Changes on transmitted Layouts get the status of “Released”.

– They are listed with the transmitted icon in the Change Manager

– Transmitted Changes can no longer be deleted; they can only be archived 

See Archive Changes in Change Manager.

– The data of transmitted Changes can only be modified to a limited extent.

See Modify Change Details.

• Transmitted Changes can still be linked to model elements. This way, an transmitted Change can still take 

part in a later Transmittal Set, on a different Layout.

• Transmitted Changes can be archived in the Change Manager (see below)
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Reopen Last Transmittal Set

Note: In Teamwork, the Transmittal Sets - Modify History access right is required to reopen a Transmittal 

Set. (By default, this right is assigned to the Lead Architect role.)

A closed Transmittal Set can be reopened using the Reopen Last Transmittal Set command

•  from Transmittal History

• from the Layout Book’s context menu in the Navigator
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Delete Transmittal Set

You can delete the current open Transmittal Set using the Delete Transmittal Set command:

• in the Transmittal History panel of Layout Book Settings, in two different places as shown here:

• from the Layout Book context menu in the Navigator or Organizer:

Deleting Transmittal Sets is not undoable.

Watch the Video
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Change List and Transmittal History

Two preconfigured Project Indexes are available for easy listing of Revision-related information:

Change List

A Project Index that lists all the changes in a particular project. Use the Criteria and Fields parameters of 

Index Settings to list exactly the data you require.
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Transmittal History

A Project Index that lists Layouts by Transmittal Set and by Revision, and can also include Changes for each. 

Note that the Transmittal History list will include all transmitted Layouts - even those which you may have 

deleted from the project since the Transmittal Set.

Use the Criteria and Fields parameters of Index Settings to list exactly the data you require.
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Transmittal Record

To create a Transmittal Record - that is, to list the contents of any given Transmittal Set - just adjust the 

Index criteria.

To narrow the index to list only the current Transmittal Set contents, use the Most Recent criterion for the 

Transmittal Set Date.
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Revisions in the Publisher

Once you have created a Transmittal Set and are using Layout Revisions, the following automatic feedback in 

the Navigator’s Publisher mode can help you in defining your Publisher Sets:

Layouts in Current Transmittal Set

• Within a Publisher Set: all Layouts that are in the current Transmittal Set are shown in green

• To publish just the green Layouts, use the Layouts in current Transmittal Set Publish option. This will 

publish all layouts of the active publisher set that are part of the current Transmittal Set.

Publisher Sets Affected by Current Transmittal Set
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• In the list of Publisher Sets: the name of any Publisher Set that includes a green Layout (that is, it includes 

a Layout that is part of the current Transmittal Set) is also shown in green.

• To publish all of these green Publisher Sets, you can use the Publish option: Sets affected by current 

Transmittal Set.

Watch the Video
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Changes from External Files

When placing an external Drawing (via an ARCHICAD view/Layout) or a Hotlinked Module in your model, the 

arriving files may include Change data.

Changes in the Hotlinked file or external view are placed into the Host file and added to the host file’s Change 

Manager. However, note the following: 

• Such external Changes are shown with a lock icon and their details cannot be edited

• Archived Changes in a Hotlinked file are not added to the host project

• Changes in external Drawings are added to the host project only if they are visible on the Layout

If the Change in the imported item has the same Change Number as a Change in the host file, they are 

combined as entries in the Change Manager.

When a Transmittal Set is closed, local copies of the imported Changes are created. From this point on, they 

are preserved in the project history.
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Publishing

Outputs are the end result of the architectural design workflow; ARCHICAD gives you a high degree of 

flexibility in printing, plotting, and electronic publishing.

For quick outputs of the current on-screen view, the Print and Plot commands are available directly from 

ARCHICAD’s file menu; the Print and Plot dialog boxes contain familiar options.

You will normally use printing for creating fast outputs on which you can check various aspects of your design 

and plotting for creating the final documentation that will be submitted and sent to the client, the building 

authorities and the subcontractors.

For large-scale, planned outputs of one or more publisher sets, the Publisher function is a handy concept 

dedicated to the architectural design workflow. Using the Publisher palette, you set up and save preferences 

for any number of publisher sets: you define whether to print, plot or save them to disk. Once a publisher set 

is defined, you can publish or republish it at any time, using the same properties, at the push of a button.

Topics in this section:

Print

Plot

Publisher Function

Create PDF Output Using the Publisher
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Print

The File > Print command will bring up a Print dialog box which varies slightly depending on the view you are 

printing: Layout, 2D or 3D.

Print 2D Document

Print 3D Document

Print Picture

Print Layout

Note: The following descriptions are based on the Windows interface.

Items to be Printed

The Print command enables you to print the entire contents of the current window, or just a particular Print 

Area, as set in the Print 2D Document dialog box. From the Layout Window, you can print just the Layouts 

which are selected in the Navigator.

Items that cannot be printed include Hotspots, selection dots, Section depth lines, Roof pivot lines, 

Cameras and their paths.

The lines of the Construction Grid can be optionally printed from the 2D windows by checking the Print Grid 

checkbox. Note that you can only print the grid if Grid Display is ON.

See Show/Hide Construction Grid.

Items on a Trace view can also be printed.

Note: Elements that are located on remote stories but individually set to display on the current story will 

always appear on the output.

Use the Document > Model View > Model View Options dialog box to specify the display of model items on 

the Floor Plan, and thereby the printed output.

Header/Footer

When printing from ARCHICAD’s 2D or 3D window or Layout window, you have the option to place a Header 

or Footer on the printed page. You set the content of the Header/Footer in Header/Footer Settings.

Output Color

If you are using a printer that supports color or grayscale output, the color of the printed elements is defined 

by:

1. The setting made in the Print dialog box. Checking the Black and White box will print all colors in black 

independently of any other setting.

For more information, see Print 2D Document.

2. The setting made on the Properties panel of the Drawing Settings dialog box for each individual drawing 

placed on the layout.

Note: In the Drawing Settings Properties panel, the Pen Set pop-up allows you to choose a pen set for 

the drawing; the Colors pop-up allows you to choose the colors that will be used for printing it. Since the 

color and grayscale pensets are not connected, it makes a difference whether you first choose the Color 

pen set and then choose to display the drawing in grayscale or the other way round. The two results can 

be entirely different as shown below.
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Plot

The File > Plot command brings up the Plot 2D Document dialog box.

Note: The following descriptions are based on the Windows interface.

Plotter drivers shipped with ARCHICAD all use the HPGL vector-graphic language. We refer to any printing 

device that supports HPGL as a ‘plotter’. GRAPHISOFT provides dedicated plotter drivers for most plotters; 

for printing, you must use printer drivers provided by the vendor.

Note: Many current large-format output devices come with printer drivers which make the device function 

as a system printer. If the device is also HPGL compatible, you can use the dedicated plotter drivers 

provided by GRAPHISOFT.

Plotter Setup

When outputting documents to a plotter, you first need to set up the plotter for ARCHICAD. The 

communication with the plotter device is ensured by specific plotter drivers stored in the PlotWare folder 

located by default in the same directory as ARCHICAD.

Choose File > Plot Setup to open the Plot Setup dialog box.

Note: The ReadMe file also contains extensive information on issues related to plotting, such as 

recommendations on the choice of drivers and cables, and network plotting.

When first using a plotter with ARCHICAD, you need to connect to it by clicking the Setup button in the 

Connection area.

You can only plot graphic data from ARCHICAD. If a text window is in front, both the Plot Setup and Plot 

commands appear in gray in the File menu.

Plot versus Print

Some of the basic differences with printing:

• You cannot define a plot range; the entire contents of the active window will be plotted. From a Layout 

Window, you can choose to plot the Layouts selected in the Navigator.

• You can choose a color for the lines of the window grid, if you wish to plot it from a 2D window.

• Elements in a Trace view cannot be plotted.

You may prefer Plotting to Printing in these cases:

• Spool Folder: You can output a print/plot job into a file in both Printing and Plotting. However, if you need 

to collect your output jobs into a spool folder, use the Plotting function. Set the location of the Spool Folder 

in the Plot Setup dialog box.

• Grayscale Output Color: When Plotting, you have the option to select the color choice of the output: 

Color, Grayscale and Black and White are the available options. The Print dialog box lets you mark the 

Black and White checkbox if you prefer Black/White to color. (You can, however, also achieve grayscale 

output when printing: use grayscale Pen Sets for Model Views, or set grayscale display for Drawings 

placed on Layouts.)

• Speed: Plotting is generally faster than Printing, so if you have a high-volume output job, you should 

consider Plotting.
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Publisher Function

ARCHICAD’s Publisher feature automates and simplifies the repeated and consistent output of views and 

layouts (Publisher items) in a variety of formats. 

The Publisher function is controlled by the Publisher Map. 

Note: The Publisher Map is available in the Navigator Palette and Organizer only. (Window > Palette). It is 

not available in the pop-up Navigator.

The Publisher Map contains this project’s Publisher Sets, which are collections of Publisher items. 

Each Publisher item refers directly to a View or to a Layout (the Publisher item is a shortcut to the View/

Layout).

Publisher Sets are stored with the project, so you can access them any time, adjust settings if needed, and re-

publish them.

Open the Publisher map of the Navigator or Organizer:

• Select its icon at the top of the Navigator/Organizer; or

• Use the Document > Publish menu command

Topics in this Section

Manage Publisher Sets

Create New Publisher Set

Add Items to Publisher Set

Add Folder or Subset to Publisher Set

View/Layout Properties
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Rename Publisher Items

Select Publishing Method

Related Topics

Defining Publisher Output Format

Publishing Process

Manage Publisher Sets

To see a list of all Publisher Sets defined in this project, click the “One level up” button to display the Publisher 

Set Chooser and Manager. 

The Publisher Sets are listed here. Select any of them, or click the Publisher Sets button at the top of the 

dialog box to access the list.
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Create New Publisher Set

Click the New Publisher Set button, then give the Publisher Set a name.

Add Items to Publisher Set

Using the Organizer, you can add any combination of Layouts and Views to a Publisher set. These will be 

“Publisher items.”

In the Organizer, the Publisher must be on the right side. The Layout Book, View Map or Publisher Set must 

be on the left side. 

Select any number of Layouts, views, folders or Publisher items from the left.

Do one of the following:

• Click the Add Shortcut command at the bottom of the View Map/Layout Map

• Drag and drop it into the Publisher Map
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To define the output format for each Publisher item:

See Defining Publisher Output Format.

Add Folder or Subset to Publisher Set

Select a folder or Subset from the Layout Book or View Map folder.

Click Add Shortcut.

This creates a shortcut linking the selected folder or Subset to a corresponding folder in the Publisher Set on 

the right. Any changes to the contents of the folder or Subset will also take place in the linked Publisher Set 

folder. 

In contrast, if you drag and drop a Subset or folder into the Publishing Set, a corresponding folder is created, 

but it is not linked and does not follow any subsequent modifications to the Subset/folder contents.

View/Layout Properties

These fields display the properties of the view or layout linked to the selected publisher item. These properties 

vary depending on which item is selected (view or layout). Besides the ID and Name, properties include Layer 

Combination, Scale, and Model Display Options Combination (for a view), and Master Layout, Size, Layout 

Revision, and Transmittal Set (for a layout). They are displayed for informational purposes and cannot be 

edited here.
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Rename Publisher Items

You can rename Publisher items, including folders, and their naming logic. Select one or more items or folders 

and use the context menu commands.

• If you have selected several publisher items, the “Rename Items” settings will apply to all of the selected 

items

• A new item placed into a Publisher folder (or sub-folder) will take on the naming logic of that folder (or sub-

folder)

• Use the Custom Name option to define any name for the item(s). 

• The Autotext options can help you conform to local file naming conventions:

– Folder Name: Renames the item using the folder name in which it is located

– Folder Structure Name: Renames the item using the entire folder path of the item’s location in the 

Publisher Set

– Publisher Set Name: Renames the item using the Publisher Set name

– Source ID: Renames the item using View ID or Layout ID, depending on the source of the Publisher 

item

– Source Item Name: Renames the item using View Name or Layout Name, depending on the source 

of the Publisher item

• Automatic Name means that the Publisher item will have the same name as its source (e.g. Layout name 

or Drawing name). 

Note: A folder in the Publisher which was created as a shortcut from the View Map or Layout Book can 

also have an Automatic name: this is the same name as the name of the original View Map folder/Layout 

Book subset.

Select Publishing Method

Use the Publisher Set Properties Dialog Box to choose a Publishing method for each Publisher Set.

To open this dialog box, make sure you are viewing the list of Publisher Sets. (Click the “One level up” button.)

Do one of the following:

• Click the Publishing Properties button in the Navigator or Organizer

• Click the Publishing Properties command button among the command icons

• Click the pop-up button to choose a publishing method.
ARCHICAD 24 Reference Guide 2242



Publishing Documentation
You have four options here:

• Print

• Plot

The Print and Plot choices have no additional formatting choices. 

• Upload BIMx Hyper-model

Choose this option to create a Hyper-model for viewing in a BIMx application on a mobile device.

See Create BIMx Hyper-Model.

• Save files (to local folder or to BIMcloud)
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Save Publisher Set

If you choose Save files, you have the following options:

• Create single file: Use this option to save the entire Publisher Set to a single file. The available 
formats are PDF and BIMx Hyper-model. 

See Create BIMx Hyper-Model.

• Create a real folder structure: Click this button to save your files in a hierarchical structure.

• Create flat file structure: Click this button to save your files in a flat structure.

• Path: Enter the path of the folder you want to save your files in, or click Browse to locate a folder or 

BIMcloud.

For info on how to define the output format for each Publisher item, see Defining Publisher Output Format.
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Defining Publisher Output Format

Use the Format section of the Publisher to define the published output. The available formats depend on the 

publishing method (Print/Plot or Save.)

See also Select Publishing Method.

• Options with Print/Plot Output: If you chose Print or Plot in the Publisher Set Properties dialog box, 

use the buttons to open the corresponding dialog boxes (e.g. Page Setup, Print Settings).

These are versions of the standard Print and Plot dialog boxes, with only the applicable options available.

For more information, see Print 2D Document and Plot Setup.

• If you chose Save in the Publisher Set Properties dialog box, use the Format tab page to choose an 

image format for outputting the file. Files can be saved in a large variety of formats including all IFC 

formats, standard image formats and CAD exchange formats. You can choose file formats for the contents 

of a folder or individually for each view.
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For some formats, a variety of options are available - in these cases, an Options button is displayed, and you 

can choose among compression settings, color depths, and other options depending on the chosen format.

See also Create BIMx Hyper-Model.

 PDF Format

• If you are saving in PDF format, two special options pages are accessible: Document Options and Page 

Options.

See Create PDF Output Using the Publisher.

PMK Format

The PMK format is a native ARCHICAD drawing format which takes up relatively less hard drive space than 

many other formats. Saving views in PMK format can be a good workflow if your project is divided among 

multiple files (e.g. Model pln and Documentation pln).

See Layout Workflow: Larger Projects.

DWG or DXF Format

Choose a DXF-DWG Translator to control the content of the published output.

See DXF/DWG Translation Setup.

If all the items in a folder are Layouts, and if the entire folder is set to DXF format, an additional checkbox 

appears: Merge to one DXF file.

If all the items in a folder are Layouts, and if the entire folder is set to DWG format, an additional checkbox 

appears: Merge to one DWG file. If you use this option:

• The resulting DWG file will contain as many Paper Spaces as the number of Layouts that have been used 

as Publisher Set items. Thus, an entire Layout Book’s contents can be saved in a single DWG file.
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• The resulting DWG file is in Paper Space, and the same translation options apply for all published 

Layouts.

For DWG or DXF format, the Translators button is available, accessing the DXF/DWG Translation Setup 

dialog box.

DWF Format: Crop Image to Zoom

If your publishing format is DWF, the Crop image to Zoom checkbox is available. Check this box to crop the 

image to the current zoom on the Floor Plan. 

When exporting an ARCHICAD view for use by AutoCAD, you can ensure that only a selected part of the view 

is exported: First, publish the view in DWF format to a separate folder, using the Crop image to zoom option. 

Open the DWFs in ARCHICAD and save them again as DWG files. Only the cropped view will be visible in the 

DWG file.
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IFC Format

For any of the IFC formats, use the pop-up to choose an IFC Translator for Export to control the content of the 

published output.

See IFC Translators: Overview.

Click the Translators button to access more information on the Translator content.

For each Publisher item, you can vary the Translator, so that the view content can be customized to the needs 

of the recipient, creating the desired output with a single click.

Watch the Video

Structural Analytical Format (SAF)

Choose this format for export a Structural Analytical Model from ARCHICAD to external applications that use 

the finite element method (FEM).

See Structural Analytical Model.
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Publishing Process

If you have finished setting up the publication but do not want to actually start publishing, you can simply close 

the palette without clicking the Publish button. All Publisher settings are preserved with the project.

A log file containing information on each publishing process is saved to the location you specify in Options > 

Work Environment > Publisher (“Publisher log location”).

If you have selected a Publisher Set containing Layouts, choose which item(s) to output:

• Entire set: the entire active publisher set

• Selected items: Only items currently selected in the active publisher set

• Layouts in current Transmittal Set: All layouts of the active publisher set that are part of the current 

Transmittal Set. (Such Layouts are listed in green.)

If you are viewing the list of Publisher Sets:

• Sets affected by current Transmittal Set: All publisher sets that contain at least one layout that is part of 

the current Transmittal Set. (Such publisher sets are listed in green.)

See also Revisions in the Publisher.

• All the sets: all currently defined publisher sets.

Note: In Teamwork: Do not do a Receive between the time that you Close the Transmittal Set and publish 

the Transmittal Set, because the Drawings might change as a result; yet these changes cannot be 

updated on the Revision, which has already been frozen.
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Click the Publish button at the bottom of the Publisher to begin the publishing process.

To end the whole publishing procedure, click Stop.

To pause it, click Pause. The Stop button now changes to Continue, allowing you to continue publication later.

To locate a published file easily, right-click on the item and navigate to its location:

A log file containing information on each publishing process is saved to the location you specify in Options > 

Work Environment > Publisher (“Publisher log location”).

Revisions of Publisher Items

Often, you may need to output a Publisher item multiple times to keep pace with revisions. You may wish to 

keep the older published files as a record.
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The file name of each output Publisher item is identical to the name of the Publisher item itself. This means 

that if you output a Publisher item, and later rename it to reflect a new revision, you can re-publish it under the 

new name, without overwriting the previously output file.

If you publish multiple items of the same name simultaneously, a yellow warning triangle appears in the 

Publishing process window; double-click to read the message, as shown below. ARCHICAD will automatically 

rename such files.

See also Republish Hyper-model.
ARCHICAD 24 Reference Guide 2251



Element Information Documentation
Element Information

The Element Information Palette displays information (e.g. properties, dimensions) of element(s) selected 

on the Floor Plan. (Use Window > Palettes > Element Information to display it.) 

Choose either All Selected or Last Selection to define which selected elements should be considered.

The Information Content buttons in the top section of the palette define what information will be shown. If 

none of the buttons is active, only the number and type of the selected elements is displayed.

The six buttons display, from left to right:

• Classifications and Properties

• Length, circumference and thickness values
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• Area values

• Height values

• Surface area values
ARCHICAD 24 Reference Guide 2253



Element Information Documentation
• Volume values

Use the pop-up commands in the top right corner of the palette to save or print the data shown.
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ID Management

The ID field is located on the Classification and Properties panel of all construction element type tools as 

well as the Fill and Zone tools.
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The ID serves to identify and group elements in list views. You can also use the ID in the Label associated to 

elements. Any character can be used.

Element ID is also important if you wish to save the ARCHICAD Model in BIMx Hyper-Model format: when 

working in a Teamwork context, BIMx provides feedback on selected elements based on their Element ID. 

(Make sure you include this element ID data when saving the ARCHICAD model as a BIMx Hyper-model - 

otherwise, BIMx cannot provide ID-based feedback on the model’s selected elements.)

Note: All construction elements also have a unique, automatically generated, unique ID (GUID) which is 

conserved throughout the life of the Project. You can also use this identifier for labeling or in lists.

Filtering or grouping elements by their IDs is used by many List Schemes. Totals obtained in calculations can 

refer to elements that have the same ID. Therefore, the content of the ID may be significant.

• If a number is included anywhere in the ID field, drawing successive elements will add one to this number 

for each new element, provided that the Assign New Element ID to Each New Element checkbox is 

enabled the Options > Work Environment > More Options dialog box. If there is no number in the ID 

field, each new element of the given type will have the same ID.

• If elements are duplicated or multiplied, the IDs of the replicas will remain the same as those of the 

originals.

• If you paste elements into a Project, you may have elements with conflicting IDs.

See also Element ID Manager.
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Element ID Manager

Use this dialog box at Document > Listing Extras to set the ID numbers of the project’s elements based on 

their criteria. You can also use it to modify automatically generated ID numbers. Settings can be saved and 

stored for future use.

The configurations you create and save with the Element ID Manager help you prepare Project elements for 

a clearer reading of quantity takeoffs.

Note: This command is only available from the Floor Plan.

The dialog box includes two tab pages: Sort Elements for defining attribute choices, and ID Format for 

defining custom ID sets.

When the Sort Elements tab is active: Choose an Element Type. 

• If any elements are selected on the Floor Plan, Element ID Manager works on selected elements only. 

• If you select elements for assigning ID’s, the ID numbers will be assigned in the order the elements were 

selected.

• If nothing is selected on the Floor Plan, the command works on all placed and visible (not on hidden 

layers) elements.

Select and add criteria to the list on the right.
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Click to open the ID Format tab page, which allows you to define custom ID Formats:

Element ID Manager allows you to subdivide the ID into four parts.

For any of the parts, you can type plain text, a counter or a story number into the ID Components field.

• Use Text type to enter custom text.

• Use Counter type to enter either numerals or letters such as “aa” that will change incrementally in the ID.

• Use Story No. to insert the ordinal number of the element story.

Note: Story No. is only available as a type if you’ve selected “Story” as a Grouping criterion.
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Click the Change ID’s button to generate the Element ID List dialog.

You can save your settings using the Edit Settings pop-up menu on top of the dialog box.

The name of the saved set then appears in the Settings field. These settings are saved by ARCHICAD in a 

separate file and can be reused for further Projects, even after choosing New and Reset.
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Calculation (Legacy)

The Calculation function - ARCHICAD’s integrated database of construction elements - can be used to 

display, in list format, the number, quantities and components of elements in a project and the elements’ 

spatial disposition (zones).

The report-generation process described in this section is a simple output function; use predefined list 

templates to generate simple lists. Use the options in the Calculation Units and Rules dialog box to set 

calculation preferences.

Advanced users may wish to use customized formatting and define customized filtering properties.

The entire process is described in detail in the “Calculation Guide.pdf”, available from ARCHICAD’s Help 

menu.

Calculation (Legacy) vs. Interactive Schedule (Supported)

The Calculation functionality is considered legacy, and is unlikely to support new developments in 

ARCHICAD.

• The Stair and Railing Tools (as of version 21) are not supported. 

• Segmented and tapered Beams and Columns (available as of version 23) are not supported. Single-

segment Beams and Columns are supported as in previous versions.

Most users will prefer ARCHICAD’s Interactive Scheduler. Interactive Schedules are part of the Project Map, 

and the schedules produced can be saved as views and output on layouts. An Interactive Schedule is a two-

way editable item which is linked to the project elements that it contains.

Topics in this section:

Calculation Setup

List Types

Displaying Lists

Related Topics:

Interactive Schedule

Project Indexes

Calculation Units and Rules Preferences

Calculation Setup

Some of the commands referenced in this section are not visible in ARCHICAD’s default work environment 

profiles. If you plan to configure lists (recommended for advanced users only), first use Options > Work 

Environment > Menus to add the following commands to an existing menu (i.e. Document > Listing 

Extras):

• Set up List Schemes (this dialog box can be reserved in a Teamwork project)

Note: List Schemes will function in Teamwork projects only if you save them to the project’s Embedded 

Library.

• Edit Database (this dialog box can be reserved in a Teamwork project)

• New Properties

• Edit Properties

• Last Selection’s Properties
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• Link Properties to Criteria (this dialog box can be reserved in a Teamwork project)

List Types

ARCHICAD can generate three types of calculation reports: Element Lists, Component Lists and Zone Lists.

Element Lists are best used when creating schedules and inventories, and to display the parameters of 

construction elements in a project. To generate Element Lists, ARCHICAD filters the project or the selection 

set for construction elements according to the configuration of the selected List Scheme. Elements matching 

the filter settings will be listed together with element Parameters, Components and Descriptors, if so defined 

in the List Scheme.

Component Lists are generated when bills of materials, quantity takeoffs or price lists are required. These 

reports typically sum up and display component type properties; however, certain element parameters can 

also be listed.
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Zone Lists are generally used to create room schedules and finish schedules. Zone Lists can include 

parameters of Zones and related construction elements. When related construction items are listed, the report 

is in fact an Element List where the range of calculated elements is limited by the Zones they belong to.

Depending on what you want to appear listed in your list, you may choose the type of List you need to use. 

Some common examples are:

Displaying Lists

The range of elements that will be used in calculation depends on the current selection made on the Floor 

Plan.

• If there is no selection made, all elements will be used and filtered by the listing command’s List Scheme 

by type or other criteria;

You want construction elements listed with basic data and parameters about them listed Element List

You want parameters specific to construction elements (such as: Door Sill Height, 

Number of holes in Slab) listed

Element List

You want to create Door/Window schedules Element List

You want quantities of components associated with construction elements listed Component List

You want descriptors associated with construction elements listed Component List

You want to create room schedules Zone List

You want Zones or detailed Zone parameters (such as: Zone Extracted Area, Zone Area 

Reduction) to be listed

Zone List

You want main Zone parameters (such as: Zone Name, Zone Number) listed for Zones 

where listed construction element is located

Element List
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• If there is a selection made, only selected elements will be used.

For more specific element ranges, use the Setup List Schemes command and define filters.
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Collaboration

The ability for several individuals and teams to collaborate effectively on a single project is a basic necessity 

of architectural work. Teamwork for ARCHICAD is optimized to meet these needs, and specifically designed 

to meet the demands of a modern, multinational team.

Architects often need to work together with each other and with professionals of other disciplines who use 

other software. Moreover, interactive communication with clients is also a growing concern. ARCHICAD’s 

sophisticated collaboration tools are designed to address these challenges.

Related Topics:

Teamwork

Hotlink Modules

Model Compare

Collision Detection

Issue Handling

Working with XREFs

Interoperability

Physical Model Quality Check

Structural Analytical Model
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Teamwork

Teamwork is based on a client-server architecture and is designed to ensure maximum flexibility, speed and 

data safety to enable teams - even those spread out around the world - to collaborate on large projects.

The following sections describe ARCHICAD’s Teamwork related features and functions.

Topics in this section:

Teamwork Functions at a Glance

GRAPHISOFT BIMcloud: Features and Benefits

Teamwork Setup/Preparation

Share a Teamwork Project in ARCHICAD

Network Diagnostic Information (BIMcloud)

Join or Leave a Teamwork Project 

Open or Join Teamwork Project

Close Teamwork Project

Save Local Copy of Teamwork Project

Send/Receive Changes in Teamwork

Manage Local Teamwork Data

Working Online/Offline in Teamwork

Remote Access to Teamwork Projects

Teamwork Interface

Reserving Elements in Teamwork

Reserving Teamwork Project Data (Non-Elements)

Reserve All Elements and Data (Teamwork)

Review Your Workspace (Teamwork)

Creating and Sending Project Data (Teamwork)

Change Tracking in Teamwork

Assign Elements (Teamwork)

Request Elements or Project Data (Teamwork)

Release Elements or Project Data (Teamwork)

Messaging (Teamwork)

Add Comment to Activities (Teamwork)

Libraries in Teamwork

External Files Linked to Teamwork Project

Create Support Package (Troubleshooting)
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Teamwork Functions at a Glance

Function Teamwork in ARCHICAD

Reserving Elements Reserve any existing elements individually, by 

selection or criteria

No reservation needed to create new element/data

Assign elements to any user

Whenever possible, reservation occurs automatically 

without user action (not available in BIMcloud Basic)

Reserving Other Project Data Reserve as needed, at any time, by any authorized 

user

Whenever possible, reservation occurs automatically 

without user action (not available in BIMcloud Basic)

Releasing Elements Released by the user at any time, as needed

Feedback on Reservation Status Always up to date (if user is online)

Color-coding for at-a-glance feedback

Ownership Conflicts Use “Request” function to signal need for data

Send & Receive Download/upload involves only data that have been 

modified since last Send or Receive.

Team Communications Use simple built-in messaging system 

Project Management Central registry of users defined for all projects on 

BIMcloud

Each user’s role can vary by project

Working Via Internet Users access the BIMcloud from any remote 

computer via Internet

Working Offline Local copy created automatically.

Local copy can be saved as “Travel pack” for transfer 

among several computers. 
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GRAPHISOFT BIMcloud: Features and Benefits

GRAPHISOFT BIMcloud responds to an industry need - allowing remote teams to work together and handle 

large files. It also allows working offline, and enables working from just about any location, so that team 

members can log in and work anywhere. Any project data that can be imported into ARCHICAD can be 

communicated via the GRAPHISOFT BIMcloud.

• When implementing BIM on a larger scale, architects often run into bottlenecks in model accessibility and 

workflow management. GRAPHISOFT’s BIMcloud is the industry’s pioneering solution for model-based 

team collaboration for companies who use Teamwork in ARCHICAD. 

• The BIMcloud’s Delta Server™ technology reduces network traffic to a minimum for instant and reliable 

data-exchange, both within the office and over the Internet. In the BIMcloud environment, long waiting 

times for server synchronization are a thing of the past: team members can collaborate in real-time on 

BIM models through standard Internet connections from virtually anywhere in the world.

• The BIMcloud’s robust system architecture ensures the integrity of the BIM project at all times. Any data 

errors from malfunctioning components are blocked, preserving the project’s integrity on the network.

• The BIMcloud was designed for Architects, not for IT professionals - so it works in any standard office 

setup through any standard computer network.

• BIMcloud supports both online and offline work: if ARCHICAD loses the connection to the BIMcloud, 

users can continue to work with their already reserved elements. Once the connection is re-established, 

they will be able to send their changes to the BIMcloud and Receive changes submitted by other users.

• Built-in Teamwork Messaging boosts the communication between team members by putting the 

messages into context: simply select any element(s), write a comment and send it to a team member user 

for a review. A pop-up notification will inform the other user about the incoming message. After opening 

the message, he will be able to zoom to the element and read the message in context.

• BIMcloud Roles allow the browser-based BIMcloud Manager to define different permission sets for the 

BIMcloud users and assign them based on their responsibilities. It is very easy to limit the functions 

available for a specific user to prevent accidental damage or unwanted modifications to the project. Each 

user can have different Roles for different projects - to fit their responsibilities in that particular project. 

Even a view-only role can be created, allowing people to Join the project without being able to modify 

anything. 

For more information on features, see the BIMcloud User Guide.
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Teamwork Setup/Preparation

Teamwork for ARCHICAD is based on a client-server technology, in which one or more server applications 

are connected through the network to client applications. Therefore, using Teamwork in ARCHICAD requires

1. the ARCHICAD client application, and

2. the GRAPHISOFT BIMcloud.

Each of these two components must be installed separately. The BIMcloud should be installed on a computer 

dedicated to server functionality.

See the BIMcloud User Guide for details.

After you install and configure ARCHICAD and the BIMcloud, you are ready to start using Teamwork within 

the office.
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Share a Teamwork Project in ARCHICAD

The process of creating a new Teamwork Project is called “Share.” This involves opening a solo ARCHICAD 

Project file (.pln), then using the Share command to add it to the BIMcloud.

Other users with the requisite access will then be able to work on this shared project in Teamwork mode.

Follow these steps to share a Teamwork Project:

1. Open a solo ARCHICAD Project file (.pln).

2. Use the Share command (Teamwork > Project > Share or File > New > Share)

3. The Share Project dialog box appears.

Log in to BIMcloud

Click the drop-down list and select the BIMcloud you need. 

This list shows the addresses of all BIMclouds to which you successfully logged in at least once. 

Click the Refresh button to refresh the status of the server and the content of the selected BIMcloud.
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• If you no longer need to see an item on this list, remove it with the Remove command in the drop-down 

list.

• If you don’t see the BIMcloud you need, you can add it to the list by logging in, using Log in to a different 

BIMcloud.

The BIMcloud address should be entered as follows:

“http://<DNS name>:<manager port>" or “http://<IP address>:<manager port>”

• Depending on the server type, the address may begin with https:.

• The manager port is the one selected during BIMcloud Manager Installation, e.g.: 1228.

• You can also see the BIMcloud address on the BIMcloud Manager’s landing page. Consult your server 

administrator.

If there is a problem with the server connection, you will get feedback on the issue.

Click Run Network Diagnostic to open a dialog box with details and help in solving the problem.

See Network Diagnostic Information (BIMcloud).

Select a User

From the pop-up list at top right, select your name.

The names you see here are those which successfully logged on to the BIMcloud at least once.

Note: Don’t forget that a user must first be added to the BIMcloud, using the BIMcloud Manager interface. 

Only then can the user join the Teamwork project from ARCHICAD, using this user name and password.

• If you no longer need to see the selected user on this list, remove it with the Remove command in the 

drop-down list.

• If you don’t see the user you need, you can add it to the list by logging in, using Log in as a different 

User.
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User (Denied)

Once you select a user, the stored password will be checked. If the password is expired, or if that user has 

been deleted from the BIMcloud, the user name is shown as Denied.

You can still select a user that is shown as Denied - and you can do one of the following:

• Delete the user from the list

• Change its stored password with the Change Stored Password command. (You may need to do this if 

your user name/password combination stems from an LDAP database in which your password has been 

changed.)

If there is a problem with the server connection, you will get feedback on the issue.

Click Run Network Diagnostic to open a dialog box with details and help in solving the problem.

See Network Diagnostic Information (BIMcloud).
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Select Project Folder

The Share Project dialog box lists the project folder(s), Library folders, and the projects/libraries to which you 

have at least view permissions.

From the tree on the left, choose a project folder in which to place the newly shared project.

 Required permission:

- Simplified Management: Project or Server Administrator

- Detailed Management: Modify details and Modify folder content for the destination folder

Name the Project

Enter the desired Project Name.

Note: Use a different name for each project. Do not use the same name as that of an existing project, 

even if the letter cases are different (e.g. ParkingGarage and PARKINGGARAGE). If you do, users may 

not be able to Open or Join the project they need.

Create New Folder

Click the Create Folder command to create a new one within any of the accessible folders.

 Required permission:

- Simplified Management: Project or Server Administrator

- Detailed Management: Modify details and Modify folder content for the destination folder
ARCHICAD 24 Reference Guide 2272



Teamwork Collaboration
The folder is created immediately; you can delete or otherwise manage it only through the browser-based 

BIMcloud Manager. (Click the Manage Folders link from the New Folder drop-down button to access the 

Projects page of the BIMcloud Manager.)

Host Server

The Host Server pop-up displays the default Host Server of the selected project folder.

Note: Not available in BIMcloud Basic.

You can access the pop-up and choose a different Host Server. 

 Required permission to access the pop-up:

- Simplified Management: Server Administrator

- Detailed Management: Modify details for the selected folder

 Available BIMcloud Servers in the pop-up:

- Simplified Management: All BIMcloud Servers for a Server Administrator

- Detailed Management: Those for which you have Modify Hosted Data on BIMcloud Server 

permission.
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Open Project Settings after Share: Check this box to navigate to the Projects page of the BIMcloud 

Manager after the Share is complete.

Libraries

A shared Teamwork project must use libraries that are hosted from the BIMcloud. 

Click the Libraries button from the Share Teamwork Project dialog box to open the Libraries dialog box.

These options define what to do with the linked libraries of the solo project you are about to share.

See details at Libraries Setup for Teamwork Project Sharing.

From the Libraries dialog box, click OK to return to the Share Teamwork Project dialog box.

Your library conversion choices will take effect after you click Share.

Share

Click Share. The newly shared project will be opened now.

If you do not want to open the shared project right away, use the Share without Join option from the Share 

button’s pop-up.
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Libraries Setup for Teamwork Project Sharing

This dialog is available when you share a solo ARCHICAD project as a Teamwork Project.

These options define what to do with the linked libraries of the project you are about to share.

See Share a Teamwork Project in ARCHICAD.

The current solo project’s Linked Libraries are shown in the left column.

For each linked library you select in this list, choose an Action from the Action pop-up. The available Actions 

vary, depending on the specific situation.

Upload

Uploads the linked library to the selected Host Server shown here. This is the default option if:

• the linked library is available

• the target folder does not already contain a library of the same name

Upload Later

This option appears if

• the linked library you want to upload is missing (e.g. it has been deleted)

• You do not have necessary permissions to access the Host Server and/or to upload libraries

If you choose Upload Later, you can still share the project, but the linked library is not uploaded now. If 

someone else (e.g. a Server Administrator) uploads the Library to the specified location, the project will 

automatically find it.

Link to

“Link to” is the default option if a library of the same name is available in the target folder of BIMcloud. This 

option links the shared project to this library. Or click the pop-up to link to a library of the same name at a 

different BIMcloud location.
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Modify Library Folder

Use this option to upload the library to a different folder (other than the default) on the BIMcloud.

Note: Not available in BIMcloud Basic.

 Required permission:

- Simplified Management: Project Administrator

- Detailed Management: Modify Content, Modify Details, View Item permissions for the Libraries 

folder

Modify Host Server

Note: Not available in BIMcloud Basic.

To upload a library to a different server (other than the default) on the BIMcloud, click the Host Server column 

in the Libraries share folder and choose from the pop-up.

You can also switch Host Servers from the Select Location dialog box (provided that the BIMcloud has 

multiple Servers to which you have access).

 Required permission:

- Simplified Management: Server Administrator

- Detailed Management: Modify Hosted Data on BIMcloud Server 

Select

This action appears if the Projects folder on BIMcloud has no defined target location. 
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(On the Projects page of BIMcloud Manager, the Library Folder setting is “Defined Manually from 

ARCHICAD.”)

In this case, a red warning triangle appears in the Libraries dialog, and you cannot Share the project at all until 

you click Select. Then use the Modify command to define the target folder.

Don’t Use

Removes the selected linked library from the project you are sharing. This option may result in a Teamwork 

project with missing library parts. In this case, a warning shows you the number of missing library parts that 

will result. Consult Library Manager for a list of these library parts.

From the Libraries dialog box, click OK to return to the Share Teamwork Project dialog box.

Your library conversion choices will take effect after you click Share.

Default Location vs. Customized Location

During the Share process, BIMcloud defines a default location for the project’s linked libraries.

You can modify these defaults in the Libraries dialog, by placing a linked library in a different folder or on a 

different Host Server - as described above. Its settings are now customized.

To return the library to its default location, click the Libraries in Project item and use Restore default settings 

from the pop-up.

To restore all listed libraries to their default locations, use the Restore all default settings button at the 

bottom of the dialog.
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Network Diagnostic Information (BIMcloud)

This dialog box, accessible to BIMcloud users, provides current information on your network connections and 

how to solve any problems.

Usually, your CAD Manager will set up the server addresses so that you will be able to access server(s) from 

ARCHICAD without any problem, and you will not have to use Network Diagnostic.

If you do need it, this dialog box is accessible from all parts of the ARCHICAD interface at which you select 

and log in to a server, plus the Teamwork Palette, and the Work Environment Settings Network and Update 

page (if you have installed a Delta Cache Server with BIMcloud).

If the currently connected server is working, the Network Diagnostic dialog box opens in compact form:

Name: This is name of the server to which ARCHICAD is currently connected. If nothing is connected, this 

field shows an editable URL.

At right, click Check to refresh the server’s status information.

Status: Basic feedback on the server’s connection.

• The green checkmark means everything is accessible and working.
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• The checkmark with exclamation point means that you can work with this server connection, but the 

connection might not be optimal. For example, if the server is communicating with ARCHICAD via the 

BIMcloud Manager (and not directly); or if the server connection is not a secure one.

• The red X means that you cannot work with this server connection.

Open the Details panel for more information.
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Components

The Components list at the left side of the Details panel lists all the server components of the installed 

BIMcloud.

For any component selected here, its addresses are listed on the right (see below). 

Addresses

This is the list of server addresses at which your ARCHICAD can access the selected server component.

Your Server Administrator, using the BIMcloud Manager, sets up this list of addresses and their priorities. 

ARCHICAD will receive these addresses upon the first successful connection, and automatically pick the 

address most suitable for the current situation. Alternatively, you can select an address manually here in the 

Network Diagnostic dialog box (see Select Manually/Select Automatically, below).

If a Manager component is selected, you have the option of adding additional local server addresses (see 

below).

The address marked with an arrow is the address that is currently in use for the selected server component.

Advantages:

• The reason for multiple addresses is to optimize data transfer to fit various network configurations. 

• If a user wishes to access the server from outside the network, via the Internet, he/she can do so using a 

public IP address, and does not have to provide the full domain (although this is still recommended).

• Enables the efficient use of various IT infrastructure configurations

• Supports single-port communications, simplifying IT tasks

The address marked with an arrow is the address that is currently in use for the selected server component.

• Set by Server Administrator: These addresses are defined by the Server Administrator and cannot be 

modified in ARCHICAD.

• Added Locally: These server addresses are optionally added by you, to allow for alternative server 

access paths. The option to add local server addresses is available if the selected component is BIMcloud 

Manager.
ARCHICAD 24 Reference Guide 2280



Teamwork Collaboration
Use the plus, minus and pencil icons to add, remove, or edit a selected address. Only locally added 

addresses can be managed here.

Select Manually/Select Automatically

By default, ARCHICAD will go through the list of server addresses and use the first successful connection. In 

this case, the Network Diagnostic will show, for this selected address, that it was “Selected Automatically.”

If you prefer to use any other server address, and not use any of the others, click the Selected pop-up and 

choose “Always use selected address.” 

Now this address will show a lock icon (since it won’t change automatically), and it will be shown as “Selected 

Manually.”
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Open or Join Teamwork Project

To open or join a Teamwork project in ARCHICAD:

1. The project must already have been shared to the BIMcloud.

See Share a Teamwork Project in ARCHICAD.

2. You must be a user on the BIMcloud.

See the BIMcloud User Guide for details.

Even if you are in offline mode, you can open a project which you joined earlier. However, since you cannot 

synchronize with the server when you are offline, you cannot be sure that the local copy you open is up to 

date.

Note: To open a Teamwork file from ARCHICAD 12 or earlier, you must first convert the project.

Open Recent Teamwork Project

If you have recently opened the project on this computer with the current user name, do one of the following:

• From the Start ARCHICAD dialog box, select it from the listed Recent Projects

• Use File > Open and select it from the listed Recent Projects

Choose Project from a BIMcloud

Do one of the following: 

• From the Start ARCHICAD dialog box, click Teamwork 

• File > Open > Open/Join Teamwork Project

• Teamwork > Project > Open/Join Teamwork Project.
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Select a BIMcloud and user as needed. See below.

See Log in to BIMcloud.

Select Project

In the Open/Join Teamwork Project dialog box:

• For the selected server, the tree structure at left lists the project folders and projects on the BIMcloud to 

which you have access. 

• Click Refresh to refresh the contents of the tree and the folders.

 Permissions required to view items:

- Simplified Management: You are a member of a folder’s child project 

- Detailed Management: View item permission for the folder or any child folder/project 

• For each project, the dialog box shows its status (whether you have joined it already), the last time it was 

modified, its size and the BIMcloud Server on which it is housed. 

• If the selected BIMcloud is “Offline”, the tree structure shows only those projects that you already joined at 

an earlier time, and whose local data is available on your machine. You can open such a project and 

continue working on it in offline mode.

• Locked projects are shown with a lock icon. You can open it in read-only mode.

Click Open.

(If you have not yet joined the project, the command changes from “Open” to “Join.”)

Import Travel Pack

The Import button in the Open Teamwork Project dialog box enables you to import a Travel Pack file 

(.twtravel). (You create a Travel Pack to transport a Teamwork Project and/or project libraries to different 

locations).

See Travel Pack: Move Your Teamwork Project and Libraries to a Different Computer.
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Close Teamwork Project

Use File > Close to close a Teamwork Project in ARCHICAD.

Your local copy of the project remains intact. If you have unsaved changes, you can opt to save them to the 

local copy. If you have unsent changes, you can opt to send them.

Close Project Online

When you close a project with unsent changes while online, the program prompts you with several options:

• Discard changes: Any unsaved and unsent changes are discarded. Your reservations remain intact.

• Send & Save: Send changes to the server and also save any unsent changes to your local copy.

Keep or Release Your Reservations with Send & Save

What happens to your reservations when you click Send & Save?

By default, your reservations remain unchanged. The next time you open this project, you will find that the 

data reserved by you before you closed the project are still yours.

To change this default, you can re-set a Work Environment preference, at Options > Work Environment > 

Data Safety and Integrity.

Here, check the Release All when closing Teamwork Project with Send Changes box. This means that 

when you close a Teamwork Project, all your reservations will be released.

Click the arrow button to the right of the Send & Save button for two more variations:

• Save without Send: Save your changes locally, but do not send them to the server

• Save & Send and Release All

or

Save & Send without Release

(The command shown - either “without Release” or “Release All” - will be the opposite of your general 

preference set in Options > Work Environment > Data Safety & Integrity.)

If you will not work on the project for a while after closing it, you are advised to release your reservations - 

before closing the project - so that other users can access the data they need.

Close a Project vs. Leave a Project

When you finish working each day, do not leave the project; just Close it.

The next day, you will not have to join the project (you are already joined in); just Open it.

As long as you are joined in to a Teamwork Project, you can Open or Close the project as many times as you 

like, without losing your reservations and without dumping your local copy.

Note: If you change the default setting “Close Teamwork Project” in Options > Work Environment > 

Data Safety & Integrity, then your reservations will be discarded if you click Save & Send when closing 

the Teamwork Project.

See Keep or Release Your Reservations with Send & Save.

However, once you Leave the project (as opposed to closing it), you lose your reservations and dump your 

local copy. It is recommended that you do not leave the project unless you do not plan to work on it any more 

in the foreseeable future. Typically, you will leave a Teamwork project when you no longer participate in it.
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Close Project Offline

If you are offline when you Close the project, you cannot send changes to the server. Your only options are to 

discard the changes, or else to save them locally.

If you choose “Discard Changes,” then your unsaved changes will be lost, and you will not synchronize your 

local copy with the server.
ARCHICAD 24 Reference Guide 2285



Teamwork Collaboration
Save Local Copy of Teamwork Project

When you join a Teamwork project, local copies of the project and of its libraries are created on your hard 

drive.

Local data is also created when you link a Drawing from another project to your own project. The source 

project data is saved as local data to your machine, even though you did not join that project.

The Save command refreshes this local data. The Save command does not create a PLN file, and it does not 

send your changes to the server.

Local data are stored in the Local Data Folder, which by default is located in your installed GRAPHISOFT 

folder on your hard drive.

All data from all Teamwork projects, regardless of the ARCHICAD version they are in, are saved to this one 

location.

To manage your local data (e.g. move it to a new location or to delete it), go to the Local Data Manager dialog 

box (Teamwork > Project > Local Data Manager).

See Manage Local Teamwork Data.

Saving to a Recovery File for a Teamwork project behaves the same way as for solo PLNs: it automatically 

stores your Teamwork project to the Local Data Folder at predefined intervals, without your having to issue the 

Save command. Each user sets his/her own Recovery File preferences locally, at Options > Work 

Environment > Data Safety & Integrity.

Save as PLN

If you wish, you can save your Teamwork project as a PLN file. (Use File > Save As, and choose PLN file 

format); this newly saved PLN will contain all project elements. This PLN file is solely a local file and cannot be 

sent to the server, but you can re-share the PLN file as a Teamwork project.

Recommendation: If you are working in Teamwork and suspect any kind of data error, the first thing you 

should do is to save your project as a PLN file.

Necessary permission to save a project as a PLN: Save as PLN,PLA,MOD

Reload Project from Server

This command is located at Teamwork > Project > Reload Project from Server.

Ordinarily, you do not have to use this command during your normal daily workflow. But if you are working 

along and then realize that you want to discard your local changes and start fresh, or if you suspect any kind 

of data error in the project you are working on, use Reload Project from Server. This means that your unsent 

changes will be discarded, and you will get the current, entire state of the project as it exists on the server. (In 

contrast, when you Receive project changes from the server, your local data, including unsent changes, 

remain intact.)
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Force User to Leave a Teamwork Project

If you have the necessary permissions, you can force any user to leave the project.

As a result, the user cannot send his/her changes to the project and will lose all his/her reservations.

Unless you also remove the user from the project’s user list, this user will be able to re-join the project 

immediately.

Consequently, the “Force Leave” function is a temporary situation that can serve to force the release of 

reserved elements or data, without waiting for the owner to release them.

To force a user to leave the project:

• Use the Teamwork Palette: select the user name from the Users panel, then click the “Force User to 

Leave Project” icon or the command from the context menu.

• In BIMcloud Manager (Users page): Select the user in the Navigator. From the Joined Projects list in the 

Summary section, click Force Leave next to the project that the user must leave. Multi-select projects as 

needed. Or use Force Leave All to eject user from all joined projects.

• In BIMcloud Manager (Projects page): Select the project in the Navigator. From the Joined Users list in the 

Summary section, click Force Leave next to the name of the user who must leave. Multi-select users as 

needed. Or use Force Leave All to eject all users.

A Warning tells you that the user will not be able to send his/her unsent changes to the project.

The user is notified that he/she has been forced to leave the project, and about the options for continuing.

 Necessary permissions to force leave:

- Simplified management: Project or Server administrator

- Detailed management: Modify access

At this point, the user is forced out, and receives the following message:
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Join or Leave a Teamwork Project

To join or leave a Teamwork project, you must be online.

Join

Typically, you will join a Teamwork project and remain joined in, for the full period of time that you are a 

participant in the life of the project.

As long as you are joined in to a Teamwork Project, a copy of the project exists locally on your machine and is 

synchronized with the project on the server whenever you send and receive changes.

As long as you are joined in to a Teamwork Project, you can Open or Close the project as many times as you 

like, without losing your reservations or dumping your local copy.

To join a project, follow the process described here: Open or Join Teamwork Project.

The only difference is that the project you choose from the Open Teamwork Project list will not have a blue 

head (which would indicate that you already joined it), and the dialog box command changes to Join.

Leave

Typically, you will leave a Teamwork project when you no longer participate in it. Once you leave a project, you 

relinquish your reservations and the local copy on your machine is discarded.

Note: Even if you leave (and not just close) the project and later re-join it, full library downloads will be not 

be repeated if the local library copy has remained on your machine. In contrast to the local copy of the 

project, which is discarded when you leave the project, the local library copy is not discarded when you 

leave the project.

Close a Project vs. Leave a Project

When you finish working each day, do not leave the project; just Close it.

The next day, you will not have to join the project (you are already joined in); just Open it.

As long as you are joined in to a Teamwork Project, you can Open or Close the project as many times as you 

like, without losing your reservations or dumping your local copy.

However, once you Leave the project (as opposed to closing it), you lose your reservations and dump your 

local copy. It is recommended that you do not leave the project unless you do not plan to work on it any more 

in the foreseeable future. Typically, you will leave a Teamwork project when you no longer participate in it.

See also Close Teamwork Project.

Force Leave

See Force User to Leave a Teamwork Project.
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Send/Receive Changes in Teamwork

The Send and Receive commands send and/or receive changes - which have occurred since the last Send/

Receive.

Send and Receive commands are available

• from the Teamwork Menu, and

• from the Teamwork Palette

Changes to model data must be sent to the server and received by other users, in order for all users to have 

an up-to-date project.

Teamwork’s DELTA-Server technology ensures that only the changes since the last Send & Receive will be 

sent through the network and processed by the server or clients; this greatly reduces network traffic and 

improves performance.

Send/Receive commands involve refreshing BIMcloud data, but these commands do not save anything 

locally on your machine.

See also Save Local Copy of Teamwork Project.

Exception: If you do a Send or Receive, then close your project, a Save will automatically occur.

When you Receive from the server, your unsent modifications in your local copy are not affected – they 

remain intact.

Send/Receive does not affect the reservation status of data; reservation status is always up-to-date as long as 

you are online.

When you work offline, your copy of the project is by definition out of sync with Teamwork server data. When 

you go online again, you must do a Send and Receive to ensure that your data and also the server data are 

up-to-date.

ARCHICAD will prevent any user from reserving any element or data type that is not in sync with the latest 

server data. In such a situation, the program will enforce a Receive. Similarly, the program will prompt you to 

do a send or receive if that is required to carry out a command: for example, if you try to release an element 

without first having sent your changes to the server, you are prompted to “Send and Release.”

Warning: The project’s undo queue is cleared entirely whenever you issue any of the Send/Receive 

commands in Teamwork

Send & Receive, Then Compare

The Receive or Send & Receive commands can be used together with Model Compare. Use this Compare 

workflow in Teamwork after receiving changes, to see what has changed in the model.

See Compare Teamwork Model Versions (Before and After Receiving Changes).

Automatic Reminder to Send Changes

If you have been working in a Teamwork project for an extended period and/or have made numerous changes 

or edits to the project, ARCHICAD will display an on-screen notice that it may be time to Send your changes. 

• You can click Send from the notice itself to send your changes. 
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• Click Snooze to make the notice disappear immediately; it will not appear again for another 30 minutes or 

100 steps. 

• If you do nothing, the message will disappear on its own after 10 seconds.

This is an optional feature. Enable or disable it at Options > Work Environment > Data Safety and 

Integrity. Here, you can also set how often the notice should appear.

Reload Project from Server

This command is located at Teamwork > Project > Reload Project from Server.

Ordinarily, you do not have to use this command during your normal daily workflow. But if you are working 

along and then realize that you want to discard your local changes and start fresh, or if you suspect any kind 

of data error in the project you are working on, use Reload Project from Server. This means that your unsent 

changes will be discarded, and you will get the current, entire state of the project as it exists on the server. (In 

contrast, when you Receive project changes from the server, your local data, including unsent changes, 

remain intact.) 

Related Topic:

Compare Teamwork Model Versions (Before and After Receiving Changes)
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Manage Local Teamwork Data

You may have joined Teamwork projects in the past that are no longer active; in this case, you should delete 

the unneeded local data that is just taking up space on your machine.

The Local Data Manager (Teamwork > Project > Local Data Manager) feature gives you feedback to help 

you manage the local data from Teamwork projects you have joined.

Topics in this section:

What is Local Data?

Get Feedback on Local Teamwork Project/Library Data

Review Status and Properties of Local Data

Move Local Teamwork Data to a Different Folder

What is Local Data?

When you join a Teamwork project or link a Drawing from an external project, local copies of that project and 

of its libraries are created on your hard drive.

Local data are stored in your Local Data Folder, which by default is located in the “GRAPHISOFT” folder, 

under your user data, on your hard drive.

All data from all Teamwork projects, regardless of the ARCHICAD version they are in, are saved to this one 

location.

See also Save Local Copy of Teamwork Project.

When you Leave a Teamwork project, the local data for that project are deleted automatically. The problem of 

unneeded data only arises for projects that you remain joined into.

See Join or Leave a Teamwork Project.

Get Feedback on Local Teamwork Project/Library Data

To see the status and amount of local Teamwork data stored on your computer, go to the Local Data 

Manager dialog box (Teamwork > Project > Local Data Manager).

In this dialog box: 

• “Projects” are the locally saved data from your Teamwork Projects. (Project data includes the Embedded 

Library, but not any BIMcloud Libraries).

• “Libraries” are local copies of the BIMcloud Libraries used in one or more of your Teamwork projects.

Review Status and Properties of Local Data

Each project and library is listed with:

• Status: The project or library data’s status with respect to the server, e.g. “Unsent Changes” or 

“Detached”.

• Location: The folder of the project/library on the BIMcloud

• Last Used: This date is the last time you accessed this project.

For libraries, this date is the last time the library was downloaded to your machine (usually, the last time 

you opened a Teamwork project using this library).
ARCHICAD 24 Reference Guide 2292



Teamwork Collaboration
For any selected Project or Library in the list, view the Properties tab page for information on:

– the Name, Address and Availability of the Host Server or Module on which the project or library is 

located

– the Version, Size and Folder of the Project or Library
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Move Local Teamwork Data to a Different Folder

1. Close all running Teamwork projects. (Save and/or Send, as necessary.)

2. Go to Teamwork > Project > Local Data Manager

3. Click the Options button to open the Local Data Options dialog box.

4. Click Move...

5. In the appearing Browse for Folder dialog box, choose or create a new folder location.

6. Click OK.

All data is moved to the new location, and all Teamwork local data - regardless of ARCHICAD version - will 

henceforth be saved to this location.

Related Topics:

Move Local Teamwork Data to a Different Computer

Delete Local Teamwork Data

Schedule Teamwork Data Cleanup Reminder
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Move Local Teamwork Data to a Different Computer

IMPORTANT: It is possible to move your local data to a different computer, as described below. However, 

if you are working on one Teamwork project at a time, the Travel Pack function is the preferred workflow 

for transporting it between computers.

See Travel Pack: Move Your Teamwork Project and Libraries to a Different Computer.

The Travel Pack is optimized for transporting one project at a time, whereas moving local data involves all 

the data from all Teamwork projects on your machine.

It is possible to use the “Move Local Data” feature to move your local data to a different machine - for 

example, your home computer - via a pen drive:

1. At the office, move your local data to a pen drive.

2. Take it home. On your home computer, start ARCHICAD and use the “Move Local Data” function again, 

defining the folder on the pen drive as the new location.

3. Since this folder contains data, ARCHICAD will henceforth use this location and this data as Local Data.
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Delete Local Teamwork Data

Use the Local Data Manager (Teamwork >Project > Local Data Manager) to delete your local copies of 

Teamwork projects and libraries. This means, of course, that you will lose any changes that you have not yet 

sent to the server.

Deleting your local data is equivalent to leaving the project, except that your reservations will remain. Should 

you wish to work in the project again, you must again join the project, thereby downloading a local copy of the 

project as well as its libraries.

1. Go to Teamwork > Project > Local Data Manager.

2. From the list, select the Project or Library you wish to delete.

3. Click Delete at the bottom of the dialog box.

4. The selected project or library copy is deleted from your Local Data Folder.

Note: If you choose to delete the local data of a project from a BIMcloud that is online, ARCHICAD will 

recommend that you leave the project instead of just deleting the local copy, because leaving the project 

will also release your reservations.

In any case, if you should prefer to delete the local copy, you should also release your reservations.
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Schedule Teamwork Data Cleanup Reminder

To help with data management, you can set ARCHICAD to issue data cleanup reminders for data of a certain 

age.

1. Go to Teamwork > Project > Local Data Manager.

2. Click the Options button to open the Local Data Options dialog box.

3. Check the Run Local Data cleanup box.

– Enter the number of days - (for example 15). This means that ARCHICAD will check for old and 

unused data every 15 days.

– Enter the number of days (e.g. 15 days) beyond which a project is considered “old.”

4. At the scheduled intervals, ARCHICAD will suggest that you consider a cleanup of your local data, if old 

data is found.
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Working Online/Offline in Teamwork

At the top of the Teamwork Palette, you can view your online status:

The client machine must be online to use the following Teamwork functions:

• Reserve

• Send and Receive

• Messaging

If the client is offline, interface items relating to these functions will be grayed.

To work Offline, click “Work Offline” from the pop-up arrow at the top of the Teamwork Palette.

Click this command once more to go online again.
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Remote Access to Teamwork Projects

ARCHICAD supports several ways for you to access and work on a Teamwork project from different locations. 

This is helpful if, for example, you are traveling and want to take the project with you; or if you regularly work 

on the same project from several locations (e.g. home and work).

Related Topics:

Working from Home and the Office: Suggested Workflow for a Teamwork Project

Read this section for a step-by-step workflow.

Travel Pack: Move Your Teamwork Project and Libraries to a Different Computer

Read this section to find out how to move your project and/or libraries easily from one computer to 

another.

Avoid Conflicting Work Sessions in Teamwork Projects

Read this section to find out how to avoid losing edits due to conflicting work sessions from multiple 

locations.
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Working from Home and the Office: Suggested Workflow for a Teamwork 

Project

The following describes how to work on a single project while alternating between two online locations.

For alternative scenarios involving working offline and how to move project data, see: Travel Pack: Move Your 

Teamwork Project and Libraries to a Different Computer.

This scenario works under two conditions:

• You must have online access at both locations

• After each session, you must do a Send & Receive before closing the project

1. At the office, finish working, do a save and Send/Receive.

2. On your home computer, start ARCHICAD. You must be online to download the Teamwork Project and 

libraries from the BIMcloud.

3. Work on it as needed, either online or offline.

4. Once you finish, you must be online: do a Send/Receive.

5. Save and close the project.

6. Back at the office, open the project again.

7. On the office computer, do a Send & Receive. The modifications you made at home are now merged into 

the project on the office computer, and you can continue working.

You can keep going in this manner, alternating your home and office computers, as long as you need to.
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Travel Pack: Move Your Teamwork Project and Libraries to a Different 

Computer

The Travel Pack function creates a portable copy of your local data from the current Teamwork project. By 

converting your local data into a Travel Pack, you can transfer project data and/or libraries to a remote 

computer and continue working there.

Important: Make sure that you are using ARCHICAD programs with identical versions and identical build 

numbers, on both the remote and original computers. Otherwise, you will not be able to merge changes to 

the project.

Topics in this section:

Why Use a Travel Pack?

Create a Travel Pack

Import Travel Pack

What does “Traveling Mode” mean?

Travel Pack Workflow 1: Work on a Project at a Remote Location without Online Access

Travel Pack Workflow 2: Work on Single Project while Alternating Between Two Online Locations

Why Use a Travel Pack?

It is possible, of course, to just go to another computer and access and download the project from the 

BIMcloud through a network, or through the Internet. The Travel Pack, however, gives you more flexibility in 

accessing project data from multiple locations. Using the Travel Pack is recommended in the following cases: 

• You cannot access the BIMcloud from the remote computer. In this case, the only way you can 

access project data is to bring it with you to the remote computer.

At the original location, you will make a Travel Pack out of the project, take it home, unpack it, work on it in 

offline mode, pack it up again, then return to the original location (or other machine with convenient 

access to the BIMcloud). You can now go online and synchronize your local copy with the project data on 

the server.

• Your network or internet access is slow. While you can download the project over the internet at the 

remote location, the sheer volume of data makes this prohibitively time-consuming. Instead, create a 

Travel Pack at the original location, then open it at the remote location. This way, the project’s local data is 

saved to the machine - no downloading necessary.

When you do go online, all you need to do is send/receive changes to synchronize your local copy with 

the project data on the server. This requires much less data transfer capacity than downloading the entire 

project with all its libraries.

• You can access the BIMcloud easily, yet the project’s BIMcloud libraries are so large that you do 

not want to wait for the whole download. On the original computer, create a new shared project, adding 

the BIMcloud Libraries you will need. This project contains no model data, just libraries. Out of this, create 

a Travel Pack. On the remote computer, open the Travel Pack project: this step will unpack those libraries 

and save them to your Local Data folder. Now, access the BIMcloud to open the project itself, the one you 

want to work on. The program will find that the libraries have already been downloaded locally, so the 

download is limited to just model data - no library downloads.
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Create a Travel Pack

1. Open the project out of which you would like to create a Travel Pack.

2. If you plan to work on the Travel Pack project in offline mode, make sure you reserve all the data and 

elements you will need.

3. Save any changes to the project. If you are online, do a Send/Receive.

4. Use the Teamwork > Project > Traveling > Create Travel Pack command.

Note: If you are online and did not do a Send/Receive, you are prompted to do so.

5. The Create Travel Pack dialog box appears.

In addition to the project data, all of the project’s libraries will be included in the Travel Pack. If you prefer 

to include only certain libraries in the Travel Pack (or no libraries at all), click Custom, then Select 

Libraries to specify them. (Uncheck any libraries you do not want to include.)

Note: If you do not include libraries in the Travel Pack, your Travel Pack will be much smaller. However, 

the first time you use Travel Pack to transfer a project to a remote computer, make sure the Travel Pack 

does include the libraries you will need. In the next “round” of creating the Travel Pack, you can skip the 

libraries to save time in the packing/imported process, provided that the needed libraries still exist on the 

remote computer, and provided that no changes to the libraries have occurred on the server in the 

meantime.
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6. Click Create. The Pack Project dialog box appears. Choose a location to which to save the file (for 

example, a pen drive).

The file name of the Travel Pack is identical to the original project name by default, but you can enter a 

different name if desired. The file extension is *.twtravel.

7. Click Pack. This action will close the current project.

Important: Even if your Work Environment is set to automatically do a Release All when you Close the 

project, you will not release all your elements at this point.

See also Keep or Release Your Reservations with Send & Save.

If you have any unsent changes, you are notified that these will be saved before the project is closed.

8. The Travel Pack, containing your local copy of the project data and/or its libraries, is ready for transport.

Import Travel Pack

On any computer that is running a compatible version of ARCHICAD (with the same version number and build 

number as on the original computer), you can open the Travel Pack and keep working.

1. Go to Teamwork > Project > Traveling > Import Travel Pack and browse for the travel pack file.

2. Click Import.

If you have worked on this project on this computer before, and if the local data is still on the machine, you 

receive a warning, because presumably the two versions of the local data are in conflict. If you want to 

continue, click Overwrite: the data in the Travel Pack will replace the existing local data on the hard drive.

If you have not worked on this project on this computer before, then the Travel Pack is imported.
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3. Click OK to bring up the Open Teamwork Project dialog box. Choose a BIMcloud, then select the project 

and click Open.

Alternatively, click Import Travel Pack to import a different Travel Pack project.

Whenever you close a project that you imported from a Travel Pack, ARCHICAD will ask you whether you 

want to recreate the Travel Pack. You may want to do this, if you want to import the latest data back to its 

original location. Once you recreate the Travel Pack, the project’s local data is removed from the computer 

you have been working on.

See Travel Pack Workflow 1: Work on a Project at a Remote Location without Online Access.
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What does “Traveling Mode” mean?

Once you create a Travel Pack out of a project’s local data, that local data stored on the hard drive is flagged 

as being in Traveling mode. The Local Data Manager, as well as the Open Teamwork Project dialog box, will 

show this project with the status of “Traveling”.

The Traveling mode “flag” is removed from the project automatically as soon as you import a Travel Pack of 

that project.

If you later open the project again (rather than importing the Travel Pack) on the same, original computer, 

ARCHICAD will warn you that you have already made a Travel Pack out of the local data (and presumably 

have worked on it, or will work on it, at another location).

It is recommended that you do NOT unlock and open the project here, unless you are certain that will not 

import the Travel Pack onto this machine at a later time.

For such a scenario, see Travel Pack Workflow 2: Work on Single Project while Alternating Between Two 

Online Locations.

Travel Pack Workflow 1: Work on a Project at a Remote Location without Online Access

Suppose you are working on a Teamwork project from your office computer, but wish to take the project and 

work on it in offline mode on your portable notebook computer. For example, you are flying on a plane 

without internet access, but want to work during your flight.

1. Reserve all the data and elements you will need before creating the Travel Pack.

Create a Travel Pack at the office and save the resulting file (*.twtravel) to a portable device.

See Create a Travel Pack for details.

Note: The project’s local data on the original computer is now flagged as being in “Traveling Mode.”

2. Once you are on the plane, start ARCHICAD on your notebook.

3. Import the Travel Pack, then Open the project.

4. Work on the project as needed in offline mode.
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5. When you are done, close the project. The following dialog box appears:

6. Choose the first option to recreate the Travel Pack from the local data on your notebook, and save the 

resulting file (*.twtravel) to a portable device. The local project data is deleted from your notebook.

7. Back at the office, start ARCHICAD, import the Travel Pack, then open the project.

8. You are ready to work as usual.

Travel Pack Workflow 2: Work on Single Project while Alternating Between Two Online 

Locations

In this scenario, you make a Travel Pack once, to transfer the local data from Location A to Location B the first 

time. Once the local data exists in both places, there is no more need for a Travel Pack.

Important: You must issue the Send command, then the Receive command at the end of your work 

session at both locations. (Do not use Send & Receive.)

Note: To work from several online locations, you do not necessarily need a Travel Pack: if you can access 

the BIMcloud online, then you can download the project and libraries from any machine, work as needed, 

then Send & Receive before closing the project.

See Working from Home and the Office: Suggested Workflow for a Teamwork Project.

However, if you do not want to download the project data and/or libraries online, you can use the Travel 

Pack to transfer this data physically from one location to another, as described here.

This scenario works under two conditions:

• You must work online at both locations

• You must issue the Send command, then the Receive command at the end of your work session at both 

locations. (Do not use Send & Receive.)

1. At the office, finish working, do a save.

2. Issue the Send command.

3. Issue the Receive command.

4. Create a Travel Pack.

5. Do a save, then close the project.

See Create a Travel Pack for details.
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The local data on your office computer is now flagged as being in “Traveling” mode.

6. On your home computer, start ARCHICAD and unpack the project. Work as usual.

7. Once you finish, you must be online so that you can do a Send/Receive. 

8. Issue the Send command.

9. Issue the Receive command.

10. Save the project.

11. Close the project. The following notice appears:

Since you have done a Send/Receive, the local data is synchronized with the server, and you do not need 

a Travel Pack to move the local data manually back to the office. Choose the third option (Do not ask me 

again), and click Close. The local project data is no longer in traveling mode on your home computer, and 

is a regular Teamwork project.

12. Back at the office, open the project again. You are alerted that the local data on this computer is in 

Traveling mode.

13. Since the modifications you made at home have been sent to the server, you can go ahead and choose 

Unlock and Open. (The local data on your office computer will thus cease to be in Traveling mode.)

14. On the office computer, issue the Receive command. The modifications you made at home are now 

merged into the project on the office computer, and you can continue working.

You can keep going in this manner, alternating your home and office computers, as long as you need to:

15. On the office computer, finish working, issue the Send command; then issue the Receive command; do a 

save, then close the project. If you want to keep working at home, you do not need to make another Travel 

Pack, because the project’s local data is already on your hard drive at home.

16. On the home computer, start ARCHICAD, open the project, issue the Receive command. The 

modifications you made at the office are now merged into your local data at home, and you can continue 

working, with no further need for a Travel Pack.

17. As needed, repeat the process as described beginning at Step 6 above.
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Avoid Conflicting Work Sessions in Teamwork Projects

If you are working on a Teamwork project that you later plan to open from a different computer, make sure you 

send in all your changes before you close it.

If you open and work on a Teamwork project on one computer, then subsequently open it on a different 

computer, you may run into editing conflicts if you did not send in all your changes.

In this case, you will be warned of an Editing Conflict.

If you choose Edit Anyway, you will lose any unsent modifications that you made to this project from the first 

computer.

Therefore, when you return to this project on the first computer, you will be warned that the project version 

here is no longer current, and the unsent changes can no longer be sent in to the server.

You have these options:

• Discard Changes and Quit

• Discard Changes and re-Open: Open the project, losing the changes.

• Save solo Project: If you do not want to lose the changes, your only option is to save this version of the 

project as a solo project. Your edits will remain, but you can no longer send them in directly to the 

BIMcloud. You can, however, manually paste your elements into the Teamwork project.
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Teamwork Interface

Teamwork-related commands are available in these locations:

Teamwork Palette

• Teamwork > Teamwork Palette

• Window > Palettes > Teamwork Palette

For information on each control, see Teamwork Palette.

Teamwork Toolbar

• Window > Toolbars > Teamwork
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Teamwork Menu

Teamwork Data Location

Choose a default Teamwork Data Folder location at:

• Teamwork > Project > Local Data Manager, then click Options.

See also Manage Local Teamwork Data.

Libraries in Teamwork

• File > Libraries and Objects > Manage BIMcloud Libraries

• File > Libraries and Objects > Library Manager
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Reserving Elements in Teamwork

To modify or delete an element, attribute or other data type in a Teamwork project, you must first reserve it.

Reservation occurs automatically whenever possible.

Note: Automatic reservation not available in BIMcloud Basic.

Topics in this section:

Overview of Teamwork Reservation

Reserve Elements by Selection (Teamwork)

Reserve Elements by Criteria (Teamwork)

Reserve Library Objects (Teamwork)

Reservation Results (Teamwork)

Feedback on Element Ownership (Teamwork)
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Overview of Teamwork Reservation

Anyone can create new elements or data; no reservation is needed to create something new. For example, 

anyone can create a slab, or save a new view, and send it to the server.

However, to modify or delete an element, attribute, or other data type from the shared project, that element/

data type must first be reserved. Reservation can be done at any time as you work in ARCHICAD; you must 

be online.

New elements created by you are reserved by you automatically.

As soon as you reserve an element or project data, the reservation data is registered on the server, and all 

other users receive feedback that the element is now reserved by you; the reserved element will not be free 

for others to use until you release it.

Typically, you will reserve the elements only when you need them, then release them when you are done 

working on them.

Reservation status is always up-to-date as long as you are online; there is no need to send and receive to 

ensure that reservation data is current.

In Teamwork, you can reserve:

1. Elements. There are two ways to reserve existing elements: 

– Reserve Elements by Selection (Teamwork)

– Reserve Elements by Criteria (Teamwork)

2. Other Project Data. You can reserve many ARCHICAD data types, such as attributes and certain 

Navigator items, that are not elements.

See Reserving Teamwork Project Data (Non-Elements).

Auto-Reservation of Elements

Note: Not available in BIMcloud Basic.

Whenever possible, existing elements are reserved by you automatically after you select them and begin a 

modification. In case it is not possible – because one or more selected elements are reserved by someone 

else, or if you must first Receive unsent changes – then a warning will appear telling you what to do.

The Auto-reserve function is checked by default at Options > Work Environment > Data Safety & Integrity. 

If Auto-reserve should slow down your work, you will be prompted to uncheck this feature. You can then 

Reserve elements as needed, by clicking the Reserve button in Teamwork Palette or from context menus.

Conditions for Reserving

To reserve something, the following conditions must be true:

1. You are online.

2. The element/data type is not currently reserved by any other user.

3. Your role includes access rights to the element or data type.

4. The project is in updated condition on your machine.

Note: If you do try to reserve elements that are not up to date on your client machine, you will be alerted 

that a Receive is necessary before you Reserve.
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Reserve Elements by Selection (Teamwork)

Note: You must be online in order to reserve.

Follow these steps:

1. Explicitly select the element(s) which you want to reserve.

2. Click the Reserve button from the Teamwork Palette, or click Reserve Selected Elements from the 

window’s context menu:

Note on Marquee Selection: To reserve elements by selection in Teamwork, you must explicitly select 

them, so that they show selection dots. Then you can use the Reserve Selected Elements command. 

Placing a Marquee is not enough, because Marquee selection does not explicitly select elements.

You can, of course, use the Marquee to help explicitly select the items you need. For example, draw a 

Marquee, then use Select All (Ctrl/Cmd +A with Arrow tool selected) to select all elements inside the 

Marquee.

If it turns out that some of the elements you designated could not be reserved - because of ownership conflicts 

- then the Reserve button changes to Request, and lets you send a Request message to the elements’ 

owners, asking that they grant the element(s) to you now.

See also Request Elements or Project Data (Teamwork).

See also Reservation Results (Teamwork).

Reserving Marker Elements: Sections/Elevations/IEs and Details/Worksheets

Important: Reserving a source-type marker element means that you reserve the right to adjust the 

marker’s location and Settings. It does not mean that you reserve elements shown in the associated 

viewpoint.

To reserve a marker-type element - e.g. a Section line - select the Section marker, then reserve it using one of 

these methods:

• Use the Teamwork Palette’s Reserve command

• Use the Reserve Selected Elements command from the window’s context menu.

• Select the Section item in the Navigator and click the Reserve button at the bottom of the Navigator.

• Select the Section item in the Navigator and click the Reserve button from its context menu.
ARCHICAD 24 Reference Guide 2313



Teamwork Collaboration
ARCHICAD 24 Reference Guide 2314



Teamwork Collaboration
Reserve Elements by Criteria (Teamwork)

Use the Reserve Elements dialog box to reserve all the elements which are located in a given region of the 

project, and which fit the criteria you define.

For example: reserve every element on particular stories.

To bring up this dialog box, click the Reserve Elements or Reserve command from one of these locations:

• the Teamwork Palette

• the Teamwork menu

• the context menu of the active window

• the context menu of a Navigator item
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 In the Reserve Elements dialog box, you define

1. the Project Region; and

2. Criteria for which elements to reserve, within the Project Region

Reserving Elements by Criteria will NOT select the elements; the criteria act as a filter for reserving elements 

in Teamwork.

In the active window:

If you clicked “Reserve Elements” from the context menu of the active window, the current window is listed as 

the Project region.

In the Navigator:

If you clicked “Reserve Elements” by right-clicking a Navigator item, that item will be listed in the Project 

region.

• If you right-clicked the Layout Book, all Layouts and Master Layouts will be listed in the Project Region.

• If you right-clicked the View Map, all views of the Public View Map will be listed in the Project Region.

• If you right-clicked any Navigator Publisher Set, all views and/or layouts linked to this Publisher Set will 

be listed in the Project Region.

• If you right-clicked any Navigator Group (e.g. Subsets; Stories; Elevations), all elements of that group 

(e.g. all Layouts in a Subset, as in the image below) are listed in the Project Region.

Add/Remove Items from Project Region

The Project Region can contain the following:

• Any viewpoint

• Any view

• Any Layout or Master Layout

To remove any listed item from the project region of the Reserve Elements dialog box, select the item and 

click Remove.
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To expand the project region to include other viewpoints, views or layouts, click Add. This brings up the 

Choose Project Region dialog box, listing eligible Navigator items to add as the Project Region.

Click one or more of the Navigator items, then click OK to add them to the Project Region.

Define Reservation Criteria (Teamwork)

In the Criteria part of the Reserve Elements dialog box, choose the criteria with which to filter the elements 

that fall within the Project Region defined at the top of the dialog box.

See Predefined Criteria Sets.

Reserve Elements

Once you have defined the Project Region and the Criteria, click Reserve Elements.

The program now attempts to reserve all elements that (1) are located in the Project region you defined; and 

(2) fit the criteria you defined.

If this reservation attempt was unsuccessful, or only partially successful, the Last Reservation Results dialog 

box appears.

See Reservation Results (Teamwork) for details.

Which Elements Will Be Reserved?

• If you reserve elements on a viewpoint (without specifying any Layer-related criteria), the reservation will 

not take the current Layer Settings into account (this means, for example, that you may reserve elements 

that are currently hidden).

• If you reserve elements in a view (without specifying any Layer-related criteria), the program will take the 

current Layer Settings into account: only the elements on visible layers will be reserved.

• Defining a “Layer” or “Layer Combination” as a criterion means that the program will find and select the 

elements which are visible according to the given Layer Combination.

• If you reserve elements on a story, the program will reserve only those elements whose Home Story is 

located on that story. For example, if your Project region is Story 4, and there are roofs visible on that story 

- yet their Home Story is one story below - those roofs will not be reserved.
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• Reserving elements from a drawing-type viewpoint, such as a Worksheet or Detail, will only reserve 2D 

Drawing elements - no model elements.

• If you reserve elements from a Layout or Master Layout, the program will reserve 2D elements only: 

Drawings and other 2D drawing elements that have been placed on the Layouts/Master Layouts.
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Reserve Library Objects (Teamwork)

When you place a library object into a Teamwork project, the placed instance of this object is automatically 

reserved by you: you can graphically move or delete the object.

You can request or reserve other placed object instances, just like other elements in Teamwork.

If the object file is located in the Embedded Library, then you can also reserve this source file, independently 

of any of its placed instances.

To reserve an embedded object, go to the Embedded Library in Library Manager. Select the object file and 

click Reserve.

See also Library Manager.

You now own the source file of the object: you can modify its parameters (use File > Libraries and Objects > 

Open Objects). Your modifications to the object’s source file will be reflected in all placed instances (after 

Send & Receive), even those not reserved by you.
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Feedback on Element Ownership (Teamwork)

The following features give you instant information on which user has reserved which data/element. 

Info Tag

Colored Workspaces

Navigator Icons

Review Your Workspace (Teamwork)

Info Tag

In Teamwork, the Info Tag of an element belonging to you displays Editable:

If an element is owned by someone else, the Info Tag indicates Reserved by [Owner name]:

If a previously reserved element has been released, the Info Tag indicates that it is again Free for 

Reservation:

Colored Workspaces

The Colored Workspaces function, in the Teamwork Palette, provides feedback on reserved elements. This 

function works in the 3D window as well as 2D windows, and in the Interactive Schedule.

From the pop-up Colored Workspaces control of the Teamwork Palette (Window > Palettes > Teamwork), 

choose one of the options to help you easily identify the reservation status of project elements.

See also Defining the Colors in Colored Workspaces.
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See also Colored Feedback in the Interactive Schedule Window.

1. Highlight my reservation

Here, the Colored Workspaces option is set to “Highlight my Reservation:” this means that your own elements 

are shown using the Highlight color; all other elements are shown in the Passive color:

Other options in the Colored Workspaces function:

2. All with original Color: This is the default option, and essentially means that no reservation-specific 

colors are used.

3. Gray out Unowned Workspace: Everything which is NOT yours is shown in the Passive color. (Your 

own items are shown in their original colors.)

4. Show Reservation by Users: Each User’s elements are shown in the default user color, defined by the 

Server Administrator in User Settings.

See the BIMcloud User Guide for details.

All unowned elements are shown in the Free Elements color.

5. Own elements/free elements/other’s workspace: Your own elements in your own color; free elements 

in the Free Elements color; others’ workspace in the Passive color.
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6. Requested by me/From me/Other Elements: Requested by me and From me are shown in those 

respective colors; other elements shown in the Passive color.

7. Highlight Tracked Changes: Display a highlight on your tracked elements.

See also Change Tracking in Teamwork

Defining the Colors in Colored Workspaces

Depending on which Colored Workspace variation you choose, you will use one or more of the following 

colors:

• Highlight

• Passive

• Free Elements

• Requested by Me

• Requested from Me

These colors are defined in the Workspace Colors section of Options > Work Environment > On-Screen 

Options:

Redefine User Colors Locally

User colors can be helpful:

• to distinguish users of a project from each other, in the Teamwork Palette 

• to distinguish their workspaces by color, if you use the Show Reservations by User option.

See Colored Workspaces.

For example, if Bob’s default color is blue, then all users will see Bob listed with a blue color in the Teamwork 

Palette, and will see Bob’s reservations in blue when using “Show Reservations by User.”
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Default user colors are assigned in User Settings; any user can change his/her own default user color in User 

Settings.

See the BIMcloud User Guide for details.

Any user can also override a user color in ARCHICAD for local purposes (the changed color will be shown on 

your monitor only). To change a user color, select the User Name in the Teamwork Palette, then click the color 

icon to bring up the color chooser palette.

Once you change a user’s color on your copy of the project, the color block in the Teamwork Palette is shown 

as missing a corner, to indicate that this color is different from the global default color.
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Navigator Icons

In a Teamwork project, a green dot next to Navigator items means that the item is reserved by you.
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The Teamwork Status panel at the bottom of the Navigator (Palette only) also indicates whether the selected 

item is

• Editable (you can click Release if you no longer need it)

• Free for Reservation (click Reserve if you need it)

• Reserved (click Request to ask for it)

  

A newly created item that has not yet been sent to the server is displayed in green in the Navigator.
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Reservation Results (Teamwork)

When you attempt to Reserve a set of elements or data in Teamwork, it may occur that some of the elements 

cannot be reserved by you.

Reasons for a failure to reserve elements or project data:

• They are already reserved by another user

• They have been deleted

In such cases, the Last Reservation Results palette appears with feedback on the results.

Note: The Last Reservation Results palette also appears if you click “Reservation Results” from the 

Reserve pop-up button on the Teamwork Palette.

This palette lists the elements (by project region) and the project data that have run into a conflict:

• Elements by Project Region: For every Project Region listed, shows the number of elements 

successfully reserved and the number of elements that were not reserved due to a conflict.

For each of the rest of the groups listed in the Last Reservation Results Palette, the reservation result is 

indicated by a green light in the Reserved column; a red light in the Conflict column; or a gray light to indicate 

“No Access Right.”

• Navigator Item Settings

• Attribute Types

• Library

• Other Settings
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Select one or more item in the list and choose an option:

Release: Release the reservation for the selected region. Reserved elements listed here are now returned to 

their previous ownership status.

Show Conflict: (Available only if you have selected a single region in the list.) ARCHICAD will open the 

window of the selected region, and zoom into and select the unreservable element(s).

Show Successful: (Available from the Show Conflict button’s pop-up.) ARCHICAD will open the window of 

the selected region, and zoom into and select the successfully reserved element(s).

Open: (Available only if you have selected a single Navigator Item or Settings item in the list). ARCHICAD will 

open the selected Settings dialog box.

Request: Click this Request for all the “conflict” elements in the selected region(s). A Request message is 

created: click Send to send this message to the owners of all of these elements.

See also Request Elements or Project Data (Teamwork).
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Reserving Teamwork Project Data (Non-Elements)

See also Overview of Teamwork Reservation.

Any user, with the appropriate access rights, can create new data and send it to the server. However, to 

modify or delete shared project data, you must first reserve that data type. After reserving an attribute/project 

data type, the user can modify/delete items of that type.

To reserve project data types, just go to the relevant dialog box, palette or Navigator item, and view the 

Teamwork Status information at the bottom.

For Navigator items, the Reserve commands are also available in the context menu.

If the data is available, click Reserve to reserve it.
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Once you have clicked Reserve in a dialog box, that data type or attribute remains part of your workspace 

until you release it (even if you click Cancel to leave the dialog box).

When you Release a data type, any changes you have made are sent to the server, even if you then click 

Cancel to leave the dialog box.

Topics in this section:

Feedback on Ownership of Teamwork Project Data

Reservation in Attribute Manager; Reserve All Attributes (Teamwork)

Reserve Individual Views and View Map Folders

Reserve Settings of Layout Book Items (Teamwork)

Moving Views and Layouts in the Navigator: Reservation Requirements (Teamwork)

Reserve Publisher Sets (Teamwork)

Reserve and Delete Layers (Teamwork)

Reserve Find and Select Criteria (Teamwork)

Reservation in Interactive Schedules (Teamwork)

Reserve List Scheme Dialog Boxes (Teamwork)
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Feedback on Ownership of Teamwork Project Data

At the bottom of each dialog box (or at the bottom of each Navigator map), the Teamwork Status “control light” 

is color-coded to indicate the current status of that data type:

• Blue - Free for Reservation. The Reserve button is available. (Clicking Reserve also means that the 

reserved data type will automatically be synchronized with the server to ensure it is up to date.) 

• Green - Editable. This data type belongs to you; you can modify or delete these data as needed, or 

Release them using the button to the right. Changes are sent to the server.

There is an additional option for Releasing:

Release and Comment. The data is released, and the Release event is added, in the form of a comment, 

to the Activities panel of the BIMcloud. You also have the option to send a message at this time.

See Add Comment to Activities (Teamwork).

• Red - Reserved (by user name). The Request button is available.

See Request Elements or Project Data (Teamwork).

• Gray- Not Accessible. (The server is offline.)

• Gray - No Access Right: You have no access rights at all regarding an attribute category (neither 

“Create” nor “Modify/Delete”).

All users joined in to the project see these control lights, which are always up-to-date. (For example, if you 

reserve the Layer Settings dialog box, your control light turns green; at the same instant, the Layer Settings 

control lights of the other users turn red.)

A list of the Project Data owned by you is included in the My Workspace pop-up of the Teamwork Palette.

See Review Your Workspace (Teamwork).
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A newly created item that has not yet been sent to the server is displayed in green in the Navigator.
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Reservation in Attribute Manager; Reserve All Attributes (Teamwork)

Like other dialog boxes in Teamwork, the Attribute Manager has a control light system. You can reserve a 

particular attribute type by navigating to the tab page you need (e.g., Layers, as in the image below).

Click the Teamwork pop-up at the bottom of the dialog box and choose the Reserve command. Reserving 

Layers here is equivalent to reserving the Layer Settings dialog box.

Note: If the Teamwork pop-up is gray, it means you do not have the access right needed to delete or 

modify the attribute.

You also have the option to Reserve All Available Attribute types, from the same pop-up. This is equivalent 

to reserving all of the settings dialog boxes of all available attributes. Attributes you have reserved display a 

green control light on their respective tab pages in Attribute Manager, as well as in their respective Settings 

dialog boxes (e.g. Layer Settings).
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Similarly, you can release attributes either individually or all together, using the Release commands from the 

Teamwork pop-up.

Related Topics:

Attribute Manager
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Reserve Individual Views and View Map Folders

In a Teamwork project, there are two View Map modes: Public Views and My Views. Shared views must be in 

the Public View Map. To switch between View Map modes, use the pop-up at the top of the Navigator Palette 

View Map:

For more information, see My Views.

Reserve a View

Reserving a view means that you reserve the right to:

• modify the View Settings

• delete the view

• move the view in the View Map hierarchy

Note: To move a view, you must also reserve the view’s source folder and its target folder.

See: Moving Views and Layouts in the Navigator: Reservation Requirements (Teamwork)

In Public Views, use context menus in the Navigator to reserve the views that you need: right-click the view, 

then choose Reserve View Settings. Alternatively, select the view and click Reserve at the bottom of the 

View Map.

 Required permissions:

• Views and Folders - Delete/Modify

Reserve All Available Views

To reserve all available views in a View Map, or one of its folders, right-click the View Map folder, then choose 

Reserve with all available sub View Settings and Folders.

If the selected folder itself is available too, the command is: Reserve Folder with all available sub View 

Settings and Folders. (This will reserve the selected folder, plus all available items that it contains.)
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Available items are those not currently reserved by any other user.

Reserve a Clone Folder

To reserve a Clone Folder, select it and choose Reserve Clone Settings from the context menu.

Reserving a clone folder thus allows you to alter the clone folder settings. (As a result, any new views added 

to the clone folder will take on these settings.)

See Clone a Folder in the View Map.

However, alterations to the clone folder settings will only affect the views in that clone folder which you have 

already reserved. Settings of cloned views that are owned by others will not change even if you change the 

clone folder settings.

Note: If you change clone folder settings but have not yet reserved all views in that cloned folder, you 

receive a reminder to this effect.

My Views

In addition to the Public View Map, you can use the local “My Views” mode in the Navigator Palette View Map. 

Views in “My Views” are visible and accessible only by you - they are not shared, and they cannot be sent to 

the BIMcloud with the Send command.

To use “My Views,” just click “My Views” from the pop-up at the top of the Navigator Palette View Map.
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To add a view to My Views, make sure that the View Map in the Navigator Palette is in My Views mode. Now, 

whenever you create a new view, it will be placed into My Views.

Alternatively, set up the Organizer with Public Views on one side and My Views on the other, and copy views 

from one to the other as needed.
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Reserve Settings of Layout Book Items (Teamwork)

Note: To reserve the Settings of a Layout, Master Layout or Subset, you must be assigned the role: 

Layouts and Subsets - Delete/Modify. If you do not have this role, the corresponding commands are not 

available.

Reserve Layout Settings

Use context menus in the Navigator to reserve the Layouts you need: right click the Layout, then choose 

Reserve Layout Settings. (The same applies to Master Layouts.) Alternatively, select the Layout and click 

Reserve at the bottom of the Layout Book.

Reserving a Layout’s Settings means that you reserve the right to:

• modify Layout Settings

• delete the Layout

• move the Layout within the Layout Book structure

Note: To move a Layout, you must also reserve the Layout’s source folder and its target folder. 

See: Moving Views and Layouts in the Navigator: Reservation Requirements (Teamwork)

To reserve Settings of all available Layouts in the Layout Book, or all Layouts in one of its Subsets or in the 

Master Layouts folder, right-click the Layout Book name (or the Subset/folder), then choose Reserve all sub-

items.

If the selected folder itself is available too, the command is: Reserve with all available sub-items. This will 

reserve the settings of the selected folder, plus the settings of all available items that it contains.

Available items are those not currently reserved by any other user.

Reserve Subset Settings

Use context menus in the Navigator to reserve the Subsets that you need: right click the subset, then choose 

Reserve Subset Settings. This gives you the right to modify Subset Settings.

Note: Modifications to Subset Settings will affect all Layouts in the Subset, even those owned by other 

users.

Reserve Layout Book Settings

To reserve Book Settings, right-click the project name at the top of the Layout Book tree structure and click 

Reserve Book Settings.
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Reserving the Layout Book gives you the sole right to edit Book Settings.
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Moving Views and Layouts in the Navigator: Reservation Requirements 

(Teamwork)

You can use Drag and Drop to rearrange views and Layouts in the Navigator, and to assign a Master Layout 

to a subset or Layout.

In a Teamwork project, you can only do this if you have reserved:

• the item itself (the one you are moving)

• all the sub-elements of item(s) you are moving

• the target folder to which you are moving the item(s).

If you are missing any of these reservations, you will get the following alert:

If you click Continue, the required reservations are carried out automatically (if this is possible).

If it is not possible to reserve the needed items (because they are reserved by other users), you are alerted to 

this.

Note that if you drag a Master Layout onto a Subset in Layout Settings, the automatic reservation (if 

available) will reserve every sub-element in that Subset (all Layouts and all Drawings).
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Reserve Publisher Sets (Teamwork)

To reserve a Publisher Set, open the Publisher Set page from the Navigator Palette.

In a Teamwork project, there are two Publisher Set modes: Public Sets and My Sets. Shared Publisher Sets 

must be placed in the Public Sets list.

Since there can be multiple public Publisher sets, you must specify which one you want to reserve. Navigate 

to Public Sets Management (use the “One Level Up” button) to see the list of public Publisher Sets.

From the Public Sets Management list, choose the desired Publisher Set. Click Reserve at the bottom of the 

Publisher Set page to reserve it; or click Reserve from the context menu.
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Reserve and Delete Layers (Teamwork)

To assist in your design work, you can change layer states and create new Layers or Layer Combinations, 

even if the Layer Settings attribute has been reserved by someone else.

However, to save and share these changes to the project, or to delete layers, you must reserve Layer 

Settings.

To reserve Layer Settings, open the Layer Settings dialog box, and click Reserve.

If you delete layers, any of your own elements located on those layers are also deleted.

However, elements on deleted layers are NOT deleted if they are owned by other users. Such elements will 

be identified as having “MISSING” layers. These elements will be displayed on all outputs; their visibility 

cannot be changed.

If you find that your elements are located on a deleted (“MISSING”) layer, you should either delete these 

elements or move them onto another layer.

To easily identify which of your elements are on “MISSING” layers, just hide all project layers: elements whose 

layers are missing (plus any elements on the ARCHICAD Layer) will be the only elements that are still 

displayed.

See also Delete Layer/Move Elements.
ARCHICAD 24 Reference Guide 2341



Teamwork Collaboration
Reserve Find and Select Criteria (Teamwork)

In a Teamwork project, the Find & Select Palette contains a number of built-in Criteria Sets.

See Find and Select Elements.

Additional Criteria Sets customized by you can be stored either locally (My Criteria Sets) or shared and 

reserved (Public Criteria Sets). Click the Criteria Sets pop-up to see which Criteria Sets are available to your 

project:

The “control light” (green, blue or red) lets you know whether Public Criteria sets are Reserved by you, 

Available for reservation, or Reserved by someone else.

Use any of these Criteria Sets to Find & Select elements in your project, even if the Public Criteria Sets are 

reserved by someone else.

These same Criteria Sets are available in the Reserve Elements dialog box.

See Reserve Elements by Criteria (Teamwork).

While any user can use the criteria sets regardless of ownership, you must reserve Public Criteria Sets in 

order to

• Store a custom Criteria Set as a Public Set

• Overwrite an existing Public Criteria Set

• Delete a Public Criteria Set

To reserve the project’s Public Criteria Set, click this command from the pop-up at the top right of the Find & 

Select dialog box.
ARCHICAD 24 Reference Guide 2342



Teamwork Collaboration
Reservation in Interactive Schedules (Teamwork)

Reserve Schemes for Interactive Schedules

Reserve Elements from IS List Window

Reserve All Elements of a Schedule

Colored Feedback in the Interactive Schedule Window

Reserve Schemes for Interactive Schedules 

Do one of the following:

1. Open Scheme Settings.

2. Select the scheme you wish to reserve.

3. If it is free for reservation, click Reserve.

Alternatively:

1. Open the Interactive Schedule window.

2. At the bottom left corner, click Reserve.
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Reserve Elements from IS List Window

You can reserve any elements directly from the Interactive Schedule window.

1. In the Interactive Schedule window, select the element(s) you wish to reserve.

2. A message at the top of the window provides feedback on the elements’ reservation status.
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“Elements referred by the selected item” means that the selected item does not correspond to a single 

element. In the picture above, the single element selected in the schedule (Masonry Block) actually refers 

to four different elements, as indicated by the “Selected: 4” information at the top. Thus, one or more of 

these four walls is reserved by another user; the Teamwork Palette shows the Request command.

3. If the element is free for reservation, click Reserve from the Teamwork Palette. (If it is reserved by another 

user, you can Request it.)

Even if the selected element is free for reservation, or if you have already reserved it, it may still not be 

possible for you to edit it. In this case, the Interactive Schedule window will provide information about the 

problem, as in these cases:

• if the element’s layer is locked or hidden. You must unlock or unhide the layer before you can edit the 

element;

• if you do not have the Access Right needed to edit the element

• if the element is not up to date in your workspace. You must Receive changes before you can edit it.

Reserve All Elements of a Schedule

1. Open the Interactive Schedule window.

2. From the Teamwork Palette, click Reserve Elements to open this dialog box. 

3. The Project Region section contains your Interactive Schedule. In the Criteria section, ensure that “All 

Types” is chosen as the criterion, then click Reserve Elements.

See also Reserve Elements by Criteria (Teamwork).
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Colored Feedback in the Interactive Schedule Window

You can use Colored Workspace options to indicate element ownership. (For example, you can show each 

schedule item is shown in the color of the user who has reserved it, by switching on “Show Reservation by 

Users” in the Teamwork Palette.)

If a selected schedule item is free for reservation, you can reserve it from the Teamwork Palette, using 

“Reserve.”
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Reserve List Scheme Dialog Boxes (Teamwork)

The following functions of the Calculation List feature can be reserved using the control light interface:

• Set Up List Schemes

Note: List Schemes will function in Teamwork projects only if you save them to the project’s Embedded 

Library.

• Edit Database

• Link Properties to Criteria

For details on the Calculation List feature, see Calculation (Legacy).
ARCHICAD 24 Reference Guide 2347



Teamwork Collaboration
Reserve All Elements and Data (Teamwork)

The Reserve All command will attempt to reserve all existing elements and project data in the currently 

opened Teamwork Project.

This function can be useful if you expect to be the only user on a project for a given period of time.

The Reserve All command is available:

• From the Teamwork menu

• From the Teamwork Palette “Reserve” pop-up:

If the attempt to Reserve All runs into conflicts, the Reservation Results dialog box appears.

See also Reservation Results (Teamwork).
ARCHICAD 24 Reference Guide 2348



Teamwork Collaboration
Review Your Workspace (Teamwork)

For an overview of all project items (both elements and non-elements) reserved by you, go to the Workspace 

panel of the Teamwork Palette and click the My Workspace button:

Select any item on this Workspace pop-up and click Show (to zoom to elements) or Open (to open the 

relevant dialog box), depending on the item you have selected.

Click Release if you are ready to release the selected item.

Related Topics:

Feedback on Element Ownership (Teamwork)

Feedback on Ownership of Teamwork Project Data
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Creating and Sending Project Data (Teamwork)

Create New Data

Regardless of reservation status, any user having the necessary access rights can create and store new 

project data, and you can modify such data locally.

For example, any user can create a new Fill Type even if he/she has not reserved the Fills dialog box.

If you create a new attribute or other data type, you are free to modify and delete it. Until the first time you 

issue the Send command, the name of the newly created data type is shown as underlined in the dialog box 

(like Pavement 20 in this image), indicating that no other users are able to see or use this attribute.

Send New Data

If you create a new attribute or other non-element data type, use Send to send it to the server.

If, at the time you want to send changes, the data type is reserved by another user, you will be warned that 

you cannot send in any changes:

To resolve this situation, you can:

• Get the owner of the data type to release it right now, then Retry

• Cancel, then reserve or request the data type (e.g. Fills Dialog Box), then Send again

• Delete the new data (e.g. Pavement 20), then Send again

New Data in the Navigator

When you create a new Navigator item (e.g. a new view), its Settings are automatically reserved by you. A 

newly created item that has not yet been sent to the server is displayed in green in the Navigator.

 Required permissions to create a new view or Public View Map Folder:

• Views and Folders - Delete/Modify

 Required permissions to create a new Layout, Subset or Master Layout:

• Layouts and Subsets - Create
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Assign Elements (Teamwork)

You can assign any of your own elements to another user, even if that user has not requested them.

To do this, select the element(s), then the Assign Selected Elements to command from the context menu or 

the Teamwork menu. Choose the user to whom you will assign the elements.

In the appearing dialog box, add any message, then click Assign to complete the operation.

The recipient is automatically notified of this assignment via a message.

If the assigned element is not in updated condition, you are prompted to Send your changes to the server first.
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It is possible for you to be assigned an element that is not yet in updated condition on your client machine. In 

this case, you cannot edit your new acquired element until you do a Receive. This is indicated in the element’s 

Info Tag:

Related Topic:

Assign Issue to User
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Request Elements or Project Data (Teamwork)

Use Request if the element you wish to reserve is currently owned by another user.

You must be on-line to Request.

The Request command is available from the following locations:

• in the Teamwork Palette

• in the context menu of selected Navigator items

• in the context menu of selected elements

• in the dialog box of project data (for example, Model View Options)

• from the Last Reservation Results dialog box.

See Reservation Results (Teamwork).

Clicking the Request button here means you request the “Conflict” items from their owners.

Click Request.

The Ownership Request dialog box appears, which includes:

• an automatically generated message about the requested items and their location

• an attached model view, which includes camera position, cutting planes and layer settings as applicable

• the number of requested elements. You can still change this set of elements before sending the message: 

reselect elements, then update the request message by clicking the popup next to the number of elements 

currently attached

• a preview of this attached view

If you don’t want to include this view, click Remove View.
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You can add and modify the text as needed; then click Request.

See also Request Elements or Project Data (Teamwork).

Whenever you send a Request message, it is filed in your Pending Requests list.

Concurrently, the Request message is delivered to the owner’s To Do list.

If the owner is not currently on-line, the Request will be delivered as soon as the user goes on-line.

If the owner releases the requested item independently of the Request message, the requesting user 

automatically receives the item.

If you open one of your Pending Requests, you get a status report: how many of the requested items have 

been granted/denied and how many are still pending. You can opt to revoke a pending request: click Revoke 

Request.
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Received Ownership Request

The owner receives the message; the user can respond to the request via the Teamwork palette, by clicking 

the triangle to show relevant commands, or double-clicking it to open the request:

• Open Message: Same effect as double-clicking the item, or clicking on the fly-over message notice.

• Mark as Read: Unopened messages are listed in bold typeface. You can remove the bold typeface using 

the Mark as Read command. (Double-clicking the message to open it will also mark it as read.)

• Show Elements/Dialog: Zoom in to view the requested element(s) or to open the corresponding dialog 

box.

• Deny Request. Click this if you do not want to release the elements. The elements remain in your 

workspace.

• Grant Request: Click to approve the request. If you grant a Request, this means you have released the 

item, which is now instantly and automatically reserved by the user who sent the request.

In the Received Ownership Request message:

• Apply View: Click this to open the attached view (if any) of the requested element(s). (This command only 

appears if a view is attached by the sender.)

• Restore View: This button appears if you have clicked Apply View (see above). Restore View will return 

you to the previous model view.

• Show Elements: This command zooms in to and selects the requested elements.

Once the owner grants or denies a Request, the associated request message is automatically moved to the 

user’s Completed list.
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At the same time, the user who issued the Request receives the response in their own To-Do list: (the 

message is concurrently removed from their Pending list).
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Release Elements or Project Data (Teamwork)

Release Project Data

To release project data owned by you, open the relevant dialog box (or select the item in the Navigator), then 

click the Release command from the bottom of the dialog box (or from the Navigator item’s context menu).

When you Release a data type, any changes you have made are sent to the server, even if you then click 

Cancel to leave the dialog box.

Release Selected Element(s)

To release an element currently owned by you, select it, then click the Release Selected command from one 

of these locations:

• the Teamwork Palette (choose either the Release button or the Release Selected and Comment option 

from the pop-up)

• the Teamwork menu

• the context menu of the selected element

Once released, an element is shown as “Free for reservation” in the Info Tag.

It can now be reserved by another user.

If any user has already sent in a request for this element, then he/she will automatically receive the element 

(and a message) as soon as it released.
ARCHICAD 24 Reference Guide 2357



Teamwork Collaboration
Before releasing a modified element, you must send your changes to the server:

Release All

If nothing is selected, the button in the Teamwork Palette changes to “Release All.” This will release all of your 

reservations: elements and project data alike.

Click the pop-up button to access other Release commands:

Release with Close

See Keep or Release Your Reservations with Send & Save.

Release and Comment

Release commands on the Teamwork Palette and in project data dialog boxes include an option to “Release 

and Comment.” Choose this to add a comment to the Activities panel of BIMcloud (with or without a message 

to other users) to report the Release event.

See Add Comment to Activities (Teamwork).
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Messaging (Teamwork)

Messaging is integrated in the Teamwork Project: its context-driven functions are tied to elements and actions, 

so that many messaging functions are automated, reducing the amount of user-initiated communications 

needed.

For example, when requesting an element, you don’t need to explain which one you need: just select it and 

click “Request.” The owner immediately and automatically receives a message (with built-in response 

commands) that displays exactly which element you have requested. This way, responding to messages is 

both easy and productive.

Every time you receive a message, an alert appears on your screen.

Note: If you do not want to see these alerts, uncheck the “Show New Message Alert in Teamwork” box at 

Options > Work Environment > More Options.

You can click this alert to view the message and respond to it as needed, or ignore it and keep working until 

you take the time to deal with the new messages.

You can communicate with users who are not online at the moment: they will receive their messages the next 

time they are online.

Teamwork’s messaging system supports all types of textual input. Any keyboard character can be entered in 

messages, including special language characters. Graphical data, attachments and hyperlinks are not 

supported.

The Messages panel, available from the Teamwork Palette, has three tabs.

• The To Do list shows you items which await action from you. New messages arrive here, including 

notification of the outcome of your Requests. (for example, “Granted request: Elements on the 1. Story;” 

or “Denied request.”)
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• The Pending Requests list stores request messages sent by you, which are still pending.

If a pending request (or a part of it) is completed, then it automatically moves to the To Do list, letting you 

know that you can start working with the elements. (Such items are automatically removed from the 

Pending Requests list.)

If you sent a request to more than one user, then each response will appear as a separate message on 

the To Do list. Your request will remain in the Pending Requests list until the last answer arrives.

If you open one of your Pending Requests, you get a status report: how many of the requested items have 

been granted/denied and how many are still pending.

If you requested an element from someone who simply released the element without responding 

specifically to your request, the element is then automatically given to you. Your request is then moved 

from the Pending Requests list to the To-Do list, in the form of a No pending elements” message.

• The Completed list is a repository of messaging actions that are no longer pending and no longer require 

action by you. You can also move an item from the To Do list to the Completed list manually: 

• Select the item, then the Move to Completed command from the context menu or from the drop-down 

menu (if available).

• Click the Move to Completed icon the bottom right corner.

Exception: If a message is expecting a response from you, then you cannot move it to the Completed list; 

you must first answer that message. (These messages are typically Requests, requiring an answer of 
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Grant or Deny.) Once you answer with a Grant/Deny, then the message automatically moves to the 

Completed list.

• To delete one or more messages from the Completed list, select them and click the Delete item at the 

bottom of the list.

Related Topics:

Request Elements or Project Data (Teamwork)

Create a New Message (Teamwork)

Receive and Open Message (Teamwork)

Review Elements (Teamwork)

Change Tracking in Teamwork
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Create a New Message (Teamwork)

To create a new message, click the Send New Message icon at the bottom of the Messages Panel of the 

Teamwork Palette, or use Teamwork > New Message.

Alternatively, select one or more user names from the Teamwork Palette’s Users panel, or from the context 

menu, and click the same icon there. The selected names will appear in the message’s To: field.
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Choose Recipients

Click the To: button to bring up a checklist of users who are logged in to the project (whether currently online 

or not). Choose the recipients of your message, or click “All Users” to include everyone joined in to the project.

For extra emphasis, you can choose to add a High Priority icon to your message from the pop-up at the top 

right. High priority messages are shown in the recipient’s To Do list with a colored background.

Type in the desired text message, and click Send.

Add a Task Request

You can make it easier for the message recipient if you add a pre-programmed task request as part of your 

message.

Before sending your message, you can optionally add a task button, so that the recipient’s copy will contain 

not only the message you typed, but also the specified command button, to facilitate a quick response.
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Click the Optional Task pop-up in the New Message dialog box:

For example, if your message asks the recipients to send in all their work, you can attach a Send Changes 

button to your message. In complying with your request, the recipient needs only to click this Send Changes 

button from the message.
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Receive and Open Message (Teamwork)

To view a new message and related options, do one of the following:

• Click on the on-screen message alert

• Click the pop-up of the new message in your To-Do list, and choose one of the options:

If the sender has included a Task as part of the message, the related command is shown here: click to 

complete the Task.

The same options are available if you open the message.
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Review Elements (Teamwork)

If you want to discuss certain element(s) with a fellow user, it often easiest to ask them to take a look. In 

Teamwork, this is easy:

1. Select the element(s) in question.

2. From the context menu or Teamwork menu, choose “Review Selected Elements.”

3. Select the user(s) who you want to review the elements.

4. The New Element Review includes an attached view, plus the number the elements in question.

5. Click Send.

6. The recipient clicks “Show” to see the elements under review.
ARCHICAD 24 Reference Guide 2366



Teamwork Collaboration
Add Comment to Activities (Teamwork)

Comments are optional texts that are recorded in the Activities panel of the BIMcloud Manager.

To add a comment to the Activities log, do one of the following:

• Use Teamwork > Project > Add Teamwork Comment

• Choose Send Changes and Comment or Release and Comment from the pop-up or context menu of 

the regular Send and Release commands.

The appearing Add Comment to Activities dialog box may contain an automatically generated text about the 

action you have just taken. (If you just issued the Add Teamwork Comment command, the field is empty.)

Type any text into this field. When you click OK, the comment will be added to the Activities panel of this 

project in BIMcloud Manager.
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Notify Others by Message

In addition to sending the Comment to the Activities panel, you can notify any other user at the same time, by 

sending a message.

When the Add Comment dialog box appears, check the “Notify Others by Message” box:

Define the message recipients and add an optional task as with regular messages.

See Create a New Message (Teamwork).
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Libraries in Teamwork

A Teamwork Project uses two types of libraries: the Embedded Library plus the BIMcloud Libraries. Just like in 

any ARCHICAD project, these libraries are listed in the Library Manager.

See also Library Manager.

In order to use a BIMcloud library in a Teamwork project:

• the library must first be uploaded to a BIMcloud Server; 

• and then it must be added to the project using ARCHICAD’s Library Manager.

See Upload a Library to BIMcloud.

See Add BIMcloud Library.

Linked libraries cannot be used by Teamwork projects; this limitation is necessary to ensure that all users 

have access to all library objects, even when working offline.

Therefore, the process of Sharing a Teamwork project includes uploading the project’s linked libraries to the 

server.

See Libraries.

Embedded Objects in Teamwork

Embedded objects are added to the Embedded Library of Teamwork projects, just like solo projects. If a user 

adds an embedded object, all other team users - after they do a Receive - can access and place the object. 

Such object instances can be reserved in Teamwork just like any other element.
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If you work in Teamwork, you must embed objects created by Add-ons, like trusses, otherwise editing these 

elements will not be possible. It is highly recommended to embed custom objects and custom door/window 

components.

If you want objects to be accessible to all Teamwork users and avoid editing conflicts, you MUST either save 

them to the Embedded library (when you initially create them), or add them to the Embedded library (if they 

have been saved to another location).

Reserve Placed Object vs. Reserve Embedded Object

You can reserve a placed object in the project, and you can also reserve an Embedded Object from the 

Library Manager (or Object Editor).

These two reservations are entirely unrelated. When you reserve a placed instance of an object in the project, 

you can then edit its Object Settings, either in place or in the Settings dialog box. Your edits will affect only the 

particular object instance you have reserved.

It is possible to reserve an Embedded Object itself (as opposed to its placed instance), either in the Library 

Manager, or in the Object Editor. (Both locations will indicate the object’s reservation status; they are in sync.) 

You can then edit its script in the Object Editor. Editing the script will affect all instances of this object in the 

project, regardless of who has reserved those instances.
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External Files Linked to Teamwork Project

The following sections describe how to manage external content linked to a Teamwork project:

Hotlink Modules and XREFs in Teamwork

External Drawings in Teamwork
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Hotlink Modules and XREFs in Teamwork

You can work with Hotlinks in Teamwork just as in solo projects, provided that you have the requisite access 

rights and reservations. 

Place New Hotlinks

• You must have the “Hotlink and XREF - Manage” access right.

Relink a Hotlink Source File

• You must have the “Hotlink and XREF - Manage” access right.

• You must have the “Hotlink - Instances” access right.

Update a Hotlink

• You must have the “Hotlink - Instances” access right.

Update a Hotlink Source File

• You must have the “Hotlink and XREF - Manage” access right.

How to Reserve Hotlink Module Manager

When updating a Hotlink, the Hotlink Module Manager will be reserved automatically in the background, if it is 

available, and then released after the update. 

Go to the Hotlink Module Manager (File > External Content > Hotlink Module Manager) and click Reserve.

Updating a Hotlink will update all module instances, regardless of who owns the instances.
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If you Change or Delete or Relink a Hotlink module in the Hotlink Module Manager, this action will affect only 

those instances of the Hotlink module which you have reserved. (Hotlink Module Manager will be reserved 

automatically in the background, if it is available, and then released after the action.) 

The same is true for deleting or replacing XREF instances.

How to Reserve a Hotlink Module Instance or XREF Instance

By placing a Hotlink Module instance, you automatically reserve it.

A placed Hotlink Module or XREF instance can also be reserved or requested by others like any element, 

using the commands of the Teamwork Palette and the context menus.

Reserving a Hotlink Module or XREF instance means that you have the right to move it or delete it. You can 

also modify its settings (e.g. its orientation/rotation, Master Layer, height and elevation/story values) and 

replace it with a different Module.

Attach New XREFs

• You must have the “Hotlink and XREF - Manage” access right.

• You must reserve the Xref Manager.

Attach or Modify Existing XREF References 

• You must have the “XREF - Instances” access right.

Explode Hotlink Module Instance in Teamwork

The Break command is not available for Hotlink Modules in Teamwork. However, you can explode individual 

Hotlink instances.

1. Select the Hotlink on the Floor Plan.

2. Use the Explode Hotlink command from the context menu, or from File > External Content.

Note: With this Explode command, any dimensions that were added to elements in the module will be 

lost. Also, Solid Element Operations connections will be lost.
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Relink from Teamwork Project

When you relink Hotlink Sources, you must first reserve all the Hotlinks you want to relink. If this is not the 

situation, then a dialog will prompt you to reserve individual Hotlinks:

 

• Continue anyway: (Available only if one or more Hotlinks of the source file are not reserved by you.) If 

you select this option, then only the instances reserved by you will be relinked to the new source. Hotlinks 

not reserved by you will remain linked to the original source.

• Reserve all instances: If you select this, the Hotlink Module Manager will close, and Hotlink instances 

will be reserved. After this process is finished, open the Hotlink Module Manager again, and start relinking 

again.

Hint: Reserve the Hotlink modules you want to relink before you begin Relink from Hotlink Module 

Manager.
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External Drawings in Teamwork

As in any ARCHICAD project, you can place an external Drawing into a Teamwork project. To place an 

external Drawing, you must have the access right “External drawings - Manage”.

Note: If you do not have this right, you cannot place an external drawing into the project, nor can you re-

link an existing Drawing to any external source. You can, however, delete or copy a placed external 

drawing after reserving it; you can also update any drawing.

If you have this right, just use the File > External Content command to place a drawing as usual.

The external Drawing may have its source in another Teamwork Project. In this case, use the File > External 

Content > Place External Drawing from BIMcloud command.

Note: Keep in mind that if you link a drawing from a Teamwork project, that source Teamwork project must 

have the same version number as the host project.

See Import View(s) from External ARCHICAD Project (Solo or Teamwork).

In the appearing dialog box, choose the BIMcloud and the project you need.

Important: To access the server and its projects, your user name must be present on the Teamwork 

project’s User list.

See the BIMcloud User Guide for details.

External Drawings in a Teamwork Project, like any ARCHICAD project, are managed in the Drawing Manager.

See Managing and Updating Placed Drawings.

To use the Drawing Manager commands, you must have reserved the Drawing(s) that you are managing.

Exception: You do not have to reserve the Drawing in order to Update it.
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Hotlink Modules

Topics in this section:

About Hotlink Modules

Place Hotlink

Edit Hotlink Module Content

Hotlink Settings

Hotlink Module Manager

Create Module (.mod) File

Save Selection in PLN Format

Hotlink Modules and XREFs in Teamwork

Compare ARCHICAD Models Before and After Hotlink Update
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About Hotlink Modules

Hotlink Modules allow you to insert the contents of external files (sources) into the currently open Project 

(host). 

Hotlink Modules can be used, for example, to manage the repetitive structures of buildings such as hotels or 

offices with a large number of identical rooms: if rooms are placed as a Hotlink module, you can modify all the 

rooms in one step, by just updating the module’s source file. Moreover, the same structures can be used in 

multiple projects.

When updating a Hotlink Module, you have the option to launch the Model Compare window, which helps you 

visualize exactly what has changed as a result of the update.

See Compare ARCHICAD Models Before and After Hotlink Update.

The source file of a module can be:

• ARCHICAD file types:

– Solo Project (.pln)

– a Module-type file (.mod)

– a Teamwork Project from a BIMcloud (of the same ARCHICAD version as your host project) 

– a Teamwork Project (.plp file types from ARCHICAD 11 or earlier)

– ARCHICAD 2D Lines (.2dl)

• an IFC file
ARCHICAD 24 Reference Guide 2377



Hotlink Modules Collaboration
• a Rhino file (.3dm)

Elements belonging to a selected Hotlink have hollow square marks on their hotspots. If several Modules are 

selected, their selection dots will have different colors to help you distinguish them.

Characteristics of Hotlink Modules

• Modules are stored in the host Project: even if the Source file is not currently available, the Module is still 

present and visible. However, the Module can’t be updated as long as the referred source file is 

unavailable.

• The placement parameters (e.g. orientation, Master Layer) of each Hotlink can be different even though 

they share the same Module source.

• The placed Hotlink can only be edited as an entity. Its elements cannot be edited as long as they remain 

part of a Hotlink.

• You can use Find & Select command to locate Hotlink Module elements.

Attributes of Hotlink Modules

• If the elements of the Hotlink Module use attributes with the same names as attributes of the Host Project, 

the Host attributes will be applied. 

• If no attributes of that name exist in the Host, new attributes will be added to the Host Project.

• Once an attribute is part of the host file, that attribute will not be updated by any attribute modifications in 

the source file.

• Attributes imported with Hotlink Modules will not be removed when deleting Hotlinks or Modules.

See also Master Layer for more information about Hotlink Module layers.

Notes: The above information applies to ARCHICAD-based Modules only. 

– IFC Hotlink Module attributes are managed according to the template file of the Translator for Import 

used to place the IFC hotlink. See Hotlink IFC File.
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– Rhino-based Hotlink Module attributes (layer and surface settings) are set at Import Options, when 

selecting the module. See Import Options for Rhino 3D Model

Library Parts in Hotlink Modules

Note: Applies to ARCHICAD-Based Modules only. For handling of imported (hotlinked) IFC library parts, 

see Library Parts Location.

• Linked Library Parts: Placing a Hotlink module does not import any linked Library Parts. Make sure that 

the Library Parts used by the source are also available to the host, by doing one of the following:

– Use the same Libraries for both source and host

– Add the source’s Libraries to the host file’s libraries

• Embedded Library Parts: Placing a Hotlink module adds the source file’s entire Embedded library to 

your host file’s Embedded library. The newly added Embedded library can be seen in your Library 

Manager, inside the automatically created “Hotlinks” folder of your Embedded library. In this folder, each 

Hotlink source file is listed separately along with all of their embedded objects. These objects will be 

updated in your host project if they are updated in the source project.

Important: It is not recommended to place any these objects into your project separately. These objects 

will be deleted from the Embedded Library if the Hotlink module is deleted from the project, or if all placed 

instances of the module are deleted. (You will notice the deletions after you re-open the host file.)

Properties and Classifications in Hotlink Modules

See Properties in Hotlinks.
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Place Hotlink

1. Choose File > External Content > Place Hotlink.

The Place Hotlink Dialog Box appears.

If the project already contains one or more Hotlinks:

• The last placed Hotlink is listed. Click Place Hotlink to place it again, or Change Module to choose 

another one.
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If no Hotlink has been placed yet:

• Click Select Module to define one.

 

2. Select Hotlink Module

The Select Hotlink Module dialog box appears. Hotlinked Modules in the project (if any) are listed with 

information on their linked stories and the source file location.

– For IFC-based Modules, the Conversion Info column indicates the Template and Translator files used 

in converting the file to ARCHICAD. 

– For Rhino-based Modules, the Conversion Info column is the timestamp identifying the module.

See also Hotlink IFC File.

3. Do one of the following:

– Select one of the existing modules of this project, shown in the list, or

– Click New Module to add a new Hotlink Module to the current project.
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If you choose New Module:

Choose the source of the new Hotlink: either From File, or From BIMcloud.

– From File: A directory dialog box will appear. Select the desired file to use as the module.

– From BIMcloud: Choose a BIMcloud, authenticating yourself with user name and password, then 

choose the Teamwork project you need.

Note: The source Teamwork project must have the same version number as the host project.

If you choose IFC file format:

See Hotlink IFC File for additional options.

If you choose Rhino (.gsm) file format:

See Hotlink Rhino File for additional options.

4. Click Select.
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5. If the selected PLN or MOD file has multiple stories, the Select Story dialog box appears.

Note: Select Story does not appear for IFC modules (which are placed with all stories) or Rhino-based 

modules. 

Select an option:

– Single Story: Click on one of the listed stories to place as Hotlink.

– All Stories (Entire Model): Place all stories of the module file into the host project.

6. Click OK.

7. Click Select to return to the Place Hotlink dialog box. Use the Hotlink Settings controls in this dialog box:

– set Master Layer and Orientation

– to assign an optional Master ID

– to define how to handle elements’ elevation and top linked elements
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Note: When hotlinking an IFC file, make sure you set the Elements’ Elevation option to Keep Elevation! 

Otherwise, the imported model may “fall apart” when its elements are placed in a different story structure.

For details, see Hotlink Settings.

8. Click Place Hotlink.

9. Match Stories (for Hotlink Modules with multiple stories):

In the Match Stories dialog box, select which story of the module to place onto the current story in the 

host project. (Not relevant for Rhino-based modules).

If you try to place a multistory module into a host project that contains fewer stories than the module you 

are placing, the module stories which do not “fit” in the host project will not be visible. 

To resolve this, create additional stories as needed in the host project.

10. Click OK to place the Hotlink.
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Edit Hotlink Module Content

This section describes three workflows:

Edit Module in Separate ARCHICAD

Break Hotlink (Embed Elements)

Save Hotlink as File...

Edit Module in Separate ARCHICAD

Not available for IFC- or Rhino-based Hotlink Modules.

1. Do one of the following:

– In Hotlink Module Manager, choose the desired source file from the Hotlink Sources list, then click 

Open in New Instance.

– Select the placed Hotlink, then use the context menu: Hotlink Module > Edit Module in Separate 

ARCHICAD from the context menu.

2. Edit the source file as needed, then save it.

Hint: If you want to see the Floor Plan context of the placed module while editing its source in the second 

ARCHICAD, use the “Trace” function. (See View Context of Hotlinked Module while Editing Module 

Content.)

3. Return to the first (host) project. 

4. Go to Hotlink Module Manager. In the Hotlink Source list, note that the Status of the edited module’s 

Hotlink Source now reads Modified. (If needed, click Refresh Status.)

5. Click Update. 

6. Click OK to carry out the update on all of the module’s Hotlinks and close Hotlink Module Manager.

Note: In Teamwork, you must reserve Hotlink Sources in the Hotlink Module Manager to be able to 

update.

Break Hotlink (Embed Elements)

Use this command to break this Hotlink and embed the elements into the host project. 

Use this if you have placed a Hotlink, but you now want to edit it locally in the host project, rather than via its 

source file.

For example: you have placed multiple hotlinks of a module of a standard hotel room. One of the rooms 

doesn’t fit into the plan. You can break the hotlink of that one instance, then edit its content to fit its particular 

location.

1. Select the module on the Floor Plan.

2. From the context menu or Hotlink Selection Settings, use Break Hotlink (Embed Elements).

Or use File > External Content > Break Hotlink (Embed Elements)

Note: To break all the placed Hotlinks of a particular module, use the Break Link command from Hotlink 

Module Manager. 

Note: In Teamwork, the Break Hotlink function is not available. Instead, you can Explode the Hotlink 

Module. (See Explode Hotlink Module Instance in Teamwork.)

3. Edit the elements as needed. (Use Edit > Grouping > Suspend Groups to enable editing.)
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Save Hotlink as File...

Available from Hotlink Module Manager, and the context menu of a placed Hotlink Module.

Use this command to save the Hotlinked Module elements as a new file in module format (.mod).

For example: you have placed multiple hotlinks of a module of a standard hotel room (Room A). You want to 

change one of the room layouts (calling it Room B), but without embedding its elements into the host project 

(because you will want to place more Room B hotlinks later).

1. Select a Hotlink. (In Hotlink Module Manager, or on the Floor Plan.)

2. Use the Save as File or Save Hotlink as File command.

3. Check the box to Replace selection with this hotlinked module file.

You have created a separate new module (Room B) which you can edit independently of the original Room A 

module.
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Hotlink Settings

Hotlink Settings are available:

• in the Place Hotlink dialog box

• in Hotlink Selection Settings, available for a selected Hotlink module from one of the following:

– Choose Hotlink Selection Settings from the module’s context menu, or

– Use File > External Content > Hotlink Selection Settings

Skip Nested Modules (Hotlink Settings)

It is possible to have several levels of Hotlink Modules nested into each other. 

Note: IFC- or Rhino-based Modules cannot have nested Modules. However, IFC- or Rhino-based 

Modules can be nested inside a PLN hotlink.

If you do not want include the nested modules in this Hotlink, check Skip Nested Modules. This will apply to 

the current Hotlink only.

To include the skipped modules again, open Hotlink Selection Settings and uncheck the box.

Note: To skip or include nested modules in all Hotlinks of this module, use Hotlink Module Manager.

See Nested Modules (Hotlink Module Manager).

Change Module

Select a different module to replace the selected module.
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Break Hotlink (Embed Elements)

See Break Hotlink (Embed Elements).

Save as File

See Save Hotlink as File....

Master Layer

The Master Layer controls the visibility and locking of the Hotlink as a whole. This Master Layer is an ordinary 

layer of the host file and can include any other elements.

• Different Hotlinks of the same module can be assigned to different Master Layers.

• The elements themselves keep their element-specific layer assignments and are placed on the 

corresponding layers of the current Project, if layers with these names exist. If necessary, new layers will 

be created.

See also Hotlink IFC File.

• Visibility of individual elements within the module depend on element-specific layers.

• Layer Combinations of the source file are not imported with the modules.

Note: For best results, use the same layer structure in both the source and the host file.

Master ID

Define an optional, custom Master ID for this Hotlink: this is a tag added to the Element ID of each Hotlink 

element.

For example: when hotlinking a hotel room, define its Master ID to correspond to its room number. Each 

element of the Hotlink now has an Element ID extended by this room number (e.g. R213).

Extend Zone Element ID with Master ID

In another example: extend the Zone Element ID by the Master ID of the Hotlink it belongs to.
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– For example, a Zone with an Element ID of Bathroom in the source file is placed into the host file as 

part of a Module having a Master ID of R213. Its Zone ID will then be R213 Bathroom. 

Note: To display this full Zone ID, make sure that the Zone Settings are using the “Hotlink and Element ID” 

display form.

Orientation

• Type a value in the Orientation field if you want to place the Hotlink at an angle, compared to its 

orientation in the source file.

• Check the box next to the Orientation field to place a mirrored Module.

Adjust angle of fixed-angle elements to reflect Hotlink rotation:

Check this if you want to rotate these fixed-angle elements (e.g. Labels or Zone Stamps) to reflect the 

Hotlink’s new orientation.

Story Matching

If you have placed a multistory module into a host project that contains fewer stories than the placed module, 

the module stories which do not “fit” in the host project will not be visible. 
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Hotlink Settings shows feedback on the situation:

To resolve this, create additional stories as needed in the host project.

Elements’ Elevation

These controls are relevant if the Hotlink module’s story structure is not the same as the Host project’s story 

structure. 

• Adjust Elevation to Story Structure of Host Project: Element elevations will follow the shift in Story 

Levels in the Host Project. Therefore, Hotlink Elements may shift vertically.

Note: If you choose this option, make sure to review additional options for Top Linked Elements and Door/

Window elevations (see controls below).

• Keep Elevation as in Story Structure of Source File: All Hotlink elements will retain their original 

vertical positions relative to the Hotlink insertion point.

Note: When hotlinking IFC files, make sure you use the Keep Elevation option! Otherwise, the imported 

model may “fall apart” when its elements are placed in a different story structure.

Optionally, set an Additional Offset (see below).
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Additional Offset

Enter an optional Elevation offset value. This modifies the elevation value of elements in the Hotlink. 

Relink all Doors/Windows to Wall Base

If you check this: Doors/Windows whose sill or header was linked to a particular story in the source file will 

lose the story link, and instead will be linked to the Wall base in the host file.

Otherwise, the sills/headers of the Doors and Windows will be linked to the stories in the host file.

Top Linked Elements

• Adjust Height to Story Structure of Host Project: Top Linked elements will stretch or shrink to match 

the corresponding story structure of the host file. Available if “Adjust Elevation” option is chosen above.

• Keep Height as in Hotlink Source Story Structure: Top Linked elements will not stretch (they will retain 

their original heights.)
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Hotlink Module Manager

Use this dialog box to manage Hotlink Modules and Hotlink Sources in the project.

Open it from:

• File > External Content > Hotlink Module Manager, or

• the context menu of any Hotlink in the project, under Hotlink Module

• You can also check Hotlink Module/Source status and access Hotlink Module Manager through the Action 

Center. (File > Info > Action Center).

The “Hotlink Modules” list (in the top half of the dialog box) shows the hierarchy of modules hotlinked into the 

current project.
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• The list is hierarchical, indicating any nested modules at a lower level in the tree structure.

Module Information

Select any module in this list. Module Information includes:

• the number of placed Hotlinks from this module

• the name of the source file

• the linked story (or stories) of this module.

•  Conversion Info 

– For IFC-based Modules: the Template and Translator files, and the template file’s location

– For Rhino-based Modules: import options for this module (e.g. layer and surface conversion)

You can also hover the cursor over a listed Module to see information about it, including the module’s location 

in the host file.
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Note that selecting a module in this list highlights the name of its source file in the “Hotlink Sources” list below.

Change Module

To replace the selected module with a different one, click Change Module.

Note: Not available for Nested Modules.

The appearing Select Hotlink Module dialog lists the available Hotlink Modules of this project. Select one to 

change the module.

See Select Hotlink Module.

Break Link

Check this box to break all the Hotlinks of this module and embed their elements into the host project. The 

elements will be regular editable ARCHICAD elements, grouped together but no longer part of a module and 

no longer linked to any other source file.

This command is not effective on Hotlinks which are on a locked layer.

Note: To break any single placed Hotlink, select the Hotlink and use the Break Hotlink (Embed 

Elements) from Hotlink Settings.

See Break Hotlink (Embed Elements).

Note: The Break command is not available for nested modules.

The Break Link function can be helpful if, for example, a project is nearing completion and you want to create 

a few internal renderings. You can save a copy of the project visualization purposes: in the copy, you use 
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Break Link to embed all the hotlinks of a module. This allows you to access all of the elements individually, so 

you can use Surface Painter much more easily.

Delete

Deletes the Hotlink Module and all of its placed Hotlinks from the project.

Hotlinks or elements which are on a locked layer will not be deleted.

Note: The Delete command is not available for nested modules.

Nested Modules (Hotlink Module Manager)

Nested Modules (if any) are listed in the Hotlink Module Manager according to their location in the module 

hierarchy. Use the Nested Modules pop-up menu to skip or include them in the placed Hotlink:

• Skip: The nested modules in all Hotlinks of the selected module will be skipped (they will not be shown on 

the Floor Plan). They will, of course, still be present in the source module.

• Include: All nested modules in all Hotlinks of the selected module are shown.

To re-display a skipped nested module, select its parent module again from the Hotlink Module Manager, then 

choose Include from the Nested Modules pop-up.

If you select a nested module in the Hotlink Modules list, you cannot change or break the Hotlink (these 

commands and the module name itself are grayed), but you can save it as a new file.

Notes: 

– IFC- or Rhino-based Modules cannot have nested Modules. However, IFC- or Rhino-based Modules 

can be nested inside a PLN hotlink.

– To skip or include Nested Modules for any single Hotlink, use Hotlink Selection Settings.

See Hotlink Settings.

Hotlink Sources

Lists the source files of the Hotlink Modules in this project, by Name and Status.

• Click the pop-up arrow to refresh the Status as needed.

Note: By default, ARCHICAD automatically checks the status of all Hotlinks each time you open Hotlink 

Module Manager. If this process slows down your work, uncheck the “Automatically Check Status” box at 

Options > Work Environment > Data Safety and Integrity.
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See also Hotlink Source File Status Messages.

• To sort data by column, click the headers

• Use the splitter bar to edit the column widths

• Select any file in this list to view, on the right:

– File size: Size of the source file.

– Modified: Last time the source file was modified (at its Location. The path is shown below).

– Last updated: Last time the source file was updated (in the current host project). If this date is older 

than the “Modified” date, your source is out of date and should be updated.

– Location: Path of the source file.

For any selected file in the list, you can do the following operations:

Relink

Update

Open in New Instance

Relink

Use Relink if any of your Hotlinked Sources are shown with “Missing” status.

In the appearing “New Hotlink” directory dialog box, provide the location of the Hotlink Source (which is 

probably missing because it was moved to a new location.) As long as a Hotlinked Source is missing, 

ARCHICAD cannot update its module instances.

All Hotlinks based on the original source will now be replaced, based on the new source file.

Note: An IFC source file must be relinked to another file in IFC format.

Warning: Carrying out these actions means that your ARCHICAD project’s entire Undo queue will be 

cleared!

If the new source file has a different story structure than the host file, you will be warned that some 

dimensions and labels may be lost as a result of relinking.

Note: Relink is available only for source files of top-level Hotlink Modules; you cannot relink a nested 

Hotlink. If a nested Hotlink is shown as “Missing,” open the file into which the nested Hotlink is placed, and 

relink the source file.

Update

If the source file of a Hotlink module has been modified at its original location, its status in the Hotlink Sources 

list is shown as “Modified.” You must update the source file and thereby update all of the module’s placed 

Hotlinks: select the source file and click Update.
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This command is also available from the context menu of a placed Hotlink, as: Hotlink Modules > Update 

Module and All Related Hotlinks.

Note: To set update preferences when opening or publishing a file containing Hotlinks, use the drop-down 

options at Options > Work Environment > Data Safety & Integrity > Hotlink Update.

See Hotlink Update.

Update, then Compare

When updating a Hotlink Module, you can launch Model Compare in one step, which helps you visualize 

exactly what has changed as a result of the update.

See Compare ARCHICAD Models Before and After Hotlink Update.
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Open in New Instance

Note: Not available for IFC or Rhino source files. 

Opens the selected source file in a new instance of ARCHICAD. 

See also Edit Module in Separate ARCHICAD.

Hotlink Source File Status Messages

• OK: This Source file’s modules are up to date.

• Modified: Source file has been changed. To update the modules in your project that originate in this 

source file, you must use Update.

• Missing: You have placed modules from this file in your project, but ARCHICAD cannot locate the source 

file. To enable the updating of these modules, you must first locate the source file (use Relink to define 

the missing file’s location).

• Not Accessible: The source file is either an old Teamwork file (a Teamwork file format from a pre-13 

version of ARCHICAD), or it is an ARCHICAD 13 or later Teamwork project located on a BIMcloud. You do 

not have access to this source, because you are using either a Demo version of ARCHICAD, or a non-

Teamwork network key.

• Legacy: Legacy source files are those saved in an ARCHICAD version prior to ARCHICAD 12. To enable 

these modules to be updated, you must first open the legacy source file and re-save it in version 12.

Module Status Icon

Normal

Nested

Modified

Updated

Deleted

Change Module

Link Broken
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Relink Source File

Skip Nested Modules

Missing

Module Status Icon
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Create Module (.mod) File

A Module format file (.mod) is a simplified type of ARCHICAD file, which can be placed as a Hotlink Module or 

merged into a project. 

• You can save all project elements or just selected elements and selected stories in the module file

• A .mod file contains only model and Floor Plan data

• A .mod file includes Embedded objects, but no information from Section/Elevation/IE, Worksheet/Detail, 

or 3D Document data

• A .mod file refers only to attributes actually used by their elements. Thus, a .mod file is much smaller than 

a .pln file

• The Save Hotlink as File always saves the hotlink in MOD format.

Note: It is also possible to split a project into multiple PLN files (as opposed to Module-format files). See 

Save Selection in PLN Format.

Topics in this section:

Save a Project as a Module File

Save Selected Elements as Module

Save a Project as a Module File

1. In the Floor Plan, use File > Save As, and choose the .mod file format.

2. You receive a warning that the module file will contain only Floor Plan data. 

3. Click OK to create the module file and close the dialog box.

Save Stories in Module

If the project contains several stories, ARCHICAD will, by default, save all of the stories as part of the module.

Alternatively, you can save only certain stories in the module: when you save the module using File > Save 

As, click the Options button in the Save As dialog box to bring up Save Options.
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• The default choice is All Stories

• Alternatively, choose just the Current Story, or a specified Range of stories to include in the module file. 

Any element that falls within this range will be included in the module. 

– Add relevant elements from other Stories: If you choose either Current Story or a Range, check 

this to include all elements that are displayed on these specified stories (because their Show on 

Stories control is set to Relevant Stories), even if their home story is out of the module’s story range. 

• Break nested Hotlinks and Xrefs: If the module file contains any nested Hotlinks and/or Xrefs, you can 

check this box to break those links, if the source files may become unavailable or are no longer needed.

See Place Hotlink.

Save Selected Elements as Module

Note: You can also save selected elements in PLN format. See Save Selection in PLN Format.

1. Select elements in the Floor Plan. (To select elements from several stories, use the Marquee tool’s 

multistory option - see Single Story or All Stories.)

2. Go to File > External Content > Save Selection as Module to open the following dialog box:

3. Enter or choose a file name.
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4. Choose the Module File (.mod) format.

5. Optionally: Check Replace selection with this Hotlinked Module file to immediately replace the 

selected elements with the module file.

Note: In Teamwork, the “Replace selection...” checkbox is NOT available.

– Also check Apply Offset and Rotation of Edited Module to retain the custom offset/orientation 

settings, if you are replacing an original module with a new one. (This option is relevant when several 

hotlinks of the edited module were placed using different rotations and offsets.)

6. Click Save.

Notes:

• If you have selected certain elements and copied them to the clipboard, you can save a module that will 

include those elements only: use File > Save As, then choose the Module File from Clipboard file 

format.

• If the selection contains elements that cannot be modified (e.g. they are locked, located on a locked layer 

or reserved by another user), an alert will warn you. You will then have the choice of either creating the 

module with the editable elements only, or canceling the operation.
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Save Selection in PLN Format

Use this feature to split an ARCHICAD model into multiple PLN files, which can act as Hotlink Modules.

For example, you can save the building facade as a separate file from the rest of the building, or save two 

wings of the building in separate files. 

Each separate PLN file retains the full 2D content as displayed in the Navigator - including Layouts, 

Worksheets, and Details. The two parts of the original model are thus “split”.

(In contrast, saving a selection in MOD format saves model and Floor Plan data only.)

Save Selection as Module

1. Open the original model, and select the part you want to save as a separate PLN file.

2. Use File > External Content > Save Selection as Module:

3. Enter or choose a file name.

4. Choose the ARCHICAD Solo Project (.pln) format.

5. Click Save.

6. ARCHICAD automatically splits the project. The original PLN file and the saved PLN selection are opened 

in two separate ARCHICADs.The feedback lets you know what is happening.

Use the checkboxes to hotlink the two projects to each other in one step, as described in the following:
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Split and Hotlink Model Parts

In this example, the facade of a highrise is selected and saved as a PLN file, and hotlinked with the original 

tower file.

1. Open the model file (Tower).

2. Select the facade elements (the Curtain Walls) in Floor Plan or the 3D window.

Note: When selecting on Floor Plan, use the Marquee tool’s multistory option to include elements from 

several stories - see Single Story or All Stories.

3. Go to File > External Content > Save Selection as Module to open the following dialog box:

4. Enter or choose a file name.

5. Choose the ARCHICAD Solo Project (.pln) format.

6. Check both options:

–  Replace selection with this hotlinked module file

– Create hotlink in target file

7. Click Save.

8. ARCHICAD splits the project and opens the saved selection (the Facade) in a second ARCHICAD 

instance.
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9. Now you have two ARCHICAD projects running: the Tower (with the Facade hotlinked in), and the Facade 

(with the Tower hotlinked in).
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You can save any number of PLN selections from the original ARCHICAD model and hotlink them 

automatically to the original model. 

However, if you also want to hotlink the resulting “secondary” PLN files to each other, you must do so 

manually. 
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Collision Detection

Use this function to identify collisions among 3D elements in the model. A collision occurs when two or more 

elements physically intersect. 

Collision Detection works by checking for collisions between any two groups of elements. The groups are 

defined by criteria chosen by you.

For example, you might run Collision Detection:

• Between construction and MEP elements. (MEP elements can come from hotlinked or merged external 

MEP IFC files, or else modeled inside ARCHICAD.)

• Between concrete and steel construction elements

• Between elements classified as different product/element types (by Uniclass, OmniClass, UniFormat or 

any other classification system)

• To check the headroom clearance for escape routes or access for the disabled

Collision Detection is available from the Floor Plan and 3D windows only.

Access from:

• Design > Model Check > Collision Detection

• or click the Collision Detection icon from the Model Check Report

Topics in this section:

Understanding Collisions

Run Collision Detection

Define Collision Groups

Set Volume/Surface Tolerances

Example: Collision Detection with Volume/Surface Tolerances

Example: Headroom Collision Check

Exempt Building Material from Collision Detection

Understanding Collisions

• Only elements on visible Layers are considered

• Elements that are just touching are not collisions

• Solid Element Operations and Priority-Based Connections are already resolved in the model and do not 

cause collisions

• 3D Cutting Planes are ignored (the entire model is considered regardless of Cutting Planes)

• You can define Tolerances for colliding Volumes and/or surfaces: if the colliding volume/surface area does 

not exceed the defined Tolerance value, it does not count as a collision

See Set Volume/Surface Tolerances.

• The status of Building Materials (“Participates in Collision Detection” property) is considered

See Exempt Building Material from Collision Detection.

Run Collision Detection

1. Go to the Floor Plan or 3D Window.

2. Go to Design > Model Check > Collision Detection.

3. In the dialog box, define criteria for the two groups of 3D elements that you want to check.
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• If any elements are selected, Collision Detection will check only selected elements! See the top of the 

dialog for feedback on any current selection.

See Define Collision Groups for more information.

4. Set Surface and/or Volume Tolerance values as needed.

See Set Volume/Surface Tolerances for more information.

5. Press Check to run Collision Detection.

6. The Model Check Report opens to show results. Collisions-type problems are listed as such in the 

Report. Click Info to see the number of Collisions.

As with other problems listed in the Model Check Report, you can view the related elements in the model and 

create Issues.

See Model Check Report.

Define Collision Groups

Under Group 1 and Group 2, use the criteria interface to define the collision groups.

• To check collisions between all element types, use the same criteria for both groups.
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• To check collisions between 3D elements and MEP elements only, limit one of the groups to elements 

classified as MEP.

• To use a saved Criteria Set to define a Collision Group: click the Criteria Set Name arrow to list the 

project’s criteria sets:

– If you pick a Criteria Set here, its contents will overwrite the Collision Group’s current criteria

– Listed Criteria Sets may be disabled if the set includes criteria not applicable to Collision Detection 

(e.g. 2D element types, or IFC properties)

See also Predefined Criteria Sets.

• Click Add to bring up a dialog to choose any Properties and Parameters by which to limit the group.

Set Volume/Surface Tolerances

Optionally, define Tolerances for the volume and surface of elements’ colliding parts.

Elements are considered to collide if the colliding parts’ volume or (if enabled) the colliding parts’ surface area 

exceeds the Tolerance value.

Note: The units here are those of the project’s Working Units (Options > Project Preferences).
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Volume Tolerance

Collision Detection always considers colliding elements in terms of the volume of the colliding parts. 

You can set an optional Volume Tolerance: If the volume of the two elements’ colliding parts exceeds this 

tolerance value, the elements are treated as colliding.

Check for Surface Collision

As an additional option, the Collision Detection function also checks the surface area of the colliding parts. If 

you enable Surface check and set a tolerance, then elements are treated as colliding if the colliding surface 

area exceeds this Surface Tolerance value.

Note: If Surface Check is on, it is possible that two elements will be considered as colliding even if the 

colliding volume doesn’t exceed the Volume Tolerance - because the colliding surface area exceeds the 

Surface Tolerance. See the example below.

Example: Collision Detection with Volume/Surface Tolerances 

Run Collision Detection with the Tolerance settings shown here.

The following two cubes are one cubic meter each. They collide slightly; the overlapping volume is very slight 

(it doesn’t exceed Volume Tolerance), but the overlapping surface is considerable (it exceeds Surface 

Tolerance). As a result: Collision Detection counts these two elements as colliding.
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Two Colliding Elements (based on Surface Area of Colliding Part)

Example: Headroom Collision Check

We will check for Headroom collision in this 3D view of the model.

Note: The headroom visibility is turned on at Document > Model View > Model View Options (Stair 

Options).

1. Go to Design > Model Check > Collision Detection.

2. In the dialog box, define the collision criteria.
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• For Group 1: all 3D elements

• For Group 2: Stairs, considering the Headroom part of the Stair Model. 

3. Press Check to run Collision Detection.

4. The Model Check Report opens to show results. Here, for each result you can view the related elements 

in the model and create Issues as needed.

See Model Check Report.

Exempt Building Material from Collision Detection

Collision Detection takes the elements’ Building Materials into account. Building Materials can be set to 

participate in Collision Detection, using the checkbox “Participates in Collision Detection” in the Classification 

and Properties panel of Building Materials, at Options > Attributes > Building Materials.
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If this checkbox is turned off, then the Building Material will not participate in Collision Detection. 

For example, an MEP element (e.g. duct) that runs through a Building Material used as an air gap will not be 

considered as a collision.
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Structural Analytical Model

This feature set supports collaboration between architects and structural engineers.

Overview

In this workflow, ARCHICAD generates a Structural Analytical Model based on the physical (architectural) 

model. The Structural Analytical Model is generated in the background, simultaneously with the Physical 

Model. As the Physical Model changes over time, the associated Structural Analytical Model is automatically 

updated. The Structural Analytical Model is not a separate model; it is more like a simplified representation of 

the Physical Model.

The Structural Analytical Model is exported to a structural engineer, who opens the model in his/her own 

structural analysis program (e.g. SCIA Engineer).

In the analysis program, the engineer performs the analysis simulation and design optimization to make any 

necessary changes to the Structural Analytical Model. The Structural Analytical Model is then exported to 

ARCHICAD, which updates the Physical Model with the changes. In this bi-directional workflow, there is no 

need for file conversion and no associated data loss.

Interoperability with structural analysis programs is ensured by use of the Structural Analytical Format 

(SAF), which is explicitly optimized for such softwares and enables a much faster model exchange workflow 

(e.g. as compared to an IFC-based workflow).

As of ARCHICAD 24, additional new features - Model Compare, Issue management, Change Tracking in 

Teamwork, and Model Check for analytical and physical models - also support this workflow.

How do I generate a Structural Analytical Model?

Use the Show Structural Analytical Model toggle

• from the View menu

• from the Structural Analytical Model Toolbar 
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Which Parts of the ARCHICAD Model Become Part of the Structural Analytical Model?

1. Load-bearing elements

2. Contain a Core

3. Created with an eligible ARCHICAD tool. See Elements of the Structural Analytical Model.

– Beams and Columns are represented as 1D Members

– Slabs, Walls, and Single-plane Roofs are represented as 2D Members

4. Enabled at the element level (enable checkbox for “Structural Member” in Element Settings)

5. Exists in the model as defined by Renovation Status (if it is “To Be Demolished” or “New” and hidden in the 

current view, it will not show up in the Structural Analytical Model)

6. Element connections (as defined by Layer Intersection Group) are reflected in the geometry of the 

Structural Analytical Model
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7. Layer visibility is NOT considered. Even elements on a hidden layer can be part of the Structural 

Analytical Model.

Default Position of 1D and 2D Members

A Structural Analytical Member is generated by default in the element’s center of gravity (for 1D Members) or 

along the center of the element’s core plane (for 2D Members). 

This default can be modified for any element in its Settings dialog, using the Eccentricity control. For example, 

you can use the Eccentricity control in Slab Default Settings so that its 2D Member is always generated on the 

top plane of the Slab.

See Eccentricity.

Automatic Adjustments by Generation Rules

The “Structural Analytical Model Generation Rules” are applied automatically each time it is generated. 

These rules adjust the geometry of 1D and 2D Members and certain End/Edge Release definitions. The 

purpose is to optimize the Structural Analytical Model to make it correct and compatible with external analysis 

programs.

Related Topics

Structural Engineering Work Environment and Commands

Elements of the Structural Analytical Model

1D Members (Column and Beam)

2D Members (Slab, Wall, Roof)

Structural Supports

Structural Links

Representation of Structural Analytical Model

Structural Analytical Model Generation Rules

Eccentricity
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End/Edge Releases

Model Check - Overview

Model Check Report

Collaboration with Structural Analysis Software
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Structural Engineering Work Environment and Commands 

The Structural Engineering Work Environment Profile includes the dedicated Structural Analytical Model 

toolbar.

Commands related to the Structural Analytical Model can be found under the existing menus, as follows:

View Menu

• Show Structural Analytical Model

• Structural Analytical Model Options

Design Menu

• Structural Analytical Model Generation Rules

• Model Check > Structural Analytical Model Quality

• Model Check > Physical Model Quality

• Model Compare

• Design Extras > Create Structural Links

Options Menu

• Project Preferences > Structural Analytical Model Representation

• Project Preferences > Structural Analytical Model Units
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Elements of the Structural Analytical Model

The Structural Analytical Model represents a simplified version of the building’s load-bearing elements and 

their supports.

Which ARCHICAD Elements Participate in the Structural Analytical Model?

The element must meet the following conditions:

• Its Structural Function is Load-Bearing Element

• Generation of the Structural Analytical Model is enabled for the element (in element settings)

• It was created using one of the eligible ARCHICAD tools:

– Column

– Beam

– Wall

– Single-Plane Roof

– Slab

• If it is a composite or Complex Profile, it must include at least one Core skin/component

Note: Certain element geometries are not supported. See more at 1D Members (Column and Beam) and 

2D Members (Slab, Wall, Roof))

Components of the Structural Analytical Model

The Structural Analytical Model consists of the following:

1D Members (Column and Beam)

2D Members (Slab, Wall, Roof)

Two new tools support generation of the Structural Analytical Model: 

Structural Links

Structural Supports

Other components are Nodes End/Edge Releases, and Local Coordinate System.

Show Nodes

End/Edge Release Symbols

Show Local Coordinate Systems
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1D Members (Column and Beam)

Beams and Columns are represented in the Structural Analytical Model as 1D Members. They have two 

nodes (start and end node) and one axis line connecting the nodes.

The 1D Member is generated by default at the center of gravity of the element’s core (or core component).

Customize 1D Member color at Structural Analytical Model Representation (Preferences).

The analytical Member does not extend outside of the physical body unless it has been adjusted.

Which Columns and Beams are 1D Members of the Structural Analytical Model?

Columns and Beams will generate a 1D Member in the Structural Analytical Model if they meet these 

conditions:

• Load-bearing

• Contains a core

• “Structural Member” checkbox is activated in Element Settings

• Geometry is supported (see table below)

Tool Settings for 1D Members

Use the Structural Analytical Parameters panel of Column or Beam settings.

Beam-Column Geometry Member of Structural Analytical Model?

Basic Element (Rectangular, Circular) YES

Complex Profile - Includes a Core YES

Complex Profile - No Core NO

Multi-Segment and/or Tapered YES, based on user-defined Replacement Profile
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Structural Function - Enable Load-Bearing

Set the Structural Function to Load-Bearing. 

This is the same control, with the same value, as in the Structural Function control found in the Classification 

and Properties panel.

Structural Member - Enable for Structural Analytical Model

This box is checked by default: include this element in the Structural Analytical Model as a 1D Member.

Uncheck if the element should NOT be included in the Structural Analytical Model.
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Notes: 

– Available only if Structural Function is set to Load-Bearing. 

– If the element is a composite or Complex Profile, it must include at least one Core skin/component in 

order to be part of the Structural Analytical Model.

1D Member - Define Structural Behavior

This Structural Behavior setting defines the Member’s behavior in a Finite Element Method (FEM)-based 

structural analysis program: specifically, which types of forces this element is designed to bear.

Choose an option to define the Member’s structural behavior:

• Standard (default) - The element can transfer all forces, such as axial and shear forces.

• Axial force only

• Compression only

• Tension only

The available definitions are fixed and cannot be customized.

The Structural Behavior setting has no effect on the Physical Model.

Allow Rule-based modifications - 1D Member

Activate these checkboxes to apply the respective Adjustment Rules that are defined in the Structural 

Analytical Model Generation Rules dialog box.

By default, the Stretch & Cutback and Offset boxes are checked: the Stretch, Cutback and Offset 

adjustments defined in the Generation Rules dialog affect this 1D Member element.
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If an Adjustment Rule uses the “Snap” Adjuster, it will be applied to this element only if both checkboxes are 

checked.

See Structural Analytical Model Generation Rules.

To exempt this 1D Member from automatic adjustment rules, uncheck the box(es). The respective 

Adjustment Rules are not applied to this element.

If needed, you can set a custom offset for this element (see below).

Custom Offset

If the Offset box is unchecked:

Redefine this element’s eccentricity, either graphically or by entering a value.

See Eccentricity.

Connection Range

For Beams and Columns: This option virtually extends the 1D Member’s core length along its axis. 

The purpose of virtually extending the core is to enable the Beam or Column to achieve a core connection 

with other elements, if such a core connection does not exist. As a result of this virtual extension, Adjustment 

Rules (which require core connections) can go into effect.

For details, see Connection Range (Extend Core to Enable Connection).

Translation and Rotation

See End/Edge Releases.
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Connection Range (Extend Core to Enable Connection)

For Beams and Columns: This option virtually extends the 1D Member’s core length along its axis. 

The purpose of virtually extending the core is to enable the Beam or Column to achieve a core connection 

with other elements. As a result, Adjustment Rules (which require core connections) can go into effect.

This can be useful with certain prefabricated elements which contain deliberate core gaps at either end (e.g. 

to make room for insulation or detailing.) This Connection Range virtually extends the core to fill these gaps.

Important Notes:

– This option extends the length of the element core only virtually: it has no effect whatsoever on the 

physical model element, and does not extend the 1D Member.

– The extra Connection Range is considered when you run a Model Check on the Structural Analytical 

Model. If the Connection Range enables the structural connection, then the Model Check will consider 

the elements to be continuous for the purposes of the Structural Analytical Model.

– You can add an extra connection range to the element only if the adjustment rules currently apply to 

this element: that is, if the Stretch & Cutback and/or Offset boxes are also checked in this dialog. If 

both of these adjuster boxes are unchecked, this option is not available.

Enter the length of the extension (“connection range”).

Choose “Start”, “End”, or “Both” to define which end should be extended. The “Both” option adds the extended 

length at both ends.
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• To see which end is which, turn on “Show Local Coordinate Systems” to see the element’s direction arrow.

In this example, the Beam core does not intersect the neighboring Column core, so the Stretch adjustment 

rule has no effect.

No Core Connection: Adjustment Rules Have No Effect

Below, the same Beam’s Connection Range is enabled at 5 cm. As a result, the Beam core is virtually 

stretched by 5 cm, and it now intersects the neighboring Column core. Now, the Stretch adjustment rule is 

applied.

Beam Core with Added Connection Range: “Stretch” Adjustment Rule Is Applied
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If a Connection Range is applied, all types of Adjustment Rules can come into play (not just the Stretch). For 

example: Offset.

In the example below:

1. The Beam has no core connection with the Column, so the Offset Adjustment rule cannot be applied.

2. Next, a Connection Range is set for the Beam, which enables its core connection with the Column.

3. Now the Offset Rule can be applied.

Beam Core with Added Connection Range: “Offset” Adjustment Rule Is Applied
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Beam/Column with Multiple Cross-Sections

When generated as a 1D Member in the Structural Analytical Model:

A Beam or Column with multiple cross-sections uses a single Replacement Profile.

The data of this Replacement Profile are used when exporting the 1D Member to analysis programs. The 

element’s Replacement Profile does not affect its physical model in ARCHICAD.

Why Do You Need a Replacement Profile?

Some Column or Beam elements can use multiple cross-sections and/or several Building Materials:

• Multi-segment Beams or Columns

• Tapered Beams or Columns

• A single Complex Profile with different Profile Modifiers at each end

Multi-Segment Beam

Yet in the Structural Analytical Model, this Column or Beam generates only a single 1D Member with a single 

Load-Bearing Profile (defined by you). 

1D Member of Multi-Segment Beam, with Single Load-Bearing Profile

For each 1D element with a variety of cross-sections, you must specify a Replacement Profile in the element 

Settings dialog box. 
ARCHICAD 24 Reference Guide 2427



Elements of the Structural Analytical Model Structural Analytical Model
Choose Replacement Profile

1. Go to the Structural Analytical Parameters panel of Beam or Column Settings.

2. If the element has a varied cross-section as described above: the Replacement Profile pop-up is available 

in the preview window.

3. Click to choose a structure for the element core: Rectangular, Circular, or Complex Profile

For a Complex Profile structure:

– Use the pop-up to choose a Profile and set editable parameters (if any). The pop-up includes Profiles 

which

- are available for Column or Beam (as applicable)

- include at least one core component

Profiles, availability, and their editable modifiers are defined at Options > Element Attributes > Profile 

Manager.

For a Rectangular or Circular structure:

– Use the pop-up to choose its Building Material and its dimensions

4. When exported to SAF format, the 1D member will use the data and dimensions corresponding to this 

Replacement Profile.

The Replacement Profile does not affect the physical model in ARCHICAD.

You can see it represented in the Structural Analytical Model: turn on Show Profiles of Load-Bearing Cores 

(from the Structural Analytical Model toolbar).
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2D Members (Slab, Wall, Roof)

Slabs, Walls, and Single-plane Roofs are represented as 2D Members in the Structural Analytical Model.

2D Members are plane surfaces generated along the center of the element’s core plane. The 2D Member 

has at least four nodes and one surface area connecting them. 

The analytical Member does not extend outside of the physical body unless it has been adjusted.

Customize 2D Member color at Structural Analytical Model Representation (Preferences).

Which Elements Are 2D Members of the Structural Analytical Model?

Slabs, Walls, and Roofs will generate a 2D Member in the Structural Analytical Model if they meet these 

conditions:

• Load-bearing

• Contains a core

• “Structural Member” checkbox is activated in Element Settings

• Geometry is supported (see table below)

Element Type Geometry Member of Structural Analytical Model?

Slab all YES

Wall Straight YES

Curved YES

Slanted (straight) YES

Double Slanted NO

Trapezoid NO

Slanted, Double Slanted (curved) NO

Complex Profile YES

Polygon Wall NO
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Tool Settings for 2D Members

Use the Structural Analytical Parameters panel of Slab, Wall or Roof settings.

Structural Function - Enable Load-Bearing

Set the Structural Function to Load-Bearing. This is the same control, with the same value, as in the Structural 

Function control found in the Classification and Properties panel.

Structural Member - Enable for Structural Analytical Model

This box is checked by default: include this element in the Structural Analytical Model as a 2D Member. 

Notes: 

– Available only if Structural Function is set to Load-Bearing

– If the element is a composite or Complex Profile, it must include at least one Core skin/component in 

order to be part of the Structural Analytical Model

Uncheck if the element should NOT be included in the Structural Analytical Model. (For example, a thin 

moisture-blocking membrane on an underground story.)

2D Member - Structural Behavior

The Structural Behavior setting defines the Member’s behavior in a FEM-based structural analysis program: 

specifically, which types of forces this element is designed to bear.

Roof Single-Plane YES

Multi-Plane NO

Element Type Geometry Member of Structural Analytical Model?
ARCHICAD 24 Reference Guide 2430



2D Members (Slab, Wall, Roof) Structural Analytical Model
Choose an option to define the Member’s structural behavior:

• Shell: Takes all loads

• Plate: Element is able to take loads perpendicular to the plane.

• Wall: Element is able to take loads along its plane.

The available definitions are fixed and cannot be customized.

The right choice here depends on the receiving structural analytical software. Some softwares will filter out 

incoming elements based on this Structural Behavior setting. If you find that exported 2D Members are not 

being imported to the receiving software, you may have to adjust their Structural Behavior definition in 

ARCHICAD.

The definition can be entirely independent of the tool used to create the element: a vertical Wall’s behavior 

can be set to “Plate” or “Shell”; a horizontal Slab’s behavior can be set to “Wall”.

• European structural analytical softwares (e.g. SCIA Engineer) consider the incoming Member’s structural 

type. For these, “Shell” is the default.

• U.S.-based softwares (e.g. RISA-3D) consider the physical model element of the 2D Member: for these, 

choose “Wall” as the structural behavior in Wall settings, and “Plate” in Slab or Roof settings.

The Structural Behavior setting has no effect on the Physical Model.

Allow Rule-based modifications - 2D Member

By default, all checkboxes are on: 

• Ignore small openings

• Stretch & Cutback

• Offset

This means that corresponding adjusters and opening filter, defined in the Generation Rules dialog, will affect 

this 2D Member element.

See Structural Analytical Model Generation Rules.

To exempt this 2D Member from adjustments: uncheck the box(es).

Custom Offset

If the Offset box is unchecked:

Redefine this element’s eccentricity along the z axis (perpendicular to the plane of the 2D Member), either 

graphically or by entering a value.

See Eccentricity.
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Translation and Rotation

See End/Edge Releases.
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Structural Supports

The Structural Support tool is a schematic element that indicates support of physical elements - e.g. by the 

soil stratum, other elements, or tethers.

Supports are created on 1D or 2D Members as applicable: at nodes (Point Support), along linear elements or 

edges (Line Support), or in the 2D plane (Surface Support). 

Structural Supports are placed only on Members of the Structural Analytical Model - you cannot use Structural 

Supports with physical model elements in ARCHICAD.

Once Structural Supports are placed, you can customize their options in the Info box or Tool settings:

• Define supports according to the global or local coordinate system of its host element

• Set translation and (where applicable) rotation stiffness (x, y, z, Rx, Ry and Rz)

To customize Structural Support colors, Structural Analytical Model Representation (Preferences).

To show or hide these elements in 3D: use View > Elements in 3D View > Filter and Cut Elements in 3D 

Notes:

– Support elements are specific to their host element. If you make a copy of the host element only, the 

new copy will not have analytical support. To copy both, you must select both: element and its 

supports. 

– Support elements inherit the Coordinate System settings (global vs. local) of their host elements. This 

information is exported accurately through SAF format. However, please note that the local 

coordinates in the receiving program may be interpreted differently than in ARCHICAD.

– Support elements attached to certain holes or openings have specific limitations. See Structural 

Supports at Openings and Holes.

Related Topics

Place Structural Support

Support Elements: Symbol Options

Structural Supports at Openings and Holes
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Place Structural Support

1. Activate the Structural Support tool

– from the toolbox, or

– Design > Structural Engineering Tools > Structural Support 

2. On Floor Plan or 3D window: hover over the Structural Analytical Member to which you want to add the 

support. 

3.  Depending on the Member type (1D or 2D), the graphical feedback indicates the available Support types: 

Point, Line, and/or Surface.

Graphical Preview: Point and Line Support for 1D Member
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Graphical Preview: Line and Surface Support for 2D Member

4. When you see the Support geometry you need, click to place.
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5. Use Support tool settings or the Info Box to set additional options as needed.

Translation/Rotation Stiffness of Line Support Element

Default Settings of Structural Support Tool

When you place a new Structural Support, the element Default Settings reflect the options and working units 

used by Point-type Supports (some of which are not relevant for other Support geometries). Even so, just set 

the values needed for your specific Support geometry (e.g. Line or Surface Support).

After placement, its Selection Settings will now show the correct and relevant options and working units. 
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Support Elements: Symbol Options

Rigid Hinge Custom

Point 

Support

Line 

Support

Surface 

Support

Not applicable
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Structural Supports at Openings and Holes

Support elements attached to certain holes or openings have specific limitations.

Support placed at Allowed Support Types Support is associated to

Opening element Point Support at nodes only 2D Member

Door-Window-Skylight hole Point Support at nodes only 2D Member

Solid Element Operation hole Point Support at nodes only 2D Member

Slab or Roof hole Point Support at nodes AND Line 

Support along hole edges

Hole
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Structural Links

Instead of connecting Structural Analytical Members using Adjustment Rules, it can make more sense to keep 

the elements separate. (For example, if adjusting 2D Members to each other would move one of the planes 

outside of its element.)

In such a case, you can use Structural Links instead, to indicate how applied loads are transferred between 

the Structural Members.

• The Structural Link can be a 1D Link or a Surface Link, depending on the situation.

Note also:

– A 1D Link with zero length can be placed at a point - for example, to link two bracings while keeping 

them as independent elements.

– A Surface Link having a length dimension but zero width can be placed between two edges.

• They are placed only on 1D and 2D Members of the Structural Analytical Model - you cannot use 

Structural Links with physical model elements in ARCHICAD.

• A Structural Link necessarily has two “parent” Members. If either Member is not part of the current 

Structural Analytical Model view (due to Renovation Status), the Link element also disappears.

1: Prefab Reinforced Concrete elements with cantilever connection; 2: Precast panels modeled with Beams; 

3: High rib (Offset adjustment not allowed)

There are two ways to create a Structural Link:

• Use the Structural Link tool

• Use the Create Links dialog

The resulting Structural Links are associated to the connecting Members: if you move the element, the link 

moves with it.

Customize Structural Link colors at Structural Analytical Model Representation (Preferences).

To show or hide these elements in 3D: use View > Elements in 3D View > Filter and Cut Elements in 3D 
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Example: Use Structural Link Tool

In this example, the user wants to transfer the forces from the upper Beam to the lower one. The two Beams 

should be “connected” through an analytical link.

1. Activate the Structural Link tool

– from the Toolbox 

– from Design > Structural Engineering Tools > Structural Link 

2. From the Info box, choose 1D Link as the Geometry method.

3. Choose Rigid as the link type.

4. Click twice - once on each 1D Member - to create the link between them.

Notes: 

– If you move linked elements, the link remains connected to the originally clicked point.

– Use space + click to automatically create a Structural Link that is the shortest distance between the 

two Members. If you later move these linked elements, the associated Structural Link will be adjusted 

as needed to be the shortest link possible.

Example: “Create Structural Links” Command

Use the Create Structural Links function to create several link types between different elements. The 

function works on selected elements, or (if nothing is selected) the entire Structural Analytical Model.

Important: This function affects only elements that are connected at their cores.
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In this example, the Slab is supported by Beams of significant height. It is not structurally realistic to use the 

offset adjuster in Generation Rules. The Beams should retain their structural axis at their default location at 

the center of gravity. 

We will add Structural Links to indicate load transfer from the Slab to the Beams.

1. Select the elements to be linked.

2. Activate Design > Design Extras > Create Structural Links.

3. In the appearing dialog, set options:

– In this case the link should be Between 1D Member and 2D Member (Beam and Slab), and the link 

should be along the full Beam length (2D Link).
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4. Click Create. The 2D Structural Links appear:

2D Structural Links Between 1D (Beam) and 2D (Slab) Members

As expected, the structural axes remain at their original position (center of gravity), but new nodes now 

appear on the Slab plane, indicating where the structural links are connected to the Slab.

When the Structural Analytical Model is exported, the structural analysis software will interpret that the loads 

imposed on the Slab will be transferred through the links to the Beams.

Display Surface Link as Transparent

See Transparent 2D Members.
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Representation of Structural Analytical Model

Show/Hide Structural Analytical Model

The Structural Analytical Model can be displayed in Floor Plan, Section windows, and 3D views.

Use the Structural Analytical Model toggle

• in the Structural Analytical Model Toolbar 

• in the View menu

The Show/Hide status is specific to each view (if it is on in one view, it can be off in another view).

Important: ARCHICAD elements are part of the Structural Analytical Model only if they have certain 

geometric and property settings. See Elements of the Structural Analytical Model.
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Show Transparent Physical Model

If the Structural Analytical Model toggle is on:

Use the Transparent Physical Model toggle to also display the Physical Model in transparent form, in the 

current view: 

Show Components of Structural Analytical Model

Use the following additional toggle controls to show or hide Structural Analytical Model components. The 

controls are available from:

• Structural Analytical Model Toolbar

• View > Structural Analytical Model Options

• View > Elements in 3D View > Filter and Cut Elements in 3D (for Structural Support and Link elements)
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Customize component colors at Structural Analytical Model Representation (Preferences)
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Show Nodes

Display nodes at ends and corners of the 1D and 2D Members.

Node Connections: Color Feedback

By default:

• A green node represents a correct connection point or intersection between joined Analytical Members

• A red node represents a point or end that is either free (no connection needed), or unconnected/

unsupported:

1: Supported, 2: Connected, 3: Free end (Cantilever), 4: Unconnected, 5: Unsupported
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Show End/Edge Releases

Use this toggle to display their symbols in the Structural Analytical Model.

See End/Edge Release Symbols.

Show Profiles of Load-Bearing Cores

Only 1D Members include a cross-section profile. Use this toggle to display their symbols in the Structural 

Analytical Model.

To make this symbol transparent: Use Transparent Symbols.
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Show Local Coordinate Systems

Display the element’s local coordinate system (in the 3D window only).

• Local X: thick red line

• Local Y: thin green

• Local Z: thin blue

Local Coordinate System of Structural Analytical Member
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Transparent 2D Members

This toggle has the following effect:

• Show 2D Members as Transparent

• Show Surface-type Structural Links as Transparent

Transparent Symbols

This toggle turns the following symbols transparent:

• Node

• End Release

• Spring-type Structural Link

• Support symbols

• Profiles of Load-Bearing Cores
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Structural Analytical Model Generation Rules

Generation Rules are applied to the Structural Analytical Model to optimize it for export to structural analysis 

softwares. 

The current Generation Rules automatically go into effect whenever you turn on the Structural Analytical 

Model - you do not have to activate the rules by command.

Each set of Generation Rules includes:

• Adjustment Rules: These rules adjust (stretch, cutback, offset) 1D and 2D Members to achieve 

continuity among the nodes. Continuity is required for structural analysis, because a disconnected model 

results in errors.

• End/Edge Releases: Define a general rule for handling End/Edge releases that have no connections. 

(This can be useful if the receiving analysis software requires all such releases to be “Rigid”.) 

• Opening filtering: Define rules to ensure that very small openings and very narrow 2D Member parts are 

ignored in the Structural Analysis model.

Open this dialog from:

• Design > Structural Analytical Model Generation Rules 

• Structural Analytical Model toolbar

The default template includes several predefined sets of Generation Rules (plus a No Rules option). Try out 

the defaults. 
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   If you need to edit the Rules, click Add to make a copy of the selected Rule set, then fine-tune them.

Details of Generation Rule settings are described in the sections below:

Adjustment Rules

End/Edge Release (Generation Rules)

Filter Openings for Structural Analytical Model
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Adjustment Rules

This is a panel of the Structural Analytical Model Generation Rules dialog.

The Goal: A Continuous Structural Analytical Model

In order to perform a structural analysis correctly, the exported model must be continuous: the nodes should 

be connected. This continuity is required for structural analysis, because a disconnected model results in 

errors.

The first image below shows the initial Structural Analytical Model: though the physical elements are 

connected to each other at their core, nevertheless the red (disconnected) nodes of 1D and 2D Members 

indicate several places where they ought to be connected.

One solution is to create and/or apply Adjustment Rules from the Generation Rules dialog. These rules adjust 

the specified Member types to each other via Stretch, Cutback, Offset and/or Snap operations.

Important: Adjustments affect the Structural Analytical Model only. They do NOT affect the geometry of 

Physical Model elements!

As a result, the Structural Analytical Members are automatically connected wherever these rules apply.

Before Adjustment Rules: Disconnected Members
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After Adjustment Rules: Connected Members

Conditions for Adjustment

An Adjustment Rule applies to Members only if:

• The Members fit the element criteria defined in the Adjustment Rule

• The adjustment (e.g. stretching distance) is within the tolerances and conditions set in the Adjustment 

Rule

• The two elements in the adjustment have a core connection (load-bearing cores meet at one or more 

points or adjoining surfaces) (see also Important Notes, below.)

• Adjustments are enabled for this Member in Element Settings.

By default, adjustments are enabled for each Member. However, you can exempt any Member at the 

element level (to leave the Member unchanged, or to adjust it manually).

See Allow Rule-based modifications - 1D Member or Allow Rule-based modifications - 2D Member.

Important Notes

• Certain ARCHICAD functions can help to identify and achieve core connections where they are missing:

– See the “Lack of Core Connection” parameter at Physical Model Quality Check

– See the Connection Range (Extend Core to Enable Connection) checkbox, in the Element Settings of 

1D Members 

• The current Generation Rules (including Adjustment Rules) go into effect whenever you turn on the 

Structural Analytical Model - you do not have to activate the rules by command.
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Set Up Adjustment Rules

1. Define the two Groups of Members: Elements by type or criteria (see Members in Adjustment Rule below)

2. Define the Rule Method (see Adjustment Rule Methods: One to the Other, or To Each Other below)

3. Set the Adjuster Type.

4. Set additional options depending on the specific adjuster

See Adjuster Types and Options for details.

Notes on Adjustment Rules

• Rules are applied in the order they are listed, and they are all carried out. You can drag rules to change 

their order.

• Generally, the Offset rules come at the top of the list: they are used not to create connections per se, but 

to line up the elements so that the rest of the rules (Stretch, Cutback) can work as needed. 
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• Hover over any Adjustment Rule to see an info pop-up, showing its parameters and a preview.

• Use the buttons at the bottom of the Adjustment Rules panel to Add or Remove rules. 

Important: If you remove a Rule, the associated adjustment is no longer applied, and the Structural 

Analytical Model reverts to its original position!

Members in Adjustment Rule

Members of an Adjustment Rule can be

• Any element type in the Structural Analytical Model

• All 1D or all 2D Members

• Criteria-based groups of Structural Analytical Members
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Adjustment Rule Methods: One to the Other, or To Each Other

This control sets how the adjustment should affect the two Member groups in the Adjustment Rule.

• One to the other:  The Members in the left column are modified; the Members in the right column 

remain unchanged. Use this method to Stretch and/or Cutback, or Offset one group of elements to each 

other. The Offset and Snap adjusters always use this unidirectional method.

• To each other:  Members in both categories are affected. Use this method to Stretch and/or 

Cutback two groups of elements to each other.

See the following sections for details and examples:

Adjuster Types and Options

Examples of Adjustment Rules
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Adjuster Types and Options

The following table summarizes the available adjuster types and methods. If all the conditions for adjustment 

are met, the adjustment takes place: the Member in red is adjusted in relation to the black Member; the 

Member in black remains unadjusted.

Depending on the specific adjuster, you can set additional options and tolerances. These are also explained 

below.

Topics in this section:

Stretch 1D Member

Stretch 2D Member

Cutback 1D Member

Cutback 2D Member

Stretch & Cutback

Adjust Connected Ends

Offset 1D Member

Offset 2D Member

Offset Options In Case of Multiple Targets

Snap (1D to 1D)

Adjustment 

Method

Member 

Types

Stretch Cutback Stretch & 

Cutback

Offset Snap

One to the other 1D > 1D + + + + +

1D > 2D + + + +

2D > 1D + + + +

2D > 2D + + + +

To each other 1D <> 1D + + +

2D <> 1D + + +

2D <> 2D + + +
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Stretch 1D Member

Stretch the 1D Member along its length (local X axis), so that it can connect to another nearby Member.

For each stretch adjuster, you can set a maximum allowed stretch distance (“Max. stretch”). This distance is 

measured between unadjusted 1D Member Nodes and/or unadjusted 2D Member planes.

Note: The defined tolerances are length-type values: the units specified for Length in Preferences > 

Working Units apply.

See also Adjust Connected Ends.

STRETCH 1D MEMBER TO 1D MEMBER

Stretch 1D to 1D 

(one to the other)

Stretch 1D to 1D 

(to each other)

STRETCH 1D MEMBER TO 2D MEMBER

Stretch 1D to 2D 

(one to the other)

Stretch 1D to 2D 

(to each other)

1D Column is stretched down to reach the 2D Slab; 

Slab edge is stretched to reach the side Beam
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Stretch 2D Member

Stretch part or all of one edge of a 2D Member polygon, so that it can connect to another nearby Member.

For each stretch adjuster, you can set a maximum allowed stretch distance (“Max. stretch”). This distance is 

measured between unadjusted 1D Member Nodes and/or unadjusted 2D Member planes.

Note: The defined tolerances are length-type values: the units specified for Length in Preferences > 

Working Units apply.

STRETCH 2D MEMBER TO 1D MEMBER

Stretch 2D to 1D 

(one to the other)

 

Stretch 2D to 1D 

(to each other)

1D Column is stretched down to reach the Slab; 

2D Slab edge is stretched to reach the side Beam

Partial stretch Check this to stretch only part of the 2D Member edge. This applies if the 1D target 

is in the same plane as the 2D Member that is being stretched.

Min. segment length If Partial Stretch is enabled: An edge part will be stretched only if it is at least this 

long.

STRETCH 2D MEMBER TO 2D MEMBER

Stretch 2D to 2D 

(one to the other)

Stretch 2D to 2D 

(to each other)

Partial stretch Check this to stretch only part of the 2D Member edge. This applies if the 2D target 

is in the same plane as the 2D Member that is being stretched.

Min. segment length If Partial Stretch is enabled: An edge part will be stretched only if it is at least this 

long.
ARCHICAD 24 Reference Guide 2459



Structural Analytical Model Generation Rules Structural Analytical Model
Cutback 1D Member

Cut back 1D Member along its length (Local X axis), so that it can connect as needed to another nearby 

Member.

See also Adjust Connected Ends.

CUTBACK 1D MEMBER TO 1D MEMBER

Cutback 1D to 1D 

(one to the other)

Cutback 1D to 1D 

(to each other)

CUTBACK 1D MEMBER TO 2D MEMBER

Cutback 1D to 2D 

(one to the other)

Cutback 1D to 2D 

(to each other)

Column is cut back to the Slab

Slab edge is cut back to the Beams

Partial cutback Check this to cut back only part of the 2D Member edge.

Min. segment length If Partial Cutback is enabled: An edge part will be cut back only if it is at least this 

long.
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Cutback 2D Member

Cuts back all or part of the edge of a 2D Member plane, so that it can connect as needed to another Member.

CUTBACK 2D MEMBER 

Cutback 2D to 1D 

(one to the other)

 

Cutback 2D to 1D 

(to each other)

Cutback 2D to 2D 

(one to the other)

Cutback 2D to 2D 

(to each other)

Partial cutback Check this to cut back only part of the 2D Member edge. This applies if the 2D 

Member edge and its target are in the same plane. 

Min. segment length If Partial cutback is enabled: An edge part will be cut back only if it is at least this 

long.
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Maximum Cutback/Maximum Overhang

 

Maximum cutback

For each Cutback (or Stretch & Cutback) adjuster, you can set a maximum allowed cutback (“Max. cutback”). 

This distance is measured between unadjusted 1D Member Nodes and/or unadjusted 2D Member planes, in 

the structural analysis model.

Maximum overhang of Physical body

In contrast to the maximum cutback value (which refers to the structural member), the Maximum overhang 

refers to the physical element’s protrusion. Set this limit so that longer extensions in the physical model (e.g. 

consoles) are not cut back.

Note: The defined tolerances are length-type values: the units specified for Length in Preferences > 

Working Units apply.
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Stretch & Cutback

Use this to apply both of these adjusters to a single 1D or 2D Member.

The Stretch & Cutback combination has the same effect as using the two adjusters separately.

For example, a 1D Member may need to be stretched at one end, and cut back at the other end. 

A 2D Member can be stretched on one edge and cut back on another.
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Adjust Connected Ends

Available when adjusting a 1D Member, using Stretch, Cutback or Snap.

If the current adjustment rule results in a new node: this option enables further adjustment(s) which take the 

newly created connection node(s) into account.

• Additional adjustments will be carried out on connected 1D Member(s) at each new node. 

• These additional adjustments occur along the 1D Members’ local x axis.

• The 1D Members’ End Release values are based on this new connection node

• The 1D Members’ Startpoint/Endpoint values in SAF are based on this new connection node

For example:

A Beam is stretched to meet the Column, creating a new node. The “Adjust Connected Nodes” option is OFF.
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If you turn “Adjust Connected Ends” ON: the new connection node is adjusted further, to coincide with the 

existing node.
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Offset 1D Member

Offset always occurs in one direction (one to the other): the adjusting Members will be offset to their targets; 

the targeted Members will remain unchanged.

In this example: the 1D Member in the left Beam is offset, so that it now connects to the other Member.

Connecting Beams: Before and After Offset Adjustment

For each Offset adjuster, you can set a maximum allowed offset distance (“Max. offset”). This distance is 

measured between unadjusted 1D Members and/or unadjusted 2D Member planes.

See also Offset Options In Case of Multiple Targets.

OFFSET 1D MEMBER

Offset 1D to 1D

Offset 1D to 2D

Offset only in Global Z Direction Check this if the 1D Member should only be offset in 

the global Z direction. Offsets in other directions will 

not be applied.

Find edge of 2D Member Check this to offset a 1D Member to the nearest edge 

of the target 2D Member (not the nearest point) - 

provided that the target edge is still within the “Max. 

offset” range.

Note: If you also activate “Offset only in Global Z 

Direction”, the “Find edge” option is limited to the 

Z direction.

See examples in the table below.
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Find Edge of 2D Member - OFF Find Edge of 2D Member - ON

Offset Beam to Slab

Offset Beam to Roof

Offset Corner Column

to Slab Corner
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Offset 2D Member

Offset always occurs in one direction (one to the other): the adjusting Members will be offset to their targets; 

the targeted Members will remain unchanged.

A 2D Member is offset perpendicular to its own plane. This is the local Z direction.

• For each Offset adjuster, you can set a maximum allowed offset distance (“Max. offset”). This distance is 

measured between unadjusted 1D Members and/or unadjusted 2D Member planes.

In this example, the offset adjuster enables the Roof’s 2D Member plane to connect to the 2D Member of the 

Wall below:

Roof Plane: Before and After Offset Adjustment
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Offset 2D Wall Members to 1D Column

See also Offset Options In Case of Multiple Targets.

OFFSET 2D MEMBER

Offset 2D to 1D

Offset 2D to 2D

Offset only parallel 2D Members Restrict the 2D-2D offset adjustment to take place 

only if the 2D Members are parallel
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Offset Options In Case of Multiple Targets

Offset always occurs in one direction (one to the other): the adjusting Members will be offset to their targets; 

the targeted Members will remain unchanged. But what if there are several possible target elements?

In this case, use the “Multiple targets” controls (shown in the images below) to define the preferred group of 

target elements based on their geometry.

In the dialog box, click on the icons to see a text and illustration for each possibility. 

Target Options When Offsetting to a 1D Member

In case of multiple targets, offset to element with 

• Highest core

Offset to the target 1D Member(s) whose core Height dimension is larger

• Lowest core

Offset to the target 1D Member(s) whose core Height dimension is smaller 

• Highest position

Offset to the target 1D Member(s) that have the highest elevation value

• Lowest position

Offset to the target 1D Member(s) that have the lowest elevation value
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Target Options When Offsetting to a 2D Member

In case of multiple targets, offset to element with 

• Thickest core

Offset to the target 2D Member(s) with the largest core thickness value

• Thinnest core

Offset to the target 2D Member(s) with the smallest core thickness value 

• Highest position

Offset to the target 2D Member(s) that have the highest elevation value

• Lowest position

Offset to the target 2D Member(s) that have the lowest elevation value

Offsetting 1D to 2D Member Offsetting 2D to 2D Member
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Snap (1D to 1D)

The Snap adjustment is available only to adjust a 1D Member to another 1D member, “one to the other” only. 

Snap connects a 1D Member to another nearby 1D Member node, if the Members are not in the same plane. 

The Snap adjuster combines stretch, offset and rotation. This can be useful, for example, in connecting 

diagonal bracing to supporting columns.

See also Example 3: Snap.

See also Adjust Connected Ends.

SNAP 1D MEMBER TO 1D MEMBER

“one to the other” only

Find Node within Find the target node within this range. (Nodes located 

farther away will be ignored.) 
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Examples of Adjustment Rules

See the following examples:

Example 1: Offset Beams to Slabs

Example 2: Stretch Beams to Columns

Example 3: Snap

Example 4: Cutback

Example 5: Stretch & Cutback
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Example 1: Offset Beams to Slabs

Turning the Structural Analytical Model on, we see that the Beams’ 1D Members (axes) are not connected to 

the Slab: there is no continuity, which is necessary for structural analysis.

The solution is to generate a rule that offsets the Beam axes to the Slab.

• Members Group 1: Beam

• Members Group 2: Slab

• Method: one to the other (adjust Beams to Slabs)

• Adjuster type: Offset

• Additional options, including the maximum allowed offset.

In this case, let’s use the global Z direction.

Note: The defined tolerances are length-type values: the units specified for Length in Preferences > 

Working Units apply.

Click OK to apply the rule. As expected, the Beam axes are offset to the plane of the Slab (straight up, in the 

Z direction).
ARCHICAD 24 Reference Guide 2474



Structural Analytical Model Generation Rules Structural Analytical Model
But one of the Beams’ axes (the center Beam) stayed in place. This seems to be an error.

Select the center Beam and check its Settings. Here, it is clear that this Beam did not participate in the Offset 

rule, because the element-level Offset setting, in Beam Settings - Structural Analytical Parameters panel, is 

unchecked.

To fix the problem:

• Activate the Offset checkbox in Beam Settings. 

• Click OK to close the Settings dialog. 
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Now the model automatically applies the defined Generation Rules. The Beam axis is now offset, according to 

the rule:

The current rule offsets Beams to Slabs in the Z direction. This model can be considered structurally correct.

You may prefer a different option: Beam axes should be offset to the edge of the Slab.

Adjust this option in Generation Rules:

Click OK to apply the rule. 

As expected, the axes of the two edge Beams are offset to the edge of the Slab plane (instead of straight up, 

as in the previous example, in which only “Global Z offset” was enabled).

If the element could be offset to several target elements, define which element should be the target.
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The preview drawing helps you understand each option:

See Offset Options In Case of Multiple Targets.
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Example 2: Stretch Beams to Columns

To illustrate this adjuster type, let’s use a common steel structure composed of Columns, Beams and diagonal 

bracing:

We see that the Beams’ 1D Members are not connected to the Columns: there is no continuity, which is 

necessary for structural analysis.

The solution is to generate a rule that stretches Beam axes to the Columns.

• Members Group 1: Beam

• Members Group 2: Column

• Method: one to the other (stretch the Beam to the Column, but leave the Column as is.)

• Adjuster type: Stretch

• Additional options for stretch: the maximum stretch allowed.

Note: The defined tolerances are length-type values: the units specified for Length in Preferences > 

Working Units apply.
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The Beams now meet the Columns, but the bracing is still not right.

See the next section to continue: Example 3: Snap.
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Example 3: Snap

Let’s continuing working on the previous example. The diagonal bracing still does not meet the continuity 

requirements, which in a later stage might lead to some issues in the structural analysis software.

To adjust these, the user should use the snap adjuster.

This allows the structural axis to rotate in order to connect its end nodes to the Beam-Column connection 

generated with the stretch adjuster.

Notice that this adjuster should be defined to work only for the Beams that are being used to model bracing 

elements. In this project, such Beams are classified as “Brace”. 

Define the Snap rule to adjust only the 1D Members which are classified as “Brace”: 
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This adjuster type allows you to define the maximum distance of the targeted snap node.

The diagonal bracing will snap to the Columns. 
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Example 4: Cutback

This adjuster is the opposite of Stretch: it cuts back the Structural Analytical Members which overlap. 

Turning on the visibility of the Structural Analytical Model, it is possible to detect the following issues:

– Gap between Walls and Slab

– Slab edge is not aligned with the Walls;
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– The Walls overlap each other at the corner.

1. To solve the first issue, stretch Walls to Slabs using the Stretch adjuster. 

2. Next, cut back the excess Slab to align it to Wall edges, using the Cutback adjuster

– Parameters: In this example, we are using a full edge cut, since the entire Slab runs along the full Wall 

length. Thus, uncheck the “Partial cutback” option.

3. To solve the third issue, we will cut back both Wall edges that intersect and overlap in the corner. Here, 

Walls act as both modifiers and targets, and the operator is “to each other”, since both Walls must be 

analyzed and cut.
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The adjusted structural analytical model should appear as shown below.
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Example 5: Stretch & Cutback

The “Stretch & Cutback” adjuster performs both these adjustments in one step.

This adjuster can be used in one direction or both directions.

Stretch & Cutback Adjustment to Beams and Columns
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Filter Openings for Structural Analytical Model

These settings filter 2D Members of the Structural Analytical Model to account for small holes and narrow 

strips which are unimportant structurally, and can be ignored in the exported model.

Use the Openings Panel of the Structural Analytical Model Generation Rules dialog box.

Ignore openings smaller than or equal to

Check this to define whether small openings in 2D Members should be ignored in the Structure Analytical 

Model.

In this context, “openings” can be any of the following:

• In the 2D Member of a Slab or Roof: Opening, Skylight, inner polygon of Slab, hole as a result of Solid 

Element Operation

• In the 2D Member of a Wall: Opening, Door, Window, hole as a result of Solid Element Operation

In the Generation Rules dialog, enter two dimensions to define a “small” opening. 

Any opening of these dimensions or smaller will be ignored in the Structural Analytical model, and will not be 

represented.

To exempt any particular 2D Member from this rule: you can disable the “Ignore small openings” filter in 

element Settings.

See Allow Rule-based modifications - 2D Member.

Remove 2D Member parts narrower than or equal to

Check this to remove very narrow parts of a 2D Member from the 2D Member surface.

For example, the narrow strip left over between two openings, or the Wall’s remaining part after the window 

opening has been cut out).

This “Remove narrow parts” filter cannot be disabled at the element level.

Example

Let’s assume that a Wall contains two openings, one for a window (1000x1000mm) and another for a 

ventilation duct (200x200mm). For structural analysis purposes, the opening for the ventilation duct does not 

have a significant impact on the structural behavior of the Wall: thus, the structural analysis software should 

ignore this opening.
ARCHICAD 24 Reference Guide 2486



Structural Analytical Model Generation Rules Structural Analytical Model
After applying these Rules, we see the result: the smaller opening is not considered in the Structural Analytical 

model, and the narrow Wall part (adjoining the larger opening) is also excluded.

Effect of Opening Filter on 2D Member
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End/Edge Release (Generation Rules)

This is a panel of the Generation Rules dialog box.

This control defines how the structural analysis software should interpret Release settings values of Ends or 

Edges which have no connections.

Some structural softwares automatically consider all such disconnected ends/edges to be “rigid”. If you are 

using such a software, you might have to change this setting in this panel. See details below. 

For Ends and Edges with no connections:

Use their Translation and Rotation settings (default setting)

By default: the program looks at the End/Edge Release settings at the element level. 

If you have customized any Translation or Rotation value, these are taken into account when the Structural 

Analytical Model is exported in SAF format.

See End/Edge Releases.

In the exported SAF file, the values at RelConnectsSurfaceEdge are “Free” or “Custom”, reflecting the 

element-level End/Edge Release settings.
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In the model, Release symbols are shown on all edges with custom values, as usual.

Custom Edge Releases

Consider as Rigid (Affects Unconnected Ends/Edge Segments)

Certain receiving softwares consider all unconnected Ends, Edges and Edge segment to be Rigid.

You may wish to export your model from ARCHICAD so that it is compatible with such a software. 

In the End/Edge Release panel: Choose Consider as Rigid.

As a result:

• All unconnected Ends, Edges and Edge segments are exported as “Rigid”, regardless of the release 

values set at the element level.

• The SAF file values at RelConnectsSurfaceEdge are “Rigid”, even if the element-level End/Edge Release 

settings have been set to different values
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• Customized Edge Release values will be generated, and the Release symbols shown in the model, only 

where Members are connected to another Member. 

Custom Edge: Shown Along Connected Segment Only
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If you later add additional Structural Analytical Members to the model, the connected edge (segments) will be 

exported with their customized release values, and will be displayed where applicable.
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Eccentricity

1D Members are generated at the center of gravity of the element’s core

2D Members generated along the center of the element’s core plane.

Any deviation of Member position from this default is called “Eccentricity”. 

Eccentricity values have no effect on the Physical Model, but are significant for the Structural Analytical 

Model.

In ARCHICAD, Members can be offset in several ways:

– Manually, by graphical offset in the model (see below)

– Manually, by setting offset/eccentricity value in element Settings (see below)

– By configuring and applying global Adjustment Rules (See Adjustment Rules.)

Offset Member Position (Graphically)

1. Select the Member.

2. Activate the Eccentricity command from the pet palette. (Not needed or available for 1D Members if the 

Physical Model is not currently visible).

3. Drag the Member to its new location (enter Tracker values as needed).

Notes: 

– For 2D Members, Eccentricity/Offset occurs perpendicular to the Member plane (regardless of any 

customized edge angles).

– For any selected Member, the eccentricity value is shown in the Element Info Tag (as well as Settings 

and Info Box).
ARCHICAD 24 Reference Guide 2492



Eccentricity Structural Analytical Model
– Once you have dragged a Member out of its original position, the global Adjustment Rules no longer 

apply to it; the “Offset” checkbox in its Settings dialog is no longer activated. To reapply the global 

Adjustment Rules, go to its Settings dialog and reactivate the Offset checkbox.

See Allow Rule-based modifications - 1D Member or Allow Rule-based modifications - 2D Member.

Offset Member Position (Element Settings)

1. Select the 1D or 2D Member.

2. Open the Settings dialog (Structural Analytical Parameters panel).

3. Uncheck the Offset option, to enable editing. (Unchecking this box means that the global Adjustment 

Rules are not applied to this element, and you are adjusting it manually.)

4. Choose a method for measuring Eccentricity:

– relative to the element’s Center of Gravity, or

– relative to the element’s Structural Analytical Model

The two approaches have the same result, but the values are defined using opposite signs.

5. Define the eccentricity values by doing either of the following:

– Click in the preview window to enter the new location at any bounding box node

– Enter offset values manually

Multiple Eccentricity Values of Imported Elements

Structural Analytical Format version 1.0.6 or later can handle varying and multiple eccentricity values at each 

end of the 1D Member.

ARCHICAD does not support multiple eccentricity values at each end. When you import such a model, 

ARCHICAD 24 converts the incoming elements by assigning an average eccentricity value, where applicable.

In these cases, a warning alerts you to the conversion.
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End/Edge Releases

For each 1D and 2D Member in the Structural Analytical Model, you can set End and Edge Release values, 

respectively.

Translation (U) and Rotation (Fi) values express the transfer of forces at the ends or edges of a Structural 

Member, in the three directions of its local coordinate system (x, y and z).

These values have no effect on the Physical Model, but are essential for structural analysis.

End/Edge Release controls are available in the Structural Analytical Parameters panel of applicable element 

Settings dialogs and the Info Box.

• For 1D Members: set Translation and Rotation values for Ends (either uniform values, or separately for 

each end).

• For 2D Members: set Translation and Rotation values for all Edges.

Notes:

– To set custom edges for 2D Members, use the pet palette. See Set Custom Releases for Each Edge.

– For the purposes of exporting the Release values to SAF format: in the Generation Rules dialog, you 

can apply an “All Rigid” override to all unconnected Ends, Edges and Edge segments of Structural 

Analytical Members. 

See End/Edge Release (Generation Rules).

Release Values: Rigid, Free, Custom

All releases are set to Rigid by default, but you can set alternative values for each direction and component to 

achieve fixed, hinge and roller-type releases:

• From any selected component: choose either Rigid, Free or Custom

• For Custom: manually enter the desired value. 
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End/Edge Release Symbols

Turn on the End/Edge Releases toggle to display Release symbols on Member ends or edges that you have 

customized. (By default, all ends and edges are set to Rigid.)

All Rigid

If the Member’s release values are all Rigid - the default value - then no symbol is shown.
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Hinge Release

For a Member with a “hinge” or “pinned” release (translations all rigid, rotations all free): the symbol is a 

pyramid

 

Custom Release

For a Member using any other Translation or Rotation value: the symbol is a “house”

End/Edge Release Color

Customize these colors at Structural Analytical Model Representation (Preferences).
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Uniform End Releases

For 1D Members, check this box to set equal values at both ends. Otherwise, set values separately for each 

end. 

Set Custom Releases for Each Edge

For 2D Members, you can customize edge release settings via the pet palette:

1. Select a 2D Member.

2. From the pet palette of an edge, choose Custom Edge Settings.

3. Set Edge Release values. 

– Activate “Clicked Edge” to apply the values only to the edge you clicked.

– Or active “All Edges”

4. Click OK to apply.
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Model Check - Overview

Use the three built-in Model Checking functions to identify collisions, potential inadequacies or contradictions 

in the model.

Collision Detection

Physical Model Quality Check

Structural Analytical Model Quality Check

For all three functions: 

• Only visible elements are checked

• If elements are selected: only the selected elements are checked

• All results are listed in the Model Check Report

Related Topic:

Model Check Report
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Physical Model Quality Check

Introduction

The Physical Model Quality check helps you ensure that the Physical Model is correct, by filtering for certain 

modeling and geometric anomalies. As with other types of Model Checking, the results (listed in the Model 

Check Report) draw your attention to potential issues. 

Thus, you will probably run the Physical Model Quality Check before applying the Adjustment Rules and 

generating the Structural Analytical Model.

The Physical Model Quality Check dialog contains a checklist of parameters. You can check the model based 

on all the listed parameters, or just some of them. Each parameter is briefly described below (see Physical 

Model Check Parameters).

The limit/tolerance values of these parameters can be customized - e.g. to conform to modeling standards, or 

to the rules of your structural analysis software.

How the Physical Model Quality Check Works

• Focuses on physical construction elements (not 1D and 2D Members)

• Construction elements are considered regardless of their Structural Function (except for one parameter: 

see Another Load-Bearing Element closer than)

• Only visible elements are checked

• If elements are selected: only the selected elements are checked

Run the Physical Model Quality Check

In the 3D/Floor Plan/Section window:

1. Open Design > Model Check > Physical Model Quality

2. The Physical Model Quality Check is based on the listed parameters (see Physical Model Check 

Parameters for details). Uncheck any parameter that should not be considered.

3. Click Check.

4. The Model Check Report opens to show results.

See Model Check Report.
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Physical Model Check Parameters

Lack of Core connection

This check identifies any two intersecting structural elements whose cores do not connect to each other.

In this example:

The Wall intersects the Slab only as far as the Slab finish: the cores are not connected! 

This problem affects the Structural Analytical Model, because if the element cores are not connected, the 

Adjustment Rules cannot take effect, and the 2D Members remain disconnected.

Notes:

– All elements with a Basic Structure have a core, so they are always considered in this check

– Complex Profiles and composite structures are considered only if they include at least one component 

that is defined as “Core”

– All elements that contain a core are considered (not just the load-bearing elements)

Another Load-Bearing Element closer than

This check identifies any pair of load-bearing elements which do not intersect at all, yet are closer to each 

other than the given tolerance value.

This situation is probably a modeling error, as shown in this image: a tiny gap exists between the Slab and the 

Wall.
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Elements with inadequate Core dimension ratio

Use this checkbox to turn this group of parameters on or off (or deactivate any parameter individually).

Each parameter examines the ratios of certain core dimensions of Beams, Columns, Slabs and Walls, and 

checks if the result ratios are within the defined range.

If the ratio is not within the defined range, these elements are identified as “Element with inadequate Core 

dimension ratio” in the Model Check dialog.

• All core-containing elements are considered, regardless of their Structural Function (not just the load-

bearing elements).

• The checked dimensions refer to the core part of the element.

– For example, for a composite Slab that is 300 mm thick (200 mm core component plus 100 mm of 

insulation and plaster skins), only the core thickness of 200 mm is considered as part of the check.

• To see an illustration of the checked ratio: select an item, then click the Info button.

To See Illustration: Select Parameter, Click “Info”

Tips for Using “Inadequate Ratio” Parameters

This set of parameters in the Physical Model Quality Check dialog are based on the Eurocode standard for 

concrete structures. (See below for a brief description of each.)

For example, a Column whose cross-section width and height are out of proportion might be considered as a 

2D Member rather than a 1D Member.

Results listed in the Model Check dialog are not necessarily errors. However, to promote consistency, you can 

use these “inadequate ratio” parameters to fit your specific workflow and the requirements of the receiving 

software. For example:

• Project team members can agree to model certain structures (such as a parapet) with a Wall rather than a 

Beam, or vice versa.
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• Project team members can agree to model the building-length Walls using separate segments, rather than 

a single extra-long Wall.

• Use the Model Check to find any discrepancies

Check any of the following parameters related to inadequate core dimension ratios:

Beam: Core Cross-section height/Element length

Ratio of the Beam’s total length to its (core cross-section) height.

For example: if the Beam is “too tall” compared to its length (based on the given relation values), then it is 

listed in the Model Check Report. 

The rules of the structural analytical software might consider this element as a 2D Member (like a Wall) rather 

than a 1D Member, or as a Column rather than a Beam.

Note: the “Wall height/length” parameter (described below) checks for the inverse of this situation. 

Beam “Too Tall” Compared to Length

Column Dimension Parameters

The next two parameters check Column dimensions in two ways: 

Core cross-section dimension/Element height

Core cross-section dimensions ratio

Notes:

– These parameters consider only the parts of the column defined as “Core”. 

– If the Column has a Veneer: the Veneer thickness is considered if that Veneer component is defined 

as “Core” (in Column Settings, “Segment” page.) If the Veneer is defined as “Finish” or “Other”, it is not 

considered.

Slab thickness/area ratio

Compares Slab core thickness to the Slab area. 

If this ratio is greater than the given value (if the Slab is too “thick” compared to its area), it is listed in the 

Model Check Report.
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Slab “Too Thick” Compared to Area

Wall height/length ratio

Ratio of the Wall height to its total length.

For example: if the Wall is “too tall” compared to its length (based on the given relation values), then it is listed 

in the Model Check Report. 

The rules of the structural analytical software might consider such an element as a 1D Member (like a Beam) 

rather than a 2D Member. 

Note: The “Beam height/length” parameter (described above) checks for the inverse of this situation.
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Structural Analytical Model Quality Check

Introduction

The Structural Analytical Model Quality Check helps you ensure that the generated Structural Analytical 

Model is correct. The results (listed in the Model Check Report) draw your attention to potential issues. 

The quality check dialog contains a checklist of parameters, in four categories. You can check the model 

based on all the listed parameters, or just some of them. Each parameter is briefly described below (see 

Structural Analytical Model Check Parameters).

You will probably run the Structural Analytical Model Quality Check after you have applied Adjustment Rules, 

and before you export it to a structural analysis application.

Note: However, it might be worth checking for certain quality check parameters - such as Overlaps - even 

before you apply the Adjustment Rules. If the model contains overlapping Members, your Adjustment 

Rules might not have the desired effect.

All results are listed in the Model Check Report.

Even if the Model Check report lists various anomalies, this does not necessarily mean you cannot export the 

Structural Analytical Model. For example, the Structural Analytical Model Check can filter for sharp angles on 

a slab edge, but this situation may well be deliberate.

Note: You must turn on the display of the Structural Analytical Model. Otherwise, this dialog is not 

available.

How the Structural Analytical Model Quality Check Works

• Focuses on 1D and 2D Members (not physical model elements)

• If any elements are selected in the model, only the selected elements are checked

• Checks only elements which exist in the Structural Analytical Model and are visible

Exception: One of the parameters identifies elements that are not Members of the Structural Analytical 

Model: see Load-Bearing Element with no Member.
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Run the Structural Analytical Model Quality Check

In the 3D/Floor Plan/Section window:

1. Turn on the display of the Structural Analytical Model.

2. Design > Model Check > Structural Analytical Model Quality

3. The dialog lists checking parameters in four categories (see below for more details).

4. Uncheck any category and/or any parameter that you want to ignore.

5. Click Check.

6. The Model Check Report opens to show results.

See Model Check Report.

Structural Analytical Model Check Parameters

Lack of Member Connection

These two parameters find intersecting or nearby Members that are not connected (but probably should be):
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Break in continuity

The cores of two load-bearing elements intersect, but their 1D or 2D Members are not connected.

Cores Intersect, but Members Do Not Connect

For 1D Members: You can “virtually” extend their connection range to avoid such breaks in continuity.

See Connection Range (Extend Core to Enable Connection).

Nodes closer than

Any two nodes are closer to each other than the given distance.

The nodes can be on the same Member or two different Members.

Element cores do not need to intersect.
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Nodes are Close Together, but Members Do Not Connect

Overlaps

The following three parameters identify overlaps among 1D and 2D Members (not overlapping physical model 

elements!)

Partially overlapping Members

Two 1D Members or two 2D Members partially overlap. Only Member position is considered - no other 

parameters are considered.

For example, two Beams overlap due to a modeling error (e.g. after stretching).

Fully overlapping Members - different Structural Analytical Parameters

Two 1D Members or two 2D Members completely overlap in 3D. 
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However, their Structural Analytical Parameters are different. (e.g. one Member uses Offset rules, while the 

other Member’s eccentricity was manually edited).

• Structural Analytical Parameters: all settings on the Structural Analytical Parameters page of the 

element’s Tool Settings.

• Only the Member’s position and Structural Analytical Parameters are considered. 

This result probably indicates an inadvertent overlap. For example, one Member’s eccentricity was adjusted 

so that it ended up outside the physical model element, right on top of the other Member.

Fully overlapping Members - identical Structural Analytical Parameters

Two 1D Members or two 2D Members overlap completely in 3D space. Their Structural Analytical Parameters 

are entirely identical.

• This result indicates duplicated elements, caused by an error in modeling.

Unusual Member Geometry

These four parameters are helpful in identifying modeling errors. Such errors are worth finding, because even 

small geometric inaccuracies can undermine the precision of the exported Structural Analytical Model and 

affect the FEM analysis.

Of course, the check might also identify unusual modeling solutions that were created deliberately.

For any of these parameters: hover over it to see the current Length or Area unit (as set in Options > Project 

Preferences > Working Units).

You can enter precise tolerance values here - set the desired number of decimals at Working Units.

The following parameters check for “Unusual Member Geometry”:

1D Member shorter than

The length of the 1D Member is shorter than the given length.
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2D Member smaller than

The area of the 2D Member is less than the given area.

2D Member Too Small, 1D Member Too Short

Consecutive Edges

The following two parameters are applicable to consecutive edges of any given 2D Member. 

They identify uneven edges and protrusions which might be modeling errors.

• Consecutive edges shorter than

For any single 2D Member, finds any adjoining edges that are both shorter than the given tolerance value.

• Angle of consecutive edges smaller than

For any single 2D Member, finds any adjoining edges that form an angle less than the given tolerance 

value.

Consecutive Edges: Too Short, Too Sharp

Unusual Structural Analytical Parameters

These three checks identify elements that might be anomalies, based on their Structural Analytical 

Parameters:
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Load-Bearing Element with no Member

Finds any construction element whose Structural Function is set to “Load-Bearing”, yet does not have a 

Structural Analytical Member. This may or may not be an error.

Possible reasons:

• This load-bearing element could be part of the Structural Analytical Model, but its 1D Member or 2D 

Member checkbox is not activated in its Tool Settings dialog. 

• This type of load-bearing ARCHICAD element cannot be part of the Structural Analytical Model (e.g. 

Morph, Stair, Multi-plane Roof, Object)

Load-Bearing Object: No Member

All End/Edge Releases with zero stiffness

Finds any Structural Member in which all of the End Releases (for a 1D Member) or Edge Releases (for a 2D 

Member) are set to “Free”. 

This is probably an error, because no forces are translated.

See End/Edge Releases.

Structural Support with zero stiffness

Finds any Structural Support element in which all of the Translation and Rotation Stiffness values are set to 

“Free”. 

This is probably an error, because no forces are translated.
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Model Check Report

The Model Check Report lists results from all three of the Model Check functions

• Collision Detection

• Physical Model Quality Check

• Structural Analytical Model Quality Check

The list is refreshed each time you run or re-run any of the checks.

New items (compared to the previous status) are shown in bold.

Every item remains on the list until you delete it, or until you close the project.

Click the Info button to see a summary of the reported problems

The results listed in Model Check Report are not necessarily errors - they may simply reflect a one-off, specific 

solution, or a particular client request. For each listed item, you can decide to fix it, ignore it, or create an 

Issue, which is easily done straight from the Model Check Report dialog.

• To create an Issue: See Create Issue from Model Check Report.

• Double-click any item to zoom to the element in 3D.

• Right-click any item for further context menu commands
ARCHICAD 24 Reference Guide 2511



Model Check - Overview Structural Analytical Model
ARCHICAD 24 Reference Guide 2512



Collaboration with Structural Analysis Software Structural Analytical Model
Collaboration with Structural Analysis Software

ARCHICAD can share the Structural Analytical Model with structural analysis applications via the Structural 

Analysis Format (SAF). This is a global, open-source file format, developed by Nemetschek Group and 

optimized for this purpose.

Import and export of the Structural Analysis Model in IFC format (IFCStructural Analysis View, developed by 

buildingSMART) is available in ARCHICAD 24 as an Experimental Feature.

Both collaboration methods are described in the following sections:

Structural Analysis Format

IFC Structural Analysis Model Import/Export - Experimental Feature
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       IFC Structural Analysis Model Import/Export - Experimental Feature

You can open, compare or save files in IFC Structural Analysis Model format (*.ifc). This is an IFC file that 

uses the “Structural Analytical View” Model View Definition.

Note: This feature is “Experimental” in this version of ARCHICAD. See Experimental Features for more 

information.

Enable This Feature

1. Go to Options > Work Environment > More Options.

2. Go to the Experimental Features tab page.

3. Check the box to Enable IFC Structural Analysis Model Import-Export.

Import

From the Floor Plan or 3D Window:

1. Use File > Open

2. Choose the IFC Structural Analysis Model (*.ifc) file format. IFC 2x3 and IFC4 are both supported.

3. Click Open.

Design > Model Compare

Browse for Structural Analysis models in *.ifc format.

Element Handling at Import

When importing a IFC Structural Analysis Model file, elements are converted automatically. There are no 

mapping rules.

1D and 2D Members are converted automatically based on geometry: a vertical Member is a Column, a 

horizontal Member is a Beam.
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Building Materials

If the imported element’s Building Material already exists (by name) in the ARCHICAD template, it uses the 

corresponding ARCHICAD Building Material.

Note: Only the names are compared. Building Materials of the same name are considered as a match.

If the Building Material does not exist in the ARCHICAD template:

• the Building Material name (as in IFC) is imported and added to the list of ARCHICAD Building Materials. 

• its settings use the Building Material defined for the corresponding default tool in ARCHICAD (e.g. the 

default Column’s Building Material attributes)

Profiles

If the imported 1D Member’s Profile already exists (same name and geometry) in the ARCHICAD template, it 

uses the corresponding Profile.

If the incoming Profile does not exist in ARCHICAD, then it is imported and added to the ARCHICAD Profiles.

Other Element Settings at Import

All other settings of imported elements use the defaults of the respective ARCHICAD tool (Layer, 

Classification, user-defined Properties, etc.)

Structural Analytical Model Settings 

The imported model uses the following settings in ARCHICAD to prevent automatic adjustments and to 

correspond as exactly as possible to the original structural model:

– Layer Intersection Group settings are reset to zero (intersecting elements will not connect)

– Adjustment Rules (in the Structural Analytical Model Generation Rules dialog) are set to “No Rules”

– Beam End Cuts are all set to vertical, Column End Cuts are all set to horizontal

Export

From the Floor Plan or 3D Window:

1. Use File > Save as

2. Choose the IFC Structural Analysis Model (*.ifc) file format. The file can be exported as IFC2x3 only. 

(IFC4 is not supported)
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3. From the Export pop-up, choose to save the entire project, or only the visible elements.

When saving from the Floor Plan, you can save elements from the current or all stories.

4. Click Save.

Element Handling at Export

All 1D and 2D Members are saved with their current settings (geometry, profiles, materials). 
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Structural Analysis Format

Structural Analysis Format (SAF) is an Excel-based, open-source and global schema optimized for storing 

and sharing structural analytical model data.

SAF supports bi-directional collaboration between ARCHICAD and structural analysis apps. The structural 

analytical model of load-bearing elements in ARCHICAD can be used for analysis and design in external 

applications that use the finite element method (FEM).

For further information about the SAF schema and its detailed content, visit http://saf.guide/.

Topics in this Section:

Export SAF File from ARCHICAD

Import SAF File to ARCHICAD

Optimizing SAF Translators

SAF Translator for Export: Settings

SAF Translator for Import: Settings

Import/Export Translator Settings
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Export SAF File from ARCHICAD

Hint: Before export, it is recommended to fill out the following fields in the Project Info dialog box (File > 

Info > Project Info). 

– Project Name

– Building Name

These data will be visible on the SAF file’s Project and Model Data tab pages.

There are two ways of exporting the structural analytical model:

1. From the ARCHICAD project (Floor Plan or 3D Window), use File > Save as.

– Choose Structural Analytical Format (*.xlsx)

– From the Export pop-up, define whether to export the Entire project, the visible elements in your 

current view, or selected elements.
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2. Use Document > Publish to export the analytical Members visible in your published views.

Export is based on the SAF Translator settings of the current ARCHICAD project. 

See Optimizing SAF Translators.
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Import SAF File to ARCHICAD

There are two import workflows:

• Open the SAF file in ARCHICAD

• Use the Model Compare to visualize the differences as part of a bi-directional workflow

Each workflow is summarized below.

Use File > Open

1. Use File > Open and browse for the desired SAF file

2. The Open process uses the SAF Translator settings of the template file you choose. 

Check the current template file, shown in Open dialog box at “Translator”. If needed, click Options to 

choose a different template.

3. The SAF file is opened in ARCHICAD.

– Incoming elements are mapped to ARCHICAD counterparts based on the settings of the SAF Import 

Translator of the chosen template file. This includes the element’s Layer definition. (See SAF 

Translator for Import: Settings.)

– After import, a “Custom” Layer Combination is activated automatically, in which the Layer Intersection 

Class is set to zero for all Layers. (This way, automatic priority-based connections do not take place, 

and the Structural Analytical Model connections are not disturbed.)

– The Structural Analytical Model Adjustment Rules are set to “No Rules” - again, to avoid altering the 

structural analytical model connections.

Use Model Compare 

If you are importing back the changes or checking the modifications in the SAF file, it is recommended to use 

the Model Compare feature (Design > Model Compare). 

When opening an SAF file using Model Compare, the Translator settings of the current project are applied by 

default. However, when selecting the SAF file in Model Compare, you can choose a different template for the 

SAF Translator, if needed.

See Compare Two Structural Analytical Models.
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Optimizing SAF Translators

When you import and export SAF files between ARCHICAD and external structural analysis softwares, the 

data exchange occurs based on SAF Translator settings. SAF Translators ensure that the ARCHICAD 

structural analytical model is correctly recognized and interpreted by the external software, and vice versa.

Translator settings include

• Building Materials (in ARCHICAD) and corresponding SAF Materials

• ARCHICAD Profiles (in ARCHICAD) and corresponding SAF Cross Sections

• Local Coordinate System standards (how to interpret the orientation of 1D Members)

• ARCHICAD element default settings to use for incoming SAF elements

• How to interpret curved Walls exported from ARCHICAD if the receiving software cannot handle them

Access SAF Translator settings at File > Interoperability > SAF > SAF Translators. 

During structural model exchange, the applied SAF Translators come from either the current ARCHICAD 

project or a template file, as summarized in this table:

Since different softwares may use different naming conventions, you should fine-tune the translator settings to 

ensure correct data exchange based on the specific software you are collaborating with.

• Mapping the Cross Section/Profile and Material names between SAF data and ARCHICAD can be done 

by hand in the corresponding Translator settings. 

• GRAPHISOFT also provides predefined data files to make the process easier. 

• You can also create your own SAF data file based on your analysis software

See the following sections:

Download SAF Data Files Optimized for Structural Applications

Prepare and Export a SAF Data File to Ensure Standard Mapping

Which SAF Translators Are Applied? 

Export ARCHICAD to SAF Translators in the Current Project

Open SAF in ARCHICAD Choose a Template File

Open SAF in Model Compare Current Project OR Chosen Template
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Download SAF Data Files Optimized for Structural Applications

To download SAF data files that are optimized for particular structural applications:

• go to the Downloads page at graphisoft.com

• or click the info link at the bottom of the SAF Translators dialog

Available content on this page, which will be expanded periodically, includes:

• SAF Material catalog in SAF.xlsx format for various Analysis Softwares (e.g. SCIA)

• SAF Manufactured Cross Section catalog in SAF.xlsx format for various Analysis Softwares (e.g. SCIA)

• External Database file for “Create Profiles for unmapped Manufactured Cross Sections” feature, used in 

the SAF Import Translator.

• Translator settings in SAF Translator.xml format

Note: The predefined SAF Translator.xml files are based on the ARCHICAD factory-defined template. 

Thus, some of its Material and Profile attributes may not match the attributes in your project file, causing 

missing attributes which you need to replace by hand. Nevertheless, using the predefined file can still 

save you time by providing a well-defined starting point.

Download the package you need, then import or merge the file in the relevant SAF Translator dialog.

Note: The available predefined content represents extensive and comprehensive catalogs, including 

many items that will not be used in your specific project.

If you only need a limited set of SAF Materials/Cross Sections, consider creating your own SAF data file 

based on the external analysis software, which includes only the items you need:

See Prepare and Export a SAF Data File to Ensure Standard Mapping.
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Prepare and Export a SAF Data File to Ensure Standard Mapping

Use this method if your project uses a limited number of specific SAF Materials/Cross Sections. This way you 

can easily access the exact Material/Profile names used in the external software.

Note: GRAPHISOFT also provides several predefined SAF data files - these are much more 

comprehensive catalogs. See Download SAF Data Files Optimized for Structural Applications

In the external software, create a file that contains all the SAF Materials and SAF Cross Sections used by the 

external software (e.g. SCIA Engineer or RISA-3D). Then export the file as SAF (*.xls).(This saved file does 

not need to contain any actual structural Members, just the SAF Cross Section and material lists.) 

Sample SAF file, containing SAF Materials and Cross Sections

Now you can import or merge the file in the relevant SAF Translator dialog.

See these sections:

Add More SAF Materials to Mapping List (Export to SAF)

Add More SAF Cross Sections to Mapping List (Export to SAF)

Add More SAF Cross Sections (Import SAF to ARCHICAD)

Mapping Imported “General” or “Parametric” SAF Cross Sections
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SAF Translator for Export: Settings

Access SAF Translator settings at:

File > Interoperability > SAF > SAF Translators. 

The SAF Export Translator has four panels:

Material Mapping (Export to SAF)

Profile Mapping (Export to SAF) 

Local Coordinate System (Export to SAF)

Segmentation Settings (Export to SAF)
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Material Mapping (Export to SAF)

Go to File > Interoperability > SAF > SAF Translators, and choose the Export translator.

Use Material Mapping to map ARCHICAD Building Materials to their exact counterparts (“SAF Material”) in 

the receiving software.

You can map each ARCHICAD Building Material by name to a specified SAF Material.

See Map ARCHICAD Building Material (By Name).

Any Building Material that is not mapped by name uses the default specified at “Other Building Materials” - 

this is a catch-all definition. 

Material mapping definitions in this panel apply to the following exported ARCHICAD structures:

• All 2D Members

• 1D Members with Rectangular and Circular Profile 

• Complex Profiles that are exported as “General” Types in the Profile Mapping panel. (These have no 

corresponding named SAF Cross-Section which would include a material.)

– For all other ARCHICAD Complex Profiles: Material mapping does not apply. These Complex Profiles 

are mapped by name (in the Profile Mapping panel) to a corresponding SAF Cross-Section, which 

includes a material definition.
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Map ARCHICAD Building Material (By Name)

1. For each listed ARCHICAD Building Material, choose a corresponding SAF Material definition.

• In the pop-up, available SAF Materials are listed according to their six predefined SAF Material Types 

(e.g. Concrete, Steel...)

• If you don’t find the material you need, add more materials by clicking the SAF Materials button.

See Add More SAF Materials to Mapping List (Export to SAF).

2. To map an additional ARCHICAD Building Material, do one of the following:

– From the Add button, click Add Core Building Materials of Load-Bearing Elements to add all the 

core Building Materials of all placed Structural Analytical Model elements of the current project.

– Click Add. Then choose from the ARCHICAD project’s list of Building Materials
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Use Element Property for More Precise Material Mapping

You may need to map a single ARCHICAD Building Material to multiple SAF materials. In Structural Analysis 

applications, various strength grades might be used for the same material type (e.g. Concrete - C20/25, C30/

37, etc.).

1. Check the box to include ‘Use Element Property for more precise mapping’.

2. The property selection pop-up is now available. Choose a single ARCHICAD property to differentiate the 

Building Material (here, Strength Grade).

Note: The pop-up contains all Properties of the ARCHICAD project. To create or manage Properties and 

Property Groups, see: Property Manager.

For example, the “Steel - Structural” Building Material in this ARCHICAD model requires three different SAF 

mapping definitions, to reflect the three different Strength Grade values: S 275, S 355 and undefined.
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3. The “Value” column is added to the mapping rule: click in the Value field to enter the relevant data (e.g. 

S 275 or S 355 for the Steel-Structural Building Material).

Important Notes:

– In a given ARCHICAD model, only a single Element Property can be used as a value in SAF Material 

Mapping.

– Only string-type Element Properties can be used for SAF Material Mapping. 

– To map by property value, these values must be assigned to ARCHICAD elements (e.g. in Beam or 

Column Settings) - not to their Building Materials.

Example: Building Material with Various Strength Grade Property Values

In this model, several ARCHICAD elements use the Steel-Structural Building Material, but with varying values 

assigned to their Strength Grade property, in the Classification and Properties Panel of Element Settings.
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Add More SAF Materials to Mapping List (Export to SAF)

In the Material Mapping Panel of SAF Export Translator: 

There are two ways to expand the browsable list of SAF Materials: Import a file, or add by hand.

Import SAF Material List from SAF File

This is the preferred method, because you can avoid typing errors.

1. Click SAF Materials.

2. Click the Import button.

3. Browse for an.xlsx (SAF) file prepared for this purpose. (It should contain the list of Materials used by the 

receiving structural analytical program.)

See Prepare and Export a SAF Data File to Ensure Standard Mapping.

4. As needed, select and edit any of the materials.
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5. Click OK. The chosen SAF file’s Materials are automatically added to the SAF Material list in 

ARCHICAD’s SAF Translator dialog.

Add or Edit SAF Materials Manually

1. Click SAF Materials.

2. Select one or more Materials from the dropdown list (these are standard SAF Material types), then click 

OK,

Or: 

3. Click Add

4. Enter the SAF Material name and Material type.

To edit data for any listed Material, select it in the list and click Edit.

5. Click OK.
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Profile Mapping (Export to SAF)

Use Profile Mapping to map 1D Members that are Complex Profiles to their exact counterparts (“SAF Cross 

Section”) in the receiving software.

Note: You only need to map 1D Members that are Complex Profiles, because the thickness of all 2D 

Members are automatically recognized and mapped. Their materials are defined based on the Material 

Mapping panel.

Go to File > Interoperability > SAF > SAF Translators, and choose the Export translator.

Cross Section Types in SAF

The SAF standard defines four Types of Cross Sections:

• Manufactured: Industrially manufactured cross-sections, with standard naming.

• Compound: Compounded section based on multiple manufactured profiles (e.g. two I-sections). Example 

of compound cross-section input: profile = IPE200 and parameters=10mm (distance between profiles).

• Parametric: Cross Sections defined by shape and dimensions (parameters).

• General: Serves to define any general shape of the cross-section. Consists of one or more closed 

polygons including openings. These do not use standard naming.

SAF Cross Sections that are “Parametric” or “General”
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Map Complex Profiles (By Name)

1. For each listed ARCHICAD Profile, choose a corresponding Type and Cross Section.

– The SAF Cross-section pop-up is filtered by the chosen type (Manufactured, Parametric or 

Compound) and listed according to SAF Formcode.

– If you don’t find the SAF Cross Section you need in the pop-up, you can add more to the list. See Add 

More SAF Cross Sections to Mapping List (Export to SAF).

– For all Profiles mapped by name, the SAF Cross Section includes the material definition.

– Profiles whose type is “General” are not mapped by name. They will be recreated as SAF Cross 

Sections based on the Profile polygon or geometry. Their material is defined in the Material Mapping 

panel.

2. To add an additional ARCHICAD Profile to the list, do one of the following:

– From the Add button, click Add used Profiles from Current Project
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– Click Add, then choose from the ARCHICAD project’s list of Complex Profiles. (Available Profile 

attributes: those with a core and used with Beams or Columns.)
ARCHICAD 24 Reference Guide 2535



SAF Translator for Export: Settings Structural Analysis Format
Add More SAF Cross Sections to Mapping List (Export to SAF)

In the Profile Mapping Panel of SAF Export Translator: there are two ways to expand the list of available SAF 

Cross Sections: Import a file, or add by hand.

Import SAF Cross Sections from SAF File

This is the preferred method, because you can avoid typing errors.

1. Click SAF Cross Sections.

2. Click the Import button.

3. Browse for an.xlsx (SAF) file prepared for this purpose.

See Prepare and Export a SAF Data File to Ensure Standard Mapping.

4. The SAF Cross Sections from the file (Parametric, Manufactured and Compound types) are now listed in 

the dialog.

Note: General types and Rectangular/Circular parametric types are not listed!
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5. Sort and select the listed Cross Sections as needed.

6. Click OK to add them to the Translator.

Add or Edit SAF Cross Sections Manually

1. Click SAF Cross Sections.

2. Click Add

3. In the New SAF Cross Section dialog.

– Enter the SAF Cross Section name and Material type.

Note: Only “Manufactured” type SAF Cross Sections can be added here, since they use standard names.
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– Choose a SAF Cross Section Formcode from the pop-up. 

– Choose a SAF Material type (steel or aluminum).

To edit data for any listed Cross Section, select it in the list and click Edit.
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Default Mapping for Exported Cross Sections

• Rectangular and circular (solid) Beams and Columns are handled automatically by the “Other Rectangular 

Profiles” and “Other Circular Profiles” default rules: they are converted to “Parametric - Rectangle” or 

“Parametric - Circle” SAF Cross Sections, with their actual dimensions (height/width or core diameter). 

(Their materials are defined based on the Material Mapping panel.)

• Rectangular or circular profiles which are hollow (tubular) are handled as “Other Profiles”.

• The “Other Profiles” default mapping rule applies to all other exported Complex Profiles that have no 

specific mapping. Its default Type can be either “General” or “Manufactured”. 
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Local Coordinate System (Export to SAF)

This is a panel of the SAF Export Translator.

In each receiving software, a cross section from the catalog is placed into the workspace based on its default 

XYZ orientation, as defined in the Local Coordinate System (LCS) of the host 1D Member.

Since the LCS standard varies by software, you must choose the standard which the receiving software uses: 

click one of the LCS standards shown in this panel of the SAF Export Translator.

At SAF file export, ARCHICAD will convert the outgoing elements accordingly, so that 1D Member Cross 

Sections will be oriented correctly in the receiving software.

How Do I Know Which Local Coordinate System to Choose?

If you have imported predefined SAF Translator Settings optimized for a particular software, the Local 

Coordinate System is correctly defined.

See Download SAF Data Files Optimized for Structural Applications.

To identify the LCS used by the receiving software, do the following (and view the image below):

1. Map an L-shaped ARCHICAD Profile Attribute to its counterpart in the receiving program. (Use a non-

symmetrical profile - such as L - whose orientation is obvious.)

2. In the receiving software, place the corresponding L Cross Section using its default placement (without 

extra rotation or mirroring), so that it “faces” the same way as the ARCHICAD profile. 

3. View the placed Cross Section position in the LCS of the 1D member. Typically, European software (e.g. 

SCIA Engineer) use LCS 0, while U.S. software use LCS 4 (e.g. RISA-3D) or LCS 3.

4. In the SAF Translator for Export, choose the LCS option that corresponds to your receiving software.
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Note: You do not have to set an LCS in the SAF Import translator. When importing a SAF file, ARCHICAD 

automatically converts the incoming element positions, based on the “LCS of cross-section” Model data.
ARCHICAD 24 Reference Guide 2541



SAF Translator for Export: Settings Structural Analysis Format
Segmentation Settings (Export to SAF)

Access SAF Translator settings at:

File > Interoperability > SAF > SAF Translators. 

This panel affects the SAF export of 2D Members that are generated from curved Walls.

Note: This is an export option only. The effects of this option are not visible in ARCHICAD.

• No Segmentation: This is the default option. If your receiving structural analysis software can handle 

curved 2D Members generated from curved Walls, use this default.

• Segment 2D Member of Curved Wall: Use this option only if your receiving structural analysis software 

cannot handle curved Walls. The curved 2D Member will be exported as multiple segments.

In the Central Angle field: Define a maximum central angle for the resulting segments.

– The resulting segments will approximate the central angle you have defined (without exceeding it), but 

are subject to the following adjustments:

- If the curved Wall contains additional nodes besides its endpoints (e.g. structural nodes where a 

connecting element meets the Wall), then segments will be created so that their endpoints coincide 

with these existing nodes.

- Based on these node locations, actual Central angle values (and segment lengths) will vary.

Important Notes 

– If you choose Segment 2D Member of Curved Wall: the receiving software will generate additional 

segment endpoints to coincide with the nodes of any Structural Support and Structural Analytical Links 

that are attached to the curved Wall.

– The newly generated, inner edges of the exported Wall segments will have Edge releases set to Rigid 

(regardless of the Release values of the original Wall edges).
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SAF Translator for Import: Settings

Access SAF Translator settings at:

File > Interoperability > SAF > SAF Translators. 

Settings of the Translator for Import are grouped into three sections:

The SAF Import Translator has four panels:

Material Mapping (Import SAF to ARCHICAD)

Profile Mapping (Import SAF to ARCHICAD) 

Miscellaneous Settings (Import SAF to ARCHICAD)
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Material Mapping (Import SAF to ARCHICAD)

Go to File > Interoperability > SAF > SAF Translators, and choose the Import translator.

Use Material Mapping to map incoming materials (“SAF Material”) from the external software to their 

counterpart ARCHICAD Building Materials.

For each SAF Material Type:

Click the pop-up to choose from the current ARCHICAD project’s Building Materials.

To add more SAF materials to the mapping list, click Add.

See Add More SAF Materials (Import SAF to ARCHICAD).

Note: Material mapping does not apply to all incoming Members in the SAF file. When incoming SAF 

Cross Sections are mapped by name (in the Profile Mapping panel), the ARCHICAD Profiles include a 

Building Material. Material mapping is therefore not applicable to them.
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Additional Material Mapping: By Element Property Value

In some cases, you may need to map multiple SAF materials to a single ARCHICAD Building Material.

To add an additional level of mapping:

1. Check the box to include ‘Fill Element Property by SAF Material’.

2. The Property pop-up is now available. Click to choose the Element Property (e.g. Strength Grade) by 

which to differentiate the Building Material.

By including this property value in the mapping definition, you can create multiple mappings, based on the 

differing property values.

Important Notes:

– In a given ARCHICAD model, only a single Element Property can be used as a value in SAF Material 

Mapping.

– Only string-type Element Properties can be used for SAF Material Mapping. 

– Property values must be assigned to ARCHICAD elements (e.g. to Beams and Walls) - not to their 

Building Materials.
ARCHICAD 24 Reference Guide 2545



SAF Translator for Import: Settings Structural Analysis Format
Add More SAF Materials (Import SAF to ARCHICAD)

To expand the list of mappable SAF Materials, do one of the following in the Material Mapping panel (SAF 

Import Translator):

Import from SAF File

This is the preferred method, because you can avoid typing errors.

1. From the Add button, click Merge from file.

2. Browse for an.xlsx (SAF) file exported for this purpose. (See Prepare and Export a SAF Data File to 

Ensure Standard Mapping).

3. Materials from the SAF file appear in a dialog. Review this list and check the ones to import.

4. Click OK.

Add or Edit Manually 

1. Click Add or (for a selected Material in the list) Edit.

2. In the appearing dialog, manually enter or edit the SAF Material name/type.
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Profile Mapping (Import SAF to ARCHICAD)

Use Profile Mapping to map incoming SAF Cross Sections (1D Members only) to ARCHICAD Profiles.

Go to File > Interoperability > SAF > SAF Translators, and choose the Import translator.

Topics in this Section

Map SAF Cross Sections By Name

Add More SAF Cross Sections (Import SAF to ARCHICAD)

Create Profiles for Unmapped Manufactured Cross Sections (Import SAF to ARCHICAD)

Mapping Imported “General” or “Parametric” SAF Cross Sections

Parametric SAF Cross Sections Recognized by ARCHICAD
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Map SAF Cross Sections By Name

1. From the structure pop-up, choose Profile.

2. Choose from the Profile attributes of the current project. (Available Profile attributes: those with a core and 

used with Beams or Columns.)

Note: You can use Options > Complex Profiles > Import Standard Steel Profile to add new Profile 

attributes to the project.

See also Use Standard Steel Column or Beam Profile.

3. View and edit the Complex Profile’s Offset Modifiers as needed, to best match the incoming Cross 

Section.

To expand the list of mappable SAF Cross Sections: see Add More SAF Cross Sections (Import SAF to 

ARCHICAD).

Automatic Mapping of Manufactured Cross Sections

For incoming, manufactured SAF profiles that are NOT mapped by name in the Profile Mapping list: you can 

activate automatic mapping based on a default database.

See Create Profiles for Unmapped Manufactured Cross Sections (Import SAF to ARCHICAD).
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Add More SAF Cross Sections (Import SAF to ARCHICAD)

To expand the list of mappable SAF Cross Sections, do one of the following in the Profile Mapping panel (SAF 

Import Translator):

Import Cross Sections from SAF File

This is the preferred method, because you can avoid typing errors.

1. From the Add button, click Merge from file.

2. Browse for an .xlsx (SAF) file prepared for this purpose.

See Prepare and Export a SAF Data File to Ensure Standard Mapping.

3. Cross Sections from the SAF file appear in a dialog. Review this list and check the ones to import.

4. Click OK.
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Add or Edit SAF Cross Sections Manually

1. Click Add or (for a selected Cross Section in the list) Edit.

2. In the appearing dialog, manually enter or edit the new SAF Cross Section name/material.

Note: Only “Manufactured” type SAF Cross Sections can be added here, since they use standard names.

3. Choose a SAF Cross Section Formcode from the pop-up. 

4. Choose a SAF Material type (steel or aluminum).
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Create Profiles for Unmapped Manufactured Cross Sections (Import SAF to 

ARCHICAD)

Incoming 1D SAF Profiles are mapped based on the definitions in the Profile Mapping panel.

However, for manufactured SAF profiles that are NOT mapped by name in the Profile Mapping list: you can 

activate automatic mapping based on a default database, which contains more than 6000 SAF Cross 

Sections mapped to ARCHICAD Complex Profiles.

Activate this checkbox in the Profile Mapping panel of the SAF Import Translator.

If the checkbox is on, then the import process will refer to a predefined list (an Excel file called “ExternalDB”) 

to map all incoming, manufactured Cross Sections which are NOT mapped by name in the Profile Mapping list 

above. This can save you a lot of time and effort compared to mapping by hand.

For each incoming SAF Cross Section mapped this way, the corresponding Complex Profile attribute is 

automatically created in ARCHICAD, based on the Standard Steel Profile database. 

See Use Standard Steel Column or Beam Profile.

Location and Editing of Database file (Manufactured SAF Cross Sections)

The “ExternalDB” Excel file is located in your Defaults folder, where you have installed ARCHICAD.

Also check the Downloads site for predefined database files you can use for this purpose. (See Download 

SAF Data Files Optimized for Structural Applications.)

It is possible to create your own database file, save it, and then browse your custom file to use. You must use 

an Excel file consisting of a single sheet, with the same two columns and column names as in the provided 

default file.
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Important: You can copy and edit the default ExternalDB file provided in your ARCHICAD template, but 

do NOT rename or move it!

Priority of Mapping Rules for Manufactured Cross Sections

Mapping rules are applied in the following order:

1. Mapping by name, based on the list in the Profile Mapping panel

2. External database (provided that the “Create Profiles for Unmapped Manufactured Cross Sections” box is 

checked).

3.  “Other Cross Sections - Manufactured” setting. This is the catch-all definition for all manufactured Cross 

Sections that have not been mapped in steps 1 and 2 above.
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Mapping Imported “General” or “Parametric” SAF Cross Sections

You can map any “General” or “Parametric” SAF Cross Section to a particular named ARCHICAD Profile (as 

with Manufactured types). (See Map SAF Cross Sections By Name.)

However, unlike Manufactured types, the SAF definition of the “General” and “Parametric” Cross Sections 

includes geometric and parametric information that can be recreated or recognized in ARCHICAD. 

Use the options below to map these Cross Sections as Custom Profiles, or to create them as new Profile 

attributes in ARCHICAD.

Option 1: Map as Custom Profile

Any SAF Cross Section of “General” type can be imported as a Custom Profile.

In addition, certain SAF Cross Sections of “Parametric” types can also be imported as Custom Profiles.

See Parametric SAF Cross Sections Recognized by ARCHICAD.

• The polygon of the SAF Cross Section is correctly interpreted and embedded within the Custom Profile, 

but without any material information. (Their materials are assigned based on the Material Mapping panel.)

• This Custom Profile is not listed among ARCHICAD’s attributes, and you cannot list it by name or 

otherwise refer to it in the ARCHICAD project.

Note: Once imported to ARCHICAD, you can place this Custom Profile in the project and then save it as a 

named Profile attribute.

To map these incoming Cross Sections to specific ARCHICAD Profile attributes, use one of the following two 

workflows.

Option 2: Create New ARCHICAD Profile Attribute Through Attribute Manager

1. Open Options > Element Attributes > Attribute Manager.

2. Click the Import button.

3. Browse for an .xlsx (SAF) file prepared for this purpose.

See Prepare and Export a SAF Data File to Ensure Standard Mapping.
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4. A Temporary Attributes dialog appears. The Profiles panel lists the potential new Complex Profile 

attributes, based on the SAF Cross Sections (General types and supported Parametric types) listed in the 

incoming file.

5. Assign ARCHICAD Building Material, Fill Type, Line, and Pen to each SAF Cross Section you want to 

append.

Note: If a Cross Section contains multiple SAF Materials, only one ARCHICAD Building Material can be 

assigned to it. However, after you add it to the ARCHICAD Project as a new Profile, you can use Profile 

Editor to set different Building Materials for each Core component.

6. Click OK to add these as temporary items to the Profiles page of Attribute Manager.

7. Append them as needed to the ARCHICAD project.
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8. Now you can map the incoming SAF Cross Section to the corresponding, named ARCHICAD Profile 

attributes (instead of “Custom Profile”).
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Parametric SAF Cross Sections Recognized by ARCHICAD

Name Parameters CS Shape CS Name in SCIA Engineer

I Section H; Bh; Bs; ts; th; s I ng (H; Bh; Bs; ts; th; s)

T Section H; B; th; sh T g (H; B; th; sh)

L Section H; B; th; sh L g (H; B; th; sh)

U Section H; B; th; sh U g (H; B; th; sh)

Oval H; B Oval (H; B)

 

 

 

 

 

ARCHICAD 24 Reference Guide 2556



SAF Translator for Import: Settings Structural Analysis Format
Pipe D; t Tube (D; t)

Z Section A; tha; B; thb1; thb2; C Z (A; tha; B, thb1; thb2; C)

Box A; tha; B; thb1; thb2 O (A; tha; B; thb)

Name Parameters CS Shape CS Name in SCIA Engineer
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 Default Mapping for “Other” Cross Sections (Import SAF to ARCHICAD)

• The “Other Rectangular/Circular” default rules generically map these incoming Cross Sections as 

“Rectangular” or “Circular”, with their actual dimensions (height/width or core diameter).

• The “Other Cross Sections” mapping rules apply to all other incoming SAF Cross Sections that are not 

mapped by name. 

– Manufactured or Compound Types: Choose a default ARCHICAD structure (Rectangular, Circular, 

Profile)

– General or supported Parametric Types: You have the additional option to import these as an 

ARCHICAD “Custom Profile”.

See also Mapping Imported “General” or “Parametric” SAF Cross Sections.
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Miscellaneous Settings (Import SAF to ARCHICAD)

Access SAF Translator settings at:

File > Interoperability > SAF > SAF Translators. 

On this panel, choose default ARCHICAD tool settings for each imported analytical Member type (Wall, Slab, 

Roof, Column and Beam). 

For each element type, use the pop-up to choose either the ARCHICAD Tool default settings, or one of its 

Favorites.

What are these settings used for?

Many structural analytical parameters of imported SAF elements are correctly recreated (or mapped by hand) 

in ARCHICAD: geometry, location, material and cross section parameters, etc. When importing a SAF file, 

these SAF data will overwrite the corresponding values in ARCHICAD.

However, analytical elements imported to ARCHICAD are transformed into physical elements that have many 

other parameters (e.g. pen set, classification) that are not defined in SAF.

Therefore, to define its physical appearance in ARCHICAD, each imported analytical element will use the tool 

settings definitions you choose in the Miscellaneous Panel of the SAF Import Translator (for all settings that 

are undefined in SAF).
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The following table summarizes the ARCHICAD elements created out of 1D and 2D Members imported from 

SAF:

Imported 1D Member ARCHICAD Element

Slant angle < 45 deg Beam

Slant angle > 45 deg Column

Imported 2D Member ARCHICAD Element

Plane is horizontal Slab

Plane is 0 > 45 deg Single-plane Roof

Plane is 45-90 deg Wall
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Import/Export Translator Settings

Use the “Export” and “Import” buttons to save SAF Translator Settings and/or exchange them in XML format.

Note: The “Export” and “Import” buttons will export/import the settings of both translators.

See also Download SAF Data Files Optimized for Structural Applications.
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Model Compare

Use Model Compare to easily compare and visualize changes between two models. Changes are identified 

based on “new”, “modified”, and “deleted” 3D elements. 

The two models being compared can be any of the following: 

• Current architectural or structural analytical model (even two different timestamp versions of the same 

current model)

• External file (PLN, PLA, or SAF) or any BIMcloud project

• Teamwork model: compare the two versions before and after Receive Changes

• Current model: compare the two versions before and after Hotlink update

• IFC model (This is an experimental feature. See IFC Structural Analysis Model Import/Export - 

Experimental Feature.)

Model Compare offers numerous options to visualize changes between two groups of 3D models

In each workflow, the Compare command generates a view of the two compared models in a separate “Model 

Compare” window. 

In the Model Compare window, use the Model Compare Palette to filter, list, and zoom to the model changes, 

and get feedback on which parameters have changed. 

2D elements are not considered.

Notes:

– The Model Compare function compares two models based on a fixed timestamp for each. Therefore, if 

you later change either model (e.g. modify view setting, delete an element), the previous Model 

Compare results cannot be updated. Run the Model Compare again, based on the updated models.
ARCHICAD 24 Reference Guide 2562



Model Compare
– Model Compares of large and complex projects may take a while, but the process runs in the 

background. You can continue to work uninterrupted on the current model.

– The Model Compare tab gives you feedback while the process is underway and also when it is 

finished.

– You can run multiple Model Compare processes simultaneously.

Topics in this section:

Compare Teamwork Model Versions (Before and After Receiving Changes)

Compare Two Saved Versions of Current Model

Compare Two Views of a Single Project

Compare ARCHICAD Models Before and After Hotlink Update

Compare Two Structural Analytical Models

Select View for Compare

Filter Changes Shown in Model Compare Palette

Model Compare: Review the Changes

Workspace Colors for Model Compare

Related Topic:

Create Issue from Model Compare Change List
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Compare Teamwork Model Versions (Before and After Receiving 

Changes)

Use this Compare workflow in Teamwork after receiving changes, to see what has changed in the model.

There are two “Compare” commands in the Teamwork context.

Send and Receive, then Compare

Send and Receive as usual. This results in a new local cache (after Receive): the “New Model”. This new 

model is compared to your previous local cache (prior to the Send), which is the “Old Model”.

Receive, then Compare

As in the above scenario: you receive changes made by others, creating a new local cache (“New Model”), 

and then compare it to your old local cache (“Old Model”). 

The only difference is that the first command shares your own work to the BIMcloud, the second command 

does not.

Example Workflow

In this example, two architects are using Teamwork to collaborate in ARCHICAD. User 1 makes changes and 

sends them to the server.

After a Receive, User 2 wants to see what has changed.

1. From the Teamwork menu or Teamwork palette: Choose Receive, then Compare.

2. User 2 receives changes from the BIMcloud.

3. The Model Compare begins in the background. The Model Compare tab indicates that generation is 

underway, then shows a green checkmark when it is done. 
ARCHICAD 24 Reference Guide 2564



Compare Teamwork Model Versions (Before and After Receiving Changes) Model Compare
4. Open the Model Compare window. The palette indicates that - after receiving changes from BIMcloud - 

you have compared the new version (“Received Model”), to the previous version (“Old Model”, as it 

existed prior to Receive).

5. The results are displayed in the Model Compare window.

Using the Model Compare palette, review the Model Compare window to see what has changed.

See Model Compare: Review the Changes.

6. As needed, create Issues.

See Create Issue from Model Compare Change List.
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Compare Two Saved Versions of Current Model

This workflow is recommended for the following scenarios:

• Create design options, then compare them

• Compare views based on Renovation status

• View today’s progress: in the afternoon, compare the current model version to what it looked like this 

morning.

Example Workflow

1. Use Design > Model Compare.

2. The Model Compare window opens. 

3. From the Model Compare palette, click Select Model 1, and choose Current model. The timestamp is 

shown.

4. Click on Select Model 2, and browse for an earlier saved version.

5. When comparing two different views, current View settings can be significant. See Select View for 

Compare.

6. Click Compare.

• While the Model Compare results are being generated, you can navigate to any other tab or window. 

7. The results are displayed in the Model Compare window.

Using the Model Compare palette, review the Model Compare window to see what has changed.

See Model Compare: Review the Changes.
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8. As needed, create Issues.

See Create Issue from Model Compare Change List.
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Compare Two Views of a Single Project

This workflow is recommended e.g. to compare two views in a single ARCHICAD project. For example, 

compare two different 3D views of the existing vs. proposed site plan.

1. Use Design > Model Compare.

2. From the Model Compare palette: 

Select Current model for both Model 1 and Model 2. 

3. Click the View Selector button. 

4. From the Select View dialog, uncheck “Apply Common View Settings.” The 3D views of each model 

version are now listed separately, side by side.

5. Here, choose “Existing Site” (from Model 1) and “Proposed Site” (from Model 2). These are two different 

views of the same project.

See also Select View for Compare.

6. Click Compare.

7. The results are displayed in the Model Compare window.
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Using the Model Compare palette, review the Model Compare window to see what has changed.

See Model Compare: Review the Changes.

8. As needed, create Issues.

See Create Issue from Model Compare Change List.
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Compare ARCHICAD Models Before and After Hotlink Update

This workflow can be useful when you update a Hotlink in your project.

As usual, the Update command refreshes the Hotlinks in your model to reflect changes in the Hotlink source. 

But if you also check the optional “Compare Models” checkbox in Hotlink Module Manager, you will be able to 

visualize what has changed as a result of the update.

Example Workflow

In Hotlink Module Manager:

1. Select the Hotlink Source which has changed (it is shown with Modified status).

2. Check the box to Compare Models After OK.

3. Click Update.

4. Click OK. 

5. The Hotlink Module is updated in the model.

6. The Model Compare window opens to compare the “Old Model” and “Updated Model”.

7. The results are displayed in the Model Compare window.

Using the Model Compare palette, review the Model Compare window to see what has changed.

See Model Compare: Review the Changes.
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Here, you can see that a desk/chair has been deleted from the cubicle module.

8. As needed, create Issues.

See Create Issue from Model Compare Change List.
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Compare Two Structural Analytical Models

Use this workflow when the structural engineer has sent back the revised analytical model, after carrying out 

structural analysis.

Example Workflow

1. Use Design > Model Compare.

2. From the Model Compare palette: 

Select Current model for Model 1 

3. For Model 2, browse for the SAF file (format: Structural Analysis File .xlsx) sent by the structural engineer. 

4. When opening an SAF file using Model Compare, the Translator settings of the current project are applied 

by default. If needed, click Options to choose a different template for the SAF Translator.

5. Click Open.
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6. From the Model Compare palette, click the View Selector button.

7. The Select View dialog opens.

8. In the Model panel, choose Structural Analytical Model.

9. Optionally, activate the components that you wish to display in the Compare window.

See also Select View for Compare.

10. Click Compare.

• While the Model Compare results are being generated, you can navigate to any other tab or window. 
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11. The results are displayed in the Model Compare window.

12. Using the Model Compare palette, review the Model Compare window to see what has changed.

13. Filter the parameters you want to see. Available parameter sets are specific to the Structural Analytical 

Model.

See also Changes By Parameter Set.
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14. As needed, create Issues.

See Create Issue from Model Compare Change List.
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Select View for Compare

Model Compare compares 3D views from two different models or versions. 

To define exactly which 3D views, use the Select View dialog.

View selection can be significant: an element’s modified status is considered by view. 

• An element can be visible in one view but not in another (e.g. due to Renovation status or Partial Structure 

Display). 

• Intersecting elements can be considered modified in one view, yet not modified in another view, 

depending on the view’s Layer Combination.

1. Use Design > Model Compare to choose the two model versions, as described in previous sections.

2. From the Model Compare palette, click the View Selector button.

3. The Select View dialog opens, showing the combined View Maps of the two selected projects.
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4. Select a view, then review its View Properties in the panel below.

To compare a 3D view that is common to both models:

Select the view, then click Compare.

To compare a two different 3D views:

1. Uncheck “Apply Common View Settings.” 

2. The 3D views of each model version are now listed separately, side by side.

3. Review their View Properties in the panel below.
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4. For each model, select a 3D view, then click Compare.

Choose Model Type to Compare

In the Model panel, choose Physical Model or Structural Analytical Model.

See Compare Two Structural Analytical Models.
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Filter Changes Shown in Model Compare Palette

By default, the Model Compare palette lists all 3D model changes resulting from the Compare process. 

Use the Filter buttons to narrow the list of changes shown here, and the list format options to display them.

Topics in this section:

Filter by Element Criteria

Filter by Subscription

Filter by Parameter Sets

List Format Settings

Filter by Element Criteria

Click the Filter by Criteria button to access the criteria set pop-up.

By default, All 3D Elements is active: All elements are listed in the Model Changes list.

To narrow the list of elements, click Custom to define elements by criteria.

• The Find & Check dialog opens.

• Set criteria for listing elements: for example, filter the list to show only the slabs.
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The custom criteria set used as a filter cannot be saved. 

Filter by Subscription

If you are using Project Change Tracking (in Teamwork), you can filter to see element changes by 

Subscription.

See also Change Tracking in Teamwork.

Filter by Parameter Sets

Check/uncheck the type of modifications that you are interested in. Items that have changed based on the 

checked parameters are listed.

Available parameter sets vary depending on the chosen Model type: Physical Model or Structural Analytical 

Model.

See Select View for Compare.
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The parameter sets in this checklist are the same as the “Selected Element Changes” feedback at the bottom 

of the list.

See Changes By Parameter Set.
ARCHICAD 24 Reference Guide 2581



Filter Changes Shown in Model Compare Palette Model Compare
List Format Settings

Click the Settings button to set format options.

In the appearing pop-up, check/uncheck boxes to define your preferred list format.

Drag and drop the items to change their order.

• Status (e.g. New/Modified/Deleted)

• Tool

• ID

• Source

• Classification
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Model Compare: Review the Changes

After the Compare command is run, the Model Compare window displays the model with colored highlights 

and other feedback on changes.

The Model Compare palette is docked at the left edge of this window (this palette cannot be moved).

Note: By default, the Model Compare palette lists all 3D model changes resulting from the Compare 

process. To filter the list of displayed changes, see Filter Changes Shown in Model Compare Palette.

Topics in this section:

Set Model Appearance

List of Model Changes

Selection in Model Compare Window

Changes By Parameter Set

Set Model Appearance

The “Model 1 only” and “Model 2 only” elements are shown in their respective colors.

In this example:

• The red wall is “Model 1 only”, because it was deleted.

• The blue wall is “Model 2 only”, because it is a new element.

• The slabs and chair objects are shown in a blended (purple) color, to indicate that they have been 

modified, while remaining in their original position.

Note: Set Model Compare colors at Options > Work Environment > On-Screen View Options.

See Workspace Colors for Model Compare.

In the Appearance section of the Model Compare palette: 

• Use the top slider to graphically emphasize Model 1 or Model 2. (Here, the slider is in the middle, showing 

both versions equally.)

• Use the bottom slider to set the relative visibility of the unchanged model (the set of unaffected or 

unchecked elements).
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Here, the bottom slider is set to hide the unchanged model completely, so all you see are the changes:

List of Model Changes

By default, the Model Changes list shows all changed elements, grouped by Status: Modified, Model 1 Only, 

and Model 2 Only. 

To customize this list, use the filter and settings buttons.

See also Filter Changes Shown in Model Compare Palette.

Selection in Model Compare Window

Select any item from the Model Changes list to select the corresponding element in the Model Compare 

window.
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Here, a modified Slab is selected:

The same works the other way around: you can select any changed element in the Model Compare window: it 

is then selected in the Model Changes list, too.

Note: In the Model Compare window, you can only select elements that are also listed in the Model 

Changes list. Unchanged elements, even if displayed in the window, cannot be selected here (see cursor 

feedback).

Select Elements By Group

Select a parent item in the list tree to select all its member elements in the Model Compare window.
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Show Changed Element in Model

For a selected item in the Model Changes list: use the context menu commands to Show on Floor Plan or 

Show in 3D.

Context Menu Commands

For a selected item in the Model Compare window:

• Use Hide Selected or Hide Unselected to get a better view of the changed element and/or its 

environment.
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• Reverse this command with Unhide All, available in the same context menu.

Changes By Parameter Set

For the last-selected element in the Model Changes list: 

The “Selected Element Changes” icons indicate which parameters have changed. (This is relevant for 

“Modified” elements in the list.)

Here, a modified object is selected in the list, and in the model.

Below the list, the “Model” icon is active: this indicates that the one or more Model parameters of this chair 

were modified.
ARCHICAD 24 Reference Guide 2587



Model Compare: Review the Changes Model Compare
These parameter sets are the same as in the “Checklist” used to filter the change list in the Model Compare 

window. 

See also Filter by Parameter Sets.

Related Topic:

Create Issue from Model Compare Change List
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Workspace Colors for Model Compare

Go to Options > Work Environment > On-Screen Options.

In the Workspace Colors panel:

Set the colors used to display “Model 1 only” and “Model 2 only” elements in the 3D Model Compare window.

Color of Modified Elements

• Elements that have moved from one place to another are shown in both the original and the new 

positions, in a lighter version of the Model 1 color (original position) and in a lighter version of the Model 2 

color (new position).

• If an element remains in place, but another of its parameter has changed (e.g. surface color):
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This element is shown as modified, using a combination of the Model 1 and Model 2 color (e.g. red + blue 

are combined into purple).
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Issue Handling

ARCHICAD’s Issue Management workflow supports an extensive collaborative workflow. It replaces the 

Markup tool from earlier ARCHICAD versions.

Use this workflow to:

• Create Issues that highlight model elements and/or views, with optional markup

• Make element-based suggestions (New, Modify, Delete)

• Create Issues from the discrepancies or modifications that are automatically flagged by ARCHICAD (the 

results of Model Compare and Model Checks)

• Add Comments

• Define Issue details (e.g. Status, Priority, Type, Labels, Description)

• Assign Issues to any user in Teamwork

• Use Issue Organizer to sort through long Issue lists in flexible formats

ARCHICAD 24 supports the latest BIM Collaboration Format (BCF 2.1), as well as all earlier BCF versions.

Topics in this section:

Add Selected Elements to New Issue

Add Views to Issue

Issue Manager

Suggestion Elements in Issue Manager (Highlight, New, Modify, Delete)

Assign Issue to User

Accept Issue Element(s)

Issue Management Workflow: Example

Issue Organizer

Issue Details

Create Issue from Model Check Report
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Create Issue from Model Compare Change List

Import Issues (BCF format)

Export Issues (BCF format)

Export/Import Issues Using PDF Markup
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Add Selected Elements to New Issue

1. Select one or more elements. Anything in the model that has Settings can be added.

2. Right click: from the context menu, choose Add to New Issue.

The New Issue dialog appears, and the Issue Manager palette opens.

3. In the New Issue dialog:

• Enter a name

• Click the icon to open Issue Details: define Status, Priority, Type, Description as needed, then click OK.
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4. The new Issue is now open in Issue Manager.

By default, the Issue elements are placed the Highlight list of Issue Manager, and are highlighted in the 

model.

Add Element(s) to New Issue - As Response

You can add a new Issue as a response to the current Issue which is open in Issue Manager.

1. Select the model element(s).

2. Right click: from the context menu, choose Add to New Issue.

3. In the New Issue dialog, check  Add as a Response to

See also Suggestion Elements in Issue Manager (Highlight, New, Modify, Delete).
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Show Containing Issue

For a selected element: check whether the element is part of any existing Issue, then filter for the relevant 

Issue(s) in Issue Organizer.
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Add Views to Issue

Add any number of snapshot views to an Issue.

Views are typically related to the Issue’s elements, but Issues do not have to contain any elements. You can 

just create a new Issue, add one or more views, and mark them up if needed.

Create and Manage Views in Issue

1. Open Issue Manager.

2. Set up the view in any model window.

3. Click the Add new view icon.

4. Optionally, name the view.

5. Use the Settings pop-up to edit or redefine any selected view.

Use the Settings pop-up to manage any single selected view.

• Redefine by Current View: Updates the list of visible elements, the camera position, the cutting planes, 

and the snapshot.

• View Image: Opens the snapshot in a new tab

• Markup Image: Open and edit the saved view in the default image editor (usually Paint or Preview)
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• Export/Import Image: Export or import the view in the chosen image format.

Note: When exporting an Issue in BCF format: if the Issue contains a Floor Plan view, it will generate a 3D 

axonometry top view, with cutting planes at the top and bottom level of the floor.
ARCHICAD 24 Reference Guide 2597



Issue Manager Issue Handling
Issue Manager

Issue Manager is a palette with controls for managing a single, opened Issue, with the following functions:

• Add views (images), or import/export images

• Manage Issue elements (categorize them as Highlight, New, Modify or Delete)

• Accept the suggestions in the Issue (e.g. new or modified elements)

• Add optional Comments.

Open Issue Manager

Issue Manager opens automatically when you create a new Issue.

You can also open it with one of the following:

• Use its toolbar command

• Double-click a listed Issue in Issue Organizer

• Document > Issue Manager

• Window > Palettes > Issue Manager

Switch to a Different Issue

From Issue Manager: 

Click the Issue name pop-up to open the Issue Organizer list.
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Choose a different Issue to work on.

Related Topics:

Suggestion Elements in Issue Manager (Highlight, New, Modify, Delete)

Add Views to Issue
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Suggestion Elements in Issue Manager (Highlight, New, Modify, 

Delete)

Use the Elements panel of Issue Manager to manage the elements contained in any given Issue.

Highlight

This is a simple markup. Any element that has its own settings in ARCHICAD can be highlighted in one or 

more Issues.

Elements of newly created Issues are shown as “Highlight” by default in Issue Manager, and they are 

highlighted in the model.

For example, when you create an Issue from the Model Check Report, the elements contained in the Issue 

are all listed in the Highlights section.

See Create Issue from Model Check Report.
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Make Suggestions with Issue Elements: New, Modify, Delete

To add element(s) to an Issue that is currently open in Issue Manager: 

1. Select the model element(s).

2. Do one of the following:

• Use the context menu command “Add to Current Issue as”

• In Issue Manager, click one of the Plus buttons to move the selected element to Highlight, New, Modify or 

Delete.

– “Highlight” elements can be moved to New, Modify, or Delete

– “Delete” elements can be moved to Highlight, New, or Modify

– “New” or “Modify” elements cannot be moved to a different category, because they do not exist in the 

model (in their suggested new form) until you accept them. Once they are accepted, they go to the 

Highlight list.
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Suggestions for element changes - New, Modify and Delete

Example: Suggest Element as “Modify”

In Issue Manager:

1. Double-click the element in the “Highlight” list. This selects the element in the model.

2. Click the Plus sign of the status where you want to move it: for example, “Modify”.

The selected Issue element is now in “Modify” status. Although it is a single element in the Issue, it exists as 

temporary element pair in the model (“Modified New” and “Modified Deleted”).

On the Floor Plan, it is displayed with a Marquee, so it is easy to locate.
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For a selected “Modify” element in the model:

Use the flag pop-up 

• to select its pair in the model (“Modified New” or “Modified Deleted”)

• to see the name of the Issue(s)

• to see which element parameters will be affected by the proposed change, if it is accepted.

Remove Element from Issue

Click the Minus sign to remove any element from the Issue.

Workspace Colors of Issue Elements

Issue elements are displayed in the model using the colors defined at Options > Work Environment > 

Workspace Colors.
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Assign Issue to User

In Teamwork, every suggestion (via its containing Issue) can be assigned to any other user, who is instantly 

notified.

1. Open Issue Organizer

2. Select the Issue(s) to assign

3. Do one of the following:

– Choose Assign to from the context menu

– In the Teamwork Owner field, click the pop-up to choose a user.

4. In the appearing dialog, add or edit the message as needed, then click Assign.
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5. The receiving user is notified (via Teamwork Messaging)

The Issue is now reserved by the user to whom it has been assigned.

6. The new Issue owner can click Show to see Issue Organizer, and handle the Issue as needed.
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Accept Issue Element(s)

Suggested design changes in any Issue (the “New”, “Modify” and “Delete” elements) are not carried out in the 

model until the assigned user accepts it.

1. In Issue Manager, select the suggested New/Modify/Delete items which you agree with. 

(If you do not select any, they will all be accepted.)

2. Click Accept. 

Once a suggestion is accepted fully or partially:

• “Delete” elements, once accepted, are removed from the project and no longer listed in the Issue

• “Modify” elements/element parameters replace the previous instances in the model, and move to the 

Highlight list of Issue Manager

• “New” elements become part of the model and move to the Highlight list of Issue Manager

For example, a Wall that is a “New” Issue element does not become part of the model until you click Accept in 

Issue Manager. Then the element moves to the Highlight part of the Elements list.
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Accept Limited Parameter Changes

When receiving an Issue with proposed element changes, you can decide to accept only changed 

parameters.

1. In Issue Manager: At the bottom of the Elements list, open the Parameter Sets pop-up.

2. Uncheck the box for Accept All Parameter Sets.

3. Now check just the parameters that you want to accept in the modified element (e.g. accept the modified 

geometry, but not the changed classification).

4. Click Accept.
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Issue Management Workflow: Example

In this example, two Teamwork users use Issues to manage the replacement of office furniture.

User 1 Creates the Issue

1. Select the problematic objects.

2. Create and name the new Issue. (See Add Selected Elements to New Issue.)

3. The Issue opens in Issue Manager: Issue elements have been added to the Highlights panel.
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User 1 Gives the Issue to User 2

1. Open Issue Manager

2. In the Issue item’s Teamwork Owner column, assign the Issue to User 2. (See Assign Issue to User.)

User 2 Gets The Issue

1. User 2 gets the alert and clicks to open the message.

2. From the message, click Show: The Issue is listed in Issue Organizer.

3. Double-click the Issue to see its content in Issue Manager.
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4. Click the Select All Elements icon to see the highlighted Issue elements close up.

User 2 Modifies the Elements

User 2 decides to update the chairs. 

1. Reserve the Issue elements (if needed.) 

2. Move the elements to the Modify part of the list in Issue Manager. (See Suggestion Elements in Issue 

Manager (Highlight, New, Modify, Delete))

3. Select the elements in the model and move/change them to a more modern chair type.

4. Reassign the Issue to User 1. (See Assign Issue to User.)
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User 1 Gets The Issue and Accepts the Changes

1. User 1 gets the alert and clicks to open the message.

2. From the message, click Show: The Issue is listed in Issue Organizer.

3. Double-click the Issue to see its content in Issue Manager.

4. Zoom in to see the modifications in the model.

5. In Issue Manager, select the elements you want to Accept. 

6. Click Accept. 

• You can opt to accept only certain parameter sets: Uncheck the parameters you want to skip.

See Accept Issue Element(s).
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Issue Organizer

Issue Organizer lists all the Issues in your Project.

Open Issue Organizer

Do one of the following:

• Use its toolbar command

• Document > Issue Organizer

• Window > Palettes > Issue Organizer

You can also access Issue Organizer as a pop-up from the top of Issue Manager.

Issue Organizer pops out from Issue Manager

Set Preferred List View and Column Headers

Use the icons and pop-out at the top right of Issue Organizer:

• In List view (default):

– Choose the column headers you need

– Click any column header to sort Issues based on that column.
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• Or display Issues using medium or large thumbnails:

View Issues as Thumbnails

Sort Issue List

Sort by Tag

1. Choose the left-side icon to sort the listed Issues by tags. 

2. Click the settings pop-up to see the available Tags. 

3. Define which tags to consider in listing the Issues, and in what order. (Here: by Status, and within that by 

Priority).
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Sort by Thread

Choose the right-side icon to sort by thread. 

Within the tree structure, you can drag Issues to manually rearrange the thread hierarchy (provided that you 

own the Issues you are dragging).

Commands for Managing Issues (Settings pop-up, right side)

• Open selected Issue (also via double-click) in Issue Manager

• Rename selected Issue

• Open Issue Details

See Issue Details.

• Issue Tags: Define values for the project’s “Priority”, “Status” and “Type” Tags. (These values are global 

definitions, irrespective of current Issue selection)

See Issue Priority, Status, and Type.

• Export/Import and Export to/Import from BIMcloud

– Use these commands to export or import BCF files (version 1.0, 2.0 or 2.1)

See Export Issues (BCF format) and Import Issues (BCF format).
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Color Feedback from Issue Organizer

The format of listed Issues helps you keep track of the Issue you are working on.

• Italics: This element is currently open in Issue Manager

• Bold: This Issue has been imported via BCF, but you have not yet clicked on it.

• Checkmark plus green highlight: An element from this Issue is currently selected.

• Eye toggle: Show/hide elements/highlights, if the Issue is not currently open in Issue Manager:

– For New elements: show or hide the elements

– For Highlight/Modify/Delete elements: show or hide their highlight colors

Eye toggle: Show Issue elements with highlight
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Eye toggle: Hide the highlights on Issue elements
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Issue Details

To open this dialog, select an Issue and click Issue Details from one the following:

• Context menu

• Issue Organizer (Settings button)

• Click the Issue Details icon from Issue Manager 

Use Issue Details to modify any of the following:

• Name

• Status

• Priority

• Type

See Issue Priority, Status, and Type below.

• Due Date

You can also enter text strings in the following fields, which are recognized in BCF-based Issue exchange:

• Responsible

• Labels

• Description

You can use these tags and data fields to configure the Issue list in Issue Organizer.

See Sort Issue List
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The History panel of Issue Details logs all activities related to a particular Issue.

Issue Priority, Status, and Type

To add or change the available values for Priority, Status and Type: 

From the Settings pop-up of Issue Organizer, click Issue Tags:
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Create Issue from Model Check Report

The Model Check Report lists problems found via ARCHICAD’s three checking functions (at Design > Model 

Check.)

See Model Check - Overview.

You can add any item listed in the Model Check Report to an Issue for further handling.

In this example, the check shows that four Load-Bearing elements are not part of the Structural Analytical 

Model, which in this model is a mistake.

Create one or more Issues out of these listed items.

In the Model Check Report: 

1. Select the problems - here, all four of them.

2. Click the Create New Issue icon at the top of the dialog.

3. In the appearing dialog, add the four items to a single issue.

4. Enter a name: “Add to Analytical Model.”
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5. Click the flag icon to open Issue Details: define Status, Priority, Description as needed, then click OK.

6. Back in the New Issue dialog, click OK.

7. The new Issue is added to Issue Organizer. 

To manage or accept elements of the Issue:

See Suggestion Elements in Issue Manager (Highlight, New, Modify, Delete).
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Create Issue from Model Compare Change List

The Model Compare function provides a list of changes between two models. Changes are identified based 

on “new”, “modified”, and “deleted” 3D elements. 

For details, see Model Compare.

From the Model Compare palette’s Change List:

1. Select one or more listed elements.

2. Use the context menu to Add to New Issue.

3. The new Issue is added to Issue Organizer. 

To manage or accept elements of the Issue:

See Suggestion Elements in Issue Manager (Highlight, New, Modify, Delete).
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Import Issues (BCF format)

1. Go to Issue Organizer.

2. From the Additional Settings pop-up button:

– Import

– Import from BIMcloud

3. Browse for a file in BCF format. (All BCF formats are supported.)

4. Click Open.

Note: When importing a BCF file, you don’t need to also re-import the IFC file that you created out of your 

ARCHICAD model. The elements in the BCF file will identify the ARCHICAD elements in their native 

environment, because the ARCHICAD elements already include a corresponding IFC GUID.

5. The Locate IFC Files dialog box appears.

p
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Here, you can optionally browse for and locate the IFC files referenced in the BCF entry. The IFC file names 

are listed: select one and then click Locate to browse for the file location. (IFC files are identified based on 

their GUID, not their name.)

Note: Locating the referenced IFC files is optional. Click Continue to skip this step. However, you may 

wish to locate the referenced file if, for example, composite elements were exploded at IFC export and 

thus were assigned different GUIDs: locating the original file here will allow the BCF file to identify the 

original elements.

6. Click Continue.

7. The imported Issues are added to Issue Organizer. Each is shown in bold type, until you open it.
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Export Issues (BCF format)

1. Go to Issue Organizer.

2. Select one or more Issues.

3. From the Additional Settings pop-up button:

– Export

– Export to BIMcloud

4. Save the file in BCF format. (All BCF versions are supported; choose a BCF version from the Save as 

type drop-down list.)

5. Click Save.

6. All the exported Issues are saved in a single .BCF file.

Note: When exporting an Issue in BCF format: if the Issue contains a Floor Plan view, it will generate a 3D 

axonometry top view, with cutting planes at the top and bottom level of the floor.
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Export/Import Issues Using PDF Markup

Save or publish ARCHICAD views or layouts as PDFs, then send the PDFs to consultants for markup in a 

reviewer application (e.g. Bluebeam). 

Then import the PDF markups back to ARCHICAD via the Issue Organizer. The imported markups will appear 

in the right places, on the original source views in ARCHICAD. 

Repeat the process as needed. Each time you reimport markups from a PDF, you can decide whether to skip 

or include duplicate or modified Markups from earlier rounds.

Notes: 

– This method works only if the marked up views originate in ARCHICAD.

– On Mac, do not use the Preview function to mark up PDFs for this workflow.

Create PDF Documents for Markup

In ARCHICAD, use the Publisher to create PDF-based Publisher sets or publisher items.

See Create PDF Output Using the Publisher.

Then send the resulting PDF to the consultant for markup in an external application.

Import Issues to ARCHICAD

Once the PDF has been marked up, follow these steps in ARCHICAD to import the Issues:

1. Go to Issue Organizer.

2. From the Additional Settings pop-up button:

– Import

– Import from BIMcloud

3. Browse for a file in PDF format.
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4. Click Options.

The Issue Import Options dialog box opens:

Issue Import Options

Choose an option for how the imported Issues should appear in Issue Organizer.

• Start New Issue Thread: The imported Issues will constitute their own thread. (In the Issue Organizer, 

you can sort entries by thread.)

• Create Response to Selected Issue: This option is available if an Issue is currently open in Issue 

Manager. Choose this to list the imported Issues underneath the currently active Issue, as sub-Issues.

Tip: To create a separate “category” for the imported Issues, first create a new Issue in ARCHICAD, and 

give it a name (e.g. “Imported Issues from PDF”.) With this new entry selected, import the PDF Issues, 

and use the “Create Response to…” option. The imported Issues will be listed under this Issues (use Sort 

by: Thread).

Attribute Conversion Options

Choose how to convert the fills, lines, fonts and layers of the Issues you are importing. 
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Fills

• Use Project’s Fill Types: No new fills will be imported from the PDF. Any imported fills that have no 

counterpart in the project will be transformed into solid fills.

• Import as Symbol Fill from PDF: A new vectorial fill attribute will be created in the project and used for 

imported fills. (For example: “60% PDF Solid Fill”)

• Import as Image Fill from PDF: A new image fill attribute will be created for any fills, among the drawing 

primitives, which have no counterpart among the project’s attributes.

Note: If an image fill is generated, then this file is added to the project’s Embedded Library. If you are 

working in a Teamwork project, you must have the needed access right: Library Parts – Create.

Lines

• Use Project’s Line Types: No new Lines will be imported. Issues are displayed using similar, existing 

ARCHICAD lines (e.g. solid, dashed, dotted). If a corresponding Line does not exist in the ARCHICAD 

project, a solid line is used.
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• Override with uniform Line Type: Choose one of the project’s Lines. Imported Issues will be displayed 

using this Line Type.

• Import from PDF: Line Types of Issues are imported and added to the ARCHICAD project.

Text Font

• Override with uniform Font: Choose one of the project’s font types to display text items on imported 

Issues.

• Use available Fonts: Imported Issue texts are displayed using similar fonts available in the ARCHICAD 

project.

Layer of Issues

• Single Layer from Project: Choose one of the project’s Layers. Imported Issues will be placed on this 

Layer.

• Import embedded Layers from PDF: Issues will be placed on layers corresponding to their embedded 

layer assignment (if any) in the PDF source. Those embedded layers will be added to your ARCHICAD 

project. 
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After setting Issue Import Options, click OK to return to the Import Issues dialog.

Import Issues

1. From the Import Issues dialog, select the file to import. Click Open.

2. The Select Issues to Import dialog appears: 

3. Select the source documents in the PDF from which to import the Issues.

4. Filter the Issues as needed:

– Skip duplicate Issues: Duplicate Issues have already been imported to ARCHICAD, and they have 

not changed in the PDF since then. Check this to skip importing these duplicate Issues.

– Skip modified Issues. Modified Issues have already been imported to ARCHICAD, but they were 

later modified in the PDF. Check this to skip importing these Issues.

– Skip unidentified Issues: Some markup applications do not assign unique IDs to the Issues. Thus, 

these Issues cannot be identified as either new, duplicate or modified. (This is not a problem in the 

Bluebeam Revu workflow.) Check this to skip importing these Issues. 

5. Click Import. An Info dialog appears:

6. Click Open Report to see a summary of Issues that have been added to the original ARCHICAD views, or 

click OK to skip the report.

The new Issues are also listed in Issue Organizer.

7. Navigate to the source ARCHICAD views or Layouts to handle the imported Issues.
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Change Tracking in Teamwork

Note: BIMcloud users only. Not available with BIMcloud Basic.

Use this optional feature in Teamwork to track project changes made by other users, and to receive 

notifications about such changes.

Change Tracking applies only to elements or data which already exist in the Teamwork project and have been 

sent to the server. (A newly created element or data type, which has not yet been sent to the server, cannot be 

tracked.)

To use Change Tracking, create any number of subscriptions. Subscription set-up is flexible, to ensure you 

are notified about changes that you need to know about.

Notifications appear on screen and in the Teamwork Palette in the dedicated “Tracked Changes” panel and 

palette. These are changes that have been sent to the server, but not yet received by you. Once you receive 

the changes, the Tracked Changes list will be deleted.

Define subscriptions for several types of changes:

• Elements by criteria or by selection, optionally filtered by parameter (track only the parameters that are 

relevant for you)

• Specific project data (such as attributes)

• Further filter any subscription by user or Team

“High-Trust” Collaboration with Teamwork Users

The Change Tracking workflow is not tied to permissions. It is thus a “high trust” workflow that enables 

Teamwork users to learn about relevant project changes sent by others to the BIMcloud.

For example: the architect, structural engineer, and mechanical engineer alike can potentially modify the 

same composite Wall. Such a modification constitutes significant information for all three professionals. 

Change Tracking allows them to track such changes (once they are sent to the BIMcloud) in a timely manner, 

and to make corrections or comments (via Issues or Messages) as needed.

Modified Element Geometry: What Counts as a Change?

Core Data

A change in element geometry is tracked only if it changes the element’s “core data”. These are geometric 

values that are defined and visible in the element’s Settings dialog box. For example: Wall height.

Derived Data

In contrast, an element’s “derived data” are not tracked as a change in element geometry. 

For example, a top linked Wall’s height is derived from the current Story height. A change in Story height will 

show up in your Tracked Changes list (if your subscription includes Story Settings), but the resulting change in 

Wall height will not. 

Topics in this Section:

Create New Subscription

Filter Element Changes by Parameter Type

Filter Change Notifications by Teams and Users

View and Manage Tracked Changes

Manage Subscriptions
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Create New Subscription

1. Go to Teamwork > Change Tracking

2. In the appearing dialog, click the New Subscription icon (or right-click anywhere in the dialog box).

3. Enter a name for the new subscription - for example, “Load-Bearing Elements”.

4. Choose one of the three methods to define this Subscription Type:

Each setup is described below:

Subscribe to Changed Elements - by Criteria

Subscribe to Changed Elements - by Selection

Subscribe to Changes in Project Data

The subscription starts tracking changes and sending notifications from the point at which you create it 

(changes that were sent to the server earlier cannot be tracked).
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Subscribe to Changed Elements - by Criteria

1. Go to Teamwork > Change Tracking

2. In the appearing dialog, click the New Subscription icon (or right-click anywhere in the dialog box).

3. In the New Subscription dialog, choose Criteria.

4. Click OK.

5. In the appearing Change Tracking dialog: use the fields (similar to those in the Find & Select dialog) to 

define element criteria for the subscription. All elements that meet these criteria will be tracked (subject to 

any additional filters).

For example, this subscription tracks all elements whose Structural Function is load-bearing.

Note: To quickly set up criteria based on a selected element: use the Copy Settings button. See Copy 

Settings.

6. In the panels below, you can fine-tune this subscription by narrowing the set of tracked parameters, and/or 

by Teams and Users.

7. Click Apply to activate tracking for this subscription.

8. Change notifications will appear in your Teamwork Palette, heralded by an on-screen pop-up.

See View and Manage Tracked Changes.

Related Topics

Filter Element Changes by Parameter Type

Filter Change Notifications by Teams and Users
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Subscribe to Changed Elements - by Selection

Use this Subscription Type to track changes in selected element instances.

1. Go to Teamwork > Change Tracking

2. In the appearing dialog, click the New Subscription icon (or right-click anywhere in the dialog box).

3. In the New Subscription dialog, choose Selected Elements.

4. Click OK.

5. If any model elements are currently selected: These elements are added to the Subscription list.

If no model elements are selected yet, select them, then click Add.

Note: Selected elements that are part of a Hotlinked Module cannot be added to a Subscription. 

6. In this example, the selected Slabs are added to the Subscription.

7. In the panels below, you can fine-tune this subscription by narrowing the set of tracked parameters, and/or 

by Teams and Users.
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8. Click Apply to activate tracking for this subscription.

See View and Manage Tracked Changes.

Related Topics

Filter Element Changes by Parameter Type

Filter Change Notifications by Teams and Users
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Subscribe to Changes in Project Data

Use this Subscription Type to track changes in project data (e.g. attributes or properties), rather than 

elements.

1. Go to Teamwork > Change Tracking

2. In the appearing dialog, click the New Subscription icon (or right-click anywhere in the dialog box).

3. In the New Subscription dialog, choose Project Data.

4. Click OK.

5. Review the list of project data types. Check only the data that you want to track. 

6. You can fine-tune this subscription by user.

7. Click Apply to activate tracking for this subscription.

See View and Manage Tracked Changes.

Related Topic

Filter Change Notifications by Teams and Users
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Filter Element Changes by Parameter Type

This feature is available when setting up an element-based subscription - e.g. the Subscription Type is either 

Criteria or Selection.

Go to the Teamwork > Change Tracking dialog.

On the Element Parameter Sets (3D Only) panel: mark the element parameters you want to track for the 

subscribed elements. These parameters can be tracked for 3D model elements only (not documentation 

elements).

Review the list of element parameters. Check only the parameter sets that you want to track with this 

subscription. 

In this example, only “Geometry and Positioning” is checked.

Thus, in this subscription:

• Only load-bearing model elements are tracked, and

• You are notified only if the Geometry and Positioning parameters of those elements have changed.

For example, if a load-bearing Column’s width value is increased, then you will be notified.

If the same Column’s layer has changed, you will not be notified.

See also Modified Element Geometry: What Counts as a Change?.
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Filter Change Notifications by Teams and Users

Teams and Users is a panel in the Teamwork > Change Tracking dialog.

By default, each Subscription tracks activities by “Everyone” - that is, all users joined in to the project. 

Whenever any user sends in a change that fits your Subscription criteria, you get a notification.

Note: You do not receive notifications for your own changes. 

However, you can narrow the subscription so that you are only notified if certain selected users (or Team 

members) make the change.

1. Open the Teams and Users panel.

2. Select the Everyone item, then click Remove.

3. Click the Add button.

4. The list of Users and Teams appears.

This list displays:

• All users who are joined into the current Teamwork Project (displaying their Team name, if any)
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• Teams (if any) which have access to the current Teamwork Project.

Note: “Teams” are sets of users, such as a Team of Structural Engineers, created for the “BIMcloud 

Project” containers on BIMcloud. 

• To filter the list to display the Teams only: click the filter icon.

5. Select one or more Users or Teams, then click Add.
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The subscription is now filtered to track only changes by the Teams/Users you have added.
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View and Manage Tracked Changes

When a user sends a change to the server which triggers one of your subscriptions, you receive a notification 

via an on-screen pop-up. 

– These notifications appear if you have checked “Show Tracked Changes Alert in Teamwork” (Options 

> Work Environment > More Options.) It is checked by default.

– Increase the size of the alert message by checking “Use large alert cues” in the same Work 

Environment dialog.

Do any of the following:

• Click the pop-up (this opens the Tracked Changes Palette - see below.)

• Click Snooze to make the pop-up disappear (it reappears after 30 minutes, or 100 steps, whichever 

comes first).

Notes:

– If an element is part of two or more subscriptions, you will receive a notification for each.

– If a particular element parameter is modified more than once, your notification contains only the latest 

change - not the earlier, obsolete ones.

Tracked Changes Panel

The Tracked Changes panel of Teamwork Palette shows a list of the subscriptions which have tracked a 

current change. 

These are changes that have been sent to the server, but not yet received by you. Once you receive the 

changes, the Tracked Changes list will be deleted.
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For a selected subscription in this list: Use context menu commands to zoom and select, or double-click to 

open the Tracked Changes palette for a detailed view of changes.

Double-Click a Change to Open Tracked Changes Palette

The palette shows more details on the model elements or project data (per your subscription) which have 

been changed in the Teamwork project and sent to the BIMcloud by other users, but not yet received by you.

Use the commands at the bottom of the Tracked Changes palette to do any of the following:

• Receive

• Receive Changes, then Compare

• Send & Receive, then Compare

Once you receive the changes, the Tracked Changes list will be deleted.

Subscriptions in the Model Compare Window

Choosing either of the Compare commands opens the Model Compare window and shows the results of the 

two project statuses: before and after receiving changes.
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By default, the Model Compare window is filtered to show the element changes as defined in the current 

subscription (e.g. the changes stemming from your “Core Geometry” subscription.)

See Model Compare: Review the Changes.
ARCHICAD 24 Reference Guide 2642



Manage Subscriptions Change Tracking in Teamwork
Manage Subscriptions

Manage your Subscriptions in the Teamwork > Change Tracking dialog.

Turn Subscription On/Off

In the Subscription list at left: Turn checkbox on or off to activate or deactivate notifications for any 

subscription. 

• If you deactivate a subscription: You will not receive any notifications or feedback on changes. (Existing 

notifications listed in your Teamwork Palette will not be deleted.)

• If you reactivate a subscription: You will start receiving notifications, but you will not get any notifications 

on changes that occurred while the subscription was turned off. 

Import/Export Subscription

Use the import/export buttons at the bottom of the dialog to transfer the definitions of one or more selected 

subscriptions in XML format.

Rename Subscription

Double-click the subscription name to edit the field, or use the context menu command.

Delete Subscription

Click the red X, or use the context menu command.

For Element-based Subscriptions (by criteria or selection):

• For any selected element in the Subscription list, use the buttons to Add or Remove it at any time.
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• For any selected element in the Subscription list, click the Zoom icon to zoom in.

Copy Settings

For criteria-based subscriptions only: 

If any model elements are selected in the project, the Copy Settings becomes active. Click to fill in the values 

of the last selected model element into the criteria.
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MEP Modeler

Use the built-in MEP Modeler Add-On to model and edit 3D MEP (mechanical, electrical and plumbing) 

systems and coordinate them in BIM models. 

MEP Modeler and the MEP Library are loaded automatically with ARCHICAD 24, and require no extra 

license. 

Activate MEP Work Environment

To see the MEP-related tools and palettes in ARCHICAD:

Use Options > Work Environment > Apply Profile > MEP Engineering Profile

For details on what this Profile contains, see MEP Work Environment.

Now you are ready to start placing MEP elements: either individually, using MEP tools, or with a series of 

clicks, using the MEP Routing function.

Note: Make sure the Autogroup function (Edit > Grouping > Autogroup) is turned off. 

Topics in this section:

MEP Work Environment

Place Individual MEP Elements

Insert MEP Junction Elements

MEP Routing

MEP-Compatible Library Parts

MEP Connection Ports

MEP Systems

MEP Preferences

MEP Element Settings

Graphical Editing of MEP Elements

Resize MEP Elements (Command)

Select Connected MEP Elements (Command)

Edit MEP Selection Set (Command)

Create Custom MEP Part
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MEP Work Environment

To access the MEP Modeler tools and interface, apply the MEP Work Environment Profile.

• The ARCHICAD Toolbox is expanded to include the Ductwork, Pipework and Cabling tools.

• MEP-related commands are added to the menu structure.

• The MEP Routing palette is displayed. Show/hide it at Window > Palettes > MEP Routing.

• The MEP Engineering Toolbar is displayed, providing shortcuts to frequently used MEP commands:

MEP Tools and Commands
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MEP Routing Palette and MEP Engineering Toolbar
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Place Individual MEP Elements

You can build up the desired mechanical system by placing individual elements one by one: 

1. Select the desired tool and place the first element.

2. Select the tool of the next element to be placed. 

3. In Tool Settings, ensure that its placement hotspot is correctly set (this is the square hotspot, in the 2D 

Symbol preview in the Preview and Positioning Panel).

4. On the Floor Plan, click at any available connection point (indicated by a checkmark cursor) on the 

existing element.

The elements will connect correctly. The second element will adopt the connection geometry of the first 

(already placed) element.

Connection geometry includes (as applicable): shape, height/width, thickness of element wall, connection 

type (e.g. flanged or not): these are the same parameters you set in the Connections Tab (MEP Element 

Custom Settings) tab page of the element’s MEP Custom Settings tab page.

Related Topics

Insert MEP Junction Elements

MEP Routing
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Insert MEP Junction Elements

Junction-type MEP tools are the Tee, Wye and Take-off.

Generally, you will add junction-type MEP elements to an already placed, straight MEP element.

Note: Make sure the Autogroup function (Edit > Grouping > Autogroup) is turned off. Junctions cannot 

be placed on grouped elements.

1. Activate the desired Junction tool (Tee, Wye or Take-off).

2. Click on the existing element - the centerline or its endpoint - to place the junction.

Note: To place a Take-off, click on the element centerline.

3. Depending on where you clicked and the junction type, additional clicks may be necessary: move the 

cursor around to see the possible positions: should it branch off the right, left, top or bottom of the duct?.

4. Click in one of these four positions to choose the desired geometry.

 Right

 Left  
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Top

Bottom  

See also Start Routing with a Junction.

5. As applicable: Guide Lines will prompt you to click to define the angle at which to continue the next routing 

element.

(If you prefer that the next placed element be vertical, do not choose any of the four horizontal directions 

indicated by the on-screen feedback. Instead, switch the Construction Method (use the MEP Routing 

palette or the Tracker) to Vertical Rise and place the next element.)

Start Routing with a Junction

You can begin a Routing operation by placing a junction (Tee, Take-off, Wye) at an already placed straight 

MEP segment.

1. Click Start Routing on the MEP Routing palette

2. Click on the centerline of a placed MEP element

3. The Insert Junction Element dialog box appears. 

Choose the type of junction you wish to insert (e.g. Duct Tee, Duct Takeoff, Duct Wye), then click OK. (The 

possible junction types vary depending on whether the clicked element is a Duct, a Cable or a Pipe.)
ARCHICAD 24 Reference Guide 2650



MEP Routing MEP Modeler
MEP Routing

Use the Routing function to place multiple connected MEP Elements with a series of clicks.

The MEP route is based on the MEP System, geometry, and other parameters you define in the Routing 

Palette. 

Routing is available in the Floor Plan and in the 3D window.

Note: Make sure the Autogroup function (Edit > Grouping > Autogroup) is turned off. 

Topics in this section:

Define Settings in Routing Palette
Routing Options
Routing Process
Vary Elevations During Routing
MEP Routing With the Magic Wand
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Define Settings in Routing Palette

Set the desired options on the MEP Routing palette (Window > Palettes > MEP Routing). These options can 

be changed in the midst of a routing operation.

1. Choose either Ductwork, Pipework or Cabling from the top dropdown menu.

2. Choose a cross-section geometry preference for the routed elements: Rectangular, Circular, Oval or 

(Ductwork only) Flexible.

3. Enter a diameter or height/width values for the cross-section, as applicable. 

– Enter a predefined height or width from the pop-up, or choose Custom to type in any custom value.

– The list of predefined Duct and Pipe sizes can be edited in MEP Preferences. (Options > Project 

Preferences > MEP Preferences).
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Choose Predefined Pipe Diameter

4. The Construction Method is not editable until after you start Routing. All new routes are set to “Constant 

Elevation” (the horizontal arrow). Once you start routing, you can switch to another routing elevation as 

you proceed. (See Vary Elevations During Routing.)

5. Reference Line location/Elevation: Choose one of the nine points in the Routing palette to define the 

location of the reference line of the routed elements, at the given elevation. (This reference line is relevant 

only during a Routing operation, and indicates the anchor point of the routed elements when you click on 

screen to place them. You can switch this location en route as needed.)

In this image, the reference line during routing runs along the top left corner of the duct, as viewed in the 

direction of routing. 

6. Choose an MEP System attribute for this Routing operation.

7. Adjust additional Routing Options as needed. (See Routing Options.)

8. Choose a Layer on which to place the routed elements.

Related Topics:

Routing Process

Routing Options
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Vary Elevations During Routing
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Routing Options

Click the Routing Options button from the MEP Routing palette.

Options you set here will affect the next Routing operation. Available options vary, depending on whether you 

are doing Ductwork, Pipework or Cabling.

Connection Type

Choose the appropriate type (e.g. Flanged, Welded, Simple), and a height/diameter as applicable.

Insulation

Click the checkbox to add an optional Insulation layer to the outside of MEP elements placed in this Routing 

operation. Define an Insulation Thickness.

Transition Rule

Transitions are straight segments placed automatically to ensure correct connections if you switch segment 

geometry (width, height, or shape) in the middle of a routing operation. If the switch occurs at a bend in the 

route, the transition element can be placed either before or after the bend. Choose your preference (“Place 

before bend”/“Place after bend”) here.

Bending Radius

Bends are placed automatically as you route. Choose an option to define the radius of bends in this route:
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Predefined if applicable

With this option, the bends will have the radius defined for the Predefined Bend you chose at the top of the 

Routing palette. (Radius values are given at MEP Preferences.) 

This applies only if you chose a MEP element type whose cross-section values have been predefined in MEP 

Preferences.

Bend Radius in a Routing Operation: Using “Predefined if applicable” 
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Always by element settings

With this option, the bends will have the radius defined in the Bend tool’s Default element settings:

Bend Radius in a Routing Operation: Using “Always By Element Settings”
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Routing Process

1. Click Start Routing at the bottom of the MEP Routing palette. 

Note: Make sure the Autogroup function (Edit > Grouping > Autogroup) is turned off. 

2. Click and drag in the active window, as with polyline input, then keep clicking to place additional segments 

on the route. 

– The active tool automatically switches to the relevant straight segment-type tool (Duct, Pipe or Cable 

Tray), depending on the tool type chosen at the top of the Routing Palette.

– Bends are placed automatically. The Bend radius depends on what you chose in Routing Options 

(either the Bend radius defined in the Bend tool’s element settings, or else the Bend radius predefined 

for the chosen pipe/duct cross-section. (See Bending Radius.)

– Press Backspace to delete the last placed segment

– Don’t worry about duct/pipe segment lengths during routing. When you complete the route, segments 

are automatically divided into duct/pipe segments based on the “Duct/ Pipe segment length limit” 

definition (Options > Project Preferences > MEP Preferences)

– Guide Lines displayed during Routing correspond to Standard Bend Angles (defined at MEP Project 

Preferences). 

3. To finish the routing, do one of the following:

– Double-click 

– Click Finish Routing from the bottom of the Routing Palette

– Click on the connection port of an existing MEP element

Start Routing from Straight MEP Element

1. Click Start Routing on the MEP Routing palette

2. Click on the connection port of a placed MEP element

3. Click as needed to place the route.

– The newly placed MEP elements will use the parameters (Element type, MEP system, shape, 

elevation) of the clicked connection port, overwriting the current parameters of the Routing Palette.

– The connection ports of straight segments are editable (shown as a diamond-shaped hotspots). This 

means that if your routing takes a sharp turn, then the original straight segment might be shortened 

automatically to accommodate the bend.
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Start Routing from Non-straight MEP element (e.g. Bends, Junctions, Terminals) 

These connection ports have fixed geometries. You cannot place the newly routed element at an angle that 

would require you to truncate the existing MEP element.

See also Start Routing with a Junction.
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Vary Elevations During Routing

All Routing operations begin with the Constant Elevation setting (the default Construction Method shown in 

the Routing palette). 

Once you start Routing, you can choose alternative Construction Methods:

 (Can also be set in the Tracker, during Routing.)

• Vertical Rise: Switch the construction method to “Vertical Rise”. 

– In the Floor Plan, a dialog box appears: enter the elevation at which the next element should end. 

Click OK to close the dialog box and place the vertical segment, and continue routing.

– In the 3D window, just draw the segment along the vertical editing plane.

• Constant Slope Angle: Switch the construction method to “Constant Slope Angle” and enter an angle. 

Subsequent elements of the current Routing will be placed along this slope until you change the angle 

value or switch to a different method.

Note: The angle unit (such as degree or mm/meter) of the slope is defined in the MEP Preferences: Rise/

Drop Unit control.
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Use 3D Editing Planes During Routing

In the 3D window:

Begin Routing and place at least one element using any of the construction methods described above. 

Then switch to one of the following construction methods (click one of the three fly-out options of the 3D 

Editing Planes icon) to constrain the Routing along to a 3D plane:

• Width Plane: Routing will continue along the width plane: the plane created where the reference line 

intersects with the “width” direction of the last placed routed element.

• Height Plane: Routing will continue along the height plane: the plane created where the reference line 

intersects with the “height” direction of the last placed routed element.

• Perpendicular Plane: Routing will continue along the plane perpendicular to the vector of the last placed 

element.
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MEP Routing With the Magic Wand

Use the Magic Wand to place connected MEP elements with a single click, based on an existing polyline or 

polygon.

Note: The Magic Wand method works only as the initial step in an MEP Routing operation.

1. Set preferences on the MEP Routing palette.

2. Click Start Routing.

3. Press the Spacebar to activate the Magic Wand, then click on the polyline or polygon.

See also Magic Wand.
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MEP-Compatible Library Parts

MEP-compatible Library Parts (with smart connections for use in duct, pipe and cabling systems) are found in 

both the MEP Library and in the regular ARCHICAD Library. Both libraries are loaded automatically as part of 

the default ARCHICAD template.

MEP Library

The MEP Library contains specially configured MEP Elements.

Commonly used MEP elements:

• a Straight segment, such as a duct with identical geometry at either end. Examples: Duct tool, Pipe tool 

and Cable Carrier tool.

• a Bend. Some Bends are inserted automatically during Routing, or as a result of editing MEP elements.

• a Transition. This is a straight segment with unequal geometries at its two ends. Transitions are used to 

connect two MEP elements of different width/height/shape.

• a Junction. These include a Tee junction, a Wye junction, and a Take-off.

• a Terminal - for example, a ceiling diffuser, or a grille or a sprinkler placed at the end of a pipe or duct. A 

Terminal has only one connection port.

• Inline element, such as a valve or filter, placed inside the route. Inline elements are straight segments 

open at both ends.

• Equipment - such as a furnace, with one or more connection ports. A single Equipment element generally 

is generally assigned to multiple MEP Systems (e.g. Heating, Exhaust Air), and are connected to multiple 

(Pipework, Ductwork) MEP element types.

MEP-Compatible Objects in the ARCHICAD Library

Many familiar elements from the ARCHICAD Library, such as this Basin, include MEP Custom Settings, which 

allows you to connect them to objects in an MEP route:
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Display MEP Connection Ports 

1. Go to Document > Model View > Set Model View

2. Open the Miscellaneous Settings for Library Parts panel)

3. Enable the Model View Option for Object MEP Connections. 

Model View Option: Show or Hide MEP Connections on Library Parts

See also Element Type of MEP-Compatible Objects.

Related Topics:

MEP Preferences

MEP Connection Ports

MEP Element Settings
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MEP Connection Ports

MEP Elements all have connection ports: these are represented by hotspots to which you can connect 

another MEP element.

A newly placed MEP element that is connected to an existing MEP element will take on the connection 

parameters (e.g. shape, size) of the element to which it is now connected.

Connected MEP elements can be moved and edited together. 

To select connected elements: see Select Connected MEP Elements (Command).

• The hotspots of correctly connected, straight MEP elements are black.

• Unconnected hotspots are displayed as diamond-shaped editable hotspots

Note: The regular ARCHICAD library includes MEP-compatible Library parts, such as plumbing fixtures, 

whose connection ports connect smartly to MEP elements. 

See MEP-Compatible Objects in the ARCHICAD Library.
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MEP Systems

A MEP System is a saved set of pens, colors and materials used to display MEP elements in your project. 

MEP Systems are attributes of the ARCHICAD project.

MEP Systems are defined or edited by you at

• Design > MEP Systems 

• Options > Element Attributes > MEP Systems

(or use the MEP Systems shortcut from the MEP Engineering Toolbar).

These controls are analogous to those of other ARCHICAD attributes (such as Lines). Create a new MEP 

System, or rename an existing one.

Check the box of one or more MEP tool categories for which you wish to use this MEP System:

• Ductwork

• Pipework

• Cable Tray
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The MEP System (based on the “Use with” availability you define here) can then be assigned to particular 

MEP tools, to individual MEP connections, or to a Routing operation.

See the following sections:

Assign MEP System in Tool Settings

Assign MEP System to Each Element Connection

Define Settings in Routing Palette
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Assign MEP System in Tool Settings

For a MEP-compatible library part that uses a single MEP System (e.g. Duct):

1. In the Tool Settings dialog, go to the General Settings panel. 

2. Use the MEP System pop-up to assign an MEP System to the currently selected connection, or else 

leave the value as “Undefined.”

The MEP System pop-up lists only those MEP Systems that have been defined as applicable to the MEP type 

of the current element: Ductwork, Pipework or Cable Tray. 

This definition is set for each MEP System attribute at

• Design > MEP Systems 

• Options > Element Attributes > MEP Systems

Assign MEP System to Each Element Connection

Some MEP elements have multiple connections used for different purposes. For example, a toilet object with 

freshwater and wastewater pipes.
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You can assign MEP System attributes individually to each connection, on the Connections tab page of its 

Settings dialog:
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MEP Preferences

Use this dialog to define general and Routing preferences when working with MEP Modeler.

Open the dialog at Options > Project Preferences > MEP Preferences (or use the MEP Preferences 

shortcut from the MEP Engineering Toolbar).

Rise/drop unit

Applies to Routing segments placed at an angle: the angle unit (such as degree or mm/meter) of the slope.

Segment Length Limits (Duct, Pipe, Cable Carrier)

During Routing, drag and click any distance to place a series of straight MEP elements. The placed elements 

will automatically be divided into segments of the length defined here.

Standard Bend Angles

While using MEP Routing in the Floor Plan window: Guide Lines will appear to assist you (provided that Guide 

Line display is turned on). These Guide Lines reflect the Standard Bend Angles defined here.

Click Add to add more Standard Bend Angles to the list, if needed.

Predefined Sizes

This is the project’s list of predefined cross-sections for each MEP tool type. The list defined here is available 

when you set up the cross-section geometry for a Routing operation in the Routing Palette. 

See Define Settings in Routing Palette.

• Click any MEP type to edit the list of predefined size, radius, and descriptions

• As needed, use the Import/Export buttons to use these data in other projects
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Element Type of MEP-Compatible Objects

By default, MEP-compatible objects from the ARCHICAD Library are placed with the Object Tool and their 

element type is therefore “Object.”

You may prefer to switch the element type of such objects to Equipment. This can make it easier to browse for 

MEP-compatible objects while you are working with MEP systems. Use the following two controls:

Convert Selected Objects to Equipment (Affects Existing Objects)

Reclassify selected MEP-compatible Objects, which were placed with the Object tool, as Equipment (rather 

than Object).
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Convert Newly Placed Objects to Equipment

If checked: the element type of MEP-compatible objects placed with the Object tool will (from now on) be 

classified as Equipment rather than Objects. Does not affect already placed Objects.
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MEP Element Settings

MEP-compatible Library Parts (with smart connections for use in duct, pipe and cabling systems) are found in 

both the MEP Library and in the regular ARCHICAD Library. Both libraries are loaded automatically as part of 

the default ARCHICAD template

MEP element Tool Settings are analogous to ARCHICAD’s Object settings.

See also MEP-Compatible Library Parts.

MEP Element Display on Stories

Use the “Show on Story” setting (Floor Plan and Section panel).

The default option for all MEP elements is “All Relevant Stories”.

• Straight segments are displayed as cut on the intersected stories.

• Other (non-straight) MEP elements that intersect stories do not have cut displays - they are shown either 

on one story or the other.

MEP Custom Settings Panel

This has two or three tab pages depending on the object: General, Visualization, and Connection Settings.
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General Settings (MEP Element Custom Settings)

Enter the basic geometry of this MEP object (such as Length of the duct). 

Bend Radius

For Bend-type elements. When Routing, you can opt to use this default value (as in element settings), or else 

the radius defined for the predefined cross-section chosen in the Routing Palette. (See Bending Radius at 

Routing Options.)

For some MEP objects, the range of possible values depends on other values.

For example, the Length of a Duct Tee (set here in the General Settings tab page) cannot be less than the 

width of the T-Branch (set in the Connections tab page) that comes off of it.

Insulation

Check this box if you wish to include an insulating layer on the element’s outside surface. Then enter the 

insulation’s Thickness value in the field below.

MEP System

See Assign MEP System in Tool Settings.
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Visualization Tab (MEP Element Custom Settings)

Use the Visualization tab page to assign custom parameters for the display of this element in 2D (plan) and 

3D views. Parameters for the 2D symbol are on the left; parameters for the 3D view are on the right.

Typically, you will use these controls if you want to override the MEP System attributes assigned to this 

element.

If you have adjusted the surface definition here, the MEP System definition applied to this MEP element 

changes to “Undefined.”

To revert to the surface defined in the MEP System: 

1. Go to the MEP System control (on the General or Connections tab): it is currently “Undefined.”

2. Choose a specific MEP System 

3. Return to the Visualization tab page

4. Check the Use System Surface box.

Connections Tab (MEP Element Custom Settings)

Use this tab page to define the parameters of each of the element's connection ports. 

The number of connections on an object varies: a Duct take-off has just one connection port, but a Duct Wye 

has three.

Use the pop-up to switch among the connections, and edit each of them separately. In this image, we have 

selected the “Branch” connection from the pop-up on Duct Wye’s Connections tab page.
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Note that the 2D Symbol object preview on the Preview and Positioning panel gives you feedback (the 

triangle) on which connection you are editing: in this case, the Branch of the Duct Wye.

Wall Thickness

This is the thickness of the MEP element’s wall.

Connection Type

Choose a Connection Type as applicable. For example, a ductwork element’s connection can either be simple 

or flanged. If you choose Flanged, enter a value for its width in the field below.

MEP System

See Assign MEP System to Each Element Connection
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Graphical Editing of MEP Elements

• For any selected MEP element, use the Pet Palette commands to edit the MEP element graphically.

• MEP-specific editing commands are available in the Floor Plan and 3D window. 

• When you edit a selected MEP element, certain parameters of connected (though unselected) MEP 

elements may also change as a result. 

• Following the edit, every modified element becomes selected.

For example, if you change the cross-section of one selected element, the connected elements will become 

disconnected as a result, and they will all be shown as selected following the edit. 

Specific Commands for MEP Elements

Select the MEP element(s) to be edited.

Click on an edge or node to access pet palette commands.

The top row of the Pet Palette can include certain commands specific to the type and geometry of the selected 

MEP element. These pet palette commands are introduced here:

Move Connection

Available for the connection node of a selected straight element connected to another straight element. 

Use the cursor to drag the connection node, or enter values in the Tracker; this modifies the length of the 

segment. (The Length parameter is the length of the element; the Distance parameter is the distance by which 

you move the node.)
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Insert Node

Available for every straight MEP element, by clicking on its edge. This command will affect not just the 

selected MEP element, but all straight connected elements up to the next connected junction, or to the last 

straight element. New bends are inserted as needed.

Offset Edge

Affects all straight elements connected to the clicked element, including any inline, transition and junction 

elements.

Elevate Edge (Floor Plan)

Enter the value by which you wish to elevate the selection. 

Since this is a vertical edit, you will have no feedback in the Floor Plan on the result, unless a previously 

connected straight segment is now disconnected: the hotspots will change.
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Elevate Edge (3D Window)

Use the Tracker’s Elevation control to enter the desired value.

Stretch

Available at the end of an unconnected straight segment or Flexible Duct.

Move Node (Flexible Duct)

Click on the Flexible Duct’s internal node.

Insert Node

Click on the Flexible Duct’s edge.

Note: Using these commands can result in duct elements of extreme geometries that are not structurally 

valid.
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Move Node (Duct Bend)

Available from the corner point of a connected Duct Bend.

Affects the selected Bend plus all straight elements connected to it, including any inline, transition and junction 

elements. The selected Bend angle will change, and new Bends are inserted as necessary.

Elevate Node

• Available from the corner point of a connected Bend having a circular cross-section, in 3D window only. 

• Also available from the endpoint of a free-standing element having a circular cross-section.

Use this command to change the overall Slope Angle of placed, connected MEP elements.

Move Inline

Move an in-line element along its straight axis.

Move Terminal (Floor Plan)

For Terminal-type MEP element in Floor Plan. The Terminal plus all connected straight segments move 

together.
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Elevate Terminal (3D Window)

For a Terminal-type MEP element in the 3D window. You will be able to elevate or lower the Terminal element 

plus all of its connected straight segments simultaneously.
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Resize MEP Elements (Command)

Use this function to resize and/or change the shape and common parameters of a whole series of connected 

elements in your MEP system.

1. Choose the Edit > Reshape > Resize MEP Elements command (or use the toolbar shortcut from the 

MEP Engineering Toolbar).

2. Click an MEP connection to define the start point of the resize.

3. Move your cursor to another connection point where you want to end the resizing. A pre-selection 

highlight indicates the part of the MEP system chosen for resizing.

4. Click to define this endpoint of the resize. ARCHICAD zooms onto the affected part of the MEP system.

5. The Resize MEP Elements dialog box appears.

6. Use these controls to set the desired shape and size of the elements, then click Resize.
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Select Connected MEP Elements (Command)

1. Use Edit > Select Connected MEP Elements (or the shortcut from the MEP Engineering Toolbar).

2. Move your cursor to any connection point on any placed MEP object. All connected MEP elements from 

that point are pre-selected.

3. Click to select these connected MEP elements.

Related Topic:

Edit MEP Selection Set (Command)
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Edit MEP Selection Set (Command)

This function enables you to adjust certain settings of multiple selected MEP elements - even if the selected 

elements have been created using a variety of MEP tools.

Note: MEP Equipment elements are not editable with this function.

1. Select any combination of MEP elements. 

2. Use the Edit > Element Settings > Edit MEP Selection Set command (also available from the MEP 

Engineering toolbar).

The appearing dialog box has a separate panel for each MEP family (i.e. Ductwork, Pipework, Cabling.) On 

the relevant panel(s), change any of the settings. These changes affect all the selected elements of that 

family.

Related Topic:

Select Connected MEP Elements (Command)
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Create Custom MEP Part

Use this function to create a specialized ARCHICAD model and save it as a custom MEP part.

1. Open a new, empty ARCHICAD project file.

2. In the Floor Plan or 3D window, use any construction elements (e.g. Wall, Slab, Object, MEP element) to 

model a custom MEP part.

3. If your custom MEP element requires one or more connections, you must use the MEP Connection object 

as part of your element under construction. 

Note: The MEP Connection object is located in the MEP Library. (You can use the Library Part search 

function to locate it.)

4. When you are finished designing the MEP part, go to the 3D window (if you are not there already).

5. Use the File > Libraries and Objects > Save Selection As > MEP Part command

6. In the appearing Save Library Part dialog box, enter a File Name for your new MEP object, which will be 

saved in your project’s Embedded Library, or another library designated by you.
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7. Choose a Subtype from the Type drop-down list:

Note: The available subtypes in this list depend on the number and type of MEP Connection objects you 

placed in the custom MEP part. If your custom MEP part has only a single Connection, the equipment and 

in-line subtypes (which require multiple collinear connections) are not available here. Also, if you placed 

an MEP Connection that is set to Pipe type in its Settings dialog box, then the Duct subtypes are not 

available.

8. Click Save. The new MEP object is now located in the library folder to which you saved it, and is 

accessible from the Tool settings of the chosen subtype.
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Visualization

Visualization in ARCHICAD encompasses all the tools and techniques that allow you to display and present 

your architectural design to your customer.

You can visualize your entire project or parts of it by adding dedicated cameras to the floor plan and then 

viewing the data from that vantage point.

For photorenderings, the built-in Cineware Engine comes with pre-set scenes and user-friendly Basic 

Settings. Cineware is optimized to work with corresponding Surfaces (with a catalog of hundreds of 

predefined surfaces) and Light objects. Even if you only use the Basic-level settings, you can quickly create 

good renderings with a minimum of effort.

However, the full menu of Detailed Settings is also available for Cineware. These correspond to Maxon 

Cinema 4D version R21, and incorporate most of its parameters.

ARCHICAD offers various options for exporting the entire model into a number of common file formats used 

by professional rendering software.

• Artlantis is a rendering solution developed by GRAPHISOFT’s French distribution partner, Abvent SA. It 

can handle still images and animations exported directly from ARCHICAD (File > Save as). Moreover, an 

intelligent link is established between the original model and the Artlantis file.

See Export to Artlantis.

• You can also export the floor plan or 3D view into a variety of applications such as Piranesi, 3D Studio or 

Photoshop for fine-tuning it or adding special effects.

GRAPHISOFT BIMx lets you create an interactive walk-through model out of your ARCHICAD project, which 

can be viewed on a computer or a mobile device.

The most commonly used commands related to Visualization techniques can be found on the predefined 3D 

Visualization toolbar. Choose Window > Toolbars > 3D Visualization to display this toolbar as needed. 

(This toolbar also contains 3D Window display and 3D Navigation commands.)

Multi-core processors are recommended to support 3D navigation and 3D model generation.

Topics in this section:

Cameras

PhotoRendering

Visualization Extras

GRAPHISOFT BIMx
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Cameras

You can place any number of Cameras in the Floor Plan for generating perspective views in still image or 

animation (fly-through) format.

Perspective Cameras allow you to view and edit the entire project or a selected part of it in the 3D Window 

and to create renderings that represent a snapshot of the current state of the project. They are defined by a 

viewpoint, a target point and an opening angle.

On the Floor Plan, all Cameras are shown with their target points and paths, and the handles that can be used 

to manipulate them. Only one camera is active at a time, as indicated by the sun and view angle markers.

Double-click the Camera tool to open Camera Tool Settings.

For details, see Camera Tool Settings.

Camera Path Options

The Display Options of perspective Cameras can be set with a pop-up menu in the Path Options dialog box 

accessed from Camera Settings. You can hide the Cameras altogether, show the Cameras with or without 

the Path line and with or without the in-between frames.

See Path Options.

When the 3D Window is active, you can modify Cameras with the Navigator and Navigator Preview palettes 

(click the desired Camera from the list in the Navigator, then modify it in the Navigator Preview). You can also 

modify the settings of placed cameras by changing the 3D view with the navigation commands, then using the 

3D Navigation Extras commands to adjust the placed cameras to the new viewpoints.

For more information, see 3D Navigation Extras.

When you have made your choices in the Camera Settings dialog box, you are ready to place Cameras on 

the Floor Plan.

Your first click on the Floor Plan defines the location of the Camera itself. Draw a rubber band line to set the 

view direction, and click again to define the target’s horizontal position. When the operation is completed, the 

sun icon appears with default settings.

To apply the camera-defined view defined to the 3D model, select the camera and activate the 3D Window. 

When you do this, the parameters of the perspective defined by the camera are copied into the 3D Projection 

Settings dialog box and the Navigator and Navigator Preview palettes.
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PhotoRendering

The ARCHICAD PhotoRendering feature allows you to create photorealistic images of the 3D model.

Creating quality renderings is a complex function that depends on the interaction among:

• Surfaces

• Light effects

• Rendering settings

ARCHICAD’s built-in Cineware Engine comes with pre-set scenes and user-friendly Basic Settings to make 

this process easier. Cineware is optimized to work with corresponding Surfaces (with a catalog of hundreds of 

predefined surfaces) and Light objects. Even if you only use the Basic-level settings, you can quickly create 

good renderings with a minimum of effort.

However, the full menu of Detailed Settings is also available for Cineware. These correspond to Maxon 

Cinema4D version R21, and incorporate most of its parameters.

Photorendered images are generated in a separate picture window and cannot be edited. 

Important: Photorendered images are not saved with your Project. If you wish to keep them, you have to 

save them manually.

PhotoRendering Settings Palette

Cineware Basic Settings

Create Rendered Image

Detailed Cineware Settings
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PhotoRendering Settings Palette

The PhotoRendering Settings palette is accessible from Window > Palettes > PhotoRendering Settings.

By default, the Preview window is at the top, and the settings of the selected Rendering engine are below. 

Click the pop-up below the Preview window to show:

• both Preview and Settings

• Preview only; or Settings only.

In the top part of the Palette, there are two main views: click the left button for Settings; click the right button 

for Size.

Note: If you save a Rendering view, you can edit the size it should render, in View Settings.

See View Settings 3D Only Panel.
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• Use the Settings view to adjust the parameters of your PhotoRendering Scene; parameters vary 

depending on the Engine you choose. You can save and manage your scenes in folders, so you can re-

use them easily in subsequent renderings and export/import them among different projects.

For Cineware’s Basic settings: see Cineware Basic Settings, below.

For details on other engine-specific settings: see PhotoRendering Settings.

• The Size parameters will not be saved as part of the Rendering Scene. Thus, you will be able to use the 

scene in a variety of contexts, regardless of size.

Note: for a rendered view, you can also edit Size parameters in View Settings.
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Select and Manage Rendering Scenes

A Rendering Scene is a set of predefined Rendering Settings that can be stored and reapplied using the 

Select and Manage Scenes dialog box.

For each Rendering engine, ARCHICAD’s factory template provides one or more predefined Scenes. These 

are listed in a tree structure in the Select and Manage Scenes dialog box.

If you have loaded a Scene into the PhotoRendering Settings Palette, and then you change any parameter, 

the name of the Scene changes to “Custom” until you store it under a new name.

To store the settings of a Rendering Scene, open the Select and Manage Scenes dialog box and click Store 

as.

A stored Scene includes all the parameters on the Settings view of the PhotoRendering Settings Palette. Note 

that this includes the Rendering engine (e.g. Cineware or Sketch). However, a Rendering’s output Size is not 

stored as part of the Scene.

Before closing a project, make sure you store any customized Scene settings under a new name if you wish 

to reapply its settings later. Also, when saving a 3D view, you can save any named Scene as part of its View 

Settings (in the 3D Only panel of View Settings).

Use the Select and Manage dialog box to organize into folders, and to export/import Scene files among 

different ARCHICADs. (Scene files have the extension “renderingscene”.)

Note: You cannot use a PhotoRendering Scene in any version of ARCHICAD earlier than ARCHICAD 18.

Choose an Engine

Choose an Engine from the Engine pop-up. ARCHICAD comes with the following built-in rendering engines. 

• Cineware Engine: This renderer is based on Maxon Cinema4D version R21 and incorporates most of its 

parameters.

Note: Copyright MAXON Computer GmbH. All rights reserved. http://www.maxon.net. (Click the Info 

button to access additional information on this engine.)
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• This engine enables you to create very high-quality, highly realistic images, with more exact texture and 

light reproduction than the other engines.

See Cineware Basic Settings.

See also Detailed Cineware Settings.

• Basic Rendering Engine: The Basic Engine (whose settings are analogous to the OpenGL engine) is 

suitable for producing draft-quality or simple renderings offering textured image surfaces, simple shadows 

and transparencies.

See Basic Rendering Engine.

• Sketch: This produces non-photorealistic renderings that replicate sketched lines - best suited for draft 

views in the early project stages.

For more information, see Sketch Rendering Engine.

Set Size

The Size parameters you set up here will not be saved as part of the Rendering Scene. Thus, you will be able 

to use the scene in a variety of contexts, regardless of size.

Click the pop-up menu to access convenient predefined Size presets (corresponding to screen size in pixels, 

paper size, or the current 3D window size).

Size Presets available (e.g. Screen, in pixels, or Print, to match paper size. 

Click the chain icon to keep these values proportionally constant: if you change one of the values manually, 

the other value will be updated accordingly.

If you choose a Paper size preset, you must also enter a Resolution value in dpi. The Size tab also displays 

the final image resolution. 

Preview Picture

Generation of the Preview picture is optimized for speed. Consequently, it has certain limitations: for example, 

the 3D grass feature is not shown in the preview (the Grass channel in Surfaces has no effect on the preview.)
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The Preview can be refreshed manually or automatically. 

• Automatic refresh: To turn on automatic Preview refresh, choose this option from the pop-up

• Manual refresh: just click the picture. A Preview that requires refreshing is shown with an update icon, 

and the Preview is grayed out.

Notes on the PhotoRendering Preview:

– The 3D window must be active in order for automatic refresh to occur. 

– While the PhotoRendering Palette can be displayed over any ARCHICAD window, the 3D window is 

always regenerated and brought to the fore every time its Preview is refreshed.

– While rendering with the Sketch Render engine, the preview will not use the actual 3D model. Instead, 

to speed up the preview feedback, a “dummy” basic model is shown, in which your current rendering 

settings are reflected.

– To refresh the Preview, ARCHICAD will regenerate only the changes resulting from modifications to 

the model, surface settings and rendering settings. However, if you close the PhotoRendering 

Settings Palette, ARCHICAD will have to re-render the entire model the next time you open it. Thus, to 

save time, you should keep the PhotoRendering Palette open while you work.
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Cineware Basic Settings

The Cineware engine’s Basic Settings are enough to create a quality rendering for most purposes. By using 

the Basic Settings interface, you need only set a few types of parameters.

The following section describes these Basic Settings.

For an overview of the Rendering process, see Create Rendered Image.

By default, the PhotoRendering Settings palette shows the Cineware engine’s Basic Settings. (Make sure the 

“Detailed Settings” box remains unchecked.)

Note: All parameters in Basic view are also available in Detailed view. The settings of these parameters 

are always identical; it doesn’t matter where you set them.

There is one exception: The Environment panel in Basic Settings contains a city chooser pop-up list. In 

contrast, location definition in Detailed Settings (Environment/Physical Sky) requires geographic 

coordinates.

Related Topic

Detailed Cineware Settings
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Render Settings (Basic) Panel

Quality

The two quality pop-ups refer to the Rendering Quality and Shadow Quality of your rendering.

• Rendering Quality: The first pop-up sets Rendering quality. Choose Low, Medium, High or Final 

(Details). (The quality you set here will have an effect on the antialiasing and Global Illumination 

processes, which produce better quality but require more render time.)

• Shadows: The second pop-up sets Shadow quality. (Varies depending on whether you are using a 

Standard or Physical Renderer.)

– Choose None for no Shadows.

– By Light Settings means that the Shadow Casting setting for each individual placed light object (as 

defined on the Lamp Settings Light Parameters page) will be in effect in this Scene. (See also Shadow 

Casting.)
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Light Sources

Use three sliders to set the intensity of three different types of light used in the rendering: Sun intensity; Lamp 

intensity; and Illuminating surfaces.

Each slider can override a particular light source intensity that is set elsewhere in the project.

• Sun Intensity

– If you are using a Physical Sky as your Environment, then this slider affects the sun that is part of that 

Physical Sky setting. 

See Cineware Basic Settings: Environment Panel.

– If you are using an HDRI image as your Environment, then this slider affects the ARCHICAD Sunlight 

settings.

 See Sunlight Settings.

– The midpoint of the slider, at “By Settings”, corresponds to 100 percent: this means that the rendering 

will use the sun intensity defined in current settings.

• Lamp Intensity: Can override the Main Intensity settings (set in Lamp Settings) for all individual lamps 

placed in the project. The midpoint of the slider, at “By Settings”, corresponds to 100 percent: this means 

that the rendering will use the lamp intensity exactly corresponding to the intensity set for lamp objects 

placed in the model.

See Light Color and Intensity for Lamp Tool Settings.

Watch the Video

Note: These Rendering settings consider the settings that affect the 3D window, but the reverse is not 

true: the 3D Window does not consider what you adjust in Rendering settings. So a lamp that is turned off 

in the 3D window cannot be turned on in Rendering Settings.

• Illuminating Surfaces: This setting overrides the surface-level Luminance channel.

Note: All surfaces also have an Illumination channel, which affects Global Illumination. But the 

Illuminating Surfaces control in Photorendering Settings affects the Luminance only.

Only two effects are part of the Basic Settings parameters: the White Model Effect and Depth of Field.
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White Model Effect

All surfaces are white, except those which use transparency or alpha channels (those remain transparent). 

This control is useful, for example, when showing an early design phase to a client, to convey the essential 

forms and space of the project plus light effects, without getting bogged down in colors and textures.

Note that applying this effect involves changing all surfaces in the model. Consequently, the entire model must 

be converted during the preview generation process, which takes time.
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Depth of Field

This parameter controls the sharpness of the depth view. (That is, to what extent should it blur over distance.) 

By default, this is set to sharp. 

Limitations:

Keep in mind that if you are using Standard rendering mode, Depth of Field functions as a post-effect: that 

is, it is only generated after the photorendered image is completed. Consequently, if:

– you are using Standard rendering mode, and 

– your project contains alpha-effect objects (e.g. a bitmap tree object that uses an alpha effect), and

– you have set a value for Depth of Field:

then the Depth of Field may not have the desired effect.

To solve this problem, switch to Physical Renderer mode. (In Physical Renderer, Depth of Field works like 

a camera setting (F-stop). (See also Physical vs. Standard Renderer.)

Cineware Basic Settings: Environment Panel

Use this panel to set your rendering into a particular environment: using an option sky backdrop, plus weather, 

time and location settings.

Sky Setup: From this popup, choose None, HDRI Sky, or Physical Sky. The most common setting is Physical 

Sky.

Physical Sky

The Physical Sky is an entire constellation that includes multiple objects having properties (sun, weather, 

clouds, fog, rainbow, atmosphere). A Physical Sky provides both a background image and lighting effects. It is 

“smart” and the parameters are interconnected. 

With Physical Sky selected, click the Weather Preset pop-up to choose a named set of weather parameters 

that combine the sky, atmosphere, clouds, flog, rainbow and sunbeams. The Physical Sky weather preset 

also includes Time and Location data.

Note: Time and Location parameters control the Physical Sky and with it, the sun settings. 
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Use ARCHICAD Sun Position: Checking this box will reset the Time & Location according to the ARCHICAD 

Sun Position. Use this to fine-tune the weather preset you have chosen to match the conditions at the project 

location.

See also Note on Sun Settings in ARCHICAD.

HDRI Sky

Click Select HDRI to select an image which provide a background picture and ambient light source for the 

rendering.

• Use a predefined image from the library ([Himg] HDF Images folder), or create your own. (If you create 

your own, you must use a spherical view, otherwise it will be distorted.)

• An HDRI image provides diffuse light and blurred shadows (no sharp shadows)

• The HDRI Sky Setup does not include a separate Sun. To use the effects of the ARCHICAD sun, make 

sure that the Sun slider on the Basic Settings panel is turned on. If you increase the Sun slider value, this 

will also increase shadow sharpness.

• Use the Sky Position slider to rotate the HDRI Sky image so that it matches with the ARCHICAD sun 

position of the 3D model. Check the rotation in the preview.

Note: The intensity of sunlight is determined in the Sunlight Settings dialog box, but that setting can be 

overridden (or turned off) in the Light Sources section of the Render settings (Basic) panel. See Light 

Sources.
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Note on Sun Settings in ARCHICAD

• ARCHICAD Sun Position is set in the 3D Projection Settings dialog boxes.

See Set Sun and Camera Positions Graphically.

• The ARCHICAD Sun’s intensity is set in Sunlight Settings (available from the 3D Projection Settings 

dialogs as well as Camera Settings).

See Sunlight Settings.

Using a More Sophisticated Sun with HDRI

1. Turn off the ARCHICAD Sun (In Light Sources, move the slider to Off). 

2. Using the Lamp tool, place a Sun Object into the model. The Sun Object can be positioned manually, has 

more parameters than the ARCHICAD Sun and takes better advantage of Cineware capabilities.

Note that the PhotoRendering Palette’s Environment settings are not reflected in the 3D model, so in order to 

gauge the effect of the Sun Object, you must watch its effect in the Rendering Palette Preview, while moving it 

in the 3D window. 

Cineware Basic Settings: Background Panel

This panel of PhotoRendering Settings is identical for all PhotoRendering engines.

A Background is a plain 2D picture that is placed “behind” the rendering. (You can use it to place the 3D model 

into a context.) 

Note: In contrast, the Environment (available with Cineware) is a genuine 3D environment which covers 

up the background. Thus, if you are using an Environment with Cineware, the Background has no 

purpose.

Use the Background controls to adjust parameters of your rendering’s background image.

• None: This option will give you a non-transparent black-and-white background if you are using the Basic 

or Sketch Engine.

With the Cineware Engine, this setting gives you a transparent background. The same effect can be 

achieved with Cineware Detailed Settings: In the General Options section, enable Generate Alpha 

Channel.

• Colors: Set the color of the sky and the ground by clicking the respective color-picker fields. During the 

photorendering process, ARCHICAD will automatically locate the horizon line of the background to 

correspond with the horizon of the picture.

In parallel projections, if the bottom of the elements is visible, sky color is used; if not, ground color is 

used. The 3D Window can also use the colors specified here. If you just need a single-color background, 

click the Chain icon and set either the Sky Color or the Ground Color.
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• Image: Use this option to browse a background image from the library.

Note: You can save the background picture together with your Project. Use the Save As command to 

save the project in archive format, then check the Include Background Picture checkbox in the dialog 

box.

Position: Use this pop-up to fit the image to the 3D window in several ways:

• Scale to Fit: Rescales the image so it fits within the 3D window.

• Scale to Fill: Rescales the image so that it fills out the full 3D window.
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• Custom: The control switches to Custom whenever you manually reposition the image to the frame: either 

by clicking and dragging the preview, or by filling out new values in the Offset fields.

Blend Image with model using alpha: This checkbox affects renderings done with the Sketch rendering 

engine; it produces a blending effect. (An alpha image used as a Background with Cineware will also have 

this effect.)
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Create Rendered Image

To create a rendered image of the 3D window contents, subject to render size settings:

• Click the render icon at the bottom of the PhotoRendering Settings Palette, or

• Use Document > Creative Imaging > PhotoRender Projection

• The picture window appears, with a progress bar and Stop button, feedback on elapsed rendering time, 

plus the familiar Zoom and Fit in Window window controls.

• In Tab Bar, Picture window tab shows feedback on background rendering progress (Cineware only). A 

checkmark indicates that the render is complete (but not yet opened).

Rendering in progress

Rendering complete, not yet viewed
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• If needed, click Stop, or just close the window to stop the render.

Note: Rendering time varies depending on many factors, including size and complexity of the rendering 

parameters, and hardware capabilities.

Render Marquee Options

By placing a Marquee in the 3D window, you have additional ways to limit the rendered model.

Note: You must use the 2D Marquee option. It will always assume a rectangular shape (even if you draw 

a custom-shaped Marquee.
ARCHICAD 24 Reference Guide 2705



PhotoRendering Visualization
Once you have placed the Marquee, two Render Region commands are available (in the Document > 

Creative Imaging menu and as pop-up options of the Render button of the Render palette):

• Render Marquee Region and Crop: With a Marquee placed, this is the default rendering command. This 

renders and outputs only the marquee region.

• Render Marquee Region: Use this function if you only want to render a small part of the 3D window. It 

will render the scene as a whole, but only the marquee region is rendered in full; the rest of the scene is 

shown as transparent. 

This is useful, for example, if you have already fully rendered the scene, but then change or correct one 

small part of it, and only need to re-render that part.

For either option, the Preview shows only the marqueed region.

Note: If the Render Safe Frame mode is on (see below), then your Marquee will only have an effect to the 

extent that it falls within the Render Safe Frame. If Render Safe Frame is off, then you will render the 

Marquee area regardless.

Render Safe Frame

Turn on this 3D view feature at Document > Creative Imaging > Render Safe Frame.

This is an ARCHICAD mode that affects the 3D window; it displays a frame that indicates which part of the 

model will be rendered. 

This might not be obvious, because the output is affected by the Size setting in Render Settings. Depending 

on the Size settings, your model could be cut off in the render.

See Set Size.

The Render Safe Frame gives you feedback on this and a chance to adjust the Size parameters.
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Note: The Render Safe Frame setting to OFF corresponds to Rendering Settings from ARCHICAD 

versions 17 and older. In this situation, the full content of the 3D window - even content that is not visible 

on screen - will be rendered, with its size determined by Render Size.

This setting (whether Render Safe Frame is applied or not) is noted in the 3D Only panel of View Settings and 

on the 3D Visualization toolbar.

Phases of Rendering with Cineware

Although the Cineware engine is built in to ARCHICAD, it is an add-on that is a separate program component. 

The rendering process involves data exchange between the ARCHICAD model and the engine, in the 

following steps:

1. Converts the 3D model. This occurs in ARCHICAD; this goes quickly, but during this time you cannot 

continue working in ARCHICAD. During this interval, you will see the “Preparing” tag in the top right corner 

of your screen in a separate Progress Window, and also and in the rendering window.

2. Model is sent to the Cineware engine. This takes only a few seconds. To optimize the process, only those 

changes are sent which occurred since the last render.

3. Rendering calculations are underway. During this time, you can keep working in ARCHICAD.

Meanwhile:

– Global Illumination (if applied) is calculated. You can recognize this phase by the sampling on the 

picture, while the lighting of the scene is calculated.

– The rendering itself takes place, recognizable by the squares revealing the image from the inside out, 

in a circular manner. Note that the number of squares corresponds to the number of cores in your 

computer (more cores result in faster renderings)

– Finally, post effects (if applied) are calculated.

4. The Render picture is sent back - this is an ongoing process whose progress you can see in the picture 

window.
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Export to Cinema 4D

The Cineware engine in ARCHICAD does not support multi-pass or net render functions. If you want to 

continue working on your model with additional Cinema4D functions, use the Export to Cinema 4D command 

from the Render pop-up button of the PhotoRendering palette. This will export your model, surfaces and 

rendering settings.

However, to improve the post-processing of images, it is possible to save model pictures with a color depth of 

32-bit per channel in certain image file formats (e.g. TIF).

Note: This color-depth feature is not available if the model picture is created using the Render Region & 

Crop command, which creates the image using only 8 bits per channel.

Limitation on Axonometric 3D Views Handled by the Cineware Engine

The following axonometric views in ARCHICAD are not supported by the Cineware engine:

• monometric axonometry

• custom axonometry (if the Z-axis is not vertical, or if the x-y axes have been distorted)

See Parallel Projection Settings.

If you are working with such a 3D view in the Photorendering environment, you will be alerted to the problem 

and options for resolving it.
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In the Preview window:

The preview window will display a warning notice:

Click Resolve to bring up further information:

The preview will be generated using a “best match,” that is, the view axes will be modified as needed to 

achieve an axonometric view that the Cineware engine can handle.

You have two options here:

• Click Cancel to proceed - the Preview and the 3D view will not be totally identical, because the Preview 

will show a “best match”. 

• Click Update 3D Window to modify the 3D view to match the view in the Photorendering Preview.

During the final PhotoRender

The following dialog box appears:

Choose one of the following options:

• Click Render to continue the rendering process. Cineware will create a rendering using a “best match,” 

that is, the view axes will be modified as needed to achieve an axonometric view that the Cineware engine 

can handle. Thus, the final rendering will correspond to the Preview, but the 3D window remains 

unchanged.

• Click Update 3D Window to modify the 3D view to match the view in the Photorendering Preview. (If you 

are not satisfied with this modified view, you can adjust it as needed.) The rendering will not take place 

until you issue the PhotoRender Projection command again.

• Click Cancel to end the process without rendering. 
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Visualization Extras

You can enhance your visualization output with dynamic content such as fly-throughs or virtual reality. This 

section is devoted to these “extras.”

Fly-Through

Sun Study

Align View
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Fly-Through

Use the Fly-Through feature to create a movie of the project.

Access this function from Document > Creative Imaging > Create Fly-Through.

The Create Fly-Through command will only be active if you have at least one Parallel Projection pre-set, or if 

a Camera path with at least two cameras is active on the Floor Plan.

The Camera path is created by the Camera Tool. Placed cameras along this path are defined as key frames, 

and the number of images between each camera is set by the in-between frames (defined at Camera Path 

Options). Only one camera path will be active at a time (cameras and their markers visible on the Floor Plan). 

Use Camera Tool to select the active Camera path.

The Parallel Projection Pre-sets are created from the 3D Projection Settings > Parallel Projection Settings 

> Pre-Sets: these are defined as key frames, and the number of images between each Pre-set is set by the 

in-between frames.

The frame can be saved from either the 3D window or PhotoRendered, as an animated movie file or as a 

sequence of still images. If you save the Fly-Through as an external movie file, you can view the animation 

with most common movie viewers on any platform. Alternatively, immediately view the animation on screen. 

Note: A large number of frames means a smoother movie but also a much larger file.

Related Topics

Camera Tool Settings

Sun Study

Create Fly-Through

The Fly-Through dialog box allows you to set the source and results of the Fly-Through.

Source

• Click 3D Window to use the 3D Window as the image source and preview window.

Note: Choose a 3D Style and set the current 3D window options before creating the Fly-Through. 

• Click PhotoRendering Window to use the PhotoRendering Window as the image source and preview 

window.
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Note: Choose a PhotoRendering Scene to generate the photorealistic images before creating the Fly-

Through.

Define the route of the Fly-Through:

• Click Parallel Projections Pre-sets to create animated transitions between parallel projections.

Note: Set up at least two pre-set projections. Otherwise, this option is disabled.

• Click Perspectives from Camera Path to create a fly-through animation along the active Camera Path. 

The name of the current Path is shown below.

Note: This option is disabled if fewer than two cameras are defined.

Define the content of the Fly-Through:

• Click Keyframes Only to image key frames without any in-between frames.

• Click With in-between Frames to image both key frames and in-between frames.

• Click All Frames to image all animation frames in the current Path.

• Click Frames to specify a range of animation frames (first and last) for imaging from the current Path.

Note: The numbers shown by default are the first and last frames in the entire animation.

Rebuild Model for Each Frame: If you check this option, ARCHICAD rebuilds the project after each frame 

and creates a new view from the rebuilt model.

Note: This option lets you create additional animation effects, provided that your project contains any 

Library Parts whose appearance changes with every frame. This can be achieved if the Library Part 

parameter is set to change along with the frame number.

Result

Specify the format of the Fly-Through.

• Select a file format, such as a single movie file or set of images.

• Specify the color resolution

Note: Higher color depths result in increased file size.

Remove Redundant Lines: Check this box to remove overlapping lines from the saved image(s).

This option is available if:

• the 3D Engine is the Vectorial Engine (not OpenGL)

• you are exporting particular Frames (not All Frames)

• the chosen file format is either PMK or ARCHICAD 2D Lines. 

Frame Rate: Enter the frame rate per second value here.

Total Length: Length of the animation is displayed in seconds, which divides the total number of frames with 

the frame rate, as an indication of how long the saved animation will be.

Show: Click to process the Fly-Through and preview the images without saving them. You can save the 

resulting animation afterwards by reopening the dialog and clicking Save.

Hint: To preview only a short sequence of frames, adjust the Frames range.
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Note: Collections of 3D parallel projections can also be linked to create a Fly-Through, but these are 

handled differently from perspectives. Only a single set of parallel projections can exist, since the parallel 

projection viewpoint distance is infinite - they cannot be displayed on the Floor Plan.
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Sun Study

To use this feature, use Document > Creative Imaging > Create Sun Study.

Sun Studies allow you to view an entire project or a selected part of it in a real-life situation by choosing a 

geographic location and defining the time period over which you wish to examine lighting and shadow casting.

What you actually see is a series of simple or photorendered 3D images defined by the current 3D Projection 

Settings, the current 3D Style or PhotoRendering Settings, and the Sun Position settings.

The geographic location of your project, including Project North, is defined at Options > Project Preferences 

> Project Location.

See Project Location and Project North.

Note: Based on these data, ARCHICAD uses the Solar Position Algorithm from the National Renewable 

Energy Laboratory (USA) to calculate the solar zenith and azimuth angles.

For information on this algorithm, see: Solar Position Algorithm.

You can either have the resulting animation shown immediately on the screen, or save these images in the 

desired file format and show them in the future using a movie viewer on any platform.

Create Sun Study

All the projections in a Sun Study will be generated in accordance with the current parallel projection or 

perspective view, including Sun Position, defined in the 3D Projection Settings dialog box. 

See 3D Projection Settings.

Source

• Click 3D Window to use the 3D Window as the image source and preview window.

Note: Choose a 3D Style and set the current 3D window options before creating a Sun Study.

• Click PhotoRendering Window to use the PhotoRendering Window as the image source and preview 

window.

Note: Choose a PhotoRendering Scene to generate the photorealistic images, before creating the Sun 

Study.
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Date

• Choose the month and day to begin the Sun Study.

• Choose the length of your sun study: either From Sunrise to Sunset, or enter a specific time span, in 

hours and minutes.

• Interval: Set the interval, in minutes, for taking the Sun Study images during the time range set above.

• Click All Frames to image all animation frames in the current Path.

• Click Frames to specify a range of animation frames (first and last) for imaging from the current Path.

Note: The numbers shown by default are the first and last frames in the entire animation.

Rebuild Model for Each Frame: If you check this option, ARCHICAD rebuilds the project after each frame 

and creates a new view from the rebuilt model.

Note: This option lets you create additional animation effects, provided that your project contains any 

Library Parts whose appearance changes with every frame. This can be achieved if the Library Part 

parameter is set to change along with the frame number.

Result

Specify the format of the Sun Study.

• Select a file format, such as a single movie file or set of images.

• Specify the color resolution.

Note: Higher color depths result in increased file size.

Remove Redundant Lines

Check this box to remove overlapping lines from the saved image(s).

This option is available if:

• the 3D Engine is the Vectorial Engine (not OpenGL)

• you are exporting particular Frames (not All Frames)

• the chosen file format is either PMK or ARCHICAD 2D Lines. 

Frame rate: Enter a frame rate per second value here.

Total Length: Length of the animation is displayed in seconds, which divides the total number of frames with 

the frame rate, as an indication of how long the saved animation will be.

Timestamp

• Check to add this information to the Sun Study (available if saving to a movie format)

• Click Edit to specify the content, appearance and location of the Timestamp.

Watch the Video

Show

Click Show to process the Sun Study and preview the images without saving them. You can save the resulting 

animation afterwards by reopening the dialog and clicking Save.

Hint: To preview only a short sequence of frames, adjust the Frames range.
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The pictures below show the same part of a building at different times of day, including sunrise, one hour later, 

two hours later and in the afternoon.
ARCHICAD 24 Reference Guide 2716



Visualization Extras Visualization
Align View

When using a scanned photograph as the background of your rendering, you may want to fit your ARCHICAD 

model into the photograph’s environment. In the photorendering made from the Camera placed by the 

Document > Creative Imaging > Align View command, the perspective of your building in ARCHICAD will 

match the perspective of the background.

For more information, see PhotoRendering.

For this feature, you need to select two clearly visible vertical segments on the photograph (e.g., the sides of 

a door or a window, two vertical edges of a wall, or two flagpoles), and connect them with their exact position 

in the virtual model or its environment. This is done by connecting each of four points on the placed 

photograph (the tops and bottoms of the two vertical segments) with their position on the Floor Plan, and then 

entering their Z coordinates in the Align View dialog box.

Note: This function is mainly useful in refurbishing, when a photograph of the existing environment is 

available.

Align View: Interior Example

Using the Figure tool, place the scanned image on the Floor Plan at any size or resolution.

For more information, see Figures.

You then have two possibilities for aligning the camera view to the photograph: you can either use existing 

lines or can manually draw lines between the corresponding points of the Floor Plan and the photograph.

Draw Connection Lines Automatically

1. Select the placed photo.

2. Choose the Document > Creative Imaging > Align View command. ARCHICAD will prompt you to make 

six clicks on the Floor Plan with the Pencil cursor, identifying the corresponding points between the picture 

and the plan. The connection lines are drawn automatically.

The Align View dialog box appears, prompting you to enter the height values for the four points.

3. Click OK. The camera will be placed on the Floor Plan on a new path.

Draw Connection Lines Manually

1. Using the Line tool, connect the tops and bottoms of two vertical lines visible on the photograph with their 

location on the Floor Plan (e.g., the sides of a door or a window, two vertical edges of a wall, or two 

flagpoles). This will give you four lines, each extending from a floor plan location to a point on the 

photograph, with the two line pairs connecting where they meet on the Floor Plan.

2. Select the photo and the four lines.

3. Choose the Align View command. The dialog box appears, prompting you to enter the height values for 

the four points.
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4. Click OK to close the Align View dialog box. The camera will be placed on the Floor Plan, on a new Path.

Note: For greater precision, you can enter the horizon of the photograph by simply rotating the picture on 

the Floor Plan so that the horizon is exactly parallel to the unskewed x-axis (otherwise the command will 

calculate the horizon for you). The precision of the result depends largely on that of the entered points, but 

even very careful preparation may result in a Camera that is slightly off position. In this case, set the 

photograph as the background of your 3D window, and fine-tune the Camera’s position in Wireframe or 

Hidden Line mode using ARCHICAD’s 3D navigation tools.

Align View: Exterior Example

Let’s say you have a photograph of a building and its plan as an ARCHICAD file. Place the original photo on 

the Floor Plan of the building. If the picture is placed without any rotation then the horizon is calculated 

automatically as horizontal. You can, of course, override this horizon calculation manually, and enter the 

horizon angle yourself; this is done by rotating the picture on the floor plan. When the picture is rotated with an 

angle other than 90º (or 180º or 270º) on the floor plan, then Align View calculates the horizon by itself, 

otherwise the horizon is assumed to be horizontal. You need to know the height values of two vertical lines 

(four points in all) on the building and their locations on the photo.

Two black hotspots on the Floor Plan and the heights of two distinct points of the building below each are 

shown on the illustration. Zoom in on the photo and place four hotspots at the locations of the four points with 

known height values.

Select the photo and choose Document > Creative Imaging > Align View.
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To link the hotspots, click first on the point on the Floor Plan that corresponds to hotspots on the photo. (In the 

above example, the side of the window on the left where you see the black hotspot with two heights, +2.64 

and -2.21.) Now click the pair of hotspots on the photo, one after the other. Repeat this operation with the 

other point on the plan and the corresponding pair of hotspots. It does not matter which point on the Floor Plan 

you start with. In addition, after marking a point on the Floor Plan, you can select the two corresponding points 

on the photo in either order.

When correctly done, the result will look as shown above, and the Align View dialog will appear.

Type the height of the hotspots in the appropriate fields in the dialog box. The upper points are located along 

the same vertical line as the lower points. In this example, these will be 2.64 and -2.21 meters (left upper and 

lower) and 3.08 and -3.40 meters (right upper and lower). After you click OK, a new camera will be placed on 

the Floor Plan.

Select the original scanned photo to be the background picture in the PhotoRendering Settings dialog box. 

Make sure the width-height ratio of the resulting PhotoRendering is the same as that of the original photo. You 

can also modify the size of the photo to suit the size of your PhotoRendering window.

Note: You cannot crop the photo. If you must, crop it in a way that the original proportions of the photo 

stay the same (i.e. cover a part of the photo with a solid white fill), because Align View needs the original 

proportions of the picture to locate the original target point of the photo. The view will not be aligned 

precisely if the proportions of the photo have been changed.
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For example, if you have a scanned picture of 1200 x 900 and you want a 3D window or PhotoRendering 

window image of 600 x 450, you would reduce the size of the background photo to 50 percent in the 

PhotoRendering Settings dialog box. (You can choose this same background in the View > 3D View Options 

> 3D Styles dialog box: in the Background panel, check “As in PhotoRendering”.) By selecting the created 

camera and generating a 3D View or a photorendering, you will see the result - the building is accurately 

placed in the existing environment.
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GRAPHISOFT BIMx

GRAPHISOFT BIMx lets you create an interactive walk-through model out of your ARCHICAD project. The 

functions needed to create and share a BIMx model are included in ARCHICAD.

The BIMx model is known as a “Hyper-model” (file format .bimx). The BIMx model can contain the full 

documentation of your ARCHICAD project: the 3D model, plus views, layouts and camera paths. 

Open and explore the BIMx model content

• on the free BIMx Desktop Viewer, installed with ARCHICAD

• on the free BIMx mobile app on any mobile device

• on the more sophisticated BIMx PRO mobile app, with extra features 

Share the BIMx model

• to the BIMx Model Transfer Site at bimx.graphisoft.com

Related Topics:

Create BIMx Hyper-Model

Architect Credits in BIMx

BIMx: Notes on Model Data, Size, Textures and Shadows

Read More:

GRAPHISOFT BIMx page

Tech Notes on BIMx
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Create BIMx Hyper-Model

The BIMx model is known as a “Hyper-model” (file format .bimx). The BIMx model can contain the full 

documentation of your ARCHICAD project: the 3D model, plus any views, layouts and camera path. However, 

depending on the application with which you explore the Hyper-model, you may only be able to access the 3D 

content.

You may need to optimize the ARCHICAD model before saving it in BIMx format to ensure the best possible 

performance.

See BIMx: Notes on Model Data, Size, Textures and Shadows.

The BIMx Hyper-model file is created in ARCHICAD. To create a Hyper-model, you must set up a Publisher 

Set in ARCHICAD, and publish it in Hyper-model format. 

There are two ways to do this:

• Use ARCHICAD’s Publisher: This method is recommended if you are familiar with Publisher Sets, and if 

you can manually optimize your model to limit model size (this may be important depending on the 

capacity of the mobile device to be used for viewing the BIMx Hyper-model).

If you use the Publisher’s Organizer mode, you can choose specific items from the Publisher Set to be 

published as the Hyper-model.

• Use the BIMx Hyper-Model Wizard: This method is launched through File > Publish BIMx Hyper-

Model command. This takes you through a wizard, which helps you configure a Hyper-model Publisher 

Set in a few easy steps.

This is the easier method if you are unfamiliar with Publisher Sets. It also includes a built-in option to help 

you optimize model size for better viewing performance on mobile devices.

When creating the Hyper-model with the wizard, you cannot pick and choose among individual layouts: 

you can include all Layouts, no Layouts, or a single Layout Subset. (You can, of course, edit the Publisher 

Set content later, using the Publisher’s Organizer mode).

You can also use the wizard to republish an existing Hyper-model Publisher Set, with one click.

See also Republish Hyper-model.

Both methods are detailed below:

Create BIMx Hyper-Model from Publisher

Create BIMx Hyper-Model Using a Wizard
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Create BIMx Hyper-Model from Publisher

You may need to optimize the ARCHICAD model before saving it in BIMx format to ensure the best possible 

performance.

See BIMx: Notes on Model Data, Size, Textures and Shadows.

Step 1: Create Publisher Set

Use the Organizer mode of the Publisher to create the desired Publisher Set: assemble the combination of 

views (including camera path), Layouts or subsets, and the 3D view(s) you wish to include in the Hyper-

model.

See also Publisher Function.

You can optimize 3D view content to fit your particular publishing needs - for example, using Partial Structure 

Display, Layer Combinations or Marquee to limit the view(s) as needed.
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Step 2: Set Publishing Properties

In the Publishing Properties dialog box, choose how you would like to publish the Hyper-model: either Upload 

BIMx Hyper-model or Save.

Upload BIMx Hyper-model

Choose this publishing method to upload the file to the BIMx Model Transfer Site at bimx.graphisoft.com. 

• Sign in: To upload to BIMx Model Transfer, click Sign in and enter your GRAPHISOFT ID (GSID), if you 

are not signed in already. 

If you don’t have a GSID, click Sign up from the appearing dialog.

• Upload to: Choose company’s or your own storage location.

• To this folder: Choose whether to upload to a Public or a Private Folder. If you choose Private Folder, 

you can optionally password-protect the file. Available storage space is shown at left.

Note: The Private Folder option is available only in your company storage location, to users who have a 

Software Service Agreement (SSA) for ARCHICAD.

•  Name: Optionally rename the Hyper-model file.

• Save local copy: Check this box and enter a destination file path if you wish to save a local copy of the 

Hyper-model in addition to uploading it to the BIMx Model Transfer site.

See also Info Set and Architect Credits (below) for information on these options.
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Save BIMx Hyper-model

Choose the Save files publishing method to save the Hyper-model to the selected destination path.

• Choose Create single file to access the BIMx Hyper-model format.

• From the Format pop-up at the bottom of the dialog box, choose BIMx Hyper-model.

• Path: Enter a destination file path.
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Info Set

Use the Info Set pop-up to control which model element information should be available to viewers of the 

BIMx model on a mobile device:

• The Classification and Properties option uses the data defined for each element in the Classification 

and Properties panel of its Element Settings dialog box.

• Choose None if you don’t want the recipient to view any element information (e.g., if the recipient will just 

be viewing the model geometry as a whole, and doesn’t need any details on the various component 

elements).

• Select Schedule: Click this to open a pop-up where you can choose one or more of your Element 

Schedule Schemes. The BIMx model will use the data defined in the selected schedule(s).

Since you can choose one or more Schedules here, you may find it useful to divide the exported custom 

data into several Schedules (for example, by element type). This speeds up the update and publishing 

process, and makes it easier to manage data.
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–  IES Default for BIMx output option uses the data defined in an Interactive Element Schedule of this 

name. This schedule is provided in the factory-default ARCHICAD template (for the International 

market), but you are free to modify the scheme as needed, or to choose any other schedule(s).

Architect Credits

 Use Architect Credits in BIMx Hyper-models

Check this box to display information about the project designer when the Hyper-model is opened in a BIMx 

application. 

You must first define this information in ARCHICAD at File > Info > Project Preview > Architect Credits in 

BIMx.

See Architect Credits in BIMx.

Step 3: Set BIMx Export Options

Note: BIMx Export Options is also available from the BIMx Hyper-model Wizard.

You can set separate Export options for each relevant Publisher Set item: the 3D view(s) and for the Camera 

view or Camera Path, if any.
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Export Options for a 3D View

Select the 3D view from the list of Publisher Set items in the Publisher, then click Options.

Global Illumination

Optionally, check the box to generate Global Illumination: this provides a highly realistic view, but increases 

rendering time. Note that Global Illumination consumes additional memory.

Select Background

Choose a background to use while exploring the BIMx model:

• SKYBOX (default BIMx Sky image)

• WHITE

• GREY

• BLACK

• GRADIENT

Gallery Options for Camera Path

If the Publisher Set contains a camera path, BIMx Export Options includes Gallery options.
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Note: If you are using the BIMx Hyper-model wizard, you must select a camera in the Floor Plan in order 

to include it in the Publisher Set. 

– Add cameras as separate gallery items: A separate gallery item (an image viewpoint) will be 

created out of each camera in the current ARCHICAD camera path

– Create a single movie for the gallery: A single movie-type gallery item will be created out of the 

current ARCHICAD camera path

– Limit navigation to gallery items: Navigation of the resulting BIMx project will be limited to just the 

views and clips you save to the Gallery (instead of the full project)
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Step 4: The Publish Process

In Publisher, select your Publisher Set and click Publish.

The Publisher process dialog box appears:

If you are uploading the BIMx Hyper-model to the BIMx Model Transfer site, the BIMx Uploader will also 

appear to track the status of the upload. Use this dialog box to stop the upload or re-start the process as 

needed.

Note: You can cancel Global Illumination calculation, without interrupting the overall Publishing process. 

To cancel, select the 3D view in the Publisher dialog box. The small red X will cancel the Global 

Illumination calculation, but the 3D view will still be saved to the Hyper-model - without Global Illumination.
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If the process encounters any problems, you are notified of the problem. Click Details to see more information.
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Create BIMx Hyper-Model Using a Wizard

Use this method (File > Publish BIMx Hyper-model) to create a new Hyper-model Publisher Set or republish 

an existing one, using a wizard.

Start by setting up the desired view in the 3D window. This will be the basis of your Hyper-model. 

If you want to include a gallery of camera positions in the BIMx model, place cameras on the Floor Plan and 

select one.

You may need to optimize the ARCHICAD model before saving it in BIMx format to ensure the best possible 

performance.

See BIMx: Notes on Model Data, Size, Textures and Shadows.

1. Use the File > Publish BIMx Hyper-model command.

2. In the appearing dialog box, choose Create new publishing set.

3. Choose a publishing method: Upload to BIMx Model Transfer Site or Save file.

– Upload to BIMx Model Transfer Site will upload the file to the site at bimx.graphisoft.com. (You must 

register before using this site.)
ARCHICAD 24 Reference Guide 2732

https://bimx.graphisoft.com


GRAPHISOFT BIMx Visualization
4. Hyper-model name: Optionally, use this field to rename the Hyper-model.

Note: The Hyper-model will include the ARCHICAD Project Info and Project Preview data.

5. 3D Content: Choose an option to filter the model’s 3D content:

– As in the 3D Window: Use the current view

– The Hide Objects and Keep Structural Elements only options limit the elements included in the 3D 

view, thus reducing file size. This may be important depending on the capacity of the mobile device to 

be used for viewing the BIMx Hyper-model.

See also BIMx: Notes on Model Data, Size, Textures and Shadows.

6. Layouts: Choose the Layout content to include in the BIMx Hyper-model: Entire Layout Book; No Layouts; 

or a selected subset.
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– Click Choose a Subset to select one Layout Book Subset.

Note: When using this wizard, you cannot add or remove individual Layouts to the new Publisher Set. To 

do that, you must use the Publisher-Organizer. 

7. Click Options to open BIMx Export Options.

For details, see Step 3: Set BIMx Export Options.

8. Click Next.
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9. Set the options depending on the publishing method you choose (either Upload or Save). 

– If you are uploading the BIMx Hyper-model:

- Choose whether to upload to the Public Domain, or to a Private Folder. If you choose Private 

Folder, you can optionally password-protect the file.

– If you are saving the BIMx Hyper-model:

- Enter a destination file path.

- Optionally, check Start BIMx after save to open the BIMx model in BIMx Desktop Viewer.

10. Click Publish.

For details, see Step 4: The Publish Process.
ARCHICAD 24 Reference Guide 2735



GRAPHISOFT BIMx Visualization
Republish Hyper-model

See also Republish Selected Items for BIMx.

 To republish all of an existing Hyper-model, do one of the following:

• Select the Hyper-model from the Publisher, and use the Publish button to republish part or all of it.

• Use File > Publish BIMx Hyper-model. In the appearing dialog box, choose the desired Hyper-model.

– Click Publish to republish it unchanged; or

– Click Organizer to access the Organizer and modify the contents of the Publisher Set. In this case, 

you will follow the steps detailed at: Create BIMx Hyper-Model from Publisher.
ARCHICAD 24 Reference Guide 2736



GRAPHISOFT BIMx Visualization
Republish Selected Items for BIMx

When republishing a Hyper-model, you may wish to republish only certain items, to save publishing time. 

There are several ways to do this:

Publish Selected Items to merge them with the previous Hyper-model

If you choose Selected Items in Publisher, ARCHICAD will publish only the selected items (layouts) and will 

merge these layouts into the previously published full hyper-model at the location you previously saved it.

You can then open this revised Hyper-model. If you open it on a mobile device, the BIMx app will recognize 

the updated contents. You will be notified of the changed items, and you can update the corresponding items 

of your existing Hyper-model on BIMx, one by one.

This method reduces publishing time (republishes selected items only), but you have to move the whole 

Hyper-model to the BIMx app.

Publish Selected Items as a New Hyper-model

Before publishing, remove the previously published Hyper-model from its saved location. In the Publisher, 

choose Selected Items. ARCHICAD will publish only the selected items as a new, smaller Hyper-model, in 

place of the one you deleted (or moved).

If you open this revised Hyper-mode on a mobile device, the BIMx app will recognize the updated contents. 

You will be notified of the changed items, and you can update the corresponding items of your existing Hyper-

model on BIMx, one by one.

This method reduces publishing time (republishes selected items only), and you only have to move a 

relatively small Hyper-model to the BIMx app.
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BIMx: Notes on Model Data, Size, Textures and Shadows

These tips are intended for optimizing the ARCHICAD model before saving it in BIMx.

The ARCHICAD Model Unit preference (e.g. Imperial or Metric) will be used by default when the BIMx model 

is opened in a viewer application.

If your BIMx model is going to be viewed on hand-held devices such as the iPhone, further optimization of the 

model may be desirable to improve performance.

For more information, consult the BIMx page from GRAPHISOFT’s website at this link.

Use Element ID Fields (For BIMx Hyper-models in Teamwork)

Each ARCHICAD element has an ARCHICAD ID, defined by default in its Tool Settings dialog box, under the 

Classification and Properties Panel. Make sure that your ARCHICAD model elements include this Element ID 

data for best results in BIMx (if you are in a Teamwork environment).

Background: In a Teamwork context, BIMx provides smart feedback on multi-selection, identifying each 

element by its ID. If the ARCHICAD model does not include this element ID data, BIMx cannot provide ID-

based feedback on the selected elements.

Limit “Extra” Model Content

If you run into memory limits while creating the BIMx model (for example, during Global Illumination 

initialization), try eliminating or reducing the following model components. This will help optimize model size 

and improve BIMx performance:

• furniture (e.g. chairs)

• GDL objects (e.g. door handles)

• other objects originating from Add-Ons (e.g. trees, cars, people)

• other non-essential elements

Typically, such “extra” elements devour a great deal of memory. A single chair can require more memory than 

all the walls in the project.

Texture Formats

BIMx supports the following surface texture formats: jpg, bmp, tif, tga, png, gif.

If a texture would fail to load for any reason, the object that uses it will be drawn with the material color 

instead.

Alpha Channel Texture Effects

BIMx supports alpha channel texture effects with 32-bit tif, tga and bmp images. For the alpha channel effects 

to be detected inside BIMx, you must enable transparency in the ARCHICAD material/texture properties.

However, transparent objects are not necessary visualized using the correct display order - to do so would put 

a big dent in your performance.

Shadows

Shadows in BIMx are rendered using the OpenGL ARB_shadow extension. It works by rendering the scene, 

from the sun’s point of view, into a texture map. This texture map is then projected onto the scene and 

OpenGL will determine whether a pixel is in shadow or not. Larger texture maps will produce higher quality 

shadows. The maximum size is determined by your graphics card (the graphics memory available and the 
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maximum texture size allowed). Some graphics cards may have 256 MB on-board memory, but only allow a 

maximum texture size of 4096 x 4096. A shadow texture is typically 24-bit.

• 8192x8192 shadow texture will consume 200 MB of video memory.

• 4096x4096 shadow texture will consume 50 MB of video memory.

• 2048x2048 shadow texture will consume 12.5 MB of video memory.

BIMx will automatically try to generate the largest possible shadow texture, starting with 8192x8192. Next, if 

this fails, it will try half that size, and so on.

To turn off the sun shadows, set sun shadow brightness to a value near zero.

Sun Shadow Artifacts

Depending on the amount of available video card memory and the (physical) size of your model, the sun 

shadows may display artifacts. This is due to the fact that BIMx cannot fit the whole model into the shadow 

map with good quality. Smaller models and more video graphics memory will improve the result. Global 

Illumination produces better shadows, which however are static.
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Energy Evaluation

Integrated in the ARCHICAD environment, Energy Evaluation offers an easy-to-use workflow for performing 

dynamic building energy calculations on projects of any size. 

Using the same dynamic building energy simulation technology as the standard compliant EcoDesigner STAR 

for ARCHICAD add-on, Energy Evaluation is an energy evaluation tool that enables architects to monitor and 

control all architectural design parameters that influence building energy performance. The Energy Evaluation 

tool performs reliable dynamic energy evaluation at all stages of the design process, so that architects can 

make informed decisions regarding their buildings’ energy efficiency. Including Energy Evaluation in the 

architectural design workflow makes it easy to create projects that conform to or even exceed energy 

efficiency regulations and comply with building energy standards.

• Create and visualize multiple thermal block Building Energy Model (BEM) geometry directly from the 

ARCHICAD BIM using the Energy Model Review Palette.

• Use the Model-Based Solar Study to determine the intensity of solar irradiation on each external glazed 

opening individually, on every hour of the reference year - including the shading effect of the surroundings 

(buildings, plants etc.) and shading devices.

• Export the ARCHICAD model geometry and material property data via IFC or as an XLS spreadsheet, to 

be processed by external energy analysis applications

• Run the dynamic energy simulation, using the VIP Core engine that is integrated in ARCHICAD, to 

produce an Energy Performance Report. This report provides information on the project’s yearly energy 

consumption, carbon footprint and monthly energy balance.

The details of the Energy Evaluation feature are described in these sections:

Energy Evaluation Workflow: Overview

General Settings for Energy Evaluation

Energy Evaluation: Direct BIM to BEM

Energy Model Review Palette

Additional Data Assignment and Input

Energy Performance Evaluation
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Energy Evaluation Workflow: Overview

This section summarizes the steps of the Energy Environmental Workflow.

Prepare the Architectural BIM for Energy Evaluation

For successful evaluation, the building model must contain at least the enveloping structures and 

fenestration, as well as all major internal structures that represent significant heat storage mass. 

Furthermore, ARCHICAD zones must be placed in every conditioned space of the building, since the model’s 

geometry analysis is based on these ARCHICAD zones.

The Energy Model Review works only on visible elements, so you must define an ARCHICAD view dedicated 

to the energy model. Use layer visibility to achieve the view you need. Make sure that zones are visible.

Note: Marquee selection does not filter building elements for the purpose of Energy Model Review.

Define Thermal Blocks

Spaces are represented by 3D Zones in the ARCHICAD Building Energy Model. For Energy Evaluation 

purposes, you will group these Zones together in “thermal blocks”, using the Thermal Blocks page of the 

Energy Model Review palette (Design > Energy Evaluation > Energy Model Review).

Thermal blocks are a collection of one or more rooms or spaces in a building that have similar orientation, 

operation profile and internal temperature requirements (also called thermostat control requirements). Zones 

need not be contiguous to be combined within a single thermal block.

Automatic Model Geometry and Material Property Analysis

After the thermal blocks have been defined, the architectural model (BIM) is transformed into a Building 

Energy Model (BEM) by the automatic model geometry and material property analysis functionality of 

ARCHICAD. This analysis does the following:

• analyzes the visible structures and openings according to their orientations and positions relative to zones 

and generates the space boundaries on them. (Space boundaries describe the building’s geometry in a 

format that works for energy simulation input.)

• populates the space boundary lists. Structures and Openings are automatically listed with their properties 

that are relevant for the energy evaluation.

Assign and Input Additional Data to Complete the BEM

The Energy Model Review palette is the main user interface of ARCHICAD’s Energy Evaluation function. 

Use the palette to edit the input data for the building energy simulation, as well as to add information:

• Assign Building Systems and Operation Profiles to Thermal Blocks

• Space boundary property settings

Note: Most space boundary properties are extracted from the architectural model by the automatic model 

geometry and material property analysis functionality of ARCHICAD. Space boundary property settings 

allow users to fine-tune this data and add information that does not come directly from the architectural 

building model.

• Structures property settings: Use the U-value calculator or U-value override functionality and the 

Infiltration and Surface material settings to define the physical properties of the opaque space boundaries 

listed on the Structures list.
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– Openings property settings: Assign Frame and Glazing performance data to fenestration from the 

Openings catalog. Select Shading devices from predefined databases to complete the Openings list.

Besides displaying the Structures and Openings list, the user-friendly Energy Model Review palette also 

contains links to dialogs.

These Additional Data Input dialogs enable quick definition of the following parameters needed to run the 

Energy Evaluation:

• Environment Settings: Provides links to the Project Location, Climate Data and Wind Protection dialogs. 

Grade level, Soil and Surrounding surface types are also set here.

• Operation Profile: Select the building’s function(s) to assign related Internal temperature and heat gain 

profiles in the Operation Profile dialog. If needed, customize an Operation Profile to fine-tune occupancy 

according to local regulations or to match actual building usage.

• Building Systems: Provide information essential for the energy calculation, regarding the building’s MEP 

Systems (for heating, cooling, ventilation, hot water generation)

• Finally, in order to enable primary energy, CO2 emission and energy cost calculations, define the Energy 

Source Factors and Energy Costs, using the dedicated dialogs.

Evaluate Building Energy Performance

Click the Start Energy Simulation button of the Model Review palette to start the Energy Performance 

Evaluation of your project. The built-in, certified VIP-Core engine executes the dynamic energy simulation 

that calculates the building’s hourly energy balance and outputs a Building Energy Evaluation Report. The 

report contains information such as the project’s energy-related structural performance, yearly energy 

consumption, energy balance and carbon footprint.

Read More on Help Center
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General Settings for Energy Evaluation

This section contains information on setting your general preferences for the Energy Evaluation function.

Units

Energy Evaluation uses the calculation units defined by you in ARCHICAD, at Options > Project 

Preferences > Calculation Units & Rules. Thus, Energy Evaluation uses the same units as the ARCHICAD 

Project to which it is applied.

Additional unit setting options:

• When defining components of Heating and Ventilation systems in the Building Systems dialog box, 

choose either Celsius or Fahrenheit for the water temperature. 

This way, for example, you can set the temperature scale of Hot water generation independently of other 

units. (This can be useful if your country uses metric dimensions and Fahrenheit temperatures 

concurrently.)

• On the U-value (R-value) Calculator and the U-value (R-value) Override panels, click the pop-up to 

alternate between U-value and R-value as needed.

General Modeling Conventions

For best results with Energy Evaluation, follow these conventions of building energy modeling in ARCHICAD: 

• Use the Mesh tool to model the building site’s grade level, especially if it is uneven. 

• Do not use multiple separate parallel walls (or slabs or roofs) to model composite structures. If such 

constructions exist in the building model, make sure that only one of the parallel structures is visible in the 

energy model, and that the adjacent Internal Space Zones touch that structure.

• Use fills consistently within your project: a particular fill should always indicate the same single building 

material or composite.

See Energy Evaluation: Direct BIM to BEM for more details on modeling guidelines.

Teamwork Settings

If you are working on a Teamwork project, you must first reserve the Energy Model Review palette using the 

control light interface on the palette itself, or the dialog boxes that open from it.
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Customize Energy Model Review Colors

To define or change the 3D default colors for Structures and Openings listed in the Model Review palette: go 

to Options > Work Environment > On-Screen Options, and use the Energy Evaluation Model Review 

Colors panel:

A quick way to access these controls is by selecting Customize Model Review Colors from the pop-up to the 

right of the Show in 3D button, at the top of the Model Review Palette:
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Energy Evaluation: Direct BIM to BEM

To be able to perform a successful evaluation with Energy Evaluation, you must create the virtual building 

model in ARCHICAD. The more detailed the model, the more accurate the calculation results will be. For 

successful evaluation, you should model, at minimum, the enveloping building structures and openings as 

well as the major internal structures that represent significant heat storage mass.

Topics in this section:

Internal Space Zones for Energy Evaluation

Building Energy Model View

Automatic Model Geometry and Material Property Analysis in Energy Evaluation
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Internal Space Zones for Energy Evaluation

Create a zone in every conditioned space of the building, using exclusively the Inner Edge zone construction 

method. Energy Evaluation is not compatible with zones created with the Manual construction method. The 

zones must be directly adjacent to the surrounding elements’ surfaces, therefore the Reference Line zone 

construction method is not applicable for energy modeling either.

ARCHICAD zones inside the project’s internal spaces

3D Zone Boundaries

When placing zones on the floor plan, make sure that they are completely enclosed by zone boundaries. 

• All ARCHICAD walls (including profiled curtain walls) automatically behave as zone boundaries. 

• When using Slabs as bottom or top zone boundaries, make sure that the zone level and/or height are set 

so that the horizontal zone surface(s) touch the inner edge of the Slab(s).

• If Roofs, Meshes, Shells, Morphs or ARCHICAD library objects are used as zone boundaries, an 

additional interaction is required besides just creating the zone. In such situations:

– Draw the zone manually, making sure that it extends beyond the Roof, Mesh, Shell zone boundary 

elements completely.
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– Use a command from the Design > Connect menu, such as Trim Elements or Solid Element 

Operations, to shape the zone with the selected zone boundaries and establish the connection 

between them. 

2D Zone Boundaries

It is also possible to define lines on the floor plan as 2D zone boundaries. Select the line(s) you want to 

behave as zone boundaries and tick the Zone Boundary checkbox on the Line Selection Settings dialog.

There are a number of modeling scenarios that make it necessary to define lines as Zone Boundaries. For 

example:

• Modeling perimeter zones in Core and Shell projects 

• Atria in buildings

• Spaces that contain several, dramatically different floor and/or roof levels

Attic space with different floor and roof levels

Walls as zone boundaries Walls and line as zone boundaries
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Update Zones

Use the Update Zones command on the left upper corner of the Energy Model Review palette after altering 

the geometry of zones or zone boundaries. This will ensure that the energy model reflects the up-to-date state 

of the ARCHICAD model.

Zone Modeling Conventions

• Model multistory internal spaces (e.g. staircase blocks, atria) with separate zones on every ARCHICAD 

Story.

Staircase - modeling of multistory internal space

• Adiabatic walls are walls of the building shell that separate heated spaces. They are called adiabatic due 

to the absence of heat transfer through them. A typical example is a fire wall separating row-houses or 

other adjacent buildings. 

In such situations, model the surfaces of the neighboring building that are adjacent to your building, with 

thin ARCHICAD zones. Use a separate zone on every story of your project. 
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Building Energy Model View

The Energy Model Review of the Energy Evaluation feature only works on visible elements; therefore it is 

necessary to define an ARCHICAD view dedicated to the energy model. Use layer visibility to achieve the 

view you need. Make sure that zones are visible.

Note: Marquee selection does not filter building elements for the purpose of Energy Model Review. 

Building Energy Model View

The Building energy Model View must display all the parts of the building that you want to include in the 

energy evaluation (internal space zones, building shell elements, internal structures with significant thermal 

mass, site mesh) and none that you do not (furniture, zones other than those representing the conditioned 

spaces of the building, separate parallel ARCHICAD elements representing composites).
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Automatic Model Geometry and Material Property Analysis in Energy 

Evaluation

Space Boundary Generation

Just select Design > Energy Evaluation, and the Automatic model geometry analysis function automatically 

turns the ARCHICAD building information model (BIM) into input for building energy modeling.

Before the Energy Model Review palette appears, ARCHICAD analyzes the visible structures and openings 

according to their orientations and positions relative to the zones that represent the internal spaces, then 

automatically generates the space boundaries. These space boundaries make up the contents of the 

Structures and Openings lists of the appearing Energy Model Review palette.

Note: When Energy Evaluation is selected for the first time on a project, ARCHICAD automatically puts all 

visible Zones into a default Thermal Block. This represents a single thermal block (simplified) building 

energy model. 

See Create Thermal Blocks for details on how to define a detailed energy model that contains multiple thermal 

blocks.

Update Energy Model Review

Use the Update Energy Model Review command on the upper left corner of the Energy Model Review palette 

after redefining Thermal Block data, or after altering the geometry of ARCHICAD Structures or Openings 

boundaries. This function regenerates the space boundaries, ensuring that the energy mode reflects the up-

to-date state of the ARCHICAD model.
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Energy Model Review Palette

The Energy Model review palette is the main user interface of ARCHICAD’s Energy Evaluation. It contains 

three tab pages that display input data for the building energy simulation. Use the tab pages to edit as well as 

to add information to this calculation input data.

Besides the three main tab pages, the Energy Model Review palette also contains:

• General function buttons:

– BEM visualization options

– BEM update options

– Tab page view switch

– Links to the Additional Energy Simulation Input dialogs

• Tab-page specific functions: see the following sections for details.

List and Tree Tab Page View Options

Thermal Blocks Tab Page

Structures Tab Page

Openings Tab Page

Building Energy Model Visualization
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List and Tree Tab Page View Options

Use the “Show Energy Model in list or tree view” function buttons of the Energy Model Review palette to 

toggle between the two available tab page view options.

These view options display the energy simulation input data in two different ways, allowing for a wide variety 

of user interactions. Most interactions (data assignments, overrides, adjustments etc.) can be performed in 

both views, while others are view-specific (e.g.: rearranging data according properties is only possible in List 

View, drag-and-dropping zones into thermal blocks is only possible in Tree View).
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Thermal Blocks Tab Page

For Energy Evaluation purposes, you will group ARCHICAD Zones together in “thermal blocks”. Thermal 

blocks are a collection of one or more rooms or spaces in a building that have similar heating or cooling 

requirements - also called thermostat control requirements. Thermal blocks are represented by groups of 3D 

Zones in the ARCHICAD Building Energy Model.

The Thermal Blocks page of the model Review Palette lists thermal blocks with all their relevant properties.

In Tree View, users can see the Zones that make up the thermal blocks as well, if they select the dropdown 

arrow by the thermal block’s name. If a thermal block is selected, its properties are displayed on the bottom of 

the page, in the Thermal Block Properties section.
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Create Thermal Blocks

Use the Add new Thermal Block button to create a new thermal block. Its name and ID can then be entered 

in the list. 

To assign Zones to the thermal block:

• Drag and Drop 3D Zones into Thermal Block (in Tree View)

• Use Find and Select to Select Zones and Add Zones to Thermal Block (in List View)

Note: Zones need not be contiguous to be combined within a single thermal block.

Thermal Blocks Data

The Thermal Blocks tab page can be viewed in either table or tree form. There are two kinds of data types on 

this page:

• ARCHICAD model data types (coming directly from the BIM): 

In case of Thermal Blocks: Number of Zones, Floor Area, Volume, Uncovered Area

• Additional data types (assigned to the Thermal Blocks list entries by the user): 

Thermal Block ID and Name, Operation Profile, Building Systems. 

See Thermal Block Property Settings (Energy Evaluation).
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Structures Tab Page

The Structures tab page of the Energy Model Review palette lists the space boundaries on the building’s 

external and internal structures, with all their physical properties that are relevant for the energy simulation. 

The opaque panels of curtain walls also appear on the Structures list.

The Tree View of the Structures Page shows exactly which External and Internal Structures belong to which 

thermal block in an easy to understand, graphic way. If a structure is selected, its properties are displayed on 

the bottom of the page, in the Structure Properties section.
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Structures Data

 There are two kinds of data types:

• ARCHICAD model data types (coming directly from the BIM): 

In case of Structures: Thermal Block assignment, Orientation, Space Boundary Category, ARCHICAD 

Element Type, Complexity, Name, Area, Thickness, Renovation Status

• Additional data types (assigned to the Structures list entries by the user):

U-value/R-value, Infiltration, Solar Absorptance, Correction-area

See Structure Property Settings (Energy Evaluation).

Show or hide any of these data types as needed:

• In tree view: right-click any Structure Properties list item to show or hide the data types

• In list view: Click the arrow pop-up at right to show or hide the table columns

One Structures List entry usually consists of multiple Space boundaries. All Space boundaries that are 

identical in all their ARCHICAD model data types are aggregated in a single Structures List entry and appear 

with the sum of their areas on the list.
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In list view, you can rearrange the list according to any property by clicking on the property’s headline button.

Area Threshold

To filter out structure or opening list entries of negligible area, enter a value in the “Area Threshold” field at the 

bottom of the Structures list. Entries whose area is smaller than this value will not be listed, and will not be 

considered by the calculation engine. (If you later lower this area threshold, the filtered-out structures will 

reappear as applicable.)

Setting an Area threshold will help you filter out small areas that are insignificant for energy evaluation, 

resulting in a more manageable Structures list.

Structure Area Correction

The Structures tab page of the Model Review palette has a data type for “Correction-area”. For any listed 

Structure, you can adjust the area by entering a positive or negative value in this column. The value of this 

item in the “Area” column will be adjusted accordingly; this corrected Area value (if positive) will be used by 

the calculation engine.
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Openings Tab Page

The Openings tab page of the Energy Model Review palette lists the space boundaries on the building’s 

external openings, with all their physical properties that are relevant for the energy simulation.
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The Tree View of the Openings page shows exactly which Doors, Windows and transparent Curtain Wall 

panels belong to which thermal block in an easy to understand, graphic way. If an Opening is selected, its 

properties are displayed on the bottom of the page, in the Opening Properties section.

Openings Data

The Openings List can be viewed in either table or tree form; each column represents a data type. There are 

two kinds of data types:

• ARCHICAD model data types (coming directly from the BIM):

In case of Openings: Thermal Block assignment, Solar Analysis results, Orientation, ARCHICAD opening 

type, Area (Glazed, Opaque, total), Frame perimeter, Renovation Status.

• Additional data types (assigned to the Openings list entries by the user):

In case of Openings: Total and Direct Solar Transmittance, U-value (for glazing, opaque areas, perimeter 

and overall), Perimeter Psi value, Shading device, Infiltration

Show or hide any of these data types as needed:

• In tree view: right-click any Structures Properties list item to show or hide the data types

• In list view: Click the arrow pop-up at right to show or hide the table columns
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In list view, you can rearrange the list according to any property by clicking on the property’s headline button.

For each Openings list item, the following data are shown in columns:

• Thermal Block Assignment

• Orientation and ARCHICAD opening type

• Solar Analysis result

See Solar Analysis.

• Data describing the transparent panels of Openings:

- Glazed area, frame perimeter

- Glazing U-value

- Total solar transmittance (TST): The percentage of incident solar radiation transmitted by an object 

which includes the Direct Solar Transmission plus the part of the Solar Absorption reradiated 

inward. TST divided by 100 equals Solar Heat Gain Coefficient (SHGC) or g-value.

- Direct solar transmittance (DST)

• Data describing the opaque panels and frames of Openings:

- Opaque area, perimeter, U and Psi-values

- Infiltration: air permeability of the selected Opening (typically occurs around the perimeter, at the 

frame to wall connection)

• Shading Device assignments

• Renovation status
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Show Uniform Items as a Single Entry

Use this checkbox in the bottom left corner of the Openings page in list view to make every Space boundary 

which is identical in terms of all ARCHICAD model data types appear in a single Openings List entry, with the 

sum of their areas on the list.

Total Area Threshold

To filter out opening list entries of negligible area, enter a value in the “Total Area Threshold” field at the 

bottom of the Openings list. Openings whose total (opaque + glazed) area is smaller than this value will not be 

listed, and will not be considered by the calculation engine. (If you later lower this area threshold, the filtered-

out openings will reappear as applicable.)

Setting a Total Area threshold will help you filter out small areas that are insignificant for energy evaluation, 

resulting in a more manageable Openings list.

Openings Area Correction

Two columns are available for manually correcting the Opening area: the “Correction - Glazed area” and 

“Correction - Opaque area.” Enter a positive or negative value in this column. The value of this item in the 

“Area” column will be adjusted accordingly; this corrected Area value (if positive) will be used by the 

calculation engine.

Solar Analysis

The Openings page of the Model Review Palette allows for the individual analysis (listing, editing and 

visualization) of every transparent space boundary of the ARCHICAD building model. This is necessary to 

take advantage of the Model-Based Solar Irradiation Study, with which solar gain through each individual 

transparent element of the building envelope may be precisely determined. This advanced tool enables 

architects to strategically determine the place of each individual piece of fenestration with respect to the 

surroundings and the building’s geometry, in order to utilize the benefits yet avoid the unwanted effects of 

solar gain throughout the year. 

The function considers all ARCHICAD objects and elements that are visible in Building Energy Model view to 

calculate direct solar irradiation on each glazed opening of the building model. Furthermore, ARCHICAD plant 

objects act as intelligent shading devices, as their shading capacity is scheduled for the reference year, 

making it possible to factor in whether the plants used for shading are coniferous or deciduous.

Watch the Video
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Select any Openings List entry, then click Open Analysis at Solar Analysis to activate the dialog dedicated to 

model-based solar irradiation study.

The Solar Analysis dialog has two tab pages. Both display diagrams that show each hour of the calculation 

reference year, with the days of the year along the x axis and the hours of the day along the y axis. 

Hover over the “Percentage of glazed area exposed to direct sunlight” diagram to get a precise reading of 

hourly values, or use the color coding of the diagram to view 100% solar exposure with bright yellow and 0% 

solar exposure (totally shaded) with blue, while shades of yellow represent times of the year when the 

Opening in question is only partially irradiated by the sun. This view disregards cloudy days specified in the 

weather file.

Hover over the “Energy transmission through glazed area” diagram to get a precise reading of hourly energy 

transmitted through the Opening, or use the color coding of the diagram to view energy transmission intensity: 

most intense is bright red and 0 is blue, while colors of the gradient between these two extremes represent 

intermediate energy flow values. This view takes cloudy days specified in the weather file into consideration 

and displays the resulting “Annual integrated direct radiation value” in kWh.

Note: If multiple entries are selected on the Openings List, or a singe entry is selected but the Show 

uniform items as a single entry option is active, then the Solar Analysis dialog will display data that 

reflect the solar irradiation on all of the selected Openings items, combined.
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Building Energy Model Visualization

The Show selected items in 3D button on the upper left corner of the Energy Model Review palette enables 

you to visualize the energy model of your project in different ways.

 

Show Zone Volumes

The Show Zone Volumes function can be used to visualize the internal spaces in 3D.
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Show Unused Zones

The Show unused Zones function highlights the visible ARCHICAD Zones that do not belong to any Thermal 

Blocks in the Building Energy Model.
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Show Uncovered Areas

The Show Uncovered Areas function highlights the surfaces that do not have space boundaries associated to 

them. Ideally, all building structure and opening surfaces are covered by space boundaries; so these 

uncovered areas indicate modeling inaccuracies.

Visualization of Thermal Blocks

In the Energy Model View, the entries that are selected on the Thermal Blocks list are simultaneously 

highlighted with solid colors on the 3D model. 
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The model elements that are not selected are shown in wireframe while this function is active. In Tree View, it 

is also possible to select and visualize the zones that make up a thermal block, one by one.
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Visualization of Structures

In the Energy Model View, the space boundaries that are selected on the Structures list are displayed on the 

ARCHICAD building model. Select one or more items from the Structures list, then click “Show selected item 

in 3D” (the model elements that are not selected are shown in wireframe while this function is active).

A separate color is assigned to each space boundary category in Energy Model View.

See Customize Energy Model Review Colors.
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A single ARCHICAD element (e.g. a wall that extends both above- and below-ground) might consist of 

multiple space boundaries, and therefore might appear as part of several different entries (with different 

orientations) on the Structures list.

A single ARCHICAD wall element that consists of multiple space boundaries

Visualization of Openings

The Show in 3D button can also be applied to visualize the selected entries of the Openings list.
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Additional Data Assignment and Input

In Energy Evaluation, there are two necessary energy calculation input data types in addition to the 

information that comes directly from the BIM: 

• Space boundary (Structures and Openings) property settings

• Auxiliary data assignment and input

These input data are described in the following sections:

Thermal Block Property Settings (Energy Evaluation)

Structure Property Settings (Energy Evaluation)

Opening Property Settings (Energy Evaluation)

Climate Data (Energy Evaluation)

Environment Settings (Energy Evaluation)

Operation Profiles (Energy Evaluation)

Building Systems (Energy Evaluation)

Energy Source Factors (Energy Evaluation)

Energy Costs (Energy Evaluation)

Bring up the Model Review Palette by selecting Design > Energy Evaluation. The three tab pages of this 

palette (Thermal Blocks, Structures and Openings) list data populated by the Automatic model geometry 

analysis. Additional data beyond the information that comes from the building model must be assigned to the 

ARCHICAD model data on the Thermal Blocks, Structures, and Openings lists.

Prior to manual editing, the fields of Model Review Palette tab pages that contain additional data are filled with 

default values. Fine-tune the building energy model by editing this data manually, using the function buttons 

on the lists.

To modify the editable values for any property, select the property from the list.

In List view, you can edit multiple entries. Select the first entry that needs to be modified. Then add further 

entries to the selection by moving the pointer with the mouse without releasing the left mouse button, or by 

clicking on the entries while pressing the CTRL or the SHIFT key. Use the function buttons that appear by the 

first selected line to modify properties of all selected list entries.

If any of the data on the lists are insufficient for simulation input, the list entry that contains it is automatically 

highlighted with red, and a warning symbol (exclamation mark in a yellow triangle) appears at the data field in 

question.
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Thermal Block Property Settings (Energy Evaluation)

In order to enable the energy simulation for Energy Evaluation, it is necessary to define three property sets for 

each thermal block individually. These key thermal block property sets are: Space Zones, Operation Profile 

and a set of Building Systems.

• Space Zones that make up the thermal block. 

See Create Thermal Blocks.

Use the control buttons below the thermal blocks tree to add or remove ARCHICAD Zones from the selected 

thermal block, as well as to create a new thermal block.

• An Operation Profile that describes how the thermal block will be used. 

See Operation Profiles (Energy Evaluation).

Click the Assign Operation Profile button to select an operation profile that fits the selected thermal block’s 

function.

• A set of Building Systems that maintain the comfort requirements defined by the Operation Profile.

 See Building Systems (Energy Evaluation).
ARCHICAD 24 Reference Guide 2770



Additional Data Assignment and Input Energy Evaluation
Use the control buttons next to the list of Supply Building Systems to add or remove systems from the list.

Note: It is also possible to assign systems to thermal blocks via the Building Systems dialog.

Note: One thermal block can only be supplied by one heating system configuration, one cooling system 

configuration and one ventilation system configuration.
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Structure Property Settings (Energy Evaluation)

U-Value (R-Value) Calculator

U-value refers to the heat transmission coefficient of the selected structure. Use the U-value Calculator to 

estimate the thermal physics performance of the structures in your projects, based on the physical properties 

of the structure’s Building Material(s).

Note: For a simpler and faster, but somewhat less accurate method, edit the U-value manually.

See U-value (R-value) Override.

Select any structure in the list. In the U-value column, click the three-dot button - with the lock icon set to 

closed (red) - to bring up the U-value Calculator dialog.

In the U-value Calculator, the skin(s) that make up the selected structure are listed with their relevant 

properties (Thickness, Thermal conductivity, Density and Heat capacity), each showing a default value.

Note: These values derive from the Physics Properties panel of ARCHICAD’s Building Materials dialog 

box. You can edit any of these values manually.

Depending on local convention, you may prefer to use the R value (Thermal Resistance Coefficient), which is 

the inverse of the U value. To list and display R values instead of U values (both here and in the final 

Evaluation Report), click the U-value pop-up at the bottom right of this dialog box, and choose R-value.

External and Internal heat transfer coefficients, and the Thermal bridge effect related to structural surface 

area are shown at the bottom left of the U-Value (R-Value) Calculator dialog box. These data, in addition to the 

material properties, are necessary for the calculation. 

The Calculated U-value is displayed in the bottom right corner of the panel. 

Note: The Calculated U-value shown in this dialog box is based on stationary building component 

performance data. This kind of data is listed under Key Values/Heat Transfer Coefficients in the Energy 

Performance Evaluation report. However, Energy Evaluation uses a more accurate, dynamic calculation 

algorithm to calculate hourly heat transmission through the building envelope structures, when simulating 

the building energy balance for the reference year. The result of this dynamic analysis is the basis of the 

Energy Consumption, Carbon Footprint and Monthly Energy Balance data displayed on the Energy 

Evaluation Report.
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U-value (R-value) Calculation Algorithm

The U-value Calculator calculates the average heat transmission coefficient of Building Materials and 

composite structures, based on a stationary algorithm that is used by most national standards.

To include the effects of thermal bridges, delta U-values are added to the average U-values of structure 

group entries. The magnitudes of external and internal heat transfer coefficients and the delta U-value 

depend on the position of the evaluated structure relative to the thermal current. Default settings are offered 

within Energy Evaluation. However, it is advisable to review and manually override these predefined values if 

the structural situation demands, or if the standards for the project location are different.

Physical Property Assignment

View the skins listed in the U-value calculator. While the fill type, name and thickness of each skin is derived 

from the element’s settings in ARCHICAD, the three properties to the right of the vertical line - Thermal 

conductivity, Density and Heat capacity - can be modified by you, if the default values here do not correspond 

to your actual project structures.

To change the Thermal conductivity, Density and/or Heat capacity value of any skin, select it from the list in 

the U-value Calculator.

Click the button with the three dots to access the Physical Property Assignment dialog box.

The Physical Property Assignment dialog box lists all Building Materials defined for this project. Those 

Building Materials actually used in this project are shown here with a checkmark in the far left column. Each 

listed fill is shown with the relevant physics properties that are assigned to it.

Note: These values derive from the Physical Properties panel of the Building Materials dialog box 

(Options > Element Attributes > Building Materials).

The Building Material you selected in the U-value calculator is highlighted in the list. Here you can edit any 

value, either directly or by choosing defined values from the Material Catalog.

Any change made here will automatically be reflected in all project elements that include the edited fill.
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Material Catalog

Materials in Energy Evaluation represent physical properties (thermal conductivity, density, heat capacity, 

embodied energy, and embodied carbon). In the Physical Property Assignment dialog box, highlight a row and 

click the right-side Catalog button: this brings up the Energy Evaluation Material Catalog.

The Material Catalog is an extensive database integrated within Energy Evaluation that contains building 

material information relevant for the energy calculations (thermal conductivity, density, heat capacity, 

embodied energy, and embodied carbon). The building materials are grouped in main categories with drop-

down detailed lists to enable easy access and quick selection. 

Select a material here whose physical properties correspond to your needs. When you click OK in the Material 

Catalog, the thermal properties of the selected material are assigned to the Building Material you selected in 

Physical Property Assignment. 

This way, the calculation engine obtains the physical data required for the thermal evaluation without any 

numeric input from you.

 U-value (R-value) Override

It is possible to enter a U-value (or R-value) manually, instead of using the U-value calculator and Physical 

Property Assignment functions. Omitting the Physical Property Assignment greatly shortens the time needed 

to evaluate a project, but leads to somewhat less accurate results.

Select any structure in the list. In the U-value column, click the three-dot button - with the lock icon set to open 

(white) - to bring up the U-value Override dialog.

Click the pop-up to alternate between U-value and R-value as needed. Simply enter the desired value in the 

editable field.
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Structure’s Heat Storage Mass

Use this pop-up (also in the U-Value Override dialog box) to select the thermal mass (Lightweight, Medium or 

Heavyweight) of the selected structure, instead of using the materials coming from the building model directly.

The threshold values for these categories are:

• heavy-weight: > 400 kg/floor area

• medium: 250 – 400 kg/floor area

• light-weight: < 250 kg/floor area

Within Energy Evaluation, these predefined settings are linked to mean density values. These density values 

are multiplied by the total volume of the interior structures, providing the numeric Internal heat storage mass 

value to the calculation engine.

Infiltration Settings

Modify the default Infiltration (unit: l/s,m2) of the selected Structures List entry to precisely define its air 

permeability (0.6 l/s,m2 is considered as low, while 1.6 l/s,m2 is considered as high infiltration).

The Energy Evaluation function of ARCHICAD not only simulates the effect of infiltration on the hourly energy 

balance, but also displays the total Air Leakage in ACH (air change per hour), in the Key Values section of the 

PDF Energy Performance Report.

Solar Absorptance

The Surface material property determines the Solar Absorptance properties of the selected Structure. Modify 

the default Solar Absorptance (unit:%) of the selected Structures List entry to precisely define its capacity to 

absorb solar energy.
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Opening Property Settings (Energy Evaluation)

The Openings tab page of the Model Review dialog box lists data for all of the Openings on the building shell 

and on internal thermal block boundaries.

To change the physical properties of the selected Openings List item, either edit the values manually, or use 

the predefined value sets from the Openings Catalog.

Openings Catalog

To access the Openings catalog, select an item on the Openings tab page and right-click to bring up the 

context menu: 

The Openings Catalog is an extensive database of building physics information relevant for the energy 

calculations. Transparent and opaque components of Openings are listed separately:

• Transparent items are listed with their U-values, Total Solar Transmissions and Direct Solar 

Transmissions;
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• Opaque items are listed with their U-values, Psi-values (the linear thermal transmittance coefficient in W/

m,K that are used to factor in the effect of the thermal bridges that occur at the frame-to-wall joint around 

Openings) and linear Infiltration properties.

Shading Devices

Click the arrow on the Shading Device item to apply a shading device, with its predefined physical properties, 

to the selected entry.

There are two types of Shading Devices on the list:

• Devices whose shading effect is additional to the effect of the model-based Solar Analysis (None, 

Sunscreen 10%, Sunscreen 40%, Sunscreen 60%, Sunscreen 80%, External Blind, External Louver)

• Devices that disable the effect of model-based Solar Analysis (Canopy, Canopy And Side-Fins, Solar 

Analysis Off). These settings are mostly used for analytic (scientific) software functionality tests. Users are 

advised to use Shading Devices from the previous group on architectural projects.
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Climate Data (Energy Evaluation)

Open this dialog box from the Model Review Palette’s pop-up at the top right; or from Design > Energy 

Evaluation > Climate Data; or from the Environment Settings dialog box.

Climate Data Source

Choose an option for the source of the climate data to be used for Energy Evaluation.

• Download from StruSoft Climate Server. All StruSoft climate data are created from NCEP Reanalysis data 

provided by the NOAA-CIRES Climate Diagnostics Center, Boulder, Colorado, USA, from their website at  

http://www.cdc.noaa.gov/.

• Use ASHRAE IWEC, TMY, WTEC2 file: Click Browse to select and import data from analytic weather files 

obtained from an external source (from open source e.g.

https://energyplus.net/weather, or purchased)

Note: Use analytic (“ideal year”) weather data whenever possible, as it usually represents a given 

location's climate better than climate data recorded in any particular year.

Once the weather data are assigned to a certain project, they are stored in the ARCHICAD Cache Library, so 

the data remain available when opening another ARCHICAD project later, even if the computer is not online.

Climate Type

It is possible to assign a Climate Type that best describes that of the building location: Moist, Dry or Marine. 

This classification is necessary for compliance with certain North American Building Energy Efficiency 

Calculation Standards, but it has no effect on the calculation result.
ARCHICAD 24 Reference Guide 2778

http://www.cdc.noaa.gov/
http://www.cdc.noaa.gov/
https://energyplus.net/weather


Additional Data Assignment and Input Energy Evaluation
View Climate Data

The chart below graphically illustrates climate fluctuation over the course of one year. Choose the climate 

data type that you want to see in the chart: either Air Temperature, Relative humidity, Solar radiation or Wind 

speed.

Use the four icons at right to choose the level of detail you want to view: by month, day, week or hour.

Below the graph, the maximum, average and minimum values for the chosen climate data type are listed.

Air Temp monthly Air Temp weekly

Air Temp daily Air Temp hourly
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If Wind speed is selected as visualized climate data type, an additional icon is also available, which displays 

the wind data in wind-rose form.

The polar diagram represents the 8 main directions. The length of each segment represents how often (as a 

percentage, over the course of a year) the wind blows from the given direction.

Each color within a segment represents a wind speed range (as a percentage of the total wind from that 

direction), in accordance with the color scheme below.

The value at the center of the wind-rose (the white area) represents the percentage of time that the wind is 

nonexistent or negligible.
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Environment Settings (Energy Evaluation)

Open this dialog box from the Model Review Palette’s pop-up at the top right; or from Design > Energy 

Evaluation > Environment Settings.

The Environment Settings dialog contains:

• Settings: Location and Climate, Grade Level, Soil Type, Surroundings

• Links to other dialogs: Project Location, Climate Data, Surface Heat Transfer, Wind Protection, Horizontal 

Shading

Project Location

Energy Evaluation considers the geographic location of your building when obtaining Climate Data from the 

StruSoft Climate Server. Use the Project Location button on the Environment Settings panel to access the 

Project Location dialog of ARCHICAD.

See Project Location and Project North.
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Grade Level

This control is in the Environment Settings dialog box.

The connection of the ground with the building can be modeled in two ways in ARCHICAD for Energy 

Evaluation:
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• Offset distance: the distance by which the pavement is offset from either Project Zero or a predefined 

Reference level.

• Modeled by Mesh elements: use the Mesh tool to model the site around the building, if it is not 

completely level, for better energy modeling accuracy of structures in contact with the ground.
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Surface Heat Transfer

This dialog is used to define Internal and External combined heat transfer coefficients for all opaque structures 

in the project. While the surface coefficients entered on the U-Value Calculator influence only the stationary 

thermal performance calculations on the level of individual structures, the global settings on the Surface Heat 

Transfer panel are used for the dynamic energy balance simulation.

Users are advised to change the default global surface coefficient values only if local standards specifically 

require the use of other values.
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Soil Type

From the pop-up, choose the option that most closely describes the soil type of the building location. This 

setting serves as the basis for calculating heat flow through structures in contact with the ground.

The applicable Thermal Conductivity, Density and Heat Capacity values are then displayed below your 

chosen soil type.

Surroundings

Choose the Surroundings option that best describes the environment of your building: Waterfront, Garden, 

Paved or Custom.
ARCHICAD 24 Reference Guide 2785



Additional Data Assignment and Input Energy Evaluation
This setting is used when calculating the effect of indirect solar irradiation.

Wind Protection

From the Environment Settings dialog box, click Wind Protection to open the dialog box of the same name.
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The polar diagram represents the 8 main directions. The length of each segment represents how often (as a 

percentage, over the course of a year) the wind blows from the given direction, and how fast.

Here, for each orientation of the building, choose the appropriate Wind Protection level: Protected, Partly 

Protected or Unprotected. For each orientation, a point is placed on the graph representing wind protection 

(the further out the point, the higher the protection factor), and the points are connected by a red line.

Horizontal Shading

The model-based Solar Analysis function of Energy Evaluation in ARCHICAD only works on the transparent 

elements of the building shell. However, it does not automatically determine the extent to which shadows are 

cast by external objects on the opaque elements of the building envelope. 

Use the Horizontal Shading button to activate a separate dialog with a list of those sides of the building that 

receive the sunlight (the list of Orientations can vary depending on project location).

 

For each orientation, choose the options that best describe the amount of shading resulting from external 

objects (select an option - None, Low, Medium or High).
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Operation Profiles (Energy Evaluation)

Open this dialog box from the Model Review Palette’s pop-up at the top right, from Design > Energy 

Evaluation > Operation Profile, or with the Options > Element Attributes > Operation Profiles command.

The Operation Profile is an ARCHICAD attribute. A separate Operation Profile can be assigned to each 

Thermal Block. 

Each Operation Profile is associated with a daily schedule comprising the following data, by hour, for a full 

year (8760 hours total):

• Required Internal temperature range

• Human heat gain 

• Hot water needs

• Humidity loads
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Available Operation Profiles

Pick the operation profile that best fits the selected thermal block’s function from the list of available defaults. 

These default values reflect the Operation Profile specifications of the DIN 18599 Standard - Energy 

Efficiency of Buildings.

It is also possible to rename or to create custom Operation Profiles with the Energy Evaluation function within 

ARCHICAD, and to add them to the list of Available Operation Profiles. You can also edit them as needed, by 

changing the values in the daily schedule list item they reference.

Occupancy Data

Below, view the Occupancy Data of the selected Operation Profile. 

Change any of these values if needed to better reflect the thermal block’s function.
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• Occupancy type: either Residential or Non-residential

• Human heat gain: the amount of heat produced by the human bodies in the building (W/capita)

• Service hot-water load: amount of hot water necessary per person, as associated to the selected 

building function (l/day, per capita)

• Humidity Load: the amount of water vapor that gets into the internal air as a result of the building’s 

operation (l/day)

Daily Profile Editor

Select “Edit Daily Schedules” to open the Daily Profile Editor. This dialog displays two daily occupation profile 

graphs with corresponding key values to the right of each graph. These controls are used to specify the 

required Internal temperature range as well as Occupancy count, Lighting power density (LPD, in W/m2) and 

Equipment power density (LPD, in W/m2), which will drive the Internal heat gains. 
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Theoretically, it is possible to define different operation conditions for each hour of the reference year with the 

Daily Profile Editor.

Internal temperature: Set the hourly allowed internal air temperature range (maximum and/or minimum) 

during the day 

Internal heat gain: Define the factors that result in energy emission (internal heat gain) during the day, per 

m2 of internal floor area (W/m2)

• Occupancy count: Refer to local regulations to enter a value that describes the density of human 

occupation for the selected operation.

• Lighting: Check the Lighting box, then select a lighting type from the dropdown list. The default Power 

value for the selected Interior Lighting type appears in the Power field. You can fine-tune this value 

manually if the lighting design of the project is available at the time of the evaluation.

• Equipment: Refer to local regulations to enter a value that describes the density of appliances (E.g.: TVs, 

Computers, servers) for the selected operation.
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Yearly Operation Scheduler

Since these data will vary by day of the week and over the course of the year, the Operation Profile consists of 

any number of daily schedules, which correspond to specific date ranges and days of the week. 

For each daily schedule, you can define the following characteristics:

• Recurrence: days of the week when the particular schedule is in effect

• Date Range: periods of the simulation year during which the schedule occurs

Recurrence and Date Range define the In use hours (the total number of hours during which the selected 

Daily Schedule is in effect).

If the Uncovered hours counter on the bottom right corner of the Yearly Operation Scheduler shows any 

number but 0, it means that further modifications in Recurrence and Date Range are necessary because 

there are some hours of the reference year without operation schedule assigned to them. 

If the Overlapped hours counter on the bottom right corner of the Yearly Operation Scheduler shows any 

number except 0, it means that further modifications in Recurrence and Date Range are necessary because 

there are some hours of the reference year with more than one operation schedules assigned to them. Click 

the yellow warning tag for details on the overlapping profiles.
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Building Systems (Energy Evaluation)

Open the Building Systems dialog box from:

• the Model Review Palette’s pop-up at the top right

• Design > Energy Evaluation > Building Systems, or 

• the Thermal Blocks page of the Energy Model Review palette

Use this dialog box to define Building Systems settings that will maintain the internal comfort conditions (as 

specified by the Operation Profiles dialog) for the thermal blocks of your building model. 

You can either select from the defaults or define custom Building Systems, which you will assign to each 

Thermal Block.

The Building Systems dialog box lists each Building System on the left, and the options for each on the right. 

The content of the building system options on the right changes depending on which system configuration is 

selected. Use the Building Systems dialog to edit the properties of existing building systems, to create new 

ones and to assign them to thermal blocks.
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Assigned Thermal Blocks

View or edit the list of thermal blocks that use the selected system.

Note: It is also possible to assign systems to thermal blocks via the Thermal Blocks page of the Energy 

Model Review palette.

Energy Source

Press the Energy Source button from either the Boiler or Furnace tab page (Heating System) or the District 

Cooling Settings tab page (Cooling System).

In the appearing Energy Source dialog box, click on a listed Source item and use the dropdown to specify 

energy sources (Natural gas, Propane, Oil, Wood, Coal, Electricity or Pellet) for the Boiler/Furnace or Cooling 

System.

If you use more than one energy source for a function, click the + (plus) button, then choose an additional 

energy source.

Define the proportion of each source used so that the Total adds up to 100%.

To remove a row, click the – (minus) button.
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In the table below, the energy sources used by Energy Evaluation are listed according to their type and with 

their colors as displayed on the Energy Balance Evaluation report.

Heating

Choose either District Heating or On Site Equipment to describe the building’s heating system.

District heating means that the evaluated building’s heating and/or hot water needs are supplied by an 

external plant in the form of hot water or steam through a pipeline.

Use the Energy Source button to define the source or multiple sources of energy consumed by the heating 

system, as applicable.

See Energy Source dialog box.
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On Site Equipment

Choose one or more equipment types corresponding to the heat source to be used:

• Boiler or Furnace

• Solar Thermal Collector

• Water Heat Pump

Each option’s settings are located on the corresponding dialog box panel below.

Boiler or Furnace

Fine-tune heater performance data such as Capacity and System Heat Loss or use the smart defaults 

provided by the program.

Specify whether or not to Include Service Hot-water Generation

Use the Energy Source button to define the source or multiple sources of energy consumed by the heating 

system, as applicable.

See Energy Source dialog box.

Solar Thermal Collector Settings

Solar thermal collector panels are designed to collect heat by absorbing sunlight and converting the energy in 

solar radiation into a more usable form.

• Type: Choose either Flat Plate or Evacuated tube.

• Target: Set the target for the recovered solar energy: Heating, Hot Water, or both.

Note: If solar collectors are used for multiple targets, then Hot water generation always has the highest 

priority. This means that if the solar collector is unable to generate enough energy to feed all targets, then 

it is going to feed the water heater first and use the remaining available energy for the Space heating.

Specify the collector geometry data required for the calculations:

• Panel area

• Orientation angle to the South (or to the North, for southern hemisphere locations) 

• Tilt Angle
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Heat Pump Settings

Specify system target and priority (drag-and drop the list items in the desired order) as well as source. 

 

System parameters can also be fine-tuned, or use the smart defaults provided by the program.

Service Hot Water Heating

Enter Cold and Hot water temperature target values. The calculation engine uses this data to calculate the 

energy consumption related to hot water generation. 

To change the temperature scale (Celsius or Fahrenheit), click the arrow button next to the input field. 

Note: For other units (apart from temperature scale), Energy Evaluation uses the units defined in 

ARCHICAD, at Options > Project Preferences > Calculation Units and Rules.

See Calculation Units and Rules Preferences.
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Cooling

Use this dialog to describe the building’s cooling system, or use the smart defaults provided by the program.

• Cooling Machine means that some type of cooling system is to be installed in the building. Click 

Characteristics to see and edit the performance graph of the cooling system.

• District cooling: In certain countries, cooled air may be obtained from an external source. If the building 

will be connected to such an external cooling system, select District cooling and use the Energy Source 

button.

See Energy Source to define the source or multiple sources of energy used by the district cooling plant.
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Ventilation

Specify the type of ventilation used in the building: “Not Yet Specified Or Natural” or Mechanical Ventilation. 

Both of these ventilation types can be defined with Steady Air Change Rate as well as Time Scheduled Air 

Change Rate.

Not Yet Specified Or Natural Ventilation

Natural ventilation involves no MEP systems: natural air currents drive fresh air into the building and used air 

out of it. From an ecological point of view, natural ventilation is preferable to mechanical solutions, but due to 

its limited controllability its use is largely limited to residential buildings.

Mechanical

For building functions other than residential, the standards usually prescribe strict target air exchange values, 

which necessitate a mechanical ventilation system of some sort:

• Supply-only systems rely on fans to drive fresh air into the thermal block.

• Exhaust-only systems rely on fans to extract used air from the thermal block.

• Supply and exhaust systems mechanically control both the air intake and outlet procedure.

• Heat Recovery: Mechanical ventilation systems may or may not have air-to-air heat recovery units. Use 

the dedicated checkbox to specify this setting.

Note: The Air to air recovery controls are available only if you have chosen a ventilation system that 

involves mechanical exhaust. If your ventilation type is set to Natural, these controls are inactive.

An air to air energy recovery system can regain a percentage of the heat content of mechanically expelled 

ventilation air. 

• Steady Air Change Rate: Enter a value for the hourly air change rate. This target value depends on 

national standards, and will vary depending on the building’s function and the local climate. 

• Time Scheduled Air Change Rate: Supply and exhaust data may vary by day of the week and over the 

course of the year. The ventilation Operation Schedule can consist of any number of daily schedules, 

which correspond to specific date ranges and days of the week.
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For each daily schedule, you can define the following characteristics:

• Recurrence: days of the week when the particular schedule is in effect

• Date Range: periods of the simulation year during which the schedule occurs

Recurrence and Date Range define the In use hours (the total number of hours during which the selected 

Daily Schedule is in effect).

If the Out of Operation hours counter on the bottom right corner of the Yearly Operation Scheduler shows 

any number except 0, it means that further modifications in Recurrence and Date Range are necessary 

because there are some hours of the reference year without operation schedule assigned to them. 

If the Overlapped hours counter on the bottom right corner of the Yearly Operation Scheduler shows any 

number except 0, it means that further modifications in Recurrence and Date Range are necessary because 

there are some hours of the reference year with more than one operation schedules assigned to them. 
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Energy Source Factors (Energy Evaluation)

Open this dialog box from:

• the Model Review Palette’s pop-up at the top right, or 

• Design > Energy Evaluation > Energy Source Factors.

Primary Energy And CO2 Emission Factors

For each energy source, default values are shown for primary energy and CO2 emission factors. These 

default values, which vary according to Project Location, are based on standard DINV-18599.

Use these default values, or enter other region-specific data if available.

Sources of Electricity Production

At the bottom of the Energy Source Factors dialog, define the building’s source or multiple sources of 

electricity. Click on a listed Source item and use the dropdown to specify the source of electricity (Natural gas, 

Propane, Oil, Wood, Coal, Nuclear energy, Wind energy, Solar energy, Water energy or Unknown).

If you use more than one energy source, click the + (plus) button, then choose an additional source. Define 

the Proportion of each source used so that they add up to 100%. To remove a row, click the - (minus) button.
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Energy Costs (Energy Evaluation)

Open this dialog box from 

• the Model Review Palette’s pop-up at the top right, or

• Design > Energy Evaluation > Environment Settings.

In the top part of the panel, enter the currency name or its abbreviation in the Displayed currency unit field.

Use the bottom part of the panel to define the Prices of purchased energy. These prices, of course, vary by 

location and therefore must be entered numerically by the user. Select the Unit of energy (e.g. kWh) from the 

dropdown list. Next, select a row representing a source of energy, and then enter the price, in the currency 

you chose.
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Energy Performance Evaluation

The following topics detail the evaluation process and the resulting reports of ARCHICAD’s Energy Evaluation 

feature.

Start Energy Simulation (Energy Evaluation)

Interoperability with Green Software (Energy Evaluation)

Advisory Messages (Energy Evaluation)

Errors And Recommended Solutions

VIP-Core Dynamic Simulation Engine (Energy Evaluation)

Energy Evaluation Report Dialog

Reading the Energy Performance Evaluation - PDF Report

Reading the Energy Performance Evaluation - XLS Report
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Start Energy Simulation (Energy Evaluation)

Once all necessary input data are obtained by means of geometry analysis and user input, you can start the 

data input into the VIP-Core calculation engine built into ARCHICAD.

See Energy Performance Evaluation.

Select the Start Energy Simulation button from the Energy Model Review Palette to launch the VIP-Core 

Calculation Engine, which performs the dynamic energy analysis. Energy Evaluation calculates the energy 

balance of a building during a period of one year, and displays the results on the Energy Performance 

Evaluation Report.

For information on exporting data to 3rd party energy calculation software, see Interoperability with Green 

Software (Energy Evaluation).
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Interoperability with Green Software (Energy Evaluation)

Software interoperability increases the design team’s work efficiency and removes a significant cost barrier 

from the design project. Energy Evaluation enables the export of project geometry and property data derived 

from the ARCHICAD model. Use these communication platforms to transfer architectural building model data 

directly to building performance analysis tools, eliminating the need for time consuming plan takeoffs and 

building geometry remodeling.

Click the arrow next to the Start Energy Simulation button to display the available data export file formats.

Note: Five different export formats are listed. The first two (Export to gbXML and Export to PHPP) are 

available in every ARCHICAD as standard features. The latter three (Export to SBEM, Export to VIP-

Energy and Save as Baseline Building) are functions exclusive to the EcoDesigner STAR add-on which is 

sold separately from ARCHICAD. These add-on specific commands remain inactive until an EcoDesigner 

STAR license is enabled, in addition to the ARCHICAD license.

Export to gbXML

XML - extensible markup language - is a computer language that allows software programs to communicate 

information. The Green Building XML (gbXML) open schema helps facilitate the transfer of BIM data to 

building energy analysis tools. Supported by the leading 3D BIM applications and major building performance 

analysis tools, gbXML has become the industry standard for BIM to SIM interoperability.

Use the dedicated export panel to save project geometry and property data derived from the ARCHICAD 

model in gbXML file format.
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The following project data are exported from ARCHICAD via gbXML:
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The gbXML protocol describes the 3D building model in a way quite similar to IFC. The gbXML model can be 

visualized using dedicated viewers or the graphical user interfaces of building performance simulation 

software that are compatible with the gbXML format.

Export to PHPP

Certified Passivhaus buildings (mainly small scale residential) are designed according to a strict yet 

straightforward directive in order to be extremely energy efficient. PHPP is the Excel workbook created by the 

Darmstadt Passivhaus Institute, to calculate and document the energy performance of projects that aspire for 

Passivhaus accreditation.

ARCHICAD supports both PHPP versions 7 and 9.

Note: The PHPP Excel workbook is an independent product of the Darmstadt Passivhaus Institute and is 

not a part of GRAPHISOFT ARCHICAD. For more information on PHPP and the Passivhaus Institute visit 

the official website at http://www.passiv.de/

The Export to PHPP button activates the PHPP Export dialog box, which enables you to send building 

information model data to the PHPP Excel workbook you specify, for post processing.

Use the PHPP Export panel to browse for the official PHPP Excel workbook to be used as a template, then 

save the project-specific PHPP Excel file under a different name.
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The following 2nd level space boundary and material property data are exported from ARCHICAD to the 

respective fields of the project-specific PHPP workbook:

The Passivhaus directive sets stringent threshold values for the Specific annual net heating and cooling 

demands (15 kilo watt hours per square meter, year maximum), total annual specific primary energy demand 

(less than 120 kilo watt hours per square meter, year), and average infiltration (maximum 0.6 1/h).

Note: The Key Values section of the Building Energy Evaluation Report displays these performance data, 

as calculated by The VIP-Core Calculation Engine.

Energy Evaluation in ARCHICAD can be used to design a building as energy efficient as a Passivhaus. 

However, in order to apply for official Passivhaus accreditation, a PHPP Excel workbook must also be 

completed and submitted to the Passivhaus Institute.
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Advisory Messages (Energy Evaluation)

The “Advisory Messages” dialog box appears if:

• the required input data are insufficient

See Additional Data Assignment and Input.

• there are simulation errors

See VIP-Core Dynamic Simulation Engine (Energy Evaluation).

Errors will be required to be resolved before continuing. However, resolving Warnings is optional.

Errors And Recommended Solutions

(mandatory to resolve before continuing)

• Physical properties of a used materials are not defined.

– Error icon: “Building Materials with missing properties”

– List of missing Building Materials

– To-do: “Select the relevant Building Material from the dedicated dialog box and enter the missing 

values (values are required to be more than zero) in the Physical Properties panel.”

• “Climate data is not available.” (missing or the server is not accessible)

– Error icon, “Climate Data is not available.”

– “To edit the Climate Data, open the Environment Settings dialog box from the Model Review palette.”

• “One or more used Building Material/Composite Structure is missing.” 

– Error icon, “Structures with missing attributes.”
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– List of structures with missing Building Material

– “Select the relevant model elements and edit its Building Material attribute.”

• “Energy simulation runtime error.” (engine errors during the hourly energy simulation) 

– Error icon, “Simulation engine errors.”

– List of <Engine error code + description>.

– To-do: “Contact technical support:”

• “No valid Operation Profile selected.”

– Error icon, “Operation Profile is missing or not defined.”

– To-do: “Select an available profile from the Operation Profile dialog.”

• “Energy model analysis error.”

– Error icon, “Energy model analysis did not found any structure or openings.”

– To-do: “Check the geometry of the Zones and update them using the Update Zones command.”

Warnings And Recommended Solutions

(optional to resolve before continuing)

• “Zones are outdated and/or have errors.” (i.e. not up to date, overlapped zones, visible zones which are 

not assigned to any TB) - zones on hidden layers will not appear 

– “Outdated zones:”

– List of Zones - Zone ID, zone name, thermal block name

– To-do: “Check the geometry of the above Zones and update them using the Update Zones command.”

• “Location data varies between project location and climate data.” 

– Warning icon, “Location data does not match between project location and climate data.”

– To-do: “Either modify the project location from the Project Location dialog box or modify the climate 

settings from the Environment Settings dialog box accessed via the Model Review palette.”

• Simplified building system is attached to a Thermal Block.

“Thermal Blocks with simplified building system:”

– List of Thermal Blocks - color swatch, number, name

– To-do: “Choose detailed settings from the Building Systems dialog and add the relevant details of 

HVAC systems used within building.”

• “Building shell contains one or more empty opening(s).”

– Warning icon, “Building shell is not closed because external wall contains empty opening.”

– To-do: “Review the Opening list and modify empty opening if necessary.”

On the Structures and Openings lists, a yellow warning exclamation mark appears next to those entries which 

contain faulty or missing data. (The problematic list items are also highlighted in pink.)

See Additional Data Assignment and Input.
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Show List in Browser

• Press the Show List in Browser button of the Advisory Messages dialog to display the list of errors and 

warnings in a browser window. This way the list can remain open for reference while you fix the building 

model in ARCHICAD following the instructions of the Suggestions / Notes field.
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VIP-Core Dynamic Simulation Engine (Energy Evaluation)

Specification

The VIP energy simulation software module integrated in ARCHICAD (a.k.a. engine) is a result of more than 

20 years of research and commercial use. It relies entirely on dynamic models, in which every model is 

broken down to a level where facts and behavior are known. Each component group is analyzed separately. 

The calculation is repeated every hour. The accuracy of each model has been validated and verified against 

real buildings under real usage. In calculating a building’s energy consumption, the program utilizes known or 

measured facts about all parts of the energy flow.

VIP-Energy is produced by Structural Design Software in Europe AB http://www.strusoft.com/ 

For technical information about VIP-Energy and for a more detailed explanation of the different calculating 

models, see http://vip.strusoft.com/.

Validation of Calculation Accuracy

Energy Evaluation uses the same simulation kernel as EcoDesigner STAR add-on for ARCHICAD. This 

kernel is validated with ANSI/ASHRAE Standard 140-2007: Standard Method of Test for the Evaluation of 

Building Energy Analysis Computer Programs.

Note: To produce code-compliant energy simulation results, the expert user interface of EcoDesigner 

STAR is necessary. 

The ASHRAE Standard 140 test documentation for EcoDesigner STAR will be available on the official product 

website, following the add-on’s release.

The stand-alone VIP Energy product, which also uses the same simulation kernel as Energy Evaluation in 

ARCHICAD and EcoDesigner STAR, is also validated with the following tests:

• EN-15265 

• IEA-BESTEST

• ASHRAE-BESTEST (ANSI/ASHRAE Standard 140-2001)

• StruSoft-BESTEST

Validation results can be read at http://www.strusoft.com/index.php/en/validationvip
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Energy Evaluation Report Dialog

After the dynamic energy simulation is finished, the Evaluation Report dialog appears. Use the controls on the 

left side to customize certain aspects of the Energy Performance Evaluation report’s content before saving it.

The right side of the dialog contains a preview of the Energy Performance Evaluation report PDF document.

Header and Footer Settings

Use the controls of the Header and Footer Settings dialog to fill the two Header rows as well as the Footer of 

the PDF Energy Performance Report with custom content.
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This content can also be an Image or even Autotext, which allows for a wide range of smart report title 

customization.

Report Format

This dialog defines font format and pen colors used for the Energy Performance Evaluation report PDF.

Insert Autotext Autotext categories
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Report Chapter Settings

In the Report Chapters section the content of the Energy Performance Evaluation report PDF is listed.

Change the order of the chapters by grabbing them with the arrows displayed before their names and 

dragging them. Use the buttons below the list to Add/Remove Page Breaks. 

Some of the report chapters can be further customized by applying certain chapter-specific settings:

• Key Values Chapter Settings: Choose one of the three available Energy unit options: kWh, kBtu, MJ

• Project Energy Balance Chapter Settings: Choose Weekly or Monthly for Time interval, and specify the 

Energy unit (kWh, kBtu, MJ). It is also possible to customize the colors of the bar chart.
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• Energy Consumption by Targets and by Sources Chapters - Settings: Toggle between Pie or Bar Chart 

Display

Format Settings Import/Export

This button on the bottom left corner of the Evaluation Report dialog makes it possible to migrate PDF report 

formats between projects (e.g. to apply a company template format to the Energy Performance Evaluation 

report PDFs of every project).

There’s also an option to reset the format of the Energy Performance Evaluation report to factory default.

Close and Save as Commands

At the bottom of the Evaluation Report:

• The Close button takes you back to the Energy Model Review palette, allowing you to further adjust the 

input data.

• Save as PDF lets you specify a location to which to save the Evaluation Report in PDF format 

See Reading the Energy Performance Evaluation - PDF Report.

• Click the button with the triangle in the bottom right corner to save the detailed monthly energy balance 

data in Microsoft Excel file format.

See Reading the Energy Performance Evaluation - XLS Report.
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Reading the Energy Performance Evaluation - PDF Report

PDF Header

The PDF header displays custom project information as defined on the Header / Footer Settings dialog.

Key Values

The Key Values section of the PDF Evaluation Report displays the most important project data.

Under General Project Data, basic information, such as Location and Operation Profile, as specified by the 

user (see Additional Data Assignment and Input). The date of the evaluation is also shown.

The Building Geometry chapter contains result of the model geometry analysis such as areas, volume and 

glazing ratio.

See Automatic Model Geometry and Material Property Analysis in Energy Evaluation.

The Building Shell Performance Data section displays overall Air Leakage in air change per hour (also called 

air exchange rate - the number of interior volume air changes that occur per hour in 1/h). Outer heat capacity 

(measures the capacity of building structures to store heat against changing outside air temperature) is also 

an important building envelope performance metric.

Also in the Key Values section, the minimum and maximum values of the Calculated heat transfer coefficients 

are listed for the entire building, for every Building structure group and for the openings on the building shell.

Under Specific annual demands, the most important energy performance data (net demand and gross 

consumption-related data) - projected to a unit area of the building - are listed, making the comparison of 

different sized projects possible.
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Thermal Blocks

The table in this chapter tabulates the thermal blocks with their geometry data and Operation Profiles.
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Monthly Energy Balance Bar Chart

The Monthly Energy Balance bar chart is a graphical display of the amount of energy the building emits 

(bottom part of chart), as well as the building’s Supplied energy: the amount of energy it absorbs from the 

environment and its own internal heat sources (top part of chart), by month or week (depending on Energy 

Performance Evaluation Report Chapter Settings).

According to the energy balance equation - which is the foundation of building physics - the Emitted energy 

and Supplied energy bars must be equal every month. The vertical axis of the chart shows an energy scale. 

Along the horizontal axis, the twelve months of the year are shown.

The Monthly Energy Balance Bar Chart shows the cumulative results of the hourly energy balance 

calculations executed by The VIPCore Calculation Engine.

Energy Supply and Emission Types

To the right of the Monthly Energy Balance diagram, the energy flows that make up the bars of the chart are 

listed. The number and type of these energy balance components that appear on a particular Energy 

Evaluation Report depend on the settings on the evaluated building’s Building Systems dialog. Total annual 

energy flow quantities are displayed in kWh/a.

The table below lists all energy supply and emission types with their default Energy Balance bar chart display 

color.
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These energy supply and emission categories, besides being used to visualize the energy balance, also 

provide addition information on the MEP systems (cooling, heating, ventilation type) and green energy 

solutions of the evaluated project.

The left column shows the energy flows that appear on the Emitted energy side of the energy balance bar 

chart, while in the right column the Supplied energy types are listed. The column in the middle contains 

energy flows that may appear as either emitted or supplied, depending on the particular situation.

Energy flows that are framed with solid lines in the table above require the input of one or more Energy 

Sources. 

See Energy Source.

Energy Consumption by Targets

This section of the Evaluation Report contains two tables and several charts.

The table’s far-left column lists energy Targets by name, plus their color codes used in the pie chart. The 

Quantity column lists the magnitude [e.g. kWh/a] while the Cost column shows the price [currency/a] of 

energy spent on each target in one year. Next to the Primary energy breakdown, the table’s far-right column 

shows the carbon footprints associated with the listed energy target magnitudes.

The Distribution by Targets charts graphically display the percentages of the

• Energy quantities

• Primary energy

• Costs
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• Carbon footprints

associated with each energy target.

The Target Energy Quantities by Primary Targets bar chart helps users to compare the magnitude of energy 

consumption with primary energy consumption.

It is possible to display the Energy Consumption chart in either bar or pie chart format. 

See Report Chapter Settings.

Primary Energy

The primary energy value is the ‘common denominator’ among different energy source consumption types, 

when determining the building’s total energy consumption. Not only does it indicate the net energy source 

consumed, but it also incorporates the energy needed for the manufacturing, transportation and the raw 

material processing of the energy source, as well as its transportation to the place of use. Minimizing the 

specific primary energy demand is a great way to improve the designed buildings’ overall performance.

The primary energy factors assigned to the energy sources differ according to building location.

See Project Location and Project North.

Use the Energy Source Factors dialog to enter the region-specific data if available, or evaluate the project 

using the default assignments (based on standard DINV-18599).

Energy Consumption by Sources

This section of the Evaluation Report contains one table and several charts.

The table’s far-left column lists energy Sources by type (Renewable, Fossil and Secondary) and name, plus 

their color codes used in the pie chart. The Quantity column lists the magnitude [e.g. kWh/a] while the Cost 

column shows the price [currency/a] of each energy source consumed in one year.

The table’s far-right column shows the carbon footprints associated with the listed energy source magnitudes.

The Distribution by Sources charts graphically display the percentage distributions of the

• Energy quantities

• Primary energy

• Costs

• Carbon footprints
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of the used energy sources.

The Source Energy Quantities by Primary Sources bar chart helps users to compare the magnitude of energy 

consumption with primary energy consumption.

It is possible to display the Energy Consumption chart in either bar or pie chart format. 

See Report Chapter Settings.

Environmental Impact

This chapter summarizes the environmental impact of the building’s operation, by displaying Carbon Footprint 

and Primary Energy, according to Energy Sources.
ARCHICAD 24 Reference Guide 2822



Energy Performance Evaluation Energy Evaluation
Reading the Energy Performance Evaluation - XLS Report

Click the button with the triangle in the bottom right corner of the Energy Model Review palette to save the 

detailed monthly energy balance data in Microsoft Excel file format.

Project Key Values Page

The Project Key Values section of the XLS Energy Performance Report displays basic information regarding 

the project. Its content is rather similar to the Key Values section of the Energy Performance Evaluation PDF 

report, yet it contains extra information about Climate Data, Design Loads and Advisory Messages (Errors 

and Warnings).

Below the Evaluation Date, Project Data such as Name and Location (with coordinates) is displayed, 

according to the user input on the Project Location dialog.

Key geometry and shell performance metrics like Gross floor area, Ventilated volume and Outer heat capacity 

come from the Automatic Model Geometry Analysis.

Calculated heat transfer coefficients (see U-Value (R-Value) Calculator) are listed for the entire building, for 

every Building structure group (see Structures Tab Page) and for the openings on the building shell (see 

Openings Tab Page).

Heating and cooling system Design Loads are simulation results that indicate gross system magnitudes.

Note: Energy Evaluation in ARCHICAD is not directly capable of providing information for sizing systems 

and equipment.The design loads under Project Key Values are only displayed for your information. 

System sizing is only possible with the expert functions of the EcoDesigner STAR for ARCHICAD add-on. 

Advisory Messages display the errors and warnings that occurred before and during the simulation.
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Project Energy Report Page

The level of data detail displayed on the Project Detailed Results tab page of the XLS Energy Performance 

Report exceeds the level of detail displayed on the Monthly Energy Balance bar chart of the PDF Energy 

Performance Report:

• Heating and Cooling are further broken down according to systems and specific target (Space heating, 

Hot water generation). Auxiliary energies necessary to operate the systems appear separately.

• Lighting and Appliance electricity consumptions are listed separately as opposed to combined.

Note: It is only possible to define so-called Local Heating and Cooling systems with the EcoDesigner 

STAR add-on. Local systems data will therefore always appear as 0 in reports generated with Energy 

Evaluation in ARCHICAD. The same is true for On-site electricity

Detailed Inputs Page

This tab page displays building geometry information as it appears on the Structures and Openings tab pages. 

Use these data as input for third-party Excel-based stationary energy calculation software.
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Interoperability

File Types Opened by ARCHICAD

File Types Saved by ARCHICAD

Merging Files to ARCHICAD

Import/Export Property Data via Spreadsheet

Import BIM Content

Working with PDF Documents

Working with DWG/DXF Files

Working with XREFs

Working with Point Clouds

Working With Rhino 3D Models

Export to Artlantis

Interoperability with MEP Applications

Interoperability with Energy Analysis

Working with IFC
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File Types Opened by ARCHICAD

The file types opened by ARCHICAD are listed here, in the following categories:

ARCHICAD File Types Opened by ARCHICAD

CAD Formats Opened by ARCHICAD

Image Formats Opened by ARCHICAD

Model/3D Formats Opened by ARCHICAD

Other Formats Opened by ARCHICAD

Read More on Help Center
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ARCHICAD File Types Opened by ARCHICAD

ARCHICAD Projects (.pln, .pla, .bpn)

ARCHICAD 24 can open projects from ARCHICAD 8.1 and up.

You cannot open project files from earlier versions directly in ARCHICAD 24. Please use ARCHICAD 8.1 or 

later version to convert them to a usable file format. 

See ARCHICAD File Converters at 

http://www.graphisoft.com/downloads/fileconverter.html.

We strongly recommend that you create an archive file (.pla) of each project you worked on with older 

ARCHICAD versions.

Solo Projects (.pln) 

These are the main native document type of ARCHICAD. A .pln file includes all model data and the views 

generated for the project, as well as the default settings, attributes and library references.

Archive (.pla)

Archive files are similar to Solo Projects, but these include all the library parts, background images and linked 

textures used in the Project, not just references to them.

For more information, see Archive Projects.

Backup Project file (.bpn)

Opening a Backup Project file (.bpn) allows you to recover the last saved version of a damaged project file, 

provided that the Make Backup Copy checkbox is active in Options > Work Environment > Data Safety & 

Integrity.

To open a backup file, do one of the following:

– Browse and double-click its name in the file system

– From the ARCHICAD Open dialog or other system dialogs: use the dialog’s “All file types” filter to 

include BPN files in the available list

ARCHICAD Teamwork (AC12 and earlier) file formats (.plp, .plc, .pca, .bpc)

Note: To open a Teamwork file saved in earlier ARCHICAD versions (12 and earlier), use the Open 

Project command (not the Open Teamwork Project command).

ARCHICAD Project Template (.tpl)

For details, see Template Files.

ARCHICAD 2D Lines (.2dl)

These files are vectorial drawings saved from ARCHICAD’s 3D Window (using the Vectorial 3D Engine). 

These drawings contain no model information and can be touched up in the Floor Plan with 2D tools.

Important note: In the 3D Window, this option is only available with the Vectorial 3D Engine - not 

available in OpenGL mode.

Module File (.mod)

For details, see Create Module (.mod) File.
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PlotMaker Layoutbook (.lbk)

PlotMaker Drawing (.pmk)
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CAD Formats Opened by ARCHICAD

DWF File (.dwf)

Drawing Web Format, a 2D vector graphics format created by Autodesk.

The DWF file will contain all drawing elements with some exceptions and limitations:

• pictures: due to format limitations, only straight pictures can be written to a DWF file,

• cameras will not be included.

DXF/DWG File (.dxf, .dwg)

ARCHICAD opens all DWG file formats starting with AutoCAD 2000.

If you choose this file type, the Settings button appears in the Open dialog box, which opens the DXF-DWG 

Translation Setup dialog box.

For details, see Opening DWG/DXF Files.

However, in most cases you need not adjust these translation settings, because the default setup will give you 

the desired result when opening a DXF/DWG file.

Note: If you are working in AutoCAD and open a DWG that was originally saved from ARCHICAD, an 

Alert may appear. However, you should go ahead and work with the saved DWG in AutoCAD - no stability 

problems should result.

MicroStation Design File (.dgn) - Version 7 or 8

Do one of the following:

• Use File > External Content > Place External Drawing and select a MicroStation Design File (.dgn) file 

(version 7 or 8)

• Use File > Open and select a MicroStation Design File (.dgn) file (version 7 or 8)

• Drag and drop a .dgn file to import into the current ARCHICAD project.

Set options in the Open DGN dialog or Import DGN dialog, as applicable:

Design/Drawing Model

Use the pop-up to select one of the models in the DGN model (if it contains multiple models). 
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Symbology

Overwrite All Colors: The ARCHICAD Pen Set is overwritten using the DGN color table.

Note: If you check this box, and if you use a configuration file, its definitions will overwrite the ARCHICAD 

Pen Set.

Config File

Optional. A default configuration file (txt) is available in the ARCHICAD Defaults folder. Use or customize a 

config file to ensure company-standard conversions.

Background Colors Visibility

If you used File > Open to open the DGN file: a dialog will appear with the option of changing the background 

color to black.

See also Save as MicroStation Design File (.dgn) - Version 7.
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Image Formats Opened by ARCHICAD

All Images (.bmp, .dib, .rle, .jpg, .jpeg, .jpe, .jfif, .gif, .tif, .tiff, .png, .hdr)

Various types of picture files can be opened as model pictures, but they will appear in their own separate 

windows, not the ARCHICAD main window.
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Model/3D Formats Opened by ARCHICAD

3D Studio File (.3ds)

3D files can be saved in 3D Studio format. The Add-On required for this is part of the ARCHICAD package.

3D files in 3D Studio format can be opened by ARCHICAD only if you install the Goodies for your language 

version of ARCHICAD.

See Goodies.

IFC (.ifc), IFCXML (.ifcxml), IFCzip

IFC stands for Industry Foundation Classes.

ARCHICAD supports the latest and most widely used IFC formats.

To read more about IFC, see Working with IFC, or download the IFC Reference Guide from: 

http://www.graphisoft.com/support/ifc/downloads/

Rhino (.3dm) - Import Model or Import as Object

Open or merge a Rhino 3D Model file (.3dm) directly in ARCHICAD with one of these commands:

• File > Open

• File > Interoperability > Merge (from File or BIMcloud)

To import a Rhino file as a single ARCHICAD Object:

• File > Libraries and Objects > Import Rhino 3DM file as Object

For further information, see Working With Rhino 3D Models.

SketchUp (.skp)

To open as a new ARCHICAD project:

• Use File > Open, then browse for the .skp file. 

To add to a running ARCHICAD project:

• Drag-and-drop the Sketchup file into ARCHICAD, or

• use File > Interoperability > Merge, then browse for the .skp file.

The Sketchup model will be saved as a GDL object to the Embedded Library.

See also SketchUp: Export and Import Limitations.

Google Earth (.kmz)

ARCHICAD imports a Google Earth model as follows:

• .kmz objects become GDL objects, placed on the ARCHICAD Layer

• .kmz polygons become Fills, placed on the 2D Drafting General Layer

• Placemarks become GDL objects, placed on the ARCHICAD Layer

Important: Make sure that the merged Google Earth model to be opened

– contains only a single location pin

– uses the Absolute method to define its altitude (see below).

To open a .kmz file directly in ARCHICAD:

1. Use the File > Open command

2. Choose the .kmz file type to open
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3.  Click Settings to open KMZ Import Options.

–  Check the box to import any ‘look at viewpoints’ as cameras, if the .kmz file contains them.

– Create Hotspots for Objects: Use these checkboxes to control where Hotspots should appear on the 

imported model. 

KMZ Import Optimization

Use these two checkboxes if importing the Google Earth model is taking too long. 

• Collect 3D geometry placemarks into a single Library Part: If you check this, ARCHICAD will generate 

a single GDL object for multi-geometry placemarks (instead of separate ones). This can reduce the time it 

takes to import the .kmz file.

• Display 3D geometry placemarks without fills: This option can speed up navigation in large models.

Altitude Settings

In Google Earth, there are several ways to export altitude data, but ARCHICAD supports only the “Absolute 

altitude” method.

If your .kmz file contains alternative altitude settings (either “Clamped to ground” or “Relative to ground”), an 

information dialog appears: you should reexport the model from Google Earth using the Absolute altitude 

method.

See also Google Earth: Export and Import Limitations.

Stereolithography (.stl)

Use the File > Open command or File > Interoperability > Merge to open or merge an .stl file directly in 

ARCHICAD. An opened or merged STL model will be opened as a Morph in ARCHICAD.

STL files only carry the 3D model’s surface geometry, divided into triangles, without any additional information 

such as color, surfaces etc.

The format is usually used for rapid prototyping, 3D printing, and computer-aided manufacturing. STL format 

has two kind of representation: ASCII and Binary

• ASCII STL

An ASCII STL file lists the triangles with the coordinates of their nodes in a readable format for any text 

editor application.

• Binary STL

In a Binary STL file the data is compressed but only readable for the appropriate STL application/machine.

Binary representation is more commonly used due to its smaller file size.

More about STL format: http://en.wikipedia.org/wiki/STL_(file_format)

For information about saving an ARCHICAD model to STL format, see Stereolithography (.stl).

Open STL file

1. Go to File > Open > Open file

2. Select Stereolithograpy File as file type

3. Browse for the STL file

4. Click Open

Merge STL file into existing model

1. Go to File > Interoperability >Merge

2. Select Stereolithograpy File as file type
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3. Browse for the STL file

4. Click Open

Limitations

1. ARCHICAD does not check the exported STL file for errors, e.g. in terms of solidity. These are usually 

done by the 3D printer.

2. STL file does not store the scale and unit of the model, these have to be set in the viewer/printer. 

ARCHICAD always exports 1 m as 1 STL unit.

3. If the imported geometry is very complex, it may affect the performance of ARCHICAD. In this case, you 

will see a warning dialog.

4. Note that if the geometry of the model is overly complex, there is a chance that the import will fail and no 

object will be generated.
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Other Formats Opened by ARCHICAD

HPGL File (.plt)

For details, see Plot.

Windows Enhanced Metafile (.emf)

Windows Metafile (.wmf)

Point Cloud Data File (.e57)

See Working with Point Clouds.

Surveyors’ data (.xyz)

Import any text file containing xyz data (e.g. surveyor’s data), or similar data, into ARCHICAD, creating a 

Mesh element automatically.

Note: To convert .xyz files to Point Cloud objects placed in ARCHICAD, see Working with Point Clouds.

Note: The text file must consist of rows of data, with each row containing three numerical entries. The row 

can be optionally preceded by an additional numerical ID. Use separators between the data entries. 

Separators must be used consistently. The separator can be a semi-colon or a white space; you can also 

use commas or periods, provided that you do not also use the same character as a decimal marker in this 

file. Any row in which the 3 data (or 3+1, in case of ID’s) is preceded or followed by a non-numerical data 

entry is considered a “comment” and will not be calculated. If the data in the text file is entered in an 

inconsistent format, a warning will appear that the file format cannot be read.

1. Click File > Interoperability > Place Mesh from Surveyors Data.

2. In the appearing directory dialog box, browse for a .txt or .xyz file containing the data you need.

3. The Place Mesh from Surveyors Data dialog box appears:

– Surveyors unit: Enter the unit for the survey data.

Placement:

– Define graphically: You will place the Mesh with a mouse-click in the desired location.

– Use coordinates of data file: The new Mesh will be placed according to the zero-point as defined in 

the surveyors data file.

In this case, you can optionally Zoom to the new mesh as soon as you place it.

Project Zero is above Sea Level by: Enter the elevation of your Project Zero above Sea Level (in the 

Surveyors Unit you have defined). ARCHICAD will take this into account when converting the z-values of the 

surveyors data file into the Mesh.
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File Types Saved by ARCHICAD

The file types saved by ARCHICAD are listed here, in the following categories:

ARCHICAD File Types Saved by ARCHICAD

CAD Formats Saved by ARCHICAD

Image Formats Saved by ARCHICAD

Model/3D Formats Saved by ARCHICAD

Document and Other Formats Saved by ARCHICAD
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ARCHICAD File Types Saved by ARCHICAD

ARCHICAD Projects (.pln)

ARCHICAD supports unicode file names of essentially unlimited length.

Archive (.pla)

For details, see Archive Projects.

ARCHICAD Project Template (.tpl)

Choose this option if you want to save the current project settings for future use as a template.

For details, see Template Files.

Archive Options

For details, see Archive Projects.

Project (.pln) in an earlier ARCHICAD version format

ARCHICAD 24 can back-save project files in ARCHICAD 23 format only (among previous ARCHICAD file 

formats).

To back-save:

1. Use File > Save as...

2. In the Save dialog box, choose ARCHICAD 22 Project from the Save as type list.

Backward Compatibility Supported for Library Parts

When back-saving your ARCHICAD project, any library parts that were revised for the latest version will be 

automatically replaced by their counterparts in the previous version.

However, if the library part in the latest-version project is using new parameters or functions that did not exist 

in the previous version, that library part will not be replaced when you back-save the project: it will be a 

missing library part.

In the Options of the Save as dialog box, you can uncheck the Convert library parts backward checkbox. 

This way, the library parts revised for the latest version will not be replaced by their original counterparts in the 

previous version, and will be shown as “missing”.

BIMx File Format/BIMx Hyper-model

For details, see GRAPHISOFT BIMx.

PlotMaker Drawing (.pmk)

Use the Publisher to save a model view in PMK file format. 

For details, see Defining Publisher Output Format.

Module File; Module File from Clipboard (.mod)

For details, see Create Module (.mod) File.
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GDL Script (.gdl)

This option will save your model in GDL script.

For details, see GDL Object Editor.

ARCHICAD 2D Lines (.2dl)

These files are vectorial drawings saved from ARCHICAD’s 3D Window (using the Vectorial 3D Engine). 

These drawings contain no model information and can be touched up in the Floor Plan with 2D tools.

Important note: In the 3D Window, this option is only available with the Vectorial 3D Engine - not 

available in OpenGL mode.
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CAD Formats Saved by ARCHICAD

DWF File (.dwf)

You can save Floor Plan and Section/Elevation/IE or 3D Document views in DWF (Drawing Web Format):

Activate the required story or Section/Elevation/IE or 3D Document window and choose the Save as 

command in the File menu. Select the DWF file format from the list, click the Save button and choose one of 

the following options:

• ASCII - readable and editable ASCII text file. May be rather long.

• Binary - binary file with a smaller size than the ASCII version.

• Compressed Binary - smallest, most easily transportable compressed binary file.

• You can view the saved DWF file with any web browser that supports the DWF Plug-In. You can download 

a DWF viewer from: http://www.autodesk.com/products/. A Java-based public domain viewer - with some 

limitations - can be found at: http://www.cadviewer.com.

DXF/DWG Files (.dxf, .dwg)

For details, see Saving DWG/DXF Files.

MicroStation Design File (.dgn) - Version 7

Use File > Save as..., and choose the MicroStation Design File (.dgn) file format.

The ARCHICAD to MicroStation converter exports 2D views (plan, elevation and section windows) from 

ARCHICAD into 2D MicroStation format (version 7 only).

In the appearing dialog:

Specify the background color and Working Units for the exported file.

All elements are exported as drawing primitives (points, lines, arcs, texts, polylines, triangles, and polygons).

Config File

During the output, you are prompted to designate an optional configuration file (.txt), which controls the layer 

assignment, line type, font and color conversion.
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• The DGN v7 format is limited to 64 layers. If the ARCHICAD file contains more, then it rolls around. The 

configuration file can control the correspondence between layers. In the absence of the configuration file, 

the default order is alphabetical.

• Pen color conversion: Defined in the configuration file. Otherwise, the Add-On will use the default 

assignments.

• Font conversion. If the configuration file is missing, the add-on will default to the international vector font 

(always present in MicroStation).

– If you define a Chicago-Chicago translation, make sure that the Chicago TrueType font is loaded into 

MicroStation (with the Element > Text > View > File >Import command). If it is not loaded, it will 

revert to the default.

If you would like the text to look the same in both files, use monospaced fonts (e.g., Courier) on the plan.

Symbol hatches and linetypes are not exported in this version.

After the DGN file is loaded into MicroStation, you must use the Full View command to see the entire drawing; 

it will not adjust the scale automatically.

See also Open MicroStation Design File (.dgn) - Version 7 or 8.
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Image Formats Saved by ARCHICAD

Windows BMP Image (.bmp)

Click Options to set output preferences.

JPEG Image (.jpg)

Click Options to set output preferences.

GIF Image (.gif)

Click Options to set output preferences.

TIFF Image (.tif)

Click Options to set output preferences.

PNG Image (.png)

Click Options to set output preferences.
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Model/3D Formats Saved by ARCHICAD

IFC (.ifc), IFCXML (.ifcxml), IFCzip

IFC stands for Industry Foundation Classes.

To read more about IFC, see Working with IFC, or download the IFC manual from: 

http://www.graphisoft.com/support/ifc/downloads/

Structural Analytical Format (.xlsx)

Use this to export the model to structural analysis programs.

See Collaboration with Structural Analysis Software.

Rhino (.3dm) - Save

From the 3D window, use Save as Rhino 3D Model (.3dm) to export part or all of the ARCHICAD model to 

Rhino. 

See also Working With Rhino 3D Models.

WaveFront File (.obj)

You can save 3D models and their surfaces in the WaveFront format, a photorealistic rendering/animation 

system.

Two output files are generated: one for the geometry and one for the surface material definitions, according to 

the WaveFront standards. The .mat file is automatically created in the same folder that was selected in the 

Save as dialog box for the .obj file.

The document you save will include the following information:

• 3D model geometry (.obj file): All geometric surfaces. No edges in the WaveFront format.

• ARCHICAD surfaces (.mat file): All surface attributes used in the model, identified by name, with full 

characteristics.

After choosing the .obj file format, click Save. The WaveFront dialog box opens:

• Layers-Surfaces: Click this radio button to create groups in the WaveFront file for each ARCHICAD layer, 

and within these groups, create internal groups for each surface.

• Elements-Surfaces: Click this radio button to create a group in the WaveFront file for each ARCHICAD 

construction element, and within these groups, create internal groups for each surface.

Set drawing unit to: In this field, you can define the distance in the WaveFront project that will be translated 

into a drawing unit in ARCHICAD or vice versa. As ARCHICAD works with metric data internally, setting the 

drawing unit to 1 meter (=1000 mm) will result in a 1:1 model after the conversion.

3D Studio File (.3ds)

3D files can be saved in 3D Studio format. The Add-On required for this is part of the ARCHICAD package.

3D files in 3D Studio format can be opened by ARCHICAD only if you install the Goodies for your language 

version of ARCHICAD.

See Goodies.

Saving in .3ds format

With the 3D window in front you can save 3D models of your projects in Autodesk’s 3D Studio 3DS 

photorealistic rendering and animation file format.
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The resulting document will include the following information: 

• 3D model geometry: All surfaces and all edges.

• Surfaces: All surfaces used in the project, including the name and the characteristics.

• Light sources: Both the sun and the additional light sources are included. Sun will be handled as a 

spotlight very far away from the project.

• 3D projection: The current perspective settings and Fly Through paths are included.

• Shadow casting information: The current shadow casting setup in the PhotoRendering Settings/Effects 

dialog box of ARCHICAD is included.

• Smooth (welding) information: The smoothing setup in the PhotoRendering Settings/Effects dialog box 

of ARCHICAD is included.

After choosing the .3ds file format, click Save. The Save 3D as 3D Studio object dialog box opens:

• Construct 3D Studio objects according to ARCHICAD objects: Click this button to create a 3D Studio 

file without grouping.

• Construct 3D Studio objects according to Element types and Surfaces: Click this button to create a 

group in the 3D Studio file for each ARCHICAD construction element, and within these groups, create 

internal groups for each surface.

• Construct 3D Studio objects according to Layers and Surfaces: Click this button to create groups in 

the 3D Studio file for each ARCHICAD layer, and within these groups, create internal groups for each 

surface.

• Construct 3D Studio objects according to Surfaces: Click this button to create a group in the 3D 

Studio file for each surface.

• Drawing Unit: In this field, you can define the distance in the ARCHICAD project that will be translated 

into a drawing unit in 3D Studio. As ARCHICAD works with metric data internally, setting the drawing unit 

to 1 meter (=1000 mm) will result in a 1:1 model after the conversion.

• Colors: You can choose either the ARCHICAD pen colors, or match the ARCHICAD colors to a similar 3D 

Studio color.

• ARCHICAD texture information: You can select whether to include surface texture information in the 3D 

Studio file.

• Object = Group Name: You can select whether the object’s name should be a generated unique ID or the 

group’s name.

Note that 3D Studio works with names up to 10 characters. For names generated by ARCHICAD the 

convention is the following:

• Chars 1 to 7: unique ID or clipped layer/surface name.

• Chars 8 to 9: used for a distinctive number to avoid identical names generated by clipping. Up to 100 

variations of the same name are allowed this way.

• Char 10: used for slicing information. 3D Studio can handle up to 65,536 polygons by object. If an object 

has multiple polygons, ARCHICAD will split the object into several objects and put the segment number 

into Char 10.

ElectricImage File (.fact)

You can save 3D models of your projects in the FACT format for ElectricImage Animation System (EIAS), a 

photorealistic rendering/animation system.

The document you save will include the following information:
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• 3D model geometry: All surfaces. (No edges in the FACT format.)

• Surfaces: All surfaces used in the project, including the name and characteristics.

• Light sources: Both the sun and the additional light sources are included.

• 3D projection: The current perspective settings are included.

With the 3D window in front, choose File > Save as, or Document > Creative Imaging > Create Fly-

Through. The Save 3D FACT Document dialog box will appear:

• Grouping hierarchy according to ARCHICAD Layers: Click this button to create groups in the FACT 

file for each ARCHICAD layer.

• Grouping hierarchy according to ARCHICAD Elements: Click this button to create a group in the FACT 

file for each ARCHICAD construction element. Do NOT use this grouping option for large models. EIAS is 

not very efficient when working with a large number of groups.

• Grouping hierarchy according to ARCHICAD Surfaces: Click this button to create groups in the FACT 

file for each ARCHICAD surface.

• Color Blend, Super Sample, Self Shadowing: Of the numerous FACT group attributes, these three can 

be controlled from within ARCHICAD. To learn more about these and other group attributes, see the EIAS 

documentation.

• Output Format: You can choose to save your file in either ElectricImage 2.1 or 2.9 format.

• Set Drawing Unit to: In this field, you can define the distance in the ARCHICAD project that will be 

translated into a drawing unit in ElectricImage. As ARCHICAD works with metric data internally, setting the 

drawing unit to 1 meter (=1000 mm) will result in a 1:1 model after the conversion.

Note: You do not need to use the Transporter application required for previous versions. ARCHICAD 

automatically transforms the coordinate system to match the EIAS specification.

VRML File (.vrl)

You can save 3D models of your projects in the VRML format. VRML is an acronym for the Virtual Reality 

Modeling Language. Using VRML you can build your own three-dimensional virtual worlds and link them 

together on the World Wide Web. To view VRML worlds, you need a VRML helper application (or plug-in) 

called VRML browser. Check both your HTML and VRML browsers manual to see how to configure them.

The document you save will include the following information:

• 3D model geometry: All surfaces as IndexedFaceSet elements including surface attributes.

• Surfaces: All surfaces used in the project. Texture data is included; texture coordinates will be computed 

by the VRML browser. Check your browser manual to see what texture image file formats it supports.

• Light sources: Additional light sources are included. If no additional lights are placed you have to use 

your VRML browser’s default headlight.

• 3D projection/Animation path: The current perspective settings are included.

Set up a 3D view and with the 3D window at the front, choose Save as from the File menu and choose the 

VRML format, or place any number of cameras on the Floor Plan and choose Create Fly-Through and set 

the Result to VRML File, then click Save. The Save VRML 3D Document dialog box will appear:

• Copy textures to destination folder: Check this box to export the surface textures used by the 

ARCHICAD model.

• Write vertex normals: Check this box to export normal vectors.

With these options active, you can export a sophisticated and complex model. If the viewer application does 

not display the model correctly, try exporting again with one or more checkboxes inactive.
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Lightscape File (.lp)

You can save 3D models of your projects in the native file format of Lightscape, a visualization system for 

generating lighting simulations of three-dimensional models using a radiosity algorithm.

The document you save will include the following information: 

• 3D model geometry: All surfaces.

• Surfaces: All surfaces used in the project, including the name and characteristics.

• Textures: Exported surfaces will refer to the appropriate texture according to the current settings of the 

surface dialog. Texture images are not included in the output file: however, the path of the first texture file 

is included. If all the image files are collected into a single ARCHICAD library folder, the visualization 

system will automatically locate them. Otherwise, you will have to collect and copy these image files into 

the appropriate folder of the visualization system.

Note: Use DOS filename conventions for naming texture image files when working with Lightscape. 

Before saving the Lightscape model, open the Surfaces dialog box, check the image names and make the 

necessary changes.

• Light sources: All light sources used in the project, except the sun. Shadow casting information is also 

exported according to the current settings of the PhotoRendering effects dialog box.

• Projection information: 3D projection data exported as the default view in Lightscape. Only perspective 

views can be used. If you choose an axonometric view, the saving process will report an error.

Set up a 3D perspective view in ARCHICAD, generate the view, then choose File > Save as. In the list, 

choose the Lightscape document format, and click the Save button. The Save as 3D Lightscape Object dialog 

box appears:

• Construct Lightscape objects according to Layers: Click this radio button to create groups for each 

ARCHICAD layer in the Lightscape file.

• Surfaces: Click this radio button to create groups for each ARCHICAD surface in the Lightscape file.

Decompose elongated triangles: Check this box if you want to decompose elongated triangles into smaller 

triangles. This will generate a more detailed mesh, which is useful for Lightscape‘s radiosity algorithm.

Note that in the case of very large scenes, it may excessively increase the number of polygons (and the 

file size).

U3D File (Windows Only)

See 3D Content in PDF.

SketchUp (.skp)

From the 3D window, use File > Save as to save the ARCHICAD model in .skp format.

In the appearing Sketchup Export Options dialog box:

• Check which elements and layers to export; use these options to optimize the size of the exported model

• Choose the particular Sketchup format you want to save to.

The resulting SketchUp file’s global location coordinates will correspond to ARCHICAD’s project location 

coordinates.

The pin in the SketchUp file (the location reference point) corresponds to the ARCHICAD project origin.

See also SketchUp: Export and Import Limitations.
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Google Earth (.kmz)

There are two ways to save an ARCHICAD model to Google Earth:

1. Use File > Interoperability > Send Model to Google Earth.

The model is saved as a .kmz file and opened in Google Earth in one step. You must have Google Earth 4 

or newer installed on the computer.

Note on Altitude: Use “Set Altitude as” options in the 3D Model Export Options in Google Options to 

determine how your ARCHICAD model will be placed into Google Earth.

2. From the 3D window, use File > Save as to save the ARCHICAD model in .kmz format.

In the Save as dialog box, click Options to see export options specific to .kmz format:

• Choose whether to export the active ARCHICAD camera as the ‘look at viewpoint’ in the kmz file. 

• Set altitude using one of two methods: Absolute Altitude (above sea level) or Clamped to Ground. 

“Absolute” means that your model will be placed at its exact altitude, as defined in ARCHICAD. “Clamped 

to ground” means that your model will be placed on the ground at the defined location (similar to 

ARCHICAD’s “Gravity” function).

See also Google Earth: Export and Import Limitations.

Stereolithography (.stl)

Use the File > Save as dialog to save an ARCHICAD model to STL format.

STL files only carry the surface geometry of a 3D model without any additional information such as color, 

surface etc. It contains the surface divided into triangles.

The format is usually used for rapid prototyping, 3D printing, and computer-aided manufacturing. 

Save to STL format

1. Open 3D window with only those elements visible that you wish to export.

2. Go to File > Save as

3. Select Stereolithograpy File as file type

4. Browse for the destination folder

5. Enter the file name

6. Click Save

7. In the Save 3D as STL dialog, choose from Binary or ASCII representation.

– ASCII STL

An ASCII STL file lists the triangles with the coordinates of their nodes in a readable format for any 

text editor application.

– Binary STL

In a Binary STL file the data is compressed but only readable for the appropriate STL application/

machine.

Binary representation is more commonly used due to its smaller file size.

More about STL format: http://en.wikipedia.org/wiki/STL_(file_format)

For information about opening or merging an STL file to ARCHICAD, see Stereolithography (.stl).
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Limitations

1. ARCHICAD does not check the exported STL file for errors, e.g. in terms of solidity. These are usually 

done by the 3D printer.

2. STL file does not store the scale and unit of the model, these have to be set in the viewer/printer. 

ARCHICAD always exports 1 m as 1 STL unit.

Twinmotion

Save the ARCHICAD model to Twinmotion, using the Save As… Twinmotion (.tma) command from the 3D 

window.

Artlantis

Export the 3D model to Artlantis version 6.5, 7, 2019 or 2020 (*.atl).

See Export to Artlantis.
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Document and Other Formats Saved by ARCHICAD

PDF (.pdf)

Click Page Options and Document Options to set output preferences. These options will vary depending on 

the active window from which you are saving.

For details, see Save Document in PDF Format.

Windows Enhanced Metafile (.emf)

Click Options to set output preferences.

Windows Metafile (.wmf)

Click Options to set output preferences.
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Merging Files to ARCHICAD

Use the File > Interoperability > Merge commands to paste the elements of another ARCHICAD Project, a 

Module, DWF/DWG/DXF, HPGL (.plt) file, IFC file, Rhino (.3dm) or other image or model-type file into 

ARCHICAD.

Merge from a local file or from BIMcloud.

Files can be merged into either the current Floor Plan, the currently open Section/Elevation/IE, 3D Document 

or Detail/Worksheet window.

Note: When merging a Module into a Section/Elevation/IE or 3D Document window, only 2D Elements will 

be pasted.

The elements of the merged files will become independent of each other after being placed. You can place the 

same elements repeatedly with the Paste command.

When merging a Project or Module, you can drag, rotate and mirror it before placing it to the final location. 

Until the file is placed, its elements will be surrounded by a dashed rectangle. Click within the rectangle to 

move the elements to the desired position. Click outside the rectangle, or click OK from the context menu (or 

the Control Box) to place the elements.

Merging and Story Structure

When merging a Project or Module file, ARCHICAD matches the stories of the merged (imported) file to the 

current (open) one. When you merge a multistory building into your current Floor Plan, ARCHICAD will ask 

you to define which story from the imported file will match the story you are working on, and it will also suggest 

a possible match.
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If you do not have enough stories in your current plan to accommodate all the merged ones, ARCHICAD will 

automatically create the missing stories.

Note: You cannot merge multistory elements or modules into 2D windows other than the Floor Plan.

Note: There is a difference between merging a multistory project, and placing a multistory Hotlink Module. 

If the host project contains fewer stories than the Hotlink Module you are placing, the module stories 

which do not “fit” in the host project will not be placed. To resolve this, create additional stories as needed 

in the Host project.

Top Linked Elements of Merged Model

• Adjust Height to Story Structure of Host Project: Top Linked elements will stretch or shrink to match 

the corresponding story structure of the host file. (Doors/Windows whose sill or header is linked to a 

particular story will adjust to the current file’s story structure.) 

• Keep Height as in Story Structure of Original Model: Top Linked elements will not stretch (they retain 

their original heights). (Doors/Windows whose sill or header was linked to a particular story in the merged 

file will lose the story link, and instead will be linked to the Wall base.)

Merging and Attributes

Since attributes (Layers, Surfaces, Lines, Fills, etc.) are identified by their names, the following rules are 

observed:

• If the name of the attribute is the same in the two ARCHICAD Projects, the merged (imported) elements 

will inherit the attributes of the current Project.

• If the name of an attribute for the merged Project is not present in the current one, this attribute is 

appended to the current Project’s attribute set to accommodate the new names.

Merge DXF/DWG File

If you merge a dxf/dwg file, the Merge DXF-DWG dialog box appears.

See Merge DXF-DWG.

Merge IFC File

For details, see Import IFC Model to ARCHICAD.

Merge Stereolithography (.stl) File

See Stereolithography (.stl).

Merge SketchUp (.skp) File

Use File > Interoperability > Merge to merge content from an .skp file into an existing ARCHICAD model. The 

Floor Plan must be active in ARCHICAD.

Since the ARCHICAD model already contains project location information, you are asked in a dialog how to 

handle the two sets of coordinates (ARCHICAD and SketchUp): 

• Overwrite the ARCHICAD information with the SketchUp information

• Ignore the SketchUp information. Your Project Location information remains as-is, and you can place the 

imported object anywhere you wish: drag the appearing boundary box and click to place.

• Place the incoming information relative to the existing coordinates. The imported object will be placed in 

its true location relative to your project origin.
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Step by Step Guide for Merging a Google Earth Snapshot into ARCHICAD using SketchUp

1. Open a project in ARCHICAD

2. Open the Project Location dialog box, check that it has the desired longitude and latitude set

3. Press the ‘Export’ button

4. Set the format to ‘SketchUp file’

5. Give a new file name and press ‘Save’

6. Close the ‘Project Location’ dialog box.

7. Using SketchUp (downloadable from http://www.sketchup.com) open the file saved in step 5

8. Open up the ‘Model Info’ dialog and check that the ‘Geo-location’ is set

9. If not (if using Mac), click the ‘Set Manual Location…’ button: the correct longitude and latitude should be 

displayed; press OK

10. Use SketchUp > File > Geo-Location > Add More Imagery… to open the ‘Add Location’ dialog box; the 

Google Earth image should be centered at the ARCHICAD origin

11. Zoom in or out as desired

12. ‘Select ‘Region’ and ‘Grab’ it

13. The same region should now be visible in the SketchUp file viewer

14. Save the changes to the .skp file

15. Return to your ARCHICAD project file

16. With the ‘Ground floor’ view open, select File > Interoperability > Merge

17. Select the .skp file you just saved in step 14

18. A dialog box containing three toggle buttons should appear. Choose the ‘Place the new geometry relative 

to existing coordinates’ option and press OK

19. The Google Earth snapshot should now appear in the ARCHICAD project

20. Open a 3D view and fit to see the snapshot in detail

See also SketchUp: Export and Import Limitations.

Merge Google Earth (.kmz) File

Use File > Interoperability > Merge to merge content from a .kmz file into an existing ARCHICAD model.

The options are similar to the Open Google Earth file process.

See Google Earth (.kmz).

Location Information

Since the ARCHICAD model already contains project location information, you are asked in a dialog how to 

handle the two sets of coordinates (ARCHICAD and Google Earth): 

• Overwrite the ARCHICAD information with the Google Earth information

• Ignore the Google Earth information. Your Project Location information remains as-is, and you can place 

the imported object anywhere you wish: drag the appearing boundary box and click to place.

• Place the incoming information relative to the existing coordinates. The imported object will be placed in 

its true location relative to your project origin.

See also Google Earth: Export and Import Limitations.
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Merging Image-Type Files

You can merge an image-type file into your ARCHICAD Project. (These include documents created in drawing 

or painting programs; 3D views and elevations saved in picture format; PhotoRenderings saved only in picture 

format.) Before choosing Merge for an image-type file, you can define its size on the plan in advance: Choose 

the Marquee tool and draw a Marquee of the desired size and position.

See also Marquee Area.
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The merged image will fit into this rectangle.

Note: Be careful to draw the Marquee with the same proportions as the original picture, otherwise the 

figure will be distorted.

SketchUp: Export and Import Limitations

• SketchUp models can contain two types of object faces and edges. Currently, standalone SketchUp 

edges are not imported into ARCHICAD.

• In SketchUp a single face can have different front and back colors and textures. In ARCHICAD a GDL 

face can only have one color and texture defined. ARCHICAD’s import function defaults to the front face’s 

properties unless the back face has texture defined and the front face doesn’t.

• SketchUp models containing faces that are very irregular (outside boundary crossing itself, i.e. figure of 

eight) or faces that contain holes may be imperfectly imported into ARCHICAD

• Some SketchUp faces get imported into ARCHICAD but lose their texture

• There is a flag in the .skp format to state whether the file is Geo-referenced or not. The Mac version of 

ARCHICAD is unable to correctly set this flag and the exported .skp files may require that the flag be 

manually turned on (the longitude and latitude are always correctly set in the .skp file).

Google Earth: Export and Import Limitations

• Occasionally Google Earth .kmz files contain triangular faces with very small angles that are not imported 

into ARCHICAD

• If the ARCHICAD 3D view is such that the camera is positioned underground, then the view shown in 

Google Earth isn’t the same as in ARCHICAD.
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Import/Export Property Data via Spreadsheet

Use this workflow to enable outside consultants to fill out an automatically configured Excel spreadsheet with 

Property data, for easy import to the corresponding elements/Building Materials in your ARCHICAD model.

For an overview of Properties in ARCHICAD, see also Properties and Classification Systems.

1. In ARCHICAD, save an Interactive Element Schedule that you will use for the data exchange. The fields 

of the Scheme Settings should include parameters to identify the items (e.g. Element ID) and selected 

Properties which require data from the consultant. It is recommended to set these to “Undefined”, so the 

consultant knows which data are needed.

See Assign Classifications/Properties in Element Schedule.

2. Use the File > Interoperability > Classifications and Properties > Export Property Values from 

Schedule command.
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3. In the appearing dialog box, select the Element Schedule Scheme that you prepared in Step 1 above. This 

scheme will serve as the basis for the data exchange.

4. Enter a file name, then click Save to save it as a spreadsheet in Excel format (XLS or XLSX).

5. Send the spreadsheet to the consultant (he/she does not need ARCHICAD or any other BIM program).

6. In the Excel file, the consultant fills out the cells that require values, saves the file and sends it back to 

you. 

Note: In the spreadsheet, any cell showing a black dashed line means that the property is not available 

for that item, and can be ignored by the consultant. 
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7. In ARCHICAD, import the Excel file using File > Interoperability > Classifications and Properties > 

Import Property Values into Elements.

8. The Import Property Values dialog box shows a preview of the data to be imported. Here you can filter the 

imported properties: uncheck any properties that you don’t want to import.

Note: Only Element Properties can be imported to ARCHICAD. Other parameters are ignored in the data 

exchange (they are shown in grey in this preview).

9. The preview highlights any errors or inconsistencies: see Manage Data Errors, below. You cannot import 

data if there are any errors present.

10. If the data is free of errors, click Import to automatically add the element-specific property values from the 

spreadsheet to the ARCHICAD model elements.

Undo will reverse the entire data import process.

Manage Data Errors

When you import data to ARCHICAD using Import Property Values, the preview highlights any errors or 

inconsistencies. You cannot import data if there are any errors present.

ARCHICAD gives you help in fixing them.
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In the preview window, hover over such fields to see information on the issue.

Note the codes:

• Black data items: Valid data, will be imported (provided that the property’s box is checked. If unchecked, 

such properties are grey and will not be imported.)

• Grey data items: These are not element properties and will not be imported.

• Red data items: Invalid or missing data; cannot be imported. Possible reasons: 

– Data format is wrong (e.g. the entered data does not correspond to one of the property’s defined 

options in an Option Set)

– Data is missing (the cell says “missing” in red)

– The property is not available for the element (the cell has a line in red)

– The model element that the property applies to is not available, because it is on a locked layer, part of 

a Hotlinked Module, not reserved in Teamwork, or has been deleted

• Blue data items belong to duplicate properties or duplicate elements. Only the values of the first instance 

of this property will be imported. The duplicate items themselves are marked with an information icon.

• Orange data items are hidden in ARCHICAD due to an Add-On (e.g. the freeBIM Manager).

• Warning triangle: The property does not exist in the target project.

To proceed, you can either uncheck the properties that are problematic (these values will be skipped entirely), 

or you can correct the data before import.

To correct the data:

1. Click Save Report. This creates an Excel spreadsheet which highlights data errors and provides further 

information on them.
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2. Open the Report spreadsheet and fix the errors as needed. (Add missing data, delete duplicate 

properties, fix invalid formats, provide data for Undefined properties.)

Note that the spreadsheet’s Legend sheet provides additional help for understanding errors/color codes.

3. Once the errors are fixed, return to ARCHICAD and import the Report spreadsheet.

– If the Import Property Values dialog box is open, click Browse to open the newly saved Report 

spreadsheet.

– Or use Import Property Values to browse for the spreadsheet.
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4. If all data is OK, click Import.
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Import BIM Content

ARCHICAD enables the one-step import of BIM data that have been predefined in an external ARCHICAD file 

(PLN, PLA or TPL format). With this function, you import the following BIM Content to your ARCHICAD 

project:

• A Classification System

• Any Properties belonging to that Classification System

• The IFC Translator “Mapping” presets which refer to that Classification System:

– Type Mapping for IFC Import

– Type Mapping for IFC Export

– Property Mapping for IFC Export

– Property Mapping for IFC Import

Import BIM Content from ARCHICAD File

Use the Import BIM Content command to browse for any ARCHICAD file that you have prepared or 

downloaded, which contains the needed Classification System and other definitions. 

1. Go to File > Interoperability > Classifications and Properties > Import BIM Content.

2. From the appearing Merge BIM Data dialog, browse for any ARCHICAD file (PLN, PLA or TPL format) 

which contains the Classification/Property/IFC Translator Mapping definitions that you need.

3. Click Open to import these data.

See also Conditions for Downloading or Importing BIM Content, below.

Download BIM Data File from Website

With this command, you browse for and download a preconfigured ARCHICAD file. 

These files, predefined for various international standards, are available at GRAPHISOFT’s website: https://

www.graphisoft.com/downloads/archicad/BIM_Data.html

1. Go to File > Interoperability > Classifications and Properties > Download BIM Content.

The same link is available from:

– Classification Manager

– Property Manager

– IFC Translators dialog box
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2. This takes you to a GRAPHISOFT website, where you can choose an ARCHICAD file containing standard 

Classification/Property/Mapping definitions.

3. Download the file to any location.

4. Use File > Interoperability > Classifications and Properties > Import BIM Content to browse for and 

import the downloaded file.

Conditions for Downloading or Importing BIM Content

The import will work only if none of the imported data already exist in the receiving ARCHICAD project. If data 

already exist, you get a warning that the import failed.

Consult the Report Window in ARCHICAD (scroll to the bottom of the window as needed) to see which data 

are in conflict.

In this case, delete the duplicate data from your project, then use Import BIM Content again. 
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Working with PDF Documents

The following sections describe how to output PDF documents from ARCHICAD.

Create PDF Output Using the Publisher

Save Document in PDF Format

3D Content in PDF

Explode into Current View (PDF Document Source)

Export/Import Issues Using PDF Markup 
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Create PDF Output Using the Publisher

From the Publisher, you can save Publisher Sets, or one or more Publisher items (views or layouts), in 

Acrobat PDF (Portable Document Format). (Publisher items are set to PDF format by default.)

1. Go to the desired Publisher Set in the Navigator’s Publisher mode.

2. Make sure that “Save” is selected from “Publishing Properties.”

See Save Publisher Set.

3. Choose one or more Publisher item(s) from the Publisher Set.

4. In the Format section of the Publisher, set Format to “PDF.”

If the contents of a folder are all in PDF format, a checkbox gives you the option to Merge to one PDF file. 

(Make sure you select the folder that contains the PDF format items.) If you leave this checkbox unmarked, 

you will publish each file in the folder as a separate PDF file.

Note: Once you have checked the “Merge to one PDF file” for one of the Publisher map folders (or for the 

entire Layout Book), the option is no longer available for any of its subfolders. To change your PDF merge 
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preference to a lower-level folder, first uncheck this preference for the higher-level folder (or at the Layout 

Book level).

5. Click Page Options to set the Paper Size and Orientation of the resulting PDF Document.

Note: The Page Options button is available if any of the selected Publisher items are views. If the 

Publisher items are layouts, their page options are taken from the layout settings; in this case, the Page 

Options button is not visible.

6. Click Document Options to define your preferred settings for the content of the resulting PDF Document. 

These are similar to the options in the Print 2D/Print 3D dialog boxes.

Here, you can save the contents in Color, Black & White, or Grayscale.

7. At the bottom left of the Document Options dialog box, click PDF Options and set the options as desired.

See PDF Options for details.

8. Click Publish.

9. Browse for the PDF output at the Path you defined in Publisher Set Properties.
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PDF Options

Content Options

PDF/A archive format

The default is PDF/A-2a.

Notes: 

– If you choose one of the PDF/A formats, you cannot also set a password.

– If you choose one of the PDF/A formats, the U3D file embedding option is not available!

See 3D Content in PDF.

– The PDF/A-1a and PDF/A1b formats do not support transparency effects. (These features are 

available with the PDF/A-2 formats.)

For more information on the PDF/A standards, see: ISO 19005-1:2005 Part I: Use of PDF 1.4 (PDF/A-1) and 

ISO 19005/2:2011 Part 2: Use of ISO 32000-1 (PDF/A-2).

Watch the Video

Export Layers to PDF

When saving a view or layout in PDF format, information on the visible layers of that view/layout - if they 

contain elements - will also be saved to the PDF document. The Export Layers to PDF checkbox is checked 

by default.
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When you open the resulting PDF document, you can show or hide the content by layer. (Click the Layers 

panel on the Navigation Pane. If you do not see the Layers panel, or use View > Show/Hide > Navigation 

Panes > Layers.) The layer names are the same as in ARCHICAD.

Restrictions on Exported Layers:

• Items placed directly on Layouts are exported without layer information, so their visibility cannot be 

controlled in the PDF.

• Layers that do not contain any elements are not exported

• Hidden layers are not exported

• Embedded layers are not exported

Watch the Video

Embed 3D Content

See 3D Content in PDF.

Security Options

Include Project Info in PDF

This checkbox is active by default: when you save a project in PDF format, the PDF retains the ARCHICAD 

Project Info data (entered at File > Info > Project Info). This can be read in the PDF’s Document Properties 

(File > Properties). 

It can be useful to uncheck this box if you do not want the PDF to display e.g. the Architect Name (as the 

Author shown in the PDF Document Properties) - for example, if the PDF is to be submitted as part of an 

anonymous competition.

Require Password

Check the box if you want to password-protect the document.

Additional Security Options

Check any of the following to allow the PDF’s recipient to access or modify the contents:

• Allow to annotate or modify

• Allow to explode or copy contents

• Allow print
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Resolution Options

Arc Resolution

The Arc resolution setting reflects the fact that the PDF format does not recognize arcs/circles and must 

approximate them by converting them to polygons. The Arc resolution setting defines the accuracy of these 

polygons.

Limit image resolution to:

The maximum image resolution of the images saved to PDF. Images whose resolution is less than this limit 

will remain as-is.

Choose a compression option:

• Compress all images: All images will be converted to JPG format, which entails a compression to 80%.

• Retain lossless image compression where possible: Images will saved in PNG format (and remain 

lossless). If the original image was in JPG format, it will remain JPG.
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Save Document in PDF Format

Go to File > Save As, and choose PDF as the file format.

PDFs created with ARCHICAD can include standard PDF features such as layers, thumbnails, and 

bookmarks.

Note: To limit the window contents to be saved, use the Marquee tool.

Click Page Options to set the Paper Size and Orientation of the resulting PDF Document.

Note: No Page Options button is available if you are saving to PDF from a Layout window.

Click Document Options to define your preferred settings for the content of the resulting PDF Document. 

These are similar to the options in the Print 2D/Print 3D dialog boxes.

Note: No Document Options button is available when saving to PDF from a formatted list window.

For more information, see Print 2D Document.

When saving to PDF, you can save the contents in Color, Black & White, or Grayscale.
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• For a Layout, you can choose to output multiple Layouts (the ones currently selected in the Navigator or 

Organizer) into PDF files, or else just the current Layout (at its current zoom or in its entirety). 

• For a formatted list, you have Scaling options and the ability to place each zone or page of the list onto a 

new sheet.

• PDF Options: At the bottom left of the Document Options dialog box, click PDF Options.

See PDF Options for details.
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3D Content in PDF

When creating a PDF, ARCHICAD allows you to take advantage of the U3D file format.

When publishing a PDF document from ARCHICAD, you can embed a U3D file into the PDF, then “navigate” 

the view within the PDF as if it were a 3D model.

1. From the 3D window, set up the desired model view. It is recommended to clear unnecessary detail from 

the 3D model as much as possible, in order to optimize the navigation speed in the resulting PDF 

document.

2. Save the 3D window contents as a file using the “Save as” command. Choose the “U3D file” format from 

the list of available formats.

3. In the Navigator or Organizer Palette, save the 3D model as a view, then add the 3D view to a Layout.

4. Next, add this Layout to a Publisher set. Select the Layout in the Publisher Set.
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5. Set the Publisher Set Properties to PDF format.

6. In the Format tab page at the bottom of the Publisher palette, choose Document Options, then PDF 

Options.

 

7. In the appearing PDF Options dialog box, check the “Embed 3D content” checkbox.

Note: If you choose one of the PDF/A formats in PDF Options, the U3D file embedding option is not 

available! 
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8. Click the “Browse” button to select the file you saved in U3D format (in Step 1 above).

9. Click OK.

10. In the Publisher, select the desired publisher item and publish it in PDF format.

The resulting PDF file will contain an embedded, navigable U3D file.
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The U3D model embedded in the PDF can be navigated only by using Adobe Reader 7.0 or later.
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Working with DWG/DXF Files

ARCHICAD is fully prepared to work in collaboration with users of other CAD systems, especially those 

supporting AutoCAD’s native DWG and the industrial standard DXF formats.

The DXF/DWG Add-On is installed together with the ARCHICAD package and is smoothly integrated in the 

ARCHICAD user interface. It allows you to:

• Open AutoCAD drawings as ARCHICAD Projects or ARCHICAD Library Parts.

• Merge AutoCAD drawings with your ARCHICAD Project file.

• Place AutoCAD drawings as ARCHICAD Drawings to Layouts or Model Views.

• Add AutoCAD drawings as external references (XREFs) to the ARCHICAD Project.

• Import BLOCKs from an AutoCAD drawing and create ARCHICAD Library Parts out of them within their 

own newly created Library.

• Save or Publish your ARCHICAD Floor Plans, Sections/Elevations, Detail Drawings and 3D Views in 

AutoCAD formats.

• Save your ARCHICAD Layouts in AutoCAD formats.

Use or edit Translators to make it easier to apply a customized set of conversion rules to the equivalent 

elements and functions of ARCHICAD and DXF/DWG files.

For details on Translator settings, see DXF/DWG Translation Setup.

Opening DWG/DXF Files

Saving DWG/DXF Files

Merge a DXF/DWG File

Working with XREFs
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Opening DWG/DXF Files

You can open DXF and DWG format files in ARCHICAD as Drawings or Layouts. 

• Choose File > Open and then select the file you need in the directory dialog box.

• Conversion rules for data exchange between ARCHICAD and AutoCAD are stored in a file called a 

Translator (extension XML).

• The Translator field in the Open dialog box lists default translators you will use in most cases (such as “for 

as is output”). 

• If you don’t know which default translator to use, choose Settings to open the DXF-DWG Translation 

Setup dialog box. Each default translator listed at the top is briefly described in the Description field.

For more information on Translator settings, see DXF/DWG Translation Setup.

For placed Drawings, you can customize the size, scale, title and framing options for your drawings in the 

Drawing Settings dialog box. The Embedded Layers control in Drawing Settings, available for Drawings with a 

DWG, DXF or DWF source file, enables you to adjust the source layers’ visibility.

See Drawing Settings.

Place Drawing from External Application

Opening as Library Part

You can also open a DXF/DWG file as a Library Part by choosing the File > Libraries and Objects > Open 

Object command. This will open the GDL Master Window, where you can configure the new object obtained 

from the entire file.

For more information, see GDL Object Editor.

Opening with Drag-and-Drop

You can import DXF/DWG drawings using Drag-and-Drop: 

Left-click the AutoCAD drawing, dragging it over the desired location and dropping it. The file will be opened 

using the last-used DXF/DWG Translator. With this method, the DWG/DXF file is simply merged into the 

ARCHICAD Project file. The 3D content of the file is not imported, only its 2D appearance.

If several DXF/DWG files are drag-and-dropped, only one of them will be dropped; since you cannot control 

which file will be dropped, it is recommended to drag-and-drop only one such file at a time

There are several ways to use Drag-and-Drop techniques while opening/merging AutoCAD drawings:

• Drag-and-dropping a DXF/DWG file onto the background of the ARCHICAD application window, the 

ARCHICAD menu bar or the ARCHICAD icon will result in opening the file.

• Drag-and-dropping a DXF/DWG file onto the ARCHICAD Floor Plan, Section/Elevation/IE or 3D 

Document window or Detail/Worksheet window will place the file as a Drawing.

• Drag-and-dropping a DXF/DWG file onto a Layout will place the Drawing onto the Layout.

Opening Password-Protected Files

In AutoCAD 2004 and later versions, it is possible to protect drawings with a password.

When importing or opening such a file, you may encounter such a situation.

Currently, on the Mac platform it is not possible to open password-protected AutoCAD 2004 and later DXF/

DWG files because the operating system does not support the encryption method used by these password 

mechanisms. In such a case an alert will come up on your Mac.
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On Windows the operating system may be such that it does not support the password decoding routine. In 

this case you will be alerted that the file cannot be opened.

If the system supports the decoding routine, a dialog appears where you can enter the password you received 

from the person sending you the file.

For XREF files, the program will require the password the first time the XREF is reloaded in ARCHICAD. If 

several XREF files are being reloaded, only the password-protected file will not be reloaded if its password is 

not entered correctly.

Opening Blocks as Library Parts

The closest analogy of an AutoCAD block is an ARCHICAD Library Part. Block references (insert entities) 

match the library part instances. The difference: while a library part is a separate file, the block is stored within 

the AutoCAD file itself.

Converting blocks into library parts is the only way to preserve the blocks’ 3D structure. However, it may be 

more efficient (use less storage space) to explode relatively complex blocks (e.g. if you explode 100 instances 

of a block containing 100 lines you end up with 10000 lines).

Drawbacks of converting blocks into library parts:

• you must regularly weed through the object libraries created during DXF/DWG import, to eliminate 

duplicate and unnecessary items,

• some editing functions available for details stored in blocks will not be available for the library part 

instance.

Import Selected Layers of DWG/DXF/DWF Files

See “Enable Partial Open” at Open Options (DXF/DWG Translation Setup).
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Show/Hide Layers of Imported DWG/DXF/DWF Files

Use the Embedded Layers control in the Properties panel of Drawing Settings to control the display of an 

imported DWG, DXF or DWF file, by showing or hiding its own layers (i.e. the layers in the source file).

This control is available if the source of the selected Drawing is a DWG, DXF or DWF file.

For more information, see Embedded Layers.
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Saving DWG/DXF Files

You can save or publish a project view or layout in ARCHICAD in DXF and DWG formats. (No DWG save is 

possible from a schedule, index or list view.)

1. Choose File > Save as, then the desired file type (DXF or DWG).

For information setting up Publisher Sets for output in DWG/DXF Format, see Publisher Function.

– To save only part of the view, use the Marquee to delimit the project. Save As will save only the part 

that falls within the Marquee.

– If you are working in AutoCAD and open a DWG that was originally saved from ARCHICAD, an Alert 

may appear. However, you should go ahead and work with the saved DWG in AutoCAD - no stability 

problems should result.

2. The Translator field in the Save dialog box lists default translators you will use in most cases (such as “for 

as is output”). 

3. If you don’t know which default translator to use, choose Settings to open the DXF-DWG Translation 

Setup dialog box. Each default translator listed at the top is briefly described in the Description field.

For details, see DXF/DWG Translation Setup.

Entity Conversion

Simple ARCHICAD elements get converted into the corresponding AutoCAD entities:

• Hotspots to points,

• Lines (without arrowheads) to lines,

• Circles to circles,

• Arcs (without arrowheads) to arcs,

• Ellipses to ellipses,

• Elliptic arcs (without arrowheads) to elliptic arcs,

• Texts to multiline texts,

• Fills to hatches,

Note: fills in walls, columns and library parts are treated the same way.
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• Pictures to images,

• Dimensions (all kinds) to dimensions.

Note: ARCHICAD and AutoCAD dimensions have different aspects of appearance to be configured, so 

your dimensions will often appear differently. The possible locations of the dimension text relative to the 

dimension line is the most apparent difference.

Arrowheads make these elements (the lines and arcs) “complex elements”.

Complex elements: their drawing details are made up of more than one AutoCAD entity. Unless you choose 

“Explode complex ARCHICAD Elements,” they are drawn into a block each and an insert is placed into the 

entity section.

• Walls: they are drawn into blocks named WALL_<n> where n is the index of the wall element. The block 

contains visible contour lines, fills (see notes to the polygon fills), block references to windows and doors 

and an attached label. The window and door references may be followed by their window dimension block 

references and attached label references if they have any.

Note: the contours of an arc wall aren’t arcs, but polylines made up of straight segments.

• Columns are drawn in blocks named COLUMN_<n> where n is the index of the column element. The 

block contains the visible contour lines, the fills (see notes to the polygon fills) and the block references to 

the attached label.

• Windows are drawn in blocks named WINDOW_<n> where n is the index of the window element.

• Doors are drawn in blocks named DOOR_<n> where n is the index of the door element.

• Objects are drawn in blocks named OBJECT_<n> where n is the index of the object element.

• Lights are drawn in blocks named LIGHT_<n> where n is the index of the light element.

Note on windows, doors, objects and lights: when the library part doesn’t have any 2D script, it may have 

up to 8 different looks depending on “Uniform Pen,” “Use Symbol Linetypes” and the possible mirrored 

state. So one library part of this kind cannot have more than 8 blocks exported. Others (with 2D scripts) 

may have any number of different looks and they will have exactly as many blocks as looks occur on the 

exported floor.

Since more than one instance may share the same detail block, the attached labels cannot be put into these 

blocks – they follow the block references.

• Slabs are drawn in blocks named SLAB_<n> where n is the index of the slab element. The block contains 

the contour and hole polygons and the block reference to the attached label.

• Roofs are drawn in blocks named ROOF_<n> where n is the index of the roof element. The block 

contains the contour and hole polygons and the block reference to the attached label.

• Beams are drawn in blocks named BEAM_<n> where n is the index of the beam element. The block 

contains the contour and hole polygons and the block reference to the attached label.

• Meshes are drawn in blocks named MESH_<n> where n is the index of the mesh element. The block 

contains the contour and hole polygons, the mesh level lines and the block reference to the attached 

label.

• Zones are drawn in blocks named ZONE_<n> where n is the index of the zone element. The block 

contains the foreground fill, the zone stamp and the block reference to the attached label.

Note: since the default zone-fill colors are light pastel colors and the AutoCAD color set does not contain 

an equivalent, they all will be RGB-matched to a light gray. If you prefer, pick a saturated color (e.g. red or 

yellow) for zone fill color and blue or black for zone stamp color.
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• Cameras and camera sets are not exported.

Using SHX Fonts in the Conversion Process

The DXF-DWG Add-On relies on the availability of AutoCAD fonts – including the SHX fonts. The Add-On will 

display a message asking for these fonts during the course of a conversion.

If you do not have these fonts available, you can expect problems in text formatting (such as incorrect line 

breaks). It is recommended that you acquire the SHX font files, which are part of the AutoCAD package, from 

an AutoCAD user. (Although the fonts are not available with ARCHICAD for proprietary reasons, AutoCAD 

users are allowed, even encouraged, to distribute them.) True-type version of all SHX fonts are also available 

in the AutoCAD package.

Once you get the fonts, create a separate folder for them. When the Add-On asks for an SHX font file, select 

it from this collection. If you don’t have the requested one, you may select another one. (In this case the 

conversion results may differ.) Once you have shown the folder to the Add-On, it will henceforth automatically 

search in that folder (but not in any newly created sub-folders) for the required SHX font files.

Note on TrueType fonts: You can use TrueType fonts in ARCHICAD without any problem on either 

Windows or Mac. (Mac users should copy the TrueType font files into the system drive’s Library/Font 

folder.)

Note on Fonts vs. Shapes: AutoCAD uses SHX files not only as fonts but for other purposes as well. 

Complex lines insert shapes into their patterns. The shapes may be added to the drawings as simple 

symbols. It may cause problems if you select an SHX of this kind instead of a font – so when the Add-On 

requests you to locate an SHX file, use the “Skip” option if you are not sure an SHX file you found is the 

right kind. The requested filename should give you a clue about which kind is needed – font or shape.
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Merge a DXF/DWG File

You can merge DXF and DWG format files into the currently open ARCHICAD Project. Use File > 

Interoperability > Merge, and choose the DXF/DWG file you want to merge, from the local file system or 

BIMcloud.

The Merge DXF-DWG dialog box appears. You have the option of merging the content of Model Space into 

the current View, or to Merge (Append) Paper Spaces to the Layout Book of the Project.

For more information, see Merge DXF-DWG.

Round-Trip Conversion (Smart Merge)

Use Smart Merge (round-trip conversion) if you are merging the DXF or DWG file back into the same 

ARCHICAD file from which you saved it. Smart Merge allows you to work at the same time on the same 

project in ARCHICAD and AutoCAD and exchange the additional information with minimal loss and 

interference.

Smart Merge allows you to deal with:

• New elements added in ARCHICAD or AutoCAD.

• Elements created in ARCHICAD or AutoCAD and modified (stretched, dragged, rotated, mirrored) in the 

other application or both applications.

• Elements created in ARCHICAD or AutoCAD and deleted in either or both applications.

If you cooperate with someone using AutoCAD (or any other CAD program that can communicate via DXF or 

DWG format), the process will be something like this:

1. You work out the architectural aspects of the whole plan to a point where it can present an overall layout 

for your partner to add details (at this point, you need not be completely finished with your part).

2. Then you save a DXF or DWG file for your partner with ARCHICAD-specific info to support merging. You 

can merge the DXF or DWG file back into the same ARCHICAD file from which you saved it:

– Use File > Save as, then click the Settings button to access the DXF-DWG Translation Setup dialog 

box.

– In the Settings panel, use the Saving Floor Plan option: Prepare File for Smart Merge.
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Note: You must first save your ARCHICAD Project (save a PLN) so that it contains the necessary 

information for the merge process. If there is no Merge information in a DWG/DXF file, you won’t be able 

to rebuild ARCHICAD model elements, only simple AutoCAD-native data. In case the ARCHICAD file was 

not saved before, this option is grayed.

For more information, see DXF/DWG Translation Setup > Save Options (DXF/DWG Translation Setup) > 

Saving Floor Plan.

3. You continue your work on the original plan, while s/he works on the DXF/DWG file. That is, while you are 

elaborating the architecture, s/he adds details (e.g. electric, plumbing etc.); but s/he may find it necessary 

to change something you created. For example, s/he may move a wall or duplicate an object.

4. Now the time has come to bring your separately made additions together. Activate the File > 

Interoperability > Merge command and select the appropriate DXF/DWG file. If you have saved an 

ARCHICAD file as dxf/dwg format in the right way (step 2), you can merge it into the same ARCHICAD file 

using the Smart Merge Options: 

– File > Interoperability > Merge > Merge from File

– Browse for the file, and click Open.

– From the Merge DXF-DWG dialog box, choose the Merge Content of Model Space into Current 

View option, and click OK.
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– From the DXF/DWG Merge dialog box, choose Merge Options, 

– The Smart Merge Options dialog box appears, allowing you to modify the Smart Merge configuration 

file and the translator options (if desired).

Note: You can also set up these options in advance at File > Interoperability > DXF-DWG > Smart 

Merge Options.

See Smart Merge Options.

5. Repeat from step (2) as many times as necessary.
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Working with XREFs

External reference files (XREF) are similar to Hotlinked Modules, except that they are DXF or DWG files and 

not ARCHICAD files.

See also Hotlink Modules and XREFs in Teamwork.

External referencing is a way of saving disk space and work. You can attach a DWG or DXF file to your Floor 

Plan or to a Detail; the file will be loaded into the Project and displayed, using the settings of the DXF/DWG 

Translator you have selected.

You can snap to all drawing elements within the XREF and print or plot them.

A common use for XREFs is to draw elements that are common to several kinds of drawings within a Project 

(e.g., the outlines of exterior and interior walls). If you have a file containing this data, you can attach it to other 

drawings that can use the geometric information contained in the XREF file without the Project file actually 

having to contain the data. Also, if the source of the data in the external reference (the DWG or DXF) is 

changed, then these changes can be updated immediately so the latest data is always available.

XREF is available in both ARCHICAD and AutoCAD - both applications can detect circular references.

In ARCHICAD, external reference files work much as they do in AutoCAD. ARCHICAD XREFs can display 2D 

elements from DWG files, but three-dimensional AutoCAD elements (such as Solid elements) are not visible 

in ARCHICAD’s 3D window.

Note: If any of the functions described do not work properly, the DXF/DWG Add-On may be missing, or 

the DXF/DWG Translator is not set. You can check this easily by choosing File > Open and looking for the 

appropriate file types in the Files of type field. The missing Add-On can be loaded with the Add-On 

Manager command in the Options menu.
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Attach XREF

1. From the Floor Plan, Detail or Worksheet window, use File > External Content > Attach XREF.

2. The Attach XREF dialog box appears.

3. From the XREF Name pop-up:

– choose from the list of XREFs already loaded in the project

– or Browse for a DWG or DXF file in a local file system or from BIMcloud

4. Set insertion and rotation options as needed.

See Attach XREF Options for details.

5. Choose a DWG/DXF Translator which will determine conversion options for the attached file (or just use 

the default translator shown). Click Settings to view the options for the current translator.

6. Click Attach.

You can attach and detach XREF files in ARCHICAD, unload and reload them, bind them to the project file 

and view information about them. These functions are available in the XREF Management Dialog box (File > 

External Content > XREF Manager and File > Attach XREF).

Note: You should not attach XREFs from different locations if they have the same file name, because 

AutoCAD cannot open such files. (If they have the same name but different file extensions - DXF vs. DWG 

- this can still cause problems.)

Manage XREFs

To manage XREFs attached to the project, use File > External Content > XREF Manager.

The XREF Management dialog box displays information about the attached files, including the name of the 

reference (usually the same as the attached file), its status (Loaded, Detached, Reloaded, Unloaded or 
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Bound), size, type (Attach or Overlay), Date and the number of instances, as well as information on the 

translator used to open each XREF.

For details, see XREF Management Dialog Box.

See also Working with XREFs for an overview.

Attributes of XREF Files

Using XREFs in Round-Trip Communication
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Attributes of XREF Files

Filter Layers of XREF Files

When you attach an XREF to your project, ARCHICAD will follow the settings of the DXF/DWG Translator 

used. This Translator can be selected and its settings viewed in the Attach XREF dialog box.

See Attach XREF.

One such Translator setting is the “Enable Partial Open” checkbox in the Open Options part of Translator 

Settings:

If this setting is enabled, then every time you attach an XREF file, the Partial Open dialog box will appear on 

screen, letting choose which layers you wish to attach along with the drawing.

See “Enable Partial Open” at Open Options (DXF/DWG Translation Setup).

Layer Settings of Attached XREF Files

When you attach an external reference file to an ARCHICAD Project, a layer will be created for it.

Exception: If you have enabled the Partial Open setting (see above) and unchecked that layer name in 

the Partial Open dialog box, that layer will not be created in your ARCHICAD project.

 The resulting layer names will have the following format:

‘XREF_NAME | LAYER_NAME’.

For example, the PEN_56 layer of a DWG file that was attached to the project with the XREF name 

3D_STUFF will become the layer 3D_STUFF|PEN_56.

In Layer Settings, the layers of any attached XREFs are listed separately, at the bottom of the layer list.
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Layers of XREF projects cannot be unlocked, but you can show or hide these layers.

If you do not want XREF layers to appear in Layer Settings, use the display filter pop-up at the top right of the 

dialog box and choose “Hide XREF layers”.

XREF layers are not available from layer selection pop-ups in other parts of the user interface (e.g. Tool 

Settings dialog boxes and Info Box). However, if an XREF element is included in the last selection, its XREF 

layer does appear - for information purposes only (in italics) - in the Layer chooser pop-up.

When the XREF is detached, a dialog lets you choose between retaining or removing the detached XREF’s 

attributes, including layers, linetypes and fills.
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Using XREFs in Round-Trip Communication

In this scenario, you are assigned to work on one part of a larger project. You get the whole project (or the part 

of it relevant to your job), extend it with your part and send it back. In this case we recommend that you use 

the XREF (External Reference) model. Using this model you can see all parts of the project, but modify only 

the part assigned to you.

The XREF model is based on a “master” AutoCAD file containing general information (e.g. a site map).

• First, attach this “master” file as an XREF to your ARCHICAD plan to see the current state of the project.

• Detail plans, including your file, are added as XREF’s. Make your modifications in your external file, using 

ARCHICAD. You will be able to modify only your file.

• Meanwhile, other members of the project team are working on their files in parallel. To receive the 

changes made by the others, reload the “master” file. The updated file contains all the modifications 

submitted by the other parties.

• If you want the others to see the work you have done so far, you can send your changes by exporting your 

work in AutoCAD format.

The XREF model preserves the “master” AutoCAD file: each team member works only on his/her own part 

without being able to modify others’ work, because externally referenced files don’t have to be sent back to 

their original sources.

Due to essential differences between ARCHICAD and AutoCAD, perfect round-trips are not possible. (For 

example, if you import and then export something, polylines and structures are lost.) In practice, however, you 

can rely on the suggested XREFs, which do not involve overwriting the other party’s original file, so that you 

don’t need to rely on a perfect round-trip. If you work in round-trip communication, your file never gets 

overwritten. The specialist gets new DXF/DWG files from you from time to time, which contain imperfect 

reproductions of his modifications. You can avoid these imperfections if you keep his additions in a separate 

XREF file, attached as an external reference to the file you send back to him.
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Working with Point Clouds

ARCHICAD opens .xyz and .e57 file formats and converts them into objects, which can be placed on the Floor 

Plan or in the 3D window. The user can then align the building model to point clouds, on the Floor Plans, 

sections/ elevations and the 3D window.

Point Clouds are not visible on any published output!

Import and place Point Cloud files for the following workflows:

• Modeling existing buildings prior to renovation: The point cloud serves as the initial basis for the 

architectural model of the rebuilt/renovated building. 

• Modeling the surroundings prior to creating a new building: Use point cloud import to create a rough 

model of the surroundings and neighbor buildings, as an aid to visualization.

• Modeling the “as-built” building for detecting the deviations from the planned state.

Topics in this section:

Import Point Clouds

Trace Point Cloud to Create Model Elements

Optimize Display of Point Cloud Object

Redefine Origin of Point Cloud Object

Place Point Cloud Object in Teamwork Project
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Import Point Clouds

1. Use File > Interoperability > Import Point Clouds.

2. In the appearing dialog box, browse for the location of the point cloud file(s) and select one or more files. 

The files must have a format of either .e57 or .xyz.

3. Click Open.

4. For XYZ format files:

If any of the selected files has the extension .xyz, the following Format Conversion dialog box appears:

Note: E57 format files are standardized and require no format conversion. You will skip the Format 

Conversion dialog box and continue with the next step.
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This dialog box gives you the opportunity to correct (if needed) how the X, Y and Z coordinates and RGB 

colors of the imported file should be interpreted in ARCHICAD.

The only editable data here are the six fields at the top of the dialog box. For each field (X, Y and Z 

coordinates, as well as Red, Green and Blue color), assign one of the columns shown in the bottom dialog 

box. (By default, the first six columns are numbered, but some of the columns may contain unneeded 

data.)

If the data assignment becomes invalid - for example, if the same column is assigned to two fields - the 

OK button is grayed, and you will see an exclamation point at the top of that column.

For more information on how to set up Format Conversion (if needed) for the .xyz file you are importing, 

consult the surveyor who created the file.
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5. The Create Point Cloud Objects dialog box appears.

The new Point Cloud objects (listed in the dialog box) will be created as LCF files and saved in the linked 

library shown in the path field. If needed, browse for a different folder path.

6. Object Name: This is the name of the newly created object. If needed, edit the object name.

7. Do one of the following:

– Click Create to create the Point Cloud file(s) and object without placing them.

– Click Create and Place if you want to place the objects now (Solo projects only. For Teamwork 

projects, see below: Place Point Cloud Object in Teamwork Project.)

Conversion of the Point Cloud files may take a few moments.

8. If you choose Create and Place, the Place Point Clouds dialog box appears. 

Here, you can:

– Specify the placement method (either place it at the Project Origin, or click anywhere to place it 

manually)

– Define the Home Story for the Point Cloud objects

See also Redefine Origin of Point Cloud Object.
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Click OK to place the Point Cloud objects. You can snap to any point on the resulting object.

 

Image Credit: BAM Construct UK Ltd, www.bam.co.uk | FARO Technologies UK Ltd, www.faro.com
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 Each time you import a particular Point Cloud file, a new LCF file is created as a linked library. You can place 

the new LCF file any number of times from the Object Settings dialog box.

Watch the Video
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Trace Point Cloud to Create Model Elements

Here, we have used line tools to trace the contours of Point Cloud shapes on the Floor Plan.
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They can be transformed into model elements using the Magic Wand.
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Optimize Display of Point Cloud Object

Use the Custom Settings panel of a Point Cloud object to change its display, to make it easier to work with.

Unit and Scale Settings: As needed, stretch or resize the object using the Model Scale settings.

Watch the Video

Override Floor Plan Display Range: By default, the object will be displayed according to the current Floor 

Plan Cut Plane height. If needed, you can override this display limit for the point cloud object, if it is hard to 

see contours.

For example, we wish to trace the column shape in this garage object, but at the current Floor Plan Display 

range, the contour is too blurred.
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You can narrow the display range values to make the contour easier to trace:

Watch the Video

Watch the Video

Watch the Video
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Redefine Origin of Point Cloud Object

If your selection includes a Point Cloud object, the context menu contains the command: Move selected 

Point Cloud by origin.

Click this command, then click in the project to place the Point Cloud’s new origin.
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Place Point Cloud Object in Teamwork Project

After importing a Point Cloud file, the Create Point Cloud Objects dialog box appears. 

See workflow above, at Import Point Clouds.

Click Create. (The Create and Place command is not available in a Teamwork project.)

The new Point Cloud objects (listed in the dialog box) will be created as LCF files and saved to the location 

specified in the dialog box.

You must add the new objects to the Teamwork project before you can place them.

See Manage BIMcloud Libraries.
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Working With Rhino 3D Models

Topics in this Section:

Open or Merge Rhino Model

Import Rhino 3DM File as Object

Hotlink Rhino File

Export Model to Rhino
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Open or Merge Rhino Model

Use these workflows to open or merge a Rhino 3D Model file (.3dm) directly in ARCHICAD

• File > Open

• File > Interoperability > Merge

A Rhino model imported to ARCHICAD will appear as a non-editable GDL object, maintaining the logical 

structure/buildup of the original Rhino model. It is placed into ARCHICAD project’s Embedded Library. You 

have the option to adjust the model segmentation before and/or after import to ARCHICAD, depending on 

your preferred settings (described below).

Topics in this section:

Import Options for Rhino 3D Model

Rhino Object Parameters in ARCHICAD

Rhino Properties in ARCHICAD

Rhino View Display in ARCHICAD

Import Options for Rhino 3D Model

The Import Options dialog is available when importing a Rhino model in any of the following workflows:

• File > Open

• File > Interoperability > Merge 

• File > External Content > Place Hotlink, from the New Hotlink Module dialog box.

In each workflow, choose the Rhino 3D Model (.3dm) file type, and click Options to open the dialog.

The name of the dialog box varies depending on the command:

• Rhino Open Options

• Rhino Merge Options
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• Rhino Import Options (when Hotlinking a Rhino model)

See Hotlink Rhino File and Import Rhino 3DM File as Object for these workflows.

Segmentation of Curved Geometry

Use the slider to adjust the segmentation of curved surfaces imported from Rhino.

Notes: 

– The segmentation slider affects curved geometry only, not planar elements

– If you increase segmentation (resulting in a higher number of polygons for smoother surfaces), 

remember that a high polygon count affects both file size and performance

Baked Curved Geometry

Optionally, check the Bake Curved Geometry box to finalize segmentation before import. As a result: 

• You will not be able to further adjust segmentation once the model is imported to ARCHICAD

• On the other hand, element snapping will be available

• In general, navigation is faster in models if this option is checked

Hidden Elements

Use these controls to define how to interpret Rhino’s “hidden” elements.
ARCHICAD 24 Reference Guide 2904



Working With Rhino 3D Models Interoperability
In Rhino (unlike in ARCHICAD), it is possible to hide an individual element, whether its Layer is visible or not. 

By default, such hidden elements are NOT imported to ARCHICAD. 

To import them, check the Import hidden elements box.

Layers

Use these controls to define the Layers onto which to place imported Rhino elements (visible and hidden, if 

any).

Import Layers to Keep Original Layer Structure (Default)

Each Rhino Layer is recreated as a separate ARCHICAD Layer, named after the Rhino Layer’s folder path: 

folder_subfolder_layer.

• These Layer names automatically get the extension “Rhino”.

• Any identical Layer names are differentiated with a number added onto the extension.

• You can add an optional Prefix to the Rhino Layers.
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Place all elements on an existing Layer

Use the pop-up to choose ARCHICAD project Layers for the visible and for the hidden elements imported with 

the Rhino model.

Place all elements on a new Layer (Available only when using Open. Not available with Merge.)

Create new Layers in ARCHICAD for the imported visible and hidden elements.

Surfaces

Use these controls to define how to handle Rhino colors, which are handled as Surface attributes in 

ARCHICAD. 

Import Rhino colors as Surfaces

With this option, each imported Rhino color

• is recreated as a separate ARCHICAD Surface. 

• is automatically assigned the name of “Rhino” plus a number 

• can be assigned an additional, optional Prefix
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Use existing uniform Surface

Use the pop-up to choose a single ARCHICAD Surface to use for all colors imported with the Rhino model.

Rhino Object Parameters in ARCHICAD

Each imported Rhino element becomes a separate ARCHICAD object (.gsm), with a file name prefix of 

“Rhino”. These are stored in the ARCHICAD Embedded Library, in a separate folder for each imported Rhino 

File, and a separate sub-folder for each layer.

Use the Rhino Import Object Settings panel of Object Settings to set its appearance.

Note: Object Settings of placed, Rhino-based hotlinks cannot be edited. 
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Note the following Rhino-specific parameters: 

Segmentation

This control is available for objects imported from Rhino, provided that you did not check the Bake Curved 

Geometry option at import. (See Baked Curved Geometry, above.)

Note: If you placed the selected object in ARCHICAD using the Object tool (instead of importing it from 

Rhino), Segmentation is not available.

Use the Segmentation pop-up to adjust the smoothness of a selected curved object. Remember that a high 

polygon count may affect file size and performance.

2D Representation

• Show Face Edges: Show them if you want to see the internal surface edges in 2D.

• Hotspots on bounding box: Turn this on if you want to see additional hotspots on the object’s bounding 

box in 2D. This can be useful, for example, for dimensioning an orthogonal object such as a curtain wall.
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Rhino Properties in ARCHICAD

Every element imported from Rhino and placed in ARCHICAD is assigned an Element Property Group called 

Rhino, in the Object Settings Classification and Properties panel.

These properties store the element’s original Layer and original ID in Rhino. (This is true even if you chose to 

place all Rhino elements onto a single Layer in ARCHICAD.) 

Use these properties to find and select Rhino elements by Layer, even after modifying the ARCHICAD Layer 

structure.

Rhino View Display in ARCHICAD

After Open, the views of the imported Rhino model are now 3D axonometric views listed in ARCHICAD’s View 

Map. The view’s display mode (a 3D Window Setting) depends on the original display mode in Rhino.

Display Mode of View in Rhino Display Mode of View in ARCHICAD

Wireframe, Ghosted, X-Ray, Technical Wireframe

Shaded, Rendered, Artistic, Pen Shaded
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Import Rhino 3DM File as Object

1. Use this command to import a Rhino file as a single object in ARCHICAD:

File > Libraries and Objects > Import Rhino 3DM file as Object

2. Click Options for Rhino Open Options:

3. Set your preferences for Segmentation and Hidden elements:

• Segmentation of Curved Geometry

Use the slider to adjust the segmentation of curved surfaces imported from Rhino.

Notes: 

– The segmentation slider affects curved geometry only, not planar elements

– If you increase segmentation (resulting in a higher number of polygons for smoother surfaces), 

remember that a high polygon count affects both file size and performance

• Baked Curved Geometry

– Optionally, check the Bake Curved Geometry box to finalize segmentation before import. As a result: 

- You will not be able to further adjust segmentation once the model is imported to ARCHICAD

- On the other hand, element snapping will be available

- In general, navigation is faster in models if this option is checked
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• Hidden Elements

Use these controls to define how to interpret Rhino’s “hidden” elements.

In Rhino (unlike in ARCHICAD), it is possible to hide an individual element, whether its Layer is visible or 

not. By default, such hidden elements are NOT imported to ARCHICAD. 

To import them, check the Import hidden elements box.

4. Click OK.

5. You are alerted that the import was successful:

6. Use the Object tool to place it into the project.

Rhino Object Settings in ARCHICAD

A Rhino file placed as a single object in ARCHICAD is stored in the ARCHICAD Embedded Library.

Use the Rhino Import Object Settings panel of Object Settings to set its appearance.

Note the following Rhino-specific parameters: 

Segmentation

This control is available for objects imported from Rhino, provided that you did not check the Bake Curved 

Geometry option at import.

Use the Segmentation pop-up to adjust the smoothness of a selected curved object. Remember that a high 

polygon count may affect file size and performance.
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2D Representation

• Show Face Edges: Show them if you want to see the internal surface edges in 2D.

• Hotspots on bounding box: Turn this on if you want to see additional hotspots on the object’s bounding 

box in 2D. This can be useful, for example, for dimensioning an orthogonal object such as a curtain wall.
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Hotlink Rhino File

1. As when placing any other Hotlink, use File > External Content > Place Hotlink.

2. From the New Hotlink Module dialog, choose the Rhino 3D Model (*.3dm) format, then click Options. 

3. The Rhino Import Options dialog appears.
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These are the same options as when opening/merging a Rhino model:

See Import Options for Rhino 3D Model.

Note: The Segmentation settings cannot be changed after you place a Rhino-based hotlink.

4. After setting the Import Options, click OK to return to the New Hotlink Module dialog.

5. Select the newly created Rhino-based hotlink, and click Select to return to the Place Hotlink dialog box.

6. Follow the usual procedure for placing and managing this Hotlink. The Hotlink will be placed on the 

currently opened story in ARCHICAD.

See Place Hotlink for an overview of this process.

Check Import Settings of Hotlink Module

Each Rhino-based Hotlink Module can have its own import settings. To see the hotlink’s settings (or 

Conversion Info): 

1. Open Hotlink Module Manager (File > External Content > Hotlink Module Manager)

2. Select the desired Rhino-based module from the list of placed modules.

3. At the right, check the Conversion Info section to see that module’s information.
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Export Model to Rhino

An ARCHICAD model exported to Rhino transfers geometrical information only, because Rhino handles only 

this type of data. 

In Rhino, ARCHICAD elements are distinct, selectable elements. Relevant element attributes (surface color, 

texture) and the original ARCHIAD layer structure and grouped elements are retained.

Non-geometrical data (e.g. properties, tags, schedule data, quantities, etc.) are not transferred. Mapping of 

AC textures is not supported.

Export ARCHICAD Model to Rhino

1. From the 3D window, use File > Save as Rhino 3D Model (.3dm) to export part or all of the ARCHICAD 

model to Rhino. 

2. Click Options in the Save as dialog box to access additional options:

Surface Model

Choose this if you want the ARCHICAD element surfaces to retain their original colors in Rhino. Each multi-

color ARCHICAD elements must be exploded into several Rhino elements.

Note: Although a single ARCHICAD element can have a different color for each surface, a single Rhino 

element can have only one color for all surfaces. Thus, to retain all the surface colors of a multi-color 

ARCHICAD element, it will be exploded into multiple elements – each with a different color – in Rhino.

Use the Surface Model option if you are using the exported ARCHICAD model for reference-model purposes 

(e.g. you are modeling part of the project in Rhino, and you want to see the surrounding environment – 

created in ARCHICAD - in their correct colors.)

Solid Model

With this option, ARCHICAD solid elements are interpreted in Rhino as a single Mesh or Polysurface element. 

Consequently, it will have a single color in Rhino (even if the original ARCHICAD element used different colors 

on different surfaces).

Use the Solid Model option, for example, if you use the Rhino model in a simulation, where colors are less 

important.
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Detailed Options (Advanced)

Note: The default options will work for most users. However, you can click the Details tab to see and 

change export settings if needed.

Given the differences in the way ARCHICAD and Rhino work with curved surfaces and edges, ARCHICAD 

seeks to optimize the way each element is interpreted. This is especially relevant for ARCHICAD’s composite 

elements and Morphs, which might have curved segments and/or multiple surfaces. 

The default setting is Hybrid – a smart method that interprets each element as either BREP or Mesh 

depending on its surface geometry – so you end up with both kinds of elements in Rhino. 

• If the element consists of all flat surfaces, it is automatically exported to Rhino as BREP

• If the element has curved surfaces, it is automatically exported to Rhino as a Mesh 

However, you may wish to ensure that all model elements in Rhino are uniformly interpreted as either Mesh or 

BREP (for example, for simplified further editing or for export to a third program that does not recognize 

Meshes.)

• BREP Model (Boundary Representation)

– Larger file size than Mesh Model

– Can interpret holes and many-sided polygons

– Internal triangulation of curved surfaces is not visible (only the boundary curve is shown)

– No user control over hard vs. soft shading on edges

• Mesh Model

– Smaller file size than BREP Model

– All surfaces are triangulated or quadrangulated. Thus, a more complex element (e.g. many-sided 

polygon or element with a hole) is also triangulated, with resulting additional edges

– The show/hide status element edges cannot be individually controlled; the display of all element 

edges is uniformly controlled with the Mesh Wires option 

For each edge, you can set whether its shading is displayed as hard or soft.
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Export to Artlantis

Use this add-on to export the ARCHICAD 24 model into Artlantis versions 6.5, 7, 2019 or 2020. Although this 

add-on is installed by default with ARCHICAD, the add-on remains the property of Abvent R&D, which 

ensures its development and maintenance.

For more information, please visit: http://www.artlantis.com.

How to Export

1. Display the perspective 3D view in ARCHICAD.

2. Select the File > Save as... command.

3. In the file format list, choose the Artlantis 6.5, 7, 2019 or 2020 option (*.atl). 

4. Click Save button, and the Export dialog box will be displayed.

From this dialog, you can either export a new Artlantis file, or update an .atl file already sent into Artlantis.

Creating a New File

Check the items to export.

• Perspectives Cameras: All cameras created in ARCHICAD will appear on Artlantis’s Perspectives 

Inspector List.

• Lights*: All lamps inserted into the ARCHICAD project will appear on Artlantis’s Lights Inspector List.

• Sun*: The heliodon (geographical position, date and time) will appear on Artlantis’s Heliodons Inspector 

List.
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• Unique Layer: If this is checked, all the ARCHICAD layers are exported into a single layer to Artlantis. If 

unchecked, all the ARCHICAD layers will be recovered into the Layers list of the Artlantis Objects 

Inspector.

*Note: If the Lights or Sun controls are disabled on the export dialog, open the ARCHICAD 

PhotoRendering Settings dialog box (Document > Creative Imaging), activate the Basic Rendering 

Engine and switch ON the appropriate light source.

• Texture Options Wall, Roof, Slab, Others*: Textures associated with the ARCHICAD Surfaces will be 

exported.

*Note: The Others option includes all ARCHICAD tools such as Column, Beam, Stair, Door, Window, as 

well as Mesh and Object.

Update an .atl File Already Sent into Artlantis

All controls described in the Creating a New File section are also valid here!

1. Select the Use Reference File option

2. Click Choose a File. 

3. Select the .atl reference file.

Options

• Replace ARCHICAD Materials with Artlantis Reference File Materials Using the Same Identifier

• Add Artlantis Perspective Views, Lights, Heliodons, Objects from the Reference File

If either of these options is activated: 

New elements in the ARCHICAD project (geometry, viewpoints, lamps, heliodon) will be exported only if they 

are not part of the reference file. 

Note on Exporting Curved Elements

By default, curved ARCHICAD elements exported into Artlantis are never smoothed. To smooth the curves in 

Artlantis, go to the Shaders inspector tab Advanced Parameters area, select the needed material, and use 

the Smoothness slider.
ARCHICAD 24 Reference Guide 2918



Interoperability with MEP Applications Interoperability
Interoperability with MEP Applications

This section describes the recommended workflow for data exchange with MEP applications.

Export ARCHICAD Files to MEP Software

Import MEP Data to ARCHICAD
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Export ARCHICAD Files to MEP Software

Preparing the ARCHICAD Model for Export

Before handing an ARCHICAD file over to an MEP engineer using MEP-specific software, certain 

simplifications have to be made to the architectural model. Like structural engineers, MEP experts need only 

certain parts of the project - those which are relevant to their work.

Relevant Data for Export to MEP

Typically, the most relevant 3D elements for export to MEP are:

• load bearing structures,

• elements of the building envelope,

• the boundaries of interior spaces.

Also important:

• structural grid of the load bearing structure,

• planned placement of lighting objects, bathroom and kitchen equipment,

• positioning of built-in furniture,

• all space functions and numberings, must also be clearly indicated,

• levels, geometry and structural grid of suspended ceilings and false floors (this will assist the engineer to 

correctly design HVAC equipment (air inlets, sprinklers etc.).

Layers containing elements of the architectural model that are irrelevant to the MEP design should be 

switched off and thus excluded from the export data. Irrelevant elements are usually these:

• floor claddings,

• door and fenestration details,

• furniture.

It is possible to define separate layer combinations that specify content suited for the electrical, plumbing, 

lighting, acoustic, low current system engineer or elevator design specialist.

See Layer Combinations for information on setting up a Layer Combination in ARCHICAD.

The two most commonly used file formats to export ARCHICAD data to MEP applications are DWG and IFC.

Save Views to DWG

The majority of MEP engineers work in a 2D design environment (mostly Autodesk AutoCAD) and therefore 

wish to receive AutoCAD DWG files.

In ARCHICAD, the architect creates DWG files by defining floor plan, section or elevation views, and 

exporting these, rather than exporting the 3D model itself. It is advisable to create a Publisher Set with pre-

configured settings in ARCHICAD to enable easy creation of the documentation to be handed over to the 

MEP expert. This way, the preset views representing the most up-to-date state of the project may be saved in 

the specified destination folder in DWG format, by a touch of a button.

See Working with DWG/DXF Files.

Save Models to IFC

Some MEP engineers design directly in a 3D work environment (AutoCAD MEP or Revit MEP). To fit this 

workflow, GRAPHISOFT has developed a translator-based IFC data exchange feature.

See Export IFC Model from ARCHICAD.
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This feature translates the ARCHICAD model to IFC, which is currently the most advanced BIM model 

exchange format. When creating IFC content for the MEP specialist, it is advisable to use an IFC Translator 

preconfigured for MEP exchange (e.g. “DDS-CAD MEP Export”), or to set up an IFC translator customized for 

your needs.

See IFC Translators: Overview.

Many MEP applications support BIM Collaboration Format (BCF)-based communication as an enhancement 

to IFC-based data exchange. The BCF workflow enables participants to add comments to the overlapping 

issues (e.g. collisions). BCF comments include the referenced IFC elements’ GUIDs and an attached preview 

(snapshot) picture; these enable users to easily locate the “problematic” model elements in the referenced 

view, using the same exact camera position as the snapshot. ARCHICAD’s Issue Management supports BCF 

commenting, import and export. 

See Issue Handling.

IFC Model Exchange with ARCHICAD for Revit

This GRAPHISOFT Add-In is developed for MEP engineers using Autodesk Revit. 

This add-in optimizes the IFC data import from any IFC data source to Revit used by MEP engineers.

It is available from GRAPHISOFT's website at:

http://www.graphisoft.com/support/archicad/downloads/interoperability/.
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Import MEP Data to ARCHICAD

The two most commonly used file formats to import data from MEP applications to ARCHICAD are DWG and 

IFC.

Importing MEP Data via DWG

MEP data from AutoCAD arrive in DWG format. The best practice is to import only the MEP content, plus the 

structural grid added for reference. 

Import the received MEP content in ARCHICAD either as an XREF or place as a Drawing. ARCHICAD’s 

Drawing Tool includes an Embedded Layer Visibility Setting, which enables the switching of layers on and off 

within the drawing content.

For further information, see Show/Hide Layers of Imported DWG/DXF/DWF Files.

Importing MEP Data via IFC

ARCHICAD’s IFC import function automatically translates the imported 3D MEP elements into native MEP 

Modeler objects.

See MEP Modeler.

IFC Model Exchange with ARCHICAD for Revit

This GRAPHISOFT Add-In is developed for MEP engineers using Autodesk Revit. 

This add-in optimizes the IFC data import from any IFC data source to Revit used by MEP engineers.

It is available from GRAPHISOFT's website at:

http://www.graphisoft.com/support/archicad/downloads/interoperability/.

Collision Detection in ARCHICAD

ARCHICAD’s Collision Detection function can detect collisions between MEP elements and architectural 

elements.

See also Collision Detection.
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Interoperability with Energy Analysis

ARCHICAD users have several ways of co-operating with energy specialists.

Integrated Energy Evaluation

Export Files from ARCHICAD to Energy Analysis Software

Import Energy Analysis Results Into ARCHICAD
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Integrated Energy Evaluation

ARCHICAD's Energy Evaluation function executes an automatic model geometry and material property 

analysis on the building model. The resultant data is then used as input by the VIP-Core dynamic energy 

simulation program module integrated in ARCHICAD. VIP-Core carries out the hourly energy-flow analysis to 

produce the Energy Performance Evaluation report. The energy performance of the design's current state is 

easily evaluated within ARCHICAD, and the effects of changes made on the architectural model in order to 

improve the energy household may be reviewed instantly. Energy Evaluation can be applied at all phases of 

architectural design, it is therefore not necessary to exit ARCHICAD and exchange data with external energy 

analysis applications for building energy performance optimization.

In order to produce local energy standard compliance documentation, however, the use of third party Energy 

Analysis Software may still be necessary. ARCHICAD therefore supports the export of building model data 

produced by the automatic geometry and material property analysis.

To find out more about VIP-Energy analysis software, please visit StruSoft’s official product website.

For details on ARCHICAD’s Energy Evaluation function, see Energy Evaluation.

See also the section on Interoperability with Green Software (Energy Evaluation).
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Export Files from ARCHICAD to Energy Analysis Software

Before the architectural model is exported to an energy analysis application, a 3D model view with simplified 

content must be defined. The ARCHICAD Building Energy Model view should be simplified, by hiding 

unnecessary data. Volumes of internal spaces and their relative positions should be properly modeled.

For detailed information on building energy model creation with ARCHICAD, please consult the following 

ARCHICAD Help chapters (under Energy Evaluation Workflow: Overview): 

- Prepare the Architectural BIM for Energy Evaluation

- Define Thermal Blocks

- Automatic Model Geometry and Material Property Analysis

There are two file formats available to export data from ARCHICAD to energy analysis applications: IFC and 

Excel.

Using IFC

Energy specialists who work with applications offering the IFC-based file import option should use an IFC 

Translator preconfigured in ARCHICAD for energy applications, or create a custom translator setup. For 

example, the exported architectural model must contain relation information between the Zones and their 

boundary elements.

See Export IFC Model from ARCHICAD.

Using Excel

Use the Geometry Data page of the result Excel table as an input for other energy calculation software, such 

as third-party excel spreadsheets that utilize simplified stationary energy calculation algorithms.

See Reading the Energy Performance Evaluation - XLS Report.
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Import Energy Analysis Results Into ARCHICAD

Energy specialists use their energy analysis software to process the architectural data received via 

ARCHICAD file export (detailed above). However, if the energy specialist makes changes in the architectural 

model, you will not be able to import those changes back into ARCHICAD. Even though building energy 

applications are capable of changing certain model attributes (e.g. shading settings, building element 

properties), automatically implementing these modifications in the BIM model is not possible, due to the lack 

of data exchange functionality between the energy analysis software and CAD applications. 

Unlike other design activities (e.g. structural, MEP), the energy expert produces written documentation, and 

does not modify the BIM model. Results of the energy analysis are typically in text format, enriched with 

tables, charts and graphs that display building element and envelope performance, energy consumption, 

energy balance overview and breakdown, HVAC system parameters and various additional results that 

depend on the specific program’s additional functionality.

Thus, alteration requests by the energy specialist still have to be communicated to the architect in the 

traditional way, and eventually the architect has to implement the changes on the ARCHICAD model based on 

instructions provided via sketches, email or telephone.

Note: GRAPHISOFT offers an add-on to ARCHICAD called EcoDesigner STAR. This add-on provides 

extra functionality that turns ARCHICAD’s built-in Energy Evaluation function into a high-end building 

energy analysis tool. Since it’s integrated in ARCHICAD, this solution is able to evaluate the effects of the 

latest architectural design changes on the project’s energy performance.

For details, see http://www.graphisoft.com/archicad/ecodesigner_star/.
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Working with IFC

IFC (Industry Foundation Classes) is an open, neutral data exchange format. It is optimized for OPEN BIM- 

and model-based interoperability among disciplines, primarily in the AEC industry. 

BIM, or “Building Information Modeling,” is one of the biggest advances in the building industry’s working 

methods since the introduction of CAD software. BIM is not synonymous with 3D projects. Three-dimensional 

geometric representation is only one part of the digital deliverables. A project includes non-graphical 

information, such as calculations, that are used in surveying, facility management and energy calculation. A 

prerequisite for a successful BIM project is that intelligent information can be exchanged between different 

software and even operating systems, throughout the stages of the building process. This interoperability 

demands a neutral file format with an open standard that supports different systems. IFC is such a system, 

enabling us to synchronize building models between the disciplines much more easily.

The IFC format is used for the efficient import and export of 3D elements and related non-geometric data, 

regardless of the application used to create the model. The IFC format is ISO-certified and can be integrated 

into any existing quality assurance polices your office may have. IFC is developed in part by buildingSMART 

(formerly the IAI - the International Alliance for Interoperability). 

GRAPHISOFT has played an active role within the buildingSMART organization since 1996 and supports the 

IFC standard. Through IFC, ARCHICAD can communicate with other disciplines within the context of the 

building model. The building model can be exported back to literally hundreds of other systems that support 

IFC.

The list of registered IFC supporter applications (by functional category/design disciplines) is available here.

ARCHICAD supports the import and export of both IFC2x3 and IFC4 versions. IFC data are managed 

according to the latest worldwide-certified IFC standard, IFC2x3 TC1 (Technical Corrigendum 1).

For more information, see the buildingSMART website.

This chapter provides an insight into the IFC standard and how it works in ARCHICAD.

Related Topics

IFC File Types Supported by ARCHICAD

ARCHICAD Classifications and Categories in IFC

Export IFC Model from ARCHICAD

Import IFC Model to ARCHICAD

Hotlink IFC File

Update with IFC Model

IFC Project Manager

Manage IFC Data at Element Level

IFC Local Preferences

Define Element Criteria using IFC Data

IFC Translators: Overview

Translators for Import (Detailed Settings)

Translators for Export (Detailed Settings)

Filter Model at Import (Secondary Filter)

Filter Model at Export

Appendix: IFC Terms and Concepts

Appendix: IFC Data Mapping in ARCHICAD
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IFC File Types Supported by ARCHICAD

ARCHICAD supports the export and import of the following IFC data file formats: 

• .ifc: the default IFC exchange format using the STEP physical file structure

• .ifcXML: IFC data file using the XML document structure. This format is recommended for architects 

whose partners’ applications cannot read the original .ifc format, but can manage XML databases (such 

as budget, energy calculations, etc.). This format delivers the same model information as the plain .ifc 

format, but the elements and their properties are stored in a more informative structure. An .ifcXML file is 

normally 300-400% larger than an .ifc file.

• .ifcZIP: IFC data file using the ZIP compression algorithm. It is the compressed version of .ifc or .ifcXML. 

An .ifcZIP file usually compresses an .ifc down by 60-80% and an .ifcXML file by 90-95%.

Note: .ifcZIP is compatible with e.g. Windows compressed folders, WinZip, etc. So if the recipient cannot 

read .ifcZIP, then a ZIP extractor application can open the file into .ifc or .ifcXML format.
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ARCHICAD Classifications and Categories in IFC

Element Classifications for IFC

Structural Function Category for IFC

Position Category for IFC

Element Classifications for IFC

In ARCHICAD, you can optionally assign one or more classifications to any project element. A classification 

makes parameters and functions available to these elements for use by other applications: to organize project 

data, to make models transparent, to locate elements, for listing purposes, to share exact data, etc.

For each construction element, classifications can be set in the Classification and Properties panel of its 

Settings dialog box.

ARCHICAD provides a flexible way to classify elements according to any national or company standard 

classification system. You can assign one Classification value per Classification System in the Elements’ 

Settings dialog, or from the Interactive Schedule.

Element classification affects the IFC export process: each element is saved to the IFC model according to an 

IFC Type.

This is displayed in the “IFC Type” item in the Classification and Properties panel (under IFC Properties).

Note: The IFC Type Mapping of ARCHICAD elements by classification depends on the Type Mapping for 

Export setting of the current Preview Translator. See IFC Translators: Overview.

For more details, see Properties and Classification Systems.
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Structural Function Category for IFC

“Load-Bearing Element” or “Non-Load-Bearing Element”

In collaborating with partners who are using structural programs, you can assign the “load-bearing” 

classification to elements in ARCHICAD and export this information with the IFC file.

Note: By default, Revit Structure will display only walls that have the “load-bearing” property in the 

“Structural” discipline views. But, if you forget to classify required walls as “Load-Bearing Elements” in 

ARCHICAD, the structural engineers can also change the bearing function of walls, or they can apply 

another display discipline (e.g. “Architectural”) in order to show all walls exported from ARCHICAD.

The current IFC standard supports the export of the “load-bearing” IFC property only for the following 

elements: Wall, Slab, Column, Beam, Roof; elements classified as such in ARCHICAD; and objects 

having these sub-types.

If you have classified ARCHICAD elements as “load-bearing”, then you can use the Partial Structure Display 

“Core of Load-Bearing Elements Only” option to display those elements only. This is particularly useful if you 

wish to export only load-bearing elements to a structural engineer: in this case, just use the “visible elements” 

export mode on a view that uses this Partial Structure Display option. 

See Partial Structure Display.

This category is useful for listing purposes - for example, you can calculate the materials needed for all load-

bearing walls or columns, separately from materials of non-load-bearing elements. 

Criteria in the Find & Select dialog box include: search for those elements that have been defined as load-

bearing or non-load-bearing, or whose Structural Function category is “Undefined”. Since IFC export can be 

limited to selected elements only, you can - for example - export all selected elements defined load-bearing 

(not just their Core only, as described in the example above).

See also Find and Select Elements.

The load-bearing data is also a standard property of exported elements. Moreover, if other applications (such 

as a structural program) also categorize elements according to their load-bearing function, ARCHICAD can 

filter these elements upon importing them, and such elements will show up in the ARCHICAD model with that 

classification.

Position Category for IFC

“Interior” or “Exterior”

This category is useful if you plan to send an IFC file to partners (e.g. energy analyzers) who are able to 

differentiate elements by their location in the building. When you export the ARCHICAD model to IFC format, 

your model elements that are classified as “Interior” or “Exterior” will carry this information to the partner’s 

application via IFC.

Naturally, the opposite is also true. Since Position (IsExternal) is a standard IFC property for certain building 

elements (e.g. Wall, Slab, Column, or Beam), if an imported IFC model contains such data, then the 

appropriate category is automatically added to the respective elements.

Criteria in the Find & Select dialog box include: search for elements categorized as either “Exterior” or 

“Interior”, or whose position is “Undefined”.

See also Find and Select Elements.

Interactive Schedule Criteria are also available to differentiate listed elements by Position.
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Note: Within ARCHICAD, the Position category is fully usable as an ARCHICAD property (e.g. in Find & 

Select and Interactive Schedule). However, it will not be exported as an IFC property for certain element 

types (e.g. Ceiling (IfcCovering)) which are not supported by the IFC standard.
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Export IFC Model from ARCHICAD

There are three export functions:

• Save as (File menu): exports the entire current ARCHICAD project or just its filtered content to an entirely 

new IFC file.

• Merge to IFC Model (File > Interoperability > IFC): merges only certain elements or, alternatively, the 

entire content of the current ARCHICAD project into an existing (unopened) IFC file. For example, use this 

command if you want to add selected content from an ARCHICAD model to an IFC file from another 

discipline.

• Publisher (Document menu): publishes views to any of the IFC file formats. For each Publisher item, 

you can vary the Translator, so that the view content can be customized to the needs of the recipient, 

creating the desired output with a single click.

See IFC Format.

Regardless of the method, the export process is controlled by an IFC Translator for Export, which defines how 

ARCHICAD elements should be interpreted and displayed in IFC. As part of the export process (see steps 

below), you will choose an IFC Translator for Export. 

Save as IFC/Merge to IFC Model

Both of these export functions (Save as and Merge) follow essentially the same steps.

1. Choose the IFC export command you need.

File > Save as...

File > Interoperability > IFC > Merge to IFC Model

2. File type

Save as IFC: From the “Save as type” choose any of the IFC file formats.

Merge to IFC Model: Only the IFC file types are available. 

See IFC File Types Supported by ARCHICAD.

Save as IFC Merge to IFC Model
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3. Define File Name

Use the “File name” field to define a file name (Save as), or browse for an existing IFC model (Merge to 

IFC Model).

4. Choose a Translator for Export

Use the drop-down list to choose among the predefined or user-defined translators. 

Click Options to open IFC Save Options, with a summary of the selected Translator settings.
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5. Filter Model at Export

As needed, further filter the set of elements to export, using the Elements to Export dropdown and/or the 

Model Filter dialog box, both available from IFC Save Options.

See Filter Model at Export.

6. Export

Click “Save” (Save as) or “Open” (Merge to IFC Model) to start the export process.

Hint: After exporting an IFC model, it is good practice to check the IFC model in an IFC viewer (or in 

ARCHICAD by reopening the IFC file). There are many free IFC viewers on the market that can be readily 

downloaded, including:

– DDS-CAD Viewer: http://www.dds-cad.net

– Solibri Model Viewer: http://www.solibri.com

– Tekla BIMsight: http://www.teklabimsight.com

Merge to IFC Model: Protected Content

In case of Merge to IFC Model, the content of the existing IFC file is protected: merging a file to IFC will only 

add to it, without replacing any of its elements. This means that if a merged element has the same IFC 

GlobalId Attribute as an existing element in the IFC file, then the element will be merged using a new IFC 

GlobalId Attribute. Elements will never be overwritten as a result of a merge. This also means that the Merge 

to IFC Model command is not suitable for merging changes from one version of an IFC file to another version 

of the same file!

This illustration shows the result of merging an ARCHICAD model into an existing file that contains an MEP 

model.
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Import IFC Model to ARCHICAD

ARCHICAD provides three methods for importing an IFC model to ARCHICAD: Open, Merge, and Hotlink. 

Open versus Merge

• Open: Opens the entire model or filtered parts of an IFC file as a new project. ARCHICAD will transform 

the imported elements into corresponding ARCHICAD elements, based on settings in the chosen IFC 

Translator for Import.

• Merge (File > Interoperability > Merge): Available only in Floor Plan view. Inserts an IFC model in whole or 

in part into a running ARCHICAD project. Merge preserves your running project, without overwriting its 

data (this is the “Reference model” concept). However, even in this “Reference model”, the merged 

elements are real ARCHICAD elements based on the IFC-ARCHICAD mapping convention.

In the Merge process, ARCHICAD automatically generates new IFC GlobalId (ARCHICAD IFC ID) values 

for all imported elements to avoid overwriting the IFC GlobalIDs of the host project. For the purposes of 

listing and searching, the elements’ original GlobalId values are also retained, in the form of a parameter 

called “External IFC ID”.

Overview of IFC Import: Defining how IFC Data are Converted to ARCHICAD

When you open (or merge or hotlink) an IFC file in ARCHICAD, the program carries out the following steps for 

each imported IFC element, using the settings in the chosen IFC Translator for Import:

1. Does the IFC element need to be imported to ARCHICAD? (based on the Translator’s “Model Filter for 

IFC Import” preset

2. Which ARCHICAD tool (e.g. Wall, Object) should be used to place the IFC element in ARCHICAD? (This 

is based on the Translator’s “Geometry Conversion for IFC Import” preset.)

3. Which ARCHICAD layer should the element be placed on, and using which attributes? (This is based on 

the Translator’s “Material and Surface Conversion for IFC Import” preset.)

4. Which ARCHICAD Classification should be assigned to the element? (This is based on the Translator’s 

“Type Mapping for IFC Import” preset.)

5. Based on the Classification: which Properties are available for the element? (This uses the Property 

Availability definitions, defined in the Classification Manager of the template file used at import.)

6. Each of these Element Properties is populated with its default Property value. (This uses Property 

definitions of the Property Manager, in the template file used at import.)

7. The program examines the IFC data assigned to the incoming element, and attempts to generate the 

equivalent property value for the element in ARCHICAD (This is based on the Translator’s “Property 

Mapping for IFC Import” preset.)

Important Note on Translators and Template Files

• When you import an IFC project using Open or Hotlink IFC: You will choose an IFC Translator for Import 

from an external Template file, selected by you.

• When you import an IFC project using the Merge command: You will choose an IFC Translator for Import 

from the current host project.

The following sections describe these processes.

Open IFC Model

Merge IFC Project
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Import IFC Model to ARCHICAD Working with IFC
Hotlink IFC File

Related Topics:

IFC Translators: Overview

Translators for Import (Detailed Settings)

Filter Model at Import (Secondary Filter)
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Open IFC Model

Follow these steps to import IFC data using the Open process.

1. Use File > Open.

2. Select the IFC File Format.

3. Choose the IFC file to import.

4. Use the drop-down list to choose among the IFC Translators.

Note: In the Open IFC process (just like the Place IFC Hotlink process), the file is imported based on an 

IFC Translator for Import, from a Template file selected by you.

For each listed Translator, its parent Template is shown in parentheses. If the Translator you need is not 

shown, you may need to search under a different template (see next step).
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Open IFC Model Working with IFC
5. From the Open dialog, click Options to see IFC Open Options.

Here, each loaded template is shown together with its Translators, location, and presets. Choose a 

Translator from one of the templates and click OK, or click Browse Template to load another one. 

6. Click “Open” to import the IFC model based on the selected Translator. Additional steps follow, depending 

on the type of imported model.

See Additional Options at IFC Import.
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Merge IFC Project

1. Use File > Interoperability > Merge.

2. Select the IFC File Format.

3. Choose the IFC file to merge.

4. Choose a Translator

Use the drop-down list to choose among the IFC Translators. These are the IFC Translators in the current 

host project.

5. Choose Info from the Merge dialog to see a summary of the selected Translator settings.

Note: In the Merge process, ARCHICAD uses an IFC Translator for Import that you choose from the 

current host project.

6. Click Open to merge the IFC Project to ARCHICAD.
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7. Additional steps follow, depending on the type of imported model.

See next section.

Additional Options at IFC Import

Building and Site Selection

If the IFC file contains multiple IfcBuildings and/or IfcSites, then a Building Selection dialog appears, so you 

can select one Building. The import process can import only one building at a time.

On the left of this selection dialog, view the site and building hierarchy in the tree structure. At right, 

information is shown on each selected building. 

If the “Import all Site geometry” checkbox (at the bottom left of the dialog box) is not enabled, then the 

selected IfcBuilding will be imported with only the geometry of the specific IfcSite to which the building is 

assigned. 

To import the entire site model, regardless of the chosen building, activate the “Import all Site geometry” 

option.

Filter Model at Import

As needed, further filter the set of elements to import, using the Model Filter dialog box.

See Filter Model at Import (Secondary Filter).
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Library Parts Location

Choose where to save Library Parts generated during IFC import:

The External location is recommended. Make sure you manually link this folder to the project as a Linked 

Library.

Notes:

– When updating a Hotlinked Module, the Linked Library will not be updated! If Linked Library contents 

have changed, you must update the library manually.

– Make sure that the target folder is write-enabled at the time of import. If it is not, the import process will 

fail.

– In Teamwork, the Linked Library option is not available; generated Library Parts are saved to the 

Embedded Library.
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Vertical Position of Merged IFC Model (only at Merge IFC Model)

View or change the options in the Vertical Position dialog box, to define the vertical position of the merged 

model in the host ARCHICAD project.

• Original: When using the File > Interoperability > Merge command to import an IFC model, ARCHICAD 

recreates the original vertical position of the merged model inside the host project by default. ARCHICAD 

will automatically match stories and create offsets to ensure that the merged model is in the same vertical 

position as in the IFC source file.

• Custom: Alternatively, click Custom to manually set the merged model’s vertical position.
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• From the pop-up menu, choose the story of the incoming IFC project which should be placed onto the 

current story. In the list, each story of the IFC model is shown with its own elevation in parentheses. 

• Elevation Offset: To adjust the vertical position of the imported model, enter a positive or negative value 

in the Elevation Offset at the bottom of the dialog. By default (and this is recommended), the Elevation 

offset value is the absolute difference between the elevation values of the chosen IFC model story and the 

current ARCHICAD story. 

Result

• See the Result field to see which merged stories will be placed on which stories of the host. 

• In either case (Original or Custom vertical position), new stories are created above or below the host 

project’s story range, if they are needed to accommodate extra stories in the merged project.
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• New stories (if any) are marked with a plus sign. These stories will be created in the Host when you click 

OK to close the dialog box.
ARCHICAD 24 Reference Guide 2944



Hotlink IFC File Working with IFC
Hotlink IFC File

Place IFC files as hotlinks directly into the currently open Project as protected reference content. You can 

place this hotlink as many times as needed. Thus, in a project using repeated building blocks/parts, you do 

not need to request a huge IFC file based on the entire project - a smaller IFC file that contains just the 

module is enough.

Place IFC Hotlink

The steps for placing an IFC hotlink are the same as when placing a PLN-based hotlink, with some additional 

options described here.

1. As when placing any other Hotlink, use File > External Content > Place Hotlink.

See Place Hotlink for an overview of this process.

2. From the New Hotlink Module dialog, choose an IFC format file and a Translator for Import.

Note: In the Place IFC Hotlink process (just like Open IFC), the hotlink elements are imported based on 

an IFC Translator for Import, from a Template file selected by you. 

For each listed Translator, its parent Template is shown in parentheses. If the Translator you need is not 

shown, you may need to search under a different template (see next step).
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3. From the Open dialog, click Options to see IFC Open Options.

Here, each loaded template is shown together with its Translators, location and presets. Choose a 

Translator from one of the templates and click OK, or click Browse Template to load another one. 

See IFC Translators: Overview for more information.

4.  Click Select to return to the Place Hotlink dialog box.

For details, see Hotlink Settings.

Note: When hotlinking an IFC file, make sure you set the Elements’ Elevation option to Keep Elevation! 

Otherwise, the imported model may “fall apart” when its elements are placed in a different story structure 
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5. Click Place Hotlink.

6. You are prompted to choose where to store the library parts.

See Library Parts Location.

7. If the IFC Translator for Import requires it, the Model Filter for Import also appears, to allow for further 

element filtering before placing the hotlink.

See Filter Model at Import (Secondary Filter).

Layers of IFC Hotlink Elements

When placing an IFC file as a Hotlink, remember that the imported elements’ own Layers depend on the Layer 

Conversion settings of the Translator for Import that you are using.

See Layer Conversion for IFC Import.

Avoid Model Element Intersections with Hotlinked IFC Elements

Like other IFC content imported to ARCHICAD, IFC-based Hotlink content depends on the settings of the IFC 

Translator used for import.

If you are importing elements as native AC construction elements, unwanted intersections can be a problem.

To avoid intersections, do one of the following:

• Make sure the imported IFC elements are placed onto a separate ARCHICAD layer. (Check the Layer 

Conversion setting of the IFC Translator used for import.) (See Layer Conversion for IFC Import.)
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Note: ARCHICAD will automatically apply a unique Layer Intersection Group setting to this new Layer. 

Elements whose layers have differing intersection numbers never intersect. (See Use Layers to Prevent 

Intersections.)

• Use the Translator’s Geometry Conversion settings to create Objects or Morphs out of the imported 

elements. Such elements do not participate in automatic element intersections.

Watch the Video
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Update with IFC Model

This command (File > Interoperability > IFC > Update with IFC Model) updates the current ARCHICAD 

project content with an IFC model. 

Use this if the ARCHICAD project and the IFC file contain elements in common, and if you want to add to or 

modify the project elements’ data using IFC data.

• Exported ARCHICAD properties that are mapped to IFC properties are updated, provided that the correct 

Translator settings are used at both export and import. (ARCHICAD 22 and later)

• “Elements in common” are those whose GlobalId Attribute is the same in both the host project and the 

imported IFC model.

• “IFC data” include IFC Attributes, IFC Properties and IFC Classification References

Thus, this command is optimized for tracking and updating changes to property data. This command is not 

suitable for updating model element changes. 

Notes:

◦ Property update using this command works properly only if Property and Type Mapping definitions are 

used correctly and consistently, both at export and at import

◦ Deleted elements and modified elements are ignored!

◦ Geometry data (size, color, layer) will not be updated or modified. 

◦ Properties of locked project elements will not be updated or modified.
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Workflow for Update

1. Go to File > Interoperability > IFC > Update with IFC Model.

In the Open dialog:

◦ Browse for an IFC model. 

◦ Choose an appropriate Translator for Import. The Translator should use Property and Type Mapping 

settings that are analogous to those used when the original ARCHICAD model was exported to IFC.

2. Click Open.

3. In the appearing dialog, set the update options as needed (see Update Options, below). 

4. Click OK. 

Example Workflow: Property Mapping at Export and Import

1. The ARCHICAD model is exported to IFC, using the File > Save As IFC command.

ARCHICAD elements are exported together with their IFC data. Based on the Translator for Export - 

Property Mapping for Export preset (which also depends on the Type Mapping for Export preset), 

ARCHICAD properties are mapped to IFC properties.

2. An external consultant works on the IFC model, deleting some properties, modifying others, and adding 

some new ones. 

3. The edited model is imported back to ARCHICAD using File > Interoperability > IFC > Update with IFC 

Model. 

4. New and modified IFC properties are added and updated in the ARCHICAD model, based on the mapping 

definitions of the Translator for Import - Property Mapping for Import preset.

• Important: To map the properties back to existing ARCHICAD properties, make sure you activate the 

option to Import as ARCHICAD Properties.

Update Options

Check the options to specify which data to update in the ARCHICAD model.

Note: These update data options are only relevant for incoming IFC Attributes and IFC Classification 

References. Properties are updated based on Translator-based property mapping definitions at export 

and import. 
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• Merge new model elements from IFC

• Merge new from IFC: IFC Attributes and IFC Classification References which do not yet exist in the host 

project will be added to elements in common. 

• Override existing if modified in IFC: For elements in common, the project data will be modified by the 

corresponding data values from the merged IFC file. Corresponding data: Attribute and Classification 

Reference must have the same name.

Note: This is a full override: all values for data items having the same name will be modified.

• Remove existing if missing in IFC: For elements in common, project data which do not exist in the 

merged IFC file will be removed.
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IFC Project Manager

The IFC Project Manager (File > Interoperability > IFC) provides a hierarchical overview of the current 

project’s IFC model database. Each model element is listed with its IFC attributes and properties. 

Most of these are inherited from import/export IFC standards set elsewhere (e.g. Type Mapping and Property 

Mapping presets of the project’s IFC Preview Translator.) However, you can edit values in IFC Project 

Manager for any specific element, and/or create custom IFC properties or Property sets as needed.

Related Topics:

Functions of the IFC Project Manager

Navigating in the IFC Project Manager: Tree Structure

Navigating in IFC Project Manager: Attributes and Properties

Assign or Edit IFC Property/Attribute Values

Create New, Custom IFC Property

Apply Predefined Rules

Using Assignments in IFC Project Manager

Using Type Products in IFC Project Manager
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Functions of the IFC Project Manager

• View all IFC model entities generated from the ARCHICAD project (including IFC import content) in a 

hierarchy

• View all IFC data available for project elements

• Create new IFC data (custom IFC Properties and Classification Reference) for any model element

• Group elements or assign entities to elements (called IFC Assignments) and manage their IFC data

• Manage IFC Type Products assigned to elements with their with their IFC data

• Assign elements directly to the IfcSite or IfcBuilding. For example, the neighboring buildings and site 

context elements (trees, fences, roads, vehicles etc.) can be assigned to the IfcSite; thus, their default 

direct relation to their home story is removed.

• Update the IFC model with the modifications of the ARCHICAD project

• Navigate easily between the ARCHICAD model and the IFC model

• Filter the IFC model by elements visible in the current view

• Find elements both in the IFC and ARCHICAD models by their IFC ID’s

• In Teamwork, reserve the IFC Project Manager to modify data for the following elements: IfcProject, 

IfcBuilding, IfcSite, Assignments, and Type Products. To modify data for model elements (e.g. IfcWall, 

IfcColumn, IfcBeam) in IFC Project Manager, you must also reserve the elements themselves. 

The IFC Project Manager palette is a modeless dialog box, so you can keep it open while working in the 

ARCHICAD project.
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Navigating in the IFC Project Manager: Tree Structure

The tree structure (upper left side of the IFC Project Manager) displays the IFC model hierarchy and lists IFC 

Entities of the current project according to their “IFC Type” classification.

See IFC Model Hierarchy.

ARCHICAD Elements in IFC Story Structure

In ARCHICAD, all elements and objects are linked to their Home Story. Therefore, by default, elements are 

listed in the IFC model hierarchy under the IfcBuildingStorey that corresponds to their Home Story. 
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You can break this link (to the IfcBuildingStorey) by dragging the element out of its IfcBuildingStorey location 

into the IfcSite. For example, a neighboring building modeled with a Morph can be placed into the Site folder. 

You can also place elements into the Building (such as an element that is logically tied directly to a particular 

building rather than a story).

To return an element to its automatic IfcBuildingStorey classification (corresponding to its Home Story), just 

drag it out of the IFC Project Manager.

Filter Data Shown in Tree

Click List visible model elements only to narrow the tree to those elements that are visible in the current 

ARCHICAD model view.
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Synchronize Project Manager Data with Model

When elements are created or deleted in the ARCHICAD model, the tree will not register these changes 

automatically. If a refresh is needed, a message appears below (“Tree is not up-to-date!”). Click the 

“Synchronize” button to refresh it.

Find Selected Model Elements in Tree; Find Selected Tree Elements in Model

• To find and select IFC Entities of the tree in the ARCHICAD model, select them in the tree and click Show 

list selection in model. The program displays and selects the elements in the active window (Floor Plan 

or 3D view only). 

• To find and select ARCHICAD model elements in the tree, select them in the Floor Plan or 3D window, 

and click Show model selection in list.

Find Tree Elements by IFC Identifiers

An IFC model checker might alert you to modeling errors. You can locate such elements in IFC Project 

Manager based on their IFC identifiers:

• ARCHICAD IFC ID (the Globalid IFC attribute automatically assigned by ARCHICAD to each element)

• External IFC ID (the Globalid IFC attribute assigned to each IFC element imported to ARCHICAD)
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IFC Project Manager Working with IFC
Switch to the search mode using the Find by GlobalId tool (third icon underneath the tree).

Note: The External IFC ID is created when importing an IFC model to ARCHICAD using either Merge or 

Hotlink IFC. This is done to prevent existing ARCHICAD elements from being overwritten by identical 

elements being imported from IFC. (The External IFC ID stores the original ID of the model elements as 

defined in the external file).
ARCHICAD 24 Reference Guide 2957
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Type the identifier (or any portion of it) that you are searching for into the empty field below the tool, and then 

click the “Search” button.

• Select any item in the “Search result” list to show that element in the tree. 

• Click “Show list selection in model” to find and select the element in the ARCHICAD model.

IFC Assignments View vs. IFC Type Products View

You can group IFC elements by Assignments and/or IFC Type Product. 

See the descriptions of IFC Assignments and IFC Type Product.

To view these groupings in IFC Project Manager:
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Switch to “Assignments” or “Type Products” view/definition mode using the first or second icon, respectively, 

underneath the tree.

View Items by Assignment or Type Product

To narrow the displayed Assignment/Type Product data to that of the selected elements only, click the “Filter 

for selected element(s)” button. 

Related Topics

Using Assignments in IFC Project Manager

Using Type Products in IFC Project Manager
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Navigating in IFC Project Manager: Attributes and Properties

Select a project element in the tree: for this selected item, the right side of IFC Project Manager displays:

• available IFC Attributes

• Properties grouped in Property Sets

• Classification References

In case of multi-selection, the IFC data of the last-selected element are shown.

At the top of the list, the numbers of selected/editable elements are shown.

Many IFC Property and Attribute are defined automatically, based on the Property Mapping rules defined in 

the IFC Translator for Export.

Filter Data Shown in IFC Project Manager

The predefined IFC data types are very numerous, and you usually don’t need to see all of them at once in 

IFC Project Manager. Use the two filter buttons at top right to cut down on the data shown here:
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Show only Properties from Active Preview Translator

Activate this button to display only those data based on to the Property Mapping preset of the Preview 

Translator.

Show only Properties from Active Preview Translator (Property Mapping for IFC Export)

See also Preview Translator and Property Mapping for IFC Export.

If you do not activate this filter, then IFC Project Manager also displays any new properties created here and 

in the Element Settings dialog boxes, as well as custom data added during an import process. 

Show Only Items with Values

Use this toggle to display only those data which have assigned values: that is, its checkbox is enabled.

Note: A property whose field is empty, but whose checkbox is enabled, counts as a property that has a 

value assigned.
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Assign or Edit IFC Property/Attribute Values

For any selected element in IFC Project Manager, overwrite any editable property or attribute value as 

needed. 

The display of Attributes and IFC Properties in IFC Project Manager indicate the data status:

• BLACK: Editable items can be overwritten with a custom value.

• Checkbox: An active checkbox indicates that this property or attribute has a value.

Note: Don’t forget that if you enable “Show only items with values”, then items without a value are not 

shown here at all. See Filter Data Shown in IFC Project Manager.
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• RED ARROW: A customized value is shown with a red arrow: click it to revert to the original value.

• GREY: cannot be modified here in the IFC Project Manager.

– The element’s IFC Type depends on the Type Mapping definition of the Preview IFC Translator. This 

item is greyed and not editable here.

• Chained: This value is derived from some other interface. For example:

– The IsExternal and LoadBearing IFC properties (see image below) are greyed and not editable here. 

- These values depend on what is set in the ARCHICAD element’s Settings dialog: the 

“LoadBearing” value comes from its Structural Function; and the “IsExternal” value comes from the 

Position.
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• If a Property Set no longer contains any Properties, it will be deleted from the list automatically. 
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Create New, Custom IFC Property

IFC Properties are additional (mostly IFC Type-specific) parameters assigned to an IFC Entity. Standard, so-

called “IFC2x3 Schema” data are defined by buildingSMART and stored in property sets whose names begin 

with the prefix “Pset_”

You may wish to create a custom Property or Property Set (e.g. an office-standard Property Set).

1. In IFC Project Manager, click New.

2. In the appearing dialog box, enter a new custom Property Set name (Pset); or else choose from the list of 

existing Property Set names defined previously for the same element type (click the arrow icon to access 

this list). For example, if you are creating a new Property for an IfcWall, the list contains all the Pset names 

earlier assigned to other IfcWalls.

Note: To avoid errors (and to keep the standard property definition rules), do not use the standard “Pset” 

prefix when giving a name to your custom Property Sets.
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3. Enter a new Property name.

4. Choose a Property type (single, enumerated, complex, etc.) as described in the following table.

5. Set the value type to label, text, integer, boolean, etc. 

See also Unit Conversion for IFC Export

Property type Definition

Single Value A property object which has a single (numeric or descriptive) value assigned.

Enumerated Value A property object whose value is chosen from an enumeration.

Bounded Value A property object which has a maximum of two (numeric or descriptive) values 

assigned, the first value specifying the upper limit and the second value 

specifying the lower limit

Table Value A property object which has two lists of (numeric or descriptive) values assigned, 

corresponding to a table with two columns.

List Value A property that has several (numeric or descriptive) values assigned, 

corresponding to an ordered list.

Reference Value 

(IfcCalendarDate only)

A property object which references to calendar date-type entity (day, month, and 

year).

Value type Definition

IfcAreaMeasure REAL type value of the extent of a surface. Value must be set in square meters, 

but is recalculated at export based on Area Unit settings.

IfcBoolean A defined data type of simple BOOLEAN type. Value: TRUE or FALSE.

IfcIdentifier An identifier is an alphanumeric STRING (max. 255 characters) which allows an 

individual thing to be identified. It may not provide natural-language meaning.

IfcInteger A defined data type of simple INTEGER type. The number of bits contained in the 

IfcInteger is unrestricted, but in practice it is implementation-specific.

IfcLabel A label is the term by which something may be referred to. It is a STRING (max. 

255 characters) which represents the human-interpretable name of something 

and shall have a natural-language meaning.

IfcLengthMeasure REAL type value of a distance. Value must be set in meters, but is recalculated 

at export based on Length Unit settings.

IfcLogical A defined data type of simple LOGICAL type. Value: TRUE, FALSE or 

UNKNOWN.

IfcMonetaryMeasure REAL type value of an amount of money without regard to its currency. The 

currency unit can be set at Currency Unit settings.

IfcPlaneAngleMeasure REAL type value of an angle in a plane. Value must be set in radians, but is 

recalculated at export based on Angle Unit settings.

IfcPositiveLengthMeasure Length measure shall be greater than zero. Value must be set in meters, but is 

recalculated at export based on Length Unit settings.
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Note: All other “Measure”-type properties not listed in the above table are handled and exported without 

any unit settings.

• Newly created IFC data will appear in the defined Property Set or under “Classification References” in the 

IFC Project Manager, as well as in the element Settings dialog among the listed properties. 

• Such newly created IFC data appear with a red X in front, meaning that you can delete them at any time. 

IfcRatioMeasure REAL type value of the relation between two physical quantities that are of the 

same kind. Input given in percent is expressed as a decimal value: e.g. 25% 

becomes 0.25. 

IfcReal A defined data type of simple REAL type. The domain of Real is all rational, 

irrational and scientific real numbers. Here the precision is unconstrained, but in 

practice it is implementation-specific.

IfcText Alphanumeric STRING of characters which is intended to be read and 

understood by a human being. It is for information purposes only. No character 

number limitation.

IfcTimeMeasure REAL type value of the duration of time periods. The time unit can be set at Time 

Unit settings.

IfcVolumeMeasure REAL type value of the solid content of a body. Value must be set in cubic 

meters, but is recalculated at export based on Volume Unit settings.

More Types… See the definitions at “alphabetical listing” > “Defined Types”:  

http://www.buildingsmart-tech.org/ifc/IFC2x3/TC1/html/index.htm

Value type Definition
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Create New Classification Reference

A Classification Reference (IfcClassificationReference) arranges IFC elements into a category. You can 

assign an Item Reference identifier, a classification Name attribute and some other optional parameters to all 

project elements (such as the building, the stories, the building elements, or the zones). 

You can classify elements with this system both in IFC Project Manager and the element Settings dialog.

Example

1. In IFC Project Manager, click New.

2. Click the Classification Reference button and assign it a new name. Here, too, you can choose from the 

list of existing Classification Reference names defined previously for the same element type (click the 

arrow icon to access this list).
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• Assign values. The Classification Reference has 7 available items (the most important ones are the 

“Name” and the identifier (“ItemReference”) of the classification reference data) for defining/editing. 

To define values of a custom-defined Classification Reference data, type them manually or use the Apply 

Predefined Rule command:

See Apply Predefined Rules. 
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Apply Predefined Rules

Use this function to create custom-defined Classification Reference data based on automatic (.xml-based) 

rules. 

1. In IFC Project Manager, click Apply Predefined Rule.

There are three types of predefined rules, based on their differing structures:

• “Tree list” rule: select an element from a tree-structure database to create the new data

• “Table” rule: select a row from a table to create the new data

• “Command” rule: start the rule-command to create the new data

The program contains factory-defined built-in rules (these vary depending on your localized version of 

ARCHICAD). 

• The available rules are accessible from the following folder, and the newly created rules should also be 

saved to this location: 

– On Windows:

GRAPHISOFT\ARCHICAD\Defaults\IFC Rules

– On Mac:

Applications\ARCHICAD\Defaults\IFC Rules
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Apply Predefined Rule: Example

Assign classifications to a number of roof slabs (IfcSlabs) using the “OmniClass / Table 21 - Elements” rule: 

1. In the model, select the Slab elements to be classified (you can use Find & Select). Open the Settings 

dialog box and click on “Manage IFC Properties” from the Classification and Properties panel. 

Alternatively, select the corresponding IfcSlab entities from the IFC Project Manager tree.

2. Click on Apply Predefined Rule. From the dialog box, choose the “OmniClass / Table 21 - Elements” 

rule.

3. In the database Search field, enter the text “roof”, and click the search icon to execute the search. (This 

searches among the rules in the databases (tree list and table) based on any partial text.)

4. From the Search result area, select the “Roof Decks, Slabs, and Sheathing” title. 
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5. Click “Apply”. The Classification Reference is generated, with the name of “Roof Decks, Slabs, and 

Sheathing”, with an ItemReference value of “21-02 10 20 20”, and additional data corresponding to the 

OmniClass standard.

Notes

• Once you select an element, only the applicable rules are available in the “Select Rule” list (for example, if 

you have selected IfcProject, then the “Concept Design BIM 2010 (US GSA) / Project Client/Owner and 

Project Architect” rule is available). All the non-applicable rules are grayed.

• IfcElement includes building, distribution (MEP) and furnishing elements.

• Certain rules are not available in Settings dialogs if the rules are related to elements which do not have 

Settings dialogs (for example, IfcBuilding, IfcBuildingStorey, IfcOccupant, IfcProject and IfcGroup).

• You can create and edit your own rule in .xml format. It is recommended to peruse the structure of an 

existing rule file (which may contain multiple rules), and to create a similar new rule by duplicating it under 

a different name.
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Using Assignments in IFC Project Manager

Use IFC Assignments (IfcRelAssigns) to create groups of project elements. The major Assignment Types of 

the IFC4 standard can be seen in IFC Project Manager. 

– IFC Groups

– IFC Zones

– IFC Systems

– IFC Building Systems

– IFC Distribution Systems

For more information on each Assignment type, see IFC Assignments.

Assignment Types in IFC Project Manager

To group IFC elements by IFC Assignment in IFC Project Manager:

1. Use the New button to create a new Assignment under an Assignment Type

2. Drag relevant IFC entities from the top tree view into the newly created Assignment Relation item

This process is described below.

Create New Assignment Relation

1. Switch to Assignment view mode by clicking the Assignments icon. (See illustration above).

2. Click on an Assignment type to select it (e.g. IFC Zones)
ARCHICAD 24 Reference Guide 2973



IFC Project Manager Working with IFC
3. Click the “New” button at the bottom of the window.

As a result:

• A New Assignment (e.g. New Zone) is created for the selected Assignment Type.

– A New Relation folder is created within the new Assignment. You can now add related IFC entities to 

this folder.

– A New Spatial Relation node is also created within the new Assignment. (Not available for IFC 

Groups). You can add related spatial entities to this node.
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4. Drag related items from the IFC Entity tree above into the New Relation folder and/or the Spatial Relation 

node. 

Hint: Shift+click to multi-select, and grab the entities by their icons to drag them.
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Click and Drag IFC Entity into New Relation Folder

See Examples of Assignments.

Which Entities Can Be Added?

Relation Folder: Entities that can be added to a Relation Folder depend on the Assignment type:

– IFC Groups: Drag any project elements here to create logical group(s)

– IFC Zones: Drag IfcSpace elements here

– IFC Systems: Drag IFC spatial types (IfcSite, IfcBuilding, IfcBuildingStorey and IfcSpace) and any of 

their related elements

– IFC Building Systems: Drag related building elements here. Possible items: IfcBuildingElement, 

IfcFurnishingElement, IfcElementAssembly, IfcTransportElement

– IFC Distribution Systems: Drag MEP elements (IfcDistributionElement and/or sub-elements) here.

Spatial Relation: Spatial IFC elements (Site, Building, Story, Zone) can be added to the Spatial Relation 

node.
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Rename Assignment Item

Rename any newly created item using the Name Attribute field on the right side of the dialog.

Delete Assignment or Entity

To delete a Relation entity or Assignment, select it and click the  “Delete” (red X) button.

Manage Assignment Hierarchy

• Within a particular Assignment Type, drag and drop entities among different Relation folders

• Define new hierarchies: Select an existing Assignment or Assignment Type item and click “New” to define 

a sub-item. This way, you can create a multi-level hierarchy within an Assignment Type.

• To copy an item, hold down Ctrl/Alt while dragging it

• To make a child Assignment into a parent Assignment, select it and drag it outside of the dialog box; it will 

reappear in the hierarchy as a parent Assignment
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Examples of Assignments

• Create an IfcZone named “Security Zone”, which will group together all of the project’s IfcSpaces that 

have a security function.

• Group elevators in a vertical circulation system, which is a child system of a mechanical system.
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MEP Modeler Elements: Automatic Assignment to IFC Distribution System 

MEP Modeler elements can be automatically added to the IFC Distribution System Assignment, 

corresponding to each element’s MEP System. For example:

1. At the IFC Distribution Systems Assignment Type: Click the New button to create a new, empty IFC 

Distribution System.
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2. Select this new Distribution System, then click on the MEP icon at the right (underneath the Assignment 

list).

3. Choose the desired MEP System from the drop-down menu (e.g. Fresh Air). The Distribution System is 

renamed accordingly. 
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4. All elements that belong to this MEP System (e.g. Fresh Air) are automatically added from the tree into the 

“New Relation” folder.

Note: You can also add any other Distribution element manually to this folder.

To delete MEP System elements from an IFC Distribution System, select the Distribution System item (e.g. 

Fresh Air), and choose “Disconnected” from the drop-down menu of the MEP System options.
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Using Type Products in IFC Project Manager

The IFC Project Manager displays all the IFC Type Products that exist in the project, plus all the elements 

which refer to them. IFC Type Products are another way to group project elements. 

To see elements by Type Product, switch to the Type Products view/definition mode using the second icon 

underneath the tree.

Property Mapping rules can be defined for Type Products. 

See an example here: Example 4: Mapping Rule by IFC Type Product.

An IFC Type Product defines a particular style/type of other entities by relating to them with common IFC 

Attributes and Properties. For example, IfcWindowStyle is an IFC Type Product, to which many windows 

(IfcWindow) refer.

IFC Type Product entities are generated for ARCHICAD elements based on the Type Mapping definition in the 

Translator for Export.
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Select a Type (e.g. IfcWallType) to check its IFC data on the right side of the IFC Project Manager. The IFC 

data of the resulting IFC Type Product are not editable by default; they are displayed in italicized gray type, 

and all IFC data on the right side are grayed.

Edit IFC Type Product

You may wish to edit an IFC Type Product. For example:

• Change its Name Attribute

• Define a value for an Attribute or standard Property that has no value yet

• Modify existing Property data

• Create a new custom Property or Classification Reference

See Create New, Custom IFC Property.
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To edit the IFC Type Product, first enable it for editing: click on the “Edit/New Type” button. 

Then make the desired modifications in the attributes/properties on the right. 

Change IFC Type Product Definition - Subtype

For some ARCHICAD elements, definition as a particular IFC Type Product is not always clear-cut - typically 

the case for HVAC elements (IfcDistributionElements). 

Suppose you have an MEP Modeler-defined Pipe element, classified as IfcFlowSegment. The program will 

automatically choose a subtype of the IfcFlowSegmentType (e.g. IfcPipeSegmentType). 
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To change this to a different subtype of the IfcFlowSegmentType (such as IfcDuctSegmentType): 

1. Make the IFC Type Product editable, using the “Edit/New Type” button.

2. Use the “Change Type Product” drop-down menu. 

Combine IFC Type Products Into One

It is possible to combine several IFC Type Products entities into a single IFC Type Product. This works for all 

element types except Doors/Windows (see below). 

For example, suppose you have two concrete Slabs of different thicknesses. By default, these will be 

classified as two separate IFC Type Products (IfcSlabType), because thickness is a significant property of 

slabs. But you want to combine them into a new, single type named “Concrete slabs.” 

1. Select one of the Type folders and make it editable using the “Edit/New Type” button.

2. From the other Type folder, select the IfcSlab drag it onto first Type folder.

3. Change the Name Attribute of the Type folder (which now contains two elements) to “Concrete slabs” (see 

illustration below).
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Combine IFC Type Products of Doors and Windows

Combining doors or windows is more complicated, because some of their major parameters are generated 

from GDL data, and cannot be modified as a result of combining elements. 

Such parameters are the OperationType Attribute and the panel and lining attributes. Suppose you have two 

doors that are identical in all their data (e.g. size, panel type), but their Operation Types are different: one 

opens to the right, the other to the left. These two doors will be classified under two different IFC Type 

Products: these two Types will have the same name, but their “OperationType” IFC Attributes will differ. 

To have both doors belong to the same IFC Type Product, select one of the doors and place it in the other 

(second) type. 

As a result, a new, common type is created that uses all of the data of the second type (such as Name 

Attribute, Properties, Classification Reference, etc.). This new common type is the one that will be exported, 

and which will be assigned to both of the doors. This common type can be renamed and its data modified. 

At the same time, the two original types will remain as so-called linked types: they will link only data which is 

generated and which differ for each of the two doors (in this case, their OperationType Attributes). In other 

words, both doors will belong to a single type, which includes all of the data they have in common, but they will 

also maintain certain IFC data that were different for each and cannot be combined (see illustration below).
ARCHICAD 24 Reference Guide 2986



IFC Project Manager Working with IFC
Reset Type

“Reset Type” means that all edited IFC data will revert to their original values, and the new data will be 

deleted.

• When Reset Type is applied to a selected IFC Type Product (e.g. IfcWallType) that has been edited, the 

Type’s original data are restored (newly modified IFC data are lost), and the Type is no longer editable. If 

the Type now contains new elements as a result of combining Types, then those elements will return to 

their original locations.

• When Reset Type is applied to a single element (e.g. IfcWall) that has been moved into a different Type, 

that element will return to its original location.
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Manage IFC Data at Element Level

ARCHICAD elements created from imported IFC model elements display their standard and custom IFC data, 

at the element level, in their respective Settings dialog boxes.

New IFC data can be added to the elements manually or automatically, based on predefined rules in the 

Manage IFC Properties dialog, which is opened from Element Settings (Classification and Properties panel). 

The interface of the Manage IFC Properties and all its functions are the same as the right side of the IFC 

Project Manager dialog box.

For detailed function descriptions, see IFC Project Manager.

The new data appear in the Classification and Properties panel of the element Settings dialog, under IFC 

Properties. Here, you can assign values to the available data fields that are still empty.
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Working with IFC Data: Element Settings vs. IFC Project Manager

Element Settings dialog IFC Project Manager

management level element-level only project level

IFC data owner • building elements

• Zone (IfcSpace)

• building elements

• spatial elements:

– IfcProject

– IfcSite

– IfcBuilding

– Story (IfcBuildingStorey)

– Zone (IfcSpace)

• IFC Assignments

• IFC Type Products

• IFC Containers

Functions • collects and lists IFC data

• enables you to create, 

edit and delete IFC data

• enables you to use 

predefined rules

• filters Mapping properties

• filters only IFC data 

having values

• collects and lists IFC data

• enables you to create, edit and delete IFC data

• enables you to use predefined rules

• filters Mapping properties

• filters only IFC data having values

• navigates between the ARCHICAD model and the 

IFC model

• displays Zone (IfcSpace) containment

• enables you to assign elements directly to the IfcSite 

or IfcBuilding
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IFC Local Preferences

The settings defined at IFC Local Preferences (File > Interoperability > IFC) affect the way that IFC data are 

created and managed.

IFC Interface language

The language of the IFC standard/code is English, thus the default and recommended setting for the interface 

is English. In localized ARCHICAD versions, some standard IFC key words (such as IFC Entity, Property, 

Attribute names) may be shown in the local language, but this has no effect on the IFC export, just helps users 

comprehend IFC terms on the interface.

Save Library Parts Generated During Import To

Set the default location of imported Library Parts when opening or merging an IFC project.

See Library Parts Location.

Express Data Manager (EDM) path

The EDM (Express Data Manager) toolkit is the engine which creates an ARCHICAD model from the imported 

IFC model, and which also creates an IFC file out of the exported ARCHICAD model. The default engine is 

the recommended one, but you can use the Redefine option here to modify it as needed.
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Define Element Criteria using IFC Data

Element criteria can include IFC data in the following functions:

• Find & Select

• Reserve Elements by Criteria (Teamwork)

• Interactive Schedule Schemes - list IFC data assigned to current project elements

In these dialog boxes:

1. When defining element criteria, choose “IFC Properties” from the “Add” pop-up list.

2. The Select IFC Properties dialog box appears.

Select IFC Properties

All IFC data added to project elements are listed here.

You can narrow the displayed data:

– Include IFC properties from the Active Preview Translator (as opposed to those currently used in the 

Project). For example, you may want to define a Find & Select criteria set that includes properties (e.g. 

Fire Rating) which may not yet exist in your project;

– Find only the IFC data of a chosen IFC Type; and/or

– Search for IFC data by typing any text string in the “Filter” list field.
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3. Select the IFC data item to use as element criteria. Click Add.

– Multiselection is available

– If you select a Property Set in the list, then all of the Properties it contains are added to the criteria.

– If you select an Attributes folder or a Classification References folder, then all items contained in the 

folder are added to the criteria

4. Define operators and values for the criteria according to their type (label, integer, boolean etc.)

Note: In Find & Select: Get values for IFC data criteria from the model by applying the Pick Up Settings 

and Copy Settings tools to the owner element of the same IFC data type.)
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Using IFC Properties in IES Schemes

• If you select a Property Set from the list, then all of the Properties it contains are added as fields.

• If you choose “IFC Assignment” as the parameter for Schedule Field, then the table will list (in non-

editable form) all those IFC Assignments (their named branch) to which the element belongs. If an 

element has multiple Assignments, all of them will be listed, separated by a “;”.

• If you list an element’s “IFC Type Product” data, then the Schedule table will generate two columns: The 

“IFC Type Product - Type” (e.g. ‘IfcWallType’) and “IFC Type Product - Name”) (the Name Attribute of the 

IFC Type Product).

Use IFC Data Types as Element Criteria

From the criteria or field selection interface (e.g. the Find & Select dialog):

1. Click the Add button.

2. From the appearing Properties list, choose an IFC Data Type:

– ARCHICAD IFC ID (the Globalid IFC attribute automatically assigned by ARCHICAD to each element)

– External IFC ID (the Globalid IFC attribute assigned to each element upon IFC import)
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– IFC Assignment, e.g. IFC Group. 

– IFC Type (see below)

– IFC Type Product, e.g. IfcColumnType. 

3. For IFC Type: the list is divided between all types available in the project (above the line) and all types that 

can be displayed and modeled in ARCHICAD (below the line). 

The IFC Type list includes all so-called “parent” element type (these are collector entities that are above the 

other elements in the IFC entity hierarchy) - for example, IfcBuildingElement.

The following are examples of Find & Select possibilities using IFC data as criteria:

1. Find all elements that are members of any Assignment.

2. Find all elements of a particular IFC System.
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3. Find all ARCHICAD Zones that have not yet been grouped into an IFC Zone.

Note: In Find and Select: the “Pick Up Settings” function does not work for IFC Assignment and IFC Type 

Product criteria.
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IFC Translators: Overview

Importing and exporting model data using IFC takes place according to the settings of the IFC Translator you 

are using. An IFC Translator defines the rules for which elements should be converted and how they should 

be interpreted - whether in ARCHICAD or in the external application reading the IFC file.

Basic Workflow for Using IFC Translators

Important Note on Translators and Template Files

IFC Translators Dialog Box - Overview

Preview Translator

Managing Translators

Basic Workflow for Using IFC Translators

ARCHICAD provides predefined, factory-default IFC Translators whose settings are optimized for the 

particular import/export purpose.

Most ARCHICAD users doing IFC export and import do not have to adjust any Translator settings. All you 

have to do is select a predefined translator from the Open dialog box (when importing a model in IFC format), 

or from the Save As/Merge to IFC dialog box (when exporting an ARCHICAD model to IFC format).

See Export IFC Model from ARCHICAD and Import IFC Model to ARCHICAD.

Important Note on Translators and Template Files

• When you import an IFC project using Open or Hotlink IFC: You will choose an IFC Translator for Import 

from an external Template file, selected by you.

• When you import an IFC project using the Merge command: You will choose an IFC Translator for Import 

from the current host project.
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IFC Translators Dialog Box - Overview

The IFC Translators dialog box (File > Interoperability > IFC > IFC Translators) allows you to view or 

modify Translator settings, or to create new Translators.

Translators are listed by name on the left side. The Translator name tells you what it is for: e.g. “Import from 

Modeling Applications” or “Export to Tekla Structures.”

They are divided into Translators for Import and Translators for Export. The two groups of translators are 

not interchangeable, since they contain different settings. 

• As needed, use the Search and Filter buttons at the top of the Translator list to locate a Translator.

– The Filter button enables you to limit the list by IFC Schema: IFC2x3, or IFC4

See IFC Schema (Translators for Export only) for more information.

For complete details on all Translator settings, see the following sections:

Translators for Import (Detailed Settings)

Translators for Export (Detailed Settings)
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Preview Translator

One of the Translators for Export is the Preview Translator, marked with the blue ARCHICAD icon:

The Preview Translator also provides default mapping definitions needed to work with IFC data in 

ARCHICAD. These essential mapping definitions are found in two presets of the Preview Translator:

• Type Mapping for Export preset

The Type Mapping preset of the Preview Translator assigns an IFC Type to each exported ARCHICAD 

element. The IFC Type, in turn, affects which IFC properties are available to the element. 

See also Type Mapping for IFC Export.

• Property Mapping for Export preset (formerly IFC Scheme Settings)

Based on IFC Type, the Property Mapping preset of the Preview Translator provides the set of IFC 

Properties used for IFC data-related functions in ARCHICAD. For example, you can find/select/list IFC 

Properties in the following parts of the ARCHICAD interface:

– criteria in Find & Select

– criteria in Interactive Schedules

– Labels (e.g. Classification and Properties Label, ID and Properties Label)

– IFC Project Manager

– Element Settings (Classification and Properties panel)

All these interfaces use the Property Mapping that is set in the Preview Translator.

See also Property Mapping for IFC Export.
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Use the Preview Translator:

• to export the model using the Properties visible in the current ARCHICAD model

• to see the IFC Properties in ARCHICAD as they are used in a particular IFC standard. For example, to 

work with the IFC Properties as defined by the COBie 2 Export standard for the US, go to the IFC 

Translators dialog box and switch the Preview Translator to “COBie 2 Export (US)”.

Note: The Property Mapping preset contains Translator-specific settings. In ARCHICAD versions prior to 

21, these settings were project-specific, and managed in IFC Scheme Setup. 

For information on migrating legacy IFC Schemes, see the Migration Guide.

Set a Different Translator as the Preview Translator

1. Go to IFC Translators. (File > Interoperability > IFC)

2. Select a Translator for Export from the list.

3. Click Set Preview at the bottom of the dialog box.

Set Preview Translator
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4. The selected Translator is now the Preview Translator, marked with the blue ARCHICAD icon:

Newly Defined Preview Translator

Managing Translators 

Create New/Duplicate Translator

Do one of the following:

• Click the New button at bottom left, or

• Click the Plus button at the right of the Translators group (Import or Export).

Delete Translator

Select a Translator, then click the Delete button at bottom left.

• Multi-selection is not available.
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• At least one Translator for Import and one Translator for Export must remain - you cannot delete the last 

one of either group.

Note: If you delete the Preview Translator, you are prompted to select a different Translator for Export to 

serve as the Preview Translator. (See also Preview Translator, below.)

Cancel Changes in IFC Translators

In the IFC Translators dialog box, clicking Cancel will discard all changes you have made not only to the main 

dialog box, but also in the sub-dialogs (the specific Conversion Preset settings dialogs.)

Import Translators From ARCHICAD Project

To import Translators from another ARCHICAD project:

1. Click the import button at bottom left.

 

2. Browse for the desired file type: PLN, PLA, TPL, or XML (translator files from previous ARCHICAD 

versions).

Notes: 

– Up to version 20, ARCHICAD saved IFC Translator files in XML format, in the Defaults/IFC 

Translators sub-folder of the ARCHICAD folder to which you installed the program. 

– You can select any file of XML format here, but if you select an XML that is not an IFC Translator (for 

example, a Work Environment file), then you get a warning, and the import will not work.
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3. Click Open. In the appearing dialog, select one or more IFC Translators to import from the selected 

project.

 

4. Click Import. In case your project already contains Translators of the same name as the imported ones, 

you are prompted to choose how to manage these (Replace, Import with new file name, or skip.)

Importing Mapping Definitions

Certain IFC Translator Mapping definitions (Type Mapping for Import/Export, and Property Mapping) are also 

imported to your project if you use the Import BIM Content or Download BIM Content commands.

See Import BIM Content.

Watch the Video

Watch the Video
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Translators for Import (Detailed Settings)

An IFC Translator for Import defines the rules for handling model elements when importing an IFC-based file 

to ARCHICAD.

For an overview of this topic, see Overview of IFC Import: Defining how IFC Data are Converted to 

ARCHICAD.

The IFC Translators dialog box (File > Interoperability > IFC > IFC Translators) allows you to view or 

modify Translator settings, or to create new Translators.

Select a Translator for Import from the list. 

The selected Translator’s settings, divided into six Conversion Presets, are shown on the right side.
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Working with Conversion Presets

For any category of Conversion Preset, click the dropdown list to view or select a different Preset. The Preset 

name gives you an idea of how it will affect the imported IFC model, if this Preset is used in a given IFC 

Translator for Import.

Choose a different preset from this list if needed.

To adjust settings or create a new preset, select Edit/Create New Preset, or click the three buttons at the 

right of the Preset.
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The Preset dialog opens (for example, the Geometry Conversion for IFC Import).

For each of the IFC Import Preset dialogs, view the following:

• Available Presets for this Conversion process (e.g. Geometry Conversion)

• Settings (this is where the import is defined in the greatest detail, for various data types, as defined for 

the currently selected preset at the top)

• Related Translators (all the currently defined IFC Translators for Import which use this Preset)

All Settings of each type of Conversion Preset (used by IFC Translators for Import) are detailed in the 

following sections.

Model Filter for IFC Import

Type Mapping for IFC Import

Property Mapping for IFC Import

Geometry Conversion for IFC Import

Layer Conversion for IFC Import

Material and Surface Conversion

Replace missing Renovation Status
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Model Filter for IFC Import

File > Interoperability > IFC > IFC Translators

Choose a Translator for Import and open the Model Filter preset.

Show Model Filter on import

If this option is active, then - after you issue an Open or Merge IFC command - the Model Filter window will 

open.

This gives you the chance to overwrite, for the purposes of the current import process, the elements to be 

imported.

See Filter Model at Import (Secondary Filter).

Select 3D Elements to Import

• By Structural Function

Use this as an additional (element-level) filter for import purposes, which takes into account the elements’ 

“LoadBearing” IFC Property at import.

– “Load-Bearing elements only” means that only those elements whose IFC Property “LoadBearing 

Element” has a “True” value will be imported from the IFC file to ARCHICAD. 

Notes: 

– If no Structural Function classification has taken place in the ARCHICAD project, or if you have not 

finished the classifying process in ARCHICAD, then you should choose “All Elements” here: either of 

the other two settings (“Load-Bearing elements only” or “Non-Load-Bearing elements only”) can result 

an empty IFC file, or one that is missing elements you might need.

– IfcPile and IfcFooting entities are load-bearing structural elements by definition, although they have no 

“LoadBearing” property in the IFC2x3 Schema. They are always handled as load-bearing elements at 

import.

• By IFC Domain

Use the IFC Domain to filter according to the following criteria for IFC import:

– “All” includes all elements from the model

– “Structural” includes only the structural building elements (IfcBuildingElement)

– “MEP” includes only the mechanical elements (IfcDistributionElement)
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See the exact composition of each Domain filter in the tree list below. Modifying this filter will create a 

“Custom” filter.

Select 2D Elements to Import

• IFC Grid: During import, all IfcGrid elements of the IFC file will be imported and converted into grouped 

ARCHICAD Grid Elements.

• IFC Annotations: Check this to import all IfcAnnotation-type elements (including exploded dimension 

elements) of the IFC file into ARCHICAD. They will be converted into 2D elements (texts and lines).

• IFC Door/Window Footprints: During import, all generated doors and windows will be displayed in floor 

plan views with correct opening direction and sizes, based on their imported 2D symbols
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Type Mapping for IFC Import

File > Interoperability > IFC > IFC Translators

Choose a Translator for Import and open the Type Mapping preset.

From this preset dialog, click Map IFC Types for Import to access the mapping definitions.

Use this chart to define how to classify IFC elements imported to ARCHICAD, based on their IFC Type.
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At the top (“Target Classification System”), choose a Classification system in ARCHICAD whose definitions 

you want to use.

The IFC Type (far left column) is mapped to the Classification (far right column) as defined here. You can 

further narrow the mapping according to Predefined Types (if any) and User Defined Types.

“Any” means that the mapping does not take the Type definition into consideration when assigning the 

classification in ARCHICAD, even if the imported element has such a definition.

Watch the Video
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Property Mapping for IFC Import

File > Interoperability > IFC > IFC Translators

Choose a Translator for Import and open the Property Mapping preset.

Use this Conversion Preset to define how to handle the properties of IFC elements imported to ARCHICAD.

Topics in this Section

Choose Import Method

Using the Mapping Table

Assigning Property Values in ARCHICAD (Based on IFC Property Mapping)

Importing IFC Data to ARCHICAD Categories

Replace missing Renovation Status
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Choose Import Method

Choose either IFC Properties or ARCHICAD Properties:

Import as IFC Properties

• This is the default option: ARCHICAD imports all properties of the imported IFC elements. 

• These data will now be available as IFC Properties in various parts of the ARCHICAD interface, such as 

Find & Select and Scheme Settings of element lists. (This is how IFC properties were imported in earlier 

AC versions.) 

• If you choose this, you do not have to use Property Mapping.
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Import as ARCHICAD Properties

This option can be useful if you wish to make certain IFC property data available for ARCHICAD functions 

which use ARCHICAD Properties (but not IFC Properties). These functions include:

• Graphic Overrides

• Expression-defined Properties

• Collision Detection

• Autotext Labels

This option activates the mapping table. Use the table to define which IFC property values to import to which 

existing ARCHICAD Property.

• Each IFC Property in the list (defined using the first four columns from the left) is mapped to an 

ARCHICAD Property of the current project (far right column).

• No new ARCHICAD Properties are generated in the current project.

• IFC properties not listed in this mapping table are ignored during import.

Remember: 

– The set of ARCHICAD Properties available to any element in ARCHICAD depends on the element’s 

Classification.

– Each ARCHICAD Property has a default value (assigned in Property Manager).

– For elements imported from IFC, this mapping table lets you change their ARCHICAD Property value 

from default to a custom value, based on the applicable IFC data if available.
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Using the Mapping Table

• Each row represents a mapping rule. You can sort the rows by clicking the column headers.

• Click on any rule, then use the list item controls to set data types or to enter custom text.

– In each rule, use the four IFC data columns - Property, Property Set, Value Type, and Property Type - 

to narrow the set of IFC data to be considered. (These are all IFC standard definitions.)

• To populate the table with the IFC properties of an existing file, click Merge from IFC and browse for an 

IFC file. The file’s IFC properties and their data will be appended to the list as mapping rules.

• Use the New, Duplicate and Delete buttons to create and delete mapping rules.

For details and examples, see Assigning Property Values in ARCHICAD (Based on IFC Property Mapping)

Importing IFC Data to ARCHICAD Categories

The following ARCHICAD Categories always use the corresponding data from imported elements. (These are 

Categories, rather than ARCHICAD Properties.) This data is filled in automatically, without reference to IFC 

Translator settings.

• Renovation Status
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• Structural Function

• Position

However, it is also possible to map these IFC values manually, in the mapping table, to any ARCHICAD 

Property.

Replace missing Renovation Status

Choose a Renovation Status in ARCHICAD (New, Existing or Demolished) for imported elements that do not 

have an assigned renovation status in IFC.

Notes:

– Nearly every model exchange scenario will lack automatic mapping of renovation status. The reason 

is that the IFC2x3 standard has no standard format for renovation status, and so the various 

applications will export this data only as custom IFC properties.
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– In model exchange with Revit, the ARCHICAD “Renovation Status” item is mapped to Revit’s 

“Phasing” item, provided that the IFC export and import on the Revit side is carried out using the  IFC 

Model Exchange with Archicad Add-In.
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Assigning Property Values in ARCHICAD (Based on IFC Property Mapping)

For general information on setting up the Property Mapping preset: see Property Mapping for IFC Import.

For each imported element, ARCHICAD attempts to execute the applicable mapping rules.

A mapping rule is applicable if the ARCHICAD Property is available to the element (based on its 

Classification).

The value of the mapped IFC property is assigned to the element’s corresponding ARCHICAD Property. (It is 

a custom value.)

Example: Mapping Rule Applied

We have set up a mapping rule in the Property Mapping for Import preset of the current IFC Translator. 

According to this rule, the IFC property called Example_A is mapped to the ARCHICAD Property called 

Product Info A.

A Column, with an IFC data called “Example_A”, is imported from an IFC file.

Element’s Data in Source IFC File (as seen in Model Viewer)
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The mapping rule is successfully applied: the Column element generated during import has a property called 

Product Info A, which is assigned a custom value (in ARCHICAD Element Settings, the Property value is 

displayed with the unlinked icon - it is no longer linked to its default value, set in Property Manager.)

Target ARCHICAD Property with Custom Value, after Element Import from IFC

Example: Non-Existent IFC Data

If a mapping rule refers to IFC property data that do not exist for the incoming element, then the element’s 

ARCHICAD Property value becomes Undefined.

Two mapping rules are shown. One of them refers to an IFC data (Example_C) that does not exist for the 

element being imported. 
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Element’s Data in Source IFC File (as seen in Model Viewer)

As a result, this mapping rule will assign the custom value of <Undefined> to the target ARCHICAD Property.

Target ARCHICAD Property with Custom <Undefined> value, after Element Import from IFC

Incompatible Data Types

• If the mapped IFC element has a value, but it cannot be interpreted by the corresponding ARCHICAD 

Property (e.g. incompatible data types): no custom Property value is assigned. The element uses the 

ARCHICAD Property’s default value.

Note on Data Types:
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– IFC and ARCHICAD use different data type definitions: See Data Types for Properties in IFC and 

ARCHICAD. When you map an IFC Property to an ARCHICAD property, their data types do not 

necessarily have to coincide. ARCHICAD attempts to convert the data. 

– If data conversion is not possible, the Session Report provides details on which elements’ IFC data 

could not be converted.

Example

Two mapping rules are shown. One of these maps the “Example_A” IFC data (a string-type IfcLabel) to the 

Thermal Transmittance ARCHICAD Property, which is a String-type value. The mapping rule is successfully 

applied: the element generated during import shows a String-type custom value for the ARCHICAD Property 

of Thermal Transmittance.

The second mapping rule maps the “Example_A” IFC data to the Combustible ARCHICAD Property, which is 

a True/False type value. The data types do not match, so the mapping rule gets a Warning icon. 

Mapping Rule to “Combustible” Property Referencing Incompatible Data Type

The targeted ARCHICAD Property does not get any custom value: it remains linked to its default value.

Property Mapping with Incompatible Data Types: No Change to ARCHICAD Property Value 

• If no mapping rule applies to an element’s given Property, then no custom Property value is assigned. The 

element uses the ARCHICAD Property’s default value.
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Conflicting Mapping Rules

The mapping table may include several IFC Properties mapped to the same single ARCHICAD Property. In 

this case, ARCHICAD will use the most specific rule. (The order in which the rules appear in the mapping 

table does not matter.)

In case of two or more equally specific mapping rules: the rules are ignored, and no mapping takes place. 

A rule becomes more specific as its IFC data properties are more narrowly defined. (For example, IFC 

PropertySet data set to “Any” is less specific than if it is a defined IFC PropertySet.) Within a mapping rule, 

each field to the right further narrows its definition.

Here, two IFC data (Example_A and Example_C) are mapped to the same ARCHICAD Property. In this case, 

the more specific rule is automatically applied. Example_C is more specific, since it is narrowed down at the 

level of IFC PropertySet.

In the next example:

Several Thickness-related IFC Properties are mapped to a single Thickness Property in ARCHICAD. If an 

imported IFC element comes with multiple Thickness properties, then ARCHICAD has no way of determining 

which Property value to use in ARCHICAD. Thus, the rules are ignored for this imported element, and its 

ARCHICAD Property value remains the default one.
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Geometry Conversion for IFC Import

File > Interoperability > IFC > IFC Translators

Choose a Translator for Import and open the Geometry Conversion preset.

Use this dialog box to define how to convert the geometry of IFC elements imported to ARCHICAD.

Building Elements

Convert to:

• Construction elements, otherwise Objects

• Construction elements, otherwise Morphs

With either of these options, IFC elements whose supertype is IfcBuilding (IfcWall, IfcColumn, IfcBeam, 

etc.) are imported as editable ARCHICAD elements (“Construction elements”: Wall, Column, Beam, etc.)

The advantage of converting the imported elements to AC tool-based construction elements is that they 

remain parametric, and ARCHICAD functions (such as automatic intersections) will apply to them. 

Even if you choose the “Construction element” option, some elements cannot be imported in this form: 

such as non-extruded (BREP geometry) elements, or elements having no counterpart in ARCHICAD).

For such elements, you can choose to convert them as either an editable Morph or an Object (“otherwise 

Objects/otherwise Morphs”). 

• Morphs

• Objects
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– Conversion of elements to Morphs or Objects guarantees perfect geometry import. 

– The resulting Morphs will be editable. 

– The resulting Objects will be Library Parts, whose subtype will match the IFC entity type: for example, 

an IfcColumn converted to an ARCHICAD Object will have the subtype “Column”.

Distribution elements

This option applies to imported elements whose domain is MEP (IfcDistributionElement).

These elements can be converted to one of three results:

• Morphs

• Objects

– Conversion of elements to Morphs or Objects guarantees perfect geometry import. 

– The resulting Morphs will be editable. 

– The resulting Objects will be Library Parts, whose subtype will match the IFC entity type: for example, 

an IfcColumn converted to an ARCHICAD Object will have the subtype “Column”.

• MEP Elements: this option generates parametric MEP elements from the project’s MEP elements. Even if 

you choose this option, the MEP IFC model might not contain sufficient data to generate the parameters, 

in which case non-parametric MEP Equipment elements will be generated, or - in case of limited data - 

Objects will be generated.

Other elements

This option defines how to convert elements that are neither building elements nor distribution elements (such 

as furnishing and transportation elements).

• Morphs

• Objects

– Conversion of elements to Morphs or Objects guarantees perfect geometry import. 

– The resulting Morphs will be editable. 

– The resulting Objects will be Library Parts, whose subtype will match the IFC entity type: for example, 

an IfcColumn converted to an ARCHICAD Object will have the subtype “Column”.

IFC Site geometry

Check this box if you want to include the geometry of the imported IfcSite. 

Define whether the converted element should be an editable Morph or an Object. (IfcSite geometry cannot be 

converted to an ARCHICAD Mesh.)

Define how to position the imported IFC model

Match ARCHICAD Project Origin with:

• IFC Site Location (Recommended)

• IFC Global Origin

Import Unnamed IFC Profiles

Choose how to handle unnamed IFC profiles imported to ARCHICAD: 

• Custom Profiles (this option does not create any new attributes in the ARCHICAD project)
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• Profile Attributes (new Profile attributes are added to the ARCHICAD project)

Notes on Geometry Conversion

• To optimize the management of shared geometry, ARCHICAD creates as few geometric elements (when 

generating Morphs) or as few Library Parts (when generating Objects) as possible.

• Objects can be placed in the project’s Embedded Library, or else saved to a given linked library (see IFC 

Local Preferences).

• Some IFC models may contain elements with special geometry which cannot be converted to Morphs, 

even if you choose the Morph conversion option. In this case, ARCHICAD will generate Objects, to 

achieve perfect geometry import.

• Imported IfcSpace elements will always be generated as ARCHICAD Zones, which will always retain the 

imported elements’ original geometry.
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Layer Conversion for IFC Import

File > Interoperability > IFC > IFC Translators

Choose a Translator for Import and open the Layer Conversion preset.

Use this dialog to define the method for placing the imported elements onto ARCHICAD layers. You can 

choose between three different methods:

Place all elements on a single new Layer

Imported elements will be placed onto a newly created, single layer that you define (such as the “IFC Import” 

layer). (Enter the desired text in the input field.) Original layer names of the IFC model will be lost.

Create new Layers to keep original Layer structure

ARCHICAD will create layers using the original layer names (e.g. IfcPresentationLayerAssignment) of the IFC 

model, and will place the imported elements onto these layers.
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• Extend original Layer names with suffix: Check this to add a custom extension (such as “IFC Model”) 

to each Layer name. (Enter the desired text in the input field). The advantage is that you will be able to 

sort the layers by extension in ARCHICAD’s Layer Settings dialog box.

Use existing ARCHICAD Layers

From the Default Layer popup, choose an existing layer from the ARCHICAD project on which to place 

imported elements.
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Override default Layer with mapping

Check this box to map individual layers manually, instead of using the default Layer assigned from the pop-up.

Click Merge from IFC to browse for the IFC model and append its IFC Layer names to the list in the Mapping 

dialog.

Alternatively, click New to add an IFC Layer name manually. 

Assign Layer to SEO Operators Used to Generate Openings

Some imported openings can be created in ARCHICAD only by using Solid Element Operations. In such 

cases, ARCHICAD uses operator elements to generate the openings automatically via SEO. 
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At IFC import, you can define the layer settings of these SEO operator elements:

• Create new dedicated Layer

• Use existing ARCHICAD Layer

Note: If you move any of the target elements, make sure that the operator elements’ layer is shown, and 

move the target and operator elements together: do this to avoid modifying the original geometry of the 

imported elements.

Notes on Layer Conversion:

• The import process automatically sets an intersection group number for all imported layers, and this 

number will be different from the current project layers' intersection group number. This difference ensures 

that the elements on the imported layers will not intersect with the existing project elements.

• If the elements have been converted to their counterpart ARCHICAD tool-based construction elements 

(that is, they have not been converted to Objects or Morphs; see Geometry Conversion for IFC Import 

above), then elements on identical layers might have their geometries modified due to automatic 

intersections. If you want to avoid this, set the intersection group number to 0.

• If layers of the same name already exist in ARCHICAD, no new layers are created; the imported elements 

are placed onto the corresponding, existing ARCHICAD layers.
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Material and Surface Conversion

File > Interoperability > IFC > IFC Translators

Choose a Translator for Import and open the Material and Surface Conversion preset.

Use this dialog to choose how to assign ARCHICAD Building Materials to imported IFC model elements.

There are two import methods:

Method 1: Replace IFC Materials with existing ARCHICAD Building Materials

With this method, a single ARCHICAD Building Material is assigned to all imported IFC elements. Choose this 

default Building Material from the pop-up below. No new Building Materials are generated.

If needed, you can override this default definition by using Material Mapping: see Override default Material 

with mapping, below.

Method 2: Create ARCHICAD Attributes from IFC Materials

For each IFC Material, a new ARCHICAD Building Material will be created: the default Building material 

chosen below will be duplicated.

The new Building material:

• is named using the IFC Material’s Name parameter
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• is assigned a color corresponding to the IFC Material Color parameter

Override default Material with mapping

Check this box to map individual materials manually, instead of using the default Building Material assigned 

from the pop-up.

Click Merge from IFC to browse for the IFC model and append its IFC Material names to the list in the 

Mapping dialog.

Alternatively, click New to add an IFC Material name manually. 

Note:

– Some of the default IFC Translators for Import include predefined mapping rules, whose settings you 

are free to expand or edit. It is recommended to duplicate the default translator before modifying it.

– You cannot import or export these mapping tables as separate files (e.g. xml); you must import/export 

them together with entire translator file itself.

Override Material colors with IFC element geometry surfaces

IFC elements in IFC models can have two colors: a material color and an additional color for the surface 

geometry color.

If you check this Override Material colors box, ARCHICAD will create Surface attributes using the color 

assigned to the IFC element’s surface geometry. 
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To check and modify the resulting surface overrides in ARCHICAD, view the Model panel of the respective 

Element Settings dialog box.
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Translators for Export (Detailed Settings)

An IFC Translator for Export defines the rules for handling model elements exported from ARCHICAD to an 

IFC format.

For an overview of this topic, see IFC Translators: Overview.

The IFC Translators dialog box (File > Interoperability > IFC > IFC Translators) allows you to view or 

modify Translator settings, or to create new Translators.

Select a Translator for Export from the list.

The selected Translator’s settings, divided into six Conversion Presets, are shown on the right side.

One of the Translators for Export is the Preview Translator. The Preview Translator exists to provide default 

mapping definitions needed to work with IFC data in ARCHICAD.

For details, see Preview Translator.

The IFC Schema and Model View Definition categories help in setting up presets that are compatible with 

particular standards (see details below).

IFC Schema (Translators for Export only)

An IFC Schema is a particular version of the IFC standard. ARCHICAD Translators can support either 

Schema IFC2x3 (recommended) or IFC4.
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Note: IFC2x3 is recommended - this is the most widely used version. Choose IFC4 only if you are certain 

that it is supported by the application that will receive IFC data using this Translator.

Model View Definition (Translators for Export only)

A Model View Definition (MVD) is a recommendation for which data and elements the IFC model should 

include, depending on the purpose of the model exchange. If your exported IFC model must conform to a 

predefined standard MVD, choose that MVD from the list.

Note: Available MVD’s depend upon the IFC Schema chosen above: IFC2x3 or IFC4.

For a more detailed explanation of MVD’s and their characteristics, see Model View Definitions.

Once you choose an MVD, then certain Translator for Export settings must conform to the requirements of 

that MVD. If you change a Translator setting so that it no longer conforms to the selected MVD’s 

requirements, then the Translator becomes invalid, and you get a warning in the dialog box. The problematic 

setting is also marked:

Working with Conversion Presets

For any category of Conversion Preset, click the dropdown list to view or select a different Preset. The Preset 

name gives you an idea of how it will affect the exported IFC model, if this Preset is used in a given IFC 

Translator for Export.

Choose a different preset from this list if needed.
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To adjust settings or create a new preset, select Edit/Create New Preset, or click the three buttons at the 

right of the Preset.

The Preset dialog opens (for example, the Geometry Conversion for IFC Export).

For each of the IFC Export Preset dialogs, view the following:

• Available Presets for this Conversion process (e.g. Geometry Conversion)

• Settings (this is where the export is defined in the greatest detail, for various data types, as defined for 

the currently selected preset at the top)

• Compatibility: Feedback on whether the current settings of this preset conform to particular Model View 

Definitions.

Click the Info button to see the settings conflicts, if any. (If the current Translator for Export does not use 

that particular MVD, then this conflict need not be a problem.) To ensure compatibility with the MVD, you 
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can adjust the settings as shown in the Info dialog, or just click the Override Settings button to solve the 

issue.

• Related Translators (all the currently defined IFC Translators for Export which use this Preset)

All Settings of each type of Conversion Preset (used by IFC Translators for Export) are detailed in the 

following sections.

Model Filter for IFC Export

Type Mapping for IFC Export

Geometry Conversion for IFC Export

Property Mapping for IFC Export

Data Conversion for IFC Export

Unit Conversion for IFC Export
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Model Filter for IFC Export

File > Interoperability > IFC > IFC Translators

Choose a Translator for Export and open the Model Filter preset.

Select 3D Elements to Export

This filter defines which ARCHICAD 3D elements should be exported to IFC. You can filter by the elements’ 

Structural Function and/or by their IFC Domain.

• By Structural Function

This is an additional filter to the IFC Domain filter set below.

- This filter considers the ARCHICAD element’s “Structural Function” category: Either Load-Bearing 

or Non-Load Bearing. This is set for each element in its Classification and Properties panel of 

Element Settings. 

-  “Load-Bearing elements only” means that only those elements classified as “Load-Bearing 

Element” (plus ARCHICAD Zones) will be exported from ARCHICAD to IFC.

• By IFC Domain

Note: An element’s IFC Domain depends on its Type Mapping preset.

– “All” includes all elements from the model
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– “Structural” includes only the structural building elements

– “MEP” includes only the mechanical elements (IfcDistributionElement). 

See the exact composition of each Domain filter in the tree list below. Modifying this filter will create a 

“Custom” filter.

Select 2D Elements to Export

• Grid System and Elements: Check this to include the Grid Elements and the grid members of Grid 

Systems in the exported file.

Grid elements will show up in the IFC structure as IfcGrid.

• Lines, Texts, Labels, Fills: Check this to export these 2D elements, plus all dimension types.

– 2D elements will show up in the IFC structure as IfcAnnotation.

– Dimensions will be exploded into lines and texts, since the IFC2x3 standard documentation does not 

include a dimension element.

– The inclusion of 2D elements in the exported file is also affected by the “Elements to Export” filter at 

“IFC Save Options”: if a 3D view is currently active, the 2D elements can be included only if the “Entire 

project” option is selected in that filter. (See Filter Model at Export.)

– IFC4 Reference View does not allow annotations. To ensure compatibility for IFC4 Reference View, 

leave this box unchecked.
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• Door/Window 2D Views: Check this box to include the 2D symbols of doors and windows in the export 

process, in addition to 3D model geometry. This is handy if the recipient program recognizes these data 

and can correctly display, for example, the door opening directions.
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Type Mapping for IFC Export

File > Interoperability > IFC > IFC Translators

Choose a Translator for Export and open the Type Mapping preset.

From this preset dialog, click the Map IFC Types for Export to access the mapping definitions.

Topics in this Section

About Type Mapping for Export

Mapping by Element Type

Mapping by Classification

Watch the Video

About Type Mapping for Export

When a model is exported to IFC format, every one of its elements is assigned an IFC Type. 

This dialog defines how to assigns an IFC Type to each exported ARCHICAD element.

There are two ways to take care of Type Mapping for IFC Export:

• By Element Type

• By Classification

Each is described below.
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Mapping by Element Type

Assigns each ARCHICAD Element Type automatically to a default, basic IFC Type, corresponding to its 

ARCHICAD tool or (for GDL objects) to its Object Subtype.

If you choose this method, no further manual mapping is needed. The rest of the dialog controls are inactive.

For more details, see Built-in IFC Type Mapping for ARCHICAD.
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Mapping by Classification

Maps each ARCHICAD Classification to an IFC Type, Type Product, and/or Predefined Type. This method 

allows for flexible and detailed IFC Type classification, according to specific IFC standards.

To use this method:

1. Select Mapping by Classification.

2. Choose a Classification System (among those available in the ARCHICAD project). The Classifications 

of the selected System are now listed on the left side of the dialog. 

3. Set the Filter to display IFC Type definitions by the IFC4 Schema, the IFC2x3 Schema, or both. This is 

relevant for fixing erroneous mapping definitions (see How to Fix Error Warnings in the Type Mapping 

Dialog). By default, the filter automatically corresponding to the IFC Schema of the current preset.

Now you can map the Classifications on the left to the IFC Type definitions on the right, as detailed below (By 

Parent and Custom). 

Classification Mapping by Parent

For a selected Classification (e.g. Pilaster): “By Parent” maps it to the same IFC Type as its parent item (e.g. 

Pilaster gets the same IFC Type as Column, that is: “IfcColumn”). Classifications mapped “by Parent” are 

shown in blue: you don’t have to define its IFC Type, because it will automatically get the same one as its 

parent.
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Custom Classification Mapping

Maps the Classification to an IFC Type and IFC Type Product selected by you. This assigns more specific 

IFC Type definitions to the exported elements.

For example, here an element is classified in ARCHICAD as Thermometer, and it is mapped to the IFC Type 

and IFC Type Product assignments as shown: just click the popups to access a list of valid definitions.

Map to IFC Type and IFC Type Product

If the chosen IFC Type or IFC Type Product have Predefined Types, you can map those too. 
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Here, the Flow element’s Type Product is assigned the Predefined Type of PRESSUREGAUGE:

Choose a Predefined Type

User Defined Type

If the list of Predefined Types does not contain what you need, choose USERDEFINED and then enter the 

desired value in the text field below.
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Synchronize Predefined Type Values

In most cases, the Predefined Types for IFC Type and IFC Type Product should be identical. To speed things 

up, the Synchronize checkbox is on by default:

Invalid Predefined Types

If a Classification element is mapped with a Predefined Type that is not available in the current Schema (e.g. 

the MOLDING value is available in IFC4 but not IFC2x3), then this value will be grayed out, and will not be 

exported. (The Translator preset will still be valid.)
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Reset Mapping

Click this button to undo the mapping definitions made since opening the dialog.

Note: The Type Mapping preset of the Preview Translator has an additional function: to define the default 

IFC Type classification of elements in the current ARCHICAD project.

See also Preview Translator.

Related Topics

IFC Type

How to Fix Error Warnings in the Type Mapping Dialog

Watch the Video
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How to Fix Error Warnings in the Type Mapping Dialog

ARCHICAD includes two Presets for Type Mapping for IFC Export. Each Preset is optimized for a supported 

IFC Schema: IFC2x3 or IFC4. 

If you use the predefined Presets, as shown in the images below, the mapping will be correct.

If you customize the Type Mapping preset or change the Schema definition, this may result in mapping 

definitions that are obsolete or incorrect, because the IFC type definitions differ somewhat for IFC2x3 and 

IFC4. 

ARCHICAD’s IFC Translators dialog and the Type Mapping subdialog will alert you about any incompatible 

Type Mapping definitions, and help you fix them.

Type Mapping Preset for IFC2x3 Schema Type Mapping Preset for IFC4 Schema
ARCHICAD 24 Reference Guide 3045



Translators for Export (Detailed Settings) Working with IFC
Here, you have a custom Type Mapping Preset that is supposed to be compatible with the IFC4 Schema. But 

the Compatibility panel indicates a problem:

Click the three-dot button to open the Type Mapping Preset dialog. 

Here, too, the problem is indicated. 
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Click the Info button to find out more. Now the Compatibility Info dialog lists the problematic mapping items 

(here: Footing, Pile, and Ramp).

Click OK to return to the main dialog, then click to open Map IFC Types for Export dialog...
ARCHICAD 24 Reference Guide 3047



Translators for Export (Detailed Settings) Working with IFC
In the Map IFC Types for Export dialog, set the filter to “Show IFC Entities for IFC4 Schema,” as shown in 

the image below.

This will set up the dialog box so that you are forced to choose mapping definitions compatible with IFC4.

In the left-hand tree view, you can see the Classification items that have errors: they are marked with warning 

triangles. These items were probably mapped correctly for IFC2x3, but since naming standards have changed 

or been expanded, you have to re-map these items to use the corresponding new terms for IFC4. This will be 

easy.
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1. Select the problem Classification item (e.g. Footing).

Its mapping definitions are on the right. The IFC Type is okay, but the IFC Type Product is missing.
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2. Click the IFC Type Product pop-up to see compatible mapping choices. Select one and click Choose.

The mapping issue for the Footing item is solved.
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Repeat this re-mapping for each of the problem elements to ensure that your Type Mapping preset is 

compatible with IFC4.
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Geometry Conversion for IFC Export

File > Interoperability > IFC > IFC Translators

Choose a Translator for Export and open the Geometry Conversion preset.

These settings define how to convert the geometry of ARCHICAD elements exported to IFC.

The conversion settings are divided into categories:

Conversion of ARCHICAD Elements

Hierarchical ARCHICAD Elements

IFC Schema-Related Options

Composite Structures and Complex Profiles

Conversion of ARCHICAD Elements

Export only geometries which “Participate in Collision Detection”

Exports only elements whose ARCHICAD Building Material includes the “Participates in Collision Detection” 

option ON. (This is set at Options > Element Attributes > Building Materials > Properties).

Use this option to export composite elements and complex profiles, which don’t have solid geometries, as real 

air gaps. This way, MEP engineers (who receive the ARCHICAD IFC file) can place pipes in the gaps without 

collision detection; only element parts which have real geometry will participate in collision detection.
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See also Collision Detection.

Export Bounding Box

Exports the dimensions of the building elements’ bounding box.

Export Geometry of IFC Type Products

Assigns a representative geometry to each Type Product. (This option is required for Concept Design BIM 

2010.)

Each type (e.g. IfcFurnishingElementType) will use a representative geometry of the elements that belong to it 

(e.g. IfcFurnishingElement).

Export gross geometry of elements (Export holes separately)

Elements containing Doors, Windows and/or Openings are exported with their gross geometry. For example, 

a host Wall is exported with its gross geometry, without considering the hole created by a window.

Use this option to ensure accurate cost calculation using the IFC model, where the opening geometry will be 

considered separately. 

Note: Openings are exported by checking IfcOpeningElement in the Model Filter for IFC Export. This is 

generally checked by default.

If the Export gross geometry option is unchecked, then elements cannot be created using extrusion. In this 

case, extruded elements with holes are exported as BREP!

Use BREP geometry in current color for all elements

All model elements are exported using BREP (Boundary Representation) geometry. BREP is precise but non-

parametric geometry. 

The elements will be exported in the color displayed in the current ARCHICAD view, including colors defined 

by Graphic Overrides, Renovation Status, and Mark-Up Corrections or Highlights.

If you do not check this box, you still have the option to set BREP or other conversion options for the following 

four element categories:
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Elements in Solid Element Operations

• Extruded/revolved: This method can retain the elements’ parameter values (such as thickness, height, 

location of reference line or edge). The skin structure of composite materials cannot be fully preserved 

because of the IFC standard’s limitations. Certain specialized sections are not retained.

This is the format usually supported by static analysis programs, in which element parameters are 

important, but their special cut angles (such as the slanted edge of a slab) are not important.

• BREP: This method provides the most exact reproduction of element geometry, together with its 

specialized sections and connections. However, the element’s parameters are lost, and BREP (Boundary 

Representation) elements are transformed into non-editable elements. This method is useful in the 

“reference model” workflow.

Elements with junctions

• Extruded/Revolved without junctions: Elements are exported without the priority-based intersections, 

resulting in a faster export process. This option is recommended for structural analysis programs, for 

which the elements’ reference lines/surface information is sufficient, and detailed intersections are not 

required.

• BREP: Elements are exported together their junctions, for precise geometry.
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The difference in the two export methods is illustrated here:

Slabs with slanted edge(s)

• Extruded: Slabs will be exported with vertical edges (even though their original geometry included a 

slanted edge.)

• BREP: Slabs will be exported with precise geometry, recreating the slanted slab edges.

Note on Export of IFC Site Geometry:

As of ARCHICAD 23, all elements that are IFC Site Geometry are exported to IFC as solid bodies.

ARCHICAD elements are IFC Sites if they are:

• Classified using “IfcSite” as their IFC Type, or

• Saved as Objects having the Subtype “IFC Site”

Match IFC Site location with:

Define location of the IFC Site entity (its coordinate system), if a Survey Point has been defined in 

ARCHICAD. (See also Using Survey Point in ARCHICAD, below.)
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• ARCHICAD Project Origin: Locate the IFC Site entity at the Project Origin if you are working close to the 

ARCHICAD Project Origin, yet still wish to define model coordinates relative to a national datum (using 

the Survey Point). This way, a far offset is stored in the IFC file not as part of the element coordinates, but 

rather generally. See the following illustration:

• ARCHICAD Survey Point position: Locate the IFC Site entity at the position of the Survey Point. Use 

this if you are working at a long distance from the Project Origin, yet you don’t want large offsets to be 

present in the IFC file (usually with legacy models). See the following illustration:

Notes:

– If the ARCHICAD project does not contain a Survey Point, then the IFC model’s global coordinate 

system origin and the IFC Site Location will be the ARCHICAD Project Origin. 

– If the ARCHICAD project contains multiple Survey Points (though it is recommended to use just one), 

then the first placed Survey Point will be used. (A warning will alert you to this.)

– The program will consider the Survey Point even if it is not visible in the exported view (i.e. if it is on a 

hidden layer)!
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Using Survey Point in ARCHICAD

ARCHICAD has a Survey Point object, which can be used as common reference point to facilitate 

coordination of models from different programs. In some countries, use of a particular reference point is a 

standard requirement when defining the project.

The position and rotation of the Survey Point defines the global coordinate system (X=0, Y=0, Z=0) of the IFC 

model. When defining this point position in ARCHICAD, it is recommended to consider the True North 

direction (use the default “Follow Project North” parameter). At IFC export, this parameter defines the 

direction of the Y axis in the global coordinate system.

Notes:

– In ARCHICAD, True North is defined by Project North (Options > Project Preferences > Project 

Location)

– The Survey Point is always created at IFC Open. In case of Merge IFC, the model is imported to be 

aligned to the host file’s Survey Point.

– To assign geographic property data, use the Survey Point’s Referencing Map page, or via IFC import. 

These properties can be shared with any project participants via IFC.

- The Geodetic Datum and Map Projection fields must be filled out (data is required)

- Geo Referencing data are exported as Property data only. They do not affect the model’s actual 

location.

- Export via IFC 2x3: The data is exported as two new IFC Property Sets.

- Export via IFC4: New IFC entities are created: IFC Map Conversion, and IFC Projected CRS.

For more information on Survey Point in ARCHICAD, see the Help Center article at: http://

helpcenter.graphisoft.com/tips/open-bim/survey-point-is-now-supported-at-ifc-importexport/.
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Mapping IFC Location Data From ARCHICAD and Revit

Hierarchical ARCHICAD Elements

Choose a conversion option for each type of hierarchical element: Curtain Walls, Stairs, Railings.

• Convert to single element: The hierarchical element is exported as a single IFC entity, which contains 

within itself the geometry of all its sub-elements. The hierarchical nature of the original element (e.g. Stair, 

with all its separate sub-components) is thus lost.

• Keep hierarchy: Retain the original element’s hierarchical structure, including sub-elements.

See also Exporting Hierarchical Elements from ARCHICAD as IFC Containers.

IFC Schema-Related Options

Material preservation mode (IFC2x3 only)

Use this control to define whether and how to explode complex elements into Building Element Parts. This 

choice depends on whether you need to retain the material definitions of the components.

Choose one of the following Material preservation modes:

• Never explode elements. Material preservation is not guaranteed. 

This is the default option: complex elements (composites and Profiles) are not exploded, because doing 

so multiplies the number of Building Element parts in IFC.

• Explode only when necessary to preserve materials. The program will explode an element only if that 

is the only way to preserve its material definition.

• Explode all elements into parts, preserve materials. All complex elements are exploded into parts, and 

material preservation is guaranteed.

Notes:

– These Material preservation options are relevant for IFC2x3 only.

– For IFC4, use the control below: see Split Complex Building Elements into parts.

Composite Structures and Complex Profiles

Split Complex Building Elements into parts

Use this control to split complex elements into Building Element Parts. This option enables you to comply with 

IFC4 Reference View. Material definitions are not affected by this option (IFC4 retains material definitions 

irrespective of whether complex elements are split.)

This option enables composite elements and Complex Profiles to be split into so-called “Building Element 

Parts”. With this option, the receiving Structural Engineer will know that a composite Wall includes an air gap 

component.

If you check the box:

– the tree structure below is editable: you can choose specific element types to be split into parts. (The 

unchecked element types will not be split up.)

IFC ARCHICAD 20 and up Revit

IFC Global Origin Survey Point Survey Point

Position of IfcSite entity Project Origin Project Base Point
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If the box is not checked: no complex elements will be split.
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Property Mapping for IFC Export

File > Interoperability > IFC > IFC Translators

Choose a Translator for Export and open the Property Mapping preset.

From this preset dialog, click the Map IFC Properties for Export to access the mapping definitions.

These mappings define the IFC properties assigned to elements when exported from ARCHICAD.
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Tree list of IFC Entities

IFC Entities are listed in the tree at left. 

• Use the pop-ups if needed to filter the tree list:

– filter by Schema (IFC2x3 or IFC4)

- Note: A parent entity, if it can be used for property mapping, will be displayed even if it does not 

belong to the Schema in the current filter

– filter by domain (Structural or MEP). For example, the Structural domain contains the building element 

(IfcBuildingElement) types (IfcBeam, IfcColumn, etc.) while the MEP domain contains the 

IfcDistribution types. 

– filter by IFC Assignment types, IFC Type Objects, or IFC Spatial element types 

(IfcSpatialStructureElements: IfcSite, IfcBuilding, IfcBuildingStorey and IfcSpace).

Filter IFC Entities in Tree List 

Note: IFC Entities in parentheses are necessary to the IFC Schema, but have no ARCHICAD elements 

assigned to them directly.
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List of IFC Properties

The IFC Properties of each selected entity are listed in the IFC Properties column.

• Property data assigned to a parent element (such as IfcElement) are automatically assigned to all its child 

elements (e.g. IfcBeam, IfcColumn, IfcSlab, IfcWall, etc.)

• BOLD TYPE: IFC Entities which have property set data assigned to them are shown in BOLD.

• BLUE TYPE: Properties of a child element are shown in blue type. You can see its parent type name in 

parentheses. 

• Chain icon: Indicates that the property has a mapping rule. View its mapping rule at the right side of the 

dialog box.

• X: Delete any data item by clicking the red X. Attributes cannot be deleted. 
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• Property assignment can be modified only at the parent level. Thus, to create a common property for all 

building elements, you don’t have to create it for every single building element type (IfcWall, IfcColumn, 

IfcSlab, etc.): instead, create it once at a higher level (e.g. at IfcElement).
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A mapping rule can be assigned at different levels. For example, you can apply a rule at the IfcElement 

level, which will be applicable to all of its child elements (e.g. IfcBeam).

A property’s mapping rule can be redefined at the child level, too. 

Add New Property/Classification Reference

To add a new IFC Property or Classification Reference data to the currently selected entity, do one or both of 

the following:

• Click the New button to create a New Property or Classification.

The same function is available in the IFC Project Manager and Element Settings dialog boxes.

See Create New, Custom IFC Property.

Import from Current Project

Click this to add all the custom IFC Property Sets and Properties of the current project (defined in either IFC 

Project Manager or Element Settings) to the Property Mapping preset. 

Note: If a custom property assigned to an IFC element type (for example IfcWall) is not yet available in the 

current project, it is not displayed in the IFC management dialogs until one instance of the type has been 

defined in the model.

Clear All Settings

Delete the entire contents (mapping rules, Properties and Classification References) of the current Property 

Mapping Preset.

Related Topics

Predefined Property Mapping (Export ARCHICAD to IFC)

Preview Translator
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How to create a Mapping Rule

1. Select the IFC Property which you would like to map. Data in italic type cannot be mapped.

2. Click on the “New Rule” button. The “Empty Rule” field appears.

3. from the “Add Content” drop-down button, select a Rule Content type:

– Parameters & Properties (as the Interactive Element Schedule)

– Library Part Parameters (as the Interactive Element Schedule)

– Static Text

4. Add fields to the rules. Fields can have types: e.g. “Thickness” is length measure, “Area” is area measure, 

“Library Part Name” is string. If a rule contains more than one field, the fields are always a concatenation 

of fields converted to a string. Conversion is based on calculation units (Project Preferences > Calculation 

Units & Rules). Fields implicitly contain filters: for example, the Wall's “Height” field can only be evaluated 

for Wall elements. “General” fields are listed at tool levels too and are valid only for that specific tool.

5. Library Part Parameters can be set in two ways:

– Library Part dependent: The selected Library Part parameter will be in effect only for elements that 

contain this parameter. If the Library Part parameter was defined at the Object subtype level, then the 

parameter mapping will take place for the child elements, too. For example, if we are mapping the 

“gs_list_cost”variable parameter of the GS Door Object subtype, then the mapping will be in effect for 

all Doors (and ifcDoors) which are child Library Part elements of the GS Door (such as Door, Double 

Door, Metal Door, etc.) See examples below. 

– Library Part independent: the parameter variable (e.g. “gs_list_cost”) will be in effect for the 

mapping, regardless of which Library Part it was chosen from. For example, if you select the 

“gs_list_cost” parameter of the Double Door for mapping as a Library Part Independent parameter, 

then the mapping will take place for every Door that accesses the “gs_list_cost” parameter. If this door 
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parameter is used for mapping at the IfcElement level, then it will be mapping for all IFC entities which 

are child entities of the IfcElement and which include the “gs_list_cost” parameter (such as Furnishing 

elements, e.g. Armchair and Chair). See examples below.

Notes: 

– If the Property Mapping Preset contains a mapping rule involving a Library Part parameter which is not 

loaded in the project, then the rule, the mapped IFC data, and the mapped IFC Entity data are all 

shown in red.

– You can assign multiple rules to a single property. This is useful, for example, if several tools will 

generate the same IFC element type. Rules will be applied in the order in which they appear on the 

user interface: the first valid rule will be applied.

– String-type rules can be split. Separator type, separator position and split type give you several ways 

to split a string. For example, use a split to cut out a particular fragment of a Library Part Name. 
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Related Topic

Examples of Property Mapping Rules
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Examples of Property Mapping Rules

Example 1

Map the user-defined “Acoustic Rating” property (Options > Property Manager) to the “AcousticRating” 

property defined for the IfcWall.

Example 2

Map the “Fire Resistance Rating” parameter of windows to the “FireRating” property defined for the 

IfcWindow.
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Example 3

Define the “Name” Attribute of IfcWall elements using a combination of Wall “ID” and “Building Material/

Composite” Name.

Example 4: Mapping Rule by IFC Type Product

You can apply data mapping rules to the IFC data of IFC Type Product elements. 

For example, generate the names of Door types (Name Attribute of IfcDoorStyle) from the combination of the 

Library Part Name, the Width and Height parameters of a Door.

Define the “Name” Attribute for IfcDoorStyle by using a fragment of the Door “Library Part name” + static text 

“-” + “Width” + static text “X” + “Height”.
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This rule overwrites the default IfcDoorStyle creation rule (see IFC Type Product) with new IfcDoorStyle 

names (you can double-check the result in the IFC Project Manager).

Example 5

Define the “Cost” Property for IfcDoor as Library Part dependent parameter. 

For mapping, choose the “gs_list_cost” parameter of the “GS Door” Library Part. 
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To find this parameter, go to the Add Content drop-down button and choose Library Part parameters. From 

the appearing dialog box, search for the gs_list_cost parameter as shown:

The mapping rule is valid for the Library Parts which are child elements of the “GS Door” subtype (e.g “Door”, 

“Double Door”, “Metal Door”, etc.).
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Example 6

Define the “Cost” Property for IfcDoor as Library Part independent parameter. For mapping, choose the 

“gs_list_cost” parameter of the “Double Door”.

To find this parameter, go to the Add Content drop-down button and choose Library Part parameters. From 

the appearing dialog box, first select the Double Door library part, then search for the gs_list_cost parameter 

as shown. However, make sure to add it as a Library Part Independent parameter:
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Example 7

Define the “Cost” Property for IfcElement as Library Part independent parameter. For mapping, choose the 

“gs_list_cost” parameter of the “Double Door”. The mapping rule is valid for not just IfcDoor elements but all 

other Library Parts which will be converted to IFC Entities that are child element of IfcElement (e.g. 

IfcWindow, IfcFurnishingElement, IfcDistributionElement, IfcTransportElement etc.) and contain the 

“gs_list_cost” parameter (e.g “Armchair”, “Desk”, “Basin”, “Sink” etc.).
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Data Conversion for IFC Export

File > Interoperability > IFC > IFC Translators

Choose a Translator for Export and open the Data Conversion preset.

Use this dialog to define which data, in addition to element geometry, should be exported to IFC. Such data 

can be useful in data exchange with facility management, energy analysis or cost estimation programs.

Select ARCHICAD Data to Export

Check the boxes of the ARCHICAD Data types you wish to export. 

The required data varies depending the purpose of the resulting IFC file (and the software that will be used to 

open and/or edit it.) 

• Classifications

ARCHICAD Classifications are exported as IFC Classification Reference data.

• Element Properties

Check to export ARCHICAD Properties as IFC Properties. (ARCHICAD Properties are defined in Options 

> Property Manager, and assigned to individual elements in their Settings dialog boxes or through the 

Interactive Schedule.)
ARCHICAD 24 Reference Guide 3074



Translators for Export (Detailed Settings) Working with IFC
– Select this list item and use the popup to choose to export All properties, or Visible properties only.

Note: The Visible Properties option is only relevant if you have loaded an Add-On which controls property 

visibility in ARCHICAD. If no such add-on is loaded, then all properties are exported in every case.

• Building Material Properties

– In IFC 2x3: Check to export ARCHICAD Building Material Properties (defined at Options > Element 

Attributes > Building Materials) as IFC Properties. Exported Building Material data is associated to the 

exported elements

– In IFC4: Exported Building Material data is associated to IFC Materials.

• Element Parameters

Check to export ARCHICAD element parameters that convert to IFC Quantities or IFC Properties, 

depending on their type. 

Note: Choosing this option will significantly increase IFC file size. Export parameters only if you know that 

the target application can read these data. 

To filter the exported parameters by type: Select this list item and use the popup to choose to export All 

parameters, or Quantity-type/Property-type data only.

– Quantity-type data include e.g. Weight, Length, Area, Volume, Time. Useful for data exchange with 

programs that can read quantities.

– Property-type data include e.g. Library Part parameters. 

• Component Parameters

Export parameters of Composite Skins and Complex Profile components as IFC Properties or IFC 

Quantities, depending on their type.

To filter the exported parameters by type: Select this list item and use the popup to choose to export All 

parameters, or Quantity-type/Property-type data only.
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– Quantity-type data include e.g. Weight, Length, Area, Volume, Time. Useful for data exchange with 

programs that can read quantities.

– Property-type data include e.g. Library Part parameters.

As a result, the exported Component data can be interpreted as such in IFC receiving applications, such 

as Solibri.

• Door-Window Parameters

Export detailed information about ARCHICAD openings as IFC Door-Window Lining or Panel properties.

• Zone Categories

Export the Zone Categories data (Code and Name) of ARCHICAD Zones as IFC Space Classification 

Reference data (ItemReference and Name).

Export IFC Properties

Choose an option for which IFC Properties and Classification References to export:

• All IFC Properties (all which are visible in the IFC Project Manager, no filter on)

• Only Properties set in the Property Mapping Preset for the selected Translator. (These properties are 

shown in the IFC Project Manager if you turn on the Show Only Properties from Preview Translator 

filter)

Select Derived Data to Export

Check one or more types of data to export to the IFC model.

• IFC Base Quantities

Check this to export Quantity Takeoff parameters (size, area and volume) to IFC. Useful in cost estimation 

applications. 

The following table summarizes the base quantities by entity types automatically calculated and exported 

when using this option. The values of IfcSite’s base quantities can be set manually at Info > Project Info 

(Site Gross Perimeter and Site Gross Area).
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Export IFC Base Quantities

• IFC Space Containment: Export data defining the relationship between ARCHICAD Zones and objects 

they contain. This feature is useful in facility management applications.

– Space Containment is relevant only for elements, within an ARCHICAD Zone, which were created 

using the Object, Lamp, Morph or Slab tools.

- For Object, Lamp or Morph elements: These elements are in space containment only if their home 

story is the same as that of the Zone, and if the center of the elements’ bounding box falls within the 

Zone’s 2D polygon.

- A Slab is in space containment if its reference line falls within the Zone top/bottom, and if the Slab 

polygon falls within the Zone polygon.

– Click Filter Containment to limit the contents of the Space Containment by their IFC Element Type.
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• IFC Space Boundaries: Export geometry data of ARCHICAD Zones. (Useful in thermal calculation 

applications.)

ARCHICAD Zones include precise geometry data that are useful to thermal calculation software 

applications. Zones are 3D solids in geometrical aspect and in normal cases are bordered by two slabs 

and four walls. Space boundaries define the logical connection between ARCHICAD Zones (IfcSpace) 

and the building elements that enclose them. In practice, Walls, Slabs, Roofs, Windows, Doors etc. all 

have different thermal conductivity properties. If you activate the “IFC Space boundaries” option, 

ARCHICAD will export Space boundaries and their relations (IfcRelSpaceBoundary) together with the 

Zones (IfcSpace) to the IFC file. In other words, ARCHICAD will calculate the position, size and adjacency 

of the elements that border each Zone. ARCHICAD divides the Zone boundaries according to the areas 

defined and cut by connected elements and openings.

See also Energy Evaluation: Direct BIM to BEM.
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Unit Conversion for IFC Export

File > Interoperability > IFC > IFC Translators

Choose a Translator for Export and open the Unit Conversion preset.

Set unit types globally for the export of all coordinates, geometric parameters and “Measure”-type IFC 

Properties.
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Filter Model at Import (Secondary Filter)

When Hotlinking, Merging or Opening an IFC file, you must select an IFC Translator for Import, which controls 

the conversion process. Every IFC Translator for Import has a filtering component (see Model Filter for IFC 

Import), which defines which elements of the IFC model should be placed in ARCHICAD (and which should 

be skipped).

Each Translator for Import also contains another, secondary Model Filter function. This dialog (Model Filter for 

Import) allows you to further fine-tune the set of imported IFC elements, based on more specific element 

categories - e.g. type, story, owner.

However, this secondary Model Filter for Import dialog does not appear by default. To use this feature, turn it 

on in IFC Translator Settings:

1. Open the template file whose IFC translators are being used.

2. Go to File > Interoperability > IFC > IFC Translators.

3. Select a Translator for Import.

4. Under Settings, open Model Filter Settings.
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5. Check the Show Model Filter dialog box on import box.
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Now the Model Filter for Import dialog will appear when you open, hotlink or merge an IFC file to 

ARCHICAD. Use it to apply custom element filters to the current import process.

 

Group element list by

To make filtering easier, sort the list items or grouping them as follows:

• IFC Element Type

• Story: List elements by their story location

• Layer: List IFC element types and elements by layer

• Element Owner: List element types and elements according to who created them in IFC

Note on Element Owner

• Elements in IFC models always have an owner attached. If the IFC file is exchanged among many users 

and programs, an element may have multiple owners.

• The IFCProject entity, like all IFC entities, also has an owner. When an IFC project is imported to 

ARCHICAD, the IFCProject entity’s owner are added to ARCHICAD’s Project Info. At export from 

ARCHICAD, the model elements are all assigned to this owner.

Additional Element Filtering

If needed, filter elements further by IFC Domain or by Structural Function.
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Filter Model at Export

Each IFC Translator contains settings for filtering the elements to be exported.

However, you can further fine-tune the set of exported elements during the export process.

IFC Save Options: Elements to Export

1. Go to File > Save as.

2. Choose an IFC file format.

3. In the Export field, choose an option:

• Selected elements only in the current view (this option is only available if the current view includes some 

selected elements)

• Visible elements on all stories. When saving from Floor Plan view, you can choose to export visible 

elements on just the current story. Visibility depends on display settings (Layers, Partial Structure 

display, etc.).

• Entire project, regardless of any selection or layer settings.

Notes:

– In order to export 2D drawing-type elements, annotation element or Grid elements, it is not enough to 

meet the criteria of the filters listed above (e.g. export based on selected or visible elements); you 

must also specifically enable their export, using the translator settings. (See Select 2D Elements to 

Export.)

– Publisher always uses the ‘visible’ element export mode, independently of the Model Filter settings of 

the applied IFC Translator for Export. 
ARCHICAD 24 Reference Guide 3083



Filter Model at Export Working with IFC
IFC Save Options: Model Filter

From the Save dialog, click the Filter button to open this dialog box.

 

Use this list to further filter the elements to be exported.

Group element list by

To make filtering easier, sort the list items or grouping them as follows:

• IFC Element Type

• Story: List elements by their story location

• Layer: List IFC element types and elements are listed by layer.

• Element Owner: element types and elements are listed according to who created them. (At export, all 

elements are considered as belonging to the same owner.)

See also Note on Element Owner.

Additional Element Filtering

If needed, filter elements further by IFC Domain or by Structural Function.
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Appendix: IFC Terms and Concepts

The following sections provide additional detail about terms and concepts used in IFC.

Model View Definitions

IFC Data Types
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Model View Definitions

A Model View Definition, MVD (or IFC View Definition) is a recommendation for which data and elements the 

IFC model should include, depending on the purpose of the model exchange.

Model View Definitions are either defined within buildingSMART International, or by other organizations and 

interest groups.

ARCHICAD IFC Export and Import supports the following Model View Definitions (choose an MVD in the 

Translator for Export Settings):

IFC2x3 Schema

• The Coordination View is currently the most widely implemented view of the IFC Schema. Its main 

purpose is to allow sharing of building information models among the disciplines of architecture, structural 

engineering, and building service. It contains definitions of spatial structure, building, and building service 

elements. ARCHICAD is certified for both import and export of the latest version: IFC2x3 Coordination 

View 2.0.

• The IFC2x3 Coordination View (Surface Geometry) is a simplified publishing format (i.e. a subset) of 

the Coordination View. This format is suitable for viewing (since all IFC viewers support this format), 

design coordination, clash prevention during design, and clash checking, similarly to IFC4 Reference 

View. “Coordination View (Surface Geometry)” means that every element will be exported with its BREP 

(boundary representation) geometry. This method comes closest to reproducing the real shape of the 

element, together with its specialized sections, connections and solid operations. (However, the element’s 

parameters are lost, and BREP elements from an imported IFC file are transformed into non-editable 

elements.)

• The IFC2x3 Basic FM Handover View is an extended version of the Coordination View (developed by 

buildingSMART) that defines the general requirements for design applications to enable the handover of 

facility management information. The basic scope can be summarized as the space and equipment list for 

the spatial and technical systems of a facility. Technically, the Basic FM Handover View fulfills the 

following requirements above and beyond those of the abovementioned Coordination View: ability to 

assign furnishing and equipment components to spaces (Space Containment, IFC System), to assign 
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spaces to zones (IFC Zone), to assign a classification to spaces and components (Classification 

Reference), to assign manufacturer base properties to components (standard and custom IFC 

Properties), to assign doors and windows to spaces (Space Boundaries), to assign type information for 

components (IFC Type Product) and to export base quantities for all project components and spatial 

structures. This MVD is required in various projects defined by buildingSMART and other organizations. 

An example is the COBie (Construction-Operations Building information exchange), a specification used 

in the handover of Facility Management information. It is a spreadsheet data format for the delivery of a 

subset of building model information, rather than geometric model information. ARCHICAD’s BIM-quality 

models and IFC data exchange capabilities produces data output that is easily converted into COBie 

documentation, with the help of free or commercial conversion programs.

• There are several other Model View Definitions (generally the extended versions of the Coordination view) 

specified by organizations or development teams outside of buildingSMART International.

IFC4 Schema

The IFC4 Schema further divides the Coordination View into two Model View Definitions:

Note: The IFC4 Schema is not supported by all applications. Use an MVD of the IFC4 Schema only if you 

are certain that it is supported by the application that will receive IFC data.

• IFC4 Reference View: Suitable for all BIM workflows based on reference models, where the exchange is 

mainly one-directional. Requested modifications of the BIM data, mainly of the shape representation, are 

handled by a change request to the original author. 

– When exporting to IFC4:

- the relation connections of chained Walls and Beams are omitted

- Surfaces of Building Materials are omitted

• IFC4 Design Transfer View: Provides building information with support for editing of interconnected 

elements: inserting, deleting, moving, and modifying physical building elements and spaces, within the 

limited scope of parametric exchange. An example of a target scenario is an architect providing building 

design information to an engineer for a particular discipline, where geometric modifications may be 

needed. Note that the Design Transfer View is not meant for round-trip model exchange scenarios.
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All Model View Definitions can be extended by definitions which support additional exchange requirements: 

• the Quantity Take-off add-on view adds the ability to transmit base quantities for all spatial and building 

elements

• the Space Boundary add-on view adds building elements to space relationships to support models in 

thermal and energy analysis

• the 2D Annotation add-on view supports the exchange of additional 2D element representations and 

annotations of building models
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IFC Data Types

This chapter summarizes the main IFC data types available in ARCHICAD.

IFC Entity

IFC Model Hierarchy

IFC Type

IFC Type Product

IFC Container

IFC Attributes

IFC Properties

IFC Classification Reference

IFC Assignments

IFC Entity

In an IFC model, the project information (generated, for example, from an ARCHICAD project) is represented 

as a set of IFC Entities - such as IFC Type, Attribute, Assignment, Type Product. Each IFC Entity (for 

example, an IfcWall) includes a fixed number of IFC Attributes, plus any number of additional IFC Properties. 

Some IFC Entities express characteristics of other entities. Some of these correspond to ARCHICAD 

attributes. These correspondences are mapped automatically when the IFC model is generated or exported, 

or when the IFC model is imported.

You can set different preferences for converting Layers, Building Materials and Surfaces of imported IFC 

models: use the conversion settings of Import translators.

See Layer Conversion for IFC Import and Material and Surface Conversion.

ARCHICAD Attribute IFC Entity

Layer IfcPresentationLayerAssignment

Building Material IfcMaterial

Surface IfcSurfaceStyleRendering

Composite IfcMaterialLayerSet (extruded geometry) or IfcMaterialList (BREP 

geometry)

Profile IfcProfileDef
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IFC Model Hierarchy

An IFC model is composed of IFC Entities built up in a hierarchical order. As shown in the following illustration, 

each story level (IfcBuildingStorey) has its corresponding story in ARCHICAD.

In ARCHICAD, all elements and objects are linked to a home story. Thus, by default, the IFC model hierarchy 

lists them under the IfcBuildingStorey of the same name as the elements’ home story. However, in IFC Project 

Manager, elements can be assigned directly to the IfcSite or IfcBuilding. So, for example, neighboring buildings 

(e.g. defined by the Morph tool) and site context elements (trees, fences, roads, etc.) can be assigned to the site 

instead of the project building with its story system.

By default, the IFC elements (for example the IfcBuildingElements) and the IfcSpace entities are on the same 

hierarchy level in an IFC model. However, ARCHICAD Objects and Morphs - regardless of their Classification 

- can be displayed on and, for IFC export purposes, linked to the ARCHICAD Zone (IfcSpace) that contains 

them, instead of to their home story.

IFC Spatial Elements

IFC Spatial Elements are IfcProject, IfcSite, IfcBuilding, IfcBuildingStorey, as well as IfcSpace. They are 

at the top of the IFC Project Manager Hierarchy.

These elements can only be managed through the IFC Project Manager, where you can also edit their IFC-

related data. 

The IFC Attribute values of these spatial elements, however, are derived from the data of the current 

ARCHICAD project.

IfcSite is the geographic position of the IfcProject. It can have a geometry, but a geometry is not required. In 

ARCHICAD, site geometry is represented by Mesh elements, Site-type Objects, or elements with “Site 

Geometry” Classification.

ARCHICAD can handle and import one building (IfcBuilding) only. But it can import more than one IfcSite, 

even though the IfcSite is above the IfcBuilding in the hierarchy. Thus, when importing an IFC file that contains 

multiple buildings, you can choose only one to import.

See Building and Site Selection.
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However, other applications can export a building’s topography into multiple IfcSites. In this case, importing 

the IfcBuilding will import all of the IfcSites, merged into the one IfcSite that actually contains the imported 

IfcBuilding. As a result, you will end up with a single IfcSite and a single IfcBuilding, but the IfcSite includes all 

of the IfcSites.

How to Control Global ID (IFC Attribute) Based on ARCHICAD Project Info

By default, ARCHICAD assigns identical GlobalID attributes to the following entities: IFC Project, IFC Site, 

IFC Building, and IFC Story. More precisely: the Global IDs will be identical, provided that the respective ID 

fields, defined at ARCHICAD’s Project Info dialog box (File > Info) contain identical keywords (or no value at 

all). However, you can alter these keywords in the Project Info dialog box to control whether the spatial entities 

have identical or different GlobalIDs.

Suppose you have two separate buildings (stored in two different ARCHICAD projects). You want both 

projects and both sites to share the same GlobalID; yet you want the various buildings on each site to have 

different GlobalIDs. 

To achieve this, enter the same keyword in the “Project ID” and “Site ID” fields of both projects. Enter different 

keywords for the “Building ID” fields.
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IFC Story entities have no corresponding ID field in the Project Info dialog box. The GlobalIDs of IFC Story 

entities are derived from their Building ID. If two buildings in two different ARCHICAD projects have the same 

Building ID, then all stories of those buildings which have the same Story Number will have the same Global 

ID.

IFC Type

IFC Type is one kind of IFC entity - it groups IFC model elements into a hierarchical structure, represented by 

the tree structure in the IFC Project Manager.

When a model is exported to IFC format, every one of its elements is assigned an IFC Type. In ARCHICAD, 

IFC Types are generated based on the Type Mapping definition (either by Tool or by Classification) in the 

Translator for Export. 

See Type Mapping for IFC Export.

in ARCHICAD, view any element’s IFC Type in the Manage IFC Properties window of Element Settings (or for 

any selected element in IFC Project Manager).

You can also use Find & Select to filter the project by “IFC Type” criteria, or use Interactive Element Schedule 

to list this data for ARCHICAD elements. For example, you can select or list just the model elements having 

IfcSlab IFC Type.

See Define Element Criteria using IFC Data.

IFC Type Product

An IFC Type Product defines a particular style/type of other entities by relating to them with common IFC 

Attributes and Properties. For example, IfcWindowStyle is an IFC Type Product, to which many windows 

(IfcWindow) refer.
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IFC Type Product entities are generated for ARCHICAD elements based on the Type Mapping definition in the 

Translator for Export. 

See Type Mapping for IFC Export.

IFC Container

IFC Container (relating object of IfcRelAggregates) is an IFC entity that does not have its own body geometry, 

but its components (related objects of IfcRelAggregates) contain all geometry and structure-related data. 

Exporting Hierarchical Elements from ARCHICAD as IFC Containers

In an ARCHICAD project, the IFC Translator for Export gives you the option of exporting hierarchical elements 

(Curtain Wall, Stair, Railing) to IFC as either a single element, or as a hierarchical one.

• If exported with the hierarchical method (“Keep Hierarchy”), it will be an IFC Container entity, and its sub-

elements will be individual IFC elements. This reflects the multi-part hierarchy of the original ARCHICAD 

element (e.g. Stair).

• If exported as a single element, it will be a single IFC entity, which contains within itself the geometry of 

all its sub-elements. The hierarchical nature of the original element (e.g. Stair, with all its separate sub-

components) is thus lost.

• IFC export that uses the “Explode Composite and Complex Profile elements into parts” option generates 

IFC Container elements from building elements in the output IFC file: for example a composite wall 

element is saved as an “IfcWall”-type IFC Container element without geometry, and its skin parts will 

provide the geometry as “IfcBuildingElementPart” elements.

These export options are found at Geometry Conversion for IFC Export.

IFC Attributes

IFC Attributes are the main identifiers of IFC Entities. The names of IFC Attributes are fixed, having been 

defined by buildingSMART as part of the IFC standard code.

Most of these IFC Attribute names are derived from the project. For example, the IFC Attributes of an IfcWall 

building element: 

• GlobalId: the Globally Unique Identifier of the IfcWall in the IFC model (not editable).

• OwnerHistory: the assignment of the information about the current ownership of the IfcWall.

• Name: its factory-default derived value is IfcWall’s ARCHICAD ID (Wall Settings dialog box > 

Classification and Properties panel).

• Description: an optional textual description.

• ObjectType: an optional text to define a subtype of an element or add type information to it.
ARCHICAD 24 Reference Guide 3093



Appendix: IFC Terms and Concepts Working with IFC
• Tag: its factory-default derived value is the IfcWall’s ARCHICAD “Unique ID” (not the same as IFC 

GlobalId).

• OwnerHistory is directly attached to all independent objects, relationships and properties. Its components 

and values are derived from project data and hidden in the ARCHICAD user interface. It includes, for 

example, the owning actor (OwningUser) (certain owner data is added to ARCHICAD’s Project Info (File > 

Info).

IFC Properties

IFC Properties are additional (mostly IFC Type-specific) parameters assigned to an IFC Entity. IFC Properties 

can be standard or non-standard.

• Standard, so-called “IFC2x3 Schema” data are defined by buildingSMART and stored in property sets 

whose names begin with the prefix “Pset_”

• Non-standard data are created by the exporting application using any property name and stored in any 

property set (the names of these property sets usually contain the name of the exporting application, or 

the IFC Model View Definition which requires the property.

See Property Mapping for IFC Export.

IFC Classification Reference

A Classification Reference (IfcClassificationReference) arranges IFC elements into a category. You can 

assign an Item Reference identifier, a classification Name attribute and some other optional parameters to all 

project elements (such as the building, the stories, the building elements, or the zones). 

You can classify elements with this system both in IFC Project Manager and the element Settings dialog.

See Create New, Custom IFC Property.
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IFC Assignments

IFC Assignments (IfcRelAssigns) define the relationship among project elements. Each assignment type can 

have its own IFC Attribute (the most significant is the Object Type), and standard and custom IFC Properties. 

The major assignment types of the IFC standard are the following:

• IFC Group (IfcGroup): Use this to group any project elements (building element, story etc.) together. For 

example: the column and beam components of a frame standing are grouped together. Grouping by 

multilevel-hierarchy is also available: for example, you can group the frame standing groups in a ‘frame-

system’ group.

• IFC Zone (IfcZone): Use this to group IfcSpace elements (the equivalent of ARCHICAD Zones) together. 

For example: ARCHICAD Zones having the identical function are grouped into an IfcZone named e.g. 

“Security Zone.” Grouping by multilevel-hierarchy is also available for IfcZone assignments. For example, 

you can group some ARCHICAD Zones (IfcSpaces) in an IfcZone (Security Zones) that is a part of a 

higher level IfcZone group (Governmental Zones).

• IFC System (IfcSystem): Use this to group any project elements (especially MEP elements) in a system 

hierarchy manually, by using MEP Modeler defined systems, or by importing systems exported from e.g. 

MEP applications. Definition of sub-system hierarchy (parent and child system) is also available. For 

example: group elevators in a vertical circulation system which can be a child system of a mechanical 

system. Or, assign plumbing elements to the cold water sub-system of a plumbing system. You can also 

tie systems to a spacial structure relation (IfcSite, IfcBuilding, IfcStorey or IfcSpace). For example, add to 

a duct system all the ARCHICAD Zones (IfcSpace) that it runs through.

• IFC Building Systems

• IFC Distribution Systems

ARCHICAD supports all of the above mentioned IFC Assignment types:

• the IFC Project Manager interface lets you define any assignments in your project and manage all their 

IFC data;

• all of the above mentioned assignment data are created at IFC model import (for example IfcSystems 

stored in an MEP-type IFC model, IfcZones defined in an FM application);

• all available IFC Assignments (defined manually or previously imported) are exported with a new IFC 

model mapped from the current ARCHICAD project.

See Using Assignments in IFC Project Manager.
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Appendix: IFC Data Mapping in ARCHICAD

This section contains two charts with detailed mapping information that is built in to ARCHICAD.

Predefined Property Mapping (Export ARCHICAD to IFC)

Built-in IFC Type Mapping for ARCHICAD

Related Topic:

Data Types for Properties in IFC and ARCHICAD
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Predefined Property Mapping (Export ARCHICAD to IFC)

The Property Mapping preset of the IFC Translator for Export defines the assignment of IFC Properties and 

Attributes when exporting ARCHICAD model to IFC.

See Property Mapping for IFC Export.

Some Attribute and Property data come with a predefined mapping rule, which you do not have to create 

yourself in Property Mapping. 

Although these rules do not appear in the Map IFC Properties for Export dialog box, they can be seen (if they 

have values) with a gray chain icon in the IFC Project Manager and Element Settings.

These rules are listed in the following table. 

ARCHICAD 

Command

ARCHICAD Parameter IFC Entity Types IFC Data IFC Project 

Manager

Project Info Project Name IfcProject Attribute>Name visible/editable

Project Info Project Description IfcProject Attribute>Description visible/editable

Project Info Project ID IfcProject Attribute>GlobalId (see 

How to Control Global ID 

(IFC Attribute) Based on 

ARCHICAD Project Info)

-

Project Info Project Status IfcProject Attribute>Phase visible/editable

Project Location Project North IfcProject Attribute>Representa-

tionContext>TrueNorth

-

Project Location Latitude IfcSite Attribute>RefLatitude visible

Project Location Longitude IfcSite Attribute>RefLongitude visible

Project Location Altitude IfcSite Attribute>RefAltitude visible

Project Info Site Name IfcSite Attribute>Name visible/editable

Project Info Site ID IfcSite Attribute>Global Id (see 

How to Control Global ID 

(IFC Attribute) Based on 

ARCHICAD Project Info)

-

Project Info Site Description IfcSite Attribute>Description visible/editable
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Project Info Site Full Address>Site 

Address1

IfcSite Attribute>SiteAd-

dress>AddressLines

-

Project Info Site Full Address>Site 

Address2

Project Info Site Full Address>Site 

Address3

Project Info Site Full Address>Site 

Postal Box

IfcSite Attribute>SiteAd-

dress>PostalBox

-

Project Info Site Full Address>Site 

City

IfcSite Attribute>SiteAd-

dress>Town

-

Project Info Site Full Address>Site 

State

IfcSite Attribute>SiteAd-

dress>Region

-

Project Info Site Full Address>Site 

Postcode

IfcSite Attribute>SiteAd-

dress>PostalCode

-

Project Info Site Full Address>Site 

Country

IfcSite Attribute>SiteAd-

dress>Country

-

Project Info Site Gross Perimeter IfcSite BaseQuantity>GrossPerim-

eter

-

Project Info Site Gross Area IfcSite BaseQuantity>GrossLan-

dArea

-

Project Info Building Name IfcBuilding Attribute>Name visible/editable

Project Info Building Description IfcBuilding Attribute>Description visible/editable

Project Info Building ID IfcBuilding & 

IfcBuildingStorey

Attribute>GlobalId (see 

How to Control Global ID 

(IFC Attribute) Based on 

ARCHICAD Project Info)

Project Info Contact Full Name>Con-

tact Prefix Title

IfcPerson Attribute>PrefixTitles -

Project Info Contact Full Name>Con-

tact Given Name

IfcPerson Attribute>GivenName -

Project Info Contact Full Name>Con-

tact Middle Name

IfcPerson Attribute>MiddleNames -

Project Info Contact Full Name>Con-

tact Family Name

IfcPerson Attribute>FamilyName -

Project Info Contact Full Name>Con-

tact Suffix Title

IfcPerson Attribute>SuffixTitles -

Project Info Contact ID IfcPerson Attribute>Id -

Project Info Contact Role IfcPerson Attribute>Roles -

Project Info Contact Department IfcPerson Addresses>Postal>Inter-

nalLocation

-

Project Info Contact Company IfcOrganization Attribute>Name -

ARCHICAD 

Command

ARCHICAD Parameter IFC Entity Types IFC Data IFC Project 

Manager
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Project Info Contact Company Code IfcOrganization Attribute>Id -

Project Info Contact Full 

Address>Contact 

Address1

IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Postal>Ad

dressLines

-

Project Info Contact Full 

Address>Contact 

Address2

Project Info Contact Full 

Address>Contact 

Address3

Project Info Contact Full 

Address>Contact Postal 

Box

IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Postal>Po

stalBox

-

Project Info Contact Full 

Address>Contact City

IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Postal>To

wn

-

Project Info Contact Full 

Address>Contact State

IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Postal>Re

gion

-

Project Info Contact Full 

Address>Contact Post-

code

IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Postal>Po

stalCode

-

Project Info Contact Full 

Address>Contact Country

IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Postal>Co

untry

-

Project Info Contact E-mail IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Tele-

com>ElectronicMailAddres

s

-

Project Info Contact Phone Number IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Tele-

com>TelephoneNumbers

-

Project Info Contact Fax IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Tele-

com>FacsimileNumbers

-

Project Info Contact Web IfcPerson & 

IfcOrganization

Attri-

bute>Addresses>Tele-

com>WWWHomePageURL

-

Story Settings Elevation IfcBuildingStorey Attribute>Elevation visible/editable

Zone Settings Name IfcSpace Attribute>LongName visible/editable

Zone Settings Number (No) IfcSpace Attribute>Name visible/editable

ARCHICAD 

Command

ARCHICAD Parameter IFC Entity Types IFC Data IFC Project 

Manager
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(element)>Set-

tings

Classification and Proper-

ties>ID

(IFC element 

type)

Attribute>Name visible/editable

(element)>Set-

tings

Classification and Proper-

ties>Classification

(IFC element 

type)

Attribute>ObjectType visible/(editable 

in Export Trans-

lator, Type Map-

ping)

(element)>Set-

tings

Classification and Proper-

ties>Classification

(IFC element 

type)

Attribute>PredefinedType visible/(editable 

in Export Trans-

lator, Type Map-

ping)

(element)>Set-

tings

Classification and Proper-

ties>Structural Function

(IFC element 

type)

Pset_...Common>LoadBear-

ing

visible

(element)>Set-

tings

Classification and Proper-

ties>Position

(IFC element 

type)

Pset_...Common>IsExter-

nal

visible

(element)>Set-

tings

Classification and Proper-

ties>Renovation Status

(IFC element 

type)

AC_Pset_RenovationAnd-

Phasing>Renovation Sta-

tus

visible

(element)>Set-

tings

Classification and Proper-

ties>Classification

(IFC type prod-

uct)

Attribute>ElementType visible/(editable 

in Export Trans-

lator, Type Map-

ping)

(element)>Set-

tings

Classification and Proper-

ties>Classification

(IFC type prod-

uct)

Attribute>PredefinedType visible/(editable 

in Export Trans-

lator, Type Map-

ping)

Schedule>(ele-

ment)

General>Unique ID (IFC element 

type)

Attribute>Tag visible/editable

Window/Door 

Settings

Preview and Position-

ing>Width

IfcWindow / Ifc-

Door

Attribute>OveralWidth visible

Window/Door 

Settings

Preview and Position-

ing>Height

IfcWindow / Ifc-

Door

Attribute>OverallHeight visible

(automatic type 

naming rule)

IfcColumn Pset_ColumnCommon>Refer-

ence

visible/editable

IfcColumnType Attribute>Name visible/editable

(automatic type 

naming rule)

IfcBeam Pset_BeamCommon>Refer-

ence

visible/editable

IfcBeamType Attribute>Name visible/editable

ARCHICAD 

Command

ARCHICAD Parameter IFC Entity Types IFC Data IFC Project 

Manager
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Built-in IFC Type Mapping for ARCHICAD

When an ARCHICAD model is exported to IFC, each element is assigned an IFC Element Type. 

Type Mapping is defined in the IFC Translator for Export, in the Type Mapping preset: either by Element Type 

or by Classification. 

See Type Mapping for IFC Export.

The following 3 charts show the Type Mapping that results using the automatic, “by Element Type” method. 

ARCHICAD Tool

LibPart (By UnId)

MEP (By Tool)
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ARCHICAD Tool

ARCHICAD Tool IFCObjectType IFCObject IFCObject PredefinedType IFCTypeObject 

Predefined-

Type

Beam IFCBeam IFCBeamType

Column IFCColumn IFCColumnType

Wall IFCWall IFCWallType

Shell IFCSlab ROOF IFCSlabType ROOF

Roof IFCSlab ROOF IFCSlabType ROOF

Slab IFCSlab FLOOR IFCSlabType FLOOR

Mesh IFCSite

Morph IFCBuildingElementProxy IFCBuildingElement-

ProxyType

Railing IFCRailing IFCRailingType

Baluster IFCMember IFCMemberType

Handrail IFCMember IFCMemberType

Inner Post IFCMember IFCMemberType

Railing Panel IFCMember IFCMemberType

Railing Post IFCMember IFCMemberType

Rail IFCMember IFCMemberType

Toprail IFCMember IFCMemberType

Handrail Connection IFCMember IFCMemberType

Rail Connection IFCMember IFCMemberType

Toprail Connection IFCMember IFCMemberType

Handrail End IFCMember IFCMemberType

Rail End IFCMember IFCMemberType

Toprail End IFCMember IFCMemberType

Railing Node IFCMember IFCMemberType

Railing Segment IFCMember IFCMemberType

Railing Pattern IFCMember IFCMemberType

Stair IFCStair IFCStairType

Riser IFCMember IFCMemberType

Stair Structure IFCMember IFCMemberType

Tread IFCMember IFCMemberType

Curtain Wall IFCCurtainWall IFCCurtainWallType

Curtain Wall Frame IFCMember IFCMemberType

Curtain Wall Panel IFCPlate IFCPlateType

Curtain Wall Acces-

sory

IFCDiscreteAccessory IFCDiscreteAccessory-

Type
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Curtain Wall Seg-

ment

IFCDiscreteAccessory IFCDiscreteAccessory-

Type

Curtain Wall Junction IFCDiscreteAccessory IFCDiscreteAccessory-

Type

Zone IFCSpace IFCSpaceType

Door IFCDoor IFCDoorType

Skylight IFCWindow IFCWindowType

Window IFCWindow IFCWindowType

Opening IFCOpeningElement

Object IFCFurniture IFCFurnitureType

Lamp IFCLightFixture IFCLightFixtureType

Fill IFCAnnotation Undefined

Line IFCAnnotation Undefined

Spline IFCAnnotation Undefined

Polyline IFCAnnotation Undefined

Circle IFCAnnotation Undefined

Arc IFCAnnotation Undefined

Dimension IFCAnnotation Undefined

Angle Dimension IFCAnnotation Undefined

Level Dimension IFCAnnotation Undefined

Radial Dimension IFCAnnotation Undefined

Text IFCAnnotation Undefined

Label IFCAnnotation Undefined

ARCHICAD Tool IFCObjectType IFCObject IFCObject PredefinedType IFCTypeObject 

Predefined-

Type
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LibPart (By UnId)

LibPart (By UnId)

ARCHICAD IFCObjectType IFCTypeObjectType

curtainWallFrame IFCBuildingElementProxy IFCBuildingElementProxyType

curtainWallPanel IFCBuildingElementProxy IFCBuildingElementProxyType

stair IFCStair IFCSpatialStructureElementType

opening IFCOpeningElement IFCMemberType

wallOpening IFCOpeningElement IFCMemberType

wallDoor IFCDoor IFCDoorStyle

wallWindow IFCWindow IFCRampFlightType

roofOpening IFCWindow IFCRampFlightType

beam IFCBeam IFCBeamType

column IFCColumn IFCColumnType

covering IFCCovering IFCCoveringType

light IFCFlowTerminal IFCFlowTerminalType

curtainWall IFCCurtainWall IFCCurtainWallType

discreteAccessory IFCDiscreteAccessory IFCDiscreteAccessoryType

footing IFCFooting IFCFlowTreatmentDeviceType

furnishing IFCFurnishingElement IFCFurnishingElementType

railing IFCRailing IFCRailingType

ramp IFCRamp IFCRailingType

roof IFCRoof IFCRampFlightType

slab IFCSlab IFCSlabType

wall IFCWall IFCRampFlightType

wallEnd IFCCovering IFCCoveringType

gridElementMarker IFCGridAxis IFCFurnishingElementType

slabOpening Undefined IFCWindowStyle

transport IFCTransportElement IFCRampFlightType

buildingElementProxy IFCBuildingElementProxy IFCBuildingElementProxyType

ifcMechanicalFastener IFCMechanicalFastener IFCMechanicalFastenerType

ifcFastener IFCFastener IFCFastenerType

ifcExtruded IFCBuildingElementProxy IFCBuildingElementProxyType

ifcBeamExtruded IFCBeam IFCBeamType

ifcColumnExtruded IFCColumn IFCColumnType

ifcDiscreteAccessoryEx-

truded

IFCDiscreteAccessory IFCDiscreteAccessoryType

ifcFootingExtruded IFCFooting IFCFlowTreatmentDeviceType

ifcOpeningExtruded IFCOpeningElement IFCMemberType
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MEP (By Tool)

MEP (By Tool)

ARCHICAD IFCObjectType IFCTypeObjectType IFCTypeObject 

PredefinedType

CableCarrierBend IFCCableCarrierFit-

ting

IFCCableCarrierFit-

tingType

BEND

CableCarrierRigidSeg-

ment

IFCCableCarrierSeg-

ment

IFCCableCarrierSeg-

mentType

NOTDEFINED

CableCarrierTee IFCCableCarrierFit-

ting

IFCCableCarrierFit-

tingType

TEE

CableCarrierTransi-

tion

IFCCableCarrierFit-

ting

IFCCableCarrierFit-

tingType

REDUCER

CableCarrierWye IFCCableCarrierFit-

ting

IFCCableCarrierFit-

tingType

TEE

DuctBend IFCDuctFitting IFCDuctFittingType BEND

DuctEndCap IFCDuctFitting IFCDuctFittingType EXIT or ENTRY

DuctFlexibleSegment IFCDuctSegment IFCDuctSegmentType FLEXIBLESEGMENT

DuctObstruction IFCDuctFitting IFCDuctFittingType OBSTRUCTION

DuctOffset IFCDuctFitting IFCDuctFittingType TRANSITION

DuctRigidSegment IFCDuctSegment IFCDuctSegmentType RIGIDSEGMENT

DuctTakeOff IFCDuctFitting IFCDuctFittingType JUNCTION

DuctTee IFCDuctFitting IFCDuctFittingType JUNCTION

DuctTransition IFCDuctFitting IFCDuctFittingType TRANSITION

DuctVerticalObstruc-

tion

IFCDuctFitting IFCDuctFittingType OBSTRUCTION

DuctWye IFCDuctFitting IFCDuctFittingType JUNCTION

PipeBend IFCPipeFitting IFCPipeFittingType BEND

PipeCombinationWye IFCPipeFitting IFCPipeFittingType JUNCTION

PipeInlineFlowDevice IFCPipeFitting <ifc_subtype parame-

ter>

<ifc_predefinedtype 

parameter>

PipeInlineFlowDevice IFCPipeFitting <ifc_subtype parame-

ter>

<ifc_predefinedtype 

parameter>

PipeRigidSegment IFCPipeSegment IFCPipeSegmentType RIGIDSEGMENT

PipeSanitaryTee IFCPipeFitting IFCPipeFittingType JUNCTION

PipeTakeOff IFCPipeFitting IFCPipeFittingType JUNCTION

PipeTee IFCPipeFitting IFCPipeFittingType JUNCTION

PipeTransition IFCPipeFitting IFCPipeFittingType TRANSITION

PipeWye IFCPipeFitting IFCPipeFittingType JUNCTION
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Data Types for Properties in IFC and ARCHICAD

IFC Data Type ARCHICAD Data Type Description

Single String String Any text or number

Single Real Number Any number expressed in decimals

Single Integer Integer A whole number

Single Boolean True/False A logical true or false value 

List String Tags List A tag or series of tags.

Enumerated String Option Set Provides a fixed set of options. The user can choose a 

value from this set. 
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User Interface Reference

In this section you will find the description of ARCHICAD’s user interface listed in 3 categories: Controls; 

Dialog Boxes; and Tool Settings Dialog Boxes.

The best way to use the User Interface Reference is to navigate to specific topics by using ARCHICAD’s 

context sensitive help.

Read more about this feature in: Context-Sensitive Help.

Topics in this section:

Controls

Dialog Boxes

Tool Settings Dialog Boxes
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Controls

This section of the User Interface Reference describes the following interface items.

Action Center

Project Chooser

The 2D Navigator Preview Palette Controls

The 3D Navigator Preview Palette Controls

Control Box

Coordinates Palette

Search and Replace Text Dialog Box

Formatting Palette and Text Editor Controls

Renovation Palette

Teamwork Palette

Project Info

Project Notes

Project Preview

Architect Credits in BIMx

Session Report Window

Solid Element Operations Palette

Classic 3D Navigation Toolbar
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Action Center

The Action Center is an ARCHICAD Tab/window:

It collects all the information you need about the update status of the following project components:

• Libraries

• Hotlinks

• Drawings

• Reports (Session Reports)

• Licenses

• Updates (ARCHICAD and Library)

• Feedback (User Surveys)

Use the Action Center to get information on their current status, issues that need to be resolved, and to run a 

check where needed.

• Some of these items (e.g. Libraries) are checked automatically whenever you open a project. 

• Other items (e.g. Hotlinks and Drawings) may require you to run a manual check.

Where Do I See the Action Center?

• The Action Center window appears automatically in the Tab Bar (or the current window, if you don’t use 

the Tab Bar) whenever any item(s) need checking or action. 

• At any time: use File > Info > Action Center
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Action Center Summary

By default, you see the Summary page:

The icon of each project item indicates its current status.

Status of Project Items

Note: The green checkmark means this item was up to date as of the last check. It is possible that some 

items shown with a green checkmark have been modified since the last check. Run a manual check to 

make sure.

Action Center Icon What it Means

No action needed

Item was up to date as of the last check.

Action needed

Issues were found during the last check.

 Click the item and follow the instructions.

Needs checking.

This item needs a check to determine if anything is missing or out of date. 

Click the item and follow the instructions.
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Click on any item for more info:

• In Action Center, for each item, the time of the last check is indicated.

• To run a manual check on any item, or all items:

– For any selected item: click the context-sensitive Check button at top left

– On the Summary page, click Check all items

Example

The Hotlinks item shows a question mark: manual checking is needed. Click the item, read the results, and 

click Check Hotlinks to run a check for missing sources or outdated hotlinks.
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As a result of the manual check, the Action Center Hotlinks item now shows a red warning icon: an update is 

needed. Click the Hotlink Manager button to open it and take care of the update.

Management Dialogs Accessible from Action Center

Library Manager

Hotlink Module Manager

Drawing Manager

Session Report Window

License Information

See also:

Updates for ARCHICAD

ARCHICAD User Feedback - Net Promoter Score Survey
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Project Chooser

 

Use this button to access choices for managing projects with the Navigator or Organizer.

The top section of the Project Chooser list displays ARCHICAD project files you have accessed.

• Active: Name of current project

• Linked: An external project from which you have already added a view or layout to the active project

• Running: An external project which is open in a separate instance of ARCHICAD.

Browse: Click this button to access a file directory and choose an ARCHICAD project whose content you 

want to use in the active project.

The rest of the items let you navigate to key palettes. This part of the Chooser menu is also available from the 

pop-up Navigator at the right end of the Tab Bar.

Show Organizer: Click this command to display the Organizer (if you are in the Navigator’s Project Chooser).

Show Navigator: Click this command to display the Navigator (if you are in the Organizer’s Project Chooser).

Show Drawing Manager: Click this command to display the Drawing Manager palette.

Show Change Manager: Click this command to display the Change Manager palette.
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The 2D Navigator Preview Palette Controls

To show the 2D Navigator Preview Palette, use Window > Palettes > Navigator Preview.

The Navigator Preview palette has three uses:

• It shows a small preview of the Project Map or View Map item selected in the Navigator palette.

• It can be updated to show the a preview of the contents of the currently active model window.

• With zoom and pan operations inside the palette, you can update the view displayed in the active window.

Go: Click Go to jump to the view you select from the Navigator or in the Overview.

Note: Clicking Go is the equivalent of double-clicking one item on the Navigator tree view or double-

clicking on the Overview inside the frame of the Overview.

Zoom Out: Clicking this results in reduction on the visible plan in the overview area.

Zoom: Sets the zoom on the plan visible in the overview area.

Zoom In: Clicking this results in magnification on the visible plan in the overview area.

Zoom Pop-up Menu: You can define the connection between the Navigator Preview and the frontmost 

window. You can also redraw preview from here.

• Real-time Zoom: If you choose this option, the zooming and panning operations made in the preview are 

continuously shown in the window.

• Auto zoom: With this option, the zooming and panning operations made in the preview do not affect the 

screen display until you release the mouse button.

• Double-click to zoom: With this option, the view does not reflect the display changes made in the 

preview. To update it, you need to either double-click inside the preview or click the Go button in the top 

right corner of the palette.

• Redraw Preview: This command updates the preview window if you have edited the contents of the 

active window.

For more information, see Navigator Preview (2D).
ARCHICAD 24 Reference Guide 3115



Controls User Interface Reference
The 3D Navigator Preview Palette Controls

The 3D Navigator Preview Palette is only available when working in the 3D window.

See also Navigator Preview (3D).

The options are different for Perspectives and Parallel Projections (Axonometrics).

If you are in a perspective view:

Choosing Show from Top from the pop-up at the lower right corner of the palette allows you to manipulate a 

perspective camera directly: move it around, fix the target point or the viewpoints.

Choosing Show from Side at the pop-up at the lower right corner displays only the perspective camera and 

story elevation marks. Click on the camera and hold the mouse button on the up or down arrow to adjust the 

camera’s vertical position. (The story signs will start to move in the opposite direction, simulating the effect of 

camera motion on the model.) A caret will appear in the upper or lower right corner of the preview field to 

indicate when the camera position has reached the top or bottom of the model.
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The double-arrow at the bottom of the window enables you to adjust the camera position from story to story 

(up or down) with just one click.

Click and drag the camera’s arrow to adjust the camera’s tilt.

Use the sliding arrow at the bottom of the window to adjust the camera’s view cone.

For axonometric views, only the small house representing the model is displayed when showing the Top 

view. The controls resemble those of the Parallel Projection Settings dialog box.

For more information, see 3D Projection Settings.
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Choosing Show Actual Preview displays the current content of the 3D Window. In this case, all zooming 

controls are disabled. To refresh the preview of the current 3D view, double-click it or choose Redraw 

Preview. Redraw all previews will redraw the 3D Navigator Preview picture of each 3D view.
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Control Box

Note: The Control Box is not visible by default. It is available at Window > Palettes.

Use the context menu to display this palette in horizontal/vertical or extended/compact form.

The Control Box contains a number of drawing aids in the form of icons.

Use the OK button to confirm the current operation.

Use the Cancel button to abandon the current operation.

The palette’s controls, from left to right:

Guide Lines On/Off

Click the toggle icon in the Control Box to turn Guide Lines display on and off.

Guide Lines Options

Click the pop-up menu to access Guide Line-related commands.

• Create Guide Line Segment

• Remove all Guide Lines

• Erase Guide Lines

Relative Construction Methods

The Relative Construction Methods help geometric input by constraining the cursor’s movement to a constant 

angle or distance as you draft or edit elements.

Click the pop-up arrow in the Control Box to access the seven different Relative Construction Method icons.

The Parallel, Perpendicular and Angle Bisector methods constrain the cursor’s movement to a constant 

angle.

• Perpendicular: Select an existing edge for a reference line by clicking on it, or draw a new reference line 

(oriented as needed) using the cursor. Draw the new element perpendicular to the reference line you 

defined.

• Parallel: Select an existing edge for a reference line by clicking on it, or draw a new reference line 

(oriented as needed) using the cursor. Draw the new element parallel to the reference line you defined.

See Parallel and Perpendicular Constraints for more information.

• Angle Bisector Constraint: Define reference vectors; use the same process as with angle dimensioning. 

Click to start drawing the new element. The mouse is constrained to the bisectorial angle.

See Angle Bisector Constraint for more information.
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Use the Offset and the Multiple Offset methods to create a polygonal element that is offset from a reference 

line.

See Offset and Multiple Offset Constraints (Relative Construction Methods).

• The Special Snap Vector method lets you draw a temporary vector that displays your defined special 

snap points, to aid in accurate placement of elements.

See Snap Points on Temporary Vector.

• The Align to Surface method works in 3D only.

Select an existing surface by clicking on it. Place the element on the section line of the input plane, and 

the surface you defined.

For more information, see Aligning Elements to a Surface in 3D.

Cursor Snap Variants

This set of icons controls the way the current position of the cursor is projected on the rubber band line 

constrained to a predefined direction. Cursor Snap becomes active when you start drawing a vector.

For more information, see Projection of Cursor with Mouse Constraints.

Enable/Suspend Groups

These two icons act as a toggle and have the same effect as the Suspend Groups toggle command. If 

Suspend Groups is active, grouped elements can be selected and edited one by one.

For more information, see Group Elements.

Magic Wand

With the Magic Wand feature, ARCHICAD allows you to trace the outline of shapes for creating elements. 

Effect of Magic Wand depends on Tool and construction method selections.

For more information, see Magic Wand.

Snap Points (Control Box)

Use this toggle to activate Snap Guides and Snap Points.

For more information, see Snap Guides and Snap Points.
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Coordinates Palette

Note: The Coordinates Palette is not visible by default. To show it, choose its name from the Window > 

Palettes menu.

Use the context menu to display this palette in horizontal/vertical or extended/compact form.

From left to right, the Coordinates Palette contains the following controls:

• User Origin: Resets the zero point to a user-defined location. Click this button and place the Origin 

anywhere on the Floor Plan.

Note: To return the User Origin to the Project Origin, double-click the User Origin button.

For more information, see Origins.

• Set Rotated Grid: Click Rotated Grid button, then draw a vector on the Floor Plan to specify the angle of 

the rotated grid. Note: To return to the ‘normal’ grid, use the Grid Switch button.

• Switch Orthogonal/Rotated Grid: Select the Rotated Grid option to switch to the rotated grid or the 

Normal Grid option to switch to the horizontal/vertical grid.

• Grid Snap: Select one of these three options to control Grid Snapping: 

- Grid Snapping OFF

- Snapping to the Snap Grid

- Snapping to the Construction Grid

For more information, see Snap to Grid.

• Absolute/Relative: Switch the delta button ON to display and enter relative X and Y coordinates (for 

Cartesian coordinates) and radial/angle coordinates (for polar coordinates).

Absolute values show the horizontal, vertical, radial and angular distance of the cursor from the Project 

Origin or a User Origin but never from an Edit Origin.

Relative values show the horizontal, vertical, radial and angular position of the cursor relative either to 

the Project Origin, to a User Origin before any element is begun, or to an Edit Origin once a drafting or 

editing process is under way.

In general, viewing Absolute Cartesian and Relative Polar coordinates provides the most information, and is 

the most useful under normal circumstances.

• Gravity: Optionally, choose to place elements atop Slabs, Meshes, Shells and Roofs.

See Gravity.

• Elevation: The “z” field in the Coordinates Palette displays the elevation at which elements will be placed. 

The pop-up lets you define the reference level from which this value should be measured: the Project 

Zero, the current Story (or in 3D, the User Origin), or one of the optional Reference Levels defined in 

Options > Project Preferences > Reference Levels.

See Reference Levels Preferences.
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Search and Replace Text Dialog Box

The Edit > Search and Replace Text command can search texts in all eligible element types. It works on the 

Floor Plan and in Section/Elevation/IE, and Detail and Worksheet windows, and on Layouts.

See also Search and Replace Text.

The dialog box it opens has two modes: Novice and Expert. By default, the Novice mode is displayed.

• Find Text that contains: Enter the text to search for. Search criteria can be changed in Expert mode.

• Replace all with: Type replace string to be applied if you click Replace All

Clicking the Filters button opens a further dialog box in which you can set Element, Layer and Story filters.

Search on:

• Current Viewpoint: Click this radio button to restrict searching to the current story.

• All Viewpoints: Click this radio button to search on all stories.

• Visible Layers: By default, only visible layers are searched. To enable the All layers option, first click 

“Include uneditable elements.”

• All Layers: Click this radio button to search on all layers.

Search in:

• Include uneditable Elements: Check this box if you wish to extend search possibilities to three new 

filters: Dimensions Measured Text; Associative Labels; and to all layers, including invisible ones. (You 

must mark the filters to include them in the search.)

• Text blocks: Check this box to include Text blocks in the search.

• Labels: Check this box to include Labels in the search.

• Dimensions Custom Text: Check this box to include Custom Dimension Texts in the search.

• Doors/Windows: Check this box to include Doors/Windows in the search.

• Zones: Check this box to include Zones in the search.

• Associative Labels: Check this box to include Associative Labels in the search. (Available only if 

“Include uneditable Elements” is checked.)

• Dimensions Measured Value: Check this box to include Measured Dimension Values in the search. 

(Available only if “Include uneditable Elements” is checked.)

• Objects/Lamps: Check this box to include Objects/Lamps in the search.

When you have made your choices here, click OK to return to the main dialog box.

• Case sensitive: Check this box for case sensitive searching.
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• Find text that... the specified string: Select search criterion from the list.

• If you click Replace All, all found texts will be automatically replaced.

• If you click Start Search, a Window will appear listing all found texts.

Search & Replace Results

• Found Elements that contains: The original search criterion

• Replace Texts that contain: Type text to be substituted when you replace selected Hit list items

• With: Type text to substitute when you replace selected Hit list items.

• Hits: This field contains the Hit list. Editable list items are in black, read-only text items are grayed out. 

You can start to edit a text by double-clicking it. Recently changed items are in Italic, they will turn back to 

plain when you apply changes.

• Replace: Click Replace to change all text selected in the list.

• Zoom in: Click here to zoom in on the first selected element on the list.

• Zoom out: Click here to zoom out.

• Apply Changes: Click Apply Changes to actually perform changes made in this list in ARCHICAD.

• By clicking New Search, the list will disappear and you can start a new search.
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Formatting Palette and Text Editor Controls

The Text Editor and Formatting Palette appears as soon as you click on the Floor Plan (with the Text tool 

active) and begin typing into the text box.

Use these controls to format individual characters, lines and paragraphs that have been typed into your text 

block, or to switch styles while typing.

The controls of the Formatting Palette and Text Editor apply only to the text you are entering in the Text Editor, 

or to selections inside the Text Editor.

The position of the Formatting palette can be customized using the “Position of Text Formatting Palette” 

controls in Options > Work Environment > Dialog Boxes and Palettes.

The Info Box is grayed while you are in the Text Editor.

Formatting Palette

The Formatting Palette appears:

– when you are entering text into the Text Editor

– by double-clicking inside an existing text block with the Arrow tool in Quick Selection mode

– by selecting an existing text block (with the Text tool active) and clicking inside the text

Use the Formatting Palette to apply formatting to selected characters or paragraphs in the text editor, or to 

insert text symbols. 

By selecting and formatting different segments of the text blocks, you can have multistyle formatting within a 

single text block.

Note: If the selected text contains multiple styles, the Formatting Palette settings reflect the formatting of 

the first character in the selection.

Choose Favorites: This pop-up contains a list of Text Settings that you have saved as favorites, as well as 

the default settings. If you have not saved any favorite Text Settings, this button is gray.

To apply text settings saved as Favorites, select text inside the text editor and click on the stored Favorite 

from the pop-up list.

Note: Only the text-specific settings of the Favorite can be applied to selected text in the Text Editor.

To apply Favorite settings to the entire text block, use the Favorites button at the top of Text Tool Settings.

Note: Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill 

Text.

For more information, see Favorites.
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Insert Autotext: Use this control to open a dialog box to choose from available Autotext categories and items. 

The Preview area depicts the selected Autotext.

See also Autotext.

Insert Symbol: Click this button to access a Character Map (Character Palette on Mac) to choose and insert 

a symbol.

Alignment Buttons: (left, center, right, justify): to set particular alignments for the selected paragraph within 

your text block.

Leading: Use this control to modify the leading value (in percentage) for a selected line in the text block. 

Enter a number or use the up-and-down arrows to change the value in increments of 25 percent.

Note: In Windows, if you enter a leading value of less than 100 percent, the text in your text editor will not 

reflect this accurately (it will still appear as if your line spacing were set to 100 percent). However, your 

text will be displayed correctly on screen.

Superscript/Subscript/Strikethrough: Click either Superscript or Subscript to raise or lower the typed text 

compared to the text line. Strikethrough will draw a line through the text.

Text format for selected text: Set font, font size, character style or font color for any one or more characters 

or paragraphs that you select inside the text block.

Note: If you use the “Automatic pen color visibility adjustment for Model Views” feature (Options > Work 

Environment > On-Screen Options), the text in the text editor will reflect this (modified) color.

For more information, see More Options.

Text Editor

The text editor appears (together with the Formatting Palette) every time you activate the Text tool and place 

a text block in the project. The flashing cursor indicates your place in the text editor.

The background color of the text editor is the same color as the text block’s background.
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Setting Indents and Tabs

When creating a new “breaking” text block, indents appear in the ruler of the Text Editor:

At left, the first-line indent marker (on top) and the left-side indent marker (on the bottom)

At right, the indent that shows the width of the text block.

To reposition these indents, just click and drag them to the desired position.

Set a new tab stop by clicking on the ruler. Drag it to a new position as needed. To delete a tab, click and drag 

it off the ruler entirely.

Alternatively, you can use the Indents and Tabs commands:

1. Click inside the paragraph whose indents or tabs you want to set or edit.

2. Choose the Indents and Tabs command from a context menu opened by right-clicking on the Text 

Editor’s ruler bar.

The Indents and Tabs dialog box appears, where you can enter values for indents of the first line, left side 

and right side of the text block. You can set new tabs: click the New button and enter a desired value. To 

modify tabs, select the existing value and enter a different one in the Tabs fields.

Note: Depending on the unit set in Options > Project Preferences > Working Units, you may set values 

in centimeter (cm) or inches (in).
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Renovation Palette

The Renovation Palette can be opened from Window > Palettes > Renovation Palette.

Use the Renovation Palette:

• to assign a Renovation Status to any number of selected elements

• to set a default Renovation Status for newly placed elements

• to switch the Renovation Filter of the current view

• to limit a selected element to a single Renovation Filter only

For general information on this feature, see Renovation.

Assign Renovation Status to Selected Element(s)

1. Select one or more elements to which you want to assign a different renovation status.

2. From the Renovation Palette, click the icon representing the status you need.

• Existing Element: to be retained

• New Element: constructed during the current renovation process; to be retained

• To Be Demolished Element: to be demolished during the current renovation process

Assign Default Renovation Status

1. With nothing selected, click the icon of the Renovation Status you wish to be the default - for example, 

“New.”

2. Now, all elements you place - regardless of which tool you use - will automatically be assigned the “New” 

status.
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Switch Renovation Filter

From the Renovation Palette, click the desired filter from the Renovation Filter pop-up:

You can also use the Quick Options Palette to switch the Renovation Filter in effect.

Show on Current Renovation Filter Only

Use the icon at the top right of the Renovation Palette to limit a selected element to the Renovation Filter 

currently in effect.

See Show an Element in a Single Renovation Filter Only.
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Teamwork Palette

Open this palette either from the Teamwork menu, or from Windows > Palettes.

If you are not joined in to a Teamwork project, the controls of this palette are gray.

In Teamwork, availability of the controls of this palette also varies depending on whether you are Online or 

Offline; and whether you have the rights of a Server or Project Administrator.

See Working Online/Offline in Teamwork.

The top of the palette shows the User name and the user’s online/offline status.

If there is a problem with the server connection, click Network Diagnostic to open a dialog box with details 

and help in solving the problem. 

See Network Diagnostic Information (BIMcloud).

To work offline, click “Work Offline” from the pop-up.

The Show New Message Alert option is enabled by default. This means that a temporary on-screen alert 

appears each time you receive a new Teamwork message.

See also Messaging (Teamwork).

The Teamwork palette has four panels: Workspace; Users; Messages; and Project Changes.
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Workspace Panel

Send & Receive: Click this button to both Send and Receive project changes to/from the BIMcloud.

Click the pop-up to access separate Send and Receive commands.

• Send means that all modifications that you have made since your last send/receive are merged with the 

project data on the BIMcloud.

• Receive means that all modifications in the server’s project data that have occurred since your last 

“Receive” are merged with your local copy.

Note: No conflicts can arise between edits in your local copy and edits to the server’s project data, 

because you must reserve elements/data in order to modify them, and you cannot reserve elements/data 

until they are first synchronized with the server’s project data.

• Send Changes & Comment: This option lets you add a comment to the Activities Panel of BIMcloud 

Manager, in addition to Sending in your changes.

See Add Comment to Activities (Teamwork).

• Send & Receive/Receive, then Compare: These commands start the Model Compare process after 

Receive, so you can visualize what changed in the model as a result of Receive.

See Compare Teamwork Model Versions (Before and After Receiving Changes).

Reserve: This button takes several forms depending on whether you have selected an element, and its 

reservation status.

• If nothing is selected: The button says “Reserve...” and will take you to the Reserve Elements dialog box.

See Reserve Elements by Criteria (Teamwork).
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• If you have selected elements that are, at least in part, free for reservation: The button says Reserve. 

After you issue this command, the available selected elements will be reserved for you. If any selected 

element could not be reserved, you are informed of the results.

See Reservation Results (Teamwork).

• If you have selected elements which are all unavailable, the command changes to Request. Clicking this 

starts the Ownership Request process.

See Request Elements or Project Data (Teamwork).

Release/Release All: If you have selected items reserved by you, the Release button will release them. 

Release All is available when nothing is selected; this command will release all of your reservations.

Two additional commands are available from the Teamwork Palette’s Release pop-up:

• Release (All or Selected Elements) and Comment: This option lets you add a comment to the Activities 

Panel of BIMcloud Manager, in addition to Releasing your reservations.

• Release All Unmodified Elements: This will release those of your reserved items that you have not 

modified.

Colored Workspaces: Use this drop-down to choose a method for distinguishing project elements by color 

depending on who owns them.

For details, see Colored Workspaces.
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My Workspace: Click this button for an overview of all project items (both elements and non-elements) 

reserved by you.

Select any item in the list and click Show (to zoom to elements) or Open (to open the relevant dialog box).

Click Release to release the selected item.

See Review Your Workspace (Teamwork).

Users

This panel lists the users who are currently joined in to the project. If the user is currently offline, the “person” 

icon to the left of the name is grayed. The color accompanying each user name can be used to identify his/her 

elements on your screen.

See “Show Reservations by Users” at Colored Workspaces.
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The icon buttons on the Users panel, from left:

Force Leave

For information, see Force Leave.

Send Message

For information, see Create a New Message (Teamwork).

Set User Color

For information, see Redefine User Colors Locally.

Messages Panel

This panel has three tabs. Click the three icons at the top to view the tab you need:

• The To Do list shows you items which await action from you.

• The Pending Requests list stores request messages sent by you, which are still pending.

• The Completed list is a repository of messaging actions that are no longer pending and no longer require 

action by you.
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For any selected message, click the black arrow on the right to bring up a list of possible actions related to the 

message.

At the bottom of this panel, three icons represent three available actions for the selected mail message:

• Send New Message: Click to create a new message.

• Reply Message: Click to send a reply to the selected message.

• Move to Completed: Click to move this message into the Completed list.

• Delete Message (available only on the Completed list): Click to delete message.

Project Changes Panel

See View and Manage Tracked Changes.
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Project Info

The Project Info command from File > Info opens a dialog box which enables you to enter information about 

the currently opened project. Select an item, then enter the desired information in the field.

If you need more space, click the three dots (...) at the right end of the field to access a Description field.
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For some fields (e.g. Site Full Address) more complete entry fields are available when you click the three dots:

Defined Project Info items are available for use as AutoText entries in Text Blocks, in both Model Views and 

Layouts.

For more information, see Autotext.

Use the buttons at right to manage Project Info entries.

• Add: Click to add a new custom Project Info entry to the currently selected group.

• Remove: Click to delete the selected Project Info item. (Only custom entries can be deleted.)

• Import: Click to load another Project Info .xml file. A file directory dialog box appears, letting you choose 

the desired .xml file.

Note: If you load a new Project Info file into your current project, all existing AutoText entries will be 

overwritten by the data in the imported Project Info file.

• Export: Click this button to save the current project info data as an .xml file. A file directory dialog box 

appears, letting you choose the path for the .xml file. You can then load this file into any other ARCHICAD 

project. This can be useful when setting up company-standard Project Info data.
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Project Notes

Access this window by choosing the File > Info > Project Notes command. Whenever you open it, the date 

and time will be updated.

It works like a note pad, where you can:

• Enter written notes about the project or comments for fellow designers.

• Keep track of the time spent on a particular job.

Any text entered here is saved with your project.

If you are signed into a Teamwork Project, the Project Notes window is not active; instead, Teamwork > 

Teamwork Comments and Log serves the same function.

See also Editing Commands in Text-Type Windows.
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Project Preview

Set an optional Project Preview image to help identify the project 

• at File > Open

• in the Start ARCHICAD dialog box

• when browsing for a project in file systems

1. Create an image or view to be the Project Preview. Do any of the following:

– Copy any image to your clipboard

– Set up the desired project view

– Create a Rendered view of your project and save the image

2. Go to File > Info > Project Preview & Architect Credits in BIMx.

3. Click on the Project Preview tab.

4. Use one of these commands to create the desired preview:

– Paste from Clipboard

– From the dropdown list of project tabs, click to select a view

– From the dropdown, click Browse and select a saved image

– Drag & Drop a saved image file 

Notes:

– Any size and resolution image can be used.

– If you drag and drop, make sure the image is in JPEG format.

On Windows:

Project Preview image serves as the icon for the project file in Windows Explorer, replacing the standard 

ARCHICAD icon.
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On Mac:

The model’s preview picture is visible in the Finder in the following locations:

• Finder window (Icon view)

• Finder window (Cover Flow view)

• Get Info window preview

• Quick Look window appearing for multiple selected elements (Thumbnail view)

Related Topic:

Architect Credits in BIMx
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Architect Credits in BIMx

When navigating in BIMx, you have the option to display the logo of the architectural company who designed 

the project.

This information must be set up in ARCHICAD, before you save or upload the BIMx Hyper-model.

Define Architect Credits in ARCHICAD

1. Go to File > Info > Project Preview & Architect Credits in BIMx.

Note: This dialog also opens automatically from Publishing Properties - see below.

2. Click on the Architect Credits in BIMx tab.

3. Click in the “Display text” field to enter the text you want to see in Architect Credits, below the logo. It will 

work as a link to the website's URL.

4. In the URL field, enter the firm’s URL address.

– The URL must be a fully qualified URL that contains http:// 

– Example: http://www.graphisoft.com/

5. Use Browse, Drag and Drop, or Copy-Paste to add an image file of the firm’s logo to the Logo field:

Tip: To make the background transparent, use a PNG file with an alpha channel.
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Add Architect Credits to BIMx Hyper-model

In Publisher Set Properties: When you set options to Save or Upload BIMx Hyper-Model, check the Architect 

Credits box.

See also Step 2: Set Publishing Properties.

The logo will appear as part of an animation when the Hyper-model is opened in the BIMx application. A user 

click on the logo will open the corresponding company web page (based on the URL defined in ARCHICAD.)

Read More on Help Center

Related Topic:

Project Preview
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Session Report Window

The Report window displays information about the imaging and listing process.

Open Session Report

Use File > Info > Session Report.

The Session Report is also accessible from the Action Center (File > Info > Action Center), which alerts you 

if the Report contains any issue requiring user action.

Enable Session Report (Work Environment)

To create Session Reports, make sure that the Write Report option is checked, at:

Options > Work Environment > Model Rebuild Options > 3D and Calculation Process Check Controls

It is checked by default.

Contents of Report Window 

The Report Window shows info on:

• Imaging processes

• Calculation processes

• Input/output operations

• Name and version number of newly loaded Add-Ons

You can use the report to keep track of and compare imaging time for different images. 

New information is always added to the end of the report. 

The Report is cleared when you close the Project. If you wish to preserve it, save it as a text file.

Related Topics:

3D and Calculation Process Check Controls

Action Center
ARCHICAD 24 Reference Guide 3143



Controls User Interface Reference
Solid Element Operations Palette

For more information, see Solid Element Operations.

The Design > Solid Element Operations command opens this floating palette.

New Operation Panel

Use the controls in this panel to set up and execute a Solid Element Operation.

• Get Target Elements: Click to store the selected objects as Target Elements. They are now stored as 

Target Elements (even after you deselect them) as long as the Solid Element Operations palette remains 

open.

Note: If you selected the Target elements in the 3D Window, they may not all belong to the same Story. In 

this case, a warning will inform you about this.

To select the stored target elements again if you have deselected them, click the Select Stored Targets 

button.

Note: If you then select another element and click the Get Target Elements button again, it will replace the 

stored selection.

• Get Operator Elements: Click to store the selected objects as Operators. You do not need to perform this 

selection in the same window as you did for the Targets; you can select the Target on one story and the 

Operator on another one.

To select the stored target elements again if you have deselected them, click the Select Stored operators 

button.
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• Choose an operation: Click to select the desired operation type between Target and Operator elements.

• New Surfaces of Target will: Specify whether the new surfaces of Target Elements will use the Target 

Element surface attributes, or whether they will inherit the Operator Elements’ surface attributes.

Inherit Attributes of Operator: Choose to define attributes of the new surfaces as those of the Operator 

Elements.

Use Their Own Attributes: Choose to define attributes of the new surfaces as those of the Target 

Elements.

• Execute: Click to create a Solid Operation Link between the stored Operator and Target Elements.

Maintain Operations Panel

Maintain Operations: Use the controls in this panel to verify, edit and cancel already existing Solid 

Operations. These controls affect elements that have been linked via a completed Solid Operation, and have 

no connection to the settings of the New Operation panel above.

Add to Selection

If you have selected an element that has participated in a Solid Element Operation, use the following two 

buttons to add more elements to the selection: those which are either the targets or the operators of the 

selected elements. You can click both buttons in succession; this will select all the targets and all the 

operators of the linked Solid Element Operation.

• Targets of Selected Elements: Click this button to add elements to the current selection which are 

targets of the selected element.

• Operators of Selected Elements: Click this button to add elements to the current selection which are 

operators on the selected element.

Cancel Operations of Selected Elements

• All Targets: Click this button to cancel any links that may exist between the selected operators and their 

targets (if any).

• All Operators: Click this button to cancel any links that may exist between the selected target elements 

and their operators (if any).

• All Other Selected Elements: The current selection may contain elements linked to each other by a solid 

operation. Click this button to cancel these links.
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Classic 3D Navigation Toolbar

If you prefer to use the 3D navigation controls of ARCHICAD 9 and earlier, activate the Window > Toolbars > 

Classic 3D Navigation command. The commands specific to this toolbar are: 

• 3D Edit icon: represented by an Arrow-Wall-Slab combination; with this mode on, 3D construction Tools 

can be used and the elements edited.

• Walk: Walk tool with Camera mode. Move back and forth and turn around.

• Lateral Move: Lateral Move tool with Camera mode. Move up and down and laterally to the left or right, 

but keep looking in the same direction.

• Turn: Turn tool with Camera mode. Stand still and look around in all directions.

• Look To: Interactively set the target point for the perspective.

• Lock Target Point: In the middle of the image, a rectangle will appear. This is the “neutral area”. If you 

click anywhere between the rectangle and the window border, you will begin moving. Click at the top or 

bottom for one kind of movement, to the left or right for another, and in the corner areas for a combination 

of the two.

Click close to the rectangle to move slowly, close to the window’s border to move fast. To move at a 

constant speed, keep the mouse pressed. Drag the pointer around to increase or decrease speed and 

change directions. For extreme speed, drag the cursor out of the 3D Window as far as your screen size 

permits.

If there are individually selected elements in the 3D Window when you start navigating, only these 

elements will be displayed as you move. This feature can be extremely helpful with large projects. It also 

allows you to analyze one or several elements on their own, without their environment.

• Look to Perpendicular of Clicked Surface: Switch to a view perpendicular to a given point.

• Reset Roll Angle: Reset the roll angle to zero to rapidly return from a bizarre view obtained during 

navigation.

• Horizontal View: Return with a single command to a horizontal view of the model.
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Dialog Boxes

This section describes ARCHICAD’s dialog boxes and palettes in detail. The list on this page is divided into 

five categories to help you navigate to the dialog box you need.

Other interface item descriptions can be found:

• in Tool Settings Dialog Boxes; and

• in Controls.

Configuration and Attributes

Work Environment Dialog Box

Working Units

Project Preferences Dialog Boxes

Layer Settings Dialog Box

Lines Dialog Box

Building Materials Dialog Box

Fills

Composite Structures Dialog Box

Pens & Color Dialog Box

Surfaces Dialog Box

Surfaces (Cineware)

Cineware Surface Channels

Add-On Manager

Working in Model Views

Story Settings Dialog Box

Edit Elements by Stories Dialog Box

Floor Plan Cut Plane Settings Dialog Box

Copy Dialog Box

Linework Consolidation Settings

Fill Consolidation Settings

Model View Options for Construction Elements

Stair Options

Detail Level of Stair and Railing Symbols

Detail Level of Door, Window and Skylight Symbols

Miscellaneous Settings for Library Parts

3D Document Settings

Filter and Cut Elements in 3D Dialog Box

3D Styles

Open GL Options

3D Projection Settings

Sunlight Settings

RoofMaker Settings

TrussMaker Settings

Grid System Settings
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GDL (Geometric Description Language)

Scheme Settings Dialog Box (Interactive Schedule)

Index Settings Dialog Box

View Settings Dialog Box

Book Settings Dialog Box

Subset Settings Dialog Box

Layout Settings

Import Views from ARCHICAD Project

Master Layout Settings

Drawing Manager

Output and Imaging

Paste Options Dialog Box

Print 2D Document

Print 3D Document

Print Picture

Print Layout

Plot Setup

Plot 2D Document

Plot Layout

PhotoRendering Settings

Interoperability

XREF Management Dialog Box

DXF/DWG Translation Setup

Merge DXF-DWG
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ARCHICAD License Not Found

This dialog box appears upon starting ARCHICAD only if you do not have an accessible license.

• If you have purchased a commercial license but it has not been activated or is unavailable, click 

Troubleshoot Commercial License to find out what to do.

• If you don’t have a license at all, you can continue in Demo Mode: choose Run without a license.

• Otherwise, you can opt to use an Education or Trial license.

See ARCHICAD License Types.
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Work Environment Dialog Box

As you get used to working with ARCHICAD, you will develop personal preferences for using the program’s 

features and arranging the various palettes, toolbars and menus on screen. You will set most of these options 

in the many sub-dialog boxes opened from the Work Environment dialog box at Options > Work 

Environment > Work Environment.

You can customize any of these settings while you work: just open the needed dialog box, change the setting, 

and press OK. The setting will take effect.

Read More on Help Center

Each setting of the Work Environment dialog boxes is described in the sections below:

Dialog Boxes and Palettes

Selection and Element Information

Tracker and Coordinate Input

Input Constraints and Guides Dialog Box

Model Rebuild Options

Publisher

More Options

Advanced Redraw Options

On-Screen Options
ARCHICAD 24 Reference Guide 3150

http://helpcenter.graphisoft.com/?p=25953


Dialog Boxes User Interface Reference
Data Safety & Integrity

Network And Update

Special Folders

Shortcut Customization Dialog Box

Toolbox Customization Dialog Box

Tool Settings Dialog Box Customization

Info Box Customization Dialog Box

Toolbar Customization Dialog Box

Menu Customization Dialog Box

Saving Your Customized Work Environment

If you have customized a number of settings in Options > Work Environment, you may wish to save them 

for future use in other projects, so that your personalized Work Environment is ready for you when you start to 

work.

Individual settings are organized into six Schemes; saving your settings occurs at the Scheme level. Work 

Environment Schemes are saved in a local folder on your computer (not with the project file). You can store, 

import and export any or all of the scheme files.

See Work Environment Schemes for more information.

You can also combine any of the schemes into a Profile, and store the Profile under its own name. Profiles 

themselves do not contain settings; they are just a collection of schemes. Use Options > Work Environment 

> Work Environment Profiles to export and import profiles to/from folders of your choice. 

See Work Environment Profiles for more information.

It is entirely possible to use ARCHICAD successfully without saving schemes and profiles; you can just adjust 

settings as you work. However, the option to save settings according to named schemes, and then to combine 

schemes into profiles, is useful for CAD managers, for offices working in teams, and for individual users who 

might want to alternate among several different sets of customized settings.

Creating an Office-Standard Work Environment

CAD managers can create office-standard Work Environment Profiles and install them as defaults when 

installing the ARCHICAD program at multiple workstations.

For more information, see Network Installation for BIM Managers.
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Work Environment Schemes

Work Environment settings (Options > Work Environment) are divided into six self-contained schemes. 

Each scheme is a thematic collection of settings.

• User Preference Schemes

• Company Standard Schemes

• Shortcut Schemes

• Tool Schemes

• Command Layout Schemes

• Workspace Schemes

The settings belonging to each scheme are set in the dialog boxes that belong to them. See the description of 

each dialog box for info on all of these settings.

Exception: Workspace Schemes consist of your workspace configuration. 

For more information, see Workspace Schemes.

As soon as you make a change to any Work Environment setting, the scheme name at the top of the settings 

page changes to Custom:
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When you finish making changes, press OK to close the dialog box and apply current settings.

The latest Custom settings will remain intact even after you close and restart ARCHICAD.

However, every new settings change redefines the “Custom” scheme according to your latest change. If you 

want to keep your modifications saved on the long term, it is advisable to store the settings of your Custom 

scheme in a named scheme, using the Scheme Options dialog box.

Scheme Options Dialog Box

The Scheme Options screen appears in the Work Environment dialog box (Options > Work Environment) 

if you have selected one of the six scheme sets from the tree structure at the left side of the dialog box. There 

is one Scheme Options page for each of the six schemes.
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Stored Schemes: This list shows all the Schemes stored for the currently selected Work Environment 

Profiles. Select the Scheme you wish to apply, rename or delete.

Note: A lock icon next to the scheme name means that the file is read-only; the profile is locked. It is not 

possible to edit or delete locked schemes.

Store a Scheme

Click Store as to enter a name and save settings of the currently selected Work Environment component into 

a Scheme. Each scheme must have a unique name.

Apply a Scheme

To apply a stored scheme, do one of the following: 

• At the top of any of Work Environment settings pages, choose the desired scheme from the Apply 

Scheme pop-up:

• On the Scheme Options page of Work Environment: choose one of the defined schemes, then either 

double-click it, or click the Apply Scheme button.

• At the top left of any of the Work Environment settings pages, use the Apply Schemes of Profile pop-up, 

choose one of the project’s defined profiles, and click it to apply all of its schemes.

Once you apply the scheme and press OK to close the Work Environment dialog box, your ARCHICAD 

program will adjust itself to reflect the settings you have stored in that scheme.
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Rename: Use the Rename Scheme dialog box to give the selected scheme a new name.

Delete: Click this button to delete selected Scheme and the settings stored in it.

Redefine: To redefine a selected scheme according to current settings, use the Redefine command. In effect, 

you will replace the stored settings with the latest Custom settings.

Export/Import Schemes

To make your schemes available to a network or other users, or to transfer them to another computer, use the 

Scheme Options page to export and import schemes to/from folders of your choice. Schemes can also be 

exported/imported as a group, when combined into a Profile.

Note: While you can import/export Work Environment schemes among computers using varying 

operating systems, this is not recommended, because - due to the differences between Windows and Mac 

- some of the imported shortcuts, menus and Workspace schemes may not correspond to your system 

standards.

– When transferring Workspace Schemes from Windows to Mac, the Application Frame will always be 

enabled

– There is one key difference between Mac and PC menus: the Mac has a customizable ARCHICAD 

(system) menu. Transferring this menu to Windows will result in a new menu to the left of the File 

menu. This “no name” menu should be kept and not renamed. If you delete it, another will be created 

automatically.

You can also set certain schemes as defaults and have users load these defaults during start-up from a 

predefined server location.

For more information, see the Network Installation for BIM Managers.

Export: Enter a name for the exported scheme, if you want to export it under a different name. Click the 

Browse button to choose a location for the scheme, then click Export.

Import: Click Browse and locate the folder you need. (Folders can be located on your hard drive or any 

network location.) When importing schemes, you must point to the folder that contains the scheme(s), not to 

the actual scheme file itself.
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If the folder contains multiple schemes, choose the one you want from the list, then click Import. The browser 

will list only those schemes that fit the scheme category you are in. (For example, you cannot import a 

Shortcut scheme into the list of Tool Schemes.)

The imported scheme will be added to the list of stored schemes in your Work Environment dialog box.

Note on Schemes with Identical Names: You can import a scheme that has the same name as a scheme 

you already have, but ARCHICAD will differentiate between them by displaying the date and time the 

scheme was created.

Workspace Schemes

These differ from the rest of the Work Environment schemes: the settings they contain are defined not in the 

Work Environment dialog box; instead, Workspace Schemes settings reflect the way you manually set up 

your palettes in your workspace.

To customize your Workspace scheme, set up your palettes, toolbars and tab bar manually in the ARCHICAD 

workspace by doing any or all of the following:

• Show or hide palettes as needed (click its name on or off from Window > Palettes)

• Show or hide toolbars as needed (click its name on or off from Window > Toolbars)

Note: While the show/hide status of a toolbar is saved in a Workspace scheme, its content is defined as 

part of a Command Layout Scheme.

• Show or hide the Tab Bar, Scrollbar and Quick Options Bar (Window > Show/Hide)

• Change the position and size of a palette by dragging the palettes to a desired position.

• Dock palettes and toolbars as needed

Use the Scheme Options page of Workspace Schemes to manage and apply Workspace Schemes. 
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Work Environment Profiles

Apply a Profile

Use Options > Work Environment > Apply Profile and choose a profile.

Save New Profile with Customized Schemes

If you have customized and saved multiple schemes, you may want to store and apply them together: in this 

case, combine any of the schemes into a Profile, and store the Profile under its own name. Using the 

ARCHICAD interface, you can export and import Profiles to use on other computers. In this operation, profiles 

are.xml files which refer to the schemes (also.xml files) contained within them.

Notes about Profiles:

• Profiles themselves do not contain settings; they are just a collection of schemes.

• A profile does not have to contain all six scheme possibilities.

• Once you start working, you don’t have to apply entire profiles at once; you can apply schemes one by 

one.

• You can save a Custom scheme as part of a profile, but the Custom scheme will be given a name when 

the profile is created.

• Schemes named “Custom” cannot be exported.
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Profile Options

To assemble any combination of schemes into a profile, open Options > Work Environment and click “Work 

Environment Profiles” (the top item in the list at the left.) This opens the Profile Options dialog page.

From the list of Stored Profiles, choose the desired Profile. Double-click to apply the profile, or click the Apply 

Schemes of Profile button.

Stored Profiles displays the list of available Profiles.

Note: A lock icon next to the profile name means that the file is read-only; the profile is locked. It is not 

possible to edit or delete locked profiles.

Clicking on any of them displays, in the window below, the Schemes stored in the selected Profile.
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Set as Default

Click this button to define the selected profile as your default profile. Henceforth, this profile will be applied if 

you choose “Default Profile” from the Set up Work Environment pop-up when starting ARCHICAD, or with the 

New & Reset All command.

New Profile

Use the New Profile dialog box to define a new profile.

• Enter the name of the new profile in the field. Each profile must have a unique name.

• Select the Schemes of the Profile: Choose the schemes you want the new profile to contain. Highlight 

each scheme type, then choose the scheme you want from the drop-down list at right. If you don’t want a 

particular scheme to be defined as part of this profile, choose “Undefined” for that scheme. When you 

apply the new profile, the “undefined” scheme’s settings will remain “as-is” or default. Any scheme in the 

new profile set to “Custom” will be stored as a scheme (and given the same name as your profile), and will 

be saved as part of your new profile. If you don’t want to include this scheme, set it to “undefined”.

Apply Schemes of Profile

Click this button to apply the Schemes stored in this Profile.
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Export Work Environment Profile

• Select a Profile and click Export. Enter a folder name in which to save the profile data. (By default, the 

folder name is identical to the profile name; but you can choose any folder name, and the folder can 

contain multiple profiles.)

Click the Browse button to choose a location for the profile folder, then click Export.
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 Import Work Environment Profile

Click Import.

From the appearing dialog, click Browse to locate the profile folder you need. If the folder contains multiple 

profiles, choose the one you want from the list, then click Import.

Note on Profiles with Identical Names: You can import a profile that has the same name as a profile you 

already have, but ARCHICAD will differentiate between them by displaying the date and time the profile 

was created.

Note: While you can import/export Work Environment schemes among computers using varying 

operating systems, this is not recommended, because - due to the differences between Windows and Mac 

- some of the imported shortcuts, menus and Workspace schemes may not correspond to your system 

standards.
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Dialog Boxes and Palettes

(Options > Work Environment > Dialog Boxes and Palettes)

This screen contains options related to the display of dialog boxes and palettes.

Dialog Box Auto-Update Delay: Enter a value in seconds for the auto-update delay time for edit text dialog 

boxes. (This is the amount of time it takes for the program to “validate” your typed entry as the desired value; 

you do not have to click “Enter”.)

Hide Locked Layers in Pop-up Palettes: This option means that locked layers will not be shown in any of 

the layer pop-up palettes.

Use Scroll Effects for Dialog Box Panel Opening (Windows Only): By default, to prevent crowding of 

dialogs when opening new panels, previously opened panels will close automatically, and the dialog box will 

move upwards on the screen. If you check this box it means that dialog box panels will “roll open” (at the 

speed you set with the slider) instead of “snapping open,” which is the effect you get if you uncheck the box.

Move up dialog box if it cannot accommodate more panels: Many dialog boxes have five or more panels 

that might not all fit on the screen if they were opened all at once. This option will move the whole dialog box 

up to make room for newly opened panels.

Close panels if the dialog box cannot accommodate more panels: This option will close one or more open 

panels to make room for newly opened panels.

Pet Palette Movement

To define the type of pet palette movement you prefer, open Options > Work Environment > Dialog Boxes 

and Palettes.
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Choose a radio button to determine whether and how your pet palettes will move around on the screen as you 

work.

• Follow Cursor: This means that the pet palette will follow your cursor around the screen as you complete 

your editing operation. (This way the editing icons on the pet palette are available right next to your cursor 

instead of at a far corner of the screen.)

• Jump to Preferred Position: This means that when you bring up a pet palette and release the mouse 

button, the pet palette jumps to one position and stays there as you complete the editing operation. If you 

want the pet palette to “stay” someplace else, drag and drop the palette to your preferred position. All 

subsequent pet palettes will appear at that preferred position. You can still move the pet palette at any 

time during your editing operation.

Distance from Cursor

Use the two slider controls to set the palette’s following distance from the cursor.

• The first slider sets the palette’s initial distance from the cursor when it first appears on screen.

• The second slider sets a minimum “following distance”: the palette will not follow the cursor until the cursor 

is at that predefined distance from the palette. (This is useful if you want to prevent the palette from 

covering up the very area that you want to edit.)

The operations that can be performed by using the pet palette are detailed in Editing Elements.

Position of Text Formatting Palette

• Above Text Editor: Check this to locate the Text Formatting Palette above the Text Editor.

• Jump to preferred position: Check this to have the Text formatting Palette jump to a preferred position. 

This means that when you bring up a the Text Formatting palette and release the mouse button, the pet 

palette jumps to one position and stays there as you complete the editing operation. If you want the 

palette to “stay” someplace else, drag and drop the palette to your preferred position. All subsequent Text 

Formatting palettes will appear at that preferred position. You can still move the palette at any time during 

your editing operation.

For more information on this palette, see Text Block Formatting Panel.

Keep ARCHICAD Palettes visible even when another application is in front (Available for Mac only): 

Check this box if you want to view any open ARCHICAD palettes while another application is in front on your 

screen.
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Show User Photos in Lists

This is a Teamwork-specific option. In Teamwork projects, this option will display the photo of joined-in users 

on the Teamwork Palette, and on the Users list when sending a message.
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Selection and Element Information

(Options > Work Environment > Selection and Element Information)

Selection Dots and Marquee Color: Click in the field to access a color pop-up and customize the color of the 

dots appearing on selected individual elements, as well as the marquee.

Editable Selection Dots Color: Click in the field to access a color pop-up and customize the color of editable 

selection dots.

For details about editable selection dots, see Graphical Editing Using Editable Hotspots.

Highlight Element Contour During Selection: Check this box if you wish to have the selected elements’ 

contours and reference lines highlighted.

Note: “Reference lines” include the reference line of a Wall or Beam, the pivot line of a Roof, and the 

profile(s) and extrusion vector or revolution axis of a Shell.

• Contour color: Choose a color for the selected elements’ contour from this pop-up palette.

• Bold contours: Check this box to display the selected elements’ contours in bold font style.

• Reference Lines in 3D: Choose a color for the selected elements’ reference lines (in the 3D window 

only).

Highlight Element Surface During Selection: Check this box to apply a highlight to the selected elements’ 

surfaces.

• Surface color: Choose a color for the selected elements’ surface color.

• Transparency: Set the transparency for shaded Open GL view here. Use the slider to set the grade of 

transparency/opacity for shaded OpenGL view.

For more information, see Selection Highlight and Element Information Highlight.

Highlight Element before selection and with Magic Wand: Check this box to highlight element contour 

lines (i.e. detection highlight) before selecting them, and when using the Magic Wand to create an element 

based on an existing element.
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• Highlight color: Choose a color for the selection highlight here.

• Bold contours: Check this box to display bold contours for the selection highlight.

• Highlight appears after: Enter a value here in seconds for the delay time before highlight appears. 

(Highlight appears immediately if you press Shift.)

Highlight Associated Element During Input and Parameter Transfer: Check this box if you wish to 

highlight related elements. During dimensioning, labeling, door/window or railing placement, or during 

parameter transfer operations, the contours of associated elements will be highlighted to help you identify 

related elements. You need not press Shift.

• Highlight color: Choose a color for the related element highlight contours here.

• Bold contours: Check this box to display bold contours for the element highlight.

Enable Element Info Tag: Check this box to enable the element information pop-up (e.g. Info Tag).

See also Element Information Pop-up (Info Tags).

• Info Tag appears after: Enter a value here in seconds for the delay time before element info pop-up 

appears.

• Show short info only: Check this box to display only short info in the element info pop-up.

• Use Tracker colors: Check this box to use the colors chosen for the Tracker in Options > Work 

Environment > Tracker and Coordinate Input.
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Tracker and Coordinate Input

(Options > Work Environment > Tracker and Coordinate Input)

For general information, see Tracker.

Show Tracker: Choose an option for preferred Tracker display: 

• Always: Select this radio button to always show the Tracker on your plan, both in 2D and in 3D, as you 

move your cursor.

• On-demand: Select this radio button to show Tracker only during coordinate input and editing operations.

Use custom appearance: Check this box to set custom color settings for the Tracker. If this box is checked, 

the three controls below will override the system color settings.

Note: These color settings also affect the interface when you work with Curtain Walls: the appearance of 

the “Edit” button and of the Curtain Wall Toolbox (visible in Edit mode).

• Text color: Choose a color from this pop-up for the foreground color (the text) of the Tracker.

• Frame color: Check this box to set a separate frame color for the Tracker.

• Fill color: Choose a color from this pop-up for the background color of the Tracker.

• Transparency: Specify the transparency of the Tracker’s background by dragging this slider.

Note: If you wish, you can apply these colors to the Element Information pop-up (Options > Work 

Environment > Selection and Element Information > Use Tracker colors).

Show Z value: Check this box to display Z value (when applicable) in the Tracker.

Show parameter tags: Check this box to show parameter tags in the Tracker. (These are the texts identifying 

the data values displayed in the tracker, e.g. “Distance”).

Coordinate input logic

This part of the panel refers to the coordinates and angles displayed in the Tracker.

See also Coordinate Input Logic: Expert Options.
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Prefer polar coordinates in Tracker during straight vector input: Check this box to prefer polar 

coordinates (D/A, or distance, angle) over X-Y coordinates in the Tracker.

Show X-Y Coordinates relative to User origin in Tracker: Check this box if you want to display absolute X-

Y coordinates in the Tracker even if you have enabled the “Relative Coordinates in Tracker” command from 

the Standard Toolbar. This way, the Tracker will display Relative polar coordinates and Absolute X-Y 

coordinates simultaneously.

Coordinate shortcuts prefer Tracker: Check this box if you want coordinate shortcuts to jump to the Tracker 

(instead of the Coordinates Palette).

Enable direct numeric input into Tracker fields: If this box is checked, numeric input during editing 

operations will be interpreted as coordinate entries into the Tracker. If this box is not checked, you must enter 

the Tracker using a coordinate shortcut or the TAB key.

Use relative angle measures: Check this box if you want the angle values in the Tracker to be measured (1) 

relative to the orthogonal grid (from 1 to 180 degrees), or (2) relative to the previous input segment during 

polygonal input.

If this box is unchecked, angle values are shown from 0 to 360 degrees.

Use angle relative to the last Snap Reference Line: If you check this box, angle values in the Tracker will 

be shown relative to the active Snap Reference. (You must first activate a Snap Reference Line for this to 

work.)

Expand Tracker automatically during numeric input: Check this box to extend the size of the Tracker 

automatically during numeric input.
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Input Constraints and Guides Dialog Box

(Options > Work Environment > Input Constraints and Guides)

Horizontal and Vertical: Check this box to constrain cursor movement to 0°, 90°, 180° and 270° from any 

Edit Origin by holding down the Shift key.

Parallel to Grid: Check this box to interpret ‘Horizontal and Vertical’ constraint in the direction of the rotated 

grid’s main axes.

Incremental Angle: Check this box to enable cursor constraint at the defined Fixed Angle from any Edit 

Origin by holding down the Shift key.

Enter an Angle value here for cursor constraint.

• Relative to Horizontal: Check this box to interpret ‘Incremental Angle’ constraint relative to the horizontal 

grid’s main axes.

• Relative to Grid: Check this box to interpret ‘Incremental Angle’ constraint relative to the rotated grid’s 

main axes.

Guide Line Color: Choose a color for the Guide Lines.

Snap Guide color: Choose a color for the Snap Guides.

Snap Point color: Use the color chooser to set a custom color for the Snap Point, if desired.

For more information, see Snap Points.

Note: Use the Q shortcut (Force Snap Reference) on any edge or point to instantly highlight an it a Snap 

Guide/Snap Point, without waiting for the predefined delay.

Autohide Snap Points: This option is checked by default. Special Snap Points (if enabled) will disappear on 

their own after a set interval. If you disable this checkbox, the snap points will remain visible until you either 

place an element or change to another view or story.

Cursor Snap Range: Enter a value here in pixels for the distance at which the cursor snaps to an element.
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Line Drawing: Set the line drawing method here by clicking one of the buttons.

Mac Classic-like: Select this option to use the standard click-drag drafting method.

Example: to draft a Line, click the Mouse button at the first endpoint, drag while holding it down and 

release at the other endpoint.

CAD-like: Select this option to use the standard CAD click-click drafting method (default).

Example: To draft a Line, click the mouse button at the first endpoint and release it, move to the other 

endpoint and click to complete the Line.

Choose your Mouse wheel scrolling preference:

• Zoom, plus Alt/Opt to Pan 

• Pan, plus Alt/Opt to zoom
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Model Rebuild Options

This dialog box (Options > Work Environment > Model Rebuild Options) provides controls that affect 

Background Updating, rebuilding the 3D and Section/Elevation/IE windows, creating reports, and dealing with 

error alerts.

Background Updating

• Enabled: This control (on by default) enables ARCHICAD to take advantage of the processor’s unused 

capacity to build up different model views in advance. Background processing also utilizes your hardware 

more efficiently. Because Background Updating keeps open model windows (or tabs) up to date, it 

enables you to switch among different views faster.

• Enabled when device is plugged in: Power save mode, recommended for mobile devices. 

Automatically suspends background updating when the device is not connected to an external power 

source. Background processing will be enabled again once you plug the device in.

• Disabled: No background updating will take place.
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Feedback in Status Bar

The status bar of your ARCHICAD window provides feedback on background processing (e.g. “Background 

Updating enabled”). By clicking on the status bar icon, you can access the three above settings and change 

them.

Auto-Rebuild Model View Control

• Update Auto-rebuild Model viewpoints continuously

If this box is checked, ARCHICAD will continuously rebuild Sections/Elevations/Interior Elevations of 

Auto-rebuild Model type to reflect your edits while you work in the viewpoint. 

However, in large projects this may cause slowdowns. In this case, try unchecking this box: as a result, 

Auto-rebuild viewpoints will be rebuilt only when you re-open the window or use the Rebuild command 

from the context menu.

3D Window Rebuild Controls

• Auto-rebuild 3D Window when activated: Checking this box means the 3D display of your plan is 

updated after each modification to the model, as soon as you activate the 3D Window.

If this box is unchecked, the 3D model does not show the modifications until you choose the View > 

Refresh > Rebuild command. Switching this option off can be useful if you want to keep an already 

existing 3D image in the window for a longer period, and you want to avoid accidentally rebuilding it.

Note: If you edit elements in an outdated 3D view, deleted elements will be visible but cannot be selected. 

Moved elements can be selected, but their selection dots are displayed at the real location and you cannot 

edit them. Modified elements can be selected and edited, but this will trigger the rebuilding of the view.

• 3D Settings changes bring 3D Window to front: Check this box if you want to activate the 3D window 

and rebuild its content every time you make a change in either 3D Projection Settings or 3D Styles.

• Keep zoomed detail on Rebuild: Check this box to preserve the last zoom made in the 3D Window even 

if you choose View > Refresh > Rebuild. If you uncheck it, the 3D Window will recreate the 3D view at 

the original zoom level.

Section Window Rebuild Control

Keep zoomed detail on Rebuild from Model: If you mark this checkbox, then the zoom level of your 

Section/Elevation/IE Window will be retained even after you execute a Rebuild command.

For more information, see Updating Sections.

3D and Calculation Process Check Controls

Show Progress Window: If this box is checked, the progress of 3D and list processing is indicated by a 

special timer. This will help you evaluate whether to cancel lengthy 3D redraws or calculations, change some 

settings (for example by selecting a smaller area, setting more specific filters or less precise imaging options 

or reducing the 3D Window’s size).

STATUS ICONS FOR BACKGROUND UPDATING

ENABLED

ENABLED IN POWER SAVE MODE

DISABLED

UPDATE IN PROGRESS
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Note: The movement of the indicator is proportional not with the elapsed time, but with the amount of data 

processed.

Interrupt with Error Messages: If this box is checked, any error messages will appear on the screen (in the 

Session Report Window) before the imaging or calculation process is completed. If the box is left unchecked, 

error reports appear only after the process is completed.

Write Report: Use this checkbox to enable or disable the creation of a report on the 3D conversion and list 

calculation processes. Use the sliding switch to set the amount of detail it should contain.

See also Session Report Window.

Selected Elements to be Calculated: This pop-up field gives you three options for handling a possible conflict 

between a listing command and items selected in the workspace.

• Select List All to calculate all selected elements in the list, even though they do not correspond to the 

filtering criteria.

• Select Use Filters to apply the filters defined for the list scheme to the selected elements. Elements that 

do not correspond to these filters will be ignored.

• Selecting Show Alert will display a warning about the situation and you will be able to choose between 

the two options above.

For more information, see Calculation (Legacy).
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Publisher

On this screen of Work Environment (Options > Work Environment > Publisher), you define options used 

by the Publisher function:

 

Publisher log location: Enter a file path, or use the Browse button to access a file directory dialog box to 

specify a file path on your system.

This path shows the save location of the publishing log file, which is generated every time you publish an 

output using the Navigator/Organizer’s Publisher map.

To view the log, click the Show the log file button.

For more information on Publisher see Publisher Function.
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More Options

(Options > Work Environment > More Options)

Create Detail/Worksheet Boundary in Detail/Worksheet Window

This box is checked by default, and each Detail or Worksheet Drawing window will include a line that 

represents the boundary you created when placing the marker. Even if such Boundaries are hidden as part of 

the Marker (View > On-Screen View Options > Marker Range), this line will be shown in the Detail/

Worksheet window.

If you do not want such a boundary in the Drawing window, disable this checkbox.

Save Navigator Preview Data with Project files

If you mark this checkbox, the saved Navigator previews will be available when you reopen your project, 

allowing for faster display of stored previews.

Notes: The Navigator Preview stores a vectorial database for the display of every window preview. A 

large project with many viewpoints will generate a large amount of such preview data. To avoid saving this 

data as part of the file, leave this box unchecked.

Assign New Element ID to Each New Element

Using this checkbox, ID numbers will automatically increase when creating a new element, provided that a 

number is included in the ID field.

For details about ID Management, see the Calculation Guide (a PDF document in the ARCHICAD > 

Documentation folder, or in the ARCHICAD Help menu).
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Enable ARCHICAD Sounds

This box is unchecked by default. If you want to hear the beeping sounds associated with ARCHICAD 

processing and certain Teamwork interactions (such as new message), check this box.

Show New Message Alert in Teamwork

Check or uncheck this box depending on whether you want a message alert to “float” across your screen 

every time you receive a message in Teamwork.

Show Tracked Changes Alert in Teamwork

Check to receive alerts of model changes for which you have subscriptions.

See also Change Tracking in Teamwork.

Use Large Alert Cues

In Teamwork: On-screen alerts (Messages, Project Changes) are displayed larger, so they are easier to 

notice.

Do not launch new instance of ARCHICAD when placing a view onto a Layout

By default, a new instance of ARCHICAD is launched when you place a view from an external project onto a 

layout in the current project. Check this box if you do not wish to launch this additional instance every time. In 

this case, the new instance of ARCHICAD will be launched only when you update the placed view.

When placing model views onto Layouts, adjust each drawing frame to show only zoomed 

area of model view

Check this box if you want the placed drawing’s frame to be adjusted to the zoomed area of the model view by 

default.

Once the zoomed view is placed, you can later opt to readjust the frame to fit other parts of the model view, 

either manually using pet palette commands, or using the Fit Frame to Drawing radio button in Drawing 

Settings.

See also Drawing Settings.

When opening another View or Layout of a similar type:

Use these checkboxes to set preferences for opening views and/or layouts in either a new or an existing tab 

(or window, if you are not using the Tab Bar):

• Open views in a new tab (or window) 

• Open layouts in a new tab (or window)

These options do not apply to Floor Plans and 3D windows, since multiple Floor Plans and 3D windows 

cannot be open simultaneously.

Show Preview in Tab Bar

Hovering over any tab displays a preview based on the tab’s last opened view. 

Launch new instance of ARCHICAD when opening a project from the recent list or by 

dragging onto a running ARCHICAD

Click this option to always start a new copy of ARCHICAD when you open a project from the “Recent list,” or 

drag a project file onto a running ARCHICAD.
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Experimental Features

One or more “experimental” features may be shown here that you can try out. Based on user feedback, these 

may or may not become part of the core ARCHICAD functionality in future versions. 

Check the box to turn on the feature.

To gauge the usefulness of this and other features, GRAPHISOFT collects anonymous usage statistics as 

part of the Customer Experience Improvement Program (CEIP), from users who allow it. If you did not enable 

CEIP when you started ARCHICAD, you are asked if you want to do so now.

Related Topics:

IFC Structural Analysis Model Import/Export - Experimental Feature
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Advanced Redraw Options

(Options > Work Environment > Advanced Redraw Options)

These options are designed for advanced-level users or IT managers familiar with processing and memory 

issues. For most users, it is sufficient to leave these settings at their default values.

Model Display in 2D Navigation

Choose from three options for displaying project elements during panning operations. (If you are experiencing 

fits and starts while navigating in a large, complex model, switching among these options can speed and 

smooth the process.)

• Simplified Model: The full model is shown in simplified version (for example, hatches are temporarily 

hidden).

• Structural Contours Only: Only the outlines of construction elements appear during a panning operation.

• Full Model: All elements are shown in full.

When you finish with the panning operation, all elements are fully displayed again.

2D Drawing Antialiasing

Check this box if you want to achieve antialiasing on line-type 2D Drawing elements.

• Mac only: Do not antialias horizontal and vertical lines. Check this box if you want to exclude 

horizontal and vertical lines from the antialiasing process.

3D OpenGL Antialiasing

Check this box if you want to achieve antialiasing in 3D, if you are using the OpenGL 3D engine. This box is 

checked by default.

2D Hardware Acceleration Level

Use the slider to adjust the level at which hardware processes (e.g. video card) are used instead of the 

software for 2D Drawing processes (e.g. lines, fills, input feedback).

To turn Hardware Acceleration off, move the slider all the way to the left.

Off: Hardware Acceleration off. 2D Drawing takes place in software-only mode.
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Level 1: 2D drawing of lines, fills, etc. occurs using the software, but certain layers of information (e.g. Floor 

Plan, Trace Reference) are constructed using the video card. If the ARCHICAD project is divided among 

several monitors, then the merging of these layers is helped to some extent by software processes.

Level 2: Both 2D drawing, including antialiasing, and the layering of information types is done using the 

hardware (video card) if the project is on a single monitor.

If the project is divided among several monitors:

• XP - processes are identical to Hardware Acceleration Level 1.

• Vista - Full hardware acceleration works, but without antialiasing (this is a technical limitation.)

Full: Full hardware mode. Regardless of the number of monitors, all 2D Drawing processes, including 

antialiasing, are done by the video card. However, the performance of certain older video cards (in terms of 

speed and memory) may be insufficient: the redrawing process must be repeated on each monitor, requiring a 

great deal of video memory.

Arbitrary Hardware Acceleration Level Decrease

If you set the Hardware Acceleration to a level that in certain situations exceeds the graphics card’s 

performance, then ARCHICAD might automatically fall back to a Hardware Acceleration Level below the one 

set up by you. The slider will not be moved by ARCHICAD but there will be a warning about this event at the 

bottom of the dialog box:

Warning: A hardware test indicates that the currently set 2D Hardware Acceleration Level exceeds the 

performance capabilities of your video card in some situations. Therefore, ARCHICAD will automatically 

switch to a lower level of 2D Hardware Acceleration.

Memory Usage

Use this slider to adjust the level of memory usage by ARCHICAD. Provided that you have enough memory 

available, and depending on your processor, increasing this value (by moving the slider to the right) may result 

in improved performance.

The Memory Usage slider defines ways of working in ARCHICAD that are not strictly related to the 2D display, 

yet might have an effect on the speed of 2D display. By default, the slider is set to Full. In this situation, when 

ARCHICAD is opened, part of the memory is reserved for indexing elements. This reserved memory enables 

ARCHICAD to accomplish various tasks - most of them affecting 2D speed - faster.

If memory usage is very high (as when working with large files) then it is advisable to move the slider to the 

left. In this case there will be less memory reserved for the indexing function, and more memory reserved for 

regular ARCHICAD functions. Note that if you are working with small files, the difference between the two 

ways of working is not noticeable. We recommend that you leave the slider on the right, in its default position, 

and only move it to the left when ARCHICAD experiences serious memory shortage problems.
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On-Screen Options

(Options > Work Environment > On-Screen Options)

This dialog box has three panels:

On-Screen Options

Workspace Colors

Energy Evaluation Model Review Colors

On-Screen Options

Show Ghost Bounding Box of Objects, Columns, Figures and Drawings

If this box is checked, the bounding box of Door, Window, Object, Lamp, Column, Figure and Drawing 

elements that you wish to place will follow the cursor.

Show Contours on Favorites and Library Part Preview

Check this option if you prefer to see contours on 3D Preview for Favorites and Library Parts. 

Display Editing Plane During Editing Operations Only

If you check this box, the 3D Window Editing Plane will appear only during the time you are actively editing in 

the 3D window (provided that the “Editing Plane Display” toggle at View > Editing Plane Display is turned 

on.) When you are done with the operation, the Editing Plane disappears.

Automatic Pen Color Visibility Adjustment for Model Views

When this box is checked, then black pens will be shown as white on your ARCHICAD screen if the luminance 

value of a particular background color falls below a threshold value - that is, if your background is sufficiently 

dark.
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Use uniform color for Master items on Layouts

Check this to display all Master items using a single color on Layouts. To choose the color, double-click the 

color field.

If you leave this box unchecked, the element’s own colors will be applied.

Use uniform color to highlight inverted elements

Check this box to display inverted or invalid elements using a single color.

To choose a color, double-click the color field. This highlight is an on-screen attribute only; it will not be seen 

on printed/published output.

Inverted or invalid elements may include

• Inverted construction elements (those whose top elevation falls below their bottom elevation, as a result of 

changing story levels affecting top linked elements)

• Stairs whose top-linked story height has changed, yet the stair parameters are defined in a way that the 

stair cannot be adjusted to the new story height automatically

• Some construction elements (e.g. Beams, Columns) in projects using the Legacy Intersection 

Preferences. If “Legacy Intersection and Surface Methods” is checked at Project Preferences, certain 

geometries (based on new tool functions in later versions of ARCHICAD) are not supported.

See Legacy Preferences.

Feedback Graphics color

Use the color chooser to set a custom color for bounding boxes and rubber band effects shown during editing 

operations.

Source Marker Color

Use the color chooser to set a custom color to highlight source markers. (To turn Source Marker Highlight on 

or off, use View > On-Screen View Options.)

For more information, see Source Marker Highlight.

Line Type and Pen of Marker Elements’ on-screen-only parts

Use these controls to set a line type and color for the on-screen parts of all marker elements. These are: 

Section Limit Line, Elevation Line, Section and Elevation Distant Line, Interior Elevation Line and Limit Line, 

and Detail/Worksheet Boundary Line.
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Workspace Colors

Teamwork

Choose preferred color for highlighting elements depending on their ownership, in Teamwork projects only.

See Colored Workspaces.

3D Compare

Set colors to display model differences in the 3D Compare window.

See Workspace Colors for Model Compare.

Issue

Set colors to display Issue elements in the model depending on their category.

See Issue Handling.
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Energy Evaluation Model Review Colors

Choose your preferred color for highlighting model structures according to their function for the Energy 

Evaluation process. (Building structures and openings are shown in these colors when you click Show in 3D 

in the Model Review palette of Energy Evaluation.)

See Customize Energy Model Review Colors.
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Data Safety & Integrity

(Options > Work Environment > Data Safety & Integrity)

Use the features of the Data Safety & Integrity dialog box (Options > Work Environment > Data Safety & 

Integrity) to minimize the risk of data loss and file corruption. This is especially important if your power lines 

suffer from voltage spikes or failures, or if your computer is prone to software conflicts.

Saving to Recovery File

The Saving to Recovery File function controls a number of options protecting you against losing work. If you 

are forced to restart your computer or the program because of a crash, then the next time you launch 

ARCHICAD, a dialog box gives you the option of resuming the interrupted work.

When Saving to Recovery File is triggered, the Bulldozer cursor may appear momentarily on the screen 

while the program saves any changes made to the Project since the last Saving to Recovery File (or manual 

Save). Even with large Projects, Saving to Recovery File should complete its cycle within a few seconds.

Saving to Recovery File Options:

• Ultra Safe: The default and recommended option. Data is saved to a recovery file after each step.

• Safe: Saves data every 5 minutes.

• Minimum Saves data every 20 minutes.

There are three limitations to Saving to Recovery File functions. The following items must be saved manually:

• Opened Library Parts
ARCHICAD 24 Reference Guide 3184



Dialog Boxes User Interface Reference
• Completed PhotoRendering Images

• All types of Calculation Lists

If ARCHICAD is restarted after a crash, it will detect the Recovery File data and prompt you to open it. The 

Recovery File is also available for opening in the Start ARCHICAD dialog.

Recovery Folder

Stores the saved documents at the specified location:

• Use Default Location, or

• Choose Location and then Browse among folders on your computer or across a network.

Changes to the settings of the Recovery Folder will take effect after the program is restarted.

Undo Limit

Set the number of undoable steps.

See also Undo/Redo.

Make Backup Copy

Mark this checkbox to create a backup copy of the previously saved version of your work, by appending the 

“.bpn” extension to its name.

For creating backups of Shared Projects, see also Teamwork.

Teamwork ‘Send’ Reminder

Check this box to have ARCHICAD automatically display an on-screen reminder to Send your changes while 

you work in Teamwork.

Enter how often the notification should appear:

• after a certain number of actions in the project, or

• after a certain number of minutes

(whichever comes first).

See Automatic Reminder to Send Changes.

Data Integrity

Hotlink Update

Controls whether ARCHICAD should check the status of Hotlink Modules whenever you begin document 

output (e.g. Publish).

• Ignore Hotlinks: Choose this option to ignore any modification made on hotlinked files. This is the fastest 

opening option for a file containing Modules.

• Check Hotlinks and ask for update confirmation: When outputting a project, ARCHICAD looks for all 

hotlinked files and checks their modification date. An alert will appear asking you to confirm whether you 

want to update modifications or not. This is the default setting in the program.

• Check and update Hotlinks automatically: When outputting a project, ARCHICAD updates all Modules 

that are hotlinked to modified files.

Should there be any problem in the course of the automatic updating process, choose the first option 

(Ignore Hotlinks), open your file again, and then update the hotlinks manually through the Hotlink Module 

Manager dialog box.
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Note: The option you choose here will be preserved in your Preferences file, but will not be saved with the 

Project.

Release All (Teamwork)

The Release All with Send Changes preference affects whether ARCHICAD will automatically release all your 

reservations whenever you Close a Teamwork project using the Send option.

See Keep or Release Your Reservations with Send & Save.

Automatically Check Status of All Hotlinks in Hotlink Module Manager

With this default setting enabled, ARCHICAD will check the status of Hotlinks each time you open Hotlink 

Module Manager. In projects with many hotlinks, the auto-check process might slow things down. In this case, 

uncheck the box.

Automatically reserve available elements when editing

Note: Not available in BIMcloud Basic.

This Teamwork feature is enabled by default. Whenever you work on an element in Teamwork, it is reserved 

by you automatically, whenever possible.

If Auto-reserve should slow down your work, you will be prompted to uncheck this feature. You can then 

Reserve elements as needed, by clicking the Reserve button in Teamwork Palette or from context menus.

Teamwork Messaging

Use this control to manage the number of stored Teamwork messages. Check the Limit Number of 

Completed Messages to box and enter the maximum number of messages you wish to store. Once you 

reach that limit, your oldest messages will be deleted.
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Network And Update

Use this screen (Options > Work Environment > Network And Update) to define options related to the 

Internet and HTML format.

HTML Output Options

Choose a style to use when saving data in HTML format, e.g., from a list-type Window in text format.

Simple: Choose this to display the HTML file without styles.

With Styles: Choose this to display the HTML file using the Style Sheet formatting below. (Click Browse 

to find and use a different style sheet.)

Style Options: Choose External if you want the resulting HTML file to include a link to the chosen Style 

Sheet. Choose Internal if you want to include the Style Sheet itself as part of the HTML file.

Check for Updates

Check this box to run an automatic check for ARCHICAD and/or Library update (Hotfix):

• Use the pop-up to set how often you want to run Check for Updates (Daily, Weekly, or Monthly.)

• Click Check Now to check for updates immediately.

• Set the components (both ARCHICAD and Library, or either one) for which you wish to Check for 

Updates.

The Action Center (File > Info > Action Center) alerts you to any available updates.

Notes on “Check for Updates” function:

– Requires internet connection

– Does not download anything to your computer automatically. It only alerts you (in Action Center) that 

an update is available.

– Provides GRAPHISOFT with automatic information about your ARCHICAD version. This information 

is limited to data needed for update; it includes no personal information.
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Always compress network traffic

This is checked by default. However, compressing data in a LAN environment might reduce performance. Use 

this option when using low bandwidth connections. (e.g. Wireless or VPN connection).

Use BIMcloud Delta Cache to optimize bandwidth usage

Enter the address of the BIMcloud Delta Cache of your office. ARCHICAD will download data from a BIMcloud 

using this BIMcloud Delta Cache.

Address format: http://proxy.address:port

Note: BIMcloud Delta Cache is used only for projects located on a BIMcloud. Not available in BIMcloud 

Basic.

Prevent macOS from automatically mounting server volumes (Mac Only)

Check this if you have a slower network connection.

Handle AFP Connections as SMB Connections (Mac Only)

Enable this checkbox to ensure that ARCHICAD uses the SMB file server protocol (not AFP) when locating 

external files (e.g. Drawings). Both protocols can still be used, but this checkbox ensures the use of SMB. 

(MacOS 10.14 supports the APFS file system, which supports the SMB protocol but not AFP).
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Special Folders

On this screen (Options > Work Environment > Special Folders), you can relocate the Temporary, Cache 

and Template Folders to a hard disk volume that is different from the default location.

Note: If you choose a custom location which is not available, ARCHICAD will use the displayed system 

default location.

When using remote network volumes, ARCHICAD’s operations may be affected by the network performance 

capabilities.

Note: If your startup volume does not have the recommended amount of free space when you launch 

ARCHICAD, you will have the opportunity (through an alert box) to select another volume during the 

startup process.

Changes to the folder location settings will take effect after the program is restarted.

 

The Temporary Folder stores data required for the quick operation of ARCHICAD.

The Cache Folder stores 3D projections, PhotoRendered images and other project data. The cache data is 

used when the program generates the image files automatically in the background and stores them in the 

chosen Cache Folder. ARCHICAD uses the Cache Folder for quick display and updating of images on the 

screen.

• On Mac, very large hard disks are recommended for advanced imaging, because the Cache Folder can 

expand greatly when rendering a very complex Project with shadow casting.

• On Windows, ARCHICAD keeps this data in the virtual memory. Set the limitation of the page file to the 

highest possible value when rendering a very complex Project with shadow casting.

The Template Folder contains template (.tpl) project files shipped with ARCHICAD. Template files do not 

contain any virtual building elements, but certain attributes and options have been pre-set.
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Shortcut Customization Dialog Box

Open Options > Work Environment > Keyboard Shortcuts.

From the list window, locate any function or command:

– by typing its name in the Search field

– or click a list format from the drop-down list.

Watch the Video

Click on any command or function to view its brief description in the field at the bottom of the list.

If the selected function/command already has a shortcut assigned to it, it is displayed in the Shortcut(s) for 

selected command window on the right.

Assign Shortcut

1. If the command already has a shortcut: Click Detach selected shortcut to remove the existing shortcut. 

– If you don’t detach it, you can still assign another shortcut; this way the function/command will have 

multiple shortcuts.
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2. Now type the keys that will constitute the new shortcut. (Use the field where it says “Click here and press 

desired shortcut keys.”) 

– Use any single letter or number character, or a function key (e.g. F2) with or without modifier keys (i.e., 

Ctrl, Shift, and/or Alt). 

3. Click Assign.

4. Click OK to close the dialog box and apply the selected shortcut scheme according to its current settings.

Shortcut Collision

If the key combination you entered has already been assigned to another function or command, this will be 

noted in the field: Currently assigned to. - In the following image, we typed F5 as a new shortcut, but this key 

has already been assigned.

In this case, you can try typing a different shortcut.

Note: No “collision” is detected if the shortcut has been assigned to commands from two different window 

types.

See Window Types (Text or Non-Text).

To assign the shortcut despite the collision, click Assign anyway. This action assigns the shortcut and 

detaches the shortcut from the function/command to which it was previously assigned.
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Window Types (Text or Non-Text)

The set of commands available in ARCHICAD varies slightly, depending on whether the active window is 

Text-type (Schedules, Lists, Report, Project Notes or GDL script window) or Non-Text type (all other 

windows).

Use these two radio buttons in the Keyboard Shortcuts dialog box to choose the window type in which the 

shortcut will work:

• Only in the currently active window type: The shortcut will work only in the type of window that is 

currently active (i.e. the one you were working in at the time you opened the Work Environment dialog 

box). If you choose this option, you can assign the same shortcut to two different commands as long as 

the two commands are from different window types.

Note: If you have defined a shortcut to apply only in the current window type, you can henceforth edit that 

shortcut only by opening the Work Environment dialog box from the window-type of that shortcut.

• In All window types: The shortcut will work in all windows of ARCHICAD.

Click OK to close the dialog box and apply the selected shortcut scheme according to its current settings.

Keyboard Shortcut Preview

To see and/or print a list of currently assigned shortcuts for the chosen scheme, press the Show Shortcut List 

in Browser button.
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Toolbox Customization Dialog Box

Go to Options > Work Environment > Toolbox.

Another way to access this dialog box is to open the Toolbox context menu by right-clicking anywhere in the 

Toolbox, then click the icon representing the Toolbox customization page.

.

Use the splitter bar as needed to change the width of the fields in this dialog box.

The Available Tools window lists all the ARCHICAD tools.

The Toolbox Groups window lists the existing tool groups.

• To change the order of the tool groups, click and drag on the up/down arrows at the left of each group.

• By clicking the pushpin icon, you define whether the selected toolbox group will remain permanently open 

(vertical pushpin), or open and close as space permits (horizontal pushpin).

• By toggling between the arrow/ABC icons, you define whether the selected toolbox group will be 

displayed by its icon only (arrow icon), or by both its name and icon (ABC icon).

The Tools in Selected Group window lists the tools that are currently part of the group you have selected.

Add a tool to the selected tool group by selecting it from the Available Tools list, then click the Add Selected 

button at the bottom, or simply drag it to the right. It is possible to place the same tool into more than one Tool 

Group.

Remove a tool from the selected tool group using the Remove button.
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How to Open and Close Tool Groups Within the Toolbox

By default, the Toolbox shows all tools in all Tool Groups simultaneously. If the Toolbox becomes too unwieldy, 

use the open/close arrows at the top of each Tool Group to temporarily open and close these groups as 

needed.

If the open/close arrows are not displayed, disable the “Always open” control in Tool Group Options.

See Tool Group Options, below.

Tool Group Options

• New Group: Use this command to create a new tool group.

• Rename or Delete Group: These commands are applied to the selected tool group.

• Always Keep Group Open: This option will keep the selected Tool Group open on your screen, and no 

open/close arrow is available on its panel.

To be able to open or close each Tool Group in the Toolbox separately: disable the “Always Keep Tool 

Groups Open” option.

• Show Icon and Tool Name, or Show Icon Only: This option determines how the tools in the selected 

Tool Group are displayed.

Changes to the Toolbox are applied when you press OK and close the dialog box. The current open/close 

status of your toolbox panels will be saved as part of the Tool Scheme, together with all the other settings 

customized in this dialog box.

Note: It is possible that the Toolbox size, as saved in your Workspace Scheme, is not big enough to 

accommodate all the toolbox panels you saved as open. In this case, one or more panels of your Toolbox 

will be displayed as closed.
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Tool Settings Dialog Box Customization

Go to Options > Work Environment > Tool Settings Dialog Boxes.

Use the splitter bar as needed to change the width of the fields in this dialog box.

The left window contains a list of all ARCHICAD tools. The right window lists the panels that appear on the 

selected tool’s Settings Dialog Box.

• To see what the selected panel looks like, double-click its name or click the Panel Preview button.

• To change the order in which the Tool Settings panels appear, use the arrow icons.

• To show or hide Tool Settings panels, click to open or close the relevant “eye” icon. (Multi-select to set 

show/hide preferences more quickly.)

When you are satisfied, click OK to apply the changes and close the dialog box.
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Info Box Customization Dialog Box

Go to Options > Work Environment > Info Box to open this dialog box.

Or open any Info Box’s context menu, then click on Info Box:

Use the splitter bar as needed to change the width of the fields in this dialog box.

The left window contains a list of all ARCHICAD tools. The right window lists the panels that appear on the 

selected tool’s Info Box.

• To see what the selected panel looks like, double-click its name or click the Panel Preview button.

• To change the order in which the Info Box panels appear, use the arrow icons.

• To show or hide Info Box panels, click to open or close the relevant “eye” icon. (Multi-select to set show/

hide preferences more quickly.)

Note that you can use a scroll-mouse to scroll through the contents of your Info Box.

When you are satisfied, click OK to apply the changes and close the dialog box. To customize the location of 

the header on your Info Box, right-click anywhere in the Info Box to access its context menu commands.

You can store your customized Info Box settings as part of a Tool Scheme in your Work Environment.
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Toolbar Customization Dialog Box

Open this dialog box at Options > Work Environment > Toolbars

Or open any Toolbar’s context menu, then click on Toolbars.

Create New Toolbar

To create a new toolbar, use the New Toolbar command from the Toolbar Options pop-up menu.

Display Command Icon and/or Name

From Toolbar Options, set a view mode for the selected toolbar: for every command in the toolbar, you can 

show its Icon, or its Name, or both Icon and Name. You can also choose “Icon and Name selectively”.
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Note: Icon and Name Selectively means that the Icon will be shown for every command, but the name will 

be shown only selectively, depending on what you set in the Further Options panel. 

See Further Options Panel, below.

Customize Toolbar

Add, remove and rearrange the menus and commands of any toolbar.

The interface is identical to the Menu Customization dialog.

See Customize Menus Panel.

Add Menu to Toolbar

You can add not only commands, but also menus to a toolbar. 

The menu can be an existing one, or you can create a customized menu (at Customize Menus Panel), then 

add it to the toolbar.

To set the behavior of a menu in a toolbar: See Sticky pop-up menu.

Further Options Panel

The settings in this panel apply to selected commands or menus in the toolbar.

Show command name in case of “Selective” option:

This checkbox is relevant only if you have chosen “Icon & Name Selectively” from Toolbar Options. In this 

case, select a command in the list for which you want to show both Icon and Name, then mark this checkbox.

Any command for which you do not check this box will be displayed with its Icon only.

Sticky pop-up menu

This option is available if you have added a menu to the toolbar. 

If you want the menu contents to appear as a pop-up of the previous command in the toolbar: check the Sticky 

pop-up menu box. The effect: the commands of the menu will appear only inside the pop-up of the previous 

Toolbar command.
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If you do not check the box: the menu appears on the toolbar under its own name, with the commands inside 

the pop-up.

For example, the Tracker command on the Standard toolbar contains an associated (sticky) pop-up menu, 

represented by a black pop-up arrow, which in turn accesses Tracker-related commands.
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Menu Customization Dialog Box

Use the Options > Work Environment > Menus dialog box to customize the contents and arrangement of all 

of the menus that exist in ARCHICAD. Any command or menu can be placed into or removed from any menu; 

the order of the commands within any menu is entirely customizable.

Exception: Context menus are not customizable.

Use the splitter bar as needed to change the width of the fields in this dialog box.

Customize Menus Panel

Commands and Menus

The left side of the dialog box lists all of ARCHICAD’s commands and menus. 

From the list window, locate any function or command:

– by typing its name in the Search field

– or click a list format from the drop-down list.

Watch the Video

Notes:

– You can display this list in one of five formats: Current menu structure; All commands by theme; All 

commands in alphabetical order; All menus in alphabetical order; All New commands in alphabetical 

order. The last item in the list is a Separator bar.

– If you are in one of the two All commands formats, you can access them (i.e. click and drag them to 

the right) only if you have chosen a particular menu (as opposed to the menubar) in the “Build or edit 

the menu” list on the right.
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Create or Edit Menu

Choose a menu to build or edit from this pop-up list. 

Note: The menu you are editing will be displayed only for windows of the currently active window type 

(either Text or Non-Text).

For more information, see Window Types (Text or Non-Text).
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• The pop-up provides a list of menus only (no commands), together with the menu path

• A menu appears in this list as many times as it is used in the interface

• Menus not yet inserted in your Work Environment are grouped at the bottom

Menu Content List

The right-hand list window displays the content of the selected menu, including

• Commands (dragged in from the “All commands” lists at left) 

• Menus (dragged in from the “All menus” list at left). 

A menu within a menu is indicated by an icon. 

• Click to enter the sub-menu
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• Click “Up one level” icon to move up a level in the hierarchy

Add/Remove/Change Menu Commands

• Use the Add selected and Remove buttons on commands or menus

• Rearrange the menus in the main ARCHICAD menubar by dragging the up-down arrows

• Change order of commands/menus by dragging the up-down arrows 

• Use separator bars to group items

• To insert a new separator bar: drag it from its location at the bottom of the left-hand list

Menu Options

For the selected menu: 

New menu creates a submenu within the selected menu.

Further Options Panel

Alternating menu items

This checkbox is available after you have selected a menu or command in the right-hand column.
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Checking this box means that the selected item (for example, New & Reset) will alternate with the item above 

it (New). (The item set as alternating will be indented underneath its pair.) Only one of the two alternating 

items will be visible at any given time in the menu.

Important: For items to alternate, their shortcuts must correspond as follows: the shortcuts are the same 

except that one item’s shortcut has an additional modifier. For example: The shortcut for New is Ctrl+N; 

the shortcut for New & Reset is Ctrl+Alt+N.

To alternate between them, press the unique modifier key (in this case, Alt).
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Project Preferences Dialog Boxes

This dialog box (Options > Project Preferences) contains several screens. Navigate among them using the 

drop-down menu at the top, or the “Previous” and “Next” arrows.

The settings you make here are Project Preferences: specific to the Project you are working on and are saved 

with it. If another user opens the Project on his or her own computer, the same settings will be applied.

Topics in this section:

Dimensions Preferences

Calculation Units and Rules Preferences

Zones Preferences

Reference Levels Preferences

Legacy Preferences

Stair Rules and Standards: Project Preferences

Structural Analytical Model Representation (Preferences)

Structural Analytical Model Units
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Dimensions Preferences

Dimensions preferences affect the dimension units as they are displayed in the project:

• Dimensions

• Zone Stamps

• Fill text

• Marker texts

• Symbol labels (not Autotext, which is displayed according to Calculation Units Preferences)

• in Element Schedules: Core element parameters entered by you (e.g. Wall height, Slant angle)

Dimensions preferences do not affect calculated values (e.g. Wall length) in Interactive Schedule, Listing, or 

the List Areas add-on. Those calculations are affected by the Calculation Units and Rules page of Project 

Preferences. (See Calculation Units and Rules Preferences.)

To access Dimensions Preferences, do one of the following: 

• Click the Dimensions icon in the Quick Options bar

• Go to Options > Project Preferences > Dimensions
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Choose Dimension Standard

Do one of the following:

• Use the Dimensions pop-up from the Quick Options Bar at the bottom of the window

• Use the list on the Dimensions page of Project Preferences

• Use the Dimensioning pop-up in View Settings (2D/3D Documents Panel)

Store Custom Dimension Standard

Store As: If you have customized a dimension setting in this dialog box, the Standard name changes to 

“Custom.” Click “Store as” to name this customized Standard and make it available to your project as a named 

Standard.
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Choose Dimension Type

Click one of the 8 icons to choose the dimension type whose options you wish to set: 

• Linear

• Angular

• Radial

• Level

• Elevation

• Door/Window/Skylight

• Sill Height

• Area Calculations (this also affects area as displayed on Zone Stamps)

Unit Display

As you set each control, consult the Sample field for a preview of how that Dimension Type will be displayed 

in the project. 

The available dimension options will vary depending on the unit (metric or imperial) you choose, and on the 

dimension type whose preferences you are setting.

Unit: Define the Unit for each of the Dimension types.

Decimals: Define the number of Decimals you want to display in each dimension value.

Extra Accuracy: Choose this if you want to display additional decimal values as a superscript.
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For example, here the number of decimal places is set to two; but Extra Accuracy is enabled to 25: thus, the 

next decimal value is also displayed, as a superscript, rounded to increments of 25. See the result in the 

Sample field of the dialog box.

Rounding to: Available for Area-type dimension. Choose a rounding option from the pop-up field.

• Nearest: Value is rounded to the number of decimals you set.

• Other: Value is rounded to the number of decimals you set, but the final digit(s) are an increment of 5 or 

25. 
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Hide Zero Wholes: Check this box to suppress whole zero values.

• For example: 0.25 meters is displayed as 25

Hide Zero Decimals: Check this box to hide any zeros at the end of the decimal dimension, regardless of the 

number of decimal places you set in the Decimals popup above.

• For example: 25 meters is displayed as 25.00

You cannot use the Hide Zero Decimals options concurrently with Hide Zero Wholes.

Accuracy: Available for an Angular Dimension Unit of degrees/minutes/seconds or surveyor’s unit. Click this 

pop-up field to select accuracy level.
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Witness Line Scalability: Choose either fixed or scaled to make your witness lines keep a fixed scale, or 

else vary them depending on window scale. (Witness lines are the perpendicular lines between a dimension 

and the dimensioned element.)

Imperial Unit Display

If you choose an imperial unit, the following other options may be available.

Note: You cannot mix units for the same dimension type in a Project. However, you can display two types 

with the Secondary Dimensions command.

Fractions: Click this pop-up field to define the fractions displayed for the selected Measurement Unit, if you 

are using a unit that includes fractional inches.

Fractions in Small Type: Toggles printing of fractional inches and feet in small characters on and off in length 

dimensioning.
ARCHICAD 24 Reference Guide 3211



Dialog Boxes User Interface Reference
Display of Zero Feet & Inches: If using Feet & fractional inches, this section has three pairs of radio buttons; 

if using fractional inches, there is one pair of radio buttons. For each pair, choose the option you prefer for 

displaying dimensions that measure either zero feet or zero inches.
ARCHICAD 24 Reference Guide 3212



Dialog Boxes User Interface Reference
Calculation Units and Rules Preferences

To access this dialog, go to Options > Project Preferences > Calculation Units and Rules.

This dialog allows you to set the units to be displayed

• in Interactive Schedules, for calculated values

• Autotext Labels

• in lists created with the Calculation function

• the List Areas add-on (available in selected markets)

Also use this dialog (Setup Rules) to set additional rules for computing the values of parameters listed in 

Interactive Schedules.

Note: If you are using the Calculation function, these settings will affect Text format lists only (not those 

based on a Graphic Template, which sets its own number format).

As you set each control, consult the preview. 

• Unit: Click this pop-up field to select from various standard Measurement Units.

• Decimals: Click the pop-up field to select the number of decimals for the chosen Unit.

• Extra Accuracy: Choose this if you want to display additional decimal values as a superscript. The 

superscript value will be rounded off to increments of the number you select (e.g. 25).

Note: Extra Accuracy values will be displayed as superscripts only in Interactive Schedules. In Calculation 

lists and some add-ons, these extra values will be shown as extra decimals (rather than superscripts).
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For example, here the number of decimal places used in calculating length (for the Wall Perimeter field) is set 

to two; but Extra Accuracy is turned on to 01, so that the next decimal value is also displayed, as a 

superscript, and rounded to 01.

Note on Volume Unit

Your choice of metric vs. imperial unit for measuring volume will affect the units used by the Density value 

and for the Embodied Carbon property of the project’s Building Materials.

See Physical Properties.

Note on Angle Unit

If your chosen Angle Unit is degrees/minutes/seconds, click the Accuracy pop-up field to the right to select 

the precision.
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Conditional Parameter Setup Rules

Click the Setup Rules button (in Options > Project Preferences > Calculation Units and Rules) to open 

this dialog box.

These controls enable you to define conditions for certain listing parameters, and how these parameters 

should calculate walls, slabs, roofs, shells and beams.

For example, suppose you are making a Wall List and your schedule criteria (as defined by you in Scheme 

Settings of the Interactive Schedule) include this field: “Conditional Surface Area on the Outside Face”.

See also Scheme Settings Dialog Box (Interactive Schedule).
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The parameter name includes “Conditional”, indicating that you can tie this parameter listing to conditions, 

using this Conditional Rules dialog box.

If you want to reduce the listed wall surface by openings that are 2.5 m2 or larger, check the box shown:

Your “Wall List” Interactive Schedule will compute wall surfaces according to this condition.
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Insulation/Air Space Building Materials

Use these pop-ups to designate which Building Materials used for the skins of your composite walls, roofs, 

and/or shells should be recognized by ARCHICAD as “insulation” or “air fill”, for the purposes of listing these 

quantities separately in listing windows.

You can define the skins of Composite Structures in the Composite Structures Dialog Box. If you consistently 

use certain Building Materials as the insulating layer in your project’s composite Walls, Roofs or Shells, check 

those Building Materials in the appropriate pop-up of the Conditional Rules dialog box.

See Composite Structures Dialog Box.

For example, if your standard insulation layer in roofs is called “GENERIC - Internal Cladding,” check its box 

from the Roof Insulation Skin pop-up of the Conditional Rules dialog box.
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Henceforth, if your listing criteria for roofs include “Insulation Skin Thickness”, ARCHICAD will list the 

thicknesses of the roof composite skins that use the checked Building Material.

Calculate Totals By

This option determines how subtotals are added up in the List Areas Add-on.

• Displayed values (default): Each value (as displayed on the interface) is rounded off according to your 

Rounding/Extra Accuracy settings. The sum of these rounded values produces the grand total.

• Exact values: Choose this for a more accurate value: the program adds up the exact values (not 

displayed on the interface) before it rounds them off according to your Rounding/Extra Accuracy settings 

to produce the grand total.
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Zones Preferences

To access this dialog, go to Options > Project Preferences > Zone Preferences. These options define how 

zones are calculated in Zone Lists.

The settings you make here are Project Preferences: specific to the Project you are working on and are saved 

with it. If another user opens the Project on his or her own computer, the same settings will be applied.

Note: To see the effect of any changes in Zone calculation settings, you must execute the Design > 

Update Zones command.

See Updating Zones.

Add Wall Recesses to Zones

These options define how to take large door/window recesses into consideration when calculating Zones.

Door/Window recesses which meet the criteria defined here will be included as part of Zones when 

ARCHICAD calculates Zone area.

Check the Door and/or Window icons if you want to consider Door and/or Window recesses in zone 

calculations.

• If deeper than: Check this box to enter a minimum depth for the recess to be considered, then enter this 

minimum depth into the text box.

• If larger than: Check this box to enter a minimum surface area for the recess to be considered, then enter 

this minimum area into the text box.

• Click AND or OR from the pop-up menu to further define the recess size (minimum depth and/or minimum 

area) to take into consideration.
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Walls & Column Subtraction

• If larger than: Enter the minimum area of Walls, Curtain Walls and/or Columns whose areas should be 

subtracted when calculating the size of Zones containing them. (Any elements smaller than this minimum 

limit will be included in the zone size.)

• Subtract: Enter how much (in percent) of the Wall/Column area to subtract from the Zone area.

Note: These options will affect only elements that are set to “Reduce Zone Area Only” or “Subtract from 

Zones” in their Settings dialog box.

Area reduction under low ceiling

Use these controls if you want to exclude areas under low ceilings as part of a zone’s area.

You can set one or two height limits.

• First checkbox: Check this box to define a height limit to take into account for calculating Zone sizes.

• Second checkbox: Check this box to define a second height limit to take into account for calculating 

Zone sizes.

• Subtract: Use these text boxes to define the percentage of the area underneath ceiling that should be 

subtracted from the zone area. You can enter up to two different subtraction percentages, one for each 

height limit you defined.

To see how much of a zone’s area has been reduced due to this Area Reduction setting, update the Zone, 

then select it and view the data in the Zone Area Calculation Panel.

Related Topics

Calculating Zone Area and Zone Volume

Zone Area Calculation Panel
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Reference Levels Preferences

You can define optional Reference Levels that will help you position elements. This is done at Levels 

Preferences (Options > Project Preferences > Reference Levels).

All of these settings are effective for Coordinates Palette, Info Box and all Dialog Boxes.

Select a level’s name and modify it as you like, then type the value you need in the Elevation field. In this 

example, we defined the top of the property, at 400 meters.

The Sea Level takes its value from the Altitude, which is set at Options > Project Preferences > Project 

Location.
ARCHICAD 24 Reference Guide 3221



Dialog Boxes User Interface Reference
You may find it easier to calculate levels (in this dialog box) by switching the zero value to another level than 

Project Zero. You can do so by simply clicking in the Relative to field next to the level’s name.

Note: You cannot rename the Project Zero or Sea Level reference levels.

Note: Reference Levels are display and input aids only. Changing their value has no effect on placed 

elements, whose actual elevation is always calculated from Project Zero. The exception is Grid lines in 

Section view, whose position changes with the Reference Level.

The newly defined Reference Levels are now available in the Bottom Elevation [to Reference level] fields of 

the Geometry and Positioning Panels of construction and object-type elements.

See also Place a Construction Element in ARCHICAD.

Reference levels can also be used for showing elevation (Z) values in the Tracker.

See Tracker.
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Reference Levels can also be used as Autotexts, such as Autotext used in Elevation Dimensions:

Related Topics:

Autotext
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Legacy Preferences

To access this dialog, go to Options > Project Preferences > Legacy.

The settings you make here are Project Preferences: specific to the Project you are working on, and saved 

with it. If another user opens the Project on his or her own computer, the same settings will be applied.

Line Types Displayed Across Stories

Select a line type with which to display the outlines of Slabs and Meshes that appear on stories above and 

below the Home Story, as well as certain Objects.

Note: This setting has no effect on Walls, Roofs or Shells, their Openings, or any elements in a Trace 

Reference.

Note: These line types are only effective on Objects if the Override Object’s Line Types checkbox in 

their Settings dialog boxes is on.
ARCHICAD 24 Reference Guide 3224



Dialog Boxes User Interface Reference
Use Symbolic Display in Floor Plan for Single-plane Roofs and their Skylights (as in 

ARCHICAD 14 and before)

Check this box if you want your Single-plane roofs and any Skylights within them to be displayed as they were 

in ARCHICAD 14 and earlier versions. Click the Info button at right for an illustration of the difference in 

displays.

• True 3D Projection: This display mode is available as of ARCHICAD 15. (All Multi-plane Roofs and newly 

placed Skylights will be shown this way.)

• Symbolic: This display mode corresponds to the way Roofs and Skylights were displayed in ARCHICAD 

14 and earlier.

(For more information, click the Info button at the right of this option.)

Use legacy intersection and Surface methods for model elements (as in ARCHICAD 16 and 

before)

Note: Legacy intersection mode may be discontinued in a future ARCHICAD release.

ARCHICAD 17 introduced smart intersection features based on element Building Materials. 

When you open an older-version project (ARCHICAD 16 and earlier), you can opt to use these latest 

intersection methods (Legacy mode OFF). To continue using the old methods instead, you can stay in Legacy 

mode (Legacy mode ON) instead.

The sections below describe the difference between these two modes.

Legacy Mode ON: Use Old Intersection Logic

There are two ways to enable Legacy intersection mode in your ARCHICAD project:

• Activate the checkbox on the Legacy page of Project Preferences
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• Choose Stay in Legacy Mode from the dialog which appears when you open an ARCHICAD project that 

is already in Legacy mode.

Legacy intersection mode (Legacy mode ON) creates the following limitations. Also, please be aware that 

Legacy intersection mode may be discontinued in a future ARCHICAD release.

• Automatic and Building Material priority-based intersections will not take effect in 3D. Connection 

methods used in ARCHICAD 16 and earlier versions will be used. You may prefer this when working on 

an older project, to ensure that your existing intersections remain intact. 

• The Building Material attribute is available – but the priority-based connections will not take effect in 3D 

(except for Walls, where they will work as in ARCHICAD 16 and earlier versions). Instead, use the slider 

below to set a global priority for Columns that intersect Beams. (See description below).

• Surfaces assigned to Building Materials are not displayed. Only element-level surfaces can be shown.

• Surface Painter is not available

• Surface Schedules are not available

• Expanded geometry features for Beams and Columns (introduced in ARCHICAD 23) are NOT available. 

These include multi-segment, end cuts, tapered and vertically curved geometry. If you are in Legacy 

mode, and if you try to use an unsupported geometry method, the resulting element is shown with a 

highlight. (See Use uniform color to highlight inverted elements.)

This table specifies how Legacy mode (checkbox ON) affects different construction elements. 

Legacy mode OFF: Use New Intersection Logic

If you open an older-version project (ARCHICAD 16 and earlier), you can opt to use the latest intersection 

methods (Legacy mode OFF).

• Newly placed elements with collisions modeled using the new methods will clean up according to the new 

logic. 

• Newly placed Beams, Columns and Openings use the full feature set available as of ARCHICAD 23.

• Existing, modeled connections that do not involve collisions will not clean up automatically. 

• This way, even when you migrate an older-version project, you will be able to enjoy the benefits of the new 

intersections features, while maintaining the existing model as it was.

Element Type Behavior in Legacy Mode (Checkbox ON)

Wall Will not intersect with non-Wall elements. 

Wall-Wall intersections shown with simplified 3D feedback.

Slabs and Morphs Priority from Building Material has no effect.

Columns Priority from Building Material has no effect.

When intersecting with Beams, uses the priority setting under Legacy Options.

Multi-segment, End Cuts, Tapered Beams not supported.

Beams Profiled Beams ignore priorities of individual components, and will use Junction 

Order from the element settings.

Multi-segment, End Cuts, Tapered Beams not supported.

Roofs and Shells Composite elements ignore priorities of individual skins, and will use Junction 

Order from the element settings.

Openings (via Opening 

Tool, AC23 and later)

Visible only as 2D symbols on Floor Plan. Not visible in 3D.
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Columns vs. Beams global priority (Legacy mode ON)

Available if Legacy mode is ON.

This slider defines the relationship between all Columns and Beams in the project. When Beams cross 

Columns, the element of lower priority will be cut in 3D, i.e., the intersection part will be removed. The element 

of higher priority will remain intact. This applies to volume calculations as well.

Note: Column priority numbers are always even and can only be defined as a general setting, in this 

dialog box. Beam Junction Order is set for each beam separately in Beam Tool Settings (Model panel).
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Structural Analytical Model Representation (Preferences)

Use this page of the Project Preferences dialog to set colors and symbol sizes for the Members and visible 

components of the Structural Analytical Model.

• Options > Project Preferences

• View > Structural Model Appearance > Structural Analytical Model Representation

Related Topic:

Representation of Structural Analytical Model
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Structural Analytical Model Units

To access this dialog, go to Options > Project Preferences > Structural Analytical Model Units.

Related Topic:

Structural Analytical Model
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Layer Settings Dialog Box

Use this dialog box to create, edit, and manage layers.

Open Layer Settings

Do one of the following:

• Click the Layer Settings icon in the Quick Options bar

• Options > Element Attributes > Layer Settings

• Document > Layers > Layer Settings (shortcut: Ctrl+L)

• Use the shortcut from the Arrange Elements toolbar:

Controls

The left panel lists existing Layer Combinations. The right side lists all the layers defined in the project. Use 

the splitter bar that separates the two sides to display as much text as you need.

• Double-click anywhere on this splitter bar to open/close the Layer Combinations panel (or click the black 

arrow at the top of the splitter bar.)

• Multiple selection is possible. All the commands detailed below act on selected Layers.

• To quickly change the layer status of several layers at once, use the shortcuts in the Quick Layers palette.

See Quick Layers.

Edit Layer Status

Select a Layer on the right side of the dialog box to edit it.

Note: The first item on the list, the ARCHICAD Layer, cannot be deleted, hidden or locked. This layer 

collects all those elements that may have lost their layer definitions.

Click on the icons of the selected layer to change its state.
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Lock/Unlock

• The open or closed lock icons indicate whether a Layer has been locked to prevent its contents from 

accidental modification. If a Layer is locked, the elements on it cannot be edited or deleted and no new 

elements can be placed on it.

Show/Hide

• Use the open or closed eye icons to show or hide a selected layer. Elements on a hidden layer will be 

hidden.

Note: To show all Layers while working in your project, use the Document > Layers > Show All Layers 

command or the relevant button of the Arrange Elements toolbar.

3D View Display

• The solid model or wireframe icons indicate that the elements placed on that layer are fully visible in 3D 

views or with their contours only, independently of the current 3D mode set in the Image menu. This can 

be useful, for example, for storing the operator elements of Solid Operations on wireframe layers and 

target elements on solid layers.

Intersection Group Number

• Set an intersection group number in the first edit box.

Note: Layer Intersection numbers have nothing to do with element priorities; they serve merely as tags or 

labels (e.g. 0 or 1) for grouping elements.

Note: Two elements that are both set to intersection group 0 will NOT intersect.

See Use Layers to Prevent Intersections.
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Layer Name Extension

• Add an extension to the layer’s name. This can act as an additional sorting control if you have many 

layers.

Tip: Layer extensions can be used effectively for project phasing and option management as well.

Sort Layers

You can sort Layers in the list alphabetically either by Name or Extension, or sort them by status or 

intersection group number, by clicking any of the column headers.

Use the pop-up items by the funnel icon to limit the display of layers in the list. The funnel icon varies 

depending on whether you have applied a filter.

• Show all layers: All layers in the project are listed. Layers of XREF items are listed separately at the 

bottom of the list.

For more information, see Attributes of XREF Files.

• Hide XREF layers: If you have XREFs in your project, and if you choose this option, then the XREF 

layers will not appear in Layer Settings.

• Filter by extension: This option is available if the selected layer has an extension. Only layers having this 

extension will appear in Layer Settings.

Select All/Deselect All: Use these buttons to select and deselect all layers, respectively.

Delete Layer/Move Elements

See Delete and Replace Attributes in a Model.

Note: In Teamwork, only elements reserved by you will be placed on the replacement layer. All other 

elements from the deleted layer will have a “Missing” layer. 

See also Reserve and Delete Layers (Teamwork).

New: Click this button to create a new layer and give it a unique name.
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Layer Combinations

See Layer Combinations.

Print Layer List

The Print... button at the bottom right of the Layer Settings Dialog Box creates a text-format list, in a PDF file, 

of the layers in your project.

This is a simple list, organized by Layer Combination. Within each Layer Combination, the layers are listed in 

order of their Attribute numbers. (These attribute numbers are not visible in Layer Settings; they are seen in 

the Attribute Manager opened from Options > Attributes > Attribute Manager.)
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Lines Dialog Box

Use the Options > Element Attributes > Lines command to open this dialog box.

For general information on Line-type elements, see Lines.

Choose a predefined Line Type from the pop-up list at the top of the dialog box. The first one in the list is a 

solid line; this is not editable.

The next set of lines in the list is dotted/dashed lines; these are editable.

For more information, see Line Edit Selected Type Panel (Dashed).

The rest of the lines in the list are symbol-type lines; these are also editable.

For more information, see Line Edit Selected Type Panel (Symbol).

To create a new line type:

New: Click this button to create a new line type. In the resulting dialog box, choose one of the following 

options:

• Dashed: Use this option to create a line type based on a dashed line. Then set its options in the Edit 

Selected Type panel - see below.

• Symbol: Use this option to create a line type based on a customized stencil of 2D drawing elements 

copied from an ARCHICAD window. Then set its options in the Edit Selected Type panel - see below.
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• Duplicate: Use this option to create a new line type by duplicating the selected line type under a new 

name and editing its properties.

Rename: Click to rename the currently selected line type.

Delete: Click to delete the selected line type.

See also Delete and Replace Attributes in a Model.

Note: The basic lines (Solid, Dashed, Dotted and Dense Dotted) cannot be deleted.

Line Edit Selected Type Panel (Dashed)

Use this field to graphically edit the first component of the new or selected dashed line. The black and white 

flags represent sections of the dashed line.

Each black flag represents the end of a dash in the line, the length of which can be edited either by dragging 

the flag in a horizontal direction, or by editing its value in the Dash edit fields. The little white flags represent 

the gap between each dash section, and can be edited similarly. The values in the numerical input boxes are 

given in the respective measurement standards defined in Options > Project Preferences > Working Units.

Line Edit Selected Type Panel (Symbol)

To create a new symbolic line type, first draw the stencil on the Floor Plan or in another window, using Lines, 

Arcs and Hotspots. Select all stencil components, then choose Edit > Copy.

Choose Options > Element Attributes > Lines.

Click New. From the New Line dialog box, select the Symbol option and click OK.
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From the Lines dialog box, click Paste under the graphic editing section.

The previously captured line component will appear in the graphic editing Window. You may edit the scale of 

both line component and the gap between each component, by either dragging the little flags in the window or 

editing the numeric values underneath. The line component will be scaled as a whole. Modifications in size 

are reflected in real time by the change of the values in the numerical editing boxes.

Notes: Only Arcs, Lines and Hotspots may be used in the definition of symbolic lines. If the selection of 

components copied from the ARCHICAD window includes splines, fills, text or other elements, these will 

not be pasted into the Lines dialog box. The bounding box of pasted graphics will be centered on the 

centerline of the Symbol line. If the Project Origin was located within the bounding box of the copied 

elements, it will be used for alignment.

Regular Copy-Paste operations do not function in this dialog box.

To change a symbolic line after the original components have been deleted from the Floor Plan, select the line 

to be edited within the Lines dialog box, and press Copy. Then paste these components on the Floor Plan, 

where you can edit them.

The appearance of the lines on the screen, printer or plotter depends on the following options:

• Scale with plan (Model size): Use this option to ensure that the current Line type will be displayed at the 

same scale as the model on every output.

Note: Avoid editing a scaled line type if the project scale is different than that of the line type, as it will be 

distorted.

• Scale-independent (Paper size): Use this option to display, plot and print the current Line type definition 

at a fixed size, regardless of output scale.
ARCHICAD 24 Reference Guide 3236



Dialog Boxes User Interface Reference
Building Materials Dialog Box

Use the Options > Element Attributes > Building Material dialog box to define and/or edit Building Material 

definitions. These include:

• Cut fill

• Cut fill pens (foreground/background)

• Intersection Priority

• Fill orientation (if used for a composite or complex element)

• Surface

• Classification and Properties, including Physical Properties

On the left side of the dialog box, the Building Materials predefined for your project are listed by Name and 

Intersection Priority. 

• Sort the list by name or priority by clicking on either of these list headers.

• If you have clicked the priority header to sort by priority, you can then edit the intersection priority of any 

selected item by dragging it up or down in the list.

• Any Building Materials used by elements that are selected in the current ARCHICAD view are listed 

with a “selected” icon at the left of the list and highlighted in green.

Edit Building Material

1. Select the Building Material(s) you wish to edit from the list.

2. Use the fields on the right side of the dialog box to edit the properties of the Building Material(s) selected 

in the list. You can select and edit multiple Building Materials simultaneously (in this case, you cannot edit 

their names).

Note: This function is also available in Attribute Manager: See Building Materials (Attribute Manager).
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Structure and Appearance Panel

Cut Fill: Define a Cut Fill for this Building Material from the pop-up. The Fills you see here are those defined 

as “Cut Fills” in the Fills dialog box. (Only cut fills are available.)

Cut Fill Foreground Pen/Fill Background Pen: From the pen chooser pop-ups, define the foreground and 

background pen for this Building Material.

See also Line Elimination Between Model Elements.

Fill Orientation: This option affects the appearance of the cut fill pattern of Building Materials applied to 

composite elements and Complex Profiles only.

• Project Origin: The fill pattern is displayed so that the pattern originates at the Project Origin.

• Element Origin: The fill pattern is displayed so that the pattern aligns with the element’s direction.

• Fit to Skin: (Available only for symbol fills.) The pattern will be drawn so that it fits within the limits of the 

Skin Thickness.

Related Topics:

Set Orientation of Vectorial or Symbol Fill Patterns

Symbol Fills as Skins of Composite Elements: Fit to Skin
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Define Building Material Surface

Define a Surface for displaying this Building Material in 3D.

Note: It is possible to override a particular element Surface in its Settings dialog box (Model Panel), or by 

using the Surface override pop-up in the element’s Info Box.

Change Intersection Priority

There are two ways to change a Building Material’s intersection priority:

• Use the slider at right to adjust this Building Material’s relative priority in its intersections with other 

construction elements. (Expressed in numbers, an intersection priority can run from weak - a minimum of 

0 - to strong - maximum of 999. This will affect the element’s intersections and display in model views.

See Basic Intersection Principles and Intersecting Elements with Identical Priorities.
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• Another way to adjust priority is on the left side of the Building Material dialog box: If you have clicked the 

priority header to sort the list by priority, you can then edit the intersection priority of any selected item(s) 

by dragging it up or down in the list.

Be aware that Building Material definitions are global; any changes you make here will affect all project 

elements which use that Building Material – not just the selected elements!
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If you want to adjust the priority in just one element of the project, you can create a duplicate Building Material 

with a different priority. 

(See Create New or Duplicate Building Material, below.)

For general information on modeling intersections, see the topics at Element Intersections.

Classification and Properties

See Properties and Classification Systems.

ID and Categories

• ID: Assign an optional ID to this Building Material. Any character can be used, with no character number 

limit.

The ID field serves as a way to identify Building Materials in lists and labels. You can also Find & Select 

elements by using Building Material ID as a search criterion.

• Manufacturer: Optionally, enter a manufacturer name for this Building Material. You can add 

Manufacturer as a field to your Interactive Schedule, e.g. to list all Building Materials by manufacturer.

• Description: Optionally, enter a Description for this Building Material. You can add Description as a field 

to your Interactive Schedule.

• Participates in Collision Detection: This data is used in exporting elements to IFC format, and in 

ARCHICAD’s Collision Detection feature.

See Collision Detection.

Watch the Video

Physical Properties

These data are predefined for ARCHICAD Building Materials, but you can edit them directly.

• Load from Catalog: Access the built-in Material Catalog (click the Open Catalog button), and click the 

name of a material having the characteristics you need; its physical properties will then be applied to the 

Building Material you are editing.

For more information, see Material Catalog.

For the selected Building Material, enter data for its

• Thermal conductivity (in W/mK)

• Density

Note: The unit for the Density property is lb/cu ft if the volume Calculation unit is an imperial unit; or kg/

m3 if the volume Calculation unit is a metric unit, as set in Project Preferences > Calculation Units & 

Rules.
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• Heat capacity (in J/kgK)

• Embodied Energy (in MJ/kg, or megajoules per kilogram)

• Embodied Carbon

Note: The unit for the Embodied Carbon property is lbCO2/lb if the volume Calculation unit is an imperial 

unit; or kgCO2/kg if the volume Calculation unit is a metric unit, as set in Project Preferences > 

Calculation Units & Rules.

Create New or Duplicate Building Material

Click New at the bottom of the Building Materials dialog box.

In the appearing dialog box, choose whether to create an entirely new Building Material, or to duplicate the 

current one.

Give the new Building Material a Name, then click OK.

Adjust the settings for the new Building Material, then click OK to close the Building Material dialog box.

Watch the Video
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Delete Building Material

See Delete and Replace Attributes in a Model.
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Composite Structures Dialog Box

Open this dialog box from Options > Element Attributes > Composites.

You can also edit a selected composite by accessing its settings from its context menu:

Use these controls to edit the components of Composite Structures used with Walls, Slabs, Roofs and Shells.

For general information, see also Composite Structures.

Choose a predefined Composite Structure from the pop-up list at the top of the dialog box. Either edit its 

properties directly, or choose one of the following commands:

• New: Click this button to create a new composite structure (based on a single default skin), or duplicate 

and rename a current one.

• Rename: Click this button to rename the currently selected composite structure.

• Delete: See Delete and Replace Attributes in a Model.

Composites Edit Skin and Line Structure Panel

This panel lists the components (skins and contour/separator lines) of the composite structure. Its graphic 

representation (both cut and surface appearances) is shown in the Preview on the right. 

From the list, select the name of the item (skin, outside/inside contour line, or separator line) you wish to edit.
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When you select an item, an arrow appears next to the corresponding section of the Preview; or click in the 

Preview to select the corresponding item in the list.

The first listed skin is considered

• “Outside” when used with Walls

• “Top” for Roof and Slab

• “Reference Side” for Shells.

Change the order of skins by dragging them. The separator lines are not moved.

Edit a Skin

A skin consists of a Building Material, plus skin end lines.

Building Material: Click the pop-up to choose a different Building Material. 
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Skin End Lines: Check this box to display the end lines of the selected skin in the composite element. Use 

the pop-up to choose the pen of the two Skin End Lines of the selected skin.

If the box is unchecked, the skin’s end lines will be hidden, and the related controls will be grayed out.

Type: Click this pop-up to define the selected skin as either Core, Finish or Other. This definition will affect the 

Partial Structure Display of the composite element.

See also Partial Structure Display.

• You can define multiple skins as “Core,” but these skins must be adjacent to each other.

• You can define multiple adjacent skins as Finish, but they must include one or both of the outermost skins.

• If you change a skin type from “Core” to “Finish”, then every skin between the changed skin and the 

closest face will also change to a finish. (If there are an equal number of skins on both sides of the 

changed skin, then every skin between the changed skin and the inside face will also change to a finish.)

Skin Thickness: Enter a value for the thickness of the selected skin.

Total thickness: The total thickness of the composite structure is shown below.

Edit a Contour or Separator Line

Select a contour (outside/inside) or separator line in the dialog box.

To choose a different line type, click the pop-up.
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Show Line: Check this box to display this contour or separator line in the composite element. Use the pop-up 

to choose the pen of the selected line.

If the box is unchecked, the selected line will be hidden, and the related controls will be grayed out.

Insert Skin

With an existing skin selected in the dialog box list, click this button to insert a new skin above it, with a 

separator line on each side. A new skin is created of the same type as the skin you selected.

Note: A composite structure can have up to 48 skins.

Remove Skin

Click this button to delete the selected skin. The separator line above it will also be removed.
ARCHICAD 24 Reference Guide 3247



Dialog Boxes User Interface Reference
Use With

Click one or more icons - Wall, Slab, Roof and/or Shell - to indicate which of these elements should list the 

current Composite Structure among its structural choices. 

• This Composite Structure will appear in the composite pop-up of the corresponding element settings 

dialog boxes (Wall, Slab, Roof and/or Shell Settings). For example, in Slab Settings:
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Pens & Color Dialog Box

Open this dialog box from:

• The Pen Sets icon in the Quick Options bar

• Document > Pen Sets > Pens & Color or

• Options > Element Attributes > Pens & Color

If a model view window is active, the name of the dialog box is Pens & Color (Model Views); the pen set you 

choose here will be applied to the model views.

If the Layout Book is active, the name of the dialog box changes to Pens & Color (Layout Book), and the pen 

set chosen here is applied to the Layout Book.

Available Pen Sets Panel

Select a Pen Set for either Model Views or the Layout Book.

The Pen Sets listed here are predefined pen sets shipped with ARCHICAD. Each pen set name (e.g. 

Structural or Mechanical) indicates that the pen weights and colors associated with each pen in that pen set 

are optimized for its particular purpose (e.g. Structural plans).

• Rename: Click this button to give a new name to the selected pen set.
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Note: The Rename button will not create another copy of the selected pen set; the new name will replace 

the old one.

• Store as: If you have edited any controls of the selected pen set, the active pen set appears as “Custom” 

and the Store as button becomes active. Click it to save the Custom pen set:

- Store the pen set under a new name (enter any name into the field); or

- Overwrite a selected Pen Set with your custom Pen Set

• Delete: Click this button to delete the selected pen set.

See Delete and Replace Attributes in a Model.

Selected Pen Set Editing Panel

There are 255 pens represented in the tablet. Their index numbers are indicated by their position in the tablet. 

The top row contains pens 1 to 20 from left to right, the row below, pens 21 to 40, and so on.

There is a default color assignment for each pen, but you can edit any color for a specific pen by double-

clicking its color box or clicking the Edit Color button.

Note: To select continuous or discrete ranges of pens for simultaneous editing, use Shift-click and 

Control-click (Mac: Cmd-click), then click Edit Color.

The Edit Color dialog box appears, in which you can select your color graphically or numerically. This is a 

system-level control. (In case of multi-selection, the dialog box is called Edit Selected Colors.)

You can edit pen weight numerically using the fields in the Pens and Color dialog box. If you click on any 

color in a pen set, the Description field indicates the purpose for which the pen is optimized in this pen set.

If you have edited any of the selected pen’s controls, the name of the pen set changes to Custom. To save 

these changes, you must click Store As and name the pen set with a unique name, or overwrite an existing 

pen set.

ARCHICAD offers user-defined Pen Weights associated with each of the 255 Pen Colors. Pen Weights are 

measured in points or millimeters, depending on the current drawing units set in the pop-up menu next to the 

Pen Weight edit field.

• Pen Weights will be displayed accurately only if you choose True Line Weight in View > On-Screen View 

Options > True Line Weight. (Disabling True Line Weight here means that Line Weight will be shown as 

Hairlines: all lines are one pixel wide only. If you also enable Bold Cut Lines, then all Cut Lines will be 2 

pixels wide.)

Note: The Hairline option (achieved by disabling True Line Weight in On-Screen View Options) affects 

display only. For hairline output, use the Hairline checkbox in the Print or Plot dialog box.
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• Separate pens can be assigned to line arrowheads, various dimensioning components and vectored fill 

pattern strokes through the corresponding Tool and attribute dialog boxes.

Note: A Pen Weight of 0.00 always produces the thinnest weight possible (i.e., one pixel on the screen or 

a hairline on a laser printer, depending on the printer’s resolution).
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Surfaces Dialog Box

Use the Options > Element Attributes > Surfaces command to open this dialog box.

The top of the Surfaces dialog box contains the surface chooser and manager functions that are identical 

regardless of which PhotoRendering Engine is chosen.

The pop-up list at the top of the dialog box displays the surfaces available in the Project. At the top of the pop-

up list, you will see the name of the currently selected surface, and icons indicating whether this surface has a 

Vectorial Hatching and/or a Texture associated with it.

The ARCHICAD Library contains hundreds of pre-configured surfaces for every need. You can also access 

additional surfaces on BIM Components, using the Surfaces dialog box.

The Preview picture changes dynamically as you work in the Surfaces dialog box, so that you can see the 

effects of your settings. The Preview gives you an idea of what the chosen surface will look when rendered, 

depending on the rendering engine used.

Engine Settings: Choose a rendering engine from the list. 

For more information on rendering engines, see PhotoRendering Settings.
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Use the commands at the top of the Surfaces dialog box to create, rename, load, delete, and share surfaces.

For details, see Create, Load and Share Surfaces (All Engines)

The panels in the bottom part of the dialog box contain Surfaces that vary for the Basic (OpenGL) and 

Cineware Engine. These settings are described in the following sections.

Important: All surfaces are specific to the engine for which they are set up. If you change a surface 

parameter for one engine, those modifications will not take effect for the same surface parameter if you 

switch to another engine.

Surfaces (Cineware)

Surface Exposure to Light Panel (Basic Engine)

Surface Vectorial Hatching Panel (Basic Engine)

Surface Texture Panel (Basic Engine)
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Create, Load and Share Surfaces (All Engines)

Use the Options > Element Attributes > Surfaces command to access these functions.

Use the commands at the top of the Surfaces dialog box to create, rename, load, delete, and share surfaces.

Note: Cineware Settings have additional commands that allow you to load C4D surfaces and match 

Cineware Settings with those of other engines. See Match Settings with Cineware Surfaces.

Delete and Replace Surface

See Delete and Replace Attributes in a Model.

Share to BIM Components

Click Share to upload your surface to BIM Components.

When you share a surface, ARCHICAD creates a .gsm file and sends it to BIM Components. A surface .gsm 

is a special subtype of the a regular (object) .gsm file. It contains all surface settings data, as well as fill 

(vectorial hatch) and texture information.

For general information on BIM Components:

See BIM Components.

For information on registering for BIM Components see Obtain BIMcomponents.com Registration Number.

Create or Add a New Surface

In Surfaces, click the New button.

In the New Surface dialog box, choose one of the following:

• Duplicate (Re-create an existing Surface with a new name)

• New from catalog (Use this to replace the current surface with one imported from the catalog, together 

with any associated texture file and/or fill attribute)

• Replace Settings from Catalog (Use this to replace the settings only of the current surface with those of a 

surface selected in the catalog)
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Duplicate Current Surface

1. Enter a new name for the surface.

2. Edit the current surface parameters in the Surfaces Settings dialog box.

3. Click OK.

New from Catalog

Use this to replace the current surface with one imported from the Catalog.

When you click OK to close the dialog box:

• the surface is shown in the Surfaces dialog

• the surface is added as a new Surface Attribute to your ARCHICAD project

• the associated texture file is added to your Embedded Library, and any fill (vectorial hatch) is added to the 

project’s Fill attributes.

Texture Naming Conventions

Surfaces contain references to texture files placed into the library, where they are differentiated by name only 

- even their file extension is not taken into account. If you download a surface which uses a texture with the 

exact same name as a texture already in the AC Library, you will get a warning that the new texture was not 

put into the library).

The file names of many textures in the Surface Catalog contain postfixes which help to distinguish their 

usage:

• c for images in the Color channel

• d for Diffusion

• l for Luminance

• t for Transparency

• r for Reflection

• ro for Roughness

• e for Environment

• f for Fog

• b for Bump
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• n for Normal

• a for Alpha

• s for Specular

• gl for Glow

• dp for Displacement

• gr for Grass

• -opt for images used by the OpenGL and Basic Rendering Engine

If an image is used by multiple channels, then the postfixes are added up, e.g.: cs for color and specular 

channel usage.

 Replace Settings from Catalog 

Use this to replace the settings only of the current surface with those of a surface selected in the catalog. 

Notes:

– In contrast to the New from Catalog function (described above), the original surface’s Name and Index 

number (as listed in Attribute Manager) will remain unchanged even after the settings have been 

overridden.

– Although surfaces can include a vectorial hatch (used to display surfaces in certain ARCHICAD 

views), this Replace Settings function will not overwrite the vectorial hatch (if any) of your original 

surface; that vectorial hatch remains unchanged in the project (and continues to be listed as before in 

Attribute Manager).

These two options access a catalog of surfaces built in to the ARCHICAD Library. The number of factory-

shipped surfaces in the catalog depends on your ARCHICAD license.
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Search for Surfaces in the Catalog

To search for surfaces by name in all the loaded libraries as well as BIM Components, enter a search term in 

the field.

Depending on the pop-up control at right, the engine will search in one or both of the following locations:

• Search Active Library: this includes linked libraries, the Embedded Library, and BIMcloud Libraries you 

have downloaded

• Search BIM Components Portal: This option searches on BIM Components, a searchable and 

interactive depository of objects contributed by ARCHICAD users or uploaded by GRAPHISOFT.

For more information, see BIM Components.

Start Search

Enter any string of characters to search for.

Once you press Enter or end your input (no input for 1 second), the search process will begin.

The search engine will search for the string in the following locations:

• Library Part name

• Library name

• Description 

• Subtype

• Name of author of Library Part
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• Keywords

The dialog box displays your search results. Only surfaces will be listed (no other element types).

If you searched in both, surfaces found in the active libraries are shown first. BIM Components hits follow 

below. The dialog box will display a maximum of 50 of found items; if more are found, you can see the 

remaining hits by clicking on the More Surfaces on BIM Components.com button at the bottom of the dialog 

box.

• BIM Components-based hits are distinguished from active library hits with a globe icon.

• Some of the BIM Components-based hits will be marked with a key. Such items are available only to users 

with some type of premium service agreement. (This may vary by market; contact your distributor.)
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Additional Surface Catalog for SSA Users

ARCHICAD users with an active ARCHICAD Software Service Agreement (SSA) can access additional 

surfaces, available as one-click downloads to the current project. This premium surface catalog is available to 

SSA users directly from the Add New Surface dialog box: click on the Additional Surface Catalog for SSA 

Users command from the pop-up button at the bottom of the dialog box. This command will check your 

license eligibility, then redirect you to the expanded surface catalog (if you are eligible) or to more information 

on the required license (if you are not).

Surfaces Found

Hover the cursor over any found surface (or select it, then click the info button at the bottom right of the dialog 

box) to see an information tag listing its Name, License type, and Location (including the name of the library in 

which it was found, e.g. the Embedded Library, or the name of the BIMcloud Library).
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Download Surface from BIM Components

If a surface found on BIM Components suits your needs, you can download it directly into your project.

Use the Download and Embed command to drag and drop the surface anywhere onto the ARCHICAD project.

• the surface is added as a Surface Attribute to your ARCHICAD project

• the associated texture file is added to your Embedded Library; any associated vectorial fill is added to 

your project’s Fills.
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Match Settings with Cineware Surfaces

Load Cinema 4D Settings

Use this command to import the settings of a specific Cinema4D material from an external file; these settings 

will be loaded for the current surface in ARCHICAD.

From the Match Settings pop-up in Surfaces, choose the Load C4D Settings command.

In the appearing dialog box, browse for a Cinema 4D file. This can be either a single material or an entire 

model in Cinema 4D format.
ARCHICAD 24 Reference Guide 3261



Dialog Boxes User Interface Reference
If you choose a model file, a chooser dialog box appears: select the Cinema4D Material you need. 

Click OK to load the chosen material. Its settings override those of your current surface.

Notes: 

- The maximum number of parameters that can be used in a surface is 1024. (See Limit on Number 

of Surface Parameters, below).

- Node-based Materials from CINEMA 4D are not supported in ARCHICAD. Such imported materials 

will be displayed with a specially generated material instead.

Match Cineware Settings with Basic Engine

All surfaces are specific to the engine for which they are set up: Basic (including OpenGL) or Cineware. If you 

change a surface parameter for one engine (e.g. Basic), those modifications will not take effect for the same 

surface parameter if you switch to another engine (e.g. Cineware). Generally, Cineware contains a larger 

number of more sophisticated parameters than the Basic or OpenGL engines (which are very similar to each 

other).

Two commands are available to help synchronize the appearance of surface defined in Cineware with its 

appearance for the Basic (or OpenGL) engine. Note that due to the difference in parameters, the result might 

only be an approximation. Generally, the basic parameters of simple surfaces will be matched accurately.

From the Match Settings pop-up in Surfaces:

Update Basic Settings (from Cineware): This will apply the Cineware surface settings to its surface 

counterpart in Basic/OpenGL.

Note: Because the Basic/OpenGL engine uses relatively few parameters, the effect of this command may 

be minimal. In particular, the parameters of procedural surfaces (in Cineware) cannot be replicated in 

Basic/OpenGL. 

Update Cineware Settings (from Basic): This will apply the Basic/OpenGL surface settings to its surface 

counterpart in Cineware.
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Limit on Number of Surface Parameters

Because of the many layers of shaders available for Cineware surfaces, you could, in theory, set an unlimited 

number of parameters for a given surface. 

However, in ARCHICAD, the maximum number of parameters that can be used in a surface is 1024. 

(ARCHICAD uses the surface attribute in GDL objects, too, and the GDL programming language sets a limit 

of 1024 parameters.) 

You may encounter this limit

• when loading a surface from a Cinema 4D file (see Load Cinema 4D Settings, above)

• when configuring your own custom surface

The solution is to limit the number of shaders used in the surface, and/or to use a more simple shader 

structure (limiting the number of embedded layers).
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Surface Exposure to Light Panel (Basic Engine)

(Options > Element Attributes > Surfaces)

The controls in this panel will affect renderings created by the Basic Rendering Engine and the Open GL 

engine.

Surface color: Define the surface’s color by double-clicking the box. This opens the Edit Color dialog box 

where you can select your color graphically or numerically by mixing the HSL (Hue-Saturation-Luminosity) or 

RGB (Red-Green-Blue) components.

The rest of the attributes in this panel are set as a percentage of their theoretical limits. You can edit the 

values either numerically or with a sliding switch.

Transparency attributes control how light penetrates the selected surface. Use the following two controls to 

adjust transparency:

• Transmittance: The higher the value, the greater percentage of light is transmitted through the surface. 

Glass is at the top of the scale and opaque surfaces are at the bottom.

• Attenuation controls how sharply transmittance diminishes as the object’s surface becomes less 

perpendicular to the viewing direction. Any number in a continuous range from zero to 100 can be set.

Emission is a measure of a surface’s fluorescence (i.e., the light emitted by its surface).

• Use the Attenuation control to adjust the emission intensity of the selected surface. Emission intensity 

decreases as attenuation increases (i.e., the viewpoint is moved farther from the object).

• Click the Emission color control to bring up the Edit Color dialog box. Select your color graphically or 

numerically by mixing the HSL (Hue-Saturation-Lightness) or RGB (Red-Green-Blue) components.

Note: If shadows don’t appear on a surface where they should, check the Emission color. If a surface’s 

Emission color is white, then shadows will not appear. Changing the Emission color also affects the color 

and intensity of shadows.

In the image below, the first two surfaces have Emission color set to black and red; the third surface has an 

Emission color of white. 
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The Surface’s Reflection has three attributes:

• The Ambient control sets the percentage of ambient light the surface is able to reflect. This determines 

how much a surface is subject to brightening effects (as opposed to shades or highlights caused by 

directional light).

• The Diffuse control describes the surface quality of the surface. Uneven or rough surfaces tend to reflect 

incident, directional light in a non-directional, diffuse way. Diffuse reflection carries the color of the surface 

rather than the color of light.

• Shininess is the ability of a curved surface to reflect directional light from a point-like source (sun, 

flashlight, spots, etc.), in a more or less focused fashion. The more focused the reflection, the shinier the 

surface appears. Highlights are confined to a small area if this control is set close to 100, while a wider 

highlight area will result if the control is set to a low value.

The Surface’s Glowing is determined by its Specular setting.

• The Specular setting is the opposite of Diffuse. It is a directional reflection carrying the color of the 

incident light rather than that of the surface. An extremely smooth and saturated hard surface will produce 

strong specular reflections (set at close to 100%), while a soft and light surface will produce hardly any 

(set at close to 0%).

• Specular Color is theoretically identical to the color of directional light, but the program lets you define it 

independently. Double-click the sample color here to display the system-level Edit Color subdialog box, in 

which you can establish your definitions. This color, mixed with the Surface color and the color of the light, 

will determine the color of the surface where directional light is reflected.
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Surface Vectorial Hatching Panel (Basic Engine)

(Options > Element Attributes > Surfaces)

On the Vectorial Hatching panel, you can choose a vectorial fill pattern and pattern color for the chosen 

surface.

Note: When assigning a 3D Vectorial Hatching in the Surfaces dialog box, you can access only fills 

defined as Cover Fills.

Note: Vectorial Hatching does not affect PhotoRenderings, so the Preview window (generated by the 

chosen PhotoRendering engine) will not reflect the modifications you make in this panel.

• Use the fill pop-up palette to select a vectorial fill.

• Check the Element Pen radio button to display the vectorial pattern in the color assigned to the uncut line 

pen.

• Alternatively, choose any other color from the pencolor pop-up.
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Surface Texture Panel (Basic Engine)

(Options > Element Attributes > Surfaces)

The controls in this panel will affect PhotoRenderings created by the Vectorial 3D Engine and 3D views 

generated by the Basic 3D engine.

Choosing and Editing a Texture

On the Texture panel, you can link a Texture to any standard or custom Surface.

If the selected Surface already has a Texture linked to it, the texture’s file name and preview picture are 

displayed, along with the image size in pixels.

To assign a Texture to a Surface:
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• Click the Browse button to open the Load Image from Library dialog box and find the needed texture 

map.

See also Texture Naming Conventions.

• Click OK to assign the texture.

• Another way to choose a texture is to click the Previous/Next arrow buttons below the preview window. 

ARCHICAD will load the previous/next texture file from the loaded libraries.

Note: Only files in the project libraries are available for selection. If you save your Project as an Archive, 

all associated Textures can be saved with the Plan by checking the Include Linked Textures checkbox. If 

a linked texture is missing from the Active Library, its name will appear in the Missing Library Items list.

Click Remove Texture to unlink the Texture from the Surface.

In the middle of the dialog box, a number of controls allow you to define the texture display.
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• Define the vertical/horizontal size of the texture as applied to 3D surfaces. For example, if the image 

shows two bricks, set its size to match the physical size of the bricks.

• Check the Keep Original Proportion checkbox if you want to keep the proportions of the original texture 

file for all elements.

• Define the angle at which the texture is applied to elements.

• Use the four rotating and mirroring radio buttons to arrange the texture sequence.

Note: For good results, you need textures prepared for seamless tiling. These are images that can be 

placed in a matrix with no apparent line at connecting edges.

• Activate the Random Origin checkbox to use a random starting point for applying the texture. This option 

is useful if there are several identical elements in the model that should differ in appearance.

Use the Sample pop-up list to adjust the number of texture units displayed in the Preview box - this helps you 

get a better idea of what the texture will look like.

Alpha Channel Effects

At the right side of the Surfaces dialog box (Texture Panel), options are provided for Alpha Channel control.

In 32-bit color images, the Alpha Channel is an extra channel (in addition to RGB components) that can be 

edited in image editing applications such as Adobe Photoshop. ARCHICAD allows you to take advantage of 

the information placed in the Alpha Channel in several ways:

• for masking elements in PhotoRenderings.

• for transparency or bump mapping.

• to model certain surface properties of the texture.
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Surface: If the alpha value is white, then you get the color of the texture, while if it is black, then the surface’s 

original color will be valid in the given pixel of the given surface. If the value is a shade of gray, then the two 

colors will be mixed and the result will appear in the PhotoRendering.

Ambient: The same as above, but applied to the Ambient color instead of the Surface color.

Specular: Controls to what extent the Specular effect is taken into account. If the alpha value is white, the 

Specular effect is entirely taken into account at the given pixel. If the alpha value is black, the Specular effect 

is entirely disregarded at the given pixel. Here again, intermediate values are allowed.

Diffuse: Controls the effect of diffuse light the same way as with Specular light.

Bump Mapping: Controls the surface normal at the given pixel, allowing for a convex effect on the surface. 

White values represent bumps, while black values represent holes.

Transparency: If the value is white, then the color of the texture is visible; if it is black, the texture will be 

perfectly transparent at the given pixel. Intermediate values are allowed.
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Add-On Manager

Use the Options > Add-On Manager command to open the Add-On Manager dialog box.

For more information on this topic, see Add-Ons and Goodies.

Click the header fields to sort data by that column. Use the splitter bars to edit column width.

Available Add-Ons Panel

Here you can load or unload Add-Ons by switching the checkboxes on and off, then check OK to close the 

dialog box and execute the changes.

If you see a checkmark in front of the name of an Add-On without a box, this means that the Add-On must 

always be loaded with ARCHICAD.

The Type column refers to the type of the Add-On, which can be Tool or Imaging.

• Tool type add-ons which are loaded by default appear as menu commands in the Standard Work 

Environment profile. You can customize their location like any other menu command. Other Tool-type add-

ons, after being loaded manually, will be placed in a menu according to the location of that menu’s Add-On 

Anchor Point.

• Imaging type add-ons add rendering or animation options to View menu items.

The icons in the Mode column show whether the Add-On was loaded individually or as part of an Add-On 

folder set to be available automatically at each startup.
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Add-On Info Panel

The Add-On Info panel contains information on the interface location and operation of the Add-On selected in 

the Available Add-Ons panel.

Edit List of Available Add-Ons Panel

In the Edit List of Available Add-Ons panel, you can add more Add-Ons, remove items from the list and 

redefine the location of the dedicated Add-On folder.

The Use designated Add-Ons folder checkbox will activate the folder enabled by default (the Add-Ons 

folder in your ARCHICAD Folder) or another dedicated folder that you can choose with the Change button by 

browsing your computer.

If you are using such a designated folder, the add-ons made available from this folder cannot be removed 

from the list of available add-ons. However, they can be unloaded manually (by unchecking its name in the 

Load column) for the current ARCHICAD session. In this case, the rest of the add-ons which are still loaded 

from this folder will appear as individual add-ons in the Mode column.

If you load an Add-On that has the same name and ID as a loaded one, it will replace the previous one.

• All settings of the Add-On Manager will be preserved when you quit and restart the program, even if you 

choose New and Reset.

• If you open a Project that refers to currently unloaded Add-Ons, an alert will appear, listing the missing 

Add-Ons.

Some of the Add-Ons cannot be loaded until you restart the program, as they contain references to the project 

database. If loading such Add-Ons with the Add-On Manager, an alert will appear. If current modifications do 

not concern these Add-Ons, you can ignore the alert or choose to save the recent changes and reload the 

Project with the required loaded Add-Ons.
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Story Settings Dialog Box

To open this dialog box, do one of the following:

• Use the context menu of a Story tab

• Use the Design > Story Settings command 

• Choose Story Settings from the context menu of a selected Story, or the Stories folder, in the Navigator.

Use the splitter bars in the header to edit column width.

In the upper section of the dialog box, a scrollable list shows the current stories in your design. When starting 

a new project, you may have several stories already created by default. Every project must contain at least 

one story.

To activate a story, select it in the list and click OK. The Floor Plan will show this selected story. 

Note: You can also navigate among stories using the Navigator’s Project or View Map, or the story-related 

commands in the Mini-Navigator toolbar.

Insert Above/Insert Below: Click either button to create a new story above or below the story currently 

selected in the list.

When the name of a Story is selected, you can edit its Name, Elevation (to Project Zero), its Height to the 

Story above, and whether to show the Story Level line on sections. The Number field is not editable manually. 

Multi-selection is available, to edit these values simultaneously for multiple stories at once.

Changes to story height and elevation are interpreted differently:

• If you modify the height of a story, this will affect the elevation of all stories above (if the story number is 

positive) or below (if the story number is negative). In practical terms, you stretch or shrink the whole 

building by making the height of a story larger or smaller. The height of all other stories remain as they 

were.
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• If you modify the elevation of a story, this will affect the heights of the stories immediately above and 

below. In practical terms, you move the level of a single story while keeping the rest of the building static. 

The elevation of all other stories remain as they were.

Note: Changing story heights may result in inverted elements: their top elevation will fall below the bottom 

elevation. 

See Inverted Elements.

Show Level on Sections (icon at far right in Story Settings): Check this box to display Level Lines of this 

Story in Section view.

For more information, see Show/Hide Story Level Lines in Section/Elevation/IE.

Delete Story: Click this button to delete the selected story.

Warning: If you delete a Story, all elements that had that story as their Home Story will also be deleted!

Warning: The undo queue is cleared entirely whenever you delete or add a story, or change story height.
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Edit Elements by Stories Dialog Box

Use this dialog box to cut-paste or copy-paste elements from one story to another, or to delete elements on a 

given story.

To open this dialog box, do one of the following:

• Select any Story item from the Navigator’s Project Map, then click Edit Elements by Stories from the 

context menu.

• Design > Edit Elements by Stories

• Edit > Move > Edit Elements by Stories

Select Element Type

At left is a list of element types. By default, they are all checked.

Note: Not all tools are included in this list, because not every element type can be copied from one story 

to another. For example, Section and Elevation lines cannot be copied among stories, and these tools are 

not included in the list.

Adjust these so that the element types you want to cut/copy/delete are checked story.

Select Action

Choose either Copy, Cut or Delete. (There is no separate Paste command. If you choose “Copy” or “Cut”, you 

will then be able to paste those elements to any story.)

From Story:

From the drop-down list, choose the Story whose elements you want to edit (i.e. cut, copy or delete).

To Story: (not available if you selected “Delete”)

From the drop-down list, choose the Story to which you want to paste the cut or copied elements.

Click OK. This will carry out the action, close the dialog box and activate the selected story on the Floor Plan.
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Floor Plan Cut Plane Settings Dialog Box

Use Document > Floor Plan Cut Plane to open the Floor Plan Cut Plane Settings dialog box.

Cut Plane height to Current Story

Enter the height at which elements will be cut for display on the Floor Plan.

The other options in this dialog box - Relative Floor Plan Range and Absolute Display Limit - will be 

applied only to construction elements whose “Show Projection” setting (in the Settings dialog box) is set to 

use one of these two definitions. These definitions set a limit on how much of the element is to be displayed, 

relative to the current story.

Relative Floor Plan Range

Use these controls to define the Relative Floor Plan Range for construction elements that use this definition.

Show up to: Enter the number of stories you want to display the element above the current story.

Offset by: Optionally, enter a positive or negative elevation value by which to offset the “Show up to” 

display limit.

Story pop-up: Choose either Current Story or, if you want to display the element on additional stories above 

the current one, Story(s) above.

Show down to: Enter the number of stories you want to display the element below the current story.

Offset by: Optionally, enter a positive or negative elevation value by which to offset the “Show down to” 

display limit.

Story pop-up: Choose either Current Story or, if you want to display the element on additional stories below 

the current one, Story(s) below.

Absolute Display Limit

Use these controls to define the Absolute (lower) Display Limit for construction elements that use this 

definition. This limit is in effect regardless of the currently active story.

Show down to: Enter the fixed lower limit to which elements will be projected. (By default, this is Project 

Zero.)

Offset by: Optionally, enter a positive or negative height value by which to offset the “Show down to” 

absolute display limit.
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Copy Dialog Box

This dialog box appears if you have copied a Marquee area from the 3D window (using the 2D Marquee 

option of the Marquee tool), when using the Vectorial 3D Engine.

For details, see Copy/Paste Marquee Area from Project Window.

Copy/Save as:

• Painting Screenshot will copy the contents of the 3D Window as a unified picture (Figure).

• When choosing Drawing, the resulting image will consist of the parts described in the dialog box. The size 

of the picture obtained will be equal to the size of the image in the 3D Window. This is important when 

pasting the copied parts into another application such as SuperPaint or Photoshop.

• The Scaled drawing option creates an image that keeps the sizes of the Floor Plan. If you paste a Side 

view of the Project on the Floor Plan using the Scaled drawing option, the sizes will match the sizes of 

the plan.

With the Elements to Copy pop-up menus you can define which elements of the 3D View you want to copy to 

the Clipboard.

The Shadows pop-ups are available only if the Sun Shadows is “On” in 3D Styles (View > 3D View Options > 

3D Styles.)

Copying the shadows of top views can be useful if you want to place accurate, measurable shadows on the 

Floor Plan. Shadows and 3D hatching of orthogonal views add a further touch of realism to elevation 

drawings.

The 3D Hatching pop-ups are available only if the Vectorial Hatching option is “On” in 3D Styles, and if the 3D 

view contains at least one element that has 3D hatching applied.
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In the lower part of the dialog box you can define whether to save/copy invisible Polygons (for example, the 

polygon elements of a window behind a wall) or only visible ones. You also have the option of copying the 

polygons with or without frames.

You will see the Remove Redundant Lines checkbox if you want to copy the selection in Drawing or Scaled 

drawing mode from a wireframe or a hidden line picture. If you check this checkbox, lines exactly on top of 

each other will be omitted in the copied file.

Hint: If you want to copy the elements of the 3D Window, e.g., for an elevation view, it is recommended to 

use the Calculate split polygons and Frameless options.
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Linework Consolidation Settings

To access this dialog box, you must first select at least two line-type elements. Use Edit > Reshape > 

Linework Consolidation... command.

For general information on this feature, see Consolidate Lines and Fills in Drawing Windows.

The first time you execute this command, you will bring up the Linetype Consolidation Wizard.

The wizard takes you through the Consolidation options one by one. Note that each line consolidation option 

builds on the previous one; the program will execute the consolidation in the order in which they appear in the 

Wizard.

Delete Duplicates: Duplicate lines are those which have identical attributes and positions. One line will 

remain, the rest will be deleted.

Explode Polylines into Drawing Primitives: Polylines will be exploded into multiple single lines.

Linework Attribute Merge Settings

Check any or all of the following attributes:

• Layer

• Pen

• Category
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Checking an attribute here means that the program will not take these attributes into account when merging 

connecting or overlapping lines.

• For example, if you check “Pen”, then the program will merge overlapping or connecting lines even if the 

lines do not use the same Pen (e.g. one line is blue and the other is red).

For each checked attribute in this dialog box, the Layer/Pen/Category controls are activated, so that you can 

assign a layer/pen/category for the lines which result from the merge process.

• For example, after checking Pen, you must decide whether the new line, merged from the original red and 

blue lines, should henceforth be red, blue, or any other color.

Merge Connecting Lines: Co-linear line segments which are connected and which have identical line types 

will be merged into a single line.

Merge Overlapping Lines: Lines which partially overlap and which have identical line types will be merged 

into a single line.

Merge Settings

If you have selected either or both of the two Merge options (Merge Connecting Lines/Merge Overlapping 

Lines), use the next screens to define the attributes of the lines which result from the merge process.

(If you are using the single-page Linework Consolidations Settings instead of the Wizard, click Merge Settings 

to access these options.
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Force Solid Lines: This option is useful if several lines overlap each other, and one of them is a solid line 

which completely overlaps the other line(s). Checking this box will delete the other line(s), with the single solid 

line remaining in place.

Adjust Overlapping Lines: This option will apply if two or more lines of different line types partially overlap 

each other. If you check this box, only the topmost line (as defined in the display order) will remain in place of 

the overlapping part.

Click Consolidate to carry out the Linework Consolidation and to display a Summary of the result.
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On the last screen of the Wizard, check “Display simple Linework Consolidation Settings next time”. This way, 

the next time you use the Edit > Reshape > Linework Consolidation command you will access the 

simplified Settings dialog box.
ARCHICAD 24 Reference Guide 3282



Dialog Boxes User Interface Reference
Fill Consolidation Settings

To access this dialog box, you must first select at least two fill-type elements. Use the Edit > Reshape > Fill 

Consolidation command.

For general information on this feature, see Consolidate Lines and Fills in Drawing Windows.

Trim Overlapping Fills: Any selected fills that partially or entirely overlap each other will be trimmed so that 

only the top fill remains; any other fill (or part of a fill) that is covered up beneath the top fill will be deleted.

Note on Overlapping Fills with Transparent backgrounds: If the top-level fill has a transparent 

background, any solid-background fill beneath it will remain intact, because it will be visible.

Exception: If there are multiple transparent fills atop each other, only the top-level fill will remain in full; 

any fills or parts of fills underneath, if they have transparent backgrounds and are covered by the top-level 

fill, will be deleted.

Convert Fill outlines into Lines and Arcs: Any fill contours will be exploded into simple line segments/arcs.

Merge identical adjoining Fills: Any adjoining fills (regardless of display order) which have identical fill 

patterns/colors will be merged into one.

Note: In Merge Identical adjoining Fills, “identical” means that fills must have identical fill patterns, 

identical foreground/background colors, and identical orientations. Fills that have different pattern 

orientations (project origin/fill origin/distorted) will not be merged.

The resulting fill will carry the ID of the largest of the original fills.

Outlines of Merged Fills: If you checked “Merge identical adjoining fills,” three different options are activated.

• Don’t merge any Fills that have outlines: Such fills are not merged at all.

• Merge identical Fills if they have identical outlines: Only those fills will be merged which also have 

identical outlines.

• Merge identical Fills regardless of their outlines: All identical fills are merged, whether they have 

outlines or not, and whether the outlines are the same or not. If you check this option, additional controls 

are activated to let you define the line type and pen of the outlines that will result after consolidation.

Note: If you checked “Convert Fill outlines into Lines and Arcs”, these options are not available, since the 

fill outlines will no longer exist after the consolidation process.

Fills that have different pattern orientations (project origin/fill origin/distorted) will not be merged.
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Merge Settings: If you have selected “Merge identical adjoining fills,” the Merge Settings button is activated. 

Click to access Fill Merge Settings to define the attributes of the lines which result from the merge process.

Check either or both of these attributes:

• Layer

• Category

Checking an attribute here means that the program will not take these attributes into account when merging 

adjoining fills.

• For example, if you check “Category”, then the program will merge adjoining fills even if the fills are not 

assigned to the same Fill Category (e.g. one fill is a “Drafting” fill, the other is a “Cover” fill.

For each checked attribute in this dialog box, the Layer/Category controls are activated, so that you can 

assign a layer/category for the fills which result from the merge process.

• For example, after checking Category, you must decide whether the new fill, merged from the original 

Drafting and Cover fills, should henceforth be a Cover fill, a Drafting fill or a Cut fill.

Related Topics:

Fill Categories
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Model View Options for Construction Elements

Construction Element Options

To access this panel, go to Document > Model View > Model View Options.

For general information, see Model View Options.

A preview window next to each settings group indicates the result.

Column

• Check with Symbol to display the symbol chosen in Column Settings (Floor Plan and Section panel > 

Floor Plan Symbol) for each column.

• Hidden Line under Slab: Check this to display Columns underneath Slabs, using Hidden Line. (Define 

Hidden Line attributes in Column Settings.)

Beam

• Contour and Axis

• Axis Only

• Contour Only

Note: You can override the Axis/Contour settings for individual Beams in Beam Settings (Floor Plan and 

Section Panel).
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• Hidden Line under Slab: Check this to display Beams underneath Slabs, using Hidden Line. (Define 

Hidden Line attributes in Beam Settings.)

Watch the Video

Slab

For adjoining Slabs (with identical top surfaces in the same plane): 

Choose an option to display or hide the dividing line.

• Show Lines

• Eliminate Lines

• Use Hidden Lines

Watch the Video

Door/Window

Set these options separately for Doors and Windows.

• Show entire Door/Window: Doors/windows will be displayed with the appropriate symbol on the Floor 

Plan and in Section-type views.

with Marker: Check this box to display doors/windows with Markers (if assigned in the Settings dialog 

box.)

• Show Opening Only: The place of the doors/windows (but not the doors/windows themselves) will be 

indicated by openings in the walls, in both Floor Plan and Section views.

with Contours: The door/window openings shown on the Floor Plan will include contours.

• Hide on Floor Plan: No placed doors/windows or openings will be shown on the Floor Plan. (In Section-

type views, openings only will be shown.)

Skylight

• Show Entire Skylight: Skylights will be displayed on the Floor Plan and in Section-type views, in 

accordance with the Floor Plan Display preferences of the host Roof or Shell.

with Markers: Check this box to display Skylights with their Markers (if any Markers are assigned in the 

Skylight Settings dialog box.)

• Show Opening Only: The place of the Skylights (but not the Skylights themselves) will be indicated by an 

opening in the Roof/Shell, on both Floor Plan and Section views.
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• Hide on Floor Plan: No placed Skylights or Skylight openings will be shown on the floor plan. (In Section-

type views, openings only will be shown.)

Opening

• Show with Symbol: Openings displayed on the Floor Plan and in Section views, together with their 

symbol.

• Show Opening Only: No Symbol is displayed

• Hide: Openings hidden in all views (including Floor Plan, 3D and Section)

Zone

• Show Zone Stamp: Check this box to display Zone Stamps in your project.
ARCHICAD 24 Reference Guide 3287



Dialog Boxes User Interface Reference
Detail Level of Door, Window and Skylight Symbols 

To access this panel, go to Document > Model View > Model View Options.

• This panel and its contents depend on the libraries you have loaded. (You may have multiple panels, one 

for each loaded library in your project.)

• Library objects located in that specific library will be globally displayed according to the Model View 

Options set here.

Override Detail Level for Particular Door/Window/Skylight

Model View Options affect all Doors/Windows in the project by view.
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To override the MVO-defined Detail Level settings for any particular Door/Window, use the Door (Window) 

Settings and Opening tab page of the Door or Window’s Custom Settings panel.

See Door/Window Settings and Opening.
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Miscellaneous Settings for Library Parts

To access this panel, go to Document > Model View > Model View Options.

• This panel and its contents depend on the libraries you have loaded. (You may have multiple panels, one 

for each loaded library in your project.)

• Library objects located in that specific library will be globally displayed according to the Model View 

Options set here.

• Options will be applied only to objects whose GDL script is programmed to allow for this.

In the INT version of ARCHICAD, the panel looks like this:

Show Minimal Space of Door and Object

Check this box to show the objects’ and doors’ minimal space on the Floor Plan by displaying a contour and fill 

corresponding to the minimal space parameter. Choose options for the contour’s line type and pen, and for 

the fill type/pen/background.

Minimal Space contour/fill display is shown for all doors and objects which have a defined Minimal Space 

parameter.
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• For Doors, set these parameters in the Minimal Space tab page of Door Settings (Custom Settings panel).

See Minimal Space.

• For Objects, use the Minimal Space parameters in Object Settings.

Object and Lamp Detail Level

Set the Detail Level on Floor Plan:

• Full, Medium, or Low

and in 3D Projections:

• Full, Simplified or Schematic

Objects and Lamps use the detail level settings defined here by default (By MVO). For a specific object/lamp, 

if the control is available, you can override its detail level in Element Settings (use the 2D or 3D 

Representation controls)

See 2D and 3D Representation of Objects.

Lighting and HVAC Plan Symbols

Choose one of the options for displaying the Floor Plan Symbols of Lighting and HVAC objects (e.g. ceiling 

lamp, smoke detector, air diffuser) in the project.

• Realistic

• Electric

• Reflected Ceiling Plan

Accessories in 3D

Click the toggle buttons to show or hide these types of accessories in 3D: 

• Object Knobs in 3D

• Object Taps in 3D

• Door Handles and Knobs in 3D
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Elevator Car

Set options for the display of the Elevator Object’s Car component:

• Show/Hide Car in 3D and Section/Elevation

• Show/Hide Elevator Doors in Floor Plan/Section, or display just the opening

Object MEP Connections

Elements compatible with MEP Modeler include Connections to enable connection to any object in an MEP 

route. 

Use this checkbox to show or hide these Connections.

Doors/Windows/Skylights Opening Line on Floor Plan

• Opening Line style: Curved or Straight

• For Sliding Doors and Windows: None or Arrow

• Line Type and Pen for the opening line

Opening Lines in 3D Projections

Click the toggle buttons (Door, Window, Skylight) to show or hide their opening lines in the 3D window.

• Choose lines (dashed, solid, dotted) for the opening lines on the opening and opposite sides.

• Choose either Handle or Hinges to set the opening lines’ orientation.

Note: This option is scale-dependent (generally, opening lines are not displayed at small scales).

Override Model View Options for Particular Door/Window

Model View Options affect all Doors/Windows in the view. To override Door/Window opening lines settings for 

any particular Door/Window, use the Opening Lines tab page of the Custom Settings panel.

See Opening Lines (Door/Window).
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3D Document Settings

The 3D Document Settings dialog box is available from:

• the context menu of any 3D Document item listed in the Navigator

• the Settings button at the bottom of the Navigator Project map, if a 3D Document is selected

• the context menu of a 3D Document window

• the Document > Documenting Tools menu

For general information on this topic, see 3D Document.

3D Document General Panel

Reference ID: An ID is assigned by default; you can change it by typing any other value into the field. This 

field can contain up to 256 characters; the ID will serves to identify the 3D Document in the project window 

and in the Navigator.

Name: This field can contain up to 256 characters. This name appears in the Navigator palette and the title 

bar of the 3D Document window.

• In 3D Document Default Settings, you can activate the Source View Name icon: this will automatically 

assign the source view as the name of the newly created 3D Document.

Note: This will only set the name of the source view at the time of creation; it will not automatically follow 

story name changes. Later, you can change it to any custom text. 

Status: Choose an option to define the status of the link between the 3D Document and the Model.

• Auto-rebuild Model: A 3D Document with Auto-rebuild status will be automatically rebuilt every time it is 

opened or brought to the front of the screen, if the model has changed.

• Manual-rebuild Model: A 3D Document with Manual-rebuild status is not rebuilt automatically. It can be 

rebuilt from the model only by using the View > Refresh > Rebuild from Model command. (The same 

command is available from the 3D Document window’s context menu, and from the Project Map item’s 

context menu.)

Note: There is no Drawing-type 3D Document.
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3D Document 3D Projection Panel

This panel is only available for a selected 3D Document that is based on the 3D window.

This panel provides information on:

• the 3D window source of the selected 3D Document (is it limited by selection/marquee, or not?); and

• the current 3D window (is it limited by selection/marquee, or not?)

The next three controls allow you to redefine the selected 3D Document:

See also Redefine the 3D Document.

Redefine 3D Projections: Click this button to access the dialog box needed to readjust the 3D projection of 

the source 3D window. Once you press OK and leave the Settings dialog box, the selected 3D Document will 

be redefined according to this modified 3D projection.

See also 3D Projection Settings.

Redefine Filter Elements: Click this button to access the Filter and Cut Elements in 3D dialog box. Make 

any adjustments you need to the source 3D window., then close the Filter Elements in 3D dialog box. Once 

you press OK and leave the Settings dialog box, the selected 3D Document will be redefined according to this 

modified element filter. 

See also Filter and Cut Elements in 3D Dialog Box.

Redefine the Projection, Cutting Planes and Visible Elements based on Current 3D window: Check this 

box to redefine the selected 3D Document based on the projection, the cutting planes, and the visible 

elements in the current 3D window.

Note: This checkbox has a one-time effect: the content of this 3D Document will not be automatically 

redefined again if the 3D window is changed. The next time you open this settings dialog, the checkbox 

will appear unchecked.
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3D Document Floor Plan Projection Panel

This panel contains options for 3D Documents based on a Floor Plan Projection (rather than the 3D window).

Source View: Shows the name of this 3D Document’s Source Floor Plan view.

Direction: Choose an option to define which direction to project the view from the cut plane:

• Reflected Ceiling: “Upward” projection from the cut plane. Will display the mirror image of the overhead 

part of the model.

Define the extent of the projection: for example, show up to 1 Story above.

Optionally, define a positive or negative offset from the projection’s story limit.
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• Floor Plan: “Downward” projection from the cut plane (down to the floor): for example, show down to 1 

Story down.

Optionally, define a positive (upwards) or negative (downwards) offset from the projection’s story limit.

Cut Plane Height: Define the height of the cut plane from which to create the Floor Plan Projection. Cut Plane 

Height is measured from the Floor Plan story that is the source of the 3D Document.

Selection/Marquee Information: The dialog box provides information on the Floor Plan source of the 

selected 3D Floor Plan Document. It indicates whether a marquee or selection was present on the Floor Plan 

at the time the 3D Document was generated: this limited the content of the resulting 3D Document.

Note: The Floor Plan source window is not necessarily the same as the currently open Floor Plan window.
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If you have checked the Redefine box below, you are given information on whether the resulting, redefined 

3D Document will be cropped, or whether it will show the entire model.

3D Document Model Display Panel

Unlike for a Section-type window, the 3D Document’s Model Display settings enable you to choose surfaces, 

element-specific fills and shaded or non-shaded colors to display cut surfaces, for the current 3D Document 

only.

The Vectorial Hatching in 3D and Transparency options for the 3D Document are specific to the 3D 

Document, and are not connected to the same options set for the 3D Window.
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CUT ELEMENTS

Fill Cut Surfaces with: This control gives you four options for displaying the surfaces of cut elements in the 

3D Document:

1. Cut Fills - as in Settings: Cut surfaces will use the cut fills of the Building Materials assigned to the 

individual elements.

In this case, an additional option is available:

Uniform Pen for Cut Elements: Check this box to use the same pens to display all the cut elements in 

this 3D Document. (If you don’t check this box, the cut elements will use the pen settings of the individual 

elements).

Then define the uniform pen using the following controls:

• Cut Line Pen

• Cut Fill Pen

• Cut Fill Background Pen
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2. Uniform Surface: This option means that all cut surfaces in this 3D Document will use a single surface.

• Choose this uniform surface using the fill pop-up of the Cut Surface Material parameter

or

• Check the box Use Surface Defined for Cut Elements in 3D. This is the surface you choose in View > 

Elements in 3D View > Filter and Cut Elements in 3D.

See Filter and Cut Elements in 3D Dialog Box.

See 3D Cutting Planes for information on 3D Cutting Planes.

3. Own Surface Colors (Non-Shaded): This option means that all cut surfaces in this 3D Document will be 

shown using the surface assigned to the individual elements, or their components, through their Building 

Material.

4. Own Surface Colors (Shaded): Same as above. The display colors will reflect shading effects.
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UNCUT ELEMENTS

Choose pen attributes for uncut elements displayed in this 3D Document.

Fill Uncut Surfaces with: Use this control to define the fill of uncut surfaces displayed in this 3D Document.

1. Uniform Pencolor: Choose this option to apply a uniform color to the fills of all uncut surfaces in this 3D 

Document. If you choose this option, the following parameter appears:

Uncut Surfaces Pen: Use this control to choose the desired pencolor to be applied uniformly to all uncut 

elements in this 3D Document.

To display Surface colors in this 3D Document (on uncut parts of this 3D Document only), choose either of 

the following options:

2. Own Surface Colors (Shaded): Choose this option to display uncut fills in this 3D Document using the 

elements’ own surface colors as defined in the Building Material. The display colors will reflect shading 

effects.

3. Own Surface Colors (Non-Shaded): Same as above, but the display colors will not reflect any shading 

effects; each surface color will be uniform over the whole surface.

Uniform Pen for Uncut Contours: Check this box if you want to display the contours of fills on uncut 

surfaces in this 3D Document. If you check it, the Uncut Contours Pen color chooser appears; choose a 

pencolor.

Vectorial 3D Hatching: Check this box to activate vectorial 3D hatch patterns in this 3D Document.

Transparency: Check this box to give see-through surfaces (e.g. glass) a transparent effect in this 3D 

Document.

Note: These Vectorial 3D Hatching and Transparency controls are specific to the 3D Document. 

Redefining the 3D Document with the settings of the current 3D window will not redefine these options.
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HIDDEN EDGES

Check this option if you want the 3D Document to display the edges of elements that are otherwise hidden in 

this view.

Set Line Type and Line pen for the Hidden Edges.

Show on Cut Plane: Controls the visibility of hidden lines that would fall in line with the cut plane or the display 

range boundaries.

SUN AND SHADOWS

Sun Shadow: Choose one of the options in this control to set the display of shadow fills in this 3D Document:

• On: Shadows are displayed, without Contours.

• On with Contours: Shadows are displayed with Contours.

• Off

Note: This setting is independent of the Sun Shadow setting in 3D Styles.

The shadow fill polygons are freely customizable. Choose the Fill type, Fill pen and Fill background pen 

using the corresponding pop-up palettes.

BOUNDARY CONTOURS

See also Element Contours at Section Boundary for an illustration of this feature.

Boundary Display: Choose one of these options to display, override or hide the contours of elements at the 

boundary of this 3D Document.

• Uncut Contours: Boundary Contours will be displayed using the Uncut pen chosen for these elements in 

their own Settings dialog boxes.

• No Contours: Boundary Contours are hidden.

• Override Contours: Choose a custom Line Type and Pen with which to display the Boundary Contours.
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Filter and Cut Elements in 3D Dialog Box

Access this dialog box from:

• View > Elements in 3D View > Filter and Cut Elements in 3D

• View Settings (3D Only panel)

• 3D Visualization toolbar’s button to open this dialog box.

• 3D Document Settings to redefine filtering criteria for a 3D Document.

Note: You may wish to display 3D Zones as solid bodies in shading mode, and all other elements types in 

wireframe mode. To achieve this effect (a default setting in earlier ARCHICAD versions), apply the 

predefined “Show 3D Zones as Solid” Layer Combination.

See 3D Document Settings.

Stories to Show in 3D: Define the stories of the project to be displayed in the 3D window:

• Infinite: Show all elements.

• Limited: Specify a continuous range of stories (from/to stories).

•  Trim Elements to Story range: Check this box to clip the model at the story range boundaries. If this box 

is not checked, then any element that falls at least partially inside the story range will be displayed.
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Marquee Effect: If you have used the Marquee tool to create a selection area prior to generating the model, 

use these options to define which part of the project will be shown in the 3D window:

• Inside Marquee: Elements inside the Marquee will be displayed.

• Outside Marquee: Elements outside the Marquee will be displayed. This option allows you, for example, 

to exclude internal elements of a house when you need only external views of the 3D model. The Marquee 

can affect multiple stories, not just the current story.

If there is a Marquee selection made in the Floor Plan, the settings of the Filter Elements in 3D dialog box are 

observed, but the caption of the 3D window includes the Marquee mention and the range of included stories.

Cut Surface Display: Use these controls to define the surface and pens for the interior surfaces and edges of 

3D Cutaways.

• Use Element Attributes: Click this button to use existing Surfaces & Pencolors/Penweights for 

highlighting the edges and surfaces of elements cut in 3D Sections. The cut surfaces of construction 

elements will have the same colors/surfaces as the uncut edges (as defined in their respective settings 

dialog boxes).

• Custom: Click this button to choose Custom Surface & Pencolor/Penweight for highlighting the edges 

and surfaces of elements cut in 3D Sections.

Surface pop-up palette: Click this pop-up palette to select a custom Surface for exposed interior surfaces of 

solid elements.

Cut surfaces of Library Parts will be painted according to the surface set for the Library Part. If the Library Part 

has internal surface descriptions, the first one in the script will define the surface for cut surfaces. The 3D 

Cutting Planes feature does not show the various layers of composite elements. To obtain sections showing 

these (if required for working drawings) use the Section/Elevation/IE tools.

The Element Types to Show in 3D checkboxes allow you to turn the 3D Window display of construction 

elements on and off. With Doors and Windows switched off, openings are interpreted as empty holes. 

Checking the All Types box selects all element types.
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3D Styles

A 3D Style is a collection of settings (3D Engine, shading, background, etc.) that determine model display in 

the 3D Window. 

The 3D Style is saved with View Settings. Every time you edit a 3D Style, all views using that 3D Style are 

updated instantly.

Note: To set 3D Window Size, use the separate command from 3D window-related menus (Tab Bar, or 

context menu of 3D window or tab).

See 3D Window Size.

Apply 3D Style

To switch the 3D style of a 3D window, use the 3D Styles pop-up from:

• context menu of the 3D window

• Quick Options Bar or Quick Options Palette

• 3D Window Tab in the Tab Bar

In the pop-up list, a separator divides the styles based on their 3D engine (Vectorial or OpenGL).
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Define or Modify 3D Styles

Use View > 3D View Options > 3D Styles to open this dialog box.

The project’s 3D Styles are listed on the left. 

• Select any Style to edit its settings using the controls on the right.

• If needed, multi-select Styles to edit their settings simultaneously.

• Click New to create and name a new 3D Style.

• Use Import and Export to transfer 3D Styles (XML files) between ARCHICAD projects.

General Options

3D Engine

Choose a 3D engine to generate the 3D window:

• OpenGL: Can display texture images (from Surfaces) and takes advantage of high-performance OpenGL 

graphics cards. This is the default engine and recommended if your video display card supports OpenGL. 
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It is optimized for fast, smooth navigation and useful in a live presentation environment. Copy/paste or 

export will result in bitmap images.

Some effects, for example vectorial 3D hatching, are not available with OpenGL. With OpenGL, you 

cannot save the 3D window contents as a vectorial 2D drawing.

Click the Settings button at right to set additional options with OpenGL.

See Open GL Options.

• Vectorial 3D engine: Produces a non-photorealistic 3D view, without texture images. Shows vectorial 

patterns (from Surfaces) and can be printed at any scale. You can save the contents of the 3D window as 

a vectorial 2D drawing. Copy/paste or print to PDF will result in 2D primitives such as lines and arcs. 

Usually results in slower navigation of the model on most machines.

3D View Mode

Choose Wireframe, Hidden Line or Shading for this 3D Style.

Note: When using the OpenGL engine, only the Wireframe and Shading modes are available.

 Wireframe mode shows all the edges and lines of your project. Note that if you have many elements one 

behind the other, this type of view can be hard to interpret.

In Hidden Line mode (available with Vectorial Engine only), lines which are blocked by solid objects are 

removed. This type of view is the best choice for easy interpretation, if you do not want a shaded view. It is 

also suitable for hard copy output on a printer. Hidden Lines can be saved in many file formats, either as 2D or 

3D files. 
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In Shading mode, the 3D model appears with all of its visible surfaces shaded according to the light direction 

set in the 3D Projection Settings dialog box.

Shading is recommended for:

• Fast on-screen feedback

• Easy checking of surface colors

• Any presentation for which photorealistic quality is not a requirement

Note: If you have defined a Layer as Wireframe, its elements will always appear in Wireframe mode, even 

if you have chosen another 3D view mode here.
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Transparency

Check this to produce transparent views of elements that have the appropriate Surfaces setting when 

generating a shaded view. Below, the same glass wall appears with Transparency Off and On.

When you save a view, the Transparency setting will be saved with the view.

Note: When used with the Vectorial Engine, Transparency is not effective with Postscript printers.

Monochrome Model

Check Monochrome Model, then set uniform colors for all of the Surfaces and Contours. 

Otherwise, the model’s surface colors depend on the elements’ Building Materials.

Watch the Video

Background

Consult the Preview to see the effects of each setting:

Click in the Sky Color and Ground Color fields to choose background colors for the 3D Window.

Click the chain icon for identical colors in both.

• As in PhotoRendering: Check this to use the background specified in PhotoRendering Settings.

See Cineware Basic Settings: Background Panel.

Contours

Consult the Preview to see the effects of each setting:

Show Contours

Check this to make the contours of model elements visible in Shaded images. Use the pop-up at right to 

define contour quality.

• The Best option produces a perfect result, but it may be rather slow for large and complex 3D models.

• The Draft option produces a fast result, but it doesn’t eliminate all the lines that the Best method would.

Use the sliders to define line weights for 

• Contours. Contour settings are applied when all its attached polygons are visible in the view.

• Silhouettes (Vectorial Engine only). Silhouette edge settings are shown when only a single attached 

polygon is visible (the rest are hidden from the camera).
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Vectorial Hatching (Vectorial Engine only)

Display Vectorial Hatching patterns in Hidden Line and Shaded images, provided that you have selected a 3D 

Hatching in the Surfaces dialog box.

For more information, see Surfaces.

Note: Vectorial 3D Hatching is also available for Section/Elevation/IE Windows and for 3D Documents, 

but that setting has to be made individually in each Section/Elevation/IE and 3D Document Settings dialog 

box. 

Shadow Contours (Vectorial Engine only)

Available if Sun Shadows are turned on (see below).

Shadows

Sun Shadows

Check this box to enable ARCHICAD’s shadow-casting capability. 

With the Vectorial Engine, the following additional Sun Shadow controls are available:

• Cast Shadow Intensity: Define using the slider.

• Shadow Contours: Check to display shadow contours.

• Use the pop-up to define where Sun Shadows are generated:

– on all surfaces, or

– on a single level only (that is, a horizontal plane). This option is useful for shadow studies in top view. 

If you choose this option, enter a value here to specify the absolute elevation of the horizontal plane 

on which the Vectorial Shadows will be generated.

• Shade surfaces using Sun: If this is turned off, all identical surfaces are draw with the same color, 

regardless of orientation.

GDL Object Hotspots

• Enable 2D Hotspots: Enable Hotspots defined for 2D editing. (This will give you more editing points in the 

3D Window.)

• Show 3D Hotspots only

Note: If the GDL Object has no 3D hotspots at all, the 2D hotspots will be always displayed, as well as 

their copies projected to the zzyzx height value, provided that such a parameter has been defined for the 

object.

Watch the Video

Watch the Video

Watch the Video
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Open GL Options

This dialog box is available from the Settings button in 3D Styles if you have chosen Open GL as your 3D 

engine.

Check the boxes of the effects you want to use when generating 3D images with the OpenGL Engine:

Headlight: Controls the light coming from the direction of the camera (on/off). Headlight On provides extra 

light and associated shadow effects in the model. Turn Off to make flat surfaces look flatter.

Highlights: Display specular reflections as highlights.

Emission: Use if you have chosen or created light emitting Surfaces and want this quality to be displayed.

Smooth Surfaces: Use to control the degree of smoothing. Curved surfaces, which are normally 

approximated by flat planes, are represented by more lifelike surfaces when this option is on.

Textures: Display bitmapped pictures on the corresponding surfaces.

Ignore hardware acceleration in 3D: ARCHICAD will bypass the display card’s OpenGL support and use 

the system-level software emulation of OpenGL, available both on Windows and Mac.

Note: Software emulation is a slower method. Use it if you are experiencing difficulties with OpenGL 

display.

Smoothness of Visual Feedback during Navigation

Customize feedback speed in Frames per Second: If you check this box, the slider below is activated. Use 

the slider to set feedback speed in frames per second.

Note: In case of a high Frames per Second value, some elements may not be displayed during 

navigation. See below.

Always display all elements located within the following radius: This slider fine-tunes your feedback 

speed preference: regardless of the effect of the Frames per Second set above (which may result in some 

elements not being shown during navigation), you can set a minimum radius here, within which all elements 

will be shown during navigation. (Set the radius either numerically or using the slider.)
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Automatic Correction for Optimized Visual Feedback

ARCHICAD uses an algorithm to maintain feedback speed when navigating in complex models using Open 

GL. The algorithm may cause certain “secondary” elements to temporarily disappear:

• “Secondary” elements are displayed based on their distance from the viewcone. Close-in elements are 

prioritized, and those furthest away are – if necessary – the first to be dropped.

• “Primary” elements never disappear during navigation, regardless of FPS. Key elements for finding your 

way are always displayed.

This algorithm applies ONLY if 3D navigation falls below a set Frames per Second (FPS) rate, as defined by 

the user, and only until FPS reaches an acceptable threshold.

Read more on Help Center.
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3D Projection Settings

Use the View > 3D View Options > 3D Projection Settings command or the 3D Visualization toolbar’s 

button to open the two modes of this dialog box.

For general information, see 3D Projections.

The name and contents of the dialog box depend on the projection type: Parallel Projection Settings or 

Perspective Settings. You can easily switch from one settings dialog to the other with the button at the top 

right corner.

The projections that you define in the 3D Projection Settings dialog boxes remain valid only until the next time 

you open the dialog box and modify them.

Related Topics:

Parallel Projection Settings

Perspective Projection Settings

Project Location and Project North

Sun Position

Sunlight Settings
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Parallel Projection Settings

Use the View > 3D View Options > 3D Projection Settings command or the 3D Visualization toolbar’s 

button to open this dialog box.

Use the controls in this dialog box to set up 3D views as parallel projections.

Click this pop-up button to select from 12 preset Projection Types, including predefined axonometrics, side, 

top and bottom views, and your own custom-defined axonometry:

For each Projection type, the editable boxes show the defining angles and scaling ratios of the X, Y and Z 

coordinate axes.

Projection Preview

This preview window shows the position of the coordinate axes for the current projection type. Click or drag to 

reposition the axes, or enter values for the angles and ratios of the three coordinate axes.
ARCHICAD 24 Reference Guide 3314



Dialog Boxes User Interface Reference
Use the Shift key to lock the angle while dragging. (If you only want to rescale, it is easier to enter a value in 

the edit box.)

Set Sun and Camera Positions Graphically

The dial shows Camera Azimuth and Sun Azimuth with respect to the target. 

Click the Sun or Camera icon and drag it to the desired location. The effect of your changes is shown by the 

rotation of the house in the preview area and by the values in the edit boxes (Angle, Axis Length, Azimuths).

Note that the Sun position and Sun Azimuth can be overridden by the Sun Position values given below.

Sun Position

Sun position values can be defined either automatically (based on a given Date and Time at the defined 

Project Location), or with Custom values.

• Date and Time: Enter a date and time. In combination with the Project Location, this data will 

automatically define the sun position, which in turn is used to calculate shadows in shaded or rendered 

images.

Note: Based on these data, ARCHICAD uses the Solar Position Algorithm from the National Renewable 

Energy Laboratory (USA) to calculate the solar zenith and azimuth angles.

For information on this algorithm, see: Solar Position Algorithm.
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– Use today’s date: Click the Current Date and Time icon to apply the current date (as defined by your 

computer’s operating system).

– +1 hr Daylight: Check this box to adjust the hour forward for Daylight Savings Time.

• Custom: Choose this, then enter the values for Sun Altitude and Azimuth manually (or adjust the sun icon 

by hand in the preview above).

Note: The Sun Altitude is measured in degrees, above the Horizon. A negative Altitude angle indicates 

that the Sun is below the horizon (night). This may produce completely black images.
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Date and Time in View Settings

The Date and Time settings are stored in the View Settings of saved 3D perspective and axonometric views:

Pre-Sets: Button: Opens a dialog where you can specify options for and insert frames in Fly-Through Paths.

For details, see Pre-Set Projections below.

Sunlight Button: Opens a dialog to define Sunlight-related settings.

See Sunlight Settings.

Pre-Set Projections

Open this dialog from Parallel Projection Settings.
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Here, you can store and retrieve projection settings. 

You can also use this sequence of axonometric views for a future animation. Animations based on 

axonometric views are not fly-throughs in the same sense as perspectives, even though they are created with 

the same command. Using in-between frames, you will get an animated metamorphosis from one projection 

to the other.

• The Add Current Projection button places the current view on the list. The views on the list will be 

keyframes in the Fly-Through. You can also name each keyframe in the dialog box that appears after 

pushing this button.

• If no projection is selected, New will be added to the bottom of the list. If a projection is selected, the new 

projection will be inserted before the selected one.

• The Set to Current Projection button changes the highlighted keyframe in the list to the one you set prior 

to opening the Pre-Sets dialog box.

• The Delete button clears a keyframe from the list.

• Under Options for Fly-Through in the right section of the dialog box you can also set the number of in-

between frames that ARCHICAD will create by interpolating between every parameter (e.g., axis scaling 

ratio, camera angle, etc.) of consecutive keyframes.

For more information, see Fly-Through.

• The Open and Closed radio buttons control whether the animation will loop continuously from the last 

defined keyframe back to the first keyframe during the Fly-Through.

• Wait frames: This number refers to the number of still frames (time units) during which the fly-through 

motion will remain frozen at the given camera before moving on to the next one.

Enter the number of still frames to be included in the Fly-Through Path.
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Perspective Projection Settings

Use the View > 3D View Options > 3D Projection Settings command or the 3D Visualization toolbar’s 

button to open this dialog box.

Use this dialog box to set all the relevant parameters for perspective 3D views, such as viewpoint location and 

elevation, target location and elevation, width of the viewing cone, and sun position.

Note: Cameras placed in the Floor Plan window also define perspective views, but they are configured in 

the Camera Tool Settings dialog box, not in this dialog box. To apply the camera-defined view to the 3D 

model, select the camera and activate the 3D Window.

The preview area on the left side of the dialog box shows your Floor Plan as it currently appears in the 

window. To see another part of the Project, leave the dialog box, choose another detail using the Navigator or 

zooming and panning operations, then open it again.

The solid line in the preview area represents the line of vision between the viewpoint and the target point. You 

can click and drag both the target point and the viewpoint independently of one another. Click anywhere in the 

preview area and the line of vision will be rotated around the target point to your click position.

The angle defining the View Cone is displayed in the preview area and provides reliable information if the line 

of vision is horizontal. If the line of vision is looking up or down, the angle can be used only for estimating the 

resulting view.

After zooms, pans, or numeric distance settings, the viewpoint and/or target point may occasionally disappear 

from the preview area. To retrieve them, simply Shift-click where you want the viewpoint and Alt/Cmd-click 

where you want the target point to be in the Window. They will immediately move to the points where you 

clicked.

You can also specify the following values numerically. Effects of these settings will be displayed graphically in 

the preview area.

• Camera Z: Enter a value here to specify Camera height from Project Zero. (In this case, the position of 

the target will remain unchanged.) 

• Target Z: Enter a value here to specify Target height from Project Zero.

• Distance: Enter a value here to specify the horizontal distance between Camera and Target.
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• Azimuth: Enter a value here to specify Camera Azimuth to Target.

Point Perspectives

• Use Two-Point Perspective: Check this box to view the 3D model from a two-point rather than three-

point perspective, while maintaining the original position and viewing angle. This perspective remains until 

you navigate away.

As a result, all 3D vertical edges become vertical in perspective projection. This emulates the vertical 

correction function of shift lenses in SLR cameras.

• To get a top view in perspective, set the viewpoint elevation higher than that of the target point elevation, 

drag the target to the desired location on the plan, then set the distance to zero by dragging the viewpoint 

until the numeric field displays a minimal value near zero. (You cannot type zero in the Distance field.)

The elevation of the viewpoint and the target point, as well as the View Cone and Roll Angle of the Camera, 

must be set numerically by using the remaining edit boxes.

View Cone: Enter a value here to specify the opening angle of the Camera View Cone.

Hint: Wider angles (a°=>60°) can fit more objects in the Window, but can also distort the image.

Roll Angle: Enter a value here to specify Camera Roll Angle.

Set Sun Position Graphically

In the preview area, the dashed line with sun icon shows the direction of light for shaded and rendered 

representations. The sun icon can be dragged around the perimeter of the plan, but it cannot be positioned 

closer. Its distance is considered to be infinite. 

The other controls are identical to those in Parallel Projections.

See Sun Position and Sunlight Settings.
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Sunlight Settings

The Sunlight Settings dialog box is accessible from:

• the Camera Tool Settings dialog box, by clicking the Sunlight... button

• the View > 3D View Options > 3D Projection Settings dialog boxes (Parallel Projections or Perspective 

Settings), by clicking the Sunlight... button.

Sunlight Settings are relevant for:

• PhotoRenderings

• Sun Studies

• 3D Projections (and views created from these)

Light Parameters

Set parameters for each component of the light: Sunlight (directional normal) and Ambient Light.

• Sunlight is the directional light falling on the project.

– Click inside the color sample box to choose a Sunlight color.

– Choose a sunlight color intensity between 0 and 100%. This Intensity value multiplies the Brightness 

component of the Sunlight color.

Note: The Sunlight color and intensity settings are considered by the Cineware Rendering Engine.

– Contribution to Ambient: Choose a percentage for how much of the Sunlight should be represented 

in non directional, ambient light.

• Ambient light is general, non-directional light that contributes to the overall brightness of the image, and 

can brighten otherwise overshadowed surfaces.

Note: Ambient light parameters affect only the 3D Window and PhotoRenderings created with the Basic 

Rendering Engine!

– Color: Click inside the color sample box to choose a color for the Ambient Light.

– Choose an Ambient light color intensity between 0 and 100%. Vary this value to obtain special effects 

in renderings.
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RoofMaker Settings

(Design > Roof Extras > RoofMaker)

Rafter Settings Dialog Box

Select a roof on the floor plan. Choose Create a Rafter from the Design > Roof Extras > RoofMaker menu 

(or select the first icon from the RoofMaker toolbox).

The Rafter Settings dialog box appears in which rafter parameters can be set. The preview picture in the 

dialog box reflects the changes in the settings as you make them, to let you experiment with several 

possibilities before placing the rafter.

Width: Enter the width of the rafter cross-section here.

Height: Enter the height of the rafter cross-section here.

Hip Rafter Width: Define the width of the hip rafter (the connecting element at the top of the rafter.)

Rafter angle at the top: Choose either radio button (Perpendicular or Vertical) to define the angle at which 

the rafter joins the connecting element at its top end.

Eaves Angle: Choose a radio button (Perpendicular, Vertical or Rectangular Cut) to define a how to cut the 

bottom end of the rafter.

Soffit: Click this box to attach a soffit to the lower end of the rafter. The soffit will have the same cross section 

as the rafter.

Soffit Angle: Enter a value to set the inclination of the soffit. A zero angle means the soffit is horizontal.

Note: The preview will not reflect the angle you set for the soffit, but the value will correctly displayed on 

screen and in all outputs.

Surface: Choose a surface for the rafter from the pop-up palette.

Width of Valley Rafter: Enter the width of the valley rafter.

Layer: Choose a layer for the Rafter element.
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Axis linetype: Choose a linetype for the axis of the rafter.

Show outline in 2D: Check this box to display the full outline of the rafter, including its axis, on the Floor Plan. 

Although roof plans usually show only the axis of any inclined element (rafters, hip rafters, valley rafters), 

switching on the outline view temporarily gives you better control of the connections between elements.

Clicking OK returns you to the floor plan.

Multiple Rafters Dialog Box

Select a roof on the floor plan. Choose Create Multiple Rafters from the Design > Roof Extras > 

RoofMaker menu (or select the appropriate icon from the RoofMaker toolbox).

The controls of this dialog box are identical to those of the Rafter Settings Dialog Box, but the controls related 

to multiple rafters are also active.

Placement of multiple rafters: The placement method is defined by either a maximal distance between the 

axes of the rafters (Distance Fixed), or by a fixed number of rafters to be placed at an equal distance 

(Number Fixed).

If you choose Distance Fixed, enter a value below for Max. distance between rafters.

If the user-defined range might not allow the regular placement of the objects. In such a case, use the 

Distance Fixed - gap start/middle/end radio buttons to fine-tune where the gap between rafters will be 

introduced (either at the start, the middle or the end).

Number of copies: This field is active if you have checked the Number Fixed radio button. Enter the desired 

number of rafters.

Clicking OK returns you to the floor plan.
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Hip or Valley Rafter Settings

Select either one or two roofs on the floor plan. Choose Create a Hip or Valley Rafter from the Design > 

Roof Extras > RoofMaker menu (or select the appropriate icon from the RoofMaker toolbox).

Width: Enter the width of the rafter cross-section here.

Height: Enter the height of the rafter cross-section here.

Width of Purlin: Enter the width of the purlin here.

Thickness of Rafter: Enter the rafter thickness here.

Axis linetype: Choose a linetype for the axis of the rafter.

Show outline in 2D: Check this box to display the full outline of the rafter, including its axis, on the Floor Plan. 

Although roof plans usually show only the axis of any inclined element (rafters, hip rafters, valley rafters), 

switching on the outline view temporarily gives you better control of the connections between elements.

Eaves Angle: Choose a radio button (Perpendicular, Vertical or Rectangular Cut) to define a how to cut the 

bottom end of the rafter.

Surface: Choose a surface for the rafter from the pop-up palette.

Enter values for the Width of purlin and Thickness of rafter fields.

Clicking OK returns you to the floor plan.
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Create a Purlin (or Beam)

Select a roof on the floor plan. Choose Create a Purlin from the Design > Roof Extras > RoofMaker menu 

(or select the appropriate icon from the RoofMaker toolbox).

Width: Enter the width of the purlin cross-section here.

Height: Enter the height of the purlin cross-section here.

Elevation: Enter an elevation value for the purlin so that it can be higher or lower than the reference plane.

Top of Rafters: Check this box to place the purlin on top of the rafters. If the purlin is placed on top, you must 

also set the rafter height at which to place the purlin.

Rotated Purlin: Check this box to place the purlin perpendicular to the rafters.

Rafter height: Enter a value for the height of the rafters.

Surface: Choose a surface for the purlin from the pop-up palette.

Clicking OK returns you to the floor plan.

Create an Eaves Purlin (or Plate Beam)

Select a roof on the floor plan. Choose Create an Eaves Purlin from the Design > Roof Extras > 

RoofMaker menu (or select the appropriate icon from the RoofMaker toolbox).

Width: Enter the width of the purlin cross-section here.

Height: Enter the height of the purlin cross-section here.

Elevation: Enter an elevation value for the purlin so that it can be higher or lower than the reference plane.
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Surface: Choose a surface for the purlin from the pop-up menu.

Clicking OK returns you to the floor plan.

Create a Trimmer (or Blocking)

Select two rafters on the floor plan. Choose Create a Trimmer from the Design > Roof Extras > RoofMaker 

menu (or select the appropriate icon from the RoofMaker toolbox).

Width: Enter the width of the trimmer cross-section here.

Height: Enter the height of the trimmer cross-section here.

Perpendicular: Check this to place the trimmer perpendicularly to the rafters

Vertical: Check this to place the trimmer vertically.

Surface: Choose a surface for the trimmer from the pop-up menu.

Clicking OK returns you to the floor plan.

Create Collar Beams

Select two rafters on the floor plan. Choose Create Collar Beams from the Design > Roof Extras > 

RoofMaker menu (or select the appropriate icon from the RoofMaker toolbox).

Width: Enter the width of the collar beam cross-section here.

Height: Enter the height of the collar beam cross-section here.

to Story 0: Enter a value here for the height of the top of the beam from the current story

to Project Zero: Enter a value here for the height of the top of the beam from Project Zero.
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Single-sided: Click this button to create a single-sided beam.

Double-sided: Click this button to create a double-sided beam (on both sides of the rafter).

Surface: Choose a surface for the purlin from the pop-up palette.

Clicking OK returns you to the floor plan.

Create Tie Beams

Select two rafters on the floor plan. Choose Create Tie Beams from the Design > Roof Extras > RoofMaker 

menu (or select the appropriate icon from the RoofMaker toolbox).

Width: Enter the width of the tie beam cross-section here.

Height: Enter the height of the tie beam cross-section here.

to Story 0: Enter a value here for the height of the bottom of the beam from the current story

to Project Zero: Enter a value here for the height of the bottom of the beam from Project Zero.

Surface: Choose a surface for the purlin from the pop-up menu.

Clicking OK returns you to the floor plan.
ARCHICAD 24 Reference Guide 3327



Dialog Boxes User Interface Reference
Roof Wizard Dialog Box

For more information, see Create Special Roof Objects with RoofMaker.

Rafters Tab Page

Create Rafters: Check this to create Rafters and enable related controls on this tab page.

Width: Enter the width of the rafter cross-section here.

Height: Enter the height of the rafter cross-section here.

Eaves Angle: Choose a radio button (Perpendicular, Vertical or Rectangular Cut) to define a how to cut the 

bottom end of the rafter.

Soffit: Click this box to attach a soffit to the lower end of the rafter. The soffit will have the same cross section 

as the rafter

Soffit Angle: Enter a value to set the inclination of the soffit. A zero angle means the soffit is horizontal.

Axis linetype: Choose a linetype for the axis of the rafter.

Show outline in 2D: Check this box to display the full outline of the rafter, including its axis, on the Floor Plan. 

Although roof plans usually show only the axis of any inclined element (rafters, hip rafters, valley rafters), 

switching on the outline view temporarily gives you better control of the connections between elements.

Distance between normal rafters: Enter a value here to set the standard distance between rafters.

Minimal distance between rafters: Enter a value here to set the minimum distance between rafters.

Use the checkboxes for special rafter placement options:

• Add extra rafters to big gaps

• Add extra rafters to corners

Choose one of the two radio buttons to set how rafters behave at slant edges:

• Join on slant edges

• Stagger on slant edges

Double rafters on window side: Check this box if you want to double the rafters on the side of window 

openings.
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Surface: Choose a surface for the rafter from the pop-up palette.

Clicking OK returns you to the floor plan and creates the rafters according to the current settings.

Beams Tab Page

Create Beams: Check this to create beams and enable related controls on this tab page.

Check a radio button for the type of beam needed:

• Collar Beams

Note: With the Roof Wizard, only double collar beams can be created.

• Tie Beam

Width: Enter the width of the beam cross-section here.

Height: Enter the height of the beam cross-section here.

Set the Elevation of the beam.

• to Story 0: Enter a value here for the height of the beam from the current story.

• to Project Zero: Enter a value here for the height of the beam from the Project Zero.

Note: For collar beams, the elevation value is the top of the beam; for tie beams, the elevation value is the 

bottom of the beam, as reflected in the preview picture.

Surface: Choose a surface for the rafter from the pop-up palette.

Clicking OK returns you to the floor plan and creates the beam(s) according to the current settings.

Purlins Tab Page

• Create Ridge Purlins

• Create Eaves Purlins

Check either or both of these boxes to create ridge purlins (use controls on the left side of the dialog box) and 

eaves purlins (use controls on the right side).

Width: Enter the width of the purlin cross-section here.

Height: Enter the height of the purlin cross-section here.

A purlin is placed either below the opposing rafters (supporting them), or between the rafters (supported by 

them).

Purlin between rafters: Check this box to place the ridge purlin between rafters.

Indenture: Check this box to set the depth at which the eaves purlin cuts into the rafter it supports

Surface: Choose a surface for the purlin from the pop-up palette.

Clicking OK returns you to the floor plan and places the purlins according to the current settings.

Note: The eaves purlin is always placed on the same level as the pivot line of the corresponding roof 

surface.

Trimmers Tab Page

Click the Create Trimmers checkbox to activate the controls on this tab page.

Width: Enter the width of the rafter cross-section here.

Height: Enter the height of the rafter cross-section here.

Perpendicular: Check this to place the trimmer perpendicularly to the rafters

Vertical: Check this to place the trimmer vertically.

Surface: Choose a surface for the purlins from the pop-up palette.
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Clicking OK returns you to the floor plan and creates the purlins according to the current settings.

Ridges Tab Page

Create Hip Rafters and Valley Rafters: Check this box to use the controls in this dialog box to create Hip 

Rafters and Valley Rafters.

Width: Enter the width of the rafter cross-section here.

Height: Enter the height of the rafter cross-section here.

Axis linetype: Choose a linetype for the axis of the rafter.

Show outline in 2D: Check this box to display the full outline of the rafter, including its axis, on the Floor Plan. 

Although roof plans usually show only the axis of any inclined element (rafters, hip rafters, valley rafters), 

switching on the outline view temporarily gives you better control of the connections between elements.

Eaves Angle: Choose a radio button (Perpendicular, Vertical or Rectangular Cut) to define a how to cut the 

bottom end of the rafter.

Drop hip rafter to match rafter’s top: Check this box to lower the hip rafter to match rafters’ top with its own 

top. (This may be necessary if the pitch angle of the standard rafters differs from that of the hip/valley rafters.)

Surface: Choose a surface for the rafters from the pop-up palette.

Clicking OK returns you to the floor plan creates the rafters according to the current settings.
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TrussMaker Settings

(Design > Design Extras > TrussMaker)

For general information, see TrussMaker.

Choose a construction type using the three large buttons on the left of the screen of the TrussMaker settings 

dialog box:

• Timber Construction: click this button to construct wooden trusses.

• Hollow Section: click this button to construct rectangular or circular hollow trusses.

• Rolled Steel Profile: click this button to construct steel trusses using a variety of profile options.

After setting a construction type, use the controls on the three tab pages to define the truss.

TrussMaker Attributes tab 

This tab page defines the appearance of the truss in floor plan, section and 3D views and is identical for all 

three construction types.

Floor Plan and Model Attributes

Enter a pen number and pen color, line type and surface setting for the line of the truss.

Enter a vertical offset for the truss:

• to Story: this value is the elevation of the truss from the current story.

• to Project Zero: this value is the elevation of the truss from Project Zero.

Resolution of Arcs: Enter a value to set the segmentation of any curves that you used to define the outline of 

the truss.

Note: The value you enter in the Resolution of arcs field is relative to the complete circle, not the arc 

segment.

TrussMaker Truss Profiles tab 

Use this tab page to assign distinct parameters (e.g., thickness, diameter or profile) to each part of the truss.

Note: To define the different parts of the truss, you must assign different pencolors when drawing the truss 

outline on the floor plan.

To select a part to work on, either click its pencolor icon, or corresponding button/field, or its outline in the 

Truss Preview. The thick outline in the preview and a black diamond next to the pen color indicate which part 

of the truss you are working on. The available parameters depend on the construction type of the truss you 

are creating.

Width: Enter a value to set the width of the element.

Height: Enter a value to set the height of the element.

Thickness: Enter a value to set the thickness of the element.

Cross Section: Displays the cross section of the selected profile type.

In addition to the above, the Hollow Section type of truss has a number of additional settings.

Profiles: Click a radio button to choose either a rectangular or circular profile.

If you choose a circular profile, such truss elements are defined by their diameter and resolution rather than 

height and width.

Thickness: Enter a value for the thickness of the truss part.

For a Rolled Steel Profile only: 
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Click the Profiles and Positioning pop-ups to choose a shape and placement option for your Rolled Steel 

Profile.

Steel Junctions tab 

This tab page is only available for the Rolled Steel Profile construction type. These controls allow you to use 

customizable junction plates at the points where the truss elements meet.

Choose a radio button to set whether your truss will include junction plates.

• Without junction plates: Check this radio button if you do not want to use junction plates. If you choose 

not to use junction plates, the corresponding options are grayed in the dialog box.

• With junction plates: Check this radio button to use junction plates.

When joining two identical profiles, choose a radio button to set whether your truss will include junction plates:

• Don’t use junction plate

• Use junction plate.

Choose a radio button to set the geography of the steel junction profile:

• Use center of gravity

• Use midpoint of bounding box.

In the Junction Plates section, T stands for the cross-section value, L for the length of the junction plate from 

the intersection point of the profile axis and M for the minimal overlapping length of the profile and the junction 

plate. Depending on the geometry (the angle between the profiles), either L or M will be used to determine the 

actual junction plate length - whichever results in a longer junction plate.

T: Enter a value to set the thickness of the plates (cross-section).

L: Enter a value for L (length of junction plate).

M: Enter a value for M (minimal overlapping length between profile and junction plate).

When you have finished customizing your truss, click the Save button at the bottom right of the dialog box. 

You will then be prompted to name the new truss object and place it in your active library.
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Grid System Settings

For general information, see The Grid Tool.

This dialog box is available from the Design > Grid System command.

Grid System General Settings Panel

Geometry: Select between orthogonal and curved grid systems. If you select a curved system, then enter a 

value for the radius of the outermost gridline.

Place...: Check any of the next four checkboxes to place additional elements at each gridline intersection:

• Elements at Grid line intersections: Check this to place elements at grid line intersections. Click the 

pop-up to select the element type (Column or Object) and click the Settings button to open that element’s 

settings dialog on top of this dialog.

• Default Beams on Grid lines: Check this to place a Beam element along the grid lines. Click the Settings 

button to open the Beam settings dialog on top of this dialog.

Note: If you are placing a curved grid system, you have the option to place either straight or curved 

beams along the gridlines.

• Dimension lines: Check this to place a dimension line between each and every grid line. Enter a value 

for the offset between the dimension line and the first crossing grid line. Click the Settings button to open 

the Dimension settings dialog on top of this dialog.

• Total Dimension: Check this to place a dimension line between the two side grid lines. Enter a value for 

the offset between the dimension line and the first crossing grid line. Click the Settings button to open the 

Dimension settings dialog on top of this dialog.

Click the chain icon to have identical attributes for dimension lines and the total dimension.

Keep Column and/or Beam within Grid perimeter: Check this to shift the columns and the beams so that 

will appear inside the perimeter of the Grid system.
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Grid System Grid Elements Panel

Grid Element Settings: Click this button to open the Grid Element to set properties for every Grid element in 

this Grid System. (All Grid elements will look the same.)

Extension: Enter a value for the distance that the Grid line extends beyond the last crossing Grid line 

Anchor: Click one of the four positioning buttons to define an anchor by which to place the Grid System.

Markers: Check any or all of the four sides of the Grid System to place Markers. (If you define a rotation 

during Grid System placement, then these sides will be rotated as well.)

Auto-stagger Grid Markers if they overlap: Check this to automatically stagger Grid markers sideways to 

avoid overlapping, if the markers would otherwise overlap.

Grid System Naming Rules Panel

Use this panel to define the logic by which to name the Grid lines of this Grid System. You can define separate 

naming styles for the two grid directions.

• For a curved grid system: circular Grid lines and radial Grid lines.

Note that assigning naming rules to “horizontal” and “vertical” gridlines, as well as the “up” and “down” 

definitions, are relative to the Grid System’s orthogonal position (if you rotate the Grid System when placing it, 

the assigned names will be rotated accordingly.)
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Custom: Select this to enter names manually for any grid element, using the fields in the Grid Positions 

Panel: if you click Custom in the Naming Rules Panel, then the Grid line names become editable in the Grid 

Positions Panel.

Generate names automatically: Select this to auto-generate names for the Grid lines in this Grid System.

Ascending direction: Select one of the two directions (click the up or down arrow) to define in which 

direction the automatically generated names should be assigned.

• Start at: This field shows the starting value of the Grid element naming.

• Prefix: a static text displayed in front of each auto generated name.

• Suffix: a static text displayed following each auto generated text.

• Style: Choose a style for the auto generated Grid element names: either numbers (1,2,3,...), letters 

(A,B,C,... or a,b,c,...), or Roman numbers (I,II,III,IV,...) 
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Grid System Grid Positions Panel

Use this panel to define the number and position of horizontal and vertical Grid lines for this Grid System.

(For a curved grid system: circular Grid lines and radial Grid lines.)

Note that “horizontal” and “vertical” gridlines parameters are relative to the Grid System’s orthogonal position, 

and rotate along with the Grid.

Add a Grid line: Click the Plus sign to add a Grid line.

Remove a Grid line: Click the Minus sign to remove a Grid line.

Set distance: Click the distance field of any of the listed Grid lines to define its distance from the previous 

Grid line. The Distance of the first Grid line in the list is always zero.

Distribute: If you do not know the distance you will need between your Grid lines, check the Distribute box 

for either or both Grid line directions. This will enable you, when you place the Grid system, to set the 

beginning and endpoints of the Grid system in the given direction, divided into the number of Grid lines 

defined in the list.
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GDL (Geometric Description Language)

The dialog boxes and commands described below are used when editing GDL objects in ARCHICAD.

GDL Object Editor

Text Editing Commands in GDL Script Windows

About GDL Object Subtypes

Subtype Hierarchy Dialog Box (GDL Master Window)
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GDL Object Editor

The GDL Object Editor contains all controls needed to edit a GDL object.

For a detailed description of scripting commands and object-level editing, see the GDL Reference Guide 

(available from the ARCHICAD Help menu).

Open GDL Object Editor

To open the GDL Object Editor, do one of the following:

• For a placed object: select the object, then use File > Libraries and Objects > Open Object (or choose 

this shortcut command from the Edit GDL Library Parts toolbar)

• For any object file (and if no placed object is selected): use File > Libraries and Objects > Open Object, 

then browse for the desired object.

• Another way to browse for an object is by subtype: use the Open Object by Subtype command from the 

Edit GDL Library Parts toolbar.

The window that opens is the GDL Object Editor.
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Use the buttons on the left side to open different tables/lists for editing (e.g. Details, Parameters, 

Components) within the GDL Object Editor.

The Script editing windows (e.g. Properties Script, Parameter Script) can be opened in two ways:

• If you click the button itself, editing will take place inside the Master Window

• If you click on the window icon next to the script’s name will open a separate window for entering or 

modifying the script

• From any of these separate windows, you can easily navigate back to the Master Window, using its Tab 

Bar context menu:

“Read-Only” Objects from a Library Container File

To edit an object placed from a library container file, you must first extract the container. Otherwise, the Object 

Editor Window is “Read-Only”.

For more information, see Library Container File.

Topics in this section:

The controls of the GDL Object Editor are described in the following sections.

Object Preview Picture

Details

Compatibility Options (Developer Use Only)

Parameters

Migration

Components

Descriptors

Script Buttons

GDL Script Window Shortcuts

2D Symbol

2D Symbol Display (Fragments)

Preview Picture

Check Object’s 2D and 3D Views

Close Window and Save Changes

Matching 2D & 3D Descriptions
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Object Preview Picture

The Preview Picture window can be viewed in one of five formats.

• Click one of the buttons beside the window to choose a display option for the preview picture: 2D Symbol, 

2D View, Front, 3D, and Preview Image.

• Using the Front or 3D previews, you can click in the preview window to rotate the image in 45 degree 

increments.

Details

Object’s subtype: Displays the subtype of the open object.

• You can change an object’s subtype by clicking the Select Subtype button, which will open the Subtype 

Hierarchy dialog box. Changing the Object’s subtype modifies its behavior and adds the parameters and 

functionality needed for the new subtype. For example, you can change a plain object into a light source 

by changing its subtype to Light.

For more information, see Subtype Hierarchy Dialog Box (GDL Master Window).

Use as subtype: If you check this box, the object will be saved as a template to be included in the list of 

available Subtypes. The new template will appear in the Subtype Hierarchy dialog box, and any new objects 

that you associate to this subtype will take on all of the parameters of the subtype.

The Placeable checkbox is enabled by default. If you uncheck it, the Object will behave as a macro. If this box 

is unchecked, this means that 

• it will not appear in any of the tool settings dialog boxes;

• you will not be able to place it directly in the project;

• it cannot be included in an archived project file;

• but you can refer to its scripts from other Objects.

Object Information Fields

The next few controls are relevant if you wish to share the library part to BIM Components, or if you plan to 

make your own object commercially available. Also, any text you enter will be considered when you use the 

Search function for locating library parts through a library part Settings dialog box.

See Search for Library Part.

Edit the following information as needed:

• Enter an Author. (If you leave this blank, the name you used to register on BIM Components will be used 

as the author, after the object is shared.)
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• Assign a License. For a complete description of a selected license option, click the Info button from the 

dialog box.

- Commercial. Use this kind of copyright if you are selling the object over the internet. An object with 

Commercial copyright cannot be shared to BIM Components. 

Note: The same license types (except Commercial) are available when sharing a custom object to 

BIMcomponents.com. 

See BIM Components.

• Password (available if the copyright is “Attribution-NoDerivs0” or “Commercial.”). Click Set Password to 

define an optional password. Such objects can be freely viewed and downloaded, but the user cannot 

open the object to edit or copy its script without a password.

• Description. Enter an optional description of the object. This text will appear when you click the Info 

button in the Settings dialog box, as well as in BIM Components, if the object has been shared there. Also, 

Description text will be considered when you use the Search function for locating library parts through a 

library part Settings dialog box.

Compatibility Options (Developer Use Only)

Consult the GDL Center for detailed information.

See gdl.graphisoft.com.

Parameters

Click the Parameters button to display the Parameters of the current Library Part in the editing area.
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Search Parameters: Enter a text string in the search field to locate any part of that string in the Variable, 

Name, or Value columns. The cursor jumps to the first found instance. Use the Find next/Find previous 

buttons to jump to additional found instances.

By assigning values to the set of variables in the Parameters list, you will define the attributes of a particular 

GDL Object. The values assigned here will be the default values found in the Settings dialog box when you 

choose a tool that uses GDL Objects. These locally defined Parameters can also be called by the different 

Scripts of the Object.

The parameters that appear in blue are the obligatory parameters (such as A and B dimensions) that belong 

to the edited Object’s subtype.

Optional parameters are available for use in the Object’s GDL description. The values specified for them will 

become the default additional values displayed when you open the appropriate Settings dialog box from the 

Toolbox.

The optional parameters are typically used to define such things as the number of window panes or door 

panels, the usual surfaces of a part, etc.

New parameters can be created by pressing the New button at the top of the Master Window. Remove 

existing parameters by selecting them in the list then pressing Delete next to the New button.

Each parameter in the list can be edited in its own row. Each line consists of an icon (required) indicating its 

type, the parameter letter or a string variable, a descriptive text (optional, but recommended) and a default 

numeric value.

Highlight the row you wish to edit. For obligatory parameters, you cannot edit the variable name or type icon. 

For optional parameters you can edit all the parameters.
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The Type icons control how the values are interpreted by ARCHICAD. Clicking a Type icon displays a dialog 

box where you can redefine the parameter’s type by choosing another icon.

The parameter types (identical for obligatory and optional parameters) are the following:

• Length:

specifies physical dimensions of the GDL Object (and makes conversions to whatever units you are 

using.) Must be a positive number.

• Angle:

specifies angular values in decimal degrees for such GDL operations as rotation transformations and 

defining arcs.

• Real Number:

specifies decimal non-dimensional values (any real number) for uses like including a magnification factor 

in a GDL calculation.

• Integer:

specifies whole numbers, dimensionless values for uses like defining the number of identical components 

in a GDL description or the number of times to loop through a part of the GDL Script.

• Boolean:

the value of a Boolean parameter can only be 1 or 0 for uses like activating or deactivating an action or an 

item in a GDL Object. These values can either be typed directly into the value box, or set by clicking the 

checkbox at the right end of the parameter line.

• Text:

specifies character strings up to 255 characters for uses like defining changes in the GDL Object or typing 

plain words instead of numbers in the parameter’s value box.

• Surface:

specifies a surface as a GDL parameter.
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• Line Type:

specifies a line type as a GDL parameter.

• Fill Pattern:

specifies a fill pattern as a GDL parameter.

• Pen Color:

specifies a pencolor as a GDL parameter.

Note: If any of the Surface, Line Type, Fill Pattern or Pen Color parameter types is selected, a button 

appears at the right end of the parameter line where you can bring up a pop-up list of corresponding 

settings. Any of the attributes currently available to ARCHICAD can be chosen.

Note: Depending on how you write your GDL descriptions, the parameters you use can affect both the 2D 

and 3D aspects of the Library Part.

Parameter Types include two further options: Separator and Title.

These are virtual parameters as they are only used to make the Parameter List more organized and easier to 

view.

To further organize and format the parameter list, use any of the list formatting icons, visible only when a list 

item is highlighted.

• Pressing the first icon, Hide Parameter, will remove the highlighted parameter from the Parameters panel 

in the Object Settings dialog box.

• The second icon, Subordinate, will create a hierarchy among parameters. The superior parameter can be 

of any type; however, a Title type parameter cannot be subordinated.

• Pressing the third icon, Bold, will make the parameter name appear in bold type.
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• The fourth, Unique icon (if activated) means that the current parameter will NOT be transferred if you 

transfer the rest of this object’s parameters to another object. (see Parameter Transfer Between Objects.)

Note: When applying a Favorite to an Object, the “unique” parameters are applied together with the 

Favorite - they are not excluded.

You can restrict the possible values of a parameter by defining an array.

When you highlight an array item in the parameter list, a button appears next to the Type icon.

Click it to toggle between a single or value list and an array. If it is toggled to array, clicking it will open the 

Array Values dialog box.

Note: Once array values have been defined for a parameter, the Array Values dialog box can only be 

opened by pressing the Set button at the top of the Master Window.

Click on the Insert and Delete buttons to add rows or columns. Edit the fields of the array by clicking on the 

fields, then entering the value in the number field at the right side. Where variable types allow, you can choose 

values from a pop-up menu.

To insert or delete a row or column, select the button showing the row/column number, then press Insert or 

Delete.

Migration

Click the Migration button to open a table in which to define the older-version objects that should be migrated 

to the currently opened (newer-version) object.

• Fill in the main GUID of any old object that can be migrated to this new, currently opened object.

• Fill in a version number for the old object (typically the version of a previous ARCHICAD): when the 

project is saved back to the previous version (and if “Convert library objects backward” is set in Options 

from the Save As dialog box), this new object will be migrated to an old object in the migration table which 

has been assigned the corresponding version number. The Backward Migration script will consider all 

such rows until the first successful run.

Note: if you enter 0 for the version number, backward migration will skip this object.
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Components

Click this button to display the Components of the current GDL Object in the editing area. Components define 

the object’s composition for use in listing and calculation features.

Click New to create a component.

DB Set: Select Database from this pop-up menu.

Key: Select one of the Keys from this pop-up menu.

Note: This pop-up menu is only available if your loaded library contains Key description.

Code: Define a Code for new Components or modify the Code of a selected one in this box.

Quantity: Define the Quantity for new Components or modify the Quantity of a selected one in this box.

Unit: Select one of the predefined Units from this pop-up menu.

Note: This pop-up menu is only available if your loaded library contains Unit description.

Proportional with: Select one of the predefined GDL expressions from this pop-up menu, or select the 

Custom button and enter any GDL expression in the long edit box above.

For details about Component Editing, see the ARCHICAD Calculation Guide.
ARCHICAD 24 Reference Guide 3346



Dialog Boxes User Interface Reference
Descriptors

Click this button to display the Descriptors of the current GDL Object in the editing area. Descriptors define 

the object’s composition for use in listing and calculation features.

Click New to create a descriptor.

Link to Database Item: Click this button to link a Component or Descriptor to an external database residing in 

the selected databases of the loaded Library. While a Component or Descriptor is linked to the selected 

database, it cannot be edited. To modify it, click the Remove Link to Database button to unlink the Component 

or Descriptor.

Change Link: Click this to re-define an existing link to another external database 

Text: Click this button to open the Descriptor Full Text dialog box displaying the whole Descriptor text.

Short Text: Enter Short Text for a new Descriptor in this box.

For details about Descriptor Editing, see the ARCHICAD Calculation Guide.
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Script Buttons

These buttons allow you to program your GDL Object. If you click the button itself, editing will take place 

inside the Master Window, while clicking the window icon next to the script’s name will open a separate 

window for entering or modifying the script.

• The Master Script will be executed each time any of the other scripts are executed. The primary benefit 

of this script is that you can globally define variables or operations, or access external data before 

executing other Scripts.

• In the 2D Script window, you can create a parametric 2D symbol using the transformations and elements 

available for the two-dimensional space in GDL. This script will be used to generate the 2D Full View of 

the Object.

• In the 3D Script window, you can find and edit the 3D description of the GDL Object. The script will be 

used to generate the 3D View of the Object.

• With the Property Script, you can attach descriptions and technical data to the Object using its variables 

and the related GDL commands and expressions. Component quantities (weight, price, paint, etc.) can be 

calculated according to the expressions in the Properties Script and included in the lists. To use the 

custom Properties Script as the default in the element’s settings dialog box, click the Set as Default 

button at the top of the screen.

Note: When there is a Property Script defined, the listing commands will use this script, even if you 

previously created Components and Descriptors in the corresponding sections of the dialog box.

• Using the Parameter Script, you can define the choices available as a value of a given parameter. For 

example, you can restrict the choice of the surface of a table top to wooden surfaces, or define the 

different panel styles of a given door by their name.
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• The Interface Script allows you to define a custom user interface for your GDL Objects, including the 

graphic explanation of additional parameters. If an Interface Script exists, the settings dialog box of the 

given library part will include a Custom Settings panel. To use the custom Interface Script as the default 

in the element’s settings dialog box, click the Set as Default button at the top of the screen.

• Forward/Backward Migration Scripts: Click the Forward Migration or Backward Migration buttons to 

define how to migrate the parameters of an old instance forward to the current open element (or backward 

to an older element).

GDL Script Window Shortcuts

At the top of all script windows, some commonly used functions are available in the form of buttons.

• Clicking the first button transforms selected lines into comments, that is, lines that will not be executed in 

the script. Comments are identified by an exclamation mark at the beginning of the line.

Note: You can select more than one line.

• The second button has the opposite effect: clicking it will transform any selected comments into 

executable lines.

• Clicking the third or fourth button will format the script window by tabulating selected paragraphs left or 

right.

• The last button checks the GDL Script of the active window.

Note: When you are working in a Script window, all of these functions are also available as menu 

commands from the Edit menu, along with other special script window editing commands.

Note: The Property, Interface and Parameter Script editing windows also include a Preview button to 

show a preview of the custom script.

2D Symbol

Clicking the 2D Symbol item opens a new editing window from the Master Window.
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Each GDL Object you place in your Project is shown on the plan by a 2D Symbol. You can edit an existing 

symbol or create a new one with the standard ARCHICAD selection and 2D tools: Arrow, Marquee, Text, Fill, 

Line, Arc/Circle, Spline and Hotspot. You can also paste elements from the 3D Window here.

The final symbol that appears on the Floor Plan will be created from the elements of this window and the 2D 

Script, if there is one.

2D Symbol Display (Fragments)

To see the fragments of the 2D Symbol, select the 2D Symbol button, then go to Options > Element 

Attributes > Layer settings. The appearing list window shows the fragments of the 2D Symbol: these are 

useful for organizing the graphic elements that compose the plan symbol of the Library Part.

To toggle the visibility of layers of the object’s 2D Symbol, open the 2D Symbol window and click Ctrl+L (the 

shortcut for Layer Settings). The specialized Layer Settings window opens, which affects this window (the 2D 

Symbol window) only.

Click any fragment to show/hide it, or use the Show All/Hide All buttons.

Note: Fragments that are hidden are not available for storing new graphic elements. If you select a hidden 

Fragment in the dialog box of the Tool you are using for editing the symbol, you will get a warning asking 

you to change your selection or Show the selected Fragment.

Fragments are especially also for letting you easily replicate parts of the Symbol. You can draw a figure in the 

2D Script Window with the various graphic tools, and refer to it by its Fragment number in a GDL 2D Script 

that incorporates the figure in the final symbol in a variety of rotated and translated positions.

To set which Fragment you are drawing in when editing the 2D Script Window, choose a number from the 

Layers pop-up in the settings dialog box of the Tool you are using.

Preview Picture

In the Preview Picture window, you can attach characteristic graphical information to a GDL Object. The 

graphic does not affect the Object’s behavior or appearance in any way. This preview is displayed as the 

default representation of your Object in its tool settings dialog box, as well as next to library objects listed in a 

browsing window.

To generate the preview of a new Object:

1. Place the Object in the project.

2. Select the object and open the 3D Window to see this selection.

3. Go to View > 3D View Options > 3D Projection Settings. Choose a projection type and set up a view 

angle that show the typical features of your Object. Click OK.

4. Open Set Window Size (from the 3D Window tab or context menu). Set the window’s height and width to 

the same value to obtain a square shaped window.

5. Choose Document > Creative Imaging > PhotoRendering Settings. Define a pixel size that you will be 

able to insert in the preview without any distortion, and choose a neutral background for the Object (for 

example, white color for both the Sky and the Ground).

6. With the Object still selected, choose Document > Creative Imaging > PhotoRender Projection. A 

Model Picture is generated.

7. Choose Edit > Select All, then Edit > Copy.

8. Go back to the Floor Plan. With the Object still selected, choose File > Libraries and Objects > Open 

Object. This will open the Master Window of the selected Object.
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9. Click the Preview Picture icon to open the corresponding window, then choose Edit > Paste.

10. Save the GDL Object.

You can also paste other data from the clipboard, for example a photograph of the real-life object.

Check Object’s 2D and 3D Views

At bottom left, the two view buttons allow you to open the corresponding views of the GDL Object:

2D View

The 2D View window allows you to check the symbol that will be shown on the Floor Plan.

If there is a 2D Script defined, the 2D View will be calculated according to the script, even if the 2D Symbol 

window contains drawing elements. However, the 2D Script can refer to 2D Symbol Fragments.

To exit 2D symbol editing, close the symbol editing window or choose a different window, either from the 

Master Window, or from the Window menu.

3D View

In this window you can see the 3D view of the GDL Object converted from the 3D Script that refers to the 

current Parameter values. The viewpoint and other aspects are controlled using the View > 3D View Options 

> 3D Styles dialog box or the 3D Navigation Palette.

Close Window and Save Changes

When closing the master window, a prompt warns you to save changes. All the components of your item will 

be saved with it.

You can also save your item using the Save or Save as commands from any of the library item’s windows. 

(From the 3D View, you can only save the image using Save as.) After saving, you can choose the View > 

Refresh > Rebuild command for the Floor Plan or 3D window to view the modified GDL Object.

If you close the Master Window of a GDL Object (Library Part), all of the other windows of the Object will also 

be closed. You will be prompted to save changes, if any.

Matching 2D & 3D Descriptions

The 2D symbol and the 3D description are automatically linked to each other in the GDL Object. There are no 

built-in safeguards against geometric incompatibilities between the two components. The most common 

incompatibility error occurs when the 2D symbol and the 3D shape have different positions or orientations with 

respect to the origin.
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To avoid this problem, follow these steps:

1. Activate the 3D View of the GDL Object.

2. Choose Top View in View > 3D View Options > 3D Projections Settings > Parallel Projections, and 

set the angle to 270°.

3. Choose Edit > Select All, then Edit > Copy. Activate the GDL Object’s 2D Symbol window and choose 

Edit > Paste. This will place the top view of the object (as a wireframe or hidden line) into the symbol 

window. It should match the dimensions and position of the 2D symbol.

4. Choose Undo once you have verified that the symbol matches the 3D view. This will remove the 3D lines.

You can use this feature to have ARCHICAD create the 2D symbol for you. You will only need to add 

additional hotspots, lines, etc. The procedure is the same for Doors and Windows, with the following 

modifications:

• Choose Side View instead of Top View (the angle should still be 270°).

• A mirrored view will be placed. Select the placed lines and mirror them across the reference line of the 

wall.

Note: When you place a wireframe view, redundant lines are removed. Using Hidden Lines will give you 

an accurate view, but underlying lines will be hidden.

You can also ensure compatibility between the 2D plan symbol and the 3D model of a GDL Object by writing 

a parametric description in GDL for the symbol.
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Text Editing Commands in GDL Script Windows

These commands in the ARCHICAD Edit menu are active only if one of the library part script windows is 

active: Master, 2D, 3D, Property, Parameter, Interface, Comment.

Other Edit menu commands that are useful in GDL Script Windows are described at: Editing Commands in 

Text-Type Windows.

See also Script Buttons and GDL Script Window Shortcuts.

Comment

The Comment command adds exclamation marks (!) in front of selected lines in a GDL script window.

Note: This commands is also available as a shortcut at the top of the GDL script windows:

Uncomment

The Uncomment command removes the exclamation marks from selected lines in a GDL script window. This 

feature is useful if you wish to visualize only a part of your script.

You can comment or uncomment the whole contents of the Window by first choosing the Select All command 

from the Edit menu.

Note: This commands is also available as a shortcut at the top of the GDL script windows:
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Increase Indent/Decrease Indent

These commands will place/remove the number of spaces defined in the Text Window Format dialog box for 

tabs at the beginning of the paragraph.

Notes: These commands are also available as shortcuts at the bottom of the GDL script windows:

Check Script

With this command, you can check whether the syntax of the GDL script in the active Window is correct.

If you wish to check all the scripts of the current Library Part, activate its Master Window before choosing the 

command.

Note: This command is also available as a shortcut at the bottom of the GDL script window.

Open Debugger

This command is only active when a GDL Script Window is in front and allows you to debug GDL Scripts.
ARCHICAD 24 Reference Guide 3354



Dialog Boxes User Interface Reference
Subtype Hierarchy Dialog Box (GDL Master Window)

See also About GDL Object Subtypes.

This dialog box is accessible using the Select Subtype button in the GDL Master window (File > Libraries 

and Objects > New Object) 

or is available on the Edit GDL Library Parts toolbar (Window > Toolbars > Edit GDL Library Parts). You 

can add it to your ARCHICAD menu structure using the Work Environment dialog box.

The items listed by name in the Subtype Hierarchy are color-coded.

• Green indicates that the item is placeable.

• Black indicates that the item cannot be placed on its own and can be only used as a macro reference.

• Bold type indicates that the item is a subtype template and is placeable.

If you highlight an item in the hierarchy, you can review its Properties in the bottom section.

Below the Name field, the GUID refers to the highlighted Subtype’s Global Unique Identification code.

For a complete description of how GUID works, see this article on Help Center.

Select: Click this button to directly open that item’s Master Window.

Create Clone: Click this button to create a copy of the highlighted Subtype with the same properties.
ARCHICAD 24 Reference Guide 3355

http://helpcenter.graphisoft.com/?p=25785


Dialog Boxes User Interface Reference
Scheme Settings Dialog Box (Interactive Schedule)

To access this dialog box, do one of the following:

• Click Scheme Settings from the opened Schedule window

• Use the Schedule’s context menu in the Navigator

• In the Navigator Palette, select a Schedule, then click the “Settings” button at the bottom of the Navigator.

• Use Document > Schedules > Scheme Settings

For more information, see Interactive Schedule.

See also Reservation in Interactive Schedules (Teamwork).

Topics in this Section:

Schemes Panel

Criteria Panel

Complex Criteria Definition

Complex Criteria Example

Schemes Fields Panel

Additional Criteria and Fields: Library Part Parameters

Sort Schedule Fields

Schemes Panel

The left panel of Scheme Settings panel lists the available Schemes defined for your project. 

Click the panel header items (ID/Name) to sort them in ascending or descending order.

You can rename the Scheme and edit its ID directly in this list. 
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Edit the Schedule’s Criteria and Fields in the panels at right.

• New/Duplicate: Click New to create a new Schedule Scheme. 

In the appearing dialog box, choose whether to create a new Scheme, or to duplicate the current one.

Choose a name and an optional ID number.

For a new Scheme, choose “Construction Elements,” “Components”, or “Surfaces”, depending on the type 

of schedule you are creating. 

• Delete: Click to delete the selected Schedule Scheme.

• Import: Click to import a Scheme data file (XML format, created with ARCHICAD 8 or above) or a Door or 

Window Schedule file (created with ARCHICAD 7.0.)

• Export: Click to export the Scheme as an XML file that you will be able to import into another project.

Criteria Panel

Use this panel to define Element/Component/Surface Criteria for listing.

For a description, see Define Element Criteria.
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See also Additional Criteria and Fields: Library Part Parameters

and Define Element Criteria using IFC Data

Remove: Click this button to delete the selected row. Inactive if no row is selected.

Click and drag the up/down arrow at the beginning of any row to move the row up or down within the 

Scheme.

Complex Criteria Definition

The and/or operator determines the relationship between adjacent criteria.

Keep in mind the meaning of “AND” and “OR” as logical operators. 

• If you have a criterion with two statements joined by AND, the criterion will be fulfilled only if BOTH of the 

statements are true.

– For example: Layer is “Interior - Partition” AND Element Type is Wall. Your schedule will list an 

element only if it is (1) on the given Layer, AND (2) it is a Wall.

• If you have a criterion with two statements joined by OR, the criterion will be fulfilled if one OR the other 

OR both of the statements are true.

– For example: Element Type is Wall OR Slab OR Column. Your schedule will list any element which is 

EITHER a Wall, OR a Slab, OR a Column.

Thus, criteria that use AND are more restrictive, because both statements must be true. 

Criteria that use OR are less restrictive, because it is enough for any one of the statements to be true.

Note that if you want to list multiple Element Types, you must join them with an OR statement. 

• For example: Element Type is Wall OR Slab. (If you join Element Types with AND, e.g. Element Type is 

Wall AND Slab, your schedule will return nothing, because an element cannot be both a Wall AND a 

Slab.)
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If needed, use the Open Parentheses and Close Parentheses columns of Scheme Settings to set up nested 

criteria for more complex schemes: in any selected row, click on the pop-up under the parentheses column to 

choose a parenthesis, or no parenthesis.

Each “open” must have a corresponding “close” in order for the scheme to be logical. If there is a mistake in 

your parentheses logic, the Criteria invalid! warning appears at the bottom of the panel.

Complex Criteria Example

Suppose you want to list all the Walls, Slabs and Columns that are on a particular layer.

To meet this criteria, an element must:

1. be either a Wall OR a Slab OR a Column.

AND

2. be located on that particular layer

To get the correct result, you must make the three element types into a group by putting parentheses around 

them. Note the parentheses in the image below, which enclose the group of three element types.

Within the parentheses, the three element types must be joined as OR statements, as shown.

Schemes Fields Panel
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This panel lists the parameters which will be displayed as fields of the schedule. Parameters that cannot be 

edited in the schedule are shown in black, while editable ones are shown in blue type. 

• Add Fields: Click this button to access the list of available parameters and properties.

The list depends on the type of schedule, and may include General parameters; specific parameters 

related to Component and Surface lists; and ARCHICAD Properties.

Choose a field (use the search field at the top to find it more quickly), then double-click to add it to the list. 

(Alternatively, click Add or press Enter.)

See also Additional Criteria and Fields: Library Part Parameters

and Define Element Criteria using IFC Data

For more information on specific parameters used in element lists, component lists, and surface lists, see the 

following sections: 

Element Parameters

Component Listing Parameters in the Interactive Schedule

Create Schedule of Surfaces

For information on using ARCHICAD Properties, see:

Properties and Classification Systems

Keep Components together in the Schedule: This checkbox is available in the Scheme Settings of 

component-type lists.

• If you check the box, components are always grouped together, corresponding to the element they belong 

to. (For composite elements, these fill components are listed in the same order as in Composite Settings.)
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• If you leave it unchecked, components will be listed according to the Scheme Settings (e.g. ordered by 

name rather than by element).

Remove: Click this button to delete the selected field from Scheme.

Once the new (or modified) scheme is defined, its name appears in the Navigator and you can use it like any 

other view.

Defining Schedule Fields for BIMx Info

You can set up one or more Interactive Schedule Schemes to define which ARCHICAD element information 

should appear when navigating a BIMx Hyper-model in a BIMx application.

See Info Set at Create BIMx Hyper-Model.

ARCHICAD comes with a predefined Interactive Schedule Scheme use in BIMx, but you can define any 

number of additional schemes.

Display a URL in BIMx Element Info

This Scheme-defined element info can include a URL - that is, a hypertext link to a website (e.g. manufacturer 

information) or project-related data (e.g. a location in Google maps).

Here’s the best way to do this:

1. In Scheme Setup, add a “Custom Text” field.

2. In the field, type what you want the BIMx user to see in brackets:

[Tap here for Manufacturer contact]
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3. Immediately next to this - without leaving a space! - type the URL address in parentheses:

https://www.google.hu/maps/place/Graphisoft+Park+Kft./@47.5608203,19.0536518,17z/

data=!3m1!4b1!4m5!3m4!1s0x4741d9823c47a959:0xb51b24e70025bbc!8m2!3d47.5608167!4d19.05584

58?hl=en
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Additional Criteria and Fields: Library Part Parameters

In both the Criteria and Fields panels of Scheme Settings, use the black arrow at the right end of the Add 

Criteria or Add Fields button to access additional parameters and properties:
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Library Part Parameters

This command makes the parameters of loaded library parts available for listing as criteria or as fields.

• Select Object by: Use the pop-up on the right to choose an option for searching for objects to select.

– Folder View: lists all the loaded library folders that contain library parts.

– Folder View (Used Objects only): lists the loaded library folders that contain the library parts used in 

the current project.

– Search Criteria: displays a form that allows you to list the library parts whose name matches the 

chosen criteria.

– Favorite Objects: shows the preview and the name of the library parts defined as Favorites.
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• Search Object: If the Search Criteria option is active in the Select Object by pop-up field, this area allows 

you to search for library parts whose name matches some criteria.

– Find names which: With the pop-up control, choose a condition (match, contain, start with, end with) 

and enter a text string in the field on the right.

– Search in: Use this pop-up control to choose a loaded library to search. Click the Find button to 

display the results in the Library parts found box.

– Find: Click this button to perform a search based on the condition set with the Find names with and 

Search in controls.

– Library parts found: Displays the preview and names of the library parts that match the condition set 

with the Find names with and Search in controls.

Add: Click this button to add the available parameter selected in the box on the left to the list of selected 

parameters on the right.

Remove: Click this button to delete the selected field from the box on the right.

IFC Properties

To use IFC properties as criteria or fields for the schedule, click this command.

See Define Element Criteria using IFC Data.
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Sort Schedule Fields

To change the order in which fields are listed in the schedule, use the up/down arrows at the left edge of each 

row to move the field up or down.

See also Schemes Fields Panel.

Sort By Value (Ascending/Descending)

For any field in Scheme Settings: Activate the up/down arrow to sort the items of this field in ascending/

descending order; or leave this field blank, for “None”. “None” means that this field will not be taken into 

consideration when sorting.

In this example: the Volume field has activated the up arrow. The listed walls that are of the same structure 

type will be listed in order of their volume (top value the highest).
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Display Sum

Display a “sum” to add a schedule cell that will contain the sum total for all items of this field. 

Display Quantity

To show the quantity of items (rather than their sum), choose the “sum1” icon.

Here, we will have the schedule add a Quantity to the schedule’s Wall Type column.

Display Subtotal

Display the flag icon next to the one schedule field to display its subtotal.

This field will display a separate sum and/or quantity for each group of identical elements in that field.

For example, the Building Material/Composite field already has a “Quantity” row, showing the total number of 

walls; to show a Quantity and Sum for each type of wall in that field, we have added a flag to that field in 

Scheme Settings.
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The result: Wall Types show a separate quantity for each separate wall type. Moreover, the Volume column 

also lists the corresponding volume sub-totals.
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Index Settings Dialog Box

For general information, see Project Indexes.

To access this dialog box, do one of the following:

• Choose Document > Project Indexes > Project Index Schemes command.

• Use the Project Index’s context menu in the Navigator Project Map structure.

• Select Project Indexes in the Navigator Project Map structure and click “Settings” at the bottom of the 

Navigator panel.

• Select an Index in the Navigator View Map structure and use its context menu.

The left panel lists the project’s Indexes, grouped by type. Select the Index you want to edit, or use the buttons 

at the bottom to create, duplicate, delete, import and export Index schemes.

The right side shows the Criteria and Fields of the selected Index.

• Use the Criteria Panel of Index Settings to define the items to be listed in the Index.

• Use the Fields Panel of Index Settings to define which parameters of the chosen criteria should be 

displayed in the Index.

The controls are identical to those of the Interactive Schedule Scheme Settings. 

Related Topics:

Schemes Panel

Criteria Panel

Schemes Fields Panel
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View Settings Dialog Box

Use the controls in the View Settings dialog box to adjust the settings of the currently selected view.

Open View Settings from any of the following:

• The tab context menu of the opened view

• The view item’s context menu in the Navigator (or Navigator Palette/Organizer)

• The “Settings” button at the bottom of the Navigator View Map

Get Current Window’s Settings: Click this button to overwrite the settings in this dialog box to correspond to 

the view currently in effect in the active (frontmost) window.

View Settings also opens whenever you use the Save View or Save as View commands.

For more information, see Navigator View Map.

View Settings Identification Panel

• ID: Choose a method for assigning an ID to this view: None, Custom (enter desired ID in adjoining text 

field), or By Project Map.

“By Project Map” means that the view will inherit the ID from its corresponding Viewpoint in the Project 

Map.

• Name: Choose a method for assigning a name to this view: either Custom (enter desired name in 

adjoining text field), or By Project Map.

“By Project Map” means that the view will inherit its Name from its corresponding Viewpoint in the 

Project map.

• Source: This field provides feedback on the view’s source viewpoint, or the file path of its source file.
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View Settings General Panel

• Layer Combination: Choose a Layer Combination to be applied to this view.

For more information, see Apply a Layer Combination.

• Scale: Choose a Scale to be applied to this view.

For more information, see Scale.

• Structure Display: Choose a Partial Structure Display setting for this view.

For more information, see Partial Structure Display.

If this pop-up is gray: This means that the original viewpoint is either Manual Update or Drawing, so you 

cannot edit the Partial Structure Display of this view. You can change the viewpoint to Auto Update, or else 

create a new view using the Partial Structure Display setting you need.

• Pen Set: Choose a Pen Set to be used with this view.

For more information, see Pen Sets.

• Model View Options: Choose a Model View Option Combination to be applied to this view.

For more information, see Model View Options.

• Graphic Override: Choose a Graphic Override Combination to be applied to this view.

For more information, see Graphic Override Combinations.

• Renovation Filter: Choose a Renovation Filter to be applied to this view.

For more information, see Renovation.

View Settings 2D/3D Documents Panel

• Floor Plan Cut Plane Settings: Click this button to access the Floor Plan Cut Plane Settings dialog box. 

Any adjustments to these settings will be applied to this view only, not to the project as a whole.

For more information, see Floor Plan Cut Plane (Global Setting).

• Dimensions: Choose a Dimensioning standard from this pop-up menu. The standard you choose here 

will be applied to this view only, not to the project as a whole.

For more information, see Dimensions Preferences.

• Zooming: Choose a zoom to save with this view:

• Note: A view’s saved Zoom value includes the Pan and the Oriented View (rotation), if any.

-  Current Zoom: The view will save the current zoom as part of its settings.

Note: Once a view is saved at “Current Zoom,” that setting is henceforth called Zoomed Area in this pop-

up list.
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- Fit in Window: whenever you open this view, or whenever drawings from this view are updated or 

published, they will be displayed to include the project window’s entire contents, subject to Layer 

status

- any custom-named Zoom you have saved earlier.

See Save Zooms.

For more information, see Zoom.

Ignore zoom when opening this view: If this box is checked, then whenever you open this view, it will be 

displayed using the zoom value of the last opened ARCHICAD window (not the saved zoom of this view). 

However, the saved zoom level of this view will still be applied when you place this view as a Drawing, or 

publish it.

Note: A view’s saved Zoom value includes the Oriented View (rotation), if any.

View Settings 3D Only Panel

Filter and Cut Elements in 3D... 

Click to open the dialog box.

See Filter and Cut Elements in 3D Dialog Box

Generate in: Choose whether to generate the 3D view in the 3D window or in the PhotoRendering window.

3D Style: The settings for 3D Window display.

See 3D Styles.

Rendering Scene: Apply a saved Scene if you choose to always generate this 3D view as a PhotoRendering. 

Size: View or edit the size of a rendered view.

Additional info is shown about:

• whether Render Safe Frame is applied

For more information, see Select and Manage Rendering Scenes and Render Safe Frame.

• how the 3D-related and rendering-related settings (collectively “Image settings”) are saved with the 

current view.

Redefine Image settings with current: Check this box if you want to overwrite the stored Image settings 

with the Image settings now in effect in the current (frontmost) window.

Note: Image settings are the following: 3D projection settings (including zooming and sunlight settings), 

filter elements in 3D, 3D Styles, 3D cutting planes, 3D cutaway and photo rendering settings.

If you check this box, the panel indicates  whether the 3D view in the current (frontmost) window has been 

filtered or limited by a marquee, and whether Render Safe Area mode is on. 

If you now click OK to close the View Settings dialog box, the 3D view will be redefined accordingly (i.e. it will 

only display the filtered or selected elements).
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Book Settings Dialog Box

To access this dialog box, do one of the following:

• Use the Document > Layout Book > Book Settings command

• Use the context menu of the Layout Book icon in the Navigator Layout Book structure, or the Settings 

button at the bottom of the Navigator Palette when the Layout Book icon is selected in the tree view.
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• Click the Transmittal History button from the Change Manager

IDs of Items in this Book Panel

• The Use Hierarchy option assigns IDs that reflect the position of the Layouts within the tree view 

hierarchy, including their position in Subsets. In this system, the Subsets can also receive an ID, which 

shows up as part of the ID assigned to each of its Layouts.

Subset IDs are defined in Subset Settings.

For more information, see Subset Settings Dialog Box.

• The Use Flat Layout Order option assigns IDs to all the Layouts of the Book. The ID assignment is 

performed in the Navigator from top to bottom regardless of the Layouts’ position in the hierarchy. In this 

case, Subsets will have no IDs. The Layout IDs will use the prefix and style you define here.

For more information, see Layout and Drawing IDs.

Transmittal History Panel

Use this panel of Layout Book Settings to create and manage Transmittal Sets as part of Revision 

management.

Note: You can access this panel easily from the Change Manager Palette.
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This panel lists all Transmittal Sets of the project, with the Layout Revisions that belong to each Transmittal 

Set.

For a selected Transmittal Set: 

• click the icon to access its Transmittal Set Details

• click the red X to delete the Transmittal Set

• if the Transmittal Set is closed, its Transmittal Set Date is listed here. The Transmittal Set Date for an 

open Transmittal Set is shown as “Work in Progress”.

For a listed Layout Revision:

• click the Info button to view any Changes associated with that Revision

• if the Transmittal Set is still open: click the blue X to remove the Layout from the Transmittal Set

Only one Transmittal Set can be open at a time. When an Transmittal Set is open, the following commands 

are available on this panel:

• Close Transmittal Set

• Delete Transmittal Set

• Add Layout

When the current Transmittal Set has been closed, the panel looks like this:
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Change Numbering in Revisions Panel

Set a Numbering logic for Revision Numbering for the current Transmittal Set:

• Use Change ID (Default): Changes should appear on Layouts using their own global ID

• Number by Revisions: Changes should appear on Layouts using the following ID: LayoutRevision ID + 

Suffix + numbering.

If you choose Number by Revisions, this will affect Change Numbering only where it appears in the Layout 

context: that is, in the Change Marker autotext; in the Revision History object on the Layout; and in the Layout 

Settings Revision History.

Layout Info Scheme Panel

Use this panel to customize or add new fields to be used for Layout-specific information.

For information on using these fields, see Layout Info Panel (Layout Settings).
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Subset Settings Dialog Box

Subset Settings provides a way to assign IDs to the Layouts contained in the selected Subset. The ID 

definitions in Subset Settings are applied if you have selected “Use Hierarchy” as the ID assignment method 

in Book Settings.

The Subset Settings dialog box can be accessed from the Navigator in one of three ways, provided that the 

Tree by Subsets view is displayed and the given Subset is selected:

• Click the Settings button at the bottom of the Navigator palette.

• Choose the Subset Settings command in the context menu opened by right-clicking (or Ctrl-clicking) the 

name of the Subset.

• Click the “Settings” icon at the middle of the Navigator palette.

For more information, see Navigator Palette.

Subset Identification Panel

Use the controls in this panel to assign an ID to the selected subset.

For more information, see Layout and Drawing IDs.

• Do not include this Subset in ID sequence: Check this box to exclude the Subset from automatic ID 

assignment. (If you check this box, the following option for automatic ID assignment is grayed.)

• Assign ID Automatically: Choose this option to assign an ID automatically, based on the Prefix and Style 

defined in Book Settings.

• Custom ID: Choose this option to assign a Subset ID of your choice.

IDs of Items in this Subset Panel

These controls affect the IDs of Layouts contained in this Subset.

• Continue Using ID Assignment of Upper Levels: Check this option if you want Layouts within this 

Subset to be assigned IDs as if they were not within this Subset, but rather part of the level above. In this 

case you are only using the Subset as a logical grouping which has no effect on IDs.
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• Customize ID assignment: Check this option if you want the Layouts inside the Subset to be assigned 

custom IDs:

- Use Prefix & IDs of Upper Levels: Layouts in this subset will be assigned IDs based on the previous 

Layout in the Layout Book structure.

- Add Prefix for this Subset:

Note: When IDs by letters exhausts the alphabet, the numbering continues as follows: y, z, aa, ab, ac. 

(The initial letter in double-letter numbering always consists of a single character regardless of the 

language being used.)

When moving a Subset within the hierarchy, IDs are automatically adjusted accordingly.
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Layout Settings

The Layout Settings dialog box contains information about the selected Layout.

To access this dialog box, select a Layout - either by opening it in the Layout window, or by selecting it from 

the Navigator/Organizer. Then do one of the following:

• Choose Document > Layout Book > Layout Settings

• Use the Layout’s context menu in the Navigator

• Click the “Settings” icon at the middle of the Navigator

• Click “Settings” at the bottom of the Navigator 

Layout Identification and Format Panel

For more information, see Layout and Drawing IDs.

• Do not include this Layout in ID sequence: Check to exclude the current layout from the automated 

layout ID assignment.

• Use Automatic Book and Subset ID assignment: Check to apply the automated layout book and 

subset ID assignment to the current Layout, as defined in Book Settings.

For more information, see Book Settings Dialog Box.

• Custom ID: Check to apply a unique ID to the current layout.

• Layout Name: Enter a Name for the Layout.

• Master Layout: Select a Master Layout from the pop-up menu.

For more information, see Master Layouts.

• Size: This field provides information on the horizontal and vertical size of the current layout (as defined in 

its Master Layout).

Drawing IDs on this Layout Panel

Settings in this panel will determine the IDs of all Drawings placed on this Layout, provided that the Drawing 

ID is set to “By Layout” in the Identification panel of its Drawing Settings dialog box.

For more information, see Drawing Identification Panel.

• Continue Drawing ID sequence from previous Layout: Check this box to assign an ID by continuing 

the ID sequence from the previous layout. (This control is grayed if the selected Layout is the first one in 

the Layout Book.)

• Drawing ID Prefix: Enter item prefix characters for the drawing ID.

• Drawing ID Style: Choose any of the listed ID styles from this pop-up field.

• Start at: Enter either a number or a letter (depending on the selected ID style) with which to begin the ID 

sequence.

• Preview: This area shows a preview of the ID style you have selected.
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Revision History Panel

The panel lists each Revision of this Layout, plus the Changes associated with each Revision and Transmittal 

Set.

Click Add Change to add an existing Change to this Layout.

See also Add an Existing Change to a Layout.

Click New Change to create a new Change in the project and add it to this Layout’s current Revision.

See also Create New Change on a Layout Revision and Revision History Data on Layout and in Layout 

Settings.

Layout Info Panel (Layout Settings)

Use these fields to define basic data values for the current Layout.

To customize these fields or add new ones, use the Layout Scheme Panel of Book Settings.

See Book Settings Dialog Box.

This can be useful if you need to differentiate these data for specific Layouts. 

• For example, the project may already be in the construction phase, yet one Layout may still have a 

Preliminary status, while another Layout has the status of Approved by Contractor. 
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• Similarly, different parts of the documentation (e.g. Details vs. Floor Plans) may be the responsibility of 

different people, so you can use the Modified by/Checked by/Approved by fields to specify these names 

for any given Layout.

These data can then be displayed in the following parts of the ARCHICAD interface:

• Autotexts placed on Layouts

• Names of Publisher Items

• Sheet Indexes

• Transmittal Set History Index

• Revision History object
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Import Views from ARCHICAD Project

For an overview, see Access Views/Layouts from External ARCHICAD Project.

This dialog box appears if you are placing a Drawing into your project in this way:

• You have chosen File > External Content > Place External Drawing from File and selected an 

ARCHICAD Project file type:

Check items to import: This list displays, in a tree structure, all the Views of the chosen project. Click the 

checkbox of each item that you wish to import into the active project. (The View Settings of any individual 

selected view are displayed at the bottom of the dialog box.) list.

If the Layout Window is open, you are placing a Drawing onto an open Layout Window, you can only choose 

a single view here.

Checking a box in front of a folder name will select all the Views in that folder.

Choose a radio button at right to define where to place the imported drawings.

• Place Drawings on Current Layout: Place each selected View as a Drawing onto the currently active 

Layout.

• Insert new Layouts in Selected Layout Book Subset: Place each View onto a New Layout in the 

Subset (provided that a Subset was selected in the Navigator palette prior to choosing the Place External 

Drawing command).

Note: This option is inactive if no Subset has been selected in the Navigator, or if multiple Navigator tree 

structures are open with several selected subsets.

• Append new Layouts to Layout Book: Place each View as a Drawing onto a new Layout appended to 

the Layout Book

Note: After importing items from this file, its tree structure will henceforth be displayed in the Navigator, so 

you will be able to drag and drop further items easily.

Use Source Hierarchy: Check this box to retain the hierarchy of the source folder: the current project will 

recreate the same folder structure inside the Navigator palette.
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Master Layout Settings

For general information, see Master Layouts.

This dialog is available from

• Context menu of Layout or Master Layout

• In Navigator: Select Master Layout, then click Settings

• Document > Layout Book > Master Layout Settings

Name and Size

Note: Length units defined for the Master Layout are Layout units, defined in Options > Project 

Preferences > Working Units.)

• Name: Enter a Name for the Master Layout in the text field.

• Size: Define the Master Layout size using the standard paper sizes listed in the drop-down list, or the 

Custom option. The two fields below give you feedback on the horizontal and vertical dimensions of the 

Layout.

• Margins: Enter values for the Master layout’s four margins in the text fields.

• Choose Portrait or Landscape as the Master Layout’s orientation.

Printable area: This area gives you feedback on the Master Layout’s printable area (taking its Size and 

Margins into consideration).

Anchor Point: Click one of the nine points to use as an anchor for your master layout.

Display Master Layout

• Above Layout: Master Layout items will be placed on top of the Layout (in some cases, obscuring some 

of the Layout content).
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• Below Layout: Master Layout items will be displayed behind the Layout. Contents of the Layout may 

obscure some Master Layout items.

Drawing Placement

Choose one of the two logics for placing multiple drawings on the layout.

Note: The default logic is “Auto Arrange.” If you are placing only a single drawing on the Layout, it will be 

placed in the center of the Layout.

Auto Arrange New Drawings

If you choose this option, click Auto Arrange Setup to set the following:

Direction: Choose either horizontal or vertical to determine the direction in which subsequent drawings are 

placed on the Layout.

Distance from Margin: For each of the four sides of the Layout, define a margin of space.

Sequence by: When placing multiple drawings at once, the Sequence setting determines the order in which 

they appear on the Layout.

• Name/ID: Alphabetical by name; in case of identical names, drawings are placed in order of ID (numerical 

or alphabetical).

• ID/Name: In ID order; in case of identical IDs, drawings are placed according to their name (alphabetical 

order).

• Navigator position: Drawings are placed in the order (top to bottom) that they are listed in the Navigator 

View Map. (Floor Plans are an exception; they are placed according to their View Map order from the 

bottom up, e.g. Story 1, 2, 3...).

Insert break between sequences: “Sequence” depends on your choice in the Sequence by options above: 
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• if you are sequencing by Name/ID (or ID/Name): Check this box to start a new row/column every time the 

Name (or ID) changes. 

• If you are sequencing by Navigator position: Check this box to start a new row/column for each new folder 

in the Navigator View Map. For example, Drawings from the Details folder will be placed in one row, from 

the Sections folder in the next, etc.

Gap Between Drawings: Define the length of the gaps between the rows and columns of placed drawings. 

(Length units here are Layout units, defined in Options > Project Preferences > Working Units.)

Create New when Layout is Full: Create a new Layout if the current layout is full.

Align and Assign Drawings to a Grid

If you choose this option, click Grid Setup to access the grid settings options. As you set these options, 

consult the Preview picture.

ID Logic: Assign an ID to each grid cell by a defined logic:

• Matrix: Each cell ID is based on its column and row number

• Flat: Cell IDs are numbered in sequence. 

Number of Cells: Define number of columns and rows in your Grid.

Depending on which ID assignment logic you choose (Matrix or Flat), the subsequent controls will vary.

Matrix-Style ID Options

Direction and Style

• Choose how to assign IDs to grid columns/rows (left/right, and up/down)

• Choose an ID numbering style

Drawing ID Format: For Matrix-style IDs, define numbering format:

• Row, then Column, or

• Column, then Row

Flat-Style ID Options

Start From: Define one corner of the grid as the starting point for assigning cell IDs

Style: Choose an ID numbering style
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Primary Direction: Define the direction (horizontal or vertical) in which to assign the cell IDs, starting from the 

corner you designated (Start From).

The rest of the controls in the panel apply to the Grid regardless of ID logic.

Grid Line Display Options

Note: These Grid line display settings also affect printed output.

• Distance from Margin: Define the distance of the Grid from the paper margin (top, bottom, left and right).

• Choose line type and pen color

• Show/Hide All Grid Lines

• Hide all which intersect with a drawing: Check this option to hide such grid lines.

Multi-Cell Drawings

Define which cell ID should be assigned as the drawing ID (You will choose one of the drawing’s four corners; 

the ID of the cell which that corner occupies becomes the drawing ID.)

Set as Default for New Layouts

Check this box if you want this Master Layout to serve as the default Master Layout for new Layouts.
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Drawing Manager

Drawing Manager lists all the Drawings you have placed in the Project (both Layout Book and Model views), 

including those referring to external projects, and external drawings such as PDF files.

Use the Drawing Manager commands to check the status of the placed drawings, modify their update type, 

reestablish, repair or change links.

For any selected drawing in the list, context menu commands are also available. 

You cannot edit a selected drawing’s parameters directly in the Drawing Manager. To edit drawing 

parameters, use Drawing Settings.

You can also check Drawings and access Drawing Manager through the Action Center. (File > Info > Action 

Center).

Topics in this Section:

Open Drawing Manager

List of Drawings

Drawing Properties

Drawing Update Status

Drawing Manager Commands

Related Topics:

Action Center

Drawing Settings

Managing and Updating Placed Drawings

Open Drawing Manager

Do one of the following:

• choose File > External Content > Drawing Manager

• click the Drawing Manager icon from the pop-up menu at the upper left corner of the Navigator/Organizer:
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• choose Window > Palettes > Drawing Manager

List of Drawings

If the active window contains a Drawing, it is listed in the Drawing Manager in bold.

• Default info for each drawing: Type, ID, Name, Status, Crop Status, Layout (Placed to), Source View, Path

• Toggle columns on/off: right-click any column header to see list of available columns, or click the black 

arrow at the right end of the list columns

• Sort columns by clicking on the column header

• Secondary sorting: click a second column header to further sort within the hierarchy obtained by the first 

sorting

• Resize column widths graphically

Drawing Properties

• Type: Indicates the Drawing’s source type (e.g. a Floor Plan view or a PDF file).

• ID: Shows Drawing ID.

• Name: Shows Drawing name.

• Status: See Drawing Update Status below.

• Placed To: Name of Layout or Model View on which Drawing is placed.

• Source View: Source view as displayed in Navigator Project Map. If the Drawing source is not an 

ARCHICAD view, then this column displays the source file name and (in the case of a multi-page PDF 

document source) the page number from which the Drawing is created.
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Note: If the Drawing source is a DWG paperspace, this field also indicates the viewport number.

• Path: Location of the drawing’s source view (e.g. either Internal, or its file path).

Drawing Update Status

For the selected Drawing(s):

• OK: Drawing is updated.

• Modified: Source has been modified. Click the Update button to update the drawing.

• Missing: The source of the linked drawing cannot be found.

• Not Accessible: The source file is either an old Teamwork file (a Teamwork file format from a pre-13 

version of ARCHICAD), or it is an ARCHICAD 13 or later Teamwork project located on a BIMcloud/BIM 

Server. You do not have access to this source, because you are using either a Demo version of 

ARCHICAD, or a non-Teamwork protection key; or you do not have Teamwork access rights to this 

source.

• To be Updated: Temporary status of a drawing included in the set of Drawings to be updated, but the 

update process has not affected this drawing yet.

• Updating: Temporary status of a drawing currently being updated.

• Embedded. This Drawing’s link has been broken and cannot be updated. (The Drawing Manager displays 

its former source view for information purposes only.)

• Needs Checking: ARCHICAD’s automated background quick-check function cannot determine 

definitively whether the drawing needs an update or not. If this status appears, you can do one of the 

following:

– Click the Check Status button to see whether the drawing is either OK or Modified. In the latter case, 

if the drawing’s update method is Manual, you can decide whether to update it or not. (A Drawing set 

to Automatic update will be updated as soon as you activate its Layout or window.)

– Click Update

Drawing Manager Commands

The commands (icons) at top left apply to the drawing(s) selected in the list. All applicable commands are also 

available from a selected Drawing’s context menu.
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Link Drawing

Links the selected drawing to either an external source or an internal view.

Break Drawing Link

Breaks the link of the selected drawing. The drawing is now embedded into the project. It cannot be updated, 

until you again link it to a source.

Update Drawing

Click to update the drawing.

Crop Drawing to Frame

For a selected Drawing with a Manually resized Frame, which is not cropped:

this command crops the unseen Drawing content.

See Drawing Frame.

Delete Drawing

Click to delete the selected drawing(s) after confirming the warning message.

Note: Deleting a drawing is undoable ONLY if the window containing the drawing is active at the time you 

delete it.
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Check Status

Check the update status of the selected drawing(s), if its status shows “Needs Checking”.

Open Source View

Open the source view of the selected drawing. (This button is grayed for Drawings having an external source.)

Settings

Open the selected drawing(s)’ Settings dialog box.

Note: To assign parameters to multiple Drawings at the same time (such as a uniform Pen Set to all 

Drawings in the Layout Book), select the Drawings in Drawing Manager and click Settings. Any settings 

you modify will be applied to all the selected drawings (other Drawing Settings will remain as-is for each 

drawing).
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Paste Options Dialog Box

This dialog box appears if you are pasting copied ARCHICAD elements from the Clipboard, and the pasted 

elements cannot appear in their entirety in the Window at the current zoom level, or if it is possible to locate 

the pasted elements relative to either the Active view or a Reference view.

Where to Paste

Center of the Current View: Paste the Clipboard contents into the center of the current view with no regard 

for the pasted elements’ source view origin.

Original Location: Paste the Clipboard contents into the current view at the same position as in the original 

source view (i.e., relative to the origin of the source view).

Reference Location: Paste the Clipboard contents into the current view relative to the origin of the Reference 

view.

This option is only available if a Reference view is shown; if the Reference view’s origin is at a different 

location from the Active view’s origin; and if that Reference view is of the same type (e.g. Floor Plan) as 

the contents of the Clipboard.

Zoom

Keep Current View: After the Paste command, the currently active window will remain at the same zoom 

level as before.

Zoom to Pasted Elements: After the Paste command, the current window will zoom in to the newly pasted 

elements.
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Print 2D Document

This dialog box is opened with the File > Print command if a 2D window (including the 3D Document Window) 

is active, or from the Print Options command when printing from the Navigator Publisher.

Printer: This field displays the printer driver currently set up for your machine. To change the assigned printer, 

choose the Page Setup button at right.

Page Setup: Click this button to open the Page Setup dialog box, where you can choose a printer and set 

paper size and orientation.

Print Area: Choose which part of the active 2D window you wish to print.

• Entire Drawing: Choose this button to print the entire printable content of the window.

• Current Zoom Only: Choose this button to print only the visible content of the current window at its 

current zoom (including its rotated orientation, if any).

• Marquee Area: If you have placed a normal orthogonal Marquee in the active window, choose this button 

to print only the marquee area. (The option is available for other marquee shapes, but the output area will 

always be orthogonal.)

Print Range: Choose either All to print all pages, or choose a page range for multi-page output. See the 

Preview at the bottom right of this dialog box for how multi-page output will be arranged.

Scale: Choose a print scale for the output of the active window.

• Original: Choose this button to print at the original scale.

• Fit to Page: Choose this button to make the output fit the page. The scale will be adjusted accordingly.

• Custom: Choose this button to enter any other scale for the output. Either type in a custom scale, or 

choose a scale from the pop-up list below.

Text & Markers: Available only if you have chosen either Fit to Page or Custom as the Print Scale. Use this 

pop-up field to define the scale of text and markers in the output. These options also affect the output 

characteristics of other elements such as arrowheads, scale-independent dashed line types and fill patterns.
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• Resize to Printing Scale: Outputs text in proportion to the size of other elements. This method is good for 

enlargement of a Project for a presentation to be seen from a distance.

• Fix Size: Outputs text at its exact size in the current paper units (inches or millimeters). To keep text at 

exactly the same size even when the printed size of the project changes, choose this option. This is 

acceptable for enlargements but can produce unwanted effects with reductions. Text may overprint other 

elements as they shrink.

Print to File: Check this box to save the output as a print file on your computer.

Collate Copies: Check this box if you are printing multiple copies, and would like each copy to be output in 

sequential order.

Black and White: Check this box for black and white output. With this option, colored elements will be output 

as follows:

• Lines: All colored lines will be black; white lines remain white.

• Fill: Foreground will be black; background will be white. Fills using RGB colors will be gray 

• Zones: All will be displayed in grayscale cover fills.

• Images: All will be displayed in grayscale.

• Trace Reference: Will always be displayed in grayscale.

Dithering: Check this box to reduce the total number of colors present in the output while retaining visual 

fidelity. Dithering may be necessary due to a limited number of colors available on the display device. For 

example, if your fills turn out solid black, the Dithering effect may help.

Print Grid: Check this box if you would like the grid (construction or rotated) to be displayed on your printed 

output.

Print Reference: Check this box if the active window includes a Trace Reference, and if you would like to 

include its elements in the printed output.

Hairline: Check this box if you want to print all lines of the document using the thinnest line available on the 

printing device.

Header/Footer: Check this box if you wish to include a Header or Footer on the printed output. To define the 

Header/Footer content, click the Settings button at right.

For more information, see Header/Footer Settings.

Print Quality: Enter a dpi (dots per square inch) setting to define print quality.

Copies: Enter the number of copies you wish to print.

Arrangement: This section helps you arrange the drawing on the output sheet(s). A preview window helps 

you get the desired outcome. In the preview window, the black square(s) represent the page(s) to be printed. 

The blue rectangle represents the drawing size. The Preview indicates the position of a Header/Footer if you 

have checked that option.

• Sheets: Shows the number of sheets of the paper size chosen in Page Setup.

• Positioning: Click these arrow-buttons to move the printed content around on the output sheets as 

shown in the Preview.
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Print 3D Document

This dialog box appears if you issue the Print command while the 3D Window is active, using the Vectorial 3D 

Engine, or from the Print Options command when printing from the Navigator Publisher.

The controls are identical to those of the Print 2D Document dialog box, except certain 2D-related options 

(Text/Marker scale, grid, Trace Reference, etc.) are not available here.

See Print 2D Document.

If you issue the Print command while the 3D Window is active, using the OpenGL Engine, then the Print 

Picture dialog box comes up.

See Print Picture.
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Print Picture

This dialog box appears if you issue the Print command while the 3D Window is active, using the OpenGL 

Engine.

This printing function treats the entire contents of the 3D window as a single image. Consequently, the only 

available controls are:

Printer: This field displays the printer driver currently set up for your machine. To change the assigned printer, 

choose the Page Setup button at right.

Page Setup: Click this button to open the Page Setup dialog box, where you can choose a printer and set 

paper size and orientation.

Print Range: Choose either All to print all pages, or choose a page range for multi-page output.

Copies: Enter the number of copies of the image to print.

Print to File: Check this box to save the output as a print file on your computer.

Collate Copies: Check this box if you are printing multiple copies, and would like each copy to be output in 

sequential order.

Dithering: Check this box to reduce the total number of colors present in the output while retaining visual 

fidelity. Dithering may be necessary due to a limited number of colors available on the display device. For 

example, if your fills turn out solid black, the Dithering effect may help.

Use Printer Resolution: Check this box to use the print resolution set up in the printer device.

Print Quality: Enter a dpi (dots per square inch) setting to define print quality.
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Print Layout

This dialog box is opened with the File > Print command if Layout is active.

Printer: This field displays the printer driver currently set up for your machine. To change the assigned printer, 

choose the Page Setup button at right.

Page Setup: Click this button to open the Page Setup dialog box, where you can choose a printer and set 

paper size and orientation.

Source: Choose which layout(s) you wish to print.

• Selected Layouts in Navigator: Click this button to print only those layouts which are selected in the 

Navigator palette.

Note: This option is inactive if nothing is selected in the Navigator, or if several Layout Books (in the 

Navigator and Organizer) are open.

• Entire Layout: Print the entire currently active layout.

• Current Zoom: Print only the visible content of the active layout at its current zoom.

• Marquee Area: If you have placed a normal rectangular Marquee in the active layout, click this button to 

print only the marquee area. (The option is available for other marquee shapes, but the output area will 

always be rectangular.)

Print Range: Choose either All to print all pages, or choose a page range for multi-page output. See the 

Preview at the bottom right of this dialog box for how multi-page output will be arranged.

Size: Choose the layout output size.

• Fit to Page: Click this button to make the output fit the page. The size (in percentage) will be adjusted 

accordingly.

• Custom: Click this button to enter a size for the printed output, as a percentage of the paper size.

Margin Options: Use these controls to assign a margin to the printed output: either the printer margin or the 

layout margin.
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Note: This option is available only if you have chosen Selected Layouts in Navigator or Entire Layout 

in the Source field.

Print to File: Check this box to save the output as a print file on your computer.

Collate Copies: Check this box if you are printing multiple copies, and would like each copy to be output in 

sequential order.

Black and White: Check this box for black and white output. With this option, colored elements will be output 

as follows:

• Lines: All colored lines will be black; white lines remain white.

• Fill: Foreground will be black; background will be white. Fills using RGB colors will be gray.

• Zones: All will be displayed in grayscale cover fills.

• Images: All will be displayed in grayscale.

Dithering: Check this box to reduce the total number of colors present in the output while retaining visual 

fidelity. Dithering may be necessary due to a limited number of colors available on the display device. For 

example, if your fills turn out solid black, the Dithering effect may help.

Print Reference: Check this box to include the Trace Reference in the Layout’s printed output.

Hairline: Check this box if you want to print all lines of the document using the thinnest line available on the 

printing device.

Header/Footer: Check this box if you wish to include a Header or Footer on the printed output. To define the 

Header/Footer content, click the Settings button at right.

For more information, see Header/Footer Settings.

Print Quality: Enter a dpi (dots per square inch) setting to define print quality.

Copies: Enter the number of copies you wish to print.

Arrangement: This section helps you arrange the drawing on the output sheet(s). A preview window helps 

you get the desired outcome. In the preview window, the black square(s) represent the page(s) to be printed. 

The blue rectangle represents the drawing size. The Preview indicates the position of a Header/Footer if you 

have checked that option.

• Sheets: Shows the number of sheets of the paper size chosen in Page Setup.

• Positioning: Click these arrow-buttons to move the printed content around on the output sheets as 

shown in the Preview.
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Print Interactive Schedule

This dialog box is opened with the File > Print command if a Schedule window is active.

Printer: This field displays the printer driver currently set up for your machine. To change the assigned printer, 

choose the Page Setup button at right.

Page Setup: Click this button to open the Page Setup dialog box, where you can choose a printer and set 

paper size and orientation.

Print Range: Choose either All to print all pages, or choose a page range for multi-page output. 

Print to File: Check this box to save the output as a print file on your computer.

Collate Copies: Check this box if you are printing multiple copies, and would like each copy to be output in 

sequential order.

Black and White: Check this box for black and white output. With this option, colored elements will be output 

as follows:

• Lines: All colored lines will be black; white lines remain white.

• Fill: Foreground will be black; background will be white. Fills using RGB colors will be gray.

• Zones: All will be displayed in grayscale cover fills.

• Images: All will be displayed in grayscale.

Dithering: Check this box to reduce the total number of colors present in the output while retaining visual 

fidelity. Dithering may be necessary due to a limited number of colors available on the display device. For 

example, if your fills turn out solid black, the Dithering effect may help.

Print Quality: Enter a dpi (dots per square inch) setting to define print quality.

Copies: Enter the number of copies you wish to print.

Scale: Choose the layout output size.

• Scale to Paper Width

• Custom: Click this button to enter a scale for the printed output.

• Every Zone/Page on New Sheet: Check this box to split the output sheets by zones or pages.
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Header/Footer Settings

Use the Settings button in Print 2D Document, Print 3D or Print Layout dialog boxes to open this dialog 

box. (Check the “Header/Footer” box first, to enable the Settings button.)

Content: In this section, check the items you would like to include in your header or footer. The available 

options are:

• Project name, optionally With Path

• Name of Story/Section/Detail/Layout

• Layer Combination (not available for Layouts)

• Model View Option Combination (not available for Layouts)

• Printing Scale (for 2D model windows)/Resize Factor (for Layouts)

• User Name

• Date and Time

• Page number/number of pages

• Custom Text. If you check this box, enter custom text in the field to the right.

Text Properties: Use the controls in this section to set the properties of text items in the header/footer, 

including Font Type, coding and font height3+.

Location: Use this pop-up field to choose between either a header (top of page) or a footer (bottom of page), 

and to set its horizontal location (left, center or right of the page.)

Preview: This field shows you the contents of your header or footer.

A symbolic preview of your header or footer is also viewable in the Print dialog.
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When using a header or footer, please note: 

• If you are working on a shared Teamwork Project, the User Name field changes to Team Member name.

• A header or footer can only be a single line.

• You cannot change the order of the fields.
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Plot Setup

Note: The following descriptions are based on the Windows interface.

Use the two drop-down lists at the top of the dialog box to choose the plotter driver. The first lists 

manufacturers and the second the plotter driver for the given manufacturer. The contents of this list depends 

on the contents of the PlotWare folder.

• If the manufacturer of your plotter is listed but that particular model is missing, browse through the other 

models and select one with a similar paper size (e.g., E size). If there are several models with these 

criteria, experiment with all of them.

• If the manufacturer is not listed with any model, check the user manual of the plotter for compatibility and 

emulation modes. If the plotter accepts HPGL-2 and/or RTL data, there is a good chance of making it 

work. In this case, choose the HP DesignJet 755C model.

See also the list of supported models in the PlotWare folder/Read Me for Plotter Users.html file.

Paper: Use these controls to choose a paper size for your plotter. Invalid paper sizes are grayed in the menu 

and are not selectable.

If you choose Custom in the Paper area, the second pop-up list contains by default two items: Current paper 

and Modify list.

Choosing Modify List opens a dialog box in which you can define your own custom paper sizes.

Click OK when you have finished defining sizes manually. The new custom sizes will appear in the custom 

size pop-up. Custom paper sizes are saved with plotter settings.

Margins: Choose either “Normal” or “Extended” for the paper margins. The values in the X and Y fields below 

give you feedback on the result.

X/Y: These fields display the horizontal and vertical paper size. If you are using a “Custom” paper size, enter 

the desired paper size here.

Available Drawing Area: The X and Y values shown here indicate the size of the usable drawing area of the 

chosen paper.

Orientation: Use these controls to determine the location/direction of the output on the paper.
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Connection 

In the Connection area, specify the connection type you intend to use with your plotter.

To configure and use a plotter connected to one of your own computer’s ports or to a network plotter, use the 

Add Printer tool of the Windows Printers Control Panel.

When first using a plotter with ARCHICAD, you need to connect to it by clicking the Setup button in the 

Connection area. The Select Plotter dialog box appears.

You can choose one of the installed printer drivers from the pop-up menu. This driver will serve as a gateway 

to the plotter; ARCHICAD will use the specific plotter driver selected on top of the dialog box for actually 

plotting data.

Spool Folder 

Below the Connection options, you can define a folder for spooling files to be plotted either from your own 

computer or anywhere on the network in the background.
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Plot 2D Document

Plotter: The name of the active plotter (chosen in Plot Setup) is shown at the top of the dialog box.

Plot Setup: Click this button to access the Plot Setup dialog box.

For more information, see Plot Setup.

Destination: Choose a destination for the plotted output:

• Plotter: send the output to the designated plotter

• File: send the output to a plot (data) file

• Spool Folder: send the output into the spool folder specified in Plot Setup.

Scale: Choose a plot scale for the output of the active window.

• Original: Choose this button to plot at the original scale.

• Fit to Page: Choose this button to make the output fit the page. The scale will be adjusted accordingly.

• Custom: Choose this button to enter any other scale for the output. Either type in a custom scale, or 

choose a scale from the pop-up below.

Note: You cannot enter a custom value that will make the plotted image larger than the usable page size.

Text & Markers: Available only if you have chosen either Fit to Page or Custom as the Scale. Use this pop-up 

to define the scale of text and markers in the output. These options also affect the output characteristics of 

other elements such as arrowheads, scale-independent dashed line types and fill patterns.

• Resize to Plotting Scale: Outputs text in proportion to the size of other elements. This method is good for 

enlargement of a Project for a presentation to be seen from a distance.

• Fix Size: Outputs text at its exact size in the current paper units (inches or millimeters). To keep text at 

exactly the same size even when the printed size of the project changes, choose this option. This is 

acceptable for enlargements but can produce unwanted effects with reductions. Text may overprint other 

elements as they shrink.

Plot Grid: Check this box if you wish the output pages to display the ARCHICAD grid.

Hairline: Check this box if you want to plot all lines of the document using the thinnest line available on the 

plotting device.

Plot with: Choose a color scheme for the plotted output (options may vary depending on the type of plotter 

used):

• Color

• Grayscale

• Black and White

Copies: Enter the number of copies to plot.

Arrangement: Use the preview window to view the arrangement of output on the plotted page.
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Plot Layout

This dialog box is opened with the File > Plot command if Layout is active.

Plotter: The name of the active plotter (chosen in Plot Setup) is shown at the top of the dialog box.

Plot Setup: Click this button to access the Plot Setup dialog box.

For more information, see Plot Setup.

Destination: Choose a destination for the plotted output:

• Plotter: send the output to the designated plotter

• File: send the output to a plot (data) file

• Spool Folder: send the output into the spool folder specified in Plot Setup.

Source

• Selected Layouts in Navigator: Click this button to plot only those layouts which are selected in the 

Navigator palette.

Note: This option is inactive if nothing is selected in the Navigator, or if several Layout Books (in the 

Navigator and Organizer) are open on screen, with several sets of selected Layouts.

• Active Layout: Plot the currently active layout.

Resize

• Fit to Page: Click this button to make the output fit the page. The size (in percentage) will be adjusted 

accordingly.

• Custom: Click this button to enter a size for the plotted output, as a percentage of the drawing’s original 

size.

Margin Options: Use these controls to assign a margin to the plotted output: either the plotter margin or the 

layout margin.

Hairline: Check this box if you want to plot all lines of the document using the thinnest line available on the 

plotting device.

Plot with: Choose a color scheme for the plotted output (options may vary depending on the type of plotter 

used):

• Color

• Grayscale

• Black and White

Copies: Enter the number of copies to plot.

Arrangement: Use the preview window to view the arrangement of output on the plotted page.

For more information on plotting, see Plot.
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PhotoRendering Settings

For general information, see PhotoRendering.

Topics in this section:

Detailed Cineware Settings

Basic Rendering Engine

Sketch Rendering Engine
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Basic Rendering Engine

Choose Basic Rendering Engine from the Engine drop-down menu in the PhotoRendering Settings dialog box 

(Document > Creative Imaging > PhotoRendering Settings). 

Note: The speed of PhotoRendering is defined most of all by image size, while model complexity affects 

speed if shadows are used. The PhotoRendering effects define the final quality or character of your 

rendering.

Basic Rendering Engine Effects Panel

Use these controls to select the PhotoRendering effects you want to use:

Method

The Method setting determines how closely the program should adhere to its ultimate imaging capacity.

• Best: The program calculates the light attributes of each pixel. As the choices decrease in quality, 

ARCHICAD calculates individual values for every second or third pixel only. The quality increase will affect 

curved surfaces more than others.

• Using multiple light sources or picture mapping may require the Final or Best settings.

• Flat Shading: Results in each shape being roughly approximated by flat surfaces only. Special effects like 

Transparency, Fog, Emission, Smooth Surfaces, Highlights and Light Decay are unavailable. The Flat 

Shading option is faster than all the other options in this dialog box, but slower than when the 3D Style 

uses Shaded mode.

Effects

Effects let you enable a variety of light and surface effects, some of which are initially set in the Options > 

Element Attributes > Surfaces dialog box.

For more information, see Surfaces Dialog Box.

• Highlights: Check this to use specular reflections as highlights

Note: If Highlights is unchecked, or the Flat Shading method is used, specular reflections are ignored in 

the rendering.

• Emission: Check this if you have chosen, or created, light emitting Surfaces and want this quality to be 

displayed in the renderings.

•  Fog: Check this box to apply a fog effect to the rendered image. Choose a color and intensity (low, 

middle, high) for the fog effect.

• Transparency: Transparent elements (such as glass) will be rendered as transparent. (If you leave this 

box unchecked, such elements will be shown as opaque.)

• Smooth Surfaces: Set the degree of smoothing, with up to one pixel accuracy. Curved surfaces, which 

are normally approximated by flat planes, are represented by more lifelike surfaces when this option is on.

• Lamp Falloff: If this is unchecked, the angle falloff and distance falloff values in the GDL Scripts of Lamps 

will be considered zero. This results in a sharp border between illuminated and dark areas. If it is checked, 

the values originally given will be used, resulting in a smooth transition between illuminated and dark 

areas.

Note: Lamps must be enabled at the Light Sources checkboxes for falloff to operate.
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• Textures: Check this box to display bitmapped pictures on the corresponding surfaces.

It also controls whether the textures linked to surfaces in the Surfaces dialog box are displayed in 

PhotoRenderings as described.

For more information, see Surfaces Dialog Box.

Antialiasing

Controls the contour quality of your renderings. Jaggedness of the contour is gradually eliminated as you 

move from Off to Best.

You may want to use the Best option only for final documents, since processing time increases along with 

quality.

Light Sources

Select which Light Sources (Sun, Lamps or both) you want to use to illuminate the model during the 

PhotoRendering process.

The Lamps checkbox can only be effective if Lamp type library parts have been placed on the plan. They must 

be switched on in their Settings dialog box.

Shadow Casting

Define which of the available light sources you want to cast shadows in the PhotoRendered picture.

• Check the High Accuracy box if you notice incorrect results on your PhotoRendered picture, especially 

missing shadows of relatively small elements. This may occur if you zoom in on a small detail of an 

otherwise large project in the 3D Window and make a photorendering of that detail.

• If the Use transparency checkbox is checked, ARCHICAD will create different shadows for surfaces with 

different transparency. The color of the transparent surface will also affect the color of the shadow in the 

final photorendering. This is also valid for surfaces with Alpha channel, where the Alpha channel is used 

to define the transparency of the surface.

Texture Antialiasing

Use the slider to set the desired image quality. As this procedure is very time consuming, use it only if you 

require a superior image quality for printing.

Basic Rendering Engine Background Panel

See Cineware Basic Settings: Background Panel.

Basic Rendering Engine Brightness Panel

This panel of the dialog box gives you choices regarding exposure.

Use the dimmer switch to set the desired brightness from dark to bright.

You have three options for correcting possible Overexposures. (Overexposure occurs when the computational 

method results in a brighter color requirement than the brightest white on the monitor.)

• Darken All Surfaces: ARCHICAD can make all surfaces darker than their computed color and make the 

brightest color white. This keeps the contrast between bright and dark parts of the image, but details in 

darker areas may be lost.

• Darken Overexposed Surfaces: You can choose to darken only the overexposed surfaces. This way, 

dark areas will not be extremely dark, but the contrast between shades in bright areas will be smaller.
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• Paint Overexposed Surfaces with: Select a color for these surfaces to show their place in the picture. 

This is an editing tool that helps you fine-tune the lighting of your renderings by changing elements of the 

model (e.g., relocating or dimming individual lamps) rather than applying one of the overall corrections 

described above.
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Sketch Rendering Engine

Choose Sketch from the Engine drop-down menu in the PhotoRendering Settings dialog box (Document > 

Creative Imaging > PhotoRendering Settings). 

The Sketch engine produces non-photorealistic renderings that replicate sketched lines - best suited for draft 

views in the early project stages, using different free-hand effects. These effects include felt tip, pencil, 

graphite and marker. Files used for sketch rendering are placed in the Add-Ons folder inside the ARCHICAD 

folder. In the SketchTextures subfolder, you can find the predefined style file named SketchPreset.txt as well 

as the line texture files, each placed in a separate subfolder of SketchTextures.

Below, the same building rendered with two different Sketch scenes.

Sketch Basic Settings Panel

Scene: Click the drop-down to access sketch scenes.

The Sketch Rendering Engine provides a number of factory scenes with preset parameter values. If you 

override these factory settings, the scene will be renamed Custom.
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Line Styles: Each linetype is represented by a dedicated folder with a set of bitmap images. These sets can 

be extended with similar scans of scripts using any graphic device. To get the best sketch effect, it is 

recommended to scan a large variety of line lengths, as the program will choose randomly among these styles 

when reproducing lines in the rendering.

Line color:

• Custom: Any preferred color can be chosen for monochrome images. The presets suggest traditional 

black, blue or tan colors.

• Current element settings: In this case, line color depends on the pen colors of individual model 

elements. Color images can be generated this way; however, it requires the careful adjustment of pen 

colors.

• As in Line Style: For the most natural effect, the color of the lines can be determined by the scans’ 

original colors (graphite pencils, black art pen ink, sepia and peine gris aquarelles, and carmine.)

• If you check the Show 3D Vectorial Hatching box, the hatch lines (for example brick or tile contours) will 

be drawn in the rendered image. The properties of the hatch lines can be controlled by the settings of the 

Hatch Line Settings panel below.

• With Show Vectorial Sun Shadows active, the rendered image will include shaded areas representing 

sun shadow. The shade lines properties can be set on the Shadow Line Settings panel.

Sketch Enhancements Panel

Antialiasing: Smooths the lines by picking longer lines from the scans than necessary. In case of textured 

lines (e.g. brush, chalk), it is recommended to keep this value low (2 or less), as high values can slow down 

rendering.

Air perspective: Similarly to the Fog effect, fades lines further to the viewpoint. Although this effect is not 

normally done with manual sketching, a light air perspective to a rough wax sketch can be an attractive 

enhancement, and can be made to look especially natural with brush scans.

Paper roughness can simulate the effects of bumps on scans of real “rough paper”. Normally, bumps are 

generated randomly by the rendering engine; however, for best results, it is advisable to use a background 

image with predefined alpha channel for the bumps (you can find some background images in the ARCHICAD 

Library/Background Images/Alpha Paper Textures folder). Check the Use background alpha channel box if 

you use such a background image.

The sketch engine can detect these bumps and fade or erase the sketch lines at this area depending on the 

settings of the Paper Roughness slider. This setting has no effect if no background image has been scanned 

with the alpha channel.

Sketch Line Settings Panel

Thickness: Use a low value to replicate thinner devices (pencil, fine marker). Large values are appropriate for 

displaying the textures of brush or wax. However, you can experiment with different line settings and try 

getting interesting results which can be varied for a given line style. For best results, use higher values for 

Sketch Lines than for Hatch Lines and Shadow Lines.

Line distortion: Try various values with the chosen line style to achieve the desired effect. Generally, to 

replicate a pencil stretch you will use a lesser distortion than for brush, but you can experiment.

When Line Overstretch is set high, the lines will be longer than their counterparts in the ARCHICAD 3D 

window, as if you had been drawing lines that do not connect properly and will cross each other. When the 

control is set low (below zero), the lines will stop short of reaching one another.
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Sketch Hatch Line Settings Panel

The controls on this panel are to set the properties of the hatch lines of the rendered image. If the Show 3D 

Vectorial Hatching checkbox on the Basic Settings panel is not active, no hatch lines will be drawn and the 

choices you make here will have no effect whatsoever.

The Thickness, Line overstretch and Line distortion controls have the same effects as on the Sketch Line 

Settings panel.

When the Clarify remote area control is set high, the hatch lines in the background will be paler and thinner. 

This is useful and sometimes even necessary when a hatched surface is viewed from a reduced angle. 

Without clarifying the remote area the hatch lines would be so dense that they would form a continuous dark 

area. These settings only take effect if you check the Apply box.

Sketch Shadow Line Settings Panel

The controls on this panel set the properties of the shadow shading lines of the rendered image. If the Show 

Vectorial Sun Shadows checkbox on the Basic Settings panel is not active, no shadow lines will be shown 

and the choices you make here will have no effect whatsoever.

• The Thickness, Line overstretch and Line distortion controls have the same effects as they do in the 

Sketch Line Settings panel.

• Darkness controls the opacity of the shadows. When it is set low, the shade is more transparent.

• Spacing controls the distance between the shadow lines. A high spacing value results in lighter shadows.

Note: The effects of Thickness, Darkness and Spacing may overlap. For example, if you set a high 

Thickness value when Spacing not very high, you will obtain a darker shadow, as if you had increased the 

Darkness value.

Sketch Background Panel

For a detailed description, see Cineware Basic Settings: Background Panel.
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XREF Management Dialog Box

To access this dialog box, go to File > External Content > XREF Manager.

Most XREF-related functions can be completed in this dialog box.

For an overview of this topic, see Working with XREFs.

View Mode Buttons

The two buttons in the upper-left corner of the dialog box control how the list of attached XREF files is 

displayed.

• The left button will display all XREFs in the order they were attached.

• The right view mode button will display attached XREFs in a hierarchical tree structure. Since DWG files 

used as external references can also contain additional external references, nesting can occur. This 

nesting can be quite complex, reaching down several levels.

The hierarchical view mode lets you see which files refer to other external files, indicating what should load 

into the project when attaching an external reference file. If an attached file refers to other files, a + sign will 

appear on its left. Clicking the + sign reveals the names of the associated files.

XREF List: This list contains the information about the attached files. In the header, click the splitter bars to 

edit column width as needed. If you are in list mode you will see data about each file, including: 

• Reference name: The name of the reference, usually the same as the name of the attached file.

• Status: The exact status of the file after each operation that affects it, such as Loaded, Detached, 

Reloaded, Unloaded or Bound.

• Size: The size of the referenced file.

• Type: The type of external referencing, either Attach or Overlay.

• Date: Last date the file was modified.

• Insts (Instances): The number of instances of a certain external reference file attached to the Project. As 

with library objects, you can attach an external reference several times to a Project file and in various 

locations (layers, different floors etc.).

• Translator: For each placed XREF, this column shows the translator used to place it, which will also be 

used to update it. If an instance has been placed multiple times with different translators, these instances 

are listed separately, by translator.
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The file path below shows the location of the selected XREF file. 

Attach

Click this button to display the Attach XREF dialog box.

For more information, see Attach XREF Options.

For information on naming options for Attached XREFs, see: Place Drawings into: in the section on DXF-

DWG Translator Settings. 

Detach

Click this button to detach the XREF from the drawing: closing the dialog box will remove it from the Project 

file. If you want to use it again you will have to attach it again. The Status column will reflect this “detached” 

state.

When the XREF is detached, a dialog lets you choose between retaining or removing the detached XREF’s 

attributes, including layers, linetypes and fills.

Reload

When the DWG or DXF file used as an external reference has been modified, and you want to have the latest 

changes appear in your ARCHICAD Project file, you can do so by clicking the Reload button. The program 

will load the whole file into ARCHICAD again and display the latest state. Also, if you unloaded an external 

reference from the Project file, you can load it again with the Reload button. The status column of the dialog 

box will reflect this state.

Note: The reload process does not display an options dialog box to specify the input parameters. They 

are present in the database: the same data will be used as specified earlier with the Attach command.

Unload

Click this button to keep the selected external reference file attached to the project file, while unloading it from 

memory. The file’s contents will not appear on the Floor Plan. As opposed to detaching, which removes the 

file from the project and the XREF Management file list, the Unload command keeps it attached. Clicking the 

Reload button will make it reappear. These changes are reflected in the Status column of the dialog box.

Note: After you unload an XREF, a text will appear at the insertion point of the XREF notifying you of this 

fact. For example, if you unload the XREF file “WALLS,” the message ‘Unloaded XREF “WALLS” will 

appear on the Floor Plan in place of the XREF.

Bind

Clicking the Bind button will merge the content of the external reference to the Project and delete the external 

reference to the file from the list.

Note: Binding will make all instances of the reference file part of the Project. It is not possible to bind only 

one instance of the XREF file.

When you bind an XREF, the layer names of the XREF will reflect the change, taking on following format:

‘XREF_NAME $ NUMBER $ LAYER_NAME’.

For example, the PEN_5 layer of the XREF file with the name “WALLS” was converted to layer 

WALLS|PEN_5 while it was attached. When it is bound to the project file, its name is automatically changed to 

WALLS$36$PEN_5, with the number “36” being a number in the list of layers.
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Browse

Click this button to open a directory dialog box where you can change the file that the selected XREF points to 

(XREF Found at). After you select another file and return to the XREF Management dialog box, you must 

click the Reload button for the change to take effect. After exiting the dialog box with the OK button, 

ARCHICAD reloads the new file, which will then be associated with the given XREF name.

This feature is particularly useful when you have an XREF in your project whose original file was changed and 

saved under a new name.

For example, consider a Floor Plan that is attached to an interior design project with the name “Floor 

Plan0728.DWG.” Later, as the Floor Plan changes, it is saved under the name “Floor Plan 0801.DWG.” 

Clicking the Browse button and selecting this new file will associate the link with this latest version of the 

Floor Plan, enabling the Interior Designer to quickly update it and use it for further work.

Show Log

Click this button to expand the XREF Management dialog box downward to show a list of all steps performed 

in the current session of the XREF Management dialog box.

This log allows you to see what functions the program will execute once you click the OK button.

Click Hide Log to hide the log from view.

Translator Settings

Click this button to view the DXF-DWG Translator settings of any selected XREF from the list. The appearing 

dialog box is view-only.

For information on naming options for Attached XREFs, see: Place Drawings into: in the section on DXF-

DWG Translator Settings. 
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Attach XREF Options

This dialog box opens when:

• you use File > External Content > Attach XREF

• you click “Attach” from the XREF Management dialog box. (File > External Content > XREF manager.)

XREF Name: Specify the name of the file to be attached as an external reference.

• Use the Browse button to select from a file selection dialog box.

• Alternatively, select from the pop-up list of already attached files if you want to place another instance of 

the file into the Project.

Path: Shows the exact path to the selected file.

Reference Type: Choose a radio button to set how nested XREFs will be handled.

Note: Nesting occurs when you load an external reference to a file that has external references loaded to 

other files.

Attachment: All levels of nesting can be displayed in the Project file.

Overlay: Nested XREFs from the referenced file will not be visible in the Project.

The following table shows what happens when you attach/overlay DWG files that contain attached/overlaid 

XREFs.

Examples:

1. A DWG file named BASE.DWG that has an attached XREF named COMMON.DWG is attached to the 

ARCHICAD Project. Both files will be visible on the Floor Plan.

2. A DWG file named BASE.DWG that has an overlaid XREF named COMMON.DWG is attached to the 

ARCHICAD Project. BASE.DWG will be visible on the Floor Plan but COMMON.DWG will not be visible.

3. A DWG file named BASE.DWG that has an attached XREF named COMMON.DWG is overlaid to the 

ARCHICAD Project. Both files will be visible on the Floor Plan.

4. A DWG file named BASE.DWG that has an overlaid XREF named COMMON.DWG is overlaid to the 

ARCHICAD Project. BASE.DWG will be visible on the Floor Plan but COMMON.DWG will not be visible.

Placement Parameters: Use these controls define where and how you want the XREF to be placed on the 

ARCHICAD floor plan.
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• Insertion point: In the X and Y field, you can enter the exact coordinates of the location of the lower left 

corner of the enclosing rectangle or of the Drawing origin. Alternatively, you can check the Specify On-

Screen box to enter these coordinates by clicking on the Floor Plan.

• Scale: Either specify a scale factor in both X and Y directions, or check the Specify On-Screen box to 

define scale on the screen.

Note: If you specify scale factors, the XREF’s enclosing box will be scaled to the appropriate size. If not, 

you will be able to stretch the enclosing rectangle just as if you were stretching an ARCHICAD object. It is 

possible to input or specify negative or positive values for scale factors. By specifying negative values you 

can achieve mirroring effects.

• Rotation: You can define an angle by which the whole placed XREF will be rotated around its insertion 

point, or check the Specify On-Screen box to define rotation manually, on the screen.

Note: If you specify a rotation angle, the XREF is rotated and then drawn. If not, you can rotate the 

enclosing rectangle until you input the value with a mouse click or coordinate input.

Anchor Point: Use these controls to define by which point of the XREF to place the drawing.

• Drawing’s own origin: the Global Origin (0;0 coordinate) of the attached XREF will be located at the 

coordinates specified by you on screen or in this Dialog.

• Drawing’s own anchor point: the attached XREF drawing’s own anchor point (if any) will be located at 

the coordinates specified.

• Bounding box node: ARCHICAD calculates the size of the bounding box of the attached XREF. You 

choose any of the 9 significant points of the bounding box, and that position of the XREF will be located at 

the coordinates specified fro placement.

Place on Story: Use this drop-down list to choose the story onto which to place the XREF. Before the actual 

placement, ARCHICAD will switch to that story.

Translator: This field displays the currently selected DXF/DWG Translator to be used during the conversion 

of the attached AutoCAD drawing. You may select any of the currently available Translators from the drop-

down list. Clicking the Settings button will bring up the Translator Dialog where you can make modifications 

to the Translator Settings before attaching the XREF file.

For more information, see DXF/DWG Translation Setup.

Description: This field shows a short explanation and note about the currently selected Translator so you can 

decide if it fits your needs.

Attach: Click this button to execute the attach operation.

Note: When you attach an external reference file to an ARCHICAD Project, a layer will be created for it. 

The resulting layer names will have the following format:

‘XREF_NAME | LAYER_NAME’.

For example, the PEN_56 layer of a DWG file that was attached to the project with the XREF name 

3D_STUFF will become the layer 3D_STUFF|PEN_56.
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DXF/DWG Translation Setup

This dialog lists predefined and customized DXF-DWG translators. Use them to define how elements in 

ARCHICAD will be interpreted when exported as DXF/DWG files, and vice versa: how the elements in DXF/

DWG files will be interpreted when imported into ARCHICAD.

DXF-DWG Translators are stored in the Defaults folder of the ARCHICAD program. Thus, translators added 

or removed in this list will be available for all projects created with the same main ARCHICAD version.

Note for Teamwork users: Using common Translators ensures that all users have access to the same 

conversion options. It is therefore recommended that the CAD Manager (or a person filling the same type 

of role in your office) manage the set of Translators and place them on a server. To use the translators, 

each user must first add them to their list by using Browse... in the DXF/DWG Translator Setup dialog.

This dialog box is accessible:

• When saving or opening DXF/DWG files: click the Settings button in the Save, Open or Merge dialogs, or 

the Attach XREF dialog box

• from File > Interoperability >DXF-DWG > DXF-DWG Translation Setup

• when opening a DXF/DWG file through the File > Libraries and Objects > Open Objects command,
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• from File > Libraries and Objects > Import Blocks from DXF/DWG 

Managing Translator Files

Translators are listed with the following data fields: Name, Project and Partner.

To edit these fields, double-click a list item to open the Rename Translator dialog, or click the Rename button 

at right.

Delete (available if the translator is not locked): 

Click to remove unneeded translators. The appearing Info dialog gives you a choice:

• Delete the translator’s XML. This option deletes all those translator settings permanently.

• Just removing the translator from the list in the dialog box. (To add it back to the list, click Browse.)

Create New: Using default settings, create a new Translator XML file and add this to the list. This XML file can 

be saved to any location, such as an office file server.

Duplicate: Duplicate the selected Translator. A new XML will be created in the same location as the selected 

Translator

Remove (available if the translator is locked or unavailable/missing): This action will remove the translator 

from the list in the dialog box, but will not delete the translator XML file from your system. (To add it back to the 

list, click Browse.)

Browse: Click to access an existing Translator file.

Location: This field displays the path of the selected translator file and cannot be edited.

Note: If an XML file is renamed, moved or deleted, then it will be shown in italics in the Translator list and 

indicated as unavailable.

DXF/DWG Description Panel

This is a multi-line edit box containing information about the selected translator. You can edit its contents with 

a single click.

DXF/DWG Settings Panel

The conversion rules for data exchange fall into six main groups:

• Drawing Unit

• Open Options

• Save Options

• Attributes

• Miscellaneous

• Custom functions
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Drawing Unit (DXF/DWG Translation Setup)

Open Options (DXF/DWG Translation Setup)

Save Options (DXF/DWG Translation Setup)

Attributes (DXF/DWG Translation Setup)

Layers (DXF/DWG Translation Setup)

Pens & Colors (DXF/DWG Translation Setup)

Line Types (DXF/DWG Translation Setup)

Fills (DXF/DWG Translation Setup)

Font-Style Conversion (DXF/DWG Translation Setup)

Miscellaneous (DXF/DWG Translation Setup)

Custom Functions (DXF/DWG Translation Setup)
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Drawing Unit (DXF/DWG Translation Setup)

This is an option of the DXF/DWG Translation Setup dialog box

See DXF/DWG Translation Setup.

Value of 1 DXF/DWG Drawing Unit in ARCHICAD: As you export or import something in DXF or DWG, you 

must set the size and distance conversion factor to ensure that ARCHICAD interprets the data correctly. 

• Prefer Drawing Unit definition in DXF/DWG file. This checkbox means that ARCHICAD will use the 

Drawing Unit definition as set in the original imported DXF-DWG file.

• If no such original definition is available, or if you want to redefine it, use the pop-up list to choose either a 

standard drawing unit (1 meter, 1 millimeter, 1 inch, 1 foot); or a custom unit (any number of millimeters or 

inches).

When opening a DXF/DWG file, you must define a scale at which you would like to see the correct ratios of 

elements drawn in AutoCAD. This particularly applies to arrowheads, symbol lines and symbol fills.

Set Scale Factor for converting texts and arrowheads: Choose one of the three options:

• Set scale factor separately with each conversion: In this case, a dialog box appears after clicking the 

Open button, letting you set the desired scale factor.

You may click the arrow before the text ‘Show Example’ to display an explanation of the effect of the scale 

factor:

This scale factor has an effect on Texts and Arrowheads of the imported AutoCAD drawing. Click OK to 

accept the scale factor.

• Use constant factor for all conversions: Set a scale factor for ARCHICAD to use for these conversions. 

In this case the Scale Factor Dialog will not come up.

• Always use the scale set in the currently active ARCHICAD window: The scale of the ARCHICAD 

Floor Plan will be used for conversion. This is the same method which worked in ARCHICAD versions up 

to 8.1.

Note: If you used the Set scale factor separately with each conversion option, the Scale Factor Dialog 

will also come up in case an AutoCAD drawing is dragged and dropped onto the ARCHICAD Window 

background (drag-and-drop Open), and in case an AutoCAD drawing is merged into the ARCHICAD Floor 

Plan, a Section/Elevation/IE Window or a Detail/Worksheet (drag-and-drop merge).
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Open Options (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

The options vary depending on the performed operation. They include:

• AutoCAD Block translation with the additional option of including 3D Data in the resulting Library Parts

• The conversion of Dimensions

• Conversion format of pictures contained in AutoCAD drawings

• 3D Conversion when AutoCAD drawing is opened as Library Part

• Filter, by layer, the elements to be converted into ARCHICAD.

For additional open options, see also Custom Functions (DXF/DWG Translation Setup).

Opening as Floor Plan:

Translate AutoCAD Blocks as: Choose one of the following options:

• 2D Elements

• Grouped 2D Elements

• Library Parts

When you choose 2D Elements or Grouped 2D Elements, all the references of all the blocks get exploded 

into simple floor plan elements.

Translate Dimensions As:

• Lines and Text: you don‘t create a dimension out of the dimension entity; rather you use the drawing 

details stored in the file to get the same look (arrowheads, colors, text positions) as in AutoCAD.

• Single Dimension Units: every dimension unit in the AutoCAD file gets converted into an ARCHICAD 

dimension unit.

Note: dimensions may have different visual features in ARCHICAD and AutoCAD. Not all of these visual 

features can be reproduced during conversion. The most significant difference is with arrowheads: 

ARCHICAD has a fixed set of them, whereas in AutoCAD you can design your own set.

• Dimension Chains: In AutoCAD only separate 2-point dimensions are available (even though there is a 

method of creating sets of dimensions that look like dimension chains.)
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Associative Dimensions where applicable: In former versions of AutoCAD, dimensions were not 

associative the way we mean it in ARCHICAD: that is, glued to hotspots of other elements. If you check this 

option the add-on will look for already imported elements to which to associate the processed dimension. It 

may be time-consuming, therefore the default behavior is to create hotspots on the element and associate the 

linear dimension to the hotspots.

Note 1: When radial dimensions are concerned, they always need something circular to be associated to.

Note 2: The most recent version of AutoCAD contains associative dimensions for certain elements, which 

cannot be converted.

Note 3: ADT has also introduced a kind of associative dimension, but it can be associated only to ADT 

objects.

Import Viewports as Embedded Drawings: Check this box to ensure that AutoCAD Viewpoints are 

imported as embedded Drawings after opening a DXF/DWG file in ARCHICAD. If you uncheck the box, 

Viewports will be converted to ARCHICAD views instead.

Convert Pictures to Format: Choose a file format to use in converting pictures: either retain the picture’s 

original format, or choose another image format from the pop-up as a uniform format for all pictures.

Open as Library Parts

3D Data in created Library Parts: Choose one of the following options:

• Binary 3D: store the 3D information in binary format,

• GDL Script: store the 3D information in GDL script.

If you process 3D data, the Binary 3D form is recommended: it is much quicker if the script doesn‘t have to be 

recompiled every time you generate the 3D view.

Note: The Open Object command is the only way to get all the 3D data stored in a DXF/DWG file!

Enable partial open

Check this box and save it as part of the Translator to filter, by layer, the elements of the DWG file to be 

opened/merged or XREF’d in ARCHICAD.

In this case, when you use File > Open or Merge on a DWG/DXF file, or when you Attach an XREF file, the 

DWG/DXF Partial Open dialog box appears, listing the source file’s layer set and the layers’ status.

Uncheck the layers which you do not wish to include in the ARCHICAD project.

This function lets you restrict the DWG conversion to just those elements that you really need, thereby 

increasing conversion speed and reducing the size of the resulting ARCHICAD project. When attaching 
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XREFs, those layers which you do not check here will not be added to the Layer attributes of your ARCHICAD 

project.

See also Attributes of XREF Files.

Convert 3D Solids, Regions and Bodies into GDL objects

Check this box to convert the listed items into GDL objects upon opening the file in ARCHICAD.
ARCHICAD 24 Reference Guide 3424



Dialog Boxes User Interface Reference
Save Options (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

For additional save options, see also Custom Functions (DXF/DWG Translation Setup).

File Format

Define which version of AutoCAD you are saving your files to. The Smart Merge feature is available in all.

Convert Images to

Choose a format from the drop-down list for images saved to AutoCAD.

As a default, Image’s original format is selected; in this case, no conversion takes place.

Force output in AutoCAD picture formats: If this box is checked, the list of available image formats will 

show only those which the selected version of AutoCAD can read. The rest of the choices are disabled.

Note: If you have also selected Image’s original format, the picture will retain its original format only if it 

is recognized by AutoCAD; unrecognized file formats will be converted as TIFF.

Template File

Some settings in AutoCAD cannot be matched to anything in ARCHICAD, and vice-versa. For example, in 

ARCHICAD, layers do not have color and line type; in AutoCAD they do. The solution for the conversion of 

these settings is to choose a Template. The Template File is a DXF/DWG file where these conversions and 

changes are already done. If you choose a Template File with DXF/DWG export, elements going to the layer 

defined in the template file will have their layer’s color and line type set to the same values as in the Template 

file. This happens without the user even opening the resulting DXF/DWG file. The template file supplies the 

layer names defined in the file, so you don’t have to type them in, making it easier to create the layer 

conversion table.

Next to an edit field, the Browse button opens a file dialog from which to select a Template File.

Note: These Template Files may come from consultants. After you saved a DXF/DWG file for a 

consultant, he opens it and makes changes to it (e.g. to layers, pens etc.). Then he saves this file and 
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sends it back to you. You will now have a Template File which you can use the next time you save DXF/

DWG data for this consultant.

Browse for and select the template file, whose path is now displayed. From the pop-up icon at the left, choose 

to store this file location information either as an Absolute path or Relative path.

To delete the Template file, click the “Clear Template File” button to the right of the file path field.

Save Layout Into

Controls how and into what Space of a DXF/DWG file the content of the Layout is saved.

Paper Space with Drawings as Blocks: All elements drawn on the Layout, plus all drawing data will be 

saved into the Paper Space of the resulting AutoCAD drawing. All Drawings placed on the Layout will be 

converted into AutoCAD Blocks, and these will be clipped so only those portions of the Blocks will be visible in 

the AutoCAD Paper Space that were visible on the Layout in ARCHICAD. The purpose is perfect reproduction 

of what you saw on the Layout. With this option the Model Space of the resulting AutoCAD drawing will be 

completely empty.

Note: If you have placed ARCHICAD Floor Plans onto Layouts as Drawings, then the Library Parts, 

Zones and Doors/Windows from those Floor Plans can be converted into intelligent AutoCAD Blocks only 

if those Drawings have the status of “OK” in the Drawing Manager (in other words, if they are up to date).

See Managing and Updating Placed Drawings.

Model Space: All elements drawn on the Layout, plus all drawing data will be saved into the Model Space of 

the resulting AutoCAD drawing. All Drawings placed on the Layout will be converted into AutoCAD Blocks, 

and these will be clipped so only those portions of the Blocks will be visible in the AutoCAD Model Space that 

were visible on the Layout in ARCHICAD. The purpose is perfect reproduction of what you saw on the Layout. 

With this option a default Paper Space will be created in the resulting AutoCAD drawing, which will be empty.

- For Drawings whose source is internal to the project and whose Drawing status is up-to-date: their 

elements will be placed on identical layers in AutoCAD, subject to any layer-conversion preference 

in the DXF/DWG Translation Setup.

- For Drawings whose source is internal to the project, but whose Drawing status is not up-to-date 

(i.e. it is a manual-update drawing detached from the model): their elements will be placed on 

separate AutoCAD layers whose name is combined out of the Drawing’s name and ID.

- If the Drawings originated in external projects: their elements will be placed on a default layer in 

AutoCAD named “Drawings and Figures”.

• Paper Space with Cropped View’s content: Drawing elements manually drawn on the Layout will be 

saved into the Paper Space of the resulting AutoCAD drawing. The image of the Layout will be 

reconstructed in the Paper Space of the AutoCAD drawing. Drawings placed on the Layout will first 

become cropped by their placement polygon on the Layout (meaning only those elements and part of 

elements inside of the cropped area will be exported), and then saved in DXF/DWG format.

• Paper Space with Full View’s content: Drawing elements drawn on the Layout will be saved into the 

Paper Space of the resulting AutoCAD drawing. The image of the Layout will be reconstructed in the 

Paper Space of the AutoCAD drawing. Drawings placed on the Layout will be saved in their entirety in 

DXF/DWG format.

Place Drawings into:

If you have chosen to save Layouts to Paper Space, the Place Drawings into field is enabled, where you can 

choose how placed Drawings should be saved:
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• Single DXF/DWG file: All drawings (either cropped or in Full – depending on the value of the Save Layout 

into field) are saved into a single DXF/DWG file. They will be placed side by side in the Model Space of the 

file, and View Ports will be created in the Paper Space of this resulting AutoCAD drawing so in Paper 

Space they will look like the Layout in ARCHICAD.

• Linked XREF drawings: A DXF/DWG file will be saved. In this file there will be placement references to 

XREF files. All files will be saved in other separate DXF/DWG files and these files will be placed in the first 

DXF/DWG file as XREFs. They will be placed side by side in the Model Space of the first file, and View 

Ports will be created in the Paper Space of this resulting AutoCAD drawing, so in Paper Space they will 

look like the Layout in ARCHICAD.

To the right, click Settings to open the Xref Settings dialog box.

Xref Drawings: The settings on this panel affect the name/location of Xref drawings created in ARCHICAD.

Define the folder path, folder location and drawing names of saved Xref drawings. Note that the folder path 

field can use Autotext.

Attached Xrefs: The settings on this panel affect the name/location of external Xrefs attached to the project.

Click OK to close this Dialog.

Saving Floor Plan

The following options are available only when saving Floor Plans:
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• Convert ARCHICAD Elements to Blocks: Convert elements to blocks that are recognized by AutoCAD, 

so you do not have to explode them. (The resulting blocks consist of multiple 2D primitives.) 

• Convert only Objects to Blocks: With this option, you will convert only GDL Objects to blocks. All other 

elements will be exported as drawing primitives.

• Explode ARCHICAD Elements: All elements are exploded into separate 2D primitives. Use this if you 

are exporting DXF files from ARCHICAD to a program which cannot process blocks.

• Prepare File for Smart Merge: Use this if you plan to merge a DXF/DWG file as part of a round-trip 

workflow. The conversion of elements takes place based on a customizable config file.

Important: To use Smart Merge, save the Project first.

For more information on Smart Merge, see Round-Trip Conversion (Smart Merge).

Saving Zones as

The Save Zones as option allows you to save Zones two ways: Stamp only, or Stamp and Fill.

Saving 3D Data

The following options are available only when saving 3D Data:

• Omit Polygon Edges: The color of polygon edges in the 3D window of ARCHICAD is usually different 

from the color of surfaces. If you want to reproduce this look in AutoCAD, leave this checkbox empty. If 

you check the checkbox, the lines representing the edges won‘t get exported.

• Export File with Simplified Data Structure: The effect of this option is similar to the “Explode Complex 

ARCHICAD Elements” option – all the data goes into the entity section, instead of blocks.
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Attributes (DXF/DWG Translation Setup)

There are five groups dedicated to different attributes: Layers, Pens and Colors, Line Types, Fills, and 

Font-Style Conversion. Each group consists of a “Method” set and/or one or more conversion “Dictionary” 

sets.

• The “Method” set contains options to define the actual attribute.

• The “Dictionary” set contains a list of ARCHICAD attributes and their AutoCAD counterparts.

Dictionaries are listed in the Attributes tree as “conversion” dialogs (i.e. Pen-color conversion). During Save, 

an ARCHICAD attribute found in the dictionary is renamed to its AutoCAD counterpart, and vice versa during 

Open. Attributes not found in the dictionary remain unchanged.

All the Dictionaries function in the same way:

• Click New to create a new entry.

• Click Edit or double-click on an existing entry brings up the same dialog to modify the entry.

• Select one or more items and click Delete to remove them from the dictionary.

If you set up a dictionary, the entered attribute pairs will appear on the corresponding panel of the Translator.

The creation of dictionary items is performed in dialog boxes listing the available choices.

Note on Attribute Names:

– ARCHICAD supports attribute names of essentially any number of unicode characters.

– AutoCAD 2000 and later versions allow almost any character attribute names. Names can contain up 

to 255 characters. (Character lengths are halved for Japanese, Chinese and Korean versions).

Note on Colors and Fonts: 

– While ARCHICAD pens can be set to any colors you like, AutoCAD versions have set pen colors that 

cannot be changed. In AutoCAD 2004 and later versions, it is possible to define further pen colors by 

specifying RGB values for them. These pens will have a pen index number of 256 or higher in these 

programs.

– Font names are stored differently in DXF/DWG files and in ARCHICAD. Even when one-by-one font 

matching is possible, a dictionary is necessary. (On a PC, ARCHICAD supports all available fonts 

including those installed by AutoCAD.)

– Symbol line types are stored differently in ARCHICAD and in AutoCAD. Due to these differences, 

some of ARCHICAD’s symbol line types won‘t look the same in AutoCAD. There are two solutions to 

this problem:

– Redesign the problematic line type until the disturbing differences disappear.

– Set up a template file containing an acceptable substitution for it.

The following sections describe the method and dictionary (conversion) options for each of the five attribute 

groups.

Layers (DXF/DWG Translation Setup)

Pens & Colors (DXF/DWG Translation Setup)

Line Types (DXF/DWG Translation Setup)

Fills (DXF/DWG Translation Setup)

Font-Style Conversion (DXF/DWG Translation Setup)
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Layers (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

You can convert layers in the DXF/DWG file by ARCHICAD layers, Pen Numbers or Element Types, or by 

combining layers with Pen Numbers. In case of ARCHICAD Layers and Element Types, you can not define 

Pen-based layer names conversion, in the other three, you can.

In addition, you can save either all layers or only visible ones and choose specific layers for Windows and 

Doors (in ARCHICAD, they are automatically placed on the same layer as their host Walls), all three Fill 

Categories and Skin Separator Lines.

Note: The Visible Layers Only option of the Save elements on field works for Drawings only if you save 

the Drawing file separately. If you save a Layout as a DXF/DWG file, all layers (both visible and hidden) of 

that Layout’s Drawings will be saved.

Methods

The options on the Methods tab are relevant for Save operations.

Create Layers According to

• ARCHICAD Layers: Create layers in the DXF/DWG file based on the layers used in ARCHICAD. The 

layers will carry their hidden and locked status with them.

Note: Pen-based layer names conversion is not available with this option, Custom Layer names take 

precedence. When you choose this option, the Layer name conversion dictionary will be used to replace 

some of the layer names.

• Do not export empty layers: This option is available only if “Create Layers according to” is set to 

ARCHICAD Layers. (If this box is checked, then only layers that contain elements will be exported.)

• Pen Numbers: This option places elements having the same color in a common layer. The Custom tags 

to Pen Numbers area has a Prefix field and a Postfix field. You can fill out these to specify the format of 

the created Layer names. The resulting Layer name will follow the following format: <Prefix>Pen 

No.<Postfix>. For example, if Prefix=’AA_’ and Postfix=’_PEN’, then all elements drawn using Pen 23 with 

be converted to Layer ‘AA_23_PEN’ in the resulting AutoCAD drawing.

Note 1: When you choose this option, the Pen-based layer names dictionary will be used to replace some 

of the layer names.

Note 2: Custom Layer names are not available with this option.

• Element types: Places common element types into a corresponding layer, such as a WALLS layer.

Note: There is no conversion dictionary associated with this layer creation method.

• Layer or declared Pen Number: Creates AutoCAD layers according to ARCHICAD Layers, but 

definitions in Pen-based layer names conversion dictionary take precedence over ARCHICAD Layer 

conversion. Within ARCHICAD Layer conversion, Custom Layers take precedence over normal Layer 

conversions.

• Layer extended by Pen Number: Creates AutoCAD Layer according to ARCHICAD Layers, but out of 

one ARCHICAD Layer it may create several Layers in the resulting AutoCAD drawing, because it will 

place elements located on the same Layer but using different Pens to different Layers in AutoCAD. The 

names of Layers will be created by the following pattern: <ARCHICADLayer>_<Prefix>Pen No.<Postfix>.
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Note 1: When you choose this option, the Pen-based layer names dictionary will be used to replace some 

of the <Prefix>Pen No.<Postfix> portion of the Layer names.

Save Elements on

• All layers: Save elements regardless of whether they are on hidden layers or visible ones.

• Visible Layers only: Elements on hidden layers are omitted.

Custom Layers

These fields allow you to assign Windows, Doors, Drafting Fills, Cover Fills, Cut Fills and Skin Separator 

Lines of Walls to separate layers, instead of remaining on the same layer as the construction element they 

belong to.

See also Fill Categories and Line Categories.

• Windows: If you enter a layer name into the ‘Windows’ edit field, all the Windows will be part of that layer 

instead of the layer of the Wall containing those Windows. If you clear it, Windows will go to their default 

layers (the layers of the Walls containing them). The same rules apply to Doors.

• Drafting Fills will go to the layer specified in the ‘Drafting Fills’ edit field.

• Cover Fills: Fills (if any) belonging to Slabs, Roofs, Meshes and Zones and Fills having the ‘Cover Fill’ 

category will go to the layer specified in the ‘Cover Fills’ edit field.

• Cut Fills showing cut surfaces or sections of construction elements and Fills having the ‘Cut Fill’ category 

will go to the layer specified in the ‘Cut Fills’ edit field.
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• Skin Separator Lines of cut composite structures, plus Lines having the ‘Skin Separator Line’ category 

will go to the layer specified in the ‘Skin Separator Lines’ edit field.

• Contours of cut construction elements and composite structures (they belong to the ‘Cut Line’ category) 

and Lines having the ‘Drafting Line’ category will remain on the layer they were in.

• In case of a Column: if there is no veneer, the contour of the Column belongs to the ‘Cut Line’ category. If 

there is a veneer, the contour of the Column belongs to the ‘Cut Line’ category, and the lines between the 

core and the veneer belong to the ‘Skin Separator Line’ category and will be saved accordingly.

• In case of Fills: the contour of a Fill (if any) belonging to the ‘Cut Fill’ category will belong to the ‘Cut Line’ 

category. Contours of other Fill categories will belong to the ‘Drafting Line’ category.

• Window Markers

• Door Markers

• Zone Background (any visible zone cover fills)

• Zone Outline

• Zone Stamp (geometry of zone stamp)

• Zone Texts (textual content of zone stamp)

The Custom Layer names you define will work even if they do not exist in the ARCHICAD project.

If you want your Custom Layer name to include the source layer name of the wall containing the element: click 

Insert Source Layer.

Example:

The Wall containing Windows is on the layer: EXTERIOR WALLS

If you enter in the Windows DXF/DWG Layer field the following: WINDOW_ON_

and then click Insert Source Layer, the Windows field shows: WINDOW_ON_<Source Layer>

Then the resulting layer name will be: WINDOW_ON_EXTERIOR_WALLS

Pen-based Layer Names

If you save a DXF/DWG file with the “Create Layers according to” option set to Pen Numbers, the export file 

will contain a layer with the name PEN_<n> where <n> is a pencolor index. AutoCAD users may prefer the 

layer name to state the actual color name (i.e. PEN_BLUE). These options can be set here.
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Pen-based layer names conversion is very similar to Layer name conversion – the only difference is that you 

have a standard ARCHICAD pen selection control instead of the layer name pop-up. You can write only valid 

pen numbers in the ARCHICAD pen field.

Layer name Conversion

Use custom tag to indicate renovation status: Check this box to append a tag corresponding to the 

renovation status to layer names. This way, all elements on a particular layer in ARCHICAD will be assigned 

to one of three different DWG layers, depending on each element’s renovation status.

To create a dictionary item in the layer-name conversion dictionary, click on the “New” button and assign the 

layers in the dialog box.

Note: A problem may arise when you convert both “Exterior Walls” and “Interior Walls” to “WALLS” in 

AutoCAD. When converting wall layers back to ARCHICAD, the dictionary will not distinguish between the 

two types of ARCHICAD wall layers.

Pick a valid ARCHICAD layer from the pop-up under the edit field in the layer conversion dialog. Press OK to 

add the item to the dictionary. Then assign a corresponding layer on the DXF/DWG side.

To modify an existing item, just double-click on it, modify it, and write it back to the dictionary.

To delete one or more items from the dictionary, select them and click Delete.
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Pens & Colors (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

ARCHICAD Pen Colors are configurable, while AutoCAD’s pen number association to colors cannot be 

modified.

You can convert ARCHICAD Pens to AutoCAD Colors by searching for the best color match, or else set up a 

conversion dictionary.

To convert by pen index numbers, use the default translator entitled “Keep Pen Index Number.” (Choose this 

option from the pop-up translator list at the top of the DXF-DWG Translation Setup dialog box.)

• If Background fill pen in ARCHICAD is set to window background (-1), it  will be converted to an AutoCAD 

Wipeout.

• A Patch object’s background fill color is assigned the window background pen color (-1): as a result, the 

patch will be displayed correctly when the background color changes. When the Patch is converted to 

AutoCAD, its background is transformed to an AutoCAD wipeout (WPOut) without a frame, and will be 

displayed correctly.

Note: If you are using an AutoCAD version preceding AutoCAD 2004, Wipeout is available as part of 

“Express Tools.” Wipeout is integrated into AutoCAD 2004.
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Pen Methods

Open

• Open: When you open a DXF/DWG file, the pen table of ARCHICAD is set to the AutoCAD colors. The 

pen numbers will be the same as the AutoCAD color indexes in the DXF/DWG file.

Other Import: With any other DXF/DWG import operation, in which pens should not be altered (Merge, 

Attach XREF, Open Object, etc.), every AutoCAD color will be mapped to the ARCHICAD pen with the 

most similar color (RGB) components.

Note: All AutoCAD pens with a pen index number of 256 or higher will have their pen index changed to 

255 in ARCHICAD. 

Save

The following two options are available when saving to AutoCAD 2004 or later.

• Best matching Standard AutoCAD Color: With a Save operation, every ARCHICAD pen will be mapped 

to the AutoCAD color with the most similar color (RGB) components.

Note: A round-trip will not necessarily result in the same colors as the original. For example, if ARCHICAD 

pen 25 finds AutoCAD color 236 the closest match, it is possible that AutoCAD color 236 will find 
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ARCHICAD pen 32 the closest match instead of 25. Grayish pastel zone-fill colors always end up a pure 

light-gray.

• RGB Color: If no match exists, it will save the RGB value of the ARCHICAD Pen and assign to it a pen 

index number of 256 or higher in the AutoCAD drawing.

Set All Elements’ Colors and Lineweights to BYLAYER

• For Save: Check this to override the Pen-Color conversion preferences above. 

• Every saved entity will have the color BYLAYER. When the AutoCAD user changes the color attached to 

a layer, everything on that layer will change its color accordingly.

Do not export ARCHICAD penweights

• For Save: With this option, penweights of ARCHICAD Pens will not be exported to the resulting AutoCAD 

drawing.

The following table shows how ARCHICAD penweights are converted to AutoCAD penweights when this 

checkbox is not checked and penweights are exported.

Pen-Color Conversion

Check the box to enable settings for conversion between ARCHICAD Pens and AutoCAD Colors .

These settings take precedence over the automatic conversion methods set on the Methods page.
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Line Types (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

When saving files, you can either set up a line type conversion table or choose to convert all ARCHICAD line 

types to a single type in AutoCAD named BYLAYER.

Note that symbol line types are stored differently in ARCHICAD and in AutoCAD. Due to these 

differences, some of ARCHICAD’s symbol line types will not look the same in AutoCAD.

Methods

Set All Elements’ Line Types to BYLAYER: This checkbox is available only during Save. It overrides the 

effect of the Linetype-linetype conversion dictionary.

When this check-box is checked, every saved entity will have line type BYLAYER. When the AutoCAD user 

changes the line type attached to a layer, everything on that layer will change its line type accordingly.

Keep Existing Line Types on Open: If you check this checkbox, ARCHICAD will keep line types currently 

defined and also import line types defined in the imported DXF/DWF file. In this case, if the DXF/DWG file 

contains line types with the same name as line types existing in the currently open ARCHICAD Project, the 

line types of the DXF/DWF file will not be imported.

If this checkbox is not checked, all line types from the DXF/DWG file will be imported, and none of the existing 

ARCHICAD line types will be kept.

LTScale value in output field: Set the LTScale to the desired value.

The LTScale variable used in DWG files are correctly interpreted when opening or merging DWG files in 

ARCHICAD. New line types will be created as needed, regardless of the length of the original line pattern.

Linetype-Linetype Conversion

This conversion dictionary works exactly the same way as the layer-layer conversion except that it deals with 

line types. The only condition restricting its use is the option “Set all Elements’ Line Types to BYLAYER.

You can pick the requested line type name from the pop-up list. Its name will appear in the ARCHICAD line 

type field. In the AutoCAD line type field, type the name of the line type you would like this ARCHICAD line 

type to be converted to in the resulting DXF/DWG drawing. Or vice-versa: from this line type, ARCHICAD will 

create a line type specified in the ARCHICAD line type field when opening DXF/DWG files.
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Fills (DXF/DWG Translation Setup)

ARCHICAD fill patterns can be saved as solid fills. You can also export fill backgrounds as additional polygons 

(as this feature is not supported by AutoCAD).

Methods

In this popup menu you can choose a method how ARCHICAD fills will be exported to AutoCAD.

• Export all Fills “as is”: This option will recreate ARCHICAD fills in AutoCAD.

• Export all Fills as “SOLID”: This option will convert all fill patterns to solid fills.

• Export all Symbol Fills as “SOLID”: This option will convert all symbol fill patterns to solid fills.

Export Fill Backgrounds as Additional Solid Hatches: ARCHICAD fill patterns have a separate 

background fill; AutoCAD fills, in contrast, are all transparent between the pattern lines. If you want the 

exported file to look like the original ARCHICAD fill, check this option.

Note: Export Fills as “SOLID” disables this option.

The results of this choice:

• Background Fill, Non-Transparent Background: When an background fill with a non-transparent color 

is exported, it will be exported as a solid fill whose color is that of the background (plus the border if it 

exists).

• Background Fill, Transparent Background: no fill will be exported (only the border if it exists).

• Foreground Fill: Exported as-is; background has no effect.

• Vectorial Fill, Non-Transparent Background: a foreground fill with the background color is exported 

first; then, a pattern fill with the foreground color is exported as a Hatch entity (and the border if it exists). 

If the Hatch lines reach a certain level of density, then it becomes a solid.

• Vectorial Fill, Transparent Background: Only the pattern fill with the foreground color is exported (and 

of course the border if necessary).

• Symbol fill: Has no AutoCAD equivalent; the symbol pattern is generated into a Block. If it has a 

background in ARCHICAD, this background will become a Hatch in AutoCAD.

• Gradient: Exported as solid.

• Image: Exported as solid.

Explode gradient fills: Gradient fills in your project will be exploded into separate components. If your Gradient 

fill had a transparent background, it will also be a separate component.

Use the Fill Conversion Table: Check this box to convert Fills to hatches using the Fill Conversion table. 

Click on the Fill-Hatch Conversion table to define correspondences.
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Fill-Hatch Conversion Table

Click New to define each new correspondence in the Edit Fill-Hatch Conversion dialog box.

This requires that you have selected an AutoCAD template file in the Save Options page of the DXF-DWG 

Translation Dialog Box, and the template file includes at least one placed instance of the desired hatch.

Choose from among the available hatch patterns using the drop-down menu below AutoCAD Hatch Pattern.

Enter a Hatch Scale in which to display the converted fill.
ARCHICAD 24 Reference Guide 3439



Dialog Boxes User Interface Reference
Font-Style Conversion (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

Font Styles when Opening a DWG in ARCHICAD

If the AutoCAD text element was created using the older TEXT command, which does not support multiple 

font styles, then you should use a font-style conversion dictionary file. The conversion file will have no effect 

on MTEXT (multi-line text) elements.

During Open, a text having a font that is listed in the dictionary will be converted according to the dictionary 

specification. The slant parameter is handled the same way as during Save (see below).

You can pick the requested font name from the pop-up list. Its name will appear in the ARCHICAD font field. 

In the AutoCAD style field, type the name of the style you would like this ARCHICAD font to be converted to 

in the resulting DXF/DWG drawing. Or vice-versa: after opening DXF/DWG files, text elements using the style 

in AutoCAD will be displayed in ARCHICAD using the font specified in the ARCHICAD font field. In the 

Oblique angle field you can specify the angle of the font in ARCHICAD.

Font Styles when Saving an ARCHICAD File to DWG

During Save, texts having the font specified on the ARCHICAD side of a dictionary item will be exported in the 

font specified on the AutoCAD side. If the slant parameter is 15 (15 degrees) or greater, the exported text will 

be in italics. Usually, an italic style has an oblique angle of 75 degrees. Unless a template file is selected, the 

style will use the AutoCAD counterpart of the ARCHICAD font. (A font conversion file specifies the best 

match, regardless of the platform ARCHICAD is running on).
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Miscellaneous (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box.

See DXF/DWG Translation Setup.

These settings concern character conversion including the use of national characters not in the English 

alphabet, font substitution rules for missing specifications and binary DXF.

Replace Missing Fonts with: If you get a DXF/DWG file containing a style/font specification that does not 

exist in any of your style/font and font/font dictionaries, you can define a default font here.

Allow national characters in layer, linetype, block names: If the recipient AutoCAD works in the same 

national environment as your ARCHICAD, you can check this checkbox.

Write binary DXF: This compressed version of DXF takes up about half the space of the text DXF format.

Note: if you really want the data to be compact, it is suggested that you write to DWG format.

Convert Splines into Polylines: Check this box to convert Splines into Polylines in ARCHICAD. ARCHICAD 

will approximate the AutoCAD Spline using a series of connected straight line segments (that is, a Polyline). 

This may be useful when in some rare cases, the converted ARCHICAD Spline still looks a bit different from 

its AutoCAD counterpart.

If you leave this box unchecked, AutoCAD Splines are converted into ARCHICAD Splines.

Replace Missing Renovation Status with: Choose a Renovation status in ARCHICAD for imported 

elements that do not have an assigned renovation status.
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Custom Functions (DXF/DWG Translation Setup)

These are options in the DXF/DWG Translation Setup dialog box. The available options will vary depending 

on the language version of ARCHICAD you are using.

Custom Functions contains add-ons for both Open Extras and Save Extras operations. Several functions 

are loaded by default; you need only turn them on or off using the checkboxes.

For example, the Store original Blocks add-on, if checked, will optimize the roundtrip of DWG files to and 

from ARCHICAD. Original blocks will be stored, so that unmodified DWG blocks, once reexported from 

ARCHICAD, will remain intact; no unnecessary new blocks will be created.

To change the order in which they are executed, you can drag and drop them to new locations within their 

element groups.

A Path area displays the location of the add-on. If you add further functions or delete any of them, you must 

press the Reload Functions button to refresh the function list. Custom function files are located in your 

ARCHICAD folder, under Add-Ons > Import/ Export.
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Merge DXF-DWG

Use File > Interoperability > Merge, and enter the desired DXF or DWG file name in the directory dialog box.

Click Open. The Merge DXF-DWG dialog box appears.

See also Working with DWG/DXF Files for general information on DXF/DWG.

There are two possible routes you may take here. Since the DXF-DWG file may contain both Model Space 

and Paper Space information, and since ARCHICAD Project Files contain both Model Views and a Layout 

Book, you need to decide which elements should be merged.

• Choose the Merge content of Model space into current View radio button if you want the Model Space 

portion of the DXF-DWG file merged into your Project file. If Model Space is merged, the Top View of 

AutoCAD elements located in the Model Space of the merged DXF-DWG file will be generated, and these 

Top Views will be placed into the ARCHICAD Model View as 2D ARCHICAD elements.

For more information, see Merge DXF-DWG Model Space Dialog Box.

• Choose the Append Paper Space(s) to Layout Book radio button if you want the Paper Space(s) 

defined in the DXF-DWG file merged appended to the Layout Book of your Project file.

If you choose the latter option, click the Append Options button to set two DXF-DWG Import options of the 

Translation Setup. The Import Options for Elements on Paper Space dialog will come up. Note that this 

button will be available only if the DXF/DWG file to be merged contains Paper Space information.

Topics in this section:

Merge DXF-DWG Model Space Dialog Box

Import Options for Elements on Paper Space

Smart Merge Options
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Merge DXF-DWG Model Space Dialog Box

To access this dialog box, first use File > Interoperability > Merge, then enter the name of the DXF or DWG 

file to merge. In the appearing DXF-DWG Merge Options dialog box, choose the first option (Merge Content of 

Model Space) and click OK.

This brings up the Merge DXF-DWG Model Space dialog box.

Use these controls define where and how you want the file to be placed on the ARCHICAD floor plan.

• Insertion point: In the X and Y field, you can enter the exact coordinates of the location of the lower left 

corner of the enclosing rectangle or of the Drawing origin. Alternatively, you can check the Specify On-

Screen box to enter these coordinates by clicking on the Floor Plan.

• Scale: Either specify a scale factor in both X and Y directions, or check the Specify On-Screen box to 

define scale on the screen.

Note: If you specify scale factors, the drawing’s bounding box will be scaled to the appropriate size. If not, 

you will be able to stretch the bounding box just as if you were stretching an ARCHICAD object. It is 

possible to input or specify negative or positive values for scale factors. By specifying negative values you 

can achieve mirroring effects.

• Rotation: You can define an angle by which the whole placed drawing will be rotated around its insertion 

point, or check the Specify On-Screen box to define rotation manually, on the screen.

Note: If you specify a rotation angle, the drawing is rotated and then drawn. If not, you can rotate the 

bounding box until you input the value with a mouse click or coordinate input.

Anchor Point: Use these controls to define by which point of the bounding box to place the drawing.

• Drawing’s own origin: the Global Origin (0;0 coordinate) of the attached drawing will be located at the 

coordinates specified by you on screen or in this Dialog.

• Drawing’s own anchor point: the attached drawing’s own anchor point (if any) will be located at the 

coordinates specified.
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• Bounding box node: ARCHICAD calculates the size of the bounding box of the attached drawing. You 

choose any of the 9 significant points of the bounding box, and that position of the drawing will be located 

at the coordinates specified for placement.

Place on Story: Use this drop-down list to choose the story onto which to place the drawing. Before the 

actual placement, ARCHICAD will switch to that story.

Import Model Space content as GDL Object: Check this box to import the model content as a single GDL 

Object.

Translator: This field displays the currently selected DXF/DWG Translator to be used during the conversion 

of the attached AutoCAD drawing. Then choose the Merge command. You may select any of the currently 

available Translators from the drop-down list (the default translator, “For editable import”, is generally 

appropriate).

To modify the Translator Settings before executing the merge, click the Settings button to access the 

Translator Dialog.

For more information, see DXF/DWG Translation Setup.

Description: This field shows a short explanation and note about the currently selected Translator so you can 

decide if it fits your needs.
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Import Options for Elements on Paper Space

To access this dialog box, first use File > Interoperability > Merge, then enter the name of the DXF or DWG 

file to merge. In the appearing Merge DXF-DWG dialog box, choose the second option (Append Paper 

Spaces to Layout Book), then click the Append Options button.

This brings up the Import Options for Elements on Paper Space dialog box.

Translate AutoCAD Blocks as: Just as in the Open Options portion of the Translation Setup Dialog, you 

have three choices: 

• 2D Elements

• Grouped 2D Elements

• Library Parts

For more information, see Open Options (DXF/DWG Translation Setup).

Convert AutoCAD Leaders to Labels: Check this box if you wish this conversion performed during the 

Merge process.

If you leave this box unchecked, AutoCAD Leaders will be converted to simple ARCHICAD 2D elements. This 

checkbox will not be available (it will be grayed) if the ARCHICAD Add-On providing this functionality is not 

loaded.

This checkbox is also available in the Translation Setup Dialog, in the Custom Functions > Open Extras 

area.

Click the OK button to accept the settings changes you made in this Dialog or click Cancel to leave the 

settings as they were before.

If Paper Space is merged, Paper Space definitions will be converted to Layouts in the Layout Book of 

ARCHICAD. A new Master Layout will also be created in case the DXF-DWG drawing contains Paper Space 

size definitions not already available in the Project file.
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The content of Viewports within the DXF-DWG file will be converted into Drawings when merged into 

ARCHICAD. These Drawings will be placed onto their appropriate Layout according to their Viewport 

definition in AutoCAD. These Drawings are not editable entities; they will appear in the Drawing Manager of 

ARCHICAD, with a status of “embedded”.

If elements were drawn in Paper Space of the DXF-DWG file, these elements will be converted into 

ARCHICAD elements and will be placed directly into the Layout they belong to.
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Smart Merge Options

To access this dialog box, use File > Interoperability > DXF-DWG > Smart Merge Options.

Use these controls to configure the Smart Merge process for DXF/DWG files.

For more information, see Round-Trip Conversion (Smart Merge).

You can choose an existing configuration, or create a new one. The configuration files (.mcf) must be located 

in the folder of the Add-On.

You can also duplicate, rename, or delete these configuration files with the appropriate buttons. You can save 

your configurations for your different needs into different files. When you merge a DXF/DWG file, ARCHICAD 

first looks for the .mcf file defined in the #MERGECONFIG section of the DXF-DWG Config.xml file. If this 

section is not used, then ARCHICAD looks for the dxf.mcf configuration file and the default.mcf file, 

successively.

If none of these exist or if you want to select another .mcf file, you can always do so in the File > 

Interoperability > DXF-DWG > Smart Merge Options dialog box.

A configuration set tells you what will happen when you merge a DXF/DWG drawing into the plan.

The Merge process affects only visible and unlocked elements, so if you want to avoid changing any elements 

you should hide or lock them.

You can study or edit the details of the configuration set, by clicking the small arrow next to Edit rules for 

current configuration text. The rules in the list are editable; the maximum number of rules is 16. A rule is 

made of a condition part and one or more actions. If an element coming from the DXF/DWG drawing meets a 

condition of a rule, the actions of that rule will be executed on it.

Those elements that do not meet any of the conditions in the list are ignored.

Add or Remove Rules

The New Rule button adds a new but empty rule to the end of the list. The condition and the actions for this 

rule will be undefined. A rule becomes valid if the condition is fully defined and at least one action is set.

You can remove a rule entirely by selecting its line and clicking the Delete Rule button. (Separator lines are 

not selectable.)

Editing a Rule

If you want to edit a condition, you have to click that line in the list, then choose another type of condition in 

the displayed pop-up window. To edit an action, click the row with the action you want to change, and select 

another enabled action from the pop-up. If you want to delete an action from a rule, select it and click the 

Delete Action button. A rule must have at least one action, thus you cannot delete the last one. The Add 

Action button inserts an action after the selected one. At first it will not be defined, so you must set a valid 

value for it.
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You have to read the actions sequentially, because there are cases when the execution order is irrelevant 

(e.g. you get different results if you first duplicate a wall in its original position and then move the duplicated 

original item or if you first move the original item and then duplicate it in the new position). Usually the actions 

are applied to the elements on the ARCHICAD plan, but not always. The operations following a duplicate 

element action are applied to the replica. The actions following the Outline from Merged file action are applied 

to the “Outlined drawing” stored in the DXF/DWG file.

For more information on “Outlined drawing,” read the next section: More Information on Smart Merge.

More Information on Smart Merge

To understand how Merge works, let’s have a look at what happens in detail:

In ARCHICAD:

• You may add new elements. Even if you create them by copying existing elements, they are still new, as 

they get new unique IDs.

• You may change elements created earlier. That is, you may drag them, stretch them, or even just alter a 

surface parameter. When you insert or change a window or door in a wall, it means the wall will change, 

because its modification date will change. This means that when merging the DWG/DXF file back into 

ARCHICAD, your only option will be to display the “Outlined drawing” next to the original ARCHICAD wall 

model element.

• You may delete anything.

What the AutoCAD-user consultant can do with your DWG file:

• He/she can add new elements.

• He/she can move, rotate or mirror items you exported. He can even stretch them, but it is not 

recommended: the Merge function processes only size-preserving transformations.

• He/she can delete these elements as well and he can duplicate them.

But how do we know that an item of the drawing (Autodesk terminology calls it entity) is something we 

exported or the other user created; and how do we know what he/she did to items of the former category?

Autodesk provides means to add custom data (called extended entity data) to each entity.

This allows us to save ARCHICAD-specific information along with the image of each of the elements we 

export.

These elements can be simple, that is, something that can be represented by one AutoCAD entity (e.g. a 

circle); or complex (e.g. a wall that is drawn as at least 2 lines and 1 hatch).

The complex elements have to be joined together in blocks (something like Library Parts in ARCHICAD) in 

order to handle them as units.

Merge needs the original, unchanged element present in the plan in order to incorporate the changes the 

AutoCAD user made on it. This means that only minimal information will be stored:

• The unique (ARCHICAD) ID and type of the element

• The three coordinates that AutoCAD (or the other program) transforms if the entity is moved, rotated or 

stretched; if the other program is not AutoCAD, it must be done similarly

• The AutoCAD ID of the layer of the element, so that ARCHICAD can detect if the AutoCAD user moved 

the element to another layer

• The AutoCAD ID of the originally exported element to separate the original from the duplicates; this is 

what happens in the Merge process to the different elements

• Elements created on the Floor Plan after exporting the DWG: no action
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Entities added by the AutoCAD user (the duplicates of the ARCHICAD-generated elements not included): you 

will most likely want to keep them, so they are added to the plan.

As to elements exported to the drawing (which may or may not have been modified by the other program): the 

problem here is that nothing prevents you and the AutoCAD user from simultaneously modifying/deleting 

these elements. The situation can be described by a matrix like this:

where:

1: the ARCHICAD user leaves the element unchanged

2: the ARCHICAD user modifies the element

3: the ARCHICAD user deletes the element

A: the AutoCAD user leaves the element unchanged

B: the AutoCAD user modifies the element

C: the AutoCAD user copies the element

D: the AutoCAD user deletes the element

• the case 1/A is simple enough: no one modified the element so it remains unchanged;

• 1/B: the original state of the element can be retrieved from the plan so there is no problem applying the 

changes;

• 1/C: like 1/B just applied to the copy of the original element;

• 1/D: the element gets deleted.

But if you have modified (2) or deleted (3) an element, the results may be very different. If you moved a wall 

the AutoCAD user left in place (2/A) but mounted tubes on it: now the tubes will appear in the middle of 

nowhere.

Or both of you moved an element (2/B): your move has been completed, but you do not know how to apply his 

movement because the original position is not preserved in the plan.

The only way to deal with this problem is this: the AutoCAD drawing contains the image of the element 

reflecting the intended changes. This image (the “Outline”) can be drawn directly in the Floor Plan so at least 

you can see what the AutoCAD user meant to do. You can then decide what to do manually.

Note: If an element was scaled in AutoCAD, the Merge Add-On will outline the drawing, and scaled 

elements will appear in ARCHICAD as single lines, arcs and fills.

• 3/D is the only simple thing: both of you meant to delete the element; since you have already done it, you 

have nothing to do.

Please bear in mind that Merge is configurable; the above mentioned solutions are just suggestions.

Many other possibilities exist: 

• You can move the original element to another layer.

• You can move the element coming from the AutoCAD drawing to another layer.
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• You can ask ARCHICAD to request confirmation at any point of an action sequence. This means that 

ARCHICAD will zoom to the element in question so you can examine the changes and decide on Merge 

Actions.

The available actions are:

• Put Element on <layer> layer: this action puts the Floor Plan element to the layer specified in the DXF/

DWG file

• Put Element on “Deleted” layer

• Put Element on “Edited” layer

• Put Element on “Copied” layer: these actions put the element on a special layer created by the Add-On. 

This is useful when you would like to separate elements edited by the AutoCAD user.

• Duplicate Element: creates a copy of the element

• Transform Element: executes the transformations applied to the element in the DXF/DWG file (dragging, 

rotating, mirroring or even changing layers if needed). Note that the last change is only carried out if the 

“Put Element on layer” action is also active. Size changing operations are ignored.

• Delete Element: removes the element from the plan

• Outline from Merged File: this action should be set when you want to put the “Outlined drawing” of the 

element on the plan, or when no other action can be chosen. This is the case when the original element 

was changed or deleted in ARCHICAD. This means the element will be generated from the AutoCAD 

entities as a set of 2D ARCHICAD elements.
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Surfaces (Cineware)

Use the Options > Element Attributes > Surfaces command to access the Surfaces dialog box.

From Engine Settings, choose Cineware. This means that the surface settings here are optimized to work with 

the Cineware PhotoRendering engine.

Important: All surfaces are specific to the engine for which they are set up. If you change a surface 

parameter for one engine, those modifications will not take effect for the same surface parameter if you 

switch to another engine.

Choose a surface from the pop-up chooser. The Preview window at the top gives you feedback on the 

surface. As you edit the properties in the panels below, this preview is updated to show the effects.

Each surface has a Size setting. These parameters define how the surface material unit will be scaled on the 

object to which it is applied.
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• Vary the size of the surface unit with Horizontal Size and Vertical Size parameters.

• Adjust the angle of the surface unit (e.g. if it uses a pattern)

• Click Lock Proportion to keep these parameters relatively constant.

• Enable Random Origin to begin the surface pattern at a random point, rather than starting it at the project 

origin. 

Surface Settings for the Cineware engine can use one or more channels, listed on the left side of the dialog 

box. Each channel represents one surface property (e.g. Luminance, Fog, Environment, Normal, Alpha, 

Glow, Transparency, Specular, Displacement).
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For any selected channel in the list, its settings and a preview window are seen on the right.

Most Surface channels enable you to load a texture. Textures add realism to the surface, enabling you to 

simulate, for example, wood grain.

The specific Texture you choose may be either a shader or an image. Each of the shaders has its own 

parameters. For a particular Surface channel, you can combine several shaders/textures in a layer, to achieve 

more realistic effects.

Navigation in Surface Settings

Surface Channels and their associated textures/shaders often include several levels of parameters. 

• Click the green down-arrow icon to enter the list of associated parameters.

• Use the blue “Step Out” button to return to your previous view.
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Related Topics

Cineware Surface Channels

Textures (Cineware Surfaces)

Special Settings for Image Textures (Cineware Surfaces)

Shaders List (Cineware Surfaces)

Using Layers to Combine Shaders (Cineware Surfaces)

Create, Load and Share Surfaces (All Engines)

Match Settings with Cineware Surfaces

Watch the Video
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Cineware Surface Channels

Surfaces for the Cineware engine consist of a set of channels, listed on the left side of the dialog box. Each 

channel represents one surface property (e.g. Luminance, Fog, Environment, Normal, Alpha, Glow, 

Transparency, Specular, Displacement).

Many surfaces can be simulated using just a few channels. So don’t be intimidated by the numerous channels 

and their wide range of parameters. Generally speaking, all everyday surfaces can be created using just a 

handful of these channels.

Color (Cineware Surface Channel)

Surface color

Diffusion (Cineware Surface Channel)

Irregularities in surface color (works by brightening and darkening the color channel) 

Luminance (Cineware Surface Channel)

Luminescent color (light-independent color) 

Transparency (Cineware Surface Channel)

Transparency (including refraction index) 

Reflectance (Cineware Surface Channel)

Ability to reflect other objects. Also controls Specular and Color effects.

Environment (Cineware Surface Channel)

Environment reflection (simulates reflection) 

Fog (Cineware Surface Channel)

Fog effect 

Bump (Cineware Surface Channel)
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Virtual bumps on a surface 

Normal (Cineware Surface Channel)

Virtual surface irregularity that is lit realistically

Alpha (Cineware Surface Channel)

Localized texture invisibility 

Glow (Cineware Surface Channel)

Glow Halo around an object 

Displacement (Cineware Surface Channel)

Realistic bumps on a surface

Grass (Cineware Surface Channel)

Create realistic-looking grass as a surface

Illumination (Cineware Surface Channel)

Use the Illumination channel in Surfaces to enable or disable the generation and reception of Global 

Illumination (GI) to and from this surface, and to control the strength of the caustics effects.
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Color (Cineware Surface Channel)

The settings on this page define the basic color of the surface. 

Defining Color and Brightness Values

Many surface channels contain (apparently identical) color selection options. Once a color has been defined it 

can be brightened or darkened using the Brightness slider.

Click the Color swatch to access the Color picker.

If you want to create a more complicated surface, such as a checkered pattern that uses several colors, you 

can load a texture. The texture is layered above the color.

See Textures (Cineware Surfaces).

If you want to see the color only and not the texture, set the Mix Strength value to 0%.

See Mix Mode and Mix Strength (Cineware Surfaces).
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Model

Choose the illumination model for the surface: Lambertian or Oren-Nayar.

• For a shiny surface needing accurate highlights, choose Lambertian.

• For rough surfaces — like cloth, sand, concrete and plaster — choose Oren-Nayar.

Note: The Blinn model is now located in the Reflectance channel’s Type menu as Specular-Blinn 

(Legacy).

Diffuse Falloff

This value defines the falloff of brightness between the specular highlight (surface Normals point in the 

direction of the light source) and the regions in which the surface Normals have an angle of 90° to the light 

source, i.e., they do not reflect light from the object surface. The default value of 0% reflects a normal falloff 

behavior. The larger the value, the more uniform the brightness will be, up to the point of producing a comic-

like look (uniform colors). If negative values are used, the 90° angle mentioned above will be reduced 

accordingly, which will produce correspondingly smaller regions from which light will be reflected.

Diffuse Level

Available only with Oren-Nayar shading.

Use this parameter to alter the general diffuse brightness that is reflected for the Oren-Nayar model (very 

similar effect to the above-described Brightness setting).

The default of 100% means normal diffuse reflection. Enter a lower value to reduce the amount of reflection.

Roughness

Available only with Oren-Nayar shading.

Larger values will produce a correspondingly more diffuse light dispersion; the surface will become 

correspondingly darker and duller. 
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Smaller values will produce a light dispersion increasingly similar to the Lambert model.

Adjusting Gradient Parameters

Every time you adjust a color gradient, you can play with the Knot parameters, used to set the color and 

position of the gradient. 

• Add as many knots as needed by clicking the Plus icon (Add Gradient Shader) at the top of the list. 

• For each knot, you can set its color, intensity, position, interpolation, and bias (the horizontal distance that 

the curve is displaced between any two knots).

• If you select an existing knot and click Add Gradient Shader, it will duplicate the selected knot. Knots are 

automatically ordered from 0 to 100 based on their Position value.

Brightness

Once a color has been defined it can be brightened or darkened using the Brightness control. Click the arrow 

at the right of the slider to increase the value past 100%: this increases brightness dramatically.This can be 

useful if the brightness of a Luminance channel, for example, is used in conjunction with Global Illumination to 

illuminate a scene, or if the shadows generated by a weak light source should be strengthened using the 

surface’s Color channel.

Note: Depending on the value of the Glass/Mirror Optimization parameter (Cineware Detailed Settings > 

Global Illumination > Details), GI will ignore all surfaces whose transparency or reflection Brightness value 

exceeds this optimization value.

See Glass/Mirror Optimization.

Texture

Here a texture or a 2D shader can be defined. If you load a texture or a 2D shader, it is placed on a layer 

above the color (i.e. the texture is placed on top of the color).

See Textures (Cineware Surfaces).
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Diffusion (Cineware Surface Channel)

Use this channel to create irregularities in surface color (it works by brightening and darkening the color 

channel).

Just about any surface can use a little variation to make it look more natural. Objects in the real world almost 

always show some type of wear and tear, signs of usage or dirt. Adding such characteristics makes a 3D 

surface look more natural and realistic. 

To create such an effect, a texture (image or shader) can be loaded into the Diffusion channel.

Use the Brightness slider to adjust the brightness of the channel’s color. The brightness functions somewhat 

like a multiplier.

Affect Luminance

Enable the Affect Luminance option if you want the diffusion map to affect the luminance property. The darker 

a pixel in the diffusion map, the darker the corresponding region of the luminance. This helps you add 

irregularities to the luminance to achieve a more natural look.

Affect Specular

If the Affect Specular option is enabled, the diffusion map is applied to the specular property as well. This will 

reduce the surface’s specular values where the diffusion map is dark. This option is enabled by default since it 

adds to the realism considerably.
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Affect Reflection

Enable Affect Reflection if you want to apply the diffusion map to the reflection and environment properties for 

a more natural look. The darker a pixel in the diffusion map, the darker the corresponding region of the 

reflection.
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Luminance (Cineware Surface Channel)

Use this channel to add a light-independent, luminescent color to your surface.

A luminescent object can be seen even when there are no lights in the scene. It is self-illuminated.

If you are using an image as your texture, load a file to use as a luminance map. The brighter a pixel in the 

luminance map, the more luminescent the corresponding region of the surface. If you have chosen a 

Luminance Color and loaded a texture (luminance map) as well, the color will be added at 100% strength to 

the texture. If you want to see the result without the chosen color, set Mix Strength to 0%.

Luminescent surfaces are used to help simulate objects that seem to be self-illuminated in the real world, 

such as the windows of an office block at night, neon writing or a TV screen.

Color and Brightness

See Defining Color and Brightness Values.

Texture

See Textures (Cineware Surfaces).

Mix Mode/Mix Strength

See Mix Mode and Mix Strength (Cineware Surfaces).
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Transparency (Cineware Surface Channel)

Here you can define the transparency, including a refraction index. 

Use the Color and/or Brightness parameters to set a transparency. Using a 50% gray is similar to using white 

and 50% brightness.

Color percentage + Transparency percentage = 100%

If the surface has a color (in the Color channel), the color is automatically reduced with increasing 

transparency. 

Tip: Much better results can be achieved if Absorption is used (see Absorption, below).

You can load a texture as a transparency map. The brighter a pixel in the transparency map, the more 

transparent the corresponding region of the surface. A transparency texture is similar to a photographic slide: 

Red parts of the slide allow only red light to pass through; white parts allow all light through. With black, no 

light can pass through the slide.

Surface Color Transparency Percentage Result

White surface zero transparency Totally White (100% white)

White surface 50% transparency Gray (50% White) 

White surface 100% transparency No color
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Color and Brightness

See Defining Color and Brightness Values.

Transparency Refraction Preset

Choose a refraction preset that automatically applies a Refraction value. These are the same presets that can 

be found in the Reflectance channel’s Fresnel function.

Watch the Video

Refraction

When not using a Preset, you can set an exact Refraction value.

Useful refraction values

Vacuum 1,00

Air 1,00

Obsidian 1,480 - 1,510

Onyx 1,486 - 1,658

Acrylic glass 1,491

Benzene 1,501

Crown glass 1,510

Jasper 1,540 

Agate 1,544 - 1,553

Amethyst 1,544 - 1,553

Amber 1,550

Quartz 1,550

Sugar 1,560

Diamond 2,417 - 2,419

Glass noodle 3,999

When a ray hits a closed surface (leftmost image, below) with transparency and refraction, the ray is bent to 

simulate refraction. The bent ray is considered to be inside the object. When the ray reaches another surface 

of the object (the exit side), it is bent back as in real life.

However, if the object is open, the ray may not hit a second surface of the object (center image, below). Thus 

the ray may not be bent back and the refraction effect may be inaccurate. 

For this reason, ensure that all transparent surfaces in the scene are closed (as in the right-side image 

below).

If you are using refraction with windows - with the refraction parameter other than 1 - the glazing must be 

closed (that is, you must use an even number of panes). (In ARCHICAD, to improve 3D generation speed, 

glass panes are modeled as surfaces that have no thickness.)
ARCHICAD 24 Reference Guide 3465

https://youtu.be/iL0L69HwlJo


Dialog Boxes User Interface Reference
Total Internal Reflection

Enable the Total Internal Reflection option to activate the Fresnel Reflectivity effect (see below). This will 

automatically reduce the transparency and increase reflectivity when the surface is viewed at an angle. This is 

a common and physically correct characteristic of glass and should therefore not be disabled for glass. 

Note that the reflective properties (e.g. Roughness) can be fine-tuned in the Reflectance channel’s 

*Transparency* setting.

See *Transparency*.

Exit Reflections

As soon as a Reflection meets a surface after being refracted through glass one of two slightly different 

reflections can be calculated - ones that result when they enter glass and those that exit the glass. A single 

reflection is often visually the most appealing one (even if it is in fact false). To achieve this effect, disable the 

Exit Reflections option.

At top, Exit Reflections enabled; at bottom, disabled.
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Fresnel Reflectivity

The Fresnel Reflectivity controls the degree to which the transparency and reflection values are dependent on 

the viewing angle. If the Fresnel Reflectivity value is larger than 0%, the viewing angle — the angle between 

the camera and the surface — will be taken into account. 

If you observe a real pane of glass with your eyes parallel to the pane (i.e. with a 90 degree viewing angle), 

you will notice that the pane barely reflects, almost all light passes through. However, look at the pane from a 

narrow viewing angle and you will see that it reflects much more of its surroundings. The transparency and 

reflection values are dependent on the viewing angle.

The Fresnel option simulates this phenomenon for you.

Fresnel Reflectivity set to a high value (left) and low value (right).

For example, provided Fresnel Reflectivity is set to 100%, if you set transparency with RGB values of 80%, 

80%, 80%, the surface is 80% transparent and 0% reflective when the viewing angle is 90 degrees. With a 

very low viewing angle, the surface is approximately 0% transparent and 80% reflective. If you have entered a 

reflection value in addition to transparency, the reflection value is added to the angle-dependent reflection.

If the Fresnel Reflectivity value is larger than 0% the transparency and reflection values are used as they are 

irrespective of the viewing angle.

Additive

Usually, if the surface has a color, the color is automatically reduced with increasing transparency. This can 

help to ensure a realistic effect. However, if you don’t want this automatic behavior to take place, enable the 

Additive option.

Generally, more realistic rendering results if this option is disabled.

Absorption

When light enters a transparent medium, it weakens and changes color to one degree or another (glass is 

very rarely completely colorless). The thicker the surface, the weaker the light becomes as it passes through 

(glass is not completely transparent). These effects can be emulated using the following two parameters. In 

the following, Color refers to the Color parameter at the top of the Transparency channel.

Tip: Note that Absorption works best with closed volumes. Otherwise faulty calculations can result if there 

are holes in the volumes.
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Absorption Color

The Absorption Color is the color that is multiplied by the Color when a “ray of light” has traveled the distance 

defined in the Absorption Distance parameter.

Thus, the Transparency channel has two colors:

• Color: The color that appears in a very thin object (e.g. a window pane or a thin film of water)

• Absorption color: The color a massive object assumes.

When creating glass you will almost always set the Color to white.

Absorption Distance

Use this setting to define the distance rays of light have to travel before Absorption Color replaces Color. The 

lower the value the more intense the Absorption Color will be, even for thin glass. A value of 0 will turn 

Absorption off completely.

Blurriness

You can blur the transparency using the Blurriness, Min Samples, Max Samples and Accuracy settings. 0% 

means no blur. Increase the value to increase the strength of blur.

Min Samples/Max Samples

Note: Has an effect only in Standard rendering mode. 

These parameters will only be available if Blurriness is set to a value higher than 0%.

The program uses samples to create the blur effect and, rather than take samples at even distances, it 

concentrates the samples where they are most needed. Max Samples defines the number of samples used 

for the most important areas. Min Samples defines the number of samples used for the least important areas.

Increasing Min Samples and/or Max Samples gives a higher quality blur, but a longer render time.

Accuracy

Note: Has an effect only in Standard rendering mode. 

This parameter will only be available if Blurriness is set to a value higher than 0%.

Increasing the Accuracy value gives a more accurate blur, but a longer render time also.

Affects the accuracy of the blur effect by controlling the number of samples per shading point. With a value of 

100%, the maximum number of samples defined under Max Samples will be used in critical areas. Lower the 

value to reduce the number of samples used.
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Reflectance (Cineware Surface Channel)

Use the Reflectance page to set a surface’s ability to reflect.

The Reflectance channel combines the Reflection and Specular channels of earlier versions. Reflectance can 

be stacked and organized in layers to create effects such as metallic car lacquer.

Use up to 16 Reflectance Layers, plus the *Transparency* Layer. Each layer can have its own Alpha, Bump or 

Normals channel.

Topics in this section:

Global Reflection Brightness
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Global Specular Brightness

Layer Color

Layer Mask

Layer Anisotropy

Layer Cloth

Layer Fresnel

Layer Sampling

*Transparency*

Watch the Video

Global Reflection Brightness

Compared to the Reflection Strength setting, which is defined per layer, the Global Reflection Brightness 

setting regulates the strength of the overall reflection. For example, if you create a complex combination of 

reflections, each with its own reflective strength and the overall reflection is too intense when rendered, this 

slider can be used to tone the reflection down without having to adjust individual reflection settings.

Global Specular Brightness

Use Global Specular Brightness to adjust or fine-tune a surface’s overall specular brightness.

Layers

Lists the reflective layers of the Reflectance surface. Each layer’s effect can be combined with another layer 

using one of the two available mix modes.

Type

Beckmann, GGX, Phong, Ward

These types only differ in the manner with which they uniformly weaken reflections from the ideal reflection 

angle (= angle of incidence).

The four most important types shown on a real-world reflective model (© Eric Smit) with 60% Roughness:
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• Beckmann is a physically correct and fast type and should therefore be the preferred method for normal 

use.

• GGX produces the greatest dispersion and works best for simulating metal surfaces: a bright specular 

highlight with diminishing brightness. 

• Ward is best suited for soft surfaces such as rubber or skin

Other Types

• Anisotropic bends the reflected bundle of rays in certain directions, which produces a distortion of the 

reflection, as with brushed or scratched metal, for example.

See Layer Anisotropy.

• Reflection (Legacy), Specular - Blinn, Specular - Phong (Legacy): These three are only available for 

reasons of compatibility if an older file is loaded. It is recommended that a different mode be used that 

works physically correctly. If Specular Blinn/Phong (Legacy) is selected, specular highlights can be 

adjusted freely without having to take roughness into consideration.

• Lambertian (Diffuse), Oren-Nayar (Diffuse): These modes are diffuse models (i.e. “perfect” matte 

reflections). They produce a result similar to the surface channel Color (which doesn’t reflect). These 

channels should be used with caution (they can’t be cached by GI’s Irradiance Cache) and are basically 

only available for reasons of compatibility. The Color channel should be used instead, because it renders 

faster.

• Irawan (Woven Cloth) is a type of special anisotropy that contains several cloth patterns internally that 

can be used to create realistic-looking cloth surfaces.

See Layer Cloth.

Dispersion of light is a product of matte reflections. These types have no effect on surfaces with perfect 

reflections (Roughness set to 0%).
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The following illustrates the Type settings, at various degrees of Roughness.

The large, reflective object reflects a HDRI sky, the depictions inset each show the specular highlights from 

two light sources. Both the Diffuse and the Irawan options produce a result very different from the rest 

because they do not allow Roughness to be defined separately (exception: Oren-Nayar).

Attenuation

These options define how the Color channel should be mixed with the Layer Color with various Reflection 

Strength settings. 

Note: If the Color channel is disabled, these settings will have no effect! 
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• Average: Both colors will be averaged. This mode produces the most realistic-looking results. (If no color 

is defined in the Layer Color setting, then the effect is the same as the next mode, Maximum). 

• Maximum: This mode is best suited for creating colored reflections: The Color channel’s effect will be 

reduced and the Layer Color will dominate.

• Additive: Both colors will be added. (In the real world, the Color channel’s effect should weaken as the 

surface’s reflectivity increases, which is something that the Additive mode ignores completely. To achieve 

a physically correct result, the Color channel must be darkened manually.)

• Metal: Only available for reasons of compatibility if an older Project is loaded (in older versions of 

Cineware, this mode was found in the Specular channel’s Mode setting; it used the color defined in the 

Color channel to color the specular highlight).
ARCHICAD 24 Reference Guide 3473



Dialog Boxes User Interface Reference
The sphere surface has a red-and-white striped Color channel

 and a Reflectance channel with Layer Color set to blue
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Roughness

Roughness values in increments of 5

In the real world, surfaces are made up of an innumerable number of microscopic reflective facets, each with 

a different orientation, which, when viewed from a distance, produce a specular highlight or reflection.

A perfectly polished (reflective) surface is made up of facets with the same orientation. The rougher a surface 

is, the more random the orientation of these micro facets is, which produces a correspondingly more spread 

out and duller specular highlight.

A roughness of 100% is referred to as a Lambertian surface. This type of surface reflects light in a circular 

dispersion in all directions, which constitutes a perfect diffuse surface. This is exactly what is defined in the 

surface channel Color: a diffuse surface’s color without reflective properties. You can even ignore the Color 

channel completely and use the layer color to control the diffuse surface color (which, however, takes longer 

to render).

Note that the render time will increase as roughness increases, because reflections from a correspondingly 

wider range of reflections must be included.

Note: A Roughness value of greater than 0% is required for the calculation of specular highlights and 

anisotropy.

Texture

The Texture setting can be used to apply the Roughness setting (described above) to an entire texture. 
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Matte reflections can be controlled using textures

See Textures (Cineware Surfaces).

The grayscale values of the texture loaded here control the setting as follows: white represents the setting’s 

full value and black = 0. In-between gray values have a corresponding effect.

Reflection Strength

This setting defines the strength with which the surface should reflect. The Attenuation setting above defines 

how this setting should work in conjunction with the surface channel Color.

Generally speaking, the intensity of the surface’s color subsides as reflection strength increases (which 

occurs for all modes with the exception of Additive). This effect is also known as energy conservation.
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If Reflection Strength is set to 0%, the surface will not reflect at all; a value of 100% will produce the maximum 

amount of reflection. Every surface in the real world reflects to some degree, even if it is very minor. Keep this 

in mind when creating highly realistic textures.

Note: The layers’ combined reflective strength can be adjusted together using the Global Reflection 

Brightness slider.

Colored

If this option is enabled, the Color defined in the Color channel will be used as the reflection color (rather than 

the Color setting in the Layers Color sub-menu).

Specular Strength

This value defines the strength of the specular highlight. The use of specular highlights is a trick to add simple 

reflections to surfaces without noticeably increasing render time.

In the real world, specular highlights are nothing more than light sources reflected in objects’ surfaces. If you 

want to create a photo-realistic scene, set this value to 0 and use the Reflection Strength setting (above) 

instead.

Note on Specular Highlights: The size and appearance of specular highlights depends on Type and 

Roughness (must be set to a value greater than 0% for most modes), and in some cases the anisotropic 

settings. This is different from earlier versions of Cineware, which let you make physically incorrect 

adjustments to the specular highlight’s height and width. This can still be done, if necessary, if Type is set 

to Specular Blinn/Phong (Legacy). See Specular highlight settings, below.

Each light source in a project generates specular highlights. Note that specular highlights are only generated 

by real ARCHICAD light sources - as well as by Polygon (area) lights (however, these differ in size and other 

aspects from real, reflected Area lights):

Area lights reflected on the floor

Note how the small Area light is rendered far too large, making it look unrealistic. 

For example images of the effect of different Type and Roughness settings, see Type.

Tip: Note that the combined specular highlight strength of multiple reflective layers can be adjusted 

together using the Global Specular Brightness slider in the Reflectance tab.
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Specular highlight settings

The following 3 settings apply only to Specular Blinn/Phong (Legacy):

• Width/Roughness: Defines the width of the specular highlight. Larger widths should be used for matte 

surfaces (for less specular strength). Polished and shiny surfaces should have very small widths (for 

greater specular strength).

• Falloff: Defines the curve of the specular highlight - anything from pinpoint to bell-shaped or rectangular 

shapes can be created.

• Inner Width: Defines the specular highlight’s inner region, which is not affected by abatement of 

brightness.

Bump Strength

Each reflection layer can have its own, autonomous Bump or Normal channel (see Mode, below). They 

function exactly like the surface channels of the same name.

Use this slider to adjust the strength of the bump or normal effect. If set to 0%, the effect will be disabled; 

100% is the maximum effect.

Mode

This setting defines the type of Bump or Normal channel that should be used.
ARCHICAD 24 Reference Guide 3478



Dialog Boxes User Interface Reference
• Default: No specific reflection layer channels.

• Custom Bump Map: Select this to load a custom bump map into the Custom Texture field. You can also 

load a normal map (using the next option) for better results.

• Custom Normal Map: elect this to load a custom normals map into the Custom Texture field. This can 

also be a bump map in a Normalizer shader.

A very common use for layer-specific Bump channels is for glitter in metallic car lacquer. The reflective 

particles are simulated using a very small Noise Texture.

Metallic glitter and scratches were created using separate Noise shaders 

in both reflection layers

Strength

Use this value to define the strength of the bump/normal mapping. 

For details, see Strength (Normal Channel) and Strength (Bump Channel).

MIP Falloff

Used with Custom Bump Map. Enabling this option will reduce the bump mapping the farther away it is from 

the camera (see also MIP Falloff).

Method

Used with Custom Normal Map. Use this setting to define the coordinate system for the Normals map. Details 

can be found under Method.

Use these settings to define which axis should have which color, with a Custom Normal Map:

• Flip X (Red)

• Flip Y (Green)

• Flip Z (Blue)

• Swap Y & Z (Y up)

See also the Swap Y & Z (Y up) description under the Normal Channel.

Layer Color

This menu’s settings serve as a type of color filter for the reflections. 
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The layer color and the color from the surface’s Color channel will be added. This method lets you use a 

black-and-white texture to define where reflections should take place (white = yes; black = no).

This is also the color you should use if you want to create colored metal surfaces.

The textures from the Layer Color menu. White produces total reflection, 

black shows the Color channel’s color.

• Color: Defines the layer filter color. The default color is white, which allow reflections without having to 

modify the color.

• Brightness

See Defining Color and Brightness Values.

• Texture

See Textures (Cineware Surfaces).

• Mix Mode

• Mix Strength

See Mix Mode and Mix Strength (Cineware Surfaces).

Layer Mask

This menu’s settings can be used to create an alpha channel for a layer that defines the visibility of the layer 

beneath it. White will not hide anything, black hides all, grayscale values hide accordingly.
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Color: This setting is used to define the color of the alpha. The default color is white, which allows reflections 

without having to modify the color. 

Layer Anisotropy

To create an anisotropic effect, set Type to Anisotropic and Roughness to a value greater than 0%. Also make 

sure that there is enough present in the environment to reflect. HDRI textures on a Sky object are well-suited 

for this.
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Re-projection

The scratches’ vector tangents, which define the scratch direction internally, can be projected onto an object 

in one of three ways:

• None: Vectors will be projected onto the object without modification

• Planar: Vectors will be scaled, rotated and moved

• Radial: Vectors will be curved circularly, e.g., to simulate the look of the disc in the image below. An image 

can be loaded into the Pattern field, Offset values can be increased, and Count can be varied to create all 

kinds of interesting spiral/symmetrical effects but the effect in the example below can only be created 

without using the Pattern setting.

Different surfaces for the cylinder heads and sides (Planar and Radial).
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Scale

Defines the size of the Pattern or Scratches selected.

Angle

Used to rotate the anisotropic microscopic scratches (and, if defined, the parallel ridges). The rotational axis is 

defined by the Offset U/V values.

Offset U, Offset V

Used to move the Pattern/Scratches in the U and V directions, respectively. For the effect on the disc in the 

image above, both values were set to 50%, which means that the rotational axis lies at the center of the 

circular scratches.

Count

When applying this setting, a Pattern should be selected first. The Count value then defines the number of 

“threads” that converge at the center defined by the Offset U/V settings.

Pattern

This setting can be used to create common anisotropic surfaces such as carbon, brushed metal, etc. In 

addition, textures can be used to create numerous other patterns.

• None: Linear scratches whose orientation will remain constant will be created.

• Circular, Box, Diagonal, Lattice, Custom, from left to right:
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Lattice and Box are well-suited for creating carbon fiber surfaces:

The fitting pattern can be used to create a carbon fiber surface.

Here, an additional reflective layer was added to the anisotropy layer

Texture

Instead of using a default pattern, you can also use a custom pattern. To do so, create a black texture with a 

white pattern on it.

Grayscale values will also be evaluated, whereby Max Angle will represent the scratches’ angle at white 

regions. Note that you will not see the difference if a scratch is rotated 180°.

The texture on the left produces the scratch pattern on the right (Max Angle set to 90°).
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Mirror

This option lets you mirror the Pattern in the U and or V directions (with the exception of Custom patterns).

Scratches

Besides anisotropic microscopic scratches that can uniformly deform specular highlights/reflections, 

additional, even larger scratches (ridges) can also be defined. There are primary ridges that run parallel to the 

microscopic scratches and secondary ridges (these make less sense in conjunction with Re-projection Radial) 

that run in a perpendicular direction. Both ridge types can be applied simultaneously, as shown at the top right 

of the image below.

Primary and secondary scratches in Planar and Radial modes.

Anisotropy

Use this value to define the overall strength of the anisotropy effect. A value of 0% will disable the effect.

Orientation

This setting regulates a property that does not actually exist in the real world: it rotates the vector tangent 

scratches mentioned above. Its effect is to change the reflective behavior. This makes it possible to fine-tune 

the anisotropy effect without having to change the position of the light source.
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Orientation values. Note the changes at the marked locations.

Primary Amplitude, Secondary Amplitude

These values are used to define the ridge depth. Note that you can also enter values in excess of 100% to 

create very deep ridges.

Small and large values for amplitude, scale and length.
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Primary Scale, Secondary Scale

Used to define the ridge width.

Primary Length, Secondary Length

Used to define the ridge length. Very high values lead to concentric (radial) or long ridges with a uniform depth 

(Planar), very small values lead to very short ridges.

Primary Attenuation, Secondary Attenuation

Layer Cloth

Cineware has its own cloth mode - Irawan (Woven Cloth) - which can be selected in the Type menu.

Cloth is most often made of yarn (and this in turn from fibers) that are woven to create a certain pattern. They 

are made up of structured surfaces that produce characteristic anisotropic specular highlights/reflections. 

The Color surface channel can be disabled in conjunction with this mode.
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Preset

A selection of presets with pre-defined values for each respective weave pattern.

The following presets are available:

If a preset’s settings are changed, it will automatically switch to Custom mode.

Cloth Pattern

Woven cloth is made up of various warp and weft threads that are woven perpendicular to each other. When 

viewed close up, the Cineware weave patterns look like this:
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When viewed from a distance, these structures blend to form a characteristic cloth, which will appear in varied 

form depending on the angle from which it is viewed. In reality, warp and weft threads are made up of yarns 

having different reflective properties. For example, Polyester lining is made of very shiny elements that lie 

perpendicular to each other and have strong reflective properties.

Quality

Internally, the reflective behavior of the weave pattern is treated like a procedural texture with a strong noise 

property (analogous to the Noise shader, this would reflect a small scale value). When rendered, this texture 

will be evaluated using various small samples. The three quality levels available here are used to adjust the 

sample count. 

Notes:

– The effect this has on render quality is minor, but the effect on render time is huge, unless you use the 

Low option, designed for creating test renderings.

– The better the antialiasing settings, the less the Quality setting will affect render quality.

– The higher the quality, the sharper the cloth structure will be and the more the Moiré pattern is 

reduced.

Orientation

Use this setting to rotate the cloth structure (rotational axis U/V=0/0). For example, if a pant leg’s pattern lies 

perpendicular to the leg, this setting can be used to correct this state. Depending on the weave pattern, even 

small modifications (e.g., 10°) can have a major effect on the rendered result.

Scale U/Scale V 

Use these settings to vary the cloth structure in U and V directions. Normally, the scale values should be the 

same in both directions to correctly reproduce the cloth’s structure.

Note that very large values will produce correspondingly unrealistic-looking results.
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Increasing Scale values from left to right (polyester lining)

Highlights

The Highlights setting defines the ‘width’ of the specular highlight/reflection. Smaller values produce sharp, 

bright highlights on individual threads; larger values will soften the highlights accordingly (they will become 

correspondingly darker and more expansive).

Increasing Highlights values from left to right

Diffuse Warp/Diffuse Weft; Specular Warp/Specular Weft

These color settings can be used to define separate diffuse and specular colors for the warp and weft threads 

(see Cloth Pattern).

Make sure that the specular color is always brighter than the diffuse color and that they have a similar tone. A 

shader or bitmap can be loaded into the Texture field to define the color. Note that the texture will be multiplied 

with the respective color. If you only want to use the texture to define the color, then set the color for that 

setting to white.
ARCHICAD 24 Reference Guide 3490



Dialog Boxes User Interface Reference
Smoothing

This setting is for use with the Polyester and Silk Pattern options only. Generally speaking, the anisotropic 

specular highlight becomes more blurred - but brighter - with increasing values.

Increasing Smoothing values from left to right

Scattering - Uniform

This setting defines the overall specular/reflection strength. The larger the value, the brighter/more reflective 

the cloth will be.

Scattering - Forward

This setting can also be used to adjust specular/highlight strength - but larger values will produce 

correspondingly smaller effects. More importantly, this setting primarily affects the bright regions of the yarn’s 

specular highlight, while the darker regions will barely be affected.

Noise Strength

Defines the strength of the noise applied to the yarn’s color (the thread color will be brightened and darkened 

in other regions).

Noise Scale

Defines the scale of the noise applied to the yarn’s color. Note that very large values can be used, which will 

produce a correspondingly spotty cloth.

Various Noise Effects

Since just about every cloth has irregularities in its threads and its weave, Cineware offers three Noise 

methods that can be used to simulate such irregularities in cloth:

• Yarn color using Noise Strength

• Shape/orientation of the warp thread’s specular highlight using Yarn Noise (Warp)

• Shape/orientation of the weft thread’s specular highlight using Yarn Noise (Weft)
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Various Noise effects (insets: greatly enlarged view)

Yarn Noise (Warp)/Yarn Noise (Weft)

Define the strength with which the internal noise affects the shape and size of the specular highlight (see also 

image above). The larger the value, the greater the deviation from the parallel thread position and the more 

the look of the cloth will change - e.g., from a silky surface to a rough canvas-type surface.

Yarn Noise Scale

Defines the scale of the noise effect. The smaller the value, the faster the deviation from the optimal shape. 

Larger values will slow deviation correspondingly, exactly like scaling a Noise shader.
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Layer Fresnel

These settings define the degree to which the reflection will increase as the surface normals increase their 

angle to the surface, which is referred to as Fresnel reflection.

Make sure that the reflectance strength is greater than 0. Otherwise, no Fresnel effect will appear.

Fresnel

Select from:

• Dielectric for transparent surfaces such as glass, water, clear coat lacquer, etc.

• Conductor for opaque, reflective surfaces such as metal, minerals, etc.

Make sure that the Color channel is disabled for more realistic-looking results. Metal surfaces use reflections 

almost exclusively.

Preset

A series of presets (primarily for metals) is integrated that are based on real-world values. These cannot be 

modified individually using the Fresnel settings described below.
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Different surfaces will be made available for selection depending on the Fresnel mode. selected. Select 

Custom if you want to modify the settings yourself.

Note that the Conductor presets will affect the internal color system (the Layer Color should be 100% white!).
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A selection of Conductor presets

Strength

The Strength slider can be used to seamlessly move from reflection (0%) to full Fresnel reflection (100%).

IOR

The IOR is mentioned mainly in conjunction with refractive light effects, but it is also a measure for the angle 

of incidence for a surface’s light reflections (regardless if it’s transparent or opaque). As you can see in the 

images above, low values cause the surface to reflect almost exclusively in regions at which the camera’s 

angle of view is extremely low. Larger values cause the reflection to move correspondingly more to the frontal 

regions.
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The Conductor mode behaves similarly but the reflections are generally much more pronounced. (However, 

the increase in reflection that corresponds to the increased IOR is not linear, because it is also affected by the 

Absorption value; it is recommended that you use the preset values to achieve a higher degree of realism)

Invert

Enable this option to invert the Fresnel reflection. Example (on a sphere): the maximum reflection that is 

normally at the sphere’s center will be switched to its edges.

Opaque

In some cases you might want to prevent the Fresnel effect of neighboring surfaces from affecting a given 

object. In this image, a reflective surface with an alpha map lies on top of a red, diffuse layer. The Opaque 

option is disabled at the left: note how the red color from the underlying layer shines through while it is blocked 

on the right side of the image where the Opaque option is enabled.

Absorption

This setting is only available for the Conductor mode. Increasing values will produce correspondingly stronger 

overall reflections. This setting can be used to fine-tune the degree of reflection.

The Absorption effect in conjunction with Roughness (IOR = 2.97)
ARCHICAD 24 Reference Guide 3496



Dialog Boxes User Interface Reference
Layer Sampling

Sampling Subdivisions

This setting is designed for use with the Standard Renderer only (not the Physical Renderer). It can be used to 

define the quality of matte reflections.

Larger values will slow rendering and increase quality correspondingly.

Clamp Secondary

A reflected HDR image/sky can produce extremely bright points (fireflies) on a third object - i.e., a reflection of 

a reflection. To prevent the sampling settings from being increased dramatically, this setting can be used to 

limit the intensity of this reflection. The higher the value, the more the intensity of the reflection will be 

restricted.

Cutoff

This is a threshold value that defines the degree to which weak reflections will be calculated, if at all. Let’s say 

you have a project with numerous reflective objects. An object at the rear of the image that is reflected in a 

small object near the front can be omitted because its role in the overall image is so small. The smaller this 

value is, the more reflections will be ignored.

The image below is an example of how this setting can be applied (the very bright HDR image helps make the 

effect more pronounced). A sphere with a Fresnel reflection reflects a HDRI sky. The Cutoff value on the left is 

too large; the corrected value is on the right.

If the effect at the left takes place, then the Cutoff value needs to be reduced

Exit Color

The Reflection Depth PhotoRendering setting (Options/General Options) defines the number of reflections 

that should take place. For example, if you have two mirrors facing each other, this setting can be used to limit 

the number of reflections that take place. Otherwise an endless number of reflections would be rendered with 

a more-or-less endless amount of render time. 

See Reflection Depth.

The Exit Color setting defines the color the reflection should assume in the end. In previous versions of 

Cineware, this was black by default. However, as you can see in the image below, this produced unwanted 

black spots. This can be avoided if a fitting color is defined for the last reflection, as seen below.
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A fitting exit color is used to create a realistic-looking result without increasing the diffuse depth

Distance Dim/Distance/Falloff

Left: Distance Dim disabled, Right: Distance Dim enabled

Distance Dim can be used to omit objects from a surface’s reflection depending on their distance from the 

surface. 

• If Distance Dim is disabled, all objects will be reflected. 

• If enabled, the Distance value defines the distance at which an object will no longer be reflected. 

• The reflection falloff up to the Distance value is defined using the Falloff value. A value of 0 produces a 

linear falloff; other values produce the effects shown in the example above.

The reflection of the Sky object was disabled because it is considered to be an endless distance away.

Distant Color

For this setting, imagine a sphere with a Distance radius around the reflective object. This sphere’s color is 

reflected when the reflection samples are longer than the Distance value defined. Normally, black would be 

the correct color in this case because it would prevent anything from being reflected. Other colors can be used 

depending on the intended result.

*Transparency*

The * Transparency * layer will be added when the Transparency channel is enabled.
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This page contains reflection settings that let you control the Total Inner Reflection’s reflective properties.

The Total Inner Reflection is also part of the Reflectance channel;

the Roughness was increased on the right

Normally, these settings do not have to be modified. If you’re not trying to achieve a very unusual effect, these 

settings can be left as they are.

Note: The Total Inner Reflection must be enabled in the Transparency channel and Refraction should be 

set to 0.

See Total Internal Reflection.
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Environment (Cineware Surface Channel)

The Environment page uses a texture to simulate reflection. Here, in contrast to the other pages, the Color 

and Texture are multiplied by the Mix mode instead of being added.

So why would you want to use the environment property instead of Reflectance? One reason is that your 

scene may not have enough objects to produce good results when reflected. Another reason is that the 

Environment property renders more quickly than the Reflectance property.

Reflections using the environment property only.

Note: If you use the Environment channel in conjunction with the Reflectance channel, make sure that the 

Reflectance channel’s Additive option is enabled. Otherwise the Environment channel will not be visible.
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Watch the Video

Color and Brightness

See Defining Color and Brightness Values.

Texture

See Textures (Cineware Surfaces).

Mix Mode and Mix Strength

For the Environment channel, the default Mix Mode is Multiply.

See Mix Mode and Mix Strength (Cineware Surfaces).

Tiles X/Tiles Y

The environment property is independent of the projection type of the surface. The environment is always 

placed spherically around the object. Use Tiles X and Tiles Y to set the number of tiles in the X and Y 

directions.
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Exclusive

If this option is enabled, the environment reflections will only appear in places where there are no real 

reflections produced by the Reflectance channel.

Left: Exclusive disabled, right: Exclusive enabled
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Fog (Cineware Surface Channel)

These parameters enable you to simulate fog or gas clouds. Objects with such surfaces are translucent, but 

weaken the light that shines through them according to their density.

Use fog surfaces with closed objects only. Fog is a volume effect applied to the inside of an object.

Color and Brightness

See Defining Color and Brightness Values.

See also the discussion of Fog color below.

Distance

Light rays weaken as the pass through the fog. You can control this weakening with Distance. The larger this 

value, the thinner the fog. Distance defines how far a light ray can pass through the fog.

You can color the fog and this also affects its visibility. The further you look into the fog, the less the objects 

are visible and the more the fog color becomes visible. The fog color therefore also depends on the Distance 

value.

If you choose, say, a Distance of 500 units, a light ray of originally 100% intensity will have an intensity of 50% 

after a distance of 250 units and is extinguished completely after a further 250 units. The shorter the distance, 

the thicker the fog appears. In addition to this effect, after 250 units, half the fog color is added to the light and 

after 500 units, the full fog color is added.
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Bump (Cineware Surface Channel)

The settings on this page enable you to simulate bumps.

Note: In contrast, the Displacement channel uses “real” bumps. (See Displacement (Cineware Surface 

Channel).)

A surface has a uniform brightness. However, if you use a bump map for the same surface, the program 

interprets the brightness values of the picture as height values for the surface.

These height values are converted into a profile, whose height affects the inclination of the normal vectors. 

Although the surface is actually smooth, through the change in the normal vectors an apparently three-

dimensional surface with a bump-like structure is created at render time.

You must use a texture with this channel. It is only from the grayscales in this image that the bump map (a 

height or relief map) is calculated.

See Textures (Cineware Surfaces).
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Strength

The strength of the bumps. The higher the value, the rougher the surface. If you choose negative values, this 

reverses the effect of the bump map — bright pixels then cause the surface to indent while darker pixels 

elevate the height of the surface.

You can enter values much higher than 100%. High values are especially useful when using MIP or SAT 

mapping, because these interpolation types tend to flatten the surface slightly.

See Special Settings for Image Textures (Cineware Surfaces).

Parallax Settings

Parallax mapping provides approximately the same quality as subpolygon displacements but without having 

to subdivide the object internally. This reduces render times dramatically. Internally, Parallax mapping “bends” 

the UV coordinates to feign elevation on a surface. The color texture is distorted in a manner that makes its 

perspective distortion appear to be correct (e.g., the black stripes at the right the image below).
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Imagine Strength and Parallax Offset as separate sliders: Strength defines the shading based on the bump 

effect and Parallax Offset calculates the texture distortion. The best results can be achieved when both 

settings are defined, i.e., bump and Parallax mapping are implemented simultaneously.

Parallax Offset

Use this setting to define the strength of the effect, i.e., the degree with which the UV coordinates should be 

moved to feign an elevated structure. Make sure to adjust the Strength setting (it most often has to be 

increased; it cannot be equal to 0) to produce convincing results.

Negative values can also be used to reverse the effect: raised regions will be sunken and vice-versa.

If the value is set to 0, no Parallax Mapping will take place. Bump mapping will take place instead.

Parallax Samples

Normally, these values do not have to be modified. However, if Parallax Offset were set very high, artifacts 

can appear. To offset this, increase the Parallax Samples value. 

Higher values will result in correspondingly longer render times.

Watch the Video

MIP Falloff 

Enable MIP Falloff to enhance the MIP/SAT mapping effect for bump maps. This will reduce the strength of 

the bump map with increasing distance from the camera.
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Normal (Cineware Surface Channel)

This surface channel produces a virtual surface irregularity that is lit realistically. 

This entails technique called Normal Mapping (as opposed to Bump mapping). Normal mapping makes it 

possible to give a low-poly object (an object with a low level of detail) a detailed, seemingly structured surface, 

resulting in low render times.

• Bump mapping uses a grayscale bitmap to generate height data. 

• Normal mapping uses an RGB texture with coded Normal orientation (the Normals can be oriented in 

various directions).

You can create Normal textures with the help of the Normalizer shader (which can load normal color textures, 

usually bump textures.

The rendered result will very much resemble the original high-poly object.

Left, the original object rendered with sub-polygon displacement;

right, the result using a Normal texture
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Strength

Regulates the strength of the Normal mapping. Do not use very high values because the effect will be 

increasingly unrealistic.

Basically, the higher the value used, the more perpendicular the view to the surface must be to keep the look 

of the surface realistic.

Method

There are several methods with which Normal maps can be defined:

• Tangent: The most common method. The Normal orientation is defined with respect to the underlying 

surface. Such textures can be identified by their mostly light blue or light green coloring; these are the 

areas in which the Normals are oriented perpendicularly to the surface.

• Object: Uses the object’s coordinate system to code Normal orientation. Such textures emit, for the most 

part, in all colors of the rainbow.

• World: Uses the world coordinate system to code Normal orientation. These textures emit in all colors of 

the rainbow as well.

When selecting a method, you must know which method was used to create the Normal texture. This same 

method should be defined here.

Note: The Normalizer shader uses Tangents.

Flip X (Red)/Flip Y (Green)/Flip Z (Blue)

Swap Y & Z (Y up)

Since no standard method of creation of Normal textures exists, each application pretty much does it as it 

wishes: Sometimes the color component for the Y-orientation is green, sometimes blue. In order to assure 

maximum compatibility, these settings let you switch all color components.

The following rule of thumb applies to the most common method, Tangent:
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• If the Normal texture is mostly light green, activate Swap Y & Z (Y up).

• If the Normal texture is mostly light blue, deactivate Swap Y & Z (Y up).
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Alpha (Cineware Surface Channel)

An alpha channel enables you to achieve localized texture invisibility. The alpha channel uses an image to 

mask out areas of the surface, allowing any background to show through. This is useful for faking detail in 3D. 

The idea is to define areas of the surface that effectively become non-existent so that any underlying surfaces 

or objects show through.

Note: When rendering bitmap images, make sure to use the Physical Renderer.

If you notice black areas when rendering objects that have multiple alpha surfaces, increase the Ray Depth 

value on the Options page of the render settings.

See Ray Depth.

If you apply a surface having an Alpha channel to an object that has no underlying surface, the object will be 

non-existent at the points where the alpha would allow the underlying surface to show through.
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Alpha Channel and Antialiasing Filter

Depending on the Filter Antialias settings, the Alpha channel can end up being smoothed as well.

See Filter.

An Alpha texture can also contain a grayscale gradient that can be used for blending.

Color

You can use clip mapping to mask particular areas with a Color value. Using this method, you pick the color 

from the selected image that you wish to become transparent. The downside is that often the areas you wish 

to become transparent contain several colors and the resulting alpha can leave a seam around the object. 

However, by setting the Delta color (see below), you can define by how much the color may deviate; this can 

help to reduce the seam.

Delta

Clipping is often attempted with texture images that are antialiased; this produces a bright border around an 

object caused by the antialiasing of colors between the main texture and the alpha color; you can remove this 

border by adjusting the deviation (delta) color.

Use alpha channels built in to the texture to mask areas softly and more accurately.

See Image Alpha below.

Invert

Enabling the Invert option will invert the effect of the Alpha channel. All black areas of the alpha image will 

remain visible and the white areas will be masked.

Soft

This enables you to fade textures and surfaces from one to another, which gives you even more ways of 

creating realistic-looking objects. With Soft enabled (the default setting), the Color and Delta settings lose 

their meaning. The texture map is now used to decide which ranges should be faded. A white texture pixel in 

the image means that here the surface is to be 100% opaque. If the texture pixel is black, the underlying 

surface shines through 100%.

Image Alpha

With Image Alpha enabled, you can use any existing alpha channel of the loaded image. Alpha channels of 

the TIF, TGA, PICT, PNG, and Photoshop PSD. If no alpha channel is present in the image, the Image Alpha 

option will be ignored. Use the Invert function to invert the alpha channel without having to rework the texture 

in your image editor.

Pre-multiplied

Enable this option if you are using a texture with a pre-multiplied alpha channel. Certain graphics applications 

only produce this type of alpha channel.
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Glow (Cineware Surface Channel)

This page enables you to create a soft glow.

Glow is a post effect. It will take place only if you also turn on Object Glow in the Rendering Settings dialog. 

See Object Glow.

Glows cannot be seen through transparent objects, nor in reflections. The glow you specify here does not act 

as a light; other parts of the scene will not be lit by the glow, nor will any shadows be cast. Glows are restricted 

to a maximum image resolution of 4,000 x 4,000 pixels.

Watch the Video

Color and Brightness

See Defining Color and Brightness Values.
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Inner Strength/Outer Strength

Inner Strength specifies the intensity of the glow over the surface; Outer Strength is the intensity of the glow at 

the edges.

Radius

The Radius determines how far the glow (either the inner or the outer) extends from the surface. This value is 

rendered relative to the distance of the object from the camera. The further away the object is, the smaller the 

glow, and vice versa.

Random

If a random percentage is defined, the intensity of the glow in each animation frame is increased and 

decreased in a random pattern, as follows:

0%: No change

100%: Maximum change

Frequency

Frequency specifies how often the glow radius changes. The amplitude of the change is given by the Random 

value.

1Hz: The glow reaches a new random value after 1 second

25Hz: The glow has a new value for each frame (for 25 fps), which causes a flicker

Use Surface Color

If Use Surface Color is enabled, the glow is calculated on the basis of the surface color rather than the color 

specified here.

If the option is disabled, the object and glow colors are mixed. For example, green objects will appear 

yellowish under a red glow.
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Displacement (Cineware Surface Channel)

Displacement is similar to Bump, the difference being that here the object is actually (not just apparently) 

deformed. This difference is best seen at object edges.

In this object: the left half of the sphere uses bump mapping, while the right half uses displacement mapping. 

(See also Bump (Cineware Surface Channel).)
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Strength

This control allows you to adjust the maximum displacement defined by the Height setting (the Strength and 

Height values will be multiplied together to control the maximum displacement).

Height

Defines the height of the displacement, which can be modified by Strength value.

Type

• Intensity: The displacement takes place in the positive direction. Black parts in the displacement map 

produce no displacement, white parts produce maximum displacement.
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• Intensity (Centered): The displacement can take place in both positive and negative directions. A gray 

value of 50% results in no displacement. White produces maximum positive displacement, while black 

produces maximum negative displacement.

• Red / Green: The displacement can take place in the negative or positive direction according to the red 

and green values in the texture. Green values raise the displacement, red values lower the displacement. 

A black color results in no displacement, it is purely the red and green components that control the 

displacement. A pure green (RGB: 0,255,0) and a pure red (RGB 255,0,0) lead to maximum displacement 

in the positive and negative directions respectively.

• RGB (XYZ Local)/RGB (XYZ World)

These modes control the displacement spatially according to the texture’s RGB components. Depending on 

the mode selected, different coordinate systems will be used for deformation. 

The components define the following directions:

– Red: X

– Green: Y

– Blue: Z

Texture

Here an image texture or a 2D shader can be defined. 

See Textures (Cineware Surfaces).

Sub-Polygon Displacement

Check to activate Sub-Polygon Displacement (SPD).

In principle, SPD is similar to displacement: an object is deformed during rendering based on a texture’s 

grayscale palette or, in some modes, color palette. The trick lies in the object’s own internal, adjustable and 

relatively high subdivision, which allows for very detailed structures without having to actually subdivide the 

object permanently. In many cases, it is impossible to achieve the same degree of detail through modeling 

because too much memory would be required.

SPD adds to the render time, since rendering real geometry using sufficient memory is, with few exceptions, 

always faster than rendering virtual polygons.

SPD offers the following advantages:

• Small details can be rendered without having to permanently subdivide the object; permanent 

subdivisions can lead to problems such as file size that is too large or even impossible to manage.

• Details can be implemented faster using 2D textures instead of modeling.

• The quality of the rendered image is much better than using a texture map in the bump channel.
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Noise shaders shown with SPD

If the option is disabled, normal displacement will be used (only existing object points will be affected). 

Subdivision Level

This is where you determine the SPD subdivision. This goes for the entire object to which the surface has 

been applied. It can be well worth the trouble to delete the object’s hidden sides in order to reduce the number 

of surfaces that must be subdivided.

As is often the case, higher values produce better results but add to the render time.

Note that you may need to change this value for each face of an object (polygon): thus, you might use 

duplicated surfaces with different SPD parameters for different faces.

A 1m by 1m wall face needs less SPD value than a wall of 1m by 100 m.

For each existing polygon, the following polygon count will be calculated internally:

• Triangle: (2 to the power of Subdivision Level) * (2 to the power of Subdivision Level) / 2

• Quadrangle: (2 to the power of Subdivision Level) * (2 to the power of Subdivision Level)

• Cube: 6*256*256 = 393,216 polygons.

• Plane: 400*256*256 = 26,214,400 polygons.

Note:

– If several displacement surfaces are assigned to a given object, the maximum values will always be 

used.

– Example: An object has 2 different displacement surfaces on 2 selections. The first displacement 

surface has a subdivision level of 4 and the second 6. The entire object has a subdivision level of 6. 

Even though the entire object is subdivided, the displacement will only be applied to the defined 

selections.
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Two sphere primitives with a subdivision of 2, 4 and 8 (from bottom to top)

Round Geometry

Since SPD cannot calculate a normal Phong shading when it is applied, a special algorithm is used (if you 

enable this option) to ensure that the object is rounded before the SPD is rendered.
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This is specially designed to smooth surfaces that appear faceted after SPD rendering. Contours (polygon 

edges that have no adjoining polygons) remain unaffected if Round Contours is disabled.

Since this can also cause unexpected results, you can also disable the option.

Round Contour

If this option is enabled, contours (polygons that have at least one adjoining polygon missing) will also be 

rounded. Disable the option for objects whose contours would be adversely affected by the smoothing.

Round Contours enabled (left) and disabled (right)

Map Rounded Geometry

This option determines whether the rounded geometry should be used to define the texture coordinates. In 

most cases this will lead to more intuitive results. It can also lead to fewer artifacts.

Because the calculation can take up to 10% longer and in some cases the projection must be onto the non-

rounded geometry, you have the option to disable this feature.
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Map Resulting Geometry

Use this setting to define how the texture should be projected:

• Setting is active: Texture is projected before applying the Sub-Polygon Displacement.

• Setting is inactive: Texture is projected after applying the Sub-Polygon Displacement.

When mapping a cube you can clearly see how the colors are projected, depending on whether or not Map 

Resulting Geometry has been activated. In contrast, no difference can be seen when using UVW Mapping 

since SPDs do not change any UV coordinates.

Various projection effects:

Left: Map Resulting Geometry not active, right: Map Resulting Geometry active

3D-based shaders (e.g. noise, wood, rust, etc.) behave differently. Since they do not require UV coordinates, 

they can also be used to texture the edges of extreme displacements.

Keep Original Edges

If this option is enabled, hard Phong edges will remain hard. If the option is disabled, the edges will be 

rounded according to the Subdivision Level.

The effects of this option mostly occur only when the Round Geometry option is disabled.

Best Distribution

The enabled Best Distribution option changes the direction of the displacements towards the Phong edges. 

The closer a displacement is to the edge, the closer it is brought to this edge and the closer it follows the 

virtually rounded Phong normal.

In most cases, this setting will ensure a soft, uninterrupted transition of the SPD over phong edges.
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If Best Distribution is deactivated (which only makes sense if one of the intensity modes is set in the Type 

setting), each displacement will point up perpendicularly. This can lead to inflated displacements at the edges. 

This is a result of displacements that overlap edges and basically stand at a right angle to each other: the 

space between them will be filled. Activate this option if modeling cities that are viewed from a greater 

distance or, for example, castle stones.

Best Distribution enabled (left) and disabled (right)
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Grass (Cineware Surface Channel)

Use this surface channel to quickly and easily create realistic-looking grass.

Note: Use the parameters in Render Settings to activate and define grass rendering for the scene as a 

whole. See Grass (PhotoRendering Option).

Watch the Video

Color

This color gradient defines the color from the root (left) to the tip (right) of the grass blade.

See Defining Color and Brightness Values and Adjusting Gradient Parameters.

Color Texture

You can also control the color of grass using a texture. The texture is assigned to the grass using UVW 

mapping. The blades of grass will assume the color of the texture. The Mix Strength value can be used to 

seamlessly mix this effect with the gradient’s colors.

Density

Defines the number of blades of grass that should be dispersed across a given surface. Note that increasing 

the Density value will lengthen render times accordingly.

To be more exact: a value of 100% will generate 1 blade of grass per 5 surface units (on a surface that is 10 

cm square, this would be approximately 10 * 10 / 5 = 20 blades of grass).

Note: Because of the effect on render time, keep the density value low. To simulate a denser effect, try 

using thicker and longer blades instead of increasing the density value.
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Density Texture

A grayscale texture can be loaded here, which will define the grass density according to the texture’s 

grayscale values. The effect is a more realistic, blotchier appearance. The density will range from white 

regions having the most density to black regions having none.

Length/Width

Defines the maximum length (the default value generates a relatively short blade) and width (at the root of the 

tapered grass blade) of the individual blades of grass.

Crinkle

This parameter works similar to the Bend parameter (see below) and varies the shape of the individual blades 

of grass to make them look more realistic. The larger the value, the more blades will randomly crinkle multiple 

times in different directions.

Bend

The Bend parameter causes the blades of grass to bend. The higher the value, the more the blades of grass 

will randomly bend in one (!) direction (in contrast to the Crinkle parameter that randomly crinkles the blades 

multiple times).

Wetness

Use this setting to define the intensity of the specular light. The more intense the specular light, the wetter the 

grass appears to be.

Tips and Tricks for Using Grass 

• If you want to let grass grow on a plane with a green surface assigned to it, the Density setting, which can 

greatly influence render speed, can be reduced without affecting the overall look very much. 

• Grass that is thicker and longer than real-world grass helps simulate fuller growth without having to 

increase the Density value too much.

• If the grass surface is very far from the camera you should consider using a texture instead of grass (for 

much faster rendering).

• Use a 3D Density gradient within the camera space in order to let 3D grass gradually fade into a simple 

grass texture with distance. This is the best way to reduce the number of unnecessary 3D grass blades.
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Illumination (Cineware Surface Channel)

Use the Illumination channel in Surfaces to enable or disable the generation and reception of Global 

Illumination (GI) to and from this surface, and to control the strength of the caustics.

If, for example, you have a project with many transparent objects it would be very laborious to calculate 

caustics for each object. In this case, you can exclude particular surfaces from caustics calculation.

This page also defines the surface’s Global Illumination model setting (this greatly affects how highlights react 

to the light in the scene).

Each type of GI (generated and received) has its own adjustable values for Strength and Saturation.

In order for the Illumination surface channel to take effect, Global Illumination (GI) must be enabled in Render 

Settings. (See Global Illumination (Cineware).)

Generate GI

The Generate GI option affects the light created by the surface’s Luminance channel as well as any passed 

on by a given light source.

• Generate GI Strength: Define how strong a given surface will emit. 

• Generate GI Saturation: Fine-tune the saturation of textures used in generating GI.

Deactivate the Generate GI setting if a given surface should not have an effect on other objects.

In the image below, the original scene is at the left. A Spot light is used to illuminate the wall. The sphere has 

been assigned a surface with an active Luminance channel through which the wall is also illuminated in part 

when the scene is rendered using Global Illumination. 
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On the right, the Receive GI option for the sphere’s surface has been disabled. This means that the sphere 

will no longer receive light reflected from the wall. The sphere’s self-illumination remains unaffected.

Below, on the left, another original scene: the sphere generates and receives GI but the Saturation value for 

the Generate GI option was set to 0%. The scene’s brightness remains constant but the sphere’s color 

information in the light it reflects is no longer present.

Finally, below right, the image shows the result of a completely disabled Generate GI option for the sphere. 

The illumination within the sphere is still evident but this illumination no longer affects the rest of the scene. 

Only the reflected light from the Spot light remains.

If a surface contains an active Transparency channel it can also be used in combination with the Portal 

parameter. This can improve the quality of GI in many instances, for example when sunlight radiates through 

a window into a room. Transparent surfaces such as windows will be sampled more closely for light passing 

through it. 

Receive GI

Deactivate this option if a given surface should not receive brightness or color from other objects.

• Receive GI Strength: Define to what degree a given surface will receive color and brightness of other 

surfaces.

• Receive GI Saturation: Fine-tune the saturation of textures used for GI. Contrary to the previously 

described Saturation, this setting affects only the receiving of GI, not the radiation of it.
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Portal

Activating this option will define the object to which it is assigned as a Portal (make sure you also activate the 

Transparency channel).

Portals should be placed/fitted at the windows. When placed at windows with a crossbar frame, multiple 

Portals will increase overall quality.

Portals are usually single-polygon surfaces (e.g. primitive Plane) that are placed where light passes through 

relatively narrow openings. The direction in which the normals show is irrelevant. 

If you do not want to make corresponding changes to the light-reflecting object itself, you can influence the 

light passing through the Portal by changing the Color or Brightness settings in the Transparency channel.

Polygon Light

If this option is enabled, the way in which a (luminous) object is included in the GI calculation will be 

optimized. This option should be enabled if the object serves as an Area light.

Caustics

A caustic effect is a light effect made up of refracted and bundled light. A typical example of a caustic effect 

are the wavy lines at the bottom of a swimming pool. Caustics can also be seen in refractive surfaces, e.g. in 

a reflective ring. Surfaces that generate caustic effects must be either reflective or transparent.

Caustics generation and reception can be enabled or disabled separately. However, this is only relevant if 

Caustics has been enabled in the Render Settings and light sources with active caustics generation are 

present in the scene.

Samples and Radius both affect the quality of the effect. (See below.)

Generate Caustics

Enable this option to activate caustics generation for the active surface. Make sure that either the 

Transparency (for caustics that result from light breaking through water in a glass) or Reflectance (for caustics 

resulting from light reflecting from a curved object) surface channels is active.

Note: Only the Generate parameter is relevant when using volume caustics.

• Generate Caustics Strength: Use the slider to set the strength of the effect.

Receive Caustics

Enables the reception of surface caustics for the surface

• Receive Caustics Strength: Use the slider to set the strength of the effect.

Radius

Since caustics are comprised of photons, the brightness and detail of the effect is determined by the density of 

these photons. 
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The Radius value defines the radius around the image pixels in which the calculation will scan for photons. 

The larger the radius the softer, and less accurate the result will be. Smaller radii offer more detailed but also 

more grainy results. 

Caustics Samples

This defines the maximum number of photons within the Radius that are used to calculate the effect.

Generally speaking, the more Samples included in the calculation, the more exact the caustics effect will be. 

Larger Radius values require longer render times and result in blurred caustic effects.

To summarize: more samples per radius means a more accurate image. Increasing the Radius means more 

blur but a longer render time also.

Radius=1; individual photons can be seen as points of light because they are not interpolated together

Radius=10 Radius=100
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Textures (Cineware Surfaces)

Most Surface channels enable you to load a texture. Textures add realism to the surface, enabling you to 

simulate, for example, wood grain. 

For a texture, you can select either a shader or an image. 

Note: You can also choose Layer as a way to combine multiple shaders/images in the same channel. 

(See Using Layers to Combine Shaders (Cineware Surfaces).)

• An image file can be manually created or a photograph (e.g. of real dirt, grime or structured surfaces such 

as walls or floors). Numerous companies have specialized in creating just such textures for use in 3D. In 

many cases you can also use your own digital camera to create such images. The image below shows the 

difference between a surface with only a simple color and one with a bitmap graphic added.
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• Alternatively, shaders are tiny routines that mathematically calculate a pattern or a certain effect such as 

light entering and diffusing within an object. Shaders can also be used for the creation of a color gradient 

or to color correct a loaded image. Shaders can be used in many different ways and are used in some 

capacity in almost every surface.

An advantage of using shaders is that you don’t have to take into consideration a bitmap’s pixel resolution. 

A pattern generated by a shader looks good close up and doesn’t pixellate or blur as a bitmap image 

might. Therefore, it is recommended that you use shaders whenever possible.

To choose a texture or shader for a particular channel in Surfaces, enable the channel, then click the Texture 

chooser button and pick one.
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When loading a new image texture, browse a tree view of available textures plus previews, including info on 

their size in pixels.

Related Topics:

Shaders List (Cineware Surfaces)

Using Layers to Combine Shaders (Cineware Surfaces)

Texture Naming Conventions

Special Settings for Image Textures (Cineware Surfaces)

Watch the Video
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Special Settings for Image Textures (Cineware Surfaces)

Ensure Size/Ratio Compatibility When Using Multiple Images

• If the Surface channels use multiple images textures of varying sizes, you get immediate feedback and 

the chance to select a uniform texture size for all of them

• Similarly, if the image ratios vary, you are prompted to select a uniform texture ratio.

All image texture will be stretched to match this ratio. (This does not affect procedurals.) Check the “lock 

proportions” to maintain those proportions when further adjusting the Horizontal and Vertical size fields.

Image Parameters

If you have loaded an image as your texture, the following parameters can be set.
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Sampling Methods

Use Sampling to control how the texture’s pixels are interpolated.

The actual pixel resolution of an image is also scaled during rendering, which depends how close the object to 

which the surface is assigned will be to the camera when rendered. The options in the Sampling control 

define which algorithm should be used for interpolation.

• MIP: Default Sampling Method: MIP stands for multum in parvo, which is Latin for many things in a small 

place. MIP is the default sampling type, and generally results in very smooth blending. 

• SAT: Highest Quality Sampling Method: The SAT option is similar to the MIP option, but more exact. 

However, the SAT mapping method also requires about twelve times more memory and more time for its 

calculations. Furthermore, this method can only be applied to textures with a maximum size of 4000 x 
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4000 pixels. Therefore, MIP mapping should be used as the default mapping method and SAT mapping 

should only be used in instances where higher quality renderings are needed.

As a rule of thumb, use MIP mapping initially and switch over to SAT mapping if required. 

• MIP and SAT are the best choices for objects in still pictures that extend towards the horizon, such as 

floors.

• MIP and SAT mapping affect the render time. On the one hand, MIP and SAT mapping take slightly longer 

to render. On the other hand, you may be able to reduce the antialiasing setting.

• The downside to MIP and SAT mapping is that they require extra memory. MIP mapping needs an extra 

byte of memory per texture pixel, SAT mapping requires an extra 12 bytes per texture pixel.

Other Sampling Methods

• None: When Sampling is set to None, the original texture values are used without interpolation. This 

method is fast, but often produces poor results and in general is best avoided. Textures tend to look 

jagged with None interpolation. You can try to reduce the jags by using a high antialiasing setting.

• Circle sampling uses a circle of texture pixels (the ones surrounding the intermediate value). Textures that 

are enlarged at render time tend to look more natural with this type than with the None type. However, 

straight lines are problematic and tend to look frayed. In addition, the texture is very jagged near the 

horizon. Circle sampling is, however, a good choice for very small textures (e.g. 3 x 3 pixels), because it 

helps the pixels to blend softly.

Issues can, however, occur on objects that reach deep into 3D space. For example, a surface at the end 

of a horizon can end up looking very turbulent.

• Square uses a square of texture pixels (the ones surrounding the intermediate value). This leads to a 

softer transition between texture pixels than with None. The picture quality is good.

• Alias 1, Alias 2 and Alias 3 blend the texture more strongly than Circle and Square. Alias 3 blends the 

most, Alias 1 the least. Alias3 can give smoother results than Alias 1, but it also takes longer to calculate. 

However, even Alias 3 cannot prevent jags near the horizon.

Use Alpha Channel Only

An Alpha Channel is a transparency channel for a given pixel, rendering it black or white or a shade of gray in 

between; no RGB color channel is used. If you use Alpha Channel only, your image will be rendered in shades 

of gray.
ARCHICAD 24 Reference Guide 3533



Dialog Boxes User Interface Reference
Mirror on X axis/Mirror on Y axis

Apply a mirror effect to the image.

Exposure

Use this setting to adjust the brightness of HDRI as well as normal images.

Black Point/White Point

These points define the darkest and brightest points, respectively, and save this information to a histogram. If 

one of these points is subsequently moved, the dark and light levels will be scaled accordingly.
ARCHICAD 24 Reference Guide 3534



Dialog Boxes User Interface Reference
Mix Mode and Mix Strength (Cineware Surfaces)

Loaded textures can also interact with defined color values, e.g., to colorize a grayscale image or to affect the 

brightness of an image or shader. 

The texture is placed on top of the color.

Their interaction is created and adjusted via the Mix Mode and Mix Strength parameters, below the channel’s 

Texture chooser.

Use these parameters to mix the color and textures using one of four modes. 

The default mode for most channels is Normal. Not all channels have Mix settings.

• Normal: In normal mode, the Mix Strength sets the opacity of the texture.

For example:

– If Mix Strength is set to 100%, you will see the texture only (which is on top). 

– If Mix Strength is set to 70%, the result is 70% of the texture and 30% of the color. For example, if a 

texture pixel of RGB 255/0/0 (red) is used with a color value of RGB 255/255/0 (yellow) with the Mix 

Strength set to 50%, the resultant color is 255/128/0 (orange).

The remaining options, Add, Subtract and Multiply, mix the texture and color according to the defined Mix 

Strength.

• Add: In this mode, the texture’s RGB value is added to the color’s RGB value. Color channel values 

cannot exceed the maximum of RGB 255. So if a texture pixel of RGB 0/255/255 (cyan) is added to a 

color value of 255/255/0 (yellow), the result is 255/255/255 (white).

• Subtract: The color’s RGB value is subtracted from the texture’s RGB value. Thus if a texture pixel is 

RGB 255/255/255 (white) and the color value is 255/0/0 (red), subtracting with Mix Strength set to 100% 

gives the result 0/255/255 (cyan).
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• Multiply: The RGB value of the texture is multiplied by the RGB value of the color. For example RGB 255/

128/0 (orange) multiplied by RGB 0/255/0 (green) results in RGB 0/128/0 (dark green).

Mix Mode: From left to right: Normal, Add, Subtract, Multiply

Mix Strength: Top row = 100%, bottom row = 50%

Mix Strength

Mix Strength defines the mixing proportion between the texture and color or between the brightness and 

transparency (depending on which mode is selected) of the texture to be mixed.

Texture Blur Settings

The Blur Offset and Blur Scale options enable you to blur or sharpen the texture. 

• Blur Offset softens a texture.

• Blur Scale: a positive value increases the blur; a negative value weakens it. 

With floors, try a positive blur scale of about +20%. Floors tend to suffer most from perspective distortion, so 

they require special treatment.

From left to right: blur offset: 0 / 25 / 50 / 75 / 100
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Shaders List (Cineware Surfaces)

To choose a shader for a particular channel in Surfaces, enable the channel, then click the Texture chooser 

button and pick one.

These shaders are tiny applications, most of which offer their own specific settings for modification. 

In general, shaders are designed for a specific purpose, e.g. to depict a gradient or surface structure (wood, 

marble, etc.). Since shaders are made up of color information they can also be multiplied with other color or 

brightness values via the Mix Mode.

See Mix Mode and Mix Strength (Cineware Surfaces).

Once a shader has been selected, its settings can be accessed by clicking either on its name in the Texture 

setting or on its preview image below its name.

For a particular Surface channel, you can combine several shaders/textures in a layer, to achieve more 

nuanced effects.

See Using Layers to Combine Shaders (Cineware Surfaces).

The following is a list of shaders and shader groups with a brief explanation of their parameters:

Color

Gradient

Fresnel

Noise

Colorizer

Filter

Fusion

Layer

Posterizer

Procedural Shaders (Cineware Surfaces)

Shader Effects (Cineware Surfaces)

Sketch Shaders (Cineware Surfaces)

Additional Effects for Shader Layers/Folders (Cineware Surfaces)
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Color

Define a color using the color chooser.

The simplest of all shaders is the Color shader. Only the basic color fields are available for modification. This 

shader can of course be used within a Layer or Fusion shader in combination with other shaders or textures.

Gradient

Use the Gradient shader to create custom color transitions in different directions and with different patterns. 

• Use the Type pop-up to choose among several standard patterns.

• Most of the gradients can be rotated using the Angle value. 

• Turbulence: This setting distorts the transition between colors. Setting the Turbulence value to greater 

than 0% will activate the Octaves, Scale and Frequency options below i

– The Octaves value defines the detail depth of the Turbulence effect.

– The Scale value defines the density of the effect. 

The larger these values are, the more distortion will be created within the gradient.

– The Frequency value can be used when animating the gradient surface. The value entered here 

defines the speed with which the turbulence will be modified.

– Modifying the Seed value will result in the turbulence being recalculated. This lets multiple Gradient 

shaders be used in a single surface without generating identical results.

Normally a gradient is limited to the area of a texture tile, i.e. the area displayed in the preview image. If the 

surface with the gradient should be used on an object multiple times, the Cycle option should be enabled. 

This will cause the surface to continue around the object. 
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An example of this is shown in the image below. The example at the left shows a surface with a Gradient 

shader assigned to a simple Plane object. Since the gradient is restricted to the size of a single tile the 

gradient is repeated across the surface of the object. When the object is rendered (center), only a single 

gradient is shown that has simply been extended to the edge of the object. Activating the Cycle option will 

remedy this and the Gradient shader will cover the Plane object entirely (right).

In addition to the normal 2D gradients, 3D gradients are also available. 3D gradients cover an area in 3D 

space along a given axis and can be used to cover a 3D object.

• The coordinate system used is defined by the Space setting

• Cycle: Sometimes the needed texture map can become much larger than the original texture. Enable 

Cycle to tile the shader.

• For spherical or cylindrical gradients, the Radius value is used to define the volume. The Start and End 

values define the position and orientation of the 3D gradient.
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3D Gradient, of cylindrical type (cycle OFF)

3D Gradient, of linear type (cycle OFF)
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Fresnel

This shader can make numerous types of surfaces, especially glass, car finish, etc.) look more realistic.

The greater the angle at which you view a surface, the more reflective any surface becomes.

Left: a Fresnel shader in the Color Channel.

Right: a Fresnel shader in the Transparency Channel.

The Fresnel shader orients itself according to the angle of the surface to the viewer. The color from the left 

end of the gradient will dominate if the surface is viewed at an angle; the color from the right end of the 

gradient will dominate if the surface is viewed frontally.

This behavior reflects natural phenomena. A storefront window, for example, is barely noticeable when 

viewed frontally but looks like a mirrored surface when viewed from an angle. 

Although the Fresnel shader can be used in any surface channel (the Reflectance channel is preferred), it 

does not affect the Bump or Displacement channels unless used as a secondary channel

• Use Bump: To make the shader affect not only geometry but the shadows on the surface as well, enable 

the Use Bump option. Bump refers to all surface characteristics that affect the Normals and thereby the 

object surface, i.e. the Bump and Normal channels.

Enable the Physical option to access additional options (IOR- Index of Refraction, Presets, and Invert) for 

fine-tuning the fresnel shader:

Noise

This shader creates a random pattern that can be used, for example, for sun surfaces and stone reliefs. The 

advantage of 3D noise is that you don’t have to worry about mapping or seams in the texture.

Noise is an integral component of any render system because it turns an otherwise far too smooth surface 

into a more or less randomly uneven surface (e.g. when used in the Bump channel).
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Below are examples of some Noise types available in the Noise Shader. Their respective effects are shown 

using Sub-Polygon Displacement (see Sub-Polygon Displacement, in the Displacement channel).
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On the left is the Noise Shader as a normal grayscale image; on the right is the same Noise Shader on a 

sphere, with different Noise scales (Global Scale parameter).

Colorizer

Colorizer takes the value of an input channel and remaps it based on a gradient. This is very useful for 

colorizing shaders such as noise and for coloring grayscale gradients.

• Input: Use the Input pop-up to select which of the texture’s characteristics should be used when 

calculating the gradient. The Gradient will then be applied from left to right in accordance with the texture’s 

input intensity. 

If, for example, Input is set to Luminance, and the Colorizer contains a black-to-white gradient, all black 

areas of the texture will be assigned the colors at the left of the gradient. White areas will be assigned the 

color from the right side of the gradient.

• Cycle: If Cycle is enable, then a texture that contains Brightness or Intensity values greater than 100% 

will be re-calculated to a range of between 0% and 100%.
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You can also use a Colorize effect applied to shader layers or folders. 

See Additional Effects for Shader Layers/Folders (Cineware Surfaces).

Filter

The Filter shader filters another shader or a bitmap. 

Use the Filter shader to adjust a shader or bitmap’s brightness, contrast, hue, and saturation. You can also 

clip the color (to reduce the color range and increase the contrast).

The Filter shader is especially useful for adjusting HDRI textures.

You can also use a Filter effect applied to shader layers or folders. 

See Additional Effects for Shader Layers/Folders (Cineware Surfaces).

left = original

middle = hue edit, colorize on, and increased saturation

right = brightness and contrast adjusting

Low Clip/High Clip

These parameters clip or cut colors on two borders. The fastest way to understand how the parameters work 

is simply to try them.

Inverting the Low Clip and High Clip values can result in the texture being inverted. 
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Gradation Curves

Gradation curves can be used to precisely modify brightness and color regions of the original image. For 

example, brighten only the dark regions of an image; or brighter regions can be colored.

Gradation curves can be used to brighten, darken or color specific brightness regions

Use this curve (in addition to the RGB curves) to define the overall brightness. 

How the Curve Works

A gradation curve defines where a new brightness value will be assigned along the X axis. The curve applies 

a brightness value of 0 to the first third, i.e., black. The second third has a linear gradient that assigns 

proportional brightness values to the region. The last third has a maximum value, which means it appears 

white.
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The gradient curve is applied to the linear grayscale at the left. The result is shown on the right.

Intensity

Use this setting to define the strength of the Gradation Curve’s effect on the shader. A value of 0% will result 

in no effect, a value of 100% produces the maximum effect.

RGB

Use this curve to define the overall brightness.

This can also be done for individual color channels using the separate red, green and blue gradient curves. 

This makes it possible to color dark or bright regions only:

Dark regions in the center were colored red, and bright regions at the right were colored blue

Fusion

Fusion allows you to combine two textures with a mask using the blending modes standard in photo editing 

applications, as if they were layers. However, you can use the Layer shader (see below) to achieve the same 

effect.

Layer

See Using Layers to Combine Shaders (Cineware Surfaces).

Posterizer

Interesting effects can be achieved by allowing only certain brightness or color characteristics of a given 

texture to be shown. For example, any number of brightness bands can be arrayed next to one another.

The number of color or brightness bands is defined by the Levels value. The Filter Width value serves to 

soften any hard edges by blurring them slightly. 

The Posterizer shader can be used to remove unwanted color transitions or to create a comic look. In the 

example below, a Lumas shader in the Posterizer shader was applied to achieve the comic look.
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You can also use a Posterize effect applied to shader layers or folders. 

See Additional Effects for Shader Layers/Folders (Cineware Surfaces).
ARCHICAD 24 Reference Guide 3547



Dialog Boxes User Interface Reference
Procedural Shaders (Cineware Surfaces)

A procedural texture is a computer-generated image created using an algorithm intended to create a realistic 

representation of natural elements such as wood, water, or marble. 

Usually, the natural look of the rendered result is achieved by the usage of fractal noise and turbulence 

functions. These functions are used as a numerical representation of the “randomness” found in nature.
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Specific settings are available for each procedural shader. 

Brick Shader Displacement Mode

The Brick shader’s parameters include a Displacement Mode for achieving more realistic brick walls.

Various Displacement Settings

The Displacement settings have an effect when the shader is used in the Displacement channel (or to a lesser 

degree in the Bump channel). The Displacement channel generates the necessary grayscale values to 

achieve realistic-looking results.

The Displacement Mode can be used in combination with the Colorizer-Shader to generate random colors in 

brick shape. The Brick shader should have similar values to the Color channel with regard to brick size and 

grout.

Height Variation

Increase this value if the height of the bricks should vary randomly. A value of 0% will produce a perfectly level 

surface with only the grout lying deeper than the brick surface. The higher the value, the more varied the 

bricks’ heights will be.

Slope Intensity

If the bricks are too uniform with regard to their perpendicular height from the wall, this value can be used to 

add variation. The brick side defined in Slope Direction will then be raised. A value of 0% will produce a brick 

surface absolutely perpendicular to the wall. Increasing values will add correspondingly more variation.

Slope Direction

Use this setting to define the brick side that should be raised. If set to Random, a random edge or corner will 

be raised on each brick.

Seed

This setting can be used to add random distribution of the random values (Height Variation, Slope Direction).
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Shader Effects (Cineware Surfaces)

This group of shaders is found in the Shader Effects sub-menu of the Surface channel’s Texture pop-up:

These shaders are listed below with a brief explanation of their parameters.

Ambient Occlusion (Cineware Surface Channel)

ChanLum, Subsurface Scattering, Backlight

Distorter

Falloff

Lumas

Normal Direction

Normalizer

Pixel

Projector

Spectral

Thinfilm

Variation

Weathering

Ambient Occlusion (Cineware Surface Channel)

Ambient Occlusion for Cineware can be found in two locations in the interface:

• In Surfaces, as a channel shader (see screenshot above).

• In PhotoRender Settings (Detailed view), as a global effect and calculated throughout the entire scene in 

Render Settings.

See Ambient Occlusion (Cineware Effect).

AO options in both locations are identical.

 ChanLum, Subsurface Scattering, Backlight

These shaders all have to do with collecting light. Some surfaces have the ability to direct light inward, where 

it is dispersed (e.g. a wax candle or frosted glass).
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Normally, light can only shine directly onto the surface of an object and cannot, for example, be transmitted 

further from the illuminated back side of an object to its front that lies in a shadowed region. Several shaders 

are available to help remedy this in their own way. 

These shaders should be loaded into the Luminance channel. In this channel, the brightness these effects 

generate can be used as an illumination effect or added to the surface’s brightness.

ChanLum

From a defined distance from the object surface outward, the ChanLum shader observes the environment 

surrounding the object and samples light rays. This light is then used to brighten the surface of the object. 

This may not be realistic according to the world of physics but is often sufficiently accurate to simulate light 

that does not penetrate too deeply into a given surface.

Subsurface Scattering

This shader causes light to penetrate a surface where the light is dispersed. If the distance traveled by the 

light within the object is less than the defined value, the light can emerge again at a different location. This 

shader is well-suited for use on backlit objects. 

Here, a candle that is simply illuminated by a light from above, which is used to simulate the flame. This light 

source is only able to illuminate the surfaces at the top end of the candle. 
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Here is the same scene with a ChanLum shader added in the wax surface’s Luminance channel. You can see 

how the light now continues around the top edge of the candle to also affect the sides. It also looks as if the 

candlelight were seeping through the edge a little.

Here, a Subsurface Scattering shader was also added to the Luminance channel. The light now affects a 

large part of the top half of the candle but does not accentuate the edge very well. This type of lighting 

scenario is less suited for Subsurface Scattering because of the small angle that lies between the angle of 

view and the rays of light. 
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Here, the angle of view is increased by placing the light source behind the candle: now the Subsurface 

Scattering shader is well-suited: the light actually shines through the candle and the top edge is affected, as 

we wanted, thanks to the more intense light.

Backlight

Allows you to gather illumination from the back face of an object. This gives the ability to create translucency 

effects with backlighting, such as rice paper or a thin leaf lit from the opposite side complete with shadowing.

Algorithm: Use this setting to define the shading algorithm for the backlighting. 

• Internal is equivalent to the common Phong shading. 

• For Oren Nayar, see Model.

• Simple generates no shading at all, so that backlit objects are rendered uniformly bright. This is 

particularly well suited for very thin surfaces such as leaves, blades of grass, etc.
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Distorter

Distorter takes the value of an input channel and distorts it using the value from another texture channel.

Type: The distortion algorithm to be used.

– Directional: The value of the distortion channel is added to the sample coordinate of the texture.

– Bidirectional: The value of the distortion channel is added to the sample coordinate of the texture if the 

value is between 50-100% and is subtracted if the value is between 0-50%.

– Flow Field: The distortion value is determined by evaluating the flow direction of the distortion texture 

and then the flow direction vector is used to offset the sample coordinate of the texture.

Wrap: The Wrap function controls what happens to parts of the texture that have been distorted and now lie 

outside the UV map. These can be ignored (None), repeated (Cycle), cut off (Clamp) or mirrored (Seamless).

Amount: Global distortion amount. 100% means distortion values from 0 to 1 in UV and 0 to 10 in 3D.
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X/Y/Z: X is the distortion amount in U for 2D and X for 3D. Y is the distortion amount in V for 2D and Y for 3D. 

Z is the distortion amount in Z for 3D.

Delta: Delta is a scaling factor to use in sampling the texture for evaluating slope to be used in the bump 

channel. This allows you to get very sharp bump with minute detail that is not possible with the standard bump 

delta.

Step: Relative step size to be used in evaluating the flow direction in Flow Field distortion type.

Texture: This is the source image or shader to distort with the Distorter texture. You can bring in and affect 

any image or channel shader available to Cineware.

Distorter: The distorter texture is used to distort the texture defined by Texture (see above). The value of the 

distorter image or shader is used in the distortion algorithm to offset the sampling of the texture.

Falloff

Falloff calculates the falloff between a custom vector and the surface normal. When the vector is the same as 

the surface normal, the value is 1, and when it points completely away, the value is 0. Falloff then remaps the 

value using a gradient.

Same shader settings, only with different vectors

Direction [XYZ]: The vector to falloff from in 3D space.

Space: The space to calculate the falloff in.

• Object: The vector is specified in object coordinates and the falloff is affected by the object’s orientation 

(and by the orientation of the texture axis). In this way, the falloff sticks to the object as it changes 

rotations.
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• World: The vector is specified in world coordinates and is not affected by the object’s orientation. This is 

the most common setting because it allows the object to move and have the falloff stay oriented in a 

consistent direction.

• Camera: The vector is specified in coordinates relative to the orientation of the camera. In this way, up is 

always up (in the camera view, for example) regardless of camera or object orientation.

Use Bump: If enabled, the bump normal is used to calculate the falloff. If off then the bump normal is ignored.

Gradient: The gradient used by Falloff to remap the value.

Lumas

Lumas is an illumination shader that includes three specular highlights and the ability to simulate the 

anisotropic scratches that tend to produce elongated highlights in particular.

An anisotropic effect is the mirroring of a surface, caused by small, inconspicuous scratches. You have 

probably seen this effect often on metal surfaces that are somewhat older in the form of concentric scratches 

on the surface 
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Lumas is useful in combination with Fusion and other channel shaders or images.

• Diffuse Active

• Diffuse Color: Sets the base diffuse color of the surface.

• Diffuse Algorithm: Specifies which illumination model Lumas will use. 

– Internal is the standard Lambertian model

– Oren Nayar, which provides for a roughness variable allowing the user to go from simple surfaces (0 

Roughness, identical to Lambertian), to complex rough surface (1+ Roughness, which provides a 

matte surface, such as linen or dirt).

• Diffuse Roughness: Dictates how rough the Oren Nayar illumination model will be. Zero is no roughness 

while 100% or greater is very rough. Experimentation is required to fully understand this parameter. This 

option is only available if Oren Nayar is selected in the Algorithm drop-down list.

• Illumination: Scales the Color to produce attenuation in the illumination of the surface (this simply means 

it makes the color darker when the value is close to zero and brighter when the value is closer to 100% or 

above).

If you are using the Oren Nayar illumination algorithm, you may want to bump up the illumination by about 

10% to 20% because it renders darker usually. Appropriate values are between 0% to 200%.

• Contrast: Provides contrast for the result of the Color. Zero causes no effect, 0% - 100% causes standard 

contrast, above 100% causes a wrap contrast (the values that go above 100% wrap around to 0% again), 

negative values provide an inverse contrast to simulates surface that seem luminescent, such as silver. 

Appropriate values are -500% to 500%.

Specular Highlight Settings (Lumas Shader)

The specular highlights controlled in the Reflectance channel are added to the surface color. All three 

specular highlights share the same parameter set, which is described below.
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• Active: Use this checkbox to individually activate or deactivate each specular light.

• Color: Sets the base specular color for the specular component.

• Intensity: Scales the Color to produce attenuation in the specular reflection of the surface (this simply 

means it makes the color darker when the value is close to 0% and brighter when the value is closer to 

100% or above). The appropriate range is 0% - 1,000%.

• Size: Sets the size of the specular reflection. Appropriate value range for Size is 0.001% - 200%.

• Contrast: Provides contrast for the result of the specular sample color. Implements a standard contrast 

function. Appropriate values are 0% - 100%.

• Glare: Works with Intensity by using the edge falloff (multiplied by the Falloff scalar) to change the 

intensity of the specular reflection. This can be used to add a glare to the surface when a light is reflecting 

more on an edge or specular effects to reduce the specular reflection when a light causes a reflection 

closer to the edge. Appropriate values run between 0% - 200%.

• Falloff: Utilized to vary the falloff of the center of the object to the edge to affect the Glare intensity. 

Smaller values cause the specular reflection to reflect the Intensity value more, while larger values make 

the surface use the Glare scalar more. Experimentation is required to fully understand this parameter.

Anisotropy: Anisotropy is the property of being directionally dependent (as opposed to isotropy, which 

implies identical properties in all directions.)

Projection: The type of projection is used to define the anamorphic (disproportional) scaling of the specular 

highlights. It can also define the scratch direction to be used with the reflection and environment convolution 

groups. 

– Planar: A flat XY planar projection.

– Auto Planar: Automatically projects on a plane parallel to the current normal.

– Shrink Wrap: A spherical projection for scaling direction, but uses a separate algorithm for projecting 

the scratches.

– Radial Auto Planar: Automatically projects on a plane parallel to the current normal. 

– Radial Pattern Auto Planar: Creates a multi-origin radial scratch pattern that is parallel to the current 

normal. 

– Radial Planar: Creates a radial scratch pattern originating at the center of a plane parallel to the 

current normal.

– Radial Pattern Planar: Creates a multi-origin radial scratch pattern that is parallel to the current 

normal.

Projection Scale: Scales the scratch algorithms that have an actual pattern (Radial Pattern is the only current 

algorithm of this type to which scale applies).

X Roughness/Y Roughness: Scale the highlights in the X and Y directions defined by the Scratch Projection 

algorithm. The appropriate range is 0.1% to 10,000%. If the X & Y roughness are the same, the standard 

internal specular algorithm is used.

Specular 1/Specular 2/ Specular 3: These check boxes specify which specular channels will be affected by 

the anisotropic scratches.

Amplitude: Scales the effect of the scratch of the specular highlights. The higher the value, the more 

scratched the speculars will look. The appropriate range is 0% - 100%.

Scale: Scales the scratch pattern itself. This applies to all scratch algorithms.
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Length: Defines the scratch length in the space of the scratch pattern. Smoother milled surfaces would use a 

higher scratch length and rougher surfaces would use smaller values. The appropriate range is 1% - 1,000%.

Attenuation: Scales the amount of detail of the scratches based upon the samples, angle to the camera and 

the distance from the camera. The larger the values, the greater the attenuation, causing less scratching 

(better for animation); the smaller the value, the greater the detail (better for still images). The appropriate 

range is 0% - 1000%.

Normal Direction

This shader colors an object based on the direction of its surface normals. Surfaces whose normals point 

towards the rendering ray take Color 1, the other surfaces take Color 2.

Normalizer

Using the Normalizer shader (placed into the Normal channel) you can use common textures that were 

usually used in Bump maps in the Normal channel. The Normalizer evaluates the contrasts to ascertain the 

location of edges and uses this information to calculate a Normal map.
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As a reminder: Normal and Bump maps basically work the same. Information coded in RGB images affect an 

object’s (geometry) surface Normals when rendered and feign a detailed structure. Contrary to Bump maps, 

Normal maps can also “alter” the direction of the Normals, which makes it possible to create realistic effects 

(note the specular light on the bumps in the image below).

The texture shown at left was placed in the Bump channel and the Normal channel, respectively
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Pixel

The Pixel Shader creates a pixel-like distribution of a texture. 

Let’s say you want to project a texture made up of small areas of the same color onto a surface (e.g. a TFT 

display). You would want the individual pixels to also look good close up. This is where the Pixel Shader works 

its magic - it creates a fitting “pixel coarseness” without having to make changes to the original texture.

Top right: With Pixel Shader applied; bottom right: Without the Pixel Shader applied

Note: The Pixel Shader only works with 2D Shaders and textures. When using a Noise Shader, for 

example, the Space option should be set to UV (2D)

Projector

Projector allows you to alter the projection of a shader or image. This is useful for having different mappings in 

separate channels of a surface, especially when used in conjunction with other shaders such as Fusion. Note 

that 3D shaders do not work with Projector.
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Texture: This is the source image or shader to be projected. You can bring in and project any image or 2D 

channel shader available to Cineware.

Projection Types:

• Spherical 

• Cylindrical 

• Flat, Cubic 

• Frontal

• Shrink Wrapping 

• Spatial 

• UVW Mapping

Offset X/Offset Y: Offset of the 2D texture in UV.

Length X/Length Y: Scaling of the 2D texture in UV.

Tiles X/Tiles Y: Tiling of the 2D texture in UV.

Tile: If enabled, the 2D texture will tile in UV the number of times specified in the Tile X and Tile Y parameters.

Seamless: If Tile is enabled, then enabling Seamless causes the tiles to be mirrored so that they tile 

seamlessly.

Position (X/Y/X): Offset of the 3D texture space.

Size: Scaling of the 3D texture space.

Rotation (Heading/Pitch/Bank): Orientation of the 3D texture space.
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Spectral

The Spectral shader is ideal for prismatic or iridescent effects such as shiny pearls.

The calculation of this effect takes the camera perspective and the angle between the light source and surface 

into account. In general, the Spectral shader should be primarily used in a Specular layer (under Layer: Color) 

in the Reflectance channel.

Intensity: Controls the overall brightness of the color reflexes. A value of 0 means no effect at all, while bigger 

values result in brighter color reflexes. 
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Variation defines how many times the gradient is repeated within the defined range.

Variation set to 1 (left) and 2 (right)

Out of Range Type: In combination with the Variation parameter, Out Of Range Type controls if and how the 

gradient is repeated. Experiment with the Stop, Mirror and Tiling modes to see the effect. 

• With Stop, the gradient is applied once only and the last color is used for the outer areas that are out of 

range. 

• With Mirror, the gradient is mirrored when it is repeated to avoid seams. 

• With Tiling, the gradient is repeated according to the Variation value.

Spectrum: The Spectrum gradient defines the colors for the spectral reflexes.

Use CD Effect: If you enable this option, the shader is optimized for cylindrical surfaces and you can render 

wedge-shaped, prismatic color effects, such as those seen on CD surfaces.
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Width: Width defines how far the gradient spreads out.

Left: greater width; right: less width

Peak: Normally the entire rainbow colored spectrum is visible only if the angle between the light source and 

the camera forms a straight line. Increasing the Peak value allows you to generate a larger color spectrum.

W Factor: Defines the starting point of the prismatic effect, based on the center of the surface. A value of 1 

makes the gradient start from the exact center of the surface. Values above 1 offset the gradient away from 

the center, and values below 1 shift it more towards the center.

W Factor 1.5, 1 and 0.7

Diffuse Intensity: Diffuse Intensity controls the intensity of the spectral effect. Increasing the value results in 

overblown colors.
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Diffuse Variation: Scatters the spectral effect by bringing in random colors from the gradient.

Lesser and greater Diffuse Variation values

Front Side: Defines how the spectral gradient is projected onto the surface, with reference to the object 

coordinate system. If you can’t see the CD effect immediately, you probably need to adjust this parameter.
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Thinfilm

Use this shader to simulate a special physical effect referred to as “thin film” or “interference” effect. This 

effect occurs on very thin transparent surfaces - for example, as when all colors of the spectrum shimmer in 

surfaces of soap bubbles, oil film on water, mother of pearl.

To render realistic-looking results, you must create realistic lighting setups (e.g., by using a Physical Sky, 

luminous reflectors).

The Thinfilm shader will only work correctly if it is loaded into a Reflectance channel’s Texture field (preferably 

in a Beckmann or GGX layer) in the channel’s Layer Color menu. Specular layers should be disabled.

Tips:

– For soap bubbles, the Transparency channel should also be enabled and its Additive enabled.

– Make sure that suitable reflective objects are used; HDRI textures can be applied to a Sky Object or 

layers with luminous materials can be used.

– This effect can also be used on materials such as leather, rubber and metals, etc.

Watch the Video
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Variation

The Variation Shader allows for easy generation of “randomness” in your scene. 

The effect can be applied in a wide range of situations:

• Rock bed: The Variation Shader makes sure all your rocks look unique.

• Foliage looks more natural when all leaves have subtle variations.

• Setup the variation shader on a single car-paint material and apply it to all cars in a parking lot -- the 

shader automatically gives each car a custom paint job.

• Render books on a shelf: Apply the variation shader to the book cover material to make all the books 

appear different with minimal effort.

The Variation Shader is designed to work with regular objects and hierarchical tools (Curtain Wall, Stair, 

Railing). Generally speaking, the effect works best for objects where some variation is desired and it's not 

worth putting in a lot of effort to manually produce custom textures.

The Variation Shader works by generating random numbers based on a seed value which is automatically 

generated at render-time. The input texture's properties are then modulated based on the random numbers 

with user-defined intensity. The effects can be subtle, but also outright garish.

The shader is not restricted to use in the color slot; interesting effects can also be achieved by using the 

Variation Shader on bump maps.

It also allows for seeding based on the polygon face ID, which makes it ideal for working with dense meshes 

such as foliage without the need to split the leaves into separate objects.

Watch the Video

Seed Mode

The seed mode controls which data type the random numbers are based on. Depending on your choice of 

seed mode, you can achieve different types of effects.

Limitation: Note that adding or removing objects to the scene may alter the seed values. This can be an 

issue when rendering sequences, as the variation will appear to change randomly from frame to frame.
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• Seed: The seed value controls how random numbers are generated. Use this value to influence the 

generation of random numbers if you're not happy with the variation that's being produced.

• Object Variation

– Disabled: No variations will take place for different objects with the same Variation shader applied to 

them.

– Object Hierarchy: If the Variations shader is applied to an object that is part of a hierarchy: In this 

mode, the same color will be applied to all Child objects, i.e., it will not be varied. It will only be varied 

per hierarchy.

– Objects: Each object to which a shader is assigned (incl. objects in subordinate hierarchies) will be 

varied (as long as this is not prevented by one of the following settings).

– Parent: No variation will be applied to objects at the same hierarchical level and with the same 

Variation shader if they share a Parent object. Child objects will also not be varied.

• Polygon Variation

– Polygons: Texture is varied for each polygon.
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– Polygon step: It may occur that, for example, a tree’s leaves are created using a huge number of 

coherent polygon groups. For example, a leaf can consist of 6 polygons (to allow it to bend), which is 

in turn duplicated hundreds of times for a single tree. If the variation should be constant within one 6-

polygon group but varied for other 6-polygon groups, define number of polygons for the leaf (in this 

case 6) and the variation will occur in steps of 6 polygons. However, if only a single leaf has a different 

polygon count, this function will not work correctly! Set this value to 1 to create variations for each 

polygon.

– Disabled: Polygons will not be given different variations.

• Probability: Controls how likely it is that the shader will apply variation for any given object. At 100% all 

objects receive variation. At 50%, variation will be applied to only (approximately) half of the objects. 

When the shader decides to not apply variation, the input texture is returned unchanged.

• Global Mask: Controls the overall effect of variation based on an input texture.
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Color Variation

These settings define which textures should be used and which colors should randomly be mixed with them.

• Shaders

– Active

– Probability

– Texture: This is the main input. Plug any shader or texture in here.

• Secondary Texture. As an example, you could introduce a dead leaf texture to make an otherwise boring 

looking tree more interesting

– Secondary Texture Blend. Controls the maximum intensity at which the secondary texture will be 

applied. This value is randomized based on the seed value

– Secondary Texture Mode: Pick the blend mode with which the texture is applied. 

• Gradient: Define a gradient from which random colors will be picked and applied using the color mode 

below.
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– Gradient Blend: Controls the maximum intensity at which the gradient color will be applied. This value 

is randomized based on the seed value.

– Gradient Mode: Pick the blend mode with which the gradient is applied.

Note: In “Replace” mode, the Texture Blend setting has no effect; the texture is applied at 100% opacity. 

This can be useful in combination with the Probability parameter

– Random Color: Generates a random color and blends it with the input texture up to the specified 

value.

– Random Color Mode: Pick the blend mode with which the texture is applied. 

Grading Variation

The color grading options all work in a similar manner: The values control the maximum offsets to the grading 

parameters. E.g. with a value of 0.5 on the Contrast slider, the shader will randomly adjust the contrast 

between -0.5 and 0.5.
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• Contrast: Randomly adds or removes contrast up to the specified value.

• Gamma: Randomly varies the gamma up to the specified value.

• Invert: Randomly inverts the input texture up to the specified value.

• Hue: Randomly shifts the color hue up to the specified value. Use low values to create natural looking 

color variation. Higher values makes for very colorful effects.
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• Saturation: Randomly increases or decreases the color saturation up to the specified value. As with the 

Hue parameter, use low values to create more natural looking effects.

• Lightness: Randomly increases or decreases the color lightness up to the specified value.

UVW Coordinate Variation

The Variation shader is able to not only mix colors, but also to move and rotate UVW coordinates. This works 

best with tileable textures.

• UVW Shift: These settings define the maximum random movement of UVW coordinates left/right or up/

down. 

– UVW Flip X/Y: These options can be used to randomly mirror UVW coordinates vertically and/or 

horizontally. The random mirroring takes place prior to any random rotation defined using the following 

two options. 
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– UVW Rotate: This value defines the maximum random rotation (by default: 100% = 360°) in each 

direction for the UV coordinates (rotation center U, V: 0.5, 0.5, i.e., center of the UV tile. Contingent on 

the next setting, the rotation calculated here will then be set to a fixed, quantized value.

– UVW Quantize Rotation: Define here if the UVW coordinates should rotate steplessly (0 Degrees) or 

in steps of 45, 90 or 180 degrees. This is dependent on the UVW Rotate value: an even distribution of 

steps is only achieved at a value of 100%.

• UVW Scale: Use these values to randomly scale the UVW coordinates. The values entered here define 

the limits in the positive and negative directions: e.g., if the U coordinate is set to 0.5, the UV polygons will 

be varied between 0.5 and 1.5 times the horizontal U scale.

Options

• Clamp One: Ensures that no values higher than 1.0 are returned. When varying colors, it can happen that 

they turn out “too bright” (RGB values in excess of 255, 255, 255). This is often not desired and can be 

prevented by enabling this option. However, if you use HDRI images, this option should remain disabled.

Weathering

This Shader helps you lend a weathered look to your objects. You can weather a texture in a specific direction, 

which makes it look as if rain, wind or other factors affected the surface.

From left to right: Unchanged, completely weathered, partially weathered
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The shader’s Intensity controls the strength with which the texture is smudged, as you can see in the image 

below in which the value is increased from left to right from 20% (default value) to 50% and 100% 

respectively.

In addition to Intensity, you can also define how smooth the smudged texture should be. The higher the 

Smoothness value, the smoother the effect will be and the more realistic it will look. In the image below, the 

Smoothness is increased from left to right from 4 to 16 (default value) to 32.
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Finally, the Intensity shader’s brightness value can be used to define the degree of weathering. An image or 

a Shader can be used. In the image below, a Tiles Shader was used to create a horizontal line structure.
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Sketch Shaders (Cineware Surfaces)

Four Sketch shaders are available: Art, Cel, Hatch and Spots. 

• The Art shader uses a sphere to calculate the lighting and shading of a given object. Uniform shading can 

be achieved by varying the surface and color of the sphere.

• The Cel shader combines Manga and Anime shading styles with quantized color shading and freely 

definable color gradients.

• The Hatch shader applies a freely definable hatch pattern based on any texture you select.

• With the Spots shader, points (or any other element you want to use) shrink in correlation to the brightness 

of the surface. This is useful for creating halftone effects that are common on low-resolution prints.

Grid / Custom texture / Circle with Invert / With color

You can load Sketch shaders into any surface channel which accepts a texture, but generally they work best 

in the Luminance channel with all other channels such as Specular disabled. 

Antialiasing tip: The Art shader, Hatch shader and Spots shader each use a texture to shade the objects. 

For example, the Hatch shader uses a picture of a stroke or block of strokes to draw hatches onto the 

objects. Naturally you will want these texture strokes to look smooth and antialiased when rendered, 

which would usually mean setting the Antialiasing mode in PhotoRendering settings to Best.

See Antialiasing (Cineware).

However, to speed up rendering you can set the Antialiasing mode to Geometry instead of Best and blur the 

texture slightly using the texture’s Blur Offset and Blur Scaling values. Although Cineware will not antialias 

textures in Geometry mode, this blurring will produce smooth strokes that look antialiased, and the rendering 

will be much faster. Ideal for when you are using thousands of hatched lines.
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Additional Effects for Shader Layers/Folders (Cineware Surfaces)

The list of Effects (available only from a channel’s Layer control) allows you to add various effects to the layers 

or folders.

See Using Layers to Combine Shaders (Cineware Surfaces).

Most of these effects are based on other Cineware shaders. For example, the Distort effect offers parameters 

that you will also find in the Distorter shader. For descriptions of these inherited parameters, look up the 

corresponding shader in the reference guide.

Brightness / Contrast / Gamma, Hue / Saturation / Lightness / Clip Color

See Filter shader.

Posterize

See Posterizer shader.

Colorize

See Colorizer shader.

Clamp Color

The Low Clamp and High Clamp parameters cut off the color values at the given points.

Transform

Use these parameters to rotate shaders or textures and mirror them horizontally or vertically. You can also 

change the scale and position of the shaders or textures.
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Distort

This effect is a simplified Distorter shader that works exclusively with noise.

The Time Scale parameter allows you to animate the noise effect. To animate the noise, set the value higher 

than 0. The higher the value, the faster the noise will change. 

See Distorter shader.
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Using Layers to Combine Shaders (Cineware Surfaces)

The Layer shader lets you load multiple shaders or bitmaps into a surface’s Texture setting, which will then be 

rendered together.

You can stack shaders and bitmaps into layers and folders. You can define various blend strengths and 

modes. Alpha channels are supported. You can apply effects to individual layers or all layers.

To change the order of the layers, drag and drop them to their new positions.

You can also add folders or move images/shaders within the Layer shader itself.

Note: The order of the shaders defines the order in which they are applied to the surface.

Some shaders are available only within Layers.

See Additional Effects for Shader Layers/Folders (Cineware Surfaces).

However, you should be aware that the maximum number of parameters that can be used in a surface is 

1024.

See Limit on Number of Surface Parameters.

Add Shaders to a Channel Layer

You can add multiple shaders and textures to a particular surface channel. 

1. To get started, choose Layer from the channel’s Texture pop-up:

2. With the Layer item selected or open, click the Add Shader pop-up.
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3. In the appearing shader row, use the first pop-up to choose a particular shader.

4. Do this for each shader you want to add.

For each shader added to a Layer, you can adjust its Blend Mode and Blend Strength (see below).

Texture Blend Strength

Select a shader row within a Layer in a surface channel, and use the slider to adjust the shader’s Blend 

Strength.
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Texture Blend Mode

Select a shader row within a Layer in a surface channel, and click the second pop-up (with the Normal blend 

mode as the default) to access the Blend Mode definitions.

• Image/Alpha

– Invert Image: Inverts the image’s color values. Black regions are made white and vice versa. 

– Use Alpha: Toggles any existing alpha channel on or off.

– Invert Alpha: Invert the alpha channel, so transparent and solid areas are reversed. 

– Alpha from RGB: This option is made available only if Use Alpha has been activated in the same 

menu. Alpha from RGB generates an alpha channel using the grayscale values extracted from a given 
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bitmap’s RGB values. If the bitmap in question also contains an alpha channel, it will also be used 

when Alpha from RGB is active.

• Normal: The background pixel is completely covered by the blend pixel if the strength of blending is 

100%.

• Multiply: This mode multiples the background pixel by the blend pixel. Unless the blend pixel is white, the 

result will be darker than the background pixel.

• Screen: This is the opposite of the Multiply blend mode. The background pixel and blend pixel are both 

inverted, multiplied and then inverted again. This mode generally gives a result brighter than the 

background.

• Overlay: A combination of Screen and Multiply mode, depending on the background color.

• Hard Light: This mode works like Multiply mode and Screen mode at the same time. 50% brightness is 

neutral (nothing happens). Lighter values act like Screen, darker values act like Multiply.

• Soft Light: This is a combination of the Burn and Dodge modes. The Dodge mode is used for blend pixels 

greater than 50% brightness, the Burn mode is used for values below 50%.

• Dodge, Burn: The brightness value of the blend pixel is used to brighten (Dodge) or darken (Burn) the 

background pixel.

• Darken: The background and blend pixel are compared and the result is whichever is darker.

• Lighten: This is the same as darken except the result is whichever pixel is lighter.

• Add: One of the simplest blend modes: the background pixel and blend pixel are added together.

• Subtract: The background pixel and blend pixel are added together then white is subtracted (result = 

background color + blend color - 256).

• Difference: The background and blend pixels are subtracted from each other.

• Exclusion: This mode is the same as Difference mode except that it creates a softer effect.

• Hue, Saturation, Luminance: In these modes, the result is the hue, saturation or luminosity of the blend 

pixel applied to the background pixel.

• Levr: The value of the blend pixel is used to apply contrast to the background pixel.

Organize Shaders into Folders

If you have loaded multiple shaders or images into a surface’s Texture Layer, you can use Folders to group 

the shaders. Folders are available only within Layers.

• Click the Folder icon to create a new folder.
ARCHICAD 24 Reference Guide 3585



Dialog Boxes User Interface Reference
• Within the list of shaders on the right half of the dialog box (but not in the tree hierarchy at the left), select 

any shader, then drag it into the folder. You will see the corresponding hierarchy in the tree structure, too. 

You can use any number of folders or Layer shaders, and each can contain any number of shaders.

• To remove a shader from a folder or from a Layer shader within another Layer, select the shader and click 

the Move Shader Up One Level button.
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Detailed Cineware Settings

To access the full set of Cineware parameters, go to PhotoRendering Settings (Document > Creative 

Imaging). 

Select the Cineware engine, then check the Detailed Settings box. 

Use the compact view, or stretch the dialog box to see the full view, with a tree structure of all the settings on 

the left.

If you are not familiar with PhotoRendering parameters, the detailed view settings can be daunting. If so, the 

Basic Settings are for you. Uncheck the Detailed Settings box and return to Basic Settings, where a half-

dozen parameters are all you need to worry about, and pre-set scenes and environments enable you to create 

high-quality renderings very easily.

See Cineware Basic Settings.

Information on Detailed Cineware Settings is found in the following sections:

General Considerations When Using Detailed Settings

Navigating in the PhotoRendering Settings Palette

List of Detailed Cineware Settings
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General Considerations When Using Detailed Settings

The following are general considerations related to some of the Detailed parameters of Cineware Settings.

Physical vs. Standard Renderer

Optimize Rendering Time with “General Options”

Consider Global Illumination

Progressive Rendering Mode

Physical vs. Standard Renderer

By default, Cineware uses a rendering mode called “Standard”, which will give good results for most users.

The alternative is the Physical Renderer, which simulates the working of a physical camera and has 

corresponding parameters (e.g. shutter speed).

To activate Physical Renderer, check the Use Physical Renderer box in the Detailed Settings view of 

Cineware Settings.

Some considerations when choosing a Renderer mode (Standard vs. Physical):

• If you have a standard-sized building without blurry reflections: Use Standard render mode

• If you have a large, detailed model including a variety of surfaces with complex parameters, and/or many 

blurry reflections: Physical render mode will decrease rendering times for these operations

• When rendering bitmap objects, use the Physical renderer

Characteristics of the Physical Renderer

• Tends to create a grainy image, if the settings are not optimized

• Correctly depicts the following photographic effects:

– Rendered depth of field with corresponding blur effects 

– Vignetting (darkening towards the image edge) 

– Chromatic Aberration (color seams at edges)

• When rendering multiple, combined blur effects (blurry reflections/blurry transparency) the Physical 

Renderer is faster than the Standard renderer.

• Easier to set up: the Physical renderer does not use Min/Max Samples and Accuracy values in light and 

Surfaces

• Does not use Antialiasing
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• includes different RayTracing Engines to choose from: Physical (legacy), Embree (Turboboost), and 

Embree.

• Includes different rendering algorithms to choose from: Fixed/Adaptive and Progressive mode. Using the 

progressive mode, one can get a grainy but still realistic image immediately after pressing the render 

button (and after GI, if used), and thus the rendered image becomes progressively less grainy as 

rendering time passes. (See Progressive Rendering Mode.)

• Depth of Field works like a camera setting (F-stop). (In contrast, Depth of Field in the Standard renderer is 

a post effect.) This makes the Physical renderer preferable if: 

– you are using Textures with alpha effects and want to combine these with Depth of Field

– your model contains many transparent surfaces (this can look artificial if rendered as a post effect, as 

in the Standard renderer).

Drawbacks of the Physical Renderer

• The realistic simulation of physical effects requires more calculation power and more time. It does, 

however, offer several more settings (which offer great potential for optimization).

• Physical rendering does not work in conjunction with Specular lights or cylindrical lens; grass is rendered 

much more slowly.

Optimize Rendering Time with “General Options”

This list of options affect the rendering as a whole: if you uncheck an option here, it is disabled for the whole 

rendering model, regardless of what else you have set elsewhere. It is worth considering which of these can 

be turned off so as to minimize render time. For example, you can turn off all blurriness with a single click.
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Consider Global Illumination

Global Illumination (GI) is a sophisticated method for achieving realistic lighting effects in your model. The 

algorithm simulates the effects of not just direct light sources, but indirect light effects - that is, inter-reflections 

caused by light rays bouncing off surfaces.

With Cineware, you can achieve very high-quality renderings using Global Illumination. However, it can 

greatly increase render time. Two methods can be used in conjunction: Primary and Secondary methods.

See Primary and Secondary Method (Cineware Global Illumination).

Of the many GI-related parameters, the Diffuse Depth value can make a significant difference in rendering 

quality. It defines the number of times light reflects in a scene, i.e. how often a “ray of light” is reflected from 

surfaces. 

• The minimum Diffuse Depth value of 1 results in only a direct illumination via flat, light-emitting elements. 

This will be sufficient for most external scenes, with Physical Sky or HDRI Sky providing a significant light 

source.

• A Diffuse Depth value of 2 is required to achieve an indirect illumination. A minimum value of 2 will be 

required for interior scenes.

Watch the Video
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Progressive Rendering Mode

If you are using the Physical renderer, its three sampling settings include the Progressive option: after you 

start the rendering process, you get immediate basic feedback.Then, as time passes, the image is gradually 

fine-tuned.

This option, in turn, has three ways to set a limit on the render process:

• Infinite: The rendering continues indefinitely until you press Stop.

• Time Limit: The rendering process will stop after a defined time interval.

• Pass count: The rendering process will stop after a specified number of passes.

With Progressive Rendering, the rendering image goes through several progressive passes, while the image 

becomes visibly less grainy. By using the Infinite option, you may click to stop rendering after a certain time 

when you feel your image is already fine enough.

In fact, it takes far less than infinity to achieve a desirable result. After a certain number of render passes, it 

will be almost impossible to see any further changes, since the image is so finely rendered.
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Navigating in the PhotoRendering Settings Palette

To access the full set of Cineware parameters, go to PhotoRendering Settings (Cineware engine) and check 

the Detailed Settings box.

The appearing dialog box, in compact view, shows only one settings category at a time.

Click the tree view button to access a tree view of all the Settings:

Or stretch the dialog box wide to see the full tree structure as part of the dialog box:

Parameters are often sorted into groups. To be able to edit the full set of parameters for each setting (e.g. 

Sampling), make sure the setting’s checkbox is turned on. Then do one of the following:

• click the name of the setting in the tree list, or

• click the One Level Down icon for the setting in the parameter list.
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To return to the previous view of the Settings list, click the One Level Up icon.
ARCHICAD 24 Reference Guide 3593



Dialog Boxes User Interface Reference
List of Detailed Cineware Settings

The following sections describe the settings available on the Detailed view of the PhotoRendering Settings 

Palette (for the Cineware engine).

Light Adjustments (Cineware)

Shadow Casting (Cineware)

Environment: Physical Sky (Cineware)

Environment: HDRI Sky (Cineware)

Cineware Effects

Global Illumination (Cineware)

Physical Renderer (Cineware)

Spherical Camera (Cineware)

Stereo Rendering (Cineware)

The Options category contains the following three parameter groups:

General Options (Cineware)

Antialiasing (Cineware)

Grass (PhotoRendering Option)
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Light Adjustments (Cineware)

Use three sliders to set the intensity of three different types of light used in the rendering: Sunlight; Lamps; 

and Illuminating surfaces.

Each slider can override a particular light source intensity that is set elsewhere in the project.

• Sunlight. Can override the Sun’s intensity setting. The midpoint of the slider corresponds to 100 percent: 

this means that the rendering will use the sun intensity exactly corresponding to the Sun object’s intensity 

setting. Adjust the slider to increase or decrease the sun intensity relative to this setting.

Note: If you are using a Physical Sky as your Environment, then this Sun intensity slider affects the sun 

that is part of that Physical Sky setting. If you are using an HDRI image as your Environment, then this 

Sun intensity slider affects the ARCHICAD Sunlight settings.

See Cineware Basic Settings: Environment Panel.

• Lamps: Can override the Main Intensity settings (set in Lamp Settings) for all individual lamps placed in 

the project. The midpoint of the slider corresponds to 100 percent: this means that the rendering will use 

the lamp intensity exactly corresponding to the intensity set for lamp objects placed in the model.

See Light Color and Intensity for Lamp Tool Settings.

Note: These Rendering settings consider the settings that affect the 3D window, but the reverse is not 

true: the 3D Window does not consider what you adjust in Rendering settings. So a lamp that is turned off 

in the 3D window cannot be turned on in Rendering Settings.

• Illuminating Surfaces: This setting overrides the surface-level Luminance channel.

Note: All surfaces also have an Illumination channel, which affects Global Illumination. But the 

Illuminating Surfaces control in Photorendering Settings affects the Luminance only.
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Shadow Casting (Cineware)

Check this setting to enable Shadow Casting in your rendering. (If you leave it unchecked, the rendering will 

not generate any shadows.)

Use the controls below to define Shadow quality:

• By Light Settings means that the Shadow Casting setting for each individual placed light object (as 

defined on the Lamp Settings Light Parameters page) will be in effect in this Scene. (See also Shadow 

Casting.)

If you are not using Light Settings, use the following three settings to control the quality of your Area shadow:

Note: The following three parameters are relevant only if you are using the Standard renderer. They have 

no effect in Physical rendering mode!

• Minimum Samples

• Maximum Samples

• Accuracy

The more samples, the more homogeneous (less grainy) the rendering will be, and the longer it will take to 

render. Fewer samples, on the other hand, mean shorter render times.

Minimum Samples and Maximum Samples let you set many or few samples, as needed (as well as an 

interpolation between them).

Of course you could render a scene with the maximum number of samples possible, but this would not make 

sense: parts of the scene would only require a minimum amount of samples, and the scene would take much 

too long to render.

The Accuracy setting determines how (and how many) samples will be allotted in order to achieve the best 

result. In the most critical areas, Maximum Samples may be set to its highest value.
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The Accuracy setting has the most influence in critical areas, since high values lead to more samples being 

used. In less critical areas, the Minimum Samples value is applied.

If Minimum Samples=Maximum Samples, Accuracy will have no effect.

Follow these steps to achieve the optimal settings for your scene:

1. Find out where the critical areas in your scene are (grainy areas).

2. Set Minimum Samples and Maximum Samples to the same value and render the scene using Render 

Marquee Region.

3. Raise the Minimum Samples and Maximum Samples equally until you achieve a good result.

4. Lower Minimum Samples to 25% of the Maximum Samples value and set Accuracy to 50%.

5. Finally, raise the Accuracy setting until you have a result you are happy with.

Also, make a note of these rules of thumb:

• Quality can be improved the most by raising the Maximum Samples and Accuracy values. A 100% 

Accuracy will not do you much good in combination with a very low Maximum Samples value. 

• No matter which of the three settings you raise, render time will increase accordingly. 

Shadow Depth

Shadow Depth behaves analogous to the Reflection Depth. If a surface point lies in the shadow of another 

object this option will use additional shadow rays to check which shadows should be sent from the object 

surface in the direction of the light source.

The Shadow Depth setting defines the shadow depth with which visible shadow rays will be calculated. For 

example, if this value is reduced to 2 no shadows will be calculated for reflective, transparent or refractive 

rays.

The examples below were rendered with Shadow Depth values of 2, 4 and 8, respectively.
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Environment: Physical Sky (Cineware)

The Physical Sky is an entire constellation that includes multiple objects having properties (sun, weather, 

clouds, fog, rainbow, atmosphere). A Physical Sky provides both a background image and lighting effects. It is 

“smart” and the parameters are interconnected. 

Choose Physical Sky from the Sky Setup parameter.

Compositing

The following effects are on by default, and their respective parameters are defined in the weather presets. 

However, you can turn any of them off, or leave just one of them on, to achieve certain effects and/or optimize 

rendering time.

• Sky Visibility: If you turn this off, the Physical Sky parameters still affect the rendering, but you cannot see 

the sky itself. 

• Sky Luminance: You can turn on Sky Luminance with the other effects off: this will give you the light effect 

of the Physical Sky without anything else.

• Sky Reflection: If only Sky Reflection is on, then you can, for example, see the environment reflected on a 

glass building, without rendering the environment itself.

• Sky Refraction: Turn on/off the Physical Sky’s refraction effect.

Time and Location

Do one of the following:

• Use ARCHICAD Sun Position: Checking this box will reset the Time & Location according to the sun 

location. Use this to fine-tune the weather preset you have chosen to match the conditions at the project 

location.

See also Note on Sun Settings in ARCHICAD.

• Manually enter the Date/Time and Location (in geographic coordinates) that will affect your rendering 

scene.

Sun

The sun is an Area light source. The following parameters can be used to define the characteristics of the sun 

light source. These have no influence on the look of the sky, on the ARCHICAD project sun, or any Sun 

Object.

Use Warm Colors: This setting increases the “warm” colors in the sun.

Intensity: Defines the intensity of the sun. If, for example, your scene is over exposed due to strong surface 

reflections, adjusting this value can help.

Saturation Correction: Defines the sun’s color saturation. If you want white sunlight, enter a value of 0% 

here.
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Hue Correction: Depending on the value used, any color in the spectrum can be generated. Great for 

creating that extraterrestrial look.

Gamma Correction: Defines the sun’s gamma value. This value can be used to prevent over exposing a 

scene even if the Intensity value is too high. Animating the Gamma Correction parameter for day to night 

animations can help reduce the brightness of the noon sun.

Size Ratio: Defines the size of the visible sun. 

Note that this also has an effect on the Area shadows. If you want a hard sun shadow, enter a value of 0% 

here.

In the first picture below, a higher Sun Size Ratio causes the shadows to be softer, which corresponds more 

closely to diffuse lighting situations in real life.
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As Seen Intensity: Defines the visibility of the sun. Does not otherwise affect emitted light, etc. This 

parameter is dependent on the Intensity parameter. If Intensity is set to 0%, setting the As Seen Intensity to, 

for example, 1000% will not make the sun visible.

Use Custom Colors: Enable this option if you want to create a custom color using the color field below.

• The sun color will have no effect on 2D Clouds.

Lens flare: Enables or disables all lens effects.

• Glow Intensity: Lens glow and lens reflection. Defines the intensity of the lens glow. Set this value to 0% 

if you do not want any glow to be seen.

• Flare Intensity: Set this parameter’s value to 0% to disable the flare altogether. Otherwise you can enter 

a different value to define its intensity.

• Distance Scale: If you encounter problems with the light sources integrated into the sun or moon (e.g. if 

lens flare or lens glow are displayed incorrectly), simply reduce their distance using this setting.

Shadow

Density: Set Shadow density using the slider. A value of 50% will make the shadow semi-transparent. 

Values in excess of 100% can also be entered.

Shadow Color: Defines the color of the shadow cast by the sun.

Transparency: Check this box to have transparent objects cast a shadow.

The following three parameters are relevant only if you are using the Standard renderer. They have no 

effect in Physical rendering mode!

– Minimum Samples

– Maximum Samples

– Shadow Accuracy
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These parameters function just like the Light parameters (with Area shadow) of the same name and 

pertain exclusively to sun Area shadows. (See Shadow Casting (Cineware).)

Sky

The Sky shader is an accurate simulation of the sun’s and sky’s natural color and brightness with regard to 

their current location and the time of day. 

• Sky Horizon: Choose either Physical Properties, Custom Gradient, or None. If you choose Physical 

Properties, the following additional parameters are available:

• Horizon Line: If enabled, the sky will be clipped at the bottom at the horizon line, where it will be colored 

black. Otherwise the southern hemisphere will be given the color (and brightness) of the horizon.

• Color Warmth: Physical Sky works internally with spectral colors that have to be converted to RGB colors 

for rendering. This setting increases the “warm” colors in the sky (i.e., less turquoise in a blue sky and 

more brown in a morning or evening sky).
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• Intensity [0..10000%]: Defines the intensity of the sky’s brightness. This affects the light used by the sky 

for GI calculation and the direct (most often blue) illumination of objects. The Intensity only regulates the 

visible intensity (without the influence of GI).

• Night Intensity Ratio [0..10000%]: Defines the brightness with which the night sky is rendered as well as 

the brightness of the light it emits. This parameter is dependent on the Intensity parameter. If Intensity is 

increased, the Night Intensity Ratio will increase accordingly, without the value itself being increased.

• Saturation Correction [0..200%]: Defines the sky’s saturation. If, for example, the sky is too blue, simply 

lower the Saturation Correction value. A value of 0 will result in a grayscale sky.

At left a lower Saturation Correction value. At right, a higher Saturation Correction value. Note how the sky’s 

blue color at the right is much more intense on the walls and the sofa.

• Hue Correction [0..100%]: This parameter can be used to create extraterrestrial sky colors. The entire 

color spectrum is available for you to use.

• Gamma Correction [0.1..10]: The internal brightness range for the sky is much larger than can be 

displayed on your monitor. Use the Gamma Correction value to define the brightness range from brightest 

to darkest values.

• As Seen Intensity [0..10000%]: Defines the brightness of the rendered, visible sky only (also dependent 

on the Intensity parameter). The GI calculation will not be affected!

• Dithering [0..100%]: If color banding (sudden color transition) appears when the sky is rendered, 

increase this value to add a slight noise to the sky’s gradient, which will hide such banding.

• Turbidity: Many natural color phenomena in the sky are caused by various combinations of light and 

water or other particles in the atmosphere. In Cineware, this is called “turbidity”.

The smaller the value, the clearer the atmosphere will be. Higher values will result in correspondingly in 

more foggy or smoky, as well as more colorful, effects. 

– Tip: In case the sky is too bright or too dark, the Turbidity and Atmosphere Strength (see below) 

parameters will have the greatest influence in rectifying this.
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• Ozone: In the real world, ozone filters ultra violet sunlight. In visual terms, it filters yellow and red sunlight 

(i.e., the Sun option must also be enabled). Therefore, the higher the Ozone value the more bluish the 

sunlight will appear (in the real world, this takes place at dusk and dawn). The color of the sky itself 

remains unaffected.

General

• Atmosphere Strength [0..100%]: The atmospheric strength affects the brightness of the atmosphere (the 

same effect as the Turbidity parameter, described above). Lower values will cause the atmosphere to 

fade to black; larger values will fade to white (if the Turbidity value is high enough).

Atmosphere Strength value reduced to 50%

• Horizon Start [-89..89°]: Varies the height of the horizon. If, for example, you have a scene in which you 

do not have an endlessly large Floor element, you may find that you can see under the horizon. If this 

happens, enter a negative Horizon Start value and the sky color will be stretched or compressed 

accordingly.

Atmosphere

Note: The default values here are generally adequate and you will rarely have to adjust them.

This effect can be described as follows: you look at a mountain panorama and notice how mountains in the 

distance seem to be increasingly covered by a bluish haze.

This atmospheric effect (also called “atmospheric perspective”) is caused by two main factors: 

• Absorption of light

• Dispersion of sunlight and skylight

Intensity: Defines the brightness of the atmospheric haze. Larger values quickly result in an unrealistic, 

overexposed effect.

Horizon Fade: This parameter helps you mix the color of the atmosphere with that of the sky, creating an 

atmospheric perspective effect. A value of 100% will result in only the horizon color being used.

Saturation Correction: Adjusts the atmosphere’s saturation. Smaller values result in a grayish, colorless 

haze.

Hue Correction: The atmospheric haze can contain any color, depending on the value entered here.
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Gamma Correction: This setting can be used to increase the atmospheric effect depending on the lighting 

situation. It can, in certain instances, help improve the overall look of the effect.

World Scale Ratio: This algorithm assumes that 1000 meters in the real world are equal to 1000 units in 

Cineware. This ratio can be modified using this setting. Values greater than 100% will increase the 

atmospheric effect, e.g. 500 Cineware units are equal to 1000 meters in the real world.

Dithering: If color banding (sudden color transition) appears when the atmosphere is rendered, this value can 

be increased to add a slight noise to the sky’s gradient, which will hide such banding.

Clouds

Use the Clouds controls to edit the look of your 2D clouds.

A special method is used to project 2D clouds onto the celestial sphere to give a realistic impression of cloud 

cover that stretches across the entire firmament.

Cast Shadows: Defines whether or not 2D Clouds should cast shadows.

Rolloff: This grayscale gradient causes the sky to fade to the cloud color near the horizon, thus giving the 

cloud cover a realistic look as it approaches the horizon.

See also Adjusting Gradient Parameters.

Cloud Layers: The levels can be turned on or off via the Levels 1-6 options.

2D Clouds can be made up of up to six cloud layers, each of which can be turned on or off separately. Each 

layer offers the same settings.
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• Noise: Noise turns an otherwise smooth surface into a more or less randomly uneven surface Here you 

can select the type of noise with which your 2D clouds should be created.

• Color: Define the color of your cloud here; its color will be independent of the sun’s color or that of other 

sources of light. Only the cloud’s brightness will be adjusted to match the sun.

• Height: Set the height of each cloud layer. If you take a look out of the window you will notice that clouds 

often consist of several layers. 

Cirrus clouds can, for example, be placed on a layer that is higher (since they reach greater heights in 

reality as well), and clouds that are darker, rain-filled, and more foreboding can be placed on a lower layer.

• Density: Density defines the contrast of the clouds. If a low value is used, the clouds will be very 

transparent, especially towards the edges. The higher the value, the more homogeneous the clouds will 

be.
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• Coverage: This is the most important cloud setting. With it you define the degree of cloud coverage. Very 

low values result in no cloud coverage; very high values result in a completely overcast sky.

Left, low Coverage value; right, higher Coverage value

• Thickness: Thickness is the measure of the degree to which the sunlight will be dispersed or absorbed. 

Lower values result in the clouds being brightened more by the sunlight, higher values result in darker 

clouds.

• Transparency: Transparency regulates the degree to which 2D clouds cast shadows onto other objects in 

the scene. Enter a value of 100% if no shadows should be cast.

If, in addition to the sun, you add light sources that cast shadows, make sure they are placed at a height 

greater than 10,000 m

• Scale N-S; Scale W-E: These settings let you scale the noise pattern in the North-South (N-S) or West-

East (W-E) directions.You can easily create long, thin, stretched cloud formations by scaling them in one 

direction only.

• Position N-S; Position W-E: Use these settings to move your clouds in the North-South (N-S) or West-

East (W-E) directions. 

Fog

A fog system has been integrated into Physical Sky - a real volumetric fog, based on diverse types of Noise 

shaders that render less homogeneously and therefore more realistically.

Note: Using fog can increase render times: the denser the fog, the more time it will consume. 

The fog stretches infinitely in a vertically adjustable fog bank.

If you already have Sunbeams activated, any added fog will add much more calculation time.

• Color: This is the color the fog should assume. This color will not be affected by other colored light 

sources, although the sun’s color can be multiplied with the fog’s color (if the Illumination Intensity setting 

described below is set to greater than 0).

• Start Height/End Height: These settings determine where the fog should begin and end (starting from 

the ground, Y=0).

The fog bank, which extends infinitely on the X- and Z-axes, must at least be limited in its vertical 

extension. Otherwise you would not be able to see anything in the resulting soupy fog.
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You can determine how quickly density is lost between the Start Height and End Height settings by 

adjusting the Density Distribution (see below).

• Max. Distance: Use this setting to optimize render times. Roughly speaking, this distance is calculated 

from the camera’s point of origin, looking into the scene. Only the fog that lies within this range will be 

calculated.

• Density: Density is the measure of the fog’s density, i.e. the higher the value, the more opaque the fog.

• Density Distribution: Regulates the density between the Start and End settings.

Rainbow

A rainbow is created by light refracting through raindrops. A rainbow’s position is dependent upon the position 

of the sun. To that end, remember the following rules:

• A rainbow’s apex always lies exactly opposite the sun.

• The lower the sun’s position, the higher a rainbow’s apex will lie.

As in reality, there always exists (even if not always visible) a second, less visible mirrored (in color) rainbow 

with a larger radius.

Two types of rainbows are available (here shown with a high Max. Strength value)

Spatially, a rainbow will always be arranged in front of all Sky objects (even clouds).

Max. Strength: Use this control to adjust the rainbow’s transparency. The second rainbow will be created 

according to the properties of the first. The lower the value, the more transparent the rainbows will be.

We suggest you use unobtrusive, transparent rainbows - less is more.

Turbidity Dependent: In reality, if there’s no rain (or moisture in the air), there’s no rainbow. Physical Sky 

regulates the density of the moisture in the air via the Turbidity setting (see above, at Environment > Physical 

Sky > Sky > Physical Properties). So, if you want to link your rainbow to this setting, activate this option. If 

Turbidity is set to 0, for example, no rainbow will be created.

If you activate Turbidity, the following options will be made available:

Min. Turbidity Threshold/Max. Turbidity Threshold 

Use these controls to adjust the rainbow’s turbidity.

Example: You set the first control to 9 and the second to 50. This means no rainbow will be visible as long 

as Turbidity is less than 10. If Turbidity is greater than 50, the rainbow will be rendered to full strength. 

Between 9 and 50, the rainbow will be rendered in correlation with the strength of Turbidity.
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First Rainbow Inner and Outer Angle/Second Rainbow Inner and Outer Angle

The precise definition of rainbow angles is not needed here. Simply view the difference of both angles as the 

measure for each rainbow’s width.

If you think rainbows are too narrow, try entering inner and outer values of 30° and 50°, respectively, for the 

first rainbow.

Start Clipping/End Clipping 

Imagine an animated airplane approaching from the distance out of the rainbow. In the distance, the airplane 

is behind the rainbow; as it approaches it will eventually cover the rainbow. Such effects are possible using 

these settings.

Objects lie in front of the rainbow up to the Start Clip point; starting at the End Clip point, the objects lie behind 

the rainbow.

Sunbeams

Sunbeams shining through the clouds can be a beautiful and useful effect.

To make the sunbeams visible, make sure of the following:

• From the point of view of the camera, the sun should be mostly hidden behind the clouds. 

• The cloud cover must be structured so that sunbeams can pass through them, i.e. with intermittent holes 

or clearing.

Using fog (see Fog) in addition to sunbeams can increase render times.

Sunbeams shine through a hole in the cloud cover

Turbidity Dependent: If, as in reality, you want to let atmospheric particles affect your sunbeams, simply 

activate this option. This links the visible sunbeams to the Turbidity setting (Environment > Physical Sky > Sky 

> Physical Properties). The more hazy the air (atmosphere), the better the sunbeams can be seen. If Turbidity 

is set to 0, no sunbeams will be visible.

Intensity: Here you can adjust the brightness of the sunbeams
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Min. Brightness: Use this control to determine at what minimum brightness value (internal) the sunbeam will 

become visible. Select a high value if you want to make only the brightest sunbeams visible, a low value if you 

also want to make weak sunbeams visible. The brightness of the rendered sunbeams is defined by Intensity.

Left: low Min. Brightness value; right: high Min. Brightness value

Start Distance/End Distance 

These settings, calculated from the camera’s point of origin, let you define an area within which sunbeams will 

be depicted. T

Sample Distance: Everywhere that physical effects are simulated (e.g. a ray of light loses intensity over a 

particular distance), points of measure (samples) are defined that calculate the level of intensity at a given 

location. The more samples you define, the more precise the result will be. Longer render times will also 

result.

The same applies to Sample Distance: The lower the value, the more precise the sunbeams will be rendered 

(and the render times will increase as well).

Details

Use these controls to add additional details to your Physical Sky.

Show Moon: Defines whether or not the moon should be shown.

• Scale: Here you can vary the size of the moon.

• Bright Intensity/Dark Intensity: Use these settings to define the bright side of the moon (side lit by the 

sun) and the dark side of the moon (side not lit by the sun). If you want a full moon, set both settings to 

100%.

• Distance Scale: If you encounter problems with the light source integrated into the moon, simply reduce 

its distance using this setting.

Show Stars: Check this box to display stars.

• Star Min. Magnitude: The Magnitude value represents the apparent brightness of stars on a firmament. 

Use this control to determine the stars’ minimum magnitude at which they should be visible. The following 

rules apply:

– Low value: Only the brightest stars will be projected

– Maximum value: All stars in the internal database will be projected.
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• Resize Stars with Magnitude: Depending on the magnitude (brightness) of the stars, individual stars will 

be scaled, thus adding even more realism. If this option is not active, all stars will have the same size.

• Brighten Stars: Use this control to adjust the brightness of the projected stars: The higher the value, the 

brighter the stars.

• Star Radius: Use this control to adjust star size

• Show Constellations: Check this box to display constellations.

• Constellation Color: Constellations can be displayed in any color. If you set anti-aliasing mode to Best in 

Render Settings (see Antialiasing (Cineware)), the constellations (as well as the Grid - see below) will be 

smoothed when rendered.

• Grid Width: The celestial sphere is similar to the earth being divided along longitudinal and latitudinal 

lines, though here they are referred to as azimuth and height. The grid can be made visible by setting Grid 

Width to 10°, for example. Azimuth and height will then be represented by a line every 10°. 

• Grid Color: Defines the color of the grid.

The grid will be smoothed if you set anti-aliasing mode to Best in Render Settings (see Antialiasing 

(Cineware)).

Show Planets: Enable or disable the display of our solar system’s planets (Mercury, Mars, etc.).

Sky Dome Light: In addition to the sun (which itself is a “normal” internal light source) an area light source 

that is (almost always) blue exists that simulates the bluish light emitted by the atmosphere. This light can now 

be disabled (this bluish light is sometimes not desirable for scenes rendered without GI).

Generate GI

See Illumination (Cineware Surface Channel) for information about Global Illumination.

Note: The GI emitted pertains only to the sky, not any other elements, i.e. Fog, Rainbow, etc.

• GI Strength: Defines the strength of the generated GI.

• GI Saturation: Defines the amount of saturation of the light emitted by the sky, i.e. how blue (or orange for 

early evening scenes) the scene should be rendered.

• GI Cloud Influence: Defines the degree to which the 2D Cloud color should affect the GI. A value of 0% 

means that the cloud color will be ignored entirely and only the sky itself will be used.
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Environment: HDRI Sky (Cineware)

HDRI Sky is an image which provides a background picture and ambient light source for the rendering.

• An HDRI image provides diffuse light and blurred shadows (no sharp shadows)

• The HDRI Sky Setup does not include a separate Sun. To use the effects of the ARCHICAD sun, make 

sure that the Sunlight is turned on in Cineware Basic Settings (see Light Sources). If you increase the Sun 

slider value, this will also increase shadow sharpness.

From the Sky Setup parameter, choose HDRI Sky.

HDRI Image

In HDRI Image, click the File Name parameter to select an image:

Use a predefined image from the library ([Himg] HDF Images folder), or create your own. (If you create your 

own, you must use a spherical view, otherwise it will be distorted.)

• Mirror on X axis/Mirror on Y axis: Apply a mirror effect to the image.

• The following effects are on by default. However, you can turn any of them off, or leave just one of them 

on, to achieve certain effects and/or optimize rendering time.

• Sky Visibility: If you turn this off, the HDRI Sky parameters still affect the rendering, but you cannot see 

the sky itself.

– Exposure: Use this setting to adjust the brightness of HDRI as well as normal images.

- Note: This will have an effect only on the visible, reflected and refracted HDR Sky, but not on the 

one used for the Sky Luminance.

– Black Point/White Point: These points define the darkest and brightest points, respectively, and save 

this information to a histogram. If one of these points is subsequently moved, the dark and light levels 

will be scaled accordingly.
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• Sky Luminance: You can turn on Sky Luminance with the other effects off: this will give you the light 

effect of the HDRI Sky without anything else.

– Use the Color/Intensity controls to vary these luminance parameters for the HDRI Image.

– Use the Blur Offset and Blur Scale controls to affect the blurriness of the image’s luminance effect.

• Sky Reflection: If only Sky Reflection is on, then you can, for example, see the environment reflected on 

a glass building, without rendering the environment itself.

• Sky Refraction: Turn on/off the HDRI Sky’s refraction effect.

• Rotation: Use these controls to rotate the HDRI Sky image.
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Cineware Effects

The following effects (available in the Detailed view of PhotoRendering Settings for the Cineware engine) are 

for optional use, to enhance your rendering. They provide extra scope for fine-tuning your scene. They 

function as post effects - that is, their effects are added to the scene after it is calculated by the rendering 

engine.

Ambient Occlusion (Cineware Effect)

Caustics (Cineware Effect)

Cel Renderer (Cineware Effect)

Color Mapping (Cineware Effect)

Color Correction (Cineware Effect)

Depth of Field (Cineware Effect)

Lens and Filters (Cineware Effect)

Distance Fog (Cineware Effect)

Monochrome Model (Cineware Effect)

Tone Mapping (Cineware Effect)

Vignetting (Cineware Effect)
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Ambient Occlusion (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Ambient Occlusion (AO) determines the degree to which each visible surface point is exposed and darkens it 

accordingly. Ambient Occlusion (AO) offers, within certain limits, a fast alternative to GI.

Watch the Video

Note: As an alternative to using AO as a global effect on the whole Rendered scene, Ambient Occlusion 

can be applied as a shader effect to specific Surface Channels. 

See Ambient Occlusion (Cineware Surface Channel).

Let’s say your scene is surrounded on all sides by a sky. The AO shader will determine to what extent each 

visible area sees the sky.

Corner areas, holes, and areas between objects placed very close to each other will see less of the sky and 

will therefore be darkened in accordance with the AO settings.

Two types of Ambient Occlusion calculation are available:

• the usual “brute force” method, which checks the environment’s visibility for each individual pixel

• the faster method via Cache, which only checks certain points’ visibility and interpolates all others in-

between.

The latter works internally, similar to the Irradiance Cache GI mode, and is controlled using similar settings. 

The advantage of using this method is that the AO calculation is much faster.

See Cache, below.

Color

Use the Color option to define the color gradient that AO assigns, dependent on exposure. Normally, it will be 

a simple custom black to white gradient but other colors can also be defined.
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Be aware of the fact that these gradients will be treated as grayscale, depending on the material channel.

See also Adjusting Gradient Parameters.

General

• Minimum Ray Length: Determines how the gradient defined in Color will be rendered between exposed 

and non-exposed areas. The closer the Minimum Ray Length value is to the Maximum Ray Length value, 

the further the gradient will be pushed towards the edges, which are defined by the maximum ray length.

This value shouldn’t really be tampered with. Leave it set to its default setting of 0.

• Maximum Ray Length: This value defines to which distance the surfaces see each other. Where geometry 

meets, as with the floor and wall or the sphere and floor, even small rays will fall upon surfaces, which is 

enough to darken those areas.

If high values are used, a much larger distance will be included within which objects will be able to see 

each other. This results in a softer, more homogeneous darkening that will cause longer render times.In 

general, lower values are recommended.

• Dispersion: During each AO calculation, several rays (Samples) will be emitted for each point within a 

virtual hemisphere in the scene. These samples check to see if any geometry lies within the Maximum 

Ray Length. Dispersion determines to what extent these samples will be taken into account on the 

hemisphere’s surface. A value of 0% takes only the hemisphere’s zenith (vertically over the sphere) into 

account. A value of 100% will take the entire hemisphere into account.

Accuracy, Minimum Samples and Maximum Samples (Ambient Occlusion)

These settings are responsible for AO quality. 

• Low quality is accompanied by grainy results. This is not necessarily bad. In fact, in some cases, this can 

be of high aesthetic value.

• If you prefer homogeneous, seamless transitions, you should select higher quality settings, which will also 

increase render times.

In simple terms: Samples are required to render AO. The more samples that are used, the more 

homogeneous (less grainy) the rendering will be - the longer the render times will be as well. Fewer samples, 

on the other hand, result in shorter render times.

Of course a maximum number of samples can be calculated for the entire scene. This would take very, very 

long to calculate and it does not make any sense since a scene contains many areas in which a relatively 

small number of samples would suffice.

That’s what the Minimum Samples and Maximum Samples settings are for. They are used to affect the 

critical and less critical areas of your scene in different ways.

The Accuracy setting determines where and in what amount samples must be distributed in order to achieve 

the best possible result. In critical areas, the maximum amount of samples will be used.

Hence, the Accuracy setting has the most influence in critical areas (since higher values in these areas lead to 

more samples) and less influence in less critical areas, which use the Minimum Samples value.

• Contrast: Use this setting to adjust the AO effect’s contrast. Negative values can also be entered!

• Use Sky Environment: AO can work without a separate light source if the Physical or HDRI Sky is used 

as Illumination. If the Environment’s Sky checkbox is active, the reflected sky color will be multiplied onto 

the final AO image. 
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Note: For this to have an effect, the Ambient Occlusion texture must activated in the Environment or 

Luminance surface channels. 

See Ambient Occlusion (Cineware Surface Channel).

• Evaluate Transparency: When this option is active, transparency will be analyzed on the basis of the 

Transparency or Alpha surface channels. In doing so, the degree of transparency will be taken into 

consideration: A semi-transparent sphere will still cause some AO in spite of this option being active.

• Self Shadowing Only: When this option is active, separate objects will not see each other, they will only 

see themselves.

Cache

Because AO works similar to Irradiance Cache, the settings are for the most part the same. In most cases, 

you will only have to adjust the Record Density setting.

Record Density

Record Density defines the subordinate parameters automatically. You should modify the subordinate 

parameters separately only if the AO is consistently wrong or if it does not appear to be precise enough.

Enable Cache

• If enabled, the AO cache (described briefly in the section below) will be used.

• If disabled, AO will work as in older versions of CineRender (Cineware) (pre-AC20): The environment’s 

visibility will be calculated for each pixel.

How the AO Cache Works

During rendering, several pre-calculations take place (pre-passes), during which the project is analyzed for 

the regions most important for the camera (“shading points” in corners, concave regions, etc.) for visibility of 

the environment and to calculate an AO value:

All AO values will be cached to an AO cache and can be saved as a file for later use.

In a second step, the selectively located AO values will be interpolated and smoothed.

The following settings primarily serve to disperse the shading points.
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Samples

This is the number of samples that are emitted hemispherically from each shading point. If the AO looks 

spotty, this is the value that should be increased.

Left: small Samples value. Right: larger Samples value. Model by Steen Winther.

Min Rate/Max Rate

These two settings can, for the most part, be ignored. The effect they have is barely visible. The “worst” 

setting for Min. Rate and Max. Rate (-8 for each) differs only slightly from their “best” settings (-8 and +4, 

respectively (see image).

8/-8 (left) and -8/+4 (right) for Min. Rate and Max. Rate, respectively
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Nevertheless, their function should be mentioned: While the pre-passes are being rendered (the phase in 

which the squares are at first large and become increasingly smaller) the dispersion of the render density is 

defined. This is an adaptive process that places particular emphasis on the critical regions. The difference 

between the Min. Rate and the Max. Rate defines the number of pre-passes.

-7 and 0 for Min. Rate and Max. Rate, respectively

A value of 0 will result in full image resolution (pixel size 1*1) and a value of -1 will produce a pixel size of 2*2, 

-2 = 4*4 and so on. The Min. Rate value should therefore be less than or equal to the Max. Rate value. 

Positive values can also be used, which will allow caching in the sub-pixel regions (for example, this could be 

useful, in conjunction with Subpolygon Displacement, if details get lost).

Density/Minimum Spacing/Maximum Spacing

These three settings work together to define the general shading point density at critical and non-critical 

areas:

• Density: The general shading point density in consideration of the following to settings.

• Minimum Spacing: The shading point density at critical areas (e.g., corners).

• Maximum Spacing: The shading point density at non-critical areas (e.g., planar surfaces without elements 

that block the view). Various values for this setting can be seen if you take a look at the GI’s Density 

setting. The shading point dispersion is exactly that of the AO cache dispersion.

Smoothing

All of the settings just described revolve around the placement of shading points and their calculation.

AO was ascertained selectively at numerous locations within the project. The selective dispersion must be 

turned into a flat dispersion for rendering. A smoothing algorithm does this as follows: For each pixel to be 

rendered on an object’s surface, the AO cache is checked for those instances nearest to that pixel and their 

values will be interpolated for that pixel.

In brief: Values that are too low will result in spotty AO; higher values will result in more homogeneous 

renderings (but even these ignore Samples that are too low). Generally speaking, higher values take into 

consideration more shading points for the rendered pixel.

Paradoxically, extremely large values will also lead to spotty results.

Screen Scale

If disabled, the output size for rendering is irrelevant for ascertaining the shading point density. It will remain 

constant, regardless if you render at a resolution of 80*80 or 3000*3000. For the former it would be too large 

and for the latter, too small.

If enabled, the shading point density will be linked to the output size for rendering. This will result in a more 

flexible and adaptive shading point density.
ARCHICAD 24 Reference Guide 3618



Dialog Boxes User Interface Reference
Invert Direction

If this option is enabled, the AO effect will be inverted. Instead of corners and holes, outward pointing edges 

and corners/peaks will be found.

If exposed surface should, for example, have a different appearance than the remaining surfaces, place the 

AO shader into the Alpha channel: the respective surface will only have an effect on outward pointing edges 

and corners/peaks.

This function works best when applied as a shader effect. When enabled as a PhotoRendering effect, only 

simple coloration of exposed regions can be rendered.
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Caustics (Cineware Effect)

Caustics are patterns of focused light created on surfaces and within a visible light beam.

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Note: The Caustics effect can also be enabled for Lamp objects. 

See Caustics at Lamp Tool Settings.

Surface Caustics: Enable this option to switch on surface caustics.

Volume Caustics: Enable this option to switch on volume caustics

Strength: This sets the general brightness of the caustics effect. Here, the strength on the left is normal; the 

strength on the right is high.

Step Size: With volume caustics, photons are saved in the photon tree at regular intervals as defined by this 

value. 

For example, if the volume caustic effect is 100m long, you might set Step Size to 5m so that 20 different 

values are saved for each photon.

• Lowering Step Size increases the accuracy of the effect but increases the render time also. 
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• A lower Step Size produces a brighter effect. This is because more values are saved in the photon tree 

over the same distance.

Sample Radius: This specifies how close photons must be to one another in order to be interpolated. Higher 

values tend to produce better results but take longer to render.

If you notice individual spots or dots in the render, increase the Sample Radius.

Samples: The Samples value represents the maximum number of photons within the sample distance that 

will be used to calculate the volume caustics.

If Samples is set too low (here, the image on the left), individual photons can be seen as small dots.

As a rule, higher values (here, the image on the right) produce a more accurate effect but add to the render 

time.

Recompute: 

With Recompute, the caustics data from a previous render can be reused to speed up rendering. This saves 

the time it takes to calculate the caustics effect, but keep in mind that a new calculation will be required if you 

make major changes to the scene such as moving a caustics-generating light to a new position. Use the 

Recompute drop-down list to choose when caustics should be recalculated.

• First Time: The scene’s caustics will be calculated for the first render only; future renders will reuse the 

data. 

• Always: Caustics data is always recalculated when you render.

• Never: Caustics are not recalculated when you render.

Save Solution: If you enable this option, the caustics data is saved when you render. Depending on the 

Recompute setting (above), the saved data can be reused to speed up future renders.
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Cel Renderer (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Using this post effect, you can render pictures in a cartoon style. This is a useful effect in architectural 

renderings.

The render time increases linearly with the number of polygons.

Color

If this option is disabled, objects will usually be rendered with black outlines on a white background.

When Color is enabled, all objects will be rendered using a reduced color palette (depending on the Quantize 

and Color Steps settings, below) and black outlines on a black background. This gives the rendered subjects 

a cartoon-like feel.

Illumination

This option is available when Color is enabled.

If this option is enabled, the shading of objects will be affected by the illumination. Shadows will also be 

rendered cartoon-style.

If Illumination is disabled, each object will have a monotone color.

Also, shadows will not be rendered with the option disabled.

Outline

When enabled, an outline will be drawn around the silhouette of individual objects. If both the Color option and 

the Outline option are disabled, all you will see is the background color. With Color enabled, the outline will 

bring out the individual objects and give them a cartoon-like feel.

You can change the color of the outline using Edge Color.

Edge Color

Use this to change the color used for the Outline — even if the Color option is disabled.

Background Color

This setting changes the background color provided that Color is disabled. When Color is enabled, the option 

has no effect.
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Quantize

To render the cartoon effect with color steps, enable the Quantize option and set steps to the number of color 

steps.
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Color Mapping (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

An image rendered with GI (and low ray depth) is very bright in some areas and very dark in others. A more 

balanced allocation of color and brightness can help make the lighting more consistent.

One solution is to edit the internal rendering’s interpretation via Color Mapping.

Watch the Video

Although these settings look inconspicuous, you should take the time to try them all out.

As a rule:

• Exponential and HSV Model should be left active. 

• Use the Multipliers to fine-tune your image.
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Exponential

The color dispersion will be controlled exponentially, not linearly.

HSV Model

If this option is active, the HSV (Hue, Saturation, Value) model’s colors will be converted and only the V 

(brightness) component will be affected. The colors will remain identical, e.g. a dark blue will not be turned 

into a purple.

Affect Background

Here you can define whether or not Color Mapping should affect the background (if you are using one - such 

as Sky or Background.)

Dark Multiplier/Bright Multiplier

These settings let you strengthen or weaken dark and light colors.
ARCHICAD 24 Reference Guide 3625



Dialog Boxes User Interface Reference
Color Correction (Cineware Effect)

This post effect lets you make common color corrections right away without having to switch to a different 

application.

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Watch the Video

Saturation

Defines the amount of hue in a given color or in the colors of an image, i.e. how brilliant a color/colors will 

appear. 

A Saturation value of 0 means no change in the hue of the original colors.

A Saturation value of -100 will result in an image being reduced to grayscale values.

A Saturation value of +100 brightens the colors. 

Brightness

Makes an image evenly brighter or darker. 

Contrast

Higher Contrast values will darken dark regions and brighten bright regions of an image. This amplifies the 

differences between regions with different brightness values.

Lower Contrast values will lighten dark regions and darken lighter regions of an image, which will result in an 

optical “flattening” of the image.

Exposure

Exposure is used to adjust the brightness of HDRI and also normal images.

Gamma

The Gamma value adjusts the brightness values (e.g. a bright pixel can be made much brighter, or darkened). 

Red/Green/Blue

Use these options to enable or disable each color channel.

Invert

Inverts the image’s color values. Black regions are made white and vice versa. RGB images are inverted by 

subtracting the maximum pixel color value (i.e. from 255 for 8-bit color depth) for each channel (red, green, 

blue). 

Black Point/White Point

These values define the darkest and brightest points, respectively. If one of the values is modified the total 

value will be scaled accordingly.
ARCHICAD 24 Reference Guide 3626

https://youtu.be/3IPjh5DdJ6w


Dialog Boxes User Interface Reference
Depth of Field (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Note: This Depth of Field parameter applies for the Standard Renderer only, and is considered a post 

effect. If you are using the Physical Renderer, its own Depth of Field settings will apply: see Depth Of 

Field.

Depth of field is the region of a rendered image in which objects will appear blurred because their distance 

from the camera (either far or near) causes them to be out of focus.

A large depth of field is when a large region in the distance is displayed, whereas a small depth of field is 

when a relatively small region is displayed in focus.

Here, the depth of field values decrease, from right to left:

Use the Depth of Field (DOF) value to define which part of an image should be in focus and which out of 

focus. Either the rear region (DOF rear) or the front region (DOF front) can be blurred. You can also focus on 

the center region of a scene. In this case both the foreground and the background will be blurred. If neither of 

the options is enabled, the camera will behave as before: all objects will be in focus.

General

Define the type and strength of Blur you want to add.

• Blur Strength: This parameter defines the general strength of blurring. Other parameters modify this 

strength such as Distance Blur and Radial Blur. Note that if you set Blur Strength to 0% there will be no 

blurring at all, even when the other blur parameters are set to high values.

• Use Distance Blur: The Distance Blur value refines the strength of blurring. For example, if you set Blur 

Strength to 80% and Distance Blur to 50%, the strength of full blurring will be 40% (50% of 80%).

• Use Radial Blur: Radial blur gets stronger from the picture’s center outwards.
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• Use Autofocus: This option can be enabled to simulate the Autofocus feature of a real camera. The 

object in the center of the view will become the focal point, i.e. the object in the center will be perfectly 

sharp.

• Autofocus: So that the object does not have to be exactly in the center, you can enter an Autofocus 

tolerance value. The maximum value of 100% allows the object to be anywhere in the view. With lower 

values, the object must be closer to the view’s center to trigger the autofocus.

• Front Blur/Rear Blur: In the gradients, black represents full sharpness, white represents full blur (i.e. the 

Distance Blur value) and gray is for intermediate blur strength (the brighter the gray, the stronger the blur).

Lens Details

Using the settings on the Lens Details page, you can simulate the popular movie effect where objects that are 

brightly lit in places slip out of focus. Artifacts will appear in the bright areas. Use the Lens Details to adjust 

these artifacts.

Lens Sharpness: The sharpness of the lens artifacts.

Lens Intensity: The brightness of the lens artifacts.

Lens Shape: Choose the shape of the lens: Circle, triangle, rhombus, pentagon, hexagon, heptagon, octagon 

or nonagon.

Lens Rotate: Controls the orientation of the lens artifacts.

Tint

Using these parameters, you can add tints that take the scene’s depth into account. For example, you can add 

a blue tint to your renders that gets stronger towards the horizon (aerial perspective); simulate the orange tint 

of the horizon on the sunset; or recreate the deep, dark cold blue of a moonlit scene. You can also simulate 

the orange tint of daylight film used to photograph interiors and the blue tint of interior film when it is used to 

photograph exteriors.

Use Tint

• Front Color

• Rear Color

Use Ranges/Use Camera Ranges

There are three possible states. The camera’s focus is always taken into account.

• Use Ranges disabled. Creates a tint that is close to reality.

• Use Ranges enabled, Use Camera Ranges enabled. This works in the same way as described for 

Distance Blur. Use a camera to help define the tint ranges.
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• Use Ranges enabled, Use Camera Ranges disabled.

Front Start/Front End/End Start/End End

The tint range is defined by the values Front Start, Front End, End Start and End End (not the camera 

parameters) based on the camera’s focus. This enables you to define the tint independently of the Depth of 

Field settings.

Depth of field limitations

Problems may occur in places where blurred objects are seen in reflections or behind transparencies.

• If glow is calculated after depth of field, inaccuracies may arise.

• If glow is calculated before depth of field, the depth of field will overwrite the glow.

• The Specular post effect does not work in conjunction with depth of field.

• DO NOT activate depth of field if Alpha Channel is activated in the image output settings. Otherwise the 

alpha channel will not be rendered correctly.
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Lens and Filters (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Cylindrical Lens

This option enables you to pan across a much larger area than would be possible using other projection types 

- for example, to achieve a panorama view of up to 360°.

• Horizontal Field of View: Use this setting to define how much of the horizontal view should be taken into 

account for calculation. A value of up to 360° can be entered.

• Vertical Size: Use this setting to define the size of the parallel camera. Higher values will enlarge the 

portion of the image shown and will compress the image.

Lens Flare

Turn this on to render lens flare effects if they are used in your scene.

See Lens Flare in Lamp Tool Settings.

See also Lens flare in the Physical Sky’s Sun settings.

Median Filter

Removes peaks in color values from the image.

Use Strength to increase or decrease the Median Filter effect.

Object Glow

Turn this on to render glow effects if they are used in your scene. 

See Glow (Cineware Surface Channel) in Surfaces.
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Sharpen Filter

This filter emphasizes transitions in the image. This reinforces the edges.

Use Strength to increase or decrease the Sharpen Filter effect. Try using the filter with 30% strength.

Soften Filter

Each pixel is balanced with its neighbor to produce a softer transition.

Use Strength to increase or decrease the Soften Filter effect. 
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Distance Fog (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Watch the Video

Color, Strength

These parameters define the color and brightness of the fog.

Distance

The shorter the distance, the thicker the fog.

Environment fog fills the entire screen, stretching to infinity. Distance refers to the fog’s intensity by specifying 

the distance over which a light beam will lose its intensity completely. As the light loses intensity, the fog color 

is added. If, for example, you have entered a value of 500 for Distance, a light beam that starts off with 100% 

intensity will reduce to 20% after traveling 400 units; at the end of a further 100 units, the light will have faded 

out completely, giving way to the fog color. 

Beams that penetrate the fog beyond the limit defined in Distance are absorbed completely by the fog color — 

if you enable environment fog, you cannot see a sky or a background image.

Affect Background

Use this setting to determine whether or not existing Sky Objects or backgrounds should be affected by the 

fog. If this setting is not active, fog will affect only normal object geometry, and the sky or background will be 

visible, as if no fog were present.
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Monochrome Model (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Check the Monochrome Model box to apply a single color to the model, replacing individual surface colors.

• Choose White Model for this effect, or

• Select Color from the color chooser.

Preserve Surface Channel

Check the Surface Channel effects that you want to include in the model display for rendering.

Watch the Video
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Tone Mapping (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Cineware always renders internally using 32 bits. These color values must be interpreted in order to convert 

these to 8 or 16 bits for commonly-used output devices. This is done by a series of algorithms (operators) that 

use different methods.

Note that Tone Mapping permanently modifies the image. If you are planning to perform a color correction in 

another application (e.g., Photoshop, After Effects, Nuke, etc.) you don’t have to perform tone mapping in 

Cineware.

Save as TIFF

To get the full effect of Tone Mapping, you must save the Render in TIFF format, and adjust the Image Save 

Options to “High Accuracy Color with Alpha Channel.”
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Operator for Tone Mapping

When choosing an Operator, it is best to test which one works best for the scene at hand.

Generally speaking, the Reinhard method is the most flexible method. It is based on photographic principles.

Operator: Linear Modes

The linear modes brighten or darken all regions of the image uniformly. This means that some image regions 

can be drowned out.

• Linear: This is a simple mode that multiplies all color values with the Scale factor. Both dark and bright 

regions will be brightened or darkened.

• Photo Linear: These common camera settings can be used to adjust the results. 

– Exposure (the larger the value, the brighter)

– ISO (the larger the value, the brighter (this setting represents the film/sensor sensitivity)

– F-Stop (the larger the value, the darker)

– Gamma: Can be used to increase (larger values) or decrease (smaller values) the image’s mid-range 

brightness (which is actually not linear behavior if the value is not equal to 1).

• Auto Linear: This operator can be compared to a camera’s automatic exposure: an average brightness 

value for the image is determined internally. Based on this, correct values for Exposure and F-Stop will be 

defined, using Photo Linear formulas. Subsequently, a gamma correction can be made using the Gamma 

setting.

Max White

This option determines the brightest point and sets it to white. The remainder of the image will be “scaled” 

relative to this point. If there are very bright regions in the image, darker regions will be made much darker or 

even black.

Reinhard 02

The Reinhard operator is based on tone mapping techniques used in photography. As you can see in the 

image below, bright regions are compressed in particular. This tone mapping method is the most widely used 

method for rendering.
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Pre-Scale primarily affects darker regions (higher values can be used to brighten shaded regions) and the 

Post-Scale is used to adjust brighter regions, and even blends between linear and exponential curve 

progression.

Three Reinhard curves with different Burn values from 1 to 3.
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Tone Mapping Example

The following scene is rendered without Tone Mapping:

The luminous material at the left has a brightness of 250%, a sphere lies at the right in the dark.

As you can see, there are over-exposed and very dark regions. 

The image below illustrates how some of the operators work. (Photo Linear is not used here because it 

behaves similarly to the other linear operators.)
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As seen in the image, Auto Linear works best (in combination with Gamma): Very bright regions are darkened 

and dark regions are brightened. Reinhard doesn’t work very well with this scene: very dark regions cannot be 

brightened adequately. The Reinhard operator works best for scenes with even lighting and no very dark 

regions (e.g., interior room renderings).

The linear operators don’t work well with the example scene, because they either darken bright regions, which 

makes dark regions even darker, or they brighten dark regions, which over-exposes brighter regions.
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Vignetting (Cineware Effect)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Vignetting is the effect of darkening an image to its edges (light that hits the lens axis at an angle does not fill 

the shutter opening entirely, due to the way the shutter is constructed).

See also Defining Color and Brightness Values and Adjusting Gradient Parameters.
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Global Illumination (Cineware)

This effect is available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Global Illumination (GI) is a sophisticated method for achieving realistic lighting effects in your model. The 

algorithm simulates the effects of not just direct light sources, but indirect light effects - that is, inter-reflections 

caused by light rays bouncing off surfaces.

With Cineware, you can achieve very high-quality renderings using Global Illumination. However, it can 

greatly increase render time.

Preset (Cineware Global Illumination)

Primary and Secondary Method (Cineware Global Illumination)

Sampling (Cineware Global Illumination)

Radiosity Maps (Cineware Global Illumination)

How Does QMC Work?

Irradiance Cache (Legacy) (Cineware Global Illumination)

Details (Cineware Global Illumination)

Watch the Video

Watch the Video

Watch the Video
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Preset (Cineware Global Illumination)

Presets are available for the optional Global Illumination effect, in the Detailed view of PhotoRendering 

Settings for the Cineware engine.

Since there are so many possible combinations of GI methods, this Preset option lets you save GI settings for 

specific types of Projects and Scenes.

It’s important to know how your Scene is set up. You should differentiate between two main types:

• Interior spaces are mostly illuminated by fewer, smaller light sources: light that falls through windows, 

and lamps that emit light within a limited radius. Interior spaces are therefore more difficult to calculate for 

GI.

• Exterior spaces are basically set up under an open sky. Skies emit light evenly from a large surface, 

which makes it easier for GI to calculate exterior scenes.

These presets should only serve as a starting point. These settings can then be fine-tuned to optimize render 

quality or render time.

List of Interior Presets

• Custom: As soon as you modify a GI setting, this option will be activated.

• Interior - Preview: Uses Irradiance Cache + Radiosity Maps. A fast preview with reduced Diffuse Depth.

• Interior - Preview (High Diffuse Depth): Uses Irradiance Cache + Light Mapping

• Interior - Preview (Small Illuminants): Uses Irradiance Cache + Light Mapping

• Interior - High: Uses Irradiance Cache + Irradiance Cache

• Interior - High (High Diffuse Depth): Uses Irradiance Cache + Light Mapping

• Interior - High (Small Illuminants): Uses Irradiance Cache + Light Mapping

Notes on Interior Presets

• Preview: These have reduced values, which can be calculated quickly and are well-suited for test 

renderings.

• High: Designed for higher quality renderings. However, it may be necessary to increase or decrease 

individual values to achieve the desired render speed/quality.

• High Diffuse Depth: Refers to the effects of numerous light reflections, which produce a much more 

realistic result with endlessly higher “sample depth”. Projects will tend to be rendered brighter; dark 

corners will also be brightened. This effect is created in conjunction with Light Mapping
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• Small Illuminants: Illumination will mainly be created by smaller lights that are defined as  Portals and 

Polygon Lights. IR+Light Mapping in combination with Force Per-Pixel is the best method of ensuring that 

small lights unfold their full potential.

List of Exterior Presets

• Exterior - Preview: Uses Irradiance Cache + Radiosity Maps. A fast preview with reduced Diffuse Depth.

• Exterior - Physical Sky: Uses Irradiance Cache + QMC.

• Exterior - HDR Image: Uses Irradiance Cache + QMC.

Notes on Exterior Presets

• Preview: These have reduced values, which can be calculated quickly and are well-suited for test 

renderings.

• The difference between Physical Sky and HDR Image: Force Per-Pixel is enabled for the latter. An HDR 

image assigned to a Sky object is evaluated precisely for rendering, which will more precisely render 

multiple shadows - if they are present in the HDR image (note that the Diffuse Depth value may have to be 

increased).

Object Visualization

Object Visualizations are well-lit and are most often centered in the composition, which means that they 

generally require few light reflections.

• Object Visualization - Preview: Uses Irradiance Cache + Light Mapping

• Object Visualization - High: Uses Irradiance Cache + Irradiance Cache.

Physical Renderer’s Progressive Sampler

• Progressive - No Prepass: Uses QMC + QMC.

• Progressive - Fast Complete Diffuse: Uses QMC + Light Mapping

These two options are designed for use with the Physical Renderer’s Progressive Sampler setting. You can 

quickly render rough images whose quality improves progressively and lets you check the overall render 

quality without long waiting periods until the image is completely rendered.
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Primary and Secondary Method (Cineware Global Illumination)

GI in Cineware works in two parts:

• The Primary Method calculates the effect of Diffuse Depth 1, which is

– the light emitted by polygon lights 

– or the light emitted by illuminated surfaces (via real light sources or the Physical Sky) without further 

reflection. The latter case results in the typical GI lighting with indirect reflection of light (e.g. a red 

sphere illuminated by a white light reflects red light).

• The Secondary Method calculates the brightness of surfaces (that do not have to lie in the camera’s field 

of view) that are brightened by multiple light reflections.

Primary Method only brightens surfaces that are directly lit.

Secondary Method is responsible for additionally reflected light.

In this example, only the Primary Method was used on the left picture. Both Primary and Secondary methods 

were used on the right picture.

In each picture, the left uses a polygon light, the right uses a normal light:

The results of both methods will be added to make up the overall GI when rendered.

The Primary Method is most important method for the render quality and therefore higher-quality methods 

such as QMC or IR should be used. These also take correspondingly longer to render! For light that is 

reflected back-and-forth, methods can be used that are of “lesser quality” and render faster (such as 

Radiosity).

Depending on the project’s setup, different methods can then be combined. Use the predefined Presets.

See Preset (Cineware Global Illumination).
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Tip: The two-part GI calculation already existed in previous versions: With Mode set to IR and Sampling 

set to Radiosity Maps, this corresponds to the current Irradiance Cache Primary Method and Radiosity 

Maps Secondary Method. 

In the following you will find a brief description of the individual methods.

Options for Primary Method

• Quasi-Monte Carlo (QMC): QMC is the most precise but slowest method. Animations are flicker-free (if 

not free of noise) when QMC+QMC is used.

For details, see How Does QMC Work?

• Irradiance Cache: A simplified, fast method of ascertaining the most important areas of a given project, 

calculating GI at these locations, and interpolating. Animations tend to flicker if the values are too low.

For details, see Irradiance Cache (Global Illumination).

• Irradiance Cache (Legacy): This is the Irradiance Cache from Cineware versions prior to V20. It has 

been maintained so older Projects can be rendered with the same render results.

For details, see Irradiance Cache (Legacy) (Cineware Global Illumination).

Options for Secondary Method

• Quasi-Monte Carlo (QMC): QMC as a Secondary Method is best when used as IR+QMC for exterior 

scenes, and most precise - and slowest - as QMC+QMC.

• Irradiance Cache: IC as Secondary Method works well for interior spaces with small lights defined as 

Portal or Polygon lights. Make sure to reduce the Samples value in combination with QMC+IR. Internally, 

a much greater number of QMC samples is used for IR, which can increase render times very 

dramatically.
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• Radiosity Maps: Radiosity Maps as Secondary Method are well-suited for fast preview renderings 

because of their low Diffuse Depth (less reflected light). 

For details, see Radiosity Maps (Cineware Global Illumination).

• Light Mapping: Light Mapping as Secondary Method works very well when rendering interior spaces 

where a lot of light is needed, which can be very quickly supplied by the high number of light reflections 

from Light Mapping.

For details, see Light Mapping.

• None: Disables the secondary GI calculation. This represents a Diffuse Depth of 1.

Intensity (Primary and Secondary)

Use these parameters to adjust the GI brightness based on the number of light reflections. The Primary 

Intensity parameter affects the regions being illuminated directly; the Secondary Illumination parameter affects 

reflected light.

From left to right, the following Primary/Secondary Intensity values:

100%/100%, 300%/100%, 100%/500%

Saturation

Defines the color saturation used within the GI calculation separately for the Primary and Secondary Method 

GI functions. This is especially useful if the Physical Sky produces shadows that are too blue. Try reducing the 

Saturation value for the Secondary Method. 

If other methods produce too little saturation (as is sometimes the case with IR/QMC as a secondary method), 

the Saturation value can be increased.

Note that if the Primary Method’s Saturation setting is set to 0%, no colors will be available for the Secondary 

Method.

A single blue Polygon Light lights the scenery, with various Saturation settings.

Note how the Secondary Method at the center emits colorless light.
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For Radiosity Maps, the Secondary Method’s Saturation will only affect real Area lights (not Polygon Lights) 

and/or Physical Sky (which is given a real light source via the Sun light).

Color saturations can also be modified for surfaces (see also Illumination (Cineware Surface Channel)). Both 

saturation parameters represent a global, project-wide saturation setting.

Diffuse Depth

Of the many GI-related parameters, the Diffuse Depth value (which can be defined only for the Irradiance 

Cache or QMC Secondary Methods) can make a significant difference in rendering quality. It defines the 

number of times light reflects in a scene, i.e. how often a “ray of light” is reflected from surfaces.

Greater Diffuse Depth values will result in moderately longer render times (the difference between a value of 

1and 2 is greater than that between 2 and 8) but the dispersion of light will become increasingly 

homogeneous, brighter and more realistic. However, the effect at values greater than 3 in a normal scene will 

become less and less noticeable and the rendered result will simply become brighter.

• The minimum Diffuse Depth value of 1 (as in the following image) results in only a direct illumination via 

flat, light-emitting elements. This will be sufficient for most external scenes, with Physical Sky or HDRI Sky 

providing a significant light source.

• A Diffuse Depth value of 3 (as in the following image) is required to achieve an indirect illumination, i.e. 

light reflected from other surfaces. A minimum value of 2 will be required for interior scenes.

Note that gamma correction can, within limits, be used to compensate for lower Diffuse Depth values.
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Tip: When “real” light sources are used, indirect illumination can already be achieved with a Diffuse Depth 

value of 1 because the objects illuminated by the light source will be recognized as a luminous object.

Gamma

This gamma value only affects the indirect GI lighting. Gamma values define how the internally rendered 

brightness values should be displayed in RGB mode. Simply stated, a progression from the darkest (black) to 

brightest (white) is defined.

This lets relatively dark renderings (e.g. resulting from a low Diffuse Depth value) be brightened. But be 

careful - high gamma values will reduce contrast and “flatten” the overall image (values ranging from 1 to 3 

have proven to be most effective; in some instances higher values may be necessary). Values less than 1 will 

darken the image, whereas values greater than 1 will brighten an image.
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Sampling (Cineware Global Illumination)

This setting is available, as part of the optional Global Illumination effect, in the Detailed view of 

PhotoRendering Settings for the Cineware engine.

The Sampling settings here only affect the GI sampling: How many samples should be sent and where in 

order to gather light from the environment? Samples are sent out hemispherically from the shading point (also 

called the “primary sampler”). 

The Sampling settings affect the GI sampling for the QMC and IR Primary Method (if these are also used for 

the Secondary Method, only a fraction of the value defined here will be used): 

The image below shows how the QMC GI Mode works.

In the image above:

• Left (Discrete Area Sampling and Discrete Sky Sampling disabled): At the first point of contact, several 

samples are sent out in a hemispherical direction (this is exactly what the Hemispherical Sampling option 

is meant for).

• Center (Discrete Area Sampling is enabled and Discrete Sky Sampling is disabled): In addition to the 

hemispherical sampling, several samples are also sent out in the direction of Portals and (polygonal) 

lights.

• Right (Discrete Area Sampling and Discrete Sky Sampling enabled): In addition to the hemispherical 

sampling and the Area light sampling, additional samples are sent out in the direction of the sky.

The Sampling settings described below primarily define if and how many samples are created on Sphere 1.
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In the following image, an Area light was positioned at the rear of the room. A window in the right-side wall 

looks out to a Sky object with an HDRI assigned to it (it can render hard shadows!). No other light sources 

have been placed in the project. The images were rendered with the QMC Primary Method (with the IC 

Method, you would see spots instead of graininess in the image).

• Left (Discrete Area Sampling and Discrete Sky Sampling disabled): This is not a viable option for this 

particular Project. The image itself is very grainy (the result of random samples hitting the Area light). The 

shadows are even more grainy. Bright points are also visible, the result of very few random samples hitting 

the (HDRI) sky’s sun.

• Center (Discrete Area Sampling enabled and Discrete Sky Sampling disabled): The general graininess 

has been greatly reduced because additional samples are being sent to the Area light (each point visible 

to the camera is analyzed, which results in a highly defined shadow for the Area).

• Right (Discrete Area Sampling and Discrete Sky Sampling enabled): In addition to the hemispherical 

sampling and the Area light samples, additional samples are sent in the direction of the sky. This 

abolishes the bright points, because every point visible to the camera is precisely analyzed with regard to 

the sky’s influence (including its effect on the remaining project elements).

In general, you can leave Discrete Sampling enabled. Disable it only for special instances, to intentionally 

exclude one of the Sampling modes. The difference in render time will be noticeable if no Area light or sky is 

present in the project.

The description of the following settings applies to the QMC Primary Method. The same applies to the IR 

method, except that sampling takes places for each shading point, rather than for each pixel.

Stochastic Samples

Method: Two methods of defining sample count are used:

• An automatic determination controlled by one of the quality settings (Low, Medium, High, Accuracy)
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• A fixed number of samples defined by the Sample Count setting

– Selecting Custom Sample Count lets you manually define the Sample Count value

– Selecting Custom Accuracy lets you manually define the Accuracy value

Accuracy: Use this setting to define an optimized sample count. The optimal count depends on the Project 

(and in IR GI Mode, on the other Irradiance Cache settings as well) and of course the defined Accuracy value.

Sample Count: This setting defines the fixed number of samples to be used. A higher value produces a 

correspondingly better render quality (for QMC this can be seen in the graininess; for IR the number of spots 

is reduced).

Increasing Sample Count (left to right)
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This rendering Sample Count will also be used by the Discrete Area and Discrete Sky Sampling if they do not 

have a custom count defined (see below).

Discrete Area Sampling

Check Use Area Sampling to enable this method.

In order for this sampling type to work, the GI Area Light option must be enabled in the Surface’s Illumination 

channel.

See Illumination (Cineware Surface Channel).

This sampling method sends additional samples to (polygon) Area lights. This will emphasize them 

disproportionately, which will have a major effect on the quality of the GI.

At center: Discrete Area Sampling disabled, at right: enabled

Note that even if you disable this option, the Area lights will NOT be omitted from the GI calculation. These 

lights will merely receive no special attention and will be hit randomly by the hemispheric sampling (with a 

correspondingly grainy result).

Force Per-Pixel: This option is only advantageous in IR Primary Method. Normally every light will be taken 

into consideration for the cache when an Irradiance Cache is created. However, this does not work if you have 

very small, bright Area lights. The result will be spotty images. If you enable the Force Per-Pixel option, the 

calculation of the Area lights will be split from the cache and calculated separately (as the QMC method does 

by default) for each potential pixel (object surfaces but no backgrounds or skies, for example).
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At left, Force Per-Pixel disabled, at right: enabled

Custom Count/Sample Count

Use these fields to define a custom sample count. If Custom Count is disabled, the same number of samples 

will be used as defined in Stochastic Sampling.

Discrete Sky Sampling

Check Use Sky Sampling to enable this method.

This sampling mode takes into account the sky in particular (e.g., the Physical Sky or a HDRI Sky).

A sky map will be calculated internally during rendering, which will then concentrate the additionally created 

samples primarily on the brightest regions during rendering. This means that HDRI textures with enough 

contrast can cast shadows with locally very bright regions.

The only source of illumination here is the HDRI texture on a Sky object.

Note the relatively hard shadow (option disabled at left). 
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If this option is disabled, the sky will NOT be omitted from the GI calculation. The sky will merely receive no 

special attention and will be hit randomly by the hemispherical sampling (the extremely bright sun will produce 

a grainy image).

Force Per-Pixel: This option has advantages only for the IR Primary Method. When an Irradiance Cache is 

created, the sky will normally be sampled and taken into consideration for the cache. For bright regions (sun) 

or those with smaller surfaces, this method has limits and will result in spotty renderings.

If you enable Force Per-Pixel, the calculation of the light emitted by the sky will be split from the cache and 

calculated separately for each pixel that comes into question (object surfaces but no backgrounds, skies, 

etc.), which is how the QMC method works by default.

A Sky object with an HDRI texture applied to it is located behind the window.

At left, Force Per-Pixel disabled, at right enabled.

Custom Count/Sample Count

Use these fields to define a custom sample count. If Custom Count is disabled, the same number of samples 

will be used as defined in Stochastic Sampling.
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Radiosity Maps (Cineware Global Illumination)

This setting is available, as part of the optional Global Illumination effect, in the Detailed view of 

PhotoRendering Settings for the Cineware engine.

When using the Secondary Method, Radiosity Maps are a quick and easy to use function that is particularly 

well-suited for preview renderings.

Simply put, illumination (light sources, Area lights, sky) on polygons is calculated internally as special textures 

(Radiosity Maps) during rendering, prior to the actual GI calculation. These Radiosity Maps are then used 

during the actual GI calculation for faster rendering. This method has several advantages and disadvantages:

Advantages:

• GI calculation is faster

• Radiosity Maps can be saved and re-used.

Disadvantages:

• The actual diffuse depth (number of diffused light reflections) is 1 (2 in the case of Area lights and/or 

skies), which darkens the rendering. To some degree, this can be offset by increasing the Gamma value.

• More memory is required

• When using simplified geometry (e.g., single-polygon walls without thickness), light can seep through. 

This can be prevented by modeling more realistically, i.e., giving walls a thickness.
ARCHICAD 24 Reference Guide 3654



Dialog Boxes User Interface Reference
In the example above, the render time was greatly reduced while achieving a similar result.

The use of Radiosity Maps darkens (reduces diffuse depth) the corners and shadows somewhat.

Tips:

• Radiosity Maps can be made visible (set the Mode control to “Shading”).

• Radiosity Maps should have a light dispersion that is as homogeneous as possible.

Map Density

Use this setting to define the Radiosity Map resolution. The higher the value, the smaller the Texels will be 

(the small squares for which a uniform color/brightness is ascertained) and the higher the quality of the 

Radiosity Map will be (with correspondingly longer render times and increased memory requirements).

At left a Radiosity Map of poor quality, at right of better quality

You can make Texels visible without complicated calculations by setting the Mode to Texels and rendering the 

Project.

If the Texels are too large and light seeps through, reducing the size of the Texels can help alleviate this 

problem.
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Light Mapping

Simply stated, the Light Mapping method works as follows: A series of samples are emitted into the scene 

from the angle of view of the camera. These samples are often reflected (depending on the Maximum Depth 

value), unless the sample doesn’t first strike the sky or doesn’t strike anything at all. The colors calculated 

when geometry is struck are evaluated. Entire sample chains result, which can be calculated very quickly 

(also for high numbers of reflections) and in consideration of other sample chains - faster than all other GI 

methods. The calculated colors are saved in a cell pattern (or as a file, if desired, which can be re-used later) 

and then made available using the Primary Method, which itself uses the Light Map with a sample depth 

greater than 1 when gathering light (samples).

Note that the rendered image will more often be brighter due to the high sample depth, which is higher than 

that of other GI methods. To compensate for this brightness, reduce the Intensity value.

This method has both advantages and disadvantages:

Advantages:

• Very fast GI calculation (with very high sample depths)

• Light Maps can be saved and re-used to a certain degree (these are dependent on the angle of view) 

Disadvantages:

Light leaks can occur (these can be minimized by reducing the Samples Size value and by not using 

interpolation. Using thicker objects instead of single polygon surfaces also helps).
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Light Map Characteristics

First, we will take a look at what a good Light Map looks like (you can make a Light Map visible by setting the 

Mode to Visualize):

At the top left and top right are poor and better quality Light Maps, respectively. Good Light Maps have a 

homogeneous light progression; in contrast, Light Maps with poor quality appear heterogeneous. When 

rendered, the difference is not as apparent, because the Primary Method takes numerous Light Map samples 

with numerous samples and produces median values. Nevertheless, the Primary Method will deliver sub-

optimal results, even with the best settings, if the initially calculated Light Map was of poor quality. This can be 

seen at the bottom left of the image, where flickering occurs in the regions around the window and beneath 

the left ball.
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Light Mapping Settings

The Prefilter and Interpolation Method functions can be used to remove the cell pattern and for smoothing 

(both render very fast), in order to achieve the most homogeneous light dispersion 

Path Count (x1000)

Next to the Record Density setting, Path Count (1000s) is the most important setting for adjusting Light Map 

quality.

The Path Count (1000s) value (which is multiplied internally by 1000) defines the number of samples that 

should be calculated for the entire scene. A sample chain with a depth corresponding to the Maximum Depth 

value will be generated.

Left: Smaller Path Count (1000s) values. Right: Larger values.

The higher the number, the more homogeneous the light dispersion will be and the longer the corresponding 

render times will be. Also, the higher the Path Count, the more samples will be used per cell element and the 

random color divergence (at the top of the image, a sample coincidentally strikes a black seam) of 

neighboring cells will be smaller
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Samples Size

Left: Larger Sample Size values, Right: smaller values

Use these values to define the cell size. The smaller the cells, the more accurate the result will be with regard 

to details. Cells that are too large will quickly lead to light leaks and are less precise with regard to details 

(shadows will be lost here and there). Depending on the Scale defined (see below), Sample Size can be 

defined as absolute (World) or relative (Screen).

Scale

Select from the following options:

• Screen: The cell diameter is defined as a fraction of the output size. A value of 0.1 represents 10 cells 

wide. The cell depth will decline for geometry in the distance.

This setting is affected by several algorithms, which use other criteria (e.g., very small Sample Size values 

will produce larger cells and geometry such as spheres will have smaller cells) to dynamically determine 

the cell size.

• World: The Sample Size values can be output as absolute in the world coordinate system. Sample Size 

will represent the approximate diameter of a cell, which means that the cell density will appear greater on 

distant geometry than on geometry that lies nearer.

Direct Lights

Enabling this option will speed up rendering for projects with a high number of real light sources. For GI 

calculation, surfaces illuminated by light sources will be placed directly into Light Maps: 
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Enabling this option will speed up rendering for projects with a high number of real light sources. For GI 

calculation, surfaces illuminated by light sources will be placed directly into Light Maps:

Left: Direct Lights disabled; right: enabled. The strip of light is the light emitted by 120 Spot lights.

The gain in render speed can be quite substantial, depending on the scene (simply put, light source 

information gathered during Light Map calculation is subsequently re-used by the GI Primary Method). Very 

good results at moderate render times can be achieved when using QMC+LM.

The following image was rendered using QMC+QMC (Record Density of 8) on the left, QMC+LM (Direct 

Lights disabled) at center, and QMC+LM (Direct Lights enabled) at right:

Note how much faster and better Direct Lights renders. The Light Map’s high Record Density produces a 

brighter and more realistic image.

Show Preview Paths

This option does not affect the Light Map directly. If enabled, the progress of the samples just calculated will 

be shown during calculation, then compiled according to Sample Size in a cell and averaged.

Build Radiosity Maps

Enabling this option is like switching on a turbo charger. If enabled, the Light Map will be calculated and it will 

then be converted to a Radiosity Map, which will be used internally for rendering. This dramatically reduces 

render time while basically maintaining the same level of quality (both with IR+LM and with QMC+LM).

• Disadvantage: Radiosity Maps require a lot of memory for the saved cache on the hard drive as well as 

RAM. Problems can occur with complex projects. Rendering a Light Map with the right settings is also 

very fast.
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Map Density

This setting works like the Map Density Radiosity Map setting of the same name, but the sampling is much 

faster. This is where you adjust the texel size.

See Map Density for the Radiosity Map.

Sampling Subdivisions

This setting works like the Sampling Subdivisions Radiosity Map setting of the same name, but the sampling 

is much faster. This is where you adjust a type of “antialiasing” for the texels.

Prefilter

Check this box to enable the Prefilter option.

The Prefilter ensures that a heterogeneous, spotty Light Map (or Radiosity Map) is converted to a more 

uniform map before they are used for rendering or one of the following interpolations.

This is done per cell. Depending on the settings, the colors of several neighboring cells will be averaged and 

then assigned to the cell. This process is calculated very fast and has basically no effect on render time.

However, note that a type of blur effect takes place that can swallow details and lead to light leaks (which can 

be compensated for by improving the Path Count (1000s) and Sample Size settings).

Left without Prefilter, right with Prefilter.

Note: Both the Prefilter and the effect of the interpolation methods are always calculated anew during 

rendering.
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Prefilter Samples

Use this setting to define the size of the radius for the current cell by averaging surrounding cells.

Values that are too large will swallow details and lead to light leaks.

At left a small Prefilter Samples value, at right a larger value.

Note that contact shadows and light leaks are present on the right.

Interpolation Method

During rendering, the Light Map’s (or Radiosity Map’s) cells are actually interpolated so the cell structure is 

dissolved if the settings’ values are high enough. This will produce even brightness progressions.

Even better results can be achieved in combination with the Prefilter. However, interpolation requires a 

corresponding amount of additional render time and correspondingly more light leaks will result with larger 

interpolations.

The pre-filtered Light Map on the left has interpolation added at the right.

Method

Choose a method for planar interpolation of discontinuous color gradients (cells):

• None: No interpolation will be made (the calculation is very fast); light leaks will be minimized but the 

Primary Method for GI will see the cells. Sufficient pre-filtering can help.
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• Nearest: A specific number of neighboring samples (defined by Sample Count) is ascertained and their 

colors are averaged. This is not an absolute value, because it also considers the Samples Size value. The 

sample density will reduce the radius in which the samples lie.

• Fixed: In conjunction with the Size Ratio value, a fixed distance around the point to be calculated is 

ascertained within which samples are obtained. This method produces the most “blurred” results.

See the image below for an illustration of these effects. (For illustration purposes, Prefilter was not used):

Prior to interpolation. 
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Various interpolation methods and settings.

Mode

Select which Light Map should be displayed:

• Visualize: The Primary Method for GI will not be calculated, and only the Secondary Method will be 

displayed. This mode is suitable for fine-tuning a Light Map prior to rendering.

• Normal: The final rendering must ALWAYS be done in Normal mode
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How Does QMC Work?

Left, rendered with QMC+QMC, right with IR+IR. 

Note the increased level of detail (shadows) in the QMC rendering.

The QMC method of Global Illumination calculation works under a so-called “brute force” principle. This 

means that, for each object pixel in the image, a definable number of rays (“Sample Count”) can be “beamed” 

in a hemispherical pattern into the scene. This is not an adaptive process, and render time will definitely not 

be reduced.

Its advantage is that it offers the most precise render results. Small details in shadows and shading can be 

rendered out that would otherwise not be noticeable if the IR method were used.

Disadvantages of using QMC as primary method:

• The render times are maxed out (much longer than with Irradiance Cache) and, since brightness and 

color values based on a finite and randomly distributed number of rays (“Sample Count”) is ascertained for 

each pixel, the images will have a slight graininess to them that can only be compensated for by 

increasing the sample count, which in turn increases render time accordingly. Using Polygon Lights/

Portals (indoor scenes, primarily illuminated by light falling through windows) can noticeably improve 

render quality (which also saves render time).

• No caching takes place (as well as no pre-pass calculation). Hence, a lot of CPU power is needed (e.g., 

render farms) to render animations at an acceptable level of quality. 
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Irradiance Cache (Global Illumination)

A new Irradiance Cache method was introduced as of ARCHICAD 20. This method bears the following 

advantages compared to other methods:

• Small details such as contact shadows - i.e., those produced where objects meet, at corner edges, etc. - 

are of much higher quality (with the right settings in the quality of a pure QMC rendering).

• New algorithms speed up rendering.

The Irradiance Cache (Legacy) method is still available. See Irradiance Cache (Legacy) (Cineware Global 

Illumination).

Improved rendering of contact shadows (e.g., in the regions marked in the image on the left).

Model by Steen Winther.

Note: All images on this page were rendered using Irradiance Cache, both as Primary and as Secondary 

method.
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What is an “Irradiance Cache?”

Several pre-calculations (“pre-passes”) are made during IR rendering in which the scene is analyzed in order 

to ascertain the most important indirect lighting regions (the “shading points”, which are the points displayed 

during pre-passes; these become very apparent when using lower Density values). See below for more 

details:

Brightness and color values for the shading points (upper image) are interpolated 

to ensure a homogeneous dispersion of light (lower image).
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The brightness and color values for these shading points will be saved in the Irradiance Cache as so-called 

“entries”. These Irradiance Cache entries are interpolated during final rendering to supply pixels that lie 

between shading points with indirect light.

Disadvantages

• When interpolating between the limited number of shading points, details with regard to light and shadow 

can be lost (however, not nearly as drastically as with the Legacy method). In this regard, QMC still has 

the advantage.

• Remember that the QMC mode always offers the best GI quality with regard to light and shadow 

dispersion (and unfortunately the slowest). Irradiance Cache always attempts to produce a result as 

closely as possible to QMC.

• Generally speaking, Irradiance Cache tends to flicker most if very bright and small Polygon Lights are 

used. Large, homogeneous light sources (e.g., a sky used for illumination from which light is emitted 

evenly from many sides) are especially IR-friendly.

Notes: 

– The following settings can also be found in the Ambient Occlusion’s settings. The basic principle with 

which they function is the same (AO, however, only has a Record Density depth of 1).

– If you get spotty results, these can most often be eliminated by using a higher Record Density value. 

Improving the Secondary Method’s settings will help.

Record Density

Most of the following settings will only be used for fine-tuning. For most instances, the Record Density settings 

Low, Medium and High in conjunction with corresponding values for the settings below will suffice. The 

Preview mode offers a quick preview of the final result. Custom will be made available as soon as the Record 

Density value is changed manually.

Generally speaking, the Record Density value must only be modified if, for example, a Polygon Light’s (e.g, 

Portal’s) hard shadow should be shown (and you don’t want to use the slow Force Per-Pixel).

Min Rate/Max Rate

When rendering with Irradiance Cache, several pre-passes will first be calculated (the phase in which squares 

appear that successively become smaller). During this phase, the dispersion of shading points will be 

ascertained. This is an adaptive process in which particular emphasis is placed on critical regions: corners, 

shadow edges, etc. The difference between Min Rate and Max Rate defines the number of pre-passes.

A value of 0 produce a full resolution image (pixel size 1*1) and a value of -1 will produce a pixel size of 2*2, -

2=4*4 and so on. Logically, the Min Rate value should always be less than the Max Rate value. Positive 

values are, however, also possible, which allow sub-pixel cache entries (this can be useful for Subpolygon 

Displacement if details are lost). I

n the end, these settings are not as important as they were for previous IR. Render times differ only nominally 

and as long as the values are kept reasonable (Max Rate not less than 0), the render results will not differ very 

much, either. If negative values are used for Min Rate, and Max Rate is set to 0, you’re pretty much on track.

Density

Minimum Spacing/Maximum Spacing 

Density: General shading point density. The Density value adjusts the general dispersion of shading points in 

consideration of the following two settings.
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Minimum Spacing: Shading point density in critical areas (e.g., corners, shadows).

Maximum Spacing: Shading point density in non-critical areas (e.g., plane surfaces).

Increasing Density values from bottom to top

It makes sense to describe these three settings together because all three work together to define the shading 

point density in critical and non-critical areas:
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The following image shows the effects of the above-mentioned settings:

Different variations of the Density, Minimum Spacing and Maximum Spacing settings

Tips for a Cleanly Rendered Image

• Use a high number of shading points in critical areas

• Use a reasonable density value in the remaining areas

• Make sure that each shading point has as many Samples as possible

Smoothing

In general, you will rarely need to modify the Smoothing setting.

All previously described settings involve the positioning and calculation of shading points, and indirect lighting 

is ascertained at numerous locations. This point-by-point dispersion of brightness must be converted to a 

planar dispersion during rendering. A smoothing algorithm does this in the following way: For each pixel to be 

rendered for a given object, Irradiance Cache is scanned to find entries in their close proximity to interpolate 

their brightness and color values.

The higher the Smoothing value, the more shading points will be used for interpolation to render a given pixel. 

This setting represents a threshold value that determines whether or not a given cache entry in its proximity 

will be used. Smaller values generally produce a sharper (and often more spotty) result, whereas larger 
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values will interpolate across larger areas, which results in a more uniform illumination but also means that 

small details will be lost. 

Color Refinement

Increasing this setting’s value will improve the render quality in regions in which GI lighting changes abruptly 

(e.g., GI shadows on bright Polygon Lights). What happens is that additional shading points will be generated 

(with a corresponding increase in render time). 

A higher Color Refinement value produces a more defined cast shadow

Important: You should increase the Record Density enough so the dispersion of light is homogeneous, 

otherwise spotty regions will result in regions in which GI lighting changes abruptly.

GI Caustics also benefit from higher Color Refinement values:

Caustics rendering (right), which took a fraction of the time to render compared to QMC

Screen Scale

With Legacy version of Irradiance Cache, the shading point dispersion was done independently of the size of 

the rendered image, i.e., the same pre-pass was used for an image 80 x 80 pixels as for an image with a 

resolution of 1024 x 768. Enabling the Screen Scale option will adjust the shading point density to the image’s 

resolution. This means that correspondingly more cache entries will be created for an image with a very large 
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resolution than for an image with a very small resolution. Hence, smaller images will render faster and larger 

images will render more slowly, which also means that more details will be visible.
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Irradiance Cache (Legacy) (Cineware Global Illumination)

These settings are available, as part of the optional Global Illumination effect, in the Detailed view of 

PhotoRendering Settings for the Cineware engine.

These parameters are available if GI Method is set to Irradiance Cache (Legacy).

For more information, see Options for Primary Method.

Generally speaking, the predefined values in these additional settings do not have to be modified.

General

Interpolation Method

Different algorithms can be used to calculate the transition between light and dark regions and between color 

values between the Shading points. 

• Least Squares: This function essentially calculates a curve based on a limited number of points.

• Delaunay: In contrast to the Least Squares interpolation method, only neighboring records and not those 

located further away will be included in the interpolation for rendering. However, in order to achieve 

homogeneous dispersion of light, the Record Density, a.k.a. shading point density, should be very high. 

The Record Density parameter offers several Delaunay preset options that can be used for this purpose 

(see Record Density, below).

The Delaunay option is in fact intended for use in special circumstances and is not really suited for use in 

“normal” renderings.

• None: If this option is selected, no smoothing will take place.

• Weighted Average: This method of interpolation works similarly to the Least Squares method, except 

that it only interpolates between values (whereas the Least Squares method can also extrapolate, i.e. for 

brighter or darker results than those represented by the defined values). This method can prevent 

artifacting when using low-quality GI settings. Furthermore, this method will render faster than the Least 

Squares method. Disadvantage: The dispersion of light is less homogeneous than when using the Least 

Squares method.

Distance Map

If, in relation to the total number of image pixels, only very few Shading points are interpolated, primarily soft 

shadows will be created and many details will be lost or smoothed too much. This can, for example, lead to 

light seeping through polygons. For example: in the form of sunlight seeping through an outer wall and being 
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visible somewhere in the room. Enabling the Distance Map option can prevent this from happening - but will 

also increase render times accordingly.

Check Record Visibility

Similar to the Distance Map functionality, this option is also designed to block light from seeping through 

polygons. Enabling this option will include objects that do not lie directly in the camera’s line of view.

Record Density

This value defines the density and dispersion of the Shading points in the prepass phase. The information that 

these Shading points gather about the Stochastic Samples will then be interpolated between the Shading 

points to create soft transitions. The more Shading points that exist, the more exact the transition between 

light and dark regions in the scene will be - and the longer the Prepass and total render time will be.

Method: This parameter contains a set of predefined parameters that are by default optimized for most uses. 

Only under special circumstances should you change the option to Custom and modify these parameters 

yourself.

• Preview: As the name suggests, a preview will be rendered quickly - with correspondingly “poor” values 

that make a quick rendering possible. These “poor” values will result in many GI details being lost or in 

faulty rendering.

• Low/Medium/High/High (Details): These four options are optimized for use with the Least Squares 

interpolation method and result in differing levels of quality.

• Low (Delaunay)/Medium (Delaunay)/High (Delaunay): These three options are designed for use with 

the Delauney interpolation method. This interpolation method requires a very dense dispersion of shading 

points.

Min Rate/Max Rate

When the program creates an Irradiance Cache, it initially starts with a lower image resolution (Min. Rate) and 

progresses to the final IR resolution (Max. Rate). A value of 0 results in full resolution (pixel size 1*1), a value 

of -1 results in a pixel size of 2*2, a value of -2 = results in a pixel size of 4*4, and so on. The Min Rate value 

should logically be smaller than the Max Rate value. Positive values can also be applied, which will allow 

cache Records in the sub-pixel range (can be useful for SubPolygon Displacement if details are lost).

These resolutions apply only to IR calculations. Since the Irradiance Cache can be scaled relatively easily (i.e. 

lower IR resolution at larger image resolution), good results can often be achieved even when using smaller 

resolutions. Hence, these two parameters offer great potential for shortening render times, especially for 

brightly illuminated, low-detail scenes.

Radius

This parameter defines the maximum distance between shading points. The lower the value the more densely 

the points will lie together. This parameter primarily affects non-critical regions of the scene such as flat, clear 

surfaces. The effect of this parameter is also dependent on the Density Control value.

Minimum Radius

This parameter defines the minimum distance between shading points. It primarily affects the critical regions 

of the scene such as corners, edges, etc. The lower the value the more densely the shading points will lie at 

these regions. This parameter works in proportion to the Radius parameter above, i.e. if this value is halved, 

the Minimum Radius value will be halved as well.
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The Minimum Radius parameter primarily affects areas in which details are important (e.g. subtle shadows). 

However, too many shading points in these areas can cause problems.

To make subtle details visible, use the Details Enhancement parameters instead. 

See Details Enhancement, below.

Density Control

In contrast to the previous two parameters that primarily affect critical or non-critical regions, this parameter 

affects the shading points globally throughout the scene. The higher the value the greater the density.

Use Proximity Correction

This parameter is responsible for having neighboring shading points “assist” each other in critical regions and 

pass on information regarding the proximity of geometry. New shading points are created and calculated 

during this process.

This behavior can be disabled here, which will save some render time but also result in poorer render quality 

(especially at corners and edges).This option should be disabled if you are using a Max. Rate value of less 

than 0. Otherwise unnecessary calculations will result.

Smoothing

Increasing the Smoothing effect results in more lost details, but also in a more homogeneous dispersion of 

light.

• Method: Use the pop-up to define the level of smoothing. Select Custom to manually define the Records 

and Scale values below. 

The Records and Scale values limit the number of shading points to be used.

• Records: The Records parameter defines, for each pixel to be rendered, the maximum number of 

surrounding Records in the Irradiance Cache that should be included in the interpolation of color and 

brightness for that pixel. If, however, the Scale value is so low that not enough Records can be included in 

the interpolation, it may result in fewer Records being included.

The lower the parameter value, the fewer Records that will be included in the final interpolation and the 

less homogeneous the rendering will turn out. Higher values will result in more smoothing but also take 

correspondingly longer to render.

• Scale: This parameter serves to spatially limit the Records included in the interpolation process. The 

larger the value, the more Records will be included and the softer the interpolation will be - and the longer 

it will take to render. Alternatively the Records parameter can be used for this purpose.

Cache Refinement

The previously described parameters all dealt with the placement of shading points based on a scene’s 

geometric properties. But what if a coarse, dark GI shadow disturbs the entire image?

This is where the Cache Refinement parameter comes in: It compares the Records in the Irradiance Cache 

and generates additional Records (i.e. shading points) in areas with high contrast (brightness and color) in 

order to refine and render these areas more precisely.

Tip: Refining the cache can greatly increase the number of Records in the Irradiance Cache, which will 

not necessarily improve the render quality. Especially when applied in conjunction with incorrect 

smoothing, this can lead to very grainy results. Hence, only refine the cache if absolutely necessary.

Higher Cache Refinement settings will lead to longer render times but not necessarily to better render quality.
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Passes [0..4]: Use this setting to set the frequency with which the cache should be defined. Each new pass 

includes the results of the previous pass and refines it further by creating additional shading points in critical 

areas.

Color Threshold: This value defines the degree to which (neighboring) cache Records can deviate from each 

other with regard to their color (intensity) before additional shading points (“Samples”) are added. The lower 

the value, the lower the deviation threshold will be and the more samples will be added.

Top: Prior to cache refinement. Bottom: After cache refinement.

Left: smaller Color Threshold, right: larger Color Threshold value.

Cutoff: This value includes differences in intensity. The lower the value, the greater the differences between 

Records have to be for the color correction to apply. A value of 0 will turn cache refinement off.

Strength: This parameter is used to adjust the cache refinement’s overall sample density. A value of 0 will 

turn cache refinement off, whereas larger values will increase the number of shading points (“Samples”) 

correspondingly while taking into account Color Threshold and Cutoff values.

Details Enhancement

The Irradiance Cache method renders noise-free and much faster than other sampling methods, but entails 

compromises on details that lie in shadowed areas. This can result in the omission of finer details, such as tile 

grouting, during the smoothing process. Enabling Details Enhancement will counteract this by sending 

additional samples specifically to these areas. The effect is similar to Ambient Occlusion.

In a nutshell: Subtle geometry details are accentuated.

In order to save render time and avoid over-emphasizing finer details, either Ambient Occlusion or the Details 

Enhancement option should be used, but not both. Using both can make fine details visually too dominant. 

Since enabling the Details Enhancement option will send additional samples into the scene, you may also 

want to consider reducing the Record Density value.

The Details Enhancement parameters include options to counteract a characteristic of the Irradiance Cache - 

the “blurring” (smoothing) of details such as subtle shadows. The enhancement of details uses the QMC 

Sampling method in critical areas (for each relevant pixel) like corners, edges, cavities, etc. The Details 

Enhancement functionality can be seen as a special type of Ambient Occlusion whereby indirect light is 

included.
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Note that the internal Irradiance Cache will be calculated differently (the algorithm will be aware of the 

subsequent detail enhancements and will calculate the critical areas differently) if this option is disabled. 

However you do it, the Details Enhancement will be calculated separately for each rendered image, i.e. re-

using a saved cache will reduce render times.

If you apply Details Enhancement, you can lower the other Irradiance Cache settings (especially those 

pertaining to Record Density).

• Details Enhancement: Check this box to enable the Details Enhancement parameter.

• Adaptive: Enabling this option can be an advantage in some circumstances, e.g. several small areas are 

more grainy than others. Additional samples will then be rendered in these areas.

• Estimate Secondary: This mode renders faster and offers good results for most applications. However, 

certain areas will be rendered too dark or too colorful as opposed to a pure QMC rendering (GI Mode 

QMC), which in most cases doesn’t matter at all. If desired, this behavior can also be disabled (note that 

grainy renderings can result, in which case the Quality Ratio value should be raised).

• Radius: Use this setting to define the radius within which neighboring objects, corners and edges should 

be included. Lower values result in only elements in the immediate proximity being “seen”, whereas larger 

values will “see” elements correspondingly far away. Larger values will also result in higher precision and 

therefore longer render times.

• Quality Ratio: As mentioned, QMC Sampling will take place in critical areas. The Quality Ratio defines 

how many samples should be used per pixel, which in turn simply defines the graininess of the Details 

Enhancement. Larger values result in less grainy, softer results but require correspondingly longer render 

times.

Quality Ratio is an autonomous value that works independently of the rest of the IR settings (a value of 

100% is equivalent to 64 samples).

• Mode: The options in this drop-down menu are for test purposes only so the effects of the detail 

enhancement, which are often very subtle, can be made more visible. You can select from the following 

options:

– Combine (Normal): Renders accurate results.

– Details Only (Preview): Renders detail enhancement without GI. Makes the detail enhancement the 

most visible of all the options.

– Global Only (Preview): Renders indirect illumination only.
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Details (Cineware Global Illumination)

These settings are available, as part of the optional Global Illumination effect, in the Detailed view of 

PhotoRendering Settings for the Cineware engine.

Glass/Mirror Optimization

The effect of GI on glass is barely visible and can therefore unnecessarily take up render capacity. To avoid 

this, use the Glass/Mirror Optimization parameter. As a result, surfaces with a Brightness value (in the 

Transparency or Reflectance channels) greater than the value defined in this parameter will not be illuminated 

by GI. This may result in somewhat darker (but faster) renderings.

This parameter has no effect on Caustics!

For example, a lot of render time can be saved when visualizing a structure containing numerous large glass 

surfaces.

Tip: In order for this parameter to work, the surface channel “Color” must be disabled and no texture 

should be present in the Transparency channel.

Refractive Caustics/Reflective Caustics

Individually enables or disables Refractive and Reflective Caustics.

What are Caustics?

In the real world, caustics occur everywhere where light is clustered or reflected by refraction (see image 

above) or mirroring (e.g., on a metal ring).

There are two types of caustics in Cineware:

• Photon caustics in earlier versions of Cineware: Faster than GI Caustics but must be generated using 

individual light sources.

• Irradiance Cache GI Caustics: In conjunction with Primary Method IR. Not very precise but affect all 

luminous surfaces within a scene.

To generate caustics in previous versions of Cineware, it was necessary to create light source objects from 

which photons were beamed throughout the scene. In contrast, GI Caustics uses any available light source 

(exception: Only the reflected light of regular light sources can be included; use Polygon Lights instead).
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GI Caustics require bright light (e.g. HDRI images with very bright regions or Area Lights) to come to fruition. 

Otherwise you can increase the strength of the Generate GI parameter in the Illumination channel of the 

Glass surface.

Tip regarding reflected GI Caustics: Reflected GI Caustics always require an active Reflectance 

surface channel. Otherwise, you can achieve the best quality caustics if GI Method is set to QMC.

Diffuse Illumination Only

Activating this option deactivates textures, reflections, light from surfaces illuminated directly by light sources, 

etc. All bothersome elements will be deactivated and only the brightness dispersion calculated by GI will be 

rendered. This also lets you judge the quality of the GI.

This option should be deactivated for the final rendering.

At top: normal rendering. Bottom: Rendering with active Diffuse Illumination Only option

(the sun is a real light source which means that its effects will be rendered 

following the first reflection).

Show Samples

Shading points are displayed during the prepass phase for Irradiance Cache calculations. Sometimes these 

can be irritating when trying to assess the prepasses. To avoid this, disable the shading points’ display. The 

render time will be reduced slightly and the final render result will not be affected.
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Physical Renderer (Cineware)

These settings are available if you check the Use Physical Renderer box in the Detailed view of 

PhotoRendering Settings for the Cineware Engine.

For information on choosing a Rendering mode, see Physical vs. Standard Renderer.
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Physical Camera

Depth Of Field

Enables or disables the depth of field for the Physical Renderer.

Strictly speaking, a real camera can only focus clearly on a single distance at a time. Everything in front of and 

behind this plane appears increasingly blurry. The area between the nearest and farthest objects that appears 

focused is known as depth of field.

For more information on how Depth of Field works, see also Depth of Field (Cineware Effect)

Camera F-Stop

The F-Stop value is used to adjust the focal aperture. The larger the focal aperture (i.e. the smaller the F-Stop 

value), the smaller the depth of field will be and vice-versa. F-Stop is the most important setting for adjusting 

the depth of field. Small values result in correspondingly small depth of field. F-Stop will also define the 

amount of light that can enter the camera.

Camera Exposure

If Exposure is enabled, the camera will simulate the exposure process, i.e. the rendered image will vary in its 

brightness in correspondence with the ISO, F-Stop and Shutter Speed settings.

In a real camera, the amount of light to which the film is exposed determines how bright the film will be. The 

more light to which the film is exposed (the larger the aperture opening is larger, or the slower the shutter 

speed), the brighter the film will turn out and vice-versa.

Camera ISO

ISO is used to define the film’s sensitivity to light. Higher ISO values make the film more sensitive and thus the 

images brighter.

Camera Shutter Speed

The shutter speed defines how long the shutter will remain open when a picture is taken. This setting defines 

the amount of light that reaches the film (only relevant if Exposure is enabled). Slower shutter speeds produce 

brighter images.

If you don’t use Exposure, this setting has no relevance for the rendered image.

Camera Chromatic Aberration

Chromatic aberration occurs in lenses when differently colored parts of light (depending on the wavelength) 

are refracted with varying intensities. Chromatic aberration only occurs in blurred image regions; without blur, 

no chromatic aberration will take place.

The value that can be defined here defines how strong the “color offset” will be rendered. It can also be 

described as the degree of saturation in the blue-red regions.

A value of 0 turns chromatic aberration off.

Remember that enabling this effect also increases render times accordingly.

Camera Aperture Shape

The following settings are used to create the bokeh regions. These are regions that lie outside of the camera’s 

area of focus and are therefore displayed as blurred. Small, bright regions are displayed on the shape of the 

aperture. Bokehs can have a strong effect on the image’s “impact,” because blurred regions can have very 

different shapes depending on the shape of the aperture.
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The Aperture Shape option is either circular (when disabled) or can be given a different shape by changing 

the Camera Blades Count setting (see below).

In general, the best looking bokeh (i.e. the softest and most flowing) can be achieved with a circular aperture 

(Aperture Shape option disabled).

Note that rendering high-contrast bokeh effects is a complex procedure and takes correspondingly long to 

render.

Camera Blades Count

The bokeh is defined primarily via an aperture shape. The aperture shape in turn is dependent upon the 

defined number of blades. The more blades are defined, the rounder your aperture shape will be. The least 

number that can be defined is 3.

Number of Blades from left to right: 3, 6, 12

Camera White balance (K)

An outdoor scene (with sky), with 5500K, 6500K and 7500K White Balance, respectively
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White balance is used to prevent light sources (e.g., sky, sun, candles, etc.) from colorizing white surfaces. 

Set the White Balance value to that of the light source’s color (Tungsten refers to the filament coil in a light 

bulb). If the presets do not quite match your needs, you can select the Custom option and define a custom 

temperature via the Custom Temperature (K) value. Color hues can be defined without having to change the 

color of the light itself.

As you can see in the image above, 5500K produces a slight blue hue and 7500K a slight yellow hue. The 

value 6500K (which is representative of daylight conditions), produces a grayed, cement-like hue (cement 

textures were applied to the objects in the image).

Color temperature is measured in Kelvin.

Of course white balance can be used to colorize renderings. The neutral value is Daylight (6500K). Generally 

speaking, lower values result in hues of blue and higher values in hues of yellow (directly opposite to the 

depiction above; the white balance, after all, is a corrective value).

Lens Distortion - Quadratic/Cubic

Lens distortion (different magnifications with regard to distance from the lens axis) causes straight lines at the 

image’s edge to appear curved. 

In photography, wide-angle lenses (short Focal Lengths) tend to produce barrel-shaped distortions, while tele-

focus lenses (long Focal Lengths) produce pillow-shaped distortions. These effects can be simulated using 

the Lens Distortion settings.

Note: Lens Distortion is not effective in conjunction with the Spherical camera.

The same plane is rendered using various lens distortions

Positive values result in a barrel-shaped and negative in a pillow-shaped distortion.

Use real-world tests and your camera’s tracking program to determine if you should use Quadratic or Cubic, 

or a combination of both (these differ only slightly visually from the center of view outward).

Watch the Video
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Physical Renderer Options

These settings are available if you check the Use Physical Renderer box in the Detailed view of 

PhotoRendering Settings for the Cineware Engine.

Sampler

The Sampler does just that - it samples the Project’s cache from the angle of view of the camera in a pixel 

raster. The Sampler has to determine which regions have to be sampled again with regard to antialiasing or 

blur effects (depth of field, motion blur, blurriness effects) in order to achieve the desired render quality.

The samples gathered (i.e. colors), whose number far exceeds the number of pixels, will in the end be turned 

into pixels colors via an antialiasing filter.

The following generally applies: The more samples taken at critical regions, the better the final result will be 

(with correspondingly longer render times).

Sampler Settings:

• Adaptive: Depending on the settings defined, an increased sampling will take place at critical or important 

regions. This mode is best for use in most cases because it offers a good compromise between quality 

and render speed (comparable with the default renderer’s Best Antialiasing setting).

The Adaptive sampler is a much more intelligent sampler compared to the Fixed sampler, and often 

renders faster than the Fixed sampler. On the other hand, if you choose a Sampling Quality of Custom, it’s 

more difficult to control because is calculates the following 4 values and distributes the samples 

accordingly:

- Sampling Subdivisions

- Shading Min

- Shading Max

- Shading Area Threshold

Special attention is paid to object edges, to which additional samples are applied to ensure that they are 

always antialiased optimally. The Adaptive sampler renders slightly less sharp than the Fixed mode.
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• Fixed: A definable and unchangeable per-pixel sample number (which will, however, already be 

increased in blurriness effect regions) will be calculated (comparable to the default renderer’s Best and 

Min/Max Antialiasing settings).

This sampler subdivides each pixel in a defined number of sub-pixels, according to the value entered for 

the Sampling Subdivisions value. For example, to make the blurred region of a motion blur effect visually 

appealing, you should use a relatively high value (e.g., 4 or 5). This means that 16 and 25 samples, 

respectively, will be calculated per pixel even in superfluous regions.

Increasing the Sampling Subdivisions level by a single value normally doubles the required render time. 

Here you can estimate render times quite precisely, which on the other hand is quite difficult using the 

Adaptive sampler.

Render time is valuable. This is why there is an Adaptive mode that recognizes at which locations more 

sampling must be done.

• Progressive: This sampler can render infinitely (samples will continuously be calculated), during which 

time the result will continuously improve. The initially grainy image will become increasingly less grainy, 

i.e. more homogeneous. The longer it renders the better the antialiasing and blur effects that will be 

calculated.

The longer the render, the better the result

This mode is primarily suited for fast preview renderings because you can very quickly determine the 

quality of the image as a whole. No other method offers you such a fast rendition of the entire image (with 

reduced quality at the start). To this end it is recommended that the Sampling Subdivision value (see 

below) be set to 0.

Progressive Mode/Pass Count/Time Limit

Use these settings to define whether the render should never end (Infinite) or if it should end after a specified 

number of passes (Pass Count) or render time (Time Limit, in minutes). A pass in this context is defined as 

a completely new rendered result over the entire surface of the given image.
ARCHICAD 24 Reference Guide 3685



Dialog Boxes User Interface Reference
Note that when using Time Limit you should allow for enough time for at least 1 pass, otherwise it can result in 

faulty renderings if the pass is stopped halfway through the images.

Sampling Quality

This selection menu makes your work a little easier by automatically defining parameter combinations, 

depending on which setting is chosen. Low, Medium, High refer to the quality of the rendered image - the 

higher the setting the less grain the image will have but the longer it will take to render. Custom will 

automatically be selected when one of the parameter values is modified manually.

Sampling Subdivisions

This setting functions somewhat differently depending on if you select Fixed or Adaptive.

• For a fixed number: The absolute number of samples that are calculated per pixel (depending on the 

subdivision values, additional samples will be calculated accordingly).

• For an adaptive number: A number of samples that are taken from the scene in order to gather 

information which will be calculated in a subsequent step (by the three shading parameters), i.e. if the 

values entered here are too low, greater values for the other parameters will not lead to good results.

The render results using the values shown for Sampling Subdivisions
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Shading Min/Shading Max/Shading Error Threshold

The Sampling Subdivisions setting is applied and the number of shading samples required per pixel will be 

determined based on the shading parameters.

“Shading” is defined as the calculation of a color value based on shadows, textures, refractions, reflections, 

etc. This can be very complex and time-consuming process, depending on the scene.

The Shading (Min) value defines the minimum number of shading samples that will always be calculated (to 

the power of two, i.e. 1, 2, 4, 8, 16, etc.).

The Shading (Max) value defines the maximum number of shading samples, in correlation with the Shading 

Error Threshold value, that should be calculated. 

The Shading Error Threshold value controls the number of samples that will in fact be calculated. The lower 

the value, the more the number of samples will lean towards Shading Subdivisions (Max) (however, only in 

critical regions!).

Subdivisions: Blurriness Max, Shadow Max, AO Max

The following three subdivision settings are the quality settings for certain effects (e.g. Ambient Occlusion) in 

the Transparency or Reflectance channels of the Surface material. The strength is defined at the surface 

level.

See Ambient Occlusion (Cineware Surface Channel).

These values will be taken into consideration when Progressive mode is used (see Sampler). Higher values 

will result in a slower, more gradual rendering. For preview renders in this mode it is suggested that each of 

these values be set to 0.

Blurriness Max: If blurriness effects are defined for surfaces (Transparency and/or Reflectance channel), 

use this value to adjust the quality (=graininess) of the effect. Larger values will result in better quality but 

will also increase render times accordingly. Render times for a given effect will double each time this value 

is increased by a factor of 1.

More samples (right) result in better quality in matte reflections and transparencies

Shadow Max: This parameter refers to Shadow Maps (the Physical Renderer simulates Shadow Maps 

because it cannot calculate them). Larger values result in better quality but also increase render times 

accordingly.
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AO Max: AO is short for Ambient Occlusion. Use this value to adjust the quality of Ambient Occlusion 

effects. Larger values result in better quality but also increase render times accordingly.

More samples (right) result in improved Ambient Occlusion quality

SSS Max

SSS stands for Subsurface Scattering Subdivision. Larger values will produce higher-quality results with 

correspondingly longer render times and vice versa.

This setting can be defined for surfaces via the Sampling Subdivision option (see Sampling Subdivisions).
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Physical Renderer Advanced

These settings are available if you check the Use Physical Renderer box in the Detailed view of 

PhotoRendering Settings for the Cineware Engine.

Raytracing Engine

This setting can almost be described as a turbo booster.

The following options are available:

• Physical (Legacy): The render engine available in ARCHICAD prior to V20. Requires the least amount of 

memory.

• Embree (Turboboost): The fastest Embree engine. Requires the most amount of memory.

• Embree: Only slightly slower than Embree (Turboboost) but requires less memory.

Note that the render results stay the same for the most part, but render inaccuracies can cause very slight 

differences between different render engines.

Watch the Video

About Embree

Embree is a technology, developed by Intel, that supports render software. Embree works with processors of 

the newest generation (i.e., those that can handle SSE3).

The Embree option renders much faster than Physical, with no quality loss.

Projects that can really benefit from this new technology are those that contain a high number of polygons/

objects, glass with a lot of refraction, area shadows, Ambient Occlusion (without cache). Complex textures or 

blurriness effects enjoy little or no benefit.
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Quick Preview

If Quick Preview is enabled, a very rough preview of the entire image will be created as quickly as possible, 

which will immediately be replaced bucket-by-bucket as the image is rendered.

This quickly gives you a preview of the image with correct lighting, which lets you decide whether or not you 

should continue with rendering.

Complex textures will slow the Quick Preview function down accordingly.

A fast preview provides a rough impression of the final render
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General Options (Cineware)

These settings are available in the Detailed view of PhotoRendering Settings for the Cineware engine.

This list of options affect the rendering as a whole: if you uncheck an option here, it is disabled for the whole 

rendering model, regardless of what else you have set elsewhere. It is worth considering which of these can 

be turned off so as to minimize render time. For example, you can turn off all blurriness with a single click.

Transparency

This option defines whether the Transparency or Alpha surface channels should be included in the 

calculation.

Refraction

Defines whether or not refraction index values should be included when rendering transparent surfaces. 

Surfaces such as glass or water only look realistic if rendered using a refraction index, but the render time will 

increase accordingly. However, no additional render time will be added if a scene does not contain materials 

that refract light.

Tip: Occasionally, transparent objects that lie behind other transparent objects are rendered black. If this 

should occur, increase the Ray Depth value (below). 

Reflection

Defines whether or not reflections should be calculated. If this option is deactivated, objects will only be 

rendered in their base color. This option can also be used in conjunction with the Limit Reflections to Floor/

Sky option (below).
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Here are some illustrations of these effects:

Limit Reflections to Floor/Sky

Enabling this option will cause the raytracer to only calculate the reflection of the floor and sky onto reflective 

surfaces (and not onto other objects!). This method is not computationally intensive and is therefore 

recommended for use in time-critical situations.

Transparency, Refraction, Reflection: All On Transparency Off

Refraction Off Transparency, Refraction, Reflection: All Off

Reflection Off
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Blurriness

Use this option to enable/disable the blur effect for the Reflectance and Transparency surface channels.

Textures

Using this option, you can enable or disable textures when rendering; only bitmaps and shaders remain 

unaffected. For example, you can disable the textures for a test render or when using the cel renderer.

• If Textures is enabled, bitmap textures will be rendered.

• If Textures is disabled, bitmaps will be replaced by the color black.

Visible Light

You can use this option to deactivate visible lights globally for the entire scene, without having to do it 

separately for each light source (lamps, lights, Sun).

Sub-Polygon Displacement

You can use this option to deactivate SPD globally for the entire scene, without having to do it separately for 

each SPD surface. This option can be turned on and off quickly for test renders.

See Sub-Polygon Displacement in Surfaces.

Identical Noise Distribution

Cineware uses numerous effects that (if low values are used) produce grainy results, which are often referred 

to as “noise”. Some examples are:

• Subsurface Scattering

• Depth of field

• Motion blur

• General Sampling in the Physical Renderer

• GI and Ambient Occlusion.

If Identical Noise Distribution is enabled, the noise distribution will be random for each rendered image, which 

means that successively rendered images will all have a random noise distribution. This reflects the real-world 

behavior of film or image sensor sampling in digital cameras, which also contain a certain amount of “noise”.

To render stills as identically to one another as possible, this option should be enabled. However, note that 

other effects can still produce randomness. This can, for example, be seen in GI renderings in which slightly 

differing results are produced despite identical noise distribution.

Subsurface Scattering

Subsurface Scattering (SSS) is an effect in which light penetrates slightly transparent surfaces, which then 

virtually transport, scatter and - in part or entirely - absorb and color the light. “Slightly transparent” means 

every material through which light can pass, however slightly. Such materials include porcelain, marble, skin, 

milk or various plastics, just to name a few.

SSS also works in conjunction with GI, i.e light that GI casts onto an SSS object will be included in the 

calculation. On the other hand, light that is generated by a SSS will only be recognized by other objects when 

in QMC GI Mode.

Limitation: Keep an eye on the object surface Normals. In some cases it can occur that the SSS doesn’t 

work correctly if the Normals are oriented incorrectly (e.g. if on a sphere they all face inward).
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Ray Threshold

This value helps to optimize render time. With complex scenes, particularly those containing many reflective 

and transparent surfaces, 90% of the processed rays contribute less than 10% to the general picture 

brightness and color. With a threshold value of, for instance, 15%, the rays stop their movement from the 

camera into the scene as soon as their brightness falls below this value.

For reflections/transparencies, this generally means that the higher the value, the greater the degree to which 

very small reflections/transparencies will be taken into consideration - with correspondingly longer render 

times.

Ray Depth

The Ray Depth determines how many transparent objects (or areas made invisible using the alpha channel) 

can be penetrated by the renderer. The lower you set the Ray Depth, the fewer the number of objects that can 

be seen through. Those areas that cannot be penetrated are rendered black.

The higher the Ray Depth value, the further the rays are followed into the scene for rendering purposes.

A Ray Depth of 1 means that calculations are finished for a pixel once its ray hits something in the scene. 

Transparencies and alphas therefore will not be visible.

A value of 2 means that after a ray has hit a surface a second ray is calculated for the transparency. 

Reflection Depth

The higher the Reflection Depth, the further rays are followed into the scene and the results rendered.

The results contain reflective objects and have been rendered with reflection depths of 2, 4 and 8

When a ray is sent into the scene, it can be reflected by reflective surfaces. With certain arrangements, e.g. 

two mirrors opposite each other, it is possible that a ray will be reflected forever, trapped between the mirrors, 

and the raytracer would never finish rendering the picture. In order to prevent this, you can set the maximum 

number of reflected rays.

You can also use Reflection Depth to limit the render time for the picture. Often, only the first generation of 

reflections is important. Further rays tend to add little to the image quality, but increase the render time 

considerably.
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A Reflection Depth of 1 means that calculations for a pixel are finished once a ray hits something in the scene. 

Reflections therefore will not be visible.

A value of 2 means that after a ray has hit a surface a second ray is calculated for the reflection. 

Global Brightness

This setting lets you simultaneously set the global brightness for all light sources present in your scene. A 

setting of 100% will utilize the intensity set in each light, 50% will decrease the intensity of each light 

proportionally by half, while a setting of 200% will double the intensity of each light.

Generate Alpha Mask for Environment

If you enable this option, a pre-multiplied alpha channel will be calculated during rendering.

The alpha channel is a grayscale image of the same resolution as your color picture. Pixels in the alpha 

channel are either black or white. A white pixel in the alpha channel indicates the presence of an object at that 

position in the image while a black pixel indicates no object.
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Antialiasing (Cineware)

These settings are available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Antialiasing is used with the Standard Renderer.

Antialiasing removes jagged edges from your images. It works by breaking down each pixel into sub-pixels; 

rather than calculate just one color for a pixel, several color values are calculated and averaged to produce 

the final color for the pixel.

Mode

Choose None, Geometry or Best.

From left to right: None, Geometry (the slightly blurred texture is a result of the antialiasing filters) and Best 

antialiasing. 

• None: The image to be output will be calculated without antialiasing (any existing Render controls with 

differing settings will be ignored). Step-like structures will be recognizable at object and color edges. This 

mode is particularly suited for fast test renderings for which quality is not important.

• Geometry: This is the default setting which smooths all object edges (automatically with 16x16 sub-

pixels).
ARCHICAD 24 Reference Guide 3696



Dialog Boxes User Interface Reference
• Best: This enables (in addition to object smoothing) adaptive antialiasing (additional sub-pixels will only 

be calculated at critical regions, i.e. for pixels whose color differs greatly from those of its neighboring 

pixels), which affects color edges (e.g. also shadows, objects behind transparencies, etc.). This in turn is 

controlled via several parameters available for this mode.

Higher antialiasing settings are often only noticeable in the finer details.

Min Level/Max Level/Threshold

The default combination of these three parameters will be fine in most cases.

These settings control Cineware’s adaptive antialiasing (set Best mode, above). Sub-pixels will be calculated 

for neighboring pixels whose color differs too greatly; for non-critical regions (large, uniformly colored regions) 

no sub-pixels will be calculated if at all possible.

Adaptive antialiasing only works for color edges or object edge smoothing for objects that lie behind 

transparent objects or in reflections.

Min Level defines the minimum number of sub-pixels that will always be rendered. The default value of 1.1 

will suffice for most cases. If, however, artifacting should occur in very detailed regions, e.g. shadow elements 

get swallowed, higher values should be used.

Max Level is the sub-pixel dispersion that is applied to critical regions (mostly high-contrast regions, i.e. color 

edges or object edges behind transparencies). This value can, for example, be increased when rendering 

glass to ensure the rendering of finer details.

The Threshold value defines the degree of color divergence at which Max Level should be applied for a given 

pixel. Small values will allow no divergence, large values will allow greater contrasts before smoothing begins.

In an average scene with a Threshold (Color) value of 10%, about 40% of all pixels will be affected, whereas 

a Threshold value of 5% will result in 90% of all pixels being affected. A value of 0% will cause all pixels of a 

rendered image to be antialiased - including superfluous regions.

These three parameters greatly influence the render speed! Settings that are too high can easily increase 

render times tenfold, without much noticeable difference in render quality. The default values offer very good 

results in most cases, with moderate render times.
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Filter

Generally speaking, the filter controls how sharp and crisp the edges will be rendered.

The filter works with both Geometry (object edge smoothing) and Best (color edge smoothing) antialiasing 

modes. In most cases, the filter selection has little effect on the render speed.

A brief explanation of how the antialiasing filter works: Depending on the antialiasing settings, a number of 

subpixels will be calculated per pixel whose colors are then pooled for that pixel (a pixel can only have a 

single color).

In the image above are 9 edge pixels that run diagonally across the image. Take a look at the center pixel. 16 

sub-pixels were used to calculate this pixel. 15 are light gray, 1 red. These pixels form a curve (Mitchell in this 

case). Imagine this curve as flat around the center of a pixel. This curve then defines the degree of influence 

each sub-pixel should have. Because the filter size (Filter Width setting) and Filter Height (i.e. the spread 

within which sub-pixels will be taken into consideration) can be expanded to up to 4 pixels, the curve can be 

made to spread out quite a bit more. Conversely, this means that neighboring pixels for the most part see the 
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same sub-pixel and therefore have a very similar color. Of course edges can then no longer be made to look 

sharp and crisp.

Each choice in the filter pop-up represents a different curve, defining the degree of influence each sub-pixel 

should have.

• Filter Width/Filter Height: Filter Width/Height defines how many sub-pixels (calculated from the center of 

the pixel outwards) will be taken into consideration when the pixel color value is calculated.

• As long as the Custom Size option is enabled, an ideal value for Filter Width and Filter Height will be 

used, which will also be displayed. The values are in relation to the pixel, i.e. a value of 0.5 for both 

parameters means that sub-pixels 0.5 to the left and right, and 0.5 above and below the pixel center point 

will be taken into consideration, i.e. all sub-pixels on the pixel surface. Higher values will extend to 

surrounding pixels accordingly, which will result in color edges being rendered correspondingly less 

sharply.

• Clip Negative Component: A filter function’s negative regions can be clipped.

In the image above, you will notice that several curves (Mitchell, Cubic and in particular Sinc) even fall 

below zero. This means that at corresponding edges, contrasting color values are rendered that are not 

even present in the scene. This makes the edges look sharper. This can, however, lead to problems under 

certain circumstances. If the Clip Negative Component option is enabled, the negative regions will be 

clipped.
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Here, a cube was rendered to which a luminous material was assigned along with the Sinc antialiasing filter. 

At left the Clip Negative Component was disabled, at right it was enabled.

MIP Scale

Scales the MIP strength globally for surfaces. For example, a MIP Scale of 200% doubles the MIP strength for 

each surface. 

See Sampling Methods in Surfaces.

This value should be increased when using highly detailed textures that are directly facing the camera. This 

will result in a better display of continuous lines - without interruption - by the antialiasing.

These values should be increased if you have detailed textures that lie perpendicular to the angle of view of 

the camera. The tendency for antialiasing to display continuous lines as dashed lines will be reduced.

For crisp, sharp stills, keep in mind that you may need to change the Sampling setting of surfaces. Although 

the default Sampling setting, MIP, is a good choice for materials on objects that extend towards the horizon — 

such as a floor — for things like bottle labels you will get a much sharper picture by changing Sampling to 

Square, Alias 1, Alias 2 or Alias 3.

Small Fragments

Let’s say you have a complete house consisting of thousands of polygons located at your scene’s horizon, 

which is so far away from the camera that it would only be about one pixel in size when rendered. The Small 

Fragments functionality is designed to render such regions more effectively (as well as regions with high 

levels of Subsurface Scattering).
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Grass (PhotoRendering Option)

These settings are available in the Detailed view of PhotoRendering Settings for the Cineware engine.

Use these controls to define the rendering parameters for the Grass surface in the scene, if the Grass surface 

channel is being used. See Grass (Cineware Surface Channel).

Sampling

When grass is rendered, light shadow and color are calculated at different locations on the grass and 

subsequently interpolated:

• Pixel: No interpolation will take place - each pixel will be calculated individually. This method delivers the 

better results but also take the longest to render.

Otherwise the Pixel option should be selected in the following instances: 

- If a texture in the Color channel is projected onto each individual hair. 

- If the Specular Lights are too blurred, regardless of changes made to the Reflectance channel. 

- In general, render quality will increase when very few grass segments are used.

• Vertex: The start and endpoints of segments are sampled and interpolated. This setting offers a good 

compromise between quality and render time and will lead to good render results in most cases.

Left Vertex, right Pixel. Note how individual grass shadows are taken into consideration

at the right, which are ignored on the left.

Cache

These options are displayed when the Physical Renderer is used. They are designed to deliver faster 

rendering but will result in corresponding loss of quality. Generally speaking, you should simply activate the 

options, see if the results meet your standards and enjoy the faster rendering.
ARCHICAD 24 Reference Guide 3701



Dialog Boxes User Interface Reference
The Cache options temporarily save the grass illumination surface properties - diffusion, specular and indirect 

lighting (GI) - to the RAM (primarily at the grass vertices). These one-time calculated values will then be used 

multiple times during rendering, which saves time. However, the calculation is simplified, which can have 

negative effects on render quality. These effects are very minimal and barely noticeable.

Left: Cache Primary Rays disabled; right: enabled.

Note how the fur on the mouse at the right appears more coarse. The grass consists of only 3 segments and 

the respective Grass surface has the color range to the right assigned to it. You can see how the colors of the 

grass on the right blend. Here, the color is calculated on each of the 4 grass vertices and interpolated. Now 

imagine this “blurriness” applied not only to the color but also to other grass properties such as specular, etc., 

and you have an impression of how the Cache options work.
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The following image shows various Cache option combinations and their effect:

Note how the color range for the grass at the top left looks best with no caching but requires the most render 

time, and how the other examples have poorer quality but shorter render times. The reduction in quality has 

been exaggerated in these examples by using only 3 grass segments. Normally you will have a far greater 

number of segments, which means that the loss in quality will be much less.

Cache Primary Rays

Effects of the rays as seen from the angle of view of the camera will be cached. This includes shading and 

shadow effects as well as the grass’s specularity (see image above).
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Cache Secondary Rays

Secondary rays are used to calculate reflections, refractions, blurriness effects and GI. If this option is 

enabled, these elements will be cached. Secondary rays are a superset of matte and GI rays, which means 

that the following two options can be disabled separately if this option is enabled. Secondary rays cannot 

read/use the primary rays’ cached specularity. This will then come after transparency and reflection.

Cache Blurry Rays

Blurry rays are needed in order to calculate Blurriness. These will then be cached if this option is enabled.

Cache GI Rays

This option caches the GI sampler’s effect and is only effective if used in conjunction with Global Illumination. 

The visible effect of the cached GI rays is very minimal, which means that this option can actually remain 

enabled. This in turn results in much faster rendering in conjunction with QMC.
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GI Sampling

The top row is illuminated using a light source, the bottom row using a polygon light

You can define where GI should be rendered or cached on grass:

• Pixel: The entire grass will be rendered with GI. This is the slowest and most precise method.

• Vertex: Only the grass vertices will be rendered with GI. The result is very similar to that of the Pixel mode 

but is generally rendered brighter because the grass normals are, internally, always oriented towards the 

camera.

GI Quality

This value represents a multiplier for the Samples parameter. It is designed for use with QMC, which requires 

more samples in conjunction with grass. When the aforementioned Cache options are used, this setting will 

be taken into consideration. However, if the Cache GI Rays option is enabled, this setting will have no effect.
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Spherical Camera (Cineware)

Use this feature to create a rendering with a 360 view. The resulting image can be viewed as a navigable 

panorama picture in various media, such as YouTube, Facebook or Twitter.

Introduction

The increasing number of virtual reality applications (VR) require new methods of creating image material for 

this purpose. The Spherical Camera setting renders the scene with a 360° view, which can be viewed with a 

VR headset or via 360° YouTube videos.

Note: Stereoscopic rendering is also possible. See also Stereo Rendering (Cineware). 

The Spherical Camera is not restricted to VR. It can also be used to render HDR images, which are simply an 

all-round view of the scenery.

Since Cineware renders two-dimensional images, the all-round view has to be distorted accordingly so it fits 

into a rectangular bitmap. For this purpose, Cineware offers the most important projection types.

The resulting view provides a spherical perspective, similar to HDRI. The rendered picture is assigned a field-

of-view (FOV) tag: either Equirectangular or Dome. These tags are recognized by certain imaging engines 

(e.g. built into YouTube, Facebook, QuickTime Viewer, etc.) which then produce the panorama.

Note: For information on uploading to YouTube, see: https://support.google.com/youtube/answer/

6178631.

Camera Setup

The camera should be positioned at or very near eye level. It’s often helpful to position the camera level in the 

direction of view and to set up the view without rotation (Roll Angle should be 0), to have a neutral angle of 

view from which to start.

Note that the projection only takes effect for rendering and will not be displayed in the 3D window.

Render Output

Make sure that the image sizes are correct for output. Since the entire scenery (not just the normal camera 

view) is used to create a bitmap, the image resolution should go beyond what you usually use. The following 

formats should be used as reference for mono images. (When using Stereo Rendering, the respective side 

should be doubled, depending on the Stereo Layout being used):

• Lat-Long: 2:1, e.g. 2000x1000, 4000x2000

• Cube Map (Cross): 4:3, e.g., 2000:2667, 4000x3000

• Cube Map (3x2): 3:2, e.g., 2000x1333, 4000x2667

• Cube Map (String): 6:1, e.g., 2000x333, 4000x667
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Spherical Camera Settings

Enable Spherical Camera

Check the Spherical Camera box at PhotoRendering Settings.

FOV Helper

Use this setting to define which part of the scene the camera sees:

• Equirectangular: The entire spherical environment around the camera.

Note: For YouTube, the views have to be rendered with FOV set to Equirectangular, and with Mapping set 

to Lat-Long.

• Dome: Only the top hemisphere of the camera’s environment will be included (the bottom half will be 

rendered black). If you restrict the field of view further using the Min/Max settings, this will be displayed by 

the FOV. 

Mapping

If you imagine the scene around the camera, the entire environment must be projected onto a rectangular 

bitmap. Define the method by choosing from the following Mapping options:

• Lat-Long: Also known as equirectangular or latitude/longitude. The “texture” will be peeled off 

cylindrically, similar to how a world map is designed with a distortion-free “equator” and increasing 

distortion towards the poles. 
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• Various Cube projection types: The environment will be depicted through the camera along all object 

axes, as illustrated in the image below.

The Spherical camera lies at the center of the cube. It was then rendered using the respective Mapping type.
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The Mapping type that is best suited for your needs depends on how the rendering will subsequently be used. 

Make your selection depending on the software with which the image will be edited. The most commonly used 

method is Lat-Long, which can also be used if you create an HDRI or a depiction of the scene for a spherical 

projection.

Fit Frame

If the FOV is restricted further using Lat-Long Min/Max (see options below), the region to be rendered will be 

stretched so the entire bitmap is filled out. If this option is disabled, the FOV will only take up part of the bitmap 

and the rest will be depicted as monochromatic.

Use Full Range

If FOV is set to Equirectangular, check Use Full Range to use the entire all-around view. If you leave it 

unchecked, then only a portion will be used, based on the following settings:

• Long Min [-180..180°]

• Long Max [-180..180°]

• Lat Min [-90..90°]

• Lat Max [-90..90°]

Use these settings to restrict the FOV starting from the X axis (Lat Min/Max) or Equator (Long Min/Max).

Latitude

If FOV is set to Dome, the Latitude setting can be used to define the dome section as a spherical element.
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Stereo Rendering (Cineware)

Use Stereo Rendering settings to define all properties having to do with the creation of two or more images 

whose perspectives are slightly offset.

Introduction 

In recent years, advances in technology have made it possible to display 3D images and movies true to color 

and free of fatigue for the human eye. Most techniques record two images of the same scene from slightly 

offset perspective views (those of the left and right “eyes”). These two images must then be displayed to the 

viewer in a way that the left eye only perceives the left image and the right eye the right image (which is done 

using specially designed glasses). The rest is done more or less automatically: the brain combines these two 

images into a single image.
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Two images with different perspectives are combined to create a stereoscopic image.

Topics in this Section

Options with a Spherical Camera

Options with a Non-Spherical Camera

Stereo Rendering Options

Options with a Spherical Camera

Special settings are available if you want to make the 360° view of a Spherical Camera into a stereoscopic 

view. The left and right eye views will be combined to a single image (left = top; right = bottom).

Check the Spherical Camera option to access the special Stereo Rendering options for a spherical camera.

If you are not using Spherical Camera: See Options with a Non-Spherical Camera.
ARCHICAD 24 Reference Guide 3711



Dialog Boxes User Interface Reference
Stereo Mode

• Mono: No stereoscopic images will be rendered.

• Parallel: Both cameras will be arranged with parallel axes of view. 

• Toe-in: Both cameras’ axes of view will cross. The point of intersection can be defined using the Focal 

Distance.

The various Stereo modes with the camera axes (the cameras are rotated internally for rendering panoramas)

The primary difference between the two stereo modes lies in the definition of the null parallax, i.e., the 

distance from the camera at which no parallax is generated.

Note: Parallax is the apparent displacement of an object when seen from two different points.

• If Toe-In is selected, the null parallax will be defined using the Focal Distance setting and cannot be 

subsequently modified. 

• If Parallel is selected, the null parallax is infinite and can be subsequently modified (by moving the left and 

right perspectives).

Stereo Layout

Define how the two stereo images should be arranged, or which one (left or right) should be rendered alone.

Eye Separation

This value defines the distance between both cameras/eyes. The default distance of 6.5 cm represents the 

average distance between human eyes.
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Eye to Neck Distance

Depending on which target model is rendered, you can define the horizontal distance from the neck to the 

eyes (see image above). If the Eye to Neck Distance is set to 0, the camera’s rotational point will no longer lie 

at the center of both cameras.

Focal Distance

If Stereo Mode is set to Toe-In, you can use this setting to define where the null parallax should lie. Objects 

that lie in front of this point and face the camera’s direction of view will protrude out of the monitor towards the 

viewer; objects that lie behind this point will more or less “sink” into the monitor.

Top Pole Smoothing/Bottom Pole Smoothing

For technical reasons, stereoscopy cannot be rendered correctly around the poles. To prevent unwanted 

artifacting, the stereo effect can be gradually faded in these regions. In most cases, this can be done with no 

problem because the visually important elements mostly occur horizontally around the camera’s location (and 

not vertically above or below it).

The smoothing can be defined separately for top and bottom poles. In the region in which the smoothing takes 

place, the views will be equalized with the left and right cameras until they are identical with the maximum 

possible smoothing. 

Smoothing Types

Smoothing, using the defined Smoothing Angle, will take place from the start to the pole using one of two 

methods:

• Linear: Smoothing occurs with linearly increasing strength, i.e., abrupt deployment
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• Exponential: Smoothing occurs with exponentially increasing strength, i.e., gradual deployment. 

– Use Top/Bottom Pole Exp settings to affect the Exponential option.

Options with a Non-Spherical Camera

If you are not using the Spherical Camera option, the following Stereo Rendering options are available.

Mode

• Mono: This is the normal camera mode without stereoscopy.

• Symmetrical: Use this mode to render normal stereoscopic images. A double camera will be assumed 

and each camera will be assigned half of the defined Eye Separation value, left and right, respectively.

Depending on the parameters defined, both cameras will be positioned as follows on the Camera object’s X 

axis:

• Left: left camera is set to 0, right camera is set to + distance between eyes

• Right: left camera is set to -distance between eyes, right camera is set to 0

Eye Separation

This value defines the distance between the left and right eye. The default value of 6.5cm reflects the average 

distance between a human’s eyes. Normally, this value should be as small as possible. Greater values will 

produce a correspondingly larger spatial view but it will also become more strenuous for the viewer to view the 

scene. 

Exception: if a scene, e.g., a landscape, is depicted that lies far away from the camera.
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Placement

Even though several options are available, most of them are only there for compatibility reasons. For 

stereoscopic double images, you should always (with the exception of special circumstances) set Placement 

to Off Axis. 

Each example in the image below uses a double camera only.

Depending on placement, both (or several) cameras will be oriented differently.

• Parallel: This is the simplest stereoscopic camera arrangement. Both cameras are positioned parallel to 

each other (the image axes are also parallel). Stereoscopic images with this type of arrangement only 

depict objects that lie in front of the projection plane. Hence, the null plane CANNOT be moved by 

modifying the Zero Parallax value. This is in contrast to other following three modes.

• Off Axis: Basically the same camera arrangement as Parallel, but with an offset, which means that the 

image axes are no longer parallel; they intersect. The zero parallax lies at this point of intersection (see 

next setting, Zero Parallax). Objects can be depicted to lie spatially either in front of or behind the 

projection plane (i.e. in or in front of the monitor).

Tip: This mode is recommended for stereoscopic double images because it delivers the best results for 

the widest range of applications.

• On Axis: When this mode is selected, both cameras are rotated so their Z axes intersect with the zero 

parallax. This reflects approximately how the human eye works but is not recommended for the creation of 

stereoscopic images because a vertical parallax can result. This mode is also referred to as “toe-in”.

• Radial: This mode is similar to On Axis, except that both cameras don’t lie on the Z axis but rather on an 

arc (whose center point lies on the point of intersection of both cameras’ zero parallaxes).

Zero Parallax

The zero parallax is a virtual plane that lies vertically to the camera’s angle of view and defines where the 

projection plane lies, i.e., the plane that represents the monitor screen at its depth. Objects that lie in front of 

this plane in the direction of the camera protrude spatially out of the monitor in the direction of the viewer; 

objects that lie behind this plane lie “within” the monitor.
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Auto Planes

Choose either an Auto value of 70 or 90, or choose Manual to enter separate Left Plane and Right Plane 

values.

If you want to play it safe, select 90 and place all visible objects in the direction of the camera and behind this 

plane.

The Auto Planes do not affect rendering! They only serve as visual references that you can adjust manually. If 

you determine via test renderings that the optimal spatial impression within a given distance from the camera 

has been achieved (objects that, for example, lie too close to the camera – while the zero parallax is 

positioned far away – can only be seen with great effort by the human eye), then you can define these planes 

accordingly and can place objects in the view correctly, within the restricted space that results.

The options 70 and 90 represent a parallax of 70 and 90 arc seconds, respectively, for the near plane. These 

values are described in technical literature as values at which the human eye can perceive spatially with 

normal effort. Therefore, objects should lie behind this near plane.
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A formula exists that defines the maximum parallax (distance between red and cyan (anaglyph)):

P = tan a * D

where P = Parallax, D = Distance of the viewer from the projection plane (e.g., the monitor), a = Angle 

between 2 points that the eye can comfortably perceive (this should be max. 1.5° or somewhat less).

For an average distance between eyes and monitor of 50 cm, an average reference value of 13 mm results.

Stereo Rendering Options

Calculate Stereoscopic Images

Define how the stereoscopic images should be rendered and saved.

• Merged Stereoscopic Image: A stereoscopic image will be rendered using the left and right eye views 

only and no other channels. This is the mode with which you will normally render.

In contrast to stereoscopic techniques that use 2 channels, multi-channel techniques let you render multiple 

camera views, which can then be edited as channels (or streams) using external applications. Auto-

stereoscopic playback devices can then be used to view these images with two matching channels (which can 

change depending on the angle of view).
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• Individual Channels: Several camera views can be rendered, depending on the number of channels 

defined. Channel 1 will always be the left eye perspective and channel X will always be the right eye 

perspective. If Channels is set to greater than 2 additional views will be rendered between these views. 

Select this mode if you want to subsequently create a stereoscopic image, either in the Picture Viewer or 

using an external application.

At left a stereoscopic setup with 2 channels, at right a stereoscopic setup with 5 channels.

• Individual Channels and Merged Image: In addition to the left and right eye views (or any number of 

additional intermediate camera views), a combined, stereoscopic image will be created out of a 

combination of these views.

• Single Channel: Only the channel defined by the Single Channel value will be calculated. This mode is 

recommended if you – for whatever reason – only want to render a single camera view.

Define which channel should be rendered. 1 will always render the left eye view. The value defined for 

Channels will be the right eye view. in-between values will represent the intermediate camera views, as 

described here: see Placement.

Non-Stereoscopic Image

Enable this option if the normal camera view should be calculated in addition to the stereoscopic views.

Stereo Rendering Mode: Anaglyph, Side-by-Side, Interlaced

Anaglyph

This is the most well known method, which has been used in movie theaters since the 50s. An image’s color 

information is separated using 2-color glasses (previously red-green, today most commonly red-cyan). 

Advantage: simple, affordable glasses. Disadvantage: color range is in part very limited.
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•  Method: Set the color of the stereoscopic image. A problem with the anaglyph technique is that some 

colors cannot be displayed without straining the viewer’s eyes (red when using red-cyan coding). 

Recommendation: Use Optimized, because it offers the least strenuous “viewing experience”.

The different available methods (Full with anaglyph colors red-blue). “Mono” = Stereo Rendering OFF. Models 

by DOSCH Design.

The following list is arranged according to the quality that can be expected from anaglyph images, from worst 

to best:

– Full: The oldest (and lowest quality) method of anaglyph display; the display is dark and monotone. 

This mode is designed for use with the Red-Blue or Red-Green anaglyph techniques.
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– Gray: The anaglyph image will appear as a gray-scale image through the glasses (not designed for 

use with red-blue or red-green). For brighter images use Full.

– Half Color and Color: These modes allow only a limited color reproduction compared to the other 

options. Blue, green and yellow tones can be reproduced very well when the common red-cyan code 

is applied. If Color is selected, “retinal rivalry” can occur, i.e., red surfaces (red-cyan) will cause the left 

eye to pass on maximum color intensity to the brain and the right eye will only see “black”. This is 

irritating and strenuous for the eyes. This effect can be minimized by selecting Half Color. However, 

red will then be darkened to such a degree that it can no longer be recognized as such.

– Optimized: This mode is similar to Half Color, but offers better color reproduction and minimizes the 

retinal rivalry effect.

• System: Define the color of the stereoscopic color coding here when using Anaglyph mode. Both colors 

should be the same as the lenses of the 3D anaglyph glasses you will be using. If your client does not 

supply you with color information, use Red-Cyan.

– Use Custom option to define the individual colors for the stereoscopic color coding (however, it will 

then be difficult to find a matching pair of glasses…). If Method is set to anything but Full, you will only 

be able to define the left eye color. The left color must be the same as the color of the left lens of the 

glasses. The right eye color will automatically be set to the left eye’s complimentary color.

Side-by-Side

Left and right images are switched and squeezed into a normal image size. Some televisions use this 

technique for HD 3D because the transmission band width is the same as the HD band width. The terminal 

device must be able to decode these double images and display them sequentially (most commonly in 

combination with shutter glasses). Disadvantage: reduced resolution, expensive technology (special 

hardware required).
ARCHICAD 24 Reference Guide 3720



Dialog Boxes User Interface Reference
• Alignment: This mode defines whether or not both image parts should be arranged next to each other 

(horizontally or vertically).

• Left Mirror X/Left Mirror Y/Right Mirror X/Right Mirror Y: Use these checkbox options to mirror the 

image halves along the X or Y axes.

Interlaced

This method requires a monitor with a polarization filter and glasses with polarized glass. Since both images 

are coded into a single image (e.g., left eye all even, right eye all uneven lines), the resolution is halved. 

Advantage: affordable glasses, good color reproduction. Disadvantage: special monitor required, reduced 

resolution.

Define whether the coding should take place via offset lines (Horizontal) or columns (Vertical). 

Checkerboard is a combination of both modes.

Additional Parallax (pixel)

Moves the image halves by the defined value in pixels. This can be used to increase the stereoscopic effect.

Swap Left/Right

If enabled, the left and right image halves will be swapped.

A few guidelines for achieving good stereoscopic images

There are several rules that should be followed when creating stereoscopic images. This is necessary so they 

can be easily viewed without any unnatural effects or fatigue for the viewer’s eyes. Hence, the following 

guidelines should be followed.

• Depth of Field: It is generally suggested that a larger depth of field (i.e. little blur) be used. A common 2D 

technique is to take the background out of focus using a slight depth of field. A blurred wall behind a sharp 

object makes this surface look flat. Such techniques are in contrast to stereoscopic techniques.

• Distance from object(s): The 3D effect depends a lot on how far the viewer is from the projection plane 

(monitor, screen, paper, etc.). The farther away the viewer is from the projection plane, the stronger the 

3D effect will be (the perceived impression of depth between an object that is near and one that is far 

away)! This should be taken into consideration when creating a stereoscopic zone.

• Ghosting is when one eye perceives the image information of the other eye (leads to irritation). This is 

especially noticeable in images with high contrast (anaglyph images in particular are prone to this). 

Therefore, you should avoid such contrasts in your images if at all possible. Very small parallax values 

can also reduce ghosting.
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• It is often irritating for the eye when objects are cut off at the edge of an image (if they do not lie on the 

projection plane). However, because there are always objects that lie on the edge of an image, it shouldn’t 

necessarily be the most important object in the image, the one that is currently the center of attention, that 

is being cut off.

• For videos it is important to give the eye time to adjust to strong parallax changes (between different 

settings). Short, fast cuts should then be avoided.

• Avoid exaggeration: Chain saws constantly flying towards the viewer or similar scenes can be fatiguing for 

the eye. Such visual gimmicks should be used sparingly or be well thought out.
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Tool Settings Dialog Boxes

This section of the User Interface Reference describes each of the Tool Settings dialog boxes, for most tools 

found in the ARCHICAD Toolbox.

The descriptions of individual tools are prefaced by the first part (Working in Tool Settings Dialog Boxes), 

which contains general information, plus information on controls that are common to every Tool Settings 

dialog box.

Working in Tool Settings Dialog Boxes

Wall Tool Settings

Roof Tool Settings

Shell Tool Settings

Slab Tool Settings

Mesh Tool Settings

Zone Tool Settings

Morph Tool Settings

Settings of Library Part Elements

Object Tool Settings

Special Lamp Parameters

Door/Window Tool Settings

Corner Windows

Custom Settings Panel for a Door/Window

Skylight Tool Settings

Dimension Tool Settings

Dimension Text Settings

Convert Dimensions Dialog Box (Add-On)

Text Tool Settings

Text Style Panel

Label Tool Settings

Drawing Settings

Fill Tool Settings

Line Tool Settings

Arc/Circle Tool Settings

Polyline Tool Settings

Section and Elevation Settings

Interior Elevation (IE) Tool Settings

Worksheet and Detail Tool Settings

Change Tool Settings

Grid Tool Settings

Wall End Tool Settings

Spline Tool Settings

Hotspot Tool Settings

Figure Tool Settings

Camera Tool Settings
ARCHICAD 24 Reference Guide 3723



Tool Settings Dialog Boxes User Interface Reference
Settings of other tools are described elsewhere in this Reference Guide:

Columns

Beams

Curtain Wall

Stairs

Railings

Openings
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Working in Tool Settings Dialog Boxes

Tool settings dialog boxes can be accessed from the Toolbox, the Info Box palette, or from context menus. 

They contain the settings that define the appearance and parameters of the elements drawn using the tools.

To open a Tool Settings dialog box, do one of the following:

• Double-click the tool icon in the Toolbox.

• Click the tool icon in the Info Box.

• With an element selected, choose Edit > Element Settings > (Tool) Settings.

• Click an element with the right mouse button (Mac: Ctrl key), and choose the (Tool) Selection Settings 

command from the appearing Context menu.

The title bar of the dialog box displays whether you are viewing Default settings or those of Selected 

elements.

The information at right of a tool settings dialog box alerts you to the status of the current settings in the box:

• Default: These settings will be used as the default for new elements.

• Selected: These settings are applied to the currently selected elements (the number of selected elements 

is displayed).

• Editable: Displays the number of selected elements which are also editable.

Favorites Button in Tool Settings

The Favorites (star) button in the top left corner of all Tool Settings dialog boxes (except Camera) opens a list 

of the Favorites stored for that tool only.

ARCHICAD comes with predefined Favorite settings for each tool, and you can define your own Favorites.

For more information, see Favorites.

See also Search Favorites.

Panel Visibility in Tool Settings

The settings for each tool are organized into several panels that can be opened or closed individually by 

clicking the caption of the panel. You can also choose to show or hide any of the panels, if you prefer, at: 

Options > Work Environment > Tool Settings Dialog Boxes.

See Tool Settings Dialog Box Customization.

When you open new panels, some visible panels may shut automatically, and/or the dialog box will move 

upward on the screen to prevent an overcrowded or too-large dialog box. To turn off these automatic 

functions, set the checkboxes in Options > Work Environment > Dialog Boxes and Palettes.

For details, see Dialog Boxes and Palettes.

Navigating Within Tool Settings Panels

A few keyboard shortcuts make it easy to navigate in any of the Tool Settings dialog boxes:

• To open and close the unfoldable settings groups within a particular panel, use the right- and left-arrow 

keys.

• To move from one setting field to the next within a particular panel, use the up- and down-arrow keys.

• As you move onto the next field, the edit field is already highlighted, so you can type in values directly.

• To activate/deactivate a checkbox in the current field, use the Spacebar.
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• To open the pop-up menu indicated by an arrow icon (such as a Fill Type or Pen Color chooser), press Alt 

+ Down Arrow. Press ESC to close.

• To exit a settings list within a particular panel, press TAB.

• To jump to the next panel or control, press TAB. To jump to the preview panel/control, use Shift+TAB.

Layer Definition in Tool Settings

At the bottom of each Tool Settings dialog box, the current Layer choice is displayed in a drop-down list. To 

change the current element’s layer, choose a different layer in this pop-up menu.

For more information, see Layers.

Listing Panels

This panel controls the handling of the current Tool in calculations. It is not visible by default. Use the Work 

Environment’s Tool Settings Dialog Boxes section to activate this panel for any of the design and documenting 

Tools.

For more information on the Calculation function, see Calculation (Legacy) and the ARCHICAD Calculation 

Guide.pdf.

• Link Property Objects by Criteria: Use this control to link a Property Object to the element for 

calculations.

• Individually: Check this box to assign additional information, such as strengthened reinforcement, to 

selected items, or to create an assignment outside of the norm of the criteria; the Choose button becomes 

active. Use this to link a single Property Object to this element. (To link multiple Property Objects, use the 

Link Property Objects by Criteria option.)

Classifications and Properties Panel

See Properties and Classification Systems.

ID and Categories

• ID: Type an ID in this box for tracking this element in Quantity Calculations.

The ID field serves to identify and group elements in list views. Any character can be used.

If a number is included anywhere in the ID, ARCHICAD will add one to this number for each new element 

drawn, provided that the Assign New Element ID to Each New Element checkbox is enabled in the 

Options > Work Environment > More Options dialog box. Each new element will have a unique ID.

If elements are duplicated or multiplied, the IDs of the replicas will remain the same as those of the 

originals.

If you paste elements into a Project, you may have elements with conflicting IDs. ARCHICAD does not 

automatically exclude ID conflicts. It is up to the user to designate different IDs for elements that may be in 

conflict.

IDs can be customized both before creating elements and after selecting a number of existing ones, by 

using Document > Listing Extras > Element ID Manager.

For more information, see Element ID Manager.

Note: All construction elements also have a globally unique, automatically generated ID which is 

conserved throughout the life of the Project. You can use this identifier for labeling or in lists.

• Structural Function: Optionally, define the element as either a “Load-Bearing Element” or a “Non-Load-

Bearing Element” part of the building. 
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If you have classified model elements as “Load-Bearing”, then you can use the Partial Structure Display 

“Core of Load-Bearing Elements Only” option to display those elements only.

See Partial Structure Display.

If you collaborate with partners who are using structural programs and export your ARCHICAD model to 

IFC format, the Structural Function classification automatically adds the “load-bearing” property to 

structural elements in the export file.

See Structural Function Category for IFC.

• Position: Optionally, define the element as either an “Exterior” or an “Interior” part of the building. This is 

useful to streamline coordination with energy analysis applications.

You can search for elements by their Position classification, using the criteria of the Find & Select dialog 

box

See Position Category for IFC.

• Classification by DIN: Set this value in the Classification and Properties section of Morph Settings. 

Available only in Morph Settings, and only if you are using the Flachenberechnung (Area List) Add-On 

(used primarily in German-speaking markets).

Renovation Controls

Renovation Status: This control is available only for a selected element. (In Default Settings, the note “Use 

palette to set default” indicates that the Renovation Palette can be used to set a default Renovation Status for 

all elements.)

For a selected element, use this pop-up to assign a Renovation Status: Existing, New, or To be Demolished.

Show on Renovation Filter: By default, this option, for a selected element, is set to “All Relevant Filters.” 

That is, this element will be shown, hidden, or shown with an override, depending on its Renovation Status 

and on the Renovation Filter in effect. However, you can restrict the display of any selected construction 

element to one Renovation Filter only: use this Show on Renovation Filter control to choose one particular 

Renovation Filter; this element will exist in that Renovation Filter only.

For more information, see Renovation.

Element Properties

For more information, see Properties and Classification Systems.

IFC Properties

This part of the Element Settings dialog box displays IFC Properties and Element Type Properties assigned to 

the selected ARCHICAD element. These property and attribute assignments help to optimize your 

ARCHICAD model for data exchange with other applications. 

For details on Interoperability using IFC, see Working with IFC.
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Wall Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For general information, see Walls.

For information on the Structural Analytical Parameters Panel of Wall Tool Settings:

See 2D Members (Slab, Wall, Roof)

Wall Geometry and Positioning Panel

By default:

• Wall top is linked to one story up

• Home Story is the current story.

The story to which the Wall bottom is linked is called the Home Story, but you can offset the bottom in either 

direction.

Use the controls in this panel to change any of these values, and to define the geometry and complexity of the 

Wall element.

Wall top: Use this control to either top link the Wall relative to its Home Story (Home+1, Home+2, etc.), or to 

make it a fixed-height wall (choose “Not linked”).

If you later modify the positions and heights of stories in your projects, the heights of any linked Walls will 

follow automatically. 

• Optionally, define an offset for the Wall top from its top linked story (the Wall height changes accordingly). 

This offset value can be positive, negative or zero.

The offset field is not available if the Wall has no top link.
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 Wall height: Enter a value for the total height of the Wall. (For a top linked Wall, this field is not editable.)

• The Wall height value is affected by the top and bottom offsets, if any. 

Home Story

See Home Story.

Bottom Elevation [to Reference Level]

Calculates the current elevation of the Wall’s reference line, as measured from the Reference level (by 

default, this Reference level is Project Zero). 

Click the pop-up arrow to change the Reference level, if needed.

Notes:

– Reference levels are defined at Options > Project Preferences > Reference Levels.

– This is a calculated value, not a link. If you change the Reference level, the bottom of the Wall will not 

change its position.

Wall Structure

Click one of these icons to define the Wall as Basic, Composite, or Complex Profile, and then choose an 

attribute that reflects its structural properties:

• For a Basic Wall: use the pop-up to choose its Building Material.

• For a Composite Wall: use the pop-up to choose its Composite structure.
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Note: This pop-up shows only those Composite Structures whose “Use With” control includes Walls. 

Composites are defined at Options > Element Attributes > Composites. 

• For a Complex Profile Wall: use the pop-up to choose its Profile.

Note: This pop-up shows only those Profiles whose “Use With” control includes Walls. Profiles are defined 

at Options > Element Attributes > Profile Manager.

Geometry Method

Click one of these three icons to draw the Wall as either straight, trapezoidal or polygonal.

• These options are not available for Complex Profiles.

• The polygonal option is not available for composite Walls.
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Wall Thickness

Enter a value for the wall thickness.

• If you are creating a trapezoidal Wall, two thickness fields are active: enter a thickness value for each end 

of the Wall.

• The thickness of a composite Wall is the total value of the individual skins as set in Options > Element 

Attributes > Composites. If you are creating a composite Wall, the thickness field is consequently not 

editable here.

• Thickness does not apply to polygonal Walls; the field cannot be edited.

• The thickness of a slanted Wall is its thickness perpendicular to its slant vector:

• The thickness of a double-slanted Wall equals the width of the Wall base.

Wall Complexity

The Wall Complexity icons give you a choice of Wall geometry: Straight, Slanted, or Double-Slanted. (Wall 

Complexity controls are not applicable and not available for Trapezoid Walls and Polygonal Walls.)
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• For a slanted or double-slanted Wall, enter the value for the slant(s) in degrees.

For more information, see Create a Slanted or Double-Slanted Wall.

PolyWall Corners Can Change

This checkbox is only visible when the chosen geometry method is Polygonal Wall. It controls the display of 

wall contours when connecting such a wall to other, plain walls.

For more information, see Create a Polygon Wall (PolyWall).

Reference Line Location

Click an option to define the Wall’s reference line.

Note: Reference line controls in Wall Settings do not apply to Polygon walls. (Polygon wall reference lines 

can be moved graphically via the pet palette.)

A basic Wall has three possible reference lines: Outside Face, Center, or Inside Face.

By default, the reference line runs along the outside face.

A composite Wall has six possible reference lines: Outside/Center/Inside of the Wall, plus Outside/Center/

Inside of the Wall core.
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Note: If the chosen composite structure has no core, then the core-related Reference Line choices are 

grayed out.

By default, the reference line runs along the outside face.

For a composite, the “outside” face is the top skin of the composite, in Composite Settings.
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A Trapezoid wall has two possible reference line locations: Outside Face or (if it is a composite Wall that has 

a core) Core Outside.

Reference Line Offset: If using an “outside” or “inside” reference line, enter a positive offset to move the 

reference line toward the center (or center of core) of the Wall. A negative offset will move the reference line 

away from the center (or core center). (No offset is available if the reference line is in the center or core 

center.)

For more information, see Wall Reference Line.

Wall Floor Plan and Section Panel

See Element Display in Floor Plan and Section

Wall End Lines: This pop-up gives you four ways to display a freestanding wall on the Floor Plan. The 

options let you show or hide one or both end lines of the wall. (The end line is the contour line perpendicular to 

the longitudinal axis of the wall.)

Wall Model Panel

This panel affects the 3D display of the wall.

Override Surfaces: Click the toggle button of any or all three pop-ups if you wish to override the surface 

assigned to this element (in its Building Material). You can override the surfaces of the Wall’s faces (outside 

and inside), and/or all Wall edges.
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See also Override Surfaces With Surface Painter.

For information on assigning surfaces to a Polygon wall, see Create a Polygon Wall (PolyWall).

• For a composite Wall, the “outside” surface is the first listed skin of the composite, in Composite Settings.

• For a profile Wall, there are two surface override possibilities: Extrusion edge and Ends surface.

Note: You can also apply a Custom surface to any edge(s) of the profile element. 

See Apply Custom Surface or Line to Profile Edge.

Click the chain icon to assign the last surface chosen to all faces and edges. Deselecting the chain icon will 

restore the surfaces that you originally set for each wall face/edge. 

Align Texture to Wall Edges: Check this box to place the texture origin at the bottom corner of the wall. This 

can be useful, for example, on freestanding walls to avoid a fragmented texture on the edges. 

See also Align 3D Texture.

End Surfaces: Override using Adjoining Walls: Check this box if you want the selected Wall’s end surface 

to take on the surface of the adjoining Wall.

Note: Any adjustments to the surface texture alignment will be correctly reflected on both walls.
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Custom Texture Alignment: If this message is activated, it indicates that the currently selected wall (already 

placed in the project) has been assigned a custom 3D texture.

• In this case, the Reset Texture button is also activated. Click to restore the origin of the Texture of the 

selected wall.
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Note: The Custom Texture Alignment text serves as feedback on the condition of the selected wall. If it 

is greyed out, no custom 3D texture has been assigned yet.

For more information, see Align 3D Texture.

Junction Order

Junction Order is relevant when

• two Walls meet whose Building Materials have the same priority

• 3 or more Walls meet in a junction

A higher Junction Order number takes priority over the lower.

When 3 or more Walls meet in a junction, the relative Junction Order of each Wall determines which two Walls 

are joined first.

Log Details Dialog Box

The Log Details button opens a dialog box for defining the display of walls constructed from logs:

• Use Log Wall: Check this box to use a Log Wall. 

Note: ARCHICAD calculates the number of logs from wall and log heights.

• Start with half log: Check to start the wall with a half-height log.

• Log Shape:

– Square logs

– Rounded on Outside Face

– Rounded on Inside Face: Use logs that are cambered on the inside. The outside wall face will 

remain flat.

– Rounded on Both Sides.

• Log Radius: choose an option for measuring log radius: either from the log centerpoint, or from the 

middle point of the opposite log.

• Surface of Horizontal Edges:

– As in Wall Settings: Click this radio button to apply the Building Material’s surface.

– Override with Outside/Inside Face Surface

Relation to Zones

See these topics:

Calculating Zone Area and Zone Volume

Relation to Zones
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Roof Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For general information on how to create and edit roofs, see Roofs.

For information on the Structural Analytical Parameters Panel of Roof Tool Settings:

See 2D Members (Slab, Wall, Roof)

Roof Geometry and Positioning Panel

Pivot Offset: Enter a value here for the offset of the pivot line from the Roof’s Home Story. 

Home Story 

See Home Story.

The Roof pivot height is physically linked to its Home Story. If you later modify the Home Story’s position (e.g. 

redefine the floor level), the Roof will change its position.

Absolute Pivot Elevation [to Project Zero]: Enter a value here for the elevation of the pivot line, as 

measured from the Reference level (by default, this Reference level is Project Zero). Click the pop-up arrow to 

change the Reference level, if needed.

Note: Reference levels are defined at Options > Project Preferences > Reference Levels.

Roof Structure: Click one of these icons to define the Roof as either Basic or Composite, then choose an 

attribute that reflects its structural properties:

• For a Basic Roof: use the pop-up to choose its Building Material.

– Roof Thickness: Enter a value for the thickness of the roof pane, measured either perpendicularly or 

vertically to the face of the roof. Click the pop-up arrow to choose a way to measure the roof 

thickness.
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Note: The thickness of a composite Roof is the total value of the individual skins as set in Options > 

Element Attributes > Composites. If you are creating a composite Roof, the thickness field is 

consequently not editable here.

• For a Composite Roof: use the pop-up to choose its Composite structure.

Note: This pop-up shows only those Composite Structures whose “Use With” control includes Roofs. 

Composites are defined at Options > Element Attributes > Composites. 

Roof Geometry Method: When defining default settings before creating a Roof, choose either Single-plane 

or Multi-plane Roof geometry.

If Multi-plane is selected here, the Multi-plane Geometry panel of Roof Settings is activated.

See Roof Multi-plane Geometry Panel.

Roof Pitch: Enter a value for the pitch (slant angle) of the roof.

Note: The pitch can be measured in degrees, in percentages, or (if you are using imperial units) in the 

amount of roof rise per 12 feet or 12 inches of horizontal run. Click the arrow icon next to the Roof Pitch 

field to display these unit choices.

If your Roof Settings refer to a Multi-plane Roof, then the pitch unit set here is also used when setting the 

pitch of individual Roof levels.

See Roof Multi-plane Geometry Panel.
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The Roof pitch is typically positive, but it can also be a negative value, in which case the resulting Roof is 

“reversed”: its roof plane will slope downward.

Edge Angle: Choose an angle (perpendicular, vertical, custom) for all roof edges.

• If you choose custom, enter the desired angle value in the field at right.

Note: You can set a different custom edge angle for any single edge(s). If you have done so, a yellow 

“custom” icon appears alongside the edge type setting control in Roof Settings. 

See Customize Edge of Roof or Roof Hole.

Roof Floor Plan and Section Panel

See Element Display in Floor Plan and Section

See also Use Symbolic Display in Floor Plan for Single-plane Roofs and their Skylights (as in ARCHICAD 14 

and before)

Cover Fills

See Assign a Cover Fill.

Roof Model Panel

This panel controls the 3D display of the roof.

Override Surfaces: Click the toggle button of any or all three pop-ups if you wish to override the surface 

assigned to this element (in its Building Material). You can override the surfaces of the Roof’s top and bottom, 

and/or all Roof edges.

See also Override Surfaces With Surface Painter.

Note: The top surface override, if it is a vectorial hatching, can also be applied as a cover fill for the Roof 

(by checking the “Use Fill from Surface” box in Floor Plan and Section panel of Roof Settings). 

Moreover, if the cover fill has a customized fill origin (via Link to Fill Origin option), the 3D Model will reflect 

that fill orientation too.

For a composite Roof, the “top” surface is the first listed skin of the composite, in Composite Settings.

Click the chain icon to assign the last surface chosen to all parts of the element. Deselecting the chain icon 

will restore the surfaces that you originally set for each part of the element. 

Note: The chain icon is available when all the surfaces use overrides.

If you have customized any of the Roof’s Edge surfaces or Top/Bottom surface (in the Custom Edge 

Settings or Custom Plane Settings dialog boxes), a yellow “custom” icon appears alongside the surface 

setting control in Roof Settings, indicating that one or more edge surfaces have been changed from the 

general setting.

See Customize Edge of Roof or Roof Hole. See also Customize Roof Plane
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Custom Texture Alignment: If this message is activated, it indicates that the currently selected roof (already 

placed in the project) has been assigned a custom 3D texture. In this case, the Reset Texture button is also 

activated. Click to restore the origin of the Texture of the selected roof.

For more information, see Align 3D Texture.

Trimming body: Use this control to define the geometry of the Roof’s trimming body. The trimming body will 

cut other elements in accordance with this geometry, when you trim another element to this Roof.

• Pivot lines down

• Contours down

Note: To see these trimming bodies while you work (in the 3D window only), turn on Trimming Bodies in 

the View > On-Screen View Options menu.

For more information, see Trim Elements to Roof or Shell.

Roof Multi-plane Geometry Panel

This panel is active only if you have selected a Multi-plane Roof, or if the Multi-plane Geometry Method is 

selected (Geometry and Positioning Panel) of Roof Default Settings.

Roof levels: Use these controls to add one or more levels to a Multi-plane Roof.

By default, a Multi-plane roof has one level.

Click Add to add another Roof level.

• In the table, adjust the pitch of any roof level as needed.

• Elevation refers to the point at which the new level begins:

Eaves overhang:

• Offset: Enter a value for the distance of the eaves overhang from the pivot polygon. This value is applied 

to the Roof as a whole.

You can adjust this value for any particular roof plane in the Customize Roof Plane dialog box.

See Customize Roof Plane.
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If you do so, the value in Roof Settings (applied to the roof as a whole) does not change, but a yellow 

“custom” icon appears alongside the eaves overhang control in Roof Settings, indicating that the eaves 

overhang value for one or more roof planes has been changed from the general setting.

If you later change the Eaves overhang “offset” value in Roof Settings, the yellow “custom” icon changes 

to red. This means that the Roof’s eaves overhang is going to change: do you want to apply this change to 

the custom-overhang planes too? If so, check the box at the bottom of Roof Settings (Apply changes to 

custom planes and/or edges too). If you do not check the box, your custom eaves offsets remain the way 

you set them.

• Manual: The overhang value control changes to “Manual” if you edit the roof contour graphically.

See Edit Roof Contour.

At any time, you can undo these manual edits by clicking “Offset” and entering a fixed value for the eaves 

overhang.

Curve resolution

Choose an option for dividing the segments of curved planes in this Roof.

• By arc: Divides the curved plane(s) into the given number of segments.

• By circle: Divides a full circle into the given number of segments, and applies that geometry to the curved 

plane(s) of the Roof.

You can customize the curve resolution setting for any individual Roof plane.

See also Customize Roof Plane.

See Add a Tower to the Roof.

Skylights treat segments as curves: When a Roof plane with a curved pivot line changes its geometry, 

ARCHICAD can adjust any skylights in the plane in one of two ways:

• Position skylight as onto a curved surface: this is the default setting, with the checkbox enabled in the 

Multi-plane Geometry panel of Roof Settings. Skylight geometry is adjusted so that it smoothly adjusts to 

a curved surface.

• Position skylight as onto a flat plane: if you uncheck the checkbox, ARCHICAD will adjust the Skylight 

geometry so that it fits flat onto the Roof plane.

See also Position Skylight to Curved Roof Plane.
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Shell Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For general information on how to create and edit shells, see Shells.

Shell Geometry and Positioning Panel

Reference Line Offset to Home Story: Enter a value here for the elevation, measured to the Home Story, of 

the initial point of

• the Shell’s extrusion vector (for an extruded Shell), or

• the Shell axis (for a rotated Shell), or

• the Shell’s first profile (for a ruled Shell).

These reference points are distinguished by a highlighted hotspot on each selected Shell.

Home Story

See Home Story.

Reference Line Elevation [to Reference level]

Elevation of the Shell’s starting point (reference point) as measured from the Reference level (by default, this 

Reference level is Project Zero). Click the pop-up arrow to change the Reference level, if needed.

Notes:

– Reference levels are defined at Options > Project Preferences > Reference Levels.
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– This is a calculated value, not a link. If you change the Reference level, the bottom of the Shell will not 

change its position.

Shell Structure

Click one of these icons to define the Wall as Basic or Composite, then choose an attribute that reflects its 

structural properties:

• For a Basic Shell: use the pop-up to choose its Building Material.

• For a Composite Shell: use the pop-up to choose its Composite structure.

Note: This pop-up shows only those Composite Structures whose “Use With” control includes Shells. 

Composites are defined at Options > Element Attributes > Composites. 

Shell Thickness: Enter a value for the thickness of the Shell.

If a composite structure is used for the Shell, this field is gray and cannot be modified, as the Shell’s thickness 

is then determined by the thickness of the Composite as defined in Options > Element Attributes > 

Composites.

Geometry Method

In Shell Default Settings, click one of the three icons to define the Geometry Method with which to place the 

new Shell:

• Extruded

• Revolved

• Ruled

See About Shells for more information.

Morphing Rule (for Ruled Shell only): Click on either the “Smooth” or “Paired” method for defining the 

geometry of a Ruled Shell, based on how the respective nodes of the two profiles should be connected.

For more information, see Ruled Shell Morphing.
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Flip: (Editable in Shell Selection Settings.) The Shell is composed of a membrane and a Shell body attached 

to one side of the membrane. Use Flip to change sides: the Shell body moves to the other side of Shell 

membrane.

Shell Special Properties Panel (Extrusion Properties, Revolution Properties)

If you are using either the Extrusion method or Revolved method, this panel contains special properties 

related to the Shell geometry.

Extrusion Properties

Starting angle: The angle between the plane of the Shell and the Shell edge at the initial point of the 

extrusion vector.

Distortion angle: Angle of the Shell profile, measured to the Shell plane. By default: 90 degrees, but 

changing it enables you to extrude the Shell profile at a angle, creating a distorted Shell, provided that either 

its starting or ending angle is other than 90 degrees.

Ending angle: The angle between the plane of the Shell and the Shell edge at the endpoint of the extrusion 

vector.

Revolution Properties

For a Revolved Shell: 

• Revolution angle: Angle of revolution of the Shell around its axis.

• Distortion angle: Angle of the axis of the revolved Shell, measured to the Shell plane angle. Modifying 

the distortion angle will affect the Shell profile. (Changing the slant angle alone, which is available through 

graphical editing, will not change the Shell profile, only “tip” it over.)
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• Segment Surface Along Rotation

By default, the surface of Revolved Shells is smooth. You have the option of dividing it into segments as 

needed.

Check the box if you would like to divide the rotated Shell into segmented planes. Next, enter a number for the 

number of segments.

The given number of segments can be applied to the existing Shell in one of two ways:

• By circle: Divides a full circle into the given number of segments, and applying that geometry to the 

existing arc of the Shell.

• By arc: Divides the existing arc of the Revolved Shell into the given number of segments.

Shell Floor Plan and Section Panel

See Element Display in Floor Plan and Section

Cover Fills

See Assign a Cover Fill.

Shell Model Panel

This panel affects the 3D display of the Shell.

See also Override Surfaces With Surface Painter.

For a composite Shell, the “reference side” surface is the first listed skin of the composite, in Composite 

Settings.

Note: The Reference Side surface override, if it is a vectorial hatching, can also be applied as a cover fill 

for the Shell (by checking the “Use Fill from Surface” box in Floor Plan and Section panel of Shell 
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Settings). Moreover, if the cover fill has a customized fill origin (via Link to Fill Origin option), the 3D Model 

will reflect that fill orientation too.

Note: You can apply custom surface settings to any one or more edges of the Shell, using Custom Edge 

Settings from the Pet Palette. If you do so, the Model panel of Shell Settings will indicate that one or more 

edges uses a custom surface, using a yellow patch.

See Customize Edge of Shell or Edge of Shell Hole.

Trimming body: Use this control to define the geometry of the Shell’s trimming body. The trimming body will 

cut other elements in accordance with this geometry, when you trim another element to this Shell.

• Downward Extrusion

• Upward Extrusion

• Editable

Note: To see these trimming bodies while you work (in the 3D window only), turn on Trimming Bodies in 

the View > On-Screen View Options menu.

For more information, see Trim Elements to Roof or Shell.
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Slab Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Slab tool is used for drawing and editing slabs, the basic horizontal building blocks of the Virtual Building.

For more information, see Slabs.

For information on the Structural Analytical Panel of Slab Tool Settings:

See 2D Members (Slab, Wall, Roof)

Slab Geometry and Positioning Panel

Slab Thickness: Enter a value for the slab’s thickness.

Note: If the structure of the slab is a composite, then the slab’s thickness is defined in Options > Element 

Attributes > Composites, and equals the sum of the skins’ thicknesses. A composite slab’s thickness 

cannot be edited in Slab Settings; you must go to Options > Element Attributes > Composites.

If you want to edit the slab thickness in Slab Settings, choose a non-composite (basic) slab structure.

Offset to Home Story: Define an offset for the Slab’s reference plane from its Home Story. The reference 

plane has several possible settings. (See Reference Plane.)

Home Story

See Home Story.

Offset to Reference Level: Define an offset for the Slab’s reference plane from the given Reference level 

(by default, this Reference level is Project Zero).

• The Slab reference plane has several possible settings. 

See Reference Plane.

Slab Structure

Click one of these icons to define the Slab as Basic or Composite, and then choose an attribute that reflects 

its structural properties:

• For a Basic Slab: use the pop-up to choose its Building Material.

• For a Composite Slab: use the pop-up to choose its Composite structure.

Note: This pop-up shows only those Composite Structures whose “Use With” control includes Slabs. 

Composites are defined at Options > Element Attributes > Composites. 
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Slab Edge Angle

By default, the Slab’s edge is perpendicular to its surface (90 degrees). If you wish to use a custom edge 

angle, click the corresponding icon and enter the angle in degrees in the field to the right. 

Note: You can set a different custom edge angle for any single edge(s). If you have done so, a yellow 

“custom” icon appears alongside the edge type setting control in Slab Settings. 

See Set Custom Slab Edge Angle and Edge Surface.

Reference Plane

Depending on the structure you choose for the Slab (either a basic or a composite slab), you have varying 

options for the Slab Reference Plane:

• A basic Slab’s reference plane is either the top or the bottom of the Slab.

• A composite Slab’s reference plane can be one of four options: top of slab, bottom of slab; top of core, 

bottom of core.

Note: If the chosen composite structure has no core, then the core-related reference plane choices are 

grayed out.

Use the Info Box or Geometry and Positioning Panel of Slab Settings to choose a reference plane.

See also Slab Reference Plane.

Slab Floor Plan and Section Panel

See Element Display in Floor Plan and Section

Note: The line type of slabs displayed on remote stories is set in Options > Project Preferences > 

Legacy.

Cover Fills

See Assign a Cover Fill.
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Slab Model Panel

This panel affects the 3D display of the slab.

See also Override Surfaces With Surface Painter.

See Set Custom Slab Edge Angle and Edge Surface.

For more information, see Align 3D Texture.
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Mesh Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Mesh tool is for creating surfaces, skirted surfaces and solid bodies by defining the elevation of its 

relevant nodes and interpolating between them.

A mesh is created on the foundation of the Mesh Reference Plane and the ridges of the Mesh.

You draw the main contours of the mesh projected to Mesh Reference Plane. You can then raise the 

characteristic points of the mesh’s top surface out of this plane.

For more information, see Meshes.

Mesh Geometry and Positioning Panel

Mesh Height: Set the depth (if any) to which the Mesh will extend below the Mesh Reference Plane.

• The resulting base elevation will be displayed as a negative value in the Info Box.

Offset to Home Story: Set the height of the Mesh Reference Plane as measured from its Home Story.

Home Story

See Home Story.

Mesh Construction Method

Choose a method for constructing the Mesh:
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• Surface Only

• Surface with Skirt

• Solid Body

Building Material: Use the pop-up to choose a Building Material for the Mesh.

Mesh Floor Plan and Section Panel

See Element Display in Floor Plan and Section

Note: These settings only apply to solid bodies, not to surface-only or skirted Meshes.

Note: The line type of meshes displayed on remote stories is set in Options > Project Preferences > 

Legacy.

• Ridge Selection: Define whether to Show all Ridges or Show User-Defined Ridges (i.e., only those 

that you have defined when drawing the Mesh.)

• Ridge Pen: Use the pop-up to assign a pencolor to both user-defined and generated ridges.

Cover Fills

See Assign a Cover Fill.

Mesh Model Panel

This panel affects the 3D display of the mesh.

For more information, see Align 3D Texture.

3D Appearance

Control the appearance of the generated ridges (either sharp or smooth) in the 3D model.

• All Ridges Sharp: Show the mesh in the 3D window with sharply connecting triangles.

• User Defined Sharp: Show the mesh surfaces with sharply connecting User Defined Ridges, and with 

smoothly connecting surfaces everywhere else.

• All Ridges Smooth: Show the mesh with smoothly connecting surfaces.

If you choose All Ridges Smooth, only user-defined ridges will appear in 3D view.
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Zone Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

Zones are 3D elements, whose floor plan representation consists of zone fills and zone stamps.

For more information, see Zones.

Zone Name and Positioning Panel

Zone Category: Choose a Zone category defined in Options > Element Attributes > Zone Categories. 

Their definition includes the Category name, code, color and zone stamp, and a set of parameters.

For a detailed description, see Zone Categories.

Zone Name and Number (No.): Enter name and number values in these fields for each Zone individually.

By default:

• The Zone top is linked to one story up

• The Home Story is the current story.

The story to which the Zone bottom is linked is called the Home Story, but you can offset the bottom in either 

direction.
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Use the controls in this panel to change any of these values, and to define the geometry and complexity of the 

Zone element.

Zone Top: Use this control to either top link the Zone relative to its Home Story (Home+1, Home+2, etc.), or to 

make it a fixed-height Zone (choose “Not linked”).

If you later modify the positions and heights of stories in your projects, the heights of any linked Zones will 

follow automatically. 

• Optionally, define an offset for the Zone top from its top linked story (the Zone height changes 

accordingly). This offset value can be positive, negative or zero.

The offset field is not available if the Zone has no top link.

Zone height: Enter a value for the total height of the Zone. (For a top linked Zone, this field is not editable.)

• The Zone height value is affected by the top and bottom offsets, if any. If you change the top offset of a top 

linked Zone, or its bottom offset from the Home Story, this change will be reflected in the height value.

Subfloor Thickness: Optionally, enter a Subfloor Thickness value (positive or negative). The bottom of the 

Zone will be offset. You may wish to use this value in a Zone Stamp marker.

• If the Zone has a top link, the bottom of the Zone body will vary depending on the Subfloor thickness value 

plus the Home Story offset value (the top of the Zone body remains in place).

• If the Zone top is set to Not linked, the entire Zone body will move up or down depending on the Subfloor 

thickness value.

Home Story

See Home Story.

• Optionally, define an offset for the Zone bottom from its Home Story (When top linked, the Zone height 

changes accordingly.) The subfloor thickness remains constant.

The bottom of the Zone is physically linked to its Home Story. If you later modify this story’s position (e.g. 

redefine the floor level), the Zone will change its position (while respecting the defined offset, if any).

Bottom Elevation [to Reference level]

Height of the Zone, as measured from the Reference level (by default, this Reference level is Project Zero). 

Click the pop-up arrow to change the Reference level, if needed.

Notes:

– Reference levels are defined at Options > Project Preferences > Reference Levels.

– This is a calculated value, not a link. If you change the Reference level, the bottom of the Zone will not 

change its position.
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Zone Polygon

Click one of the icons to choose the Manual, Inner Edge or Reference Line method for creating a zone.

Use the Info Box icon to access the three options of the manual method: Polyline, Rectangular or Rotated 

Rectangle.

For more information, see Creating Zones.

Zone Polygon Display (Gross/Net): Use these options to set the Floor Plan display of a Zone created with 

the Reference Line method. 

• Net: Zone polygon will not be displayed beyond the inner edge of the boundary walls.

• Gross: Full zone polygon is displayed.
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Regardless of the option, the Zone area remains unchanged, only the polygon is displayed differently.

Zone Polygon Net vs. Zone Polygon Gross

Zone Floor Plan Panel

The Floor Plan panel defines the appearance of the Zone’s fill on the Floor Plan.

Zone Fill Outline:

• Click the button if you want your Zone fill to have an outline.
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• Choose a Line Type and an outline color from the Line Type and Pencolor pop-up palettes.

Zone (Cover) Fill Pattern:

• Click the button to choose a cover Fill pattern and background from the Fill pop-up.

Note: Only those Fills defined as Cover Fills in Options > Element Attributes > Fills dialog box are 

available here. 

For more information, see Assign a Cover Fill.

• Use Fill from Surface checkbox: Zone fill on the Floor Plan will display the same top-side hatching as 

you set for the Zone’s 3D display in the Zone’s Model panel.

Link Fill Orientation: Choose a method for displaying the vectorial cover fill:

For more information, see Set Orientation of Vectorial or Symbol Fill Patterns.
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Zone Stamp Panel

Use these controls to set the Zone Stamp’s appearance on the Floor Plan.

The first field displays the name of the Zone Stamp. You cannot assign a different zone stamp here; the zone 

stamp shown is the one associated with the Zone Category you chose in the Name and Positioning Panel.

Note: The Zone Stamp assigned to each Zone Category is determined by the settings in Options > 

Element Attributes > Zone Categories.

Uniform Stamp Pen

Check this box to use this pencolor for all parts of the marker symbol, regardless of any custom colors set 

elsewhere for this marker.

Zone Stamp Angle

• Enter a rotation angle for the Zone Stamp. 

• Use two icons to define how this angle value should be interpreted when the element is placed: 

– Fixed Angle to Screen

– Fixed Angle to Model: Zone Stamp will be rotated along with the view.

See Set Orientation.

For more information on Zone Stamps, see Zone Stamp Panel.

Note: To set the units for the Zone Area display on this Zone Stamp, use Options > Project Preferences 

> Dimensions, and select Area Calculation units.
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Note: Customization of the Zone Stamp parameters will be lost if you change the Category of the Zone. 

Parameters will revert to the values stored with the Zone Category attributes.

Zone Custom Settings Panel

This panel contains additional choices linked to the Zone Stamp.

Zone Model Panel

The Model panel controls the 3D appearance of Zones, including Surface choices and crop options.

Use the pop-up to choose a surface to display this Zone.
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• Use this Surface on All Zone Faces: Click this option to display all zone faces of the 3D zone shape 

using the single surface you selected with the pop-up above.

• Inherit Boundary Walls and Cropping Elements Surfaces: Click this option to have individual surface 

polygons of the zone inherit the corresponding surfaces of boundary walls and any elements that you 

cropped the Zone with.

Note: If the Surface has a texture, the texture is automatically aligned to the longest edge of the Zone.

Related Topics:

Crop Zone to Another Element

3D Display of Zone Spaces

Zone Area Calculation Panel

Use the controls in this panel to view the measured area of the Zone and to optionally refine the calculated 

values.

Note: To see the effect of any changes in Zone calculation settings, you must execute the Design > 

Update Zones command.

See Updating Zones.

Measured Net Area

The Measured Net Area is the Zone Polygon only up to the inside face of the Bounding Walls. (In contrast, 

the Measured Area includes the area of bounding Walls all the way to their reference lines.)

Compared to the Measured Area, Measured Net Area is further reduced by Walls, Columns, and/or Curtain 

Walls that are inside the polygon IF their Relation to Zones is set to „Zone Boundary.”
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Reduced Area 

The Reduced Area results from subtracting the area of certain elements, subject to Zones Preferences, from 

Measured Net Area.

• Subtract the area of Walls, Columns, and/or Curtain Walls that are inside the polygon IF their Relation to 

Zones is set to „Reduce Zone Area only.” 

– Reduction of these Wall, Curtain Wall and Column areas is further subject to Zones Preferences.

• Subtract the area of Area of Fills if their „reduce Fill area” option is enabled.

• Subtract the area of Area of low ceilings and wall recesses as defined in Zones Preferences

Calculated Area

Click the Reduce by checkbox if you want to further reduce the Reduced Area by any given percentage 

(enter the desired percentage value in the input field). The result is the Calculated Area.

Area Subtraction

These read-only fields display how much of the zone’s original area is subtracted, depending on elements 

within or intersecting the zone.

• Walls, Curtain Walls and Columns

Displays the area subtracted for these elements as a result of settings at Options > Project Preferences 

> Zones.

• Fills

Area subtraction value displays the area subtracted as a result of the Fill’s Subtract from Zones option. 

(Turn it on or off in Fill Settings - General Settings panel).

• Low ceilings

If the zone is cut by a roof or Shell, displays the area subtracted as a result of settings at Options > 

Project Preferences > Zones.

Related Topic

Calculating Zone Area and Zone Volume
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Morph Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For general information on how to create and edit Morphs, see Morphs.

Morph Default Settings enable you to set parameters for Morphs to be created.

Morph Selection Settings vary depending on whether you have selected

• the entire Morph, or

• one or more of its sub-elements (faces and/or edges),

• or a combination thereof. 

See also Morph Selection.

Settings are shown for the last-selected face or edge, but when you change the options, they are applied to all 

selected faces and/or edges.

Morph Selection Settings: Entire Morphs

If you have selected the entire Morph, all controls of Morph Settings are available:

Exception: Texture Mapping (either Box or Planar) can only be modified for selected individual faces. For 

a Morph as a whole, the texture mapping is always “Box.”
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Morph Selection Settings: Faces and/or Edges

Use sub-element selection to select any combination of particular edges and faces from any number of 

Morphs to edit them.

In this case, only the Model panel is available, and the only available controls are Override Surface and 

Texture mapping (if any faces are selected) and Edge Type (if any edges are selected).

The rest of the controls (Morph Shadows) are gray, because these options can be applied here only to the 

Morph as a whole, not to its selected sub-elements.

Settings are shown for the last-selected face or edge, but when you change the options, they are applied to all 

selected faces and/or edges.

The numbers of editable faces and editable edges, if any, are shown in the Model Panel as well as in the Info 

Box.

 

Morph Selection Settings: Whole Morph plus Faces and/or Edges

If you have selected an entire Morph plus any additional faces or edges, you will be able to edit sub-element 

options only: all the sub-elements of the entire Morph, plus the additional selected sub-elements.

Again, only the Model Panel of Morph Selection Settings is available, and only the Face Surface, Texture 

Mapping, and Edge Type can be edited. The total number of editable items is shown in the Model Panel as 

well as in the Info Box.
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Morph Geometry and Positioning Panel

Note: The controls of this panel are available only in Default Morph Settings, or if you have selected one 

or more entire Morph elements (no sub-elements).

Bottom Offset to Home Story: Enter a value here for the Morph’s elevation from the Home Story.

This point is distinguished by a highlighted hotspot on the selected Morph; this is the Morph’s bottommost 

point.

Home Story

See Home Story.

The Morph’s bottommost point is physically linked to its Home Story. 

Bottom Elevation [to Reference level]

Height of the Morph’s lowest point as measured from the Reference level (by default, this Reference level is 

Project Zero). Click the pop-up arrow to change the Reference level, if needed.

Notes:

– Reference levels are defined at Options > Project Preferences > Reference Levels.

– This is a calculated value, not a link. If you change the Reference level, the bottom of the Morph will 

not change its position.

Building Material: Use the pop-up to choose a Building Material for the Morph.
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Morph Floor Plan and Section Panel

See Element Display in Floor Plan and Section

Note: The controls of this panel are available only in Default Morph Settings, or if you have selected one 

or more entire Morph elements (no sub-elements).

Outlines: 

• Outline Contour Display: Adds an outline contour around the morph element in Floor Plan/Section/3DD 

even if edges are hidden or soft.

Cover Fills

See Assign a Cover Fill.

Morph Model Panel

This panel affects the 3D display of the Morph.

Note: If you have selected one or more Morph sub-elements (faces and/or edges), then the only available 

controls are Face Surface, Texture Mapping and Edge Type.

You can apply custom settings to one or more Morph faces or edges by using the Custom Face Settings 

or Custom Edge Settings commands of the pet palette.

See Transforming Morphs: Custom Face Settings.

If you have customized any of the Morph’s surfaces (in the Custom Face Settings or Custom Edge Settings 

dialog boxes), a yellow “custom” icon appears alongside the surface/edge control in Morph Settings, 

indicating that one or more edge surfaces or types have been changed from the general setting.

See Custom Morph Surface: Feedback in Morph Settings, and Change Edge Type.

• Texture Mapping: This control (either Box or Planar) can only be modified for selected individual faces. 

For a Morph as a whole, the texture mapping is always “Box” and cannot be edited.

• Edges: Choose an option for displaying all Edges of the Morph.

• Morph Shadows: Check one or both boxes to display shadows either cast by the Morph and/or received 

on the Morph (shadows cast by other elements). Effects are visible whenever shadows are used (e.g. 

Rendering, 3D window).

Related topics

Override Surfaces With Surface Painter.

Transforming Morphs: Custom Face Settings

Morph Edge Type: Hard, Hidden, Soft

Morph Texture Mapping and Alignment

Change Edge Type

Watch the Video

Morph Classification and Properties Panel

Note: The controls of this panel are available only in Default Morph Settings, or if you have selected one 

or more entire Morph elements (no sub-elements).

See Classifications and Properties Panel.
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Settings of Library Part Elements

The following ARCHICAD tools are used to place Library Part elements:

• Object

• Lamp

• Door

• Window

• Skylight

• Corner Window

• Wall End

• MEP tools

For specifics on the settings of library parts, see the following sections:

Object Tool Settings

Door/Window Tool Settings

Skylight Tool Settings

For all Library Part-type elements, the browser section on the left side of the Settings dialog box contains 

identical functions. These functions are described below.
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Customize Dialog Box Panels

Library View/Favorites View

Preferred Display (List vs. Icons)

View and Apply Settings

Search for Library Parts/Favorites/BIM Components

Settings in Library View

Settings in Favorites View

Browse Folders and Subfolders (Library View)

Customize Dialog Box Panels

• Double-click the vertical splitter bar, or click the black arrow, to open/close the browser area

• Drag or double-click the splitter to resize or close the folder tree area
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• From the browser Settings pop-up, use Tree View Above or Tree View on Left to change this preference

If the tree view is visible, the folder chooser is automatically hidden.
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To use the folder chooser, hide the tree view:

Folder chooser is shown; Tree view is hidden

Library View/Favorites View

The browser area has two views:

• Library View (chair icon). Displays Library Parts in a hierarchical structure. (See Settings in Library View, 

below.)

• Favorite View (star icon). Displays only the Favorites for this tool. (See Settings in Favorites View, 

below.)

Preferred Display (List vs. Icons)

From the Settings pop-up, choose how to display the Library Parts: List View, or Medium or Large Icons.

Stretch-and- release the Palette horizontally to also access these options as buttons.

Note: In List view, you can sort the contents alphabetically by Name, by clicking the Name header.
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View and Apply Settings

Click any library part in the in the browser area to see its settings on the right side of the dialog box

The name of the library whose settings you see is shown in bold.

Reset to Default Settings

If you customize any Library Part’s GDL settings, you can reset to its default using the Reset command from 

the Info Box:
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Search for Library Parts/Favorites/BIM Components

See Search for Library Part.

See Search Favorites.

Settings in Library View

The Library View displays Library Parts in a hierarchical structure.

Click and hold to switch between folder view (the default) and subtype view:

For information on subtypes, see About GDL Object Subtypes.

Hover your cursor over a library part to see its name and location in the library.
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A library part in a loaded library has the following context menu commands:

– Click Search for Name to start a search using the Library Part name

– Use Share Object to share the object on BIM Components

See Share Object on BIM Components.

– Use Show in Library Manager to see this library part in the context of its library hierarchy in Library 

Manager

See also Library Manager.

Use the icons at bottom left to access the following commands:

• Open Library Manager

• Load Other Object

• Go to BIM Components Portal

• Share GDL Object (if a library part is selected)
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Note: Some of these commands are also available from the pop-up in the Library Part’s Info Box.

Settings in Favorites View

In the Favorites view of Library Part Settings, only the Favorites for this tool are shown.

For general information, see Favorites.

• Use the Additional Settings pop-up to switch between 2D and 3D Favorite previews

Note: To switch on the fly between the 3D and 2D preview of any Favorite, hover your cursor over the 

preview and click Shift.
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• Hover the cursor over a Favorite to see certain details about it

• Click a Favorite to view/edit its settings in the right-hand panels.

• Available context menu commands:

– Redefine Favorite: Click to redefine this Favorite based on the currently active settings (those in the 

right-hand side of the Object Settings dialog box)

– Rename Favorite

– Delete Favorite: A warning appears to confirm the delete.

 

Use the New Favorite command at the bottom of Library Part Settings (Favorites view) to store a new 

Favorite, using the current default Library Part Settings:
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Optionally, create a Folder for the new Favorite.

For further Favorites management functions, use the Favorites Palette.

See Favorites Palette and Edit Settings of One or More Favorites.
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Object Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Object tool is used to place object type library parts into the project.

The left-hand browser area of the Object Settings dialog box is similar to those of other Library Part 

elements.

See Settings of Library Part Elements.

Browse Folders and Subfolders (Library View)

In Object Tool settings, you can access a wide variety of objects that are not part of a dedicated subtype. 

These objects are divided into three main folders: Basic Library; Visualization Objects; and Add-On Library, 

and several sub-folders. As you can see by the folder names, the Basic Library contains all kinds of 

Furnishings (Beds; Chairs; Office Equipment, etc.); Decorations (such as clocks and vases); Health/

Recreation items (such as a piano, a billiard table, a TV). Additional folders contain Building Structures (such 

as fences and moldings); Special Constructions (such as fireplaces and shutters); Mechanical Elements (such 

as air conditioners and elevators); and 2D Elements (such as electric and graphic symbols.)

The Visualization folder contains Site improvements (e.g. trees) and objects depicting People and Vehicles.

For information on searching for library parts, see Search for Library Part.
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Panels of the Object Settings Dialog Box

Object Preview and Positioning Panel

Object Custom Settings Panel 

Object Floor Plan and Section Panel

Object Model Panel (Not Visible by Default)

Object Preview and Positioning Panel

Bottom Offset to Home Story: Enter a value to define the object’s base elevation relative to its Home Story.

Bottom Elevation [to Reference level]: Shows the object’s absolute base elevation, measured to Project 

Zero or to any other custom-defined Reference Level.

See also Reference Levels Preferences.

Notes:

– Reference levels are defined at Options > Project Preferences > Reference Levels.

– This is a calculated value, not a link. If you change the Reference level, the bottom of the object will 

not change its position.

Dimensions 1 and 2: enter the two orthogonal size values (e.g. length and width) of the object.

Click the chain icon to keep these values proportionally constant.

Height: Enter the object’s height.

Enter a rotation angle for the object, if any.

Use the pop-up to define how this angle value should be interpreted when the element is placed: 

•  Relative to Orientation (the angle will be measured relative to the Oriented View);

See also Set Orientation.

or

•  Absolute to Coordinate System (the angle will be measured from the (0,0) point of the project 

coordinates).
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Check the Mirror Library Part box to mirror the chosen Library Part when placing it, or to mirror a selected 

object. (View the preview after checking this box to see how the object will be placed.)

Preview Options

The Preview Area at the right shows you the object in different displays, depending on which of the icons (at 

left) that you choose. As you set different parameters for the object, keep an eye on this preview to see the 

effects of your edits.

Click among the Preview Options to vary the preview picture:

Move the cursor inside the Preview Area and the cursor will change to a “flip” arrow, allowing you (in the Plan 

or 3D previews) to alternately view each side of your Library Part.

The preview options, from top to bottom:

• Plan view

• Front view

• 3D view

• predefined preview picture

Note: To modify the predefined preview picture, use the Preview Picture controls in the GDL Object 

Editor.

See Preview Picture.
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Move the cursor inside the Preview Area and the cursor will change to a “rotate” arrow, allowing you (with 

successive clicks) to rotate the Plan or 3D preview.

Information

Click the information icon to view a brief description of the object.

Click the Info button to see further information about the library part (e.g. author, description). If you share 

your own library part to the BIM Components Portal, you have the opportunity to enter this information during 

the process.

See Share Object on BIM Components.

Placement Anchor

Objects can be positioned by their hotspots, defined in the 2D symbol of the Library Part. One Hotspot is 

initially defined as the primary hotspot. This hotspot is marked with a highlighted rectangle, and it will act as 

the default insertion point and anchor point for the Object.

The other hotspots are displayed as X’s. Click any of them if you wish to use it as an insertion/anchor point 

instead of the default primary hotspot.
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Home Story: Choose a Home Story for the Object: by default, it is the Current Story, but you can click Select 

Story instead and choose any other Story as the Home Story.

For more information, see Home Story.

Object Custom Settings Panel

The available parameters vary depending on the object. Where applicable, click the pop-up menu to access 

different parameter categories.

For information on transferring modified parameters from one object to another, see Parameter Transfer 

Between Objects.

– All Parameters: Some objects have Parameter lists as an alternative interface for the graphical 

Custom Settings. If you prefer the Parameter list, choose this from the Custom Settings Panel pop-up:
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The Minimal Space parameter (included with many Objects from the default ARCHICAD Library) defines the 

area surrounding the placed object that you want to keep free. You can opt to display the minimal space of all 

objects in 2D views, depending on the global options set at Model View Options.

See Miscellaneous Settings for Library Parts.

Reset to Default Settings

If you customize any Library Part’s GDL settings, you can reset to its default using the Reset command from 

the Info Box:

Object Floor Plan and Section Panel

Use this panel (or the equivalent controls in the Info Box) to do the following:

• Define the Stories on which the Object should be displayed

• Optionally override the 2D representation parameters that have been defined for the object in its GDL 

script (see Override Object Attributes, below).

Show on Stories: Use this pop-up (where available) to control the stories on which objects will be displayed: 

on its Home Story only, or in outline form on other stories as well.
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The Object/Lamp can also be shown One Story Up or One Story Down only.

For more information, see Show On Stories.

Override Object Attributes

Typically, you will define the 2D attributes (line type, pen, fill) for an object using the 2D Representation 

settings in the Custom Settings panel, described above.

See Object Custom Settings Panel, above.

However, you may wish to override these attributes, using the simplified settings of the Floor Plan and Section 

Panel of Object Settings.

Define the attributes for cut, uncut and overhead lines, pens and fills as needed.

For these settings to take effect, make sure that the applicable Override Object’s /Line Types/Pens/Attributes 

checkbox(es) are on. 
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Note: For some objects, no GDL Object parameter is defined. In this case, the object will be displayed 

using the attributes defined in the Floor Plan and Section panel (regardless of the Override checkboxes).

Object Model Panel (Not Visible by Default)

This panel is not visible by default. If you need it, make the panel visible in Door/Window Settings, using 

Options > Work Environment > Tool Settings Dialog Boxes.

Use this panel to if you want to define one single Surface for the Object. 

Activate the Surface button, then choose a Surface from the pop-up.
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Special Lamp Parameters

The left-hand browser area of the Lamp Settings dialog box is similar to those of other Library Part elements.

See Settings of Library Part Elements.

The right-hand Settings panels of the Lamp Tool dialog box controls are similar to those of Object Settings. 

See Object Tool Settings for a description of the common Settings panels.

Basic Light Parameters

All lights and lamps have certain parameters in common, on the Light Settings Panel of Lamp Tool Settings. 

Some of these are described below:

See Basic Light Parameters.

General Light Sources and Effects

The General Light Sources folder contains light sources that serve to illuminate the project, and have many 

sophisticated optional effects. The effects are advanced-level settings that are separated from the basic 

parameters in the Settings dialog box.

These effects parameters are introduced below, in this section:

See General Light Sources and Effects.

Watch the Video

The effects you set for your lamps and light sources are taken into consideration for Photorenderings. As a 

rule, the global effects are set in PhotoRendering Settings (turn on GI, Lens effect, Intensity). You can then 

fine-tune these in your individual lamp/light objects.

Note that certain individual Lamp parameter settings will take effect only if the corresponding global parameter 

in PhotoRendering Settings is switched on. These situations are noted in the descriptions of light effects, 

which follow.
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Basic Light Parameters

All lights and lamps have basic light parameters in common, on the Light Settings Panel of Lamp Tool 

Settings. Some of these are described below.

Turn Light On/Off in PhotoRendering

• Click the light bulb on the Light Parameters panel to turn the Light ON or OFF. The Light or Lamp must be 

turned on here in order for Lamp-related PhotoRendering Settings to have an effect.

Light Color and Intensity

• Set the light source’s color by clicking the Color field.

• The Main Intensity of the light can be adjusted with this slider. By default, it is set to the middle of the 

slider (at 100 percent), which corresponds exactly to the light intensity defined for this lamp with the 

controls below. Adjust the Main Intensity slider to either strengthen or weaken this defined light intensity.

– Absolute Light Intensity: Define the light source intensity in candelas or lumens.
ARCHICAD 24 Reference Guide 3785



Tool Settings Dialog Boxes User Interface Reference
– Light Distance: (Available for lamps only if Absolute Light Intensity is unchecked.) This is an 

alternative way of defining the light source intensity. Light Distance represents the distance over which 

the source light intensity changes from 100% to 0%.

– Falloff - Reduce Light Intensity over Distance: (Available for some general light sources). Check 

this box to reduce intensity over distance. Falloff type is always Inverse Square.

Effect of Lamp Intensity Settings in PhotoRendering

By default, the individually set intensity of each placed light object will be in effect in photorenderings with 

Cineware. This is shown in the Basic Render Settings “Lamp Intensity” slider, which is set to “By Settings” 

(100 percent) by default.

Adjusting this slider in PhotoRendering Settings will override individual lamp settings and either increase or 

decrease them accordingly.
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Shadow Casting

Check this box in the Light Settings dialog box to have the light cast a shadow.

 The slider position defines shadow quality; the higher the quality, the longer it will take to render. The default 

value of 2 enables fast rendering and is usually adequate. You should adjust this slider only if the light effect 

seems too grainy.

Effect of Shadow Casting Settings in PhotoRendering

Individual Lamp settings will take effect in Cineware PhotoRenderings only if you have set the Shadow Quality 

option in the PhotoRendering Palette’s Cineware Basic Settings to “By Light Settings.”
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Light Object: Show Illumination in 2D and 3D

You can depict a light object’s arc of illumination in 3D windows (and, for General Light Objects, on the Floor 

Plan as well.)

Use the Floor Plan and Model Representation page of Light Settings panel. The arc shown corresponds to the 

Light Distance value (set on the Light Parameters page).

General Light sources have a separate Model Representation settings page for 3D:
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General Light Sources and Effects

Choose from among seven light objects in this category to provide a general source of light. 

Watch the Video

General lights, unlike lamps in the Interior or Street Lamp categories, include special effects such as Visible 

Light and Noise parameters. Click the parameters pop-up to access these Effects parameters.
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The main Effects page contains graphical links to the sub-pages:

On each page, one or more sample images helps you understand the effect of the parameters.

Note: Not all effects are available for all General Light objects.

Visible Light

This effect controls properties of the light beam in the scene.
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Use the pop-up to choose a Visible Light type: Visible, Volumetric, or Inverse Volumetric. The images on the 

pop-up help you understand the options.

• Visible: This type of effect will produce visible light that passes through all objects and does not affect 

them; this effect casts no shadow in the beam.

• Volumetric: Use Volumetric if you want your Visible light effect to cast a shadow. 

• Inverse Volumetric: This is the opposite effect of the volumetric light: the light is visible where the light 

cone would normally be in shadow. This can be useful if you want to give the impression that an object is 

radiating light (e.g. a neon company logo on the side of a building).

Density/Quality: Use the two sliders to set these parameters of the light beam.

• Transparent/Dense slider: defines how dense this light effect is.

• Fastest/Best Quality slider: The “Fastest” setting means few samples are taken, and the PhotoRendering 

effect is generated relatively quickly. The Best Quality will take more samples and take longer.

Reduce Density over Distance: Check this to have the light density decrease toward the edges.

• Amount of Reduction: 100 percent means the light fades entirely.

• Use the Reduction Starts and Reduction Ends fields to define where to begin and end this reduction.
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Noise

Noise adds irregularities to the light source in two ways, to make the effect more realistic.

The images in the Light Settings Noise controls help illustrate what the parameters mean.

• Noisy Illumination: Check this box to add noise to the illuminated surface.

• Noisy Visible Light: Check this box to add noise to the Visible light beam itself.

Use the pop-up to choose a Noise type: plain Noise, or Soft/Hard/Wavy Turbulence (which produce a cloud-

like effect). The images on the pop-up help you understand the options.

Use the sliders to further adjust the Noise effect you have chosen:

• Grittiness: A higher value will create a larger number of irregularities for a grainier effect.

• Brightness: Affects the overall brightness of the white “blotches” of the noise effect.

• Contrast: Affects the black/white contrast of the noise effect.

Caustics

Caustics are patterns of focused light created on surfaces and within a visible light beam.

Check the box of the types of Caustics you wish to create (you can use both effects at once):

• Surface Caustics: Achieves a Caustic effect on the illuminated surface.

• Volume Caustics. Achieves a Caustic effect within the light beam itself.
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Important: The Volume checkbox will have an effect only if you have chosen enabled the Volumetric 

option for the Visible Light parameter (Visible Light page of Light Settings):

For both types of Caustics, you can set the following parameters:

• Starting Energy: Affects the brightness

• Photons: Affects the accuracy and quality of the Caustic effect; higher values increase rendering time.

Falloff - Reduce Energy over Distance: This is unchecked by default. If checked, you may not see the 

Caustic effect, if the light source is far enough away from the surface.
ARCHICAD 24 Reference Guide 3793



Tool Settings Dialog Boxes User Interface Reference
Using Caustic Effect in PhotoRendering

The Caustics settings of your Light Objects will have the desired effect in PhotoRenderings only if 

1. the corresponding Caustics effects are enabled in PhotoRendering Settings (see Caustics (Cineware 

Effect)); and

2. the Caustic channel of the affected Surface(s) are also turned on.

Lens Flare

Lens Flare simulates the aberrations of real-world camera lens systems and film material. Its two main 

components are Glow and Reflexes.

• Glows are a type of over-exposure to light

• Reflexes are lens reflections
ARCHICAD 24 Reference Guide 3794



Tool Settings Dialog Boxes User Interface Reference
You can choose from a large number of predefined glow and reflex effects: click the pop-ups to see the 

images for each.

Glow: Check this box and use the pop-up to choose a Glow style for your Lens Flare.

Reflexes: Check this box and use the pop-up to choose a Reflex style for your Lens Flare.

Use the Brightness slider to adjust the brightness of the Glow and/or Reflexes in the lens flare.

The Height/Width value express a proportion; changing this value will distort the shape of the effect (glow or 

reflex).

Use the Rotation parameter (enter a value in degrees) to rotate the Glow element.

Using the Lens Flare Effect in PhotoRendering

Lens flare is a so-called “post effect” which is applied after the rendering calculation is completed. 

The Lens Flare settings of your Light Objects will have the desired effect in PhotoRenderings only if you turn 

on Lens Effects in PhotoRendering Settings (Cineware engine, Detailed view):
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Clipping

This effect clips the light effect between two points.

Check the boxes to create a Near Clip and/or Far Clip.

For each Clip, define where the clip effect should start and end.
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Illumination-Related Special Effects

These effects are important general parameters for your light effects. Try out the checkboxes to see how the 

sample image changes, to help you understand the effect. 

Use Global Illumination: This is on by default. Global Illumination (GI) is a sophisticated method for 

achieving realistic lighting effects in your model. The algorithm simulates the effects of not just direct light 

sources, but indirect light effects - that is, inter-reflections caused by light rays bouncing off surfaces.

Using Global Illumination can greatly increase render time.

See also Consider Global Illumination.

Ambient Illumination: Normally the brightness of a surface is determined by the angle at which a ray of light 

hits it. When Ambient Illumination is switched on, however, the angle does not matter. All surfaces are lit with 

the same intensity; this results in a much flatter look. Only the material color is considered in the lighting 

calculations.

Only Effects, No Illumination: With this option, just the visible light effect itself, plus any lens effect, will be 

shown. No objects are illuminated by the light source.

Illuminate One Direction Only: Check this if your rendering doesn’t need the light to illuminate the space in 

all directions. (Use the hostpots on the Show Illumination feedback lines in 2D and 3D to graphically adjust 

the direction.)

Shadow and Surface Related Special Effects

• Only Shadow, No Illumination: Use this if you want the light object to only cast a shadow, without 

producing any illumination. This can be useful if your scene contains multiple lights, and you don’t need all 

the illumination for the scene.
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• Disregard Surface Transparency: Check this option to help minimize render times (e.g. for a test 

render).

• Ignore Diffuse Channel: With this option, the color properties of an object are ignored by the light source; 

only specular surfacing is produced by the light. This can be useful for objects such as a golden signature, 

where you would like specular glints, but no lightening of the color properties. This also produces a more 

metallic effect.

• Ignore Specular Channel: With this option, the light source produces no specular highlights on your 

scene’s objects. This can be useful if, for example, an object is lit from both sides by two light sources, 

producing too many shiny highlights. You can retain the lighting but reduce the highlights by using Ignore 

Specular Channel for one of the lights.

Sun Object

One of the General Light Sources is the Sun object. It is a simpler alternative to the sun defined in the 

Cineware’s Physical Sky settings; and it takes better advantage of Cineware capabilities than the ARCHICAD 

Sun.

The sun object provides lighting based on the Time and Location settings of the ARCHICAD Sun (see 

Sunlight Settings.)

Alternatively, the Sun Object can be positioned manually: In Sun Object settings, check the Set Sun Position 

Manually checkbox. The Sun Azimuth/Altitude values are now editable, and they will be updated automatically 

as you move the object in the project.

Note that the PhotoRendering Palette’s Environment settings are not reflected in the 3D model, so in order to 

gauge the effect of the Sun Object, you must watch its effect in the Rendering Palette Preview, while moving it 

in the 3D window. 
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Door/Window Tool Settings

Door/Window libraries and their library part settings may vary considerably depending on the library that you 

are using.

The following description corresponds to the “International” library that is the basis for many of the language 

versions of ARCHICAD.

For information on settings of a specialized Door/Window that are not described here, please contact your 

distributor.

For information on browsing and searching in this dialog box, see:

Settings of Library Part Elements

Search for Library Part

Empty Opening: Click this button to clear the current Library Part choice and automatically use an Empty 

Hole for the Door or Window opening.

See also Creating an Empty Opening.
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Settings Panels

The Door and Window Settings dialog box contains the following panels:

• Preview and Positioning

For details, see Door/Window Preview and Positioning Panel.

• Custom Settings (the name of the panel varies depending on the type of Door/Window)

For a description of controls here, see: Custom Settings Panel for a Door/Window

• Floor Plan and Section

• Dimension Marker

• Marker Custom Settings (this panel’s availability depends on the type of marker chosen in the Dimension 

Marker Panel above. If no marker is chosen, this panel is gray.)

• Classification and Properties

Topics in this section:

Door/Window Preview and Positioning Panel

Where to Set Door/Window Parameters

Floor Plan Display of Door/Window: Symbolic vs. Projected

Other Panels in Door/Window Settings

Door/Window Model Panel (Not Visible by Default)

Door/Window Reveal Controls (for Non-Standard or Legacy Openings only)

Related topics:

Custom Settings Panel for a Door/Window
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Door/Window Preview and Positioning Panel

Use the fields to enter the following values for the Door/Window:

Width: Enter Width of the opening here.

Height: Enter Height of the opening here.

Note: These Width/Height values are the window’s Nominal Size values, which can also be entered in 

the Graphical Interface Panel’s Nominal Sizes and Tolerance panel.

Sill/Header Value: Enter the height of the Door or Window Sill or Header from the chosen reference point.
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Define the reference point for the sill/header by choosing from the pop-up above the value field:

See also Sill or Header Heights.

Reveal: Enter the depth of the Door/Window Reveal, if any.

Anchor the Reveal to either the Wall face or the Wall core (the closest core skin, if there are several core 

skins). This is relevant if you are using a composite Wall.

See also Anchor Reveal.

Note: The Reveal value, on the Preview and Positioning Panel, is the same as the Reveal Depth value on 

the Reveal tab page of the Custom Settings panel of Door/Window Settings.

Preview Area

See also Preview Options.

The Flip button switches the opening direction of a selected door/window from one side to the other, while 

keeping the frame in place. (This button is also available in the Info Box).
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Anchor Point: This control affects the method used to place a new Window/Door. Choose either side or the 

Center as your preferred geometry method for placing the Door/Window.

As you place the opening into a Wall, you can switch Geometry Methods on the fly (use the Anchor Point 

control in the Info Box, or its shortcut.)

See also Placing Doors or Windows.

Opening Plane: This control is relevant if your door/window is placed into a slanted wall.

• Associated to Wall: The plane of the door/window will follow the plane of the wall.

• Vertical: The door/window will be placed vertically regardless of the plane of the wall it is placed into.

For more information, see Setting the Window/Door Plane in Slanted or Complex Walls.
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Where to Set Door/Window Parameters

For every Door/Window in the INT library, you can set parameters using the Custom Settings panel, which 

has a graphical interface. The name of the panel varies depending on the Door/Window type that is selected.

Parameters are grouped into a hierarchy of tab pages.

For fast, simple setup of doors and windows, you only need the three main tab pages: Settings and Opening, 

Wall Opening, Fixtures and Fittings. 

To set additional details, go deeper into the tab page hierarchy, or access them with shortcuts from the main 

pages

Another way to switch tab pages is to use the arrows at the top right of the panel.

For a description of these controls, see: Custom Settings Panel for a Door/Window

For more information on Door/Window attributes, see Override GDL Object Attributes of Doors/Windows.
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Floor Plan Display of Door/Window: Symbolic vs. Projected

Use the Floor Plan Display control in Door/Window Settings (Floor Plan and Section Panel) to define how to 

display the opening:

• Symbolic (default setting): This is the object’s standard symbol, which is defined independently of the 

element’s 3D model appearance.

• Overhead All: the element’s symbolic 2D view is shown with its overhead attributes.

Note: Define Overhead attributes (line type, pen) in the Floor Plan and Section panel of Door/Window 

Settings.

See Override GDL Object Attributes of Doors/Windows.

In case of a slanted wall, however, you might prefer a more realistic display of the cut door/window: choose 

either Projected or Projected with Overhead to see all parts of the window in a slanted wall.

• Projected: shows cut part of element’s 3D model, plus its uncut (downward) part.

• Projected with Overhead: shows cut part of element’s 3D model, plus the element’s overhead part (i.e. 

the part of the element that is above the Floor Plan Cut Plane, plus its uncut (downward) part.

Symbolic Overhead All

Projected Projected with Overhead
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Other Panels in Door/Window Settings

Door/Window Model Panel (Not Visible by Default)

This panel is not visible by default. If you need it, make the panel visible in Door/Window Settings, using 

Options > Work Environment > Tool Settings Dialog Boxes.

Use this panel to if you want to define one single Surface for the Door or Window. 

Activate the Surface button, then choose a Surface from the pop-up.

Door/Window Reveal Controls (for Non-Standard or Legacy Openings only)

A separate tab page for Reveal Settings are available only for certain Doors/Windows that are not part of the 

standard ARCHICAD library.

Use these controls to customize the various elements of the reveal, such as the Head Depth, Sill/Threshold 

Depth, Reveal or Sill construction, left and right Jamb Depth and Reveal Depth.

Door/Window Dimension Marker

From the pop-up list, choose a predefined Marker or browse for a different marker object.

To show or hide door/window markers on the plan, use the Door/Window Options in Document > Model View 

> Model View Options.

For more information, see Model View Options for Construction Elements.

Dimension Markers are essentially parametric GDL objects permanently linked to the opening.
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The dimension units of Door/Window markers, and the dimension units of sill heights displayed in Door/

Window markers, can be customized in Options > Project Preferences > Dimensions.

For more information, see Dimensions Preferences.

The preview window gives you feedback on the selected Marker’s appearance.

Subfloor Thickness: Use this control if you want the Door/Window marker to indicate a sill height value 

which takes into account the height difference (if any) between the floor level and the bottom of the wall (for 

example, due to carpeting or parquet flooring). This value will then be calculated as part of the sill value 

shown in the Door/Window marker.

This value will not affect the positioning of the Door/Window.

See also Sill Height Using Subfloor Thickness.

Door/Window Marker Text Style

See Text Style Panel.

Door/Window Marker Symbol and Text 

See Marker Symbol and Text Panel.
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Skylight Tool Settings

The left-hand browser area of the Skylight Settings dialog box is similar to those of other Library Part 

elements.

See Settings of Library Part Elements.

For general information, see Skylights.

Skylight Preview and Positioning Panel

Width: Enter Skylight width.

Height: Enter Skylight height.

Constraint in Roof: Only available for selected Skylights placed in Roofs (not Shells). Use this control to 

decide how to constrain the Skylight position in a modified Roof plane: 

• either Horizontally (the Skylight will retain its position as seen on the Floor Plan)

• or Vertically (the Skylight will retain its vertical elevation regardless of its Floor Plan position.)

For more information, see Skylight Constraint Relative to Roof.

Sill or header height: This field that expresses the height of the Skylight anchor point (either its sill or header) 

as measured from either a particular story, or from the Roof Pivot line. (If you have constrained the Skylight 

position horizontally, this field is read-only.)

• Click on a hotspot the Preview window to define the Skylight sill/header anchor point (at the top or bottom 

of the Skylight).
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• From the pop-up, choose whether to measure this height from a particular story, or the Roof pivot line.

The Flip in Shell button is only available for selected Skylights placed in Shells (not Roofs). Click Flip in Shell 

to change the orientation of the Skylight to the opposite side (e.g. from “inside” to “outside”.)

Check the Mirror Library Part box to mirror the Skylight when placing it, or to mirror a selected Skylight.

Preview Area

See Preview Options.

A Skylight is positioned by its hotspot, defined in the 2D symbol of the Library Part.This hotspot is marked with 

a highlighted rectangle, and it will act as the insertion point and anchor point for the Object.

The other hotspots (if any) are displayed as X’s. Click any of them if you wish to use it as an insertion/anchor 

point instead of the default primary hotspot.

Skylight Settings

Use this interface to set parameters for the Skylight.

Note: Fill and pencolors for Floor Plan display can be defined either in this panel (using the 

Representation controls), or else overwritten by entering custom fills and pens in the Floor Plan and 

Section panel below.

Click any of the parameters to select it and to modify the value of the variable.
ARCHICAD 24 Reference Guide 3809



Tool Settings Dialog Boxes User Interface Reference
Skylight Floor Plan and Section Panel

On the Floor Plan, Skylights are, by default, based on a 3D projection, not a symbolic depiction.

Note: Skylights in Single-plane Roofs that were migrated from ARCHICAD 14 or older version projects 

can be displayed, if you prefer, using a Symbolic depiction.

See Legacy Preferences.

For information on overriding the Skylight’s defined GDL attributes:

See Override GDL Object Attributes of Doors/Windows.

Skylight Dimension Marker Panel 

The Dimension Marker panel features the customizable options for the Skylight’s Dimension Marker.

To show or hide Skylight markers on the plan, use the Skylight Options in Document > Model View > Model 

View Options.

For more information, see Model View Options for Construction Elements.

Dimension Markers are essentially parametric GDL objects permanently linked to the opening.

The dimension units of Skylight markers can be customized in Options > Project Preferences > 

Dimensions.

For more information, see Dimensions Preferences.

From the pop-up list, choose a predefined Marker or browse for a different marker object.

The preview window gives you feedback on the selected Marker’s appearance.

Define Marker size and pencolor.

Uniform Marker Pen: Check this box to use this pencolor for all parts of the marker symbol, regardless of 

any custom colors set elsewhere for this marker.
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Skylight Marker Settings Panel

The Marker Settings panel contains options for the Library Part type dimension marker. The panel is active 

only if an eligible Marker has been selected in the Dimension Marker panel.

Sill Height: Use this control if you want the Skylight marker to indicate a sill height value which takes into 

account the height difference (if any) between the story level and the sill of the Skylight (e.g., to account for 

carpeting). This value will then be calculated as part of the sill value shown in the Skylight marker.

See also Sill or Header Heights.

This value will not affect the positioning of the Skylight.
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Dimension Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

There are five variations of the Dimension Tool. Each has its own dedicated tool in the Toolbox.

Linear Dimension Tool Settings

Elevation Dimensions

Radial Dimensions

Level Dimensions

Angle Dimensions
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Linear Dimension Tool Settings

Dimension Type Panel

Dimension Type

Define how you want to calculate your linear dimension.

• With the Linear method, distances between two adjacent Reference Points are measured and displayed.

• With the Cumulative method, the first Reference Point is considered the zero point of the dimension 

chain. All dimension values of the chain will give you the distance between any Reference Point and the 

zero point.
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• With the Base-line method, measuring the dimensioning distances is the same as with the Cumulative 

method, but the zero point is not marked.

• With the fourth icon, you create Elevation Dimensions.

See specific settings at Elevation Dimensions.

Marker Type

Extend Witness Line: Choose whether the witness line should extend past the node.

Marker Selection: Choose a Marker type from the pop-up. 
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• The last arrowhead type results in a double Dimension Line enclosing the values. With this marker, value 

position settings are not effective.

Static Dimension

Enable this checkbox to create static dimensions that are not associated with any of the elements in the 

Project.

Show Dimension Text Only

Check this box to display the dimension text only, without any lines.

You can display a reference line (on-screen only) for this type of dimension as an aid in editing: turn it on at 

View > On-Screen View Options > Dimension Reference Lines.

Witness Line Format

Click an icon to define the Witness Line format. From left:

• None

• Sized height

Note: Set Marker Size in the Marker and Witness Lines Options panel, below.
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• Custom height

Note: Set length of custom witness lines in the Marker and Witness Lines Options panel, below.

• Dynamic height (associated to the dimensioned element).

Note: Set the gap between the Witness Line and the dimensioned element in the Marker and Witness 

Lines Options panel, below.

Pens for Dimension Marker and Line: Choose Pencolors/Penweights for the Dimension Marker and for the 

Dimension Line.

Text Style Panel

Pointer Line

Dimension Marker and Witness Line Options Panel

These options set the Witness Line options, depending on the type of Witness Line you chose in the Type 

panel, above. (See Dimension Type Panel.)

Marker Size: Enter the size of the marker here.

Dynamic Witness Line Gap: Enter the element-Witness Line gap value here for the Dynamic Witness Line.

Custom Witness Line Length: Enter the length of the Custom Witness Line here.

Dimension Details Panel

The Dimension Details panel contains options for the dimensioning of Windows and Doors and composite 

Walls.

Note: These controls are in addition to the options available through the Dimension Marker panel of the 

Door/Window Settings dialog boxes, and works for both smaller and larger sizes for German type reveals.

Display the Height of Openings as well: Check this box if you want the dimension marker to display the 

opening’s height value along with the width. If you check this box, choose one of the three radio buttons at 

right to define how to display the Height value:

• Always with Oversize: Include the opening’s vertical oversize, if any, in the Height value.

• Always without Oversize: Do not include any oversize when calculating the displayed Height value.
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• Determined by Width: If the dimensioned Width includes an oversize, show Height with its Oversize. If the 

dimensioned Width does not include an oversize, do not include any oversize in the displayed Height 

value.

Dimension Components of Composite and Profile Elements

• With the Manual method, click the endpoints of each skin in turn before placing the dimension. 

• With the Automatic method, dimension points are placed at the faces and/or reference lines depending 

on the options checked below (at least one category must be checked)

– Outer faces

– Core faces

– Reference lines

The Automatic method works on Walls on the Floor Plan, and on Walls and Slabs in Section.

See also Dimension Wall or Slab Thickness.

Notes:

• On the Floor Plan, the core(s) of a profile element will be dimensioned along its cut part.

• In Section, the core(s) of a profile element will be dimensioned along its bounding box.

• If you edit the composite or profile structure so that it no longer has a core, the core-only dimension will 

automatically change to dimension the full thickness of the Wall/Slab.

Dimension Text Placement Method

Use these options to control how Dimension Texts should be adjusted if they become too crowded.

Note: These options are available if the dimension type is set to “linear” (not cumulative, baseline, or 

elevation). (See Dimension Type Panel.)
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• Classic: The algorithm used in older versions of ARCHICAD. 

Dimension Texts are placed horizontally and in the middle of the measured segment. 

– If there is not enough room, Dimension Texts are shifted sideways so as to be readable. 

Adjacent Dimension texts also shift sideways.

– If there’s no space to move sideways, they are adjusted vertically upwards, by rows. 

• Flexible (default): This method is more sophisticated than the Classic: it makes automatic adjustments 

even if a dimension text has been manually moved, or consists of multiple lines. 

– Dimension Texts are placed horizontally and in the middle of the measured segment. 

– If the space is too narrow, Dimension Texts will shift sideways. (Adjacent texts stay put.)

– If there is not enough space for a sideways shift, texts may be adjusted vertically.

Two additional checkmarks options are available with this method:

– Allow below dimension line: As part of the adjustment, texts may be displayed below the dimension 

line as well as above.
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– Allow adjacent texts to shift: When a dimension text is shifted sideways, its adjacent dimension 

texts may also shift sideways (to the middle of the space remaining) as needed.

• Centered: 

– All dimension texts are placed right in the middle of the measured segment. Nothing is adjusted 

sideways.

– If there is not enough room, they are adjusted vertically.

         

– Allow below dimension line: As part of the adjustment, texts may be displayed below the dimension 

line as well as above.

– Allow overlap with Markers: Texts may overlap with the dimension markers. (If this is off, then texts 

will be adjusted vertically to avoid overlap with Markers.)

• Off: No automatic adjustment takes place to enhance readability.

All the texts are simply placed in a row, directly above the dimension line without regard to readability.
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Dimension Text Settings

To open the Dimension Text Settings dialog box, you must first select the Dimension Text item (not the 

entire Dimension line).

Select Dimension Text

To select a Dimension text, do one of the following:

• Use the Quick Selection cursor

• Click on a corner of the text with the Checkmark with Arrow cursor

Note: To select a Fill Area text, make sure you have enabled Textbox handles at View > On-Screen View 

Options.

Open Dimension Text Settings

Select a dimension text (see above), then do one of the following:

• click the Text icon in the Info Box

• double-click the Dimension Tool icon in the Toolbox

• use the Ctrl+T shortcut

• click the Edit > Dimension Text Settings command. (This command is only available when a Dimension 

Text is selected.)

Copy-Paste Dimension Text

Only simple text items can be copied; superscripts will not be copied.

1. Select the dimension text only (not the dimension line itself)

2. Use the Copy command (Edit > Copy or Ctrl/Cmd + C)

3. Paste the dimension text (Edit > Paste or Ctrl/Cmd + V) - for example, to a text box or onto a Layout.
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Dimension Text Content Panel

Measured Value

This field displays the measured value of the selected dimension.

The unit and accuracy of the dimension value can be set separately for each type of dimension value (e.g. 

length, angle, area) at Dimensions Preferences (Options > Project Preferences > Dimensions).

See Dimensions Preferences.

 Custom Text

Choose this option if you want to add custom data to the dimension text. By default, the <MeasuredValue> 

Autotext item is displayed in the edit field as soon as you click the Custom Text radio button.

Note: For Level Dimensions, the <toPZValue> Autotext item is shown, representing “Project Zero” as the 

dimension origin.

In the Custom Text field, enter any custom text before and/or after the Autotext (or in place of it). 

You can add multiple lines of custom text, separated by the Enter key.
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Such line breaks are shown in the Info Box with the Paragraph sign.

Regardless of any additional custom text that you may have added, the Autotext remains associative - that is, 

if you edit the dimension line, the Measured Value will be adjusted accordingly.

Insert Autotext as Dimension Text

From the pop-up field to the right, you can choose from additional Autotexts to add to the Dimension text field. 

The contents of this list depend on the type of dimension (e.g. Linear or Elevation dimension):

Autotext means that the Dimension text will display the current value of the chosen Autotext reference: for 

example, if you have defined a reference level called Sea Level, you can choose to Sea Level here as the 

Autotext, and Dimension Text will display the elevation dimension to that level.

If you choose a text in quotation marks (e.g. “1st Reference Level”), this text itself will be displayed, not its 

value.

Note: To define your project’s reference levels, use Options > Project Preferences > Reference Levels.

See Reference Levels Preferences.

Add Superscript to Dimension Text

Use the Start/Finish Superscript Autotext if you want the Custom text to include superscript text; click this 

option to insert a caret before the superscript text, and click it again (or insert a line break) to finish the 

superscript with a second caret.
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Note: If your dimension’s Measured Value already includes a superscript - because you are using Extra 

Accuracy defined in Options > Project Preferences > Dimensions - then add a space before inserting 

the Start Superscript caret. Otherwise, the caret itself will appear in the dimension text.

The Displayed Value field shows you what the dimension text will look like on screen.

Related Topics:

Text Style Panel

Pointer Line
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Convert Dimensions Dialog Box (Add-On)

Use Document > Annotation > Secondary Dimensions > Convert Dimensions to open this dialog box.

For general information, see Secondary Dimensions (Add-On).

Convert Dimensions

Convert to: Choose the desired dimension unit from the list.

Depending on the chosen unit, additional display options for the dimension unit appear below. Choose the 

desired display option.

Decimals: Enter the number of decimal places to include in each dimension.

Hide Zero Wholes: Check this box to suppress whole zero values:

Example: 

• 0.25 meters is displayed as 25

• 25 meters is displayed as 25.00

Hide Zero Decimals: Check this box to hide any zeros at the end of the decimal dimension, regardless of the 

number of decimal places you set in the Decimals popup above.

You cannot use the Hide Zero Decimals options concurrently with Hide Zero Wholes.

Display of Zero Feet & Inches: This section has four pairs of radio buttons. For each pair, choose the option 

you prefer for displaying dimensions that measure either zero feet or zero inches.
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Text Tool Settings

The Text tool offers multiline texts, full-scale font options, multiple styles and justification in any direction.

For details, see Text Blocks.

Text Block Formatting Panel

Settings in this panel define the overall appearance of the Text Block as a whole.

Anchor Point

Click one of the nine buttons in the Anchor Point icon: this point represents the part of the text block that will 

be anchored when you click to position the text block. The Anchor Point will remain fixed even if you change 

the size of the text block (for example, by editing font sizes). A Text Block with a non-fixed angle will rotate 

along with the oriented view; in this case, the Text Block will rotate around the Anchor Point you set here.

Rotation Angle

Enter a rotation angle for the text. Use the pop-up to define how this angle value should be interpreted when 

the element is placed: 

•  Relative to Orientation (the angle will be measured relative to the Oriented View) - think of it as relative 

to your screen.

See also Set Orientation.

•  Absolute to Coordinate System (the angle will be measured from the (0,0) point of the project 

coordinates). This means the angle value will not change, regardless of how you change the oriented 

view.

• Fixed Angle (Text Block): Keep the Text Block Angle fixed relative to the screen, even if you rotate the 

view.

 Always Readable

ARCHICAD will automatically “flip” the text to make it legible on screen (as opposed to upside down) 

regardless of the view’s orientation. This automatic “flip” occurs if the text is at an angle between 90 and 270 

degrees.

Wrap Text

This checkbox “locks” the width of a placed text (including non-breaking text blocks) and wraps to the next 

line.

Opaque

Check this box if you want a background color that differs from the screen’s background color. Open the pop-

up palette to choose a color.

Note: You can override the Fill Background Color via Graphic Override Rules (Document > Graphic 

Overrides).

See also Graphic Override Rules.

Frame

Display your text or label with or without a frame.

If desired, offset the Frame from the text by entering an offset value in the field at right.
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Related Topics

Text Style Panel

Model Size vs. Paper Size Elements

Working in Tool Settings Dialog Boxes
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Text Style Panel

Available, with some variations, in the following Tool Settings dialog boxes:

• Section, Elevation, Interior Elevation (Marker Text Style, Story Levels Text Style)

• Detail, Worksheet, Change (Marker Text Style)

• Label, Dimension, Dimension Text

• Drawing (Title Text Style)

• Door/Window (Marker Text Style)

• Zone (Stamp Text Style)

• Grid

Text Style Panel Controls

Font and Font Size

Enter the font height, in mm (metric units) or points (imperial units).

• The unit depends on the Length Unit defined in Options > Project Preferences > Working Units.

• The number of decimals depends on the setting under “Numbers without Units”, also at Options > 

Project Preferences > Working Units.

Encoding (Windows only)

Choose a regional font encoding. 

Note: Text elements in ARCHICAD are unicode-based. All encoding systems are supported when you 

print, plot, edit or display text items, or convert them to DXF/DWG format. 

For each language version of ARCHICAD, the default font encoding system is generally the right one.

Text Pencolor

Choose a pencolor with the numeric field or the pop-up control. 

Font Style

Select bold, italic, underline, strikethrough.

Alignment

Left, center, right, or justify.

Leading

Modifies the leading value (vertical line spacing) as a percentage. Enter a number or use the arrows to 

change the value in increments of 25 percent.
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Width

Text character width as a percentage.

Spacing

Modify the spacing between text characters.

Override Text Style

Format settings in the Text Style Panel are uniformly applied to all text in the relevant Marker or textual item.

However, in most of these Settings dialog boxes, you can override particular Text Style settings for specific 

items.

Override Text Style

Text Style Controls in Grey

Some controls of the Text Style panel may not be relevant for a particular text item. These will be shown in 

grey. For example, the Leading and Alignment controls for this Drawing Title:

Irrelevant Text Style Controls in Grey
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Controls might also be grey if you have overridden them, as with the font style, pen and size in this Section 

Marker text:

More Text Style Controls (Dimension, Label)

 Always Readable

ARCHICAD will automatically “flip” the text to make it legible on screen (as opposed to upside down) 

regardless of the view’s orientation. This automatic “flip” occurs if the text is at an angle between 90 and 270 

degrees.

Opaque

Check this box if you want a background color that differs from the screen’s background color. Open the pop-

up palette to choose a color.

Note: You can override the Fill Background Color via Graphic Override Rules (Document > Graphic 

Overrides).

See also Graphic Override Rules.

Frame

Display your text or label with or without a frame.

If desired, offset the Frame from the text by entering an offset value in the field at right.

Wrap Text

This checkbox “locks” the width of a placed text (including non-breaking text blocks) and wraps to the next 

line.

Rotation Angle

Enter a rotation angle for the text. Use the pop-up to define how this angle value should be interpreted when 

the element is placed: 

•  Relative to Orientation (the angle will be measured relative to the Oriented View);

See also Set Orientation.
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•  Absolute to Coordinate System (the angle will be measured from the (0,0) point of the project 

coordinates).

Revert to Automatic Position (Dimension Text)

Check this to reset the position of a selected Dimension Text.

To undo the position changes of all modified dimension text items, go to Document > Annotation and click 

the Revert All Dimension Text to Automatic Position command.

See also Dimension Text Settings.
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Label Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

See also Labels.

Double-click the Label tool in the Toolbox.

Label Type and Preview Panel

The Type and Preview panel defines the labeling options for elements, and displays a preview.

Load another Label: Click the icon in the lower right corner, and browse for a Label-type object. 

Text Style Panel

Pointer Line

Symbol Label Panel

(Not active for Text/Autotext Label).

Define Label dimensions.

Enter the Label’s orientation. Available options depend on the particular Symbol Label.

See also Label Orientation, below.

Use Text Pen as Uniform Pen: Check this box to use the Text pen (set in the Text Style panel) pencolor for 

all parts of the marker symbol, regardless of any custom colors set elsewhere for this marker.
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Label Custom Settings Panel

Use Custom Settings to set up the content and geometry of the Label. 

For tips on the various controls for Symbol labels, see: Custom Settings for Symbol Labels.

Text Label Panel

Available only if you have chosen Text Label on the Type and Preview panel.

See also Text/Autotext Label Content.

Note: Favorites of the Text tool can be applied to the text-type items in Dimensions and Labels, and to Fill 

Text.

Label Orientation 

• The Parallel method always places the Labels parallel to the labeled elements.

• The Perpendicular method places the Labels perpendicular to the labeled elements.

• The Vertical method always places the Labels vertically. The text is read from bottom to top.

• The Horizontal method always places the Labels horizontally.

• The Custom method places the Labels at the angle you define in the edit field next to it.

Use the pop-up to define how this angle value should be interpreted when the element is placed: 

– Relative to Orientation (the angle will be measured relative to the Oriented View)

– Absolute to Coordinate System (the angle will be measured from the (0,0) point of the project 

coordinates).

For more information, see Set Orientation.

Fixed Angle (For Text Label with Custom Angle)

Check this to fix the angle regardless of subsequent rotation of the element.

Optimize Position: Reposition the Label’s arrow if it ends up in an awkward position after the Label is 

moved or if the view is rotated.
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Not optimized Label, after rotation:

Optimized Label, after rotation:

Hide with Associated Element

By default, a Label will be hidden if its associated element is hidden (e.g. on a hidden layer). To display 
the Label regardless of whether its associated element is visible, uncheck this box.
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Drawing Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

Drawing Identification Panel

Drawing ID

Assign an ID to the placed drawing.

Note: For a Drawing placed in a model view, this field is empty.

• By Layout: Drawing ID depends on the Layout Settings of the Layout on which the Drawing is placed. In 

Layout Settings, consult the “IDs of Drawings on this Layout” tab page.

• By View ID: The Drawing ID will be equivalent to the ID of its source View, if any.

• Custom: Enter a custom Drawing ID in the text field to the right.

Include Drawing in ID sequence: Check this box to include your drawing in the ID sequence, even if it is a 

custom ID.

Drawing Name

If the Drawing source is an ARCHICAD view:

• By View: Name only

• By View: ID + Name

• Custom

If the Drawing source is an external file:

• Custom

• By source file. Read-only field. Click the folder icon to display the file path as absolute or relative.

• ARCHICAD view: Displays the view’s path if the Drawing source is an ARCHICAD view.

• Page No.: Appears if the Drawing source is a multi-page document (e.g. a PDF file).

Update Type

• Auto: Drawing will be updated automatically when the layout is activated. If a drawing comes from a 

different source than the currently opened project file, then ARCHICAD will check whether it requires 

updating or not.
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• Manual: The Drawing is frozen in the state its source view or file was in when placed on the layout. This 

can be useful if you wish to keep the drawings untouched until they are approved or you are ready to 

move on to the next stage in your work.

• Store Drawing in the Project File: Checked automatically for Manual-update Drawings.

If it is not checked, then an external Drawing’s source files must be available if you open the project in a 

different location.

Drawing Size and Appearance Panel

The first four fields - Width, Height, Magnification, and Drawing Scale - are interrelated (as indicated by the 

lock icon). A change in any of the fields will result in corresponding changes in the other three fields, so that 

the drawing’s proportions remain fixed. Use these fields to set the size of the placed Drawing in either 

measurement units or as a percent of its original size (the Magnification).

Fit to Layout

Use this option from the Magnification pop-up.

Fit to Grid Cell

Available if the Layout contains a Grid.

Drawing Scale

To rescale the Drawing on the Layout (instead of using the original scale of the source view), choose a 

predefined scale factor from the Drawing Scale pop-up, or enter any other custom scale. (The Width/Height/

Magnification values will change to reflect the new Drawing scale.)

Note: If your source drawing size, as defined in Master Layout Settings, is larger than the paper size you 

choose here, ARCHICAD will automatically resize the drawing’s output size to make it fit on the page.

Note: For Drawings placed on Model Views, and for placed Images and PDF documents, no scale is 

shown. Instead, the drawing’s Resolution (in dpi) is indicated.

Customizing the Drawing scale has no effect on the scale of objects within the drawing; it is equivalent to a 

graphical resizing of the Drawing, like the effect of magnifying a document with a copy machine.

Your customized Drawing Scale is distinct from its Original Scale. Separate Autotext entries and Title 

parameters are available for Drawing Scale and Original Scale: if you place an Autotext for “Drawing Scale” 

on a Layout or Master Layout, the Drawing Scales of every Drawing on that Layout are displayed.

See Autotext.

Original Scale: Scale of the drawing’s source view.
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Include Scale in Autotexting and Indexes: Drawing scale can be included on your output via Autotext (e.g. 

in an Index or on a Layout). However, for some Drawings, the resulting scale value may be misleading - for 

example, if the Drawing is placed as part of a PDF file. Since ARCHICAD cannot interpret the content of the 

PDF, there is no point in displaying a Drawing scale in this case. Uncheck this box for such Drawings.

Anchor Point: The point by which the drawing is placed onto the layout. Serves as the drawing’s fixed point 

in case its elements are modified in its source view.

Define the Drawing’s anchor point:

• Use Drawing’s internal origin as anchor: Check this box to use the Drawing’s origin as an anchor point 

after placing it.

• Anchor Point: Click one of the nine points to use as an anchor point.

Angle: Enter a rotation angle in degrees for the Drawing position, if desired.

For Drawings placed on the Floor Plan, Detail, Worksheet, or in a 3D Document, the Angle field includes an 

additional popup: 

• Relative to Orientation (the angle will be measured relative to the Oriented View)

• Absolute to Coordinate System (the angle will be measured from the (0,0) point of the project 

coordinates).

For more information, see Set Orientation.

Pen Set

• By View: Use the pen set assigned to the Drawing’s source view.

• By Source File: This is the default if the drawing source is an external vectorial file.

Use the Pen Set drop-down to choose a different pen set.
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View Drawing’s own Pen Set

Click to view and edit the Drawing’s Pen Set.

Then Add to Project’s Pen Sets. In the appearing dialog:

• Store Drawing’s Pen Set: Enter a name and store it among the project’s pen sets.

• Overwrite following Pen Set: Choose a Pen Set to overwrite and replace it.

Colors

By default, the Drawing will display the colors as defined in the pen set you have chosen. 

Optionally: use Grayscale or Black & White instead, for this drawing only.

Note: When printing a layout, you have the option to choose black and white output regardless of the 

color setting in Drawing Settings: activate Black and White checkbox in Print Layout Settings.

See Print Layout.

Transparent Background: Check this box to ensure that the Drawing is displayed with a transparent 

background.
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Embedded Layers

This control is active if the source of the selected Drawing is a DWG, DXF, DWF or PDF file.

Click Drawing’s own Layers to bring up a list of the Drawing’s own (embedded) layers. For any layer you 

wish to hide, click the “eye” icon to close it.

You can sort this list by either Layer name or by show/hide status.

Once you click OK to close Drawing Settings, any change you made in the Embedded Layers’ show/hide 

status will be carried out in ARCHICAD; no drawing update is necessary.

If you do modify the Drawing source and then update the Drawing in ARCHICAD:

• any new layers created in the source file will be displayed in the ARCHICAD Drawing

• any layers deleted or hidden from the source file will be deleted from the ARCHICAD Drawing

Should you explode this Drawing, then only the elements on currently visible layers of the Drawing will be 

placed into the ARCHICAD project.
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Hide Drawing’s Embedded Layer from Layout

A quick way to hide the embedded layer of a Drawing component is from its context menu on the Layout itself.

First, ascertain the name of the embedded layer: zoom in to the Drawing, use the cursor to identify a point or 

line in the Drawing, and view the Info Tag to see the name of the embedded layer for that part of the Drawing:

Now, with the cursor at the selected drawing item (e.g. the contour of the wall element), bring up the context 

menu: in the Layers sub-menu, the Hide Embedded Layer command appears. Click this command to hide 

the embedded layer.

Note: If there are multiple elements at the cursor location, the embedded layer of the topmost item will be 

hidden.

On-Screen Preview

Choose a format for the on-screen display of this Drawing on the Layout. 

With large Layout Books, your choice here can affect navigation speed significantly:

• Full Precision (drawing shown with full details, always rebuilt)

• Quick Preview (faster navigation; Drawing rebuilt only upon explicit Rebuild of the Layout, or when a 

Drawing update occurs)

• No Preview (fastest navigation)

If you choose Quick Preview, the text “Quick Preview” will be displayed. The drawing content is an accurate 

vectorial preview, but you may lose certain details: certain dashed lines and fills will be shown as solid.

If you choose No Preview, the Drawing frame will be shown with the text “No Preview” in place of the Drawing 

content. (You may prefer this option to reduce redraw time if you are working on a Layout with multiple 

drawings, and you do not need to see this Drawing’s content as you work.).

This preview display option is an on-screen effect only and does not affect output.
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Drawing Frame Panel

Select any edge of the drawing and use the usual pet palette editing commands to modify the frame into any 

shape. In this case, the Manually resized frame button is activated.

To reset the frame to fit the drawing, click Fit Frame to Drawing.

By default, Crop Drawing to Frame is also checked: as you resize the Frame, the Drawing content is 

cropped accordingly. (Cropping takes place after you deselect the edited Drawing.) Cropping the Drawing 

content reduces file size and can speed up Drawing update.

For further information on Frame and cropping, see Drawing Frame.

Split Drawing among Multiple Layouts: This checkbox is active and applicable only if the selected Drawing 

is created from a Schedule or Index view. If this box is checked, such Drawings will be split into multiple 

Layouts, if the contents cannot be fit onto a single Layout page.

See Split Schedule into Multiple Layouts.

Add Printable Border: Check this box to add a printable border for your drawing. Use the controls below to 

choose a line type and pen color for this border.

Border Offset: Enter an offset value for the printable border.

Title Panel

See also Drawing Titles.

Note: Drawing Titles can be applied only to Drawings which are placed on Layouts. Drawings in Model 

Views do not have Drawing Titles.

Choose a predefined drawing title type from the pop-up list.

Note: You can also create a custom Title Type.

See Create a New Title Type.

Define Title size and pencolor.

Uniform Title Pen: Check this box to use this pencolor for all parts of the Drawing Title, regardless of any 

custom colors set elsewhere for this Title.

Flip Title: Check this box to flip (mirror) the title graphically.

Title’s Preview Area: The window at right shows a symbolic preview of the Title in one of two formats. Click 

one of the two buttons to display a preview:

• Show Preview of the Title’s position to the Drawing: Click the upper button (Layout icon) to display a 

preview of the Title’s position relative to the Drawing.

• Show Preview of the Title: Click the lower icon (with a T) to display a preview of the Title only.

Back Reference: Click this button to access the Back Reference dialog box. If the current drawing is based 

on a source marker, then this dialog box will list any Layout whose Drawing displays the source marker of the 

current drawing.

See Back Reference to Layout Containing Source Marker.
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Title Text Style Panel

See Text Style Panel.

Drawing Title Panel (Custom Settings)

Use these controls to fine-tune the GDL parameters of the selected Drawing Title, as applicable.
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Fill Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For details, see Fills.

If You Are Editing the Fill Component of a Profile

If you are editing a selected fill component of a Profile attribute, the only available controls are Fill outline on/

off, cut line type and color, and Fill type selection (the available Fills here represent Building Materials for the 

profile you are editing).

See Profile Manager.

Fill General Settings Panel

This panel controls the appearance of the Fill in the Floor Plan. These Fill settings will also be used if you 

draw a Fill in a Section/Elevation/IE or Detail/Worksheet window.

Fill Outline

• Click to define a Fill outline.

• Choose its Line Type and color.

Fill Type

• Choose the fill type that will be used to display the Fill.
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The Fills available here are all simple Fills (composite structures are not available); and all are defined as 

Drafting fills. (set in Options > Element Attributes > Fills).

• Choose foreground and background pen colors.

For the fill background, you can also choose the transparent option or the Window Background color 

(located at the end of the Pen Color palette).

Note: You can override the Fill Background Color via Graphic Override Rules (Document > Graphic 

Overrides).

See also Graphic Override Rules.

Fill Category

Click the button to the left of the Fill pattern pop-up to choose a Fill Category for this Fill. 

For more information, see Fill Categories.
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Construction Method

Set the orientation of the fill’s vectorial hatching (if any) or symbol fill pattern.

Note: Vectorial hatching is displayed only if you have switched to in View > On-Screen View Options > 

Vectorial Hatching.

•  Project Origin: the pattern will always start at the Origin.

•  Fill Origin: Use the fill handle icon to define the fill orientation vector. Then click to place the vectorial fill.

• Custom Distortion: Use the two fill handles to achieve a “distorted” effect to simulate the real geometric 

situation of the fill components.

For examples of each option, see Fill Orientation Methods.

• Radial Distortion: Graphically adjust the vector’s radial distortion. Available only for a selected symbol 

Fill and only if:

– the symbol fill was used as a skin of a composite structure; and

– the skin’s Fill Orientation was defined as Fit to Skin in the Composite Structures dialog box; and

– you have selected this symbol fill after exploding a curved composite wall.

See Radial Distortion (Symbol Fills only).

Note: The use of many radial distorted fills in your project may decrease project performance.

Show Area Text

The Show Area Text checkbox allows you to show an associative area text with the Fill. If this box is checked, 

you will place (as part of the fill drafting process) a dimension-text element displaying the Fill’s area on the 

plan.

Note: The format of Area Text and any associated Pointer line is defined in the Dimension Text Settings 

dialog box. 

See Dimension Text Settings.

Subtract from Zones

Check the Subtract from Zones checkbox to subtract default or selected Fill elements from the Zones.

Type a number (1-100) in the percentage field to define the percentage of the Fill element’s area that you 

want to subtract from the Zones in percentage.

Fill Properties Panel

ID: Type an ID in this box for tracking this element in Quantity Calculations.

The ID field serves to identify and group elements in list views. Any character can be used.
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If a number is included anywhere in the ID, ARCHICAD will add one to this number for each new element 

drawn, provided that the Assign New Element ID to Each New Element checkbox is enabled in the Options 

> Work Environment > More Options dialog box. Each new element will have a unique ID.

If elements are duplicated or multiplied, the IDs of the replicas will remain the same as those of the originals.

If you paste elements into a Project, you may have elements with conflicting IDs. ARCHICAD does not 

automatically exclude ID conflicts. It is up to the user to designate different IDs for elements that may be in 

conflict.

IDs can be customized both before creating elements and after selecting a number of existing ones, by using 

Document > Listing Extras > Element ID Manager.

For more information, see Element ID Manager.

Note: All construction elements also have a globally unique, automatically generated ID which is 

conserved throughout the life of the Project. You can use this identifier for labeling or in lists.
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Line Tool Settings

Lines are the simplest drafting element in ARCHICAD.

For general information on using lines, see Lines.

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Uniform Settings for Line Tools checkbox allows you to apply the settings made in this dialog box to all 

line-type tools: Line, Arc/Circle, Spline, Polyline.

Favorites of any of the four Line-type tools (Line, Arc, Polyline, Spline) can be applied to any of the other 

Line-type elements.

Line General Settings Panel

The General Settings panel is similar to those of the Line, Arc/Circle, Polyline and Spline tools.

Select a Line type from the pop-up selection palette.

Type a Pen number (1-255) for the Line/Arc/Polyline/Spline.

Click the color for a Pencolor selection palette for the Line/Arc/Polyline/Spline.

Check the Zone Boundary box to allow lines to delimit Zones when using the automatic recognition methods 

of the Zone tool.

See Automatic Recognition Zone Construction.

Use the Arrowhead icons to choose a Line with no arrowheads, or a Line with an arrowhead at start, at end 

or at both ends.

Enter a height value for the Arrowhead marker.

Type a Pen number (1-255) for the Arrowhead marker.

Click for a Pencolor selection palette for the Arrowhead marker.

Click the Arrowhead pop-up icon for selection of marker types.

The last arrowhead type is special, as it doubles the line with arrows at both ends. Using a line like this, the 

cursor will snap to the invisible axis line between the two visible lines.

• If you begin to draft an open element with Arrowheads and decide to close it either while drafting or later, 

the Arrowheads will simply disappear.

• If you later convert a closed element to an open one, for example a Circle to an Arc, you can select it, 

open the settings dialog box and add Arrowheads to it.

Line Properties Panel

The Line Properties panel is identical for the Line, Arc/Circle, Polyline and Spline tools.

Line Category: Assign a category to a selected line. You can then use line categories to fine-tune display 

options and export settings for lines depending on their category.

ARCHICAD has three line categories:

• Drafting line: Simple 2D drafting line. Lines drawn with the Line tool will be in this category by default.

• Cut line: Contour line of a 3D element on a cutting plane.
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Note: You can choose to display Cut lines in boldface: In View > On-Screen View Options enable the 

Bold Cut Lines option.

• Skin Separator Line: Separator line between skins of composite structures, including walls, columns, 

slabs and roofs.

Line categories can be useful if, for example, you have exploded a composite wall into its constituent lines 

and fills. By default, in the Line Tool’s Properties Panel, all the contour lines are put into the “Cut line” 

category, while all the skin separator lines are put into the “Skin Separator” category.

All other lines are placed into the Drafting category by default. However, if you draw lines by hand into a 

Detail/Worksheet, Patch, or Section/Elevation/IE Window, you can assign categories to these lines according 

to their function in the plan. This way, when assigning a display option, even hand-drawn lines can be 

considered Cut lines or Skin Separator lines.

Assigning line categories can also be useful if you save your file in DXF/DWG format: the Translation Setup 

dialog box allows you to define a separate layer onto which Skin Separator lines can be exported.
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Arc/Circle Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Arc/Circle tool is used to draw any circular or elliptic element needed in your design.

For more information, see Drawing Arcs and Full Circles.

The Geometry methods are: 

• Centerpoint, Three Points, Tangent Point for circles,

• Diagonal, Semi-Diagonal and Ellipse Radii for ellipses.

Arc/Circle General Settings Panel

The General Settings panel is similar to those of the Line, Arc/Circle, Polyline and Spline tools.

See description at Line General Settings Panel.

For Arc/Circles only:

• Circles and Ellipses are closed elements with no starting point or endpoint to receive an Arrowhead, and 

therefore do not support them.

Arc/Circle Properties Panel

See description at Line Properties Panel.
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Polyline Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Polyline tool creates a single element by drawing a series of segments.

Geometry methods are: Polyline, Rectangle and Rotated Rectangle.

For more information on Polylines, see Drawing Polylines and Chained Lines.

Polyline General Settings Panel

The General Settings panel is similar to those of the Line, Arc/Circle, Polyline and Spline tools.

See description at Line General Settings Panel.

For polylines only: Choose a preference for handling the pattern of a dashed line type.

See Dashed Polylines: by Segment or Continuous

Polyline Properties Panel

See description at Line Properties Panel.
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Section and Elevation Settings

The following settings work essentially the same way for the Section and Elevation tools. 

For information on creating Sections and Elevations, see:

Sections

Elevations

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

General Panel

Reference ID: An ID is assigned by default; you can change it by typing any other value into the field. This 

field can contain up to 256 characters; the ID will serves to identify the Section/Elevation in the project window 

and in the Navigator.

The Name field can contain up to 256 characters. This name appears in the Navigator palette and the title bar 

of the Section/Elevation window.

Note: If you place a Linked or Independent marker that does not generate a viewpoint, the ID/Name fields 

are gray.

To Place a New Section/Elevation Marker (Default Settings)

Use the next pop-ups to define what you want to create with the Section/Elevation tool:

If you choose Create New Viewpoint:

its Marker Reference can contain either

• the viewpoint, identifying it by its location in the Navigator Project Map;

or

• the first placed drawing of the viewpoint, identifying it by its location in the Layout Book hierarchy

If you choose Place Linked Marker:

its Marker Reference can contain information from of any of the following:

• a selected viewpoint

• a selected drawing
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• the first placed drawing of the selected viewpoint

• the first placed drawing of the selected view

If you choose Place Unlinked Marker:

the Marker Reference will not contain any linked information; you can define a custom text (First Text Row/

Second Text Row parameters) in the Marker Panel below.

Reference to: shows the path (location in the Navigator hierarchy) of the chosen reference item.

To Redefine a Placed Section/Elevation Marker (with Marker selected):

The pop-up fields give you feedback on the current status of the selected Marker (either Source Marker, 

Linked Marker, or Unlinked Marker).

Use the pop-ups to change the status as needed.

To redefine the Marker Reference: Choose from among the pop-up choices, or click the Browse button to 

select the viewpoint/view/drawing whose Navigator path you wish to display in the Marker. The available 

choices vary depending on the Marker status (Source Marker, Linked Marker or Unlinked Marker).

For an Unlinked Marker, you can define a custom text (First Text Row/Second Text Row parameters) in the 

Marker Panel below.

Status (for Source markers only)

Choose an option to define the status of the link between the Section/Elevation and the Floor Plan.

• Auto-rebuild Model: This view will be automatically rebuilt every time it is activated if the Floor Plan has 

changed.

• Manual-rebuild Model: This view is not rebuilt automatically. It can be rebuilt from the model only by 

using the View > Refresh > Rebuild from Model command.

• Drawing: Elements are exploded into 2D drawing elements, which are not linked to the Floor Plan and will 

not be automatically rebuilt from the model. You can, however, update the drawing to reflect recent changes 

made to the model.

Show on Stories (for Source markers only)

Choose the stories on which to display the marker and lines.

• If the Vertical Range is Infinite: choose All stories or a particular custom story (choose the story shown in 

the pop-up list, or choose Browse Story)

• If the Vertical Range is Limited, two additional options are active.

Entirely in Range: The marker and line will appear on all stories that are entirely in the vertical range 

defined in the height value fields.

At Least Partly in Range: The marker and line will appear on all stories that are at least partly included in 

the vertical range defined in the height value fields.

Horizontal Range (for Source markers only)

The horizontal range defines the depth of model that will be included in the Section/Elevation window: 

• Infinite: All elements behind the Line will be shown in the Section/Elevation window, provided that they 

are not hidden by other elements.

• Limited: Only the elements between the Line and the limit line will be shown in the Section/Elevation 

window. (The limit line is defined when you click with the Eyeball cursor after you finish drawing the 

Section/Elevation line.)
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Note: The limit line is a display-only Marker item, and is not shown on the Layout.

See Display of Marker Range Lines.

• Zero Depth: Only elements actually cut by the Section Line will be shown. (Not available for Elevations.)

Vertical Range (for Source markers only)

Define the vertical range of the Floor Plan to include in the Section/Elevation window.

• Infinite: Include the entire height of the project.

• Limited: Include a limited vertical range. Enter elevation values for the upper and lower limits of the range. 

(Click the black arrow to choose the reference for the elevation values: to Project Zero, or to a particular 

custom story.)

Marker Panel

Section Line Settings (Section only)

• Select a Line Type and Penweight/Pencolors for the Section Line and ID.

Note: The Section Depth (limit) line (for a Section of Limited Horizontal range) is an on-screen-only 

Marker Range item, whose line type and color are set in Options > Work Environment > On-Screen 

Options.
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• Choose Continuous or Segmented.

– Segmented: Use the checkboxes at right to define which segments to display:

- first segment

- internal segments at breaks

- last segment

- Length: of each segment

Marker Head and Type

Place the Marker Head in the Middle or at the Ends of the marker.

Enable or disable the Markers at either or both ends of the Section/Elevation Line.

Select Marker Type: The chosen marker’s 2D Symbol appears in the preview window.

Define Marker size and pencolor.

Uniform Marker Pen: Check this box to use this pencolor for all parts of the marker symbol, regardless of 

any custom colors set elsewhere for this marker.

Marker Text Style Panel

See Text Style Panel.

Marker Symbol and Text Panel

Use the settings pages to customize the appearance and content of the marker chosen in the Marker Panel 

above.
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For Marker Geometry and Style, options vary depending on the Markers loaded in your library.

Refer to the preview window of the Marker Panel to see how your choices affect the Marker.

Model Display Panel

Available for Source-type Sections and Elevations.

Use these controls to define how to display the contents of the Section Viewpoint.

CUT ELEMENTS

Fill Cut Surfaces with: This control gives you four options for displaying the surfaces of cut elements in the 

Section:

1. Cut Fills - as in Settings: Cut surfaces will use the cut fills of the Building Materials assigned to the 

individual elements.

In this case, an additional option is available:

Uniform Pen for Cut Elements: Check this box to use the same pens to display all the cut elements. (If 

you don’t check this box, the cut elements will use the pen settings of the individual elements).

Then define the pen using the following controls:

• Cut Line Pen

• Cut Fill Pen

• Cut Fill Background Pen

2. Uniform Surface: Use a single surface for all cut surfaces in this Section/Elevation.

• Choose this uniform surface using the fill pop-up of the Cut Surface parameter

3. Own Surface Colors (Non-Shaded): All cut surfaces will be shown using the surface assigned to the 

individual elements through their Building Material.

4. Own Surface Colors (Shaded): Same as above. The display colors will reflect shading effects.

UNCUT ELEMENTS 

Choose attributes for uncut elements.
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Note: Applying a fill means that you will be able to quick-select these surfaces in the Section/Elevation 

window. However, using the Fill Uncut Surface option may increase rebuild time for large models. If this is 

a problem, choose “Nothing”.

Fill Uncut Surfaces with:

1. Uniform Pencolor: Choose a pencolor to apply to the fills of all uncut surfaces in this view, and a Uniform 

Pen for Uncut Contours.

The next two options will display Surface colors on uncut parts of the Section/Elevation:

2. Own Surface Colors (Shaded): Choose this option to display uncut fills using the elements’ own surface 

colors as defined in the Building Material. The display colors will reflect shading effects.

3. Own Surface Colors (Non-Shaded): Same as above, but the display colors will not reflect any shading 

effects; each surface color will be uniform over the whole surface.

4. Nothing (no color applied to uncut surfaces)

Uniform Pen for Uncut Contours: Check this box if you want to display the contours of fills on uncut 

surfaces. If you check it, the Uncut Contours Pen color chooser appears; choose a pencolor.

Vectorial 3D Hatching: Check this box to activate vectorial 3D hatch patterns.

Transparency: Check this box to give see-through surfaces (e.g. glass) a transparent effect .

SUN AND SHADOWS

Viewpoint Sun Settings: Choose one of two sun positions relative to the Section/Elevation Line:

• As in 3D Window: Use this option to inherit the sun position set up in the 3D Projection or 3D Perspective 

Settings dialog box.

See also 3D Window.

• Custom: Use the Sun Azimuth/Sun Altitude controls below to define a custom sun position for this 

Section/Elevation.

Note: These custom values will apply to this Section/Elevation only and are calculated differently from the 

values set in the 3D Projection/Perspective Settings dialog box.

The Azimuth value is an angle value in degrees. The line that is at a right angle to the Section/Elevation 

line represents zero degrees. As I increase the azimuth by increasing this angle value, the sun moves 

toward the right - meaning the shadows start to lengthen to the left of the shadow-casting surfaces.

If you do not want the visible side of the building to be overshadowed, you should use an Azimuth value 

between -90 and +90 degrees.
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Sun Shadow: Check this box to activate Sun Shadows. Controls defining the Sun Shadow become 

accessible.

Shadows work independently of vectorial 3D Hatching patterns.

Shadow Polygons: This control is available if you have activated the Sun Shadow checkbox. In Section/

Elevation views, shadows have no contours; however, the fill polygons are freely customizable. Choose the 

Fill type, Fill pen and Fill background pen using the corresponding pop-up palettes.

Note: You cannot choose a custom fill for the shadow if your uncut surface fills are set to use “Own 

Surface Colors - Shaded”.

MARKED DISTANT AREA

Check this box to divide the view displayed in the Section/Elevation Window into a “closer” and “farther” area.

If you check the box, use the appearing controls to define a unique set of colors, fills and effects for the Distant 

Area to indicate that they are at a longer distance from the Section/Elevation Line.

Note: You can set separate Sun Shadow Polygons for the Marked Distant Area. (The Sun’s Azimuth and 

Altitude settings are the same as those set up in the Sun and Shadows panel.) When choosing the “Fill 

Uncut Surfaces with” option for the Marked Distant Area, your available choices might be limited 

depending on what you chose above in the Uncut Elements control: if you set the Uncut Elements to “Own 

Surface Colors - Shaded”, then the non-Shaded option is not available for the Distant Area, either.

The limit where “close” ends and “distant” begins depends on how you created the Section/Elevation.

• For a view with an Infinite horizontal range, the secondary “distant” line is displayed at the place where 

you clicked with the Eyeball cursor when defining the Section/Elevation line and orientation.

• For a view with Limited horizontal range, the secondary “distant” line will be placed by default halfway 

between the Section/Elevation line and the limit line

(Zero Depth sections cannot include a distant area.)

The secondary “distant” line, like the limit line, is an on-screen-only element. You can change its line type/

color in Options > Work Environment > On-Screen Options.

ELEMENT CONTOURS AT SECTION/ELEVATION BOUNDARY

See also Element Contours at Section Boundary for an illustration of this feature.
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Add Element Contours: Choose one of these options to display, override or hide the contours of elements at 

the boundary.

• None: Element contours at the boundary are hidden.

• Own Contours: Element contours are displayed using the Uncut pen chosen for these elements in their 

own Settings dialog boxes.

• Override Contours: Choose a custom Line Type and Pen with which to display the Boundary Contours.

Story Levels Panel

Define the display of Story Level lines and Story Handle Markers in this view.

Show Story Levels

• Display only: Story lines will appear only on-screen, but will not be displayed in the output.

• Display and Output.

• None

For more information, see Story Level Lines.

Choose a line type and pencolor for the story level lines.
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Display Markers & Story Level Lines

• Display the left and/or right Story Markers

• Display or hide the Story Level Line

Note: You cannot uncheck this box if the Offset values of the Story Handle Markers are both set to zero.

Use the Design > Edit Story Levels command to adjust story levels in this Section/Elevation window.

Offset to Boundary: Enter a value for the offset of the Story Level line beyond the limits of the Section/

Elevation.

Select Marker Type: The chosen marker’s 2D Symbol appears in the preview window.

Define Marker size and pencolor.

Uniform Marker Pen: Check this box to use this pencolor for all parts of the marker symbol, regardless of 

any custom colors set elsewhere for this marker.

Story Levels Text Style Panel

See Text Style Panel.

Story Levels Symbol and Text Settings Panel

Use these controls to set the display of the Story Level Marker (selected in the Story Levels Panel).

Grid Tool Panel

Define the display of Grid elements on the Section/Elevation.

Show Grid Elements: Check this to see the Grid Elements.

To narrow the displayed Grid elements:

• Show Grid Elements by Stories: Click Selected to narrow the set of displayed Grid elements by Story: 

click Select stories to choose the stories whose Grid elements you want to display. (If a Grid element is 

visible on the selected stories, then it will be visible on this Section/Elevation as well.)

• Show Grid Elements by Name: Click Selected to narrow the set of displayed Grid elements by Name: 

click Select elements to select individual elements.

Note: These two filtering criteria are related as an “AND” statement: if you set filters both by Story and by 

Name, then the Section/Elevation will display only those Grid elements which fit the both the Story criteria 

AND the Name criteria.

Dimension lines: Place a dimension between each grid line. Enter the vertical location of this dimension 

chain and set the reference level.
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Total Dimension: Place a dimension line between the two grid lines on the far left and far right end of this 

Section/Elevation. Enter the vertical location of this dimension chain and set the reference level.

These dimension lines will use the default dimension settings. When a new Grid line is inserted on the Floor 

Plan and it appears on the Section/Elevation, then it will be included in the dimension chain.

Auto-stagger Grid Markers if they overlap: Automatically stagger Grid markers sideways to avoid 

overlapping, if the markers would otherwise overlap.

Show non-perpendicular Grid Elements: By default, the Section/Elevation will display only Grid elements 

that are perpendicular to the Section/Elevation line and are located within the Section/Elevation depth. (By 

default, no Grid elements that are curved on the Floor Plan will be displayed on a Section/Elevation.) 

Check this to show Grid elements which are not perpendicular to the Section/Elevation line, but which 

intersect the Section/Elevation on the Floor Plan. These Grid lines will appear at the intersection point with the 

Section/Elevation line.
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Interior Elevation (IE) Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For details, see Interior Elevations (IE).

Interior Elevation General Panel

Settings in this panel depend on whether the selected Interior Elevation (IE) is the whole IE Group, or one of 

its viewpoints. If nothing is selected, the default settings are those of an IE Group.

For an IE Group:

Reference ID: Enter any customized ID, if desired, or click the Autotext button to choose an Autotext 

reference as part of the ID.

Name: Enter any customized Name, if desired, or click the Autotext button to choose an Autotext reference as 

part of the Name.

For an individual IE viewpoint:

Reference ID/Name: To inherit the ID or Name defined in the parent IE Group’s settings, leave the pop-up on 

“By IE Group.” 

Any Autotext defined in the parent IE Group’s ID/Name settings will be interpreted individually for each 

viewpoint in the group.

To enter any other ID/Name for this viewpoint, switch the pop-up to Custom and enter the desired text.
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Marker Reference to: Choose an item whose information you want to display in the IE marker:

• the Interior Elevation viewpoint, identifying it by its location in the Navigator Project Map;

or

• the first placed drawing of the Interior Elevation viewpoint, identifying it by its location in the Layout 

Book hierarchy

Reference to: shows the path (location in the Navigator hierarchy) of the chosen reference item.

To redefine the Marker Reference: Choose from among the pop-up choices (either viewpoint or first placed 

drawing of the viewpoint).

Interior Elevation Status

Choose an option to define the status of the link between the Elevation and the Floor Plan.

• Auto-rebuild Model: An Interior Elevation with Auto-rebuild status will be automatically rebuilt every time 

it is opened or brought to the front of the screen if the Floor Plan has changed.

• Manual-rebuild Model: An Interior Elevation with Manual-rebuild status is not rebuilt automatically. It can 

be rebuilt from the model only by using the Rebuild Elevations/Rebuild from Model command of the 

View menu.

• Drawing: In an Interior Elevation of Drawing status, elements will be exploded into 2D drawing elements 

which are not linked to the Floor Plan and will not be automatically rebuilt from the model. You can, 

however, update the drawing to reflect recent changes made to the model.

Show on Stories 

This pop-up list allows you to choose the stories on which to display the Interior Elevation markers and lines.

• If you have selected the Infinite radio button under Vertical Range, choose All stories or a particular 

custom story (choose the story shown in the pop-up list, or choose Browse Story to select another 

story of the project.)

• If you have selected the Limited radio button under Vertical Range and entered height values, two 

additional options are active.

Entirely in Range: The Elevation marker and line will appear on all stories that are entirely in the vertical 

range defined in the height value fields.

At Least Partly in Range: The Elevation marker and line will appear on all stories that are at least partly 

included in the vertical range defined in the height value fields.

Horizontal Range

The Horizontal Range can be either Infinite or Limited.

The default choice is Limited. In this case, the IE view will extend horizontally until the Room Boundary line. 

If the Room Boundary is a Wall, then the view automatically extends to the depth of the Wall.

To adjust the horizontal range, select the Room Boundary line and stretch or shrink it using the commands of 

the pet palette. (Stretch/shrink modifications to this segment will affect the neighboring line segments 

accordingly, as when editing any polyline.)
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An Infinite Horizontal Range means that the Interior Elevation viewpoint will extend horizontally to include all 

visible parts of the model.

Note: The visibility of elements in an Interior Elevation is defined differently as of ARCHICAD 18. In earlier 

versions, the bounding box of elements determined whether they would be shown in the viewpoint. To use 

the older-version logic, turn on the Interior Elevation Legacy checkbox in Project Preferences. (See 

Legacy Preferences.)

Add Bounded Areas (Interior Elevation Default Settings)

To include connected enclosed areas in the Interior Elevation viewpoint, choose Add bounded areas. This 

checkbox is available

• in Interior Elevation Default Settings (you must set it before you place the IE; you cannot set this control 

for an already placed IE)

• if the Limited option is checked for Horizontal Range

Vertical Range

The vertical range defines the height of the Floor Plan Elevation that will be included in the Interior Elevation 

window.

• Infinite: The Elevation will include the entire height of the project.

• Limited: The Elevation is confined to a limited vertical range. If you click this button, enter elevation values 

for the upper and lower limits of the Interior Elevation. Elements above and below these limits will not appear 

in the Interior Elevation.

Use the pop-up to define whether this vertical range should be measured from Project Zero, or a 

particular custom story: choose the story shown in the pop-up list, or choose Browse Story to select 

another story of the project.
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• Detect and Fit to Zones: The Interior Elevation will use the Zone height (if it detects any zones in the 

Interior Elevation limit) as the IE viewpoint’s vertical range.

If you want this zone calculation to take any Solid Operations into account, you should also check the 

Consider Solid Operations box.

Interior Elevation Marker Panel

Marker Placement: Use this control if you are creating a Group of IE viewpoints. Choose one of these 

options:

• Individually for Each Viewpoint: You will place as many markers as viewpoints you are creating in the 

Group.

• One common Marker for the IE Group: You will place a single marker for the entire group of viewpoints.

Select Marker Type pop-up: Select a parametric marker from this list.

The chosen marker’s 2D Symbol appears in the preview window.

Define Marker size and pencolor.

Uniform Marker Pen: Check this box to use this pencolor for all parts of the marker symbol, regardless of 

any custom colors set elsewhere for this marker.
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Worksheet and Detail Tool Settings

The following settings work essentially the same way for the Worksheet and Detail tools. 

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For more information on these views, see:

Worksheets

Details

General Panel

Reference ID: This editable field contains the ID of the generated Detail viewpoint. The ID serves to identify 

the Detail in the project window and in the Navigator.

Name: Enter a Name for the Detail Drawing if desired. This name appears in the Navigator palette and the 

title bar of the Detail window.

Note: If you place a Linked or Independent marker that does not generate a viewpoint, the ID/Name fields 

are gray.

Use the next pop-ups to either place a new Detail Marker (Detail Default Settings) or redefine the selected 

Detail Marker:

To Place a New Worksheet or Detail Marker (Default Settings)

If you choose Create New Viewpoint:

select one of the items about which the Marker should display information:

• the viewpoint

or

• the first placed drawing of the viewpoint

If you choose Place Linked Marker:

select one of the items about which the Marker should display information:

• a selected viewpoint

• a selected drawing

• the first placed drawing of the selected viewpoint

• the first placed drawing of the selected view
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If you choose Place Unlinked Marker:

the Marker will not contain any linked information; you can define a custom text in the Marker Panel below.

Reference to: shows the path (location in the Navigator hierarchy) of the chosen reference item.

Copy construction elements only: If this box is checked, only 2D lines/fills and construction elements from 

the model view will be exploded and copied into the Detail viewpoint (without dimensions/annotations).

For information on annotation elements cut by the Detail boundary, see Annotations, Dimensions and Markers 

Cut by the Boundary.

To Redefine a Placed Marker:

As needed, use the pop-ups to change the status of the selected Marker (either Source Marker, Linked 

Marker, or Unlinked Marker).

To redefine the Marker information: Choose from among the pop-up choices, or click the Browse button to 

select the viewpoint/view/drawing whose information you wish to display in the Marker. The available choices 

vary depending on the Marker status (Source Marker, Linked Marker or Unlinked Marker).

For an Unlinked Marker, enter a custom text in the Marker Panel below.

Marker Panel

Select Marker Type pop-up: Select a parametric marker from this list.

The chosen marker’s 2D Symbol appears in the preview window.

Define Marker size and pencolor.

Uniform Marker Pen: Check this box to use this pencolor for all parts of the marker symbol, regardless of 

any custom colors set elsewhere for this marker.

Marker Angle: Use these controls to set the desired Marker angle. Define the angle as relative to the screen, 

or to the model. 

• Enter a rotation angle for the Marker. 

• Use the two icons to define how this angle value should be interpreted when the element is placed: 

– Fixed Angle to Screen

– Fixed Angle to Model: Marker will be rotated along with the view.
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Change Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For more information on this tool, see Revision Management.

Change General Panel

Change ID: This ID serves to identify the Change in the Change Manager, on the Layout Revision and in lists.

Change Name: Enter any descriptive text for the Change Name.

Note: If you place an unlinked Change marker, the ID/Name fields are gray. For an Unlinked Marker, enter 

a custom text in the Marker Panel below.

Marker Type: Select either Create new Change or Place unlinked Marker.

• If you choose Create new Change, a Change Marker is linked to the Change you just placed. The name 

of this marker name is shown in the Reference to field below.

• If you choose Place unlinked Marker, you will create an unlinked Change Marker. This is a graphical 

element, not linked to anything, but you can link it at any time to an existing Change.

Change Marker Panel

Select Marker Type pop-up: Select a parametric marker from this list.

The chosen marker’s 2D Symbol appears in the preview window.
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Preview: On the right, a preview area shows you how the Marker will look when placed.

Define Marker size and pencolor.

Uniform Marker Pen: Check this box to use this pencolor for all parts of the marker symbol, regardless of 

any custom colors set elsewhere for this marker.

Marker Angle: Use these controls to set the desired Marker angle. Define the angle as relative to the screen, 

or to the model. 

• Enter a rotation angle for the Marker. 

• Use the two icons to define how this angle value should be interpreted when the element is placed: 

– Fixed Angle to Screen

– Fixed Angle to Model: Marker will be rotated along with the view.

Display Cloud/Marker Head: Choose the Change element component(s) you want to place: a Cloud plus a 

Marker Head, or just one or the other.
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Grid Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For general information on the Grid tool function, see The Grid Tool.

Grid Tool Floor Plan Panel

Use the controls in this panel to define the Floor Plan attributes of the grid element.

Grid Line: Select the desired representation of the grid line. It can be Hidden, Segmented or Full.

If you select Segmented, enter Segment Length in the field to the right.

Select a Line Type and pen color for this Grid Element.

Show on Story: From the dropdown list, select where you would like to see the Grid Element.

• Current Story Only: The Grid element will be shown only on the current story.

• One Story Up and/or Down: The Grid element will be shown on the current story, plus one story up and/

or down.

• All Stories: The Grid element will be shown on every story of the project.

• Custom: Choose this option if you wish to set any other combination of stories. The Selected Stories 

dialog box appears.

(Once you set these Custom Settings, use the Edit Custom option to edit them.)

Markers: Select either, both or none of the two checkboxes to indicate the display of markers on either end of 

the Grid line.

Staggering: When you stagger grid markers sideways, a given grid line segment will be staggered together 

with the markers.
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Set the default value of this staggering length here.

Grid Tool Section/Elevation Panel

This description applies to the display of Grid elements in both Section and Elevation windows.

Use the controls in this panel to define the Section attributes of the Grid element.

General/Custom: Use this pop-up to apply either the General settings to the selected Grid element, or to set 

Custom settings for the selected Grid element in this Section only.

Every Grid element has one “General” section settings and any number of “Custom” Section settings.

A Grid element using General section settings will be displayed identically in every Section that it appears in.

Custom settings for selected Grid elements are available only if you open Grid Element Settings from a 

Section window. Custom settings for a Grid element are applied only in the current Section window.

Thus, the same Grid element can be displayed in different ways, depending on which Section it is in.

If you apply Custom settings to a Grid element in one Section, then when opening the same Grid element in 

another Section, it will be displayed using its original settings, because Custom settings apply to a given Grid 

element only in a single Section window. However, you can use the Copy from command to copy those 

Custom attributes from the other Section, and use them for the Grid element in the current Section, too.

Grid Line: Select the desired representation of the grid line. It can be Hidden, Segmented or Full.

If you select Segmented, enter Segment Length in the field to the right.

Select a Line Type and pen color for this Grid Element.

Markers: Select either, both or none of the two checkboxes to indicate the display of markers on either end of 

the Grid line.

In the two fields to the right, enter the height level of each Grid line marker as displayed in Sections, and 

choose a reference level (default: Project Zero) for measuring this height level.

Note: The actual position of the Grid line (unlike other ARCHICAD elements) will change if the Reference 

Level is changed.

Staggering: When you stagger grid markers sideways, a given grid line segment will be staggered together 

with the markers.

Set the default value of this staggering length here.

Grid Tool Naming Rules Panel

Use this panel to define the logic by which each placed Grid element is named.

Generate names automatically: Select this option to auto increase the name every time you place a Grid 

element.

• Start at: This field shows the next name value to be assigned to the next placed Grid element.

• Prefix: a static text displayed in front of each auto generated name.

• Suffix: a static text displayed following each auto generated text 

• Style: Choose a style for the auto generated Grid element names: either numbers (1,2,3,...), letters 

(A,B,C,... or a,b,c,...), or Roman numbers (I,II,III,IV,...) 

A preview of the next name value to be assigned to the next placed Grid element is visible in the field next to 

Custom.

Custom: Click this button to override the auto generated name and to assign any other name to the Grid 

element.
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Grid Tool Marker Panel

Use this panel to define the appearance of the Grid element’s markers.

Marker Shape: Click this item, the click the black arrow to pop-up a list of available marker shapes. Choose 

one.

Connect Grid Line to: Click this item, the click the black arrow to pop-up a list of available choices of where 

to connect the grid line to the marker. (Not available for circular marker shape).

Grid Tool 3D View Panel

Use this panel to control whether and how the Grid Element appears in the 3D window. 3D Documents 

created from a 3D window showing Grid elements will also display Grid elements.

Display in 3D view: Check this box to display the Grid element in the 3D window. If this box is not checked, 

all other controls in this panel are grayed.

Vertical position: Enter the vertical position of the Grid Element in 3D. Click the black pop-up arrow to 

choose a reference level from which to measure its vertical position.

Show as line: Check this box to display Grid elements as line only in the 3D window. If you check this option, 

Grid elements will not be visible in renderings, and the rest of the Grid line controls in this panel are grayed. 

Unchecking this option means that Grid lines will be displayed in 3D with surfaces and a physical cross-

section, and will be displayed in renderings.

Grid Line Surface: Set the surface of the Grid line’s body.

Grid Line cross-section: Select between circular and rectangular cross sections and set their size 

Marker Text Surface: Set the marker text’s surface 

Text Follows View: Check this box to rotate the marker texts to always face the viewpoint. Note: This option 

is effective only in perspective views.
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Wall End Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

For more information, see Wall Ends.

The Wall End tool is used for placing wall end items onto walls by clicking one end of a wall.

The left-hand browser area of the Wall End Settings dialog box is similar to those of other Library Part 

elements.

See Settings of Library Part Elements.

Wall End Preview Panel

On the right-hand side of the panel, the Preview Area displays the 2D symbol, the hidden line front view, the 

hidden line axonometry, the 3D shaded axonometry, the predefined preview picture or the optional information 

notes of the selected Wall End, depending on the button you switch ON.

Wall End Parameters Panel

In the Parameters panel, you can adjust the size, thickness, and (where applicable) fills and colors of the wall 

end.

• The Fit to wall height checkbox is checked by default. If you uncheck it, you can use the settings below 

to enter any value for the height of the wall end and for the distance of the wall end from the base of the 

wall.

• The Cut Depth parameter tells you how much of the wall, in the Floor Plan view, is cut by the wall end.

Wall End Thickness Panel

Where applicable, the Thickness panel contains a preview to assist in setting the wall end’s thickness.

• Depending on its type, a Wall End can be set to automatically inherit the wall’s skin fills, or you can 

custom-set the Wall End fills instead.

For wall end objects with turning skins, you can set which wall fills should turn together with the wall end.

• As with other objects, you can also set many of these parameters in the Info Box or by using the wall end’s 

editing hotspots.
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Spline Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

Geometry methods are: Natural Splines, Bézier Splines and Free-hand.

For more information, see Drawing Splines.

Spline General Settings Panel

The General Settings panel is similar to those of the Line, Arc/Circle, Polyline and Spline tools.

See description at Line General Settings Panel.

For Splines only, use the two pairs of control buttons to define the type of spline:

• either a natural Spline or a Bézier curve.

• either an open-ended or a closed spline.

Spline Properties Panel

See description at Line Properties Panel.
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Hotspot Tool Settings

Hotspots are drafting aids to mark important nodes anywhere on screen.

To add Hotspots to your plan, activate the Hotspot Tool and click.

Note: Hotspots do not appear on the printed and plotted outputs.

For more information, see Hotspots.

Hotspot Color Panel

Click the Color drop-down menu to either type a Pencolor number (1-255) for the Hotspot in the text field or 

choose the appropriate color from the pop-up palette.

For more information on other options of this dialog box, see Working in Tool Settings Dialog Boxes.
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Figure Tool Settings

For a description of generic settings common to all tools in the Toolbox, see Working in Tool Settings Dialog 

Boxes.

The Figure tool is a dedicated tool for placing and manipulating images. Figures are embedded images in the 

project file.

Images files can be directly imported from within the Figure Settings dialog box.

For more information, see Figures.

Figure Preview and Positioning Panel

You have two options for obtaining image files:

• Click the Open button to browse the directory system for image files.

• Click the Paste button to use the contents of the Clipboard. (If the Clipboard contains image information, it 

will be used directly. If the contents is text, it will be first converted to bitmap.)

Note: You can also insert a cropped view of any image file into your ARCHICAD plan. With your 

ARCHICAD project file open, open any image format file. Click and drag (the Marquee tool is the only 

available tool) to select the desired image area, then copy it to the clipboard. Close the image file, then 

paste the clipboard contents into the open project. You can modify it like any other figure.

The Preview area displays the image.

The Name field below displays the imported file’s name, or “Pasted Image #” if the figure was inserted from 

the Clipboard. Click in the field to rename the image if needed. This does not affect the original file’s name.

Figure Size: Use these fields to give accurate dimensions to scanned site plans or measured layouts.

• Enter a value for the horizontal size of the inserted image in default length unit.

• Enter a value for the vertical size of the inserted image in default length unit.

• The Keep Proportions checkbox below allows you to fix image proportions if appropriate.

Hint: Dimensions are often distorted when drawings or images are scanned. Uncheck the Keep 

Proportions box to unlink the dimensions and adjust figure width and height independently if you want to 

make sure that dimensions are correct. This is especially important when inserting existing site plans, 

survey plans or layouts into ARCHICAD Projects.
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Resolution: Adjust resolution of the inserted figure if necessary for specific print output quality:

• Enter a horizontal resolution in dpi.

• Enter a vertical resolution value in dpi.

Note: Figure size and image resolution are interdependent. By increasing image size, you decrease 

resolution, and vice versa.

Use the Restore Original Values button to reset the image default parameters for figure size and resolution.

Insert Figure using 1 to 1 pixel correspondence with screen resolution: Every time you insert the 

selected image with this option, one pixel of the selected image will correspond to one pixel of the screen. The 

figure size upon insertion will depend on the current zoom level of the screen.

Check Transparent to show elements that are located underneath the Figure’s white pixels, according to the 

current display order.

Check the Mirror icons to insert the figure flipped horizontally.

• Rotation Angle: Enter a rotation angle for the Figure. 

Use the pop-up to define how this angle value should be interpreted when the element is placed: 

• either Relative to Orientation (the angle will be measured relative to the Oriented View)

• or Absolute to Coordinate System (the angle will be measured from the (0,0) point of the project 

coordinates).

See also Set Orientation.

Click an Anchor point button to define the positioning point of the Figure.

Figure Image Format Panel

Use the Storage Format field to change the format in which the file is saved within the project file: click on the 

preferred format and choose OK.

The control to the right of Storage Format displays the color resolution of the image.

The controls below display the horizontal and vertical image size in pixels.

Use the Save as button to save a copy of the selected image file in a different format as an external file.

The field next to the disc icon displays the file size of the selected image in kilobytes.
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Camera Tool Settings

Double-click the Camera tool to open Camera Tool Settings.

Use these settings to define individual perspective views and the Fly-Through path.

For more information, see Cameras.

The Camera Settings palette and the Floor Plan are simultaneously active, so you can alter the settings, the 

camera locations and orientations without repeatedly opening and closing the window.

Click New to add a new path to the project to start a new collection of 3D projections. The New Camera Path 

dialog box opens. Here you can:

• Enter the name of the new Path.

• Add Copy of Current Path: Check this box to duplicate the current set of projections while you define a 

new one.

Click Rename to rename the current path, then type the new name in the dialog box and click OK or select a 

path in the pop-up list.

If you have already defined one or more camera paths, choose the desired camera path from the pop-up 

menu.

Click Delete to delete the current path. The path name will be removed from the list and all its cameras will be 

deleted.

Camera

To select a particular camera from the current camera path, use the up/down arrows to scroll through the 

camera numbers, or enter the camera number from the keyboard.

Wait here

This value refers to the number of still frames (time units) during which the fly-through motion will remain 

frozen at the given camera before moving on to the next one.
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Smooth Path at Cameras

Restores the tangent line defining the path to its original position, if you have modified it.

Current Camera Position

Camera Z: Enter a value to specify Camera height from Project Zero.

Target Z: Enter a value to specify Target height from Project Zero.

Distance: Enter a value to specify the horizontal viewing distance between Camera and Target.

Azimuth: Enter a value to specify Camera Azimuth to Target.

View Cone: Enter a value to specify the opening angle of the Camera View Cone.

Roll Angle: Enter a value here to specify Camera Roll Angle.

Sun Position

Use these controls to define a Sun Position for the selected Camera.

See Sun Position.

Use the Pencolor/Penweight controls to specify a pen color for the selected camera. (To modify the color of 

the path line, use the Path button for opening the Path Options dialog box.)

Sunlight: Click this button to access the Sunlight Settings dialog box.

For details, see Sunlight Settings dialog box.

Path Options

To open this dialog, click Path from Camera Settings.

Motion Controls 

Camera: Choose radio buttons to set the shape of the Camera Path:

• Polygon: Click this button to place In-between Frames along a straight line between Key Frames 

(Polygonal Animation Path).
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• Bézier: Click this button to place in-between Frames along a Bézier curve between Key Frames (Bézier 

Animation Path).

Note: Bézier makes for smoother animations, while Polygon paths are somewhat jumpier.

• Open: Click this button for an open-ended Path Loop.

Hint: The first and last Key Frames of an Animation Path can also be coincident.

• Closed: Click this button for a continuous-loop Path.

Hint: Use this to create smooth endless loop Animations.

The Target option defines the shape of the target point path during the Fly-Through animation.

• Polygon: This option will place the target points of the in-between frames on the straight line that 

connects the two consecutive key target points.

• Smooth: This option will place Targets along a smooth curve between Key Targets.

Note: Smooth is available only if you have specified Bézier for the camera motion.

Hint: Use Polygon target motion if your camera moves a lot but the target stands stills or moves just a 

little. This is the case when you fly around a building but keep the same spot in sight. In other cases, try 

both methods to see which one suits you better.

Motion Resolution 

Each 3D Projection you add to the path is considered a keyframe. ARCHICAD can interpolate between 

keyframes to create In-between views which produce a smoother animation.

Cameras on the path: Shows the total number of Cameras in the current Polygonal or closed loop Bézier 

Path.

In-between frames: Enter the number of in-between Frames between each Key Frame here.

A larger number of in-between frames makes a smoother animation Path, but uses more memory and hard 

disk storage space.

Total frames: Shows the total number of Key and in-between Frames.

Display Options 

Choose the format in which to display the frames of the current Path: (Cameras are never displayed in printed 

output.)

• None: Since Cameras cannot be assigned to Layers, choosing None in Display Options here is the only 

way you can hide them on the Floor Plan.

• Camera only

• Camera & Path

• Everything: the location of the in-between frames will also be shown.

Choose which frames to display:

• Click the Cameras radio button to specify a range of keyframes to be displayed.

• Click All to display all frames of the path

This setting will be used as a default in the Create Fly-Through dialog box: only the visible part of the path 

will be processed.

Enter a Pencolor for the line of the camera path.

For more information, see Fly-Through.

Click OK to confirm Path Options and return to the Camera Settings dialog.
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Custom Settings Panel for a Door/Window

For every Door/Window in the INT library, you can set parameters using the Custom Settings panel, which has a 

graphical interface. The name of the panel varies depending on the Door/Window type that is selected.

The following sections describe the Custom Settings Panel of Door and Window Settings.

Available Door/Windows and their parameters vary depending on your library version. For information on 

Door/Window parameters that are not described here, please contact your distributor.

Reset to Default Settings

If you customize any Library Part’s GDL settings, you can reset to its default using the Reset command from 

the Info Box:
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For general information on the Custom Settings panel, see Where to Set Door/Window Parameters.

Nominal Sizes and Tolerance

Shape

Door/Window Settings and Opening

Frame Style and Dimensions (for Door)

Natural Ventilation

Door Leaf Type

Handle and Kick Board (for Door)

Leaf and Sash Dimension (for Door)

Sash Type/Sash Options (Door or Window)

Frame and Sash (for Windows)

Frame Widths (for Windows)

Opening Type and Angle (Door/Window)

Opening Lines (Door/Window)

Opening Lines - Sidelight and Transom

Model Attributes of Door/Window Opening

Wall Opening

Reveal Settings

Wall Closure

Wall Inset (for Windows)

Masonry Arch

Tolerances

Model Attributes of Wall Opening

Fixtures and Fittings

Threshold Settings
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Sill Settings

Board Settings

Casing Outside/Inside Settings

Sunshade Settings

Model Attributes of Fixtures and Fittings

Floor Plan and Section Tab Page (Door/Window Settings)

Minimal Space

Custom Corner (for Windows)
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Nominal Sizes and Tolerance

The following is a description of the Nominal Sizes and Tolerance page of the Custom Settings Panel of Door 

or Window Settings, from the INT ARCHICAD Library.

Opening size (height and width) can be defined with respect to any of four types of dimensions: Wallhole, Unit, 

Egress or Leaf dimensions.

The numbered graphics help you identify the dimensions.

Wallhole Dimensions

The Wallhole is the part cut out of the wall to accommodate the whole opening structure.

Wallhole Width is equal to Unit Dimension Width plus the sum of Side Tolerance values.

Wallhole Height is equal to Unit Dimension Height plus Upper Tolerance value.

See Tolerances.

Unit Dimensions

Unit Dimensions are the width and height of the whole opening structure.

Egress Dimensions

Egress dimensions are the opening’s unit width, subtracting the frame width.

Set as Nominal

Use the Set as Nominal radio button to choose one of these dimension definitions as the opening’s Nominal 

Size.

• This is the Nominal dimension that will be listed in the Interactive Schedule in the Nominal W x H Size 

field.

• This Nominal dimension will be displayed in the Width and Height fields in the Preview and Positioning 

Panel or Window Settings.
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Transfer Current Nominal Size to Selection: This checkbox is applicable if you change your definition of the 

Nominal Dimension (e.g. from Unit Dimensions to Wallhole Dimensions). If this box is checked, then the 

values of the original Nominal Dimension (those set for Unit Dimensions) are transferred to the new Nominal 

Dimension (your Wallhole Dimensions). The other dimension values will be adjusted automatically.

Show Dimensions in Marker

The opening’s dimensions (Wallhole, Unit, Leaf or Egress Dimensions) can be displayed in the opening’s 

Marker, if any.

Use the Marker Symbol and Text panel / Content - Dimensions page to choose the preferred dimension to 

display in the marker.
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The dimension definitions chosen here will also be used in Automatic Dimensioning and the Interactive 

Schedule.

Uniform Tolerances

By default, this is checked, so that you can enter a single value to apply to tolerances on all sides of the 

opening structure. To vary the tolerance values for the sides of the opening, (as for a complex-shaped 

opening whose sidelights have varying sill heights), uncheck the box and click Tolerances to go to the 

Tolerances tab page.

See Tolerances.

Note: If you wish to enter Oversize values, use the Oversize controls on the Wall Opening page of this 

Settings dialog. Entering an Oversize does not (unlike the Tolerance value) affect the Nominal Size of the 

opening.
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Shape

Use this page of the Custom Settings Panel of Door or Window Settings, to define the configuration of door 

leaves/window panes and their divisions.
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Door/Window Settings and Opening

The following is a description of the Door/Window Settings and Opening tab page of the Custom Settings 

Panel of Door or Window Settings, from the INT ARCHICAD Library.

You can set all of the main parameters on this tab page.

To set additional, more detailed parameters for any of these components (e.g. Leaf, Frame), click the icon at 

the right of the setting to access the respective tab page, where you will find additional parameters.

Door Leaf and Handle

Use the pop-ups to choose a Leaf style and Handle style for the door.

To set additional parameters, click the icon at the right of the respective pop-ups to jump to the Door Leaf 

Type tab page.

Opening Type

For each component of the opening, choose a type from the pop-up. (Available settings depend on the library 

part.)

To set additional parameters, click the icon at right to jump to the Opening Type and Angle tab page.

See Opening Type and Angle (Door/Window).

Frame Style: Choose one of three frame styles.

Note: If the chosen door uses a double-egress opening type, the simplest Block style is automatically 

used. In this case, no other options are available.
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To set additional frame parameters, click the icon at right to jump to the Frame Style and Dimensions tab 

page.

Natural Ventilation: Check this if the opening uses natural ventilation, then choose either “over Frame” or 

“over Glazing.”

To set additional ventilation parameters, click the icon at right to jump to the Natural Ventilation tab page.

See Natural Ventilation.

Detail Level

Choose options for the level of detail with which to display the opening in both 2D and 3D.

The default setting for both 3D and 2D Detail level is By MVO. This corresponds to the options set in Model 

View Options (Document > Model View > Model View Options):
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3D Detail Level

To overwrite the MVO-based settings for this Door/Window: Choose Schematic, Simplified, or Full.

From left: Schematic, Simplified, Full

If you choose Off, only an empty opening is shown.

2D Detail Level

Scale Sensitive: The detail level depends on project scale.

Otherwise, you can fix the detail level to a given level (e.g. 1:200), or turn it off (in which case, no 2D opening 

symbol is shown at all).
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Frame Style and Dimensions (for Door)

The following is a description of the Frame Style and Dimensions page of the Graphical Interface Panel of 

Door Settings for a “Hinged Door”, with sidelight and transom, from the INT ARCHICAD Library.

Frame Style: Choose one of three frame styles.

Note: If the chosen door uses a double-egress opening type (set on the General Settings page), the 

simplest Block style is automatically used. In this case, no other options are available.

Depending on the chosen Frame Style, set parameters for frame width and thickness, and the thickness of the 

leaf and glass.

Frame Thickness = Wall Thickness: Check this to make the frame and the wall the same thickness.

Uncheck Uniform Frame Thickness if you want to vary the frame thickness parameter.

Note: By default, this checkbox is checked and gray (unavailable.) This parameter becomes available 

only if you have set Frame Thickness to equal Wall Thickness, and if all door sashes open in the same 

direction. (By default, door leafs and their sidelights/transoms open in opposite directions.)
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Natural Ventilation

The following is a description of the Frame Style and Dimensions page of the Custom Settings Panel of Door 

or Window Settings, from the INT ARCHICAD Library.

Natural Ventilation: Check this if the opening uses natural ventilation, then define its position: choose either 

“over Frame” or “over Glazing.”

In the fields below, define the height/width of the ventilation component profile (for each sash, if applicable.)

Set fill attributes for the Ventilation profile (in Section views) on the Floor Plan and Section page.

See Floor Plan and Section Tab Page (Door/Window Settings)
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Door Leaf Type

The following is a description of the Door Leaf Type tab page of the Custom Settings panel for a “Hinged 

Door”, with sidelight and transom, from the INT ARCHICAD Library.

Door Leaf Type

Scroll through the preview panel to find a leaf style that suits your needs. Most of these are predefined; in 

some cases, you can adjust the width of the frame.

Grid-Style Panels

Choose the Grid style (H-V Grid, French Panel or Prairie Style) if you wish to specify the number of horizontal 

and vertical panes and the mullion configuration. For these panel styles, set the Position: place the mullions 

inside or outside the door, or run them through on both sides (“Throughout”).

Custom Door Leaf

If you have created a Custom Door Leaf, choose the Custom style to apply your leaf to the door.

For information on creating a custom door panel, see Create Custom Components for Doors, Windows, 

Curtain Wall, Stair, Railing.
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Handle and Kick Board (for Door)

The following is a description of the Handle and Kick Board tab page of the Custom Settings panel for a 

“Hinged Door”, with sidelight and transom, from the INT ARCHICAD Library.

Door Handle

For a multi-leaf door, set Handle preferences for each leaf separately, or check Uniform Handles to use the 

same on all door leaves.

From the pop-up list, choose a Handle. Set its height and its position (horizontal distance) from the opening 

edge of the door.

Kick Board

Check to add a kick board on the outside and/or inside of the door, and to define its height.
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Leaf and Sash Dimension (for Door)

Use this tab page to define the thickness and width of the door leaf, sash frames, and the glass.
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Sash Type/Sash Options (Door or Window)

The following is a description of the Sash Type or Sash Options page of the Custom Settings Panel of Door or 

Window Settings, from the INT ARCHICAD Library.

Start by selecting the sash or transom to edit from the pop-up list.

Note: If you check the Uniform Sashes box, all the sashes will use a single type.

Next, choose a pattern of mullions for the selected sash:

See also Custom Panel.

Note: The “Editable Grid” sash type means that you can edit the sash divisions graphically, in the project, 

using the editable hotspots.

See Graphical Editing Using Editable Hotspots.
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Enter values for the sash pattern: the number of panes horizontally and vertically, and parameters for the grid 

divisions.

Position: Choose whether to place the grid for this sash inside or outside the opening, or to run it through on 

both sides (“Throughout”).

Custom Panel

If you have created a custom Window Sash, choose the Custom Panel style to apply your sash to the 

sidelight.

For information on creating a custom panel, see Create Custom Components for Doors, Windows, Curtain 

Wall, Stair, Railing.
ARCHICAD 24 Reference Guide 3896



Tool Settings Dialog Boxes User Interface Reference
Frame and Sash (for Windows)

The following is a description of the Frame and Sash page of the Custom Settings panel for a Basic Window, 

from the INT ARCHICAD Library.

Use these controls to adjust the frame and sash width and thickness.

Note: To set options for the sash types and grids, use the Sash Options tab page.

Frame Element Joinery: Choose either Mitered or Butt Joint.

 Uniform Frame Width: Check this box if you need a single frame width for the entire window structure. To 

set a different frame width for any and all sides of the frame, uncheck the box and then click the Set Frame 

Widths button to go to the Frame Widths tab page.

See Frame Widths (for Windows).
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Frame Widths (for Windows)

The following is a description of the Frame Widths page of the Custom Settings panel for a Basic Window, 

from the INT ARCHICAD Library.

If Uniform Frame Width is checked (either on this tab page, or on the Frame and Sash tab page), then you 

set a single width value for all sides of the frame.

If you uncheck Uniform Frame Width, you can set varying width values for the sides, (as for a complex-shaped 

window).
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Opening Type and Angle (Door/Window)

The following is a description of the Opening Type and Angle tab page of the Custom Settings Panel of Door 

or Window Settings, from the INT ARCHICAD Library.

Use this to set options for the openings of the opening as a whole, and for the sidelight and transom (if used).

Opening Type

For each component of the opening, choose a type from the pop-up. (Available settings depend on the library 

part.)

Note: The Opening Type chosen here may limit the possibilities for the door’s Frame Style.

2D/3D Opening Angle

Optionally, for each component of the opening, set an opening angle in 2D and 3D display. (You can also edit 

the opening graphically, using the editable hotspots.)

Sidelight and Transom: Opening Direction

For the Sidelight and Transom, choose “Same as Leaf” or “Opposite to Leaf” from the pop-up to define the 

opening direction.
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Sidelight and Transom: Opening Type and 3D Opening Angle/Distance

Use the pop-up lists to choose a type for the sidelights and transom. Enter an opening angle (or opening 

distance, for a sliding door) as needed.
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Opening Lines (Door/Window)

The following is a description of the Opening Lines tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Use these controls to set the display of Opening Lines for each opening.

By default, these controls are grayed, because Opening Line display is set globally for all doors and windows 

in Model View Options.

For details on these settings, see Miscellaneous Settings for Library Parts.

However, to adjust Opening Line settings for this opening only, check the Override Model View Options box 

and set the options as needed.

Separate options are available for 2D Symbolic Display and 3D Projections.

The 2D & 3D Line Pen control affects the opening line display in both 2D and 3D.
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Opening Lines - Sidelight and Transom

The following is a description of the Opening Lines - Sidelight and Transom tab page of the Custom Settings 

panel for a “Hinged Door”, with sidelight and transom, from the INT ARCHICAD Library.

Use these controls to set the 3D Projection display options of Opening Lines for the sidelight and transom (if 

applicable) for each door.

By default, these controls are grayed: Opening Line display is set globally for all doors (including their 

sidelights and transoms) in Model View Options.

For details on these settings, see Miscellaneous Settings for Library Parts.

However, to set separate Opening Line options for the transom/sidelight of this door only, check the Override 

Model View Options box and set the options as needed.
ARCHICAD 24 Reference Guide 3902



Tool Settings Dialog Boxes User Interface Reference
Model Attributes of Door/Window Opening

The following is a description of the Model Attributes tab page (in the “Door Opening” or “Window Opening” 

section) of the Custom Settings Panel of Door or Window Settings, from the INT ARCHICAD Library.

Use this page to define the opening’s 3D appearance. The available controls depend on the components of 

the particular opening.

In addition to general attributes, you can set specific surface materials and 3D pens for the door leaf, frame, 

grid and glass components, and for the handle and handle accessory, if any.

3D Detail Level

This is the same setting as on the main Settings and Opening page. 

See Detail Level.

Shadow

Turn on to display a shadow effect for this opening in 3D.

Curve Resolution

Applied to the opening’s curved components when generating their 3D display. (The circle formed out of the 

curved component will be divided into the given number of segments.) A higher curve resolution can improve 

the 3D appearance, but increases file size.

Frame Element Joinery

Choose either Mitered or Butt Joint.
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Override MVO for 3D Projections

Check this box to override, for this particular opening, the Model View Options for Opening Lines defined at 

Document > Model View > Model View Options > Miscellaneous Settings for Library Parts (Opening 

Lines in 3D Projections).

Frame and Leaf (Sash) 3D Pen

These controls affect the parts of the Frame and Leaf/Sash that are displayed

• in the 3D window

• and in 3D-like form on the Floor Plan - that is, the Projected parts, if the opening’s Floor Plan Display 

option is set to Projected or Projected with Overhead.
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Wall Opening

The following is a description of the Wall Opening tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Reveal Type and Depth

From the pop-up list, choose a Reveal Type to use for this opening, or choose one of the No Reveal options. 

Enter a value for the Reveal Depth.

• You can also choose a Reveal Type and set Reveal Depth on the Reveal tab page.

• Reveal Depth can also be set on the Preview and Positioning Panel.

Wall Closure

This control is applicable if you have placed the opening in a composite wall.

Choose a predefined or custom Closure from the pop-up list. Available closure types vary depending on the 

type of reveal used for the opening.

• Closure options can be defined in the Wall Closure tab page.

See Wall Closure.

Masonry Arch

Check this to include a Masonry Arch in the opening, and choose the desired type from the drop-down list.

To set additional Masonry Arch parameters, click the icon at right to jump to the Masonry Arch tab page.

Opening Oversizes

Enter values if you want to increase the wall hole cut by the opening, on its left, right, upper and/or lower 

sides.

Note: Entering an Oversize does not (unlike the Tolerance value) affect the Nominal Size of the window.

Wall Opening Surface

The surfaces of the host Wall can be applied to the opening in two ways.

• If you choose the Same as Wall Edge option, ARCHICAD will apply the surface of the wall’s edge to the 

opening’s edges.

• If you choose the Same as Wall Side option, the external and internal wall surfaces will be applied to the 

opening’s edges, with the reveal depth as the division line between them.

If you are programming a Door/Window in GDL for a curved wall, see also Hole Surface’s Split is Curved.
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Reveal Settings

The following is a description of the Reveal tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Use this tab page to choose a Reveal Type and to set its parameters, such as Head and Jamb dimensions 

and Reveal Depth.

• You can also choose a Reveal Type and set Reveal Depth on the Wall Opening tab page.

• Reveal Depth is also set on the Preview and Positioning Panel.
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Wall Closure

The following is a description of the Wall Closure tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Use this tab page to define how the layers of a composite wall will close around the opening that is placed into 

it. (These settings are relevant only for openings placed in composite walls.)

• These settings only affect the display of openings in 2D views.

• The effect of your Turn Plaster settings will be displayed in Section/Elevation views as an extension of the 

composite wall into the frame. (To see the effect of these settings in the 3D window, you must check the 

“Show in 3D” box among the Turn Plaster controls.)

Watch the Video

Wall Closure Tab Page Settings

There are two types of settings on this page:

• Closure Settings (if you choose to use a Wall Closure); and

• Turn Plaster settings, which are independent of whether you are using a Wall Closure type.

Closure Type

Choose a Closure Type from the drop-down menu, or No Closure if you are not using one.

Available closure types can vary depending on the structure of the reveal.

Closure Settings

These options vary depending on the chosen Closure Type.

Turn Skin on Side

Choose whether the wall skins should be turned in on the right, the left or on both sides of the opening.
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 Number of Skins to Turn

Choose the number, starting from either the Outside face or Inside face of the wall. (Switch this preference 

using the Number from pop-up.)

Profile Width

This parameter is available for the prefabricated cavity closure. Enter a width for the closure element.

If you have chosen Custom Closure: see Custom Closure for information on these settings.

Insulation Strip

Check this box to add a strip of insulation.

Enter a thickness value for this insulation strip.

Turn Plaster

Use these settings if you want the wall’s plaster to turn in at the end of wall - irrespective of whether you are 

using a Wall Closure.

Notes:

– The turned plaster skin will be turned outside of the wall contour, as defined in Reveal Settings.

– You cannot use both Casing and Turn Plaster options at the same time. If Turn Plaster settings are 

grey, go to the Casing pages of the Settings panel and turn off Inside and Outside Casing. (See 

Casing Outside/Inside Settings.)

Plaster Skin Definition

First, define which wall skin should be considered the Plaster Skin:

• Use Wall Finish Component: the component of the composite wall that is defined as “Finish” will be 

considered plaster.

Alternatively:

• Plaster Thickness Limit: Define the Plaster skin by a given thickness - e.g., all skins up to 40 mm thick 

will be considered plaster.

Once you have defined which wall skins are considered plaster, use the controls under Turn Plaster to define 

which of the plaster skins should be turned in:

• either Automatically (all skins defined as plaster under the Plaster Skin Definition above will turn), or

• the specified Number of Skins to Turn.
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Custom Closure

If you want to use a custom closure type, you will set the closure preferences separately for each skin.

First, under Select Skin to Edit, choose whether you want the closure on the left jamb, right jamb or both.

Next, select the skin you want to turn in. (Use the pop-up to number the skins starting from either the wall’s 

Outside Face side or the Inside Face.)

On the right side, check Turn-in Skin if you want the currently edited skin to be turned in (wrapped); then set 

the rest of the options (thickness, hatch orientation, separating line pen) for the selected skin.

Check Consider Skin as Plaster if you want the skin to behave as plaster: that is, it will turn in along the wall 

opening as defined by the reveal.

Note: If the wall skin is defined as “Core”, it cannot be considered plaster, and this checkbox will have no 

effect.

See How to Define Components as “Core” or “Finish”.
ARCHICAD 24 Reference Guide 3909



Tool Settings Dialog Boxes User Interface Reference
Wall Inset (for Windows)

The following is a description of the Wall Inset page of the Custom Settings panel for a Basic Window, from 

the INT ARCHICAD Library.

Use this page to define a wall inset below the window (e.g. to make room for a radiator).

Choose a Wall Inset Size:

• Automatic: The width of the inset is always equal to the window width.

• Symmetric: Define a fixed width and a fixed height for the inset, which will be created symmetrically to the 

window opening.

• Asymmetric: Define different overhangs (from right and from left) for the horizontal location of the inset. 

Define a single fixed height for the inset.

For all inset sizes:

• Define the bottom elevation of the inset, or leave it 0 to extend it to the floor.

• Define the depth of the inset.
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Show Hidden Parapet on 2D: Check this box to display, in 2D views, the parapet line created by the wall 

inset even if its cut view is blocked by the wall and/or window opening.
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Masonry Arch

The following is a description of the Masonry Arch tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Masonry Arch: Check this box, then choose a style for the arch from the drop-down menu. The rest of the 

controls vary depending on the arch you choose here.

Rise: The value of the arch’s rise.

Skewback angle: For “Jack” arch styles.

Type: Choose Stucco or Brick. If you choose Brick, you can set values for the Brick and Mortar thicknesses 

below.

Note: Using brick arches in a large number of windows may increase your model size significantly.

Keystone: For arch styles with a keystone, set values for its width, oversize (if the keystone extends vertically 

above the arch) and projection (if it protrudes horizontally from arch).

Using the fields on the right side of the dialog box, set the height and depth values for the arch; the depth of 

any hole behind it (“Rear Hold Depth”); and the arch projection horizontally, if any.
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Arch on Header: Check this box to place the arch directly atop the opening header.

If it is not checked, then you can use the field below to define the distance between the arch and the header.

Niche below Arch: Check this box to create a niche (or inset) beneath the arch.

Horizontal Overhang: Use the two fields on either side of the drawing to define the arch overhang on the 

right and left side of the opening.
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Tolerances

The following is a description of the Tolerances tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Use this tab page to set the side and upper tolerance values for the opening structure.

If Uniform Tolerances is checked (either on this tab page, or on the Nominal Size and Tolerances tab page), 

then you set a single tolerance value for all sides of the structure, and another value as the Upper Tolerance.

If you uncheck Uniform Tolerances, you can set varying tolerance values for the sides, (as for a complex-

shaped opening whose sidelights have varying sill heights).
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Model Attributes of Wall Opening

This is the Model Attributes tab (in the Wall Opening Section) of the Custom Settings Panel of Door or 

Window Settings, from the INT ARCHICAD Library.

Use this page to define the 3D attributes of the opening’s masonry arch, if any.

Hole Surface’s Split is Curved

This control may be relevant when creating an opening in GDL and setting its defaults. 

In case of a curved wall whose wall opening displays the Wall Side surfaces (see Wall Opening Surface), the 

two surfaces - where they meet in the wall hole - can be split either along a straight line or a curve.

Check Hole Surface’s Split is Curved to split the surfaces along an arc.
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Fixtures and Fittings

The following is a description of the Fixtures and Fittings tab page of the Custom Settings Panel of Door or 

Window Settings, from the INT ARCHICAD Library.

Use this tab page to define the main fixtures of the opening. 

To set additional, more detailed parameters for any of these structures (e.g. Casing, Sunshade), click the icon 

at the right of the setting to access the respective tab page, where you will find additional parameters.

Casing

Use the Outside and Inside checkboxes to add Casing to the outer and/or inner side of the opening.

See Casing Outside/Inside Settings.

Ganging

You can align adjacent openings horizontally and vertically with these parameters. You must check these 

boxes both for this opening and for the adjacent one so that the opening symbol is displayed correctly.

As a result of ganging, the connecting lines between adjacent opening components (e.g. casing, sill, 

threshold) disappear - as if they were a single unit.

If you use ganging, some other structure options for this opening may no longer be applicable and will be 

grayed or eliminated.

Threshold/Sill/Board/Sunshade

Check this box, then use the pop-up to choose the desired component for the opening as needed. To set 

more detailed parameters, click the icon at the right of the setting to access the respective tab page.

See Threshold Settings.

See Sill Settings.

See Board Settings.

See Sunshade Settings.

Custom Corner (For Windows)

Check “Right” or “Left” to add a custom corner to the window.

To set more detailed parameters, click the icon at the right of the setting to access the Custom Corner tab 

page.

See Custom Corner (for Windows).
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Threshold Settings

The following is a description of the Threshold tab page of the Custom Settings panel for a “Hinged Door”, 

with sidelight and transom, from the INT ARCHICAD Library.

Use the Threshold Type pop-up to choose a threshold.

Threshold Settings include the Threshold Thickness and - for Extended threshold types - the nosing and side 

overhangs on either side of the door.
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Sill Settings

The following is a description of the Sill Settings of the Custom Settings Panel of Door or Window Settings, 

from the INT ARCHICAD Library.

Check the Sill box to assign a sill.

Use the Sill Type pop-up to choose a sill type. Depending on the type you choose, the settings will vary.

Choose either Simple or Detailed for the Sill’s 3D Detail level.

Sill Settings include thickness, width, angle, and nosing, as well as other settings for particular sill types.

Slip in Depth: The distance by which the sill extends beneath the frame (its maximum value is equal to the 

frame thickness). This value is added to the Sill Width.
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Board Settings

The following is a description of the Board Settings tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Use this page to define a board if you are using an opening with one or more raised sidelights.

Check Board to assign one to the sidelight(s).

Board in Curved Wall

You can opt to curve the board itself if it the window is placed in a curved wall: check the box “Is Curved in 

Curved Walls.”

Board in Polygon Wall

If the opening is in a polygonal wall, set the board edge to either follow the wall polygon (Parallel to Wall 

Polygon) or to stay parallel with the sidelight window.
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Casing Outside/Inside Settings

The following is a description of the Casing Outside and Casing Inside tab pages of the Custom Settings 

Panel of Door or Window Settings, from the INT ARCHICAD Library.

Note: You cannot use both Casing and Turn Plaster options at the same time.

See Turn Plaster.

Check Outside Casing and/or Inside Casing to assign it and to set the casing’s parameters.
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Sunshade Settings

The following is a description of the Sunshade tab page of the Custom Settings Panel of Door or Window 

Settings, from the INT ARCHICAD Library.

Sunshades are not available if the opening also has a raised sidelight.

Check the Sunshade box to assign one, then choose a type from the pop-up. The rest of the controls vary 

depending on the sunshade type.

Open in 3D: (For shutters that open.) Display the shutters in open position in the 3D window.

3D Opening (Angle): For movable shutters, enter how far to open it in 3D views. (You can also edit the 

shutter opening graphically in the 3D window, using editable hotspots.)

2D Symbol: Check this to display the shutter symbolically in the 2D window.

Extra Frame: Check this box to display (in the 3D window) the sunshade’s frame adjacent to the opening.

Shutter Height: Enter a value for the shutter height, or click Automatic Shutter Height to make it the same 

height as the opening.
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Model Attributes of Fixtures and Fittings

This is the Model Attributes tab page (in the Fixtures and Fittings section) of the Custom Settings panel for a 

Door or Window from the INT ARCHICAD Library.

The available controls depend on the fixtures assigned to the particular Opening.

Set specific surface materials and 3D pens, as applicable, to the Threshold, Sill, Casing, Board and/or 

Sunshade.
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Floor Plan and Section Tab Page (Door/Window Settings)

The following is a description of the Floor Plan and Section tab page of the Custom Settings Panel of Door or 

Window Settings, from the INT ARCHICAD Library.

This tab page contains all of the 2D display parameters for the various parts of the opening, as defined for this 

GDL object in its user interface script. The available parameters vary depending on the opening’s components 

and their geometry.

Note: Alternatively, you can use the 2D attributes on the Floor Plan and Section panel of Door/Window 

Settings. This method involves a reduced number of parameters for simplicity. See Override GDL Object 

Attributes of Doors/Windows, below.

While setting the parameters, it is worth displaying the Preview from Door/Window Settings to see how your 

definitions will affect the display.

Note that some display parameters are “by MVO”, that is, corresponding to the options set in Model View 

Options (Document > Model View > Model View Options), but you can override some of these attributes for 

the particular opening being edited.
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The first three parameters apply to the opening as a whole.

2D Detail Level

This is the same setting as on the main Settings and Opening page. 

See Detail Level.

Show Reveal on Symbol

Choose the scale at which the reveal should be displayed on the Floor Plan. (Reveal will not be displayed if 

the scale is larger than the chosen value.)

Wall Contour Lines

Set the Wall Contour lines for the opening display. If you turn on any of the contour lines, you can set separate 

lines for hidden/visible lines.

Use Fills on Doors/Windows

To apply any fills to the door/window, check the Use Fills box to enable all fill parameters. If Use Fills is off, 

the opening display will not use any fills on any of its components.

Override GDL Object Attributes of Doors/Windows

Typically, you will define the 2D attributes (line type, pen, fill) for each component of the Window/Door on the 

Floor Plan using the Floor Plan and Section tab page of the Custom Settings panel, described above.
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However, you may wish to override these, using the simplified settings of the Floor Plan and Section Panel of 

Door/Window Settings.

Set the attributes for cut, uncut and overhead lines and pens as needed on the Floor Plan and Section panel 

of Door/Window Settings (or the Info Box).

For these settings to take effect, make sure that the applicable Override Object’s /Line Types/Pens/Attributes 

checkbox(es) are on. Otherwise, the Door/Window will be displayed with its GDL Object attributes.

Note: For some doors/windows, no relevant GDL parameter is defined. In this case, the object will be 

displayed using the attributes defined in the Floor Plan and Section panel (regardless of the Override 

checkboxes).
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Minimal Space

The following is a description of the Minimal Space tab page of the Custom Settings panel for a “Hinged 

Door”, with sidelight and transom, from the INT ARCHICAD Library.

Use these controls to define the minimal space requirements for clearance on either side of this door.

As a drafting aid, you can then turn on a Model View Option to display the minimal space clearances (for both 

doors and objects) on the Floor Plan.

To view Minimal Space limits on the Floor Plan for all doors and objects in the project which have a defined 

minimal space parameter:

1. Go to Document > Model View > Model View Options

2. Open the Miscellaneous Settings for Library Parts panel.

3. Check the Minimal Space of Door and Object box.
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Use the controls below the checkbox to define pens, line type and fills for the display of minimal space.

For general information on the Custom Settings panel, see Where to Set Door/Window Parameters.
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Custom Corner (for Windows)

The following is a description of the Custom Corner page of the Custom Settings panel for a Basic Window, 

from the INT ARCHICAD Library.

Use this tab page to define how two windows which meet at a corner should connect to each other. Set the 

options for both connecting windows.

The corner connection type can be one of three kinds:

• Frame: join the Frames directly to each other;

• Corner Column: insert a column element which each window frame will abut

• Glass: insert a glass element between the frames.

Set the angle at which the two walls meet.

If the two walls that form the corner are of differing thicknesses, check Different Connecting Wall Thickness 

so you can enter the thickness values for each wall.
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Extra Topics

Functions in this section are not available in all markets.

Bluebeam Connection

Bluebeam Connection is a PDF-based collaboration and markup solution. This add-on provides an easy 

connection between ARCHICAD (version 21 and later) and Bluebeam Revu (any version).

Recommended Workflow

From ARCHICAD, save or publish 2D views or layouts as PDFs, then send the PDFs to consultants for 

markup in the Bluebeam Revu application. 

Re-import the PDF markups to ARCHICAD using Bluebeam Connection. The Bluebeam Issues will appear in 

the right places, on the original 2D source views or Layouts in ARCHICAD. Manage the Issues, using 

ARCHICAD’s Issue Management functions.

Repeat the process as needed. Each time you reimport Issues from a PDF, you can decide whether to skip or 

include duplicate or modified Issues from earlier rounds.

Install Bluebeam Connection

Download the Bluebeam Add-on from http://www.graphisoft.com/downloads/addons/

Note: For the USA version only, the Add-on is included in ARCHICAD (version 21 Update series 5000 

and later). All other language versions must download the add-on separately, using the link shown above.

Bluebeam Connection Palette

The Bluebeam Connection Palette contains three commands used in the Bluebeam Connection workflow. 

Use these commands to save ARCHICAD view(s) in PDF format, and to import PDF markups to ARCHICAD.

Note: These commands are also available from the Publisher, the File menu and Issue Organizer. 

However, if you are using the Bluebeam workflow, this palette conveniently groups these commands for 

you.

Open the palette using one of these commands:

• File > Interoperability > Bluebeam Connection

• Window > Palettes > Bluebeam Connection
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Publish ARCHICAD View(s) for Bluebeam

From the Bluebeam Connection palette, use one of these two commands:

• Save as PDF

• Publish PDF

to publish one or more ARCHICAD views in PDF format, optimized for markup in Bluebeam Revu.

In particular, the published PDF will include Zone polygons from the ARCHICAD Floor Plan view, which can 

then be annotated in Bluebeam Revu.

Both commands are described below.

Save Single ARCHICAD View in PDF Format

1. From the Bluebeam Connection palette, click Save as PDF to save the current view in PDF format. 

2. Forward the PDF for markup in Bluebeam Revu.

Bluebeam Connection Palette Bluebeam Connection Palette - Docked
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Publish PDF Set 

To publish an entire Publisher Set in PDF format, for use in Bluebeam Revu:

1. From the Bluebeam Connection palette, click Publish PDF Documentation.

2. The Publish PDF dialog appears.

3. From the Set to publish drop-down, choose a Publisher Set.

– You must choose a Publisher Set in which all items are in PDF format. If the set you choose includes 

items in other formats, the Publish button is grey and you cannot continue. 

- In this case, click Edit Set to open the Organizer, where you can set up a new Publisher Set and/or 

redefine Publisher Set items in PDF format. 

4. Click Publish.

5. Forward the resulting PDF for markup in Bluebeam Revu.

Import Issues to ARCHICAD

Once the PDF has been marked up in Bluebeam Revu, follow these steps in ARCHICAD to import the Issues:

1. From the Bluebeam Connection Palette: click Import Issues.

2. In the appearing Import Issues dialog box, set the File Type as PDF.

3. Browse for and select the marked up PDF file.
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4. Click Options.

The Issue Import Options dialog box opens:

Issue Import Options

In this dialog, define how the issues imported from Bluebeam should appear in ARCHICAD.

Issue Thread

Choose an option for how the imported Issues should appear in Issue Organizer.

• Start New Issue Thread: The imported Issues will constitute their own thread. (In the Issue Organizer, 

you can sort entries by thread.)

• Create Response to Selected Issue: This option is available if an Issue is currently open in Issue 

Manager. Choose this to list the imported Issues underneath the currently active Issue, as sub-Issues.

Tip: To create a separate “category” for the imported Issues, first create a new Issue in ARCHICAD, and 

give it a name (e.g. “Imported Issues from PDF”.) With this new entry selected, import the PDF Issues, 

and use the “Create Response to…” option. The imported Issues will be listed under this Issues (use Sort 

by: Thread).
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Attribute Conversion Options

Choose how to convert the fills, line types, fonts and layers of the Issues you are importing. 

Fills

• Use Project’s Fill Types: No new Fill Types will be imported from the PDF. Any imported fills that have no 

counterpart in the project will be transformed into solid fills.

• Import as Symbol Fill from PDF: A new vectorial fill attribute will be created in the project and used for 

imported fills. (For example: “60% PDF Solid Fill”)

• Import as Image Fill from PDF: A new image fill attribute will be created for any fills, among the drawing 

primitives, which have no counterpart among the project’s attributes.

Note: If an image fill is generated, then this file is added to the project’s Embedded Library. If you are 

working in a Teamwork project, you must have the needed access right: Library Parts – Create.

Line Types
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• Use Project’s Line Types: No new Line Types will be imported. Issues are displayed using similar, 

existing ARCHICAD line types (e.g. solid, dashed, dotted). If a corresponding Line Type does not exist in 

the ARCHICAD project, a solid line is used.

• Override with uniform Line Type: Choose one of the project’s Line Types. Imported Issues will be 

displayed using this Line Type.

• Import from PDF: Line Types of Issues are imported and added to the ARCHICAD project.

Text Font

• Override with uniform Font: Choose one of the project’s font types to display text items on imported 

Issues.

• Use available Fonts: Imported Issue texts are displayed using similar fonts available in the ARCHICAD 

project.

Layer of Issues

• Single Layer from Project: Choose one of the project’s Layers. Imported Issues will be placed on this 

Layer.
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• Import embedded Layers from PDF: Issues will be placed on layers corresponding to their embedded 

layer assignment (if any) in the PDF source. Those embedded layers will be added to your ARCHICAD 

project. 

After setting Issue Import Options, click OK to return to the Import Issues dialog.

Import Issues Open File

1. From the Import Issues dialog, select the Bluebeam file to import. Click Open.

2. The Select Issues to Import dialog appears: 

3. Select the source documents in the PDF from which to import the Issues.

4. Filter the Issues as needed:

– Skip duplicate Issues: Duplicate Issues have already been imported to ARCHICAD, and they have 

not changed in the PDF since then. Check this to skip importing these duplicate Issues.

– Skip modified Issues. Modified Issues have already been imported to ARCHICAD, but they were 

later modified in the PDF. Check this to skip importing these Issues.

– Skip unidentified Issues: Some markup applications do not assign unique IDs to the Issues. Thus, 

these Issues cannot be identified as either new, duplicate or modified. (This is not a problem in the 

Bluebeam Revu workflow.) Check this to skip importing these Issues. 

5. Click Import. An Info dialog appears:

6. Click Open Report to see a summary of Issues that have been added to the original ARCHICAD views, or 

click OK to skip the report.

The new Issues are also listed in Issue Organizer.

7. Navigate to the source ARCHICAD views or Layouts to handle the imported Issues. 
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PARAM-O Reference Guide

PARAM-O is a node-based environment to create parametric Archicad objects. You can design your objects in 

a graphical interface, and then PARAM-O saves it as a regular Archicad object in the embedded library. 

The PARAM-O scripts are stored as a section of the library part. The created objects will work in every 

Archicad - even if PARAM-O is not installed.

Note: PARAM-O is a Technology Preview feature for ARCHICAD 24. Technology Preview features 

provide early access to upcoming product innovations, enabling users to test functionality and provide 

feedback during the development process. Technology Preview features are not fully supported, may not 

be functionally complete, and are not suitable for deployment in production. 

Installation and Update

Getting Started

PARAM-O Manager

PARAM-O Editor

Creating an Object

Making an Object Parametric

For details on each node type, see:

PARAM-O Node Documentation
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Installation and Update

Go to the PARAM-O webpage at https://www.graphisoft.com/param-o.

You have two options for installing PARAM-O. 

Copy the apx file to the Add-Ons folder

Copy the apx file to your installed Archicad's "Add-Ons" folder. By default, Archicad is installed in the 

"Program Files" folder. After you copy the file, restart Archicad. PARAM-O will load automatically. 

Load apx from a specific location

Place the apx file to any location in your computer. Start Archicad, then open Add-On Manager from the 

"Options/Add-On Manager" menu. In Add-On Manager, find the "Edit List of Available Add-Ons" section and 

click "Add". Choose the apx file and close Add-On Manager. Now PARAM-O is loaded. 

Update the previous installation

To make the new version work, you must always remove the previously installed PARAM-O. If you placed it 

the previous version in the Add-Ons folder, then you have to delete it. If you added it with the Add-On 

Manager, you have to unload it. 
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Getting Started

PARAM-O registers three menu commands in Archicad's menu structure. You can find these commands in 

the "File/Libraries and Objects" submenu: 

• PARAM-O Manager: Opens the manager dialog, where you can manage your existing objects.

• New PARAM-O Object: Opens the editor dialog, where you can create a new object without opening the 

manager dialog.

• Edit Selected PARAM-O Object: Opens the editor dialog for the selected library part.

o
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PARAM-O Manager

Use PARAM-O Manager to create and manage your objects. 

• Create new objects or edit existing ones.

• Duplicate, rename or delete an existing object.

• Export/Import objects to/from a file on your computer.

Please note that if you delete an object from PARAM-O Manager, it will also be deleted from the embedded 

library. Renaming an object means that the old object will be deleted and a new one will be created. 

Teamwork

To use any of the functions, you must have the access right to create/modify/delete library parts in the 

embedded library. If you don't have these rights, you will get an error message. 
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PARAM-O Editor

PARAM-O Editor is the place where you create or modify your scripts. 

Parts of the editor dialog: 

• Node Tree

• Editor Canvas

• Model Preview

Node Tree

On the left side of the editor, you can find the available nodes. You can create a new node by double-clicking 

on it or by dragging and dropping it to the editor canvas. 

Editor Canvas

The canvas is the main part of the editor. Here you can edit your script by connecting nodes and setting node 

parameters. 

Model Preview

On the right side of the editor, you see the object preview. Please note that the preview is not exactly the 

same as what you will see in Archicad. Here are some limitations: 

• No texture handling. Every object appears with the base color of the surface.

• No edge rendering. You can set the pen color, but the edges won't be visible in the preview.
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• Limited transparency handling. You can see transparent surfaces in the preview, but Archicad has a much 

better transparency handling method.

You can modify the grid visibility and settings from the preview's context menu. 

Automatic and Manual Preview

At the bottom-left corner of the editor, you can switch the preview mode between automatic and manual. In 

automatic mode, the preview is updated if anything changes in the editor. But with large models, updating the 

preview may be time-consuming. In this case, you can switch to manual mode and rebuild the model only 

when needed, using the Update button. 

Unit handling

Currently, every number value is in meters. If you use the Length node, then the parameter will appear in 

Archicad taking the working unit settings into account, but you still have to think in meters during editing. 

Hotkeys

You can use the following hotkeys in the editor: 

• Ctrl+A: Select all nodes

• Ctrl+C: Copy the selected nodes to the clipboard

• Ctrl+V: Paste nodes from the clipboard

• Ctrl+Z: Undo the last modification

• Ctrl+Y: Redo the last modification

• Ctrl+T: Open settings dialog for selected nodes

• Ctrl+G: Group selected nodes

• Ctrl+B: Rebuild the preview (in case of manual rebuild mode)
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Creating an Object

Let's see an example. To create a simple block object, double-click on the Block node in the editor. The new 

node appears on the canvas, and the preview is updated automatically. Set the block's default parameters 

from the node's context menu. 

After clicking OK, give your object a name. The name should be unique among all library objects. After you 

define the name, the object will be created in the embedded library, in the PARAM-O folder. It is also set as 

the default for the Object Tool. 
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Now you can use your object in Archicad like any other library object. The 2D representation of the object will 

be the 2D projection of its 3D model. 

You are probably wondering why the object is green by default. This color comes from the Object Tool's 

default settings. If no surface is specified, we use the object's default pen to generate the surface. 
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Making an Object Parametric

To make an object parametric, you have to use an input node. For example, you can create a Length node 

and connect it to the Size X input of the Block node. 

Now the value can be set by modifying the value of the Length node. To make an object parameter from the 

Length node, open the settings dialog and set the Create Parameter value to true. You can also set a name 

for this parameter. This name will be visible in the Object Settings Dialog. 
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You can use as many parameters as you wish for your objects. 

Using Standard Parameters

There are some special parameters in Archicad: Dimension 1, Dimension 2 and Height. Set the value of these 

parameters in the Preview and Positioning page of the Object Settings Dialog. The real size of a well-

designed library object is always synchronized with these values. 

To use the value of these parameters, use the corresponding nodes from the Parameters group in the editor. 

The default value of these nodes can be set below the Node Tree. 

Available Nodes

See PARAM-O Node Documentation for details on all node types. 
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PARAM-O Node Documentation

Parameters

Shapes

Inputs

List Inputs

Attribute Inputs

Point Inputs

Transformations

Shape Transformations

Maths

Trigonometry

Solid Operations

Extras
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Parameters

Dimension 1

Dimension 2 

Height
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Dimension 1

This node outputs the standard Dimension 1 parameter of a GDL object. You can modify this value in 

ARCHICAD on the Preview and Positioning tab page of the object's settings dialog. During editing you can set 

the default value in the bottom left corner of the editor.

Outputs

Name Type Description

Variable Number The value of the parameter.
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Dimension 2

This node outputs the standard Dimension 2 parameter of a GDL object. You can modify this value in 

ARCHICAD on the Preview and Positioning tab page of the object's settings dialog. During editing you can set 

the default value in the bottom left corner of the editor.

Outputs

Name Type Description

Variable Number The value of the parameter.
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Height

This node outputs the standard Height parameter of a GDL object. You can modify this value in ARCHICAD 

on the Preview and Positioning tab page of the object's settings dialog. During editing you can set the default 

value in the bottom left corner of the editor.

Outputs

Name Type Description

Variable Number The value of the parameter.
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Shapes

Block 

Cylinder 

Cone 

Sphere 

Ellipsoid 

Elbow 

Wedge 

Regular Prism 

Profile Extrude
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Block

Creates a block.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Size X Number X size of the block.

Size Y Number Y size of the block.

Size Z Number Z size of the block.

Name Type Description

Shape Shape The resulting shape.
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Cylinder

Creates a cylinder.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Height Number Height of the cylinder.

Radius Number Radius of the cylinder.

Name Type Description

Shape Shape The resulting shape.
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Cone

Creates a cone.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Height Number Height of the cone.

Bottom Radius Number Bottom radius of the cone.

Top Radius Number Bottom radius of the cone.

Name Type Description

Shape Shape The resulting shape.
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Sphere

Creates a sphere.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Radius Number The radius of the sphere.

Name Type Description

Shape Shape The resulting shape.
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Ellipsoid

Creates an ellipsoid.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Height Number Height of the ellipsoid.

Radius Number Radius of the ellipsoid.

Name Type Description

Shape Shape The resulting shape.
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Elbow

Creates an elbow (curved tube).

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Radius 1 Number Radius of the curve of the elbow.

Radius 2 Number Radius of the tube of the elbow.

Alpha Number Curve angle of the elbow in degrees.

Name Type Description

Shape Shape The resulting shape.
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Wedge

Creates a wedge (right-angle triangle based prism).

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Size X Number X size of the wedge.

Size Y Number Y size of the wedge.

Height Number Height of the wedge.

Name Type Description

Shape Shape The resulting shape.
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Regular Prism

Creates a prism with a regular base polygon.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Count Number Vertex count of the base polygon.

Height Number Height of the prism.

Radius Number Radius of the prism.

Name Type Description

Shape Shape The resulting shape.
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Profile Extrude

Creates an extruded shape based on a profile attribute. The base polygon of the extrude will be aligned to the 

origin regardless of the profile's original position.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Profile Profile The profile to use.

Height Number Height of the extrusion.

End Surface Surface Top and bottom surface of the shape.

Name Type Description

Shape Shape The resulting shape.

X Size Number X size of the profile's default bounding box.

Y Size Number Y size of the profile's default bounding box.
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Inputs

Boolean 

Integer 

Number 

Length 

Angle 

Random Number 

Global Value
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Boolean

Defines a boolean variable. You can create a GDL object parameter from this variable in the node settings 

dialog.

Outputs

Name Type Description

Variable Boolean The resulting variable.
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Integer

Defines an integer variable. You can create a GDL object parameter from this variable in the node settings 

dialog.

Outputs

Name Type Description

Variable Integer The resulting variable.
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Number

Defines a number variable. You can create a GDL object parameter from this variable in the node settings 

dialog.

Outputs

Name Type Description

Variable Number The resulting variable.
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Length

Defines a length variable. You can create a GDL object parameter from this variable in the node settings 

dialog. Works the same as the Number node, but the created GDL parameter will have length type.

Outputs

Name Type Description

Variable Number The resulting variable.
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Angle

Defines an angle variable. You can create a GDL object parameter from this variable in the node settings 

dialog. Works the same as the Number node, but the created GDL parameter will have angle type.

Outputs

Name Type Description

Variable Number The resulting variable.
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Random Number

Defines a random number variable.

Inputs

Outputs

Name Type Description

Min Number The minimum value of the random range.

Max Number The maximum value of the random range.

Name Type Description

Variable Number The resulting variable.
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Global Value

Defines a variable based on a GDL global value. 

See the GDL Reference Guide or more information about the meaning of these values.

Outputs

Name Type Description

Variable Various The resulting variable.
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List Inputs

Integer Series 

Number Series 

Random Series 

Number Distribution
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Integer Series

Defines a series of integer variables. For example: [2, 4, 6, 8, 10].

Inputs

Outputs

Name Type Description

Name Type Description

Start Integer The first element of the series.

Step Integer The difference between elements in the series.

Count Integer The number of elements in the series.

Name Type Description

Variable Integer List The resulting variable.
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Number Series

Defines a series of number variables. For example: [2.0, 4.0, 6.0, 8.0, 10.0].

Inputs

Outputs

Name Type Description

Start Number The first element of the series.

Step Number The difference between elements in the series.

Count Integer The number of elements in the series.

Name Type Description

Variable Number List The resulting variable.
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Random Series

Defines a series of random number variables.

Inputs

Outputs

Name Type Description

Min Number The minimum value of the random range.

Max Number The maximum value of the random range.

Count Integer The number of elements in the series.

Name Type Description

Variable Number The resulting variable.
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Number Distribution

Defines a series of number variables. The numbers are distributed equally over the given range. For example 

if you generate 3 numbers between 0 and 10 the result will be [0.0, 5.0, 10.0].

Inputs

Outputs

Name Type Description

Start Number The first element of the series.

End Number The last element of the series.

Count Integer The number of elements in the series.

Name Type Description

Variable Number List The resulting variable.
ARCHICAD 24 Reference Guide 3973



PARAM-O Node Documentation PARAM-O Reference Guide
Attribute Inputs

Pen 

Surface 

Profile
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Pen

Defines a pen variable. You can create a GDL object parameter from this variable in the node settings dialog.

Outputs

Name Type Description

Variable Pen The resulting variable.
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Surface

Defines a surface variable. You can create a GDL object parameter from this variable in the node settings 

dialog.

Outputs

Name Type Description

Variable Surface The resulting variable.
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Profile

Defines a profile variable. You can create a GDL object parameter from this variable in the node settings 

dialog.

Outputs

Name Type Description

Variable Profile The resulting variable.

X Size Number X size of the profile's default bounding box.

Y Size Number Y size of the profile's default bounding box.
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Point Inputs

Point 

Vector 

Deconstruct Point 

Deconstruct Vector 

Line Points 

Line Points 

Grid Points 

Arc Points
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Point

Defines a point variable.

Inputs

Outputs

Name Type Description

X Number The X coordinate of the point.

Y Number The Y coordinate of the point.

Z Number The Z coordinate of the point.

Name Type Description

Variable Point The resulting variable.
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Vector

Defines a vector variable.

Inputs

Outputs

Name Type Description

X Number The X component of the vector.

Y Number The Y component of the vector.

Z Number The Z component of the vector.

Name Type Description

Variable Vector The resulting variable.
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Deconstruct Point

Defines three variables based on the input point's coordinates.

Inputs

Outputs

Name Type Description

Point Point The point.

Name Type Description

X Number The X coordinate of the point.

Y Number The Y coordinate of the point.

Z Number The Z coordinate of the point.
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Deconstruct Vector

Defines three variables based on the input vector's components.

Inputs

Outputs

Name Type Description

Point Vector The point.

Name Type Description

X Number The X component of the vector.

Y Number The Y component of the vector.

Z Number The Z component of the vector.
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Line Points

Defines a series of points along a line.

Inputs

Outputs

Name Type Description

From X Number The X coordinate of the start point.

From Y Number The Y coordinate of the start point.

From Z Number The Z coordinate of the start point.

To X Number The X coordinate of the end point.

To Y Number The Y coordinate of the end point.

To Z Number The Z coordinate of the end point.

Count Integer The number of points.

Name Type Description

Point X Number List The X coordinates of the result.

Point Y Number List The Y coordinates of the result.

Point Z Number List The Z coordinates of the result.
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Line Points

Defines a series of points along a line.

Inputs

Outputs

Name Type Description

From X Number The X coordinate of the start point.

From Y Number The Y coordinate of the start point.

From Z Number The Z coordinate of the start point.

To X Number The X coordinate of the end point.

To Y Number The Y coordinate of the end point.

To Z Number The Z coordinate of the end point.

Count Integer The number of points.

Name Type Description

Point X Number List The X coordinates of the result.

Point Y Number List The Y coordinates of the result.

Point Z Number List The Z coordinates of the result.
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Grid Points

Defines a series of points along a 2D grid.

Inputs

Outputs

Name Type Description

From X Number The X coordinate of the start point.

From Y Number The Y coordinate of the start point.

To X Number The X coordinate of the end point.

To Y Number The Y coordinate of the end point.

Count X Integer The number of points along the X direction.

Count Y Integer The number of points along the Y direction.

Name Type Description

Point X Number List The X coordinates of the result.

Point Y Number List The Y coordinates of the result.
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Arc Points

Defines a series of points along an arc.

Inputs

Outputs

Name Type Description

Start Angle Number The start angle of the arc.

End Angle Number The end angle of the arc.

Radius Number The radius of the arc.

Count Integer The number of points.

Name Type Description

Point X Number List The X coordinates of the result.

Point Y Number List The Y coordinates of the result.
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Transformations

Move 

Move By Vector 

Rotation X

Rotation Y 

Rotation Z 

Scale 

Combination
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Move

Defines a move transformation.

Inputs

Outputs

Name Type Description

Offset X Number Offset along the X axis.

Offset Y Number Offset along the Y axis.

Offset Z Number Offset along the Z axis.

Name Type Description

Variable Transformation The resulting variable.
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Move By Vector

Defines a move transformation.

Inputs

Outputs

Name Type Description

Offset Point/Vector The offset of move.

Name Type Description

Variable Transformation The resulting variable.
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Rotation X

Defines a rotation transformation around the X axis.

Inputs

Outputs

Name Type Description

Angle Number Rotation angle in degrees.

Name Type Description

Variable Transformation The resulting variable.
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Rotation Y

Defines a rotation transformation around the Y axis.

Inputs

Outputs

Name Type Description

Angle Number Rotation angle in degrees.

Name Type Description

Variable Transformation The resulting variable.
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Rotation Z

Defines a rotation transformation around the Z axis.

Inputs

Outputs

Name Type Description

Angle Number Rotation angle in degrees.

Name Type Description

Variable Transformation The resulting variable.
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Scale

Defines a scale transformation.

Inputs

Outputs

Name Type Description

Scale X Number Scale along the X axis.

Scale Y Number Scale along the Y axis.

Scale Z Number Scale along the Z axis.

Name Type Description

Variable Transformation The resulting variable.
ARCHICAD 24 Reference Guide 3993



PARAM-O Node Documentation PARAM-O Reference Guide
Combination

Defines a combination of some transformations. The result is a transformation with all of the given 

transformations applied in the same order of the inputs.

Inputs

Outputs

Name Type Description

Transformation 1 Transformation Transformation to combine.

Transformation 2 Transformation Transformation to combine.

Transformation 3 Transformation Transformation to combine.

Transformation 4 Transformation Transformation to combine.

Name Type Description

Variable Transformation The resulting variable.
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Shape Transformations

Transform Shape 

Move Shape 

Move Shape By Vector 

Rotate Shape X 

Rotate Shape Y 

Rotate Shape Z 

Scale Shape
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Transform Shape

Transforms a shape with the given transformation matrix.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Transformation Transformation The transformation to use.

Name Type Description

Shape Shape The resulting shape.
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Move Shape

Moves a shape.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Offset X Number Offset along the X axis.

Offset Y Number Offset along the Y axis.

Offset Z Number Offset along the Z axis.

Name Type Description

Shape Shape The resulting shape.
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Move Shape By Vector

Moves a shape.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Offset Point/Vector The offset of move.

Name Type Description

Shape Shape The resulting shape.
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Rotate Shape X

Rotates a shape around the X axis.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Angle Number Rotation angle in degrees.

Name Type Description

Shape Shape The resulting shape.
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Rotate Shape Y

Rotates a shape around the Y axis.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Angle Number Rotation angle in degrees.

Name Type Description

Shape Shape The resulting shape.
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Rotate Shape Z

Rotates a shape around the Z axis.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Angle Number Rotation angle in degrees.

Name Type Description

Shape Shape The resulting shape.
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Scale Shape

Scales a shape.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Shape Shape The shape to transform.

Scale X Number Scale along the X axis.

Scale Y Number Scale along the Y axis.

Scale Z Number Scale along the Z axis.

Name Type Description

Shape Shape The resulting shape.
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Maths

Addition 

Subtraction 

Multiplication 

Division 

Lower 

Lower Or Equal 

Greater 

Greater Or Equal 

Equal 

Not Equal 

Expression 

Abs 

Floor 

Ceil 

Sqrt 

Negative 

Min 

Max
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Addition

Adds two values.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Number The resulting variable.
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Subtraction

Subtracts two values.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Number The resulting variable.
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Multiplication

Multiplies two values.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Number The resulting variable.
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Division

Divides two values.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Number The resulting variable.
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Lower

Returns true if the first value is lower than the second value, false otherwise.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Boolean The resulting variable.
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Lower Or Equal

Returns true if the first value is lower than or equal to the second value, false otherwise.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Boolean The resulting variable.
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Greater

Returns true if the first value is greater than the second value, false otherwise.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Boolean The resulting variable.
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Greater Or Equal

Returns true if the first value is greater than or equal to the second value, false otherwise.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Boolean The resulting variable.
ARCHICAD 24 Reference Guide 4011



PARAM-O Node Documentation PARAM-O Reference Guide
Equal

Returns true if the first value is equal to the second value, false otherwise.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Boolean The resulting variable.
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Not Equal

Returns true if the first value is not equal to the second value, false otherwise.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Boolean The resulting variable.
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Expression

Calculates a mathematical expression. You can use any GDL operators or functions in the expression. You 

have to reference the parameters with a $ sign prefix.

Inputs

Outputs

Name Type Description

A Number Refer to it in expression with $a.

B Number Refer to it in expression with $b.

C Number Refer to it in expression with $c.

D Number Refer to it in expression with $d.

Name Type Description

Variable Number The resulting variable.
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Abs

Returns the absolute value of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Number The resulting variable.
ARCHICAD 24 Reference Guide 4015



PARAM-O Node Documentation PARAM-O Reference Guide
Floor

Returns the integral part of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Integer The resulting variable.
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Ceil

Returns the smallest integral value that is not smaller than the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Integer The resulting variable.
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Sqrt

Returns the square root of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Number The resulting variable.
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Negative

Returns the opposite value of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Number The resulting variable.
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Min

Returns the minimum value of the given values.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Number The resulting variable.
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Max

Returns the maximum value of the given values.

Inputs

Outputs

Name Type Description

A Number First value.

B Number Second value.

Name Type Description

Variable Number The resulting variable.
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Trigonometry

Sine 

Cosine 

Tangent 

Arc Sine 

Arc Cosine 

Arc Tangent
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Sine

Returns the sine value of the given value.

Inputs

Outputs

Name Type Description

A Number The value in degrees.

Name Type Description

Variable Number The resulting variable.
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Cosine

Returns the cosine value of the given value.

Inputs

Outputs

Name Type Description

A Number The value in degrees.

Name Type Description

Variable Number The resulting variable.
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Tangent

Returns the tangent value of the given value.

Inputs

Outputs

Name Type Description

A Number The value in degrees.

Name Type Description

Variable Number The resulting variable.
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Arc Sine

Returns the arc sine value of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Number The resulting variable.
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Arc Cosine

Returns the arc cosine value of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Number The resulting variable.
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Arc Tangent

Returns the arc tangent value of the given value.

Inputs

Outputs

Name Type Description

A Number The value.

Name Type Description

Variable Number The resulting variable.
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Solid Operations

Union 

Difference 

Intersection
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Union

Calculates the union of two shapes.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Shape 1 Shape The first shape.

Shape 2 Shape The second shape.

Name Type Description

Shape Shape The resulting shape.
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Difference

Subtracts the second shape from the first.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Shape 1 Shape The first shape.

Shape 2 Shape The second shape.

Name Type Description

Shape Shape The resulting shape.
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Intersection

Calculates the intersection of two shapes.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

Shape 1 Shape The first shape.

Shape 2 Shape The second shape.

Name Type Description

Shape Shape The resulting shape.
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Extras

GDL Object 

GDL Shape 

Viewer
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GDL Object

References an Object from the loaded library. You can select four parameters of the object (A, B, C, D) and 

modify these parameters from the script. You can set the referenced Object and its parameters in the node 

settings dialog.

This is an experimental node, use it at your own risk.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

A Number Value of the selected A parameter.

B Number Value of the selected B parameter.

C Number Value of the selected C parameter.

D Number Value of the selected D parameter.

Name Type Description

Shape Shape The resulting shape.
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GDL Shape

Runs the user defined GDL script snippet and generates a shape. You can use any GDL command here, but 

be careful. You have to reset the GDL stack in every snippet. You have to reference the parameters with a $ 

sign prefix.

This is an experimental node, use it at your own risk.

Inputs

Outputs

Name Type Description

Visible Boolean Defines if the model is visible or not.

Pen Pen Pen color of the edges.

Surface Surface Surface color of the polygons.

Transformation Transformation Transformation of the shape.

A Number Refer to it in the script with $a.

B Number Refer to it in the script with $b.

C Number Refer to it in the script with $c.

D Number Refer to it in the script with $d.

Name Type Description

Shape Shape The resulting shape.
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Viewer

Shows a string representation of the given value.

Inputs

Outputs

Name Type Description

Input Any The value to show.

Name Type Description

Output Any The same value as the input.
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