Solibri Connection Add-on for Archicad 24

EEEEEEEEEEEEEEEEE



GRAPHISOFT®

Visit the GRAPHISOFT website at www.graphisoft.com for local distributor and product availability
information.

Solibri Connection Add-on for Archicad 24
Copyright © 2020 by GRAPHISOFT, all rights reserved. Reproduction, paraphrasing or translation without
express prior written permission is strictly prohibited.
Trademarks

ARCHICAD® is a registered trademark of GRAPHISOFT.
All other trademarks are the property of their respective holders.


https://www.graphisoft.com

Contents

Contents

Introduction 1
Getting Started 2
Connect to Solibri 3
Export Model to Solibri 5
Select Elements in Solibri 7
Get Selection Basket 8
Import Issues from Solibri 10
Break Solibri File Link 11

Solibri Connection Add-on for Archicad 24 1



Introduction

Introduction

The Archicad-Solibri connection add-on provides fast and automated code- and constructability checking. The
updated add-on automatically detects and sends only those elements that are changed in the Archicad model,
resulting in faster round-trip collaboration.

The workflow supports Issue reporting based on BCF 2.1, enabling designers to assign the detected issues or
solve them later on.

This add-on allows fast BIM updates and the use of Solibri while working in a real time design scenario. No
longer do you need to save files and upload back and forth between programs. Simply design, check and
amend as necessary.

New in this version:
* Fully aligned with AC24's new Issue Manager functionality

* Improved info and feedback on Solibri Connection palette

Key Features and Benefits
» |FC-based data exchange:

— Archicad Classifications

— Archicad Properties

— IFC Type Products

— Colors

— Space boundaries

— Junctions, priority-based connections

— Hierarchical elements
» Fast synchronization between the two applications
« Ability to manage the exported content
* Selection of elements in Archicad based on the selection in Solibri
» Selection of elements in Solibri based on the selection in Archicad
« Connection between the applications can be disconnected and re-established
e BCF-based issue import into Archicad
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Getting Started

Getting Started

Install Add-On
1. Before installing the Add-on, make sure that Archicad 24 is installed on your computer.
2. Download the Add-on to your computer.
3. Launch the Setup Wizard.
— On Windows: Double?click on the .exe file to launch the Setup Wizard.

— On MacOS: Double?click on the installer file to launch the Setup Wizard.

After installing, the Add-on will be placed in the following folder:
— On Windows: Program Files\GRAPHISOFT\Archicad 24\Add?0Ons\Solibri Connection
— On MacOS: Applications/GRAPHISOFT/Archicad 24/Add-Ons/Extras

Uninstall Add-On
On Windows: Navigate to Program FilesS\GRAPHISOFT\Archicad 24\Uninstall.SB and click on Uninstall.
On MacOS: Navigate to Applications/GRAPHISOFT/Archicad 24/Uninstall.SB and click on Uninstall.
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Connect to Solibri

Connect to Solibri

1. Open the Solibri Connection palette from
— File > Interoperability > Solibri Connection or
— Window > Palettes

2. Click Start Solibri.

Solibri Connection *

@ Solibriis not running...

Mo connection to Solibri file.

Start Solibri

{CE} Connection Settings...

Ej' Export Settings...
Import All Issues

Select in Solibri

Get Selection Basket
Elements in Basket
Currently Selected:

Mo elements selected

Please note: Solibri must be started from Archicad to enable the communication between the two
applications.

Connection Status
Check the top of the palette for the current status. If needed, click the info button for further details.

Solibri Connection *

@ olibri is running...
Last Updated: No model has been exported yet

Exported View: Mo connection to Solibri file,

Export Translator:
[ Export to solibri

Connected file: Mo connection to Solibri file.

Faort Number: 40550 {CE} Connection Settings...

@ Solibri Office 9.10.8.34 is running... gj- Export Settings...
Import All [ssues
Select in Solibri

Get Selection Basket
Elements in Basket

Currently Selected:

Mo elements selected

Connection Settings

If there is a problem with the connection, click Connection Settings:

e Check if Archicad has found the location of Solibri.app. If not, click Browse and select your Solibri
application.

* The communication between the two application requires a free Connection port. The green dot indicates
that the port is free and ready to use.
If it is red, enter a different port number.
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Connect to Solibri

Solibri Connection
@ Solibri is running...

Mo connection to Solibri file.

| Export to solibri

Eﬁ}} Connection Settings...

| Export Settings...

2] Import All Issues

[Z) Select in Solibri
) Get Selection Basket
Elements in Basket:

Currently Selected:

Mo elements selected

@ Connection Settings

SET CONMNECTION TO SOLIERI

Solibri application location:

Browse...

MProgram Files\Solibri'SOLIBRI\Solibri.exe

Connection port:
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Export Model to Solibri

Export Model to Solibri

In the Solibri Connection palette: Click the Export Settings button.

Select the view for export.

The selected view can either be 2D or 3D. In case of floor plan view, the visible elements on the selected

story will be exported.

Please note: Even if you select a Structural Analytical model view, all of the view’s physical

elements (not the Structural Members) will be exported to Solibri.

VIEW FOR EXPORT
[ 1. story
["5 0. Ground Floor
v [

[} Physical Madel
[ Physical Maodel - Frontal Axonometry

[ Structural Analytical Model with Core
View Properties
Physical Maodel
02 Drafting
Entire Model

oE 0o

02 Drafting

View Settings...

| TRANSLATOR FOR EXPORT

| Exact Geometry Export ~ Options..

® To edit or create Translators, navigate to the IFC
Translator dialog box,

Cancel

3. Select the IFC translator for the Export. (Click Options to see a summary of the IFC Translator’s settings.)

Translators can be managed from File > Interoperability > IFC > IFC Translators.
After you have selected the view and the translator: click OK.
In the Solibri Connection palette: Click Export to Solibri.

Solibri Connection *

@ Solibri is running...

Mo connection to Solibri file.

% Export to Solibri

@ Connection Settings...

B' Export Settings...
Import All [ssues

Select in Solibri
Get Selection Basket
Elements in Basket

Currently Selected:

Mo elements selected

6. The model is exported.
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Export Model to Solibri

Solibri Office - OfficeBuilding

(& MODEL TREE REEBW 0050 @30
v &) Untitled "
v s Defautt Site
% Solibri Building

¥ K Ground floor
» | Column
Deor
Grid
Opening
Roof
Sanitary Terminal
Slab
Space

Stair
v

rY YUY YT YooY ovow

@ INFO < v > v S @aEn
9 Solibri Building

Identification  Location Quantities Relations Classification Hyperlinks

Property Value
Model Untitled ~
Discipline Architectural

Name Solibri Building

Description

DC Cwm~ Om~ Hig o -P-P ARQAQ K- S

Search

Selected: 0

7. Make sure to save the model in Solibri: the next time you open it, the Solibri model can resume its

connection to the Archicad model.

Export multiple models into one Solibri

Users can connect multiple Archicad instances with one Solibri. Once the connection between the Archicad

and Solibri is established, the second Archicad can be connected as well.

1. Launch the second Archicad.

2. From the Solibri Connection palette, click on Export to Solibri.

3. A Warning appears: another Archicad model is already connected to the currently loaded Solibri model.

@ Warning! *
The currently loaded Solibri model is not
! originated from the current ARCHICAD model.

Do you want to append StructuralColumns model

to the currently loaded 7
Mo Append

4. To add a second Archicad model: Click Append.

Note: In this situation, Connection Settings indicates that Solibri is using the port to connect to another
Archicad. The same connection is used for the second Archicad model, too.

This model will appear in Solibri next to the first one.
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Select Elements in Solibri

Select Elements in Solibri

Selected elements in Archicad can be selected in Solibri as well.

1. Select elements in Archicad.
2. Click the Select in Solibri command on Solibri Connection palette.

Solibri Connection b4

(i) Last updated: Today, 12:33 ..

Connected to:
OfficeBuilding.smc

@ Update in Saolibri

|{§} Connection Settings...

@ Export Settings...

|_—al Impart A1l [ssues | = |
(5] Select in Solibri I

) Get Selection Basket |

| Elements in Basket:

Solibri's Selection Basket is filled with the selected elements from Archicad.
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Get Selection Basket

Get Selection Basket

When you find components that need to be fixed in Solibri, use Get Selection Basket to easily select them in
Archicad.
1. In Solibri, add elements to the Selection Basket.

D] |

[ SELECTION BASKET *
Mo Selection Sets ¥ o, & E?. E 'E% tﬁﬁ (B E] E] i

v Slab
v Solid Fill 300

#* Slab.0.1

T ——

Selected: 1

2. In Archicad, click Get Selection Basket.
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Get Selection Basket

Solibri Connection *

(i) Last updated: Today, 12:33 ..

Connected to:
OfficeBuilding.smc

T

|@) Update in Solibri |

|{§} Connection Settings... |

@ Export Settings... |
|_—El Import &ll Issues |- |

T

(5] Select in Solibri |

) Get Selection Basket |

Elements in Basket: 1
Currently Selected: il
Successfully selected all @

All components in the Selection Basket will be selected in Archicad, provided that they are visible in the
current view.

The Solibri palette gives you feedback on

* the number of elements in the Selection Basket

the number of elements currently selected in Archicad

whether any elements are not visible in Archicad, and therefore cannot be selected.
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Import Issues from Solibri

Import Issues from Solibri

Issues created in Solibri can be imported to Archicad’s Issue Organizer, where you can handle them as

needed.
You can import all issues, or limit the import to issues that are either selected or marked in Solibri.

Solibri Connection *

@ Last updated: Today, 12:33 ...

Connected to:
OfficeBuilding.smc

() Update in Solibri
{E:'} Connection Settings...

Ej‘ Export Settings...

| Impart &1l [ssues I 7
@] z Impaort Selected lssues
}:@_I Import Marked Issues

@ 9 _@l Impart &1l [ssues
Elements in Basket: 1

Currently Selected: 1

Successfully selected all

Click one of the following commands from the pop-up:
* Import Selected Issues
* Import Marked Issues

e Import All Issues

= 1SSUES EE Mewlssue P H

P Title Tracking ID Status @

13 Open A
14 Open
3/5lab 15 Open
5 Beam 4 Open
11 Column too close to furniture 12 Open

“Selected” and “Marked” (flagged) Issues in Solibri

The imported Issues are now added to Archicad’s Issue Organizer.
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Break Solibri File Link

Break Solibri File Link

This is an extra function that breaks the current connection between Archicad and Solibri.

This command is not available by default. To use it, first you must add it to an Archicad menu:

1. Goto Options > Work Environment > Menus

2. Choose the menu where you want to place the command (here, the File > Interoperability menu)
3. Search for the command: Break Solibri file link

4. Add it to the menu.

@ Work Environment ? *
Apply Schemes of Profile: L3 Command Layout Schemes: Custom Apply Scheme: L3
Waork Environment Profiles v CUSTOMIZE MENUS
[F2, User Preference Schemes Commands and Menus: eeateor Edit Menu:
[ETT Company Standards Schemes
F'ﬁ Shortcut Schemes |Solibri | * I File | Interoperability I v|
|

%\E'i] Tool Schemes All commands in alphabetical order V| Menu Options L4 Fa"
[‘[% Workspace Schemes cx Break Solibrifile link olibri Connect BB Merge... 7 A

v |55 Command Layout Schemes Solibri Connection {Solibri Connectio % seeeeeeeeese s
== Solibri Connection... (Solibri Connect ¥ @ IFC k|
Toolbars 5;3 _tl
: SAF z
¢ DFDWS 3
= Classifications and Properties k|
H 3D Studio k|
H b E'n
< > - CIMEMA 4D |;|

Solibri Connection... {Solibri Conn...

Break Solibri file link (Selibri Con...

‘ e / + 9§, Add-On Commands inthe File/Int..
> > Add selected = Remove
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