模型/三维格式(打开)

3D Studio文件(.3ds)

3D文件可以保存为3D Studio格式。所需插件是Archicad包的一部分。

只要您安装了您使用的Archicad语言版本的Doodies插件,3D Studio格式的3D文件,就可以由Archicad打开。

参见小插件。

IFC (.ifc)、IFCXML(.ifcxml)、IFCzip

IFC代表工业基础类。

如要了解更多信息,请参见 以IFC工作。

Rhino (.3dm) - 导入模型或作为对象导入

通过这些指令的其中一个直接从Archicad中打开或合并一个Rhino 3D 模型 文件 (.3dm) :

  • 文件 > 打开
  • 文件>互操作性>合并(来自文件或BIMcloud)

要导入一个Rhino文件作为单个Archicad对象:

  • 文件 > 图库和对象 > 将 Rhino 3DM 文件作为对象导入

    更多信息,参见用Rhino 3D模型工作。

草图大师 (.skp)

要打开新的项目:

  • 使用 文件 > 打开, 查找.skp文件

要添加到一个已打开的项目中:

  • 拖放Sketchup 文件,或
  • 使用 文件> 互操作性 > 合并, 再查找.skp文件。

Sketchup模型将以GDL项目形式保存在嵌入图库中。

见草图大师 导出和导入局限。导出和导入局限。

Google Earth (.kmz)

Google Earth模型按以下方式导入:

  • .kmz 对象成为GDL对象,放置在Archicad图层上
  • .kmz 多边形成为填充,放置在2D草图常规图层上
  • 地点标记成为GDL对象,放置在Archicad图层上
    重要: 确保合并后的Google Earth模型被打开
    • 仅包括一个单一的定位针
    • 使用绝对的方法来定义其属性 (见下文)。

要直接打开 .kmz文件:

  1. 使用文件 > 打开命令
  2. 选择.kmz文件类型打开
  3. 点击设置,打开KMZ导入选项 。
    • 勾选此框导入任何“查看视点”作为相机,如果.kmz文件包含它们的话 。
    • 创建对象的热点:使用这些复选框控制热点在导入模型上出现的位置。

KMZ导入优化

如果导入Google地球模型耗时过长,使用这两个复选框。

  • 把3D几何图形地点标记聚集到单个图库部件中:如果选中此项,为多个几何图形地点标记生成一个单一的GDL对象(而不是多个)。这将减少导入.kmz文件的时间。
  • 显示无填充的3D几何图形地点标记:此项可加速在大型模型中的导航。

标高设置

在Google Earth中,有几种方法导出属性数据,但是Archicad 只支持“绝对高度”法。

如果您的 .kmz文件保护绝对高度设置 ( “夹紧到地面” 或 “相对于地面”),将出现一个信息对话框:您应该使用绝对高度法,从Google Earth中再次导出模型。

见Google Earth:导出和导入局限。

立体平版印刷 (.stl)

使用文件 > 打开命令或文件 > 互操作性 > 合并 直接打开或合并一个.stl文件。一个打开的或合并的STL模型将作为一个变形体打开。

STL文件只能携带3D模型的表面几何图形,被分成三角形,没有任何诸如颜色、表面等附加信息。

该格式常被用于快速成型,3D打印和计算机辅助制造。STL格式有两种表现:ASCII 和二进制

  • ASCII STL

    一个ASCII STL文件按照用于任何文本编辑器应用程序中的可读格式列出含有坐标节点的三角形。

  • 二进制 STL

    在一个二进制STL文件中,数据被压缩但只有用于适当的STL应用程序/机械的数据可读。

    二进制表示法更常用于较小的文件尺寸。

    更多关于 STL格式:http://en.wikipedia.org/wiki/STL_(file_format)http://en.wikipedia.org/wiki/STL_(文件_格式)

    更多关于将模型另存为STL格式的信息,见 立体平版印刷 (.stl)。

打开STL文件

  1. 转到 文件 >打开 > 打开文件
  2. 选择立体平版印刷文件作为填充类型
  3. 浏览STL文件
  4. 点击打开

将STL文件合并到现有模型中

  1. 转到文件 > 互操作性 >合并
  2. 选择立体平版印刷文件作为填充类型
  3. 浏览STL文件
  4. 点击打开

局限

  1. Archicad不检查导出的STL文件的错误,例如,稳定性方面。这些常通过3D打印机完成。
  2. STL文件不能保存模型的比例和单位,这些必须在观察器/打印机中设置。程序经常导出1 m 作为1 STL单位。
  3. 如果导入的几何图形非常复杂,可能会影响性能。这种情况下,您将看到警告对话框。
  4. 注意,如果模型的几何图形过于复杂,可能出现导入失败且没有产生对象。

FBX (.fbx)

在Archicad 中使用以下命令之一打开或合并一个FBX文件(.fbx):

  • 文件> 打开(打开一个新模型)
  • 文件> 互操作性> 合并(将模型添加到正在运行的项目中)
  • 文件> 图库和对象 > 将 FBX 导入为 GDL 对象(导入模型而不放入项目中)。
  • 拖放

在导入时,FBX模型将被保存为GDL对象到嵌入式图库中。

如要了解更多信息,请参见 使用FBX文件。