Paramètres par défaut personnalisés de l’entreprise, pour une installation silencieuse
Cette description détaille comment configurer un dossier par défaut à utiliser avec le paramètre --customEnvironment, utilisé pour personnaliser l'installation silencieuse.
Introduction
En mode sans assistance, l'installation par défaut contient des réglages prédéfinis pour les éléments suivants :
Il est cependant possible que vous préfériez utiliser des options personnalisées (par ex. les préférences de votre société) pour tous les réglages d'usine ou un certain nombre d'entre eux.
Pour cela, vous devez
- Définir vos propres réglages personnalisés préférés dans Archicad
- Configurer un emplacement de dossier “Défauts” dans la hiérarchie décrite dans ce qui suit
- Ajouter vos réglages personnalisés à ce dossier ou à ces sous-dossier, comme décrit dans la suite
- Ajouter le chemin d'accès de ce dossier "Défauts" à la ligne de commande ou au fichier d'options.
Pour en savoir plus, voir Paramètres de ligne commande (Installation personnalisée) et Fichier d'options (Installation personnalisée).
Pas à pas
- Créer une installation simple standard
La première étape consiste à installer du programme de manière standard sur un seul ordinateur client.
Ensuite, définissez votre environnement de travail, votre fichier modèle et/ou vos traducteurs DXF-DWG :
- Personnaliser les réglages d'environnement de travail ;
Utilisez les dialogues dans Options > Environnement de travail pour configurer les réglages d'Environnement de travail standard de votre société. La majorité de ces options se trouvent dans trois dialogues, dans la rubrique Configurations Normes internes : Sécurité et intégrité des données Mises à jour et réseau; et Dossiers spéciaux.
Dès que vous avez défini ces options, enregistrez ces réglages suivant des configurations et enregistrer ces dernières et dans un profil par défaut pour votre société. Pour enregistrer un profil, choisissez Options > Environnement de travail > Profils d'environnement de travail.
- Personnaliser les fichiers modèle
Créez et enregistrez autant de fichiers modèle que vous souhaitez. Les fichiers modèle incluent des liens vers les bibliothèques chargées grâce au Gestionnaire de bibliothèque (par ex. “Bibliothèque de bureau standard”). Les modèles peuvent également inclure vos Préférences de projet (par ex. Unité de dessin, préférences de Calcul de Zone), des Mises en page types, les Informations de projet et même des éléments placés (marques d'altitude, voire des bâtiments complets).
Enregistrez chacun des modèles en utilisant la commande Fichier > Enregistrer Sous... (Fichier Modèle *.tpl).
- Créez un dossier “Défauts”
Créez un dossier “Défauts” temporaire. Assurez-vous que tous les utilisateurs peuvent accéder à son emplacement.
Voir aussi Remarque pour assurez l'accès réseau au dossier “Défauts” (WIN seulement) :.
Dans ce dossier ”Défauts”, créez des sous-dossiers et ajoutez vos personnalisations par défaut comme il est décrit dans les étapes suivantes.
- Créer le sous-dossier "Défauts/Archicad" ou "Défauts/MEP Designer".
Emplacement du dossier Environnement de travail enregistré :
Utilisateurs\<Nom_utilisateur>\AppData\Roaming\Graphisoft\Archicadxx.0.0 yyy (Windows)
~/Bibliothèque/Préférences/Graphisoft/ACxx.0.0 yyy (Mac)
xx étant le numéro de version et yyy étant la version linguistique.
- Créez un dossier "Défauts\Traducteurs DXF-DWG".
Emplacement des dossiers Traducteurs enregistrés :
Utilisateurs\<Nom_utilisateur>\Graphisoft\Traducteurs DXF-DWG xx.0.0. yyy (Windows)
~/Bibliothèque/<Nom_utilisateur>/Graphisoft/Traducteurs DXF-DWG xx.0.0. yyy (Mac)
- Ajoutez le fichier DXF/DWG Translator List.xml au dossier "Défauts".
Emplacement du fichier xml TranslatorList :
Utilisateurs\<Nom_utilisateur>\AppData\Roaming\Graphisoft\Archicadxx.0.0 yyy R1\Dxf-Dwg Préférences\ (Windows)
~/Bibliothèque/Préférences/Graphisoft/ACxx.0.0 yyy v1. (Mac)
- Fournissez le chemin d'accès du dossier “Défauts” comme un paramètre de ligne de commande :
--customEnvironment
Exemple
Windows
Archicad-30-INT-3000-1.0.exe --mode unattended --customEnvironment "D:\...\Defaults"
Remarque pour assurez l'accès réseau au dossier “Défauts” (WIN seulement):
- Si vous accédez à votre dossier ”Défauts” par une connexion réseau, vous devez inclure le chemin d'accès entier dans ce paramètre.
- Si le dossier est placé sur un volume réseau, assurez-vous que le chemin est accessible quelle que soit la permission de l'utilisateur (par ex. Administrateur).
Mac
Archicad\ 30\Installer.app/Contents/MacOS/installbuilder.sh --mode unattended --customEnvironment "userhome/.../Defaults"
