Extensions
Les extensions sont de petites applications qui étendent les fonctionnalités de base du logiciel. De nombreuses extensions sont intégrées sous forme de commandes de menu.
Pour les gérer :
Ouvrir Options > Gestionnaire d’extensions

Utilisez le Gestionnaire d'extensions pour:
- Charger ou décharger les extensions de la liste des extensions disponibles pour la session de programme en cours
- Ajouter ou supprimer des extensions dans la liste des extensions disponibles
- Afficher des informations sur les extensions
Volet Extensions disponibles
Affiche la liste des extensions actuellement disponibles. Les éléments cochés sont chargés pour la session actuelle du programme.
Sélectionnez une extension pour voir sa fonction, l'emplacement du fichier et (si elle est chargée) son emplacement dans le menu.

Charger ou Décharger
- Pour la session en cours : Chargez ou déchargez des extensions en activant ou en désactivant les cases à cocher. Cela active ou désactive temporairement une extension disponible - pour la session Archicad en cours. (Cela ne les supprime pas de la liste)
- Certaines extensions doivent toujours être chargées - leur case à cocher n'est pas modifiable
- Si vous ouvrez un projet qui fait référence à des extensions actuellement déchargées, vous en serez alerté
Ajouter ou supprimer des extensions
Gérer la liste des extensions disponibles en utilisant ajouter ou supprimer. Une fois qu'une extension est ajoutée, elle peut être chargée.
Type et mode d'extension
- Les extensions "Outil" chargées par défaut apparaissent sous la forme de commandes de menu dans le profil d'environnement de travail standard. (Vous pouvez personnaliser leur emplacement comme pour toutes les autres commandes de menu.)
- Les extensions "Outil" chargées manuellement apparaissent dans un menu en fonction de l'emplacement du point d'ancrage de l’extension de ce menu (voir Emplacement de menu des fonctions d'extension)
- Les extensions "Imagerie" fournissent des options de rendu ou d'animation aux commandes du menu Affichage
- La colonne Mode indique si l’extension a été chargée par défaut ou manuellement
Afficher les extensions masquées
Dans le panneau paramètres avancés , cochez la case Afficher les extensions masquées pour les afficher dans le panneau extensions disponibles.

Dossier extension attribué
Cochez la case Utiliser le Dossier Extension pour activer l'emplacement par défaut (le dossier extensions de votre dossier Archicad) ou un autre dossier dédié (cliquez sur Changer pour parcourir un autre dossier).
Emplacement de menu des fonctions d'extension
L'emplacement des extensions dans les menus et dans la barre d'outils est défini par le dialogue de réglages sous Options > Environnement de travail > Menus/Barres d'outils.
Sur la page Personnaliser Menus (Barres d'outils), ajoutez un article “Point d'ancrage des Extensions” à n'importe quel menu (par ex. Fichier) ou barre d'outils. Les Extensions appropriées seront affichées dans cette position de menu/barre d'outils personnalisée.
Si le Point d'ancrage d'Extensions ne fait pas partie de la structure de vos menus, les Extensions ne seront pas affichées dans le menu.
