Caixa de Diálogo Hierarquia de Subtipo (Janela GDL)

Ver também Sobre Subtipos de Objectos GDL.

Esta caixa de diálogo é acessível a partir do botão Seleccionar Subtipo na Janela GDL (Ficheiro > Bibliotecas e Objectos > Novo Objecto)


SelectSubtype.png

ou está disponível na barra de ferramentas Editar Itens de Biblioteca GDL (Janela > Barras de Ferramentas > Editar Itens de Biblioteca GDL). Pode adicioná-la à estrutura de menus, utilizando a caixa de diálogo Ambiente de Trabalho.


EditGDLToolbar00100364.png

Os itens listados pelo nome na Hierarquia de Subtipo possuem códigos de cores.

  • Verde indica que o item pode ser colocado.
  • Preto indica que o item não pode ser colocado individualmente, e só pode ser utilizado como uma referência macro.
  • Tipo Carregado indica que o item é um modelo de subtipo, e é colocável.

Se seleccionar um item na hierarquia, pode verificar as respectivas Propriedades na secção inferior.

Abaixo do campo Nome, o termo GUID refere-se ao código Global Unique Identification do Subtipo seleccionado.

Para uma descrição completa de como o GUID funciona, ver este artigo.

Seleccionar: clique aqui para abrir directamente o item na Janela Principal.

Criar Duplicado: clique neste botão para criar uma cópia do Subtipo seleccionado, com as mesmas propriedades.