Caixa de Diálogo Hierarquia de Subtipo (Janela GDL)

Consulte também Sobre Subtipos de Objetos GDL.

Esta caixa de diálogo é acessível a partir do botão Selecionar Subtipo na Janela GDL (Arquivo > Bibliotecas e Objetos > Novo Objeto)


SelectSubtype.png

ou está disponível na barra de ferramentas Editar Itens da Biblioteca GDL (Janela > Barras de Ferramentas > Editar Itens da Biblioteca GDL). Você pode adicioná-lo à estrutura do seu menu usando a caixa de diálogo Ambiente de Trabalho.


EditGDLToolbar00100364.png

Os itens listados pelo nome na Hierarquia de Subtipo possuem códigos de cores.

  • Verde indica que o item pode ser colocado.
  • Preto indica que o item não pode ser colocado individualmente, e só pode ser utilizado como uma referência macro.
  • Tipo Carregado indica que o item é um modelo de subtipo, e é colocável.

Se você selecionar um item na hierarquia, pode verificar as respectivas Propriedades na seção inferior.

Abaixo do campo Nome, o termo GUID refere-se ao código Global Unique Identification do Subtipo selecionado.

Para uma descrição completa de como funciona o GUID, ver este artigo.

Selecionar: clique aqui para abrir diretamente o item na Janela Principal.

Criar Duplicado: clique neste botão para criar uma cópia do Subtipo selecionado, com as mesmas propriedades.