Pomocné body

Pomocné body jsou dočasné aktivní body, které se objeví na prvcích v určitém intervalu (vámi definovaném), aby vám usnadnily kreslit nové prvky s větší přesností.

Zapnutí pomocných bodů

Použijte jeden z následujících postupů:

  • Pomocné prvky a body můžete zapnout na Standardní nástrojové liště (nabídka Pomocné prvky)
  • Použijte menu Zobrazení > Pomocné body

    SnapPointsCommand.png

Používání pomocných bodů

Najeďte kurzorem nad prvek, jehož pomocné body chcete vidět.

Body se objeví. Jejich počet a umístění závisí na tom, jak jste je nastavili.

Viz Nastavení intervalů pomocných bodů, níže.

Tyto body se chovají jako dočasné aktivní body - lze k nim přichytit kurzor a slouží také jako pomocné referenční body. ( Viz Aktivování pomocných referenčních prvků .) Nové prvky můžete začít kreslit od těchto bodů, nebo je můžete použít pro editaci jiných prvků vzhledem k těmto bodům.

Pomocné body zmizí po 5 sekundách. Nicméně pokud jsou zobrazeny na pomocném referenčním segmentu, zůstanou zobrazeny stejně dlouho jako reference.

Poznámka: Pokud chcete, aby byly pomocné body zobrazeny do vložení prvku nebo změny zobrazení: vypněte volbu “Automaticky skrývat pomocné body” v menu Volby > Pracovní prostředí > Pomocné prvky a vodící čáry.

Další způsob, jak používat pomocné body, je nakreslení dočasného vektoru, na kterém budou pomocné body zobrazeny.

Viz Přichycení k pomocnému bodu.

Nastavení intervalů pomocných bodů

Použijte příkazy z nabídky Zobrazit > Volby pomocných bodů nebo z panelu nástrojů Pomůcky pro kreslení.


SnapIntervals.png
  • Polovina: Rozděluje hranu na dvě stejné části.
  • Dělení: Rozděluje hranu na nastavený počet segmentů. Rozsah: 3-100.
  • Procenta: Rozděluje hranu na dvě části podle nastaveného procentuálního poměru.
  • Vzdálenost: Rozdělí hranu podle na části, jejichž vzdálenost jste nastavili.
  • Nejlepší dělení podle vzdálenosti: Pomocné body budou podél hrany rozmístěné ve vzdálenosti, která je co nejbližší k nastavené délce.
    Poznámka: Potřebnou volbu dělení, procent atd. nastavíte v okně Hodnoty pomocných bodů.

    Viz Hodnoty pomocných bodů, níže.

Pokud používáte procenta nebo vzdálenost, máte dvě další možnosti:

  • Začít od konce: Pomocné body jsou vloženy po zadané vzdálenosti/části měřené od koncového bodu segmentu, který je blíže kurzoru.
  • Začít od středu: Pomocné body jsou vloženy po zadané vzdálenosti/části měřené od středu segmentu.

Hodnoty pomocných bodů

Z nabídky pomocných bodů ve standardní nástrojové liště (nebo Zobrazení > Volby pomocných bodů), vyberte Nastavit hodnoty pomocných bodů.

V následujícím okně nastavte hodnoty pro dělení, procentuální dělení a vzdálenost.


SpecialSnapdialog.png

Volby pomocných bodů

Zvolte si volbu pomocných bodů z následujících možností:

  • panel nástrojů Pomůcky pro kreslení
  • Menu Zobrazení
  • Nabídka Pomocné prvky na Standardní nástrojové liště (je-li k dispozici)

    SpecialSnapOptions.png
  • Mezi uzly: Pomocné body budou zobrazeny pouze na zvoleném segmentu (mezi sousedícími uzly).

    BetweenNodes.png
  • Podél celého prvku: Pomocné body budou zobrazeny podle zadaného intervalu na celém prvku (včetně polygonálních prvků), bez ohledu na průniky s ostatními prvky.

    AlongEntire.png
  • Mezi body průniku: Pomocné body budou na prvku zobrazeny pouze mezi dvěma sousedícími body průniku s jinými prvky.

    BetweenIntersect.png

Barva pomocných bodů

Barvu pomocných bodů můžete nastavit v menu Volby > Pracovní prostředí > Pomocné prvky a vodící čáry.