2D a 3D zobrazení
K dispozici v Editoru GDL objektů.

2D zobrazení
Zobrazí půdorysný symbol objektu.
Pokud má objekt definovaný 2D skript, bude 2D symbol generován podle tohoto 2D skriptu, a to i v případě, kdy okno 2D symbol obsahuje nakreslené prvky. 2D popis však může na tyto fragmenty odkazovat.
3D zobrazení
Zobrazí 3D symbol objektu.
V tomto okně uvidíte 3D pohled na GDL objekt, který je vytvořen na základě 3D popisu podle aktuálních hodnot parametrů. Nastavení zobrazení můžete upravit příkazem Zobrazení > Volby 3D zobrazení > 3D styly nebo v paletce 3D navigace.
Srovnání 2D & 3D popisů
2D symbol a 3D popis jsou v GDL objektu automaticky navzájem propojeny. Neexistuje však žádná zabudovaná kontrola proti geometrické nekompatibilitě mezi těmito dvěma komponenty. Většina chyb kompatibility se zobrazí, když 2D symbol a 3D tvar mají různou pozici nebo orientaci vzhledem k počátku.
Abyste se problému vyhnuli, postupujte takto:
- Aktivujte 3D pohled na GDL objekt.
- Vyberte horní pohled v Zobrazení > Nastavení 3D zobrazení > Nastavení 3D zobrazení > Paralelní zobrazení, poté nastavte úhel na 270°.
- Zvolte Úpravy > Označit vše a poté Úpravy > Kopírovat. Aktivujte 2D symbol GDL objektu a zadejte Úpravy > Vložit. Tím vložíte horní pohled na objekt (jako čárový model nebo viditelné hrany) do okna symbolu. Rozměry a umístění 2D symbolu by se s ním mělo shodovat.
- Jakmile ověříte, že symbol odpovídá 3D pohledu, zadejte jednou Zpět. Tím odstraníte 3D čáry.
Tuto funkci můžete použít také k automatickému vytvoření 2D symbolu. Budete jen muset přidat další aktivní body, čáry, atd. Procedura je stejná pro Dveře i Okna, jen s následujícími odlišnostmi:
- Zvolte Boční namísto Horního pohledu (úhel by měl být stále 270°).
- Vložen bude zrcadlový pohled. Označte vložené čáry a zrcadlete je podle referenční čáry zdi.
Kompatibilitu mezi 2D půdorysných symbolem a 3D modelem GDL objektu můžete zajistit také tak, že zadáte parametrický popis GDL symbolu.