Contenuto e formato della Legenda

La Legenda è un elemento di tipo oggetto, presente nella libreria del progetto.

Utilizzare le pagine del pannello Impostazioni Legenda per impostare il contenuto e il formato nel modo desiderato.


LegendFormat.png

Filtrare il contenuto della Legenda (per cartella e per visibilità)

Numero di pilastri

Selezionare campi da visualizzare delle Note chiave

Selezionare i campi della Cartella da visualizzare

Unisci voci dei dati

Separatore per i campi uniti

Allineamento dei dati nella colonna

Visualizza bordi e separazioni

Visualizza retino sfondo

Dividi in unità orizzontali

Formattazione del testo

Filtrare il contenuto della Legenda (per cartella e per visibilità)

Nella scheda Filtro:

  • Impostare quali Note chiave visualizzare: tutte le Note chiave o solo le Note chiave visibili sui disegni
  • Impostare quali cartelle devono essere visualizzate (o scegliere Tutte le cartelle)

    FilterVisibleKeys.png   FilterFolderContent.png

Mostra i dati relativi alle Note chiave in conflitto tra loro

Se il contenuto della Legenda include Note chiave con dati contrastanti (questo può accadere con gli elementi collegati): selezionare questa casella per visualizzare le informazioni sui dati in conflitto. In caso contrario la Legenda visualizzerà solo una chiave, senza altre informazioni.

Vedere anche Note chiave nei collegamenti.

Ordine delle righe

Scegliere l'ordine di elencazione delle Note chiave nella Legenda:

  • Alfabetico (basato sul primo campo della riga)
  • Come nella palette Note chiave

Numero di pilastri

Nella scheda Seleziona i campi:

  • Fare clic per definire il numero di colonne della Legenda (ad esempio, "2 colonne")

    LegendColumnNumber.png

Selezionare campi da visualizzare delle Note chiave

Nella scheda Seleziona i Campi:

Utilizzare le finestre a comparsa per impostare quali dati delle Note chiave mostrare in ciascuna colonna della legenda. (Se sono state selezionate "2 colonne" si possono scegliere due dati delle Note chiave, ad esempio Chiave nella prima colonna e Descrizione nella seconda.)


KeynoteDataLegend.png

Selezionare i campi della Cartella da visualizzare

La Legenda può visualizzare sia i dati della cartella sia le Note chiave stesse. Nella scheda Seleziona i Campi:

Selezionare Visualizza i dati della cartella.

Quindi impostare i dati della cartella da visualizzare in ciascuna colonna della legenda (ad esempio, Chiave della cartella nella prima colonna e Titolo della cartella nella seconda).


FolderDataLegend.png

Unisci voci dei dati

È possibile unire i dati e la formattazione di campi adiacenti.

In questo caso è opportuno unire i primi due campi chiave (Chiave e Titolo):


UnmergedFields.png

Per unire questi dati: nella scheda Seleziona i Campi delle Impostazioni oggetto Legenda, fare clic sul pulsante Unisci tra i due campi.


MergedFields.png
Nota: un campo unito utilizzerà l'allineamento impostato per la prima colonna. Ad esempio, il campo unito Chiave + Titolo utilizza l'allineamento definito per la Colonna 1 (qui è allineato a sinistra).

Separatore per i campi uniti

Se la legenda ha campi uniti (come Chiave e Titolo), è possibile impostare qualsiasi separatore tra di essi.

Ad esempio, inserire un'interruzione di riga tra i dati Nota chiave uniti e uno spazio tra i dati delle cartelle uniti.

KeynoteSeparator.pngKeynoteSeparatorDone.png 

Allineamento dei dati nella colonna

Impostare l'Allineamento del testo preferito per ciascuna colonna della Legenda (sinistra, centro, destra).


LegendColumnAlign.png

L'intera colonna viene allineata in modo uniforme.

Visualizza bordi e separazioni

Nella scheda Formato Tabella:


LegendBorders.png
  • Aggiungere il bordo e le linee di separazione per la tabella Legenda (fare clic sulle icone per attivarle o disattivarle)
  • Impostare i tipi di linea e i colori per il bordo e le linee di separazione
  • Nella Legenda, trascinare le linee come necessario

Visualizza retino sfondo

Se preferite, potete evidenziare i campi dati di Nota chiave e/o Cartella con i retini di sfondo.

Dividi in unità orizzontali

Se la Legenda è troppo lunga, è possibile suddividere le righe della tabella in unità orizzontali.

Nella scheda Formato Tabella:

Usare il menu a comparsa Unità per dividere la legenda Nota chiave in unità uguali o in unità di dimensione fissa.

Per personalizzare ulteriormente il risultato, modificare graficamente le unità di Nota chiave sul Layout.



Formattazione del testo

Utilizzare le schede Formato note e Formato cartelle.


LegendFormatText.png

Per esempio:

  • Distanziare il testo di Nota chiave o della cartella dalla cornice della Legenda
  • Impostare l'allineamento del testo
  • Utilizzare formati di testo separati per dati particolari, come "Chiave" o "Riferimento"

    LegendFormatReference.png