
Getting Started with 
Archicad 

Start Edition 2024



Graphisoft®
Visit the Graphisoft website at www.graphisoft.com for 

local distributor and product availability information.

Getting Started with Archicad 
Start Edition 2024

Copyright ©2024 by Graphisoft, all rights reserved. 
Reproduction, paraphrasing or translation without 

express prior written permission is strictly prohibited.

Trademarks
Archicad® is a registered trademark of Graphisoft. All 
other trademarks are the property of their respective 

holders.

http://www.graphisoft.com


Contents

Getting Started with Archicad Start Edition 2024 3

Contents
Hardware/Software Requirements. . . . . . . . . . . . . . . 5
Install Archicad SE 2024. . . . . . . . . . . . . . . . . . . . . . . 6
Archicad Licensing . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Add/Repair Archicad. . . . . . . . . . . . . . . . . . . . . . . . . 11
Updates for Archicad . . . . . . . . . . . . . . . . . . . . . . . . 12
Compatibility Information. . . . . . . . . . . . . . . . . . . . . 13
Release Notes for Start Edition 2024  . . . . . . . . . . . 14
Archicad Tools and Utilities . . . . . . . . . . . . . . . . . . . 17
Uninstall Archicad. . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Notes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19



Contents

4 Getting Started with Archicad Start Edition 2024



Hardware/Software Requirements

Getting Started with Archicad Start Edition 2024 5

Hardware/Software 
Requirements
Hardware/Software requirements are modified from time 
to time. For up to date information on system 
requirements, please consult the following link: 
www.graphisoft.com/support/system_requirements/

http://www.graphisoft.com/support/system_requirements
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Install Archicad SE 2024
In the following pages, we take you through the process 
of installing the Archicad program at a stand-alone 
workstation.
Archicad Start Edition is available by electronic delivery 
or on DVD, depending on your market. For details, 
contact your distributor.

Electronic Delivery
Download Archicad SE 2024 to your computer, then 
proceed with the installation.

Install from DVD
Insert the Archicad SE 2024 DVD into your computer’s 
DVD-ROM drive.
To avoid performance issues, it is recommended that 
you first copy the installer from the DVD to your 
computer and install the program from there.

Macintosh users
1) Go into the “Mac” folder.
2) Copy the Archicad-Start-2024....dmg file to your 

computer.
3) Double-click the dmg file.
4) In the appearing volume, double-click the Archicad 

Installer.app to start the installation wizard.

Windows users
1) Go into the “Win” folder.
2) Copy the Archicad-Start-2024....exe file to your 

computer.
3) Double-click the exe file to start the installation 

wizard.
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Run Installation Wizard
1) Welcome Screen

Make sure that you close all running programs 
before you proceed with the installation.
Click Next.

2) License Agreement
Read the license agreement carefully and accept it. 
Click Open in Browser to see the agreement in a 
new window. 
Click Next.

3) Select Installation Directory
On this page, define the file path of the installation. 
As a rule, you should choose the path suggested by 
default, to simplify the installation of any future 
updates. 
To confirm the file path, click Next.

4) Choose Setup Type
With the “Typical” installation option 
(recommended), you will install Archicad Start 
Edition 2024 together with all of its components (e.g. 
Library). 
Alternatively, choose the “Custom” installation option 
to install only specific program components. 
After you make your choice, click Next.

5) Installation Summary
This screen summarizes your chosen configuration, 
so you can make any needed corrections to the 
installation settings. 
Click Install to begin installation.

6) Installation Underway
Depending on your Hardware configuration, this 
process may take several minutes.
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7) Enable Full Disk Access (Mac only)
When installing or updating Archicad on a macOS, 
you will see a warning: for Archicad to run properly, 
you must enable Full Disk Access in macOS 
settings. Follow the steps described in the warning 
dialog.

8) Shortcuts/Automatic Updates: Here you can create 
an “Archicad SE 2024” Desktop shortcut. Review the 
setting to Enable Archicad to Check for Updates 
automatically (checked by default).

9) Confirm your choices by clicking Next.
10) Complete Installation

Click Finish to complete the installation process. 
You may be prompted to restart your computer.
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Archicad Licensing
When you start Archicad, the program automatically 
checks to see if you have a license available. If so, you 
are ready to work.
To update, download and otherwise manage your 
license keys, use the License Manager Tool. The 
License Manager Tool is automatically installed to your 
computer as part of the installation of Start Edition. It is 
also available for download at:
www.graphisoft.com/downloads/licensing/

Hardware Key
The Hardware Key (Dongle) contains your license 
information on a USB stick. Before you start using the 
latest version of Archicad Start Edition, this Hardware 
Key must be updated. 
For the update process, start the License Manager Tool 
(LMT) and follow the directions.
See https://help.graphisoft.com/lmt/.
Now you are ready to use Start Edition 2024.

Note: After updating your license key to Archicad 
Start Edition 2024, you can still use all earlier Start 
Edition versions. (To run SE 2008 or SE 2009, you 
must have its latest hotfix installed.)

Software Key
The Software Key is a software-based license. Using the 
License Manager Tool, a software key can be 
downloaded from the License Pool to a local client 
computer. 
To download a software key, start the License Manager 
Tool (LMT) and follow the directions.
See https://help.graphisoft.com/lmt/.

https://help.graphisoft.com/lmt/
https://www.graphisoft.com/downloads/licensing/
https://help.graphisoft.com/lmt/
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If you are using a single license and plan to work on a 
different computer, you should upload the software key 
to the License Pool, so that you can access it from a 
different location. (Internet connection is required.)

Demo Mode
When you start Archicad, the program automatically 
checks to see if you have a license available. If you don’t 
have a license at all, you can continue in Demo Mode.
Demo Mode gives you full functionality except file 
saving. Use Demo mode to open, view and try out 
functions.
The unavailable commands and menu items are 
disabled, and the Archicad title bar changes to Archicad 
SE 2024 Demo.
Your Archicad program may also be restricted to Demo 
mode for the following reasons:
• No key is attached to your computer
• All of your Archicad licenses are in use
• Your Hardware Key is defective
• CodeMeter service is not running

Lost or Defective License Key
In case of a lost or defective License Key, contact your 
local distributor.
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Add/Repair Archicad
If you already have Archicad installed, and start the 
Installation Wizard, you are given two options:
1) Add will add new features to your current 

installation. You will see all available features in a list 
and you can check features to be added to your 
current installation.

2) Repair will reinstall Archicad with the features of 
your current installation. 

• The Repair process will revert your Archicad version 
to its default settings. After Repair, you must reinstall 
the latest Archicad and Library updates.

• Project files you saved into the Archicad SE 2024 
folder will not be deleted or overwritten by the repair 
process.
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Updates for Archicad
To check for available updates of your localized version 
of Archicad or Archicad libraries, start Archicad SE 2024 
and do any of the following:
• Use Help > Check for Updates
• Open the Action Center (File > Info > Action Center) 

and select the Updates item to see notifications on 
any updates available for download.

• For automatic checking: Set the Check for Updates 
options in Options > Work Environment > Network 
and Update. You will be notified if a new library or 
program version matching your Archicad language 
version is available, which you can then download.

The Check for Updates command takes you to the 
Graphisoft update website. If there is a new update 
patch available, the web page will automatically offer you 
the updater package that fits your current Archicad 
installation.
You can find other downloadable materials (example 
files, goodies etc.) at: 
www.graphisoft.com/downloads/

Note: If you have an updater patch installed and use 
the Add/Repair function of the Archicad SE 2024 
Installer, you will be prompted to re-apply the 
updates after the modification or repair is carried out. 

https://www.graphisoft.com/downloads/


Compatibility Information

Getting Started with Archicad Start Edition 2024 13

Compatibility Information
Opening Archicad Files
Archicad Start Edition 2024 can open Archicad project 
files from all earlier Start Edition versions, and Archicad 
8.1 and 9.

Saving Project Files
Files created in Archicad Start Edition 2024 can be 
saved as:
• Archicad SE 2024 Solo Project (*.pln)
• Archicad SE 2024 Project Template (*.tpl)
• Archicad SE 2024 Archive Project (*.pla)
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Release Notes for 
Start Edition 2024
This section lists the feature limitations of Start Edition 
(SE) 2024 compared to Archicad 27.

Note: To take advantage of the entire range of 
Archicad features and benefits, you can upgrade at 
any time to the current, full version of Archicad and 
continue editing your previous projects with it.

Collaboration Limitations
• Teamwork
• Graphisoft BIM Server
• Hotlinked Modules
• Xrefs
• Views from external Archicad files placed as 

Drawings
• PMK file format support
• Point Cloud file format support
• STL (stereolithography) file format support
• Export to gbXML and PHPP
• PDF Markup Import
• Collision Detection
• Rhino Export/Import
• Solibri Connection
• Import Element Property Data from Excel
• 3D Model Compare

Visualization Limitations
• Cineware Rendering Engine
• Special Lamp effects for Cineware engine (these are 

available but have no effect)
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• Sketch Rendering Engine

Modeling Limitations
• Design Options
• Curtain Wall
• Structural Analytical Model
• MEP Modeler
• PARAM-O

Workflow Productivity Tools
• Publisher function
• Renovation
• Link Element Height to Stories (Wall, Column, Zone, 

Stair)
• Revision management
• Physical Model Quality Check
• Structural Analytical Model Quality Check
• Experimental Features

Energy Evaluation
• Not available

Project Organization
• License Borrowing
• Network license

Performance
• Multithreading limited to two cores
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Help System
Please note that the Start Edition 2024 Help is based on 
the Archicad 27 Reference Guide. Consequently, some 
features and functions described in the Help System are 
NOT AVAILABLE in Start Edition 2024.
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Archicad Tools and Utilities
The following utilities are automatically installed on your 
computer together with Archicad.

The following utilities are also installed with Archicad SE 
2024. If you prefer not to install them, use Custom 
Installation and uncheck these options.

For more information about additional utilities, open the 
folders of the applications in the Archicad main folder to 
find detailed descriptions.

CodeMeter 
system 
components

A Hardware Key driver (CodeMeter) will 
be installed as part of the installation 
process for Archicad.

Plotter 
Drivers

Archicad includes a number of built-in 
drivers for a wide variety of HPGL 
compatible plotters.
If you are using a large-format printer, 
make sure you use a printer driver 
specified by the manufacturer, because 
its plotter function is only an emulation.

Graphisoft 
Shell 
Extension

Optional, for Windows only. Utility for 
extended Graphisoft file property 
information on Windows.

BIMx 
Desktop 
Viewer

Use BIMx to explore the virtual model in 
the context of the hyperlinked 2D project 
documentation and embedded BIM data.

License 
Manager 
Tool

The License Manager Tool can be used to 
manage the Graphisoft protection keys 
you have purchased, whether hard or soft.
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Uninstall Archicad
To uninstall Archicad SE 2024 from Windows, it is best 
to use the “Programs” or “Add or Remove Programs” 
utility, accessible from the Control Panel.
On Mac, navigate to the “Uninstall.AC” folder in your 
Archicad SE 2024 folder, and select the “Uninstall.app” 
application. 
The Uninstall Wizard will remove files which were 
installed by the Archicad Installation Wizard. CodeMeter 
and associated components are not removed. 
The uninstaller will not remove any files you have 
created in the Archicad main folder - e.g. Archicad 
project files that you saved into the Archicad main folder.
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Notes
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