Открытие или Объединение Моделей Rhino

Следующие команды позволяют открывать или объединять файлы 3D-моделей Rhino (.3dm) с проектами Archicad

  • Файл > Открыть
  • Файл > Взаимодействие > Объединить

Модели Rhino, импортируемые в Archicad в виде нередактируемых GDL-объектов, сохраняют структуру исходных моделей Rhino. Они сохраняются во Вложенной Библиотеке проекта Archicad. Уровень сегментации моделей можно настраивать до и/или после импорта в Archicad (см. ниже).

Темы раздела:

Параметры Импорта 3D-моделей Rhino

Параметры Объектов Rhino в Archicad

Свойства Rhino в Archicad

Отображение Видов Rhino в Archicad

Параметры Импорта 3D-моделей Rhino

Диалог Параметров Импорта становится доступен в процессе импорта моделей Rhino при помощи следующих команд:

  • Файл > Открыть
  • Файл > Взаимодействие > Объединить 
  • Файл > Внешние Данные > Разместить Связь (в диалоге Нового Связанного Модуля).

    RhinoOpenDialog.png

Выбрав файл 3D-модели Rhino (.3dm), нажмите кнопку Параметры.

Наименование диалог зависит от использованной для импорта команды:

Сегментация Криволинейной Геометрии

При помощи регулятора настройте уровень сегментации криволинейных поверхностей, импортируемых из Rhino.

Note:

  • Уровень сегментации учитывается только для криволинейных поверхностей и никак не влияет на плоские элементы.
  • Пожалуйста, обратите внимание, что повышение уровня сегментации (увеличение количества многоугольников, образующих криволинейные поверхности) увеличивает размеры файла и может привести к снижению производительности.

Фиксация Криволинейной Геометрии

При желании активируйте маркер Зафиксировать Криволинейную Геометрию, чтобы завершить настройку сегментации перед импортом. В результате:

  • В дальнейшем вы не сможете изменить уровень сегментации модели, импортированной в Archicad;
  • Появится возможности привязки и позиционирования курсора по элементам модели;
  • Как правило, активация этого маркера повышает скорость навигации.

Скрытые элементы

Данные элементы управления предназначены для настройки импорта “скрытых” элементов Rhino.

В Rhino (в отличие от Archicad) можно скрывать отдельные элементы, находящиеся на отображаемом Слое. По умолчанию такие скрытые элементы НЕ импортируются в Archicad.

Чтобы импортировать эти элементы, активируйте маркер Импорта скрытых элементов.

Слои

При помощи этих элементов управления можно выбрать Слои для размещения импортированных элементов Rhino (отображаемых и скрытых).


ImportRhinoLayers.png

Импортировать Слои для сохранения исходной структуры Слоев (По Умолчанию)

Каждый Слой Rhino будет воссоздан в качестве отдельного Слоя Archicad, а в его названии будет указана исходная папка Слоя Rhino: папка_вложеная папка_слой.

  • К названиям этих Слоев автоматически добавляется расширение “Rhino”.
  • Если наименования Слоев совпадают, то в расширении добавляется порядковый номер.
  • Вы можете также добавить Префикс для Слоев Rhino.

    LayerRhino.png

Разместить все элементы на существующем Слое

Воспользуйтесь выпадающими списками, чтобы выбрать Слои проекта Archicad для размещения скрытых и отображаемых элементов импортируемой модели Rhino.

Разместить все элементы на новом Слое (доступно только при активации команды Открыть, при Объединении этот вариант не отображается).

Создается новый Слой Archicad для всех отображаемых и скрытых элементов.

Покрытия

Эти элементы управления предназначены для выбора способа преобразования цветов Rhino в реквизиты Покрытий Archicad.

Импортировать цвета в качестве Покрытий

Установка переключателя в это положение приводит к тому, что для каждого импортированного цвета Rhino

  • создается отдельное Покрытие Archicad
  • создаваемым Покрытиям присваивается наименование “Rhino” и порядковый номер
  • наименования слоев можно при желании дополнить Префиксом

    RhinoImportSurfaces.png

    ImportRhinoSurfaces.png

Использовать существующее единое Покрытие

Воспользуйтесь выпадающим списком, чтобы выбрать Покрытие Archicad для всех цветов импортируемой модели Rhino.

Параметры Объектов Rhino в Archicad

Все элементы Rhino импортируются в виде отдельных объектов Archicad (.gsm), в наименование которых включается префикс “Rhino”. Каждый импортированный объект сохраняется в отдельной папке Вложенной Библиотеки Archicad, содержащей вложенные папки для каждого отдельного слоя.


RhinoObject.png

Панель Параметров Объекта, Импортированного из Rhino, находящаяся в диалоге Параметров Объекта, позволяет управлять отображением импортированных элементов.

Прим.: Параметры Объектов Rhino, размещенных в качестве Связей, нельзя отредактировать.

RhinoSegmentation.png

Обратите внимание на особые параметры объектов Rhino:

Сегментация

Этот элемент управления становится доступен, если в процессе импорта объекта Rhino не был активирован маркер Фиксации Криволинейной Геометрии. (См. Фиксация Криволинейной Геометрии , выше.)

Прим.: Управление уровнем Сегментации недоступно, если выбранный объект был размещен в Archicad при помощи инструмента Объект, а не импортирован из Rhino.

Воспользуйтесь выпадающим списком уровней Сегментации, чтобы настроить степень сглаживания криволинейных поверхностей объекта. Пожалуйста, помните, что увеличение количества многоугольников может привести к снижению производительности.

2D-представление

  • Показ Ребер Граней: Активация этого маркера приводит к отображению внутренних граней ребер в 2D.
  • Узловые Точки Габаритного Контейнера: При активации этого маркера в 2D отображаются дополнительные точки габаритного контейнера объекта. Данные точки можно использовать, например, для нанесения габаритных размеров таких ортогональных объектов как навесные стены.

Свойства Rhino в Archicad

Каждому элементу, импортированному из Rhino и размещенному Archicad, в панели Классификации и Свойства диалога Параметров Объекта назначается Группа Свойств Элемента Rhino.


RhinoProps.png

В этих свойствах сохраняется исходный Слой и ID элемента в Rhino. Эти данные сохраняются даже при размещении всех импортируемых элементов Rhino на одном Слое Archicad.

При помощи этих свойств вы можете найти и выбрать элементы Rhino по Слою в случае изменения структуры Слоев Archicad.


RhinoLayerFS.png

Отображение Видов Rhino в Archicad

Открытие файлов Rhino приводит к импорту аксонометрических модельных видов Rhino  в Карту Видов Archicad. Эти виды определяют способ отображения (и Параметры 3D-окна) в соответствии с исходными настройками, сделанными в Rhino.

Режим Отображения Видов в Rhino

Режим Отображения Видов в Archicad

Wireframe, Ghosted, X-Ray, Technical

Каркасный

Shaded, Rendered, Artistic, Pen

С Раскраской и Тенями