Менеджер Связанных Модулей
Данный диалог предназначен для управления Связанными Модулями и Источниками Связей в Основном Проекте.
Его можно открыть при помощи:
- команды меню Файл > Внешние Данные > Менеджер Связанных Модулей или
- контекстного меню любой выбранной Связи в проекте, в разделе Связанный Модуль

- Вы также можете проверить статус Связанного Модуля/Источника в Центре Взаимодействия (Файл > Информация > Центр Взаимодействия).
В находящемся в верхней части диалога списке Связанных Модулей отображается иерархическая структура всех модулей, связанных с текущим проектом.
Информация о Модуле
Выберите из списка любой модуль. В разделе Информации о Модуле отображается:
- количество размещенных Связей модуля;
- наименование Исходного Файла (Источника Связи);
- связанный этаж (или этажи) модуля;
- Информация о Преобразовании
- Для IFC-модулей: файлы Шаблона и Транслятора, расположение файла шаблона
- Для Rhino-модулей: параметры импорта модуля (т.е. преобразование слоев и покрытий)
Можно также навести курсор на любой Модуль, присутствующий в списке, чтобы просмотреть информацию о нем, включая расположение модуля в Основном Проекте.
Обратите внимание, что выбор модуля в этом списке приводит к выделению наименования его Исходного Файла в списке Источников Связей, расположенном ниже.

Изменение Модуля
Для замены выбранного модуля другим модулем нажмите кнопку Изменить Модуль.
В открывшемся диалоге Выбора Связанного Модуля приводится список всех доступных Связанных Модулей проекта. Выберите модуль для замены.
Сохранить как Файл
Разорвать Связь
Воспользуйтесь этой командой, чтобы разорвать все Связи модуля и вложить их элементы в Основной Проект. Элементы модуля станут обычными редактируемыми элементами, объединенными в одну группу и никак более не связанными с исходным файлом.
Эта команда не действует для Модулей, расположенных на заблокированных слоях.
См. Разрыв Связи (Вложенные Элементы).
Функция Разрыва Связи может пригодиться, например, для создания визуализаций проекта. Сохранив копию проекта, можно Разорвать Связи, чтобы вложить все элементы модулей в проект. Это позволит редактировать отдельные элементы непосредственно в проекте, например, используя панель Окраски Поверхностей.
Удалить
Нажатие кнопки Удалить приводит к удалению Связанного Модуля и всех его размещенных Связей из проекта.
Расположенные на заблокированных слоях Связи или элементы удалены не будут.
Вложенные Модули (Менеджер Связанных Модулей)
Вложенные Модули (если они присутствуют в проекте) отображаются в списке Менеджера Связанных Модулей в соответствии с их расположением в иерархии модулей. Выпадающее меню Вложенных Модулей позволяет пропускать или включать их в размещаемые Связи:
- Пропустить: Вложенные Модули во всех Связях выбранного модуля будут пропущены (не будут отображаться в Основном Проекте). Разумеется, они по-прежнему будут оставаться частью исходного модуля.
- Включить: Все Вложенные Модули во всех Связях выбранного модуля будут отображаться в Основном Проекте.
Для отображения ранее пропущенного Вложенного Модуля выберите его родительский модуль в Менеджере Связанных Модулей и при помощи выпадающего меню Связанных Модулей активируйте команду Включить.

Если вы выберете Вложенный Модуль в списке Менеджера Связей, то не сможете изменить или разорвать эту Связь (соответствующие команды и само имя модуля становятся недоступным), но его можно сохранить как новый файл.
Note:
- IFC-модули или модули Rhino не могут иметь Вложенных Модулей. Однако IFC-модули и модули Rhino можно вложить в связанные модули PLN.
- Чтобы пропустить или включить Вложенный Модуль в отдельной Связи, воспользуйтесь диалогом Параметров Выбранной Связи.
См. Параметры Связи.
Источники Связей
В этом списке отображается наименование и статус Исходных Файлов Связанных Модулей.
- При необходимости Статус Источников Связей можно обновить, воспользовавшись выпадающим меню.Прим.: По умолчанию программа автоматическая проверяет статус всех Связей при каждом открытии Менеджера Связанных Модулей. Если это приводит к снижению производительности, то функцию “Автоматической Проверки Статуса” можно деактивировать при помощи команды меню Параметры > Окружающая Среда > Безопасность и Целостность Данных.

См. также Статус Исходного Файла Связи.
- Для сортировки данных сделайте щелчок на названии столбца.
- Перемещая разделитель, можно регулировать ширину столбцов.
- Выберите файл в списке, чтобы увидеть справа:
- Размер Файла: размер исходного файла. размер исходного файла.
- Изменен: дата и время последнего изменения Исходного Файла (в месте его Расположения, указываемом ниже). дата и время последнего изменения Исходного Файла (в месте его Расположения, указываемом ниже).
- Сохранен: время последнего обновления Исходного Файла (в текущем Основном Проекте). время последнего обновления Исходного Файла (в текущем Основном Проекте). Сохранение выполнено раньше, чем Изменение, то Источник Связи следует обновить.
- Расположение: путь к Исходному Файлу.
Выбрав файл из списка Источников Связей, можно выполнить следующие действия:
Повторно связать
Воспользуйтесь командой Повторно Связать, если Источнику Связи присвоен статус "Отсутствует".
В открывшемся диалоге “Новой Связи” укажите путь к Источнику Связи (который мог оказаться "Отсутствующим" из-за перемещения в другую папку). Если Источник Связи отсутствует, то программа не может обновлять экземпляры его модуля.
Все Связи, основанные на данном Исходном Файле, будут заменены указанным Исходным Файлом.
Если структура этажей нового Исходного Файла отличается от структуры этажей Основного Проекта, то отображается предупреждение о возможной потере некоторых выносок и размеров в результате повторного связывания модуля.
Обновить
Если Исходный Файл Связанного Модуля был изменен, то ему назначается статус "Измененного". Для обновления всех размещенных Связей модуля выберите Источник Связи и нажмите кнопку Обновить.

Эта команда также доступна в контекстном меню размещенной Связи: Связанный Модуль > Обновить Модуль и все относящиеся к нему Связи.
См. Обновление Связей.
Обновить, затем Сопоставить
Выполняя обновление Связанного Модуля, вы можете сразу открыть окно Сопоставления Моделей, чтобы увидеть все изменения модели с момента ее последнего обновления.

См. Сопоставления моделей Archicad до и после обновления Связей .
Открыть в новом Сеансе
Выбранный Исходный Файл открывается в новом сеансе работы Archicad .
См. также Редактирование Модуля в отдельном сеансе работы ArchicadMEP Designer.
Статус Исходного Файла Связи
- OK: Исходный Файл модуля в порядке.
- Изменен: Исходный Файл был изменен. Для обновления модулей проекта, полученных из этого файла, следует нажать кнопку Обновить.
- Отсутствует: не удается обнаружить Источник Связи размещенного в проекте модуля. Воспользуйтесь командой Повторно Связать, чтобы указать местоположение отсутствующего исходного файла.
- Недоступен: Исходный файл - это старый проект Teamwork, расположенный в BIMcloud. У вас нет доступа к этому исходному файлу в связи с тем, что вы либо используете Демо версию, либо не имеете ключа защиты Teamwork.
- Устаревший: Устаревший исходный файл - это файл, сохраненный в Archicad версии 17 или ниже. Чтобы обновить подобный модуль, его надо открыть и повторно сохранить в Archicad версии 17-26.
|
Статус Модуля |
Иконка |
|
Нормали |
|
|
Вложенный |
|
|
Изменено |
|
|
Обновлен |
|
|
Удалено |
|
|
Изменение Модуля |
|
|
Связь Разорвана |
|
|
Повторное связывание с Исходным Файлом |
|
|
Игнорировать Вложенные Модули |
|
|
Отсутствует |
|
